%%ItemTitle%%

DicomObjects.NetStandard Documentation
In This Topic
    Introduction to DicomObjects.NetStandard

    DicomObjects.NetStandard consists of an inter-related, but independent, set of .NetStandard compatible "Objects" that enable developers to quickly and easily add DICOM functionality to their products without needing to understand or program the intricacies of the DICOM standard. This help file provides full reference to those objects and also some introductory guidance

    Almost any aspect of DICOM image/data manipulation can be performed using DicomObjects, including:

    • Image read/write and parsing
    • Network transmission of images and associated data, including worklists
    • Printing to DICOM and windows printers
    • Normalised operations including storage commitment
    • Image creation from scratch and import/export to/from non-DICOM formats
    • DICOM Web client and server

    The main Components of DicomObjects are:

    DicomServer Class

    An object that provides storage, query/retrieve and normalised facilities as a service class provider (SCP). Events are raised in response to incoming operations.

    DicomQuery Class

    An object that handles the query/retrieve parts of the DICOM standard as a service class user (SCU).

    DicomDataSet Class

    Used for reading, writting, parsing, imporint and exportring DICOM objects

    DicomPrint Class

    Used for sending DICOM print requests to DICOM Printer SCP

    DicomGlobal Class

    Used for certain global operations, including logging and setting global behaviour.

    DicomAssociation Class

    A DicomAssociation Object represents a DICOM association, and may either be created automatically in response to an incoming query request, or explicitly by the client program. Methods of this object are used to send data, images, and verification requests.

    DicomException Class

    A DicomException Object represents the errors that occur within DicomObjects which is wrapped and thrown as a manageable exception in the user code with descriptive error messages.

    Other classes and collections are created and used by the above, and some may also be created directly. They are:

    Object Description | Single Item | Collection
Generic SOP instance, used for results of DICOM queries or as a sub-element of a Sequence | DicomDataSet Class | DicomDataSetCollection Class
Attribute (Data Element) of a DicomDataSet | DicomAttribute Class |
DICOM Presentation context | DicomContext Class | DicomContextCollection Class
Licencing Information and Control | DicomLicence Class |

    © 2022 Medical Connections Ltd

    Send feedback


Inheritance Hierarchy
    DicomObjects Namespace
    Classes
     | Class | Description
Class | DicomAssociation | Class representing a single DICOM Association
Class | DicomAttribute | Class representing a single DICOM Attribute
Class | DicomContext | A DICOM presentation context, as used in association negotiation
Class | DicomContextCollection | The list of DICOM Presentation contexts proposed or accepted during negotiation
Class | DicomDataSet | A DICOM data set
Class | DicomDataSetCollection | A collection of DicomDataSet objects
Class | DicomException | Specific Exception for DICOM errors
Class | DicomGlobal | Placeholder for various static methods and properties
Class | DicomImage | Class representing a DICOM Image
Class | DicomImageCollection | A Collection of DicomImage objects
Class | DicomLabel | A label, or annotation, to be displayed over an image in a DicomViewer control, or in derived copies of the image.
Class | DicomLabelCollection | A collection of DicomLabel objects.
Class | DicomLicence | This class handles DicomObjects licensing
Class | DicomMaskRange | Subclass of DicomImage, created for Mask Subtraction
Class | DicomPrint | An object to simply printing to a DICOM printer
Class | DicomQuery | Object used for DICOM Query/retrieve SCU operations
Class | DicomServer | An object for handling advanced network communications, as both SCU & SCP
Class | ReadBehaviours | Specific behaviour to use when reading/receiving a DICOM instance
Class | SequencePath | Class to hold details of the path from a dataset to an attribute within it, including those nested in sequences.
Class | WriteBehaviours | Specific behaviour to use when writing/sending a DICOM instance
    Structures
     | Structure | Description
Structure | WsiTile | Representing WSI Tile with its list of tile fragments
Structure | WsiTileFragment | Representing each WSI Tile Fragment
    Delegates
     | Delegate | Description
Delegate | DicomAttribute.DelayedDataRoutine | Delegate to fetch binary data for the bid
    See Also

    Reference

    DicomObjects.NetStandard Assembly


    DicomObjects.NetStandard Assembly
    Namespaces
    Namespace | Description
DicomObjects |
DicomObjects.Codecs |
DicomObjects.Delegates |
DicomObjects.Enums |
DicomObjects.EventArguments |
DicomObjects.UIDs |
DicomObjects.Validation |
DicomObjects.Video |


%%PageItemTitle%%

DicomObjects Namespace / DicomAssociation Class
Members

In This Topic
    DicomAssociation Class
    In This Topic
    Class representing a single DICOM Association
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Class DicomAssociation
    'Usage

    Dim instance As DicomAssociation
    public class DicomAssociation
    Remarks

    A DicomAssociation Object represents the current state of an association, and may either be created automatically in response to an incoming query request, or explicitly by the client program. Methods of this object are used to send data, images, and verification requests. There is not a one-to-one correspondence between DicomAssociations and associations, as one incoming association may cause several DicomAssociation objects to be produced, one in response to each incoming command, and likewise, an outgoing DicomAssociation object may during its life serve more than one association, but at a given time, each association is represented by one, and only one DicomAssociation.

    Inheritance Hierarchy

    System.Object
    DicomObjects.DicomAssociation

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Members
    DicomObjects Namespace


%%PageItemTitle%% $$Members$$

DicomObjects Namespace / DicomAssociation Class
Properties Methods Events

In This Topic
    DicomAssociation Class Members
    In This Topic

    The following tables list the members exposed by DicomAssociation.

    Public Constructors
     | Name | Description
Public Constructor | DicomAssociation Constructor | Creates a new DicomAssociation object.
    Top
    Public Properties
     | Name | Description
Public Property | AgreedContexts | The Presentation Contexts associated with this DicomAssociation
Public Property | AssociationNumber | Returns the association number of current connection.
Public Property | BytesReceived | Approximate Measures of Network Input
Public Property | BytesSent | Approximate measures of Network Output
Public Property | CalledAET | Application entity title of the remote application
Public Property | CallingAET | Application entity title of this application
Public Property | Cancelled | Indicates that the remote AE has issued a C-CANCEL request.
Public Property | ChangeLossyUIDs | Control allocation of new UIDs for lossy compressed images
Public Property | CheckForCancel | Control whether to check for incoming C-CANCEL asynchronous messages
Public Property | CoercionSOP | SOP Class to which images should be coerced if peer does not accept true SOP class
Public Property | Command | The full command dataset received
static (Shared in Visual Basic) | DefaultThrowStatusException | The value intially assigned for the ThrowStatusException of new DicomAssociation objects.
Public Property | Destination | The Application Entity Name to which images should be sent by a C-MOVE request
Public Property | Identity | The user identity to use for an association
Public Property | ImplementationName | Returns the Implementation Version Name of the Connecting AE
Public Property | ImplementationUID | Returns the Implementation Class UID of the Connecting AE
Public Property | IsOpen | Indicates whether a DicomAssociation is open
Public Property | LastCommand | Returns the last command in the current association.
Public Property | LastError | Returns the last error status from LastCommand.
Public Property | LastInstanceUID | Holds the InstanceUID created or used by the last normalised operation.
Public Property | LastOperation | Returns the last operation in the current association.
Public Property | LastStatus | Shortcut for the first element of the Status property
Public Property | LocalIP | Provide information about which local interface the remote application entity called
Public Property | LocalPort | Provide information about which local port the remote application entity called
Public Property | LogLevel | Controls the level of logging for this particular Association.
Public Property | MetaSOPClass | Determines the Abstract Syntax used for normalised operations
Public Property | MoveOriginator | The DicomAssociation object which initiated the C-MOVE resulting in the current C-STORE
Public Property | PreferredPCID | Provides guidance for the choice of presentation context
Public Property | PreferredTS | Provides guidance for the choice of presentation context
Public Property | PreferredTSList | Provides guidance for the choice of presentation context
Public Property | ReadBehaviour | Specific behaviours to use when receiving data on this association.
Public Property | RemoteIP | Provides information about the remote application entity
Public Property | Request | This contains the list of attributes to be matched, as specified in the DICOM standard
Public Property | RequestedContexts | The Presentation Contexts associated with this DicomAssociation
Public Property | RequestingQuery | Provides a linkage to the primary C-MOVE request.
Public Property | ReturnedCommands | The command datasets returned in response to the last operation
Public Property | ReturnedIdentifier | Hold data returned from outgoing operations
Public Property | ReturnedIdentifiers | Hold data returned from outgoing operations
Public Property | ReturnedInstances | Hold instances returned from outgoing C-GET operations
Public Property | SslStream | Returns the secure Stream object
Public Property | Status | Array containing the status codes returned by the last SendInstances or Echo action
Public Property | Tag | A general purpose Tag for developer use
Public Property | ThrowStatusException | Controls whether an exception is generated when a non-zero status is received.
Public Property | WriteBehaviour | Specific behaviours to use when sending data on this association.
    Top
    Public Methods
     | Name | Description
Public Method | Abort | Aborts an association
Public Method | Cancel | Causes a C-CANCEL request to be sent to the remote AE asking it to terminate any outstanding image transfers
Public Method | CheckForNEventReports | Checks whether there is any unsolicited incoming data on the association
Public Method | Close | Closes the association represented by a "stand-alone" DicomAssociation
Public Method | Dispose | Releases the resources used by the DicomAssociation object
Public Method | Echo | Sends a verification request (C-ECHO) over a "stand-alone" DicomAssociation and returns the result
Public Method | Find | Overloaded. Sends a C-FIND request
Public Method | Get | Overloaded. Sends a C-GET request
Public Method | Move | Overloaded. Sends a C-MOVE request
Public Method | NAction | Sends an N-ACTION request
Public Method | NCreate | Sends an N-CREATE request
Public Method | NDelete | Sends an N-DELETE request
Public Method | NEventReport | Send an N-EVENT-REPORT over an established DicomAssociation
Public Method | NGet | Sends an N-GET request
Public Method | NSet | Sends an N-SET request
Public Method | Open | Overloaded. Negotiate an association with a remote application.
Public Method | PcidFor | Indicates the presentaiton context ID which would be used to send an instance of the given SOP class
Public Method | SendInstances | Overloaded. Sends data over a DicomAssociation
Public Method | SendPending | Send a "pending" response to an outstanding C-MOVE request
Public Method | SendResponse | Overloaded. Returns results to a C-FIND request
Public Method | SetQuality | Set the quality factor for lossy compression
    Top
    Public Events
     | Name | Description
Public Event | InitiateTls | Routine to use to generate encrypted stream when TLS is to be used for outgoing associations.
Public Event | N_Event_Report | This event handler is fired when an N-EVENT-REPORT notification is received.
Public Event | ResponseReceived | Event fires when a response is received on an out-going operation
    Top
    See Also

    Reference

    DicomAssociation Class
    DicomObjects Namespace


%%PageItemTitle%%

DicomObjects Namespace / DicomAssociation Class / DicomAssociation Constructor

In This Topic
    DicomAssociation Constructor
    In This Topic
    Creates a new DicomAssociation object.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Function New()
    'Usage

    Dim instance As New DicomAssociation()
    public DicomAssociation()

    Return Value

    DicomAssociation
    Remarks

    Creates a new DicomAssociation object.

    Such an explicitly created DicomAssociation is assumed to be for outgoing use, and requires use of open before operations can occur on it.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


%%PageItemTitle%% $$Methods$$

DicomObjects Namespace / DicomAssociation Class

    DicomAssociation Class Methods
    In This Topic

    For a list of all members of this type, see DicomAssociation members.

    Public Methods
     | Name | Description
Public Method | Abort | Aborts an association
Public Method | Cancel | Causes a C-CANCEL request to be sent to the remote AE asking it to terminate any outstanding image transfers
Public Method | CheckForNEventReports | Checks whether there is any unsolicited incoming data on the association
Public Method | Close | Closes the association represented by a "stand-alone" DicomAssociation
Public Method | Dispose | Releases the resources used by the DicomAssociation object
Public Method | Echo | Sends a verification request (C-ECHO) over a "stand-alone" DicomAssociation and returns the result
Public Method | Find | Overloaded. Sends a C-FIND request
Public Method | Get | Overloaded. Sends a C-GET request
Public Method | Move | Overloaded. Sends a C-MOVE request
Public Method | NAction | Sends an N-ACTION request
Public Method | NCreate | Sends an N-CREATE request
Public Method | NDelete | Sends an N-DELETE request
Public Method | NEventReport | Send an N-EVENT-REPORT over an established DicomAssociation
Public Method | NGet | Sends an N-GET request
Public Method | NSet | Sends an N-SET request
Public Method | Open | Overloaded. Negotiate an association with a remote application.
Public Method | PcidFor | Indicates the presentaiton context ID which would be used to send an instance of the given SOP class
Public Method | SendInstances | Overloaded. Sends data over a DicomAssociation
Public Method | SendPending | Send a "pending" response to an outstanding C-MOVE request
Public Method | SendResponse | Overloaded. Returns results to a C-FIND request
Public Method | SetQuality | Set the quality factor for lossy compression
    Top
    See Also

    Reference

    DicomAssociation Class
    DicomObjects Namespace


DicomObjects Namespace / DicomAssociation Class / Abort Method

The "Cause" of the Abort

The "Cause" of the Abort

In This Topic
    Abort Method
    In This Topic
    Aborts an association
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Sub Abort( _
   ByVal Reason As Byte, _
   ByVal Source As Byte _
)
    'Usage

    Dim instance As DicomAssociation
Dim Reason As Byte
Dim Source As Byte

instance.Abort(Reason, Source)
    public void Abort(
   byte Reason,
   byte Source
)

    Parameters

    Reason

    The "Cause" of the Abort

    Source

    The "Cause" of the Abort

    Remarks

    An A-ABORT request is sent, and the association is then terminated.

    The full meanings of the parameters are defined in DICOM Standard part 8, detailed as below:

    Source

    0 - DICOM UL service-user (initiated abort)

    1 - Reserved

    2 - DICOM UL service-provider (initiated abort)

    Reason

    0 - reason-not-specified

    1 - unrecognized-PDU

    2 - unexpected-PDU

    3 - reserved

    4 - unrecognized-PDU parameter

    5 - unexpected-PDU parameter

    6 - invalid-PDU-parameter value

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / Cancel Method

    Cancel Method
    Causes a C-CANCEL request to be sent to the remote AE asking it to terminate any outstanding image transfers
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Sub Cancel()
    'Usage

    Dim instance As DicomAssociation

instance.Cancel()
    public void Cancel()
    Remarks
    The C-CANCEL request is sent between images so a single image transfer may not be affected.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / CheckForNEventReports Method

    CheckForNEventReports Method
    Checks whether there is any unsolicited incoming data on the association
    Syntax
    • Visual Basic
    • C#
    'Declaration

    <ObsoleteAttribute("This method is no longer needed, and does nothing")>
Public Sub CheckForNEventReports()
    'Usage

    Dim instance As DicomAssociation

instance.CheckForNEventReports()
    [Obsolete("This method is no longer needed, and does nothing")]
public void CheckForNEventReports()
    Remarks

    This method is only needed when there is the possibility of receiving N-EVENT-REPORT messages in between outgoing operations. In practice this only applies to the (now disparaged) use of Storage Commitment over a single association or direct DICOM Printing.

    If any such data is found, then it will be handled and passed to the associated N_Event_Report event handler

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / Close Method

    Close Method (DicomAssociation)
    In This Topic
    Closes the association represented by a "stand-alone" DicomAssociation
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Sub Close()
    'Usage

    Dim instance As DicomAssociation

instance.Close()
    public void Close()
    Remarks
    After a close method, a DicomAssociation object may be re-used, using Open to establish a new association. The isOpen property is set to false after this method.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / Dispose Method

    Dispose Method (DicomAssociation)
    In This Topic
    Releases the resources used by the DicomAssociation object
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overridable Sub Dispose()
    'Usage

    Dim instance As DicomAssociation

instance.Dispose()
    public virtual void Dispose()
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / Echo Method

    Echo Method (DicomAssociation)
    In This Topic
    Sends a verification request (C-ECHO) over a "stand-alone" DicomAssociation and returns the result
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Function Echo() As Integer
    'Usage

    Dim instance As DicomAssociation
Dim value As Integer

value = instance.Echo()
    public int Echo()

    Return Value

    Integer
    Remarks

    DicomAssociation must be open before sending out C-ECHO request.

    Although in theory the remote entity may return a status other than 0 to indicate an error, in most circumstances (such as remote machine turned off), this method will fail with a trappable error, such as "Fail to connection at TCP level".

    The C-ECHO status can also be found in the LastStatus property of DicomAssociation.

    For more details of sending C-ECHO via TLS, see Echo method of DicomGlobal object.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / Find Method

    Find Method (DicomAssociation)
    In This Topic
    Sends a C-FIND request
    Overload List
    Overload | Description
Find(QueryRoot,DicomDataSet) | Sends a C-FIND request
Find(String,DicomDataSet) | Sends a C-FIND request for Object with Private SOP Class UID
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / Find Method / Find(QueryRoot,DicomDataSet) Method

The query root

The DataSet parameter defines the C-FIND searching criteria.

In This Topic
    Find(QueryRoot,DicomDataSet) Method
    In This Topic
    Sends a C-FIND request
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub Find( _
   ByVal Root As QueryRoot, _
   ByVal DataSet As DicomDataSet _
)
    'Usage

    Dim instance As DicomAssociation
Dim Root As QueryRoot
Dim DataSet As DicomDataSet

instance.Find(Root, DataSet)
    public void Find(
   QueryRoot Root,
   DicomDataSet DataSet
)

    Parameters

    Root

    The query root

    DataSet

    The DataSet parameter defines the C-FIND searching criteria.

    Remarks

    The query to be performed is defined by the DataSet parameter, and this method is functionally equivalent to the Find method of the DicomQuery object.

    Note that the QueryLevel value (0008,0052), must be included in the data set, but the dataset parameter MUST NOT contain any group 0x0000 elements (the group 0x0000 contains elements describing operation and some of the fields like MessageID, etc.)

    Once the operation has completed, the result may be found in the ReturnedIdentifiers Collection.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members
    Overload List


DicomObjects Namespace / DicomAssociation Class / Find Method / Find(String,DicomDataSet) Method

The Private SOP Class UID of the DICOM object

The DataSet parameter defines the C-FIND searching criteria.

In This Topic
    Find(String,DicomDataSet) Method
    In This Topic
    Sends a C-FIND request for Object with Private SOP Class UID
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub Find( _
   ByVal SopClassUID As String, _
   ByVal DataSet As DicomDataSet _
)
    'Usage

    Dim instance As DicomAssociation
Dim SopClassUID As String
Dim DataSet As DicomDataSet

instance.Find(SopClassUID, DataSet)
    public void Find(
   string SopClassUID,
   DicomDataSet DataSet
)

    Parameters

    SopClassUID

    The Private SOP Class UID of the DICOM object

    DataSet

    The DataSet parameter defines the C-FIND searching criteria.

    Remarks

    This is for use with private SOP classes and it is rarely used and only being needed for very specialist use.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members
    Overload List


DicomObjects Namespace / DicomAssociation Class / Get Method

    Get Method (DicomAssociation)
    In This Topic
    Sends a C-GET request
    Overload List
    Overload | Description
Get(QueryRoot,DicomDataSet) | Sends a C-GET request
Get(QueryRoot,DicomDataSet,Boolean) | Sends a C-GET request
Get(String,DicomDataSet) | Sends a C-GET request for Object with Private SOP Class UID
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / Get Method / Get(QueryRoot,DicomDataSet) Method

The query root

The identifier for the request

In This Topic
    Get(QueryRoot,DicomDataSet) Method
    In This Topic
    Sends a C-GET request
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub Get( _
   ByVal Root As QueryRoot, _
   ByVal DataSet As DicomDataSet _
)
    'Usage

    Dim instance As DicomAssociation
Dim Root As QueryRoot
Dim DataSet As DicomDataSet

instance.Get(Root, DataSet)
    public void Get(
   QueryRoot Root,
   DicomDataSet DataSet
)

    Parameters

    Root

    The query root

    DataSet

    The identifier for the request

    Remarks

    The images to be retrieved are defined by the DataSet parameter.

    Note that the QueryLevel value (0008,0052), must be included in the data set, but the dataset parameter MUST NOT contain any group 0x0000 elements (the group 0x0000 contains elements describing operation and some of the fields like MessageID, etc.)

    Once the operation has completed, the images retrieved may be found in the ReturnedInstances collection.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members
    Overload List


DicomObjects Namespace / DicomAssociation Class / Get Method / Get(QueryRoot,DicomDataSet,Boolean) Method

The query root

The identifier for the request

Specify if bulk data is required in the response

In This Topic
    Get(QueryRoot,DicomDataSet,Boolean) Method
    In This Topic
    Sends a C-GET request
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub Get( _
   ByVal Root As QueryRoot, _
   ByVal DataSet As DicomDataSet, _
   ByVal NoBulkData As Boolean _
)
    'Usage

    Dim instance As DicomAssociation
Dim Root As QueryRoot
Dim DataSet As DicomDataSet
Dim NoBulkData As Boolean

instance.Get(Root, DataSet, NoBulkData)
    public void Get(
   QueryRoot Root,
   DicomDataSet DataSet,
   bool NoBulkData
)

    Parameters

    Root

    The query root

    DataSet

    The identifier for the request

    NoBulkData

    Specify if bulk data is required in the response

    Remarks

    The images to be retrieved are defined by the DataSet parameter.

    Note that the QueryLevel value (0008,0052), must be included in the data set, but the dataset parameter MUST NOT contain any group 0x0000 elements (the group 0x0000 contains elements describing operation and some of the fields like MessageID, etc.)

    Once the operation has completed, the images retrieved may be found in the ReturnedInstances collection.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members
    Overload List


DicomObjects Namespace / DicomAssociation Class / Get Method / Get(String,DicomDataSet) Method

The Private SOPClassUID of the

The identifier for the request

In This Topic
    Get(String,DicomDataSet) Method
    In This Topic
    Sends a C-GET request for Object with Private SOP Class UID
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub Get( _
   ByVal SopClassUID As String, _
   ByVal DataSet As DicomDataSet _
)
    'Usage

    Dim instance As DicomAssociation
Dim SopClassUID As String
Dim DataSet As DicomDataSet

instance.Get(SopClassUID, DataSet)
    public void Get(
   string SopClassUID,
   DicomDataSet DataSet
)

    Parameters

    SopClassUID

    The Private SOPClassUID of the

    DataSet

    The identifier for the request

    Remarks

    This is for use with private SOP classes and it is rarely used and only being needed for very specialist use.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members
    Overload List


DicomObjects Namespace / DicomAssociation Class / Move Method

    Move Method (DicomAssociation)
    In This Topic
    Sends a C-MOVE request
    Overload List
    Overload | Description
Move(QueryRoot,String,DicomDataSet) | Sends a C-MOVE request
Move(String,DicomDataSet) | Sends a C-MOVE request for Object with Private SOP Class UID
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / Move Method / Move(QueryRoot,String,DicomDataSet) Method

The query root

The destination AE Title

The identifier for the C_MOVE request

In This Topic
    Move(QueryRoot,String,DicomDataSet) Method
    In This Topic
    Sends a C-MOVE request
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub Move( _
   ByVal Root As QueryRoot, _
   ByVal Destination As String, _
   ByVal DataSet As DicomDataSet _
)
    'Usage

    Dim instance As DicomAssociation
Dim Root As QueryRoot
Dim Destination As String
Dim DataSet As DicomDataSet

instance.Move(Root, Destination, DataSet)
    public void Move(
   QueryRoot Root,
   string Destination,
   DicomDataSet DataSet
)

    Parameters

    Root

    The query root

    Destination

    The destination AE Title

    DataSet

    The identifier for the C_MOVE request

    Remarks

    The images to be moved are defined by the DataSet parameter.

    Note that the QueryLevel value (0008,0052), must be included in the data set, but the dataset parameter MUST NOT contain any group 0x0000 elements (the group 0x0000 contains elements describing operation and some of the fields like MessageID, etc.)

    Once the operation has completed, the result codes may be found in the Status property.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members
    Overload List


DicomObjects Namespace / DicomAssociation Class / Move Method / Move(String,DicomDataSet) Method

The Private SOP Class UID of the DICOM object

The identifier for the C_MOVE request

In This Topic
    Move(String,DicomDataSet) Method
    In This Topic
    Sends a C-MOVE request for Object with Private SOP Class UID
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub Move( _
   ByVal SopClassUID As String, _
   ByVal DataSet As DicomDataSet _
)
    'Usage

    Dim instance As DicomAssociation
Dim SopClassUID As String
Dim DataSet As DicomDataSet

instance.Move(SopClassUID, DataSet)
    public void Move(
   string SopClassUID,
   DicomDataSet DataSet
)

    Parameters

    SopClassUID

    The Private SOP Class UID of the DICOM object

    DataSet

    The identifier for the C_MOVE request

    Remarks

    This is for use with private SOP classes and it is rarely used and only being needed for very specialist use.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members
    Overload List


DicomObjects Namespace / DicomAssociation Class / NAction Method

The requested SOP Class UID

The requested SOP InstanceUID

Context dependent Action code

The attributes to be set, with their values

In This Topic
    NAction Method
    In This Topic
    Sends an N-ACTION request
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Sub NAction( _
   ByVal SOPClassUID As String, _
   ByVal InstanceUID As String, _
   ByVal ActionID As Integer, _
   ByVal DataSet As DicomDataSet _
)
    'Usage

    Dim instance As DicomAssociation
Dim SOPClassUID As String
Dim InstanceUID As String
Dim ActionID As Integer
Dim DataSet As DicomDataSet

instance.NAction(SOPClassUID, InstanceUID, ActionID, DataSet)
    public void NAction(
   string SOPClassUID,
   string InstanceUID,
   int ActionID,
   DicomDataSet DataSet
)

    Parameters

    SOPClassUID

    The requested SOP Class UID

    InstanceUID

    The requested SOP InstanceUID

    ActionID

    Context dependent Action code

    DataSet

    The attributes to be set, with their values

    Remarks

    This method sends an N-ACTION request, using the quoted SOP Class and Instance UIDs, ActionID and DataSet.

    In many cases, a dataset is not required, in which case an empty dataset should be used.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / NCreate Method

The requested SOP Class UID

The requested SOP InstanceUID

The attributes to be set, with their values

In This Topic
    NCreate Method
    In This Topic
    Sends an N-CREATE request
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Sub NCreate( _
   ByVal SOPClassUID As String, _
   ByVal InstanceUID As String, _
   ByVal DataSet As DicomDataSet _
)
    'Usage

    Dim instance As DicomAssociation
Dim SOPClassUID As String
Dim InstanceUID As String
Dim DataSet As DicomDataSet

instance.NCreate(SOPClassUID, InstanceUID, DataSet)
    public void NCreate(
   string SOPClassUID,
   string InstanceUID,
   DicomDataSet DataSet
)

    Parameters

    SOPClassUID

    The requested SOP Class UID

    InstanceUID

    The requested SOP InstanceUID

    DataSet

    The attributes to be set, with their values

    Remarks

    This method sends an N-CREATE request, using the quoted SOP Class and Instance UIDs.

    If appropriate, the SCP may use the values in DataSet to initialise the object.

    If the operation succeeds, then the UID of the object created may be found, once the operation has completed, in the LastInstanceUID property.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / NDelete Method

The requested SOP Class UID

The requested SOP InstanceUID

In This Topic
    NDelete Method
    In This Topic
    Sends an N-DELETE request
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Sub NDelete( _
   ByVal SOPClassUID As String, _
   ByVal InstanceUID As String _
)
    'Usage

    Dim instance As DicomAssociation
Dim SOPClassUID As String
Dim InstanceUID As String

instance.NDelete(SOPClassUID, InstanceUID)
    public void NDelete(
   string SOPClassUID,
   string InstanceUID
)

    Parameters

    SOPClassUID

    The requested SOP Class UID

    InstanceUID

    The requested SOP InstanceUID

    Remarks

    This method sends an N-DELETE request, using the quoted SOP Class and Instance UIDs.

    No other information is permitted in an N-DELETE command.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / NEventReport Method

The requested SOP Class UID

The requested SOP InstanceUID

Event ID, as defined by the Class UID

Associated Data

In This Topic
    NEventReport Method
    In This Topic
    Send an N-EVENT-REPORT over an established DicomAssociation
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Sub NEventReport( _
   ByVal SOPClassUID As String, _
   ByVal InstanceUID As String, _
   ByVal EventID As Integer, _
   ByVal DataSet As DicomDataSet _
)
    'Usage

    Dim instance As DicomAssociation
Dim SOPClassUID As String
Dim InstanceUID As String
Dim EventID As Integer
Dim DataSet As DicomDataSet

instance.NEventReport(SOPClassUID, InstanceUID, EventID, DataSet)
    public void NEventReport(
   string SOPClassUID,
   string InstanceUID,
   int EventID,
   DicomDataSet DataSet
)

    Parameters

    SOPClassUID

    The requested SOP Class UID

    InstanceUID

    The requested SOP InstanceUID

    EventID

    Event ID, as defined by the Class UID

    DataSet

    Associated Data

    Remarks

    Before using this method, it is important to ensure that the required SOP Class UID has been negotiated with the remote entity. In some cases such as when using Storage Commitment, reverse role SCU/SCP negotiation may also be necessary.

    The return status can be found in the LastStatus property of DicomAssociation object.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / NGet Method

The requested SOP Class UID

The requested SOP InstanceUID

The attributes requested

In This Topic
    NGet Method
    In This Topic
    Sends an N-GET request
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Sub NGet( _
   ByVal SOPClassUID As String, _
   ByVal InstanceUID As String, _
   ByVal DataSet As DicomDataSet _
)
    'Usage

    Dim instance As DicomAssociation
Dim SOPClassUID As String
Dim InstanceUID As String
Dim DataSet As DicomDataSet

instance.NGet(SOPClassUID, InstanceUID, DataSet)
    public void NGet(
   string SOPClassUID,
   string InstanceUID,
   DicomDataSet DataSet
)

    Parameters

    SOPClassUID

    The requested SOP Class UID

    InstanceUID

    The requested SOP InstanceUID

    DataSet

    The attributes requested

    Return Value

    This method sends an N-GET request, using the quoted SOP Class and Instance UIDs. The values of the attributes in the DataSet are irrelevant, as it is used solely as a list of attributes whose values are to be retrieved.

    The returned values may be found, once the operation has completed, in the ReturnedIdentifier property.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / NSet Method

The requested SOP Class UID

The requested SOP InstanceUID

The attributes to be set, with their values

In This Topic
    NSet Method
    In This Topic
    Sends an N-SET request
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Sub NSet( _
   ByVal SOPClassUID As String, _
   ByVal InstanceUID As String, _
   ByVal DataSet As DicomDataSet _
)
    'Usage

    Dim instance As DicomAssociation
Dim SOPClassUID As String
Dim InstanceUID As String
Dim DataSet As DicomDataSet

instance.NSet(SOPClassUID, InstanceUID, DataSet)
    public void NSet(
   string SOPClassUID,
   string InstanceUID,
   DicomDataSet DataSet
)

    Parameters

    SOPClassUID

    The requested SOP Class UID

    InstanceUID

    The requested SOP InstanceUID

    DataSet

    The attributes to be set, with their values

    Remarks

    This method sends an N-SET request, using the quoted SOP Class and Instance UIDs.

    If values are returned they may be found, once the operation has completed, in the ReturnedIdentifier property.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / Open Method

    Open Method (DicomAssociation)
    In This Topic
    Negotiate an association with a remote application.
    Overload List
    Overload | Description
Open(String,Int32,String,String) | Open and negotiate a new DICOM Association
Open(Socket,Stream,String,String) | Open a DICOM association over an independently created System.Net.Sockets.NetworkStream
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / Open Method / Open(String,Int32,String,String) Method

Network address (as dotted notation or resolvable name) to which the association is to be made

Port on which remote application is listening

Name to quote for this Application Entity

Name of remote Application Entity

In This Topic
    Open(String,Int32,String,String) Method
    In This Topic
    Open and negotiate a new DICOM Association
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub Open( _
   ByVal Node As String, _
   ByVal Port As Integer, _
   ByVal CallingAET As String, _
   ByVal CalledAET As String _
)
    'Usage

    Dim instance As DicomAssociation
Dim Node As String
Dim Port As Integer
Dim CallingAET As String
Dim CalledAET As String

instance.Open(Node, Port, CallingAET, CalledAET)
    public void Open(
   string Node,
   int Port,
   string CallingAET,
   string CalledAET
)

    Parameters

    Node

    Network address (as dotted notation or resolvable name) to which the association is to be made

    Port

    Port on which remote application is listening

    CallingAET

    Name to quote for this Application Entity

    CalledAET

    Name of remote Application Entity

    Remarks

    This method returns, after the connection has been established. If there is a protocol failure, then a trappable DicomException is thrown.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members
    Overload List


DicomObjects Namespace / DicomAssociation Class / Open Method / Open(Socket,Stream,String,String) Method
Specifies the underlying Socket through which an association should be made.

The NetworkStream via which the connection is to be made

Name to quote for this Application Entity

Name of remote Application Entity

In This Topic
    Open(Socket,Stream,String,String) Method
    In This Topic
    Open a DICOM association over an independently created System.Net.Sockets.NetworkStream
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub Open( _
   ByVal Socket As Socket, _
   ByVal Stream As Stream, _
   ByVal CallingAET As String, _
   ByVal CalledAET As String _
)
    'Usage

    Dim instance As DicomAssociation
Dim Socket As Socket
Dim Stream As Stream
Dim CallingAET As String
Dim CalledAET As String

instance.Open(Socket, Stream, CallingAET, CalledAET)
    public void Open(
   Socket Socket,
   Stream Stream,
   string CallingAET,
   string CalledAET
)

    Parameters

    Socket
    Specifies the underlying Socket through which an association should be made.
    Stream

    The NetworkStream via which the connection is to be made

    CallingAET

    Name to quote for this Application Entity

    CalledAET

    Name of remote Application Entity

    Remarks

    This version is useful in some security scenarios, as the NetworkStream may be negotiated and verified before starting DICOM negoations. Note that both the NetworkStream and underlying Socket need to be specified, as some controls (such as timeout values) are only valid when applied to the socket. This method returns, after the connection has been established. If there is a protocol failure, then a trappable DicomException is thrown.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members
    Overload List


DicomObjects Namespace / DicomAssociation Class / PcidFor Method
The SOP class to test for

    PcidFor Method
    In This Topic
    Indicates the presentaiton context ID which would be used to send an instance of the given SOP class
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Function PcidFor( _
   ByVal SOPClass As String _
) As Byte
    'Usage

    Dim instance As DicomAssociation
Dim SOPClass As String
Dim value As Byte

value = instance.PcidFor(SOPClass)
    public byte PcidFor(
   string SOPClass
)

    Parameters

    SOPClass
    The SOP class to test for

    Return Value

    Either the presentation context ID which would be used to send an instance of the stated SOP class, or 0 if so suitable, agreed presentation context exists.

    Remarks

    This routines uses the properties AgreedContexts, MetaSOPClass, PreferredPCID, PreferredTS and PreferredTSList

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / SendInstances Method

    SendInstances Method
    Sends data over a DicomAssociation
    Overload List
    Overload | Description
SendInstances(IEnumerable<DicomDataSet>) | Sends images over a DicomAssociation
SendInstances(DicomDataSet) | Sends an DataSet over a DicomAssociation
SendInstances(Stream) | Sends data which is contained in a System IO Stream over a DicomAssociation
SendInstances(String) | Sends a file referenced by a string over a DicomAssociation
SendInstances(IEnumerable<String>) | Sends multiple files referenced by a collection of strings over a DicomAssociation
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / SendInstances Method / SendInstances(IEnumerable<DicomDataSet>) Method
The DicomDataSetCollection to send

    SendInstances(IEnumerable<DicomDataSet>) Method
    In This Topic
    Sends images over a DicomAssociation
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub SendInstances( _
   ByVal DataSets As IEnumerable(Of DicomDataSet) _
)
    'Usage

    Dim instance As DicomAssociation
Dim DataSets As IEnumerable(Of DicomDataSet)

instance.SendInstances(DataSets)
    public void SendInstances(
   IEnumerable<DicomDataSet> DataSets
)

    Parameters

    DataSets
    The DicomDataSetCollection to send
    Remarks

    For automatically generated DicomAssociation objects, this method is used in response to a C-GET or C-MOVE request, but it may also be used to send any images the client chooses over a "stand-alone" DicomAssociation.

    Data sent by this method are sent either to the requesting application (C-GET) or to another (C-MOVE or stand-alone) as a series of C-STORE actions.

    For C-MOVE operations, if this Association has been linked internally to the request (i.e. if it is the DicomObjects.EventArguments.QueryReceivedArgs.InstanceAssociation), then:

    • "pending" responses are generated automatically by this method.
    • The number of images remaining, failed, warning, and successful associated with the request are automatically updated by the method, and the Failures property maintains a list of refused images UIDs. If all images are to be returned via a single call to SendImages, then no specific client action is required, as NumberRemaining is set automatically to the number of images in Data if previously 0. If, however, the client wishes to return images via multiple calls to this method (e.g. to enable pending status messages), then NumberRemaining must be set correctly before the first image is returned.

    For C-MOVE requests, or "stand-alone" DicomAssociation objects, Open must be called before this method.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members
    Overload List


DicomObjects Namespace / DicomAssociation Class / SendInstances Method / SendInstances(DicomDataSet) Method
The DicomDataSet to send

    SendInstances(DicomDataSet) Method
    In This Topic
    Sends an DataSet over a DicomAssociation
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub SendInstances( _
   ByVal DataSet As DicomDataSet _
)
    'Usage

    Dim instance As DicomAssociation
Dim DataSet As DicomDataSet

instance.SendInstances(DataSet)
    public void SendInstances(
   DicomDataSet DataSet
)

    Parameters

    DataSet
    The DicomDataSet to send
    Remarks

    For automatically generated DicomAssociation objects, this method is used in response to a C-GET or C-MOVE request, but it may also be used to send any images the client chooses over a "stand-alone" DicomAssociation.

    Data sent by this method are sent either to the requesting application (C-GET) or to another (C-MOVE or stand-alone) as a series of C-STORE actions.

    For C-MOVE operations, if this Association has been linked internally to the request (i.e. if it is the DicomObjects.EventArguments.QueryReceivedArgs.InstanceAssociation), then:

    • "pending" responses are generated automatically by this method.
    • The number of images remaining, failed, warning, and successful associated with the request are automatically updated by the method, and the Failures property maintains a list of refused images UIDs. If all images are to be returned via a single call to SendImages, then no specific client action is required, as NumberRemaining is set automatically to the number of images in Data if previously 0. If, however, the client wishes to return images via multiple calls to this method (e.g. to enable pending status messages), then NumberRemaining must be set correctly before the first image is returned.

    For C-MOVE requests, or "stand-alone" DicomAssociation objects, Open must be called before this method.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members
    Overload List


DicomObjects Namespace / DicomAssociation Class / SendInstances Method / SendInstances(Stream) Method

The Stream which contains the data to be transmitted

    SendInstances(Stream) Method
    In This Topic
    Sends data which is contained in a System IO Stream over a DicomAssociation
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub SendInstances( _
   ByVal Stream As Stream _
)
    'Usage

    Dim instance As DicomAssociation
Dim Stream As Stream

instance.SendInstances(Stream)
    public void SendInstances(
   Stream Stream
)

    Parameters

    Stream

    The Stream which contains the data to be transmitted

    Remarks

    For automatically generated DicomAssociation objects, this method is used in response to a C-GET or C-MOVE request, but it may also be used to send any images the client chooses over a "stand-alone" DicomAssociation.

    Data sent by this method are sent either to the requesting application (C-GET) or to another (C-MOVE or stand-alone) as a series of C-STORE actions.

    For C-MOVE operations, if this Association has been linked internally to the request (i.e. if it is the DicomObjects.EventArguments.QueryReceivedArgs.InstanceAssociation), then:

    • "pending" responses are generated automatically by this method.
    • The number of images remaining, failed, warning, and successful associated with the request are automatically updated by the method, and the Failures property maintains a list of refused images UIDs. If all images are to be returned via a single call to SendImages, then no specific client action is required, as NumberRemaining is set automatically to the number of images in Data if previously 0. If, however, the client wishes to return images via multiple calls to this method (e.g. to enable pending status messages), then NumberRemaining must be set correctly before the first image is returned.

    For C-MOVE requests, or "stand-alone" DicomAssociation objects, Open must be called before this method.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members
    Overload List


DicomObjects Namespace / DicomAssociation Class / SendInstances Method / SendInstances(String) Method

The name of the file to read.

This is passed unmodified to the operating system, and it is therefore the container’s responsibility to ensure either that the file exists within the current directory, or that a fully qualified filename is provided.

In This Topic
    SendInstances(String) Method
    In This Topic
    Sends a file referenced by a string over a DicomAssociation
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub SendInstances( _
   ByVal Filename As String _
)
    'Usage

    Dim instance As DicomAssociation
Dim Filename As String

instance.SendInstances(Filename)
    public void SendInstances(
   string Filename
)

    Parameters

    Filename

    The name of the file to read.

    This is passed unmodified to the operating system, and it is therefore the container’s responsibility to ensure either that the file exists within the current directory, or that a fully qualified filename is provided.

    Remarks

    For automatically generated DicomAssociation objects, this method is used in response to a C-GET or C-MOVE request, but it may also be used to send any images the client chooses over a "stand-alone" DicomAssociation.

    Data sent by this method are sent either to the requesting application (C-GET) or to another (C-MOVE or stand-alone) as a series of C-STORE actions.

    For C-MOVE operations, if this Association has been linked internally to the request (i.e. if it is the DicomObjects.EventArguments.QueryReceivedArgs.InstanceAssociation), then:

    • "pending" responses are generated automatically by this method.
    • The number of images remaining, failed, warning, and successful associated with the request are automatically updated by the method, and the Failures property maintains a list of refused images UIDs. If all images are to be returned via a single call to SendImages, then no specific client action is required, as NumberRemaining is set automatically to the number of images in Data if previously 0. If, however, the client wishes to return images via multiple calls to this method (e.g. to enable pending status messages), then NumberRemaining must be set correctly before the first image is returned.

    For C-MOVE requests, or "stand-alone" DicomAssociation objects, Open must be called before this method.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members
    Overload List


DicomObjects Namespace / DicomAssociation Class / SendInstances Method / SendInstances(IEnumerable<String>) Method
The filenames of the files to send

    SendInstances(IEnumerable<String>) Method
    In This Topic
    Sends multiple files referenced by a collection of strings over a DicomAssociation
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub SendInstances( _
   ByVal Filenames As IEnumerable(Of String) _
)
    'Usage

    Dim instance As DicomAssociation
Dim Filenames As IEnumerable(Of String)

instance.SendInstances(Filenames)
    public void SendInstances(
   IEnumerable<string> Filenames
)

    Parameters

    Filenames
    The filenames of the files to send
    Remarks

    For automatically generated DicomAssociation objects, this method is used in response to a C-GET or C-MOVE request, but it may also be used to send any images the client chooses over a "stand-alone" DicomAssociation.

    Data sent by this method are sent either to the requesting application (C-GET) or to another (C-MOVE or stand-alone) as a series of C-STORE actions.

    For C-MOVE operations, if this Association has been linked internally to the request (i.e. if it is the DicomObjects.EventArguments.QueryReceivedArgs.InstanceAssociation), then:

    • "pending" responses are generated automatically by this method.
    • The number of images remaining, failed, warning, and successful associated with the request are automatically updated by the method, and the Failures property maintains a list of refused images UIDs. If all images are to be returned via a single call to SendImages, then no specific client action is required, as NumberRemaining is set automatically to the number of images in Data if previously 0. If, however, the client wishes to return images via multiple calls to this method (e.g. to enable pending status messages), then NumberRemaining must be set correctly before the first image is returned.

    For C-MOVE requests, or "stand-alone" DicomAssociation objects, Open must be called before this method.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members
    Overload List


DicomObjects Namespace / DicomAssociation Class / SendPending Method

    SendPending Method (DicomAssociation)
    In This Topic
    Send a "pending" response to an outstanding C-MOVE request
    Syntax
    • Visual Basic
    • C#
    'Declaration

    <ObsoleteAttribute("This method should be replaced by QueryReceivedArgs.SendPending (e.SendPending) which also handles DICOM Asynchronous operations")>
Public Sub SendPending()
    'Usage

    Dim instance As DicomAssociation

instance.SendPending()
    [Obsolete("This method should be replaced by QueryReceivedArgs.SendPending (e.SendPending) which also handles DICOM Asynchronous operations")]
public void SendPending()
    Remarks
    The existing values of NumberRemaining, NumberFailed>, NumberWarning and NumberCompleted from the outstanding request are used in the response
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / SendResponse Method

    SendResponse Method (DicomAssociation)
    In This Topic
    Returns results to a C-FIND request
    Overload List
    Overload | Description
SendResponse(IEnumerable<DicomDataSet>,Int32) | Returns results to a C-FIND request
SendResponse(DicomDataSet,Int32) | Returns a single result to a C-FIND request
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / SendResponse Method / SendResponse(IEnumerable<DicomDataSet>,Int32) Method

A DataSet Collection to be returned to the requesting application, with each DataSet describing a single successful match

The status associated with the above data, indicating the level of matching achieved

In This Topic
    SendResponse(IEnumerable<DicomDataSet>,Int32) Method
    In This Topic
    Returns results to a C-FIND request
    Syntax
    • Visual Basic
    • C#
    'Declaration

    <ObsoleteAttribute("This method should be replaced by QueryReceivedArgs.SendResponse (e.SendResponse) which also handles DICOM Asynchronous operations")>
Public Overloads Sub SendResponse( _
   ByVal Data As IEnumerable(Of DicomDataSet), _
   ByVal Status As Integer _
)
    'Usage

    Dim instance As DicomAssociation
Dim Data As IEnumerable(Of DicomDataSet)
Dim Status As Integer

instance.SendResponse(Data, Status)
    [Obsolete("This method should be replaced by QueryReceivedArgs.SendResponse (e.SendResponse) which also handles DICOM Asynchronous operations")]
public void SendResponse(
   IEnumerable<DicomDataSet> Data,
   int Status
)

    Parameters

    Data

    A DataSet Collection to be returned to the requesting application, with each DataSet describing a single successful match

    Status

    The status associated with the above data, indicating the level of matching achieved

    Remarks

    The data returned by this method is sent to the requesting application as a series of C-FIND responses, each with the status indicated. Once all matches have been returned, a final SendResponse call should be made to terminate the list.

    As the status for all returned matches must be "Pending", only the values 0xFF00 and 0xFF01 are allowed for Status, the meanings being as follows:

    • 0xFF00 : "Optional Keys were supported in the same manner as Required Keys"
    • 0xFF01 : "Warning that one or more Optional Keys were not supported for existence and/or matching for this Identifier"
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members
    Overload List


DicomObjects Namespace / DicomAssociation Class / SendResponse Method / SendResponse(DicomDataSet,Int32) Method

The DataSet to be returned to the requesting application, which describes a single successful match

The status associated with the above data, indicating the level of matching achieved

In This Topic
    SendResponse(DicomDataSet,Int32) Method
    In This Topic
    Returns a single result to a C-FIND request
    Syntax
    • Visual Basic
    • C#
    'Declaration

    <ObsoleteAttribute("This method should be replaced by QueryReceivedArgs.SendResponse (e.SendResponse) which also handles DICOM Asynchronous operations")>
Public Overloads Sub SendResponse( _
   ByVal Data As DicomDataSet, _
   ByVal Status As Integer _
)
    'Usage

    Dim instance As DicomAssociation
Dim Data As DicomDataSet
Dim Status As Integer

instance.SendResponse(Data, Status)
    [Obsolete("This method should be replaced by QueryReceivedArgs.SendResponse (e.SendResponse) which also handles DICOM Asynchronous operations")]
public void SendResponse(
   DicomDataSet Data,
   int Status
)

    Parameters

    Data

    The DataSet to be returned to the requesting application, which describes a single successful match

    Status

    The status associated with the above data, indicating the level of matching achieved

    Remarks

    The data returned by this method is sent to the requesting application as a C-FIND response, with the status indicated. Once the match has been returned, a final SendResponse call should be made to terminate the return.

    As the status for all returned matches must be "Pending", only the values 0xFF00 and 0xFF01 are allowed for Status, the meanings being as follows:

    • 0xFF00 : "Optional Keys were supported in the same manner as Required Keys"
    • 0xFF01 : "Warning that one or more Optional Keys were not supported for existence and/or matching for this Identifier"
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members
    Overload List


DicomObjects Namespace / DicomAssociation Class / SetQuality Method

The transfer syntax to which this quality factor applies

The quality to be set

In This Topic
    SetQuality Method
    In This Topic
    Set the quality factor for lossy compression
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Sub SetQuality( _
   ByVal TransferSyntax As String, _
   ByVal Quality As Object _
)
    'Usage

    Dim instance As DicomAssociation
Dim TransferSyntax As String
Dim Quality As Object

instance.SetQuality(TransferSyntax, Quality)
    public void SetQuality(
   string TransferSyntax,
   object Quality
)

    Parameters

    TransferSyntax

    The transfer syntax to which this quality factor applies

    Quality

    The quality to be set

    Remarks

    An application does not necessarily "know" which images will be sent by which transfer syntax, as the remote AE may have accepted different transfer syntaxes for different abstract syntaxes, and a common quality factor for an association would not therefore be appropriate. Instead, this method allows quality to be set for a specific transfer syntax.

    The following limitations apply:

    • This method is only meaningful when used in an application actually sending an image (normally the SCP), as there is no official means in DICOM for the SCU to send this information to the SCP.
    • Where an image is already compressed using the transfer syntax required, it is not decompressed and recompressed, so this value is ignored. If absolutely necessary, this can be over-ridden by applying the DecompressAll method to the image before sending it, but multiple compressions do have an adverse effect on image quality.

    At present, the only syntaxes to which this method applies are TransferSyntaxes.JPEGBaseline (1.2.840.10008.1.2.4.50), TransferSyntaxes.JPEGExtended (1.2.840.10008.1.2.4.51), TransferSyntaxes.JPEG2000Lossy (1.2.840.10008.1.2.4.90), and TransferSyntaxes.JPEG2000Lossy (1.2.840.10008.1.2.4.91), though it is also made available to private syntaxes defined through .

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


%%PageItemTitle%% $$Properties$$

DicomObjects Namespace / DicomAssociation Class

    DicomAssociation Class Properties
    In This Topic

    For a list of all members of this type, see DicomAssociation members.

    Public Properties
     | Name | Description
Public Property | AgreedContexts | The Presentation Contexts associated with this DicomAssociation
Public Property | AssociationNumber | Returns the association number of current connection.
Public Property | BytesReceived | Approximate Measures of Network Input
Public Property | BytesSent | Approximate measures of Network Output
Public Property | CalledAET | Application entity title of the remote application
Public Property | CallingAET | Application entity title of this application
Public Property | Cancelled | Indicates that the remote AE has issued a C-CANCEL request.
Public Property | ChangeLossyUIDs | Control allocation of new UIDs for lossy compressed images
Public Property | CheckForCancel | Control whether to check for incoming C-CANCEL asynchronous messages
Public Property | CoercionSOP | SOP Class to which images should be coerced if peer does not accept true SOP class
Public Property | Command | The full command dataset received
static (Shared in Visual Basic) | DefaultThrowStatusException | The value intially assigned for the ThrowStatusException of new DicomAssociation objects.
Public Property | Destination | The Application Entity Name to which images should be sent by a C-MOVE request
Public Property | Identity | The user identity to use for an association
Public Property | ImplementationName | Returns the Implementation Version Name of the Connecting AE
Public Property | ImplementationUID | Returns the Implementation Class UID of the Connecting AE
Public Property | IsOpen | Indicates whether a DicomAssociation is open
Public Property | LastCommand | Returns the last command in the current association.
Public Property | LastError | Returns the last error status from LastCommand.
Public Property | LastInstanceUID | Holds the InstanceUID created or used by the last normalised operation.
Public Property | LastOperation | Returns the last operation in the current association.
Public Property | LastStatus | Shortcut for the first element of the Status property
Public Property | LocalIP | Provide information about which local interface the remote application entity called
Public Property | LocalPort | Provide information about which local port the remote application entity called
Public Property | LogLevel | Controls the level of logging for this particular Association.
Public Property | MetaSOPClass | Determines the Abstract Syntax used for normalised operations
Public Property | MoveOriginator | The DicomAssociation object which initiated the C-MOVE resulting in the current C-STORE
Public Property | PreferredPCID | Provides guidance for the choice of presentation context
Public Property | PreferredTS | Provides guidance for the choice of presentation context
Public Property | PreferredTSList | Provides guidance for the choice of presentation context
Public Property | ReadBehaviour | Specific behaviours to use when receiving data on this association.
Public Property | RemoteIP | Provides information about the remote application entity
Public Property | Request | This contains the list of attributes to be matched, as specified in the DICOM standard
Public Property | RequestedContexts | The Presentation Contexts associated with this DicomAssociation
Public Property | RequestingQuery | Provides a linkage to the primary C-MOVE request.
Public Property | ReturnedCommands | The command datasets returned in response to the last operation
Public Property | ReturnedIdentifier | Hold data returned from outgoing operations
Public Property | ReturnedIdentifiers | Hold data returned from outgoing operations
Public Property | ReturnedInstances | Hold instances returned from outgoing C-GET operations
Public Property | SslStream | Returns the secure Stream object
Public Property | Status | Array containing the status codes returned by the last SendInstances or Echo action
Public Property | Tag | A general purpose Tag for developer use
Public Property | ThrowStatusException | Controls whether an exception is generated when a non-zero status is received.
Public Property | WriteBehaviour | Specific behaviours to use when sending data on this association.
    Top
    See Also

    Reference

    DicomAssociation Class
    DicomObjects Namespace


DicomObjects Namespace / DicomAssociation Class / AgreedContexts Property

    AgreedContexts Property
    The Presentation Contexts associated with this DicomAssociation
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property AgreedContexts As DicomContextCollection
    'Usage

    Dim instance As DicomAssociation
Dim value As DicomContextCollection

value = instance.AgreedContexts
    public DicomContextCollection AgreedContexts {get;}
    Remarks

    This is a powerful feature, allowing a client program as much, or as little control over presentation contexts as it wishes. the collection returned by this property may be used To check the presentation contexts available on an established association (incoming or outgoing).

    IMPORTANT:

    Note that operations relating to the acceptance of presentation contexts are not possible on this DicomContexts object or its contained DicomContext object. Such operations are only possible from within the AssociationRequest event.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / AssociationNumber Property

    AssociationNumber Property
    Returns the association number of current connection.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property AssociationNumber As Integer
    'Usage

    Dim instance As DicomAssociation
Dim value As Integer

value = instance.AssociationNumber
    public int AssociationNumber {get;}
    Remarks
    This property is read only and returns 0 if current connection is null.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / BytesReceived Property

    BytesReceived Property
    Approximate Measures of Network Input
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property BytesReceived As Long
    'Usage

    Dim instance As DicomAssociation
Dim value As Long

value = instance.BytesReceived
    public long BytesReceived {get;}
    Remarks
    This property report only approximate values, but are useful for updating of status bars etc.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / BytesSent Property

    BytesSent Property
    Approximate measures of Network Output
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property BytesSent As Long
    'Usage

    Dim instance As DicomAssociation
Dim value As Long

value = instance.BytesSent
    public long BytesSent {get;}
    Remarks
    This property reports only approximate values, but is useful for updating of status bars etc.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / CalledAET Property

    CalledAET Property
    Application entity title of the remote application
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property CalledAET As String
    'Usage

    Dim instance As DicomAssociation
Dim value As String

value = instance.CalledAET
    public string CalledAET {get;}
    Remarks

    CallingAET, CalledAET and RemoteIP, these property relate to open associations, and can be accessed at any time after the association has been established. For “outgoing” DicomAssociation objects, they refer to the outgoing association and for “incoming” DicomAssociation objects such as those created automatically as part of incoming C-STORE (async), C-FIND of C-GET requests, they relate to the association received. For C-MOVE, they continue to refer to the incoming association even once an outgoing association to carry the images has been established.

    For details of the interface and port, see LocalIP and LocalPort properties.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / CallingAET Property

    CallingAET Property
    Application entity title of this application
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property CallingAET As String
    'Usage

    Dim instance As DicomAssociation
Dim value As String

value = instance.CallingAET
    public string CallingAET {get;}
    Remarks

    CallingAET, CalledAET and RemoteIP, these property relate to open associations, and can be accessed at any time after the association has been established. For “outgoing” DicomAssociation objects, they refer to the outgoing association and for “incoming” DicomAssociation objects such as those created automatically as part of incoming C-STORE (async), C-FIND of C-GET requests, they relate to the association received. For C-MOVE, they continue to refer to the incoming association even once an outgoing association to carry the images has been established.

    For details of the interface and port, see LocalIP and LocalPort properties.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / Cancelled Property

    Cancelled Property
    Indicates that the remote AE has issued a C-CANCEL request.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property Cancelled As Boolean
    'Usage

    Dim instance As DicomAssociation
Dim value As Boolean

value = instance.Cancelled
    public bool Cancelled {get;}
    Remarks
    C-CANCEL requests are handled internally by DicomObjects, with the result that no further images are sent on the connection, and a status of Cancelled is automatically returned to the peer. In order to prevent errors from operations on a closed association, operations such as SendInstances are still accepted but are silently ignored. This property is therefore provided solely as an optimisation, to prevent unnecessary preparatory work by the client application.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / ChangeLossyUIDs Property

    ChangeLossyUIDs Property (DicomAssociation)
    In This Topic
    Control allocation of new UIDs for lossy compressed images
    Syntax
    • Visual Basic
    • C#
    'Declaration

    <ObsoleteAttribute("This property has been superceded by WriteBehaviours.ChangeLossyUIDs, which is more flexible, including use when writing files")>
Public Property ChangeLossyUIDs As Boolean
    'Usage

    Dim instance As DicomAssociation
Dim value As Boolean

instance.ChangeLossyUIDs = value

value = instance.ChangeLossyUIDs
    [Obsolete("This property has been superceded by WriteBehaviours.ChangeLossyUIDs, which is more flexible, including use when writing files")]
public bool ChangeLossyUIDs {get; set;}
    Remarks
    There are times when the negotiated transfer syntaxes for a DicomConnection require a previously uncompressed (or losslessly compressed) image to be transmmited in a lossy form. Although the DICOM standard is not entirely clear, most people believe that a new instance UID should be generated whenever this happens. This is the normal DicomObjects behaviour, and a reference to the original UID is included in the referenced image sequence. However, some query SCUs having requested a specific image by it's UID fail to look in the referenced image sequence and reject images with UIDs other than those they had requested. The default value of this property is copied from DicomGlobal.ChangeLossyUIDs (which itself has a default value of true), but if set to false, then images sent via SendInstances which undergo lossy compression will not have new UIDs allocated.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / CheckForCancel Property

    CheckForCancel Property
    Control whether to check for incoming C-CANCEL asynchronous messages
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property CheckForCancel As Boolean
    'Usage

    Dim instance As DicomAssociation
Dim value As Boolean

instance.CheckForCancel = value

value = instance.CheckForCancel
    public bool CheckForCancel {get; set;}
    Remarks
    When about to send a status response to an SCU, if this property is true (which it is bt default), then DicomObjects check whether there is any incoming data to be read off the network. If there is, then it is received, and checked to see if it is a C-CANCEL message. If it is C-CANCEL, then it is processed, but if it is any other message, then that would be illegal (without asynchronous operation), and an exception is raised.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / CoercionSOP Property

    CoercionSOP Property
    SOP Class to which images should be coerced if peer does not accept true SOP class
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property CoercionSOP As String
    'Usage

    Dim instance As DicomAssociation
Dim value As String

instance.CoercionSOP = value

value = instance.CoercionSOP
    public string CoercionSOP {get; set;}
    Remarks

    Some equipments can only support a limited range of SOP classes, but there may be a need to send images of other types to it. If this property is set to a non-null value, and if the remote AE does not support the SOP class of an image being sent, (but does support he CoercionSOP class), then a temporary image (with a New UID) is generated with its SOP class set to equal CoercionSOP, and this is transmitted instead.

    The most common value for CoercionSOP would be SecondaryCapture (1.2.840.10008.5.1.4.1.1.7).

    Although this practice is questionable, it is often useful for sending images such as ultrasounds, to display stations primarily designed for CT and MRI etc. but which also support secondary capture.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / Command Property

    Command Property (DicomAssociation)
    In This Topic
    The full command dataset received
    Syntax
    • Visual Basic
    • C#
    'Declaration

    <ObsoleteAttribute("This property should be replaced by OperationBaseArgs.Command (e.Command) which also handles DICOM Asynchronous operations")>
Public ReadOnly Property Command As DicomDataSet
    'Usage

    Dim instance As DicomAssociation
Dim value As DicomDataSet

value = instance.Command
    [Obsolete("This property should be replaced by OperationBaseArgs.Command (e.Command) which also handles DICOM Asynchronous operations")]
public DicomDataSet Command {get;}
    Remarks

    An incoming request consists of two parts, a command dataset, containing elements in the 0000 group, and an identifier containing the details. This property equates to the command dataset, and the Request property equates to the identifier.

    Whilst this property is available for all incoming requests on a DicomAssociation, incoming composite operations are interpreted internally by DicomObjects, and presented via convenient arguments to QueryReceived. The main use for this property is therefore for incoming normalised operations (via NormalisedReceived) for which it provides the only access to the CommandID (0000,0100), and the requested and affected Instance UIDs and SOP Classes

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / DefaultThrowStatusException Property

    DefaultThrowStatusException Property
    The value intially assigned for the ThrowStatusException of new DicomAssociation objects.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Property DefaultThrowStatusException As Boolean
    'Usage

    Dim value As Boolean

DicomAssociation.DefaultThrowStatusException = value

value = DicomAssociation.DefaultThrowStatusException
    public static bool DefaultThrowStatusException {get; set;}
    Remarks

    This is particularly useful for operations such as DicomImage.Send or DicomQuery.Find where implicit, temporary DicomAssociation objects are used.

    See ThrowStatusException for more information.

    The default value is false.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / Destination Property

    Destination Property (DicomAssociation)
    In This Topic
    The Application Entity Name to which images should be sent by a C-MOVE request
    Syntax
    • Visual Basic
    • C#
    'Declaration

    <ObsoleteAttribute("This method should be replaced by QueryReceivedArgs.Destination (e.Destination) which also handles DICOM Asynchronous operations")>
Public ReadOnly Property Destination As String
    'Usage

    Dim instance As DicomAssociation
Dim value As String

value = instance.Destination
    [Obsolete("This method should be replaced by QueryReceivedArgs.Destination (e.Destination) which also handles DICOM Asynchronous operations")]
public string Destination {get;}
    Remarks

    A Query/Retrieve SCP must use this property of the DicomAssociation object to find the values of the IP address, port number and possibly Calling AET to use before calling Open.

    This Application Entity Name must be known by the C-MOVE SCP, as the standard allows no other means of specifying the destination. In particular, it is not possible to direct images to an arbitrary IP address and port using Move.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / Identity Property

    Identity Property
    The user identity to use for an association
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property Identity As DicomUserIdentity
    'Usage

    Dim instance As DicomAssociation
Dim value As DicomUserIdentity

instance.Identity = value

value = instance.Identity
    public DicomUserIdentity Identity {get; set;}
    Remarks
    When used as an initiator, this should be set before the call to Open
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / ImplementationName Property

    ImplementationName Property (DicomAssociation)
    In This Topic
    Returns the Implementation Version Name of the Connecting AE
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property ImplementationName As String
    'Usage

    Dim instance As DicomAssociation
Dim value As String

value = instance.ImplementationName
    public string ImplementationName {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / ImplementationUID Property

    ImplementationUID Property (DicomAssociation)
    In This Topic
    Returns the Implementation Class UID of the Connecting AE
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property ImplementationUID As String
    'Usage

    Dim instance As DicomAssociation
Dim value As String

value = instance.ImplementationUID
    public string ImplementationUID {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / IsOpen Property

    IsOpen Property
    Indicates whether a DicomAssociation is open
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property IsOpen As Boolean
    'Usage

    Dim instance As DicomAssociation
Dim value As Boolean

value = instance.IsOpen
    public bool IsOpen {get;}
    Remarks
    Returns true if a DicomAssociation is open, otherwise returns false. For outgoing connection, this property is true after the connection is 'opened' by Open method and before the connection is 'closed' by Close method. For incoming connection, if it is a C-GET request, the DicomAssociation object is passed as a property of the EventArguments.QueryReceivedArgs and the value is true. If it is a C-MOVE request, the value is false as the passed secondary connection has to be opened by the SCP to send requested images.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / LastCommand Property

    LastCommand Property
    Returns the last command in the current association.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property LastCommand As DicomDataSet
    'Usage

    Dim instance As DicomAssociation
Dim value As DicomDataSet

value = instance.LastCommand
    public DicomDataSet LastCommand {get;}
    Example

    Returns the last command from the ReturnedCommands collections.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / LastError Property

    LastError Property

    Returns the last error status from LastCommand.

    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property LastError As String
    'Usage

    Dim instance As DicomAssociation
Dim value As String

value = instance.LastError
    public string LastError {get;}
    Remarks
    If the LastCommand property if not null then this property returns the error status which is contained in the (Keyword.ErrorComment) attribute of the last command, otherwise an empty string is returned.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / LastInstanceUID Property

    LastInstanceUID Property
    Holds the InstanceUID created or used by the last normalised operation.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property LastInstanceUID As String
    'Usage

    Dim instance As DicomAssociation
Dim value As String

value = instance.LastInstanceUID
    public string LastInstanceUID {get;}
    Remarks

    Although this property could be used for checking the UID involved in any normalised operation, its primary purpose is to allow retrieval of the UID of the object created in response to an NCreate operation.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / LastOperation Property

    LastOperation Property
    Returns the last operation in the current association.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property LastOperation As DicomOperation
    'Usage

    Dim instance As DicomAssociation
Dim value As DicomOperation

value = instance.LastOperation
    public DicomOperation LastOperation {get;}
    Remarks

    If % LastCommand :LastCommand% is not null then this property returns the Enumeration value contained in the (Keyword.CommandField) attribute of that last command, otherwise it returns Enums.Operation.NONE.

    Enumerated values for this property are:

    0x0 - NONE

    0x1 - C_STORE

    0x10 - C_GET

    0x20 - C_FIND

    0x21 - C_MOVE

    0x30 - C_ECHO

    0x100 - N_EVENT_REPORT

    0x110 - N_GET

    0x120 - N_SET

    0x130 - N_ACTION

    0x140 - N_CREATE

    0x150 - N_DELETE

    0xFFF - C_CANCEL

    0x8001 - C_STORE_RSP

    0x8010 - C_GET_RSP

    0x8020 - C_FIND_RSP

    0x8021 - C_MOVE_RSP

    0x8030 - C_ECHO_RSP

    0x8100 - N_EVENT_REPORT_RSP

    0x8110 - N_GET_RSP

    0x8120 - N_SET_RSP

    0x8130 - N_ACTION_RSP

    0x8140 - N_CREATE_RSP

    0x8150 - N_DELETE_RSP

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / LastStatus Property

    LastStatus Property
    Shortcut for the first element of the Status property
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property LastStatus As Integer
    'Usage

    Dim instance As DicomAssociation
Dim value As Integer

value = instance.LastStatus
    public int LastStatus {get;}
    Remarks
    A very useful shortcut which makes it easier to access the result of the last operation performed, where only a single result is expected (e.g. after Echo).
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / LocalIP Property

    LocalIP Property
    Provide information about which local interface the remote application entity called
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property LocalIP As String
    'Usage

    Dim instance As DicomAssociation
Dim value As String

value = instance.LocalIP
    public string LocalIP {get;}
    Remarks
    This property relates to open incoming associations only, and can be accessed at any time after the association has been made. For "outgoing" DicomAssociation objects, they are null and 0. For "incoming" DicomAssociation objects such as those created automatically as part of incoming C-STORE (Async), C-FIND of C-GET requests, they relate to the association received. For C-MOVE, they continue to refer to the incoming association even once an outgoing association to carry the images has been established.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / LocalPort Property

    LocalPort Property
    Provide information about which local port the remote application entity called
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property LocalPort As Long
    'Usage

    Dim instance As DicomAssociation
Dim value As Long

value = instance.LocalPort
    public long LocalPort {get;}
    Remarks
    This property relates to open incoming associations only, and can be accessed at any time after the association has been made. For "outgoing" DicomAssociation objects, they are null and 0. For "incoming" DicomAssociation objects such as those created automatically as part of incoming C-STORE (Async), C-FIND of C-GET requests, they relate to the association received. For C-MOVE, they continue to refer to the incoming association even once an outgoing association to carry the images has been established.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / LogLevel Property

    LogLevel Property (DicomAssociation)
    In This Topic
    Controls the level of logging for this particular Association.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property LogLevel As LogLevel
    'Usage

    Dim instance As DicomAssociation
Dim value As LogLevel

instance.LogLevel = value

value = instance.LogLevel
    public LogLevel LogLevel {get; set;}
    Remarks
    The levels are exactly the same as used by LogToFile and any level set by that function provides the default level used for any new DicomAssociation objects (whether incoming or outgoing), but this property allows that level to be changed on a per association basis.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / MetaSOPClass Property

    MetaSOPClass Property (DicomAssociation)
    In This Topic
    Determines the Abstract Syntax used for normalised operations
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property MetaSOPClass As String
    'Usage

    Dim instance As DicomAssociation
Dim value As String

instance.MetaSOPClass = value

value = instance.MetaSOPClass
    public string MetaSOPClass {get; set;}
    Remarks

    Normalised operations, unlike composite operations, are not directly tied to specific abstract syntaxes, but still need to be sent within a negotiated presentation context, which generally relates to a number of related operations, and is known as a Meta SOP Class. This property defines this abstract context, and is therefore used for the selection of an appropriate presentation context, according to those negotiated and available.

    If this property is a null string, then the SOP class specified in the normalised operation itself is used, which may be appropriate for some classes, which do not use meta SOP classes for negotiation.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / MoveOriginator Property

    MoveOriginator Property
    The DicomAssociation object which initiated the C-MOVE resulting in the current C-STORE
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property MoveOriginator As DicomAssociation
    'Usage

    Dim instance As DicomAssociation
Dim value As DicomAssociation

value = instance.MoveOriginator
    public DicomAssociation MoveOriginator {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / PreferredPCID Property

    PreferredPCID Property
    Provides guidance for the choice of presentation context
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property PreferredPCID As Byte
    'Usage

    Dim instance As DicomAssociation
Dim value As Byte

instance.PreferredPCID = value

value = instance.PreferredPCID
    public byte PreferredPCID {get; set;}
    Remarks

    Under some circumstances, DicomObjects may have a choice of presentation contexts to use for a given operation, and PreferredTS and PreferredPCID, provide guidance on which of the available options to use.

    DicomObjects cannot, however, guarantee that the values given will be honoured, as the requirements of the standard, and the negotiated presentation contexts available will always take priority. Note also, that they can only be effective at the application actually carrying out the operation involved, normally the SCP.

    The default values for these parameters are a null string and zero respectively, and these values are taken to mean "no preference".

    Presentation context will be selected according to the following procedure:

    • If the presentation context given by PreferredPCID is appropriate for the operation, it is used.
    • If not, and if any presentation context, using the transfer syntax given by PreferredTS is available, then that is used.
    • If neither of the above applies, then any suitable and negotiated presentation context is used.

    These properties are particularly designed for teleradiology applications, where run-time selection of a compressed syntax may be appropriate.

    For a list of the available presentation contexts, see the Contexts property.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / PreferredTS Property

    PreferredTS Property
    Provides guidance for the choice of presentation context
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property PreferredTS As String
    'Usage

    Dim instance As DicomAssociation
Dim value As String

instance.PreferredTS = value

value = instance.PreferredTS
    public string PreferredTS {get; set;}
    Remarks

    Under some circumstances, DicomObjects may have a choice of presentation contexts to use for a given operation, and PreferredTS and PreferredPCID, provide guidance on which of the available options to use.

    DicomObjects cannot, however, guarantee that the values given will be honoured, as the requirements of the standard, and the negotiated presentation contexts available will always take priority. Note also, that they can only be effective at the application actually carrying out the operation involved, normally the SCP.

    The default values for these parameters are a null string and zero respectively, and these values are taken to mean "no preference".

    Presentation context will be selected according to the following procedure:

    • If the presentation context given by PreferredPCID is appropriate for the operation, it is used.
    • If not, and if any presentation context, using the transfer syntax given by PreferredTS is available, then that is used.
    • If neither of the above applies, then any suitable and negotiated presentation context is used.

    These properties are particularly designed for teleradiology applications, where run-time selection of a compressed syntax may be appropriate.

    For a list of the available presentation contexts, see the Contexts property.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / PreferredTSList Property

    PreferredTSList Property
    Provides guidance for the choice of presentation context
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property PreferredTSList As IEnumerable(Of String)
    'Usage

    Dim instance As DicomAssociation
Dim value As IEnumerable(Of String)

instance.PreferredTSList = value

value = instance.PreferredTSList
    public IEnumerable<string> PreferredTSList {get; set;}
    Remarks

    Under some circumstances, DicomObjects may have a choice of presentation contexts to use for a given operation, and PreferredTSList, PreferredTS and PreferredPCID, provide guidance on which of the available options to use.

    DicomObjects cannot, however, guarantee that the values given will be honoured, as the requirements of the standard, and the negotiated presentation contexts available will always take priority. Note also, that they can only be effective at the application actually carrying out the operation involved, normally the SCP.

    The default values for these parameters are a null string, empty array and zero respectively, and these values are taken to mean "no preference".

    Presentation context will be selected according to the following procedure:

    • If the presentation context given by PreferredPCID is appropriate for the operation, it is used.
    • If not, and if any presentation context, using the transfer syntax given by PreferredTS is available, then that is used.
    • If not, and if any presentation context, using any of the transfer syntaxes given by PreferredTSList is available, then that is used. The list is in order of decreasing priority, so the first TS in the list with a matching negotiated presentation context will be used.
    • If none of the above applies, then any suitable and negotiated presentation context is used.

    These properties are particularly designed for teleradiology applications, where run-time selection of a compressed syntax may be appropriate.

    For a list of the available presentation contexts, see the Contexts property.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / ReadBehaviour Property

    ReadBehaviour Property
    Specific behaviours to use when receiving data on this association.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property ReadBehaviour As ReadBehaviours
    'Usage

    Dim instance As DicomAssociation
Dim value As ReadBehaviours

instance.ReadBehaviour = value

value = instance.ReadBehaviour
    public ReadBehaviours ReadBehaviour {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / RemoteIP Property

    RemoteIP Property
    Provides information about the remote application entity
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property RemoteIP As String
    'Usage

    Dim instance As DicomAssociation
Dim value As String

value = instance.RemoteIP
    public string RemoteIP {get;}
    Remarks

    CallingAET, CalledAET andRemoteIP, these property relate to open associations, and can be accessed at any time after the association has been established. For “outgoing” DicomAssociation objects, they refer to the outgoing association and for “incoming” DicomAssociation objects such as those created automatically as part of incoming C-STORE (async), C-FIND of C-GET requests, they relate to the association received. For C-MOVE, they continue to refer to the incoming association even once an outgoing association to carry the images has been established.

    For details of the interface and port, see LocalIP and LocalPort properties.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / Request Property

    Request Property (DicomAssociation)
    In This Topic
    This contains the list of attributes to be matched, as specified in the DICOM standard
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property Request As DicomDataSet
    'Usage

    Dim instance As DicomAssociation
Dim value As DicomDataSet

value = instance.Request
    public DicomDataSet Request {get;}
    Remarks

    It is the client's responsibility to interpret the contents of this identifier and ensure that the data or images returned match the data sent, and in the case of C-FIND operations, to ensure that all data elements requested are included in the response.

    The "level" of the query may be found in (0008, 0052) of this property.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / RequestedContexts Property

    RequestedContexts Property
    The Presentation Contexts associated with this DicomAssociation
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property RequestedContexts As DicomContextCollection
    'Usage

    Dim instance As DicomAssociation
Dim value As DicomContextCollection

value = instance.RequestedContexts
    public DicomContextCollection RequestedContexts {get;}
    Remarks

    This is a powerful feature, allowing a client program as much, or as little control over presentation contexts as it wishes. the collection returned by this property may be used to set up a collection of presentation contexts to offer to the peer SE prior to establishing an association

    IMPORTANT:

    If this property has any presentation contexts added before an association is established, then DicomObjects assumes that the client application has taken charge of this entirely, and the normal Abstract/Transfer context lists found in the registry settings (see SetRegString) are NOT used.

    Note that operations relating to the acceptance of presentation contexts are not possible on this DicomContexts object or its contained DicomContext object. Such operations are only possible from within the AssociationRequest event using e.Contexts.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / RequestingQuery Property

    RequestingQuery Property
    Provides a linkage to the primary C-MOVE request.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property RequestingQuery As QueryReceivedArgs
    'Usage

    Dim instance As DicomAssociation
Dim value As QueryReceivedArgs

instance.RequestingQuery = value

value = instance.RequestingQuery
    public QueryReceivedArgs RequestingQuery {get; set;}
    Remarks
    This property can be used when implementing a C-MOVE SCP. This property points to the object holding the information about the current query request. in the new association (established from SCP to the move destination) to point it to the primary C-MOVE request. This will make a linkage between the outgoing association and the C-MOVE requesting association, and with every image sent out via the outgoing association DicomObjects will automatically send a notification (as part of the C-MOVE response) and once a final C-MOVE response has been sent by SCP, the outgoing association will be automatically closed.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / ReturnedCommands Property

    ReturnedCommands Property
    The command datasets returned in response to the last operation
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property ReturnedCommands As DicomDataSetCollection
    'Usage

    Dim instance As DicomAssociation
Dim value As DicomDataSetCollection

value = instance.ReturnedCommands
    public DicomDataSetCollection ReturnedCommands {get;}
    Remarks
    In most cases, the useful data returned from an operation will be present once the operation is complete in properties such as Status, LastStatus, ReturnedIdentifier or ReturnedIdentifiers. However, in some cases, particularly where errors are reported, it is useful to be able to access and parse the associated command (group 0) elements. This property provides that facility, and contains one DicomDataSet for each response received.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / ReturnedIdentifier Property

    ReturnedIdentifier Property
    Hold data returned from outgoing operations
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property ReturnedIdentifier As DicomDataSet
    'Usage

    Dim instance As DicomAssociation
Dim value As DicomDataSet

value = instance.ReturnedIdentifier
    public DicomDataSet ReturnedIdentifier {get;}
    Remarks
    This property contain the results of outgoing Normalized Operations on the DicomAssociation. It is equivalent to ReturnedDataSets(0).
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / ReturnedIdentifiers Property

    ReturnedIdentifiers Property
    Hold data returned from outgoing operations
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property ReturnedIdentifiers As DicomDataSetCollection
    'Usage

    Dim instance As DicomAssociation
Dim value As DicomDataSetCollection

value = instance.ReturnedIdentifiers
    public DicomDataSetCollection ReturnedIdentifiers {get;}
    Remarks
    This property contain the results of outgoing C-FIND and C-GET Operations on the DicomAssociation.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / ReturnedInstances Property

    ReturnedInstances Property
    Hold instances returned from outgoing C-GET operations
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property ReturnedInstances As DicomDataSetCollection
    'Usage

    Dim instance As DicomAssociation
Dim value As DicomDataSetCollection

value = instance.ReturnedInstances
    public DicomDataSetCollection ReturnedInstances {get;}
    Remarks
    This property contain the results of outgoing C-GET Operations on the DicomAssociation.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / SslStream Property

    SslStream Property
    Returns the secure Stream object
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property SslStream As Stream
    'Usage

    Dim instance As DicomAssociation
Dim value As Stream

value = instance.SslStream
    public Stream SslStream {get;}
    Remarks
    If Windows nehotiation is used, then this will be an SslStream object
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / Status Property

    Status Property (DicomAssociation)
    In This Topic
    Array containing the status codes returned by the last SendInstances or Echo action
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property Status As Integer()
    'Usage

    Dim instance As DicomAssociation
Dim value() As Integer

value = instance.Status
    public int[] Status {get;}
    Remarks

    This property contains the result of an outgoing operation on the DicomAssociation. This array is cleared before each operation, and the number of elements therefore reflects the number of images sent.

    After a SendVerify operation, the element will contain only one value, so LastStatus is normally more appropriate.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / Tag Property

    Tag Property (DicomAssociation)
    In This Topic
    A general purpose Tag for developer use
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property Tag As Object
    'Usage

    Dim instance As DicomAssociation
Dim value As Object

instance.Tag = value

value = instance.Tag
    public object Tag {get; set;}
    Remarks
    This property is not used by DicomObjects in any way, and is provided purely as a convenience for developers who wish to associate other objects with this object. As an alternative, most of the objects in DicomObjects can have other classes derived from them.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / ThrowStatusException Property

    ThrowStatusException Property
    Controls whether an exception is generated when a non-zero status is received.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property ThrowStatusException As Boolean
    'Usage

    Dim instance As DicomAssociation
Dim value As Boolean

instance.ThrowStatusException = value

value = instance.ThrowStatusException
    public bool ThrowStatusException {get; set;}
    Remarks
    Previous versions of DicomObjects have always simply returned the status of an operation, leaving the developer to check the value (as well as catching any exceptions which can occur due to protocol violations etc.) if however this property is set to true (directly, or by setting DefaultThrowStatusException to true before creating the DicomAssociation), then an error status will cause an exception to the thrown. Where present, the values in the 0000,0901 (offending attributes) and 0000,0902 (error comment) will be included in the exception text, to provide more useful information.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / WriteBehaviour Property

    WriteBehaviour Property (DicomAssociation)
    In This Topic
    Specific behaviours to use when sending data on this association.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property WriteBehaviour As WriteBehaviours
    'Usage

    Dim instance As DicomAssociation
Dim value As WriteBehaviours

instance.WriteBehaviour = value

value = instance.WriteBehaviour
    public WriteBehaviours WriteBehaviour {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


%%PageItemTitle%% $$Events$$

DicomObjects Namespace / DicomAssociation Class

    DicomAssociation Class Events
    In This Topic

    For a list of all members of this type, see DicomAssociation members.

    Public Events
     | Name | Description
Public Event | InitiateTls | Routine to use to generate encrypted stream when TLS is to be used for outgoing associations.
Public Event | N_Event_Report | This event handler is fired when an N-EVENT-REPORT notification is received.
Public Event | ResponseReceived | Event fires when a response is received on an out-going operation
    Top
    See Also

    Reference

    DicomAssociation Class
    DicomObjects Namespace


DicomObjects Namespace / DicomAssociation Class / InitiateTls Event

    InitiateTls Event (DicomAssociation)
    In This Topic
    Routine to use to generate encrypted stream when TLS is to be used for outgoing associations.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Event InitiateTls As TlsInitiator
    'Usage

    Dim instance As DicomAssociation
Dim handler As TlsInitiator

AddHandler instance.InitiateTls, handler
    public event TlsInitiator InitiateTls
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / N_Event_Report Event

    N_Event_Report Event (DicomAssociation)
    In This Topic
    This event handler is fired when an N-EVENT-REPORT notification is received.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Event N_Event_Report As N_Event_ReportHandler
    'Usage

    Dim instance As DicomAssociation
Dim handler As N_Event_ReportHandler

AddHandler instance.N_Event_Report, handler
    public event N_Event_ReportHandler N_Event_Report
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


DicomObjects Namespace / DicomAssociation Class / ResponseReceived Event

    ResponseReceived Event (DicomAssociation)
    In This Topic
    Event fires when a response is received on an out-going operation
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Event ResponseReceived As ResponseReceivedHandler
    'Usage

    Dim instance As DicomAssociation
Dim handler As ResponseReceivedHandler

AddHandler instance.ResponseReceived, handler
    public event ResponseReceivedHandler ResponseReceived
    Remarks

    This Event will be generated when any responses are received from the remote application.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAssociation Class
    DicomAssociation Members


%%PageItemTitle%%

DicomObjects Namespace / DicomAttribute Class
Members

In This Topic
    DicomAttribute Class
    In This Topic
    Class representing a single DICOM Attribute
    Syntax
    • Visual Basic
    • C#
    'Declaration

    <DefaultMemberAttribute("Item")>
Public Class DicomAttribute
    'Usage

    Dim instance As DicomAttribute
    [DefaultMember("Item")]
public class DicomAttribute
    Inheritance Hierarchy

    System.Object
    DicomObjects.DicomAttribute

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAttribute Members
    DicomObjects Namespace


%%PageItemTitle%% $$Members$$

DicomObjects Namespace / DicomAttribute Class
Properties Methods

In This Topic
    DicomAttribute Class Members
    In This Topic

    The following tables list the members exposed by DicomAttribute.

    Public Properties
     | Name | Description
Public Property | BulkDataUri | The URI from which the data could be retrieved
Public Property | ByteArrayData | Returns a single byte array containing the attribute's data
Public Property | DateTimeFrom | Start values for date and time ranges
Public Property | DateTimeTo | End values for date and time ranges
Public Property | DelayedData | Callback to DelayedDataRoutine specified by used for fetching binary data
Public Property | Description | The DICOM Description of the Attribute
Public Property | Element | The element indices of a data element
Public Property | Exists | Determines whether an attribute actually exists
Public Property | ExistsWithValue | Returns True if non-null data is present.
Public Property | Group | The Group indices of a data element.
Public Property | IsMultiple | Determines whether an attribute has a potential value multiplicity of greater than 1
Public Property | IsNull | Indicates whether DicomAttribute has a non-null value
Public Property | IsPrivate | Checks whether an attribute is private
Public Property | Item | The default indexer.
Public Property | Keyword | String representation of the attribute's keyword
Public Property | KeywordCode | The attribute's keyword as a Keyword
Public Property | RawData | The raw data held in DicomAttribute object
Public Property | Tag | A general purpose Tag for developer use
Public Property | Value | The value of a Data Element
Public Property | VM | The value multiplicity of an attribute
Public Property | VR | The Value Representation of an attribute
    Top
    Public Methods
     | Name | Description
static (Shared in Visual Basic) | DefinedVM | The value multiplicity of an attribute as defined by the DICOM standard
static (Shared in Visual Basic) | DefinedVR | The value representation of an attribute as defined by the DICOM standard
Public Method | Dispose | Release all resources used by this DicomAttribute object.
Public Method | ToString | Overloaded. Returns a string that represents the current object.
Public Method | ValueInContext | Returns the value of Data Element, which may vary according to its surrounding context
    Top
    See Also

    Reference

    DicomAttribute Class
    DicomObjects Namespace


%%PageItemTitle%% $$Methods$$

DicomObjects Namespace / DicomAttribute Class

    DicomAttribute Class Methods
    In This Topic

    For a list of all members of this type, see DicomAttribute members.

    Public Methods
     | Name | Description
static (Shared in Visual Basic) | DefinedVM | The value multiplicity of an attribute as defined by the DICOM standard
static (Shared in Visual Basic) | DefinedVR | The value representation of an attribute as defined by the DICOM standard
Public Method | Dispose | Release all resources used by this DicomAttribute object.
Public Method | ToString | Overloaded. Returns a string that represents the current object.
Public Method | ValueInContext | Returns the value of Data Element, which may vary according to its surrounding context
    Top
    See Also

    Reference

    DicomAttribute Class
    DicomObjects Namespace


DicomObjects Namespace / DicomAttribute Class / DefinedVM Method

    DefinedVM Method
    The value multiplicity of an attribute as defined by the DICOM standard
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Function DefinedVM( _
   ByVal Keyword As Keyword _
) As String
    'Usage

    Dim Keyword As Keyword
Dim value As String

value = DicomAttribute.DefinedVM(Keyword)
    public static string DefinedVM(
   Keyword Keyword
)

    Parameters

    Keyword
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAttribute Class
    DicomAttribute Members


DicomObjects Namespace / DicomAttribute Class / DefinedVR Method

    DefinedVR Method
    The value representation of an attribute as defined by the DICOM standard
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Function DefinedVR( _
   ByVal Keyword As Keyword _
) As String
    'Usage

    Dim Keyword As Keyword
Dim value As String

value = DicomAttribute.DefinedVR(Keyword)
    public static string DefinedVR(
   Keyword Keyword
)

    Parameters

    Keyword
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAttribute Class
    DicomAttribute Members


DicomObjects Namespace / DicomAttribute Class / Dispose Method

    Dispose Method (DicomAttribute)
    In This Topic
    Release all resources used by this DicomAttribute object.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Sub Dispose()
    'Usage

    Dim instance As DicomAttribute

instance.Dispose()
    public void Dispose()
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAttribute Class
    DicomAttribute Members


DicomObjects Namespace / DicomAttribute Class / ToString Method

    ToString Method (DicomAttribute)
    In This Topic
    Returns a string that represents the current object.
    Overload List
    Overload | Description
ToString() | Returns a string that represents the current object.
ToString(String) | Converts to a string using the format parameter (where possible)
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAttribute Class
    DicomAttribute Members


DicomObjects Namespace / DicomAttribute Class / ToString Method / ToString() Method

    ToString() Method
    Returns a string that represents the current object.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Overrides Function ToString() As String
    'Usage

    Dim instance As DicomAttribute
Dim value As String

value = instance.ToString()
    public override string ToString()

    Return Value

    A string that represents the current object.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAttribute Class
    DicomAttribute Members
    Overload List


DicomObjects Namespace / DicomAttribute Class / ToString Method / ToString(String) Method
Stansdard format string - e.g. "{0}"

    ToString(String) Method
    In This Topic
    Converts to a string using the format parameter (where possible)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Function ToString( _
   ByVal Format As String _
) As String
    'Usage

    Dim instance As DicomAttribute
Dim Format As String
Dim value As String

value = instance.ToString(Format)
    public string ToString(
   string Format
)

    Parameters

    Format
    Stansdard format string - e.g. "{0}"

    Return Value

    resulting string
    Remarks
    The format parameter is currently only used for numeric scalar values
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAttribute Class
    DicomAttribute Members
    Overload List


DicomObjects Namespace / DicomAttribute Class / ValueInContext Method

The DicomDataSet which contains the definition/description of the current DicomAttribute

In This Topic
    ValueInContext Method
    In This Topic
    Returns the value of Data Element, which may vary according to its surrounding context
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Function ValueInContext( _
   ByVal ds As DicomDataSet _
) As Object
    'Usage

    Dim instance As DicomAttribute
Dim ds As DicomDataSet
Dim value As Object

value = instance.ValueInContext(ds)
    public object ValueInContext(
   DicomDataSet ds
)

    Parameters

    ds

    The DicomDataSet which contains the definition/description of the current DicomAttribute

    Return Value

    object
    Remarks

    This method is used for accessing attribute values which may vary according to its surrounding context. For example when accessing Patient Name (0010, 0010), the correct Character Set Encoding info is needed in order to return valid value. There is no problem with this when the patient name and the Character Set Encoding are within the same level. But it would be difficult to tell which Character Set to use if you have nested level of DicomDataSets, which is quite common in Sequence. To avoid this user can provide a DicomDataSet which defines/describes how the value could be interpreted.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAttribute Class
    DicomAttribute Members


%%PageItemTitle%% $$Properties$$

DicomObjects Namespace / DicomAttribute Class

    DicomAttribute Class Properties
    In This Topic

    For a list of all members of this type, see DicomAttribute members.

    Public Properties
     | Name | Description
Public Property | BulkDataUri | The URI from which the data could be retrieved
Public Property | ByteArrayData | Returns a single byte array containing the attribute's data
Public Property | DateTimeFrom | Start values for date and time ranges
Public Property | DateTimeTo | End values for date and time ranges
Public Property | DelayedData | Callback to DelayedDataRoutine specified by used for fetching binary data
Public Property | Description | The DICOM Description of the Attribute
Public Property | Element | The element indices of a data element
Public Property | Exists | Determines whether an attribute actually exists
Public Property | ExistsWithValue | Returns True if non-null data is present.
Public Property | Group | The Group indices of a data element.
Public Property | IsMultiple | Determines whether an attribute has a potential value multiplicity of greater than 1
Public Property | IsNull | Indicates whether DicomAttribute has a non-null value
Public Property | IsPrivate | Checks whether an attribute is private
Public Property | Item | The default indexer.
Public Property | Keyword | String representation of the attribute's keyword
Public Property | KeywordCode | The attribute's keyword as a Keyword
Public Property | RawData | The raw data held in DicomAttribute object
Public Property | Tag | A general purpose Tag for developer use
Public Property | Value | The value of a Data Element
Public Property | VM | The value multiplicity of an attribute
Public Property | VR | The Value Representation of an attribute
    Top
    See Also

    Reference

    DicomAttribute Class
    DicomObjects Namespace


DicomObjects Namespace / DicomAttribute Class / BulkDataUri Property

    BulkDataUri Property
    The URI from which the data could be retrieved
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property BulkDataUri As String
    'Usage

    Dim instance As DicomAttribute
Dim value As String

instance.BulkDataUri = value

value = instance.BulkDataUri
    public string BulkDataUri {get; set;}
    Remarks
    This is primarily used when the "metadata only" option is used in WADO-RS.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAttribute Class
    DicomAttribute Members


DicomObjects Namespace / DicomAttribute Class / ByteArrayData Property

    ByteArrayData Property
    Returns a single byte array containing the attribute's data
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property ByteArrayData As Byte()
    'Usage

    Dim instance As DicomAttribute
Dim value() As Byte

value = instance.ByteArrayData
    public byte[] ByteArrayData {get;}
    Remarks
    For pixel data attributes, this property returns the uncompressed data for all frames as a single array.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAttribute Class
    DicomAttribute Members


DicomObjects Namespace / DicomAttribute Class / DateTimeFrom Property

    DateTimeFrom Property
    Start values for date and time ranges
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property DateTimeFrom As Date
    'Usage

    Dim instance As DicomAttribute
Dim value As Date

value = instance.DateTimeFrom
    public DateTime DateTimeFrom {get;}
    Remarks
    If the attribute has an open ended range - e.g. "-20060101", then this property will return DicomGlobal.MinimumDateTime
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAttribute Class
    DicomAttribute Members


DicomObjects Namespace / DicomAttribute Class / DateTimeTo Property

    DateTimeTo Property
    End values for date and time ranges
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property DateTimeTo As Date
    'Usage

    Dim instance As DicomAttribute
Dim value As Date

value = instance.DateTimeTo
    public DateTime DateTimeTo {get;}
    Remarks
    If the attribute has an open start range - e.g. "20060101-", then this property will return DicomGlobal.MaximumDateTime
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAttribute Class
    DicomAttribute Members


DicomObjects Namespace / DicomAttribute Class / DelayedData Property

    DelayedData Property
    Callback to DelayedDataRoutine specified by used for fetching binary data
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property DelayedData As DicomAttribute.DelayedDataRoutine
    'Usage

    Dim instance As DicomAttribute
Dim value As DicomAttribute.DelayedDataRoutine

instance.DelayedData = value

value = instance.DelayedData
    public DicomAttribute.DelayedDataRoutine DelayedData {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAttribute Class
    DicomAttribute Members


DicomObjects Namespace / DicomAttribute Class / Description Property

    Description Property (DicomAttribute)
    In This Topic
    The DICOM Description of the Attribute
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property Description As String
    'Usage

    Dim instance As DicomAttribute
Dim value As String

value = instance.Description
    public string Description {get;}
    Remarks
    This is a general description of the DICOM tag itself, NOT the actual data in this instance.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAttribute Class
    DicomAttribute Members


DicomObjects Namespace / DicomAttribute Class / Element Property

    Element Property (DicomAttribute)
    In This Topic
    The element indices of a data element
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property Element As Integer
    'Usage

    Dim instance As DicomAttribute
Dim value As Integer

value = instance.Element
    public int Element {get;}
    Remarks

    Group and Element, although these properties would be redundant if accessing the elements by Group and element number, the ability to iterate through the elements using the "for each" requires these properties to be exposed, in order to identify the nature of each attribute.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAttribute Class
    DicomAttribute Members


DicomObjects Namespace / DicomAttribute Class / Exists Property

    Exists Property
    Determines whether an attribute actually exists
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overridable ReadOnly Property Exists As Boolean
    'Usage

    Dim instance As DicomAttribute
Dim value As Boolean

value = instance.Exists
    public virtual bool Exists {get;}
    Remarks

    This property returns True if this attribute exists within the Image/DataSet.

    If an attempt is made to access a non-existent element of a DicomAttributeCollection, then no error is generated, but the element item returned is a unique "error element", which has an Exists property of False, and returns a Value of Null.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAttribute Class
    DicomAttribute Members


DicomObjects Namespace / DicomAttribute Class / ExistsWithValue Property

    ExistsWithValue Property
    Returns True if non-null data is present.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property ExistsWithValue As Boolean
    'Usage

    Dim instance As DicomAttribute
Dim value As Boolean

value = instance.ExistsWithValue
    public bool ExistsWithValue {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAttribute Class
    DicomAttribute Members


DicomObjects Namespace / DicomAttribute Class / Group Property

    Group Property (DicomAttribute)
    In This Topic
    The Group indices of a data element.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property Group As Integer
    'Usage

    Dim instance As DicomAttribute
Dim value As Integer

value = instance.Group
    public int Group {get;}
    Remarks

    Group and Element, although these properties would be redundant if accessing the elements by Group and element number, the ability to iterate through the elements using the "for each" requires these properties to be exposed, in order to identify the nature of each attribute.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAttribute Class
    DicomAttribute Members


DicomObjects Namespace / DicomAttribute Class / IsMultiple Property

    IsMultiple Property
    Determines whether an attribute has a potential value multiplicity of greater than 1
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property IsMultiple As Boolean
    'Usage

    Dim instance As DicomAttribute
Dim value As Boolean

value = instance.IsMultiple
    public bool IsMultiple {get;}
    Remarks
    If true, then the element has a potential value multiplicity of > 1, and its value will be an array not a scalar.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAttribute Class
    DicomAttribute Members


DicomObjects Namespace / DicomAttribute Class / IsNull Property

    IsNull Property
    Indicates whether DicomAttribute has a non-null value
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property IsNull As Boolean
    'Usage

    Dim instance As DicomAttribute
Dim value As Boolean

value = instance.IsNull
    public bool IsNull {get;}
    Remarks
    IsNull is true if the value is a Null (or "Nothing" in VB). This can be due to the actual data being zero length, OR if it consists entirely of discardable characters such as trailing blanks.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAttribute Class
    DicomAttribute Members


DicomObjects Namespace / DicomAttribute Class / IsPrivate Property

    IsPrivate Property
    Checks whether an attribute is private
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property IsPrivate As Boolean
    'Usage

    Dim instance As DicomAttribute
Dim value As Boolean

value = instance.IsPrivate
    public bool IsPrivate {get;}
    Remarks
    The current implemntation simply checks if the Group number is odd.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAttribute Class
    DicomAttribute Members


DicomObjects Namespace / DicomAttribute Class / Item Property
The 1-based index of the component to return

    Item Property (DicomAttribute)
    In This Topic
    The default indexer.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Default Property Item( _
   ByVal Index As Integer _
) As Object
    'Usage

    Dim instance As DicomAttribute
Dim Index As Integer
Dim value As Object

value = instance.Item(Index)
    public object this[
   int Index
]; {get;}

    Parameters

    Index
    The 1-based index of the component to return
    Remarks

    If Item is 0, then the overall value (equivalent to the Value) is returned

    If the VM is greater than 1 then individual items may be accessed by using the 1-based index.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAttribute Class
    DicomAttribute Members


DicomObjects Namespace / DicomAttribute Class / Keyword Property

    Keyword Property
    String representation of the attribute's keyword
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property Keyword As String
    'Usage

    Dim instance As DicomAttribute
Dim value As String

value = instance.Keyword
    public string Keyword {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAttribute Class
    DicomAttribute Members


DicomObjects Namespace / DicomAttribute Class / KeywordCode Property

    KeywordCode Property
    The attribute's keyword as a Keyword
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property KeywordCode As Keyword
    'Usage

    Dim instance As DicomAttribute
Dim value As Keyword

value = instance.KeywordCode
    public Keyword KeywordCode {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAttribute Class
    DicomAttribute Members


DicomObjects Namespace / DicomAttribute Class / RawData Property

    RawData Property
    The raw data held in DicomAttribute object
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property RawData As Array
    'Usage

    Dim instance As DicomAttribute
Dim value As Array

value = instance.RawData
    public Array RawData {get;}
    Remarks
    This property returns an array of bytes as the raw data held in a DicomAttribute object.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAttribute Class
    DicomAttribute Members


DicomObjects Namespace / DicomAttribute Class / Tag Property

    Tag Property (DicomAttribute)
    In This Topic
    A general purpose Tag for developer use
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property Tag As Object
    'Usage

    Dim instance As DicomAttribute
Dim value As Object

instance.Tag = value

value = instance.Tag
    public object Tag {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAttribute Class
    DicomAttribute Members


DicomObjects Namespace / DicomAttribute Class / Value Property

    Value Property (DicomAttribute)
    In This Topic
    The value of a Data Element
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property Value As Object
    'Usage

    Dim instance As DicomAttribute
Dim value As Object

value = instance.Value
    public object Value {get;}
    Remarks

    The type of object returned depends on the value representation of the data element, and may be a string, date (or time, date or date-time), or a numeric type, including floating point values where appropriate.

    Data elements of types not known to the program, whether private elements, or attributes recently defined by DICOM return the string " Unknown Data Type".

    The pixel data attribute(7FE0,0010) is handled slightly differently and returns a flattened 1 dimensional array.

    If the data dictionary lists the element as having the possibility of a value multiplicity of >1, then an single dimensional array of the appropriate type is returned, the size of the array reflecting the actual number of elements present (which may be just one).

    If the element is a sequence then an Object of type DicomDataSetCollection is returned. As this is the only possible result of type Object, it can easily be identified using Visual Basic’s "Vartype" function or equivalent.

    Non-existent Elements have a value of Null.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAttribute Class
    DicomAttribute Members


DicomObjects Namespace / DicomAttribute Class / VM Property

    VM Property
    The value multiplicity of an attribute
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property VM As Integer
    'Usage

    Dim instance As DicomAttribute
Dim value As Integer

value = instance.VM
    public int VM {get;}
    Remarks

    This property returns the actual number of items which will be returned by a call to the Attribute’s Value property. If the attribute has zero length, then the value will be 0, and if it is only allowed to have a single value then it will be 1, but for other cases the value depends on the data itself. If the Value property returns an array, then the value of this property equals the upper bound of the array.

    If the underlying attribute is a sequence, then this property returns the number of items in the sequence.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAttribute Class
    DicomAttribute Members


DicomObjects Namespace / DicomAttribute Class / VR Property

    VR Property
    The Value Representation of an attribute
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property VR As String
    'Usage

    Dim instance As DicomAttribute
Dim value As String

instance.VR = value

value = instance.VR
    public string VR {get; set;}
    Remarks

    This property is normally used as read-only and may be useful in determining the type of an element.

    Changing the type of an element is not normally needed or a good idea, but may be required occasionally, such as when private data has been read through the implicit VR transfer syntax.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAttribute Class
    DicomAttribute Members


%%PageItemTitle%%

DicomObjects Namespace / DicomContext Class
Members

In This Topic
    DicomContext Class
    In This Topic
    A DICOM presentation context, as used in association negotiation
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Class DicomContext
    'Usage

    Dim instance As DicomContext
    public class DicomContext
    Remarks
    A DicomContext represents a DICOM presentation context, and is used in association negotiation, and in the selection of transmission formats (transfer syntaxes). DicomContext items only exist within a DicomContextCollection, and more information on the use of DicomContext items may be found in the DicomContextCollection entry.
    Inheritance Hierarchy

    System.Object
    DicomObjects.DicomContext

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomContext Members
    DicomObjects Namespace


%%PageItemTitle%% $$Members$$

DicomObjects Namespace / DicomContext Class
Properties Methods

In This Topic
    DicomContext Class Members
    In This Topic

    The following tables list the members exposed by DicomContext.

    Public Properties
     | Name | Description
Public Property | AbstractSyntax | The abstract syntax associated with the presentation context
Public Property | AcceptedTS | The negotiated and accepted transfer syntax to be used in a presentation context
Public Property | ContextID | Uniquely identifies a presentation context for a given association
Public Property | ExtendedNegotiationValues | Used to negotiate extended information about a SOP class
Public Property | OfferedTS | The list of transfer syntaxes offered in a presentation context
Public Property | RequestorSCPRole | Used for reverse role negotiation
Public Property | RequestorSCURole | Used for reverse role negotiation
Public Property | Tag | A general purpose Tag for developer use
    Top
    Public Methods
     | Name | Description
Public Method | Reject | Rejects a particular presentation context
    Top
    See Also

    Reference

    DicomContext Class
    DicomObjects Namespace


%%PageItemTitle%% $$Methods$$

DicomObjects Namespace / DicomContext Class

    DicomContext Class Methods
    In This Topic

    For a list of all members of this type, see DicomContext members.

    Public Methods
     | Name | Description
Public Method | Reject | Rejects a particular presentation context
    Top
    See Also

    Reference

    DicomContext Class
    DicomObjects Namespace


DicomObjects Namespace / DicomContext Class / Reject Method

Byte value, the reason for rejection

    Reject Method (DicomContext)
    In This Topic
    Rejects a particular presentation context
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Sub Reject( _
   ByVal Reason As Byte _
)
    'Usage

    Dim instance As DicomContext
Dim Reason As Byte

instance.Reject(Reason)
    public void Reject(
   byte Reason
)

    Parameters

    Reason

    Byte value, the reason for rejection

    Remarks

    This method, and setting of the AcceptedTS property are mutually exclusive, and if both are used, the latest used takes precedence.

    The defined reasons are:

    • 1: user-rejection
    • 2: no-reason (provider rejection)
    • 3: abstract-syntax-not-supported (provider rejection)
    • 4: transfer-syntax-not-supported (provider rejection)
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomContext Class
    DicomContext Members


%%PageItemTitle%% $$Properties$$

DicomObjects Namespace / DicomContext Class

    DicomContext Class Properties
    In This Topic

    For a list of all members of this type, see DicomContext members.

    Public Properties
     | Name | Description
Public Property | AbstractSyntax | The abstract syntax associated with the presentation context
Public Property | AcceptedTS | The negotiated and accepted transfer syntax to be used in a presentation context
Public Property | ContextID | Uniquely identifies a presentation context for a given association
Public Property | ExtendedNegotiationValues | Used to negotiate extended information about a SOP class
Public Property | OfferedTS | The list of transfer syntaxes offered in a presentation context
Public Property | RequestorSCPRole | Used for reverse role negotiation
Public Property | RequestorSCURole | Used for reverse role negotiation
Public Property | Tag | A general purpose Tag for developer use
    Top
    See Also

    Reference

    DicomContext Class
    DicomObjects Namespace


DicomObjects Namespace / DicomContext Class / AbstractSyntax Property

    AbstractSyntax Property
    The abstract syntax associated with the presentation context
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property AbstractSyntax As String
    'Usage

    Dim instance As DicomContext
Dim value As String

value = instance.AbstractSyntax
    public string AbstractSyntax {get;}
    Remarks

    This value may either be a SOP class, such as CT, or a Meta SOP class such as BasicGrayscalePrint.

    Whilst this property may be set to, or compared with full UID strings, use of UID Constants is advised for better readability.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomContext Class
    DicomContext Members


DicomObjects Namespace / DicomContext Class / AcceptedTS Property

    AcceptedTS Property

    The negotiated and accepted transfer syntax to be used in a presentation context

    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property AcceptedTS As String
    'Usage

    Dim instance As DicomContext
Dim value As String

instance.AcceptedTS = value

value = instance.AcceptedTS
    public string AcceptedTS {get; set;}
    Remarks

    This property allows a client program, in an AssociationRequest event, to select which transfer syntax to accept for a given presentation context, the list offered being found in the OfferedTS property. If none of the offered contexts is acceptable, then instead of setting this value, the Reject method should be called.

    If no value is set, and Reject is not called, then DicomObjects will automatically select a value, based on the Transfer Syntax Negotiation settings. On an established association, whether incoming or outgoing, the client may use this property to check which transfer syntax will be used, especially if the same abstract context exists in more than one presentation context. The DicomAssociation's PreferredPCID property may then be set to the appropriate DicomContext's ContextID value.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomContext Class
    DicomContext Members


DicomObjects Namespace / DicomContext Class / ContextID Property

    ContextID Property
    Uniquely identifies a presentation context for a given association
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property ContextID As Byte
    'Usage

    Dim instance As DicomContext
Dim value As Byte

value = instance.ContextID
    public byte ContextID {get;}
    Remarks

    The value of this property is normally a small odd integer between 1 and 255, though some faulty public domain software incorrectly uses even values which may be seen, and need to be tolerated.

    The value is set when the DicomContext item is created, either implicitly, or by the DicomContextCollection's Add method, and cannot be changed.

    This value may be used to set the DicomAssociation's PreferredPCID property and is also used to index into the DicomContextCollection.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomContext Class
    DicomContext Members


DicomObjects Namespace / DicomContext Class / ExtendedNegotiationValues Property

    ExtendedNegotiationValues Property
    Used to negotiate extended information about a SOP class
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property ExtendedNegotiationValues As Byte()
    'Usage

    Dim instance As DicomContext
Dim value() As Byte

instance.ExtendedNegotiationValues = value

value = instance.ExtendedNegotiationValues
    public byte[] ExtendedNegotiationValues {get; set;}
    Remarks

    This property enable applications to share or negotiate extended information about themselves.

    The exact meanings of the various values and byte positions used for extended negotiation vary from one service class to another, and they are all detailed in part 4 of DICOM. e.g. for C-STORE operations, byte 1 represents the "storage level", byte 3 the level of digital signature support and byte 5 controls the coercion of data elements (2,4, & 6 are reserved). However, for C-FIND operations, only 1 byte is specified, indicating whether the SCP supports relational queries. In all cases, support is optional, and default values exist if extended negotiation is not performed.

    If this property is set to true, then any extended negotiation items set up before Open are proposed. When incoming associations are received, then incoming values are automatically sent out again (i.e. accepted) unless altered using the ExtendedNegotiationValues property in the AssociationRequest event.

    Once an association is established, this property becomes read-only, but still reflects the arrangement negotiated.

    Please note that this property is shared between all contexts with the same AbstractSyntax (SOP class), so changing one will change the value for any other matching contexts.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomContext Class
    DicomContext Members


DicomObjects Namespace / DicomContext Class / OfferedTS Property

    OfferedTS Property
    The list of transfer syntaxes offered in a presentation context
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property OfferedTS As String()
    'Usage

    Dim instance As DicomContext
Dim value() As String

instance.OfferedTS = value

value = instance.OfferedTS
    public string[] OfferedTS {get; set;}

    Property Value

    The list of transfer syntaxes offered
    Remarks

    This property holds the list of transfer syntaxes offered as part of association negotiation. As an SCU, it may be set up by a client program prior to calling Open. As an SCP, the values may be inspected during the AssociationRequest event in order to select which on to accept (by setting AcceptedTS).

    If not set explicitly by a client program, a default list is used, based on tghe current Transfer Syntax Negotiation settings.

    Whilst this property may be set to, or compared with full UID strings, use of symbolic constants is advised for better readability.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomContext Class
    DicomContext Members


DicomObjects Namespace / DicomContext Class / RequestorSCPRole Property

    RequestorSCPRole Property
    Used for reverse role negotiation
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property RequestorSCPRole As Boolean
    'Usage

    Dim instance As DicomContext
Dim value As Boolean

instance.RequestorSCPRole = value

value = instance.RequestorSCPRole
    public bool RequestorSCPRole {get; set;}

    Property Value

    True if reverse role negotiation is to be supported
    Remarks

    Normally in DICOM, the requester of an association becomes the SCU, and the acceptor becomes the SCP, but there are some situations (notably Storage Commitment), where this relationship needs to be reversed (or it is possible for both applications to adopt both roles). In DicomObejcts, this is achieved using these properties, and is only possible (for outgoing operations) using an association based on an explicit DicomAssociation.

    To propose reverse role negotiation, DicomContext items must be created explicitly, and the contexts' RequestorSCURole should be set to false, and the RequestorSCPRole should be set to true.

    When accepting associations, DicomObjects's default action is to accept whatever roles are proposed by the requester, but this may be over-ridden in the AssociationRequest event by modifying these properties of any of the proposed contexts.

    Once an association is established, these properties become read-only, but still reflect the arrangement negotiated.

    Please note that these properties are shared between all contexts with the same AbstractSyntax (SOP Class), so changing one will change the value for any other matching contexts.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomContext Class
    DicomContext Members


DicomObjects Namespace / DicomContext Class / RequestorSCURole Property

    RequestorSCURole Property
    Used for reverse role negotiation
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property RequestorSCURole As Boolean
    'Usage

    Dim instance As DicomContext
Dim value As Boolean

instance.RequestorSCURole = value

value = instance.RequestorSCURole
    public bool RequestorSCURole {get; set;}

    Property Value

    True if reverse role negotiation is to be supported
    Remarks

    Normally in DICOM, the requester of an association becomes the SCU, and the acceptor becomes the SCP, but there are some situations (notably Storage Commitment), where this relationship needs to be reversed (or it is possible for both applications to adopt both roles). In DicomObejcts, this is achieved using these properties, and is only possible (for outgoing operations) using an association based on an explicit DicomAssociation.

    To propose reverse role negotiation, DicomContext items must be created explicitly, and the contexts' RequestorSCURole should be set to false, and the RequestorSCPRole should be set to true.

    When accepting associations, DicomObjects's default action is to accept whatever roles are proposed by the requester, but this may be over-ridden in the AssociationRequest event by modifying these properties of any of the proposed contexts.

    Once an association is established, these properties become read-only, but still reflect the arrangement negotiated.

    Please note that these properties are shared between all contexts with the same AbstractSyntax (SOP Class), so changing one will change the value for any other matching contexts.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomContext Class
    DicomContext Members


DicomObjects Namespace / DicomContext Class / Tag Property

    Tag Property (DicomContext)
    In This Topic
    A general purpose Tag for developer use
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property Tag As Object
    'Usage

    Dim instance As DicomContext
Dim value As Object

instance.Tag = value

value = instance.Tag
    public object Tag {get; set;}
    Remarks
    This property is not used by DicomObjects in any way, and is provided purely as a convenience for developers who wish to associate other objects with this object. As an alternative, most of the objects in DicomObjects can have other classes derived from them.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomContext Class
    DicomContext Members


%%PageItemTitle%%

DicomObjects Namespace / DicomContextCollection Class
Members

In This Topic
    DicomContextCollection Class
    In This Topic
    The list of DICOM Presentation contexts proposed or accepted during negotiation
    Object Model
    DicomContextCollection ClassDicomContext Class
    Syntax
    • Visual Basic
    • C#
    'Declaration

    <DefaultMemberAttribute("Item")>
<DebuggerTypeProxyAttribute(System.Collections.Generic.Mscorlib_KeyedCollectionDebugView`2)>
<DebuggerDisplayAttribute("Count = {Count}")>
Public Class DicomContextCollection
   Inherits System.Collections.ObjectModel.KeyedCollection(Of Byte,DicomContext)
    'Usage

    Dim instance As DicomContextCollection
    [DefaultMember("Item")]
[DebuggerTypeProxy(System.Collections.Generic.Mscorlib_KeyedCollectionDebugView`2)]
[DebuggerDisplay("Count = {Count}")]
public class DicomContextCollection : System.Collections.ObjectModel.KeyedCollection<byte,DicomContext>
    Inheritance Hierarchy

    System.Object
    System.Collections.ObjectModel.Collection<T>
    System.Collections.ObjectModel.KeyedCollection<TKey,TItem>
    DicomObjects.DicomContextCollection

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomContextCollection Members
    DicomObjects Namespace


%%PageItemTitle%% $$Members$$

DicomObjects Namespace / DicomContextCollection Class
Properties Methods

In This Topic
    DicomContextCollection Class Members
    In This Topic

    The following tables list the members exposed by DicomContextCollection.

    Public Properties
     | Name | Description
Public Property | AnyPresent | Indicates if there is any context agreed by the remote application
Public Property | Comparer | (Inherited from System.Collections.ObjectModel.KeyedCollection<byte,DicomContext>)
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<TItem>)
Public Property | Item | Overloaded. (Inherited from System.Collections.ObjectModel.KeyedCollection<byte,DicomContext>)
Public Property | Tag | A general purpose Tag for developer use
    Top
    Public Methods
     | Name | Description
Public Method | Add | Overloaded. Adds a DicomContext to a DicomContextCollection
Public Method | AddDefaults | Add the default SOP Class UIDs to Presentation Contexts
Public Method | CanUse | Checks whether at least one presentation context has been negotiated for a given SOP class
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<TItem>)
Public Method | Contains | Overloaded. (Inherited from System.Collections.ObjectModel.KeyedCollection<byte,DicomContext>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<TItem>)
Public Method | Exists | Checks whether a particular presentation ocntext ID exists
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<TItem>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<TItem>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<TItem>)
Public Method | Remove | Overloaded. (Inherited from System.Collections.ObjectModel.KeyedCollection<byte,DicomContext>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<TItem>)
    Top
    See Also

    Reference

    DicomContextCollection Class
    DicomObjects Namespace


%%PageItemTitle%% $$Methods$$

DicomObjects Namespace / DicomContextCollection Class

    DicomContextCollection Class Methods
    In This Topic

    For a list of all members of this type, see DicomContextCollection members.

    Public Methods
     | Name | Description
Public Method | Add | Overloaded. Adds a DicomContext to a DicomContextCollection
Public Method | AddDefaults | Add the default SOP Class UIDs to Presentation Contexts
Public Method | CanUse | Checks whether at least one presentation context has been negotiated for a given SOP class
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<TItem>)
Public Method | Contains | Overloaded. (Inherited from System.Collections.ObjectModel.KeyedCollection<byte,DicomContext>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<TItem>)
Public Method | Exists | Checks whether a particular presentation ocntext ID exists
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<TItem>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<TItem>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<TItem>)
Public Method | Remove | Overloaded. (Inherited from System.Collections.ObjectModel.KeyedCollection<byte,DicomContext>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<TItem>)
    Top
    See Also

    Reference

    DicomContextCollection Class
    DicomObjects Namespace


DicomObjects Namespace / DicomContextCollection Class / Add Method

    Add Method (DicomContextCollection)
    In This Topic
    Adds a DicomContext to a DicomContextCollection
    Overload List
    Overload | Description
Add(String) | Adds a DicomContext to a DicomContextCollection
Add(String,String) | Adds a DicomContext to a DicomContextCollection, together with the proposed TransferSyntax for the Presentation Context
Add(String,IEnumerable<String>) | Adds a DicomContext to a DicomContextCollection, together with a list of proposed TransferSyntax for the Presentation Context
Add(DicomContext) | (Inherited from System.Collections.ObjectModel.Collection<TItem>)
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomContextCollection Class
    DicomContextCollection Members


DicomObjects Namespace / DicomContextCollection Class / Add Method / Add(String) Method

String value specifying the proposed AbstractSyntax

    Add(String) Method
    In This Topic
    Adds a DicomContext to a DicomContextCollection
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Function Add( _
   ByVal AbstractSyntax As String _
) As DicomContext
    'Usage

    Dim instance As DicomContextCollection
Dim AbstractSyntax As String
Dim value As DicomContext

value = instance.Add(AbstractSyntax)
    public DicomContext Add(
   string AbstractSyntax
)

    Parameters

    AbstractSyntax

    String value specifying the proposed AbstractSyntax

    Return Value

    DicomContext
    Remarks
    Note that in keeping with the DICOM requirement, newly added contexts have odd values, so adding two items to a DicomContexts collection using this method will create item numbers 1 and 3, not 1 and 2.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomContextCollection Class
    DicomContextCollection Members
    Overload List


DicomObjects Namespace / DicomContextCollection Class / Add Method / Add(String,String) Method

The string value of proposed AbstractSyntax

The string value of he proposed TransferSyntax for that Presentation Context.

In This Topic
    Add(String,String) Method
    In This Topic
    Adds a DicomContext to a DicomContextCollection, together with the proposed TransferSyntax for the Presentation Context
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Function Add( _
   ByVal AbstractSyntax As String, _
   ByVal TransferSyntax As String _
) As DicomContext
    'Usage

    Dim instance As DicomContextCollection
Dim AbstractSyntax As String
Dim TransferSyntax As String
Dim value As DicomContext

value = instance.Add(AbstractSyntax, TransferSyntax)
    public DicomContext Add(
   string AbstractSyntax,
   string TransferSyntax
)

    Parameters

    AbstractSyntax

    The string value of proposed AbstractSyntax

    TransferSyntax

    The string value of he proposed TransferSyntax for that Presentation Context.

    Return Value

    DicomContext
    Remarks

    Note that in keeping with the DICOM requirement, newly added contexts have odd values, so adding two items to a DicomContexts collection using this method will create item numbers 1 and 3, not 1 and 2.

    Transfer Syntax can be a space separated list as follows:

    "1.2.840.10008.1.2 1.2.840.10008.1.2.1 1.2.840.10008.1.2.2"

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomContextCollection Class
    DicomContextCollection Members
    Overload List


DicomObjects Namespace / DicomContextCollection Class / Add Method / Add(String,IEnumerable<String>) Method

The string value of proposed AbstractSyntax

The list of proposed TransferSyntaxes for that Presentation Context.

In This Topic
    Add(String,IEnumerable<String>) Method
    In This Topic
    Adds a DicomContext to a DicomContextCollection, together with a list of proposed TransferSyntax for the Presentation Context
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Function Add( _
   ByVal AbstractSyntax As String, _
   ByVal TransferSyntaxes As IEnumerable(Of String) _
) As DicomContext
    'Usage

    Dim instance As DicomContextCollection
Dim AbstractSyntax As String
Dim TransferSyntaxes As IEnumerable(Of String)
Dim value As DicomContext

value = instance.Add(AbstractSyntax, TransferSyntaxes)
    public DicomContext Add(
   string AbstractSyntax,
   IEnumerable<string> TransferSyntaxes
)

    Parameters

    AbstractSyntax

    The string value of proposed AbstractSyntax

    TransferSyntaxes

    The list of proposed TransferSyntaxes for that Presentation Context.

    Return Value

    DicomContext
    Remarks

    Note that in keeping with the DICOM requirement, newly added contexts have odd values, so adding two items to a DicomContexts collection using this method will create item numbers 1 and 3, not 1 and 2.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomContextCollection Class
    DicomContextCollection Members
    Overload List


DicomObjects Namespace / DicomContextCollection Class / AddDefaults Method
TransferSyntax to add to each of the SOP Class UIDs in the default list

In This Topic
    AddDefaults Method
    In This Topic
    Add the default SOP Class UIDs to Presentation Contexts
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Sub AddDefaults( _
   ByVal TransferSyntax As String _
)
    'Usage

    Dim instance As DicomContextCollection
Dim TransferSyntax As String

instance.AddDefaults(TransferSyntax)
    public void AddDefaults(
   string TransferSyntax
)

    Parameters

    TransferSyntax
    TransferSyntax to add to each of the SOP Class UIDs in the default list
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomContextCollection Class
    DicomContextCollection Members


DicomObjects Namespace / DicomContextCollection Class / CanUse Method
The SOP Class (abstract syntax) to be checked

    CanUse Method
    In This Topic
    Checks whether at least one presentation context has been negotiated for a given SOP class
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Function CanUse( _
   ByVal SOPClass As String _
) As Boolean
    'Usage

    Dim instance As DicomContextCollection
Dim SOPClass As String
Dim value As Boolean

value = instance.CanUse(SOPClass)
    public bool CanUse(
   string SOPClass
)

    Parameters

    SOPClass
    The SOP Class (abstract syntax) to be checked

    Return Value

    True if the SOP class can be used
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomContextCollection Class
    DicomContextCollection Members


DicomObjects Namespace / DicomContextCollection Class / Exists Method
the (odd numbered) presentation Context ID to check

    Exists Method
    In This Topic
    Checks whether a particular presentation ocntext ID exists
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Function Exists( _
   ByVal ContextID As Byte _
) As Boolean
    'Usage

    Dim instance As DicomContextCollection
Dim ContextID As Byte
Dim value As Boolean

value = instance.Exists(ContextID)
    public bool Exists(
   byte ContextID
)

    Parameters

    ContextID
    the (odd numbered) presentation Context ID to check

    Return Value

    True if the entry exists
    Remarks
    If rejected by the other entity, then this will return false
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomContextCollection Class
    DicomContextCollection Members


%%PageItemTitle%% $$Properties$$

DicomObjects Namespace / DicomContextCollection Class

    DicomContextCollection Class Properties
    In This Topic

    For a list of all members of this type, see DicomContextCollection members.

    Public Properties
     | Name | Description
Public Property | AnyPresent | Indicates if there is any context agreed by the remote application
Public Property | Comparer | (Inherited from System.Collections.ObjectModel.KeyedCollection<byte,DicomContext>)
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<TItem>)
Public Property | Item | Overloaded. (Inherited from System.Collections.ObjectModel.KeyedCollection<byte,DicomContext>)
Public Property | Tag | A general purpose Tag for developer use
    Top
    See Also

    Reference

    DicomContextCollection Class
    DicomObjects Namespace


DicomObjects Namespace / DicomContextCollection Class / AnyPresent Property

    AnyPresent Property
    Indicates if there is any context agreed by the remote application
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property AnyPresent As Boolean
    'Usage

    Dim instance As DicomContextCollection
Dim value As Boolean

value = instance.AnyPresent
    public bool AnyPresent {get;}
    Remarks
    This property returns true only if there is 1 or more presentation context which has been agreed, during the association negotiation, by the remote application.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomContextCollection Class
    DicomContextCollection Members


DicomObjects Namespace / DicomContextCollection Class / Tag Property

    Tag Property (DicomContextCollection)
    In This Topic
    A general purpose Tag for developer use
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property Tag As Object
    'Usage

    Dim instance As DicomContextCollection
Dim value As Object

instance.Tag = value

value = instance.Tag
    public object Tag {get; set;}
    Remarks
    This property is not used by DicomObjects in any way, and is provided purely as a convenience for developers who wish to associate other objects with this object. As an alternative, most of the objects in DicomObjects can have other classes derived from them.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomContextCollection Class
    DicomContextCollection Members


%%PageItemTitle%%

DicomObjects Namespace / DicomDataSet Class
Members

In This Topic
    DicomDataSet Class
    In This Topic
    A DICOM data set
    Object Model
    DicomDataSet ClassDicomAttribute Class
    Syntax
    • Visual Basic
    • C#
    'Declaration

    <DefaultMemberAttribute("Item")>
Public Class DicomDataSet
    'Usage

    Dim instance As DicomDataSet
    [DefaultMember("Item")]
public class DicomDataSet
    Remarks

    A DicomDataSet object holds a set of DicomAttributes, and constitutes the main set of data within DICOM. The content may be:

    • A composite instance (image or other persistent object)
    • A Command
    • An item in a sequence (in which case it is part of a DicomDataSetCollection)

    The constituent attributes may be accessed in many different ways:

    • By Group and Element - dataset[group, element]
    • By KeyWord - dataset[Keyword]
    • Sequentially by index - dataset[index]
    • Sequentially by using the iterator - foreach(DicomAttribute in dataset)

    Inheritance Hierarchy

    System.Object
    DicomObjects.DicomDataSet

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Members
    DicomObjects Namespace


%%PageItemTitle%% $$Members$$

DicomObjects Namespace / DicomDataSet Class
Fields Properties Methods

In This Topic
    DicomDataSet Class Members
    In This Topic

    The following tables list the members exposed by DicomDataSet.

    Public Constructors
     | Name | Description
Public Constructor | DicomDataSet Constructor | Overloaded. Creates a new DicomDataSet
    Top
    Public Fields
     | Name | Description
Public Field | CompressedFrameStream | User-defined function to set output stream for compressed frame. This is suitable for writing out large compressed frames with Basic Offset Table.
    Top
    Public Properties
     | Name | Description
Public Property | AccessionNumber | The Accession Number
Public Property | CacheMode | Controls how the pixel data is cached
Public Property | Children | Holds the hierarchical directory structure for DICOM directory files
Public Property | Command | The full command dataset received
Public Property | Count | Number of Attributes held in the DataSet
Public Property | DateOfBirth | Date of birth of the patient
Public Property | Identifer | Returns the underlying DataSet which contains the list of attributes to be matched, as specified in the DICOM standard.
Public Property | InstanceUID | Unique identifier for the four levels of the DICOM Query/Retrieve hierarchy
Public Property | Item | Overloaded. Provides access of all attributes of the dataset
Public Property | Modality | The Modality of the image
Public Property | Name | The Name of the patient
Public Property | OriginalTS | Returns the Transfer syntax with which the object was originally received or read.
Public Property | Overrides | Image-specific list of unusual behaviours (e.g. to cope with faulty images)
Public Property | OverrideTS | A means to override an incorrect transfer syntax
Public Property | PatientID | The Patient ID
Public Property | PixelsPerFrame | The number of pixels per frame
Public Property | RawPixels | Accesses the raw pixel data as an array
Public Property | SamplesPerFrame | The number of samples per frame
Public Property | SeriesDescription | Descriptions for the series
Public Property | SeriesUID | Unique identifier for the four levels of the DICOM Query/Retrieve hierarchy
Public Property | Sex | Sex of the patient
Public Property | Size | The dimensions of the pixel data if present
Public Property | SOPClass | SOP class of the DicomDataSet.
Public Property | StudyDescription | Description for the study
Public Property | StudyUID | Unique identifier for the four levels of the DICOM Query/Retrieve hierarchy
Public Property | Tag | A general purpose Tag for developer use
Public Property | UncompressedPI | Gets the Photometric Interpretation of the uncompressed Image data.
Public Property | ValidationDataSet | Assign a Validation DataSet to this property would override the DataSet's Validation scheme. This is mainly used for validation of CharacterSet.
Public Property | ValidationOptions | The default DicomObjects.Validation.ValidationOptions to apply to newly created DicomDataSet objects
    Top
    Public Methods
     | Name | Description
Public Method | Add | Overloaded. Creates and adds data elements to DicomDataSet
Public Method | AddByReference | Overloaded. Add byte[] as attribute value to avoid copying large data
Public Method | AddPixelData | Adds pixel data to DicomDataSet
Public Method | AddToDirectory | Overloaded. Simplified DICOMDIR creation
Public Method | ChangeCharacterSet | Change the specific Character Set of a DICOM dataset. All applicable attributes will have its data re-encoded by the new character set
Public Method | ChangeToDecompressed | Simulate the effect of writing out as a Decompressed Image
Public Method | Clear | Clear the DicomDataSet data
Public Method | ClearCaches | Overloaded. Clears all internal cache for compressed and uncompressed pixel data
Public Method | Clone | Overloaded. Returns a copy of the DicomDataSet
Public Method | DecompressAll | Causes all the frames of an image to be decompressed.
Public Method | Dispose | Release the resources used by the DicomDataSet object
Public Method | FindAttribute | Locate an attribute within either a top level dataset, or within one of the functional group macros
Public Method | ForEachAttribute | Recursively perform an action on every attribute within the dataset
Public Method | FrameSubSet | Generates a new DicomDataSet as a subset of the current instance as described in supplement 119
Public Method | FunctionalGroupDataSet | Overloaded. Locate the required functional group within a DicomDataSet
Public Method | FunctionalGroupOrRootLevelAttribute | Overloaded. Return the required DicomAttribute within a specified functional group within a DicomDataSet If DicomAttribute is not present in the specified DicomDataSet, it searches amongst the root level attributes
Public Method | GetCacheSize | Get cache size used by DicomObjects for the image - useful to help decide when to call ClearCaches method
Public Method | GetMinAndMax | Overloaded. Find the maximum and minimum pixel data values in the pixel data
Public Method | GetPixelStream | Returns the raw pixel data as a Stream object for a specific frame
Public Method | GetRawFrame | Extract individual frame from the pixel data
Public Method | ImportPixelData | Direct import of compressed pixel data
Public Method | IsPresentationStateFor | Overloaded. Indicates if the PresentationState is for the specified DicomImage
Public Method | MergeBulkData | Load Bulk data for all attributes, getting data from a method, based on the URI
Public Method | OriginalPixelData | Method to extract Original pixel data as Array
Public Method | PixelValuesByFrameGeneric | Returns an array of pixel values for a frame, optionally transformed via the modality transformation. Also accssible from
Public Method | PrinterImage | Creates a copy of the image for printing or other purposes
Public Method | Read | Overloaded. Reads from a file, a system IO stream or a byte array
Public Method | ReadJson | Read DICOM data from a Json Stream
Public Method | ReadURL | Reads DataSet from Web Address
Public Method | ReadXml | Read DICOM data from an XML Stream
Public Method | Remove | Overloaded. Removes an attribute from the DataSet
Public Method | RemovePrivateAttributes | Remove private attributes
Public Method | Send | Overloaded. Sends a DicomDataSet to a remote DICOM application
Public Method | SetDicomCodec | Specify a "DICOM" codec
Public Method | SetNonDicomCodec | Specify a non-DICOM source (e.g. AVI) as a source of frame data
Public Method | SetPixelFile | Maps an external file as the pixel data
Public Method | SetPlanarConfiguration | Sets the planar configuration in DicomDataSet
Public Method | SimplifyOverlays | Decompress the data, and move any overlays which are encoded with the pixel data (a method deprecated in DICOM many years ago) to stand-along overlay data in 60xx,3000.
Public Method | SubImage | Creates a copy of part or all of the image with controlled size
Public Method | Validate | Validate all DicomAttributes within the DicomDataset based on its ValidationOptions
Public Method | ValidateAll | Validate all DicomAttributes within the DicomDataset based on its ValidationOptions
Public Method | Value | Overloaded. Returns the value of the specified Data Element
Public Method | Write | Overloaded. Writes the dataset to an external DICOM file, a system IO stream or a byte array etc.
Public Method | WriteJson | Write the DICOM data into an Json Stream
Public Method | WriteXml | Write the DICOM data into an XML Stream
    Top
    See Also

    Reference

    DicomDataSet Class
    DicomObjects Namespace


%%PageItemTitle%%

DicomObjects Namespace / DicomDataSet Class / DicomDataSet Constructor

In This Topic
    DicomDataSet Constructor
    In This Topic
    Creates a new DicomDataSet
    Overload List
    Overload | Description
DicomDataSet Constructor() | Creates an empty DicomDataSet
DicomDataSet Constructor(Stream,ReadBehaviours) | Creates a new DicomDataSet from system IO stream
DicomDataSet Constructor(Byte[],ReadBehaviours) | Creates a new DicomDataSet from a byte array
DicomDataSet Constructor(SKBitmap) | Import a SKBitmap object into DicomDataSet
DicomDataSet Constructor(DicomDataSet,Boolean) | Creates a new DicomDataSet from an existing DicomDataSet object
DicomDataSet Constructor(String,ReadBehaviours) | Creates a new DicomDataSet from an external DICOM file
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


%%PageItemTitle%%

DicomObjects Namespace / DicomDataSet Class / DicomDataSet Constructor / DicomDataSet Constructor()

In This Topic
    DicomDataSet Constructor()
    In This Topic
    Creates an empty DicomDataSet
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Function New()
    'Usage

    Dim instance As New DicomDataSet()
    public DicomDataSet()

    Return Value

    DicomDataSet
    Remarks
    This is the constructor method.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


%%PageItemTitle%%

DicomObjects Namespace / DicomDataSet Class / DicomDataSet Constructor / DicomDataSet Constructor(Stream,ReadBehaviours)

The Stream from which to read.

ReadBehavioursObject to control individual read operation

In This Topic
    DicomDataSet Constructor(Stream,ReadBehaviours)
    In This Topic
    Creates a new DicomDataSet from system IO stream
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Function New( _
   ByVal Stream As Stream, _
   Optional ByVal ReadBehaviour As ReadBehaviours _
)
    'Usage

    Dim Stream As Stream
Dim ReadBehaviour As ReadBehaviours

Dim instance As New DicomDataSet(Stream, ReadBehaviour)
    public DicomDataSet(
   Stream Stream,
   ReadBehaviours ReadBehaviour
)

    Parameters

    Stream

    The Stream from which to read.

    ReadBehaviour
    ReadBehavioursObject to control individual read operation

    Return Value

    DicomDataSet
    Remarks
    A direct constructor of DicomDataSet object.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


%%PageItemTitle%%

DicomObjects Namespace / DicomDataSet Class / DicomDataSet Constructor / DicomDataSet Constructor(Byte[],ReadBehaviours)

The byte array to read

ReadBehavioursObject to control individual read operation

In This Topic
    DicomDataSet Constructor(Byte[],ReadBehaviours)
    In This Topic
    Creates a new DicomDataSet from a byte array
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Function New( _
   ByVal Array() As Byte, _
   Optional ByVal ReadBehaviour As ReadBehaviours _
)
    'Usage

    Dim Array() As Byte
Dim ReadBehaviour As ReadBehaviours

Dim instance As New DicomDataSet(Array, ReadBehaviour)
    public DicomDataSet(
   byte[] Array,
   ReadBehaviours ReadBehaviour
)

    Parameters

    Array

    The byte array to read

    ReadBehaviour
    ReadBehavioursObject to control individual read operation

    Return Value

    DicomDataSet
    Remarks
    A DicomDataSet constructor.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


%%PageItemTitle%%

DicomObjects Namespace / DicomDataSet Class / DicomDataSet Constructor / DicomDataSet Constructor(SKBitmap)
An SKBitmap object to import

In This Topic
    DicomDataSet Constructor(SKBitmap)
    In This Topic
    Import a SKBitmap object into DicomDataSet
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Function New( _
   ByVal bmp As SkiaSharp.SKBitmap _
)
    'Usage

    Dim bmp As SkiaSharp.SKBitmap

Dim instance As New DicomDataSet(bmp)
    public DicomDataSet(
   SkiaSharp.SKBitmap bmp
)

    Parameters

    bmp
    An SKBitmap object to import
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


%%PageItemTitle%%

DicomObjects Namespace / DicomDataSet Class / DicomDataSet Constructor / DicomDataSet Constructor(DicomDataSet,Boolean)

The Original DicomDataSet object from which the new DicomDataSet is created.

Boolean, indicates weather a Deep/Shallow clone of the Original DicomDataSet will be performed when creating the new DicomDataSet.

In This Topic
    DicomDataSet Constructor(DicomDataSet,Boolean)
    In This Topic
    Creates a new DicomDataSet from an existing DicomDataSet object
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Function New( _
   ByVal Original As DicomDataSet, _
   ByVal Deep As Boolean _
)
    'Usage

    Dim Original As DicomDataSet
Dim Deep As Boolean

Dim instance As New DicomDataSet(Original, Deep)
    public DicomDataSet(
   DicomDataSet Original,
   bool Deep
)

    Parameters

    Original

    The Original DicomDataSet object from which the new DicomDataSet is created.

    Deep

    Boolean, indicates weather a Deep/Shallow clone of the Original DicomDataSet will be performed when creating the new DicomDataSet.

    Return Value

    DicomDataSet
    Remarks
    A direct constructor of DicomDataSet object.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


%%PageItemTitle%%

DicomObjects Namespace / DicomDataSet Class / DicomDataSet Constructor / DicomDataSet Constructor(String,ReadBehaviours)

The name of the file to read.

This is passed unmodified to the operating system, and it is therefore the container�s responsibility to ensure either that the file exists within the current directory, or that a fully qualified filename is provided.

ReadBehavioursObject to control individual read operation

In This Topic
    DicomDataSet Constructor(String,ReadBehaviours)
    In This Topic
    Creates a new DicomDataSet from an external DICOM file
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Function New( _
   ByVal Filename As String, _
   Optional ByVal ReadBehaviour As ReadBehaviours _
)
    'Usage

    Dim Filename As String
Dim ReadBehaviour As ReadBehaviours

Dim instance As New DicomDataSet(Filename, ReadBehaviour)
    public DicomDataSet(
   string Filename,
   ReadBehaviours ReadBehaviour
)

    Parameters

    Filename

    The name of the file to read.

    This is passed unmodified to the operating system, and it is therefore the container�s responsibility to ensure either that the file exists within the current directory, or that a fully qualified filename is provided.

    ReadBehaviour
    ReadBehavioursObject to control individual read operation

    Return Value

    DicomDataSet
    Remarks
    A direct constructor of DicomDataSet object.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


%%PageItemTitle%% $$Methods$$

DicomObjects Namespace / DicomDataSet Class

    DicomDataSet Class Methods
    In This Topic

    For a list of all members of this type, see DicomDataSet members.

    Public Methods
     | Name | Description
Public Method | Add | Overloaded. Creates and adds data elements to DicomDataSet
Public Method | AddByReference | Overloaded. Add byte[] as attribute value to avoid copying large data
Public Method | AddPixelData | Adds pixel data to DicomDataSet
Public Method | AddToDirectory | Overloaded. Simplified DICOMDIR creation
Public Method | ChangeCharacterSet | Change the specific Character Set of a DICOM dataset. All applicable attributes will have its data re-encoded by the new character set
Public Method | ChangeToDecompressed | Simulate the effect of writing out as a Decompressed Image
Public Method | Clear | Clear the DicomDataSet data
Public Method | ClearCaches | Overloaded. Clears all internal cache for compressed and uncompressed pixel data
Public Method | Clone | Overloaded. Returns a copy of the DicomDataSet
Public Method | DecompressAll | Causes all the frames of an image to be decompressed.
Public Method | Dispose | Release the resources used by the DicomDataSet object
Public Method | FindAttribute | Locate an attribute within either a top level dataset, or within one of the functional group macros
Public Method | ForEachAttribute | Recursively perform an action on every attribute within the dataset
Public Method | FrameSubSet | Generates a new DicomDataSet as a subset of the current instance as described in supplement 119
Public Method | FunctionalGroupDataSet | Overloaded. Locate the required functional group within a DicomDataSet
Public Method | FunctionalGroupOrRootLevelAttribute | Overloaded. Return the required DicomAttribute within a specified functional group within a DicomDataSet If DicomAttribute is not present in the specified DicomDataSet, it searches amongst the root level attributes
Public Method | GetCacheSize | Get cache size used by DicomObjects for the image - useful to help decide when to call ClearCaches method
Public Method | GetMinAndMax | Overloaded. Find the maximum and minimum pixel data values in the pixel data
Public Method | GetPixelStream | Returns the raw pixel data as a Stream object for a specific frame
Public Method | GetRawFrame | Extract individual frame from the pixel data
Public Method | ImportPixelData | Direct import of compressed pixel data
Public Method | IsPresentationStateFor | Overloaded. Indicates if the PresentationState is for the specified DicomImage
Public Method | MergeBulkData | Load Bulk data for all attributes, getting data from a method, based on the URI
Public Method | OriginalPixelData | Method to extract Original pixel data as Array
Public Method | PixelValuesByFrameGeneric | Returns an array of pixel values for a frame, optionally transformed via the modality transformation. Also accssible from
Public Method | PrinterImage | Creates a copy of the image for printing or other purposes
Public Method | Read | Overloaded. Reads from a file, a system IO stream or a byte array
Public Method | ReadJson | Read DICOM data from a Json Stream
Public Method | ReadURL | Reads DataSet from Web Address
Public Method | ReadXml | Read DICOM data from an XML Stream
Public Method | Remove | Overloaded. Removes an attribute from the DataSet
Public Method | RemovePrivateAttributes | Remove private attributes
Public Method | Send | Overloaded. Sends a DicomDataSet to a remote DICOM application
Public Method | SetDicomCodec | Specify a "DICOM" codec
Public Method | SetNonDicomCodec | Specify a non-DICOM source (e.g. AVI) as a source of frame data
Public Method | SetPixelFile | Maps an external file as the pixel data
Public Method | SetPlanarConfiguration | Sets the planar configuration in DicomDataSet
Public Method | SimplifyOverlays | Decompress the data, and move any overlays which are encoded with the pixel data (a method deprecated in DICOM many years ago) to stand-along overlay data in 60xx,3000.
Public Method | SubImage | Creates a copy of part or all of the image with controlled size
Public Method | Validate | Validate all DicomAttributes within the DicomDataset based on its ValidationOptions
Public Method | ValidateAll | Validate all DicomAttributes within the DicomDataset based on its ValidationOptions
Public Method | Value | Overloaded. Returns the value of the specified Data Element
Public Method | Write | Overloaded. Writes the dataset to an external DICOM file, a system IO stream or a byte array etc.
Public Method | WriteJson | Write the DICOM data into an Json Stream
Public Method | WriteXml | Write the DICOM data into an XML Stream
    Top
    See Also

    Reference

    DicomDataSet Class
    DicomObjects Namespace


DicomObjects Namespace / DicomDataSet Class / Add Method

    Add Method (DicomDataSet)
    In This Topic
    Creates and adds data elements to DicomDataSet
    Overload List
    Overload | Description
Add(Int32,Int32,Object) | Creates and adds standard data elements to DicomDataSet
Add(DicomAttribute) | Add an existing attribute to the DataSet
Add(Keyword,Object) | Creates and adds standard data elements to DicomDataSet
Add(IEnumerable<DicomAttribute>) | Add a collection of DicomAttributes to the DataSet
Add(String,Object) | Creates and adds standard data elements to DicomDataSet
Add(Keyword,String,Object) | Creates and adds standard data elements to DicomDataSet
Add(Int32,Int32,String,Object) | Creates and adds standard data elements with specified VR to DicomDataSet
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / Add Method / Add(Int32,Int32,Object) Method

The group index of a data element.

The element index of a data element.

The Value to be assigned

In This Topic
    Add(Int32,Int32,Object) Method
    In This Topic
    Creates and adds standard data elements to DicomDataSet
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub Add( _
   ByVal Group As Integer, _
   ByVal Element As Integer, _
   ByVal Value As Object _
)
    'Usage

    Dim instance As DicomDataSet
Dim Group As Integer
Dim Element As Integer
Dim Value As Object

instance.Add(Group, Element, Value)
    public void Add(
   int Group,
   int Element,
   object Value
)

    Parameters

    Group

    The group index of a data element.

    Element

    The element index of a data element.

    Value

    The Value to be assigned

    Remarks

    This method is to add standard elements, VR of which will be determined by the internal dictionary. The type of value required for the "Value" parameter depends on the value representation of the data element, as defined by the values of group and element. Values of the types are always acceptable, as are values of other types that can be suitably coerced. Variants of type “null” are also accepted, resulting a zero-length data element, which can be useful in raw queries and for “type 2” elements. There are some special conditions relating to date and time types.

    To create a sequence, value may be a DicomDataSetCollection.

    If the data element being added has a potential value multiplicity (VM) of >1, then value may be either an array or scalar, but if the element’s VM is always 1, then an attempt to assign an array will generate an error.

    Any existing data element with the same group and element will be silently replaced, even if it is an array.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / Add Method / Add(DicomAttribute) Method
An existing DicomAttribute to add

    Add(DicomAttribute) Method
    In This Topic
    Add an existing attribute to the DataSet
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub Add( _
   ByVal attribute As DicomAttribute _
)
    'Usage

    Dim instance As DicomDataSet
Dim attribute As DicomAttribute

instance.Add(attribute)
    public void Add(
   DicomAttribute attribute
)

    Parameters

    attribute
    An existing DicomAttribute to add
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / Add Method / Add(Keyword,Object) Method

The DICOM Keyword of the data element.

The Value to be assigned

In This Topic
    Add(Keyword,Object) Method
    In This Topic
    Creates and adds standard data elements to DicomDataSet
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub Add( _
   ByVal Keyword As Keyword, _
   ByVal Value As Object _
)
    'Usage

    Dim instance As DicomDataSet
Dim Keyword As Keyword
Dim Value As Object

instance.Add(Keyword, Value)
    public void Add(
   Keyword Keyword,
   object Value
)

    Parameters

    Keyword

    The DICOM Keyword of the data element.

    Value

    The Value to be assigned

    Remarks

    This method is to add standard elements, VR of which will be determined by the internal dictionary. The type of value required for the "Value" parameter depends on the value representation of the data element, as defined by the values of group and element. Values of the types are always acceptable, as are values of other types that can be suitably coerced. Variants of type �null� are also accepted, resulting a zero-length data element, which can be useful in raw queries and for �type 2� elements. There are some special conditions relating to date and time types.

    To create a sequence, value may be a DicomDataSetCollection.

    If the data element being added has a potential value multiplicity (VM) of >1, then value may be either an array or scalar, but if the element�s VM is always 1, then an attempt to assign an array will generate an error.

    Any existing data element with the same group and element will be silently replaced, even if it is an array.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / Add Method / Add(IEnumerable<DicomAttribute>) Method
A list of DicomAttribute to add

    Add(IEnumerable<DicomAttribute>) Method
    In This Topic
    Add a collection of DicomAttributes to the DataSet
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub Add( _
   ByVal attributes As IEnumerable(Of DicomAttribute) _
)
    'Usage

    Dim instance As DicomDataSet
Dim attributes As IEnumerable(Of DicomAttribute)

instance.Add(attributes)
    public void Add(
   IEnumerable<DicomAttribute> attributes
)

    Parameters

    attributes
    A list of DicomAttribute to add
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / Add Method / Add(String,Object) Method

The DICOM Keyword of the data element.

The Value to be assigned

In This Topic
    Add(String,Object) Method
    In This Topic
    Creates and adds standard data elements to DicomDataSet
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub Add( _
   ByVal Keyword As String, _
   ByVal Value As Object _
)
    'Usage

    Dim instance As DicomDataSet
Dim Keyword As String
Dim Value As Object

instance.Add(Keyword, Value)
    public void Add(
   string Keyword,
   object Value
)

    Parameters

    Keyword

    The DICOM Keyword of the data element.

    Value

    The Value to be assigned

    Remarks

    This method is to add standard elements, VR of which will be determined by the internal dictionary. The type of value required for the "Value" parameter depends on the value representation of the data element, as defined by the values of group and element. Values of the types are always acceptable, as are values of other types that can be suitably coerced. Variants of type �null� are also accepted, resulting a zero-length data element, which can be useful in raw queries and for �type 2� elements. There are some special conditions relating to date and time types.

    To create a sequence, value may be a DicomDataSetCollection.

    If the data element being added has a potential value multiplicity (VM) of >1, then value may be either an array or scalar, but if the element�s VM is always 1, then an attempt to assign an array will generate an error.

    Any existing data element with the same group and element will be silently replaced, even if it is an array.

    Although this method, taking a string as the keyword is available, where possible the aternative overload, taking an Enums.Keyword is preferable.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / Add Method / Add(Keyword,String,Object) Method

The DICOM Keyword of the data element.

The value representation (2 character string) of the data element to be added

The Value to be assigned

In This Topic
    Add(Keyword,String,Object) Method
    In This Topic
    Creates and adds standard data elements to DicomDataSet
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub Add( _
   ByVal Keyword As Keyword, _
   ByVal VR As String, _
   ByVal Value As Object _
)
    'Usage

    Dim instance As DicomDataSet
Dim Keyword As Keyword
Dim VR As String
Dim Value As Object

instance.Add(Keyword, VR, Value)
    public void Add(
   Keyword Keyword,
   string VR,
   object Value
)

    Parameters

    Keyword

    The DICOM Keyword of the data element.

    VR

    The value representation (2 character string) of the data element to be added

    Value

    The Value to be assigned

    Remarks

    This method is to add standard elements, VR of which will be determined by the internal dictionary. The type of value required for the "Value" parameter depends on the value representation of the data element, as defined by the values of group and element. Values of the types are always acceptable, as are values of other types that can be suitably coerced. Variants of type �null� are also accepted, resulting a zero-length data element, which can be useful in raw queries and for �type 2� elements. There are some special conditions relating to date and time types.

    To create a sequence, value may be a DicomDataSetCollection.

    If the data element being added has a potential value multiplicity (VM) of >1, then value may be either an array or scalar, but if the element�s VM is always 1, then an attempt to assign an array will generate an error.

    Any existing data element with the same group and element will be silently replaced, even if it is an array.

    Although this method, taking a string as the keyword is available, where possible the aternative overload, taking an Enums.Keyword is preferable.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / Add Method / Add(Int32,Int32,String,Object) Method

The group index of a data element.

The element index of a data element.

The value representation (2 character string) of the data element to be added

The Value to be assigned

In This Topic
    Add(Int32,Int32,String,Object) Method
    In This Topic
    Creates and adds standard data elements with specified VR to DicomDataSet
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub Add( _
   ByVal Group As Integer, _
   ByVal Element As Integer, _
   ByVal VR As String, _
   ByVal Value As Object _
)
    'Usage

    Dim instance As DicomDataSet
Dim Group As Integer
Dim Element As Integer
Dim VR As String
Dim Value As Object

instance.Add(Group, Element, VR, Value)
    public void Add(
   int Group,
   int Element,
   string VR,
   object Value
)

    Parameters

    Group

    The group index of a data element.

    Element

    The element index of a data element.

    VR

    The value representation (2 character string) of the data element to be added

    Value

    The Value to be assigned

    Remarks

    This method is to explicitly add elements with specified VR. The type of value required for the "Value" parameter depends on the value representation of the data element, as defined by either by the VR parameter. Values of the types are always acceptable, as are values of other types that can be suitably coerced. Variants of type "null" are also accepted, resulting a zero-length data element, which can be useful in raw queries and for �type 2� elements. There are some special conditions relating to date and time types.

    To create a sequence, value may be a DicomDataSetCollection.

    If the data element being added has a potential value multiplicity (VM) of >1, then value may be either an array or scalar, but if the element�s VM is always 1, then an attempt to assign an array will generate an error.

    Any existing data element with the same group and element will be silently replaced, even if it is an array.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / AddByReference Method

    AddByReference Method (DicomDataSet)
    In This Topic
    Add byte[] as attribute value to avoid copying large data
    Overload List
    Overload | Description
AddByReference(Keyword,Byte[]) | Add byte[] as attribute value to avoid copying large data
AddByReference(Keyword,String,Byte[]) | Add byte[] as attribute value to avoid copying large data
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / AddByReference Method / AddByReference(Keyword,Byte[]) Method
Attribute tag to add
Attribute value as byte array

In This Topic
    AddByReference(Keyword,Byte[]) Method
    In This Topic
    Add byte[] as attribute value to avoid copying large data
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub AddByReference( _
   ByVal keyword As Keyword, _
   ByVal Value() As Byte _
)
    'Usage

    Dim instance As DicomDataSet
Dim keyword As Keyword
Dim Value() As Byte

instance.AddByReference(keyword, Value)
    public void AddByReference(
   Keyword keyword,
   byte[] Value
)

    Parameters

    keyword
    Attribute tag to add
    Value
    Attribute value as byte array
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / AddByReference Method / AddByReference(Keyword,String,Byte[]) Method
Attribute tag to add
Attribute VR to add
Attribute value as byte array

In This Topic
    AddByReference(Keyword,String,Byte[]) Method
    In This Topic
    Add byte[] as attribute value to avoid copying large data
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub AddByReference( _
   ByVal keyword As Keyword, _
   ByVal VR As String, _
   ByVal Value() As Byte _
)
    'Usage

    Dim instance As DicomDataSet
Dim keyword As Keyword
Dim VR As String
Dim Value() As Byte

instance.AddByReference(keyword, VR, Value)
    public void AddByReference(
   Keyword keyword,
   string VR,
   byte[] Value
)

    Parameters

    keyword
    Attribute tag to add
    VR
    Attribute VR to add
    Value
    Attribute value as byte array
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / AddPixelData Method

The Byte Array to be added to the Pixel Attribute (7FE0, 0010) of the DataSet

Specifies the UID of the transfer syntax in which the data is coded. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see the entry.

In This Topic
    AddPixelData Method
    In This Topic
    Adds pixel data to DicomDataSet
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Sub AddPixelData( _
   ByVal Data As Object, _
   ByVal TransferSyntax As String _
)
    'Usage

    Dim instance As DicomDataSet
Dim Data As Object
Dim TransferSyntax As String

instance.AddPixelData(Data, TransferSyntax)
    public void AddPixelData(
   object Data,
   string TransferSyntax
)

    Parameters

    Data

    The Byte Array to be added to the Pixel Attribute (7FE0, 0010) of the DataSet

    TransferSyntax

    Specifies the UID of the transfer syntax in which the data is coded. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see the entry.

    Remarks
    This method overwrites the pixel data (if present) in the DicomDataSet object.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / AddToDirectory Method

    AddToDirectory Method
    Simplified DICOMDIR creation
    Overload List
    Overload | Description
AddToDirectory(DicomDataSet,String,String,Int16) | Simplified DICOMDIR creation with specified Image, Path, TransferSyntax and IconSize
AddToDirectory(DicomDataSet,String,String,Int16,QueryLevel) | Simplified DICOMDIR creation with specified Image, Path, TransferSyntax and IconSize
AddToDirectory(DicomDataSet,String,String) | Simplified DICOMDIR creation with specified Image, Path, TransferSyntax
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / AddToDirectory Method / AddToDirectory(DicomDataSet,String,String,Int16) Method

Image from which to extract demographics, and (optionally) create an icon

The path is relative to where the DICOMDIR is to be written, and must conform to ISO9660/DICOM rules, and therefore be composed to up to 6 elements, each no more than 8 characters, with no extensions, separated by backslashes.

The format with which the image is to be written to disk

The size of the icon image to be included in the DICOMDIR � use 0 for no icon

In This Topic
    AddToDirectory(DicomDataSet,String,String,Int16) Method
    In This Topic
    Simplified DICOMDIR creation with specified Image, Path, TransferSyntax and IconSize
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Function AddToDirectory( _
   ByVal dataSet As DicomDataSet, _
   ByVal Path As String, _
   ByVal TransferSyntax As String, _
   ByVal IconSize As Short _
) As DicomDataSetCollection
    'Usage

    Dim instance As DicomDataSet
Dim dataSet As DicomDataSet
Dim Path As String
Dim TransferSyntax As String
Dim IconSize As Short
Dim value As DicomDataSetCollection

value = instance.AddToDirectory(dataSet, Path, TransferSyntax, IconSize)
    public DicomDataSetCollection AddToDirectory(
   DicomDataSet dataSet,
   string Path,
   string TransferSyntax,
   short IconSize
)

    Parameters

    dataSet

    Image from which to extract demographics, and (optionally) create an icon

    Path

    The path is relative to where the DICOMDIR is to be written, and must conform to ISO9660/DICOM rules, and therefore be composed to up to 6 elements, each no more than 8 characters, with no extensions, separated by backslashes.

    TransferSyntax

    The format with which the image is to be written to disk

    IconSize

    The size of the icon image to be included in the DICOMDIR � use 0 for no icon

    Return Value

    DicomDataSetCollection
    Remarks

    This method makes the creation of DICOMDIR files much easier than previously. Simply create a new DicomDataSet object, then call this method for each image to be added to the file set. A full 4-level hierarchy is automatically created.

    Note that this method does not write the image file to disk, it merely adds demographics from it, and possibly an icon to the DICOMDIR DicomDataSet.

    The return value is a DicomDataSetCollection object containing 4 values, referencing the PATIENT, STUDY, SERIES and IMAGE Levels of the DICOMDIR, allowing optional attributes to be added if wished.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / AddToDirectory Method / AddToDirectory(DicomDataSet,String,String,Int16,QueryLevel) Method

Image from which to extract demographics, and (optionally) create an icon

The path is relative to where the DICOMDIR is to be written, and must conform to ISO9660/DICOM rules, and therefore be composed to up to 6 elements, each no more than 8 characters, with no extensions, separated by backslashes.

The format with which the image is to be written to disk

The size of the icon image to be included in the DICOMDIR � use 0 for no icon

Specify which level to add the Icon to.

In This Topic
    AddToDirectory(DicomDataSet,String,String,Int16,QueryLevel) Method
    In This Topic
    Simplified DICOMDIR creation with specified Image, Path, TransferSyntax and IconSize
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Function AddToDirectory( _
   ByVal dataSet As DicomDataSet, _
   ByVal Path As String, _
   ByVal TransferSyntax As String, _
   ByVal IconSize As Short, _
   ByVal Level As QueryLevel _
) As DicomDataSetCollection
    'Usage

    Dim instance As DicomDataSet
Dim dataSet As DicomDataSet
Dim Path As String
Dim TransferSyntax As String
Dim IconSize As Short
Dim Level As QueryLevel
Dim value As DicomDataSetCollection

value = instance.AddToDirectory(dataSet, Path, TransferSyntax, IconSize, Level)
    public DicomDataSetCollection AddToDirectory(
   DicomDataSet dataSet,
   string Path,
   string TransferSyntax,
   short IconSize,
   QueryLevel Level
)

    Parameters

    dataSet

    Image from which to extract demographics, and (optionally) create an icon

    Path

    The path is relative to where the DICOMDIR is to be written, and must conform to ISO9660/DICOM rules, and therefore be composed to up to 6 elements, each no more than 8 characters, with no extensions, separated by backslashes.

    TransferSyntax

    The format with which the image is to be written to disk

    IconSize

    The size of the icon image to be included in the DICOMDIR � use 0 for no icon

    Level

    Specify which level to add the Icon to.

    Return Value

    DicomDataSetCollection
    Remarks

    This method makes the creation of DICOMDIR files much easier than previously. Simply create a new DicomDataSet object, then call this method for each image to be added to the file set. A full 4-level hierarchy is automatically created.

    Note that this method does not write the image file to disk, it merely adds demographics from it, and possibly an icon to the DICOMDIR DicomDataSet.

    The return value is a DicomDataSetCollection object containing 4 values, referencing the PATIENT, STUDY, SERIES and IMAGE Levels of the DICOMDIR, allowing optional attributes to be added if wished.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / AddToDirectory Method / AddToDirectory(DicomDataSet,String,String) Method

Image from which to extract demographics, and (optionally) create an icon

The path is relative to where the DICOMDIR is to be written, and must conform to ISO9660/DICOM rules, and therefore be composed to up to 8 elements, each no more than 8 characters, with no extensions, separated by backslashes.

The format with which the image is to be written to disk

In This Topic
    AddToDirectory(DicomDataSet,String,String) Method
    In This Topic
    Simplified DICOMDIR creation with specified Image, Path, TransferSyntax
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Function AddToDirectory( _
   ByVal Image As DicomDataSet, _
   ByVal Path As String, _
   ByVal TransferSyntax As String _
) As DicomDataSetCollection
    'Usage

    Dim instance As DicomDataSet
Dim Image As DicomDataSet
Dim Path As String
Dim TransferSyntax As String
Dim value As DicomDataSetCollection

value = instance.AddToDirectory(Image, Path, TransferSyntax)
    public DicomDataSetCollection AddToDirectory(
   DicomDataSet Image,
   string Path,
   string TransferSyntax
)

    Parameters

    Image

    Image from which to extract demographics, and (optionally) create an icon

    Path

    The path is relative to where the DICOMDIR is to be written, and must conform to ISO9660/DICOM rules, and therefore be composed to up to 8 elements, each no more than 8 characters, with no extensions, separated by backslashes.

    TransferSyntax

    The format with which the image is to be written to disk

    Return Value

    DicomDataSetCollection
    Remarks

    This method makes the creation of DICOMDIR files much easier than previously. Simply create a new DicomDataSet object, then call this method for each image to be added to the file set. A full 4-level hierarchy is automatically created.

    Note that this method does not write the image file to disk, it merely adds demographics from it, and possibly an icon to the DICOMDIR DicomDataSet.

    The return value is a DicomDataSetCollection object containing 4 values, referencing the PATIENT, STUDY, SERIES and IMAGE Levels of the DICOMDIR, allowing optional attributes to be added if wished.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / ChangeCharacterSet Method
The new Specific Character Set value

    ChangeCharacterSet Method
    In This Topic
    Change the specific Character Set of a DICOM dataset. All applicable attributes will have its data re-encoded by the new character set
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Sub ChangeCharacterSet( _
   ByVal NewCharacterSet As String _
)
    'Usage

    Dim instance As DicomDataSet
Dim NewCharacterSet As String

instance.ChangeCharacterSet(NewCharacterSet)
    public void ChangeCharacterSet(
   string NewCharacterSet
)

    Parameters

    NewCharacterSet
    The new Specific Character Set value
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / ChangeToDecompressed Method

    ChangeToDecompressed Method (DicomDataSet)
    In This Topic
    Simulate the effect of writing out as a Decompressed Image
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Sub ChangeToDecompressed()
    'Usage

    Dim instance As DicomDataSet

instance.ChangeToDecompressed()
    public void ChangeToDecompressed()
    Remarks
    Unlike DecompressAll which is designed merely for performance improvement, this method permanently changes the data as if written out in an uncompressed transfer syntax and then read back. This might therefore change the Photometric interpretation etc. (e.g. from YBR_FULL_422 to RGB)
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / Clear Method

    Clear Method
    Clear the DicomDataSet data
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Sub Clear()
    'Usage

    Dim instance As DicomDataSet

instance.Clear()
    public void Clear()
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / ClearCaches Method

    ClearCaches Method (DicomDataSet)
    In This Topic
    Clears all internal cache for compressed and uncompressed pixel data
    Overload List
    Overload | Description
ClearCaches() | Clears the entire internal cache
ClearCaches(CacheTypes) | Clears the caches of the specified types
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / ClearCaches Method / ClearCaches() Method

    ClearCaches() Method
    Clears the entire internal cache
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub ClearCaches()
    'Usage

    Dim instance As DicomDataSet

instance.ClearCaches()
    public void ClearCaches()
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / ClearCaches Method / ClearCaches(CacheTypes) Method
The types of cached information to be cleared

    ClearCaches(CacheTypes) Method
    In This Topic
    Clears the caches of the specified types
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub ClearCaches( _
   ByVal Types As CacheTypes _
)
    'Usage

    Dim instance As DicomDataSet
Dim Types As CacheTypes

instance.ClearCaches(Types)
    public void ClearCaches(
   CacheTypes Types
)

    Parameters

    Types
    The types of cached information to be cleared
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / Clone Method

    Clone Method (DicomDataSet)
    In This Topic
    Returns a copy of the DicomDataSet
    Overload List
    Overload | Description
Clone(Boolean) | Returns a copy of the DicomDataSet
Clone() | Returns a copy of the DicomDataSet
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / Clone Method / Clone(Boolean) Method

If true then returns a Deep copy of the DicomDataSet.

If false, returns a Shallow copy.

In This Topic
    Clone(Boolean) Method
    In This Topic
    Returns a copy of the DicomDataSet
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Overridable Function Clone( _
   ByVal Deep As Boolean _
) As Object
    'Usage

    Dim instance As DicomDataSet
Dim Deep As Boolean
Dim value As Object

value = instance.Clone(Deep)
    public virtual object Clone(
   bool Deep
)

    Parameters

    Deep

    If true then returns a Deep copy of the DicomDataSet.

    If false, returns a Shallow copy.

    Return Value

    DicomDataSet
    Remarks

    This method makes either a Shallow Copy or a Deep Copy of the DicomDataSet, dependants on the Deep parameter.

    A shallow copy will only have the top level objects replicated, any referenced objects under the top level will be shared by the original DicomDataSet and the cloned copy.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / Clone Method / Clone() Method

    Clone() Method
    Returns a copy of the DicomDataSet
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Overridable Function Clone() As Object
    'Usage

    Dim instance As DicomDataSet
Dim value As Object

value = instance.Clone()
    public virtual object Clone()

    Return Value

    DicomDataSet
    Remarks

    This method makes a Shallow Copy of the DicomDataSet

    A shallow copy will only have the top level objects replicated, any referenced objects under the top level will be shared by the original DicomDataSet and the cloned copy.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / DecompressAll Method

    DecompressAll Method (DicomDataSet)
    In This Topic
    Causes all the frames of an image to be decompressed.
    Causes all the frames of an image to be decompressed into a byte array
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Sub DecompressAll()
    'Usage

    Dim instance As DicomDataSet

instance.DecompressAll()
    public void DecompressAll()
    Remarks

    The normal policy adopted by DicomObjects for the handling of compressed images is to decompress frames only when necessary, and to keep the decompressed versions only for as long as is necessary for display or transmission, thereby minimising image load times, and memory use. This behaviour is not, however, always appropriate, especially when cine sequences are shown, or where modifications need to be made to the image. When this method is called, all frames are decompressed and held in RAM, replacing the original compressed version, thereby greatly speeding subsequent display, though needing much more memory.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / Dispose Method

    Dispose Method (DicomDataSet)
    In This Topic
    Release the resources used by the DicomDataSet object
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overridable Sub Dispose()
    'Usage

    Dim instance As DicomDataSet

instance.Dispose()
    public virtual void Dispose()
    Remarks
    This method releases all resources used by the DicomDataSet object.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / FindAttribute Method
The sequence in a functional group that this attribute is part of
The item to be found
The frame number. This is only relevant if the item is found within the PerFrame functional groups sequence

In This Topic
    FindAttribute Method
    In This Topic
    Locate an attribute within either a top level dataset, or within one of the functional group macros
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Function FindAttribute( _
   ByVal Macro As Keyword, _
   ByVal Item As Keyword, _
   ByVal Frame As Integer _
) As DicomAttribute
    'Usage

    Dim instance As DicomDataSet
Dim Macro As Keyword
Dim Item As Keyword
Dim Frame As Integer
Dim value As DicomAttribute

value = instance.FindAttribute(Macro, Item, Frame)
    public DicomAttribute FindAttribute(
   Keyword Macro,
   Keyword Item,
   int Frame
)

    Parameters

    Macro
    The sequence in a functional group that this attribute is part of
    Item
    The item to be found
    Frame
    The frame number. This is only relevant if the item is found within the PerFrame functional groups sequence

    Return Value

    The requested DicomAttribute
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / ForEachAttribute Method
Delegate, which takes as a parameter, the path to each attribute.

In This Topic
    ForEachAttribute Method
    In This Topic
    Recursively perform an action on every attribute within the dataset
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Sub ForEachAttribute( _
   ByVal action As Action(Of SequencePath) _
)
    'Usage

    Dim instance As DicomDataSet
Dim action As Action(Of SequencePath)

instance.ForEachAttribute(action)
    public void ForEachAttribute(
   Action<SequencePath> action
)

    Parameters

    action
    Delegate, which takes as a parameter, the path to each attribute.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / FrameSubSet(IEnumerable<UInt32>) Method
Requested frame numbers

    FrameSubSet(IEnumerable<UInt32>) Method
    In This Topic
    Generates a new DicomDataSet as a subset of the current instance as described in supplement 119
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Function FrameSubSet( _
   ByVal Frames As IEnumerable(Of UInteger) _
) As DicomDataSet
    'Usage

    Dim instance As DicomDataSet
Dim Frames As IEnumerable(Of UInteger)
Dim value As DicomDataSet

value = instance.FrameSubSet(Frames)
    public DicomDataSet FrameSubSet(
   IEnumerable<uint> Frames
)

    Parameters

    Frames
    Requested frame numbers

    Return Value

    Subset DicomDataSet that includes the requested frames
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / FunctionalGroupDataSet Method

    FunctionalGroupDataSet Method
    Locate the required functional group within a DicomDataSet
    Overload List
    Overload | Description
FunctionalGroupDataSet(Int32,Int32,Int32) | Locate the required functional group within a DicomDataSet
FunctionalGroupDataSet(Keyword,Int32) | Locate the required functional group within a DicomDataSet
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / FunctionalGroupDataSet Method / FunctionalGroupDataSet(Int32,Int32,Int32) Method
The Group of the requested dataset
The Element of the requested dataset
The frame number to which the dataset should apply

In This Topic
    FunctionalGroupDataSet(Int32,Int32,Int32) Method
    In This Topic
    Locate the required functional group within a DicomDataSet
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Function FunctionalGroupDataSet( _
   ByVal FunctionalGroup As Integer, _
   ByVal FunctionalElement As Integer, _
   ByVal Frame As Integer _
) As DicomDataSet
    'Usage

    Dim instance As DicomDataSet
Dim FunctionalGroup As Integer
Dim FunctionalElement As Integer
Dim Frame As Integer
Dim value As DicomDataSet

value = instance.FunctionalGroupDataSet(FunctionalGroup, FunctionalElement, Frame)
    public DicomDataSet FunctionalGroupDataSet(
   int FunctionalGroup,
   int FunctionalElement,
   int Frame
)

    Parameters

    FunctionalGroup
    The Group of the requested dataset
    FunctionalElement
    The Element of the requested dataset
    Frame
    The frame number to which the dataset should apply

    Return Value

    The requested dataset
    Remarks
    The enhanced DICOM multi-frame objects (e.g. enhanced CT and MRI) allow many attributes to be held in functional group macros, which may be either:
    • The same for all frames - in the "Shared Functional Groups Sequence" (5200,9229)
    • Different for different frames - in the "Per-frame Functional Groups Sequence" (5200,9230)
    This method allows the designated dataset to be located, irrespective of which sequence it is in. Note that the Group and Element used to identify the functional group are independent of the Group and Element of individual attributes within that DataSet.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / FunctionalGroupDataSet Method / FunctionalGroupDataSet(Keyword,Int32) Method
The Keyword descriptor of the requested dataset
The frame number to which the dataset should apply

In This Topic
    FunctionalGroupDataSet(Keyword,Int32) Method
    In This Topic
    Locate the required functional group within a DicomDataSet
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Function FunctionalGroupDataSet( _
   ByVal Macro As Keyword, _
   ByVal Frame As Integer _
) As DicomDataSet
    'Usage

    Dim instance As DicomDataSet
Dim Macro As Keyword
Dim Frame As Integer
Dim value As DicomDataSet

value = instance.FunctionalGroupDataSet(Macro, Frame)
    public DicomDataSet FunctionalGroupDataSet(
   Keyword Macro,
   int Frame
)

    Parameters

    Macro
    The Keyword descriptor of the requested dataset
    Frame
    The frame number to which the dataset should apply

    Return Value

    The requested dataset
    Remarks
    The enhanced DICOM multi-frame objects (e.g. enhanced CT and MRI) allow many attributes to be held in functional group macros, which may be either:
    • The same for all frames - in the "Shared Functional Groups Sequence" (5200,9229)
    • Different for different frames - in the "Per-frame Functional Groups Sequence" (5200,9230)
    This method allows the designated dataset to be located, irrespective of which sequence it is in. Note that the Keyword used to identify the functional group is independent of the Keyword of individual attributes within that DataSet.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / FunctionalGroupOrRootLevelAttribute Method

    FunctionalGroupOrRootLevelAttribute Method
    Return the required DicomAttribute within a specified functional group within a DicomDataSet If DicomAttribute is not present in the specified DicomDataSet, it searches amongst the root level attributes
    Overload List
    Overload | Description
FunctionalGroupOrRootLevelAttribute(Keyword,Int32,Keyword) | Return the required DicomAttribute within a specified functional group within a DicomDataSet If DicomAttribute is not present in the specified DicomDataSet, it searches amongst the root level attributes
FunctionalGroupOrRootLevelAttribute(Int32,Int32,Int32,Int32,Int32) | Return the required DicomAttribute within a specified functional group within a DicomDataSet
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / FunctionalGroupOrRootLevelAttribute Method / FunctionalGroupOrRootLevelAttribute(Keyword,Int32,Keyword) Method
The keyword of the requested dataset
The frame number to which the dataset should apply
The keyword of the requested attribute within the dataset

In This Topic
    FunctionalGroupOrRootLevelAttribute(Keyword,Int32,Keyword) Method
    In This Topic
    Return the required DicomAttribute within a specified functional group within a DicomDataSet If DicomAttribute is not present in the specified DicomDataSet, it searches amongst the root level attributes
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Function FunctionalGroupOrRootLevelAttribute( _
   ByVal FunctionalAttribute As Keyword, _
   ByVal Frame As Integer, _
   ByVal keyword As Keyword _
) As DicomAttribute
    'Usage

    Dim instance As DicomDataSet
Dim FunctionalAttribute As Keyword
Dim Frame As Integer
Dim keyword As Keyword
Dim value As DicomAttribute

value = instance.FunctionalGroupOrRootLevelAttribute(FunctionalAttribute, Frame, keyword)
    public DicomAttribute FunctionalGroupOrRootLevelAttribute(
   Keyword FunctionalAttribute,
   int Frame,
   Keyword keyword
)

    Parameters

    FunctionalAttribute
    The keyword of the requested dataset
    Frame
    The frame number to which the dataset should apply
    keyword
    The keyword of the requested attribute within the dataset

    Return Value

    The requested DicomAttribute
    Remarks
    The enhanced DICOM multi-frame objects (e.g. enhanced CT and MRI) allow many attributes to be held in functional group macros, which may be either:
    • The same for all frames - in the "Shared Functional Groups Sequence" (5200,9229)
    • Different for different frames - in the "Per-frame Functional Groups Sequence" (5200,9230)
    This method allows an attribute to be retrieved from the chosen dataset, irrespective of which sequence it is in. Note that the DicomObjects.Enums.Keyword used to identify the functional group is independent of the DicomObjects.Enums.Keyword of individual attributes within that DataSet.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / FunctionalGroupOrRootLevelAttribute Method / FunctionalGroupOrRootLevelAttribute(Int32,Int32,Int32,Int32,Int32) Method
The Group of the requested dataset
The Element of the requested dataset
The frame number to which the dataset should apply
The Group number of the requested attribute within the dataset
The Element number of the requested attribute within the dataset

In This Topic
    FunctionalGroupOrRootLevelAttribute(Int32,Int32,Int32,Int32,Int32) Method
    In This Topic
    Return the required DicomAttribute within a specified functional group within a DicomDataSet
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Function FunctionalGroupOrRootLevelAttribute( _
   ByVal FunctionalGroup As Integer, _
   ByVal FunctionalElement As Integer, _
   ByVal Frame As Integer, _
   ByVal Group As Integer, _
   ByVal Element As Integer _
) As DicomAttribute
    'Usage

    Dim instance As DicomDataSet
Dim FunctionalGroup As Integer
Dim FunctionalElement As Integer
Dim Frame As Integer
Dim Group As Integer
Dim Element As Integer
Dim value As DicomAttribute

value = instance.FunctionalGroupOrRootLevelAttribute(FunctionalGroup, FunctionalElement, Frame, Group, Element)
    public DicomAttribute FunctionalGroupOrRootLevelAttribute(
   int FunctionalGroup,
   int FunctionalElement,
   int Frame,
   int Group,
   int Element
)

    Parameters

    FunctionalGroup
    The Group of the requested dataset
    FunctionalElement
    The Element of the requested dataset
    Frame
    The frame number to which the dataset should apply
    Group
    The Group number of the requested attribute within the dataset
    Element
    The Element number of the requested attribute within the dataset

    Return Value

    The requested DicomAttribute
    Remarks
    The enhanced DICOM multi-frame objects (e.g. enhanced CT and MRI) allow many attributes to be held in functional group macros, which may be either:
    • The same for all frames - in the "Shared Functional Groups Sequence" (5200,9229)
    • Different for different frames - in the "Per-frame Functional Groups Sequence" (5200,9230)
    This method allows an attribute to be retrieved from the chosen dataset, irrespective of which sequence it is in. Note that the Group and Element used to identify the functional group are independent of the Group and Element of individual attributes within that DataSet.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / GetCacheSize Method
Type of Cache of interest, default value is DicomObjects.Enums.CacheTypes.All

In This Topic
    GetCacheSize Method (DicomDataSet)
    In This Topic
    Get cache size used by DicomObjects for the image - useful to help decide when to call ClearCaches method
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Function GetCacheSize( _
   ByVal cacheType As CacheTypes _
) As Long
    'Usage

    Dim instance As DicomDataSet
Dim cacheType As CacheTypes
Dim value As Long

value = instance.GetCacheSize(cacheType)
    public long GetCacheSize(
   CacheTypes cacheType
)

    Parameters

    cacheType
    Type of Cache of interest, default value is DicomObjects.Enums.CacheTypes.All

    Return Value

    number of bytes cached by DicomObjects
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / GetMinAndMax Method

    GetMinAndMax Method (DicomDataSet)
    In This Topic
    Find the maximum and minimum pixel data values in the pixel data
    Overload List
    Overload | Description
GetMinAndMax(Single,Single,Single,Boolean) | Find the maximum and minimum pixel data values in the pixel data
GetMinAndMax(Single,Single,Single,Boolean,Boolean) | Find the maximum and minimum pixel data values in the pixel data
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / GetMinAndMax Method / GetMinAndMax(Single,Single,Single,Boolean) Method
The minimum value found
The maximum value found
Proportion of extreme values to ignore
Whether to apply scaling/modality lookup table transformation

In This Topic
    GetMinAndMax(Single,Single,Single,Boolean) Method
    In This Topic
    Find the maximum and minimum pixel data values in the pixel data
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub GetMinAndMax( _
   ByRef Min As Single, _
   ByRef Max As Single, _
   ByVal Centile As Single, _
   ByVal Scale As Boolean _
)
    'Usage

    Dim instance As DicomDataSet
Dim Min As Single
Dim Max As Single
Dim Centile As Single
Dim Scale As Boolean

instance.GetMinAndMax(Min, Max, Centile, Scale)
    public void GetMinAndMax(
   out float Min,
   out float Max,
   float Centile,
   bool Scale
)

    Parameters

    Min
    The minimum value found
    Max
    The maximum value found
    Centile
    Proportion of extreme values to ignore
    Scale
    Whether to apply scaling/modality lookup table transformation
    Remarks

    Pixel padding values are ignored

    If Scale is false, then the values returned are "raw" values before application of rescaling or modality lookup tables

    If Scale is true, then the values returned are transformed using the modality slope and intercept or modality lookup tables as appropriate to the image

    If it is necessray to use separate control for the 2 scaling methods, then the GetMinAndMax(Single,Single,Single,Boolean,Boolean) override may be used instead.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / GetMinAndMax Method / GetMinAndMax(Single,Single,Single,Boolean,Boolean) Method
The minimum value found
The maximum value found
Centile as Float
Whether to apply modality lookup table transformation
Whether to apply modality rescale slope and offset transformations

In This Topic
    GetMinAndMax(Single,Single,Single,Boolean,Boolean) Method
    In This Topic
    Find the maximum and minimum pixel data values in the pixel data
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub GetMinAndMax( _
   ByRef Min As Single, _
   ByRef Max As Single, _
   ByVal Centile As Single, _
   ByVal ScaleLUT As Boolean, _
   ByVal ScaleRescale As Boolean _
)
    'Usage

    Dim instance As DicomDataSet
Dim Min As Single
Dim Max As Single
Dim Centile As Single
Dim ScaleLUT As Boolean
Dim ScaleRescale As Boolean

instance.GetMinAndMax(Min, Max, Centile, ScaleLUT, ScaleRescale)
    public void GetMinAndMax(
   out float Min,
   out float Max,
   float Centile,
   bool ScaleLUT,
   bool ScaleRescale
)

    Parameters

    Min
    The minimum value found
    Max
    The maximum value found
    Centile
    Centile as Float
    ScaleLUT
    Whether to apply modality lookup table transformation
    ScaleRescale
    Whether to apply modality rescale slope and offset transformations
    Remarks

    Pixel padding values are ignored

    If ScaleLUT is false, then the values returned are "raw" values before application of rescaling or modality lookup tables

    If ScaleLUT is true, then the values returned are transformed using the modality slope and intercept or modality lookup tables as appropriate to the image

    If it is necessray to use separate control for the 2 scaling methods, then the GetMinAndMax(Single,Single,Single,Boolean,Boolean) override may be used instead.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / GetPixelStream Method
Requested pixel data for the frame

    GetPixelStream Method
    In This Topic
    Returns the raw pixel data as a Stream object for a specific frame
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Function GetPixelStream( _
   ByVal Frame As Integer _
) As Stream
    'Usage

    Dim instance As DicomDataSet
Dim Frame As Integer
Dim value As Stream

value = instance.GetPixelStream(Frame)
    public Stream GetPixelStream(
   int Frame
)

    Parameters

    Frame
    Requested pixel data for the frame

    Return Value

    PixelData of the specified frame or null if it is uncompressed data or it encounters any failure during conversion
    Remarks
    Specify requested frame as 1 for MPEG data (mpeg 1,2,4) as they are defined/handled as 1 frame in DICOM
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / GetRawFrame Method
Frame number to extract
Cache result for the extracted frame

In This Topic
    GetRawFrame Method (DicomDataSet)
    In This Topic
    Extract individual frame from the pixel data
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Function GetRawFrame( _
   ByVal Frame As Integer, _
   ByVal cache As Boolean _
) As Byte()
    'Usage

    Dim instance As DicomDataSet
Dim Frame As Integer
Dim cache As Boolean
Dim value() As Byte

value = instance.GetRawFrame(Frame, cache)
    public byte[] GetRawFrame(
   int Frame,
   bool cache
)

    Parameters

    Frame
    Frame number to extract
    cache
    Cache result for the extracted frame

    Return Value

    Raw pixel data of the request frame
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / ImportPixelData Method
The data fragments
The transfer synatax corresponding to the data

In This Topic
    ImportPixelData Method
    In This Topic
    Direct import of compressed pixel data
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Sub ImportPixelData( _
   ByVal CompressedData As IEnumerable(Of Byte()), _
   ByVal TransferSyntax As String _
)
    'Usage

    Dim instance As DicomDataSet
Dim CompressedData As IEnumerable(Of Byte())
Dim TransferSyntax As String

instance.ImportPixelData(CompressedData, TransferSyntax)
    public void ImportPixelData(
   IEnumerable<byte[]> CompressedData,
   string TransferSyntax
)

    Parameters

    CompressedData
    The data fragments
    TransferSyntax
    The transfer synatax corresponding to the data
    Remarks

    This is an advanced technique, as no validation or data extraction is performed by DicomObjects, so those using it are responsible for setting all related attributes directly, including:

    • Rows and columns
    • Photometric Interpretation
    • Frame Count
    • The bit depth values (0028,0100-0028,0103)

    For MPEG, there must only be one fragment, covering all frames. For other transfer syntaxes, there is normally one fragment per frame.

    This method should not normally be used to import JPEG images, as most "normal" JPEG images have a JFIF header which is not permitted in DICOM - use the DicomImage.Import method instead.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / IsPresentationStateFor Method

    IsPresentationStateFor Method
    Indicates if the PresentationState is for the specified DicomImage
    Overload List
    Overload | Description
IsPresentationStateFor(DicomDataSet) | Indicates if the PresentationState is for the specified DicomImage
IsPresentationStateFor(DicomDataSet,Int32) | Indicates if the PresentationState is for the specified DicomImage
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / IsPresentationStateFor Method / IsPresentationStateFor(DicomDataSet) Method

The DicomImage to check for its InstanceUID

    IsPresentationStateFor(DicomDataSet) Method
    In This Topic
    Indicates if the PresentationState is for the specified DicomImage
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Function IsPresentationStateFor( _
   ByVal dicomDataSet As DicomDataSet _
) As Boolean
    'Usage

    Dim instance As DicomDataSet
Dim dicomDataSet As DicomDataSet
Dim value As Boolean

value = instance.IsPresentationStateFor(dicomDataSet)
    public bool IsPresentationStateFor(
   DicomDataSet dicomDataSet
)

    Parameters

    dicomDataSet

    The DicomImage to check for its InstanceUID

    Return Value

    true if the presentation state matches the image
    Remarks
    The Image's InstanceUID is checked against the value specified in the PresentationState's referenced Image SOP Instance UID field. This method returns true if the two values match, otherwise it returns false.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / IsPresentationStateFor Method / IsPresentationStateFor(DicomDataSet,Int32) Method

The DicomImage to check for its InstanceUID

Specify which frame to check

In This Topic
    IsPresentationStateFor(DicomDataSet,Int32) Method
    In This Topic
    Indicates if the PresentationState is for the specified DicomImage
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Function IsPresentationStateFor( _
   ByVal dicomDataSet As DicomDataSet, _
   ByVal Frame As Integer _
) As Boolean
    'Usage

    Dim instance As DicomDataSet
Dim dicomDataSet As DicomDataSet
Dim Frame As Integer
Dim value As Boolean

value = instance.IsPresentationStateFor(dicomDataSet, Frame)
    public bool IsPresentationStateFor(
   DicomDataSet dicomDataSet,
   int Frame
)

    Parameters

    dicomDataSet

    The DicomImage to check for its InstanceUID

    Frame

    Specify which frame to check

    Return Value

    true if the presentation state matches the image
    Remarks
    The Image's InstanceUID is checked against the value specified in the PresentationState's referenced Image SOP Instance UID field. The frame number is also checked against the values specified in the PresentationState. This method returns true if the the values match, otherwise it returns false.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / MergeBulkData Method
A method which, when passed a URI, returns the associated byte array
If true, then an exception is thrown if any items cannot be found

In This Topic
    MergeBulkData Method
    In This Topic
    Load Bulk data for all attributes, getting data from a method, based on the URI
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Sub MergeBulkData( _
   ByVal GetData As Func(Of Uri,String,HttpContent), _
   ByVal RequireBulkData As Boolean _
)
    'Usage

    Dim instance As DicomDataSet
Dim GetData As Func(Of Uri,String,HttpContent)
Dim RequireBulkData As Boolean

instance.MergeBulkData(GetData, RequireBulkData)
    public void MergeBulkData(
   Func<Uri,string,HttpContent> GetData,
   bool RequireBulkData
)

    Parameters

    GetData
    A method which, when passed a URI, returns the associated byte array
    RequireBulkData
    If true, then an exception is thrown if any items cannot be found
    Remarks
    This method is used to re-assemble data from STOW-RS etc., where some bulk data items have been sent as parts of a multipart message, and the GetData delegate points to a routine which finds the appropriate part of the message.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / OriginalPixelData Method
Frame number to extract
TransferSyntax of the compressed data

In This Topic
    OriginalPixelData Method
    In This Topic
    Method to extract Original pixel data as Array
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Function OriginalPixelData( _
   ByVal Frame As Integer, _
   ByRef TransferSyntax As String _
) As Array
    'Usage

    Dim instance As DicomDataSet
Dim Frame As Integer
Dim TransferSyntax As String
Dim value As Array

value = instance.OriginalPixelData(Frame, TransferSyntax)
    public Array OriginalPixelData(
   int Frame,
   out string TransferSyntax
)

    Parameters

    Frame
    Frame number to extract
    TransferSyntax
    TransferSyntax of the compressed data

    Return Value

    Original pixel data (Compressed or Uncompressed)
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / PixelValuesByFrameGeneric Method
The 1-based frame number to retrieve
Controls whether to apply the scale/offset or Modality LUT if present

In This Topic
    PixelValuesByFrameGeneric Method (DicomDataSet)
    In This Topic
    Returns an array of pixel values for a frame, optionally transformed via the modality transformation. Also accssible from
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Function PixelValuesByFrameGeneric( _
   ByVal frame As Integer, _
   ByVal modalityTransform As Boolean _
) As Array
    'Usage

    Dim instance As DicomDataSet
Dim frame As Integer
Dim modalityTransform As Boolean
Dim value As Array

value = instance.PixelValuesByFrameGeneric(frame, modalityTransform)
    public Array PixelValuesByFrameGeneric(
   int frame,
   bool modalityTransform
)

    Parameters

    frame
    The 1-based frame number to retrieve
    modalityTransform
    Controls whether to apply the scale/offset or Modality LUT if present

    Return Value

    Array of values representing the (possibly transformed) pixel values. Return type is a generic array as opposed to DicomImage.PixelValuesByFrame which returns a float[]
    Remarks
    Even if modalityTransform is false, the values are still masked to the relevant bit length and interpreted as sign/unsigned. This differs from DicomImage.RawPixelValuesByFrame.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / PrinterImage(Int32,Int32,Single,SKRectI,Boolean,Int32) Method

Bit depth of final image (must be 8-16, but always 8 when Planes=3)

1 for monochrome and 3 for colour

Zoom to apply to new image

The area of the original image to use

Controls whether Image Aspect Ratio is used - if true, then output pixels are square, but if false, then they retain their original aspect ratio

Choose which Frame of the MultiFrame Image to apply PrinterImage method

In This Topic
    PrinterImage(Int32,Int32,Single,SKRectI,Boolean,Int32) Method
    In This Topic
    Creates a copy of the image for printing or other purposes
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Function PrinterImage( _
   ByVal Bits As Integer, _
   ByVal Planes As Integer, _
   ByVal Zoom As Single, _
   ByVal Area As SkiaSharp.SKRectI, _
   ByVal SquarePixels As Boolean, _
   ByVal Frame As Integer _
) As DicomDataSet
    'Usage

    Dim instance As DicomDataSet
Dim Bits As Integer
Dim Planes As Integer
Dim Zoom As Single
Dim Area As SkiaSharp.SKRectI
Dim SquarePixels As Boolean
Dim Frame As Integer
Dim value As DicomDataSet

value = instance.PrinterImage(Bits, Planes, Zoom, Area, SquarePixels, Frame)
    public DicomDataSet PrinterImage(
   int Bits,
   int Planes,
   float Zoom,
   SkiaSharp.SKRectI Area,
   bool SquarePixels,
   int Frame
)

    Parameters

    Bits

    Bit depth of final image (must be 8-16, but always 8 when Planes=3)

    Planes

    1 for monochrome and 3 for colour

    Zoom

    Zoom to apply to new image

    Area

    The area of the original image to use

    SquarePixels

    Controls whether Image Aspect Ratio is used - if true, then output pixels are square, but if false, then they retain their original aspect ratio

    Frame

    Choose which Frame of the MultiFrame Image to apply PrinterImage method

    Return Value

    DicomImage
    Remarks
    The copy is fully rendered and scaled to the chosen bit depth, so no further windowing is required. Only 8 bits are allowed when Planes=3 (RGB). Area refers to the original image � the size of the final image is the product of the cropped size and the chosen zoom. If the edges are given as 0, the full image is used.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / Read Method

    Read Method (DicomDataSet)
    In This Topic
    Reads from a file, a system IO stream or a byte array
    Overload List
    Overload | Description
Read(Stream) | Reads from a standard Stream
Read(Stream,ReadBehaviours) | Reads from a standard Stream, with specific reading behaviour
Read(String) | Reads from an external DICOM file
Read(String,ReadBehaviours) | Reads from a DICOM file, using specific read behaviours
Read(Byte[],ReadBehaviours) | Reads from a byte array
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / Read Method / Read(Stream) Method

The Stream from which to read.

In This Topic
    Read(Stream) Method
    In This Topic
    Reads from a standard Stream
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub Read( _
   ByVal Stream As Stream _
)
    'Usage

    Dim instance As DicomDataSet
Dim Stream As Stream

instance.Read(Stream)
    public void Read(
   Stream Stream
)

    Parameters

    Stream

    The Stream from which to read.

    Remarks

    This method can read streams in either official "Part10" format, with the 128 byte header, or unofficial "Part5" format, without a header. Detection of the type is automatic.

    The stream may have been written by the Write method or by other DICOM software.

    It is the caller's responsibility to position the stream correctly before calling this method - no rewind is done internally.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / Read Method / Read(Stream,ReadBehaviours) Method

The Stream from which to read.

The behaviours to be used when reading this stream

In This Topic
    Read(Stream,ReadBehaviours) Method
    In This Topic
    Reads from a standard Stream, with specific reading behaviour
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub Read( _
   ByVal Stream As Stream, _
   ByVal Behaviour As ReadBehaviours _
)
    'Usage

    Dim instance As DicomDataSet
Dim Stream As Stream
Dim Behaviour As ReadBehaviours

instance.Read(Stream, Behaviour)
    public void Read(
   Stream Stream,
   ReadBehaviours Behaviour
)

    Parameters

    Stream

    The Stream from which to read.

    Behaviour

    The behaviours to be used when reading this stream

    Remarks

    This is a variation on the standard Read(Stream) method which allows control of specific behaviour (normally to cope with bugs in the recieved data) on an operation by operation bases.

    The stream may have been written by the Write method or by other DICOM software.

    It is the caller's responsibility to position the stream correctly before calling this method - no rewind is done internally.

    This in the only method to provide this additional Behaviour parameter, but all other Read opeations may be performed by creating a suitable stream from the file, byte[] etc., and using a null Password if necessary.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / Read Method / Read(String) Method

The name of the file to read.

This is passed unmodified to the operating system, and it is therefore the container’s responsibility to ensure either that the file exists within the current directory, or that a fully qualified filename is provided.

In This Topic
    Read(String) Method
    In This Topic
    Reads from an external DICOM file
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub Read( _
   ByVal FileName As String _
)
    'Usage

    Dim instance As DicomDataSet
Dim FileName As String

instance.Read(FileName)
    public void Read(
   string FileName
)

    Parameters

    FileName

    The name of the file to read.

    This is passed unmodified to the operating system, and it is therefore the container’s responsibility to ensure either that the file exists within the current directory, or that a fully qualified filename is provided.

    Remarks

    This method can read files in either official "Part10" format, with the 128 byte header, or unofficial "Part5" format, without a header. Detection of the type is automatic.

    The file may have been written by the Write method or by other DICOM software.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / Read Method / Read(String,ReadBehaviours) Method

The name of the file to read.

This is passed unmodified to the operating system, and it is therefore the container�s responsibility to ensure either that the file exists within the current directory, or that a fully qualified filename is provided.

The behaviours to be used when reading this stream

In This Topic
    Read(String,ReadBehaviours) Method
    In This Topic
    Reads from a DICOM file, using specific read behaviours
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub Read( _
   ByVal FileName As String, _
   Optional ByVal ReadBehaviour As ReadBehaviours _
)
    'Usage

    Dim instance As DicomDataSet
Dim FileName As String
Dim ReadBehaviour As ReadBehaviours

instance.Read(FileName, ReadBehaviour)
    public void Read(
   string FileName,
   ReadBehaviours ReadBehaviour
)

    Parameters

    FileName

    The name of the file to read.

    This is passed unmodified to the operating system, and it is therefore the container�s responsibility to ensure either that the file exists within the current directory, or that a fully qualified filename is provided.

    ReadBehaviour

    The behaviours to be used when reading this stream

    Remarks

    This method can read files in either official "Part10" format, with the 128 byte header, or unofficial "Part5" format, without a header. Detection of the type is automatic.

    The file may have been written by the Write method or by other DICOM software.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / Read Method / Read(Byte[],ReadBehaviours) Method

The byte array to read

The behaviours to be used when reading this stream

In This Topic
    Read(Byte[],ReadBehaviours) Method
    In This Topic
    Reads from a byte array
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub Read( _
   ByVal Array() As Byte, _
   Optional ByVal Behaviour As ReadBehaviours _
)
    'Usage

    Dim instance As DicomDataSet
Dim Array() As Byte
Dim Behaviour As ReadBehaviours

instance.Read(Array, Behaviour)
    public void Read(
   byte[] Array,
   ReadBehaviours Behaviour
)

    Parameters

    Array

    The byte array to read

    Behaviour

    The behaviours to be used when reading this stream

    Remarks
    Reads an array of bytes, which may have been written by the Write method.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / ReadJson Method
The Stream to read from

    ReadJson Method (DicomDataSet)
    In This Topic
    Read DICOM data from a Json Stream
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Sub ReadJson( _
   ByVal Stream As Stream _
)
    'Usage

    Dim instance As DicomDataSet
Dim Stream As Stream

instance.ReadJson(Stream)
    public void ReadJson(
   Stream Stream
)

    Parameters

    Stream
    The Stream to read from
    Remarks
    The Json data must be compliant with the Native DICOM Model outlined in the DICOM Part 19 (Application Hosting), with modifications as defined in supplement 163 to allow bulk data
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / ReadURL Method

The web address of the DataSet to read.

In This Topic
    ReadURL Method (DicomDataSet)
    In This Topic
    Reads DataSet from Web Address
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Sub ReadURL( _
   ByVal URL As String _
)
    'Usage

    Dim instance As DicomDataSet
Dim URL As String

instance.ReadURL(URL)
    public void ReadURL(
   string URL
)

    Parameters

    URL

    The web address of the DataSet to read.

    Remarks

    A valid web address should be provided by the user. This method does not support progressive downloading (JPIP support is to be implemented).

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / ReadXml Method
The Stream to read from
The transfer syntax to assign to the resulting instances - see remarks

In This Topic
    ReadXml Method
    In This Topic
    Read DICOM data from an XML Stream
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Sub ReadXml( _
   ByVal Stream As Stream, _
   Optional ByVal TransferSyntax As String _
)
    'Usage

    Dim instance As DicomDataSet
Dim Stream As Stream
Dim TransferSyntax As String

instance.ReadXml(Stream, TransferSyntax)
    public void ReadXml(
   Stream Stream,
   string TransferSyntax
)

    Parameters

    Stream
    The Stream to read from
    TransferSyntax
    The transfer syntax to assign to the resulting instances - see remarks
    Remarks

    The XML data must be compliant with the Native DICOM Model outlined in the DICOM Part 19 (Application Hosting), with modifications as defined in supplement 163 to allow bulk data

    The TransferSyntaxvalue does not directly affect the data itself, which is independent of transfer syntax, but the assigned value may be used internally to control the form in which are missing bulk data (e.g. pixel data) is requested fromn an origin server if replaced by a BulkDataUri property.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / Remove Method

    Remove Method (DicomDataSet)
    In This Topic
    Removes an attribute from the DataSet
    Overload List
    Overload | Description
Remove(Int32,Int32) | Removes an attribute from the DataSet
Remove(Keyword) | Removes an attribute from the DataSet
Remove(Predicate<DicomAttribute>) | Removes the attributes from the DataSet that match the selector
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / Remove Method / Remove(Int32,Int32) Method

The group index of a data element

The element index of a data element

In This Topic
    Remove(Int32,Int32) Method
    In This Topic
    Removes an attribute from the DataSet
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub Remove( _
   ByVal Group As Integer, _
   ByVal Element As Integer _
)
    'Usage

    Dim instance As DicomDataSet
Dim Group As Integer
Dim Element As Integer

instance.Remove(Group, Element)
    public void Remove(
   int Group,
   int Element
)

    Parameters

    Group

    The group index of a data element

    Element

    The element index of a data element

    Remarks

    If the appropriate data element exists in the DicomDataSet, it is removed.

    No error is generated if the requested item is not present in the DataSet.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / Remove Method / Remove(Keyword) Method
The attribute to be removed, specified as a Keyword

    Remove(Keyword) Method
    In This Topic
    Removes an attribute from the DataSet
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub Remove( _
   ByVal Keyword As Keyword _
)
    'Usage

    Dim instance As DicomDataSet
Dim Keyword As Keyword

instance.Remove(Keyword)
    public void Remove(
   Keyword Keyword
)

    Parameters

    Keyword
    The attribute to be removed, specified as a Keyword
    Remarks

    If the appropriate data element exists in the DicomDataSet, it is removed.

    No error is generated if the requested item is not present in the DataSet.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / Remove Method / Remove(Predicate<DicomAttribute>) Method
The predicate to match the attributes to be removed

    Remove(Predicate<DicomAttribute>) Method
    In This Topic
    Removes the attributes from the DataSet that match the selector
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub Remove( _
   ByVal selector As Predicate(Of DicomAttribute) _
)
    'Usage

    Dim instance As DicomDataSet
Dim selector As Predicate(Of DicomAttribute)

instance.Remove(selector)
    public void Remove(
   Predicate<DicomAttribute> selector
)

    Parameters

    selector
    The predicate to match the attributes to be removed
    Remarks

    If the appropriate data element exists in the DicomDataSet, it is removed.

    No error is generated if the requested item is not present in the DataSet.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / RemovePrivateAttributes Method
Remove top level private attributes only by default. When set to true, all private attributes within sequence and sub-sequences will be removed

In This Topic
    RemovePrivateAttributes Method
    In This Topic
    Remove private attributes
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Sub RemovePrivateAttributes( _
   Optional ByVal deep As Boolean _
)
    'Usage

    Dim instance As DicomDataSet
Dim deep As Boolean

instance.RemovePrivateAttributes(deep)
    public void RemovePrivateAttributes(
   bool deep
)

    Parameters

    deep
    Remove top level private attributes only by default. When set to true, all private attributes within sequence and sub-sequences will be removed
    Remarks
    This method removes all attributes with an odd group number
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / Send Method

    Send Method (DicomDataSet)
    In This Topic
    Sends a DicomDataSet to a remote DICOM application
    Overload List
    Overload | Description
Send(String,Int32,String,String) | Sends a DicomDataSet to a remote DICOM application
Send(String,Int32,String,String,IEnumerable<String>) | Sends a DicomDataSet to a remote DICOM application, with control over the set of transfer synatxes offered.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / Send Method / Send(String,Int32,String,String) Method

Network address (as dotted notation or resolvable name) to which the image is to be sent.

Port on which remote application is listening.

Name of remote Application Entity.

Name to quote for this Application Entity

In This Topic
    Send(String,Int32,String,String) Method
    In This Topic
    Sends a DicomDataSet to a remote DICOM application
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Function Send( _
   ByVal Node As String, _
   ByVal Port As Integer, _
   ByVal CallingAE As String, _
   ByVal CalledAE As String _
) As Integer
    'Usage

    Dim instance As DicomDataSet
Dim Node As String
Dim Port As Integer
Dim CallingAE As String
Dim CalledAE As String
Dim value As Integer

value = instance.Send(Node, Port, CallingAE, CalledAE)
    public int Send(
   string Node,
   int Port,
   string CallingAE,
   string CalledAE
)

    Parameters

    Node

    Network address (as dotted notation or resolvable name) to which the image is to be sent.

    Port

    Port on which remote application is listening.

    CallingAE

    Name of remote Application Entity.

    CalledAE

    Name to quote for this Application Entity

    Return Value

    The status as returned by the remote application. Zero indicates success.

    Remarks
    This method negotiates an association, sends one dataset over it, and then closes it. DICOM does not allow SCPs to draw any conclusion about the relationships between images based on the opening and closing of associations, so this should never be a problem (apart from slight network inefficiency). However, there are several badly written applications in the world, which incorrectly assume that the end of an association indicates the end of a series or a study etc., and if interfacing to such a faulty implementation, it is possible to send multiple images on one association by using DicomAssociation object, and its SendInstances methods.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / Send Method / Send(String,Int32,String,String,IEnumerable<String>) Method

Network address (as dotted notation or resolvable name) to which the image is to be sent.

Port on which remote application is listening.

Name of remote Application Entity.

Name to quote for this Application Entity

A list of offered Transfer Syntaxes

In This Topic
    Send(String,Int32,String,String,IEnumerable<String>) Method
    In This Topic
    Sends a DicomDataSet to a remote DICOM application, with control over the set of transfer synatxes offered.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Function Send( _
   ByVal Node As String, _
   ByVal Port As Integer, _
   ByVal CallingAE As String, _
   ByVal CalledAE As String, _
   ByVal OfferedTS As IEnumerable(Of String) _
) As Integer
    'Usage

    Dim instance As DicomDataSet
Dim Node As String
Dim Port As Integer
Dim CallingAE As String
Dim CalledAE As String
Dim OfferedTS As IEnumerable(Of String)
Dim value As Integer

value = instance.Send(Node, Port, CallingAE, CalledAE, OfferedTS)
    public int Send(
   string Node,
   int Port,
   string CallingAE,
   string CalledAE,
   IEnumerable<string> OfferedTS
)

    Parameters

    Node

    Network address (as dotted notation or resolvable name) to which the image is to be sent.

    Port

    Port on which remote application is listening.

    CallingAE

    Name of remote Application Entity.

    CalledAE

    Name to quote for this Application Entity

    OfferedTS

    A list of offered Transfer Syntaxes

    Return Value

    The status as returned by the remote application. Zero indicates success.

    Remarks
    This method negotiates an association, sends one dataset over it, and then closes it. DICOM does not allow SCPs to draw any conclusion about the relationships between images based on the opening and closing of associations, so this should never be a problem (apart from slight network inefficiency). However, there are several badly written applications in the world, which incorrectly assume that the end of an association indicates the end of a series or a study etc., and if interfacing to such a faulty implementation, it is possible to send multiple images on one association by using DicomAssociation object, and its SendInstances methods.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / SetDicomCodec Method
The transfer syntax of the data
The decompressor to use to access the frames etc.
The tream containing the data

In This Topic
    SetDicomCodec Method
    In This Topic
    Specify a "DICOM" codec
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Sub SetDicomCodec( _
   ByVal TS As UID, _
   ByVal dec As IDecompressor, _
   ByVal Stream As Stream _
)
    'Usage

    Dim instance As DicomDataSet
Dim TS As UID
Dim dec As IDecompressor
Dim Stream As Stream

instance.SetDicomCodec(TS, dec, Stream)
    public void SetDicomCodec(
   UID TS,
   IDecompressor dec,
   Stream Stream
)

    Parameters

    TS
    The transfer syntax of the data
    dec
    The decompressor to use to access the frames etc.
    Stream
    The tream containing the data
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / SetNonDicomCodec Method
An objects to provide the frames

    SetNonDicomCodec Method
    In This Topic
    Specify a non-DICOM source (e.g. AVI) as a source of frame data
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Sub SetNonDicomCodec( _
   ByVal source As IFrameSource _
)
    'Usage

    Dim instance As DicomDataSet
Dim source As IFrameSource

instance.SetNonDicomCodec(source)
    public void SetNonDicomCodec(
   IFrameSource source
)

    Parameters

    source
    An objects to provide the frames
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / SetPixelFile Method

The name of the external file

Input Transfer Syntax of the Pixel Data

The offset in the file of the start of the first frame

The offset in the file between the start of one frame, and the start of the next

In This Topic
    SetPixelFile Method (DicomDataSet)
    In This Topic
    Maps an external file as the pixel data
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Sub SetPixelFile( _
   ByVal FileName As String, _
   ByVal TransferSyntax As String, _
   ByVal InitialOffset As Long, _
   ByVal FrameOffset As Long _
)
    'Usage

    Dim instance As DicomDataSet
Dim FileName As String
Dim TransferSyntax As String
Dim InitialOffset As Long
Dim FrameOffset As Long

instance.SetPixelFile(FileName, TransferSyntax, InitialOffset, FrameOffset)
    public void SetPixelFile(
   string FileName,
   string TransferSyntax,
   long InitialOffset,
   long FrameOffset
)

    Parameters

    FileName

    The name of the external file

    TransferSyntax

    Input Transfer Syntax of the Pixel Data

    InitialOffset

    The offset in the file of the start of the first frame

    FrameOffset

    The offset in the file between the start of one frame, and the start of the next

    Remarks
    The PixelData attribute (7FE0, 0010) is set after calling this method and Pixel data is read from the specified external file only when image rendering is about to happen.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / SetPlanarConfiguration Method

The enumerated value to be set for planar configuration attribute (0028, 0006)

In This Topic
    SetPlanarConfiguration Method
    In This Topic
    Sets the planar configuration in DicomDataSet
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Sub SetPlanarConfiguration( _
   ByVal Value As Integer _
)
    'Usage

    Dim instance As DicomDataSet
Dim Value As Integer

instance.SetPlanarConfiguration(Value)
    public void SetPlanarConfiguration(
   int Value
)

    Parameters

    Value

    The enumerated value to be set for planar configuration attribute (0028, 0006)

    Remarks

    Planar Configuration indicates whether the color pixel data are sent color-by-color or color-by-pixel. This element shall be present if Samples per Pixel (0028, 0002) has a value greater than 1. It shall not be present otherwise.

    This method removes Planar Configuration (0028, 0006) from dataset if it has only 1 plane, otherwise it sets Planar Configuration to the value provided.

    Enumerated Values for Planar Configuration are:

    • 0 = The sample values for the first pixel are followed by the sample values for the second pixel, etc. For RGB images, this means the order of the pixel values sent shall be R1, G1, B1, R2, G2, B2, ..., etc.
    • 1 = Each color place shall be sent contiguously. For RGB images, this means the order of the pixel values sent is R1, R2, R3, ..., G1, G2, G3, ..., B1, B2, B3, etc.

    Planar Configuration is not meaningful when a compression transfer syntax is used that involves reorganization of sample components in the compressed bit stream. In such cases, since the data element is required to be sent, then an appropriate value to use may be specified, though in all likelihood the value will be ignored by the receiving implementation.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / SimplifyOverlays Method

    SimplifyOverlays Method
    Decompress the data, and move any overlays which are encoded with the pixel data (a method deprecated in DICOM many years ago) to stand-along overlay data in 60xx,3000.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Sub SimplifyOverlays()
    'Usage

    Dim instance As DicomDataSet

instance.SimplifyOverlays()
    public void SimplifyOverlays()
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / SubImage Method

The left top corner point of the sub Image

The total size of the original image to capture

The zooming factor which determines the output size

The frame number

The scaling mode to use

In This Topic
    SubImage Method (DicomDataSet)
    In This Topic
    Creates a copy of part or all of the image with controlled size
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Function SubImage( _
   ByVal Offset As SkiaSharp.SKPointI, _
   ByVal SKSizeI As SkiaSharp.SKSizeI, _
   ByVal Magnification As Single, _
   ByVal Frame As Integer, _
   Optional ByVal Scaling As ScaleMode _
) As DicomDataSet
    'Usage

    Dim instance As DicomDataSet
Dim Offset As SkiaSharp.SKPointI
Dim SKSizeI As SkiaSharp.SKSizeI
Dim Magnification As Single
Dim Frame As Integer
Dim Scaling As ScaleMode
Dim value As DicomDataSet

value = instance.SubImage(Offset, SKSizeI, Magnification, Frame, Scaling)
    public DicomDataSet SubImage(
   SkiaSharp.SKPointI Offset,
   SkiaSharp.SKSizeI SKSizeI,
   float Magnification,
   int Frame,
   ScaleMode Scaling
)

    Parameters

    Offset

    The left top corner point of the sub Image

    SKSizeI

    The total size of the original image to capture

    Magnification

    The zooming factor which determines the output size

    Frame

    The frame number

    Scaling

    The scaling mode to use

    Return Value

    A new DicomImage
    Remarks

    Makes a derived image (of same basic DICOM type as the original) scaled and cropped as required. SKSizeI refers to the final image size, whether or not it is transformed as below.

    The coordinate system used depends on the value of scaling. If ScaleMode.Image then the original image is used without rotation etc, but if ScaleMode.Output then the image is conceptually flipped, rotated etc. before applying the bounds.

    This overload is now recommended in place of the earlier version without the scaling mode which is retained for backwards compatibility only.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / Validate Method

    Validate Method
    Validate all DicomAttributes within the DicomDataset based on its ValidationOptions
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Sub Validate()
    'Usage

    Dim instance As DicomDataSet

instance.Validate()
    public void Validate()
    Remarks
    Throws a DicomObjects.Validation.ValidationException on the first invalid DicomAttribute
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / ValidateAll Method

    ValidateAll Method
    Validate all DicomAttributes within the DicomDataset based on its ValidationOptions
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Function ValidateAll() As List(Of ValidationException)
    'Usage

    Dim instance As DicomDataSet
Dim value As List(Of ValidationException)

value = instance.ValidateAll()
    public List<ValidationException> ValidateAll()

    Return Value

    A list of validation errors as DicomObjects.Validation.ValidationException objects
    Remarks
    If there are no errors, then an Empty list is returned
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / Value Method

    Value Method
    Returns the value of the specified Data Element
    Overload List
    Overload | Description
Value(Int32,Int32) | Returns the value of the specified Data Element
Value(Keyword) | Returns the value of the specified Data Element
Value(String) | Returns the value of the specified Data Element
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / Value Method / Value(Int32,Int32) Method

The group index of the specified Data Element

The element index of the specified Data Element

In This Topic
    Value(Int32,Int32) Method
    In This Topic
    Returns the value of the specified Data Element
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Function Value( _
   ByVal group As Integer, _
   ByVal element As Integer _
) As Object
    'Usage

    Dim instance As DicomDataSet
Dim group As Integer
Dim element As Integer
Dim value As Object

value = instance.Value(group, element)
    public object Value(
   int group,
   int element
)

    Parameters

    group

    The group index of the specified Data Element

    element

    The element index of the specified Data Element

    Return Value

    object
    Remarks

    The type of variant returned depends on the value representation of the data element, and may be a string, date (for time, date or date-time), or a numeric type, including floating point values where appropriate.

    Data elements of types not known to the program, whether private elements, or attributes recently defined by DICOM return the string " Unknown Data Type".

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / Value Method / Value(Keyword) Method

The keyword of the DicomAttribute

    Value(Keyword) Method
    In This Topic
    Returns the value of the specified Data Element
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Function Value( _
   ByVal Keyword As Keyword _
) As Object
    'Usage

    Dim instance As DicomDataSet
Dim Keyword As Keyword
Dim value As Object

value = instance.Value(Keyword)
    public object Value(
   Keyword Keyword
)

    Parameters

    Keyword

    The keyword of the DicomAttribute

    Return Value

    object
    Remarks

    The type of variant returned depends on the value representation of the data element, and may be a string, date (for time, date or date-time), or a numeric type, including floating point values where appropriate.

    Data elements of types not known to the program, whether private elements, or attributes recently defined by DICOM return the string " Unknown Data Type".

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / Value Method / Value(String) Method

The String Keyword of the DicomAttribute

    Value(String) Method
    In This Topic
    Returns the value of the specified Data Element
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Function Value( _
   ByVal Keyword As String _
) As Object
    'Usage

    Dim instance As DicomDataSet
Dim Keyword As String
Dim value As Object

value = instance.Value(Keyword)
    public object Value(
   string Keyword
)

    Parameters

    Keyword

    The String Keyword of the DicomAttribute

    Return Value

    object
    Remarks

    The type of variant returned depends on the value representation of the data element, and may be a string, date (for time, date or date-time), or a numeric type, including floating point values where appropriate.

    Data elements of types not known to the program, whether private elements, or attributes recently defined by DICOM return the string " Unknown Data Type".

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / Write Method

    Write Method (DicomDataSet)
    In This Topic
    Writes the dataset to an external DICOM file, a system IO stream or a byte array etc.
    Overload List
    Overload | Description
Write(String,String,Object) | Writes dataset to an external DICOM file with specified transfer syntax and quality factor
Write(String,String,Object,DicomDataSet) | Writes dataset to an external DICOM file with specified transfer syntax, quality factor and meta header
Write(String,String,Object,DicomDataSet,WriteBehaviours) | Writes dataset to an external DICOM file with specified transfer syntax, quality factor, meta header and behaviour overrides
Write(Stream,String,Object,DicomDataSet,WriteBehaviours) | Writes dataset to a stream with specified transfer syntax, quality factor, meta header and behaviour overrides
Write(String,Boolean) | Writes dataset to an external DICOM file
Write(String,String,DicomDataSet) | Writes dataset to an external DICOM file with specified transfer syntax and meta header
Write(String,String) | Writes dataset to an external DICOM file with specified transfer syntax
Write(String) | Writes dataset to an external DICOM file in the current TransferSyntax
Write(String,DicomDataSet) | Writes dataset to an external DICOM file with specified meta header
Write(Stream,String,Object) | Writes dataset to a system IO stream object with specified transfer syntax
Write(Stream,Boolean) | Writes dataset to a system IO stream object
Write(Stream,String) | Writes dataset to a system IO stream object with specified transfer syntax
Write(Stream,String,DicomDataSet) | Writes dataset to a system IO stream object with specified transfer syntax and meta header
Write(Stream) | Writes dataset to a system IO stream object
Write(Byte[],String,Object) | Writes dataset to a byte array with specified transfer syntax and quality factor
Write(Byte[],Boolean) | Writes dataset to a byte array
Write(Byte[],String) | Writes dataset to a byte array with specified transfer syntax
Write(Byte[]) | Writes the dataset to a byte array
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / Write Method / Write(String,String,Object) Method

The name of the file to write.

This is passed unmodified to the operating system, and it is therefore the container�s responsibility to ensure either that the current directory is set correctly, or that a fully qualified filename is provided.

Specifies the full UID of the transfer syntax with which the file is to be saved when Part 10 format is used. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see the entry.

The quality factor to be used.

In This Topic
    Write(String,String,Object) Method
    In This Topic
    Writes dataset to an external DICOM file with specified transfer syntax and quality factor
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub Write( _
   ByVal FileName As String, _
   ByVal TransferSyntax As String, _
   ByVal Quality As Object _
)
    'Usage

    Dim instance As DicomDataSet
Dim FileName As String
Dim TransferSyntax As String
Dim Quality As Object

instance.Write(FileName, TransferSyntax, Quality)
    public void Write(
   string FileName,
   string TransferSyntax,
   object Quality
)

    Parameters

    FileName

    The name of the file to write.

    This is passed unmodified to the operating system, and it is therefore the container�s responsibility to ensure either that the current directory is set correctly, or that a fully qualified filename is provided.

    TransferSyntax

    Specifies the full UID of the transfer syntax with which the file is to be saved when Part 10 format is used. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see the entry.

    Quality

    The quality factor to be used.

    Remarks

    The file may subsequently be read by the Read method or by other DICOM software.

    Quality is specific to the compression method being used, and is ignored for non-compressed or lossless JPEG transfer syntaxes. For Lossy JPEG, it is an integer in the range 1-100, the higher the number, the better the quality (and the larger the file), and for JPEG 2000 lossy, it is a compression ratio. Other compression methods may use this for other purposes in the future.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / Write Method / Write(String,String,Object,DicomDataSet) Method

The name of the file to write.

This is passed unmodified to the operating system, and it is therefore the container�s responsibility to ensure either that the current directory is set correctly, or that a fully qualified filename is provided.

Specifies the full UID of the transfer syntax with which the file is to be saved when Part 10 format is used. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see the entry.

The quality factor to be used.

The customized MetaHeader (only Group 2 Elements)

In This Topic
    Write(String,String,Object,DicomDataSet) Method
    In This Topic
    Writes dataset to an external DICOM file with specified transfer syntax, quality factor and meta header
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub Write( _
   ByVal FileName As String, _
   ByVal TransferSyntax As String, _
   ByVal Quality As Object, _
   ByVal MetaHeader As DicomDataSet _
)
    'Usage

    Dim instance As DicomDataSet
Dim FileName As String
Dim TransferSyntax As String
Dim Quality As Object
Dim MetaHeader As DicomDataSet

instance.Write(FileName, TransferSyntax, Quality, MetaHeader)
    public void Write(
   string FileName,
   string TransferSyntax,
   object Quality,
   DicomDataSet MetaHeader
)

    Parameters

    FileName

    The name of the file to write.

    This is passed unmodified to the operating system, and it is therefore the container�s responsibility to ensure either that the current directory is set correctly, or that a fully qualified filename is provided.

    TransferSyntax

    Specifies the full UID of the transfer syntax with which the file is to be saved when Part 10 format is used. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see the entry.

    Quality

    The quality factor to be used.

    MetaHeader

    The customized MetaHeader (only Group 2 Elements)

    Remarks

    The file may subsequently be read by the Read method or by other DICOM software.

    Quality is specific to the compression method being used, and is ignored for non-compressed or lossless JPEG transfer syntaxes. For Lossy JPEG, it is an integer in the range 1-100, the higher the number, the better the quality (and the larger the file), and for JPEG 2000 lossy, it is a compression ratio. Other compression methods may use this for other purposes in the future.

    The provided MetaHeader should only contain group 2 elements.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / Write Method / Write(String,String,Object,DicomDataSet,WriteBehaviours) Method

The name of the file to write.

This is passed unmodified to the operating system, and it is therefore the container�s responsibility to ensure either that the current directory is set correctly, or that a fully qualified filename is provided.

Specifies the full UID of the transfer syntax with which the file is to be saved when Part 10 format is used. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see the entry.

The quality factor to be used.

The customized MetaHeader (only Group 2 Elements)

Specific options to use when writing the data

In This Topic
    Write(String,String,Object,DicomDataSet,WriteBehaviours) Method
    In This Topic
    Writes dataset to an external DICOM file with specified transfer syntax, quality factor, meta header and behaviour overrides
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub Write( _
   ByVal FileName As String, _
   ByVal TransferSyntax As String, _
   ByVal Quality As Object, _
   ByVal MetaHeader As DicomDataSet, _
   ByVal Behaviour As WriteBehaviours _
)
    'Usage

    Dim instance As DicomDataSet
Dim FileName As String
Dim TransferSyntax As String
Dim Quality As Object
Dim MetaHeader As DicomDataSet
Dim Behaviour As WriteBehaviours

instance.Write(FileName, TransferSyntax, Quality, MetaHeader, Behaviour)
    public void Write(
   string FileName,
   string TransferSyntax,
   object Quality,
   DicomDataSet MetaHeader,
   WriteBehaviours Behaviour
)

    Parameters

    FileName

    The name of the file to write.

    This is passed unmodified to the operating system, and it is therefore the container�s responsibility to ensure either that the current directory is set correctly, or that a fully qualified filename is provided.

    TransferSyntax

    Specifies the full UID of the transfer syntax with which the file is to be saved when Part 10 format is used. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see the entry.

    Quality

    The quality factor to be used.

    MetaHeader

    The customized MetaHeader (only Group 2 Elements)

    Behaviour

    Specific options to use when writing the data

    Remarks

    The file may subsequently be read by the Read method or by other DICOM software.

    Quality is specific to the compression method being used, and is ignored for non-compressed or lossless JPEG transfer syntaxes. For Lossy JPEG, it is an integer in the range 1-100, the higher the number, the better the quality (and the larger the file), and for JPEG 2000 lossy, it is a compression ratio. Other compression methods may use this for other purposes in the future.

    The provided MetaHeader should only contain group 2 elements.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / Write Method / Write(Stream,String,Object,DicomDataSet,WriteBehaviours) Method

The Stream to which to write.

Specifies the full UID of the transfer syntax with which the file is to be saved when Part 10 format is used. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see the entry.

The quality factor to be used.

The customized MetaHeader (only Group 2 Elements)

Specific options to use when writing the data

In This Topic
    Write(Stream,String,Object,DicomDataSet,WriteBehaviours) Method
    In This Topic
    Writes dataset to a stream with specified transfer syntax, quality factor, meta header and behaviour overrides
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub Write( _
   ByVal Stream As Stream, _
   ByVal TransferSyntax As String, _
   ByVal Quality As Object, _
   ByVal MetaHeader As DicomDataSet, _
   ByVal Behaviour As WriteBehaviours _
)
    'Usage

    Dim instance As DicomDataSet
Dim Stream As Stream
Dim TransferSyntax As String
Dim Quality As Object
Dim MetaHeader As DicomDataSet
Dim Behaviour As WriteBehaviours

instance.Write(Stream, TransferSyntax, Quality, MetaHeader, Behaviour)
    public void Write(
   Stream Stream,
   string TransferSyntax,
   object Quality,
   DicomDataSet MetaHeader,
   WriteBehaviours Behaviour
)

    Parameters

    Stream

    The Stream to which to write.

    TransferSyntax

    Specifies the full UID of the transfer syntax with which the file is to be saved when Part 10 format is used. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see the entry.

    Quality

    The quality factor to be used.

    MetaHeader

    The customized MetaHeader (only Group 2 Elements)

    Behaviour

    Specific options to use when writing the data

    Remarks

    The file may subsequently be read by the Read method or by other DICOM software.

    Quality is specific to the compression method being used, and is ignored for non-compressed or lossless JPEG transfer syntaxes. For Lossy JPEG, it is an integer in the range 1-100, the higher the number, the better the quality (and the larger the file), and for JPEG 2000 lossy, it is a compression ratio. Other compression methods may use this for other purposes in the future.

    The provided MetaHeader should only contain group 2 elements.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / Write Method / Write(String,Boolean) Method

The name of the file to write.

This is passed unmodified to the operating system, and it is therefore the container�s responsibility to ensure either that the current directory is set correctly, or that a fully qualified filename is provided.

If TRUE, a blank 128 byte header, DICM marker, and meta-header are written at the start of the file, and an appropriate transfer syntax is used, as below.

If FALSE, the file is written in the unofficial, but common format, with no header, and using the little-endian implicit VR transfer syntax.

In This Topic
    Write(String,Boolean) Method
    In This Topic
    Writes dataset to an external DICOM file
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub Write( _
   ByVal FileName As String, _
   ByVal isPart10 As Boolean _
)
    'Usage

    Dim instance As DicomDataSet
Dim FileName As String
Dim isPart10 As Boolean

instance.Write(FileName, isPart10)
    public void Write(
   string FileName,
   bool isPart10
)

    Parameters

    FileName

    The name of the file to write.

    This is passed unmodified to the operating system, and it is therefore the container�s responsibility to ensure either that the current directory is set correctly, or that a fully qualified filename is provided.

    isPart10

    If TRUE, a blank 128 byte header, DICM marker, and meta-header are written at the start of the file, and an appropriate transfer syntax is used, as below.

    If FALSE, the file is written in the unofficial, but common format, with no header, and using the little-endian implicit VR transfer syntax.

    Remarks

    The file may subsequently be read by the Read method or by other DICOM software.

    Quality is specific to the compression method being used, and is ignored for non-compressed or lossless JPEG transfer syntaxes. For Lossy JPEG, it is an integer in the range 1-100, the higher the number, the better the quality (and the larger the file), and for JPEG 2000 lossy, it is a compression ratio. Other compression methods may use this for other purposes in the future.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / Write Method / Write(String,String,DicomDataSet) Method

The name of the file to write.

This is passed unmodified to the operating system, and it is therefore the container�s responsibility to ensure either that the current directory is set correctly, or that a fully qualified filename is provided.

Specifies the full UID of the transfer syntax with which the file is to be saved when Part 10 format is used. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see the entry.

The customized MetaHeader (only Group 2 Elements)

In This Topic
    Write(String,String,DicomDataSet) Method
    In This Topic
    Writes dataset to an external DICOM file with specified transfer syntax and meta header
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub Write( _
   ByVal FileName As String, _
   ByVal TransferSyntax As String, _
   ByVal MetaHeader As DicomDataSet _
)
    'Usage

    Dim instance As DicomDataSet
Dim FileName As String
Dim TransferSyntax As String
Dim MetaHeader As DicomDataSet

instance.Write(FileName, TransferSyntax, MetaHeader)
    public void Write(
   string FileName,
   string TransferSyntax,
   DicomDataSet MetaHeader
)

    Parameters

    FileName

    The name of the file to write.

    This is passed unmodified to the operating system, and it is therefore the container�s responsibility to ensure either that the current directory is set correctly, or that a fully qualified filename is provided.

    TransferSyntax

    Specifies the full UID of the transfer syntax with which the file is to be saved when Part 10 format is used. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see the entry.

    MetaHeader

    The customized MetaHeader (only Group 2 Elements)

    Remarks

    The file may subsequently be read by the Read method or by other DICOM software.

    The provided meta header should only contain group 2 elements.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / Write Method / Write(String,String) Method

The name of the file to write.

This is passed unmodified to the operating system, and it is therefore the container�s responsibility to ensure either that the current directory is set correctly, or that a fully qualified filename is provided.

Specifies the full UID of the transfer syntax with which the file is to be saved when Part 10 format is used. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see the entry.

In This Topic
    Write(String,String) Method
    In This Topic
    Writes dataset to an external DICOM file with specified transfer syntax
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub Write( _
   ByVal FileName As String, _
   ByVal TransferSyntax As String _
)
    'Usage

    Dim instance As DicomDataSet
Dim FileName As String
Dim TransferSyntax As String

instance.Write(FileName, TransferSyntax)
    public void Write(
   string FileName,
   string TransferSyntax
)

    Parameters

    FileName

    The name of the file to write.

    This is passed unmodified to the operating system, and it is therefore the container�s responsibility to ensure either that the current directory is set correctly, or that a fully qualified filename is provided.

    TransferSyntax

    Specifies the full UID of the transfer syntax with which the file is to be saved when Part 10 format is used. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see the entry.

    Remarks

    The file may subsequently be read by the Read method or by other DICOM software.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / Write Method / Write(String) Method

The name of the file to write.

This is passed unmodified to the operating system, and it is therefore the container�s responsibility to ensure either that the current directory is set correctly, or that a fully qualified filename is provided.

In This Topic
    Write(String) Method
    In This Topic
    Writes dataset to an external DICOM file in the current TransferSyntax
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub Write( _
   ByVal fileName As String _
)
    'Usage

    Dim instance As DicomDataSet
Dim fileName As String

instance.Write(fileName)
    public void Write(
   string fileName
)

    Parameters

    fileName

    The name of the file to write.

    This is passed unmodified to the operating system, and it is therefore the container�s responsibility to ensure either that the current directory is set correctly, or that a fully qualified filename is provided.

    Remarks

    The file may subsequently be read by the Read method or by other DICOM software.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / Write Method / Write(String,DicomDataSet) Method

The name of the file to write.

This is passed unmodified to the operating system, and it is therefore the container�s responsibility to ensure either that the current directory is set correctly, or that a fully qualified filename is provided.

The customized MetaHeader (only Group 2 Elements)

In This Topic
    Write(String,DicomDataSet) Method
    In This Topic
    Writes dataset to an external DICOM file with specified meta header
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub Write( _
   ByVal FileName As String, _
   ByVal MetaHeader As DicomDataSet _
)
    'Usage

    Dim instance As DicomDataSet
Dim FileName As String
Dim MetaHeader As DicomDataSet

instance.Write(FileName, MetaHeader)
    public void Write(
   string FileName,
   DicomDataSet MetaHeader
)

    Parameters

    FileName

    The name of the file to write.

    This is passed unmodified to the operating system, and it is therefore the container�s responsibility to ensure either that the current directory is set correctly, or that a fully qualified filename is provided.

    MetaHeader

    The customized MetaHeader (only Group 2 Elements)

    Remarks

    The file may subsequently be read by the Read method or by other DICOM software.

    The provided meta header should only contain group 2 elements.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / Write Method / Write(Stream,String,Object) Method

The Stream from which to read.

Specifies the full UID of the transfer syntax with which the data is to be saved when Part 10 format is used. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see the entry.

The quality factor to be used.

In This Topic
    Write(Stream,String,Object) Method
    In This Topic
    Writes dataset to a system IO stream object with specified transfer syntax
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub Write( _
   ByVal Stream As Stream, _
   ByVal TransferSyntax As String, _
   ByVal Quality As Object _
)
    'Usage

    Dim instance As DicomDataSet
Dim Stream As Stream
Dim TransferSyntax As String
Dim Quality As Object

instance.Write(Stream, TransferSyntax, Quality)
    public void Write(
   Stream Stream,
   string TransferSyntax,
   object Quality
)

    Parameters

    Stream

    The Stream from which to read.

    TransferSyntax

    Specifies the full UID of the transfer syntax with which the data is to be saved when Part 10 format is used. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see the entry.

    Quality

    The quality factor to be used.

    Remarks

    The stream may subsequently be read by the Read method or by other DICOM software.

    Quality is specific to the compression method being used, and is ignored for non-compressed or lossless JPEG transfer syntaxes. For Lossy JPEG, it is an integer in the range 1-100, the higher the number, the better the quality (and the larger the file) , and for JPEG 2000 lossy, it is a compression ratio. Other compression methods may use this for other purposes in the future.

    This method is particularly suitable for use with Delphi, which provides access to streams via classes such as TStreamAdapter.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / Write Method / Write(Stream,Boolean) Method

The Stream from which to read.

If TRUE, a blank 128 byte header, DICM marker, and meta-header are written at the start of the stream, and an appropriate transfer syntax is used, as below.

If FALSE, the stream is written in the unofficial, but common format, with no header, and using the little-endian implicit VR transfer syntax.

In This Topic
    Write(Stream,Boolean) Method
    In This Topic
    Writes dataset to a system IO stream object
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub Write( _
   ByVal Stream As Stream, _
   ByVal isPart10 As Boolean _
)
    'Usage

    Dim instance As DicomDataSet
Dim Stream As Stream
Dim isPart10 As Boolean

instance.Write(Stream, isPart10)
    public void Write(
   Stream Stream,
   bool isPart10
)

    Parameters

    Stream

    The Stream from which to read.

    isPart10

    If TRUE, a blank 128 byte header, DICM marker, and meta-header are written at the start of the stream, and an appropriate transfer syntax is used, as below.

    If FALSE, the stream is written in the unofficial, but common format, with no header, and using the little-endian implicit VR transfer syntax.

    Remarks

    The stream may subsequently be read by the Read method or by other DICOM software.

    This method is particularly suitable for use with Delphi, which provides access to streams via classes such as TStreamAdapter.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / Write Method / Write(Stream,String) Method

The Stream to which to write.

Specifies the full UID of the transfer syntax with which the data is to be saved when Part 10 format is used. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see the entry.

In This Topic
    Write(Stream,String) Method
    In This Topic
    Writes dataset to a system IO stream object with specified transfer syntax
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub Write( _
   ByVal Stream As Stream, _
   ByVal TransferSyntax As String _
)
    'Usage

    Dim instance As DicomDataSet
Dim Stream As Stream
Dim TransferSyntax As String

instance.Write(Stream, TransferSyntax)
    public void Write(
   Stream Stream,
   string TransferSyntax
)

    Parameters

    Stream

    The Stream to which to write.

    TransferSyntax

    Specifies the full UID of the transfer syntax with which the data is to be saved when Part 10 format is used. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see the entry.

    Remarks

    The stream may subsequently be read by the Read method or by other DICOM software.

    This method is particularly suitable for use with Delphi, which provides access to streams via classes such as TStreamAdapter.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / Write Method / Write(Stream,String,DicomDataSet) Method

The Stream to which to write.

Specifies the full UID of the transfer syntax with which the data is to be saved when Part 10 format is used. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see the entry.

The customized MetaHeader (only Group 2 Elements)

In This Topic
    Write(Stream,String,DicomDataSet) Method
    In This Topic
    Writes dataset to a system IO stream object with specified transfer syntax and meta header
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub Write( _
   ByVal Stream As Stream, _
   ByVal TransferSyntax As String, _
   ByVal MetaHeader As DicomDataSet _
)
    'Usage

    Dim instance As DicomDataSet
Dim Stream As Stream
Dim TransferSyntax As String
Dim MetaHeader As DicomDataSet

instance.Write(Stream, TransferSyntax, MetaHeader)
    public void Write(
   Stream Stream,
   string TransferSyntax,
   DicomDataSet MetaHeader
)

    Parameters

    Stream

    The Stream to which to write.

    TransferSyntax

    Specifies the full UID of the transfer syntax with which the data is to be saved when Part 10 format is used. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see the entry.

    MetaHeader

    The customized MetaHeader (only Group 2 Elements)

    Remarks

    The file may subsequently be read by the Read method or by other DICOM software.

    The provided meta header should only contain group 2 elements.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / Write Method / Write(Stream) Method

The Stream to which to write.

In This Topic
    Write(Stream) Method
    In This Topic
    Writes dataset to a system IO stream object
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub Write( _
   ByVal Stream As Stream _
)
    'Usage

    Dim instance As DicomDataSet
Dim Stream As Stream

instance.Write(Stream)
    public void Write(
   Stream Stream
)

    Parameters

    Stream

    The Stream to which to write.

    Remarks

    The stream may subsequently be read by the Read method or by other DICOM software.

    This method is particularly suitable for use with Delphi, which provides access to streams via classes such as TStreamAdapter.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / Write Method / Write(Byte[],String,Object) Method

The byte array to write dataset to

Specifies the full UID of the transfer syntax with which the data is to be saved when Part 10 format is used. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see the entry.

The quality factor to be used

In This Topic
    Write(Byte[],String,Object) Method
    In This Topic
    Writes dataset to a byte array with specified transfer syntax and quality factor
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub Write( _
   ByRef Array() As Byte, _
   ByVal TransferSyntax As String, _
   ByVal Quality As Object _
)
    'Usage

    Dim instance As DicomDataSet
Dim Array() As Byte
Dim TransferSyntax As String
Dim Quality As Object

instance.Write(Array, TransferSyntax, Quality)
    public void Write(
   out byte[] Array,
   string TransferSyntax,
   object Quality
)

    Parameters

    Array

    The byte array to write dataset to

    TransferSyntax

    Specifies the full UID of the transfer syntax with which the data is to be saved when Part 10 format is used. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see the entry.

    Quality

    The quality factor to be used

    Remarks

    Quality is specific to the compression method being used, and is ignored for non-compressed or lossless JPEG transfer syntaxes. For Lossy JPEG, it is an integer in the range 1-100, the higher the number, the better the quality (and the larger the file) , and for JPEG 2000 lossy, it is a compression ratio. Other compression methods may use this for other purposes in the future.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / Write Method / Write(Byte[],Boolean) Method

The byte array to write dataset to

If TRUE, a blank 128 byte header, DICM marker, and meta-header are written at the start of the file, and an appropriate transfer syntax is used, as below.

If FALSE, the file is written in the unofficial, but common format, with no header, and using the little-endian implicit VR transfer syntax.

In This Topic
    Write(Byte[],Boolean) Method
    In This Topic
    Writes dataset to a byte array
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub Write( _
   ByRef Array() As Byte, _
   ByVal isPart10 As Boolean _
)
    'Usage

    Dim instance As DicomDataSet
Dim Array() As Byte
Dim isPart10 As Boolean

instance.Write(Array, isPart10)
    public void Write(
   out byte[] Array,
   bool isPart10
)

    Parameters

    Array

    The byte array to write dataset to

    isPart10

    If TRUE, a blank 128 byte header, DICM marker, and meta-header are written at the start of the file, and an appropriate transfer syntax is used, as below.

    If FALSE, the file is written in the unofficial, but common format, with no header, and using the little-endian implicit VR transfer syntax.

    Remarks

    Data may subsequently be read by the Read methods or by other DICOM software.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / Write Method / Write(Byte[],String) Method

The byte array to write dataset to

Specifies the full UID of the transfer syntax with which the file is to be saved when Part 10 format is used. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see the entry.

In This Topic
    Write(Byte[],String) Method
    In This Topic
    Writes dataset to a byte array with specified transfer syntax
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub Write( _
   ByRef Array() As Byte, _
   ByVal TransferSyntax As String _
)
    'Usage

    Dim instance As DicomDataSet
Dim Array() As Byte
Dim TransferSyntax As String

instance.Write(Array, TransferSyntax)
    public void Write(
   out byte[] Array,
   string TransferSyntax
)

    Parameters

    Array

    The byte array to write dataset to

    TransferSyntax

    Specifies the full UID of the transfer syntax with which the file is to be saved when Part 10 format is used. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see the entry.

    Remarks

    Data may subsequently be read by the Read method or by other DICOM software.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / Write Method / Write(Byte[]) Method

The byte array to write dataset to

    Write(Byte[]) Method
    In This Topic
    Writes the dataset to a byte array
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub Write( _
   ByRef Array() As Byte _
)
    'Usage

    Dim instance As DicomDataSet
Dim Array() As Byte

instance.Write(Array)
    public void Write(
   out byte[] Array
)

    Parameters

    Array

    The byte array to write dataset to

    Remarks

    Data may subsequently be read by the Read method or by other DICOM software.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / WriteJson Method
The Stream to write to

    WriteJson Method (DicomDataSet)
    In This Topic
    Write the DICOM data into an Json Stream
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Sub WriteJson( _
   ByVal Stream As Stream _
)
    'Usage

    Dim instance As DicomDataSet
Dim Stream As Stream

instance.WriteJson(Stream)
    public void WriteJson(
   Stream Stream
)

    Parameters

    Stream
    The Stream to write to
    Remarks
    The result Json data is compliant with the Native DICOM Model outlined in the DICOM Part 19 (Application Hosting), with modifications as defined in supplement 163 to allow bulk data, which is used for attributes of appropriate types with more than 16 values
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / WriteXml Method
The Stream to write to

    WriteXml Method
    In This Topic
    Write the DICOM data into an XML Stream
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Sub WriteXml( _
   ByVal Stream As Stream _
)
    'Usage

    Dim instance As DicomDataSet
Dim Stream As Stream

instance.WriteXml(Stream)
    public void WriteXml(
   Stream Stream
)

    Parameters

    Stream
    The Stream to write to
    Remarks
    The result XML data is compliant with the Native DICOM Model outlined in the DICOM Part 19 (Application Hosting), with modifications as defined in supplement 163 to allow bulk data, which is used for attributes of appropriate types with more than 16 values
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


%%PageItemTitle%% $$Properties$$

DicomObjects Namespace / DicomDataSet Class

    DicomDataSet Class Properties
    In This Topic

    For a list of all members of this type, see DicomDataSet members.

    Public Properties
     | Name | Description
Public Property | AccessionNumber | The Accession Number
Public Property | CacheMode | Controls how the pixel data is cached
Public Property | Children | Holds the hierarchical directory structure for DICOM directory files
Public Property | Command | The full command dataset received
Public Property | Count | Number of Attributes held in the DataSet
Public Property | DateOfBirth | Date of birth of the patient
Public Property | Identifer | Returns the underlying DataSet which contains the list of attributes to be matched, as specified in the DICOM standard.
Public Property | InstanceUID | Unique identifier for the four levels of the DICOM Query/Retrieve hierarchy
Public Property | Item | Overloaded. Provides access of all attributes of the dataset
Public Property | Modality | The Modality of the image
Public Property | Name | The Name of the patient
Public Property | OriginalTS | Returns the Transfer syntax with which the object was originally received or read.
Public Property | Overrides | Image-specific list of unusual behaviours (e.g. to cope with faulty images)
Public Property | OverrideTS | A means to override an incorrect transfer syntax
Public Property | PatientID | The Patient ID
Public Property | PixelsPerFrame | The number of pixels per frame
Public Property | RawPixels | Accesses the raw pixel data as an array
Public Property | SamplesPerFrame | The number of samples per frame
Public Property | SeriesDescription | Descriptions for the series
Public Property | SeriesUID | Unique identifier for the four levels of the DICOM Query/Retrieve hierarchy
Public Property | Sex | Sex of the patient
Public Property | Size | The dimensions of the pixel data if present
Public Property | SOPClass | SOP class of the DicomDataSet.
Public Property | StudyDescription | Description for the study
Public Property | StudyUID | Unique identifier for the four levels of the DICOM Query/Retrieve hierarchy
Public Property | Tag | A general purpose Tag for developer use
Public Property | UncompressedPI | Gets the Photometric Interpretation of the uncompressed Image data.
Public Property | ValidationDataSet | Assign a Validation DataSet to this property would override the DataSet's Validation scheme. This is mainly used for validation of CharacterSet.
Public Property | ValidationOptions | The default DicomObjects.Validation.ValidationOptions to apply to newly created DicomDataSet objects
    Top
    See Also

    Reference

    DicomDataSet Class
    DicomObjects Namespace


DicomObjects Namespace / DicomDataSet Class / AccessionNumber Property

    AccessionNumber Property (DicomDataSet)
    In This Topic
    The Accession Number
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property AccessionNumber As String
    'Usage

    Dim instance As DicomDataSet
Dim value As String

instance.AccessionNumber = value

value = instance.AccessionNumber
    public string AccessionNumber {get; set;}

    Property Value

    The Accession Number
    Remarks
    Shortcut for Attribute 0008,0050
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / CacheMode Property

    CacheMode Property (DicomDataSet)
    In This Topic
    Controls how the pixel data is cached
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property CacheMode As CacheTypes
    'Usage

    Dim instance As DicomDataSet
Dim value As CacheTypes

instance.CacheMode = value

value = instance.CacheMode
    public CacheTypes CacheMode {get; set;}
    Remarks
    See DicomObjects.Enums.CacheTypes for details of the values
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / Children Property

    Children Property
    Holds the hierarchical directory structure for DICOM directory files
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property Children As DicomDataSetCollection
    'Usage

    Dim instance As DicomDataSet
Dim value As DicomDataSetCollection

value = instance.Children
    public DicomDataSetCollection Children {get;}
    Remarks
    Recursive use of this property and the datasets contained within it allows representation and manipulation of the hierarchical structure of a DICOMDIR file. The Children property exists for all DicomDataSet objects, but is only created by AddToDirectory and is used by Write method. There are normally five levels, the objects representing the DICOMDIR file itself, and the four hierarchical levels PATIENT, STUDY, SERIES and IMAGE.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / Command Property

    Command Property (DicomDataSet)
    In This Topic
    The full command dataset received
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property Command As DicomDataSet
    'Usage

    Dim instance As DicomDataSet
Dim value As DicomDataSet

value = instance.Command
    public DicomDataSet Command {get;}
    Remarks
    Returns the DataSet which contains elements in the 0000 and 0002 Group.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / Count Property

    Count Property
    Number of Attributes held in the DataSet
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property Count As Integer
    'Usage

    Dim instance As DicomDataSet
Dim value As Integer

value = instance.Count
    public int Count {get;}
    Remarks
    Returns the number of attributes in the dataset, irrespective of their values being null or none-null.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / DateOfBirth Property

    DateOfBirth Property (DicomDataSet)
    In This Topic
    Date of birth of the patient
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property DateOfBirth As Date
    'Usage

    Dim instance As DicomDataSet
Dim value As Date

instance.DateOfBirth = value

value = instance.DateOfBirth
    public DateTime DateOfBirth {get; set;}

    Property Value

    Date of birth of the patient
    Remarks
    A shortcut for attribute (0010, 0030)
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / Identifer Property

    Identifer Property
    Returns the underlying DataSet which contains the list of attributes to be matched, as specified in the DICOM standard.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property Identifer As DicomDataSet
    'Usage

    Dim instance As DicomDataSet
Dim value As DicomDataSet

value = instance.Identifer
    public DicomDataSet Identifer {get;}

    Property Value

    DicomDataSet
    Remarks

    It is the client's responsibility to interpret the contents of this identifier and ensure that the data or images returned match the data sent, and in the case of C-FIND operations, to ensure that all data elements requested are included in the response.

    The "level" of the query may be found in Attribute (Keyword.QueryRetrieveLevel) of this property.

    The handling of Query/Retrieve requests as an SCP is an advanced technique, and the rules to be obeyed are beyond the scope of this help file. See the Access SCP example for a demonstration of a possible implementation.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / InstanceUID Property

    InstanceUID Property (DicomDataSet)
    In This Topic
    Unique identifier for the four levels of the DICOM Query/Retrieve hierarchy
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property InstanceUID As String
    'Usage

    Dim instance As DicomDataSet
Dim value As String

instance.InstanceUID = value

value = instance.InstanceUID
    public string InstanceUID {get; set;}

    Property Value

    The Instance UID
    Remarks
    A shortcut for attribute (0008, 0018)
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / Item Property

    Item Property (DicomDataSet)
    In This Topic
    Provides access of all attributes of the dataset
    Overload List
    Overload | Description
Item(Int32,Int32) | Provides access of all attributes of the dataset
Item(Int32) | The default indexer
Item(Keyword) | Indexer based on the new DICOM keyword
Item(String) | Indexer based on the new DICOM keyword as a string
    Remarks
    There are several possible indexers for a dataset, allowing both specific and sequential access.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / Item Property / Item(Int32,Int32) Property

The group index of a data element.

The element index of a data element.

In This Topic
    Item(Int32,Int32) Property
    In This Topic
    Provides access of all attributes of the dataset
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Overridable ReadOnly Property Item( _
   ByVal group As Integer, _
   ByVal element As Integer _
) As DicomAttribute
    'Usage

    Dim instance As DicomDataSet
Dim group As Integer
Dim element As Integer
Dim value As DicomAttribute

value = instance.Item(group, element)
    public virtual DicomAttribute Item(
   int group,
   int element
) {get;}

    Parameters

    group

    The group index of a data element.

    element

    The element index of a data element.

    Remarks
    There are several possible indexers for a dataset, allowing both specific and sequential access.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / Item Property / Item(Int32) Property
The Index of the DicomAttribute

    Item(Int32) Property
    In This Topic
    The default indexer
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads ReadOnly Property Item( _
   ByVal index As Integer _
) As DicomAttribute
    'Usage

    Dim instance As DicomDataSet
Dim index As Integer
Dim value As DicomAttribute

value = instance.Item(index)
    public DicomAttribute Item(
   int index
) {get;}

    Parameters

    index
    The Index of the DicomAttribute
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / Item Property / Item(Keyword) Property
The Keyword of the DicomAttribute

    Item(Keyword) Property
    In This Topic
    Indexer based on the new DICOM keyword
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads ReadOnly Property Item( _
   ByVal Keyword As Keyword _
) As DicomAttribute
    'Usage

    Dim instance As DicomDataSet
Dim Keyword As Keyword
Dim value As DicomAttribute

value = instance.Item(Keyword)
    public DicomAttribute Item(
   Keyword Keyword
) {get;}

    Parameters

    Keyword
    The Keyword of the DicomAttribute
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / Item Property / Item(String) Property
A String containing the DicomObjects.Enums.Keyword of the DicomAttribute

In This Topic
    Item(String) Property
    In This Topic
    Indexer based on the new DICOM keyword as a string
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads ReadOnly Property Item( _
   ByVal Keyword As String _
) As DicomAttribute
    'Usage

    Dim instance As DicomDataSet
Dim Keyword As String
Dim value As DicomAttribute

value = instance.Item(Keyword)
    public DicomAttribute Item(
   string Keyword
) {get;}

    Parameters

    Keyword
    A String containing the DicomObjects.Enums.Keyword of the DicomAttribute
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members
    Overload List


DicomObjects Namespace / DicomDataSet Class / Modality Property

    Modality Property (DicomDataSet)
    In This Topic
    The Modality of the image
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property Modality As String
    'Usage

    Dim instance As DicomDataSet
Dim value As String

instance.Modality = value

value = instance.Modality
    public string Modality {get; set;}

    Property Value

    The Modality of the image
    Remarks

    A shortcut for Modality (0008,0060).

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / Name Property

    Name Property (DicomDataSet)
    In This Topic
    The Name of the patient
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property Name As String
    'Usage

    Dim instance As DicomDataSet
Dim value As String

instance.Name = value

value = instance.Name
    public string Name {get; set;}

    Property Value

    The Name of the patient
    Remarks

    A shortcut for attribute (0010,0010).

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / OriginalTS Property

    OriginalTS Property (DicomDataSet)
    In This Topic
    Returns the Transfer syntax with which the object was originally received or read.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property OriginalTS As String
    'Usage

    Dim instance As DicomDataSet
Dim value As String

value = instance.OriginalTS
    public string OriginalTS {get;}
    Remarks

    The value returned is the UID, in dotted numerical form, or the transfer syntax used.

    This property may be useful to programs to handle compressed images, that wish to avoid re-compression of images, e.g. when using the Write method.

    If an image/dataset has been created locally, then then explicit VT little endian (1.2.840.10008.1.2.1") is returned.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / Overrides Property

    Overrides Property
    Image-specific list of unusual behaviours (e.g. to cope with faulty images)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property Overrides As Dictionary(Of String,Object)
    'Usage

    Dim instance As DicomDataSet
Dim value As Dictionary(Of String,Object)

instance.Overrides = value

value = instance.Overrides
    public Dictionary<string,object> Overrides {get; set;}
    Remarks
    Use only if requested by Medical Connections.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / OverrideTS Property

    OverrideTS Property
    A means to override an incorrect transfer syntax
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property OverrideTS As String
    'Usage

    Dim instance As DicomDataSet
Dim value As String

instance.OverrideTS = value

value = instance.OverrideTS
    public string OverrideTS {get; set;}
    Remarks
    If set to a non-empty value, then this is used in place of the value in 0002,0010 in the meta-header of any dataset read into this object (e.g. using one of the Read methods.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / PatientID Property

    PatientID Property (DicomDataSet)
    In This Topic
    The Patient ID
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property PatientID As String
    'Usage

    Dim instance As DicomDataSet
Dim value As String

instance.PatientID = value

value = instance.PatientID
    public string PatientID {get; set;}

    Property Value

    The Patient ID
    Remarks
    A shortcut for attribute (0010, 0020)
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / PixelsPerFrame Property

    PixelsPerFrame Property
    The number of pixels per frame
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property PixelsPerFrame As Integer
    'Usage

    Dim instance As DicomDataSet
Dim value As Integer

value = instance.PixelsPerFrame
    public int PixelsPerFrame {get;}
    Remarks
    This returns Size.Height * Size.Width
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / RawPixels Property

    RawPixels Property (DicomDataSet)
    In This Topic
    Accesses the raw pixel data as an array
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property RawPixels As Array
    'Usage

    Dim instance As DicomDataSet
Dim value As Array

instance.RawPixels = value

value = instance.RawPixels
    public Array RawPixels {get; set;}
    Remarks

    This returns an array containing one element per frame. The data returned is unaffected by the display parameters.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / SamplesPerFrame Property

    SamplesPerFrame Property
    The number of samples per frame
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property SamplesPerFrame As Integer
    'Usage

    Dim instance As DicomDataSet
Dim value As Integer

value = instance.SamplesPerFrame
    public int SamplesPerFrame {get;}
    Remarks
    For monochrome images, this is the same as PixelsPerFrame but for multi-component images such as RGB it will be PixelsPerFrame * Samples per Pixel.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / SeriesDescription Property

    SeriesDescription Property (DicomDataSet)
    In This Topic
    Descriptions for the series
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property SeriesDescription As String
    'Usage

    Dim instance As DicomDataSet
Dim value As String

instance.SeriesDescription = value

value = instance.SeriesDescription
    public string SeriesDescription {get; set;}

    Property Value

    The Series Description
    Remarks

    Provides human readable descriptions of the Study returned by a query, or relating to an image. They correspond to attribute (0008, 103E).

    The usefulness is limited by the fact that not all equipment provides descriptions in its SOP instances, and even if it does, they may not be available through Query/Retrieve. For instance the RSNA CTN (up to and including version 2.8) supports the study description, but fails to index and provide the series description.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / SeriesUID Property

    SeriesUID Property (DicomDataSet)
    In This Topic
    Unique identifier for the four levels of the DICOM Query/Retrieve hierarchy
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property SeriesUID As String
    'Usage

    Dim instance As DicomDataSet
Dim value As String

instance.SeriesUID = value

value = instance.SeriesUID
    public string SeriesUID {get; set;}

    Property Value

    The Series UID
    Remarks
    A shortcut for the attribute (0020, 000E).
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / Sex Property

    Sex Property (DicomDataSet)
    In This Topic
    Sex of the patient
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property Sex As String
    'Usage

    Dim instance As DicomDataSet
Dim value As String

instance.Sex = value

value = instance.Sex
    public string Sex {get; set;}

    Property Value

    Sex of the patient
    Remarks
    A shortcut for attribute (0010, 0040)
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / Size Property

    Size Property (DicomDataSet)
    In This Topic
    The dimensions of the pixel data if present
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property Size As SkiaSharp.SKSizeI
    'Usage

    Dim instance As DicomDataSet
Dim value As SkiaSharp.SKSizeI

value = instance.Size
    public SkiaSharp.SKSizeI Size {get;}
    Remarks
    This property provides access to the horizontal (SKSizeI.Width) and vertical dimensions (SKSizeI.Height) of the image. Dimensions are 32-bit Integers.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / SOPClass Property

    SOPClass Property (DicomDataSet)
    In This Topic
    SOP class of the DicomDataSet.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property SOPClass As String
    'Usage

    Dim instance As DicomDataSet
Dim value As String

instance.SOPClass = value

value = instance.SOPClass
    public string SOPClass {get; set;}

    Property Value

    The SOP class UID
    Remarks
    Shortcut for attribute (0008, 0016).
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / StudyDescription Property

    StudyDescription Property (DicomDataSet)
    In This Topic
    Description for the study
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property StudyDescription As String
    'Usage

    Dim instance As DicomDataSet
Dim value As String

instance.StudyDescription = value

value = instance.StudyDescription
    public string StudyDescription {get; set;}

    Property Value

    Study Description
    Remarks

    This property provides human readable descriptions of the Study returned by a query, or relating to an image. It corresponds to attribute (0008, 1030).

    The usefulness is limited by the fact that not all equipment provides these descriptions in its SOP instances, and even if it does, they may not be available through Query/Retrieve. For instance the RSNA CTN (up to and including version 2.8) supports the study description, but fails to index and provide the series description.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / StudyUID Property

    StudyUID Property (DicomDataSet)
    In This Topic
    Unique identifier for the four levels of the DICOM Query/Retrieve hierarchy
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property StudyUID As String
    'Usage

    Dim instance As DicomDataSet
Dim value As String

instance.StudyUID = value

value = instance.StudyUID
    public string StudyUID {get; set;}

    Property Value

    The Study UID
    Remarks
    A shortcut for attribute (0020, 000D).
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / Tag Property

    Tag Property (DicomDataSet)
    In This Topic
    A general purpose Tag for developer use
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property Tag As Object
    'Usage

    Dim instance As DicomDataSet
Dim value As Object

instance.Tag = value

value = instance.Tag
    public object Tag {get; set;}
    Remarks
    This property is not used by DicomObjects in any way, and is provided purely as a convenience for developers who wish to associate other objects with this object. As an alternative, most of the objects in DicomObjects can have other classes derived from them.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / UncompressedPI Property

    UncompressedPI Property
    Gets the Photometric Interpretation of the uncompressed Image data.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property UncompressedPI As String
    'Usage

    Dim instance As DicomDataSet
Dim value As String

value = instance.UncompressedPI
    public string UncompressedPI {get;}

    Property Value

    The Photometric Interpretation
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / ValidationDataSet Property

    ValidationDataSet Property
    Assign a Validation DataSet to this property would override the DataSet's Validation scheme. This is mainly used for validation of CharacterSet.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property ValidationDataSet As DicomDataSet
    'Usage

    Dim instance As DicomDataSet
Dim value As DicomDataSet

instance.ValidationDataSet = value

value = instance.ValidationDataSet
    public DicomDataSet ValidationDataSet {get; set;}
    Remarks

    This property provides a means to override the CharacterSet validation of the DataSet within a sequence, which is added onto another DataSet, value of which should be passed to this property.

    Example

    Dim sequence As New DicomObjects.DicomDataSetCollection

    Dim sequenceItem As New DicomObjects.DicomDataSet

    Dim d As New DicomObjects.DicomDataSet

    d.ValidationOptions = ValidationOptions.CharacterSet

    d.Add(&H8, &H5, "ISO_IR 100")

    sequenceItem.ValidationOptions = ValidationOptions.CharacterSet

    sequenceItem.ValidationDataSet = d

    sequenceItem.Name = "C�nan"

    d.Add(&H88, &H200, sequence)

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / ValidationOptions Property

    ValidationOptions Property (DicomDataSet)
    In This Topic
    The default DicomObjects.Validation.ValidationOptions to apply to newly created DicomDataSet objects
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property ValidationOptions As ValidationOptions
    'Usage

    Dim instance As DicomDataSet
Dim value As ValidationOptions

instance.ValidationOptions = value

value = instance.ValidationOptions
    public ValidationOptions ValidationOptions {get; set;}
    Remarks
    The default value for this default is DicomObjects.Validation.ValidationOptions combined with DicomObjects.Validation.ValidationOptions
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


%%PageItemTitle%% $$Fields$$

DicomObjects Namespace / DicomDataSet Class

    DicomDataSet Class Fields
    In This Topic

    For a list of all members of this type, see DicomDataSet members.

    Public Fields
     | Name | Description
Public Field | CompressedFrameStream | User-defined function to set output stream for compressed frame. This is suitable for writing out large compressed frames with Basic Offset Table.
    Top
    See Also

    Reference

    DicomDataSet Class
    DicomObjects Namespace


DicomObjects Namespace / DicomDataSet Class / CompressedFrameStream Field

    CompressedFrameStream Field
    User-defined function to set output stream for compressed frame. This is suitable for writing out large compressed frames with Basic Offset Table.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public CompressedFrameStream As Func(Of Integer,Stream)
    'Usage

    Dim instance As DicomDataSet
Dim value As Func(Of Integer,Stream)

value = instance.CompressedFrameStream

instance.CompressedFrameStream = value
    public Func<int,Stream> CompressedFrameStream
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


%%PageItemTitle%%

DicomObjects Namespace / DicomDataSetCollection Class
Members

In This Topic
    DicomDataSetCollection Class
    In This Topic
    A collection of DicomDataSet objects
    Object Model
    DicomDataSetCollection ClassDicomDataSet Class
    Syntax
    • Visual Basic
    • C#
    'Declaration

    <DefaultMemberAttribute("Item")>
<DebuggerTypeProxyAttribute(System.Collections.Generic.Mscorlib_CollectionDebugView`1)>
<DebuggerDisplayAttribute("Count = {Count}")>
Public Class DicomDataSetCollection
   Inherits System.Collections.ObjectModel.Collection(Of DicomDataSet)
    'Usage

    Dim instance As DicomDataSetCollection
    [DefaultMember("Item")]
[DebuggerTypeProxy(System.Collections.Generic.Mscorlib_CollectionDebugView`1)]
[DebuggerDisplay("Count = {Count}")]
public class DicomDataSetCollection : System.Collections.ObjectModel.Collection<DicomDataSet>
    Inheritance Hierarchy

    System.Object
    System.Collections.ObjectModel.Collection<T>
    DicomObjects.DicomDataSetCollection

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSetCollection Members
    DicomObjects Namespace


%%PageItemTitle%% $$Members$$

DicomObjects Namespace / DicomDataSetCollection Class
Properties Methods

In This Topic
    DicomDataSetCollection Class Members
    In This Topic

    The following tables list the members exposed by DicomDataSetCollection.

    Public Constructors
     | Name | Description
Public Constructor | DicomDataSetCollection Constructor | Overloaded. Creates a DicomDataSetCollection object
    Top
    Public Properties
     | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<DicomDataSet>)
Public Property | Item | Overloaded. Provides access to collection item via its InstanceUID
Public Property | SopUIDList | Contains a list of SOP Class UIDs for all DataSet items contained in this Collection
Public Property | Tag | A general purpose Tag for developer use
    Top
    Public Methods
     | Name | Description
Public Method | Add | Overloaded. Adds a DicomDataSet to a DicomDataSetCollection
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<DicomDataSet>)
Public Method | Clone | Overloaded. Returns a copy of the DicomDataSetCollection
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<DicomDataSet>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<DicomDataSet>)
Public Method | Dispose | Release all resources used by DicomDataSetCollection
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<DicomDataSet>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<DicomDataSet>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<DicomDataSet>)
Public Method | MakeKOS | Make DICOM Key Object Note object from a collection of DicomDataSets. The first DicomDataSet object in the collection will be used as the primary data for KOS content. If multiple Studies are present in the collection, each Study will be added as a new Current Requested Procedure Evidence Sequence item. All Referenced Instance(s) will be added to the Content Sequence.
Public Method | Read | Overloaded. Creates and adds a DicomDataSet from an external DICOM File, a byte array, or a file stream. Or Creates and adds a collection of DicomDataSet objects from an array of external DICOM files
Public Method | ReadJson | Read DICOM data from a JSON Stream
Public Method | Remove | Overloaded. Removes DicomDataSet from a DicomDataSetCollectionby matching its InstanceUID
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<DicomDataSet>)
Public Method | Send | Sends all DataSets within the collection in one association
Public Method | WriteJson | Write DICOM data to a JSON Stream
    Top
    See Also

    Reference

    DicomDataSetCollection Class
    DicomObjects Namespace


%%PageItemTitle%%

DicomObjects Namespace / DicomDataSetCollection Class / DicomDataSetCollection Constructor

In This Topic
    DicomDataSetCollection Constructor
    In This Topic
    Creates a DicomDataSetCollection object
    Overload List
    Overload | Description
DicomDataSetCollection Constructor() | Creates a DicomDataSetCollection object
DicomDataSetCollection Constructor(IEnumerable<DicomImage>) | Creates a DicomDataSetCollection from a DicomImageCollection
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSetCollection Class
    DicomDataSetCollection Members


%%PageItemTitle%%

DicomObjects Namespace / DicomDataSetCollection Class / DicomDataSetCollection Constructor / DicomDataSetCollection Constructor()

In This Topic
    DicomDataSetCollection Constructor()
    In This Topic
    Creates a DicomDataSetCollection object
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Function New()
    'Usage

    Dim instance As New DicomDataSetCollection()
    public DicomDataSetCollection()

    Return Value

    DicomDataSetCollection
    Remarks
    This is the constructor method.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSetCollection Class
    DicomDataSetCollection Members
    Overload List


%%PageItemTitle%%

DicomObjects Namespace / DicomDataSetCollection Class / DicomDataSetCollection Constructor / DicomDataSetCollection Constructor(IEnumerable<DicomImage>)
images as DicomImageCollection, the DicomImageCollection from which the new DicomDataSetCollection is created.

In This Topic
    DicomDataSetCollection Constructor(IEnumerable<DicomImage>)
    In This Topic
    Creates a DicomDataSetCollection from a DicomImageCollection
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Function New( _
   ByVal images As IEnumerable(Of DicomImage) _
)
    'Usage

    Dim images As IEnumerable(Of DicomImage)

Dim instance As New DicomDataSetCollection(images)
    public DicomDataSetCollection(
   IEnumerable<DicomImage> images
)

    Parameters

    images
    images as DicomImageCollection, the DicomImageCollection from which the new DicomDataSetCollection is created.

    Return Value

    DicomDataSetCollection
    Remarks
    This is a "down-grading" approach to extract a DicomDataSetCollection from a DicomImageCollection.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSetCollection Class
    DicomDataSetCollection Members
    Overload List


%%PageItemTitle%% $$Methods$$

DicomObjects Namespace / DicomDataSetCollection Class

    DicomDataSetCollection Class Methods
    In This Topic

    For a list of all members of this type, see DicomDataSetCollection members.

    Public Methods
     | Name | Description
Public Method | Add | Overloaded. Adds a DicomDataSet to a DicomDataSetCollection
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<DicomDataSet>)
Public Method | Clone | Overloaded. Returns a copy of the DicomDataSetCollection
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<DicomDataSet>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<DicomDataSet>)
Public Method | Dispose | Release all resources used by DicomDataSetCollection
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<DicomDataSet>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<DicomDataSet>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<DicomDataSet>)
Public Method | MakeKOS | Make DICOM Key Object Note object from a collection of DicomDataSets. The first DicomDataSet object in the collection will be used as the primary data for KOS content. If multiple Studies are present in the collection, each Study will be added as a new Current Requested Procedure Evidence Sequence item. All Referenced Instance(s) will be added to the Content Sequence.
Public Method | Read | Overloaded. Creates and adds a DicomDataSet from an external DICOM File, a byte array, or a file stream. Or Creates and adds a collection of DicomDataSet objects from an array of external DICOM files
Public Method | ReadJson | Read DICOM data from a JSON Stream
Public Method | Remove | Overloaded. Removes DicomDataSet from a DicomDataSetCollectionby matching its InstanceUID
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<DicomDataSet>)
Public Method | Send | Sends all DataSets within the collection in one association
Public Method | WriteJson | Write DICOM data to a JSON Stream
    Top
    See Also

    Reference

    DicomDataSetCollection Class
    DicomObjects Namespace


DicomObjects Namespace / DicomDataSetCollection Class / Add Method

    Add Method (DicomDataSetCollection)
    In This Topic
    Adds a DicomDataSet to a DicomDataSetCollection
    Overload List
    Overload | Description
Add(IEnumerable<DicomDataSet>) | Adds a DicomDataSetCollection to a DicomDataSetCollection
Add(DicomDataSet) | (Inherited from System.Collections.ObjectModel.Collection<DicomDataSet>)
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSetCollection Class
    DicomDataSetCollection Members


DicomObjects Namespace / DicomDataSetCollection Class / Add Method / Add(IEnumerable<DicomDataSet>) Method

Collection of DicomDataSets to be added

    Add(IEnumerable<DicomDataSet>) Method
    In This Topic
    Adds a DicomDataSetCollection to a DicomDataSetCollection
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub Add( _
   ByVal value As IEnumerable(Of DicomDataSet) _
)
    'Usage

    Dim instance As DicomDataSetCollection
Dim value As IEnumerable(Of DicomDataSet)

instance.Add(value)
    public void Add(
   IEnumerable<DicomDataSet> value
)

    Parameters

    value

    Collection of DicomDataSets to be added

    Remarks
    Adds a Collection of DicomDataSets to the end of a DicomDataSetCollection.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSetCollection Class
    DicomDataSetCollection Members
    Overload List


DicomObjects Namespace / DicomDataSetCollection Class / Clone Method

    Clone Method (DicomDataSetCollection)
    In This Topic
    Returns a copy of the DicomDataSetCollection
    Overload List
    Overload | Description
Clone(Boolean) | Returns a copy of the DicomDataSetCollection
Clone() | Returns a copy of the DicomDataSetCollection
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSetCollection Class
    DicomDataSetCollection Members


DicomObjects Namespace / DicomDataSetCollection Class / Clone Method / Clone(Boolean) Method

Boolean value, if true then returns a Deep copy of the DicomDataSetCollection.

If false, returns a Shallow copy.

In This Topic
    Clone(Boolean) Method
    In This Topic
    Returns a copy of the DicomDataSetCollection
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Overridable Function Clone( _
   ByVal Deep As Boolean _
) As Object
    'Usage

    Dim instance As DicomDataSetCollection
Dim Deep As Boolean
Dim value As Object

value = instance.Clone(Deep)
    public virtual object Clone(
   bool Deep
)

    Parameters

    Deep

    Boolean value, if true then returns a Deep copy of the DicomDataSetCollection.

    If false, returns a Shallow copy.

    Return Value

    DicomDataSetCollection
    Remarks

    This method makes either a Shallow Copy or a Deep Copy of the DicomDataSetCollection, dependants on the Deep parameter.

    A shallow copy will only have the top level objects replicated, any referenced objects under the top level will be shared by the original DicomDataSetCollection and the cloned copy.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSetCollection Class
    DicomDataSetCollection Members
    Overload List


DicomObjects Namespace / DicomDataSetCollection Class / Clone Method / Clone() Method

    Clone() Method
    Returns a copy of the DicomDataSetCollection
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Overridable Function Clone() As Object
    'Usage

    Dim instance As DicomDataSetCollection
Dim value As Object

value = instance.Clone()
    public virtual object Clone()

    Return Value

    DicomDataSetCollection
    Remarks
    This method makes a Shallow Copy of the DicomDataSetCollection. A shallow copy will only have the top level objects replicated, any referenced objects under the top level will be shared by the original DicomDataSetCollection and the cloned copy.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSetCollection Class
    DicomDataSetCollection Members
    Overload List


DicomObjects Namespace / DicomDataSetCollection Class / Dispose Method

    Dispose Method (DicomDataSetCollection)
    In This Topic
    Release all resources used by DicomDataSetCollection
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Sub Dispose()
    'Usage

    Dim instance As DicomDataSetCollection

instance.Dispose()
    public void Dispose()
    Remarks
    Standard Dispose method.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSetCollection Class
    DicomDataSetCollection Members


DicomObjects Namespace / DicomDataSetCollection Class / MakeKOS Method
The location UID of each referenced Series where Instances can be retreived
Name of the Application Entity Title of where the referenced Instances can be retrieved

In This Topic
    MakeKOS Method
    In This Topic
    Make DICOM Key Object Note object from a collection of DicomDataSets. The first DicomDataSet object in the collection will be used as the primary data for KOS content. If multiple Studies are present in the collection, each Study will be added as a new Current Requested Procedure Evidence Sequence item. All Referenced Instance(s) will be added to the Content Sequence.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Function MakeKOS( _
   ByVal RetrieveLocationUID As String, _
   ByVal RetrieveAET As String _
) As DicomDataSet
    'Usage

    Dim instance As DicomDataSetCollection
Dim RetrieveLocationUID As String
Dim RetrieveAET As String
Dim value As DicomDataSet

value = instance.MakeKOS(RetrieveLocationUID, RetrieveAET)
    public DicomDataSet MakeKOS(
   string RetrieveLocationUID,
   string RetrieveAET
)

    Parameters

    RetrieveLocationUID
    The location UID of each referenced Series where Instances can be retreived
    RetrieveAET
    Name of the Application Entity Title of where the referenced Instances can be retrieved
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSetCollection Class
    DicomDataSetCollection Members


DicomObjects Namespace / DicomDataSetCollection Class / Read Method

    Read Method (DicomDataSetCollection)
    In This Topic
    Creates and adds a DicomDataSet from an external DICOM File, a byte array, or a file stream. Or Creates and adds a collection of DicomDataSet objects from an array of external DICOM files
    Overload List
    Overload | Description
Read(String) | Creates and adds a DicomDataSet from an external DICOM file
Read(Byte[]) | Creates and adds a DicomDataSet from a byte array
Read(IEnumerable<String>) | Creates and adds a collection of DicomDataSet objects from a collection of external DICOM files
Read(Stream) | Reads a DICOM file from a Stream
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSetCollection Class
    DicomDataSetCollection Members


DicomObjects Namespace / DicomDataSetCollection Class / Read Method / Read(String) Method

The name of the file to read.

This is passed unmodified to the operating system, and it is therefore the container’s responsibility to ensure either that the file exists within the current directory, or that a fully qualified filename is provided.

In This Topic
    Read(String) Method
    In This Topic
    Creates and adds a DicomDataSet from an external DICOM file
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Function Read( _
   ByVal FileName As String _
) As DicomDataSet
    'Usage

    Dim instance As DicomDataSetCollection
Dim FileName As String
Dim value As DicomDataSet

value = instance.Read(FileName)
    public DicomDataSet Read(
   string FileName
)

    Parameters

    FileName

    The name of the file to read.

    This is passed unmodified to the operating system, and it is therefore the container’s responsibility to ensure either that the file exists within the current directory, or that a fully qualified filename is provided.

    Return Value

    If successful, a DicomDataSet Object is returned, and is added to the appropriate collection. If unsuccessful, an appropriate error is thrown.
    Remarks

    This method can read either official "Part10" format files with the 128 byte header, or unofficial "Part5" format files without a header. Detection of the type is automatic.

    The file may have been written by the Write method or by other DICOM software.

    By default, pixel data is read only when it is required, greatly speeding the display of multi-frame images, and reducing memory requirements. However, a side effect of this is that any elements after the pixel data (7FE0,0010) will not be read. This should not affect most applications, but if necessary, this behavior may be over-ridden using the DicomGlobal.CloseFilesAfterReading property.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSetCollection Class
    DicomDataSetCollection Members
    Overload List


DicomObjects Namespace / DicomDataSetCollection Class / Read Method / Read(Byte[]) Method

Array as Byte Array:

The Byte Array to read

In This Topic
    Read(Byte[]) Method
    In This Topic
    Creates and adds a DicomDataSet from a byte array
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Function Read( _
   ByVal Array() As Byte _
) As DicomDataSet
    'Usage

    Dim instance As DicomDataSetCollection
Dim Array() As Byte
Dim value As DicomDataSet

value = instance.Read(Array)
    public DicomDataSet Read(
   byte[] Array
)

    Parameters

    Array

    Array as Byte Array:

    The Byte Array to read

    Return Value

    DicomDataSet
    Remarks
    This method uses memory stream to read a byte array and creates a new DicomDataSet and adds it to the DicomDataSetCollection.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSetCollection Class
    DicomDataSetCollection Members
    Overload List


DicomObjects Namespace / DicomDataSetCollection Class / Read Method / Read(IEnumerable<String>) Method

A set of Filenames to read.

In This Topic
    Read(IEnumerable<String>) Method
    In This Topic
    Creates and adds a collection of DicomDataSet objects from a collection of external DICOM files
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Function Read( _
   ByVal FileNames As IEnumerable(Of String) _
) As DicomDataSetCollection
    'Usage

    Dim instance As DicomDataSetCollection
Dim FileNames As IEnumerable(Of String)
Dim value As DicomDataSetCollection

value = instance.Read(FileNames)
    public DicomDataSetCollection Read(
   IEnumerable<string> FileNames
)

    Parameters

    FileNames

    A set of Filenames to read.

    Return Value

    If successful, a DicomDataSetCollection is returned, and is added to the appropriate collection. If unsuccessful, an appropriate error is thrown.
    Remarks
    Like reading from a single DICOM file, this method loops through the list of files and read them one by one and if successful returns a DicomDataSetCollectionwhich contains all the newly created DicomDataSets.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSetCollection Class
    DicomDataSetCollection Members
    Overload List


DicomObjects Namespace / DicomDataSetCollection Class / Read Method / Read(Stream) Method

The stream from which to read.

In This Topic
    Read(Stream) Method
    In This Topic
    Reads a DICOM file from a Stream
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Function Read( _
   ByVal Stream As Stream _
) As DicomDataSet
    'Usage

    Dim instance As DicomDataSetCollection
Dim Stream As Stream
Dim value As DicomDataSet

value = instance.Read(Stream)
    public DicomDataSet Read(
   Stream Stream
)

    Parameters

    Stream

    The stream from which to read.

    Return Value

    If successful, a DicomDataSet Object is returned, and is added to the appropriate collection. If unsuccessful, an appropriate error is thrown.
    Remarks

    This method can read streams in either official "Part10" format, with the 128 byte header, or unofficial "Part5" format, without a header. Detection of the type is automatic.

    The stream may have been written by the Write method or by other DICOM software.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSetCollection Class
    DicomDataSetCollection Members
    Overload List


DicomObjects Namespace / DicomDataSetCollection Class / ReadJson Method
The Stream to read from
The transfer syntax to assign to the resulting instances - see remarks

In This Topic
    ReadJson Method (DicomDataSetCollection)
    In This Topic
    Read DICOM data from a JSON Stream
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Sub ReadJson( _
   ByVal Stream As Stream, _
   Optional ByVal TransferSyntax As String _
)
    'Usage

    Dim instance As DicomDataSetCollection
Dim Stream As Stream
Dim TransferSyntax As String

instance.ReadJson(Stream, TransferSyntax)
    public void ReadJson(
   Stream Stream,
   string TransferSyntax
)

    Parameters

    Stream
    The Stream to read from
    TransferSyntax
    The transfer syntax to assign to the resulting instances - see remarks
    Remarks

    The JSON data must be compliant with the Native DICOM Model outlined in the DICOM Part 18, with modifications as defined in supplement 163 to allow bulk data

    The TransferSyntaxvalue does not directly affect the data itself, which is independent of transfer syntax, but the assigned value may be used internally to control the form in which are missing bulk data (e.g. pixel data) is requested fromn an origin server if replaced by a BulkDataUri property.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSetCollection Class
    DicomDataSetCollection Members


DicomObjects Namespace / DicomDataSetCollection Class / Remove Method

    Remove Method (DicomDataSetCollection)
    In This Topic
    Removes DicomDataSet from a DicomDataSetCollectionby matching its InstanceUID
    Overload List
    Overload | Description
Remove(String) | Removes DicomDataSet from a DicomDataSetCollectionby matching its InstanceUID
Remove(DicomDataSet) | (Inherited from System.Collections.ObjectModel.Collection<DicomDataSet>)
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSetCollection Class
    DicomDataSetCollection Members


DicomObjects Namespace / DicomDataSetCollection Class / Remove Method / Remove(String) Method

The InstanceUID of the DicomDataSet to be removed from the DicomDataSetCollection

In This Topic
    Remove(String) Method
    In This Topic
    Removes DicomDataSet from a DicomDataSetCollectionby matching its InstanceUID
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub Remove( _
   ByVal InstanceUID As String _
)
    'Usage

    Dim instance As DicomDataSetCollection
Dim InstanceUID As String

instance.Remove(InstanceUID)
    public void Remove(
   string InstanceUID
)

    Parameters

    InstanceUID

    The InstanceUID of the DicomDataSet to be removed from the DicomDataSetCollection

    Remarks
    The first DicomDataSet objects with the same InstanceUID will be removed from the Collection.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSetCollection Class
    DicomDataSetCollection Members
    Overload List


DicomObjects Namespace / DicomDataSetCollection Class / Send Method
String value, the IP address
Integer value, the port number
String value, the calling application entity title
String value, the called application entity title

In This Topic
    Send Method (DicomDataSetCollection)
    In This Topic
    Sends all DataSets within the collection in one association
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Function Send( _
   ByVal Node As String, _
   ByVal Port As Integer, _
   ByVal CallingAE As String, _
   ByVal CalledAE As String _
) As Integer()
    'Usage

    Dim instance As DicomDataSetCollection
Dim Node As String
Dim Port As Integer
Dim CallingAE As String
Dim CalledAE As String
Dim value() As Integer

value = instance.Send(Node, Port, CallingAE, CalledAE)
    public int[] Send(
   string Node,
   int Port,
   string CallingAE,
   string CalledAE
)

    Parameters

    Node
    String value, the IP address
    Port
    Integer value, the port number
    CallingAE
    String value, the calling application entity title
    CalledAE
    String value, the called application entity title

    Return Value

    int Array, as status of each image transfer
    Remarks
    This does the send in ONE association and returns an array of integers as the status of each transfer. Association is closed automatically once sending has completed.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSetCollection Class
    DicomDataSetCollection Members


DicomObjects Namespace / DicomDataSetCollection Class / WriteJson Method
The Stream to write to

    WriteJson Method (DicomDataSetCollection)
    In This Topic
    Write DICOM data to a JSON Stream
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Sub WriteJson( _
   ByVal Stream As Stream _
)
    'Usage

    Dim instance As DicomDataSetCollection
Dim Stream As Stream

instance.WriteJson(Stream)
    public void WriteJson(
   Stream Stream
)

    Parameters

    Stream
    The Stream to write to
    Remarks
    The JSON data will be compliant with the Native DICOM Model outlined in the DICOM Part 18, with modifications as defined in supplement 163 to allow bulk data
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSetCollection Class
    DicomDataSetCollection Members


%%PageItemTitle%% $$Properties$$

DicomObjects Namespace / DicomDataSetCollection Class

    DicomDataSetCollection Class Properties
    In This Topic

    For a list of all members of this type, see DicomDataSetCollection members.

    Public Properties
     | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<DicomDataSet>)
Public Property | Item | Overloaded. Provides access to collection item via its InstanceUID
Public Property | SopUIDList | Contains a list of SOP Class UIDs for all DataSet items contained in this Collection
Public Property | Tag | A general purpose Tag for developer use
    Top
    See Also

    Reference

    DicomDataSetCollection Class
    DicomObjects Namespace


DicomObjects Namespace / DicomDataSetCollection Class / Item Property

    Item Property (DicomDataSetCollection)
    In This Topic
    Provides access to collection item via its InstanceUID
    Overload List
    Overload | Description
Item(String) | Provides access to collection item via its InstanceUID
Item(Int32) | (Inherited from System.Collections.ObjectModel.Collection<DicomDataSet>)
    Remarks
    This is the default indexer. Individual DicomDataSet item can be accessed via DicomDataSetCollection[InstanceUID].
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSetCollection Class
    DicomDataSetCollection Members


DicomObjects Namespace / DicomDataSetCollection Class / Item Property / Item(String) Property

String, the Instance UID of the DicomDataSet

    Item(String) Property
    In This Topic
    Provides access to collection item via its InstanceUID
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads ReadOnly Property Item( _
   ByVal InstanceUID As String _
) As DicomDataSet
    'Usage

    Dim instance As DicomDataSetCollection
Dim InstanceUID As String
Dim value As DicomDataSet

value = instance.Item(InstanceUID)
    public DicomDataSet Item(
   string InstanceUID
) {get;}

    Parameters

    InstanceUID

    String, the Instance UID of the DicomDataSet

    Remarks
    This is the default indexer. Individual DicomDataSet item can be accessed via DicomDataSetCollection[InstanceUID].
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSetCollection Class
    DicomDataSetCollection Members
    Overload List


DicomObjects Namespace / DicomDataSetCollection Class / SopUIDList Property

    SopUIDList Property
    Contains a list of SOP Class UIDs for all DataSet items contained in this Collection
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property SopUIDList As String()
    'Usage

    Dim instance As DicomDataSetCollection
Dim value() As String

value = instance.SopUIDList
    public string[] SopUIDList {get;}
    Remarks
    Returns an empty Array if the DicomDataSetCollection is empty, otherwise it returns a list of SOP Class UIDs of all DataSet items.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSetCollection Class
    DicomDataSetCollection Members


DicomObjects Namespace / DicomDataSetCollection Class / Tag Property

    Tag Property (DicomDataSetCollection)
    In This Topic
    A general purpose Tag for developer use
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property Tag As Object
    'Usage

    Dim instance As DicomDataSetCollection
Dim value As Object

instance.Tag = value

value = instance.Tag
    public object Tag {get; set;}
    Remarks
    This property is not used by DicomObjects in any way, and is provided purely as a convenience for developers who wish to associate other objects with this object. As an alternative, most of the objects in DicomObjects can have other classes derived from them.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSetCollection Class
    DicomDataSetCollection Members


%%PageItemTitle%%

DicomObjects Namespace / DicomException Class
Members

In This Topic
    DicomException Class
    In This Topic
    Specific Exception for DICOM errors
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Class DicomException
   Inherits System.Exception
    'Usage

    Dim instance As DicomException
    public class DicomException : System.Exception
    Remarks
    Where possible, "standard" exceptions are thrown (file not found etc.) but this exception class exists to handle more specialized DICOM exceptions

    Where possible, "standard" exceptions are thrown (file not found etc.) but this exception class exists to handle more specialized DICOM exceptions

    For validation errors, the more specific derived class, DicomObjects.Validation.ValidationException is used instead

    Inheritance Hierarchy

    System.Object
    System.Exception
    DicomObjects.DicomException
    DicomObjects.Validation.ValidationException

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomException Members
    DicomObjects Namespace


%%PageItemTitle%% $$Members$$

DicomObjects Namespace / DicomException Class
Properties Methods

In This Topic
    DicomException Class Members
    In This Topic

    The following tables list the members exposed by DicomException.

    Public Constructors
     | Name | Description
Public Constructor | DicomException Constructor | Overloaded. Create a new DicomException
    Top
    Public Properties
     | Name | Description
Public Property | CausedAbort | True if this exception caused the related to association to issue an Abort (thereby no longer requiring to be closed)
Public Property | Code | The Error code
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | Tag | A general purpose Tag for developer use
Public Property | TargetSite | (Inherited from System.Exception)
    Top
    Public Methods
     | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
    Top
    See Also

    Reference

    DicomException Class
    DicomObjects Namespace


%%PageItemTitle%%

DicomObjects Namespace / DicomException Class / DicomException Constructor

In This Topic
    DicomException Constructor
    In This Topic
    Create a new DicomException
    Overload List
    Overload | Description
DicomException Constructor(Int32) | Create a new DicomException
DicomException Constructor(Int32,String) | Create a new DicomException
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomException Class
    DicomException Members


%%PageItemTitle%%

DicomObjects Namespace / DicomException Class / DicomException Constructor / DicomException Constructor(Int32)
The DicomObjects error code

In This Topic
    DicomException Constructor(Int32)
    In This Topic
    Create a new DicomException
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Function New( _
   ByVal code As Integer _
)
    'Usage

    Dim code As Integer

Dim instance As New DicomException(code)
    public DicomException(
   int code
)

    Parameters

    code
    The DicomObjects error code
    Remarks
    This is only intended for internal use, but is made public for use by external codecs
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomException Class
    DicomException Members
    Overload List


%%PageItemTitle%%

DicomObjects Namespace / DicomException Class / DicomException Constructor / DicomException Constructor(Int32,String)
Error code
Associated string to be inserted

In This Topic
    DicomException Constructor(Int32,String)
    In This Topic
    Create a new DicomException
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Function New( _
   ByVal code As Integer, _
   ByVal val As String _
)
    'Usage

    Dim code As Integer
Dim val As String

Dim instance As New DicomException(code, val)
    public DicomException(
   int code,
   string val
)

    Parameters

    code
    Error code
    val
    Associated string to be inserted
    Remarks
    This is only intended for internal use, but is made public for use by external codecs
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomException Class
    DicomException Members
    Overload List


%%PageItemTitle%% $$Properties$$

DicomObjects Namespace / DicomException Class

    DicomException Class Properties
    In This Topic

    For a list of all members of this type, see DicomException members.

    Public Properties
     | Name | Description
Public Property | CausedAbort | True if this exception caused the related to association to issue an Abort (thereby no longer requiring to be closed)
Public Property | Code | The Error code
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | Tag | A general purpose Tag for developer use
Public Property | TargetSite | (Inherited from System.Exception)
    Top
    See Also

    Reference

    DicomException Class
    DicomObjects Namespace


DicomObjects Namespace / DicomException Class / CausedAbort Property

    CausedAbort Property
    True if this exception caused the related to association to issue an Abort (thereby no longer requiring to be closed)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property CausedAbort As Boolean
    'Usage

    Dim instance As DicomException
Dim value As Boolean

value = instance.CausedAbort
    public bool CausedAbort {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomException Class
    DicomException Members


DicomObjects Namespace / DicomException Class / Code Property

    Code Property
    The Error code
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property Code As Integer
    'Usage

    Dim instance As DicomException
Dim value As Integer

value = instance.Code
    public int Code {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomException Class
    DicomException Members


DicomObjects Namespace / DicomException Class / Tag Property

    Tag Property (DicomException)
    In This Topic
    A general purpose Tag for developer use
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property Tag As Object
    'Usage

    Dim instance As DicomException
Dim value As Object

instance.Tag = value

value = instance.Tag
    public object Tag {get; set;}
    Remarks
    This property is not used by DicomObjects in any way, and is provided purely as a convenience for developers who wish to associate other objects with this object. As an alternative, most of the objects in DicomObjects can have other classes derived from them.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomException Class
    DicomException Members


%%PageItemTitle%%

DicomObjects Namespace / DicomGlobal Class
Members

In This Topic
    DicomGlobal Class
    In This Topic
    Placeholder for various static methods and properties
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public MustInherit NotInheritable Class DicomGlobal
    'Usage

    Dim instance As DicomGlobal
    public static class DicomGlobal
    Remarks
    Properties may be set and methods called from a config file if necessary - see Config File for more information.
    Inheritance Hierarchy

    System.Object
    DicomObjects.DicomGlobal

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Members
    DicomObjects Namespace


%%PageItemTitle%% $$Members$$

DicomObjects Namespace / DicomGlobal Class
Properties Methods Events

In This Topic
    DicomGlobal Class Members
    In This Topic

    The following tables list the members exposed by DicomGlobal.

    Public Properties
     | Name | Description
static (Shared in Visual Basic) | AssemblyDirectory | Returns the Assembly Directory information
static (Shared in Visual Basic) | AssemblyVersion | Gets the Assembly Version of DicomObjects.NET
static (Shared in Visual Basic) | Assume2022Escapes | Controls whether DicomObjects attempts to locate unannounced 2022 escape sequences
static (Shared in Visual Basic) | BufferSize | User controlled internal buffer size if attribute data is a large array. This will define the array size for the list of arrays needed to handle the attribute value. Used to avoid .NET's array dimension limit for very large data
static (Shared in Visual Basic) | ChangeLossyUIDs | Controls whether DicomObjects changes the UID when doing lossy compression
static (Shared in Visual Basic) | CloseFilesAfterReading | Controls how pixel data is read from disk
static (Shared in Visual Basic) | ColourConverter | Interface to allow override of the default CIELab <=> RGB conversion
static (Shared in Visual Basic) | CombinePDVs | Controls whether to combine outgoing command and data PDVs into a single PDU
static (Shared in Visual Basic) | CurrentLogFileName | Returns the Current DicomObjects Log File Name in full.
static (Shared in Visual Basic) | DefaultCharacterSet | Default Character to set to use if 0008,0005 is absent
static (Shared in Visual Basic) | DefaultFFmpegFilter | Description of the Default filter to apply for FFmpeg processing
static (Shared in Visual Basic) | DefaultIpAddressFamily | The IP Address family to be used where not otherwise specified
static (Shared in Visual Basic) | DefaultReadBehaviour | Default behaviour when reading or receiving files
static (Shared in Visual Basic) | DefaultSOPClasses | Default list of SOP class UID's (Abstract syntaxes) to be used until specifically overridden by user settings
static (Shared in Visual Basic) | DefaultWriteBehaviour | Default behaviour when writing or sending files
static (Shared in Visual Basic) | DeidentifyInLog | A list of keywords fo attributes which should not be included in any standard log file.
static (Shared in Visual Basic) | DescriptionAsSerializationTag | To use attribute string description as tag for Json/XML serialization
static (Shared in Visual Basic) | DirectionStrings | Language specific indicators for anatomic labelling
static (Shared in Visual Basic) | DisplayCacheTime | Controls how long display cache copies of images are retained.
static (Shared in Visual Basic) | Enable10BitDisplay | To allows support for 10bit data.
static (Shared in Visual Basic) | EventLogLevel | Controls the logging of diagnostic message to the LogEvent event.
static (Shared in Visual Basic) | FailOnSuspiciousPreamble | Detect any non-zero data in the preamble (the first 128 bytes) leading to 'DICM', and alert if any unwanted bytes or malicious code is present. A pre-defined list of file formats PreambleFileSignatures is used for checking against the non-zero preamble This mainly affects data with such preamble when reading it in. Writing to disk or sending using DICOM protocol would remove existing preamble (effectively cleaning any malicious preamble) and recreate it when written to disk on the receiving side
static (Shared in Visual Basic) | FileVersion | Gets the File Version of DicomObjects.NET
static (Shared in Visual Basic) | FlushLevel | A level to cause the log to be flushed to disk
static (Shared in Visual Basic) | FontScaling | The factor by which to increase the font size when using DirectX display mode. The default is 1.5, which gives appearance similar to those in GDI mode.
static (Shared in Visual Basic) | HologicCompressedDataAttributeElements | List of attribute elements known to be used by Hologic for their compressed frames used to detect any compressed data in private sequence
static (Shared in Visual Basic) | IgnoreShortPixelData | Try to ignore Short pixel data error to suppress read exception. This does not fix any faulty attributes or guarantee the read pixels are correct and complete
static (Shared in Visual Basic) | ImplementationName | The Implementation Name of this application
static (Shared in Visual Basic) | ImplementationUID | The Implementation UID of this application
static (Shared in Visual Basic) | IndentJson | Controls whether JSON generated is indented and formatted for easy human interpretation
static (Shared in Visual Basic) | JpipInitialSize | The size of the first request (in bytes) to make to a JPIP server.
static (Shared in Visual Basic) | LockGdiOperations | Controls whether to use an explicit lock to prevent recurrent GDI operations from happening
static (Shared in Visual Basic) | LogLicenceDetails | Controls logging of licence initialization details Suggested use is for debugging purposes only
static (Shared in Visual Basic) | MaximumDateTime | Control the global MaximumDateTime value used by DicomObjects. Default value is DateTime.MaxValue
static (Shared in Visual Basic) | MaximumNesting | Controls to what level deep are nested Sequences parsed
static (Shared in Visual Basic) | MaximumPDUSize | The Maximum PDU size accepted and used by DicomObjects
static (Shared in Visual Basic) | MinFontSize | Contains the Minimum SKFont SKSizeI used when drawing Text Label.
static (Shared in Visual Basic) | MinimumDateTime | Control the global MinimumDateTime value used by DicomObjects. Default value is DateTime.MinValue
static (Shared in Visual Basic) | MoveTimesOut | Controls whether DicomObjects will time out during a C-MOVE operation
static (Shared in Visual Basic) | PreambleFileSignatures | A pre-defined modifiable list of file signatures to match against the preamble if FailOnSuspiciousPreamble is enabled
static (Shared in Visual Basic) | PreferredBitmapMode | Controls method of rendering used by "Bitmap"
static (Shared in Visual Basic) | PreferredCodec | Codec to prioritize if applicable
static (Shared in Visual Basic) | PreserveDoublePrecision | Retain precision for double numbers
static (Shared in Visual Basic) | ProductName | The product name to be shown in licensing Dialogs etc. Default value is "DicomObjects".
static (Shared in Visual Basic) | QuadrupedDirectionStrings | The quadruped equivalent of DirectionStrings allowing localisation of these abbreviations
static (Shared in Visual Basic) | RenderException | Controls whether non-image objects throw an exception during rendering
static (Shared in Visual Basic) | ReUseArrays | Controls whether DicomObjcts re-uses arrays to hold pixel data
static (Shared in Visual Basic) | ReuseOnlyExactArraySize | Controls whether "Over-sized" arrays are used
static (Shared in Visual Basic) | RunningInDocker | Flag to see if application is runner in a Docker container
static (Shared in Visual Basic) | ShowTextBoxForPresentationStates | Controls whether bounding boxes are drawn around internally generated DicomLabel objects derived from text entries in Presentation States
static (Shared in Visual Basic) | SigningLicensePrefix | Set to tell DicomObjects to check the exe.{Prefix}.lic, instead of default exe.lic file
static (Shared in Visual Basic) | ThreadCount | Controls how many threads may be used by DicomObjects when rendering etc.
static (Shared in Visual Basic) | Timeout | The period of time that a network operation will wait if there is no response from the peer
static (Shared in Visual Basic) | UIDRoot | UIDRoot used by the NewUID method
static (Shared in Visual Basic) | UsePerformanceCounters | Controls use of specific performance counters for DicomObjects
static (Shared in Visual Basic) | UsePixelCache | Controls whether to use an area of memory as a pixel cache to reduce demands on the memory allocator
static (Shared in Visual Basic) | ValidDateMax | Maximum allowed DateTime for validation purposes Default value is DateTime.MaxValue
static (Shared in Visual Basic) | ValidDateMin | Minimum allowed DateTime for validation purposes Default value is DateTime.MinValue
    Top
    Public Methods
     | Name | Description
static (Shared in Visual Basic) | AcceptedTransferSyntaxes | List of Transfer Syntaxes accepted by default for a group of SOP classes
static (Shared in Visual Basic) | AddDictionaryElement | Adds Non-Private Data Element to the Dictionary.
static (Shared in Visual Basic) | AddPrivateDictionaryElement | Adds Private Data Element Creator to the Dictionary.
static (Shared in Visual Basic) | AddToAcceptedTransferSyntaxes | Add an accepted Transfer Syntax into a group used to help control automatic acceptance of transfer syntaxes
static (Shared in Visual Basic) | AddToOfferedTransferSyntaxes | Add an offered Transfer Syntax into a group used to help control automatic acceptance of transfer syntaxes
static (Shared in Visual Basic) | AddToSOPClassGroup | Add a SOP class into a group used to help control use of associated transfer syntaxes
static (Shared in Visual Basic) | ClearAcceptedTransferSyntaxes | Clear all accepted Transfer Syntaxes from a group used to help control automatic acceptance of transfer syntaxes
static (Shared in Visual Basic) | ClearOfferedTransferSyntaxes | Clear all offered Transfer Syntaxes from a group used to help control automatic acceptance of transfer syntaxes
static (Shared in Visual Basic) | ClearSOPClassGroup | Clear all SOP classes from a group used to help control use of associated transfer syntaxes
static (Shared in Visual Basic) | Echo | Sends a DICOM verify (C-ECHO), with IP address, port number, callingAET, calledAET to another application entity, and returns the result
static (Shared in Visual Basic) | FindGroup | Find to which group a particular SOP class is currently assigned
static (Shared in Visual Basic) | GenerateWsiTileOffsets | Parses WSI tile fragments consisting of offset and length of all WSI tiles present in this instance for quick access
static (Shared in Visual Basic) | GetRegString | Overloaded. Returns the key values from internal look up table
static (Shared in Visual Basic) | GetRegWord | Overloaded. Returns the key values from internal look up table
static (Shared in Visual Basic) | GetStatusCodeType | Checks if status code is a defined error code
static (Shared in Visual Basic) | GuidToUID | Construct a DICOM UID from Universally Unique Identifier (GUID) based on the method defined in ISO/IEC 9834-8 / ITU-T X.667
static (Shared in Visual Basic) | IgnoreAttribute | Instruct DicomObjects to ignore particular attributes
static (Shared in Visual Basic) | IgnoreAttributeGroup | Instruct DicomObjects to ignore particular attributes
static (Shared in Visual Basic) | IsDICOM | Overloaded. Methods to check for DICOM content
static (Shared in Visual Basic) | IsEncrypted | Tests whether a DICOM file is encrypted according the CMS encoding defined in DICOM supplement 895
static (Shared in Visual Basic) | Keyword | Overloaded. Construct a keyword from arbitrary group and element hex string (not the integer values)
static (Shared in Visual Basic) | KeywordElement | Returns the "element" number for a keyword
static (Shared in Visual Basic) | KeywordGroup | Returns the "group" number for a keyword
static (Shared in Visual Basic) | KeywordTag | Construct a string representation of the Group and Element number of keyword
static (Shared in Visual Basic) | LoadConfigFile | Forces loading of the XML configuration file
static (Shared in Visual Basic) | Log | Add text to the log file.
static (Shared in Visual Basic) | LogToFile | Overloaded. Enables DicomObjects logging
static (Shared in Visual Basic) | LogToFileStop | Stop logging to the currently active file
static (Shared in Visual Basic) | LogToLogger | Overloaded. Enables DicomObjects logging to a user provided Microsoft ILogger interface
static (Shared in Visual Basic) | LogToStream | Enables DicomObjects logging to a user provided stream
static (Shared in Visual Basic) | MakeDictionary | Create a Dataset containing a null copy of all 'known' possible attributes
static (Shared in Visual Basic) | NewUID | Generates a guaranteed unique valid DICOM UID
static (Shared in Visual Basic) | OfferedTransferSyntaxes | List of Transfer Syntaxes offered by default for a group of SOP classes
static (Shared in Visual Basic) | RemoveFromAcceptedTransferSyntaxes | Remove an accepted Transfer Syntax from a group used to help control automatic acceptance of transfer syntaxes
static (Shared in Visual Basic) | RemoveFromOfferedTransferSyntaxes | Remove an offered Transfer Syntax from a group used to help control automatic acceptance of transfer syntaxes
static (Shared in Visual Basic) | RemoveFromSOPClassGroup | Remove a SOP class from a group used to help control use of associated transfer syntaxes
static (Shared in Visual Basic) | ResetPixelCache | Clear any existing pixel cache
static (Shared in Visual Basic) | SetRegString | Insert or replace values in the internal virtual registry
static (Shared in Visual Basic) | SetRegWord | Sets key values in the internal look up table
static (Shared in Visual Basic) | SOPClassGroup | Groups of SOP classes that use the same default Transfer Syntaxes
static (Shared in Visual Basic) | Zoom | The Zoom factor corresponding to a given SkiaSharp.SKMatrix object
    Top
    Public Events
     | Name | Description
Public Event | LogEvent | Event fires when loggable events occur
Public Event | OnChangeUid | Event fired when DicomObjects should change a UID for an object
Public Event | ValidateFragments | Routine to allow validation (and if necessary, correction) of fragments of compressed pixel data
    Top
    See Also

    Reference

    DicomGlobal Class
    DicomObjects Namespace


%%PageItemTitle%% $$Methods$$

DicomObjects Namespace / DicomGlobal Class

    DicomGlobal Class Methods
    In This Topic

    For a list of all members of this type, see DicomGlobal members.

    Public Methods
     | Name | Description
static (Shared in Visual Basic) | AcceptedTransferSyntaxes | List of Transfer Syntaxes accepted by default for a group of SOP classes
static (Shared in Visual Basic) | AddDictionaryElement | Adds Non-Private Data Element to the Dictionary.
static (Shared in Visual Basic) | AddPrivateDictionaryElement | Adds Private Data Element Creator to the Dictionary.
static (Shared in Visual Basic) | AddToAcceptedTransferSyntaxes | Add an accepted Transfer Syntax into a group used to help control automatic acceptance of transfer syntaxes
static (Shared in Visual Basic) | AddToOfferedTransferSyntaxes | Add an offered Transfer Syntax into a group used to help control automatic acceptance of transfer syntaxes
static (Shared in Visual Basic) | AddToSOPClassGroup | Add a SOP class into a group used to help control use of associated transfer syntaxes
static (Shared in Visual Basic) | ClearAcceptedTransferSyntaxes | Clear all accepted Transfer Syntaxes from a group used to help control automatic acceptance of transfer syntaxes
static (Shared in Visual Basic) | ClearOfferedTransferSyntaxes | Clear all offered Transfer Syntaxes from a group used to help control automatic acceptance of transfer syntaxes
static (Shared in Visual Basic) | ClearSOPClassGroup | Clear all SOP classes from a group used to help control use of associated transfer syntaxes
static (Shared in Visual Basic) | Echo | Sends a DICOM verify (C-ECHO), with IP address, port number, callingAET, calledAET to another application entity, and returns the result
static (Shared in Visual Basic) | FindGroup | Find to which group a particular SOP class is currently assigned
static (Shared in Visual Basic) | GenerateWsiTileOffsets | Parses WSI tile fragments consisting of offset and length of all WSI tiles present in this instance for quick access
static (Shared in Visual Basic) | GetRegString | Overloaded. Returns the key values from internal look up table
static (Shared in Visual Basic) | GetRegWord | Overloaded. Returns the key values from internal look up table
static (Shared in Visual Basic) | GetStatusCodeType | Checks if status code is a defined error code
static (Shared in Visual Basic) | GuidToUID | Construct a DICOM UID from Universally Unique Identifier (GUID) based on the method defined in ISO/IEC 9834-8 / ITU-T X.667
static (Shared in Visual Basic) | IgnoreAttribute | Instruct DicomObjects to ignore particular attributes
static (Shared in Visual Basic) | IgnoreAttributeGroup | Instruct DicomObjects to ignore particular attributes
static (Shared in Visual Basic) | IsDICOM | Overloaded. Methods to check for DICOM content
static (Shared in Visual Basic) | IsEncrypted | Tests whether a DICOM file is encrypted according the CMS encoding defined in DICOM supplement 895
static (Shared in Visual Basic) | Keyword | Overloaded. Construct a keyword from arbitrary group and element hex string (not the integer values)
static (Shared in Visual Basic) | KeywordElement | Returns the "element" number for a keyword
static (Shared in Visual Basic) | KeywordGroup | Returns the "group" number for a keyword
static (Shared in Visual Basic) | KeywordTag | Construct a string representation of the Group and Element number of keyword
static (Shared in Visual Basic) | LoadConfigFile | Forces loading of the XML configuration file
static (Shared in Visual Basic) | Log | Add text to the log file.
static (Shared in Visual Basic) | LogToFile | Overloaded. Enables DicomObjects logging
static (Shared in Visual Basic) | LogToFileStop | Stop logging to the currently active file
static (Shared in Visual Basic) | LogToLogger | Overloaded. Enables DicomObjects logging to a user provided Microsoft ILogger interface
static (Shared in Visual Basic) | LogToStream | Enables DicomObjects logging to a user provided stream
static (Shared in Visual Basic) | MakeDictionary | Create a Dataset containing a null copy of all 'known' possible attributes
static (Shared in Visual Basic) | NewUID | Generates a guaranteed unique valid DICOM UID
static (Shared in Visual Basic) | OfferedTransferSyntaxes | List of Transfer Syntaxes offered by default for a group of SOP classes
static (Shared in Visual Basic) | RemoveFromAcceptedTransferSyntaxes | Remove an accepted Transfer Syntax from a group used to help control automatic acceptance of transfer syntaxes
static (Shared in Visual Basic) | RemoveFromOfferedTransferSyntaxes | Remove an offered Transfer Syntax from a group used to help control automatic acceptance of transfer syntaxes
static (Shared in Visual Basic) | RemoveFromSOPClassGroup | Remove a SOP class from a group used to help control use of associated transfer syntaxes
static (Shared in Visual Basic) | ResetPixelCache | Clear any existing pixel cache
static (Shared in Visual Basic) | SetRegString | Insert or replace values in the internal virtual registry
static (Shared in Visual Basic) | SetRegWord | Sets key values in the internal look up table
static (Shared in Visual Basic) | SOPClassGroup | Groups of SOP classes that use the same default Transfer Syntaxes
static (Shared in Visual Basic) | Zoom | The Zoom factor corresponding to a given SkiaSharp.SKMatrix object
    Top
    See Also

    Reference

    DicomGlobal Class
    DicomObjects Namespace


DicomObjects Namespace / DicomGlobal Class / AcceptedTransferSyntaxes Method
The SOPClassGroups

    AcceptedTransferSyntaxes Method
    In This Topic
    List of Transfer Syntaxes accepted by default for a group of SOP classes
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Function AcceptedTransferSyntaxes( _
   ByVal Group As SOPClassGroups _
) As List(Of String)
    'Usage

    Dim Group As SOPClassGroups
Dim value As List(Of String)

value = DicomGlobal.AcceptedTransferSyntaxes(Group)
    public static List<string> AcceptedTransferSyntaxes(
   SOPClassGroups Group
)

    Parameters

    Group
    The SOPClassGroups

    Return Value

    A list of Transfer Syntaxes to be accepted
    Remarks

    The list is pre-populated at initialization, but may be modified by the user

    This method is intended for advanced usage - for simpler methods see:

    • AddToAcceptedTransferSyntaxes
    • RemoveFromAcceptedTransferSyntaxes
    • ClearAcceptedTransferSyntaxes

    To control the related SOP classes and accepted transfer syntaxes associated with the group see:

    • AddToSOPClassGroup
    • RemoveFromSOPClassGroup
    • ClearSOPClassGroup
    • AddToOfferedTransferSyntaxes
    • RemoveFromOfferedTransferSyntaxes
    • ClearOfferedTransferSyntaxes
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / AddDictionaryElement Method
Integer value, the group index of the data element.
Integer value, the element index of the data element.
String value, the value representation of the new data element.
String value, the value multiplicity of the data element.
String value, the description of the data element.

In This Topic
    AddDictionaryElement Method
    In This Topic
    Adds Non-Private Data Element to the Dictionary.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Sub AddDictionaryElement( _
   ByVal Group As Integer, _
   ByVal Element As Integer, _
   ByVal VR As String, _
   ByVal VM As String, _
   ByVal Description As String _
)
    'Usage

    Dim Group As Integer
Dim Element As Integer
Dim VR As String
Dim VM As String
Dim Description As String

DicomGlobal.AddDictionaryElement(Group, Element, VR, VM, Description)
    public static void AddDictionaryElement(
   int Group,
   int Element,
   string VR,
   string VM,
   string Description
)

    Parameters

    Group
    Integer value, the group index of the data element.
    Element
    Integer value, the element index of the data element.
    VR
    String value, the value representation of the new data element.
    VM
    String value, the value multiplicity of the data element.
    Description
    String value, the description of the data element.
    Remarks

    If the specified Group and Element locate an existing data element in the dictionary, that data element will be removed from the dictionary and the new data element will be added to the dictionary. Otherwise, a new dictionary entry for the specified data element will be created.

    Following the link to see more information about Group, Element, VR, VM and Description.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / AddPrivateDictionaryElement Method
Integer value, the group index of the data element.
Byte value, the lower byte element index of the data element.
The name of the private creator
String value, the value representation of the new data element.
String value, the value multiplicity of the data element.
String value, the description of the data element.

In This Topic
    AddPrivateDictionaryElement Method
    In This Topic
    Adds Private Data Element Creator to the Dictionary.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Sub AddPrivateDictionaryElement( _
   ByVal Group As Integer, _
   ByVal Element As Byte, _
   ByVal Creator As String, _
   ByVal VR As String, _
   ByVal VM As String, _
   ByVal Description As String _
)
    'Usage

    Dim Group As Integer
Dim Element As Byte
Dim Creator As String
Dim VR As String
Dim VM As String
Dim Description As String

DicomGlobal.AddPrivateDictionaryElement(Group, Element, Creator, VR, VM, Description)
    public static void AddPrivateDictionaryElement(
   int Group,
   byte Element,
   string Creator,
   string VR,
   string VM,
   string Description
)

    Parameters

    Group
    Integer value, the group index of the data element.
    Element
    Byte value, the lower byte element index of the data element.
    Creator
    The name of the private creator
    VR
    String value, the value representation of the new data element.
    VM
    String value, the value multiplicity of the data element.
    Description
    String value, the description of the data element.
    Remarks

    If the specified Group and Element locate an existing data element in the private element dictionary, that data element will be removed from the dictionary and the new data element will be added to the dictionary. Otherwise, a new dictionary entry for the specified data element will be created.

    The Creator is a string which will be found in the element GGGG,00EE and identifies the creator of this private element

    DicomGlobal.AddPrivateDictionaryElement(0x0023, 0x10, "privateCreator for block (0023,1000) - (0023,10FF)", "LO", "1", "Description of this private attribute"); DicomGlobal.AddDictionaryElement(0x23, 0x1001, "LT", "1", "private tag 1"); DicomDataSet ds = new DicomDataSet(); ds.Add(0x23, 0x1001, "Test Value");
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / AddToAcceptedTransferSyntaxes Method
The group to add the accepted Transfer Syntax to
The accepted Transfer Syntax to add

In This Topic
    AddToAcceptedTransferSyntaxes Method
    In This Topic
    Add an accepted Transfer Syntax into a group used to help control automatic acceptance of transfer syntaxes
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Sub AddToAcceptedTransferSyntaxes( _
   ByVal Group As SOPClassGroups, _
   ByVal TransferSyntax As UID _
)
    'Usage

    Dim Group As SOPClassGroups
Dim TransferSyntax As UID

DicomGlobal.AddToAcceptedTransferSyntaxes(Group, TransferSyntax)
    public static void AddToAcceptedTransferSyntaxes(
   SOPClassGroups Group,
   UID TransferSyntax
)

    Parameters

    Group
    The group to add the accepted Transfer Syntax to
    TransferSyntax
    The accepted Transfer Syntax to add
    Remarks

    The groups are pre-populated at initialization, but may be modified by the user

    For direct access to the underlying List of Strings to allow advanced usage see AcceptedTransferSyntaxes

    See Also:

    • AddToSOPClassGroup
    • RemoveFromSOPClassGroup
    • ClearSOPClassGroup
    • RemoveFromAcceptedTransferSyntaxes
    • ClearAcceptedTransferSyntaxes
    • AddToOfferedTransferSyntaxes
    • RemoveFromOfferedTransferSyntaxes
    • ClearOfferedTransferSyntaxes
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / AddToOfferedTransferSyntaxes Method
The group to add the offered Transfer Syntax to
The offered Transfer Syntax to add

In This Topic
    AddToOfferedTransferSyntaxes Method
    In This Topic
    Add an offered Transfer Syntax into a group used to help control automatic acceptance of transfer syntaxes
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Sub AddToOfferedTransferSyntaxes( _
   ByVal Group As SOPClassGroups, _
   ByVal TransferSyntax As UID _
)
    'Usage

    Dim Group As SOPClassGroups
Dim TransferSyntax As UID

DicomGlobal.AddToOfferedTransferSyntaxes(Group, TransferSyntax)
    public static void AddToOfferedTransferSyntaxes(
   SOPClassGroups Group,
   UID TransferSyntax
)

    Parameters

    Group
    The group to add the offered Transfer Syntax to
    TransferSyntax
    The offered Transfer Syntax to add
    Remarks

    The groups are pre-populated at initialization, but may be modified by the user

    For direct access to the underlying List of Strings to allow advanced usage see OfferedTransferSyntaxes

    See Also:

    • AddToSOPClassGroup
    • RemoveFromSOPClassGroup
    • ClearSOPClassGroup
    • AddToAcceptedTransferSyntaxes
    • RemoveFromAcceptedTransferSyntaxes
    • ClearAcceptedTransferSyntaxes
    • RemoveFromOfferedTransferSyntaxes
    • ClearOfferedTransferSyntaxes
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / AddToSOPClassGroup Method
The group to add the SOP class to
The SOP class to add

In This Topic
    AddToSOPClassGroup Method
    In This Topic
    Add a SOP class into a group used to help control use of associated transfer syntaxes
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Sub AddToSOPClassGroup( _
   ByVal Group As SOPClassGroups, _
   ByVal SOPClass As UID _
)
    'Usage

    Dim Group As SOPClassGroups
Dim SOPClass As UID

DicomGlobal.AddToSOPClassGroup(Group, SOPClass)
    public static void AddToSOPClassGroup(
   SOPClassGroups Group,
   UID SOPClass
)

    Parameters

    Group
    The group to add the SOP class to
    SOPClass
    The SOP class to add
    Remarks

    The groups are pre-populated at initialization, but may be modified by the user

    For direct access to the underlying List of Strings to allow advanced usage see SOPClassGroup

    See Also:

    • RemoveFromSOPClassGroup
    • ClearSOPClassGroup
    • AddToAcceptedTransferSyntaxes
    • RemoveFromAcceptedTransferSyntaxes
    • ClearAcceptedTransferSyntaxes
    • AddToOfferedTransferSyntaxes
    • RemoveFromOfferedTransferSyntaxes
    • ClearOfferedTransferSyntaxes
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / ClearAcceptedTransferSyntaxes Method
The list of accepted Transfer Syntaxes to clear

    ClearAcceptedTransferSyntaxes Method
    In This Topic
    Clear all accepted Transfer Syntaxes from a group used to help control automatic acceptance of transfer syntaxes
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Sub ClearAcceptedTransferSyntaxes( _
   ByVal Group As SOPClassGroups _
)
    'Usage

    Dim Group As SOPClassGroups

DicomGlobal.ClearAcceptedTransferSyntaxes(Group)
    public static void ClearAcceptedTransferSyntaxes(
   SOPClassGroups Group
)

    Parameters

    Group
    The list of accepted Transfer Syntaxes to clear
    Remarks

    The groups are pre-populated at initialization, but may be modified by the user

    For direct access to the underlying List of Strings to allow advanced usage see AcceptedTransferSyntaxes

    See Also:

    • AddToSOPClassGroup
    • RemoveFromSOPClassGroup
    • ClearSOPClassGroup
    • AddToAcceptedTransferSyntaxes
    • RemoveFromAcceptedTransferSyntaxes
    • AddToOfferedTransferSyntaxes
    • RemoveFromOfferedTransferSyntaxes
    • ClearOfferedTransferSyntaxes
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / ClearOfferedTransferSyntaxes Method
The list of offered Transfer Syntaxes to clear

    ClearOfferedTransferSyntaxes Method
    In This Topic
    Clear all offered Transfer Syntaxes from a group used to help control automatic acceptance of transfer syntaxes
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Sub ClearOfferedTransferSyntaxes( _
   ByVal Group As SOPClassGroups _
)
    'Usage

    Dim Group As SOPClassGroups

DicomGlobal.ClearOfferedTransferSyntaxes(Group)
    public static void ClearOfferedTransferSyntaxes(
   SOPClassGroups Group
)

    Parameters

    Group
    The list of offered Transfer Syntaxes to clear
    Remarks

    The groups are pre-populated at initialization, but may be modified by the user

    For direct access to the underlying List of Strings to allow advanced usage see OfferedTransferSyntaxes

    See Also:

    • AddToSOPClassGroup
    • RemoveFromSOPClassGroup
    • ClearSOPClassGroup
    • AddToAcceptedTransferSyntaxes
    • RemoveFromAcceptedTransferSyntaxes
    • ClearAcceptedTransferSyntaxes
    • AddToOfferedTransferSyntaxes
    • RemoveFromOfferedTransferSyntaxes
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / ClearSOPClassGroup Method
The group to clear

    ClearSOPClassGroup Method
    In This Topic
    Clear all SOP classes from a group used to help control use of associated transfer syntaxes
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Sub ClearSOPClassGroup( _
   ByVal Group As SOPClassGroups _
)
    'Usage

    Dim Group As SOPClassGroups

DicomGlobal.ClearSOPClassGroup(Group)
    public static void ClearSOPClassGroup(
   SOPClassGroups Group
)

    Parameters

    Group
    The group to clear
    Remarks

    The groups are pre-populated at initialization, but may be modified by the user

    For direct access to the underlying List of Strings to allow advanced usage see SOPClassGroup

    See Also:

    • AddToSOPClassGroup
    • RemoveFromSOPClassGroup
    • AddToAcceptedTransferSyntaxes
    • RemoveFromAcceptedTransferSyntaxes
    • ClearAcceptedTransferSyntaxes
    • AddToOfferedTransferSyntaxes
    • RemoveFromOfferedTransferSyntaxes
    • ClearOfferedTransferSyntaxes
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / Echo Method

Remote entity name as IP address or resolvable name

Port to connect to

Calling Application Entity Titles (AETs)

Called Application Entity Titles (AETs)

In This Topic
    Echo Method (DicomGlobal)
    In This Topic
    Sends a DICOM verify (C-ECHO), with IP address, port number, callingAET, calledAET to another application entity, and returns the result
    Sends a DICOM verify (C-ECHO) and returns the result
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Function Echo( _
   ByVal Node As String, _
   ByVal Port As Integer, _
   ByVal CallingAET As String, _
   ByVal CalledAET As String _
) As Integer
    'Usage

    Dim Node As String
Dim Port As Integer
Dim CallingAET As String
Dim CalledAET As String
Dim value As Integer

value = DicomGlobal.Echo(Node, Port, CallingAET, CalledAET)
    public static int Echo(
   string Node,
   int Port,
   string CallingAET,
   string CalledAET
)

    Parameters

    Node

    Remote entity name as IP address or resolvable name

    Port

    Port to connect to

    CallingAET

    Calling Application Entity Titles (AETs)

    CalledAET

    Called Application Entity Titles (AETs)

    Return Value

    The status provided by the SCP. This should always be 0
    Remarks

    Although in theory the remote entity may return a status other than 0 to indicate an error, in most circumstances (such as remote machine turned off), this method will fail with a trappable error, such as "Fail to connection at TCP level"

    When certificate is used, a secure association will be attempted using TLS. If certificate is a valid x509 certificate, then user authentication will be used, but if it is null, then an anonymous client association will be attempted, which may or may not be accepted by the SCP.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / FindGroup Method
The SOP class to be queried

    FindGroup Method
    In This Topic
    Find to which group a particular SOP class is currently assigned
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Function FindGroup( _
   ByVal UID As String _
) As SOPClassGroups
    'Usage

    Dim UID As String
Dim value As SOPClassGroups

value = DicomGlobal.FindGroup(UID)
    public static SOPClassGroups FindGroup(
   string UID
)

    Parameters

    UID
    The SOP class to be queried

    Return Value

    The associated group
    Remarks
    If no group is found, then SOPClassGroups.Services is returned
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / GenerateWsiTileOffsets Method
Data containing the WSI tiles

    GenerateWsiTileOffsets Method
    In This Topic
    Parses WSI tile fragments consisting of offset and length of all WSI tiles present in this instance for quick access
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Function GenerateWsiTileOffsets( _
   ByVal stream As Stream _
) As IEnumerable(Of WsiTile)
    'Usage

    Dim stream As Stream
Dim value As IEnumerable(Of WsiTile)

value = DicomGlobal.GenerateWsiTileOffsets(stream)
    public static IEnumerable<WsiTile> GenerateWsiTileOffsets(
   Stream stream
)

    Parameters

    stream
    Data containing the WSI tiles

    Return Value

    A list of WSI tile fragments
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / GetRegString Method

    GetRegString Method
    Returns the key values from internal look up table
    Overload List
    Overload | Description
GetRegString(String,String) | Returns the value of a cached key with default value
GetRegString(String) | Returns the value of a cached key
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / GetRegString Method / GetRegString(String,String) Method

The name of the registry key.

The default return value.

In This Topic
    GetRegString(String,String) Method
    In This Topic
    Returns the value of a cached key with default value
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Shared Function GetRegString( _
   ByVal Name As String, _
   ByVal Default As String _
) As String
    'Usage

    Dim Name As String
Dim Default As String
Dim value As String

value = DicomGlobal.GetRegString(Name, Default)
    public static string GetRegString(
   string Name,
   string Default
)

    Parameters

    Name

    The name of the registry key.

    Default

    The default return value.

    Return Value

    string
    Remarks

    This method returns the registry key values from a internal look up table. If Name does not exist in that table, the default value will be returned.

    As DicomGlobal does not look in to registry any more (as did in COM version) for key values, instead, an internal look up table is used to provide all those options used by DicomObjects, like logging, Importing/Exporting external files, Compression/Decompression, Supported SOP Class, Supported Transfer Syntax.

    For a current list of values, se the wiki: http://www.medicalconnections.co.uk/kb/Registry_Values

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members
    Overload List


DicomObjects Namespace / DicomGlobal Class / GetRegString Method / GetRegString(String) Method

The name of the registry key.

In This Topic
    GetRegString(String) Method
    In This Topic
    Returns the value of a cached key
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Shared Function GetRegString( _
   ByVal Name As String _
) As String
    'Usage

    Dim Name As String
Dim value As String

value = DicomGlobal.GetRegString(Name)
    public static string GetRegString(
   string Name
)

    Parameters

    Name

    The name of the registry key.

    Return Value

    string
    Remarks
    This method returns the registry key values from a internal look up table. If Name does not exist in that table, it will return an empty string "".

    As DicomGlobal does not look in to registry any more (as did in COM version) for key values, instead, an internal look up table is used to provide all those options used by DicomObjects, like logging, Importing/Exporting external files, Compression/Decompression, Supported SOP Class, Supported Transfer Syntax.

    For a current list of values, se the wiki: http://www.medicalconnections.co.uk/kb/Registry_Values

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members
    Overload List


DicomObjects Namespace / DicomGlobal Class / GetRegWord Method

    GetRegWord Method
    Returns the key values from internal look up table
    Overload List
    Overload | Description
GetRegWord(String,Int32) | Returns the value of a cached key with default value
GetRegWord(String) | Returns the value of a cached key
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / GetRegWord Method / GetRegWord(String,Int32) Method

The name of the registry key.

The default return value.

In This Topic
    GetRegWord(String,Int32) Method
    In This Topic
    Returns the value of a cached key with default value
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Shared Function GetRegWord( _
   ByVal Name As String, _
   ByVal Default As Integer _
) As Integer
    'Usage

    Dim Name As String
Dim Default As Integer
Dim value As Integer

value = DicomGlobal.GetRegWord(Name, Default)
    public static int GetRegWord(
   string Name,
   int Default
)

    Parameters

    Name

    The name of the registry key.

    Default

    The default return value.

    Return Value

    int
    Remarks
    This method returns the registry key values from a internal look up table. If Name does not exist in that table, the default value will be returned.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members
    Overload List


DicomObjects Namespace / DicomGlobal Class / GetRegWord Method / GetRegWord(String) Method

The name of the registry key.

In This Topic
    GetRegWord(String) Method
    In This Topic
    Returns the value of a cached key
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Shared Function GetRegWord( _
   ByVal Name As String _
) As Integer
    'Usage

    Dim Name As String
Dim value As Integer

value = DicomGlobal.GetRegWord(Name)
    public static int GetRegWord(
   string Name
)

    Parameters

    Name

    The name of the registry key.

    Return Value

    int
    Remarks
    This method returns the registry key values from a internal look up table. If Name does not exist in that table, it will return 0.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members
    Overload List


DicomObjects Namespace / DicomGlobal Class / GetStatusCodeType Method
Status code to check

    GetStatusCodeType Method
    In This Topic
    Checks if status code is a defined error code
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Function GetStatusCodeType( _
   ByVal statusCode As StatusCode _
) As StatusType
    'Usage

    Dim statusCode As StatusCode
Dim value As StatusType

value = DicomGlobal.GetStatusCodeType(statusCode)
    public static StatusType GetStatusCodeType(
   StatusCode statusCode
)

    Parameters

    statusCode
    Status code to check

    Return Value

    Type of the status code
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / GuidToUID Method
A System.Guid object to construct the DICOM UID from

    GuidToUID Method
    In This Topic
    Construct a DICOM UID from Universally Unique Identifier (GUID) based on the method defined in ISO/IEC 9834-8 / ITU-T X.667
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Function GuidToUID( _
   ByVal guid As Guid _
) As String
    'Usage

    Dim guid As Guid
Dim value As String

value = DicomGlobal.GuidToUID(guid)
    public static string GuidToUID(
   Guid guid
)

    Parameters

    guid
    A System.Guid object to construct the DICOM UID from

    Return Value

    A DICOM UID based on the Guid object
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / IgnoreAttribute Method
The Group to ignore
The Element to ignore

In This Topic
    IgnoreAttribute Method
    In This Topic
    Instruct DicomObjects to ignore particular attributes
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Sub IgnoreAttribute( _
   ByVal Group As Integer, _
   ByVal Element As Integer _
)
    'Usage

    Dim Group As Integer
Dim Element As Integer

DicomGlobal.IgnoreAttribute(Group, Element)
    public static void IgnoreAttribute(
   int Group,
   int Element
)

    Parameters

    Group
    The Group to ignore
    Element
    The Element to ignore
    Remarks
    This is a very specialist feature, intended only to be used when receiving or reading data from systems so bad that the data cannot be fixed after reading. It is most commonly used when receiving badly formatted sequences, but in that context can only be used when they use explicit length for the sequence as a whole, as it would otherwise not be possible to determine the location of the end of the sequence.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / IgnoreAttributeGroup Method
The Group to ignore

    IgnoreAttributeGroup Method
    In This Topic
    Instruct DicomObjects to ignore particular attributes
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Sub IgnoreAttributeGroup( _
   ByVal group As UShort _
)
    'Usage

    Dim group As UShort

DicomGlobal.IgnoreAttributeGroup(group)
    public static void IgnoreAttributeGroup(
   ushort group
)

    Parameters

    group
    The Group to ignore
    Remarks
    This is a very specialist feature, intended only to be used when receiving or reading data from systems so bad that the data cannot be fixed after reading. It is most commonly used when receiving badly formatted sequences, but in that context can only be used when they use explicit length for the sequence as a whole, as it would otherwise not be possible to determine the location of the end of the sequence.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / IsDICOM Method

    IsDICOM Method
    Methods to check for DICOM content
    Overload List
    Overload | Description
IsDICOM(Stream) | A very simple method to test whether a stream contains valid DICOM
IsDICOM(String) | A very simple method to decide if a File is DICOM
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / IsDICOM Method / IsDICOM(Stream) Method
The Stream which carries the data

    IsDICOM(Stream) Method
    In This Topic
    A very simple method to test whether a stream contains valid DICOM
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Shared Function IsDICOM( _
   ByVal stream As Stream _
) As Boolean
    'Usage

    Dim stream As Stream
Dim value As Boolean

value = DicomGlobal.IsDICOM(stream)
    public static bool IsDICOM(
   Stream stream
)

    Parameters

    stream
    The Stream which carries the data

    Return Value

    True if the byte 129 - 132 is DICM and the next 8 bytes contains the group 0 header data 02 00 00 00 55 4C 04 00
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members
    Overload List


DicomObjects Namespace / DicomGlobal Class / IsDICOM Method / IsDICOM(String) Method
The full file path

    IsDICOM(String) Method
    In This Topic
    A very simple method to decide if a File is DICOM
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Shared Function IsDICOM( _
   ByVal Filename As String _
) As Boolean
    'Usage

    Dim Filename As String
Dim value As Boolean

value = DicomGlobal.IsDICOM(Filename)
    public static bool IsDICOM(
   string Filename
)

    Parameters

    Filename
    The full file path

    Return Value

    True if bytes 129 - 132 are "DICM" and the next 8 bytes contains the group 0 header data 02 00 00 00 55 4C 04 00
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members
    Overload List


DicomObjects Namespace / DicomGlobal Class / IsEncrypted Method
File to test

    IsEncrypted Method
    In This Topic
    Tests whether a DICOM file is encrypted according the CMS encoding defined in DICOM supplement 895
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Function IsEncrypted( _
   ByVal Filename As String _
) As Boolean
    'Usage

    Dim Filename As String
Dim value As Boolean

value = DicomGlobal.IsEncrypted(Filename)
    public static bool IsEncrypted(
   string Filename
)

    Parameters

    Filename
    File to test

    Return Value

    True if file is encrypted
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / Keyword Method

    Keyword Method
    Construct a keyword from arbitrary group and element hex string (not the integer values)
    Overload List
    Overload | Description
Keyword(String,String) | Construct a keyword from arbitrary group and element hex string (not the integer values)
Keyword(UInt16,UInt16) | Construct a keyword from arbitrary group and element values
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / Keyword Method / Keyword(String,String) Method
The Group value represented in hexadecimal string
The Element value represented in hexadecimal string

In This Topic
    Keyword(String,String) Method
    In This Topic
    Construct a keyword from arbitrary group and element hex string (not the integer values)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Shared Function Keyword( _
   ByVal group As String, _
   ByVal element As String _
) As Keyword
    'Usage

    Dim group As String
Dim element As String
Dim value As Keyword

value = DicomGlobal.Keyword(group, element)
    public static Keyword Keyword(
   string group,
   string element
)

    Parameters

    group
    The Group value represented in hexadecimal string
    element
    The Element value represented in hexadecimal string

    Return Value

    A keyword
    Remarks
    Note that the keyword generated does not need to exist within the pre-defined values of the DicomObjects.Enums.Keyword enumeration, so this method may be used to generate keyword for private elements etc.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members
    Overload List


DicomObjects Namespace / DicomGlobal Class / Keyword Method / Keyword(UInt16,UInt16) Method
The Group value
The Element value

In This Topic
    Keyword(UInt16,UInt16) Method
    In This Topic
    Construct a keyword from arbitrary group and element values
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Shared Function Keyword( _
   ByVal Group As UShort, _
   ByVal Element As UShort _
) As Keyword
    'Usage

    Dim Group As UShort
Dim Element As UShort
Dim value As Keyword

value = DicomGlobal.Keyword(Group, Element)
    public static Keyword Keyword(
   ushort Group,
   ushort Element
)

    Parameters

    Group
    The Group value
    Element
    The Element value

    Return Value

    A keyword
    Remarks
    Note that the keyword generated does not need to exist within the pre-defined values of the DicomObjects.Enums.Keyword enumeration, so this method may be used to generate keyword for private elements etc.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members
    Overload List


DicomObjects Namespace / DicomGlobal Class / KeywordElement Method

    KeywordElement Method
    Returns the "element" number for a keyword
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Function KeywordElement( _
   ByVal keyword As Keyword _
) As UShort
    'Usage

    Dim keyword As Keyword
Dim value As UShort

value = DicomGlobal.KeywordElement(keyword)
    public static ushort KeywordElement(
   Keyword keyword
)

    Parameters

    keyword

    Return Value

    The unsigned element number
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / KeywordGroup Method

    KeywordGroup Method
    Returns the "group" number for a keyword
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Function KeywordGroup( _
   ByVal keyword As Keyword _
) As UShort
    'Usage

    Dim keyword As Keyword
Dim value As UShort

value = DicomGlobal.KeywordGroup(keyword)
    public static ushort KeywordGroup(
   Keyword keyword
)

    Parameters

    keyword

    Return Value

    The group number
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / KeywordTag Method
Keyword to convert to string value
String to separate Group and Element string representation

In This Topic
    KeywordTag Method
    In This Topic
    Construct a string representation of the Group and Element number of keyword
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Function KeywordTag( _
   ByVal keyword As Keyword, _
   Optional ByVal separator As String _
) As String
    'Usage

    Dim keyword As Keyword
Dim separator As String
Dim value As String

value = DicomGlobal.KeywordTag(keyword, separator)
    public static string KeywordTag(
   Keyword keyword,
   string separator
)

    Parameters

    keyword
    Keyword to convert to string value
    separator
    String to separate Group and Element string representation

    Return Value

    String value of the keyword
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / LoadConfigFile Method

    LoadConfigFile Method
    Forces loading of the XML configuration file
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Sub LoadConfigFile()
    'Usage

    DicomGlobal.LoadConfigFile()
    public static void LoadConfigFile()
    Remarks
    Normally, this is loaded automatically, but this method exists for unusual situations where this need to be done before it would otherwise happen.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / Log Method
Text as string, which is to be added to the log file.

In This Topic
    Log Method
    In This Topic
    Add text to the log file.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Sub Log( _
   ByVal Text As String _
)
    'Usage

    Dim Text As String

DicomGlobal.Log(Text)
    public static void Log(
   string Text
)

    Parameters

    Text
    Text as string, which is to be added to the log file.
    Remarks
    Adds user specified text to the log file. Only works when the log file is enabled. For information about how to enable logging, see LogToFile.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / LogToFile Method

    LogToFile Method
    Enables DicomObjects logging
    Overload List
    Overload | Description
LogToFile(String,Int32,Int32) | Enables DicomObjects logging, specifies where DicomObjects log files appear, what the logging level is and the timer interval when new log file should be generated.
LogToFile(String,Int32) | Enables DicomObjects logging, specifies where DicomObjects log files appear, what the logging level is and the timer interval when new log file should be generated.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / LogToFile Method / LogToFile(String,Int32,Int32) Method

The location of the log files.

If an empty string being passed, DicomObjects will use "C:\" as the default location.

But still it is the container's responsibility to ensure either that the path is valid and correct.

This value controls the level of details logged either to the display, or to a file.

The allowable values for log level are:

Decimal | Hex |
1 | 1 | Errors
2 | 2 | Warnings
4 | 4 | Informational Messages
8 | 8 | Detailed Logging
16 | 10 | All DICOM attributes received or read
32 | 20 | All DICOM attributes send or written
64 | 40 | Byte-Level data received, except contents of data PDUs
128 | 80 | Byte-level data sent, except contents of data PDUs
256 | 100 | All bytes received
512 | 200 | All bytes sent

RestartMinutes as int, the time interval when a new log file should be generated.

In This Topic
    LogToFile(String,Int32,Int32) Method
    In This Topic
    Enables DicomObjects logging, specifies where DicomObjects log files appear, what the logging level is and the timer interval when new log file should be generated.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Shared Sub LogToFile( _
   ByVal Path As String, _
   ByVal LogLevel As Integer, _
   ByVal RestartMinutes As Integer _
)
    'Usage

    Dim Path As String
Dim LogLevel As Integer
Dim RestartMinutes As Integer

DicomGlobal.LogToFile(Path, LogLevel, RestartMinutes)
    public static void LogToFile(
   string Path,
   int LogLevel,
   int RestartMinutes
)

    Parameters

    Path

    The location of the log files.

    If an empty string being passed, DicomObjects will use "C:\" as the default location.

    But still it is the container's responsibility to ensure either that the path is valid and correct.

    LogLevel

    This value controls the level of details logged either to the display, or to a file.

    The allowable values for log level are:

    Decimal | Hex
    1 | 1 | Errors
    2 | 2 | Warnings
    4 | 4 | Informational Messages
    8 | 8 | Detailed Logging
    16 | 10 | All DICOM attributes received or read
    32 | 20 | All DICOM attributes send or written
    64 | 40 | Byte-Level data received, except contents of data PDUs
    128 | 80 | Byte-level data sent, except contents of data PDUs
    256 | 100 | All bytes received
    512 | 200 | All bytes sent
    RestartMinutes

    RestartMinutes as int, the time interval when a new log file should be generated.

    Remarks

    The last two levels should NOT be used routinely when images are being sent or received, as the quality of log data becomes unmanageable, and the system will probably run so slowly that connecting equipment will time-out.

    Other bits in the higher word are reserved for Medical Connections' use or future expansion.

    This overload is to provide users a means to restart the logging on a regular time basic. This method is useful to avoid log file end up being HUGE.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members
    Overload List


DicomObjects Namespace / DicomGlobal Class / LogToFile Method / LogToFile(String,Int32) Method

The location of the log files.

If an empty string being passed, DicomObjects will use "C:\" as the default location.

But still it is the container's responsibility to ensure either that the path is valid and correct.

This value controls the level of details logged either to the display, or to a file.

The allowable values for log level are:

Decimal | Hex |
1 | 1 | Errors
2 | 2 | Warnings
4 | 4 | Informational Messages
8 | 8 | Detailed Logging
16 | 10 | All DICOM attributes received or read
32 | 20 | All DICOM attributes send or written
64 | 40 | Byte-Level data received, except contents of data PDUs
128 | 80 | Byte-level data sent, except contents of data PDUs
256 | 100 | All bytes received
512 | 200 | All bytes sent

In This Topic
    LogToFile(String,Int32) Method
    In This Topic
    Enables DicomObjects logging, specifies where DicomObjects log files appear, what the logging level is and the timer interval when new log file should be generated.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Shared Sub LogToFile( _
   ByVal Path As String, _
   ByVal LogLevel As Integer _
)
    'Usage

    Dim Path As String
Dim LogLevel As Integer

DicomGlobal.LogToFile(Path, LogLevel)
    public static void LogToFile(
   string Path,
   int LogLevel
)

    Parameters

    Path

    The location of the log files.

    If an empty string being passed, DicomObjects will use "C:\" as the default location.

    But still it is the container's responsibility to ensure either that the path is valid and correct.

    LogLevel

    This value controls the level of details logged either to the display, or to a file.

    The allowable values for log level are:

    Decimal | Hex
    1 | 1 | Errors
    2 | 2 | Warnings
    4 | 4 | Informational Messages
    8 | 8 | Detailed Logging
    16 | 10 | All DICOM attributes received or read
    32 | 20 | All DICOM attributes send or written
    64 | 40 | Byte-Level data received, except contents of data PDUs
    128 | 80 | Byte-level data sent, except contents of data PDUs
    256 | 100 | All bytes received
    512 | 200 | All bytes sent

    Remarks

    The last two levels should NOT be used routinely when images are being sent or received, as the quality of log data becomes unmanageable, and the system will probably run so slowly that connecting equipment will time-out.

    Other bits in the higher word are reserved for Medical Connections' use or future expansion.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members
    Overload List


DicomObjects Namespace / DicomGlobal Class / LogToFileStop Method

    LogToFileStop Method
    Stop logging to the currently active file
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Sub LogToFileStop()
    'Usage

    DicomGlobal.LogToFileStop()
    public static void LogToFileStop()
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / LogToLogger Method

    LogToLogger Method
    Enables DicomObjects logging to a user provided Microsoft ILogger interface
    Overload List
    Overload | Description
LogToLogger(ILogger,Int32) | Enables DicomObjects logging to a user provided Microsoft ILogger interface
LogToLogger(ILogger,LogLevel) | Enables DicomObjects logging to a user provided Microsoft ILogger interface
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / LogToLogger Method / LogToLogger(ILogger,Int32) Method

A Microsoft.Extensions.ILogger interface provided by user

This value controls the level of details logged in the output

In This Topic
    LogToLogger(ILogger,Int32) Method
    In This Topic
    Enables DicomObjects logging to a user provided Microsoft ILogger interface
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Shared Sub LogToLogger( _
   ByVal msLogger As ILogger, _
   ByVal logLevel As Integer _
)
    'Usage

    Dim msLogger As ILogger
Dim logLevel As Integer

DicomGlobal.LogToLogger(msLogger, logLevel)
    public static void LogToLogger(
   ILogger msLogger,
   int logLevel
)

    Parameters

    msLogger

    A Microsoft.Extensions.ILogger interface provided by user

    logLevel

    This value controls the level of details logged in the output

    Remarks

    The last two levels should NOT be used routinely when images are being sent or received, as the quality of log data becomes unmanageable, and the system will probably run so slowly that connecting equipment will time-out.

    Other bits in the higher word are reserved for Medical Connections' use or future expansion.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members
    Overload List


DicomObjects Namespace / DicomGlobal Class / LogToLogger Method / LogToLogger(ILogger,LogLevel) Method

A Microsoft.Extensions.ILogger interface provided by user

This Enum value controls the level of details logged in the output

In This Topic
    LogToLogger(ILogger,LogLevel) Method
    In This Topic
    Enables DicomObjects logging to a user provided Microsoft ILogger interface
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Shared Sub LogToLogger( _
   ByVal msLogger As ILogger, _
   Optional ByVal logLevel As LogLevel _
)
    'Usage

    Dim msLogger As ILogger
Dim logLevel As LogLevel

DicomGlobal.LogToLogger(msLogger, logLevel)
    public static void LogToLogger(
   ILogger msLogger,
   LogLevel logLevel
)

    Parameters

    msLogger

    A Microsoft.Extensions.ILogger interface provided by user

    logLevel

    This Enum value controls the level of details logged in the output

    Remarks

    The last two levels should NOT be used routinely when images are being sent or received, as the quality of log data becomes unmanageable, and the system will probably run so slowly that connecting equipment will time-out.

    Other bits in the higher word are reserved for Medical Connections' use or future expansion.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members
    Overload List


DicomObjects Namespace / DicomGlobal Class / LogToStream Method

The stream to send log data to

This value controls the level of details logged either to the display, or to a file.

The allowable values for log level are:

Decimal | Hex |
1 | 1 | Errors
2 | 2 | Warnings
4 | 4 | Informational Messages
8 | 8 | Detailed Logging
16 | 10 | All DICOM attributes received or read
32 | 20 | All DICOM attributes send or written
64 | 40 | Byte-Level data received, except contents of data PDUs
128 | 80 | Byte-level data sent, except contents of data PDUs
256 | 100 | All bytes received
512 | 200 | All bytes sent

In This Topic
    LogToStream Method
    In This Topic
    Enables DicomObjects logging to a user provided stream
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Sub LogToStream( _
   ByVal Stream As Stream, _
   ByVal LogLevel As Integer _
)
    'Usage

    Dim Stream As Stream
Dim LogLevel As Integer

DicomGlobal.LogToStream(Stream, LogLevel)
    public static void LogToStream(
   Stream Stream,
   int LogLevel
)

    Parameters

    Stream

    The stream to send log data to

    LogLevel

    This value controls the level of details logged either to the display, or to a file.

    The allowable values for log level are:

    Decimal | Hex
    1 | 1 | Errors
    2 | 2 | Warnings
    4 | 4 | Informational Messages
    8 | 8 | Detailed Logging
    16 | 10 | All DICOM attributes received or read
    32 | 20 | All DICOM attributes send or written
    64 | 40 | Byte-Level data received, except contents of data PDUs
    128 | 80 | Byte-level data sent, except contents of data PDUs
    256 | 100 | All bytes received
    512 | 200 | All bytes sent
    Remarks

    The last two levels should NOT be used routinely when images are being sent or received, as the quality of log data becomes unmanageable, and the system will probably run so slowly that connecting equipment will time-out.

    Other bits in the higher word are reserved for Medical Connections' use or future expansion.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / MakeDictionary Method
Include all user added Private attributes

    MakeDictionary Method
    In This Topic
    Create a Dataset containing a null copy of all 'known' possible attributes
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Function MakeDictionary( _
   Optional ByVal includePrivateAttributes As Boolean _
) As DicomDataSet
    'Usage

    Dim includePrivateAttributes As Boolean
Dim value As DicomDataSet

value = DicomGlobal.MakeDictionary(includePrivateAttributes)
    public static DicomDataSet MakeDictionary(
   bool includePrivateAttributes
)

    Parameters

    includePrivateAttributes
    Include all user added Private attributes

    Return Value

    DicomDataSet
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / NewUID Method

    NewUID Method
    Generates a guaranteed unique valid DICOM UID
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Function NewUID() As String
    'Usage

    Dim value As String

value = DicomGlobal.NewUID()
    public static string NewUID()

    Return Value

    String
    Remarks
    The UIDRoot property is used, followed by a unique combination of thread ID, date/time and an incrementing counter
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / OfferedTransferSyntaxes Method

The SOPClassGroups

    OfferedTransferSyntaxes Method
    In This Topic
    List of Transfer Syntaxes offered by default for a group of SOP classes
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Function OfferedTransferSyntaxes( _
   ByVal Group As SOPClassGroups _
) As List(Of String)
    'Usage

    Dim Group As SOPClassGroups
Dim value As List(Of String)

value = DicomGlobal.OfferedTransferSyntaxes(Group)
    public static List<string> OfferedTransferSyntaxes(
   SOPClassGroups Group
)

    Parameters

    Group

    The SOPClassGroups

    Return Value

    The list of Transfer Syntaxes to be offered
    Remarks

    The list is pre-populated at initialization, but may be modified by the user

    This method is intended for advanced usage - for simpler methods see:

    • AddToOfferedTransferSyntaxes
    • RemoveFromOfferedTransferSyntaxes
    • ClearOfferedTransferSyntaxes

    To control the related SOP classes and accepted transfer syntaxes associated with the group see:

    • AddToSOPClassGroup
    • RemoveFromSOPClassGroup
    • ClearSOPClassGroup
    • AddToAcceptedTransferSyntaxes
    • RemoveFromAcceptedTransferSyntaxes
    • ClearAcceptedTransferSyntaxes
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / RemoveFromAcceptedTransferSyntaxes Method
The group to remove the accepted Transfer Syntax from
The accepted Transfer Syntax to remove

In This Topic
    RemoveFromAcceptedTransferSyntaxes Method
    In This Topic
    Remove an accepted Transfer Syntax from a group used to help control automatic acceptance of transfer syntaxes
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Sub RemoveFromAcceptedTransferSyntaxes( _
   ByVal Group As SOPClassGroups, _
   ByVal TransferSyntax As UID _
)
    'Usage

    Dim Group As SOPClassGroups
Dim TransferSyntax As UID

DicomGlobal.RemoveFromAcceptedTransferSyntaxes(Group, TransferSyntax)
    public static void RemoveFromAcceptedTransferSyntaxes(
   SOPClassGroups Group,
   UID TransferSyntax
)

    Parameters

    Group
    The group to remove the accepted Transfer Syntax from
    TransferSyntax
    The accepted Transfer Syntax to remove
    Remarks

    The groups are pre-populated at initialization, but may be modified by the user

    For direct access to the underlying List<String> to allow advanced usage see AcceptedTransferSyntaxes

    See Also:

    • AddToSOPClassGroup
    • RemoveFromSOPClassGroup
    • ClearSOPClassGroup
    • AddToAcceptedTransferSyntaxes
    • ClearAcceptedTransferSyntaxes
    • AddToOfferedTransferSyntaxes
    • RemoveFromOfferedTransferSyntaxes
    • ClearOfferedTransferSyntaxes
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / RemoveFromOfferedTransferSyntaxes Method
The group to remove the offered Transfer Syntax from
The offered Transfer Syntax to remove

In This Topic
    RemoveFromOfferedTransferSyntaxes Method
    In This Topic
    Remove an offered Transfer Syntax from a group used to help control automatic acceptance of transfer syntaxes
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Sub RemoveFromOfferedTransferSyntaxes( _
   ByVal Group As SOPClassGroups, _
   ByVal TransferSyntax As UID _
)
    'Usage

    Dim Group As SOPClassGroups
Dim TransferSyntax As UID

DicomGlobal.RemoveFromOfferedTransferSyntaxes(Group, TransferSyntax)
    public static void RemoveFromOfferedTransferSyntaxes(
   SOPClassGroups Group,
   UID TransferSyntax
)

    Parameters

    Group
    The group to remove the offered Transfer Syntax from
    TransferSyntax
    The offered Transfer Syntax to remove
    Remarks

    The groups are pre-populated at initialization, but may be modified by the user

    For direct access to the underlying List of Strings to allow advanced usage see OfferedTransferSyntaxes

    See Also:

    • AddToSOPClassGroup
    • RemoveFromSOPClassGroup
    • ClearSOPClassGroup
    • AddToAcceptedTransferSyntaxes
    • RemoveFromAcceptedTransferSyntaxes
    • ClearAcceptedTransferSyntaxes
    • AddToOfferedTransferSyntaxes
    • ClearOfferedTransferSyntaxes
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / RemoveFromSOPClassGroup Method
The group to remove the SOP class from
The SOP class to remove

In This Topic
    RemoveFromSOPClassGroup Method
    In This Topic
    Remove a SOP class from a group used to help control use of associated transfer syntaxes
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Sub RemoveFromSOPClassGroup( _
   ByVal Group As SOPClassGroups, _
   ByVal SOPClass As UID _
)
    'Usage

    Dim Group As SOPClassGroups
Dim SOPClass As UID

DicomGlobal.RemoveFromSOPClassGroup(Group, SOPClass)
    public static void RemoveFromSOPClassGroup(
   SOPClassGroups Group,
   UID SOPClass
)

    Parameters

    Group
    The group to remove the SOP class from
    SOPClass
    The SOP class to remove
    Remarks

    The groups are pre-populated at initialization, but may be modified by the user

    For direct access to the underlying Listof Strings to allow advanced usage see SOPClassGroup

    See Also:

    • AddToSOPClassGroup
    • ClearSOPClassGroup
    • AddToAcceptedTransferSyntaxes
    • RemoveFromAcceptedTransferSyntaxes
    • ClearAcceptedTransferSyntaxes
    • AddToOfferedTransferSyntaxes
    • RemoveFromOfferedTransferSyntaxes
    • ClearOfferedTransferSyntaxes
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / ResetPixelCache Method

    ResetPixelCache Method
    Clear any existing pixel cache
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Sub ResetPixelCache()
    'Usage

    DicomGlobal.ResetPixelCache()
    public static void ResetPixelCache()
    Remarks
    See UsePixelCache for more details.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / SetRegString Method

The name of the registry key.

The value to set.

In This Topic
    SetRegString Method
    In This Topic
    Insert or replace values in the internal virtual registry
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Sub SetRegString( _
   ByVal Name As String, _
   ByVal Value As String _
)
    'Usage

    Dim Name As String
Dim Value As String

DicomGlobal.SetRegString(Name, Value)
    public static void SetRegString(
   string Name,
   string Value
)

    Parameters

    Name

    The name of the registry key.

    Value

    The value to set.

    Remarks

    This method creates or replaces string values in the internal virtual registry. The internal look up table can be updated by calling this method to provide a pair of 'Name' and 'Value' e.g. 'UIDRoot' - '1.2.826.3.4.5.6'

    As DicomGlobal does not look in to registry any more (as did in COM version) for key values, instead, an internal look up table is used to provide all those options used by DicomObjects, like logging, Importing/Exporting external files, Compression/Decompression, Supported SOP Class, Supported Transfer Syntax.

    For a current list of values, se the wiki: http://www.medicalconnections.co.uk/kb/Registry_Values

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / SetRegWord Method

The name of the registry key.

The value to set.

In This Topic
    SetRegWord Method
    In This Topic
    Sets key values in the internal look up table
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Sub SetRegWord( _
   ByVal Name As String, _
   ByVal Value As Integer _
)
    'Usage

    Dim Name As String
Dim Value As Integer

DicomGlobal.SetRegWord(Name, Value)
    public static void SetRegWord(
   string Name,
   int Value
)

    Parameters

    Name

    The name of the registry key.

    Value

    The value to set.

    Remarks

    This method creates, if the specified key does not exist, and puts the word value in. The internal look up table can be made by calling this method to provide a pair of 'Name' and 'Value' e.g. 'LogLevel' - '1', 'LogLocation' - '"c:\"'.

    As DicomGlobal does not look in to registry any more (as did in COM version) for key values, instead, an internal look up table is used to provide all those options used by DicomObjects, like logging, Importing/Exporting external files, Compression/Decompression, Supported SOP Class, Supported Transfer Syntax.

    For a current list of values, se the wiki: http://www.medicalconnections.co.uk/kb/Registry_Values

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / SOPClassGroup Method
The group requested

    SOPClassGroup Method
    In This Topic
    Groups of SOP classes that use the same default Transfer Syntaxes
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Function SOPClassGroup( _
   ByVal Group As SOPClassGroups _
) As List(Of String)
    'Usage

    Dim Group As SOPClassGroups
Dim value As List(Of String)

value = DicomGlobal.SOPClassGroup(Group)
    public static List<string> SOPClassGroup(
   SOPClassGroups Group
)

    Parameters

    Group
    The group requested

    Return Value

    The list of SOP classes to which the selected group applies
    Remarks

    These groups pre-populated at initialization, but may be modified by the user

    This method is intended for advanced usage - for simpler methods see:

    • AddToSOPClassGroup
    • RemoveFromSOPClassGroup
    • ClearSOPClassGroup

    To control the offered and accepted transfer syntaxes associated with the group see:

    • AddToAcceptedTransferSyntaxes
    • RemoveFromAcceptedTransferSyntaxes
    • ClearAcceptedTransferSyntaxes
    • AddToOfferedTransferSyntaxes
    • RemoveFromOfferedTransferSyntaxes
    • ClearOfferedTransferSyntaxes
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / Zoom Method
The Matrix to use

    Zoom Method
    In This Topic
    The Zoom factor corresponding to a given SkiaSharp.SKMatrix object
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Function Zoom( _
   ByVal m As SkiaSharp.SKMatrix _
) As Single
    'Usage

    Dim m As SkiaSharp.SKMatrix
Dim value As Single

value = DicomGlobal.Zoom(m)
    public static float Zoom(
   SkiaSharp.SKMatrix m
)

    Parameters

    m
    The Matrix to use

    Return Value

    float/single
    Remarks
    If the Matrix is anisometropic (different zooms in different directions), then the lower of the two is used, corresponding to the behaviour of the DicomImage.Zoom property, which uses the specified zoom as the lower figure, and inflates the other as necessary to correct for non-square pixels.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


%%PageItemTitle%% $$Properties$$

DicomObjects Namespace / DicomGlobal Class

    DicomGlobal Class Properties
    In This Topic

    For a list of all members of this type, see DicomGlobal members.

    Public Properties
     | Name | Description
static (Shared in Visual Basic) | AssemblyDirectory | Returns the Assembly Directory information
static (Shared in Visual Basic) | AssemblyVersion | Gets the Assembly Version of DicomObjects.NET
static (Shared in Visual Basic) | Assume2022Escapes | Controls whether DicomObjects attempts to locate unannounced 2022 escape sequences
static (Shared in Visual Basic) | BufferSize | User controlled internal buffer size if attribute data is a large array. This will define the array size for the list of arrays needed to handle the attribute value. Used to avoid .NET's array dimension limit for very large data
static (Shared in Visual Basic) | ChangeLossyUIDs | Controls whether DicomObjects changes the UID when doing lossy compression
static (Shared in Visual Basic) | CloseFilesAfterReading | Controls how pixel data is read from disk
static (Shared in Visual Basic) | ColourConverter | Interface to allow override of the default CIELab <=> RGB conversion
static (Shared in Visual Basic) | CombinePDVs | Controls whether to combine outgoing command and data PDVs into a single PDU
static (Shared in Visual Basic) | CurrentLogFileName | Returns the Current DicomObjects Log File Name in full.
static (Shared in Visual Basic) | DefaultCharacterSet | Default Character to set to use if 0008,0005 is absent
static (Shared in Visual Basic) | DefaultFFmpegFilter | Description of the Default filter to apply for FFmpeg processing
static (Shared in Visual Basic) | DefaultIpAddressFamily | The IP Address family to be used where not otherwise specified
static (Shared in Visual Basic) | DefaultReadBehaviour | Default behaviour when reading or receiving files
static (Shared in Visual Basic) | DefaultSOPClasses | Default list of SOP class UID's (Abstract syntaxes) to be used until specifically overridden by user settings
static (Shared in Visual Basic) | DefaultWriteBehaviour | Default behaviour when writing or sending files
static (Shared in Visual Basic) | DeidentifyInLog | A list of keywords fo attributes which should not be included in any standard log file.
static (Shared in Visual Basic) | DescriptionAsSerializationTag | To use attribute string description as tag for Json/XML serialization
static (Shared in Visual Basic) | DirectionStrings | Language specific indicators for anatomic labelling
static (Shared in Visual Basic) | DisplayCacheTime | Controls how long display cache copies of images are retained.
static (Shared in Visual Basic) | Enable10BitDisplay | To allows support for 10bit data.
static (Shared in Visual Basic) | EventLogLevel | Controls the logging of diagnostic message to the LogEvent event.
static (Shared in Visual Basic) | FailOnSuspiciousPreamble | Detect any non-zero data in the preamble (the first 128 bytes) leading to 'DICM', and alert if any unwanted bytes or malicious code is present. A pre-defined list of file formats PreambleFileSignatures is used for checking against the non-zero preamble This mainly affects data with such preamble when reading it in. Writing to disk or sending using DICOM protocol would remove existing preamble (effectively cleaning any malicious preamble) and recreate it when written to disk on the receiving side
static (Shared in Visual Basic) | FileVersion | Gets the File Version of DicomObjects.NET
static (Shared in Visual Basic) | FlushLevel | A level to cause the log to be flushed to disk
static (Shared in Visual Basic) | FontScaling | The factor by which to increase the font size when using DirectX display mode. The default is 1.5, which gives appearance similar to those in GDI mode.
static (Shared in Visual Basic) | HologicCompressedDataAttributeElements | List of attribute elements known to be used by Hologic for their compressed frames used to detect any compressed data in private sequence
static (Shared in Visual Basic) | IgnoreShortPixelData | Try to ignore Short pixel data error to suppress read exception. This does not fix any faulty attributes or guarantee the read pixels are correct and complete
static (Shared in Visual Basic) | ImplementationName | The Implementation Name of this application
static (Shared in Visual Basic) | ImplementationUID | The Implementation UID of this application
static (Shared in Visual Basic) | IndentJson | Controls whether JSON generated is indented and formatted for easy human interpretation
static (Shared in Visual Basic) | JpipInitialSize | The size of the first request (in bytes) to make to a JPIP server.
static (Shared in Visual Basic) | LockGdiOperations | Controls whether to use an explicit lock to prevent recurrent GDI operations from happening
static (Shared in Visual Basic) | LogLicenceDetails | Controls logging of licence initialization details Suggested use is for debugging purposes only
static (Shared in Visual Basic) | MaximumDateTime | Control the global MaximumDateTime value used by DicomObjects. Default value is DateTime.MaxValue
static (Shared in Visual Basic) | MaximumNesting | Controls to what level deep are nested Sequences parsed
static (Shared in Visual Basic) | MaximumPDUSize | The Maximum PDU size accepted and used by DicomObjects
static (Shared in Visual Basic) | MinFontSize | Contains the Minimum SKFont SKSizeI used when drawing Text Label.
static (Shared in Visual Basic) | MinimumDateTime | Control the global MinimumDateTime value used by DicomObjects. Default value is DateTime.MinValue
static (Shared in Visual Basic) | MoveTimesOut | Controls whether DicomObjects will time out during a C-MOVE operation
static (Shared in Visual Basic) | PreambleFileSignatures | A pre-defined modifiable list of file signatures to match against the preamble if FailOnSuspiciousPreamble is enabled
static (Shared in Visual Basic) | PreferredBitmapMode | Controls method of rendering used by "Bitmap"
static (Shared in Visual Basic) | PreferredCodec | Codec to prioritize if applicable
static (Shared in Visual Basic) | PreserveDoublePrecision | Retain precision for double numbers
static (Shared in Visual Basic) | ProductName | The product name to be shown in licensing Dialogs etc. Default value is "DicomObjects".
static (Shared in Visual Basic) | QuadrupedDirectionStrings | The quadruped equivalent of DirectionStrings allowing localisation of these abbreviations
static (Shared in Visual Basic) | RenderException | Controls whether non-image objects throw an exception during rendering
static (Shared in Visual Basic) | ReUseArrays | Controls whether DicomObjcts re-uses arrays to hold pixel data
static (Shared in Visual Basic) | ReuseOnlyExactArraySize | Controls whether "Over-sized" arrays are used
static (Shared in Visual Basic) | RunningInDocker | Flag to see if application is runner in a Docker container
static (Shared in Visual Basic) | ShowTextBoxForPresentationStates | Controls whether bounding boxes are drawn around internally generated DicomLabel objects derived from text entries in Presentation States
static (Shared in Visual Basic) | SigningLicensePrefix | Set to tell DicomObjects to check the exe.{Prefix}.lic, instead of default exe.lic file
static (Shared in Visual Basic) | ThreadCount | Controls how many threads may be used by DicomObjects when rendering etc.
static (Shared in Visual Basic) | Timeout | The period of time that a network operation will wait if there is no response from the peer
static (Shared in Visual Basic) | UIDRoot | UIDRoot used by the NewUID method
static (Shared in Visual Basic) | UsePerformanceCounters | Controls use of specific performance counters for DicomObjects
static (Shared in Visual Basic) | UsePixelCache | Controls whether to use an area of memory as a pixel cache to reduce demands on the memory allocator
static (Shared in Visual Basic) | ValidDateMax | Maximum allowed DateTime for validation purposes Default value is DateTime.MaxValue
static (Shared in Visual Basic) | ValidDateMin | Minimum allowed DateTime for validation purposes Default value is DateTime.MinValue
    Top
    See Also

    Reference

    DicomGlobal Class
    DicomObjects Namespace


DicomObjects Namespace / DicomGlobal Class / AssemblyDirectory Property

    AssemblyDirectory Property
    Returns the Assembly Directory information
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly Property AssemblyDirectory As String
    'Usage

    Dim value As String

value = DicomGlobal.AssemblyDirectory
    public static string AssemblyDirectory {get;}
    Remarks
    This property contains the directory information of the running DicomObjects.NET.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / AssemblyVersion Property

    AssemblyVersion Property
    Gets the Assembly Version of DicomObjects.NET
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly Property AssemblyVersion As String
    'Usage

    Dim value As String

value = DicomGlobal.AssemblyVersion
    public static string AssemblyVersion {get;}
    Remarks
    This property contains the Assembly Version of the running DicomObjects.NET. This information can be found in the DicomObjects.NET log file.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / Assume2022Escapes Property

    Assume2022Escapes Property
    Controls whether DicomObjects attempts to locate unannounced 2022 escape sequences
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Property Assume2022Escapes As Boolean
    'Usage

    Dim value As Boolean

DicomGlobal.Assume2022Escapes = value

value = DicomGlobal.Assume2022Escapes
    public static bool Assume2022Escapes {get; set;}
    Remarks
    Officiallly in DICOM, ISO 2022 character escape may ONLY be used if the the specific character set (0008,0005) lists both the initial character set in its 2022 form (e.g. "ISO 2022 IR 100" in place of "ISO_IR 100" and also contains a list of all character sets that could be used. In practice however, some modality equipment suppliers don't bother to include 0008,0005 in their data at all, or fail to use the 2022-specific variant. This property, if true (the default value) allows DicomObjects to check whether a string contains any escape (0x1B) characters, and if it does, to assume 2022 mode (thereby enabling chages of character set) even in the absence of a marker in (0008,0005).
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members
    DefaultCharacterSet Property


DicomObjects Namespace / DicomGlobal Class / BufferSize Property

    BufferSize Property
    User controlled internal buffer size if attribute data is a large array. This will define the array size for the list of arrays needed to handle the attribute value.

    Used to avoid .NET's array dimension limit for very large data

    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Property BufferSize As Long
    'Usage

    Dim value As Long

DicomGlobal.BufferSize = value

value = DicomGlobal.BufferSize
    public static long BufferSize {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / ChangeLossyUIDs Property

    ChangeLossyUIDs Property (DicomGlobal)
    In This Topic
    Controls whether DicomObjects changes the UID when doing lossy compression
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Property ChangeLossyUIDs As Boolean
    'Usage

    Dim value As Boolean

DicomGlobal.ChangeLossyUIDs = value

value = DicomGlobal.ChangeLossyUIDs
    public static bool ChangeLossyUIDs {get; set;}
    Remarks

    There are times when the negotiated transfer syntaxes for a DicomAssociation require a previously uncompressed (or losslessly compressed) image to be transmmited in a lossy form. Although the DICOM standard is not entirely clear, most people believe that a new instance UID should be generated whenever this happens. This is the normal DicomObjects behaviour, and a reference to the original UID is included in the referenced image sequence. However, some query SCUs having requested a specific image by it's UID fail to look in the referenced image sequence and reject images with UIDs other than those they had requested.

    This property provides a default value for new DicomAssociation objects, and also controls the behaviour for DicomImage.Write and DicomDataSet.Write. The default value of this property is true, causing new UIDs to be generated.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / CloseFilesAfterReading Property

    CloseFilesAfterReading Property (DicomGlobal)
    In This Topic
    Controls how pixel data is read from disk
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Property CloseFilesAfterReading As Boolean
    'Usage

    Dim value As Boolean

DicomGlobal.CloseFilesAfterReading = value

value = DicomGlobal.CloseFilesAfterReading
    public static bool CloseFilesAfterReading {get; set;}
    Remarks

    If true, then all the pixel data is read from the disk at the time of reading the file, and the file is then closed. if false, then the file is kept open and pixel data is only read as and when required.

    The default setting is true which improves memory usage, but has the downside that the file is locked. If you wish to over-write files which have been opened, then set this value to true before reading the files.

    The default value is false

    This corresponds to the old "DisableMemoryMapping" registry setting.

    If required, this behaviour can be controlled on a file by file basis by using the CloseFilesAfterReading property of the ReadBehaviours class, combined with the appropriate override of DicomDataSet.Read

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / ColourConverter Property

    ColourConverter Property
    Interface to allow override of the default CIELab <=> RGB conversion
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Property ColourConverter As IColourConverter
    'Usage

    Dim value As IColourConverter

DicomGlobal.ColourConverter = value

value = DicomGlobal.ColourConverter
    public static IColourConverter ColourConverter {get; set;}
    Remarks
    A default implementation is provided, but an application which implements an object with the DicomObjects.Internal.IColourConverter interface can then assign it to this property which allows appropriate calibration where required.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / CombinePDVs Property

    CombinePDVs Property
    Controls whether to combine outgoing command and data PDVs into a single PDU
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Property CombinePDVs As Boolean
    'Usage

    Dim value As Boolean

DicomGlobal.CombinePDVs = value

value = DicomGlobal.CombinePDVs
    public static bool CombinePDVs {get; set;}
    Remarks

    DicomObjects accepts PDVs in any combination in incoming PDUs, but as some implementations fall over when sent such data, by default (when this property is false), DicomObjects send command and data PDVs in separate PDUs

    Setting this to true provides a small performance improvement

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / CurrentLogFileName Property

    CurrentLogFileName Property
    Returns the Current DicomObjects Log File Name in full.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly Property CurrentLogFileName As String
    'Usage

    Dim value As String

value = DicomGlobal.CurrentLogFileName
    public static string CurrentLogFileName {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / DefaultCharacterSet Property

    DefaultCharacterSet Property
    Default Character to set to use if 0008,0005 is absent
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Property DefaultCharacterSet As String
    'Usage

    Dim value As String

DicomGlobal.DefaultCharacterSet = value

value = DicomGlobal.DefaultCharacterSet
    public static string DefaultCharacterSet {get; set;}
    Remarks
    The official DICOM rule, if the specific character set (0008,0005) is absent is to use ISO_IR 6 - i.e. just 7 bit US ASCII. This however commonly causes problems since many modality equipment suppliers (especially in Europe & Japan) use extension characters in the range 128-255 but don't bother to include 0008,0005 in their data. This property allows the default to be changed, and the initial value is "ISO_IR 100", which permits and assumes use of European accented characters in the upper range. Fortunately, the lower raneg (0-127) of this character set is identical to US ASCII (ISO_IR 6), so this value does not break compatibility for valid ASCII-only data.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members
    Assume2022Escapes Property


DicomObjects Namespace / DicomGlobal Class / DefaultFFmpegFilter Property

    DefaultFFmpegFilter Property
    Description of the Default filter to apply for FFmpeg processing
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Property DefaultFFmpegFilter As String
    'Usage

    Dim value As String

DicomGlobal.DefaultFFmpegFilter = value

value = DicomGlobal.DefaultFFmpegFilter
    public static string DefaultFFmpegFilter {get; set;}
    Remarks
    For more details please refer to this page "https://ffmpeg.org/ffmpeg-filters.html"
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / DefaultIpAddressFamily Property

    DefaultIpAddressFamily Property
    The IP Address family to be used where not otherwise specified
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Property DefaultIpAddressFamily As AddressFamily
    'Usage

    Dim value As AddressFamily

DicomGlobal.DefaultIpAddressFamily = value

value = DicomGlobal.DefaultIpAddressFamily
    public static AddressFamily DefaultIpAddressFamily {get; set;}
    Remarks
    The default is System.Net.Sockets.AddressFamily.InterNetwork (IPv4)
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / DefaultReadBehaviour Property

    DefaultReadBehaviour Property
    Default behaviour when reading or receiving files
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Property DefaultReadBehaviour As ReadBehaviours
    'Usage

    Dim value As ReadBehaviours

DicomGlobal.DefaultReadBehaviour = value

value = DicomGlobal.DefaultReadBehaviour
    public static ReadBehaviours DefaultReadBehaviour {get; set;}
    Remarks

    A new ReadBehaviours object is created for each file operation or association. If this property is non-null, then the new object is a clone of this property, but if this property is null, then a new ReadBehaviours object is created which will, when created, reflect the values of the internal registry at that time

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / DefaultSOPClasses Property

    DefaultSOPClasses Property
    Default list of SOP class UID's (Abstract syntaxes) to be used until specifically overridden by user settings
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly Property DefaultSOPClasses As ReadOnlyCollection(Of String)
    'Usage

    Dim value As ReadOnlyCollection(Of String)

value = DicomGlobal.DefaultSOPClasses
    public static ReadOnlyCollection<string> DefaultSOPClasses {get;}
    Remarks
    Returns a copy of the default SOP classes. This may not match the effective SOP classes used if overridden in user code.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / DefaultWriteBehaviour Property

    DefaultWriteBehaviour Property
    Default behaviour when writing or sending files
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Property DefaultWriteBehaviour As WriteBehaviours
    'Usage

    Dim value As WriteBehaviours

DicomGlobal.DefaultWriteBehaviour = value

value = DicomGlobal.DefaultWriteBehaviour
    public static WriteBehaviours DefaultWriteBehaviour {get; set;}
    Remarks

    A new WriteBehaviours object is created for each file operation or association. If this property is non-null, then the new object is a clone of this property, but if this property is null, then a new WriteBehaviours object is created which will, when created, reflect the values of the internal registry at that time

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / DeidentifyInLog Property

    DeidentifyInLog Property
    A list of keywords fo attributes which should not be included in any standard log file.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly Property DeidentifyInLog As List(Of Keyword)
    'Usage

    Dim value As List(Of Keyword)

value = DicomGlobal.DeidentifyInLog
    public static List<Keyword> DeidentifyInLog {get;}
    Remarks

    Any such attributes will be replaced by either {De-identified} or by the value of DicomGlobal.GetRegString("DeIdentifyText") if that has been set.

    It is important to note that this not applies to the individual attributes (as listed in a 3F level log), as a full byte level log will still contain the binary versions of such data

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / DescriptionAsSerializationTag Property

    DescriptionAsSerializationTag Property
    To use attribute string description as tag for Json/XML serialization
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Property DescriptionAsSerializationTag As Boolean
    'Usage

    Dim value As Boolean

DicomGlobal.DescriptionAsSerializationTag = value

value = DicomGlobal.DescriptionAsSerializationTag
    public static bool DescriptionAsSerializationTag {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / DirectionStrings Property

    DirectionStrings Property
    Language specific indicators for anatomic labelling
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Property DirectionStrings As String()
    'Usage

    Dim value() As String

DicomGlobal.DirectionStrings = value

value = DicomGlobal.DirectionStrings
    public static string[] DirectionStrings {get; set;}
    Remarks

    This property supplies the strings used by all DicomLabels of type LabelType Special. The default value is{"R","L","A","P","I","S"} corresponding to the English abbreviations for RIGHT, LEFT, ANTERIOR, POSTERIOR, INFERIOR and SUPERIOR respectively. If you wish to to change this value, please note the following:

    • Exactly 6 values are required (otherwise you will get error message), in the order indicated above.
    • Unicode is fully supported allowing Chinese or other non-western direction indicators.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / DisplayCacheTime Property

    DisplayCacheTime Property
    Controls how long display cache copies of images are retained.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Property DisplayCacheTime As TimeSpan
    'Usage

    Dim value As TimeSpan

DicomGlobal.DisplayCacheTime = value

value = DicomGlobal.DisplayCacheTime
    public static TimeSpan DisplayCacheTime {get; set;}
    Remarks
    Cached copies of displayed images are discarded after this interval if the memory has not been needed earlier. The default value is 25 seconds.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / Enable10BitDisplay Property

    Enable10BitDisplay Property
    To allows support for 10bit data.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Property Enable10BitDisplay As Boolean
    'Usage

    Dim value As Boolean

DicomGlobal.Enable10BitDisplay = value

value = DicomGlobal.Enable10BitDisplay
    public static bool Enable10BitDisplay {get; set;}
    Remarks
    This is an experimental feature to handle data as 10bit
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / EventLogLevel Property

    EventLogLevel Property
    Controls the logging of diagnostic message to the LogEvent event.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Property EventLogLevel As LogLevel
    'Usage

    Dim value As LogLevel

DicomGlobal.EventLogLevel = value

value = DicomGlobal.EventLogLevel
    public static LogLevel EventLogLevel {get; set;}
    Remarks
    Bit field indicating which levels of activity should be logged. See DicomGlobal.LogToFile for more details.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / FailOnSuspiciousPreamble Property

    FailOnSuspiciousPreamble Property
    Detect any non-zero data in the preamble (the first 128 bytes) leading to 'DICM', and alert if any unwanted bytes or malicious code is present. A pre-defined list of file formats PreambleFileSignatures is used for checking against the non-zero preamble This mainly affects data with such preamble when reading it in. Writing to disk or sending using DICOM protocol would remove existing preamble (effectively cleaning any malicious preamble) and recreate it when written to disk on the receiving side
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Property FailOnSuspiciousPreamble As Boolean
    'Usage

    Dim value As Boolean

DicomGlobal.FailOnSuspiciousPreamble = value

value = DicomGlobal.FailOnSuspiciousPreamble
    public static bool FailOnSuspiciousPreamble {get; set;}
    Remarks
    This mainly affects data with such preamble when reading it in. Writing to disk or sending using DICOM protocol would remove existing preamble (effectively cleaning any malicious preamble) and recreate it when written to disk on the receiving side
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / FileVersion Property

    FileVersion Property
    Gets the File Version of DicomObjects.NET
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly Property FileVersion As String
    'Usage

    Dim value As String

value = DicomGlobal.FileVersion
    public static string FileVersion {get;}
    Remarks
    This property contains the File Version of the running DicomObjects.NET. This information can be found in the DicomObjects.NET log file.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / FlushLevel Property

    FlushLevel Property
    A level to cause the log to be flushed to disk
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Property FlushLevel As LogLevel
    'Usage

    Dim value As LogLevel

DicomGlobal.FlushLevel = value

value = DicomGlobal.FlushLevel
    public static LogLevel FlushLevel {get; set;}
    Remarks
    Any log event which has bits which match this property causes the log to be flushed This is useful to ensure that exceptions are flsuhed to disk without slowing normal operations.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / FontScaling Property

    FontScaling Property
    The factor by which to increase the font size when using DirectX display mode. The default is 1.5, which gives appearance similar to those in GDI mode.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Property FontScaling As Single
    'Usage

    Dim value As Single

DicomGlobal.FontScaling = value

value = DicomGlobal.FontScaling
    public static float FontScaling {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / HologicCompressedDataAttributeElements Property

    HologicCompressedDataAttributeElements Property
    List of attribute elements known to be used by Hologic for their compressed frames used to detect any compressed data in private sequence
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Property HologicCompressedDataAttributeElements As List(Of UShort)
    'Usage

    Dim value As List(Of UShort)

DicomGlobal.HologicCompressedDataAttributeElements = value

value = DicomGlobal.HologicCompressedDataAttributeElements
    public static List<ushort> HologicCompressedDataAttributeElements {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / IgnoreShortPixelData Property

    IgnoreShortPixelData Property
    Try to ignore Short pixel data error to suppress read exception. This does not fix any faulty attributes or guarantee the read pixels are correct and complete
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Property IgnoreShortPixelData As Boolean
    'Usage

    Dim value As Boolean

DicomGlobal.IgnoreShortPixelData = value

value = DicomGlobal.IgnoreShortPixelData
    public static bool IgnoreShortPixelData {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / ImplementationName Property

    ImplementationName Property (DicomGlobal)
    In This Topic
    The Implementation Name of this application
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Property ImplementationName As String
    'Usage

    Dim value As String

DicomGlobal.ImplementationName = value

value = DicomGlobal.ImplementationName
    public static string ImplementationName {get; set;}
    Remarks
    This value is used in association negotiation and is put into Part 10 files
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / ImplementationUID Property

    ImplementationUID Property (DicomGlobal)
    In This Topic
    The Implementation UID of this application
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Property ImplementationUID As String
    'Usage

    Dim value As String

DicomGlobal.ImplementationUID = value

value = DicomGlobal.ImplementationUID
    public static string ImplementationUID {get; set;}
    Remarks
    This value is used in association negotiation and is put into Part 10 files
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / IndentJson Property

    IndentJson Property
    Controls whether JSON generated is indented and formatted for easy human interpretation
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Property IndentJson As Boolean
    'Usage

    Dim value As Boolean

DicomGlobal.IndentJson = value

value = DicomGlobal.IndentJson
    public static bool IndentJson {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / JpipInitialSize Property

    JpipInitialSize Property
    The size of the first request (in bytes) to make to a JPIP server.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Property JpipInitialSize As Integer
    'Usage

    Dim value As Integer

DicomGlobal.JpipInitialSize = value

value = DicomGlobal.JpipInitialSize
    public static int JpipInitialSize {get; set;}
    Remarks
    Lower values give a lower latency, but higher values are more efficient.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / LockGdiOperations Property

    LockGdiOperations Property
    Controls whether to use an explicit lock to prevent recurrent GDI operations from happening
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Property LockGdiOperations As Boolean
    'Usage

    Dim value As Boolean

DicomGlobal.LockGdiOperations = value

value = DicomGlobal.LockGdiOperations
    public static bool LockGdiOperations {get; set;}
    Remarks
    This is false by default, as t is believed that these problems have been eliminated, but is left as an option to prevent rare but difficult to reproduce errors when different threads happen to use the GDI sub-system at the same time - e.g. when rendering labels through use of DicomImage.PrinterImage
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / LogLicenceDetails Property

    LogLicenceDetails Property
    Controls logging of licence initialization details

    Suggested use is for debugging purposes only

    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Property LogLicenceDetails As Boolean
    'Usage

    Dim value As Boolean

DicomGlobal.LogLicenceDetails = value

value = DicomGlobal.LogLicenceDetails
    public static bool LogLicenceDetails {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / MaximumDateTime Property

    MaximumDateTime Property
    Control the global MaximumDateTime value used by DicomObjects. Default value is DateTime.MaxValue
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Property MaximumDateTime As Date
    'Usage

    Dim value As Date

DicomGlobal.MaximumDateTime = value

value = DicomGlobal.MaximumDateTime
    public static DateTime MaximumDateTime {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / MaximumNesting Property

    MaximumNesting Property
    Controls to what level deep are nested Sequences parsed
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Property MaximumNesting As Integer
    'Usage

    Dim value As Integer

DicomGlobal.MaximumNesting = value

value = DicomGlobal.MaximumNesting
    public static int MaximumNesting {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / MaximumPDUSize Property

    MaximumPDUSize Property
    The Maximum PDU size accepted and used by DicomObjects
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Property MaximumPDUSize As Integer
    'Usage

    Dim value As Integer

DicomGlobal.MaximumPDUSize = value

value = DicomGlobal.MaximumPDUSize
    public static int MaximumPDUSize {get; set;}
    Remarks

    This corresponds to the old "MaxPDU" registry setting.

    The default value is 65536 (64k)

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / MinFontSize Property

    MinFontSize Property
    Contains the Minimum SKFont SKSizeI used when drawing Text Label.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Property MinFontSize As Single
    'Usage

    Dim value As Single

DicomGlobal.MinFontSize = value

value = DicomGlobal.MinFontSize
    public static float MinFontSize {get; set;}
    Remarks
    Default value is 8.0F.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / MinimumDateTime Property

    MinimumDateTime Property
    Control the global MinimumDateTime value used by DicomObjects. Default value is DateTime.MinValue
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Property MinimumDateTime As Date
    'Usage

    Dim value As Date

DicomGlobal.MinimumDateTime = value

value = DicomGlobal.MinimumDateTime
    public static DateTime MinimumDateTime {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / MoveTimesOut Property

    MoveTimesOut Property
    Controls whether DicomObjects will time out during a C-MOVE operation
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Property MoveTimesOut As Boolean
    'Usage

    Dim value As Boolean

DicomGlobal.MoveTimesOut = value

value = DicomGlobal.MoveTimesOut
    public static bool MoveTimesOut {get; set;}
    Remarks

    This is unlikely to be needed with "good" SCPs which return regular status updates to the C-MOVE SCU, but is needed when getting many images (particularly over slow connections) from SCPs which do not send such notifications

    This corresponds to the old "MoveTimesOut" registry setting.

    The default value is true

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / PreambleFileSignatures Property

    PreambleFileSignatures Property
    A pre-defined modifiable list of file signatures to match against the preamble if FailOnSuspiciousPreamble is enabled
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Property PreambleFileSignatures As List(Of FileSignature)
    'Usage

    Dim value As List(Of FileSignature)

DicomGlobal.PreambleFileSignatures = value

value = DicomGlobal.PreambleFileSignatures
    public static List<FileSignature> PreambleFileSignatures {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / PreferredBitmapMode Property

    PreferredBitmapMode Property
    Controls method of rendering used by "Bitmap"
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Property PreferredBitmapMode As ViewerMode
    'Usage

    Dim value As ViewerMode

DicomGlobal.PreferredBitmapMode = value

value = DicomGlobal.PreferredBitmapMode
    public static ViewerMode PreferredBitmapMode {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / PreferredCodec Property

    PreferredCodec Property
    Codec to prioritize if applicable
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Property PreferredCodec As CodecUsage
    'Usage

    Dim value As CodecUsage

DicomGlobal.PreferredCodec = value

value = DicomGlobal.PreferredCodec
    public static CodecUsage PreferredCodec {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / PreserveDoublePrecision Property

    PreserveDoublePrecision Property
    Retain precision for double numbers
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Property PreserveDoublePrecision As Boolean
    'Usage

    Dim value As Boolean

DicomGlobal.PreserveDoublePrecision = value

value = DicomGlobal.PreserveDoublePrecision
    public static bool PreserveDoublePrecision {get; set;}
    Remarks
    To control floating value precision when adding attributes with double values
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / ProductName Property

    ProductName Property
    The product name to be shown in licensing Dialogs etc. Default value is "DicomObjects".
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Property ProductName As String
    'Usage

    Dim value As String

DicomGlobal.ProductName = value

value = DicomGlobal.ProductName
    public static string ProductName {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / QuadrupedDirectionStrings Property

    QuadrupedDirectionStrings Property
    The quadruped equivalent of DirectionStrings allowing localisation of these abbreviations
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Property QuadrupedDirectionStrings As String()
    'Usage

    Dim value() As String

DicomGlobal.QuadrupedDirectionStrings = value

value = DicomGlobal.QuadrupedDirectionStrings
    public static string[] QuadrupedDirectionStrings {get; set;}
    Remarks

    Exactly 14 values are required (otherwise you will get error message), in the order indicated below.

    Unicode is fully supported allowing Chinese or other non-western direction indicators.

    • Le: Left
    • Rt: Right
    • Pr: Proximal
    • Di: Distal
    • Pa:
    • Pl:
    • Cr: Cranial
    • Cd: Caudal (opposite of cranial)
    • D : Dorsal
    • V : Ventral
    • R : Rostral
    • Cd: Caudal (opposite of rostral)
    • M : Medial
    • L : Laeral
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / RenderException Property

    RenderException Property
    Controls whether non-image objects throw an exception during rendering
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Property RenderException As Boolean
    'Usage

    Dim value As Boolean

DicomGlobal.RenderException = value

value = DicomGlobal.RenderException
    public static bool RenderException {get; set;}
    Remarks
    If true, then attempts to display or otherwise render images without the required attributes (e.g. structured reports) will throw an exception. If false (default value), then such attempts merely result in a blank output.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / ReUseArrays Property

    ReUseArrays Property
    Controls whether DicomObjcts re-uses arrays to hold pixel data
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Property ReUseArrays As Boolean
    'Usage

    Dim value As Boolean

DicomGlobal.ReUseArrays = value

value = DicomGlobal.ReUseArrays
    public static bool ReUseArrays {get; set;}
    Remarks

    Whilst the approach to array allocation pushed by Microsoft is "don't worry about it, just leave all memory management to the garbage collector", the reality is very different, and in practice, especially for "large" objects (>85kbytes - small by pixel standards)fragmentation can occur after prolonged use, leading to performance issues and even, on some systems, memory allocation failure, even when sufficient total memory should be available.

    As of V8 therefore, DicomObjects attempts to "re-use" pixel arrays where possible, which it does by intercepting their release, and then adding them to a cache list, from which new allocations can be made if an array of sufficient (including possibly larger) size is available. The use of over-sized arrays can be prvented by use of the ReuseOnlyExactArraySize property.

    If this property is set to false, then arrays are not re-used at all.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / ReuseOnlyExactArraySize Property

    ReuseOnlyExactArraySize Property
    Controls whether "Over-sized" arrays are used
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Property ReuseOnlyExactArraySize As Boolean
    'Usage

    Dim value As Boolean

DicomGlobal.ReuseOnlyExactArraySize = value

value = DicomGlobal.ReuseOnlyExactArraySize
    public static bool ReuseOnlyExactArraySize {get; set;}
    Remarks

    DicomObjects attempts where possible to re-user arrays to hold pixel data, as this reduces fragmentation of the Large Object Heap. (see ReUseArrays for more details).

    If this property is false (the default) then the smallest array available for re-use which is either the right size or larger than the required size is used, but if this is false, then only an exactly sized array is accepted (and a new array is allocated if an exactly sized array is not available).
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / RunningInDocker Property

    RunningInDocker Property
    Flag to see if application is runner in a Docker container
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly Property RunningInDocker As Boolean
    'Usage

    Dim value As Boolean

value = DicomGlobal.RunningInDocker
    public static bool RunningInDocker {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / ShowTextBoxForPresentationStates Property

    ShowTextBoxForPresentationStates Property
    Controls whether bounding boxes are drawn around internally generated DicomLabel objects derived from text entries in Presentation States
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Property ShowTextBoxForPresentationStates As Boolean
    'Usage

    Dim value As Boolean

DicomGlobal.ShowTextBoxForPresentationStates = value

value = DicomGlobal.ShowTextBoxForPresentationStates
    public static bool ShowTextBoxForPresentationStates {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / SigningLicensePrefix Property

    SigningLicensePrefix Property
    Set to tell DicomObjects to check the exe.{Prefix}.lic, instead of default exe.lic file
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Property SigningLicensePrefix As String
    'Usage

    Dim value As String

DicomGlobal.SigningLicensePrefix = value

value = DicomGlobal.SigningLicensePrefix
    public static string SigningLicensePrefix {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / ThreadCount Property

    ThreadCount Property
    Controls how many threads may be used by DicomObjects when rendering etc.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Property ThreadCount As Integer
    'Usage

    Dim value As Integer

DicomGlobal.ThreadCount = value

value = DicomGlobal.ThreadCount
    public static int ThreadCount {get; set;}
    Remarks
    The default value is the number of procesors on the system. Setting to 1 disables the multi-threading rendering support.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / Timeout Property

    Timeout Property
    The period of time that a network operation will wait if there is no response from the peer
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Property Timeout As Integer
    'Usage

    Dim value As Integer

DicomGlobal.Timeout = value

value = DicomGlobal.Timeout
    public static int Timeout {get; set;}
    Remarks

    The default value is 60 (seconds)

    This corresponds to the old "Timeout" registry setting.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / UIDRoot Property

    UIDRoot Property
    UIDRoot used by the NewUID method
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Property UIDRoot As String
    'Usage

    Dim value As String

DicomGlobal.UIDRoot = value

value = DicomGlobal.UIDRoot
    public static string UIDRoot {get; set;}
    Remarks

    If not set explicitly, then a "statistically unique" (i.e. not guaranteed) UID generation technique is used instead

    This corresponds to the old "UIDRoot" registry setting.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / UsePerformanceCounters Property

    UsePerformanceCounters Property
    Controls use of specific performance counters for DicomObjects
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Property UsePerformanceCounters As Boolean
    'Usage

    Dim value As Boolean

DicomGlobal.UsePerformanceCounters = value

value = DicomGlobal.UsePerformanceCounters
    public static bool UsePerformanceCounters {get; set;}
    Remarks
    These are only designed for specialist diagnostic use, and this should only be set to true on request from Medical Connections support.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / UsePixelCache Property

    UsePixelCache Property
    Controls whether to use an area of memory as a pixel cache to reduce demands on the memory allocator
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Property UsePixelCache As Boolean
    'Usage

    Dim value As Boolean

DicomGlobal.UsePixelCache = value

value = DicomGlobal.UsePixelCache
    public static bool UsePixelCache {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / ValidDateMax Property

    ValidDateMax Property
    Maximum allowed DateTime for validation purposes Default value is DateTime.MaxValue
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Property ValidDateMax As Date
    'Usage

    Dim value As Date

DicomGlobal.ValidDateMax = value

value = DicomGlobal.ValidDateMax
    public static DateTime ValidDateMax {get; set;}
    Remarks
    Default value is DateTime.MaxValue
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / ValidDateMin Property

    ValidDateMin Property
    Minimum allowed DateTime for validation purposes Default value is DateTime.MinValue
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Property ValidDateMin As Date
    'Usage

    Dim value As Date

DicomGlobal.ValidDateMin = value

value = DicomGlobal.ValidDateMin
    public static DateTime ValidDateMin {get; set;}
    Remarks
    Default value is DateTime.MinValue
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


%%PageItemTitle%% $$Events$$

DicomObjects Namespace / DicomGlobal Class

    DicomGlobal Class Events
    In This Topic

    For a list of all members of this type, see DicomGlobal members.

    Public Events
     | Name | Description
Public Event | LogEvent | Event fires when loggable events occur
Public Event | OnChangeUid | Event fired when DicomObjects should change a UID for an object
Public Event | ValidateFragments | Routine to allow validation (and if necessary, correction) of fragments of compressed pixel data
    Top
    See Also

    Reference

    DicomGlobal Class
    DicomObjects Namespace


DicomObjects Namespace / DicomGlobal Class / LogEvent Event

    LogEvent Event
    Event fires when loggable events occur
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Event LogEvent As LogHandler
    'Usage

    Dim instance As DicomGlobal
Dim handler As LogHandler

AddHandler instance.LogEvent, handler
    public event LogHandler LogEvent
    Remarks
    The types of events are controlled by the EventLogLevel property
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / OnChangeUid Event

    OnChangeUid Event
    Event fired when DicomObjects should change a UID for an object
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Event OnChangeUid As ChangeUidHandler
    'Usage

    Dim instance As DicomGlobal
Dim handler As ChangeUidHandler

AddHandler instance.OnChangeUid, handler
    public event ChangeUidHandler OnChangeUid
    Remarks
    This event allows developers to see the old and new UIDs in circumstances where UIDs should be changed, allowing the default bahaviour and new UID to be overridden
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


DicomObjects Namespace / DicomGlobal Class / ValidateFragments Event

    ValidateFragments Event
    Routine to allow validation (and if necessary, correction) of fragments of compressed pixel data
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Event ValidateFragments As Action(Of ValidateFragmentsArgs)
    'Usage

    Dim instance As DicomGlobal
Dim handler As Action(Of ValidateFragmentsArgs)

AddHandler instance.ValidateFragments, handler
    public event Action<ValidateFragmentsArgs> ValidateFragments
    Remarks

    This is called whenever compressed pixel data read/received, including compressedpixel data within a sequence.

    CloseFilesAfterReading must be set to true if hooking this event.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomGlobal Class
    DicomGlobal Members


%%PageItemTitle%%

DicomObjects Namespace / DicomImage Class
Members

In This Topic
    DicomImage Class
    In This Topic
    Class representing a DICOM Image
    Syntax
    • Visual Basic
    • C#
    'Declaration

    <DefaultMemberAttribute("Item")>
Public Class DicomImage
    'Usage

    Dim instance As DicomImage
    [DefaultMember("Item")]
public class DicomImage
    Remarks

    Each DicomImage object corresponds to one SOP instance, and for display, DicomImages are commonly held within a DicomImages collection.

    In general, a DicomImage is a utility wrapper around a DicomDataSet to help accomplish the Image viewing-related tasks, like zooming, scrolling, flipping, rotating, windowing etc.

    A DicomImage references a DicomDataSet ( DataSet property ), which also contains the attributes, the distinction being that a DicomImage contains pixel data, and is therefore displayable within a DicomViewer control, whereas a DicomDataSet may or may not contain pixel data, and is not displayable. The different properties and methods reflect this difference.

    A DicomImage object can be constructed directly from a file, stream or byte array

    Inheritance Hierarchy

    System.Object
    DicomObjects.DicomImage

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Members
    DicomObjects Namespace


%%PageItemTitle%% $$Members$$

DicomObjects Namespace / DicomImage Class
Properties Methods Events

In This Topic
    DicomImage Class Members
    In This Topic

    The following tables list the members exposed by DicomImage.

    Public Constructors
     | Name | Description
Public Constructor | DicomImage Constructor | Overloaded. Creates a blank DicomImage object
    Top
    Public Properties
     | Name | Description
Public Property | AccessionNumber | The Accession Number
Public Property | Angle | Controls the rotation of an image
Public Property | Area | The display area of DicomImage
Public Property | BorderPaint | The Paint object for Image border
Public Property | CacheMode | Controls how the pixel data is cached
Public Property | CaptureBackColour | User defined background colour for image output of PrinterImage, SKBitmap and SubImage methods Default is Black background
Public Property | CineFramesToDisplay | The set of frames to display for cine modes
Public Property | CineIndex | The index of the currently displayed frame when using CineMode
Public Property | CineSmoothing | Boolean property indicating whether Smoothing is applied when Cine is being displayed.
Public Property | ColourTable | The colour lookup table of DicomImage
Public Property | CubicSplineAlpha | Parameter to control the degree of smoothing. The default value is �0.75, and normal values range from �0.5 to �1.25, though higher negative values may be used to produce deliberate edge enhancement.
Public Property | DataSet | The underlying DICOM Dataset containing persistent data for the image
Public Property | DateOfBirth | Date of birth of the patient
static (Shared in Visual Basic) | DefaultModalityLUT | Default value for the ModalityLUT property
static (Shared in Visual Basic) | DefaultPresentationLUT | Default value for the PresentationLUT property
static (Shared in Visual Basic) | DefaultRealTimeCine | Controls the default for how cine images are displayed
static (Shared in Visual Basic) | DefaultVoiLUT | Default value for the VoiLUT property
Public Property | DisplayMode | Controls how the image is rendered internal before transfer to the screen
Public Property | DrawCacheMode | Specify the DrawCacheMode to control how image is drawn/cached
Public Property | ExplicitModalityLUT | An explicit modality Lookup Table to be used in place of one specified in the image or presentaiton state.
Public Property | ExplicitPresentationLUT | An explicit presentation Lookup Table to be used in place of one specified in the image or presentaiton state.
Public Property | ExplicitVOILUT | An explicit Values of Interest (VOI) Lookup Table to be used in place of one specified in the image or presentaiton state.
Public Property | FilterLength | Contains the length of the smoothing filter
Public Property | FlipState | The flip state of the image, allowing the orientation of the image, as displayed, to be altered
Public Property | Frame | Controls which frame of a multi-frame image is displayed
Public Property | FrameCount | The number of frames contained in a multi-frame image
Public Property | Gamma | A number that specifies a power
Public Property | InstanceUID | Unique identifier for the four levels of the DICOM Query/Retrieve hierarchy
Public Property | Invert | Controls whether the Image will be inverted.
Public Property | Item | Overloaded. Provides access to all attributes of the image
Public Property | Labels | Provides access to the DicomLabelCollection, items of which are to be displayed over an image.
Public Property | Level | The Window Level (also known as the centre) - which controls the greyscale mapping of a displayed image
Public Property | LevelShift | Provides a means to modify the usage of a Values of Interest Lookup Table (VOI LUT) or other display mapping
Public Property | MagnificationMode | Controls how pixels are interpolated when the image is magnified
Public Property | MinificationMode | Controls how pixels are interpolated when the image is minified
Public Property | Modality | The Modality of the image
Public Property | ModalityLUT | Enables or disables the Modality Lookup Table to be used in the DicomImage
Public Property | Name | The Name of the patient
Public Property | OriginalTS | Original Transfer syntax of the underlying DataSet
Public Property | OverlayColour | Controls how overlays embedded in the image are displayed
Public Property | OverlayVisible | Controls whether overlays embedded in the image are displayed
Public Property | PatientID | The Patient ID
Public Property | Pixels | Accesses the raw pixel data as a typed array
Public Property | PresentationLUT | Enables or disables the Presentation Lookup Table to be used in the DicomImage
Public Property | PresentationState | Support for DICOM greyscale presentation state
Public Property | PresentationStates | Support for a list of DICOM greyscale presentation state
Public Property | RawPixels | Accesses the raw pixel data as an array
Public Property | RealTimeCine | Controls how cine images are displayed
Public Property | RenderedSize | Returns the Image display size in output (normally screen) coordinates
Public Property | RotateState | The rotation state of the image, allowing the orientation of the image, as displayed, to be altered
Public Property | RotationBehaviour | Controls the baseline positioning of an image which is not stretched to fit and is rotated
Public Property | Scroll | Controls the positioning of an image display
Public Property | SeriesDescription | Descriptions for the series
Public Property | SeriesUID | Unique identifier for the four levels of the DICOM Query/Retrieve hierarchy
Public Property | Sex | Sex of the patient
Public Property | ShowLabels | Controls whether the image�s labels (annotations) are shown on screen
Public Property | ShowShutter | Controls whether image shutters (if specified in the image) are used.
Public Property | ShowUpdates | Controls whether the images is updated when image display parameters change
Public Property | Size | The dimensions of the image
Public Property | SOPClass | SOP class of the DicomDataSet.
Public Property | StretchMode | Controls the automatic zooming of an image.
Public Property | StudyDescription | Description for the study
Public Property | StudyUID | Unique identifier for the four levels of the DICOM Query/Retrieve hierarchy
Public Property | Tag | A general purpose Tag for developer use
Public Property | UnsharpEnhancement | UnsharpLength and UnsharpEnhancement, allow use of unsharp masking, as simple method of image edge enhancement
Public Property | UnsharpLength | UnsharpLength and UnsharpEnhancement, allow use of unsharp masking, as simple method of image edge enhancement
Public Property | UserMatrix | Means to override the matrix used to display 2D images
Public Property | ValidationOptions | The default DicomObjects.Validation.ValidationOptions to apply to newly created DicomImage objects
Public Property | VoiLUT | The VOI Lookup Table to be used to display the DicomImage
Public Property | VOILUTFunction | Controls which VOILUT function to be used, default value is Linear
Public Property | VoiLUTInUse | Indicates whether a Values of Interest Lookup Table is in use
Public Property | Width | The Window "Width" - which controls the greyscale mapping of a displayed image
Public Property | WidthMultiplier | Provides a means to modify the usage of a Values of Interest Lookup Table (VOI LUT) or other display mapping
Public Property | Zoom | Controls the magnification of an image display
    Top
    Public Methods
     | Name | Description
Public Method | Add | Overloaded. Creates and adds standard data elements to the underlying DicomDataSet
Public Method | AddByReference | Overloaded. Add byte[] as attribute value to avoid copying large data
Public Method | Bitmap | Overloaded. Creates a SKBitmap object from DicomImage
Public Method | CanConvertTo | Useful method to check if the image can be converted using a different compression specified by the TransferSyntax
Public Method | ChangeToDecompressed | Simulate the effect of writing out as a Decompressed Image
Public Method | ClearCaches | Overloaded. Clears the internal cache for compressed and uncompressed pixel data, lookup data and DirectX textures
Public Method | Clone | Overloaded. Returns a cloned copy of the DicomImage
Public Method | DecompressAll | Causes all the frames of an image to be decompressed.
Public Method | DisplaySize | Overloaded. Methods to determine the size at which am image would be shown
Public Method | Dispose | Releases the resources used by the DicomImage object This does not dispose the underlying DicomDataSet object which is DataSet, an explicit Dispose call will be needed to have that effect
Public Method | DistanceFromPoint | Perpendicular distance from a Point to the plane of this image
Public Method | DownloadStatus | Overloaded. Methods to determine the degree to which part of an image has already been downloaded
Public Method | Export | Overloaded. Export DicomImage to supported Format
Public Method | GetCacheSize | Get cache size used by DicomObjects for the image - useful to help decide when to call ClearCaches method
Public Method | GetColourTable | The colour lookup table of DicomImage
Public Method | GetMaskRanges | Contains an array of DicomMaskRange objects to be applied to this image. See the DicomMaskRange object for more information on how this is used.
Public Method | GetMinAndMax | Overloaded. Find the maximum and minimum pixel data values in the pixel data
Public Method | GetRawFrame | Extract individual frame from the pixel data
Public Method | Histogram | Returns an array containing the distribution of raw pixel values.
Public Method | ImagePlane | The currently displayed plane of this image.
Public Method | Import | Overloaded. Copies the image data from an external image format
Public Method | Matrix | Matrix specifying how the image is displayed onto display of the stated size
Public Method | MatrixBase | Matrix specifying how the image would be displayed with a Zoom of 1:1
Public Method | PixelValuesByFrame | Returns a float array of pixel values for a frame, optionally transformed via the modality transformation
Public Method | PixelValuesByFrameGeneric | Returns an array of pixel values for a frame, optionally transformed via the modality transformation
Public Method | PrinterImage | Overloaded. Creates a copy of the image for printing or other purposes
Public Method | RawPixelValuesByFrame | Returns an array of raw pixel values for a frame
Public Method | Read | Overloaded. Read from a file, a system IO stream or a byte array
Public Method | ReadURL | Reads from Web Address
Public Method | ReferenceLine | This method returns a new DicomLabel object which represents the position of one DicomImage relative to another.
Public Method | RenderToArray | Overloaded. Render the DicomImage to array.
Public Method | Send | Overloaded. Sends an image to a remote Storage SCP
Public Method | SetColourTable | The colour lookup table of DicomImage
Public Method | SetDefaultWindows | Recalculates the default windows used by DicomObjects as if the image had just been loaded
Public Method | SetMaskRanges | Contains an array of DicomMaskRange objects to be applied to this image. See the DicomMaskRange object for more information on how this is used.
Public Method | SetPixelData | Method to set pixel data directly from a stream
Public Method | SetPixelDataAndImport | Method to import pixel data directly from a non-DICOM data
Public Method | SetPixelFile | Maps an external file as the pixel data
Public Method | SetSimpleMasking | Overloaded. Sets the frame number of the mask frame for subtraction.
Public Method | Spacing | Overloaded. Get the pixel spacing of the DicomImage
Public Method | SubImage | Overloaded. Creates a copy of part or all of the image
Public Method | Update | Causes the image to be updated
Public Method | Write | Overloaded. Write the data to a file, Stream or Byte Array
    Top
    Public Events
     | Name | Description
Public Event | PositionChanged | An event which fires when the plane displayed by this image changes.
    Top
    Public Operators
    public Operator Implicit Type Conversion Implicit DicomImage to DicomDataSet cast
    Top
    See Also

    Reference

    DicomImage Class
    DicomObjects Namespace


%%PageItemTitle%%

DicomObjects Namespace / DicomImage Class / DicomImage Constructor

In This Topic
    DicomImage Constructor
    In This Topic
    Creates a blank DicomImage object
    Overload List
    Overload | Description
DicomImage Constructor() | Creates a new DicomImage with an empty Dataset
DicomImage Constructor(SKBitmap) | Creates a new DicomImage from a Windows Bitmap
DicomImage Constructor(DicomImage) | Creates a new DicomImage from an existing DicomImage
DicomImage Constructor(String,ReadBehaviours) | Creates a new DicomImage from an external DICOM file
DicomImage Constructor(Stream,ReadBehaviours) | Reads a stream into a new DicomImage
DicomImage Constructor(Byte[],ReadBehaviours) | Reads an array of bytes into a new DicomImage
DicomImage Constructor(DicomDataSet) | Creates a new DicomImage from an existing DicomDataSet
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


%%PageItemTitle%%

DicomObjects Namespace / DicomImage Class / DicomImage Constructor / DicomImage Constructor()

In This Topic
    DicomImage Constructor()
    In This Topic
    Creates a new DicomImage with an empty Dataset
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Function New()
    'Usage

    Dim instance As New DicomImage()
    public DicomImage()

    Return Value

    DicomImage
    Remarks
    A direct constructor of DicomImage object.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members
    Overload List


%%PageItemTitle%%

DicomObjects Namespace / DicomImage Class / DicomImage Constructor / DicomImage Constructor(SKBitmap)

The SKBitmap Image from which the new DicomImage is created

In This Topic
    DicomImage Constructor(SKBitmap)
    In This Topic
    Creates a new DicomImage from a Windows Bitmap
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Function New( _
   ByVal Bitmap As SkiaSharp.SKBitmap _
)
    'Usage

    Dim Bitmap As SkiaSharp.SKBitmap

Dim instance As New DicomImage(Bitmap)
    public DicomImage(
   SkiaSharp.SKBitmap Bitmap
)

    Parameters

    Bitmap

    The SKBitmap Image from which the new DicomImage is created

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members
    Overload List


%%PageItemTitle%%

DicomObjects Namespace / DicomImage Class / DicomImage Constructor / DicomImage Constructor(DicomImage)

The existing Image to create the new image from

In This Topic
    DicomImage Constructor(DicomImage)
    In This Topic
    Creates a new DicomImage from an existing DicomImage
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Function New( _
   ByVal img As DicomImage _
)
    'Usage

    Dim img As DicomImage

Dim instance As New DicomImage(img)
    public DicomImage(
   DicomImage img
)

    Parameters

    img

    The existing Image to create the new image from

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members
    Overload List


%%PageItemTitle%%

DicomObjects Namespace / DicomImage Class / DicomImage Constructor / DicomImage Constructor(String,ReadBehaviours)

The name of the file to read.

This is passed unmodified to the operating system, and it is therefore the container's responsibility to ensure either that the file exists within the current directory, or that a fully qualified filename is provided.

The behaviours to be used when reading this stream

In This Topic
    DicomImage Constructor(String,ReadBehaviours)
    In This Topic
    Creates a new DicomImage from an external DICOM file
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Function New( _
   ByVal FileName As String, _
   Optional ByVal ReadBehaviour As ReadBehaviours _
)
    'Usage

    Dim FileName As String
Dim ReadBehaviour As ReadBehaviours

Dim instance As New DicomImage(FileName, ReadBehaviour)
    public DicomImage(
   string FileName,
   ReadBehaviours ReadBehaviour
)

    Parameters

    FileName

    The name of the file to read.

    This is passed unmodified to the operating system, and it is therefore the container's responsibility to ensure either that the file exists within the current directory, or that a fully qualified filename is provided.

    ReadBehaviour

    The behaviours to be used when reading this stream

    Return Value

    DicomImage
    Remarks
    A direct constructor of DicomImage. Reads an external DICOM file to create a new DicomImage object.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members
    Overload List


%%PageItemTitle%%

DicomObjects Namespace / DicomImage Class / DicomImage Constructor / DicomImage Constructor(Stream,ReadBehaviours)

The Stream from which to read.

The behaviours to be used when reading this stream

In This Topic
    DicomImage Constructor(Stream,ReadBehaviours)
    In This Topic
    Reads a stream into a new DicomImage
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Function New( _
   ByVal Stream As Stream, _
   Optional ByVal ReadBehaviour As ReadBehaviours _
)
    'Usage

    Dim Stream As Stream
Dim ReadBehaviour As ReadBehaviours

Dim instance As New DicomImage(Stream, ReadBehaviour)
    public DicomImage(
   Stream Stream,
   ReadBehaviours ReadBehaviour
)

    Parameters

    Stream

    The Stream from which to read.

    ReadBehaviour

    The behaviours to be used when reading this stream

    Return Value

    DicomImage
    Remarks

    A direct constructor of DicomImage. This method can read streams in either official "Part10" format, with the 128 byte header, or unofficial "Part5" format, without a header. Detection of the type is automatic.

    The stream may have been written by the Write method or by other DICOM software.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members
    Overload List


%%PageItemTitle%%

DicomObjects Namespace / DicomImage Class / DicomImage Constructor / DicomImage Constructor(Byte[],ReadBehaviours)

Array of bytes to read

The behaviours to be used when reading this stream

In This Topic
    DicomImage Constructor(Byte[],ReadBehaviours)
    In This Topic
    Reads an array of bytes into a new DicomImage
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Function New( _
   ByVal Array() As Byte, _
   Optional ByVal ReadBehaviour As ReadBehaviours _
)
    'Usage

    Dim Array() As Byte
Dim ReadBehaviour As ReadBehaviours

Dim instance As New DicomImage(Array, ReadBehaviour)
    public DicomImage(
   byte[] Array,
   ReadBehaviours ReadBehaviour
)

    Parameters

    Array

    Array of bytes to read

    ReadBehaviour

    The behaviours to be used when reading this stream

    Return Value

    DicomImage
    Remarks
    A direct constructor of DicomImage. Reads a byte array to create a new DicomImage object.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members
    Overload List


%%PageItemTitle%%

DicomObjects Namespace / DicomImage Class / DicomImage Constructor / DicomImage Constructor(DicomDataSet)

The DataSet to read

In This Topic
    DicomImage Constructor(DicomDataSet)
    In This Topic
    Creates a new DicomImage from an existing DicomDataSet
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Function New( _
   ByVal Data As DicomDataSet _
)
    'Usage

    Dim Data As DicomDataSet

Dim instance As New DicomImage(Data)
    public DicomImage(
   DicomDataSet Data
)

    Parameters

    Data

    The DataSet to read

    Return Value

    DicomImage
    Remarks
    A direct constructor of DicomImage. Reads a DicomDataSet to create a new DicomImage object.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members
    Overload List


%%PageItemTitle%% $$Methods$$

DicomObjects Namespace / DicomImage Class

    DicomImage Class Methods
    In This Topic

    For a list of all members of this type, see DicomImage members.

    Public Methods
     | Name | Description
Public Method | Add | Overloaded. Creates and adds standard data elements to the underlying DicomDataSet
Public Method | AddByReference | Overloaded. Add byte[] as attribute value to avoid copying large data
Public Method | Bitmap | Overloaded. Creates a SKBitmap object from DicomImage
Public Method | CanConvertTo | Useful method to check if the image can be converted using a different compression specified by the TransferSyntax
Public Method | ChangeToDecompressed | Simulate the effect of writing out as a Decompressed Image
Public Method | ClearCaches | Overloaded. Clears the internal cache for compressed and uncompressed pixel data, lookup data and DirectX textures
Public Method | Clone | Overloaded. Returns a cloned copy of the DicomImage
Public Method | DecompressAll | Causes all the frames of an image to be decompressed.
Public Method | DisplaySize | Overloaded. Methods to determine the size at which am image would be shown
Public Method | Dispose | Releases the resources used by the DicomImage object This does not dispose the underlying DicomDataSet object which is DataSet, an explicit Dispose call will be needed to have that effect
Public Method | DistanceFromPoint | Perpendicular distance from a Point to the plane of this image
Public Method | DownloadStatus | Overloaded. Methods to determine the degree to which part of an image has already been downloaded
Public Method | Export | Overloaded. Export DicomImage to supported Format
Public Method | GetCacheSize | Get cache size used by DicomObjects for the image - useful to help decide when to call ClearCaches method
Public Method | GetColourTable | The colour lookup table of DicomImage
Public Method | GetMaskRanges | Contains an array of DicomMaskRange objects to be applied to this image. See the DicomMaskRange object for more information on how this is used.
Public Method | GetMinAndMax | Overloaded. Find the maximum and minimum pixel data values in the pixel data
Public Method | GetRawFrame | Extract individual frame from the pixel data
Public Method | Histogram | Returns an array containing the distribution of raw pixel values.
Public Method | ImagePlane | The currently displayed plane of this image.
Public Method | Import | Overloaded. Copies the image data from an external image format
Public Method | Matrix | Matrix specifying how the image is displayed onto display of the stated size
Public Method | MatrixBase | Matrix specifying how the image would be displayed with a Zoom of 1:1
Public Method | PixelValuesByFrame | Returns a float array of pixel values for a frame, optionally transformed via the modality transformation
Public Method | PixelValuesByFrameGeneric | Returns an array of pixel values for a frame, optionally transformed via the modality transformation
Public Method | PrinterImage | Overloaded. Creates a copy of the image for printing or other purposes
Public Method | RawPixelValuesByFrame | Returns an array of raw pixel values for a frame
Public Method | Read | Overloaded. Read from a file, a system IO stream or a byte array
Public Method | ReadURL | Reads from Web Address
Public Method | ReferenceLine | This method returns a new DicomLabel object which represents the position of one DicomImage relative to another.
Public Method | RenderToArray | Overloaded. Render the DicomImage to array.
Public Method | Send | Overloaded. Sends an image to a remote Storage SCP
Public Method | SetColourTable | The colour lookup table of DicomImage
Public Method | SetDefaultWindows | Recalculates the default windows used by DicomObjects as if the image had just been loaded
Public Method | SetMaskRanges | Contains an array of DicomMaskRange objects to be applied to this image. See the DicomMaskRange object for more information on how this is used.
Public Method | SetPixelData | Method to set pixel data directly from a stream
Public Method | SetPixelDataAndImport | Method to import pixel data directly from a non-DICOM data
Public Method | SetPixelFile | Maps an external file as the pixel data
Public Method | SetSimpleMasking | Overloaded. Sets the frame number of the mask frame for subtraction.
Public Method | Spacing | Overloaded. Get the pixel spacing of the DicomImage
Public Method | SubImage | Overloaded. Creates a copy of part or all of the image
Public Method | Update | Causes the image to be updated
Public Method | Write | Overloaded. Write the data to a file, Stream or Byte Array
    Top
    See Also

    Reference

    DicomImage Class
    DicomObjects Namespace


DicomObjects Namespace / DicomImage Class / Add Method

    Add Method (DicomImage)
    In This Topic
    Creates and adds standard data elements to the underlying DicomDataSet
    Overload List
    Overload | Description
Add(Int32,Int32,Object) | Creates and adds standard data elements to the underlying DicomDataSet
Add(DicomAttribute) | Add an existing attribute to the underlying DicomDataSet
Add(Keyword,Object) | Creates and adds standard data elements to the underlying DicomDataSet
Add(IEnumerable<DicomAttribute>) | Add a collection of DicomAttributes to the DataSet the underlying DicomDataSet
Add(String,Object) | Creates and adds standard data elements to the underlying DicomDataSet
Add(Keyword,String,Object) | Creates and adds standard data elements to the underlying DicomDataSet
Add(Int32,Int32,String,Object) | Creates and adds standard data elements with specified VR to the underlying DicomDataSet
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / Add Method / Add(Int32,Int32,Object) Method

The group index of a data element.

The element index of a data element.

The Value to be assigned

In This Topic
    Add(Int32,Int32,Object) Method
    In This Topic
    Creates and adds standard data elements to the underlying DicomDataSet
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub Add( _
   ByVal Group As Integer, _
   ByVal Element As Integer, _
   ByVal Value As Object _
)
    'Usage

    Dim instance As DicomImage
Dim Group As Integer
Dim Element As Integer
Dim Value As Object

instance.Add(Group, Element, Value)
    public void Add(
   int Group,
   int Element,
   object Value
)

    Parameters

    Group

    The group index of a data element.

    Element

    The element index of a data element.

    Value

    The Value to be assigned

    Remarks

    This method can read either official "Part10" format files with the 128 byte header, or unofficial "Part5" format files without a header. Detection of the type is automatic.

    The file may have been written by the Write method or by other DICOM software.

    By default, pixel data is read only when it is required, greatly speeding the display of multi-frame images, and reducing memory requirements. However, a side effect of this is that any elements after the pixel data (7FE0,0010) will not be read. This should not affect most applications, but if necessary, this behavior may be over-ridden using the CloseFilesAfterReading property.

    Another effect of file mapping is that files read using this method cannot be deleted until the image object is released. This method creates two references to the newly created DicomImage object (one in the collection, and one as the return value), and both must be released before the file can be deleted.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members
    Overload List


DicomObjects Namespace / DicomImage Class / Add Method / Add(DicomAttribute) Method
An existing DicomAttribute to add

    Add(DicomAttribute) Method
    In This Topic
    Add an existing attribute to the underlying DicomDataSet
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub Add( _
   ByVal attribute As DicomAttribute _
)
    'Usage

    Dim instance As DicomImage
Dim attribute As DicomAttribute

instance.Add(attribute)
    public void Add(
   DicomAttribute attribute
)

    Parameters

    attribute
    An existing DicomAttribute to add
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members
    Overload List


DicomObjects Namespace / DicomImage Class / Add Method / Add(Keyword,Object) Method

The DICOM Keyword of the data element.

The Value to be assigned

In This Topic
    Add(Keyword,Object) Method
    In This Topic
    Creates and adds standard data elements to the underlying DicomDataSet
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub Add( _
   ByVal Keyword As Keyword, _
   ByVal Value As Object _
)
    'Usage

    Dim instance As DicomImage
Dim Keyword As Keyword
Dim Value As Object

instance.Add(Keyword, Value)
    public void Add(
   Keyword Keyword,
   object Value
)

    Parameters

    Keyword

    The DICOM Keyword of the data element.

    Value

    The Value to be assigned

    Remarks

    This method is to add standard elements, VR of which will be determined by the internal dictionary. The type of value required for the "Value" parameter depends on the value representation of the data element, as defined by the values of group and element. Values of the types are always acceptable, as are values of other types that can be suitably coerced. Variants of type �null� are also accepted, resulting a zero-length data element, which can be useful in raw queries and for �type 2� elements. There are some special conditions relating to date and time types.

    To create a sequence, value may be a DicomDataSetCollection.

    If the data element being added has a potential value multiplicity (VM) of >1, then value may be either an array or scalar, but if the element�s VM is always 1, then an attempt to assign an array will generate an error.

    Any existing data element with the same group and element will be silently replaced, even if it is an array.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members
    Overload List


DicomObjects Namespace / DicomImage Class / Add Method / Add(IEnumerable<DicomAttribute>) Method
A list of DicomAttribute to add

    Add(IEnumerable<DicomAttribute>) Method
    In This Topic
    Add a collection of DicomAttributes to the DataSet the underlying DicomDataSet
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub Add( _
   ByVal attributes As IEnumerable(Of DicomAttribute) _
)
    'Usage

    Dim instance As DicomImage
Dim attributes As IEnumerable(Of DicomAttribute)

instance.Add(attributes)
    public void Add(
   IEnumerable<DicomAttribute> attributes
)

    Parameters

    attributes
    A list of DicomAttribute to add
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members
    Overload List


DicomObjects Namespace / DicomImage Class / Add Method / Add(String,Object) Method

The DICOM Keyword of the data element.

The Value to be assigned

In This Topic
    Add(String,Object) Method
    In This Topic
    Creates and adds standard data elements to the underlying DicomDataSet
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub Add( _
   ByVal Keyword As String, _
   ByVal Value As Object _
)
    'Usage

    Dim instance As DicomImage
Dim Keyword As String
Dim Value As Object

instance.Add(Keyword, Value)
    public void Add(
   string Keyword,
   object Value
)

    Parameters

    Keyword

    The DICOM Keyword of the data element.

    Value

    The Value to be assigned

    Remarks

    This method is to add standard elements, VR of which will be determined by the internal dictionary. The type of value required for the "Value" parameter depends on the value representation of the data element, as defined by the values of group and element. Values of the types are always acceptable, as are values of other types that can be suitably coerced. Variants of type �null� are also accepted, resulting a zero-length data element, which can be useful in raw queries and for �type 2� elements. There are some special conditions relating to date and time types.

    To create a sequence, value may be a DicomDataSetCollection.

    If the data element being added has a potential value multiplicity (VM) of >1, then value may be either an array or scalar, but if the element�s VM is always 1, then an attempt to assign an array will generate an error.

    Any existing data element with the same group and element will be silently replaced, even if it is an array.

    Although this method, taking a string as the keyword is available, where possible the aternative overload, taking an Enums.Keyword is preferable.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members
    Overload List


DicomObjects Namespace / DicomImage Class / Add Method / Add(Keyword,String,Object) Method

The DICOM Keyword of the data element.

The value representation (2 character string) of the data element to be added

The Value to be assigned

In This Topic
    Add(Keyword,String,Object) Method
    In This Topic
    Creates and adds standard data elements to the underlying DicomDataSet
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub Add( _
   ByVal Keyword As Keyword, _
   ByVal VR As String, _
   ByVal Value As Object _
)
    'Usage

    Dim instance As DicomImage
Dim Keyword As Keyword
Dim VR As String
Dim Value As Object

instance.Add(Keyword, VR, Value)
    public void Add(
   Keyword Keyword,
   string VR,
   object Value
)

    Parameters

    Keyword

    The DICOM Keyword of the data element.

    VR

    The value representation (2 character string) of the data element to be added

    Value

    The Value to be assigned

    Remarks

    This method is to add standard elements, VR of which will be determined by the internal dictionary. The type of value required for the "Value" parameter depends on the value representation of the data element, as defined by the values of group and element. Values of the types are always acceptable, as are values of other types that can be suitably coerced. Variants of type �null� are also accepted, resulting a zero-length data element, which can be useful in raw queries and for �type 2� elements. There are some special conditions relating to date and time types.

    To create a sequence, value may be a DicomDataSetCollection.

    If the data element being added has a potential value multiplicity (VM) of >1, then value may be either an array or scalar, but if the element�s VM is always 1, then an attempt to assign an array will generate an error.

    Any existing data element with the same group and element will be silently replaced, even if it is an array.

    Although this method, taking a string as the keyword is available, where possible the aternative overload, taking an Enums.Keyword is preferable.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members
    Overload List


DicomObjects Namespace / DicomImage Class / Add Method / Add(Int32,Int32,String,Object) Method

The group index of a data element.

The element index of a data element.

The value representation (2 character string) of the data element to be added

The Value to be assigned

In This Topic
    Add(Int32,Int32,String,Object) Method
    In This Topic
    Creates and adds standard data elements with specified VR to the underlying DicomDataSet
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub Add( _
   ByVal Group As Integer, _
   ByVal Element As Integer, _
   ByVal VR As String, _
   ByVal Value As Object _
)
    'Usage

    Dim instance As DicomImage
Dim Group As Integer
Dim Element As Integer
Dim VR As String
Dim Value As Object

instance.Add(Group, Element, VR, Value)
    public void Add(
   int Group,
   int Element,
   string VR,
   object Value
)

    Parameters

    Group

    The group index of a data element.

    Element

    The element index of a data element.

    VR

    The value representation (2 character string) of the data element to be added

    Value

    The Value to be assigned

    Remarks

    This method is to explicitly add elements with specified VR. The type of value required for the "Value" parameter depends on the value representation of the data element, as defined by either by the VR parameter. Values of the types are always acceptable, as are values of other types that can be suitably coerced. Variants of type "null" are also accepted, resulting a zero-length data element, which can be useful in raw queries and for �type 2� elements. There are some special conditions relating to date and time types.

    To create a sequence, value may be a DicomDataSetCollection.

    If the data element being added has a potential value multiplicity (VM) of >1, then value may be either an array or scalar, but if the element�s VM is always 1, then an attempt to assign an array will generate an error.

    Any existing data element with the same group and element will be silently replaced, even if it is an array.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members
    Overload List


DicomObjects Namespace / DicomImage Class / AddByReference Method

    AddByReference Method (DicomImage)
    In This Topic
    Add byte[] as attribute value to avoid copying large data
    Overload List
    Overload | Description
AddByReference(Keyword,Byte[]) | Add byte[] as attribute value to avoid copying large data
AddByReference(Keyword,String,Byte[]) | Add byte[] as attribute value to avoid copying large data
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / AddByReference Method / AddByReference(Keyword,Byte[]) Method
Attribute tag to add
Attribute value as byte array

In This Topic
    AddByReference(Keyword,Byte[]) Method
    In This Topic
    Add byte[] as attribute value to avoid copying large data
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub AddByReference( _
   ByVal keyword As Keyword, _
   ByVal Value() As Byte _
)
    'Usage

    Dim instance As DicomImage
Dim keyword As Keyword
Dim Value() As Byte

instance.AddByReference(keyword, Value)
    public void AddByReference(
   Keyword keyword,
   byte[] Value
)

    Parameters

    keyword
    Attribute tag to add
    Value
    Attribute value as byte array
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members
    Overload List


DicomObjects Namespace / DicomImage Class / AddByReference Method / AddByReference(Keyword,String,Byte[]) Method
Attribute tag to add
Attribute VR to add
Attribute value as byte array

In This Topic
    AddByReference(Keyword,String,Byte[]) Method
    In This Topic
    Add byte[] as attribute value to avoid copying large data
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub AddByReference( _
   ByVal keyword As Keyword, _
   ByVal VR As String, _
   ByVal Value() As Byte _
)
    'Usage

    Dim instance As DicomImage
Dim keyword As Keyword
Dim VR As String
Dim Value() As Byte

instance.AddByReference(keyword, VR, Value)
    public void AddByReference(
   Keyword keyword,
   string VR,
   byte[] Value
)

    Parameters

    keyword
    Attribute tag to add
    VR
    Attribute VR to add
    Value
    Attribute value as byte array
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members
    Overload List


DicomObjects Namespace / DicomImage Class / Bitmap Method

    Bitmap Method
    Creates a SKBitmap object from DicomImage
    Overload List
    Overload | Description
Bitmap(Int32) | Creates a SKBitmap Image from DicomImage
Bitmap(Int32,SKSizeI,SKColorType,SKMatrix,Single,Single,Boolean) | Creates a new Bitmap object, in the chosen format representing the appearance of a DicomImage
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / Bitmap Method / Bitmap(Int32) Method

The frame number to use. This is 1-index, i.e. first frame is 1 not 0

In This Topic
    Bitmap(Int32) Method
    In This Topic
    Creates a SKBitmap Image from DicomImage
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Function Bitmap( _
   Optional ByVal frame As Integer _
) As SkiaSharp.SKBitmap
    'Usage

    Dim instance As DicomImage
Dim frame As Integer
Dim value As SkiaSharp.SKBitmap

value = instance.Bitmap(frame)
    public SkiaSharp.SKBitmap Bitmap(
   int frame
)

    Parameters

    frame

    The frame number to use. This is 1-index, i.e. first frame is 1 not 0

    Return Value

    Bitmap
    Remarks
    Returns a SKBitmap image of the RenderedSize of the first Frame by default of the DicomImage
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members
    Overload List


DicomObjects Namespace / DicomImage Class / Bitmap Method / Bitmap(Int32,SKSizeI,SKColorType,SKMatrix,Single,Single,Boolean) Method
The frame number to use. This is 1-index, i.e. first frame is 1 not 0
The size of the image to generate
The requested format
The Matrix to apply to convert from DICOM coordinates to SKBitmap coordinates. Empty matrix will be set to Identity internally to avoid errors during calculation
Custom Window Width value to apply if VOILUT is not present or useVOIIfPresent is set to false
Custom Window Centre value to apply if VOILUT is not present or useVOIIfPresent is set to false
Apply VOI LUT is present in base Image object

In This Topic
    Bitmap(Int32,SKSizeI,SKColorType,SKMatrix,Single,Single,Boolean) Method
    In This Topic
    Creates a new Bitmap object, in the chosen format representing the appearance of a DicomImage
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Function Bitmap( _
   ByVal frame As Integer, _
   ByVal size As SkiaSharp.SKSizeI, _
   Optional ByVal format As SkiaSharp.SKColorType, _
   Optional ByVal matrix As SkiaSharp.SKMatrix, _
   Optional ByVal windowWidth As Single, _
   Optional ByVal windowCenter As Single, _
   Optional ByVal useVoiIfPresent As Boolean _
) As SkiaSharp.SKBitmap
    'Usage

    Dim instance As DicomImage
Dim frame As Integer
Dim size As SkiaSharp.SKSizeI
Dim format As SkiaSharp.SKColorType
Dim matrix As SkiaSharp.SKMatrix
Dim windowWidth As Single
Dim windowCenter As Single
Dim useVoiIfPresent As Boolean
Dim value As SkiaSharp.SKBitmap

value = instance.Bitmap(frame, size, format, matrix, windowWidth, windowCenter, useVoiIfPresent)
    public SkiaSharp.SKBitmap Bitmap(
   int frame,
   SkiaSharp.SKSizeI size,
   SkiaSharp.SKColorType format,
   SkiaSharp.SKMatrix matrix,
   float windowWidth,
   float windowCenter,
   bool useVoiIfPresent
)

    Parameters

    frame
    The frame number to use. This is 1-index, i.e. first frame is 1 not 0
    size
    The size of the image to generate
    format
    The requested format
    matrix
    The Matrix to apply to convert from DICOM coordinates to SKBitmap coordinates. Empty matrix will be set to Identity internally to avoid errors during calculation
    windowWidth
    Custom Window Width value to apply if VOILUT is not present or useVOIIfPresent is set to false
    windowCenter
    Custom Window Centre value to apply if VOILUT is not present or useVOIIfPresent is set to false
    useVoiIfPresent
    Apply VOI LUT is present in base Image object

    Return Value

    A SKBitmap object
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members
    Overload List


DicomObjects Namespace / DicomImage Class / CanConvertTo Method
The transfer syntax to test

    CanConvertTo Method
    In This Topic
    Useful method to check if the image can be converted using a different compression specified by the TransferSyntax
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Function CanConvertTo( _
   ByVal TransferSyntax As String _
) As Boolean
    'Usage

    Dim instance As DicomImage
Dim TransferSyntax As String
Dim value As Boolean

value = instance.CanConvertTo(TransferSyntax)
    public bool CanConvertTo(
   string TransferSyntax
)

    Parameters

    TransferSyntax
    The transfer syntax to test

    Return Value

    True is the conversion is possible
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / ChangeToDecompressed Method

    ChangeToDecompressed Method (DicomImage)
    In This Topic
    Simulate the effect of writing out as a Decompressed Image
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Sub ChangeToDecompressed()
    'Usage

    Dim instance As DicomImage

instance.ChangeToDecompressed()
    public void ChangeToDecompressed()
    Remarks
    Unlike DecompressAll which is designed merely for performance improvement, this method permanently changes the data as if written out in an uncompressed transfer syntax and then read back. This might therefore change the Photometric interpretation etc. (e.Graphics. from YBR_FULL_422 to RGB)
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / ClearCaches Method

    ClearCaches Method (DicomImage)
    In This Topic
    Clears the internal cache for compressed and uncompressed pixel data, lookup data and DirectX textures
    Overload List
    Overload | Description
ClearCaches() | Clears the entire internal cache
ClearCaches(CacheTypes) | Clears the caches of the specified types
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / ClearCaches Method / ClearCaches() Method

    ClearCaches() Method
    Clears the entire internal cache
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub ClearCaches()
    'Usage

    Dim instance As DicomImage

instance.ClearCaches()
    public void ClearCaches()
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members
    Overload List


DicomObjects Namespace / DicomImage Class / ClearCaches Method / ClearCaches(CacheTypes) Method
The types of cached information to be cleared

    ClearCaches(CacheTypes) Method
    In This Topic
    Clears the caches of the specified types
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub ClearCaches( _
   ByVal Types As CacheTypes _
)
    'Usage

    Dim instance As DicomImage
Dim Types As CacheTypes

instance.ClearCaches(Types)
    public void ClearCaches(
   CacheTypes Types
)

    Parameters

    Types
    The types of cached information to be cleared
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members
    Overload List


DicomObjects Namespace / DicomImage Class / Clone Method

    Clone Method (DicomImage)
    In This Topic
    Returns a cloned copy of the DicomImage
    Overload List
    Overload | Description
Clone(Boolean) | Returns a cloned copy of the DicomImage
Clone() | Returns a Shallow copy of the DicomImage
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / Clone Method / Clone(Boolean) Method

If true then returns a Deep copy of the DicomImage, otherwise returns a Shallow copy.

In This Topic
    Clone(Boolean) Method
    In This Topic
    Returns a cloned copy of the DicomImage
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Overridable Function Clone( _
   ByVal Deep As Boolean _
) As Object
    'Usage

    Dim instance As DicomImage
Dim Deep As Boolean
Dim value As Object

value = instance.Clone(Deep)
    public virtual object Clone(
   bool Deep
)

    Parameters

    Deep

    If true then returns a Deep copy of the DicomImage, otherwise returns a Shallow copy.

    Return Value

    DicomImage
    Remarks

    This method makes either a Shallow Copy or a Deep Copy of the DicomImage, dependants on the Deep parameter.

    A shallow copy will only have the top level objects replicated, any referenced objects under the top level will be shared by the original DicomImage and the cloned copy.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members
    Overload List


DicomObjects Namespace / DicomImage Class / Clone Method / Clone() Method

    Clone() Method
    Returns a Shallow copy of the DicomImage
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Overridable Function Clone() As Object
    'Usage

    Dim instance As DicomImage
Dim value As Object

value = instance.Clone()
    public virtual object Clone()

    Return Value

    DicomImage
    Remarks
    Equivalent to Clone(False)
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members
    Overload List


DicomObjects Namespace / DicomImage Class / DecompressAll Method

    DecompressAll Method (DicomImage)
    In This Topic
    Causes all the frames of an image to be decompressed.
    Causes all the frames of an image to be decompressed into a byte array
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Sub DecompressAll()
    'Usage

    Dim instance As DicomImage

instance.DecompressAll()
    public void DecompressAll()
    Remarks

    The normal policy adopted by DicomObjects for the handling of compressed images is to decompress frames only when necessary, and to keep the decompressed versions only for as long as is necessary for display or transmission, thereby minimising image load times, and memory use. This behaviour is not, however, always appropriate, especially when cine sequences are shown, or where modifications need to be made to the image. When this method is called, all frames are decompressed and held in RAM, replacing the original compressed version, thereby greatly speeding subsequent display, though needing much more memory.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / DisplaySize Method

    DisplaySize Method
    Methods to determine the size at which am image would be shown
    Overload List
    Overload | Description
DisplaySize(DicomViewer) | The size at which this image, using current values for StretchMode etc. will display in this viewer.
DisplaySize(SKMatrix) | The display size in output coordinates
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / DisplaySize Method / DisplaySize(DicomViewer) Method
The Viewer being used to provide spacing etc.

In This Topic
    DisplaySize(DicomViewer) Method
    In This Topic
    The size at which this image, using current values for StretchMode etc. will display in this viewer.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Function DisplaySize( _
   ByVal Viewer As DicomViewer _
) As SkiaSharp.SKSizeI
    'Usage

    Dim instance As DicomImage
Dim Viewer As DicomViewer
Dim value As SkiaSharp.SKSizeI

value = instance.DisplaySize(Viewer)
    public SkiaSharp.SKSizeI DisplaySize(
   DicomViewer Viewer
)

    Parameters

    Viewer
    The Viewer being used to provide spacing etc.

    Return Value

    The size of the displayed image, in pixels
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members
    Overload List


DicomObjects Namespace / DicomImage Class / DisplaySize Method / DisplaySize(SKMatrix) Method
The transformation to apply to the original image size.

In This Topic
    DisplaySize(SKMatrix) Method
    In This Topic
    The display size in output coordinates
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Function DisplaySize( _
   ByVal skMatrix As SkiaSharp.SKMatrix _
) As SkiaSharp.SKSizeI
    'Usage

    Dim instance As DicomImage
Dim skMatrix As SkiaSharp.SKMatrix
Dim value As SkiaSharp.SKSizeI

value = instance.DisplaySize(skMatrix)
    public SkiaSharp.SKSizeI DisplaySize(
   SkiaSharp.SKMatrix skMatrix
)

    Parameters

    skMatrix
    The transformation to apply to the original image size.

    Return Value

    The transformed SKSizeI
    Remarks
    This method takes the user provided Matrix, perform Transformation on the Image and returns the Image display size in output (normally screen) coordinates.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members
    Overload List


DicomObjects Namespace / DicomImage Class / Dispose() Method

    Dispose() Method
    Releases the resources used by the DicomImage object This does not dispose the underlying DicomDataSet object which is DataSet, an explicit Dispose call will be needed to have that effect
    Standard Dispose methods
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Sub Dispose()
    'Usage

    Dim instance As DicomImage

instance.Dispose()
    public void Dispose()
    Remarks
    This does not dispose the underlying DicomDataSet object which is DataSet, an explicit Dispose call will be needed to have that effect
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / DistanceFromPoint Method
The reference point
Frame within the image being used for calculation

In This Topic
    DistanceFromPoint Method
    In This Topic
    Perpendicular distance from a Point to the plane of this image
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overridable Function DistanceFromPoint( _
   ByVal Point As SkiaSharp.SKPoint3, _
   ByVal Frame As Integer _
) As Single
    'Usage

    Dim instance As DicomImage
Dim Point As SkiaSharp.SKPoint3
Dim Frame As Integer
Dim value As Single

value = instance.DistanceFromPoint(Point, Frame)
    public virtual float DistanceFromPoint(
   SkiaSharp.SKPoint3 Point,
   int Frame
)

    Parameters

    Point
    The reference point
    Frame
    Frame within the image being used for calculation

    Return Value

    Distance in mm
    Remarks
    The distance may be positive/negative
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / DownloadStatus Method

    DownloadStatus Method (DicomImage)
    In This Topic
    Methods to determine the degree to which part of an image has already been downloaded
    Overload List
    Overload | Description
DownloadStatus(SKRectI,Single,Int32) | The download status of an image compared to specific attributes of the image
DownloadStatus(SKRect,Single,Int32) | The download status of an image compared to specific attributes of the image
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / DownloadStatus Method / DownloadStatus(SKRectI,Single,Int32) Method
The Area of the image needed
The required zoom for the image
The requested frame number

In This Topic
    DownloadStatus(SKRectI,Single,Int32) Method
    In This Topic
    The download status of an image compared to specific attributes of the image
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Function DownloadStatus( _
   ByVal Area As SkiaSharp.SKRectI, _
   ByVal Zoom As Single, _
   ByVal Frame As Integer _
) As ProgressiveStatus
    'Usage

    Dim instance As DicomImage
Dim Area As SkiaSharp.SKRectI
Dim Zoom As Single
Dim Frame As Integer
Dim value As ProgressiveStatus

value = instance.DownloadStatus(Area, Zoom, Frame)
    public ProgressiveStatus DownloadStatus(
   SkiaSharp.SKRectI Area,
   float Zoom,
   int Frame
)

    Parameters

    Area
    The Area of the image needed
    Zoom
    The required zoom for the image
    Frame
    The requested frame number

    Return Value

    The status relative to the parameters
    Remarks
    For this overload, the Area is specified in pixels
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members
    Overload List


DicomObjects Namespace / DicomImage Class / DownloadStatus Method / DownloadStatus(SKRect,Single,Int32) Method
The Area of the image needed
The required zoom for the image
The requested frame number

In This Topic
    DownloadStatus(SKRect,Single,Int32) Method
    In This Topic
    The download status of an image compared to specific attributes of the image
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Function DownloadStatus( _
   ByVal Area As SkiaSharp.SKRect, _
   ByVal Zoom As Single, _
   ByVal Frame As Integer _
) As ProgressiveStatus
    'Usage

    Dim instance As DicomImage
Dim Area As SkiaSharp.SKRect
Dim Zoom As Single
Dim Frame As Integer
Dim value As ProgressiveStatus

value = instance.DownloadStatus(Area, Zoom, Frame)
    public ProgressiveStatus DownloadStatus(
   SkiaSharp.SKRect Area,
   float Zoom,
   int Frame
)

    Parameters

    Area
    The Area of the image needed
    Zoom
    The required zoom for the image
    Frame
    The requested frame number

    Return Value

    The status relative to the parameters
    Remarks
    For this overload, the Area is specified in image fractions (0.0-1.0)
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members
    Overload List


DicomObjects Namespace / DicomImage Class / Export Method

    Export Method (DicomImage)
    In This Topic
    Export DicomImage to supported Format
    Overload List
    Overload | Description
Export(String,String,Object) | Export DicomImage to supported Format
Export(Stream,String,Object) | Export DicomImage to supported Format
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / Export Method / Export(String,String,Object) Method

The name of the file to export

The type of export operation to perform

The quality factor to be used. This is a generic compression quality depending on the Transfer Syntax used. This value for JPEG Baseline and JPEG Extended compression represents an integer between 0 – 100. This tells DicomObjects to set up the compressor to try to achieve the quality in percentage (higher quality value towards 100 means better quality and lower compression ratio). And for JPEG-LS Lossy and JPEG2000 Lossy compression this value is actually the desired compression ratio, i.e. if you set the quality value to 10, it tells DicomObjects to try to achieve compression ratio of 10. The actual compression ratio achieved will not be exactly the same as specified by quality value but close enough. The actual compression ratio is calculated based on the original data size and the compressed data size before it is added to “Lossy Image Compression Ratio” tag of the image. For Video compression, this value directly corresponds to the BitsPerSecond of the compressed video.

In This Topic
    Export(String,String,Object) Method
    In This Topic
    Export DicomImage to supported Format
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub Export( _
   ByVal fileName As String, _
   Optional ByVal format As String, _
   Optional ByVal quality As Object _
)
    'Usage

    Dim instance As DicomImage
Dim fileName As String
Dim format As String
Dim quality As Object

instance.Export(fileName, format, quality)
    public void Export(
   string fileName,
   string format,
   object quality
)

    Parameters

    fileName

    The name of the file to export

    format

    The type of export operation to perform

    quality

    The quality factor to be used. This is a generic compression quality depending on the Transfer Syntax used. This value for JPEG Baseline and JPEG Extended compression represents an integer between 0 – 100. This tells DicomObjects to set up the compressor to try to achieve the quality in percentage (higher quality value towards 100 means better quality and lower compression ratio). And for JPEG-LS Lossy and JPEG2000 Lossy compression this value is actually the desired compression ratio, i.e. if you set the quality value to 10, it tells DicomObjects to try to achieve compression ratio of 10. The actual compression ratio achieved will not be exactly the same as specified by quality value but close enough. The actual compression ratio is calculated based on the original data size and the compressed data size before it is added to “Lossy Image Compression Ratio” tag of the image. For Video compression, this value directly corresponds to the BitsPerSecond of the compressed video.

    Remarks

    Any of the formats supported via SkiaSharp.SKEncodedImageFormat or via internal codecs are supported

    See for details of how to write and configure your own codecs.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members
    Overload List


DicomObjects Namespace / DicomImage Class / Export Method / Export(Stream,String,Object) Method

The stream into which the image is written

The file format you would like to export image to

The quality factor to be used. This is a generic compression quality depending on the Transfer Syntax used. This value for JPEG Baseline and JPEG Extended compression represents an integer between 0 – 100. This tells DicomObjects to set up the compressor to try to achieve the quality in percentage (higher quality value towards 100 means better quality and lower compression ratio). And for JPEG-LS Lossy and JPEG2000 Lossy compression this value is actually the desired compression ratio, i.e. if you set the quality value to 10, it tells DicomObjects to try to achieve compression ratio of 10. The actual compression ratio achieved will not be exactly the same as specified by quality value but close enough. The actual compression ratio is calculated based on the original data size and the compressed data size before it is added to “Lossy Image Compression Ratio” tag of the image. For Video compression, this value directly corresponds to the BitsPerSecond of the compressed video.

In This Topic
    Export(Stream,String,Object) Method
    In This Topic
    Export DicomImage to supported Format
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub Export( _
   ByVal stream As Stream, _
   ByVal format As String, _
   ByVal quality As Object _
)
    'Usage

    Dim instance As DicomImage
Dim stream As Stream
Dim format As String
Dim quality As Object

instance.Export(stream, format, quality)
    public void Export(
   Stream stream,
   string format,
   object quality
)

    Parameters

    stream

    The stream into which the image is written

    format

    The file format you would like to export image to

    quality

    The quality factor to be used. This is a generic compression quality depending on the Transfer Syntax used. This value for JPEG Baseline and JPEG Extended compression represents an integer between 0 – 100. This tells DicomObjects to set up the compressor to try to achieve the quality in percentage (higher quality value towards 100 means better quality and lower compression ratio). And for JPEG-LS Lossy and JPEG2000 Lossy compression this value is actually the desired compression ratio, i.e. if you set the quality value to 10, it tells DicomObjects to try to achieve compression ratio of 10. The actual compression ratio achieved will not be exactly the same as specified by quality value but close enough. The actual compression ratio is calculated based on the original data size and the compressed data size before it is added to “Lossy Image Compression Ratio” tag of the image. For Video compression, this value directly corresponds to the BitsPerSecond of the compressed video.

    Remarks
    This method uses the internal DicomObjects export methods, including the ability to export multi-frame GIF etc.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members
    Overload List


DicomObjects Namespace / DicomImage Class / GetCacheSize Method
Type of Cache of interest, default value is DicomObjects.Enums.CacheTypes.All

In This Topic
    GetCacheSize Method (DicomImage)
    In This Topic
    Get cache size used by DicomObjects for the image - useful to help decide when to call ClearCaches method
    Clears the internal cache for uncompressed pixel data
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Function GetCacheSize( _
   ByVal cacheType As CacheTypes _
) As Long
    'Usage

    Dim instance As DicomImage
Dim cacheType As CacheTypes
Dim value As Long

value = instance.GetCacheSize(cacheType)
    public long GetCacheSize(
   CacheTypes cacheType
)

    Parameters

    cacheType
    Type of Cache of interest, default value is DicomObjects.Enums.CacheTypes.All

    Return Value

    number of bytes cached by DicomObjects
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / GetColourTable Method

    GetColourTable Method
    The colour lookup table of DicomImage
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Function GetColourTable() As IList(Of SKColor)
    'Usage

    Dim instance As DicomImage
Dim value As IList(Of SKColor)

value = instance.GetColourTable()
    public IList<SKColor> GetColourTable()

    Return Value

    List of SkiaSharp.SKColor values
    Remarks
    This property enables developers to define and apply their own color table to Images.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / GetMaskRanges Method

    GetMaskRanges Method

    Contains an array of DicomMaskRange objects to be applied to this image.

    See the DicomMaskRange object for more information on how this is used.

    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Function GetMaskRanges() As DicomMaskRange()
    'Usage

    Dim instance As DicomImage
Dim value() As DicomMaskRange

value = instance.GetMaskRanges()
    public DicomMaskRange[] GetMaskRanges()
    Remarks
    If this property is changed, then the internal caches are cleared automatically, but if you change individual elements of the array without chaning the array itself, then it is necessary to call ClearCaches explicitly.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / GetMinAndMax Method

    GetMinAndMax Method (DicomImage)
    In This Topic
    Find the maximum and minimum pixel data values in the pixel data
    Overload List
    Overload | Description
GetMinAndMax(Single,Single,Single,Boolean) | Find the maximum and minimum pixel data values in the pixel data
GetMinAndMax(Single,Single,Single,Boolean,Boolean) | Find the maximum and minimum pixel data values in the pixel data
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / GetMinAndMax Method / GetMinAndMax(Single,Single,Single,Boolean) Method
The minimum value found
The maximum value found
Proportion of extreme values to ignore (in range 0.0 to 1.0)
Whether to apply scaling/modality lookup table transformation

In This Topic
    GetMinAndMax(Single,Single,Single,Boolean) Method
    In This Topic
    Find the maximum and minimum pixel data values in the pixel data
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub GetMinAndMax( _
   ByRef Min As Single, _
   ByRef Max As Single, _
   ByVal Centile As Single, _
   ByVal Scale As Boolean _
)
    'Usage

    Dim instance As DicomImage
Dim Min As Single
Dim Max As Single
Dim Centile As Single
Dim Scale As Boolean

instance.GetMinAndMax(Min, Max, Centile, Scale)
    public void GetMinAndMax(
   out float Min,
   out float Max,
   float Centile,
   bool Scale
)

    Parameters

    Min
    The minimum value found
    Max
    The maximum value found
    Centile
    Proportion of extreme values to ignore (in range 0.0 to 1.0)
    Scale
    Whether to apply scaling/modality lookup table transformation
    Remarks

    Pixel padding values are ignored

    If Scale is false, then the values returned are "raw" values before application of rescaling or modality lookup tables

    If Scale is true, then the values returned are transformed using the modality slope and intercept or modality lookup tables as appropriate to the image

    If it is necessray to use separate control for the 2 scaling methods, then the GetMinAndMax(Single,Single,Single,Boolean,Boolean) override may be used instead.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members
    Overload List


DicomObjects Namespace / DicomImage Class / GetMinAndMax Method / GetMinAndMax(Single,Single,Single,Boolean,Boolean) Method
The minimum value found
The maximum value found
Centile as Float
Whether to apply modality lookup table transformation
Whether to apply modality rescale slope and offset transformations

In This Topic
    GetMinAndMax(Single,Single,Single,Boolean,Boolean) Method
    In This Topic
    Find the maximum and minimum pixel data values in the pixel data
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub GetMinAndMax( _
   ByRef Min As Single, _
   ByRef Max As Single, _
   ByVal Centile As Single, _
   ByVal ScaleLUT As Boolean, _
   ByVal ScaleRescale As Boolean _
)
    'Usage

    Dim instance As DicomImage
Dim Min As Single
Dim Max As Single
Dim Centile As Single
Dim ScaleLUT As Boolean
Dim ScaleRescale As Boolean

instance.GetMinAndMax(Min, Max, Centile, ScaleLUT, ScaleRescale)
    public void GetMinAndMax(
   out float Min,
   out float Max,
   float Centile,
   bool ScaleLUT,
   bool ScaleRescale
)

    Parameters

    Min
    The minimum value found
    Max
    The maximum value found
    Centile
    Centile as Float
    ScaleLUT
    Whether to apply modality lookup table transformation
    ScaleRescale
    Whether to apply modality rescale slope and offset transformations
    Remarks

    Pixel padding values are ignored

    If ScaleLUT is false, then the values returned are "raw" values before application of rescaling or modality lookup tables

    If ScaleLUT is true, then the values returned are transformed using the modality slope and intercept or modality lookup tables as appropriate to the image

    If it is necessray to use separate control for the 2 scaling methods, then the GetMinAndMax(Single,Single,Single,Boolean,Boolean) override may be used instead.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members
    Overload List


DicomObjects Namespace / DicomImage Class / GetRawFrame Method
Frame number to extract
Cache result for the extracted frame

In This Topic
    GetRawFrame Method (DicomImage)
    In This Topic
    Extract individual frame from the pixel data
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Function GetRawFrame( _
   ByVal Frame As Integer, _
   ByVal cache As Boolean _
) As Byte()
    'Usage

    Dim instance As DicomImage
Dim Frame As Integer
Dim cache As Boolean
Dim value() As Byte

value = instance.GetRawFrame(Frame, cache)
    public byte[] GetRawFrame(
   int Frame,
   bool cache
)

    Parameters

    Frame
    Frame number to extract
    cache
    Cache result for the extracted frame

    Return Value

    Raw pixel data of the request frame
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / Histogram Method
The lowest pixel value to be included
The highest pixel value to be included
The number of adjacent pixel values to be grouped into each bin

In This Topic
    Histogram Method
    In This Topic
    Returns an array containing the distribution of raw pixel values.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Function Histogram( _
   ByVal MinValue As Integer, _
   ByVal MaxValue As Integer, _
   ByVal BinSize As Integer _
) As Integer()
    'Usage

    Dim instance As DicomImage
Dim MinValue As Integer
Dim MaxValue As Integer
Dim BinSize As Integer
Dim value() As Integer

value = instance.Histogram(MinValue, MaxValue, BinSize)
    public int[] Histogram(
   int MinValue,
   int MaxValue,
   int BinSize
)

    Parameters

    MinValue
    The lowest pixel value to be included
    MaxValue
    The highest pixel value to be included
    BinSize
    The number of adjacent pixel values to be grouped into each bin

    Return Value

    An integer array containing the distribution.
    Remarks
    The format of the returned data is suitable for creating DICOM Image Histogram modules, though to use this a few other attributes must be added. In keeping with the image histogram module, the values used are raw pixel values before application of a modality lookup table or rescaling � apply Lookup Tables if such translation is required. For multi-frame images, only the first frame is used for this method.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / ImagePlane Method

    ImagePlane Method
    The currently displayed plane of this image.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overridable Function ImagePlane( _
   ByVal frame1 As Integer _
) As Plane3D
    'Usage

    Dim instance As DicomImage
Dim frame1 As Integer
Dim value As Plane3D

value = instance.ImagePlane(frame1)
    public virtual Plane3D ImagePlane(
   int frame1
)

    Parameters

    frame1

    Return Value

    The plane of the image in 3D space, or null if not applicable to this image.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / Import Method

    Import Method (DicomImage)
    In This Topic
    Copies the image data from an external image format
    Overload List
    Overload | Description
Import(String) | Copies the image data from an external image
Import(Stream,String) | Copies the image data from a System IO Stream
Import(SKBitmap,Int32) | Copies the image data from the provided SkiaSharp.SKBitmap
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / Import Method / Import(String) Method

The name of the file to read.

This is passed unmodified to the operating system, and it is therefore the container�s responsibility to ensure either that the current directory is set correctly, or that a fully qualified filename is provided.

In This Topic
    Import(String) Method
    In This Topic
    Copies the image data from an external image
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub Import( _
   ByVal fileName As String _
)
    'Usage

    Dim instance As DicomImage
Dim fileName As String

instance.Import(fileName)
    public void Import(
   string fileName
)

    Parameters

    fileName

    The name of the file to read.

    This is passed unmodified to the operating system, and it is therefore the container�s responsibility to ensure either that the current directory is set correctly, or that a fully qualified filename is provided.

    Remarks

    Like the Paste method, this method modifies only the minimum number of attributes necessary to ensure consistency of the image. In order to produce a valid DICOM SOP instance, many other attributes (depending on the SOP class) must be added.

    The import file format is detected automatically, if DicomObjects cannot detect the file type then it will use the file extension as the format.

    All formats which are supported via Bitmap overloads (or including JPEG 2000) are supported.

    File extensions for supported formats are:

    • JPEG: "JPEG" or "JPG"
    • Bitmap: "BMP"
    • DIB: "DIB"
    • AVI: "AVI"

    A multiframe image is created if the input data is a multipage Image

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members
    Overload List


DicomObjects Namespace / DicomImage Class / Import Method / Import(Stream,String) Method

The System IO Stream to read

The type of import operation to perform

In This Topic
    Import(Stream,String) Method
    In This Topic
    Copies the image data from a System IO Stream
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub Import( _
   ByVal stream As Stream, _
   ByVal format As String _
)
    'Usage

    Dim instance As DicomImage
Dim stream As Stream
Dim format As String

instance.Import(stream, format)
    public void Import(
   Stream stream,
   string format
)

    Parameters

    stream

    The System IO Stream to read

    format

    The type of import operation to perform

    Remarks

    Like the Paste method, this method modifies only the minimum number of attributes necessary to ensure consistency of the image. In order to produce a valid DICOM SOP instance, many other attributes (depending on the SOP class) must be added.

    All formats which are supported via Bitmap overloads (or including JPEG 2000) are supported.

    The following applies to JPEG file import:

    • The JPEG data is imported directly, and may either be stored or transmitted unchanged as a JPEG encapsulated SOP instance (1.2.840.10008.1.2.4.50), or automatically decompressed if necessary.
    • The Type parameter must be JPEG or JPG

    The following applies to JPEG 2000 file import:

    • The import format must be "J2K", "JPC" or "JP2"
    • The JPEG 2000 data is imported directly, and may either be stored or transmitted unchanged as a JPEG 2000 encapsulated SOP instance (1.2.840.10008.1.2.4.90 or .91), or automatically decompressed if necessary.
    • The Type parameter must be J2K, JPC or JP2.
    • For JP2, the header is stripped

    The following applies to AVI file import:

    • The Type parameter must be AVI.
    • A multi-frame DICOM image is generated.

    See for details of how to write and configure your own codecs.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members
    Overload List


DicomObjects Namespace / DicomImage Class / Import Method / Import(SKBitmap,Int32) Method
The image to import
Total number of frames included in the bitmap

In This Topic
    Import(SKBitmap,Int32) Method
    In This Topic
    Copies the image data from the provided SkiaSharp.SKBitmap
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub Import( _
   ByVal bitmap As SkiaSharp.SKBitmap, _
   Optional ByVal frames As Integer _
)
    'Usage

    Dim instance As DicomImage
Dim bitmap As SkiaSharp.SKBitmap
Dim frames As Integer

instance.Import(bitmap, frames)
    public void Import(
   SkiaSharp.SKBitmap bitmap,
   int frames
)

    Parameters

    bitmap
    The image to import
    frames
    Total number of frames included in the bitmap
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members
    Overload List


DicomObjects Namespace / DicomImage Class / Matrix(SKSize) Method
The size used for calculations

    Matrix(SKSize) Method
    In This Topic
    Matrix specifying how the image is displayed onto display of the stated size
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Function Matrix( _
   ByVal OutputSize As SkiaSharp.SKSize _
) As SkiaSharp.SKMatrix
    'Usage

    Dim instance As DicomImage
Dim OutputSize As SkiaSharp.SKSize
Dim value As SkiaSharp.SKMatrix

value = instance.Matrix(OutputSize)
    public SkiaSharp.SKMatrix Matrix(
   SkiaSharp.SKSize OutputSize
)

    Parameters

    OutputSize
    The size used for calculations

    Return Value

    Matrix
    Remarks
    A .NET object containing the image display information, like rotation, scale etc. The SKSize is important if the DicomObjects.Enums.ScaleMode of the image indicates stetching to fit the available space.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / MatrixBase Method
If true, then the aspect ratio of the image is respected, so the zoom in one of the directions may be >1 if necessary to give a correctly shaped image

In This Topic
    MatrixBase Method
    In This Topic
    Matrix specifying how the image would be displayed with a Zoom of 1:1
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Function MatrixBase( _
   ByVal UseAspect As Boolean _
) As SkiaSharp.SKMatrix
    'Usage

    Dim instance As DicomImage
Dim UseAspect As Boolean
Dim value As SkiaSharp.SKMatrix

value = instance.MatrixBase(UseAspect)
    public SkiaSharp.SKMatrix MatrixBase(
   bool UseAspect
)

    Parameters

    UseAspect
    If true, then the aspect ratio of the image is respected, so the zoom in one of the directions may be >1 if necessary to give a correctly shaped image

    Return Value

    Matrix
    Remarks
    The RotateState, FlipState and Angle are all used in this method.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / PixelValuesByFrame Method
The 1-based frame number to retrieve
Controls whether to apply the scale/offset or Modality LUT if present

In This Topic
    PixelValuesByFrame Method
    In This Topic
    Returns a float array of pixel values for a frame, optionally transformed via the modality transformation
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Function PixelValuesByFrame( _
   ByVal frame As Integer, _
   ByVal modalityTransform As Boolean _
) As Single()
    'Usage

    Dim instance As DicomImage
Dim frame As Integer
Dim modalityTransform As Boolean
Dim value() As Single

value = instance.PixelValuesByFrame(frame, modalityTransform)
    public float[] PixelValuesByFrame(
   int frame,
   bool modalityTransform
)

    Parameters

    frame
    The 1-based frame number to retrieve
    modalityTransform
    Controls whether to apply the scale/offset or Modality LUT if present

    Return Value

    Array of float values representing the (possibly transformed) pixel values
    Remarks
    Even if modalityTransform is false, the values are still masked to the relevant bit length and interpreted as sign/unsigned. This differs from RawPixelValuesByFrame.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / PixelValuesByFrameGeneric Method
The 1-based frame number to retrieve
Controls whether to apply the scale/offset or Modality LUT if present

In This Topic
    PixelValuesByFrameGeneric Method (DicomImage)
    In This Topic
    Returns an array of pixel values for a frame, optionally transformed via the modality transformation
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Function PixelValuesByFrameGeneric( _
   ByVal frame As Integer, _
   ByVal modalityTransform As Boolean _
) As Array
    'Usage

    Dim instance As DicomImage
Dim frame As Integer
Dim modalityTransform As Boolean
Dim value As Array

value = instance.PixelValuesByFrameGeneric(frame, modalityTransform)
    public Array PixelValuesByFrameGeneric(
   int frame,
   bool modalityTransform
)

    Parameters

    frame
    The 1-based frame number to retrieve
    modalityTransform
    Controls whether to apply the scale/offset or Modality LUT if present

    Return Value

    Array of values representing the (possibly transformed) pixel values. Return type is a generic array as opposed to PixelValuesByFrame which returns a float[]
    Remarks
    Even if modalityTransform is false, the values are still masked to the relevant bit length and interpreted as sign/unsigned. This differs from RawPixelValuesByFrame.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / PrinterImage Method

    PrinterImage Method (DicomImage)
    In This Topic
    Creates a copy of the image for printing or other purposes
    Overload List
    Overload | Description
PrinterImage(Int32,Int32,Boolean,Single,SKRectI,Boolean) | Creates a copy of the image for printing or other purposes
PrinterImage(Int32,Int32,Boolean,Single,SKRectI,Boolean,Int32) | Creates a copy of the image for printing or other purposes
PrinterImage(Int32,Int32,Boolean,Single,SKRectI,Boolean,Int32,Int32) | Creates a copy of the image for printing or other purposes
PrinterImage(Int32,Int32,Boolean,SKMatrix,SKRectI,Int32,Int32) | Creates a copy of the image for printing or other purposes
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / PrinterImage Method / PrinterImage(Int32,Int32,Boolean,Single,SKRectI,Boolean) Method

Bit depth of final image (must be 8-16, but always 8 when Planes=3)

1 for monochrome and 3 for colour

Controls whether annotations are "burnt-in" to the new image

Zoom to apply to new image

The area of the original image to use

Controls whether Image Aspect Ratio is used - if true, then output pixels are square, but if false, then they retain their original aspect ratio

If ShowAnnotations is true, then this parameter is agnored and treated as true.

In This Topic
    PrinterImage(Int32,Int32,Boolean,Single,SKRectI,Boolean) Method
    In This Topic
    Creates a copy of the image for printing or other purposes
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Function PrinterImage( _
   ByVal Bits As Integer, _
   ByVal Planes As Integer, _
   ByVal ShowAnnotations As Boolean, _
   ByVal Zoom As Single, _
   ByVal Area As SkiaSharp.SKRectI, _
   ByVal SquarePixels As Boolean _
) As DicomImage
    'Usage

    Dim instance As DicomImage
Dim Bits As Integer
Dim Planes As Integer
Dim ShowAnnotations As Boolean
Dim Zoom As Single
Dim Area As SkiaSharp.SKRectI
Dim SquarePixels As Boolean
Dim value As DicomImage

value = instance.PrinterImage(Bits, Planes, ShowAnnotations, Zoom, Area, SquarePixels)
    public DicomImage PrinterImage(
   int Bits,
   int Planes,
   bool ShowAnnotations,
   float Zoom,
   SkiaSharp.SKRectI Area,
   bool SquarePixels
)

    Parameters

    Bits

    Bit depth of final image (must be 8-16, but always 8 when Planes=3)

    Planes

    1 for monochrome and 3 for colour

    ShowAnnotations

    Controls whether annotations are "burnt-in" to the new image

    Zoom

    Zoom to apply to new image

    Area

    The area of the original image to use

    SquarePixels

    Controls whether Image Aspect Ratio is used - if true, then output pixels are square, but if false, then they retain their original aspect ratio

    If ShowAnnotations is true, then this parameter is agnored and treated as true.

    Return Value

    DicomImage
    Remarks
    The copy is fully rendered and scaled to the chosen bit depth, so no further windowing is required. Only 8 bits are allowed when Planes=3 (RGB). Area refers to the original image � the size of the final image is the product of the cropped size and the chosen zoom. If the edges are given as 0, the full image is used.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members
    Overload List


DicomObjects Namespace / DicomImage Class / PrinterImage Method / PrinterImage(Int32,Int32,Boolean,Single,SKRectI,Boolean,Int32) Method

Bit depth of final image (must be 8-16, but always 8 when Planes=3)

1 for monochrome and 3 for colour

Controls whether annotations are "burnt-in" to the new image

Zoom to apply to new image

The area of the original image to use

Controls whether Image Aspect Ratio is used - if true, then output pixels are square, but if false, then they retain their original aspect ratio

If ShowAnnotations is true, then this parameter is agnored and treated as true.

The frame number to use. This is 1-index, i.e. first frame is 1 not 0

In This Topic
    PrinterImage(Int32,Int32,Boolean,Single,SKRectI,Boolean,Int32) Method
    In This Topic
    Creates a copy of the image for printing or other purposes
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Function PrinterImage( _
   ByVal Bits As Integer, _
   ByVal Planes As Integer, _
   ByVal ShowAnnotations As Boolean, _
   ByVal Zoom As Single, _
   ByVal Area As SkiaSharp.SKRectI, _
   ByVal SquarePixels As Boolean, _
   ByVal Frame As Integer _
) As DicomImage
    'Usage

    Dim instance As DicomImage
Dim Bits As Integer
Dim Planes As Integer
Dim ShowAnnotations As Boolean
Dim Zoom As Single
Dim Area As SkiaSharp.SKRectI
Dim SquarePixels As Boolean
Dim Frame As Integer
Dim value As DicomImage

value = instance.PrinterImage(Bits, Planes, ShowAnnotations, Zoom, Area, SquarePixels, Frame)
    public DicomImage PrinterImage(
   int Bits,
   int Planes,
   bool ShowAnnotations,
   float Zoom,
   SkiaSharp.SKRectI Area,
   bool SquarePixels,
   int Frame
)

    Parameters

    Bits

    Bit depth of final image (must be 8-16, but always 8 when Planes=3)

    Planes

    1 for monochrome and 3 for colour

    ShowAnnotations

    Controls whether annotations are "burnt-in" to the new image

    Zoom

    Zoom to apply to new image

    Area

    The area of the original image to use

    SquarePixels

    Controls whether Image Aspect Ratio is used - if true, then output pixels are square, but if false, then they retain their original aspect ratio

    If ShowAnnotations is true, then this parameter is agnored and treated as true.

    Frame

    The frame number to use. This is 1-index, i.e. first frame is 1 not 0

    Return Value

    DicomImage
    Remarks
    The copy is fully rendered and scaled to the chosen bit depth, so no further windowing is required. Only 8 bits are allowed when Planes=3 (RGB). Area refers to the original image � the size of the final image is the product of the cropped size and the chosen zoom. If the edges are given as 0, the full image is used.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members
    Overload List


DicomObjects Namespace / DicomImage Class / PrinterImage Method / PrinterImage(Int32,Int32,Boolean,Single,SKRectI,Boolean,Int32,Int32) Method

Bit depth of final image (must be 8-16, but always 8 when Planes=3)

1 for monochrome and 3 for colour

Controls whether annotations are "burnt-in" to the new image

Zoom to apply to new image

The area of the original image to use

Controls whether Image Aspect Ratio is used - if true, then output pixels are square, but if false, then they retain their original aspect ratio

If ShowAnnotations is true, then this parameter is agnored and treated as true.

The frame number to use. This is 1-index, i.e. first frame is 1 not 0

The planar configuration value of the resulting image. For use in Printing, this should be 1 as defined by DICOM rules, but if this function is used for other purposes, then 0 may be required.

In This Topic
    PrinterImage(Int32,Int32,Boolean,Single,SKRectI,Boolean,Int32,Int32) Method
    In This Topic
    Creates a copy of the image for printing or other purposes
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Function PrinterImage( _
   ByVal Bits As Integer, _
   ByVal Planes As Integer, _
   ByVal ShowAnnotations As Boolean, _
   ByVal Zoom As Single, _
   ByVal Area As SkiaSharp.SKRectI, _
   ByVal SquarePixels As Boolean, _
   ByVal Frame As Integer, _
   ByVal PlanarConfig As Integer _
) As DicomImage
    'Usage

    Dim instance As DicomImage
Dim Bits As Integer
Dim Planes As Integer
Dim ShowAnnotations As Boolean
Dim Zoom As Single
Dim Area As SkiaSharp.SKRectI
Dim SquarePixels As Boolean
Dim Frame As Integer
Dim PlanarConfig As Integer
Dim value As DicomImage

value = instance.PrinterImage(Bits, Planes, ShowAnnotations, Zoom, Area, SquarePixels, Frame, PlanarConfig)
    public DicomImage PrinterImage(
   int Bits,
   int Planes,
   bool ShowAnnotations,
   float Zoom,
   SkiaSharp.SKRectI Area,
   bool SquarePixels,
   int Frame,
   int PlanarConfig
)

    Parameters

    Bits

    Bit depth of final image (must be 8-16, but always 8 when Planes=3)

    Planes

    1 for monochrome and 3 for colour

    ShowAnnotations

    Controls whether annotations are "burnt-in" to the new image

    Zoom

    Zoom to apply to new image

    Area

    The area of the original image to use

    SquarePixels

    Controls whether Image Aspect Ratio is used - if true, then output pixels are square, but if false, then they retain their original aspect ratio

    If ShowAnnotations is true, then this parameter is agnored and treated as true.

    Frame

    The frame number to use. This is 1-index, i.e. first frame is 1 not 0

    PlanarConfig

    The planar configuration value of the resulting image. For use in Printing, this should be 1 as defined by DICOM rules, but if this function is used for other purposes, then 0 may be required.

    Return Value

    DicomImage
    Remarks
    The copy is fully rendered and scaled to the chosen bit depth, so no further windowing is required. Only 8 bits are allowed when Planes=3 (RGB). Area refers to the original image � the size of the final image is the product of the cropped size and the chosen zoom. If the edges are given as 0, the full image is used.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members
    Overload List


DicomObjects Namespace / DicomImage Class / PrinterImage Method / PrinterImage(Int32,Int32,Boolean,SKMatrix,SKRectI,Int32,Int32) Method

Bit depth of final image (must be 8-16, but always 8 when Planes=3)

1 for monochrome and 3 for colour

Controls whether annotations are "burnt-in" to the new image

The transform to apply to the pixels - this includes zoom etc.

The output area to be filled

The frame number to use. This is 1-index, i.e. first frame is 1 not 0

The planar configuration value of the resulting image. For use in Printing, this should be 1 as defined by DICOM rules, but if this function is used for other purposes, then 0 may be required.

In This Topic
    PrinterImage(Int32,Int32,Boolean,SKMatrix,SKRectI,Int32,Int32) Method
    In This Topic
    Creates a copy of the image for printing or other purposes
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Function PrinterImage( _
   ByVal Bits As Integer, _
   ByVal Planes As Integer, _
   ByVal ShowAnnotations As Boolean, _
   ByVal skMatrix As SkiaSharp.SKMatrix, _
   ByVal FinalArea As SkiaSharp.SKRectI, _
   ByVal Frame As Integer, _
   ByVal PlanarConfig As Integer _
) As DicomImage
    'Usage

    Dim instance As DicomImage
Dim Bits As Integer
Dim Planes As Integer
Dim ShowAnnotations As Boolean
Dim skMatrix As SkiaSharp.SKMatrix
Dim FinalArea As SkiaSharp.SKRectI
Dim Frame As Integer
Dim PlanarConfig As Integer
Dim value As DicomImage

value = instance.PrinterImage(Bits, Planes, ShowAnnotations, skMatrix, FinalArea, Frame, PlanarConfig)
    public DicomImage PrinterImage(
   int Bits,
   int Planes,
   bool ShowAnnotations,
   SkiaSharp.SKMatrix skMatrix,
   SkiaSharp.SKRectI FinalArea,
   int Frame,
   int PlanarConfig
)

    Parameters

    Bits

    Bit depth of final image (must be 8-16, but always 8 when Planes=3)

    Planes

    1 for monochrome and 3 for colour

    ShowAnnotations

    Controls whether annotations are "burnt-in" to the new image

    skMatrix

    The transform to apply to the pixels - this includes zoom etc.

    FinalArea

    The output area to be filled

    Frame

    The frame number to use. This is 1-index, i.e. first frame is 1 not 0

    PlanarConfig

    The planar configuration value of the resulting image. For use in Printing, this should be 1 as defined by DICOM rules, but if this function is used for other purposes, then 0 may be required.

    Return Value

    DicomImage
    Remarks
    The copy is fully rendered and scaled to the chosen bit depth, so no further windowing is required. Only 8 bits are allowed when Planes=3 (RGB). Area refers to the original image � the size of the final image is the product of the cropped size and the chosen zoom. If the edges are given as 0, the full image is used.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members
    Overload List


DicomObjects Namespace / DicomImage Class / RawPixelValuesByFrame Method
The 1-based frame number to retrieve

    RawPixelValuesByFrame Method
    In This Topic
    Returns an array of raw pixel values for a frame
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Function RawPixelValuesByFrame( _
   ByVal Frame As Integer _
) As Array
    'Usage

    Dim instance As DicomImage
Dim Frame As Integer
Dim value As Array

value = instance.RawPixelValuesByFrame(Frame)
    public Array RawPixelValuesByFrame(
   int Frame
)

    Parameters

    Frame
    The 1-based frame number to retrieve

    Return Value

    Array of values representing the raw pixel values before masking, signing interpretation, or modality transformations
    Remarks
    For interpretted values (with or with use of the modality transformation, see PixelValuesByFrame.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / Read Method

    Read Method (DicomImage)
    In This Topic
    Read from a file, a system IO stream or a byte array
    Overload List
    Overload | Description
Read(String,ReadBehaviours) | Reads from an external DICOM file
Read(Stream,ReadBehaviours) | Reads from a system IO stream
Read(Byte[],ReadBehaviours) | Reads from a Byte Array
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / Read Method / Read(String,ReadBehaviours) Method

The name of the file to read.

This is passed unmodified to the operating system, and it is therefore the container�s responsibility to ensure either that the file exists within the current directory, or that a fully qualified filename is provided.

The behaviours to be used when reading this stream

In This Topic
    Read(String,ReadBehaviours) Method
    In This Topic
    Reads from an external DICOM file
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub Read( _
   ByVal FileName As String, _
   Optional ByVal readBehaviours As ReadBehaviours _
)
    'Usage

    Dim instance As DicomImage
Dim FileName As String
Dim readBehaviours As ReadBehaviours

instance.Read(FileName, readBehaviours)
    public void Read(
   string FileName,
   ReadBehaviours readBehaviours
)

    Parameters

    FileName

    The name of the file to read.

    This is passed unmodified to the operating system, and it is therefore the container�s responsibility to ensure either that the file exists within the current directory, or that a fully qualified filename is provided.

    readBehaviours
    The behaviours to be used when reading this stream
    Remarks

    This method can read either official "Part10" format files with the 128 byte header, or unofficial "Part5" format files without a header. Detection of the type is automatic.

    The file may have been written by the Write method or by other DICOM software.

    By default, pixel data is read only when it is required, greatly speeding the display of multi-frame images, and reducing memory requirements. However, a side effect of this is that any elements after the pixel data (7FE0,0010) will not be read. This should not affect most applications, but if necessary, this behavior may be over-ridden using the CloseFilesAfterReading property.

    Another effect of file mapping is that files read using this method cannot be deleted until the image object is released. This method creates two references to the newly created DicomImage object (one in the collection, and one as the return value), and both must be released before the file can be deleted.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members
    Overload List


DicomObjects Namespace / DicomImage Class / Read Method / Read(Stream,ReadBehaviours) Method

The Stream from which to read.

ReadBehavioursObject to control individual read operation

In This Topic
    Read(Stream,ReadBehaviours) Method
    In This Topic
    Reads from a system IO stream
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub Read( _
   ByVal Stream As Stream, _
   Optional ByVal readBehaviours As ReadBehaviours _
)
    'Usage

    Dim instance As DicomImage
Dim Stream As Stream
Dim readBehaviours As ReadBehaviours

instance.Read(Stream, readBehaviours)
    public void Read(
   Stream Stream,
   ReadBehaviours readBehaviours
)

    Parameters

    Stream

    The Stream from which to read.

    readBehaviours
    ReadBehavioursObject to control individual read operation
    Remarks

    This method can read streams in either official "Part10" format, with the 128 byte header, or unofficial "Part5" format, without a header. Detection of the type is automatic.

    The stream may have been written by the Write method or by other DICOM software.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members
    Overload List


DicomObjects Namespace / DicomImage Class / Read Method / Read(Byte[],ReadBehaviours) Method

Byte Array to read

The behaviours to be used when reading this stream

In This Topic
    Read(Byte[],ReadBehaviours) Method
    In This Topic
    Reads from a Byte Array
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub Read( _
   ByVal Array() As Byte, _
   Optional ByVal readBehaviours As ReadBehaviours _
)
    'Usage

    Dim instance As DicomImage
Dim Array() As Byte
Dim readBehaviours As ReadBehaviours

instance.Read(Array, readBehaviours)
    public void Read(
   byte[] Array,
   ReadBehaviours readBehaviours
)

    Parameters

    Array

    Byte Array to read

    readBehaviours

    The behaviours to be used when reading this stream

    Remarks
    Reads an array of byte, which may have been written by Write method.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members
    Overload List


DicomObjects Namespace / DicomImage Class / ReadURL Method

The web address of the image to read.

In This Topic
    ReadURL Method (DicomImage)
    In This Topic
    Reads from Web Address
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Sub ReadURL( _
   ByVal URL As String _
)
    'Usage

    Dim instance As DicomImage
Dim URL As String

instance.ReadURL(URL)
    public void ReadURL(
   string URL
)

    Parameters

    URL

    The web address of the image to read.

    Remarks

    A valid web address should be provided by the user. This method does not support progressive downloading (JPIP support is to be implemented).

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / ReferenceLine Method

The main Image, who's position is to be shown.

Whether the intersection should be used - see remarks for details

In This Topic
    ReferenceLine Method
    In This Topic
    This method returns a new DicomLabel object which represents the position of one DicomImage relative to another.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Function ReferenceLine( _
   ByVal Image As DicomImage, _
   ByVal Intersection As Boolean _
) As DicomLabel
    'Usage

    Dim instance As DicomImage
Dim Image As DicomImage
Dim Intersection As Boolean
Dim value As DicomLabel

value = instance.ReferenceLine(Image, Intersection)
    public DicomLabel ReferenceLine(
   DicomImage Image,
   bool Intersection
)

    Parameters

    Image

    The main Image, who's position is to be shown.

    Intersection

    Whether the intersection should be used - see remarks for details

    Return Value

    DicomLabel
    Remarks

    This method is used which you wish to show the relative positions of one image on another. It is typically used in CT and MRI to indicate the position of main imaging sections relative to a previously obtained localizer or �scout� image.

    The method is called on the �localizer� image, and the first parameter is the main section who�s position is to be shown. The result is a new DicomLabel object which is designed to be added to the localizer image�s Labels collection. e.Graphics. if �localizer� and �main_image� are defined as DicomObjects, then the following code will add an appropriate reference line to the localizer image:

    NewLabel = localizer.ReferenceLine(main_image, false)
    Localizer.Labels.Add(NewLabel)

    If the images are orthogonal, then the �Intersection� parameter is not used, and the DicomLabel returned will always be of type LabelType.Line, but if they are not, then it controls how this is handled:

    • If true, then the DicomLabel will still be of type LabelType.Line, representing the intersection of the two image planes.
    • If false, then the DicomLabel returned will be of type LabelType.Polygon with 4 vertices, each representing the projection of a corner of the main image onto the plane of the localizer.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / RenderToArray Method

    RenderToArray Method
    Render the DicomImage to array.
    Overload List
    Overload | Description
RenderToArray(Array,Boolean,Int32) | Render the DicomImage to array. The data returned will be exactly the same as the "presentation data" if the Image gets displayed on screen.
RenderToArray(Array,Boolean,Int32,Int32) | Render the DicomImage to array. The data returned will be exactly the same as the "presentation data" if the Image gets displayed on screen.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / RenderToArray Method / RenderToArray(Array,Boolean,Int32) Method

Array to write the image presentation data to

Set Colour to True if you want the color output.

Bit depth of final data.

In This Topic
    RenderToArray(Array,Boolean,Int32) Method
    In This Topic
    Render the DicomImage to array. The data returned will be exactly the same as the "presentation data" if the Image gets displayed on screen.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub RenderToArray( _
   ByVal destination As Array, _
   ByVal Colour As Boolean, _
   ByVal BitsPerSample As Integer _
)
    'Usage

    Dim instance As DicomImage
Dim destination As Array
Dim Colour As Boolean
Dim BitsPerSample As Integer

instance.RenderToArray(destination, Colour, BitsPerSample)
    public void RenderToArray(
   Array destination,
   bool Colour,
   int BitsPerSample
)

    Parameters

    destination

    Array to write the image presentation data to

    Colour

    Set Colour to True if you want the color output.

    BitsPerSample

    Bit depth of final data.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members
    Overload List


DicomObjects Namespace / DicomImage Class / RenderToArray Method / RenderToArray(Array,Boolean,Int32,Int32) Method

Array to write the image presentation data to

Set Colour to True if you want the color output.

Bit depth of final data.

Choose which frame of a Multi-Frame Image you want to render.

In This Topic
    RenderToArray(Array,Boolean,Int32,Int32) Method
    In This Topic
    Render the DicomImage to array. The data returned will be exactly the same as the "presentation data" if the Image gets displayed on screen.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub RenderToArray( _
   ByVal destination As Array, _
   ByVal Colour As Boolean, _
   ByVal BitsPerSample As Integer, _
   ByVal frame As Integer _
)
    'Usage

    Dim instance As DicomImage
Dim destination As Array
Dim Colour As Boolean
Dim BitsPerSample As Integer
Dim frame As Integer

instance.RenderToArray(destination, Colour, BitsPerSample, frame)
    public void RenderToArray(
   Array destination,
   bool Colour,
   int BitsPerSample,
   int frame
)

    Parameters

    destination

    Array to write the image presentation data to

    Colour

    Set Colour to True if you want the color output.

    BitsPerSample

    Bit depth of final data.

    frame

    Choose which frame of a Multi-Frame Image you want to render.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members
    Overload List


DicomObjects Namespace / DicomImage Class / Send Method

    Send Method (DicomImage)
    In This Topic
    Sends an image to a remote Storage SCP
    Overload List
    Overload | Description
Send(String,Int32,String,String) | Sends an image to a remote Storage SCP
Send(String,Int32,String,String,IEnumerable<String>) | Sends an image to a remote Storage SCP
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / Send Method / Send(String,Int32,String,String) Method

Network address (as dotted notation or resolvable name) to which the image is to be sent

Port on which remote application is listening

Name of remote Application Entity

Name to quote for this Application Entity

In This Topic
    Send(String,Int32,String,String) Method
    In This Topic
    Sends an image to a remote Storage SCP
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Function Send( _
   ByVal Node As String, _
   ByVal Port As Integer, _
   ByVal CallingAE As String, _
   ByVal CalledAE As String _
) As Integer
    'Usage

    Dim instance As DicomImage
Dim Node As String
Dim Port As Integer
Dim CallingAE As String
Dim CalledAE As String
Dim value As Integer

value = instance.Send(Node, Port, CallingAE, CalledAE)
    public int Send(
   string Node,
   int Port,
   string CallingAE,
   string CalledAE
)

    Parameters

    Node

    Network address (as dotted notation or resolvable name) to which the image is to be sent

    Port

    Port on which remote application is listening

    CallingAE

    Name of remote Application Entity

    CalledAE

    Name to quote for this Application Entity

    Return Value

    The status as returned by the remote application. Zero indicates success.

    Remarks
    This method negotiates an association, sends one image over it, and then closes it. DICOM does not allow SCPs to draw any conclusions about the relationships between images based on the opening and closing of associations, so this should never be a problem (apart from slight network inefficiency). However, there are several badly written applications in the world, which incorrectly assume that the end of an association indicates the end of a series or a study etc., and if interfacing to such a faulty implementation, it is possible to send multiple images on one association by using a DicomAssociation object, and its SendInstances methods.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members
    Overload List


DicomObjects Namespace / DicomImage Class / Send Method / Send(String,Int32,String,String,IEnumerable<String>) Method

Network address (as dotted notation or resolvable name) to which the image is to be sent

Port on which remote application is listening

Name of remote Application Entity

Name to quote for this Application Entity

A list of offered Transfer Syntaxes

In This Topic
    Send(String,Int32,String,String,IEnumerable<String>) Method
    In This Topic
    Sends an image to a remote Storage SCP
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Function Send( _
   ByVal Node As String, _
   ByVal Port As Integer, _
   ByVal CallingAE As String, _
   ByVal CalledAE As String, _
   ByVal OfferedTS As IEnumerable(Of String) _
) As Integer
    'Usage

    Dim instance As DicomImage
Dim Node As String
Dim Port As Integer
Dim CallingAE As String
Dim CalledAE As String
Dim OfferedTS As IEnumerable(Of String)
Dim value As Integer

value = instance.Send(Node, Port, CallingAE, CalledAE, OfferedTS)
    public int Send(
   string Node,
   int Port,
   string CallingAE,
   string CalledAE,
   IEnumerable<string> OfferedTS
)

    Parameters

    Node

    Network address (as dotted notation or resolvable name) to which the image is to be sent

    Port

    Port on which remote application is listening

    CallingAE

    Name of remote Application Entity

    CalledAE

    Name to quote for this Application Entity

    OfferedTS

    A list of offered Transfer Syntaxes

    Return Value

    The status as returned by the remote application. Zero indicates success.

    Remarks
    This method negotiates an association, sends one image over it, and then closes it. DICOM does not allow SCPs to draw any conclusions about the relationships between images based on the opening and closing of associations, so this should never be a problem (apart from slight network inefficiency). However, there are several badly written applications in the world, which incorrectly assume that the end of an association indicates the end of a series or a study etc., and if interfacing to such a faulty implementation, it is possible to send multiple images on one association by using a DicomAssociation object, and its SendInstances methods.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members
    Overload List


DicomObjects Namespace / DicomImage Class / SetColourTable Method
List of SkiaSharp.SKColor values

    SetColourTable Method
    In This Topic
    The colour lookup table of DicomImage
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Sub SetColourTable( _
   ByVal value As IList(Of SKColor) _
)
    'Usage

    Dim instance As DicomImage
Dim value As IList(Of SKColor)

instance.SetColourTable(value)
    public void SetColourTable(
   IList<SKColor> value
)

    Parameters

    value
    List of SkiaSharp.SKColor values
    Remarks
    This property enables developers to define and apply their own color table to Images.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / SetDefaultWindows() Method

    SetDefaultWindows() Method
    Recalculates the default windows used by DicomObjects as if the image had just been loaded
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Sub SetDefaultWindows()
    'Usage

    Dim instance As DicomImage

instance.SetDefaultWindows()
    public void SetDefaultWindows()
    Remarks
    Where possible, DicomObjects sets the initial values of Width and Level using attributes (0028,1050) & (0028,1051) in the file itself, but where these are not present, it calculates the values by measuring the range of pixel values. The values may of course be subsequently changed, and this method is therefore useful either to reset to initial values, or to calculate suitable "guess" values when new images are created, or when the pixel data itself is changed.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / SetMaskRanges Method

    SetMaskRanges Method

    Contains an array of DicomMaskRange objects to be applied to this image.

    See the DicomMaskRange object for more information on how this is used.

    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Sub SetMaskRanges( _
   ByVal value() As DicomMaskRange _
)
    'Usage

    Dim instance As DicomImage
Dim value() As DicomMaskRange

instance.SetMaskRanges(value)
    public void SetMaskRanges(
   DicomMaskRange[] value
)

    Parameters

    value
    Remarks
    If this property is changed, then the internal caches are cleared automatically, but if you change individual elements of the array without chaning the array itself, then it is necessary to call ClearCaches explicitly.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / SetPixelData Method
The transfer syntax of the data provided via the GetData function
User defined function to return the correct pixel data stream for the requested frame number

In This Topic
    SetPixelData Method
    In This Topic
    Method to set pixel data directly from a stream
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Sub SetPixelData( _
   ByVal TransferSyntax As String, _
   ByVal GetData As Func(Of Integer,Stream) _
)
    'Usage

    Dim instance As DicomImage
Dim TransferSyntax As String
Dim GetData As Func(Of Integer,Stream)

instance.SetPixelData(TransferSyntax, GetData)
    public void SetPixelData(
   string TransferSyntax,
   Func<int,Stream> GetData
)

    Parameters

    TransferSyntax
    The transfer syntax of the data provided via the GetData function
    GetData
    User defined function to return the correct pixel data stream for the requested frame number
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / SetPixelDataAndImport Method
The transfer syntax of the data provided via the GetData function
Number of frames that would get imported
User defined function to return the correct data stream to be imported

In This Topic
    SetPixelDataAndImport Method
    In This Topic
    Method to import pixel data directly from a non-DICOM data
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Sub SetPixelDataAndImport( _
   ByVal TransferSyntax As String, _
   ByVal FrameCount As Integer, _
   ByVal GetData As Func(Of Integer,Stream) _
)
    'Usage

    Dim instance As DicomImage
Dim TransferSyntax As String
Dim FrameCount As Integer
Dim GetData As Func(Of Integer,Stream)

instance.SetPixelDataAndImport(TransferSyntax, FrameCount, GetData)
    public void SetPixelDataAndImport(
   string TransferSyntax,
   int FrameCount,
   Func<int,Stream> GetData
)

    Parameters

    TransferSyntax
    The transfer syntax of the data provided via the GetData function
    FrameCount
    Number of frames that would get imported
    GetData
    User defined function to return the correct data stream to be imported
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / SetPixelFile Method

The name of the external file

Transfer Syntax of the Pixel Data

The offset in the file of the start of the first frame

The offset in the file between the start of one frame, and the start of the next

In This Topic
    SetPixelFile Method (DicomImage)
    In This Topic
    Maps an external file as the pixel data
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Sub SetPixelFile( _
   ByVal FileName As String, _
   ByVal TransferSyntax As String, _
   ByVal InitialOffset As Long, _
   ByVal FrameOffset As Long _
)
    'Usage

    Dim instance As DicomImage
Dim FileName As String
Dim TransferSyntax As String
Dim InitialOffset As Long
Dim FrameOffset As Long

instance.SetPixelFile(FileName, TransferSyntax, InitialOffset, FrameOffset)
    public void SetPixelFile(
   string FileName,
   string TransferSyntax,
   long InitialOffset,
   long FrameOffset
)

    Parameters

    FileName

    The name of the external file

    TransferSyntax

    Transfer Syntax of the Pixel Data

    InitialOffset

    The offset in the file of the start of the first frame

    FrameOffset

    The offset in the file between the start of one frame, and the start of the next

    Remarks
    The PixelData attribute (7FE0, 0010) is set after calling this method and Pixel data is read from the specified external file only when image rendering is about to happen.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / SetSimpleMasking Method

    SetSimpleMasking Method
    Sets the frame number of the mask frame for subtraction.
    Overload List
    Overload | Description
SetSimpleMasking(Int32[],MaskMode) | Sets an int array as frame numbers of the mask frames for subtraction
SetSimpleMasking(Int32,MaskMode) | Sets the frame number of the mask frame for subtraction.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / SetSimpleMasking Method / SetSimpleMasking(Int32[],MaskMode) Method

Frame numbers of the frames for subtraction

The subtraction mode to use

In This Topic
    SetSimpleMasking(Int32[],MaskMode) Method
    In This Topic
    Sets an int array as frame numbers of the mask frames for subtraction
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub SetSimpleMasking( _
   ByVal Frames() As Integer, _
   ByVal mode As MaskMode _
)
    'Usage

    Dim instance As DicomImage
Dim Frames() As Integer
Dim mode As MaskMode

instance.SetSimpleMasking(Frames, mode)
    public void SetSimpleMasking(
   int[] Frames,
   MaskMode mode
)

    Parameters

    Frames

    Frame numbers of the frames for subtraction

    mode
    The subtraction mode to use
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members
    Overload List


DicomObjects Namespace / DicomImage Class / SetSimpleMasking Method / SetSimpleMasking(Int32,MaskMode) Method

Frame number of the frame for subtraction

The subtraction mode to use

In This Topic
    SetSimpleMasking(Int32,MaskMode) Method
    In This Topic
    Sets the frame number of the mask frame for subtraction.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub SetSimpleMasking( _
   ByVal Frame As Integer, _
   ByVal mode As MaskMode _
)
    'Usage

    Dim instance As DicomImage
Dim Frame As Integer
Dim mode As MaskMode

instance.SetSimpleMasking(Frame, mode)
    public void SetSimpleMasking(
   int Frame,
   MaskMode mode
)

    Parameters

    Frame

    Frame number of the frame for subtraction

    mode
    The subtraction mode to use
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members
    Overload List


DicomObjects Namespace / DicomImage Class / Spacing Method

    Spacing Method
    Get the pixel spacing of the DicomImage
    Overload List
    Overload | Description
Spacing() | The pixel spacing of the DicomImage
Spacing(SKRectI) | This method returns the Pixel Spacing within the region specified by Area
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / Spacing Method / Spacing() Method

    Spacing() Method
    The pixel spacing of the DicomImage
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Function Spacing() As SkiaSharp.SKSize
    'Usage

    Dim instance As DicomImage
Dim value As SkiaSharp.SKSize

value = instance.Spacing()
    public SkiaSharp.SKSize Spacing()

    Return Value

    The pixel spacing of the image
    Remarks
    The pixel size in mm.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members
    Overload List


DicomObjects Namespace / DicomImage Class / Spacing Method / Spacing(SKRectI) Method
The Area for which the spacing should be calculated

    Spacing(SKRectI) Method
    In This Topic
    This method returns the Pixel Spacing within the region specified by Area
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Function Spacing( _
   ByVal Area As SkiaSharp.SKRectI _
) As SkiaSharp.SKSize
    'Usage

    Dim instance As DicomImage
Dim Area As SkiaSharp.SKRectI
Dim value As SkiaSharp.SKSize

value = instance.Spacing(Area)
    public SkiaSharp.SKSize Spacing(
   SkiaSharp.SKRectI Area
)

    Parameters

    Area
    The Area for which the spacing should be calculated

    Return Value

    The pixel spacing of the requested area
    Remarks
    This method returns the Pixel Spacing within a Region of the DicomImage. Note, one Image may have multiple regions with different pixel spacing values, so this method may return different values for different inputs.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members
    Overload List


DicomObjects Namespace / DicomImage Class / SubImage Method

    SubImage Method (DicomImage)
    In This Topic
    Creates a copy of part or all of the image
    Overload List
    Overload | Description
SubImage(SKPointI,SKSizeI,Single,Int32) | Creates a copy of part or all of the image with controlled size
SubImage(SKPointI,SKSizeI,Single,Int32,ScaleMode) | Creates a copy of part or all of the image with controlled size
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / SubImage Method / SubImage(SKPointI,SKSizeI,Single,Int32) Method

The left top corner point of the sub Image

The total size of the original image to capture

The zooming factor which determines the output size

The frame number to use. This is 1-index, i.e. first frame is 1 not 0

In This Topic
    SubImage(SKPointI,SKSizeI,Single,Int32) Method
    In This Topic
    Creates a copy of part or all of the image with controlled size
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Function SubImage( _
   ByVal Offset As SkiaSharp.SKPointI, _
   ByVal size As SkiaSharp.SKSizeI, _
   ByVal magnification As Single, _
   ByVal frame As Integer _
) As DicomImage
    'Usage

    Dim instance As DicomImage
Dim Offset As SkiaSharp.SKPointI
Dim size As SkiaSharp.SKSizeI
Dim magnification As Single
Dim frame As Integer
Dim value As DicomImage

value = instance.SubImage(Offset, size, magnification, frame)
    public DicomImage SubImage(
   SkiaSharp.SKPointI Offset,
   SkiaSharp.SKSizeI size,
   float magnification,
   int frame
)

    Parameters

    Offset

    The left top corner point of the sub Image

    size

    The total size of the original image to capture

    magnification

    The zooming factor which determines the output size

    frame

    The frame number to use. This is 1-index, i.e. first frame is 1 not 0

    Return Value

    A new DicomImage
    Remarks
    Makes a derived image (of same basic DICOM type as the original) scaled and cropped as required. Unlike PrinterImage, the pixel data is not modified or scaled, and XSize and YSize refer to the final image size, not the input (useful for making fixed size thumbnails etc.) If the original image is flipped and/or rotated, then the SubImage will be similarly modified, and the coordinates used for the offsets and sizes apply in the rotated/flipped coordinate space. This makes it simple to select sub-images using a GUI, as the coordinates used for SubImage are compatible with those used for an "ImageTied" DicomLabel.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members
    Overload List


DicomObjects Namespace / DicomImage Class / SubImage Method / SubImage(SKPointI,SKSizeI,Single,Int32,ScaleMode) Method

The left top corner point of the sub Image

The total size of the original image to capture

The zooming factor which determines the output size

The frame number to use. This is 1-index, i.e. first frame is 1 not 0

The scaling mode to use

In This Topic
    SubImage(SKPointI,SKSizeI,Single,Int32,ScaleMode) Method
    In This Topic
    Creates a copy of part or all of the image with controlled size
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Overridable Function SubImage( _
   ByVal offset As SkiaSharp.SKPointI, _
   ByVal size As SkiaSharp.SKSizeI, _
   ByVal magnification As Single, _
   ByVal frame As Integer, _
   ByVal scaleMode As ScaleMode _
) As DicomImage
    'Usage

    Dim instance As DicomImage
Dim offset As SkiaSharp.SKPointI
Dim size As SkiaSharp.SKSizeI
Dim magnification As Single
Dim frame As Integer
Dim scaleMode As ScaleMode
Dim value As DicomImage

value = instance.SubImage(offset, size, magnification, frame, scaleMode)
    public virtual DicomImage SubImage(
   SkiaSharp.SKPointI offset,
   SkiaSharp.SKSizeI size,
   float magnification,
   int frame,
   ScaleMode scaleMode
)

    Parameters

    offset

    The left top corner point of the sub Image

    size

    The total size of the original image to capture

    magnification

    The zooming factor which determines the output size

    frame

    The frame number to use. This is 1-index, i.e. first frame is 1 not 0

    scaleMode

    The scaling mode to use

    Return Value

    A new DicomImage
    Remarks

    Makes a derived image (of same basic DICOM type as the original) scaled and cropped as required. SKSizeI refers to the final image size, whether or not it is transformed as below.

    The coordinate system used depends on the value of scaling. If ScaleMode.Image then the original image is used without rotation etc, but if ScaleMode.Output then the image is conceptually flipped, rotated etc. before applying the bounds.

    This overload is now recommended in place of the earlier version without the scaling mode which is retained for backwards compatibility only.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members
    Overload List


DicomObjects Namespace / DicomImage Class / Update() Method

    Update() Method
    Causes the image to be updated
    Causes the image to be updated
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Sub Update()
    'Usage

    Dim instance As DicomImage

instance.Update()
    public void Update()
    Remarks
    Forces a refresh to re-draw the image onto screen.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / Write Method

    Write Method (DicomImage)
    In This Topic
    Write the data to a file, Stream or Byte Array
    Overload List
    Overload | Description
Write(String,String,Object) | Write the data to a file with specified transfer syntax and quality
Write(String,Boolean) | Write the image data to a file
Write(String,String) | Write the image data to a file with specified transfer syntax
Write(String) | Writes dataset to an external DICOM file in the current TransferSyntax
Write(Stream,String,Object) | Write the image data to a stream with specified transfer syntax and quality
Write(Stream,Boolean) | Write the image data to a stream
Write(Stream,String) | Write the data to a stream with specified transfer syntax
Write(Stream) | Write the data to a stream
Write(Byte[],String,Object) | Write the data to a Byte Array with specified transfer syntax and quality
Write(Byte[],Boolean) | Write the data to a Byte Array
Write(Byte[],String) | Write the image data to a Byte Array with specified transfer syntax
Write(Byte[]) | Write the image data to a Byte Array
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / Write Method / Write(String,String,Object) Method

The name of the file to write.

This is passed unmodified to the operating system, and it is therefore the container�s responsibility to ensure either that the current directory is set correctly, or that a fully qualified filename is provided.

Specifies the full UID of the transfer syntax with which the file is to be saved when Part 10 format is used. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see the entry.

The quality factor to be used. This is a generic compression quality depending on the Transfer Syntax used. This value for JPEG Baseline and JPEG Extended compression represents an integer between 0 – 100. This tells DicomObjects to set up the compressor to try to achieve the quality in percentage (higher quality value towards 100 means better quality and lower compression ratio). And for JPEG-LS Lossy and JPEG2000 Lossy compression this value is actually the desired compression ratio, i.e. if you set the quality value to 10, it tells DicomObjects to try to achieve compression ratio of 10. The actual compression ratio achieved will not be exactly the same as specified by quality value but close enough. The actual compression ratio is calculated based on the original data size and the compressed data size before it is added to “Lossy Image Compression Ratio” tag of the image. For Video compression, this value directly corresponds to the BitsPerSecond of the compressed video.

In This Topic
    Write(String,String,Object) Method
    In This Topic
    Write the data to a file with specified transfer syntax and quality
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub Write( _
   ByVal FileName As String, _
   ByVal TransferSyntax As String, _
   ByVal Quality As Object _
)
    'Usage

    Dim instance As DicomImage
Dim FileName As String
Dim TransferSyntax As String
Dim Quality As Object

instance.Write(FileName, TransferSyntax, Quality)
    public void Write(
   string FileName,
   string TransferSyntax,
   object Quality
)

    Parameters

    FileName

    The name of the file to write.

    This is passed unmodified to the operating system, and it is therefore the container�s responsibility to ensure either that the current directory is set correctly, or that a fully qualified filename is provided.

    TransferSyntax

    Specifies the full UID of the transfer syntax with which the file is to be saved when Part 10 format is used. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see the entry.

    Quality

    The quality factor to be used. This is a generic compression quality depending on the Transfer Syntax used. This value for JPEG Baseline and JPEG Extended compression represents an integer between 0 – 100. This tells DicomObjects to set up the compressor to try to achieve the quality in percentage (higher quality value towards 100 means better quality and lower compression ratio). And for JPEG-LS Lossy and JPEG2000 Lossy compression this value is actually the desired compression ratio, i.e. if you set the quality value to 10, it tells DicomObjects to try to achieve compression ratio of 10. The actual compression ratio achieved will not be exactly the same as specified by quality value but close enough. The actual compression ratio is calculated based on the original data size and the compressed data size before it is added to “Lossy Image Compression Ratio” tag of the image. For Video compression, this value directly corresponds to the BitsPerSecond of the compressed video.

    Remarks

    The file may subsequently be read by one of the Read method overloads or by other DICOM software.

    Quality is specific to the compression method being used, and is ignored for non-compressed or lossless JPEG transfer syntaxes. For Lossy JPEG, it is an integer in the range 1-100, the higher the number, the better the quality (and the larger the file), and for JPEG 2000 lossy, it is a compression ratio. Other compression methods may use this for other purposes in the future.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members
    Overload List


DicomObjects Namespace / DicomImage Class / Write Method / Write(String,Boolean) Method

The name of the file to write.

This is passed unmodified to the operating system, and it is therefore the container�s responsibility to ensure either that the current directory is set correctly, or that a fully qualified filename is provided.

If TRUE, a blank 128 byte header, DICM marker, and meta-header are written at the start of the file, and an appropriate transfer syntax is used, as below.

If FALSE, the file is written in the unofficial, but common format, with no header, and using the little-endian implicit VR transfer syntax.

In This Topic
    Write(String,Boolean) Method
    In This Topic
    Write the image data to a file
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub Write( _
   ByVal FileName As String, _
   ByVal isPart10 As Boolean _
)
    'Usage

    Dim instance As DicomImage
Dim FileName As String
Dim isPart10 As Boolean

instance.Write(FileName, isPart10)
    public void Write(
   string FileName,
   bool isPart10
)

    Parameters

    FileName

    The name of the file to write.

    This is passed unmodified to the operating system, and it is therefore the container�s responsibility to ensure either that the current directory is set correctly, or that a fully qualified filename is provided.

    isPart10

    If TRUE, a blank 128 byte header, DICM marker, and meta-header are written at the start of the file, and an appropriate transfer syntax is used, as below.

    If FALSE, the file is written in the unofficial, but common format, with no header, and using the little-endian implicit VR transfer syntax.

    Remarks

    The file may subsequently be read by one of the Read method overloads or by other DICOM software.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members
    Overload List


DicomObjects Namespace / DicomImage Class / Write Method / Write(String,String) Method

The name of the file to write.

This is passed unmodified to the operating system, and it is therefore the container�s responsibility to ensure either that the current directory is set correctly, or that a fully qualified filename is provided.

Specifies the full UID of the transfer syntax with which the file is to be saved when Part 10 format is used. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see the entry.

In This Topic
    Write(String,String) Method
    In This Topic
    Write the image data to a file with specified transfer syntax
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub Write( _
   ByVal FileName As String, _
   ByVal TransferSyntax As String _
)
    'Usage

    Dim instance As DicomImage
Dim FileName As String
Dim TransferSyntax As String

instance.Write(FileName, TransferSyntax)
    public void Write(
   string FileName,
   string TransferSyntax
)

    Parameters

    FileName

    The name of the file to write.

    This is passed unmodified to the operating system, and it is therefore the container�s responsibility to ensure either that the current directory is set correctly, or that a fully qualified filename is provided.

    TransferSyntax

    Specifies the full UID of the transfer syntax with which the file is to be saved when Part 10 format is used. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see the entry.

    Remarks

    The file may subsequently be read by one of the Read method overloads method or by other DICOM software.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members
    Overload List


DicomObjects Namespace / DicomImage Class / Write Method / Write(String) Method

The name of the file to write.

This is passed unmodified to the operating system, and it is therefore the container�s responsibility to ensure either that the current directory is set correctly, or that a fully qualified filename is provided.

In This Topic
    Write(String) Method
    In This Topic
    Writes dataset to an external DICOM file in the current TransferSyntax
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub Write( _
   ByVal fileName As String _
)
    'Usage

    Dim instance As DicomImage
Dim fileName As String

instance.Write(fileName)
    public void Write(
   string fileName
)

    Parameters

    fileName

    The name of the file to write.

    This is passed unmodified to the operating system, and it is therefore the container�s responsibility to ensure either that the current directory is set correctly, or that a fully qualified filename is provided.

    Remarks

    The file may subsequently be read by one of the Read method overloads or by other DICOM software.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members
    Overload List


DicomObjects Namespace / DicomImage Class / Write Method / Write(Stream,String,Object) Method

The Stream from which to read.

Specifies the full UID of the transfer syntax with which the file is to be saved when Part 10 format is used. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see the entry.

The quality factor to be used. This is a generic compression quality depending on the Transfer Syntax used. This value for JPEG Baseline and JPEG Extended compression represents an integer between 0 – 100. This tells DicomObjects to set up the compressor to try to achieve the quality in percentage (higher quality value towards 100 means better quality and lower compression ratio). And for JPEG-LS Lossy and JPEG2000 Lossy compression this value is actually the desired compression ratio, i.e. if you set the quality value to 10, it tells DicomObjects to try to achieve compression ratio of 10. The actual compression ratio achieved will not be exactly the same as specified by quality value but close enough. The actual compression ratio is calculated based on the original data size and the compressed data size before it is added to “Lossy Image Compression Ratio” tag of the image. For Video compression, this value directly corresponds to the BitsPerSecond of the compressed video.

In This Topic
    Write(Stream,String,Object) Method
    In This Topic
    Write the image data to a stream with specified transfer syntax and quality
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub Write( _
   ByVal Stream As Stream, _
   ByVal TransferSyntax As String, _
   ByVal Quality As Object _
)
    'Usage

    Dim instance As DicomImage
Dim Stream As Stream
Dim TransferSyntax As String
Dim Quality As Object

instance.Write(Stream, TransferSyntax, Quality)
    public void Write(
   Stream Stream,
   string TransferSyntax,
   object Quality
)

    Parameters

    Stream

    The Stream from which to read.

    TransferSyntax

    Specifies the full UID of the transfer syntax with which the file is to be saved when Part 10 format is used. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see the entry.

    Quality

    The quality factor to be used. This is a generic compression quality depending on the Transfer Syntax used. This value for JPEG Baseline and JPEG Extended compression represents an integer between 0 – 100. This tells DicomObjects to set up the compressor to try to achieve the quality in percentage (higher quality value towards 100 means better quality and lower compression ratio). And for JPEG-LS Lossy and JPEG2000 Lossy compression this value is actually the desired compression ratio, i.e. if you set the quality value to 10, it tells DicomObjects to try to achieve compression ratio of 10. The actual compression ratio achieved will not be exactly the same as specified by quality value but close enough. The actual compression ratio is calculated based on the original data size and the compressed data size before it is added to “Lossy Image Compression Ratio” tag of the image. For Video compression, this value directly corresponds to the BitsPerSecond of the compressed video.

    Remarks

    The stream object may subsequently be read by one of the Read method overloads or by other DICOM software.

    Quality is specific to the compression method being used, and is ignored for non-compressed or lossless JPEG transfer syntaxes. For Lossy JPEG, it is an integer in the range 1-100, the higher the number, the better the quality (and the larger the file) , and for JPEG 2000 lossy, it is a compression ratio. Other compression methods may use this for other purposes in the future.

    This method is particularly suitable for use with Delphi, which provides access to streams via classes such as TStreamAdapter.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members
    Overload List


DicomObjects Namespace / DicomImage Class / Write Method / Write(Stream,Boolean) Method

The Stream from which to read.

If TRUE, a blank 128 byte header, DICM marker, and meta-header are written at the start of the stream, and an appropriate transfer syntax is used, as below.

If FALSE, the stream is written in the unofficial, but common format, with no header, and using the little-endian implicit VR transfer syntax.

In This Topic
    Write(Stream,Boolean) Method
    In This Topic
    Write the image data to a stream
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub Write( _
   ByVal Stream As Stream, _
   ByVal isPart10 As Boolean _
)
    'Usage

    Dim instance As DicomImage
Dim Stream As Stream
Dim isPart10 As Boolean

instance.Write(Stream, isPart10)
    public void Write(
   Stream Stream,
   bool isPart10
)

    Parameters

    Stream

    The Stream from which to read.

    isPart10

    If TRUE, a blank 128 byte header, DICM marker, and meta-header are written at the start of the stream, and an appropriate transfer syntax is used, as below.

    If FALSE, the stream is written in the unofficial, but common format, with no header, and using the little-endian implicit VR transfer syntax.

    Remarks
    The stream object may subsequently be read by one of the Read method overloads or by other DICOM software.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members
    Overload List


DicomObjects Namespace / DicomImage Class / Write Method / Write(Stream,String) Method

The Stream from which to read.

Specifies the full UID of the transfer syntax with which the data is to be saved when Part 10 format is used. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see .

In This Topic
    Write(Stream,String) Method
    In This Topic
    Write the data to a stream with specified transfer syntax
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub Write( _
   ByVal Stream As Stream, _
   ByVal TransferSyntax As String _
)
    'Usage

    Dim instance As DicomImage
Dim Stream As Stream
Dim TransferSyntax As String

instance.Write(Stream, TransferSyntax)
    public void Write(
   Stream Stream,
   string TransferSyntax
)

    Parameters

    Stream

    The Stream from which to read.

    TransferSyntax

    Specifies the full UID of the transfer syntax with which the data is to be saved when Part 10 format is used. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see .

    Remarks
    The stream object may subsequently be read by one of the Read method overloads or by other DICOM software.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members
    Overload List


DicomObjects Namespace / DicomImage Class / Write Method / Write(Stream) Method

The Stream from which to read.

In This Topic
    Write(Stream) Method
    In This Topic
    Write the data to a stream
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub Write( _
   ByVal Stream As Stream _
)
    'Usage

    Dim instance As DicomImage
Dim Stream As Stream

instance.Write(Stream)
    public void Write(
   Stream Stream
)

    Parameters

    Stream

    The Stream from which to read.

    Remarks
    The stream object may subsequently be read by one of the Read method overloads or by other DICOM software.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members
    Overload List


DicomObjects Namespace / DicomImage Class / Write Method / Write(Byte[],String,Object) Method

Byte Array to write image data to

Specifies the full UID of the transfer syntax with which the data is to be saved when Part 10 format is used. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see .

The quality factor to be used. This is a generic compression quality depending on the Transfer Syntax used. This value for JPEG Baseline and JPEG Extended compression represents an integer between 0 – 100. This tells DicomObjects to set up the compressor to try to achieve the quality in percentage (higher quality value towards 100 means better quality and lower compression ratio). And for JPEG-LS Lossy and JPEG2000 Lossy compression this value is actually the desired compression ratio, i.e. if you set the quality value to 10, it tells DicomObjects to try to achieve compression ratio of 10. The actual compression ratio achieved will not be exactly the same as specified by quality value but close enough. The actual compression ratio is calculated based on the original data size and the compressed data size before it is added to “Lossy Image Compression Ratio” tag of the image. For Video compression, this value directly corresponds to the BitsPerSecond of the compressed video.

In This Topic
    Write(Byte[],String,Object) Method
    In This Topic
    Write the data to a Byte Array with specified transfer syntax and quality
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub Write( _
   ByRef Array() As Byte, _
   ByVal TransferSyntax As String, _
   ByVal Quality As Object _
)
    'Usage

    Dim instance As DicomImage
Dim Array() As Byte
Dim TransferSyntax As String
Dim Quality As Object

instance.Write(Array, TransferSyntax, Quality)
    public void Write(
   out byte[] Array,
   string TransferSyntax,
   object Quality
)

    Parameters

    Array

    Byte Array to write image data to

    TransferSyntax

    Specifies the full UID of the transfer syntax with which the data is to be saved when Part 10 format is used. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see .

    Quality

    The quality factor to be used. This is a generic compression quality depending on the Transfer Syntax used. This value for JPEG Baseline and JPEG Extended compression represents an integer between 0 – 100. This tells DicomObjects to set up the compressor to try to achieve the quality in percentage (higher quality value towards 100 means better quality and lower compression ratio). And for JPEG-LS Lossy and JPEG2000 Lossy compression this value is actually the desired compression ratio, i.e. if you set the quality value to 10, it tells DicomObjects to try to achieve compression ratio of 10. The actual compression ratio achieved will not be exactly the same as specified by quality value but close enough. The actual compression ratio is calculated based on the original data size and the compressed data size before it is added to “Lossy Image Compression Ratio” tag of the image. For Video compression, this value directly corresponds to the BitsPerSecond of the compressed video.

    Remarks

    Quality is specific to the compression method being used, and is ignored for non-compressed or lossless JPEG transfer syntaxes. For Lossy JPEG, it is an integer in the range 1-100, the higher the number, the better the quality (and the larger the file) , and for JPEG 2000 lossy, it is a compression ratio. Other compression methods may use this for other purposes in the future.

    Data may be read back by the corresponding Read method.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members
    Overload List


DicomObjects Namespace / DicomImage Class / Write Method / Write(Byte[],Boolean) Method

Byte Array to write image data to

If TRUE, a blank 128 byte header, DICM marker, and meta-header are written at the start of the file, and an appropriate transfer syntax is used, as below.

If FALSE, the file is written in the unofficial, but common format, with no header, and using the little-endian implicit VR transfer syntax.

In This Topic
    Write(Byte[],Boolean) Method
    In This Topic
    Write the data to a Byte Array
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub Write( _
   ByRef Array() As Byte, _
   ByVal isPart10 As Boolean _
)
    'Usage

    Dim instance As DicomImage
Dim Array() As Byte
Dim isPart10 As Boolean

instance.Write(Array, isPart10)
    public void Write(
   out byte[] Array,
   bool isPart10
)

    Parameters

    Array

    Byte Array to write image data to

    isPart10

    If TRUE, a blank 128 byte header, DICM marker, and meta-header are written at the start of the file, and an appropriate transfer syntax is used, as below.

    If FALSE, the file is written in the unofficial, but common format, with no header, and using the little-endian implicit VR transfer syntax.

    Remarks
    Data may be read back by the corresponding Read method.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members
    Overload List


DicomObjects Namespace / DicomImage Class / Write Method / Write(Byte[],String) Method

Byte Array to write image data to

Specifies the full UID of the transfer syntax with which the data is to be saved when Part 10 format is used. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see the page

In This Topic
    Write(Byte[],String) Method
    In This Topic
    Write the image data to a Byte Array with specified transfer syntax
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub Write( _
   ByRef Array() As Byte, _
   ByVal TransferSyntax As String _
)
    'Usage

    Dim instance As DicomImage
Dim Array() As Byte
Dim TransferSyntax As String

instance.Write(Array, TransferSyntax)
    public void Write(
   out byte[] Array,
   string TransferSyntax
)

    Parameters

    Array

    Byte Array to write image data to

    TransferSyntax

    Specifies the full UID of the transfer syntax with which the data is to be saved when Part 10 format is used. If omitted, the little-endian explicit VR transfer syntax is used. For details of the currently supported syntaxes, see the page

    Remarks
    Data may be read back by the corresponding Read method.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members
    Overload List


DicomObjects Namespace / DicomImage Class / Write Method / Write(Byte[]) Method

Byte Array to write image data to

    Write(Byte[]) Method
    In This Topic
    Write the image data to a Byte Array
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub Write( _
   ByRef Array() As Byte _
)
    'Usage

    Dim instance As DicomImage
Dim Array() As Byte

instance.Write(Array)
    public void Write(
   out byte[] Array
)

    Parameters

    Array

    Byte Array to write image data to

    Remarks
    Data may be read back by the corresponding Read method.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members
    Overload List


%%PageItemTitle%% $$Properties$$

DicomObjects Namespace / DicomImage Class

    DicomImage Class Properties
    In This Topic

    For a list of all members of this type, see DicomImage members.

    Public Properties
     | Name | Description
Public Property | AccessionNumber | The Accession Number
Public Property | Angle | Controls the rotation of an image
Public Property | Area | The display area of DicomImage
Public Property | BorderPaint | The Paint object for Image border
Public Property | CacheMode | Controls how the pixel data is cached
Public Property | CaptureBackColour | User defined background colour for image output of PrinterImage, SKBitmap and SubImage methods Default is Black background
Public Property | CineFramesToDisplay | The set of frames to display for cine modes
Public Property | CineIndex | The index of the currently displayed frame when using CineMode
Public Property | CineSmoothing | Boolean property indicating whether Smoothing is applied when Cine is being displayed.
Public Property | ColourTable | The colour lookup table of DicomImage
Public Property | CubicSplineAlpha | Parameter to control the degree of smoothing. The default value is �0.75, and normal values range from �0.5 to �1.25, though higher negative values may be used to produce deliberate edge enhancement.
Public Property | DataSet | The underlying DICOM Dataset containing persistent data for the image
Public Property | DateOfBirth | Date of birth of the patient
static (Shared in Visual Basic) | DefaultModalityLUT | Default value for the ModalityLUT property
static (Shared in Visual Basic) | DefaultPresentationLUT | Default value for the PresentationLUT property
static (Shared in Visual Basic) | DefaultRealTimeCine | Controls the default for how cine images are displayed
static (Shared in Visual Basic) | DefaultVoiLUT | Default value for the VoiLUT property
Public Property | DisplayMode | Controls how the image is rendered internal before transfer to the screen
Public Property | DrawCacheMode | Specify the DrawCacheMode to control how image is drawn/cached
Public Property | ExplicitModalityLUT | An explicit modality Lookup Table to be used in place of one specified in the image or presentaiton state.
Public Property | ExplicitPresentationLUT | An explicit presentation Lookup Table to be used in place of one specified in the image or presentaiton state.
Public Property | ExplicitVOILUT | An explicit Values of Interest (VOI) Lookup Table to be used in place of one specified in the image or presentaiton state.
Public Property | FilterLength | Contains the length of the smoothing filter
Public Property | FlipState | The flip state of the image, allowing the orientation of the image, as displayed, to be altered
Public Property | Frame | Controls which frame of a multi-frame image is displayed
Public Property | FrameCount | The number of frames contained in a multi-frame image
Public Property | Gamma | A number that specifies a power
Public Property | InstanceUID | Unique identifier for the four levels of the DICOM Query/Retrieve hierarchy
Public Property | Invert | Controls whether the Image will be inverted.
Public Property | Item | Overloaded. Provides access to all attributes of the image
Public Property | Labels | Provides access to the DicomLabelCollection, items of which are to be displayed over an image.
Public Property | Level | The Window Level (also known as the centre) - which controls the greyscale mapping of a displayed image
Public Property | LevelShift | Provides a means to modify the usage of a Values of Interest Lookup Table (VOI LUT) or other display mapping
Public Property | MagnificationMode | Controls how pixels are interpolated when the image is magnified
Public Property | MinificationMode | Controls how pixels are interpolated when the image is minified
Public Property | Modality | The Modality of the image
Public Property | ModalityLUT | Enables or disables the Modality Lookup Table to be used in the DicomImage
Public Property | Name | The Name of the patient
Public Property | OriginalTS | Original Transfer syntax of the underlying DataSet
Public Property | OverlayColour | Controls how overlays embedded in the image are displayed
Public Property | OverlayVisible | Controls whether overlays embedded in the image are displayed
Public Property | PatientID | The Patient ID
Public Property | Pixels | Accesses the raw pixel data as a typed array
Public Property | PresentationLUT | Enables or disables the Presentation Lookup Table to be used in the DicomImage
Public Property | PresentationState | Support for DICOM greyscale presentation state
Public Property | PresentationStates | Support for a list of DICOM greyscale presentation state
Public Property | RawPixels | Accesses the raw pixel data as an array
Public Property | RealTimeCine | Controls how cine images are displayed
Public Property | RenderedSize | Returns the Image display size in output (normally screen) coordinates
Public Property | RotateState | The rotation state of the image, allowing the orientation of the image, as displayed, to be altered
Public Property | RotationBehaviour | Controls the baseline positioning of an image which is not stretched to fit and is rotated
Public Property | Scroll | Controls the positioning of an image display
Public Property | SeriesDescription | Descriptions for the series
Public Property | SeriesUID | Unique identifier for the four levels of the DICOM Query/Retrieve hierarchy
Public Property | Sex | Sex of the patient
Public Property | ShowLabels | Controls whether the image�s labels (annotations) are shown on screen
Public Property | ShowShutter | Controls whether image shutters (if specified in the image) are used.
Public Property | ShowUpdates | Controls whether the images is updated when image display parameters change
Public Property | Size | The dimensions of the image
Public Property | SOPClass | SOP class of the DicomDataSet.
Public Property | StretchMode | Controls the automatic zooming of an image.
Public Property | StudyDescription | Description for the study
Public Property | StudyUID | Unique identifier for the four levels of the DICOM Query/Retrieve hierarchy
Public Property | Tag | A general purpose Tag for developer use
Public Property | UnsharpEnhancement | UnsharpLength and UnsharpEnhancement, allow use of unsharp masking, as simple method of image edge enhancement
Public Property | UnsharpLength | UnsharpLength and UnsharpEnhancement, allow use of unsharp masking, as simple method of image edge enhancement
Public Property | UserMatrix | Means to override the matrix used to display 2D images
Public Property | ValidationOptions | The default DicomObjects.Validation.ValidationOptions to apply to newly created DicomImage objects
Public Property | VoiLUT | The VOI Lookup Table to be used to display the DicomImage
Public Property | VOILUTFunction | Controls which VOILUT function to be used, default value is Linear
Public Property | VoiLUTInUse | Indicates whether a Values of Interest Lookup Table is in use
Public Property | Width | The Window "Width" - which controls the greyscale mapping of a displayed image
Public Property | WidthMultiplier | Provides a means to modify the usage of a Values of Interest Lookup Table (VOI LUT) or other display mapping
Public Property | Zoom | Controls the magnification of an image display
    Top
    See Also

    Reference

    DicomImage Class
    DicomObjects Namespace


DicomObjects Namespace / DicomImage Class / AccessionNumber Property

    AccessionNumber Property (DicomImage)
    In This Topic
    The Accession Number
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property AccessionNumber As String
    'Usage

    Dim instance As DicomImage
Dim value As String

instance.AccessionNumber = value

value = instance.AccessionNumber
    public string AccessionNumber {get; set;}

    Property Value

    The Accession Number
    Remarks
    Shortcut for Attribute 0008,0050
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / Angle Property

    Angle Property (DicomImage)
    In This Topic
    Controls the rotation of an image
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property Angle As Single
    'Usage

    Dim instance As DicomImage
Dim value As Single

instance.Angle = value

value = instance.Angle
    public float Angle {get; set;}
    Remarks

    If set to anything other than 0, then (MagnificationMode and MinificationMode, are handled internally as if they were set to DicomObjects.Enums.FilterMode.Gpu

    The centre of rotation is the centre of the original image

    The angle is measured in degrees, and clockwise

    As for all other display features, the Scroll values continue to work in screen units and relative to the screen axes, and hence are applied after rotation

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / Area Property

    Area Property (DicomImage)
    In This Topic
    The display area of DicomImage
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overridable Property Area As SkiaSharp.SKRect
    'Usage

    Dim instance As DicomImage
Dim value As SkiaSharp.SKRect

instance.Area = value

value = instance.Area
    public virtual SkiaSharp.SKRect Area {get; set;}
    Remarks
    If set to a non-empty value, this property overrides the normal placement of images in the Rows x Columns grid in the DicomViewer by specifying the abolute position and size of the image in the viewer.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / BorderPaint Property

    BorderPaint Property
    The Paint object for Image border
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property BorderPaint As SkiaSharp.SKPaint
    'Usage

    Dim instance As DicomImage
Dim value As SkiaSharp.SKPaint

instance.BorderPaint = value

value = instance.BorderPaint
    public SkiaSharp.SKPaint BorderPaint {get; set;}
    Remarks
    User defined Paint object for drawing the Image border. The default color is transparent and width is zero. If set to null, this property will be reset to transparent.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / CacheMode Property

    CacheMode Property (DicomImage)
    In This Topic
    Controls how the pixel data is cached
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property CacheMode As CacheTypes
    'Usage

    Dim instance As DicomImage
Dim value As CacheTypes

instance.CacheMode = value

value = instance.CacheMode
    public CacheTypes CacheMode {get; set;}
    Remarks
    See DicomObjects.Enums.CacheTypes for details of the values
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / CaptureBackColour Property

    CaptureBackColour Property
    User defined background colour for image output of PrinterImage, SKBitmap and SubImage methods Default is Black background
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property CaptureBackColour As SkiaSharp.SKColor
    'Usage

    Dim instance As DicomImage
Dim value As SkiaSharp.SKColor

instance.CaptureBackColour = value

value = instance.CaptureBackColour
    public SkiaSharp.SKColor CaptureBackColour {get; set;}
    Remarks
    Default is Black background
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / CineFramesToDisplay Property

    CineFramesToDisplay Property
    The set of frames to display for cine modes
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property CineFramesToDisplay As Integer()
    'Usage

    Dim instance As DicomImage
Dim value() As Integer

instance.CineFramesToDisplay = value

value = instance.CineFramesToDisplay
    public int[] CineFramesToDisplay {get; set;}
    Remarks
    If non-null, then the contents are used in place of native frame numbers to control which frames are displayed when CineMode is not Static.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / CineIndex Property

    CineIndex Property
    The index of the currently displayed frame when using CineMode
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property CineIndex As Integer
    'Usage

    Dim instance As DicomImage
Dim value As Integer

instance.CineIndex = value

value = instance.CineIndex
    public int CineIndex {get; set;}
    Remarks

    This acts as an index into CineFramesToDisplay and is therefore 0-based.

    If CineFramesToDisplay is null, then this property will be equal to Frame - 1

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / CineSmoothing Property

    CineSmoothing Property
    Boolean property indicating whether Smoothing is applied when Cine is being displayed.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property CineSmoothing As Boolean
    'Usage

    Dim instance As DicomImage
Dim value As Boolean

instance.CineSmoothing = value

value = instance.CineSmoothing
    public bool CineSmoothing {get; set;}
    Remarks
    Default value is false, which speeds up the cine display with out applying smoothing. Once the cine stops, smoothing will be back on to give the user a better view of the Image.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / ColourTable Property

    ColourTable Property
    The colour lookup table of DicomImage
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property ColourTable As IList(Of SKColor)
    'Usage

    Dim instance As DicomImage
Dim value As IList(Of SKColor)

instance.ColourTable = value

value = instance.ColourTable
    public IList<SKColor> ColourTable {get; set;}

    Property Value

    List of SkiaSharp.SKColor values
    Remarks
    This property enables developers to define and apply their own color table to Images.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / CubicSplineAlpha Property

    CubicSplineAlpha Property
    Parameter to control the degree of smoothing. The default value is �0.75, and normal values range from �0.5 to �1.25, though higher negative values may be used to produce deliberate edge enhancement.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property CubicSplineAlpha As Single
    'Usage

    Dim instance As DicomImage
Dim value As Single

instance.CubicSplineAlpha = value

value = instance.CubicSplineAlpha
    public float CubicSplineAlpha {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / DataSet Property

    DataSet Property (DicomImage)
    In This Topic
    The underlying DICOM Dataset containing persistent data for the image
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property DataSet As DicomDataSet
    'Usage

    Dim instance As DicomImage
Dim value As DicomDataSet

instance.DataSet = value

value = instance.DataSet
    public DicomDataSet DataSet {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / DateOfBirth Property

    DateOfBirth Property (DicomImage)
    In This Topic
    Date of birth of the patient
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property DateOfBirth As Date
    'Usage

    Dim instance As DicomImage
Dim value As Date

instance.DateOfBirth = value

value = instance.DateOfBirth
    public DateTime DateOfBirth {get; set;}

    Property Value

    Date of birth of the patient
    Remarks
    A shortcut for attribute (0010, 0030)
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / DefaultModalityLUT Property

    DefaultModalityLUT Property
    Default value for the ModalityLUT property
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Property DefaultModalityLUT As Short
    'Usage

    Dim value As Short

DicomImage.DefaultModalityLUT = value

value = DicomImage.DefaultModalityLUT
    public static short DefaultModalityLUT {get; set;}
    Remarks
    All new DicomImage objects will have this as their ModalityLUT property
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / DefaultPresentationLUT Property

    DefaultPresentationLUT Property
    Default value for the PresentationLUT property
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Property DefaultPresentationLUT As Short
    'Usage

    Dim value As Short

DicomImage.DefaultPresentationLUT = value

value = DicomImage.DefaultPresentationLUT
    public static short DefaultPresentationLUT {get; set;}
    Remarks
    All new DicomImage objects will have this as their PresentationLUT property
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / DefaultRealTimeCine Property

    DefaultRealTimeCine Property
    Controls the default for how cine images are displayed
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Property DefaultRealTimeCine As Boolean
    'Usage

    Dim value As Boolean

DicomImage.DefaultRealTimeCine = value

value = DicomImage.DefaultRealTimeCine
    public static bool DefaultRealTimeCine {get; set;}
    Remarks

    If true, then frames are skipped as necessary to ensure that the required display speed is maintained. If false, then every frame is displayed in turn, even if this slows the display

    This is equivalent to the "RealTimeCine" registry value

    New images acquire this value for their RealTimeCine property

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / DefaultVoiLUT Property

    DefaultVoiLUT Property
    Default value for the VoiLUT property
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Property DefaultVoiLUT As Short
    'Usage

    Dim value As Short

DicomImage.DefaultVoiLUT = value

value = DicomImage.DefaultVoiLUT
    public static short DefaultVoiLUT {get; set;}
    Remarks
    All new DicomImage objects will have this as their VoiLUT property
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / DisplayMode Property

    DisplayMode Property
    Controls how the image is rendered internal before transfer to the screen
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property DisplayMode As DisplayMode
    'Usage

    Dim instance As DicomImage
Dim value As DisplayMode

instance.DisplayMode = value

value = instance.DisplayMode
    public DisplayMode DisplayMode {get; set;}
    Remarks
    Although public, this is an experimental property intended for performance tuning experiments and may not be supported in future versions of DicomObjects
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / DrawCacheMode Property

    DrawCacheMode Property
    Specify the DrawCacheMode to control how image is drawn/cached
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property DrawCacheMode As DrawCacheMode
    'Usage

    Dim instance As DicomImage
Dim value As DrawCacheMode

instance.DrawCacheMode = value

value = instance.DrawCacheMode
    public DrawCacheMode DrawCacheMode {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / ExplicitModalityLUT Property

    ExplicitModalityLUT Property
    An explicit modality Lookup Table to be used in place of one specified in the image or presentaiton state.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property ExplicitModalityLUT As LookupTable
    'Usage

    Dim instance As DicomImage
Dim value As LookupTable

instance.ExplicitModalityLUT = value

value = instance.ExplicitModalityLUT
    public LookupTable ExplicitModalityLUT {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / ExplicitPresentationLUT Property

    ExplicitPresentationLUT Property
    An explicit presentation Lookup Table to be used in place of one specified in the image or presentaiton state.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property ExplicitPresentationLUT As LookupTable
    'Usage

    Dim instance As DicomImage
Dim value As LookupTable

instance.ExplicitPresentationLUT = value

value = instance.ExplicitPresentationLUT
    public LookupTable ExplicitPresentationLUT {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / ExplicitVOILUT Property

    ExplicitVOILUT Property
    An explicit Values of Interest (VOI) Lookup Table to be used in place of one specified in the image or presentaiton state.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property ExplicitVOILUT As LookupTable
    'Usage

    Dim instance As DicomImage
Dim value As LookupTable

instance.ExplicitVOILUT = value

value = instance.ExplicitVOILUT
    public LookupTable ExplicitVOILUT {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / FilterLength Property

    FilterLength Property
    Contains the length of the smoothing filter
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property FilterLength As Integer
    'Usage

    Dim instance As DicomImage
Dim value As Integer

instance.FilterLength = value

value = instance.FilterLength
    public int FilterLength {get; set;}
    Remarks
    This property is used when DicomImage's FilterMode is set to MovingAverage and it controls the number of pixel values used in the smoothing calculation. If length is zero then a suitable value is determined internally based on the zoom, but if FileterLenght is non-zero then 2 * FilterLength number of pixel values will be used in MovingAverage smoothing calculation.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / FlipState Property

    FlipState Property
    The flip state of the image, allowing the orientation of the image, as displayed, to be altered
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property FlipState As FlipState
    'Usage

    Dim instance As DicomImage
Dim value As FlipState

instance.FlipState = value

value = instance.FlipState
    public FlipState FlipState {get; set;}
    Remarks

    Check DicomImage.FlipState for all possible values.

    Default values is Normal.

    Only display within a DicomViewer is altered by these properties. Storage and transmission are NOT affected.

    RotateState and FlipState properties interact, as for example, RotateState=180 has the same effect as FlipState=Both. Conceptually, the flip is performed first, followed by any rotation.

    These properties are over-ridden if a PresentationState is applied.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / Frame Property

    Frame Property (DicomImage)
    In This Topic
    Controls which frame of a multi-frame image is displayed
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property Frame As Integer
    'Usage

    Dim instance As DicomImage
Dim value As Integer

instance.Frame = value

value = instance.Frame
    public int Frame {get; set;}

    Property Value

    The number of the frame to display
    Remarks

    Unlike other indices in DicomObjects, this is 1-based, as that is the DICOM convention - i.e. the range is from 1 to FrameCount.

    If set to a value higher than FrameCount, this property is reduced modulo FrameCount, to bring it within range. Cine sequences may therefore be run repeatedly simply by incrementing Frame continuously. Alternatively, to allow multi-frame images to "play" autonomously, the CineMode property may be used.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / FrameCount Property

    FrameCount Property (DicomImage)
    In This Topic
    The number of frames contained in a multi-frame image
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property FrameCount As Integer
    'Usage

    Dim instance As DicomImage
Dim value As Integer

value = instance.FrameCount
    public int FrameCount {get;}

    Property Value

    The number of frames
    Remarks

    The actual frame displayed is controlled by the image's Frame property.

    If the image does not contain a frame count, a value of 1 is returned.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / Gamma Property

    Gamma Property
    A number that specifies a power
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property Gamma As Single
    'Usage

    Dim instance As DicomImage
Dim value As Single

instance.Gamma = value

value = instance.Gamma
    public float Gamma {get; set;}
    Remarks
    Default value is 1.0F. If value of this property is not 1 then transformation is applied after rewindowing to calculate the value for output pixel data.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / InstanceUID Property

    InstanceUID Property (DicomImage)
    In This Topic
    Unique identifier for the four levels of the DICOM Query/Retrieve hierarchy
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property InstanceUID As String
    'Usage

    Dim instance As DicomImage
Dim value As String

instance.InstanceUID = value

value = instance.InstanceUID
    public string InstanceUID {get; set;}

    Property Value

    The Instance UID
    Remarks
    A shortcut for attribute (0008, 0018)
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / Invert Property

    Invert Property
    Controls whether the Image will be inverted.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property Invert As Boolean
    'Usage

    Dim instance As DicomImage
Dim value As Boolean

instance.Invert = value

value = instance.Invert
    public bool Invert {get; set;}
    Remarks
    If set to true then Image will be inverted, which means black becomes white and write becomes black. Setting this property to true has the same effect of setting Image's Width property to some negative value.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / Item Property

    Item Property (DicomImage)
    In This Topic
    Provides access to all attributes of the image
    Overload List
    Overload | Description
Item(Int32,Int32) | Provides access to all attributes of the image
Item(Keyword) | Indexer based on the new DICOM keyword
    Remarks
    This is the default indexer to provide access to all attributes of the image. Attribute element can be accessed by "Image[Group, Element]".
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / Item Property / Item(Int32,Int32) Property

The group index of a data element.

The element index of a data element.

In This Topic
    Item(Int32,Int32) Property
    In This Topic
    Provides access to all attributes of the image
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads ReadOnly Property Item( _
   ByVal Group As Integer, _
   ByVal Element As Integer _
) As DicomAttribute
    'Usage

    Dim instance As DicomImage
Dim Group As Integer
Dim Element As Integer
Dim value As DicomAttribute

value = instance.Item(Group, Element)
    public DicomAttribute Item(
   int Group,
   int Element
) {get;}

    Parameters

    Group

    The group index of a data element.

    Element

    The element index of a data element.

    Remarks
    This is the default indexer to provide access to all attributes of the image. Attribute element can be accessed by "Image[Group, Element]".
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members
    Overload List


DicomObjects Namespace / DicomImage Class / Item Property / Item(Keyword) Property
The Keyword of the DicomAttribute

    Item(Keyword) Property
    In This Topic
    Indexer based on the new DICOM keyword
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads ReadOnly Property Item( _
   ByVal Keyword As Keyword _
) As DicomAttribute
    'Usage

    Dim instance As DicomImage
Dim Keyword As Keyword
Dim value As DicomAttribute

value = instance.Item(Keyword)
    public DicomAttribute Item(
   Keyword Keyword
) {get;}

    Parameters

    Keyword
    The Keyword of the DicomAttribute
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members
    Overload List


DicomObjects Namespace / DicomImage Class / Labels Property

    Labels Property
    Provides access to the DicomLabelCollection, items of which are to be displayed over an image.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property Labels As DicomLabelCollection
    'Usage

    Dim instance As DicomImage
Dim value As DicomLabelCollection

instance.Labels = value

value = instance.Labels
    public DicomLabelCollection Labels {get; set;}
    Remarks
    If ShowLabels is true, then the labels in this collection are displayed over the image. The labels are also used if the image is captured to a secondary capture image.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / Level Property

    Level Property (DicomImage)
    In This Topic
    The Window Level (also known as the centre) - which controls the greyscale mapping of a displayed image
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property Level As Single
    'Usage

    Dim instance As DicomImage
Dim value As Single

instance.Level = value

value = instance.Level
    public float Level {get; set;}

    Property Value

    The Window Level (also known as the centre)
    Remarks

    Width and Level are the parameters that control the grey-scale mapping from the original pixel data to the screen. Following the normal convention, the grey scale ranges from level-width/2 to level+width/2. Note that re-scale values present in some SOP classes are used for the purposes of this mapping, but the native data are not altered, and other operations such as obtaining the Pixels are unaffected.

    Windowing using these values applies now also to colour (RGB, YBR & COLOR PALETTE images, which by default have Width=255 and Level=128)

    These values are initialised from the suggested values in the DICOM data, if present, but if not present, then reasonable initial values are calculated from the pixel data itself.

    These values are regarded as transitory, and therefore, when an image is written, they are not written back into the DICOM data. If this behaviour is required, then code similar to this should be included prior to the write:

    Image.Attributes.Add(&h0028,&h1050), Image.Level Image.Attributes.Add(&h0028,&h1051), Image.Width

    Width and Level are ignored under the following circumstances:

    • When a PresentationState is applied to the image
    • When the image contains a "Values of Interest Lookup Table" (VOILUT), as this takes the place of windowing

    In the later case, the VOI LUT can be ignored (and width and level used), by setting the image�s VOILUT property to 0.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / LevelShift Property

    LevelShift Property
    Provides a means to modify the usage of a Values of Interest Lookup Table (VOI LUT) or other display mapping
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property LevelShift As Single
    'Usage

    Dim instance As DicomImage
Dim value As Single

instance.LevelShift = value

value = instance.LevelShift
    public float LevelShift {get; set;}
    Remarks

    Width and Level are ignored when a VOI LUT is in use (VoiLUTInUse is true), but this property, together with WidthMultiplier provides an alternative means to allow users to have some control over the display without having to disable the VOILUT completely

    The mechanism used is that the entire lookup table is shifted (in original image units) by LevelShift units, then widended or narrowed around its mid-point (where it crosses the mid-point of the output space) by a factor of WidthMultiplier.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / MagnificationMode Property

    MagnificationMode Property
    Controls how pixels are interpolated when the image is magnified
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property MagnificationMode As FilterMode
    'Usage

    Dim instance As DicomImage
Dim value As FilterMode

instance.MagnificationMode = value

value = instance.MagnificationMode
    public FilterMode MagnificationMode {get; set;}
    Remarks
    This property controls how DicomObjects handles magnification of images, either for display or other uses such as PrinterImage. The FilterMode enumerations (used for MagnificationMode and MinificationMode) are:
    • Default: For MagnificationMode, this acts identically to Replicate. This behaviour is the default, and is designed to minimise regulatory issues by doing the minimum necessary to display all pixel data, without adding extra "image processing".
    • Replicate: If zooming up is necessary, then pixels are simply replicated, giving a possibly "blocky" but honest representation of the pixel data. For minification, rows and columns are simply omitted as necessary.
    • BSpline: This smoothing procedure interpolates using a Cubic B-Spline, which has the advantage of guaranteeing continuity in both the first and second differentials of the image, in both directions. No other parameters are used in this smoothing method, which produces good visual results, though some users find them a little too "smoothed".
    • CubicSpline: This is similar to the B-Spline described above, but uses an additional parameter (CubicSplineAlpha) to control the degree of smoothing or edge enhancement. The default value is "�0.75", and normal values range from "�0.5" to "�1.25", though higher negative values may be used to produce deliberate edge enhancement, though generally, UnsharpLength and UnsharpEnhancement should be used for this purpose, as they are independent of the smoothing method.
    • MovingAverage: This mode is most applicable when zoom is less than 1, and calculates pixels values as a weighted average of the surrounding values. The number of values used for this calculation depends on the value of FilterLength. If FilterLength is 0 (the default), then a suitable value is determined internally, based on the zoom (approximately 2/ActualZoom), but if FilterLength is non-zero then 2*FilterLength values are used.
    • GDI (Graphical Device Intergace): This mode uses the interinsic capabilities of modern display hardware and software to leave the interpolation of the image to such systems. In practice, it is generally similar on most systems to a DicomObjects.Enums.FilterMode.BSpline, and should, particularly for large format display be the most efficient. However, experience shows that some graphic cards perform quite badly in this mode, especially in 64 bit mode, so practical testing is advised.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / MinificationMode Property

    MinificationMode Property
    Controls how pixels are interpolated when the image is minified
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property MinificationMode As FilterMode
    'Usage

    Dim instance As DicomImage
Dim value As FilterMode

instance.MinificationMode = value

value = instance.MinificationMode
    public FilterMode MinificationMode {get; set;}
    Remarks
    This property controls how DicomObjects handles minification of images, either for display or other uses such as PrinterImage. The FilterMode enumerations (used for MagnificationMode and MinificationMode) are:
    • Default: For MinificationMode, this acts identically to MovingAverage. This behaviour is the default, and is deigned to minimise regulatory issues by doing the minimum necessary to display all pixel data, without adding extra "image processing".
    • Replicate: If zooming up is necessary, then pixels are simply replicated, giving a possibly "blocky" but honest representation of the pixel data. For minification, rows and columns are simply omitted as necessary.
    • BSpline: This smoothing procedure interpolates using a Cubic B-Spline, which has the advantage of guaranteeing continuity in both the first and second differentials of the image, in both directions. No other parameters are used in this smoothing method, which produces good visual results, though some users find them a little too "smoothed".
    • CubicSpline: This is similar to the B-Spline described above, but uses an additional parameter (CubicSplineAlpha) to control the degree of smoothing or edge enhancement. The default value is "�0.75", and normal values range from "�0.5" to "�1.25", though higher negative values may be used to produce deliberate edge enhancement, though generally, UnsharpLength and UnsharpEnhancement should be used for this purpose, as they are independent of the smoothing method.
    • MovingAverage: This mode is most applicable when zoom is less than 1, and calculates pixels values as a weighted average of the surrounding values. The number of values used for this calculation depends on the value of FilterLength. If FilterLength is 0 (the default), then a suitable value is determined internally, based on the zoom (approximately 2/ActualZoom), but if FilterLength is non-zero then 2*FilterLength values are used.
    • GDI (Graphical Device Intergace): This mode uses the interinsic capabilities of modern display hardware and software to leave the interpolation of the image to such systems. In practice, it is generally similar on most systems to a DicomObjects.Enums.FilterMode.BSpline, and should, particularly for large format display be the most efficient. However, experience shows that some graphic cards perform quite badly in this mode, especially in 64 bit mode, so practical testing is advised.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / Modality Property

    Modality Property (DicomImage)
    In This Topic
    The Modality of the image
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property Modality As String
    'Usage

    Dim instance As DicomImage
Dim value As String

instance.Modality = value

value = instance.Modality
    public string Modality {get; set;}

    Property Value

    The Modality of the image
    Remarks

    A shortcut for Modality (0008,0060).

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / ModalityLUT Property

    ModalityLUT Property
    Enables or disables the Modality Lookup Table to be used in the DicomImage
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property ModalityLUT As Short
    'Usage

    Dim instance As DicomImage
Dim value As Short

instance.ModalityLUT = value

value = instance.ModalityLUT
    public short ModalityLUT {get; set;}

    Property Value

    The index of the modality lookup table to use
    Remarks

    DICOM allows multiple VOI and presentation Lookup Tables (LUTs) in images, and the user may select whichever they require. These properties provide that choice, and the value 0 may be used to disable a particular type of LUT.

    Only one Modality LUT is allowed, so the only meaningful values for ModalityLUT are 0 and 1, but the other two may range from 0 to the number of such LUTs in the image. Value beyond the available range are treated as 0.

    For Modality LUT, the default value is all 1, indicating that the Lookup Table, if present, should be used.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / Name Property

    Name Property (DicomImage)
    In This Topic
    The Name of the patient
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property Name As String
    'Usage

    Dim instance As DicomImage
Dim value As String

instance.Name = value

value = instance.Name
    public string Name {get; set;}

    Property Value

    The Name of the patient
    Remarks

    A shortcut for attribute (0010,0010).

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / OriginalTS Property

    OriginalTS Property (DicomImage)
    In This Topic
    Original Transfer syntax of the underlying DataSet
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property OriginalTS As String
    'Usage

    Dim instance As DicomImage
Dim value As String

value = instance.OriginalTS
    public string OriginalTS {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / OverlayColour Property

    OverlayColour Property
    Controls how overlays embedded in the image are displayed
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property OverlayColour As SkiaSharp.SKColor()
    'Usage

    Dim instance As DicomImage
Dim value() As SkiaSharp.SKColor

value = instance.OverlayColour
    public SkiaSharp.SKColor[] OverlayColour {get;}

    Property Value

    Array of 16 SkiaSharp.SKColorelements, one for each possible overlay plane
    Remarks

    DICOM defines up to 16 overlay planes embedded in an image, using group number 6000, 6002, 6004�601E, and these properties allow the developer to choose which to display. Each is a simple single bit mask, and is displayed if the appropriate OverlayVisible property is true, using the associated OverlayColour.

    The source of the data for such overlays can be either unused bits in the pixel data, or separate elements, but this is handled internally by DicomObjects, and all such overlays are handled identically.

    The OverlayIDs are numbered from 0 to 15, and so are related to the group numbers as follows:

    OverlayID=(group number � 0x6000) / 2

    Or put another way

    Group number=OverlayID * 2 + 0x6000

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / OverlayVisible Property

    OverlayVisible Property
    Controls whether overlays embedded in the image are displayed
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property OverlayVisible As Boolean()
    'Usage

    Dim instance As DicomImage
Dim value() As Boolean

value = instance.OverlayVisible
    public bool[] OverlayVisible {get;}

    Property Value

    Array of 16 elements, one for each possible overlay plane
    Remarks

    DICOM defines up to 16 overlay planes embedded in an image, using group number 6000, 6002, 6004�601E, and these properties allow the developer to choose which to display. Each is a simple single bit mask, and is displayed if the appropriate OverlayVisible property is true, using the associated OverlayColour.

    The source of the data for such overlays can be either unused bits in the pixel data, or separate elements, but this is handled internally by DicomObjects, and all such overlays are handled identically.

    The OverlayIDs are numbered from 1 to 15, and so are related to the group numbers as follows:

    OverlayID=(group number � 0x6000) / 2

    Or put another way

    Group number=OverlayID * 2 + 0x6000

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / PatientID Property

    PatientID Property (DicomImage)
    In This Topic
    The Patient ID
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property PatientID As String
    'Usage

    Dim instance As DicomImage
Dim value As String

instance.PatientID = value

value = instance.PatientID
    public string PatientID {get; set;}

    Property Value

    The Patient ID
    Remarks
    A shortcut for attribute (0010, 0020)
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / Pixels Property

    Pixels Property
    Accesses the raw pixel data as a typed array
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property Pixels As Object
    'Usage

    Dim instance As DicomImage
Dim value As Object

instance.Pixels = value

value = instance.Pixels
    public object Pixels {get; set;}
    Remarks

    This returns an array of either bytes or short or long integers, depending on the size of the native data. The data returned is unaffected by the display parameters.

    The first two dimensions of the array returned are those of the image itself, the third being the number of frames (as returned by FrameCount).

    If the data has more than one sample per pixel (e.Graphics. RGB images), then the format of the array returned depends on the planar configuration (0028,0006). If this is 0 (colour-by-pixel), then the 1st (horizontal) dimension of the array is multiplied by the number of samples, whereas if the planar configuration is 1 (colour-by-plane), then it is the 2nd (vertical) dimension that is increased. This ensures that each �row� of pixels remains intact.

    When writing to this property, either a 1, 2 or 3 dimensional array will be accepted, and will be interpreted as a byte or word stream, varying the first dimension fastest, then the others in order.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / PresentationLUT Property

    PresentationLUT Property
    Enables or disables the Presentation Lookup Table to be used in the DicomImage
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property PresentationLUT As Short
    'Usage

    Dim instance As DicomImage
Dim value As Short

instance.PresentationLUT = value

value = instance.PresentationLUT
    public short PresentationLUT {get; set;}

    Property Value

    The index of the Presentation LUT to use
    Remarks

    DICOM allows multiple VOI and presentation Lookup Tables (LUTs) in images, and the user may select whichever they require. These properties provide that choice, and the value 0 may be used to disable a particular type of LUT. Only one Modality LUT is allowed, so the only meaningful values for ModalityLUT are 0 and 1, but the other two may range from 0 to the number of such LUTs in the image. Value beyond the available range are treated as 0.

    The default values are all 1, indicating that the first VOI Lookup Table, if present, should be used.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / PresentationState Property

    PresentationState Property (DicomImage)
    In This Topic
    Support for DICOM greyscale presentation state
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property PresentationState As DicomDataSet
    'Usage

    Dim instance As DicomImage
Dim value As DicomDataSet

instance.PresentationState = value

value = instance.PresentationState
    public DicomDataSet PresentationState {get; set;}
    Remarks
    When this property is set to an existing DicomDataSet containing a valid DICOM greyscale presentation state, all the normal display parameters (Zoom, Scroll, Width & Level etc.) are over-ridden, and the display is determines solely by the presentation state as defined in DICOM supplement 33.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / PresentationStates Property

    PresentationStates Property
    Support for a list of DICOM greyscale presentation state
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property PresentationStates As DicomDataSetCollection
    'Usage

    Dim instance As DicomImage
Dim value As DicomDataSetCollection

instance.PresentationStates = value

value = instance.PresentationStates
    public DicomDataSetCollection PresentationStates {get; set;}
    Remarks
    This property is for user to provide a list of PresentationStates for matching. If the Image's PresentationState property is null then the first matching item from this list will get used.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / RawPixels Property

    RawPixels Property (DicomImage)
    In This Topic
    Accesses the raw pixel data as an array
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property RawPixels As Array
    'Usage

    Dim instance As DicomImage
Dim value As Array

instance.RawPixels = value

value = instance.RawPixels
    public Array RawPixels {get; set;}
    Remarks

    This returns an array containing one element per frame. The data returned is unaffected by the display parameters.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / RealTimeCine Property

    RealTimeCine Property
    Controls how cine images are displayed
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property RealTimeCine As Boolean
    'Usage

    Dim instance As DicomImage
Dim value As Boolean

instance.RealTimeCine = value

value = instance.RealTimeCine
    public bool RealTimeCine {get; set;}
    Remarks

    If true, then frames are skipped as necessary to ensure that the required display speed is maintained. If false, then every frame is displayed in turn, even if this slows the display

    This is equivalent to the "RealTimeCine" registry value

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / RenderedSize Property

    RenderedSize Property
    Returns the Image display size in output (normally screen) coordinates
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overridable ReadOnly Property RenderedSize As SkiaSharp.SKSizeI
    'Usage

    Dim instance As DicomImage
Dim value As SkiaSharp.SKSizeI

value = instance.RenderedSize
    public virtual SkiaSharp.SKSizeI RenderedSize {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / RotateState Property

    RotateState Property
    The rotation state of the image, allowing the orientation of the image, as displayed, to be altered
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property RotateState As RotateState
    'Usage

    Dim instance As DicomImage
Dim value As RotateState

instance.RotateState = value

value = instance.RotateState
    public RotateState RotateState {get; set;}
    Remarks

    Check RotateState for all possible values.

    Default values is Normal.

    Only display within a DicomViewer is altered by these properties. Storage and transmission are NOT affected.

    RotateState and FlipState properties interact, as for example, RotateState=180 has the same effect as FlipState=Both. Conceptually, the flip is performed first, followed by any rotation.

    These properties are over-ridden if a PresentationState is applied.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / RotationBehaviour Property

    RotationBehaviour Property
    Controls the baseline positioning of an image which is not stretched to fit and is rotated
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property RotationBehaviour As RotationBehaviour
    'Usage

    Dim instance As DicomImage
Dim value As RotationBehaviour

instance.RotationBehaviour = value

value = instance.RotationBehaviour
    public RotationBehaviour RotationBehaviour {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / Scroll Property

    Scroll Property
    Controls the positioning of an image display
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property Scroll As SkiaSharp.SKPoint
    'Usage

    Dim instance As DicomImage
Dim value As SkiaSharp.SKPoint

instance.Scroll = value

value = instance.Scroll
    public SkiaSharp.SKPoint Scroll {get; set;}

    Property Value

    The offset to use for display
    Remarks

    Together with Zoom, this determines the display of an image, which is magnified by 'Zoom' and then displaced Scroll.X pixels to the left and Scroll.Y pixels up. Zoom and Scroll are ignored if the containing control's StretchMode property is true.

    In order to find the values used at any given time, even if StretchToFit is true, use the Matrix method to get the ActualScrollX, ActualScrollY and ActualZoom which are used in the COM version.

    This property is over-ridden if a PresentationState is applied.

    If the viewer in which the image is held has
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / SeriesDescription Property

    SeriesDescription Property (DicomImage)
    In This Topic
    Descriptions for the series
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property SeriesDescription As String
    'Usage

    Dim instance As DicomImage
Dim value As String

instance.SeriesDescription = value

value = instance.SeriesDescription
    public string SeriesDescription {get; set;}

    Property Value

    The Series Description
    Remarks

    Provides human readable descriptions of the Study returned by a query, or relating to an image. They correspond to attribute (0008, 103E).

    The usefulness is limited by the fact that not all equipment provides descriptions in its SOP instances, and even if it does, they may not be available through Query/Retrieve. For instance the RSNA CTN (up to and including version 2.8) supports the study description, but fails to index and provide the series description.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / SeriesUID Property

    SeriesUID Property (DicomImage)
    In This Topic
    Unique identifier for the four levels of the DICOM Query/Retrieve hierarchy
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property SeriesUID As String
    'Usage

    Dim instance As DicomImage
Dim value As String

instance.SeriesUID = value

value = instance.SeriesUID
    public string SeriesUID {get; set;}

    Property Value

    The Series UID
    Remarks
    A shortcut for the attribute (0020, 000E).
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / Sex Property

    Sex Property (DicomImage)
    In This Topic
    Sex of the patient
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property Sex As String
    'Usage

    Dim instance As DicomImage
Dim value As String

instance.Sex = value

value = instance.Sex
    public string Sex {get; set;}

    Property Value

    Sex of the patient
    Remarks
    A shortcut for attribute (0010, 0040)
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / ShowLabels Property

    ShowLabels Property
    Controls whether the image�s labels (annotations) are shown on screen
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property ShowLabels As Boolean
    'Usage

    Dim instance As DicomImage
Dim value As Boolean

instance.ShowLabels = value

value = instance.ShowLabels
    public bool ShowLabels {get; set;}
    Remarks

    If set false, then the DicomLabel objects in the image's Labels collection are not displayed, and are not incorporated into any captured versions, but they remain present, and may be redisplayed by setting this property to true.

    Unlike other label manipulations, altering this property does cause the display to be updated to include or exclude the annotations as appropriate.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / ShowShutter Property

    ShowShutter Property
    Controls whether image shutters (if specified in the image) are used.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property ShowShutter As Boolean
    'Usage

    Dim instance As DicomImage
Dim value As Boolean

instance.ShowShutter = value

value = instance.ShowShutter
    public bool ShowShutter {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / ShowUpdates Property

    ShowUpdates Property
    Controls whether the images is updated when image display parameters change
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property ShowUpdates As Boolean
    'Usage

    Dim instance As DicomImage
Dim value As Boolean

instance.ShowUpdates = value

value = instance.ShowUpdates
    public bool ShowUpdates {get; set;}
    Remarks
    Set this property false before making multiple changes to an image, e.Graphics. Zoom, Scroll and Windowing, then set true once changes are complete. This will ensure that only a single screen update occurs.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / Size Property

    Size Property (DicomImage)
    In This Topic
    The dimensions of the image
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property Size As SkiaSharp.SKSizeI
    'Usage

    Dim instance As DicomImage
Dim value As SkiaSharp.SKSizeI

value = instance.Size
    public SkiaSharp.SKSizeI Size {get;}
    Remarks
    This property provides access to the horizontal (SKSizeI.Width) and vertical dimensions (SKSizeI.Height) of the image. Dimensions are 32-bit Integers.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / SOPClass Property

    SOPClass Property (DicomImage)
    In This Topic
    SOP class of the DicomDataSet.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property SOPClass As String
    'Usage

    Dim instance As DicomImage
Dim value As String

instance.SOPClass = value

value = instance.SOPClass
    public string SOPClass {get; set;}

    Property Value

    The SOP class UID
    Remarks
    Shortcut for attribute (0008, 0016).
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / StretchMode Property

    StretchMode Property
    Controls the automatic zooming of an image.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property StretchMode As StretchModes
    'Usage

    Dim instance As DicomImage
Dim value As StretchModes

instance.StretchMode = value

value = instance.StretchMode
    public StretchModes StretchMode {get; set;}
    Remarks
    If not None, the image is sized to fit the display area available to it, whilst retaining its aspect ratio. If None, the image is displayed according to the Zoom and Scroll properties.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / StudyDescription Property

    StudyDescription Property (DicomImage)
    In This Topic
    Description for the study
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property StudyDescription As String
    'Usage

    Dim instance As DicomImage
Dim value As String

instance.StudyDescription = value

value = instance.StudyDescription
    public string StudyDescription {get; set;}

    Property Value

    Study Description
    Remarks

    This property provides human readable descriptions of the Study returned by a query, or relating to an image. It corresponds to attribute (0008, 1030).

    The usefulness is limited by the fact that not all equipment provides these descriptions in its SOP instances, and even if it does, they may not be available through Query/Retrieve. For instance the RSNA CTN (up to and including version 2.8) supports the study description, but fails to index and provide the series description.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / StudyUID Property

    StudyUID Property (DicomImage)
    In This Topic
    Unique identifier for the four levels of the DICOM Query/Retrieve hierarchy
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property StudyUID As String
    'Usage

    Dim instance As DicomImage
Dim value As String

instance.StudyUID = value

value = instance.StudyUID
    public string StudyUID {get; set;}

    Property Value

    The Study UID
    Remarks
    A shortcut for attribute (0020, 000D).
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / Tag Property

    Tag Property (DicomImage)
    In This Topic
    A general purpose Tag for developer use
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property Tag As Object
    'Usage

    Dim instance As DicomImage
Dim value As Object

instance.Tag = value

value = instance.Tag
    public object Tag {get; set;}
    Remarks
    This property is not used by DicomObjects in any way, and is provided purely as a convenience for developers who wish to associate other objects with this object. As an alternative, most of the objects in DicomObjects can have other classes derived from them.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / UnsharpEnhancement Property

    UnsharpEnhancement Property
    UnsharpLength and UnsharpEnhancement, allow use of unsharp masking, as simple method of image edge enhancement
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property UnsharpEnhancement As Single
    'Usage

    Dim instance As DicomImage
Dim value As Single

instance.UnsharpEnhancement = value

value = instance.UnsharpEnhancement
    public float UnsharpEnhancement {get; set;}
    Remarks
    Effectively, a moving average image is created with a filter length of UnsharpLength, and then subtracted from the original image to leave an enhanced image. The relative contributions of the original and averaged images are controlled by UnsharpEnhancement, higher values giving a greater degree of enhancement, but the factors are adjusted so that the pixel values remain unchanged where there are no edges.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / UnsharpLength Property

    UnsharpLength Property
    UnsharpLength and UnsharpEnhancement, allow use of unsharp masking, as simple method of image edge enhancement
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property UnsharpLength As Integer
    'Usage

    Dim instance As DicomImage
Dim value As Integer

instance.UnsharpLength = value

value = instance.UnsharpLength
    public int UnsharpLength {get; set;}
    Remarks
    Effectively, a moving average image is created with a filter length of UnsharpLength, and then subtracted from the original image to leave an enhanced image. The relative contributions of the original and averaged images are controlled by UnsharpEnhancement, higher values giving a greater degree of enhancement, but the factors are adjusted so that the pixel values remain unchanged where there are no edges.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / UserMatrix Property

    UserMatrix Property
    Means to override the matrix used to display 2D images
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property UserMatrix As Nullable(Of SKMatrix)
    'Usage

    Dim instance As DicomImage
Dim value As Nullable(Of SKMatrix)

instance.UserMatrix = value

value = instance.UserMatrix
    public Nullable<SKMatrix> UserMatrix {get; set;}
    Remarks
    There are multiple uses for the display matrix, with numerous matrix overrides, which all ultimately call the CoreMatrix protected function, but there could be special circumstances where the uses wished to override the normal zoom/scroll/rotate behaviour, and if so, then it can be done by setting this property to a non-null value.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / ValidationOptions Property

    ValidationOptions Property (DicomImage)
    In This Topic
    The default DicomObjects.Validation.ValidationOptions to apply to newly created DicomImage objects
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property ValidationOptions As ValidationOptions
    'Usage

    Dim instance As DicomImage
Dim value As ValidationOptions

instance.ValidationOptions = value

value = instance.ValidationOptions
    public ValidationOptions ValidationOptions {get; set;}
    Remarks
    The default value for this default is DicomObjects.Validation.ValidationOptions combined with DicomObjects.Validation.ValidationOptions
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / VoiLUT Property

    VoiLUT Property
    The VOI Lookup Table to be used to display the DicomImage
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property VoiLUT As Short
    'Usage

    Dim instance As DicomImage
Dim value As Short

instance.VoiLUT = value

value = instance.VoiLUT
    public short VoiLUT {get; set;}

    Property Value

    The index of the VOI LUT to use for display
    Remarks

    DICOM allows multiple VOI and presentation Lookup Tables (LUTs) in images, and the user may select whichever they require. These properties provide that choice, and the value 0 may be used to disable the LUT. The value may range from 0 (disabling the LUT) to the number of VOI LUTs in the image. Values beyond the available range are treated as 0.

    The value is initially set to the DefaultVoiLUT property, which if itself having the default value of 1, indicates that the first VOI Lookup Table, if present, should be used.

    See VoiLUTInUse for a mean to tell which VOILUT is actually being used

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / VOILUTFunction Property

    VOILUTFunction Property
    Controls which VOILUT function to be used, default value is Linear
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property VOILUTFunction As VoiLUTFunction
    'Usage

    Dim instance As DicomImage
Dim value As VoiLUTFunction

instance.VOILUTFunction = value

value = instance.VOILUTFunction
    public VoiLUTFunction VOILUTFunction {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / VoiLUTInUse Property

    VoiLUTInUse Property
    Indicates whether a Values of Interest Lookup Table is in use
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property VoiLUTInUse As Short
    'Usage

    Dim instance As DicomImage
Dim value As Short

value = instance.VoiLUTInUse
    public short VoiLUTInUse {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / Width Property

    Width Property (DicomImage)
    In This Topic
    The Window "Width" - which controls the greyscale mapping of a displayed image
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property Width As Single
    'Usage

    Dim instance As DicomImage
Dim value As Single

instance.Width = value

value = instance.Width
    public float Width {get; set;}
    Remarks

    Width and Levels are the parameters that control the grey-scale mapping from the original pixel data to the screen. Following the normal convention, the grey scale ranges from level-width/2 to level+width/2. Note that re-scale values present in some SOP classes are used for the purposes of this mapping, but the native data are not altered, and other operations such as obtaining the Pixels are unaffected.

    Windowing using these values applies now also to colour (RGB, YBR & COLOR PALETTE images, which by default have Width=255 and Level=128)

    These values are initialised from the suggested values in the DICOM data, if present, but if not present, then reasonable initial values are calculated from the pixel data itself.

    These values are regarded as transitory, and therefore, when an image is written, they are not written back into the DICOM data. If this behaviour is required, then code similar to this should be included prior to the write:

    Image.Attributes.Add(&h0028,&h1050), Image.Level Image.Attributes.Add(&h0028,&h1051), Image.Width

    Width and Level are ignored under the following circumstances:

    • When a PresentationState is applied to the image
    • When the image contains a "Values of Interest Lookup Table" (VOILUT), as this takes the place of windowing

    In the later case, the VOI LUT can be ignored (and width and level used), by setting the image�s VOILUT property to 0.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / WidthMultiplier Property

    WidthMultiplier Property
    Provides a means to modify the usage of a Values of Interest Lookup Table (VOI LUT) or other display mapping
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property WidthMultiplier As Single
    'Usage

    Dim instance As DicomImage
Dim value As Single

instance.WidthMultiplier = value

value = instance.WidthMultiplier
    public float WidthMultiplier {get; set;}
    Remarks

    Width and Level are ignored when a VOI LUT is in use (VoiLUTInUse is true), but this property, together with LevelShift provides an alternative means to allow users to have some control over the display without having to disable the VOILUT completely

    The mechanism used is that the entire lookup table is shifted (in original image units) by LevelShift units, then widended or narrowed around its mid-point (where it crosses the mid-point of the output space) by a factor of WidthMultiplier.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / Zoom Property

    Zoom Property
    Controls the magnification of an image display
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property Zoom As Single
    'Usage

    Dim instance As DicomImage
Dim value As Single

instance.Zoom = value

value = instance.Zoom
    public float Zoom {get; set;}
    Remarks

    Together with Scroll, this property determines the display of an image, which is magnified by 'Zoom' relative to an original size which is defined as 1 pixel = 1 screen pixel. This property is ignored if the image's StretchMode property is True.

    In order to find the values used at any given time, even if StretchToFit is true, use the Matrix method to get the ActualZoom which is used in the COM version.

    This property is over-ridden if a PresentationState is applied.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


%%PageItemTitle%% $$Events$$

DicomObjects Namespace / DicomImage Class

    DicomImage Class Events
    In This Topic

    For a list of all members of this type, see DicomImage members.

    Public Events
     | Name | Description
Public Event | PositionChanged | An event which fires when the plane displayed by this image changes.
    Top
    See Also

    Reference

    DicomImage Class
    DicomObjects Namespace


DicomObjects Namespace / DicomImage Class / PositionChanged Event

    PositionChanged Event
    An event which fires when the plane displayed by this image changes.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Event PositionChanged As PositionChangedHandler
    'Usage

    Dim instance As DicomImage
Dim handler As PositionChangedHandler

AddHandler instance.PositionChanged, handler
    public event PositionChangedHandler PositionChanged
    Remarks
    This is used by the DicomLabel objects with type = DicomObjects.Enums.LabelType.ReferenceLine to cause them to update automatically, but is also available for user use - e.g. for updating displayed axes.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / Implicit Type Conversion Operator

DicomImage

    Implicit Type Conversion Operator (DicomImage)
    In This Topic
    Implicit DicomImage to DicomDataSet cast
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Operator Widening CType( _
   ByVal im As DicomImage _
) As DicomDataSet
    'Usage

    public DicomDataSet operator implicit(
   DicomImage im
)

    Parameters

    im

    DicomImage

    Return Value

    DicomDataSet
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


%%PageItemTitle%%

DicomObjects Namespace / DicomImageCollection Class
Members

In This Topic
    DicomImageCollection Class
    In This Topic
    A Collection of DicomImage objects
    Object Model
    DicomImageCollection ClassDicomImage Class
    Syntax
    • Visual Basic
    • C#
    'Declaration

    <DefaultMemberAttribute("Item")>
<DebuggerTypeProxyAttribute(System.Collections.Generic.Mscorlib_CollectionDebugView`1)>
<DebuggerDisplayAttribute("Count = {Count}")>
Public Class DicomImageCollection
   Inherits System.Collections.ObjectModel.Collection(Of DicomImage)
    'Usage

    Dim instance As DicomImageCollection
    [DefaultMember("Item")]
[DebuggerTypeProxy(System.Collections.Generic.Mscorlib_CollectionDebugView`1)]
[DebuggerDisplay("Count = {Count}")]
public class DicomImageCollection : System.Collections.ObjectModel.Collection<DicomImage>
    Inheritance Hierarchy

    System.Object
    System.Collections.ObjectModel.Collection<T>
    DicomObjects.DicomImageCollection

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImageCollection Members
    DicomObjects Namespace


%%PageItemTitle%% $$Members$$

DicomObjects Namespace / DicomImageCollection Class
Properties Methods

In This Topic
    DicomImageCollection Class Members
    In This Topic

    The following tables list the members exposed by DicomImageCollection.

    Public Constructors
     | Name | Description
Public Constructor | DicomImageCollection Constructor | Overloaded.
    Top
    Public Properties
     | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<DicomImage>)
Public Property | Item | Overloaded. Provides access to Image collection item via its InstanceUID
Public Property | Tag | A general purpose Tag for developer use
    Top
    Public Methods
     | Name | Description
Public Method | Add | Overloaded. Adds a DicomImageCollection to a DicomImageCollection
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<DicomImage>)
Public Method | Clone | Returns a Shallow copy of the DicomImageCollection
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<DicomImage>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<DicomImage>)
Public Method | Dispose | Release all resources used by DicomImageCollection
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<DicomImage>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<DicomImage>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<DicomImage>)
Public Method | MakeEnhancedMultiFrame | Creates a single enhanced multi-frame object from a collection of individual images.
Public Method | MakeMultiFrame | Creates a single multi-frame object from a collection of individual images.
Public Method | Move | Moves a DicomImage within a DicomDicomImageCollection.
Public Method | Read | Overloaded. Creates and adds one or more DicomImage objects from an external DICOM file, a byte array, a system IO stream or a collection of external DICOM files.
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<DicomImage>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<DicomImage>)
Public Method | Send | Sends all images within the collection in one association
    Top
    See Also

    Reference

    DicomImageCollection Class
    DicomObjects Namespace


%%PageItemTitle%%

DicomObjects Namespace / DicomImageCollection Class / DicomImageCollection Constructor

In This Topic
    DicomImageCollection Constructor
    In This Topic
    Overload List
    Overload | Description
DicomImageCollection Constructor() | Create a blank DicomImageCollection object
DicomImageCollection Constructor(IEnumerable<DicomImage>) | Create a DicomImageCollection from an enumeration
DicomImageCollection Constructor(IEnumerable<DicomDataSet>) | Create a DicomImageCollection from an enumeration
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImageCollection Class
    DicomImageCollection Members


%%PageItemTitle%%

DicomObjects Namespace / DicomImageCollection Class / DicomImageCollection Constructor / DicomImageCollection Constructor()

In This Topic
    DicomImageCollection Constructor()
    In This Topic
    Create a blank DicomImageCollection object
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Function New()
    'Usage

    Dim instance As New DicomImageCollection()
    public DicomImageCollection()
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImageCollection Class
    DicomImageCollection Members
    Overload List


%%PageItemTitle%%

DicomObjects Namespace / DicomImageCollection Class / DicomImageCollection Constructor / DicomImageCollection Constructor(IEnumerable<DicomImage>)

In This Topic
    DicomImageCollection Constructor(IEnumerable<DicomImage>)
    In This Topic
    Create a DicomImageCollection from an enumeration
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Function New( _
   ByVal Images As IEnumerable(Of DicomImage) _
)
    'Usage

    Dim Images As IEnumerable(Of DicomImage)

Dim instance As New DicomImageCollection(Images)
    public DicomImageCollection(
   IEnumerable<DicomImage> Images
)

    Parameters

    Images
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImageCollection Class
    DicomImageCollection Members
    Overload List


%%PageItemTitle%%

DicomObjects Namespace / DicomImageCollection Class / DicomImageCollection Constructor / DicomImageCollection Constructor(IEnumerable<DicomDataSet>)

In This Topic
    DicomImageCollection Constructor(IEnumerable<DicomDataSet>)
    In This Topic
    Create a DicomImageCollection from an enumeration
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Function New( _
   ByVal DataSets As IEnumerable(Of DicomDataSet) _
)
    'Usage

    Dim DataSets As IEnumerable(Of DicomDataSet)

Dim instance As New DicomImageCollection(DataSets)
    public DicomImageCollection(
   IEnumerable<DicomDataSet> DataSets
)

    Parameters

    DataSets
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImageCollection Class
    DicomImageCollection Members
    Overload List


%%PageItemTitle%% $$Methods$$

DicomObjects Namespace / DicomImageCollection Class

    DicomImageCollection Class Methods
    In This Topic

    For a list of all members of this type, see DicomImageCollection members.

    Public Methods
     | Name | Description
Public Method | Add | Overloaded. Adds a DicomImageCollection to a DicomImageCollection
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<DicomImage>)
Public Method | Clone | Returns a Shallow copy of the DicomImageCollection
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<DicomImage>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<DicomImage>)
Public Method | Dispose | Release all resources used by DicomImageCollection
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<DicomImage>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<DicomImage>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<DicomImage>)
Public Method | MakeEnhancedMultiFrame | Creates a single enhanced multi-frame object from a collection of individual images.
Public Method | MakeMultiFrame | Creates a single multi-frame object from a collection of individual images.
Public Method | Move | Moves a DicomImage within a DicomDicomImageCollection.
Public Method | Read | Overloaded. Creates and adds one or more DicomImage objects from an external DICOM file, a byte array, a system IO stream or a collection of external DICOM files.
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<DicomImage>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<DicomImage>)
Public Method | Send | Sends all images within the collection in one association
    Top
    See Also

    Reference

    DicomImageCollection Class
    DicomObjects Namespace


DicomObjects Namespace / DicomImageCollection Class / Add Method

    Add Method (DicomImageCollection)
    In This Topic
    Adds a DicomImageCollection to a DicomImageCollection
    Overload List
    Overload | Description
Add(IEnumerable<DicomImage>) | Adds a DicomImageCollection to a DicomImageCollection
Add(IEnumerable<DicomDataSet>) | Adds a DicomDataSetCollection to a DicomImageCollection
Add(DicomImage) | (Inherited from System.Collections.ObjectModel.Collection<DicomImage>)
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImageCollection Class
    DicomImageCollection Members


DicomObjects Namespace / DicomImageCollection Class / Add Method / Add(IEnumerable<DicomImage>) Method

The DicomImageCollection to be added to the collection

    Add(IEnumerable<DicomImage>) Method
    In This Topic
    Adds a DicomImageCollection to a DicomImageCollection
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub Add( _
   ByVal value As IEnumerable(Of DicomImage) _
)
    'Usage

    Dim instance As DicomImageCollection
Dim value As IEnumerable(Of DicomImage)

instance.Add(value)
    public void Add(
   IEnumerable<DicomImage> value
)

    Parameters

    value

    The DicomImageCollection to be added to the collection

    Remarks
    Adds a DicomImageCollection to the end of another DicomImageCollection
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImageCollection Class
    DicomImageCollection Members
    Overload List


DicomObjects Namespace / DicomImageCollection Class / Add Method / Add(IEnumerable<DicomDataSet>) Method

The DicomDataSetCollection to be added to the collection

    Add(IEnumerable<DicomDataSet>) Method
    In This Topic
    Adds a DicomDataSetCollection to a DicomImageCollection
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub Add( _
   ByVal value As IEnumerable(Of DicomDataSet) _
)
    'Usage

    Dim instance As DicomImageCollection
Dim value As IEnumerable(Of DicomDataSet)

instance.Add(value)
    public void Add(
   IEnumerable<DicomDataSet> value
)

    Parameters

    value

    The DicomDataSetCollection to be added to the collection

    Remarks
    Similar to adding a DicomDataSet to DicomImageCollection, this method adds a collection of DicomDataSets to the end of a DicomImageCollection.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImageCollection Class
    DicomImageCollection Members
    Overload List


DicomObjects Namespace / DicomImageCollection Class / Clone Method

    Clone Method (DicomImageCollection)
    In This Topic
    Returns a Shallow copy of the DicomImageCollection
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overridable Function Clone() As Object
    'Usage

    Dim instance As DicomImageCollection
Dim value As Object

value = instance.Clone()
    public virtual object Clone()

    Return Value

    DicomImageCollection
    Remarks

    This method makes a Shallow Copy of the DicomImageCollection.

    A shallow copy will only have the top level objects replicated, any referenced objects under top level will be shared by the original DicomImageCollection and the cloned copy.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImageCollection Class
    DicomImageCollection Members


DicomObjects Namespace / DicomImageCollection Class / Dispose Method

    Dispose Method (DicomImageCollection)
    In This Topic
    Release all resources used by DicomImageCollection
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Sub Dispose()
    'Usage

    Dim instance As DicomImageCollection

instance.Dispose()
    public void Dispose()
    Remarks
    Standard Dispose method.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImageCollection Class
    DicomImageCollection Members


DicomObjects Namespace / DicomImageCollection Class / MakeEnhancedMultiFrame Method
True if the images should be removed from the collection after this function call.

In This Topic
    MakeEnhancedMultiFrame Method
    In This Topic
    Creates a single enhanced multi-frame object from a collection of individual images.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Function MakeEnhancedMultiFrame( _
   ByVal Remove As Boolean _
) As DicomImage
    'Usage

    Dim instance As DicomImageCollection
Dim Remove As Boolean
Dim value As DicomImage

value = instance.MakeEnhancedMultiFrame(Remove)
    public DicomImage MakeEnhancedMultiFrame(
   bool Remove
)

    Parameters

    Remove
    True if the images should be removed from the collection after this function call.

    Return Value

    The new DicomImage
    Remarks

    Constructs a single enhanced multi-frame image from a series of identically-sized single frame images, which have been collected into a DicomImageCollection. If the argument is true, the images are removed from the collection as they are added to the new object. Unlike MakeMultiFrame, data is taken from all frames, and incorporated into the Common or PerFrame functional groups, not from the first image only.

    Note that the newly created multi-frame image may need some modifications, as DicomObjects has no knowledge of many attributes which only exist in enhanced images but it does do much of the hard work

    If you find any attributes which you feel should be moved to functional groups but which are not, then please contact support@medicalconnections.co.uk

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImageCollection Class
    DicomImageCollection Members


DicomObjects Namespace / DicomImageCollection Class / MakeMultiFrame Method
True if the images should be removed from the collection after this function call.

In This Topic
    MakeMultiFrame Method
    In This Topic
    Creates a single multi-frame object from a collection of individual images.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Function MakeMultiFrame( _
   ByVal remove As Boolean _
) As DicomImage
    'Usage

    Dim instance As DicomImageCollection
Dim remove As Boolean
Dim value As DicomImage

value = instance.MakeMultiFrame(remove)
    public DicomImage MakeMultiFrame(
   bool remove
)

    Parameters

    remove
    True if the images should be removed from the collection after this function call.

    Return Value

    The new DicomImage
    Remarks

    Constructs a single multi-frame image from a series of identically-sized single frame images, which have been collected into a DicomImageCollection. If the argument is true, the images are removed from the collection as they are added to the new object. Apart from the pixel data, all information is copied from the first image only.

    Note that the newly created multi-frame image may need some modifications, as DicomObjects has no knowledge of the relationship between frames. By default, attributes 0028,0009 & 0018,1063 are set to give a constant 10 frames per second. These may need to be removed/changed.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImageCollection Class
    DicomImageCollection Members


DicomObjects Namespace / DicomImageCollection Class / Move Method

The current index in the collection

The destination index for the image within the collection

In This Topic
    Move Method (DicomImageCollection)
    In This Topic
    Moves a DicomImage within a DicomDicomImageCollection.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Sub Move( _
   ByVal From As Integer, _
   ByVal To As Integer _
)
    'Usage

    Dim instance As DicomImageCollection
Dim From As Integer
Dim To As Integer

instance.Move(From, To)
    public void Move(
   int From,
   int To
)

    Parameters

    From

    The current index in the collection

    To

    The destination index for the image within the collection

    Remarks
    By using Move, Images may be re-ordered within the collection. The Image referred to by the index is placed at the position given by To, other Images are kept in sequence but moved as necessary to accommodate the moved item.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImageCollection Class
    DicomImageCollection Members


DicomObjects Namespace / DicomImageCollection Class / Read Method

    Read Method (DicomImageCollection)
    In This Topic
    Creates and adds one or more DicomImage objects from an external DICOM file, a byte array, a system IO stream or a collection of external DICOM files.
    Overload List
    Overload | Description
Read(String) | Creates and adds a DicomImage from an external DICOM file
Read(Byte[]) | Creates and adds a DicomImage from a byte array
Read(IEnumerable<String>) | Creates and adds DicomImage objects from a collection of external DICOM files
Read(Stream) | Reads a DICOM file from a Stream
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImageCollection Class
    DicomImageCollection Members


DicomObjects Namespace / DicomImageCollection Class / Read Method / Read(String) Method

The name of the file to read.

This is passed unmodified to the operating system, and it is therefore the container’s responsibility to ensure either that the file exists within the current directory, or that a fully qualified filename is provided.

In This Topic
    Read(String) Method
    In This Topic
    Creates and adds a DicomImage from an external DICOM file
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Function Read( _
   ByVal FileName As String _
) As DicomImage
    'Usage

    Dim instance As DicomImageCollection
Dim FileName As String
Dim value As DicomImage

value = instance.Read(FileName)
    public DicomImage Read(
   string FileName
)

    Parameters

    FileName

    The name of the file to read.

    This is passed unmodified to the operating system, and it is therefore the container’s responsibility to ensure either that the file exists within the current directory, or that a fully qualified filename is provided.

    Return Value

    If successful, a DicomImage Object is returned, and is added to the appropriate collection. If unsuccessful, an appropriate error is thrown.
    Remarks

    This method can read either official "Part10" format files with the 128 byte header, or unofficial "Part5" format files without a header. Detection of the type is automatic.

    The file may have been written by the Write method or by other DICOM software.

    By default, pixel data is read only when it is required, greatly speeding the display of multi-frame images, and reducing memory requirements. However, a side effect of this is that any elements after the pixel data (7FE0,0010) will not be read. This should not affect most applications, but if necessary, this behavior may be over-ridden using the CloseFilesAfterReading property.

    Another effect of file mapping is that files read using this method cannot be deleted until the image object is released. This method creates two references to the newly created DicomImage object (one in the collection, and one as the return value), and both must be released before the file can be deleted.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImageCollection Class
    DicomImageCollection Members
    Overload List


DicomObjects Namespace / DicomImageCollection Class / Read Method / Read(Byte[]) Method
Array of Bytes to read

    Read(Byte[]) Method
    In This Topic
    Creates and adds a DicomImage from a byte array
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Function Read( _
   ByVal Array() As Byte _
) As DicomImage
    'Usage

    Dim instance As DicomImageCollection
Dim Array() As Byte
Dim value As DicomImage

value = instance.Read(Array)
    public DicomImage Read(
   byte[] Array
)

    Parameters

    Array
    Array of Bytes to read

    Return Value

    If successful, a DicomImage Object is returned, and is added to the appropriate collection. If unsuccessful, an appropriate error is thrown.
    Remarks
    This method uses memory stream to read a byte array and creates a new DicomImage and adds it to the DicomImageCollection.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImageCollection Class
    DicomImageCollection Members
    Overload List


DicomObjects Namespace / DicomImageCollection Class / Read Method / Read(IEnumerable<String>) Method
A set of filenames as strings

    Read(IEnumerable<String>) Method
    In This Topic
    Creates and adds DicomImage objects from a collection of external DICOM files
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub Read( _
   ByVal FileNames As IEnumerable(Of String) _
)
    'Usage

    Dim instance As DicomImageCollection
Dim FileNames As IEnumerable(Of String)

instance.Read(FileNames)
    public void Read(
   IEnumerable<string> FileNames
)

    Parameters

    FileNames
    A set of filenames as strings
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImageCollection Class
    DicomImageCollection Members
    Overload List


DicomObjects Namespace / DicomImageCollection Class / Read Method / Read(Stream) Method

The Stream from which to read.

In This Topic
    Read(Stream) Method
    In This Topic
    Reads a DICOM file from a Stream
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Function Read( _
   ByVal Stream As Stream _
) As DicomImage
    'Usage

    Dim instance As DicomImageCollection
Dim Stream As Stream
Dim value As DicomImage

value = instance.Read(Stream)
    public DicomImage Read(
   Stream Stream
)

    Parameters

    Stream

    The Stream from which to read.

    Return Value

    If successful, a DicomImage Object is returned, and is added to the appropriate collection. If unsuccessful, an appropriate error is thrown.
    Remarks

    This method can read streams in either official "Part10" format, with the 128 byte header, or unofficial "Part5" format, without a header. Detection of the type is automatic.

    The stream may have been written by the Write method or by other DICOM software.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImageCollection Class
    DicomImageCollection Members
    Overload List


DicomObjects Namespace / DicomImageCollection Class / Send Method
The IP address
The port number
The calling application entity title
The called application entity title

In This Topic
    Send Method (DicomImageCollection)
    In This Topic
    Sends all images within the collection in one association
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Function Send( _
   ByVal Node As String, _
   ByVal Port As Integer, _
   ByVal CallingAE As String, _
   ByVal CalledAE As String _
) As Integer()
    'Usage

    Dim instance As DicomImageCollection
Dim Node As String
Dim Port As Integer
Dim CallingAE As String
Dim CalledAE As String
Dim value() As Integer

value = instance.Send(Node, Port, CallingAE, CalledAE)
    public int[] Send(
   string Node,
   int Port,
   string CallingAE,
   string CalledAE
)

    Parameters

    Node
    The IP address
    Port
    The port number
    CallingAE
    The calling application entity title
    CalledAE
    The called application entity title

    Return Value

    int Array, as status of each image transfer
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImageCollection Class
    DicomImageCollection Members


%%PageItemTitle%% $$Properties$$

DicomObjects Namespace / DicomImageCollection Class

    DicomImageCollection Class Properties
    In This Topic

    For a list of all members of this type, see DicomImageCollection members.

    Public Properties
     | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<DicomImage>)
Public Property | Item | Overloaded. Provides access to Image collection item via its InstanceUID
Public Property | Tag | A general purpose Tag for developer use
    Top
    See Also

    Reference

    DicomImageCollection Class
    DicomObjects Namespace


DicomObjects Namespace / DicomImageCollection Class / Item Property

    Item Property (DicomImageCollection)
    In This Topic
    Provides access to Image collection item via its InstanceUID
    The default indexer of collection object
    Overload List
    Overload | Description
Item(String) | Provides access to Image collection item via its InstanceUID
Item(Int32) | (Inherited from System.Collections.ObjectModel.Collection<DicomImage>)
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImageCollection Class
    DicomImageCollection Members


DicomObjects Namespace / DicomImageCollection Class / Item Property / Item(String) Property

    Item(String) Property
    Provides access to Image collection item via its InstanceUID
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads ReadOnly Property Item( _
   ByVal InstanceUID As String _
) As DicomImage
    'Usage

    Dim instance As DicomImageCollection
Dim InstanceUID As String
Dim value As DicomImage

value = instance.Item(InstanceUID)
    public DicomImage Item(
   string InstanceUID
) {get;}

    Parameters

    InstanceUID
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImageCollection Class
    DicomImageCollection Members
    Overload List


DicomObjects Namespace / DicomImageCollection Class / Tag Property

    Tag Property (DicomImageCollection)
    In This Topic
    A general purpose Tag for developer use
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property Tag As Object
    'Usage

    Dim instance As DicomImageCollection
Dim value As Object

instance.Tag = value

value = instance.Tag
    public object Tag {get; set;}
    Remarks
    This property is not used by DicomObjects in any way, and is provided purely as a convenience for developers who wish to associate other objects with this object. As an alternative, most of the objects in DicomObjects can have other classes derived from them.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImageCollection Class
    DicomImageCollection Members


%%PageItemTitle%%

DicomObjects Namespace / DicomLabel Class
Members

In This Topic
    DicomLabel Class
    In This Topic
    A label, or annotation, to be displayed over an image in a DicomViewer control, or in derived copies of the image.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    <SerializableAttribute()>
Public Class DicomLabel
    'Usage

    Dim instance As DicomLabel
    [Serializable()]
public class DicomLabel
    Remarks

    Labels may be ellipses (or circles), rectangles (or squares), lines, text or bitmaps, or other shapes (see LabelType for a full list), and the properties control not only the type and size of the object, but many other properties such as colour and line thickness.

    Labels may be tied to the viewer control, to the display area in which an image is displayed, or to the image itself, this latter distinction being controlled by the ScaleMode property.

    All properties have default values, which are suitable for many uses, and each is documented with the appropriate property. The same label may be added into several DicomLabelCollections if necessary, but where this is done, subsequent labels will be “cloned” when added, so that they may later be manipulated independently. Also, unambiguous association of each DicomLabel with one image is necessary for the ROI functions.

    An arc is defined as if it were an ellipse using top, left, height and width, but the first two items of the Points collection are used to define the start and end (working anti-clockwise)

    There will be a separate help topic for Special Labels.

    Inheritance Hierarchy

    System.Object
    DicomObjects.DicomLabel

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLabel Members
    DicomObjects Namespace


%%PageItemTitle%% $$Members$$

DicomObjects Namespace / DicomLabel Class
Properties Methods Events

In This Topic
    DicomLabel Class Members
    In This Topic

    The following tables list the members exposed by DicomLabel.

    Public Constructors
     | Name | Description
Public Constructor | DicomLabel Constructor | Creates a new blank DicomLabel object
    Top
    Public Properties
     | Name | Description
Public Property | Anchor | A pair of coordinates (x, y) of an visible anchor point for a text label
Public Property | AnchorScaleMode | Defines how anchor point is transformed with the image
Public Property | Angle | Angle to rotate Label (Clockwise)
Public Property | Area | The 4 edges of the SKRectI area of the DicomLabel
Public Property | AutoSizeMode | Controls the size of a text label.
Public Property | BoundingBox | Area that encloses the label as displayed
Public Property | Font | The SKFont to be used for text labels
Public Property | ForeColor | Contains the fore colour of DicomLabel depending on the LabelType whether the shape or text colour This is a shortcut for Paint.Color
Public Property | FrameList | List of Frames you want to display the DicomLabel on. Empty FrameList is default value and it means display on all frames.
Public Property | Height | Define the height of a DicomLabel (annotation) on an image
Public Property | Image | The Image to be displayed by an Image type DicomLabel
Public Property | ImageOpacity | Controls the opacity of the Image label. Only applicable to Image type. Value ranges from 0-1 (None to Full opacity)
static (Shared in Visual Basic) | ImportedLabelType | The type of label created by DicomObjects from Presentation states
Public Property | IncludeInPresentationState | This property controls whether the DicomLabel goes into the PresentationState or not when one of the CurrentToPresentationState methods is used.
Public Property | IsInterpolated | Specify if the DicomLabel is Interpolated
Public Property | IsShutter | This property decides whether or not the DicomLabel will be acting as a Shutter.
Public Property | LabelType | Determines the basic type of a label
Public Property | Left | Define the left of a DicomLabel (annotation) on an image
Public Property | Margin | Defines a margin between text and it’s bounding box
Public Property | MinArrowSize | Specify the minimum Arrow size when the labeltype is set to LabelArrow
Public Property | Paint | Information about the style and color that is used to draw the different LabelTypes
Public Property | Points | The points of a DicomLabel (of type PolyLine or Polygon)
Public Property | RefImage | The image whose plane is used to control the placement of this image, as a line.
Public Property | RotationCentre | Controls the centre of rotation of a text label.
Public Property | RotationMode | Controls the rotation behaviour of a label.
Public Property | RotationPoint | Defines the centre point used for label rotation (whether due to Angle or as a result of RotationMode) if the RotationCentre is set to SpecifiedPoint
Public Property | RulerOptions | Ruler options used if LabelType is set to Ruler
Public Property | RulerSpacing | Controls the approximate spacing of the minor ticks for a ruler label
Public Property | ScaleFontSize | Determines whether the SKFont size scales with the image
Public Property | ScaleMode | Defines a basic scale mode of DicomLabel
Public Property | ScaleStrokeWidth | Control whether the width of a line scales with the label being drawn
Public Property | SelectMode | Controls whether a label is highlighted using a box and/or “handles”
Public Property | Shadow | Controls whether a label is displayed with a contrasting shadow, to make it more visible over image areas with the same colour.
Public Property | ShadowColor | Contains the colour of the Shadow applied to the DicomLabel
Public Property | ShowAnchor | Determines whether the anchor point is shown
Public Property | ShowTextBox | Controls whether text boxes have a visible border
static (Shared in Visual Basic) | SKFonts | A Static SKFont collection. Users can define and add their list of SKFonts and choose which to apply to each DicomLabel object using DicomLabel's SKFontIndex property.
Public Property | StartAngle | Starting angle (in degrees) where the arc begins used by SkiaSharp
Public Property | SweepAngle | Sweep angle (in degrees) measured clockwise used by SkiaSharp
Public Property | Tag | A general purpose Tag for developer use
Public Property | Text | The text to be displayed by a text type DicomLabel
Public Property | Top | Define the top of a DicomLabel (annotation) on an image
Public Property | Visible | Controls whether a DicomLabel object is displayed
Public Property | Width | Define the width of a DicomLabel (annotation) on an image
    Top
    Public Methods
     | Name | Description
Public Method | AddPoint | Overloaded. Adds to point to the path used for a polyline or polygon type of DicomLabel
Public Method | ClipTo | Limits a line to the section within a given rectangle
Public Method | Clone | Clones the DicomLabel
Public Method | OnExport | Allows control of Export of objects derived from a DicomLabel
Public Method | OnImport | Allows control of Import of objects derived from a DicomLabel
Public Method | ROIMax | Returns the maximum values of the pixels in the ROI
Public Method | ROIMean | Returns the mean value of the pixels in the ROI
Public Method | ROIMin | Returns the minimum values of the pixels in the ROI
Public Method | ROIPoints | The list of points within the label
Public Method | ROIStandardDeviation | Returns the standard deviation of the values of the pixels in the ROI
Public Method | ROIValues | The values within a DicomLabel, interpreted as a region of interest
Public Method | ScaledAngle | Returns the line angle of the DicomLabel. Image Pixel Aspect Ratio is automatically taken into account.
Public Method | Threshold | Makes a bitmap label by thresholding an existing label
Public Method | Transform | Adjusts the position, size etc. of the label
Public Method | Update | Force display update for this label
    Top
    Public Events
     | Name | Description
Public Event | LabelChanged | Event fired when the properties of a label are changed.
Public Event | PSLabelCreated | Event fires when a new DicomLabel is created when a Presentation State is applied to an image. This event gives users a chance to customise the label before display
    Top
    See Also

    Reference

    DicomLabel Class
    DicomObjects Namespace


%%PageItemTitle%%

DicomObjects Namespace / DicomLabel Class / DicomLabel Constructor

In This Topic
    DicomLabel Constructor
    In This Topic
    Creates a new blank DicomLabel object
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Function New()
    'Usage

    Dim instance As New DicomLabel()
    public DicomLabel()
    Remarks
    The default LabelType value is LabelType.Text
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLabel Class
    DicomLabel Members


%%PageItemTitle%% $$Methods$$

DicomObjects Namespace / DicomLabel Class

    DicomLabel Class Methods
    In This Topic

    For a list of all members of this type, see DicomLabel members.

    Public Methods
     | Name | Description
Public Method | AddPoint | Overloaded. Adds to point to the path used for a polyline or polygon type of DicomLabel
Public Method | ClipTo | Limits a line to the section within a given rectangle
Public Method | Clone | Clones the DicomLabel
Public Method | OnExport | Allows control of Export of objects derived from a DicomLabel
Public Method | OnImport | Allows control of Import of objects derived from a DicomLabel
Public Method | ROIMax | Returns the maximum values of the pixels in the ROI
Public Method | ROIMean | Returns the mean value of the pixels in the ROI
Public Method | ROIMin | Returns the minimum values of the pixels in the ROI
Public Method | ROIPoints | The list of points within the label
Public Method | ROIStandardDeviation | Returns the standard deviation of the values of the pixels in the ROI
Public Method | ROIValues | The values within a DicomLabel, interpreted as a region of interest
Public Method | ScaledAngle | Returns the line angle of the DicomLabel. Image Pixel Aspect Ratio is automatically taken into account.
Public Method | Threshold | Makes a bitmap label by thresholding an existing label
Public Method | Transform | Adjusts the position, size etc. of the label
Public Method | Update | Force display update for this label
    Top
    See Also

    Reference

    DicomLabel Class
    DicomObjects Namespace


DicomObjects Namespace / DicomLabel Class / AddPoint Method

    AddPoint Method
    Adds to point to the path used for a polyline or polygon type of DicomLabel
    Overload List
    Overload | Description
AddPoint(Single,Single) | Adds to point to the path used for a polyline or polygon type of DicomLabel.
AddPoint(SKPoint) | Adds to point to the path used for a polyline or polygon type of DicomLabel.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLabel Class
    DicomLabel Members


DicomObjects Namespace / DicomLabel Class / AddPoint Method / AddPoint(Single,Single) Method
The X co-ordinates of the point to add.
The Y co-ordinates of the point to add.

In This Topic
    AddPoint(Single,Single) Method
    In This Topic
    Adds to point to the path used for a polyline or polygon type of DicomLabel.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub AddPoint( _
   ByVal X As Single, _
   ByVal Y As Single _
)
    'Usage

    Dim instance As DicomLabel
Dim X As Single
Dim Y As Single

instance.AddPoint(X, Y)
    public void AddPoint(
   float X,
   float Y
)

    Parameters

    X
    The X co-ordinates of the point to add.
    Y
    The Y co-ordinates of the point to add.
    Remarks

    This method only affects Label objects where the LabelType is Polygon or PolyLine.

    The points are scaled and moved exactly as are Top, Left, Width & Height, i.e. if used a part of a DicomViewer’s Labels collection or if ImageTied is false, then they are display pixels, but ImageTied is true, and used as part of a DicomImage’s Labels collection, then they are scaled and scrolled with the image pixels, ensuring that the shape produced maintains an exact relationship to the underlying image.

    After points have been added, they may be accessed through the Points property, which may also be used to set the whole array in a single operation.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLabel Class
    DicomLabel Members
    Overload List


DicomObjects Namespace / DicomLabel Class / AddPoint Method / AddPoint(SKPoint) Method
The point to add

    AddPoint(SKPoint) Method
    In This Topic
    Adds to point to the path used for a polyline or polygon type of DicomLabel.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub AddPoint( _
   ByVal point As SkiaSharp.SKPoint _
)
    'Usage

    Dim instance As DicomLabel
Dim point As SkiaSharp.SKPoint

instance.AddPoint(point)
    public void AddPoint(
   SkiaSharp.SKPoint point
)

    Parameters

    point
    The point to add
    Remarks

    This method only affects Label objects where the LabelType is Polygon or PolyLine.

    The points are scaled and moved exactly as are Top, Left, Width & Height, i.e. if used a part of a DicomViewer’s Labels collection or if ImageTied is false, then they are display pixels, but ImageTied is true, and used as part of a DicomImage’s Labels collection, then they are scaled and scrolled with the image pixels, ensuring that the shape produced maintains an exact relationship to the underlying image.

    After points have been added, they may be accessed through the Points property, which may also be used to set the whole array in a single operation.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLabel Class
    DicomLabel Members
    Overload List


DicomObjects Namespace / DicomLabel Class / ClipTo Method
The area to clip to

    ClipTo Method
    In This Topic
    Limits a line to the section within a given rectangle
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Sub ClipTo( _
   ByVal SKRectI As SkiaSharp.SKRect _
)
    'Usage

    Dim instance As DicomLabel
Dim SKRectI As SkiaSharp.SKRect

instance.ClipTo(SKRectI)
    public void ClipTo(
   SkiaSharp.SKRect SKRectI
)

    Parameters

    SKRectI
    The area to clip to
    Remarks
    Although the type of the label is not explicitly checked (as the mehod merely changes the Area property, in practice it only makes sense to use this method for labels of type Line
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLabel Class
    DicomLabel Members


DicomObjects Namespace / DicomLabel Class / Clone Method

    Clone Method (DicomLabel)
    In This Topic
    Clones the DicomLabel
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overridable Function Clone() As DicomLabel
    'Usage

    Dim instance As DicomLabel
Dim value As DicomLabel

value = instance.Clone()
    public virtual DicomLabel Clone()

    Return Value

    A cloned copy
    Remarks
    A complete cloned copy is created.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLabel Class
    DicomLabel Members


DicomObjects Namespace / DicomLabel Class / OnExport Method
The DicomDataset within the presentation state representing this particular label
The UsePrivate parameter from CurrentToPresentationState .

In This Topic
    OnExport Method
    In This Topic
    Allows control of Export of objects derived from a DicomLabel
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overridable Sub OnExport( _
   ByVal LabelDataSet As DicomDataSet, _
   ByVal UsePrivate As Boolean _
)
    'Usage

    Dim instance As DicomLabel
Dim LabelDataSet As DicomDataSet
Dim UsePrivate As Boolean

instance.OnExport(LabelDataSet, UsePrivate)
    public virtual void OnExport(
   DicomDataSet LabelDataSet,
   bool UsePrivate
)

    Parameters

    LabelDataSet
    The DicomDataset within the presentation state representing this particular label
    UsePrivate
    The UsePrivate parameter from CurrentToPresentationState .
    Remarks
    This routine is called afterDicomObjects has added its own private attributes
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLabel Class
    DicomLabel Members


DicomObjects Namespace / DicomLabel Class / OnImport Method
The DicomDataset within the presentation state representing this particular label

In This Topic
    OnImport Method
    In This Topic
    Allows control of Import of objects derived from a DicomLabel
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overridable Sub OnImport( _
   ByVal LabelDataSet As DicomDataSet _
)
    'Usage

    Dim instance As DicomLabel
Dim LabelDataSet As DicomDataSet

instance.OnImport(LabelDataSet)
    public virtual void OnImport(
   DicomDataSet LabelDataSet
)

    Parameters

    LabelDataSet
    The DicomDataset within the presentation state representing this particular label
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLabel Class
    DicomLabel Members


DicomObjects Namespace / DicomLabel Class / ROIMax Method
The image from which the pixel data is taken for the calculations
If true, then the rescale slope and offset are applied to the data values

In This Topic
    ROIMax Method
    In This Topic
    Returns the maximum values of the pixels in the ROI
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Function ROIMax( _
   ByVal Image As DicomImage, _
   ByVal Scale As Boolean _
) As Double
    'Usage

    Dim instance As DicomLabel
Dim Image As DicomImage
Dim Scale As Boolean
Dim value As Double

value = instance.ROIMax(Image, Scale)
    public double ROIMax(
   DicomImage Image,
   bool Scale
)

    Parameters

    Image
    The image from which the pixel data is taken for the calculations
    Scale
    If true, then the rescale slope and offset are applied to the data values

    Return Value

    The maximum value
    Remarks
    This property, where rescale parameters are used (e.g. for CT) it is applied to the pixel values automatically before the statistical values are calculated.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLabel Class
    DicomLabel Members


DicomObjects Namespace / DicomLabel Class / ROIMean Method
The image from which the pixel data is taken for the calculations
If true, then the rescale slope and offset are applied to the data values

In This Topic
    ROIMean Method
    In This Topic
    Returns the mean value of the pixels in the ROI
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Function ROIMean( _
   ByVal Image As DicomImage, _
   ByVal Scale As Boolean _
) As Double
    'Usage

    Dim instance As DicomLabel
Dim Image As DicomImage
Dim Scale As Boolean
Dim value As Double

value = instance.ROIMean(Image, Scale)
    public double ROIMean(
   DicomImage Image,
   bool Scale
)

    Parameters

    Image
    The image from which the pixel data is taken for the calculations
    Scale
    If true, then the rescale slope and offset are applied to the data values

    Return Value

    The mean value of the pixels in the ROI
    Remarks
    This method may only be used for DicomLabels of type SKRectI, Ellipse, Polygon or Bitmap.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLabel Class
    DicomLabel Members


DicomObjects Namespace / DicomLabel Class / ROIMin Method
The image from which the pixel data is taken for the calculations
If true, then the rescale slope and offset are applied to the data values

In This Topic
    ROIMin Method
    In This Topic
    Returns the minimum values of the pixels in the ROI
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Function ROIMin( _
   ByVal Image As DicomImage, _
   ByVal Scale As Boolean _
) As Double
    'Usage

    Dim instance As DicomLabel
Dim Image As DicomImage
Dim Scale As Boolean
Dim value As Double

value = instance.ROIMin(Image, Scale)
    public double ROIMin(
   DicomImage Image,
   bool Scale
)

    Parameters

    Image
    The image from which the pixel data is taken for the calculations
    Scale
    If true, then the rescale slope and offset are applied to the data values

    Return Value

    The minimum value
    Remarks
    This property, where rescale parameters are used (e.g. for CT) it is applied to the pixel values automatically before the statistical values are calculated.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLabel Class
    DicomLabel Members


DicomObjects Namespace / DicomLabel Class / ROIPoints Method
The image to which to which the label is being applied.

In This Topic
    ROIPoints Method
    In This Topic
    The list of points within the label
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Function ROIPoints( _
   ByVal Image As DicomImage _
) As SkiaSharp.SKPoint()
    'Usage

    Dim instance As DicomLabel
Dim Image As DicomImage
Dim value() As SkiaSharp.SKPoint

value = instance.ROIPoints(Image)
    public SkiaSharp.SKPoint[] ROIPoints(
   DicomImage Image
)

    Parameters

    Image
    The image to which to which the label is being applied.

    Return Value

    Array of SKPoint values
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLabel Class
    DicomLabel Members


DicomObjects Namespace / DicomLabel Class / ROIStandardDeviation Method
The image from which the pixel data is taken for the calculations
If true, then the rescale slope and offset are applied to the data values

In This Topic
    ROIStandardDeviation Method
    In This Topic
    Returns the standard deviation of the values of the pixels in the ROI
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Function ROIStandardDeviation( _
   ByVal Image As DicomImage, _
   ByVal Scale As Boolean _
) As Double
    'Usage

    Dim instance As DicomLabel
Dim Image As DicomImage
Dim Scale As Boolean
Dim value As Double

value = instance.ROIStandardDeviation(Image, Scale)
    public double ROIStandardDeviation(
   DicomImage Image,
   bool Scale
)

    Parameters

    Image
    The image from which the pixel data is taken for the calculations
    Scale
    If true, then the rescale slope and offset are applied to the data values

    Return Value

    The standard deviation
    Remarks
    ROIStandardDeviation returns the standard deviation of the values of the pixels in the ROI
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLabel Class
    DicomLabel Members


DicomObjects Namespace / DicomLabel Class / ROIValues Method
The image from which the pixel data is taken for the calculations
If true, then the rescale slope and offset are applied to the data values

In This Topic
    ROIValues Method
    In This Topic
    The values within a DicomLabel, interpreted as a region of interest
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Function ROIValues( _
   ByVal Image As DicomImage, _
   ByVal Scale As Boolean _
) As Single()
    'Usage

    Dim instance As DicomLabel
Dim Image As DicomImage
Dim Scale As Boolean
Dim value() As Single

value = instance.ROIValues(Image, Scale)
    public float[] ROIValues(
   DicomImage Image,
   bool Scale
)

    Parameters

    Image
    The image from which the pixel data is taken for the calculations
    Scale
    If true, then the rescale slope and offset are applied to the data values

    Return Value

    Array of floats
    Remarks

    This property may only be used for DicomLabels of type SKRectI, Ellipse, Polygon or Bitmap.

    Where rescale parameters are used (e.g. for CT) they are applied to the pixel values automatically before returning these values.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLabel Class
    DicomLabel Members


DicomObjects Namespace / DicomLabel Class / ScaledAngle Method
The Image where the Label is drawn on

    ScaledAngle Method
    In This Topic
    Returns the line angle of the DicomLabel. Image Pixel Aspect Ratio is automatically taken into account.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Function ScaledAngle( _
   ByVal img As DicomImage _
) As Single
    'Usage

    Dim instance As DicomLabel
Dim img As DicomImage
Dim value As Single

value = instance.ScaledAngle(img)
    public float ScaledAngle(
   DicomImage img
)

    Parameters

    img
    The Image where the Label is drawn on

    Return Value

    The angle of the line
    Remarks
    The angle returned is measued counterclockwise from a line pointing to the right, and uses the range -π to +π (equivalent to -180º to +180º)
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLabel Class
    DicomLabel Members


DicomObjects Namespace / DicomLabel Class / Threshold Method
The minimum value to include in the new DicomLabel
The maximum value to include in the new DicomLabel
The image from which the pixel data is taken for the calculations
If true, then the rescale slope and offset are applied to the data values

In This Topic
    Threshold Method
    In This Topic
    Makes a bitmap label by thresholding an existing label
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Function Threshold( _
   ByVal Min As Single, _
   ByVal Max As Single, _
   ByVal Image As DicomImage, _
   ByVal Scale As Boolean _
) As DicomLabel
    'Usage

    Dim instance As DicomLabel
Dim Min As Single
Dim Max As Single
Dim Image As DicomImage
Dim Scale As Boolean
Dim value As DicomLabel

value = instance.Threshold(Min, Max, Image, Scale)
    public DicomLabel Threshold(
   float Min,
   float Max,
   DicomImage Image,
   bool Scale
)

    Parameters

    Min
    The minimum value to include in the new DicomLabel
    Max
    The maximum value to include in the new DicomLabel
    Image
    The image from which the pixel data is taken for the calculations
    Scale
    If true, then the rescale slope and offset are applied to the data values

    Return Value

    A new DicomLabel
    Remarks

    The DicomLabel to which this method is applied must be of a type which defines an area, i.e. SKRectI, Ellipse, Polygon, or Bitmap.

    The result is a new label (unattached to any collection) of type Bitmap, which consists of all those points in the original label whose values (after applying scaling if necessary) fall with the range Min to Max inclusive.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLabel Class
    DicomLabel Members


DicomObjects Namespace / DicomLabel Class / Transform(SKMatrix) Method
The SKMatrix object to use to transform the label

    Transform(SKMatrix) Method
    In This Topic
    Adjusts the position, size etc. of the label
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Sub Transform( _
   ByVal SKMatrix As SkiaSharp.SKMatrix _
)
    'Usage

    Dim instance As DicomLabel
Dim SKMatrix As SkiaSharp.SKMatrix

instance.Transform(SKMatrix)
    public void Transform(
   SkiaSharp.SKMatrix SKMatrix
)

    Parameters

    SKMatrix
    The SKMatrix object to use to transform the label

    Return Value

    void
    Remarks
    The Area and Points properties are both transformed acccording the values in the SKMatrix
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLabel Class
    DicomLabel Members


DicomObjects Namespace / DicomLabel Class / Update Method

    Update Method (DicomLabel)
    In This Topic
    Force display update for this label
    Force display update for this label
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Sub Update()
    'Usage

    Dim instance As DicomLabel

instance.Update()
    public void Update()
    Remarks
    This method is useful when elements or properties of a DicomLabel have been altered, (e.g. the items in the Points array, as the label receives no other notification that these have changed, preventing the normal update mechanism from occurring.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLabel Class
    DicomLabel Members


%%PageItemTitle%% $$Properties$$

DicomObjects Namespace / DicomLabel Class

    DicomLabel Class Properties
    In This Topic

    For a list of all members of this type, see DicomLabel members.

    Public Properties
     | Name | Description
Public Property | Anchor | A pair of coordinates (x, y) of an visible anchor point for a text label
Public Property | AnchorScaleMode | Defines how anchor point is transformed with the image
Public Property | Angle | Angle to rotate Label (Clockwise)
Public Property | Area | The 4 edges of the SKRectI area of the DicomLabel
Public Property | AutoSizeMode | Controls the size of a text label.
Public Property | BoundingBox | Area that encloses the label as displayed
Public Property | Font | The SKFont to be used for text labels
Public Property | ForeColor | Contains the fore colour of DicomLabel depending on the LabelType whether the shape or text colour This is a shortcut for Paint.Color
Public Property | FrameList | List of Frames you want to display the DicomLabel on. Empty FrameList is default value and it means display on all frames.
Public Property | Height | Define the height of a DicomLabel (annotation) on an image
Public Property | Image | The Image to be displayed by an Image type DicomLabel
Public Property | ImageOpacity | Controls the opacity of the Image label. Only applicable to Image type. Value ranges from 0-1 (None to Full opacity)
static (Shared in Visual Basic) | ImportedLabelType | The type of label created by DicomObjects from Presentation states
Public Property | IncludeInPresentationState | This property controls whether the DicomLabel goes into the PresentationState or not when one of the CurrentToPresentationState methods is used.
Public Property | IsInterpolated | Specify if the DicomLabel is Interpolated
Public Property | IsShutter | This property decides whether or not the DicomLabel will be acting as a Shutter.
Public Property | LabelType | Determines the basic type of a label
Public Property | Left | Define the left of a DicomLabel (annotation) on an image
Public Property | Margin | Defines a margin between text and it’s bounding box
Public Property | MinArrowSize | Specify the minimum Arrow size when the labeltype is set to LabelArrow
Public Property | Paint | Information about the style and color that is used to draw the different LabelTypes
Public Property | Points | The points of a DicomLabel (of type PolyLine or Polygon)
Public Property | RefImage | The image whose plane is used to control the placement of this image, as a line.
Public Property | RotationCentre | Controls the centre of rotation of a text label.
Public Property | RotationMode | Controls the rotation behaviour of a label.
Public Property | RotationPoint | Defines the centre point used for label rotation (whether due to Angle or as a result of RotationMode) if the RotationCentre is set to SpecifiedPoint
Public Property | RulerOptions | Ruler options used if LabelType is set to Ruler
Public Property | RulerSpacing | Controls the approximate spacing of the minor ticks for a ruler label
Public Property | ScaleFontSize | Determines whether the SKFont size scales with the image
Public Property | ScaleMode | Defines a basic scale mode of DicomLabel
Public Property | ScaleStrokeWidth | Control whether the width of a line scales with the label being drawn
Public Property | SelectMode | Controls whether a label is highlighted using a box and/or “handles”
Public Property | Shadow | Controls whether a label is displayed with a contrasting shadow, to make it more visible over image areas with the same colour.
Public Property | ShadowColor | Contains the colour of the Shadow applied to the DicomLabel
Public Property | ShowAnchor | Determines whether the anchor point is shown
Public Property | ShowTextBox | Controls whether text boxes have a visible border
static (Shared in Visual Basic) | SKFonts | A Static SKFont collection. Users can define and add their list of SKFonts and choose which to apply to each DicomLabel object using DicomLabel's SKFontIndex property.
Public Property | StartAngle | Starting angle (in degrees) where the arc begins used by SkiaSharp
Public Property | SweepAngle | Sweep angle (in degrees) measured clockwise used by SkiaSharp
Public Property | Tag | A general purpose Tag for developer use
Public Property | Text | The text to be displayed by a text type DicomLabel
Public Property | Top | Define the top of a DicomLabel (annotation) on an image
Public Property | Visible | Controls whether a DicomLabel object is displayed
Public Property | Width | Define the width of a DicomLabel (annotation) on an image
    Top
    See Also

    Reference

    DicomLabel Class
    DicomObjects Namespace


DicomObjects Namespace / DicomLabel Class / Anchor Property

    Anchor Property
    A pair of coordinates (x, y) of an visible anchor point for a text label
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property Anchor As SkiaSharp.SKPoint
    'Usage

    Dim instance As DicomLabel
Dim value As SkiaSharp.SKPoint

instance.Anchor = value

value = instance.Anchor
    public SkiaSharp.SKPoint Anchor {get; set;}
    Remarks

    Anchor comprises the x and y coordinates, which are now floating numbers in .NET version, and only applies to text labels.

    If ShowAnchor is true, then a line is drawn from the border of the text label to a point in the image indicated by these coordinates.

    If AnchorScaleMode is set to Image, then the anchor point is transformed with the image exactly the same way that the label itself is if ScaleMode is set to Image.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLabel Class
    DicomLabel Members


DicomObjects Namespace / DicomLabel Class / AnchorScaleMode Property

    AnchorScaleMode Property
    Defines how anchor point is transformed with the image
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property AnchorScaleMode As ScaleMode
    'Usage

    Dim instance As DicomLabel
Dim value As ScaleMode

instance.AnchorScaleMode = value

value = instance.AnchorScaleMode
    public ScaleMode AnchorScaleMode {get; set;}
    Remarks

    Check LabelScaleMode for possible values of AnchorScaleMode.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLabel Class
    DicomLabel Members


DicomObjects Namespace / DicomLabel Class / Angle Property

    Angle Property (DicomLabel)
    In This Topic
    Angle to rotate Label (Clockwise)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property Angle As Single
    'Usage

    Dim instance As DicomLabel
Dim value As Single

instance.Angle = value

value = instance.Angle
    public float Angle {get; set;}
    Remarks

    The label is rotated around its centre after any transformations due to ImageTied have been applied.

    This property only applies to labels of type rectangle, ellipse and text

    If RotateTextWithImage is true, and the label is of type text, then:

    • For display, this angle is added to the rotation of the image.
    • This angle is modified when Rescale is called, so as to preserve the relationship between the text and the image
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLabel Class
    DicomLabel Members


DicomObjects Namespace / DicomLabel Class / Area Property

    Area Property (DicomLabel)
    In This Topic
    The 4 edges of the SKRectI area of the DicomLabel
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property Area As SkiaSharp.SKRect
    'Usage

    Dim instance As DicomLabel
Dim value As SkiaSharp.SKRect

instance.Area = value

value = instance.Area
    public SkiaSharp.SKRect Area {get; set;}
    Remarks
    Coordinates of the corner points are returned as Floating numbers.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLabel Class
    DicomLabel Members


DicomObjects Namespace / DicomLabel Class / AutoSizeMode Property

    AutoSizeMode Property
    Controls the size of a text label.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property AutoSizeMode As AutoSizeMode
    'Usage

    Dim instance As DicomLabel
Dim value As AutoSizeMode

instance.AutoSizeMode = value

value = instance.AutoSizeMode
    public AutoSizeMode AutoSizeMode {get; set;}
    Remarks
    This is used to control both the drawing of a visible box around the text if ShowTextBox is true. It is also used for rotation if RotationCentre is set to RotationCentre.AutoSizeCentre
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLabel Class
    DicomLabel Members


DicomObjects Namespace / DicomLabel Class / BoundingBox Property

    BoundingBox Property
    Area that encloses the label as displayed
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property BoundingBox As SkiaSharp.SKRect
    'Usage

    Dim instance As DicomLabel
Dim value As SkiaSharp.SKRect

value = instance.BoundingBox
    public SkiaSharp.SKRect BoundingBox {get;}
    Remarks
    For labels of type Polygon and PolyLine this returns the bounding box of the Points collection, but for other labels, it returns the same as Area
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLabel Class
    DicomLabel Members


DicomObjects Namespace / DicomLabel Class / Font Property

    Font Property
    The SKFont to be used for text labels
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property Font As SkiaSharp.SKFont
    'Usage

    Dim instance As DicomLabel
Dim value As SkiaSharp.SKFont

instance.Font = value

value = instance.Font
    public SkiaSharp.SKFont Font {get; set;}
    Remarks

    This property is only relevant where LabelType is doLabelText or doLabelSpecial.

    Use SKFont.Name and SKFont.Size to change the SKFont properties.

    The default SKFont name is System.SKFont and default size is 12.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLabel Class
    DicomLabel Members


DicomObjects Namespace / DicomLabel Class / ForeColor Property

    ForeColor Property
    Contains the fore colour of DicomLabel depending on the LabelType whether the shape or text colour This is a shortcut for Paint.Color
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property ForeColor As SkiaSharp.SKColor
    'Usage

    Dim instance As DicomLabel
Dim value As SkiaSharp.SKColor

instance.ForeColor = value

value = instance.ForeColor
    public SkiaSharp.SKColor ForeColor {get; set;}
    Remarks
    This is a shortcut for Paint.Color
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLabel Class
    DicomLabel Members


DicomObjects Namespace / DicomLabel Class / FrameList Property

    FrameList Property
    List of Frames you want to display the DicomLabel on. Empty FrameList is default value and it means display on all frames.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property FrameList As List(Of Integer)
    'Usage

    Dim instance As DicomLabel
Dim value As List(Of Integer)

value = instance.FrameList
    public List<int> FrameList {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLabel Class
    DicomLabel Members


DicomObjects Namespace / DicomLabel Class / Height Property

    Height Property
    Define the height of a DicomLabel (annotation) on an image
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property Height As Single
    'Usage

    Dim instance As DicomLabel
Dim value As Single

instance.Height = value

value = instance.Height
    public float Height {get; set;}
    Remarks
    Equivalent to Area.Height. Remained in .NET version for backward compatibility.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLabel Class
    DicomLabel Members


DicomObjects Namespace / DicomLabel Class / Image Property

    Image Property (DicomLabel)
    In This Topic
    The Image to be displayed by an Image type DicomLabel
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property Image As SkiaSharp.SKBitmap
    'Usage

    Dim instance As DicomLabel
Dim value As SkiaSharp.SKBitmap

instance.Image = value

value = instance.Image
    public SkiaSharp.SKBitmap Image {get; set;}
    Remarks

    This property is only relevant where LabelType is Image

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLabel Class
    DicomLabel Members


DicomObjects Namespace / DicomLabel Class / ImageOpacity Property

    ImageOpacity Property
    Controls the opacity of the Image label. Only applicable to Image type.

    Value ranges from 0-1 (None to Full opacity)

    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property ImageOpacity As Single
    'Usage

    Dim instance As DicomLabel
Dim value As Single

instance.ImageOpacity = value

value = instance.ImageOpacity
    public float ImageOpacity {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLabel Class
    DicomLabel Members


DicomObjects Namespace / DicomLabel Class / ImportedLabelType Property

    ImportedLabelType Property
    The type of label created by DicomObjects from Presentation states
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Property ImportedLabelType As Type
    'Usage

    Dim value As Type

DicomLabel.ImportedLabelType = value

value = DicomLabel.ImportedLabelType
    public static Type ImportedLabelType {get; set;}
    Remarks
    DicomObjects converts the graphic and text objects in a presentation state to DicomLabel or derived objects either temporarily (when displaying) or permanently when calling PresentationStateToCurrent. In order to allow custom values, under user control, the OnImport
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLabel Class
    DicomLabel Members


DicomObjects Namespace / DicomLabel Class / IncludeInPresentationState Property

    IncludeInPresentationState Property
    This property controls whether the DicomLabel goes into the PresentationState or not when one of the CurrentToPresentationState methods is used.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property IncludeInPresentationState As Boolean
    'Usage

    Dim instance As DicomLabel
Dim value As Boolean

instance.IncludeInPresentationState = value

value = instance.IncludeInPresentationState
    public bool IncludeInPresentationState {get; set;}
    Remarks
    Default value is True. Set the value to false to stop the DicomLabel from being included in the PresentationState.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLabel Class
    DicomLabel Members


DicomObjects Namespace / DicomLabel Class / IsInterpolated Property

    IsInterpolated Property
    Specify if the DicomLabel is Interpolated
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property IsInterpolated As Boolean
    'Usage

    Dim instance As DicomLabel
Dim value As Boolean

instance.IsInterpolated = value

value = instance.IsInterpolated
    public bool IsInterpolated {get; set;}
    Remarks
    Curving/Smoothing will be appleid if this property is set to true. This only applies to Label of type Polyline and Polygon.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLabel Class
    DicomLabel Members


DicomObjects Namespace / DicomLabel Class / IsShutter Property

    IsShutter Property
    This property decides whether or not the DicomLabel will be acting as a Shutter.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property IsShutter As Boolean
    'Usage

    Dim instance As DicomLabel
Dim value As Boolean

instance.IsShutter = value

value = instance.IsShutter
    public bool IsShutter {get; set;}
    Remarks
    Label must be polygonal to be a shutter. Brush property must be assigned in order to make the shutter effect visible. If set to true, the outside area will be filled with the color specified by Brush property.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLabel Class
    DicomLabel Members


DicomObjects Namespace / DicomLabel Class / LabelType Property

    LabelType Property
    Determines the basic type of a label
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property LabelType As LabelType
    'Usage

    Dim instance As DicomLabel
Dim value As LabelType

instance.LabelType = value

value = instance.LabelType
    public LabelType LabelType {get; set;}
    Remarks

    Possible values for LabelType

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLabel Class
    DicomLabel Members


DicomObjects Namespace / DicomLabel Class / Left Property

    Left Property
    Define the left of a DicomLabel (annotation) on an image
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property Left As Single
    'Usage

    Dim instance As DicomLabel
Dim value As Single

instance.Left = value

value = instance.Left
    public float Left {get; set;}
    Remarks
    Text label uses only needs (X = Left, Y = Top) for the text location Equivalent to Area.Left. Remains in .NET version for backward compatibility.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLabel Class
    DicomLabel Members


DicomObjects Namespace / DicomLabel Class / Margin Property

    Margin Property
    Defines a margin between text and it’s bounding box
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property Margin As Integer
    'Usage

    Dim instance As DicomLabel
Dim value As Integer

instance.Margin = value

value = instance.Margin
    public int Margin {get; set;}
    Remarks
    The bounding SKRectI defined by Height and Width is reduced by this size on all four sides before text is drawn, leaving a clear margin around the text. If the AutoSizeMode property causes the size to be reduced, then the calculated box is automatically expanded to accommodate this margin.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLabel Class
    DicomLabel Members


DicomObjects Namespace / DicomLabel Class / MinArrowSize Property

    MinArrowSize Property
    Specify the minimum Arrow size when the labeltype is set to LabelArrow
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property MinArrowSize As Integer
    'Usage

    Dim instance As DicomLabel
Dim value As Integer

instance.MinArrowSize = value

value = instance.MinArrowSize
    public int MinArrowSize {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLabel Class
    DicomLabel Members


DicomObjects Namespace / DicomLabel Class / Paint Property

    Paint Property
    Information about the style and color that is used to draw the different LabelTypes
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property Paint As SkiaSharp.SKPaint
    'Usage

    Dim instance As DicomLabel
Dim value As SkiaSharp.SKPaint

instance.Paint = value

value = instance.Paint
    public SkiaSharp.SKPaint Paint {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLabel Class
    DicomLabel Members


DicomObjects Namespace / DicomLabel Class / Points Property

    Points Property
    The points of a DicomLabel (of type PolyLine or Polygon)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property Points As SkiaSharp.SKPoint()
    'Usage

    Dim instance As DicomLabel
Dim value() As SkiaSharp.SKPoint

instance.Points = value

value = instance.Points
    public SkiaSharp.SKPoint[] Points {get; set;}
    Remarks

    This is a single-dimension array, but interpreted as pairs of values (x and y).

    The values may be updated either by direct assignment to this property, or as in earlier versions of DicomObjects, the AddPoint:o method may be used to add a point to the end of the array.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLabel Class
    DicomLabel Members


DicomObjects Namespace / DicomLabel Class / RefImage Property

    RefImage Property
    The image whose plane is used to control the placement of this image, as a line.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property RefImage As DicomImage
    'Usage

    Dim instance As DicomLabel
Dim value As DicomImage

instance.RefImage = value

value = instance.RefImage
    public DicomImage RefImage {get; set;}
    Remarks
    Unlike lines generated using the DicomImage.ReferenceLine method, this line is fully dynamic, and updates automatically if the plane displayed by the referenced image is changed.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLabel Class
    DicomLabel Members


DicomObjects Namespace / DicomLabel Class / RotationCentre Property

    RotationCentre Property
    Controls the centre of rotation of a text label.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property RotationCentre As RotationCentre
    'Usage

    Dim instance As DicomLabel
Dim value As RotationCentre

instance.RotationCentre = value

value = instance.RotationCentre
    public RotationCentre RotationCentre {get; set;}
    Remarks
    This properrty is used for 2 purposes:
    • When an explicit rotation is applied to a label
    • When an image is rotated, but the label is not rotated due to the setting of the RotationMode which therefore requires that the label be rotated relative to the image.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLabel Class
    DicomLabel Members


DicomObjects Namespace / DicomLabel Class / RotationMode Property

    RotationMode Property
    Controls the rotation behaviour of a label.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property RotationMode As RotationMode
    'Usage

    Dim instance As DicomLabel
Dim value As RotationMode

instance.RotationMode = value

value = instance.RotationMode
    public RotationMode RotationMode {get; set;}
    Remarks

    If a DicomImage is rotated (either by use of an explicit Angle, or by use of RotateState, and if the ScaleMode is Image then this property controls whether the label rotates with the underlying image, or whether its base rotation remains upright.

    In either case, the label may still be rotated, relative to that base rotation using the label's Angle property

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLabel Class
    DicomLabel Members


DicomObjects Namespace / DicomLabel Class / RotationPoint Property

    RotationPoint Property
    Defines the centre point used for label rotation (whether due to Angle or as a result of RotationMode) if the RotationCentre is set to SpecifiedPoint
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property RotationPoint As SkiaSharp.SKPoint
    'Usage

    Dim instance As DicomLabel
Dim value As SkiaSharp.SKPoint

instance.RotationPoint = value

value = instance.RotationPoint
    public SkiaSharp.SKPoint RotationPoint {get; set;}
    Remarks
    The point is defined using the same coordinates as Area or Points, which depend on the value of ScaleMode
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLabel Class
    DicomLabel Members


DicomObjects Namespace / DicomLabel Class / RulerOptions Property

    RulerOptions Property
    Ruler options used if LabelType is set to Ruler
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property RulerOptions As RulerOptions
    'Usage

    Dim instance As DicomLabel
Dim value As RulerOptions

instance.RulerOptions = value

value = instance.RulerOptions
    public RulerOptions RulerOptions {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLabel Class
    DicomLabel Members


DicomObjects Namespace / DicomLabel Class / RulerSpacing Property

    RulerSpacing Property
    Controls the approximate spacing of the minor ticks for a ruler label
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property RulerSpacing As Integer
    'Usage

    Dim instance As DicomLabel
Dim value As Integer

instance.RulerSpacing = value

value = instance.RulerSpacing
    public int RulerSpacing {get; set;}
    Remarks

    This value is measured in screen/output pixels. When drawing a ruler, DicomObjects first calculates the distance (in mm) corresponding to this number of output pixels. It then rounds it up to the next significant figure (1, 2 or 5 times a power of 10) and uses that as the minor tick spacing.

    The default value is 20

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLabel Class
    DicomLabel Members


DicomObjects Namespace / DicomLabel Class / ScaleFontSize Property

    ScaleFontSize Property
    Determines whether the SKFont size scales with the image
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property ScaleFontSize As Boolean
    'Usage

    Dim instance As DicomLabel
Dim value As Boolean

instance.ScaleFontSize = value

value = instance.ScaleFontSize
    public bool ScaleFontSize {get; set;}
    Remarks
    When this property is true (the default case, as used in previous versions of DicomObjects), then when ScaleMode is set to Image, the SKFont size of a text label scales with the zoom of the image. Otherwise, the SKFont size remains constant.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLabel Class
    DicomLabel Members


DicomObjects Namespace / DicomLabel Class / ScaleMode Property

    ScaleMode Property
    Defines a basic scale mode of DicomLabel
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property ScaleMode As ScaleMode
    'Usage

    Dim instance As DicomLabel
Dim value As ScaleMode

instance.ScaleMode = value

value = instance.ScaleMode
    public ScaleMode ScaleMode {get; set;}
    Remarks

    Check the ScaleMode for the possible values.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLabel Class
    DicomLabel Members


DicomObjects Namespace / DicomLabel Class / ScaleStrokeWidth Property

    ScaleStrokeWidth Property
    Control whether the width of a line scales with the label being drawn
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property ScaleStrokeWidth As Boolean
    'Usage

    Dim instance As DicomLabel
Dim value As Boolean

instance.ScaleStrokeWidth = value

value = instance.ScaleStrokeWidth
    public bool ScaleStrokeWidth {get; set;}
    Remarks
    Default value is false
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLabel Class
    DicomLabel Members


DicomObjects Namespace / DicomLabel Class / SelectMode Property

    SelectMode Property
    Controls whether a label is highlighted using a box and/or “handles”
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property SelectMode As SelectMode
    'Usage

    Dim instance As DicomLabel
Dim value As SelectMode

instance.SelectMode = value

value = instance.SelectMode
    public SelectMode SelectMode {get; set;}
    Remarks

    The allowable values are:

    • None 0 No Highlighting
    • Box 1 A bounding box is drawn around the label
    • BoxHandles 2 Handles are drawn at the corners of the above box
    • AllHandles 4 Handles are drawn at all relevant 'points' (This only applies to labels of type dolabelPolygon, doLabelPolyline & doLabelArc)

    Although defined as enumerated types, the values above can be (and normally are) used as bit fields, so the value doSelectBox + doSelectBoxHandles gives a bounding box with visible corners.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLabel Class
    DicomLabel Members


DicomObjects Namespace / DicomLabel Class / Shadow Property

    Shadow Property
    Controls whether a label is displayed with a contrasting shadow, to make it more visible over image areas with the same colour.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property Shadow As Short
    'Usage

    Dim instance As DicomLabel
Dim value As Short

instance.Shadow = value

value = instance.Shadow
    public short Shadow {get; set;}
    Remarks

    The allowable values are:

    • doShadowNone =0
    • doShadowTopLeft =1
    • doShadowTop =2
    • doShadowTopRight =4
    • doShadowRight =8
    • doShadowBottomRight =16
    • doShadowBottom =32
    • doShadowBottomLeft =64
    • doShadowLeft =128
    • doShadowAll =255

    Although defined as enumerated types, the values above can be (and normally are) combined and used as bit fields

    The shadow is drawn in the direction(s) indicated above displaced by one pixel from the main label, and it is drawn using the label’s BackColour colour.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLabel Class
    DicomLabel Members


DicomObjects Namespace / DicomLabel Class / ShadowColor Property

    ShadowColor Property
    Contains the colour of the Shadow applied to the DicomLabel
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property ShadowColor As SkiaSharp.SKColor
    'Usage

    Dim instance As DicomLabel
Dim value As SkiaSharp.SKColor

instance.ShadowColor = value

value = instance.ShadowColor
    public SkiaSharp.SKColor ShadowColor {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLabel Class
    DicomLabel Members


DicomObjects Namespace / DicomLabel Class / ShowAnchor Property

    ShowAnchor Property
    Determines whether the anchor point is shown
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property ShowAnchor As Boolean
    'Usage

    Dim instance As DicomLabel
Dim value As Boolean

instance.ShowAnchor = value

value = instance.ShowAnchor
    public bool ShowAnchor {get; set;}
    Remarks

    If the label is a text label, and this property is true, then a line is drawn from the border of the text label to a point in the image indicated by the X and Y co-ordinates of the anchor.

    If AnchorScaleMode is set to Image, then the anchor point is transformed with the image exactly the same way that the label itself is if ScaleMode is set to Image.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLabel Class
    DicomLabel Members


DicomObjects Namespace / DicomLabel Class / ShowTextBox Property

    ShowTextBox Property
    Controls whether text boxes have a visible border
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property ShowTextBox As Boolean
    'Usage

    Dim instance As DicomLabel
Dim value As Boolean

instance.ShowTextBox = value

value = instance.ShowTextBox
    public bool ShowTextBox {get; set;}
    Remarks
    If true, then the area occupied by a text label is outlined.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLabel Class
    DicomLabel Members


DicomObjects Namespace / DicomLabel Class / SKFonts Property

    SKFonts Property
    A Static SKFont collection. Users can define and add their list of SKFonts and choose which to apply to each DicomLabel object using DicomLabel's SKFontIndex property.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Property SKFonts As List(Of SKFont)
    'Usage

    Dim value As List(Of SKFont)

DicomLabel.SKFonts = value

value = DicomLabel.SKFonts
    public static List<SKFont> SKFonts {get; set;}
    Remarks
    No SKFont is in this collection by default. User have to add the SKFont(s) to it before its item can be later indexed by SKFontIndex property. This collection provides a method for the SKFonts of many labels to be changed at once.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLabel Class
    DicomLabel Members


DicomObjects Namespace / DicomLabel Class / StartAngle Property

    StartAngle Property
    Starting angle (in degrees) where the arc begins used by SkiaSharp
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property StartAngle As Single
    'Usage

    Dim instance As DicomLabel
Dim value As Single

instance.StartAngle = value

value = instance.StartAngle
    public float StartAngle {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLabel Class
    DicomLabel Members


DicomObjects Namespace / DicomLabel Class / SweepAngle Property

    SweepAngle Property
    Sweep angle (in degrees) measured clockwise used by SkiaSharp
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property SweepAngle As Single
    'Usage

    Dim instance As DicomLabel
Dim value As Single

instance.SweepAngle = value

value = instance.SweepAngle
    public float SweepAngle {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLabel Class
    DicomLabel Members


DicomObjects Namespace / DicomLabel Class / Tag Property

    Tag Property (DicomLabel)
    In This Topic
    A general purpose Tag for developer use
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property Tag As Object
    'Usage

    Dim instance As DicomLabel
Dim value As Object

instance.Tag = value

value = instance.Tag
    public object Tag {get; set;}
    Remarks
    This property is not used by DicomObjects in any way, and is provided purely as a convenience for developers who wish to associate other objects with this object. As an alternative, most of the objects in DicomObjects can have other classes derived from them.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLabel Class
    DicomLabel Members


DicomObjects Namespace / DicomLabel Class / Text Property

    Text Property (DicomLabel)
    In This Topic
    The text to be displayed by a text type DicomLabel
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property Text As String
    'Usage

    Dim instance As DicomLabel
Dim value As String

instance.Text = value

value = instance.Text
    public string Text {get; set;}
    Remarks

    This property is only relevant where LabelType is Text, Special or Formatted.

    The Paint, ScaleFontSize, ShowAnchor and Anchor properties are important also for this case.

    If ShowTextBox is true, then the text is surrounded by a rectangular box, drawn in the foreground colour.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLabel Class
    DicomLabel Members


DicomObjects Namespace / DicomLabel Class / Top Property

    Top Property
    Define the top of a DicomLabel (annotation) on an image
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property Top As Single
    'Usage

    Dim instance As DicomLabel
Dim value As Single

instance.Top = value

value = instance.Top
    public float Top {get; set;}
    Remarks
    Text label uses only needs (X = Left, Y = Top) for the text location Equivalent to Area.Top. Remains in .NET version for backward compatibility.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLabel Class
    DicomLabel Members


DicomObjects Namespace / DicomLabel Class / Visible Property

    Visible Property
    Controls whether a DicomLabel object is displayed
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property Visible As Boolean
    'Usage

    Dim instance As DicomLabel
Dim value As Boolean

instance.Visible = value

value = instance.Visible
    public bool Visible {get; set;}
    Remarks
    A label is only displayed if this property is true, and if the ShowLabels property of the associated image is also true.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLabel Class
    DicomLabel Members


DicomObjects Namespace / DicomLabel Class / Width Property

    Width Property (DicomLabel)
    In This Topic
    Define the width of a DicomLabel (annotation) on an image
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property Width As Single
    'Usage

    Dim instance As DicomLabel
Dim value As Single

instance.Width = value

value = instance.Width
    public float Width {get; set;}
    Remarks
    Equivalent to Area.Width. Remains in .NET version for backward compatibility.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLabel Class
    DicomLabel Members


%%PageItemTitle%% $$Events$$

DicomObjects Namespace / DicomLabel Class

    DicomLabel Class Events
    In This Topic

    For a list of all members of this type, see DicomLabel members.

    Public Events
     | Name | Description
Public Event | LabelChanged | Event fired when the properties of a label are changed.
Public Event | PSLabelCreated | Event fires when a new DicomLabel is created when a Presentation State is applied to an image. This event gives users a chance to customise the label before display
    Top
    See Also

    Reference

    DicomLabel Class
    DicomObjects Namespace


DicomObjects Namespace / DicomLabel Class / LabelChanged Event

    LabelChanged Event
    Event fired when the properties of a label are changed.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Event LabelChanged As LabelChangedHandler
    'Usage

    Dim instance As DicomLabel
Dim handler As LabelChangedHandler

AddHandler instance.LabelChanged, handler
    public event LabelChangedHandler LabelChanged
    Remarks

    Note that this Event is only fired when a complete property changes e.g.

    label.Area = new SKRect(0,0,10,20);

    It is not fired when a property of a property changes - e.g.

    label.Area.Left = 20;
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLabel Class
    DicomLabel Members


DicomObjects Namespace / DicomLabel Class / PSLabelCreated Event

    PSLabelCreated Event
    Event fires when a new DicomLabel is created when a Presentation State is applied to an image. This event gives users a chance to customise the label before display
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Event PSLabelCreated As PSLabelCreatedHandler
    'Usage

    Dim instance As DicomLabel
Dim handler As PSLabelCreatedHandler

AddHandler instance.PSLabelCreated, handler
    public event PSLabelCreatedHandler PSLabelCreated
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLabel Class
    DicomLabel Members


%%PageItemTitle%%

DicomObjects Namespace / DicomLabelCollection Class
Members

In This Topic
    DicomLabelCollection Class
    In This Topic
    A collection of DicomLabel objects.
    Object Model
    DicomLabelCollection ClassDicomLabel Class
    Syntax
    • Visual Basic
    • C#
    'Declaration

    <DefaultMemberAttribute("Item")>
<DebuggerTypeProxyAttribute(System.Collections.Generic.Mscorlib_CollectionDebugView`1)>
<DebuggerDisplayAttribute("Count = {Count}")>
<SerializableAttribute()>
Public Class DicomLabelCollection
   Inherits System.Collections.ObjectModel.Collection(Of DicomLabel)
    'Usage

    Dim instance As DicomLabelCollection
    [DefaultMember("Item")]
[DebuggerTypeProxy(System.Collections.Generic.Mscorlib_CollectionDebugView`1)]
[DebuggerDisplay("Count = {Count}")]
[Serializable()]
public class DicomLabelCollection : System.Collections.ObjectModel.Collection<DicomLabel>
    Inheritance Hierarchy

    System.Object
    System.Collections.ObjectModel.Collection<T>
    DicomObjects.DicomLabelCollection

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLabelCollection Members
    DicomObjects Namespace


%%PageItemTitle%% $$Members$$

DicomObjects Namespace / DicomLabelCollection Class
Properties Methods

In This Topic
    DicomLabelCollection Class Members
    In This Topic

    The following tables list the members exposed by DicomLabelCollection.

    Public Constructors
     | Name | Description
Public Constructor | DicomLabelCollection Constructor | Overloaded.
    Top
    Public Properties
     | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<DicomLabel>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<DicomLabel>)
Public Property | Tag | A general purpose Tag for developer use
    Top
    Public Methods
     | Name | Description
Public Method | Add | Overloaded. Add a list of DicomLabel objects
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<DicomLabel>)
Public Method | Clone | Overloaded. Returns a copy of the DicomLabelCollection
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<DicomLabel>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<DicomLabel>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<DicomLabel>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<DicomLabel>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<DicomLabel>)
Public Method | Remove | Overloaded. Remove a list of DicomLabel objects
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<DicomLabel>)
    Top
    See Also

    Reference

    DicomLabelCollection Class
    DicomObjects Namespace


%%PageItemTitle%%

DicomObjects Namespace / DicomLabelCollection Class / DicomLabelCollection Constructor

In This Topic
    DicomLabelCollection Constructor
    In This Topic
    Overload List
    Overload | Description
DicomLabelCollection Constructor() | Create a blank DicomLabelCollection object
DicomLabelCollection Constructor(IEnumerable<DicomLabel>) | Create a DicomLabelCollection object fro ma list
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLabelCollection Class
    DicomLabelCollection Members


%%PageItemTitle%%

DicomObjects Namespace / DicomLabelCollection Class / DicomLabelCollection Constructor / DicomLabelCollection Constructor()

In This Topic
    DicomLabelCollection Constructor()
    In This Topic
    Create a blank DicomLabelCollection object
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Function New()
    'Usage

    Dim instance As New DicomLabelCollection()
    public DicomLabelCollection()
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLabelCollection Class
    DicomLabelCollection Members
    Overload List


%%PageItemTitle%%

DicomObjects Namespace / DicomLabelCollection Class / DicomLabelCollection Constructor / DicomLabelCollection Constructor(IEnumerable<DicomLabel>)

In This Topic
    DicomLabelCollection Constructor(IEnumerable<DicomLabel>)
    In This Topic
    Create a DicomLabelCollection object fro ma list
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Function New( _
   ByVal Items As IEnumerable(Of DicomLabel) _
)
    'Usage

    Dim Items As IEnumerable(Of DicomLabel)

Dim instance As New DicomLabelCollection(Items)
    public DicomLabelCollection(
   IEnumerable<DicomLabel> Items
)

    Parameters

    Items
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLabelCollection Class
    DicomLabelCollection Members
    Overload List


%%PageItemTitle%% $$Methods$$

DicomObjects Namespace / DicomLabelCollection Class

    DicomLabelCollection Class Methods
    In This Topic

    For a list of all members of this type, see DicomLabelCollection members.

    Public Methods
     | Name | Description
Public Method | Add | Overloaded. Add a list of DicomLabel objects
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<DicomLabel>)
Public Method | Clone | Overloaded. Returns a copy of the DicomLabelCollection
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<DicomLabel>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<DicomLabel>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<DicomLabel>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<DicomLabel>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<DicomLabel>)
Public Method | Remove | Overloaded. Remove a list of DicomLabel objects
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<DicomLabel>)
    Top
    See Also

    Reference

    DicomLabelCollection Class
    DicomObjects Namespace


DicomObjects Namespace / DicomLabelCollection Class / Add Method

    Add Method (DicomLabelCollection)
    In This Topic
    Add a list of DicomLabel objects
    Overload List
    Overload | Description
Add(IEnumerable<DicomLabel>) | Add a list of DicomLabel objects
Add(DicomLabel) | (Inherited from System.Collections.ObjectModel.Collection<DicomLabel>)
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLabelCollection Class
    DicomLabelCollection Members


DicomObjects Namespace / DicomLabelCollection Class / Add Method / Add(IEnumerable<DicomLabel>) Method
Items to add

    Add(IEnumerable<DicomLabel>) Method
    In This Topic
    Add a list of DicomLabel objects
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub Add( _
   ByVal Items As IEnumerable(Of DicomLabel) _
)
    'Usage

    Dim instance As DicomLabelCollection
Dim Items As IEnumerable(Of DicomLabel)

instance.Add(Items)
    public void Add(
   IEnumerable<DicomLabel> Items
)

    Parameters

    Items
    Items to add
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLabelCollection Class
    DicomLabelCollection Members
    Overload List


DicomObjects Namespace / DicomLabelCollection Class / Clone Method

    Clone Method (DicomLabelCollection)
    In This Topic
    Returns a copy of the DicomLabelCollection
    Overload List
    Overload | Description
Clone() | Returns a copy of the DicomLabelCollection
Clone(Boolean) | Returns a copy of the DicomLabelCollection
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLabelCollection Class
    DicomLabelCollection Members


DicomObjects Namespace / DicomLabelCollection Class / Clone Method / Clone() Method

    Clone() Method
    Returns a copy of the DicomLabelCollection
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Overridable Function Clone() As Object
    'Usage

    Dim instance As DicomLabelCollection
Dim value As Object

value = instance.Clone()
    public virtual object Clone()

    Return Value

    DicomLabelCollection
    Remarks
    This method makes a Shallow Copy of the DicomLabelCollection. A shallow copy will only have the top level objects replicated, any referenced objects under the top level will be shared by the original DicomLabelCollection and the cloned copy.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLabelCollection Class
    DicomLabelCollection Members
    Overload List


DicomObjects Namespace / DicomLabelCollection Class / Clone Method / Clone(Boolean) Method

Controls whether a Shallow copy or a Deep copy is to be returned

In This Topic
    Clone(Boolean) Method
    In This Topic
    Returns a copy of the DicomLabelCollection
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Overridable Function Clone( _
   ByVal Deep As Boolean _
) As Object
    'Usage

    Dim instance As DicomLabelCollection
Dim Deep As Boolean
Dim value As Object

value = instance.Clone(Deep)
    public virtual object Clone(
   bool Deep
)

    Parameters

    Deep

    Controls whether a Shallow copy or a Deep copy is to be returned

    Return Value

    DicomLabelCollection
    Remarks

    If Deep is true, then returns a Deep copy of the DicomLabelCollection, otherwise returns a Shallow copy.

    A Deep copy will have all referenced objects of all levels cloned, where a Shallow copy will only have the top level referenced objects cloned.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLabelCollection Class
    DicomLabelCollection Members
    Overload List


DicomObjects Namespace / DicomLabelCollection Class / Remove Method

    Remove Method (DicomLabelCollection)
    In This Topic
    Remove a list of DicomLabel objects
    Overload List
    Overload | Description
Remove(IEnumerable<DicomLabel>) | Remove a list of DicomLabel objects
Remove(DicomLabel) | (Inherited from System.Collections.ObjectModel.Collection<DicomLabel>)
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLabelCollection Class
    DicomLabelCollection Members


DicomObjects Namespace / DicomLabelCollection Class / Remove Method / Remove(IEnumerable<DicomLabel>) Method
Items to remove

    Remove(IEnumerable<DicomLabel>) Method
    In This Topic
    Remove a list of DicomLabel objects
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub Remove( _
   ByVal Items As IEnumerable(Of DicomLabel) _
)
    'Usage

    Dim instance As DicomLabelCollection
Dim Items As IEnumerable(Of DicomLabel)

instance.Remove(Items)
    public void Remove(
   IEnumerable<DicomLabel> Items
)

    Parameters

    Items
    Items to remove
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLabelCollection Class
    DicomLabelCollection Members
    Overload List


%%PageItemTitle%% $$Properties$$

DicomObjects Namespace / DicomLabelCollection Class

    DicomLabelCollection Class Properties
    In This Topic

    For a list of all members of this type, see DicomLabelCollection members.

    Public Properties
     | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<DicomLabel>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<DicomLabel>)
Public Property | Tag | A general purpose Tag for developer use
    Top
    See Also

    Reference

    DicomLabelCollection Class
    DicomObjects Namespace


DicomObjects Namespace / DicomLabelCollection Class / Tag Property

    Tag Property (DicomLabelCollection)
    In This Topic
    A general purpose Tag for developer use
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property Tag As Object
    'Usage

    Dim instance As DicomLabelCollection
Dim value As Object

instance.Tag = value

value = instance.Tag
    public object Tag {get; set;}
    Remarks
    This property is not used by DicomObjects in any way, and is provided purely as a convenience for developers who wish to associate other objects with this object. As an alternative, most of the objects in DicomObjects can have other classes derived from them.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLabelCollection Class
    DicomLabelCollection Members


%%PageItemTitle%%

DicomObjects Namespace / DicomLicence Class
Members

In This Topic
    DicomLicence Class
    In This Topic
    This class handles DicomObjects licensing
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public NotInheritable Class DicomLicence
    'Usage

    Dim instance As DicomLicence
    public sealed class DicomLicence
    Remarks
    This class both represents an individual Licence issued to allow use of DicomObjects on a particular machine, and also acts as a placeholder for many static methods and properties which allow Licences to be listed, obtained (off-line or on-line) selected and deleted. For licence activation to be controlled via an external file at startup, DicomObjects offers a mechanism for using an Activation File
    Inheritance Hierarchy

    System.Object
    DicomObjects.DicomLicence

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLicence Members
    DicomObjects Namespace


%%PageItemTitle%% $$Members$$

DicomObjects Namespace / DicomLicence Class
Properties Methods Events

In This Topic
    DicomLicence Class Members
    In This Topic

    The following tables list the members exposed by DicomLicence.

    Public Properties
     | Name | Description
static (Shared in Visual Basic) | BestLicence | Select a Licence with maximum validity and most features. Licence with most functionality will be prioritized over number of remaining days
static (Shared in Visual Basic) | CurrentLicence | The DicomLicence current in use
Public Property | Expiry | The expiryDate date of the Licence
static (Shared in Visual Basic) | ExpiryWarningDays | Number of days before expiryDate to start issuing warnings
static (Shared in Visual Basic) | InstalledLicences | The list of currently available licences. This includes expired licences if any The property invokes internal update of available licences, minimize calls to this property to avoid delays
static (Shared in Visual Basic) | LicenceServer | Specifies the server to be used to obtain on-line Licences This is an advanced property and is to be used with caution
static (Shared in Visual Basic) | LicenceServerCount | Specifies how many Licence servers are to be tried to obtain on-line Licences This is an advanced property and is to be used with caution
static (Shared in Visual Basic) | MachineId | A unique string to identify each machine
static (Shared in Visual Basic) | ProxyDomain | Domain to be used if the machine's web proxy requires authentication.
static (Shared in Visual Basic) | ProxyPassword | Password to be used if the machine's web proxy requires authentication.
static (Shared in Visual Basic) | ProxyUsername | Username to be used if the machine's web proxy requires authentication.
Public Property | Source | Licence source type
Public Property | Token | The token which activated this licence
Public Property | Type | The type of this Licence that determines the allowed functions
    Top
    Public Methods
     | Name | Description
static (Shared in Visual Basic) | ActivateConcurrent | Attempt to obtain a concurrent, time-limited DicomObjects licence online
static (Shared in Visual Basic) | ActivateOffLine | Activate using an LicenceToken obtained off-line
static (Shared in Visual Basic) | ActivateOnLine | Attempt to obtain a standard DicomObjects licence online
static (Shared in Visual Basic) | ActivateSigned | Attempt to obtain a signed DicomObjects licence online for this assembly. Our standalone application signer tool can be used to generate signed licences for other external assemblies
Public Method | Deactivate | Attempt to delete installed licence from your machine and notify our licence servers of the deletion No exception is thrown if licence server cannot be notified, it only deletes locally
static (Shared in Visual Basic) | DeactivateAll | Attempt to delete All installed licences from your machine and notify our licence servers of the deletion
Public Method | Equals | Equality comparer for Licence objects
Public Method | GetHashCode | Serves as the default hash function.
Public Method | ToString | Returns a string that represents the current object.
    Top
    Public Events
     | Name | Description
Public Event | LicenceExpired | Event to alert that the current temporary licence has just expired You can have code to handle the expiration, for example, licence Re-activation can happen here
Public Event | LicenceRetrieve | Event fired when DicomObjects needs to retrieve a previously stored Licence
Public Event | LicenceStore | Event fires when DicomObjects needs to store a licence
    Top
    See Also

    Reference

    DicomLicence Class
    DicomObjects Namespace


%%PageItemTitle%% $$Methods$$

DicomObjects Namespace / DicomLicence Class

    DicomLicence Class Methods
    In This Topic

    For a list of all members of this type, see DicomLicence members.

    Public Methods
     | Name | Description
static (Shared in Visual Basic) | ActivateConcurrent | Attempt to obtain a concurrent, time-limited DicomObjects licence online
static (Shared in Visual Basic) | ActivateOffLine | Activate using an LicenceToken obtained off-line
static (Shared in Visual Basic) | ActivateOnLine | Attempt to obtain a standard DicomObjects licence online
static (Shared in Visual Basic) | ActivateSigned | Attempt to obtain a signed DicomObjects licence online for this assembly. Our standalone application signer tool can be used to generate signed licences for other external assemblies
Public Method | Deactivate | Attempt to delete installed licence from your machine and notify our licence servers of the deletion No exception is thrown if licence server cannot be notified, it only deletes locally
static (Shared in Visual Basic) | DeactivateAll | Attempt to delete All installed licences from your machine and notify our licence servers of the deletion
Public Method | Equals | Equality comparer for Licence objects
Public Method | GetHashCode | Serves as the default hash function.
Public Method | ToString | Returns a string that represents the current object.
    Top
    See Also

    Reference

    DicomLicence Class
    DicomObjects Namespace


DicomObjects Namespace / DicomLicence Class / ActivateConcurrent Method
The key provided by Medical Connections in the format 'CON-1111-2222-3333', allowing you to activate DicomObjects for specific functions
An optional string identifying this system and/or the institution at which this copy is being activated. This optional parameter can be empty
Another optional string with the same type of information as 'activationInfo1'/>
An out parameter, into which an explanation of the result is placed.

In This Topic
    ActivateConcurrent Method
    In This Topic
    Attempt to obtain a concurrent, time-limited DicomObjects licence online
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Function ActivateConcurrent( _
   ByVal licenceKey As String, _
   ByVal activationInfo1 As String, _
   ByVal activationInfo2 As String, _
   ByRef result As String _
) As DicomLicence
    'Usage

    Dim licenceKey As String
Dim activationInfo1 As String
Dim activationInfo2 As String
Dim result As String
Dim value As DicomLicence

value = DicomLicence.ActivateConcurrent(licenceKey, activationInfo1, activationInfo2, result)
    public static DicomLicence ActivateConcurrent(
   string licenceKey,
   string activationInfo1,
   string activationInfo2,
   out string result
)

    Parameters

    licenceKey
    The key provided by Medical Connections in the format 'CON-1111-2222-3333', allowing you to activate DicomObjects for specific functions
    activationInfo1
    An optional string identifying this system and/or the institution at which this copy is being activated. This optional parameter can be empty
    activationInfo2
    Another optional string with the same type of information as 'activationInfo1'/>
    result
    An out parameter, into which an explanation of the result is placed.

    Return Value

    A valid DicomLicence object if the activation succeeded or if already activated using Licence string.

    null if the activation failed.

    Remarks

    This is the main method used to activate a concurrent DicomObjects Licence, and is used both explicitly by users and internally when requested. For more information please visit this webpage - https://www.medicalconnections.co.uk/kb/Concurrent-Licensing/

    The result indicates whether the method succeeded, and further information (whether successful or not) is available in the Result parameter

    If a Licence has previously been activated on the same machine, using the same Licence string, then the method returns the existing licence, but the fact is noted in the Result

    The Licence server to be contacted is specified by LicenceServer, but this should not normally be changed.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLicence Class
    DicomLicence Members


DicomObjects Namespace / DicomLicence Class / ActivateOffLine Method
The key provided by Medical Connections in the format 'XYZ-1111-2222-3333', allowing you to activate DicomObjects for specific functions
The string obtained from the licence server activation webpage, using your licence key, in the format '12AB-34CD-56EF-78GH-90XY'
An out parameter, into which an explanation of the result is placed.

In This Topic
    ActivateOffLine Method
    In This Topic
    Activate using an LicenceToken obtained off-line
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Function ActivateOffLine( _
   ByVal licenceKey As String, _
   ByVal licenceToken As String, _
   ByRef result As String _
) As DicomLicence
    'Usage

    Dim licenceKey As String
Dim licenceToken As String
Dim result As String
Dim value As DicomLicence

value = DicomLicence.ActivateOffLine(licenceKey, licenceToken, result)
    public static DicomLicence ActivateOffLine(
   string licenceKey,
   string licenceToken,
   out string result
)

    Parameters

    licenceKey
    The key provided by Medical Connections in the format 'XYZ-1111-2222-3333', allowing you to activate DicomObjects for specific functions
    licenceToken
    The string obtained from the licence server activation webpage, using your licence key, in the format '12AB-34CD-56EF-78GH-90XY'
    result
    An out parameter, into which an explanation of the result is placed.

    Return Value

    A valid DicomLicence object if the activation succeeded or if already activated using this Licence string.

    null if the activation failed

    Remarks

    This method may be used where the machine being activated does not have a direct internet connection. The same information as would be used by ActivateOnLine is entered into the website http://activation.medicalconnections.co.uk using a separate machine which will return a 'licenceToken', which should then be used in this method

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLicence Class
    DicomLicence Members


DicomObjects Namespace / DicomLicence Class / ActivateOnLine Method
The key provided by Medical Connections in the format 'XYZ-1111-2222-3333', allowing you to activate DicomObjects for specific functions
An optional string identifying this system and/or the institution at which this copy is being activated. This optional parameter can be empty
Another optional string with the same type of information as 'activationInfo1'/>
An out parameter, into which an explanation of the result is placed.

In This Topic
    ActivateOnLine Method
    In This Topic
    Attempt to obtain a standard DicomObjects licence online
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Function ActivateOnLine( _
   ByVal licenceKey As String, _
   ByVal activationInfo1 As String, _
   ByVal activationInfo2 As String, _
   ByRef result As String _
) As DicomLicence
    'Usage

    Dim licenceKey As String
Dim activationInfo1 As String
Dim activationInfo2 As String
Dim result As String
Dim value As DicomLicence

value = DicomLicence.ActivateOnLine(licenceKey, activationInfo1, activationInfo2, result)
    public static DicomLicence ActivateOnLine(
   string licenceKey,
   string activationInfo1,
   string activationInfo2,
   out string result
)

    Parameters

    licenceKey
    The key provided by Medical Connections in the format 'XYZ-1111-2222-3333', allowing you to activate DicomObjects for specific functions
    activationInfo1
    An optional string identifying this system and/or the institution at which this copy is being activated. This optional parameter can be empty
    activationInfo2
    Another optional string with the same type of information as 'activationInfo1'/>
    result
    An out parameter, into which an explanation of the result is placed.

    Return Value

    A valid DicomLicence object if the activation succeeded or if already activated using Licence string.

    null if the activation failed.

    Remarks

    This is the main method used to activate a DicomObjects Licence, and is used both explicitly by users and internally when requested

    The result indicates whether the method succeeded, and further information (whether successful or not) is available in the Result parameter

    If a Licence has previously been activated on the same machine, using the same Licence string, then the method returns the existing licence, but the fact is noted in the Result

    The Licence server to be contacted is specified by LicenceServer, but this should not normally be changed.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLicence Class
    DicomLicence Members


DicomObjects Namespace / DicomLicence Class / ActivateSigned Method
The key provided by Medical Connections in the format 'SK-1111-2222-3333', allowing you to activate DicomObjects for specific functions
An optional string identifying this system and/or the institution at which this copy is being activated. This optional parameter can be empty
Another optional string with the same type of information as 'activationInfo1'
An out parameter, into which an explanation of the result is placed.
Optional expiryDate date for the licence to be generated. Default is controlled by the licence key itself

In This Topic
    ActivateSigned Method
    In This Topic
    Attempt to obtain a signed DicomObjects licence online for this assembly. Our standalone application signer tool can be used to generate signed licences for other external assemblies
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Function ActivateSigned( _
   ByVal licenceKey As String, _
   ByVal activationInfo1 As String, _
   ByVal activationInfo2 As String, _
   ByRef result As String, _
   Optional ByVal expiryDate As Date _
) As DicomLicence
    'Usage

    Dim licenceKey As String
Dim activationInfo1 As String
Dim activationInfo2 As String
Dim result As String
Dim expiryDate As Date
Dim value As DicomLicence

value = DicomLicence.ActivateSigned(licenceKey, activationInfo1, activationInfo2, result, expiryDate)
    public static DicomLicence ActivateSigned(
   string licenceKey,
   string activationInfo1,
   string activationInfo2,
   out string result,
   DateTime expiryDate
)

    Parameters

    licenceKey
    The key provided by Medical Connections in the format 'SK-1111-2222-3333', allowing you to activate DicomObjects for specific functions
    activationInfo1
    An optional string identifying this system and/or the institution at which this copy is being activated. This optional parameter can be empty
    activationInfo2
    Another optional string with the same type of information as 'activationInfo1'
    result
    An out parameter, into which an explanation of the result is placed.
    expiryDate
    Optional expiryDate date for the licence to be generated. Default is controlled by the licence key itself

    Return Value

    A valid DicomLicence object if the activation succeeded or if already activated using Licence string

    null if the activation failed.

    Remarks

    This is the main method used to activate a singed DicomObjects Licence, and is used both explicitly by users and internally when requested. For more information please visit this webpage - https://www.medicalconnections.co.uk/kb/Signed-Licensing/

    The result indicates whether the method succeeded, and further information (whether successful or not) is available in the Result parameter

    If a Licence has previously been activated on the same machine, using the same Licence string, then the method returns the existing licence, but the fact is noted in the Result

    The Licence server to be contacted is specified by LicenceServer, but this should not normally be changed.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLicence Class
    DicomLicence Members


DicomObjects Namespace / DicomLicence Class / Deactivate Method
An optional string identifying this system and/or the institution at which this copy is being deactivated. This optional parameter can be empty
Another optional string with the same type of information as 'deactivationInfo1'/>

In This Topic
    Deactivate Method
    In This Topic
    Attempt to delete installed licence from your machine and notify our licence servers of the deletion

    No exception is thrown if licence server cannot be notified, it only deletes locally

    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Sub Deactivate( _
   ByVal deactivationInfo1 As String, _
   ByVal deactivationInfo2 As String _
)
    'Usage

    Dim instance As DicomLicence
Dim deactivationInfo1 As String
Dim deactivationInfo2 As String

instance.Deactivate(deactivationInfo1, deactivationInfo2)
    public void Deactivate(
   string deactivationInfo1,
   string deactivationInfo2
)

    Parameters

    deactivationInfo1
    An optional string identifying this system and/or the institution at which this copy is being deactivated. This optional parameter can be empty
    deactivationInfo2
    Another optional string with the same type of information as 'deactivationInfo1'/>
    Remarks

    If the licence being removed is set as the CurrentLicence, the next BestLicence will be set as the CurrentLicence.

    This method may be useful to remove trial Licences etc., but should be used with care on end-user machine just in case there are licences installed by other vendors, which should not be deleted

    Depending on the version of windows, and the permissions of the user, it is possible that the Licence may be removed, especially if it was installed by an administrator, but this method is invoked by a less privileged user.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLicence Class
    DicomLicence Members


DicomObjects Namespace / DicomLicence Class / DeactivateAll Method
An optional string identifying this system and/or the institution at which this copy is being deactivated. This optional parameter can be empty
Another optional string with the same type of information as 'deactivationInfo1'/>

In This Topic
    DeactivateAll Method
    In This Topic
    Attempt to delete All installed licences from your machine and notify our licence servers of the deletion
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Sub DeactivateAll( _
   ByVal deactivationInfo1 As String, _
   ByVal deactivationInfo2 As String _
)
    'Usage

    Dim deactivationInfo1 As String
Dim deactivationInfo2 As String

DicomLicence.DeactivateAll(deactivationInfo1, deactivationInfo2)
    public static void DeactivateAll(
   string deactivationInfo1,
   string deactivationInfo2
)

    Parameters

    deactivationInfo1
    An optional string identifying this system and/or the institution at which this copy is being deactivated. This optional parameter can be empty
    deactivationInfo2
    Another optional string with the same type of information as 'deactivationInfo1'/>
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLicence Class
    DicomLicence Members


DicomObjects Namespace / DicomLicence Class / Equals Method
Another licence to compare

    Equals Method (DicomLicence)
    In This Topic
    Equality comparer for Licence objects
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
    'Usage

    Dim instance As DicomLicence
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
    public override bool Equals(
   object obj
)

    Parameters

    obj
    Another licence to compare

    Return Value

    True if they are the same licence objects
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLicence Class
    DicomLicence Members


DicomObjects Namespace / DicomLicence Class / GetHashCode Method

    GetHashCode Method (DicomLicence)
    In This Topic
    Serves as the default hash function.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overrides Function GetHashCode() As Integer
    'Usage

    Dim instance As DicomLicence
Dim value As Integer

value = instance.GetHashCode()
    public override int GetHashCode()

    Return Value

    A hash code for the current object.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLicence Class
    DicomLicence Members


DicomObjects Namespace / DicomLicence Class / ToString Method

    ToString Method (DicomLicence)
    In This Topic
    Returns a string that represents the current object.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overrides Function ToString() As String
    'Usage

    Dim instance As DicomLicence
Dim value As String

value = instance.ToString()
    public override string ToString()

    Return Value

    A string that represents the current object.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLicence Class
    DicomLicence Members


%%PageItemTitle%% $$Properties$$

DicomObjects Namespace / DicomLicence Class

    DicomLicence Class Properties
    In This Topic

    For a list of all members of this type, see DicomLicence members.

    Public Properties
     | Name | Description
static (Shared in Visual Basic) | BestLicence | Select a Licence with maximum validity and most features. Licence with most functionality will be prioritized over number of remaining days
static (Shared in Visual Basic) | CurrentLicence | The DicomLicence current in use
Public Property | Expiry | The expiryDate date of the Licence
static (Shared in Visual Basic) | ExpiryWarningDays | Number of days before expiryDate to start issuing warnings
static (Shared in Visual Basic) | InstalledLicences | The list of currently available licences. This includes expired licences if any The property invokes internal update of available licences, minimize calls to this property to avoid delays
static (Shared in Visual Basic) | LicenceServer | Specifies the server to be used to obtain on-line Licences This is an advanced property and is to be used with caution
static (Shared in Visual Basic) | LicenceServerCount | Specifies how many Licence servers are to be tried to obtain on-line Licences This is an advanced property and is to be used with caution
static (Shared in Visual Basic) | MachineId | A unique string to identify each machine
static (Shared in Visual Basic) | ProxyDomain | Domain to be used if the machine's web proxy requires authentication.
static (Shared in Visual Basic) | ProxyPassword | Password to be used if the machine's web proxy requires authentication.
static (Shared in Visual Basic) | ProxyUsername | Username to be used if the machine's web proxy requires authentication.
Public Property | Source | Licence source type
Public Property | Token | The token which activated this licence
Public Property | Type | The type of this Licence that determines the allowed functions
    Top
    See Also

    Reference

    DicomLicence Class
    DicomObjects Namespace


DicomObjects Namespace / DicomLicence Class / BestLicence Property

    BestLicence Property
    Select a Licence with maximum validity and most features. Licence with most functionality will be prioritized over number of remaining days
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly Property BestLicence As DicomLicence
    'Usage

    Dim value As DicomLicence

value = DicomLicence.BestLicence
    public static DicomLicence BestLicence {get;}

    Property Value

    A DicomLicence object
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLicence Class
    DicomLicence Members


DicomObjects Namespace / DicomLicence Class / CurrentLicence Property

    CurrentLicence Property
    The DicomLicence current in use
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Property CurrentLicence As DicomLicence
    'Usage

    Dim value As DicomLicence

DicomLicence.CurrentLicence = value

value = DicomLicence.CurrentLicence
    public static DicomLicence CurrentLicence {get; set;}
    Remarks

    Only one licence can be in use at any time, and this property allows the developer to choose which of those available (from the InstalledLicences should be used, or to tell which is currently in use.

    If no Licence has specifically been selected, then DicomObject will use the BestLicence method to obtain one when this method is first called or when a Licence is first required.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLicence Class
    DicomLicence Members


DicomObjects Namespace / DicomLicence Class / Expiry Property

    Expiry Property
    The expiryDate date of the Licence
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property Expiry As Date
    'Usage

    Dim instance As DicomLicence
Dim value As Date

value = instance.Expiry
    public DateTime Expiry {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLicence Class
    DicomLicence Members


DicomObjects Namespace / DicomLicence Class / ExpiryWarningDays Property

    ExpiryWarningDays Property
    Number of days before expiryDate to start issuing warnings
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Property ExpiryWarningDays As Integer
    'Usage

    Dim value As Integer

DicomLicence.ExpiryWarningDays = value

value = DicomLicence.ExpiryWarningDays
    public static int ExpiryWarningDays {get; set;}
    Remarks
    Default value is 5. Set to 0 to disable all expiryDate warnings
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLicence Class
    DicomLicence Members


DicomObjects Namespace / DicomLicence Class / InstalledLicences Property

    InstalledLicences Property
    The list of currently available licences. This includes expired licences if any

    The property invokes internal update of available licences, minimize calls to this property to avoid delays

    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly Property InstalledLicences As IEnumerable(Of DicomLicence)
    'Usage

    Dim value As IEnumerable(Of DicomLicence)

value = DicomLicence.InstalledLicences
    public static IEnumerable<DicomLicence> InstalledLicences {get;}
    Remarks
    Licences are added to this list automatically by invoking ActivateOnLine or ActivateOffLine, and removed by invoking Deactivate
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLicence Class
    DicomLicence Members


DicomObjects Namespace / DicomLicence Class / LicenceServer Property

    LicenceServer Property
    Specifies the server to be used to obtain on-line Licences This is an advanced property and is to be used with caution
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Property LicenceServer As String
    'Usage

    Dim value As String

DicomLicence.LicenceServer = value

value = DicomLicence.LicenceServer
    public static string LicenceServer {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLicence Class
    DicomLicence Members


DicomObjects Namespace / DicomLicence Class / LicenceServerCount Property

    LicenceServerCount Property
    Specifies how many Licence servers are to be tried to obtain on-line Licences This is an advanced property and is to be used with caution
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Property LicenceServerCount As Integer
    'Usage

    Dim value As Integer

DicomLicence.LicenceServerCount = value

value = DicomLicence.LicenceServerCount
    public static int LicenceServerCount {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLicence Class
    DicomLicence Members


DicomObjects Namespace / DicomLicence Class / MachineId Property

    MachineId Property
    A unique string to identify each machine
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly Property MachineId As String
    'Usage

    Dim value As String

value = DicomLicence.MachineId
    public static string MachineId {get;}
    Remarks
    This string is needed to generate a Licence and must be entered into the web activation system when ActivateOffLine is to be used.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLicence Class
    DicomLicence Members


DicomObjects Namespace / DicomLicence Class / ProxyDomain Property

    ProxyDomain Property
    Domain to be used if the machine's web proxy requires authentication.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Property ProxyDomain As String
    'Usage

    Dim value As String

DicomLicence.ProxyDomain = value

value = DicomLicence.ProxyDomain
    public static string ProxyDomain {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLicence Class
    DicomLicence Members


DicomObjects Namespace / DicomLicence Class / ProxyPassword Property

    ProxyPassword Property
    Password to be used if the machine's web proxy requires authentication.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Property ProxyPassword As String
    'Usage

    Dim value As String

DicomLicence.ProxyPassword = value

value = DicomLicence.ProxyPassword
    public static string ProxyPassword {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLicence Class
    DicomLicence Members


DicomObjects Namespace / DicomLicence Class / ProxyUsername Property

    ProxyUsername Property
    Username to be used if the machine's web proxy requires authentication.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Property ProxyUsername As String
    'Usage

    Dim value As String

DicomLicence.ProxyUsername = value

value = DicomLicence.ProxyUsername
    public static string ProxyUsername {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLicence Class
    DicomLicence Members


DicomObjects Namespace / DicomLicence Class / Source Property

    Source Property (DicomLicence)
    In This Topic
    Licence source type
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property Source As String
    'Usage

    Dim instance As DicomLicence
Dim value As String

value = instance.Source
    public string Source {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLicence Class
    DicomLicence Members


DicomObjects Namespace / DicomLicence Class / Token Property

    Token Property
    The token which activated this licence
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property Token As String
    'Usage

    Dim instance As DicomLicence
Dim value As String

value = instance.Token
    public string Token {get;}
    Remarks
    This token would either have been obtained automatically via ActivateOnLine or entered manually via ActivateOffLine). It is an encrypted opaque token, which will generated for a specific MachineId.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLicence Class
    DicomLicence Members


DicomObjects Namespace / DicomLicence Class / Type Property

    Type Property (DicomLicence)
    In This Topic
    The type of this Licence that determines the allowed functions
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property Type As LicenceTypes
    'Usage

    Dim instance As DicomLicence
Dim value As LicenceTypes

value = instance.Type
    public LicenceTypes Type {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLicence Class
    DicomLicence Members


%%PageItemTitle%% $$Events$$

DicomObjects Namespace / DicomLicence Class

    DicomLicence Class Events
    In This Topic

    For a list of all members of this type, see DicomLicence members.

    Public Events
     | Name | Description
Public Event | LicenceExpired | Event to alert that the current temporary licence has just expired You can have code to handle the expiration, for example, licence Re-activation can happen here
Public Event | LicenceRetrieve | Event fired when DicomObjects needs to retrieve a previously stored Licence
Public Event | LicenceStore | Event fires when DicomObjects needs to store a licence
    Top
    See Also

    Reference

    DicomLicence Class
    DicomObjects Namespace


DicomObjects Namespace / DicomLicence Class / LicenceExpired Event

    LicenceExpired Event
    Event to alert that the current temporary licence has just expired

    You can have code to handle the expiration, for example, licence Re-activation can happen here

    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Event LicenceExpired As LicenceExpirationHandler
    'Usage

    Dim instance As DicomLicence
Dim handler As LicenceExpirationHandler

AddHandler instance.LicenceExpired, handler
    public event LicenceExpirationHandler LicenceExpired
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLicence Class
    DicomLicence Members


DicomObjects Namespace / DicomLicence Class / LicenceRetrieve Event

    LicenceRetrieve Event
    Event fired when DicomObjects needs to retrieve a previously stored Licence
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Event LicenceRetrieve As LicenceRetrieveHandler
    'Usage

    Dim instance As DicomLicence
Dim handler As LicenceRetrieveHandler

AddHandler instance.LicenceRetrieve, handler
    public event LicenceRetrieveHandler LicenceRetrieve
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLicence Class
    DicomLicence Members


DicomObjects Namespace / DicomLicence Class / LicenceStore Event

    LicenceStore Event
    Event fires when DicomObjects needs to store a licence
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Event LicenceStore As LicenceStoredHandler
    'Usage

    Dim instance As DicomLicence
Dim handler As LicenceStoredHandler

AddHandler instance.LicenceStore, handler
    public event LicenceStoredHandler LicenceStore
    Remarks

    DicomObjects stores licences on the system and may require privileges. In these cases, the user may choose to intercept the storage of the Licence via the LicenceStore event, and then to provide it on request via this event

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLicence Class
    DicomLicence Members


%%PageItemTitle%%

DicomObjects Namespace / DicomMaskRange Class
Members

In This Topic
    DicomMaskRange Class
    In This Topic
    Subclass of DicomImage, created for Mask Subtraction
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Class DicomMaskRange
    'Usage

    Dim instance As DicomMaskRange
    public class DicomMaskRange
    Inheritance Hierarchy

    System.Object
    DicomObjects.DicomMaskRange

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomMaskRange Members
    DicomObjects Namespace


%%PageItemTitle%% $$Members$$

DicomObjects Namespace / DicomMaskRange Class
Properties

In This Topic
    DicomMaskRange Class Members
    In This Topic

    The following tables list the members exposed by DicomMaskRange.

    Public Constructors
     | Name | Description
Public Constructor | DicomMaskRange Constructor |
    Top
    Public Properties
     | Name | Description
Public Property | ApplicableFrames | Specifies the frame ranges where mask operation is valid
Public Property | MaskFraction | Specifies the fraction used in the Mask operation
Public Property | MaskFrames | This list of frames to use as the mask. Not used if Mode is DicomObjects.Enums.MaskMode.TimeDifference, in which case see TIDOffset instead.
Public Property | MaskShift | Specifies the fractional pixel shift applied to the mask
Public Property | Mode | The enumerated values for mask subtraction mode
Public Property | NumberOfContrastFrames | Specifies the number of contrast frames to average together before performing the mask operation
Public Property | TIDOffset | Specifies the offset to be subtracted from the current frame number in order to locate the mask frame in TID mode
    Top
    See Also

    Reference

    DicomMaskRange Class
    DicomObjects Namespace


%%PageItemTitle%%

DicomObjects Namespace / DicomMaskRange Class / DicomMaskRange Constructor

In This Topic
    DicomMaskRange Constructor
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Function New()
    'Usage

    Dim instance As New DicomMaskRange()
    public DicomMaskRange()
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomMaskRange Class
    DicomMaskRange Members


%%PageItemTitle%% $$Properties$$

DicomObjects Namespace / DicomMaskRange Class

    DicomMaskRange Class Properties
    In This Topic

    For a list of all members of this type, see DicomMaskRange members.

    Public Properties
     | Name | Description
Public Property | ApplicableFrames | Specifies the frame ranges where mask operation is valid
Public Property | MaskFraction | Specifies the fraction used in the Mask operation
Public Property | MaskFrames | This list of frames to use as the mask. Not used if Mode is DicomObjects.Enums.MaskMode.TimeDifference, in which case see TIDOffset instead.
Public Property | MaskShift | Specifies the fractional pixel shift applied to the mask
Public Property | Mode | The enumerated values for mask subtraction mode
Public Property | NumberOfContrastFrames | Specifies the number of contrast frames to average together before performing the mask operation
Public Property | TIDOffset | Specifies the offset to be subtracted from the current frame number in order to locate the mask frame in TID mode
    Top
    See Also

    Reference

    DicomMaskRange Class
    DicomObjects Namespace


DicomObjects Namespace / DicomMaskRange Class / ApplicableFrames Property

    ApplicableFrames Property
    Specifies the frame ranges where mask operation is valid
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property ApplicableFrames As Integer()
    'Usage

    Dim instance As DicomMaskRange
Dim value() As Integer

instance.ApplicableFrames = value

value = instance.ApplicableFrames
    public int[] ApplicableFrames {get; set;}
    Remarks
    The list of frames to which this MaskRange applies. Frames in a Multi-frame Images are specified by sequentially increasing number values beginning with 1.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomMaskRange Class
    DicomMaskRange Members


DicomObjects Namespace / DicomMaskRange Class / MaskFraction Property

    MaskFraction Property
    Specifies the fraction used in the Mask operation
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property MaskFraction As Single
    'Usage

    Dim instance As DicomMaskRange
Dim value As Single

instance.MaskFraction = value

value = instance.MaskFraction
    public float MaskFraction {get; set;}
    Remarks
    Default value is 1.0F.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomMaskRange Class
    DicomMaskRange Members


DicomObjects Namespace / DicomMaskRange Class / MaskFrames Property

    MaskFrames Property
    This list of frames to use as the mask. Not used if Mode is DicomObjects.Enums.MaskMode.TimeDifference, in which case see TIDOffset instead.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property MaskFrames As Integer()
    'Usage

    Dim instance As DicomMaskRange
Dim value() As Integer

instance.MaskFrames = value

value = instance.MaskFrames
    public int[] MaskFrames {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomMaskRange Class
    DicomMaskRange Members


DicomObjects Namespace / DicomMaskRange Class / MaskShift Property

    MaskShift Property
    Specifies the fractional pixel shift applied to the mask
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property MaskShift As SkiaSharp.SKPoint
    'Usage

    Dim instance As DicomMaskRange
Dim value As SkiaSharp.SKPoint

instance.MaskShift = value

value = instance.MaskShift
    public SkiaSharp.SKPoint MaskShift {get; set;}
    Remarks
    A pair of floating point numbers specifying the fractional vertical [adjacent row spacing] and horizontal [adjacent column spacing] pixel shift applied to the mask before subtracting it from the contrast frame.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomMaskRange Class
    DicomMaskRange Members


DicomObjects Namespace / DicomMaskRange Class / Mode Property

    Mode Property
    The enumerated values for mask subtraction mode
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property Mode As MaskMode
    'Usage

    Dim instance As DicomMaskRange
Dim value As MaskMode

instance.Mode = value

value = instance.Mode
    public MaskMode Mode {get; set;}
    Remarks
    Enumerated values are as follows: None: No mask subtraction operation is specified AverageSubtraction: Frames are averaged together before subtraction TimeDifference: The mask is selected by subtracting the value (specified by TIDOffset property) from the respective frame number.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomMaskRange Class
    DicomMaskRange Members


DicomObjects Namespace / DicomMaskRange Class / NumberOfContrastFrames Property

    NumberOfContrastFrames Property
    Specifies the number of contrast frames to average together before performing the mask operation
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property NumberOfContrastFrames As Integer
    'Usage

    Dim instance As DicomMaskRange
Dim value As Integer

instance.NumberOfContrastFrames = value

value = instance.NumberOfContrastFrames
    public int NumberOfContrastFrames {get; set;}
    Remarks
    If not set, no averaging is performed.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomMaskRange Class
    DicomMaskRange Members


DicomObjects Namespace / DicomMaskRange Class / TIDOffset Property

    TIDOffset Property
    Specifies the offset to be subtracted from the current frame number in order to locate the mask frame in TID mode
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property TIDOffset As Integer
    'Usage

    Dim instance As DicomMaskRange
Dim value As Integer

instance.TIDOffset = value

value = instance.TIDOffset
    public int TIDOffset {get; set;}
    Remarks
    If zero length, TID Offset defaults to 1. This property is required if MaskMode is set to TimeDifference.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomMaskRange Class
    DicomMaskRange Members


%%PageItemTitle%%

DicomObjects Namespace / DicomPrint Class
Members

In This Topic
    DicomPrint Class
    In This Topic
    An object to simply printing to a DICOM printer
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Class DicomPrint
    'Usage

    Dim instance As DicomPrint
    public class DicomPrint
    Inheritance Hierarchy

    System.Object
    DicomObjects.DicomPrint

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomPrint Members
    DicomObjects Namespace


%%PageItemTitle%% $$Members$$

DicomObjects Namespace / DicomPrint Class
Properties Methods

In This Topic
    DicomPrint Class Members
    In This Topic

    The following tables list the members exposed by DicomPrint.

    Public Constructors
     | Name | Description
Public Constructor | DicomPrint Constructor | Creates a DicomPrint object
    Top
    Public Properties
     | Name | Description
Public Property | AnnotationFormat | Common printing variable, the annotation format
Public Property | Annotations | DataSets containing annotations to add to a film
Public Property | BitDepth | The bit depth to send to the printer
Public Property | Colour | Controls whether monochrome of colour printing is attempted
Public Property | Connection | Reference to the underlying DicomAssociation object used by a DicomPrint object
Public Property | Copies | Common printing variable, number of copies to print
Public Property | FilmBox | Over-rides of default values for Film Box Object
Public Property | FilmSize | Common printing variable, the size of the film
Public Property | Format | Common printing variable, the printing format
Public Property | ImageBox | Over-rides of default values for Image Box Object
Public Property | MetaSOPClass | Returns the Meta SOP Class used during the printing session
Public Property | NextPosition | Indicates/Controls the next image box to be used by PrintImage
Public Property | Orientation | Common printing variable, the printing orientation
Public Property | Printer | The well known Printer Instance (as a DicomDataSet)
Public Property | Session | Over-rides of default values for Film Session Object
Public Property | Tag | A general purpose Tag for developer use
    Top
    Public Methods
     | Name | Description
Public Method | AddAnnotation | Adds an Annotation to the Annotations collection
Public Method | CheckStatus | Check Print Status and return success or error message
Public Method | Close | Closes an association to a DICOM printer, completing any pending print operations
Public Method | Open | Opens an association to a DICOM printer for printing
Public Method | PrintFilm | Print current film
Public Method | PrintImage | Sends an image to the printer
    Top
    See Also

    Reference

    DicomPrint Class
    DicomObjects Namespace


%%PageItemTitle%%

DicomObjects Namespace / DicomPrint Class / DicomPrint Constructor

In This Topic
    DicomPrint Constructor
    In This Topic
    Creates a DicomPrint object
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Function New()
    'Usage

    Dim instance As New DicomPrint()
    public DicomPrint()

    Return Value

    DicomPrint
    Remarks

    The default constructor. The following properties are initialized during object creation:

    Property | Default Value
Session | Empty
Printer | Empty
ImageBox | Empty
FilmBox | Empty
Annotations | Empty
NextPosition | 0
BitDepth | 12
SKColor | False
Orientation | "PORTRAIT"
FilmSize | ""
AnnotationFormat | ""
Format | "STANDARD\1,1"
Copies | 1

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomPrint Class
    DicomPrint Members


%%PageItemTitle%% $$Methods$$

DicomObjects Namespace / DicomPrint Class

    DicomPrint Class Methods
    In This Topic

    For a list of all members of this type, see DicomPrint members.

    Public Methods
     | Name | Description
Public Method | AddAnnotation | Adds an Annotation to the Annotations collection
Public Method | CheckStatus | Check Print Status and return success or error message
Public Method | Close | Closes an association to a DICOM printer, completing any pending print operations
Public Method | Open | Opens an association to a DICOM printer for printing
Public Method | PrintFilm | Print current film
Public Method | PrintImage | Sends an image to the printer
    Top
    See Also

    Reference

    DicomPrint Class
    DicomObjects Namespace


DicomObjects Namespace / DicomPrint Class / AddAnnotation Method

ID of Annotation to be added

Text value of the annotation to be added

In This Topic
    AddAnnotation Method
    In This Topic
    Adds an Annotation to the Annotations collection
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Sub AddAnnotation( _
   ByVal AnnotationID As Integer, _
   ByVal AnnotationString As String _
)
    'Usage

    Dim instance As DicomPrint
Dim AnnotationID As Integer
Dim AnnotationString As String

instance.AddAnnotation(AnnotationID, AnnotationString)
    public void AddAnnotation(
   int AnnotationID,
   string AnnotationString
)

    Parameters

    AnnotationID

    ID of Annotation to be added

    AnnotationString

    Text value of the annotation to be added

    Remarks
    This is simply a shortcut way of adding items to the Annotations collection. See that property for more details of how annotations work in DicomObjects printing.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomPrint Class
    DicomPrint Members


DicomObjects Namespace / DicomPrint Class / CheckStatus Method
String

    CheckStatus Method
    In This Topic
    Check Print Status and return success or error message
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Sub CheckStatus( _
   ByVal Message As String _
)
    'Usage

    Dim instance As DicomPrint
Dim Message As String

instance.CheckStatus(Message)
    public void CheckStatus(
   string Message
)

    Parameters

    Message
    String
    Remarks
    This method checks the LastStatus property of the underlying DicomAssociation object, and returns 0 if it is a success status. If false, the default error message together with error code is logged.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomPrint Class
    DicomPrint Members


DicomObjects Namespace / DicomPrint Class / Close Method

    Close Method (DicomPrint)
    In This Topic
    Closes an association to a DICOM printer, completing any pending print operations
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Sub Close()
    'Usage

    Dim instance As DicomPrint

instance.Close()
    public void Close()
    Remarks

    It is often not necessary to call this method explicitly, as it is called automatically then the DicomPrint object goes out of scope.

    Any pending film boxes are printed (using an implicit PrintFilm method) before the association is closed.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomPrint Class
    DicomPrint Members


DicomObjects Namespace / DicomPrint Class / Open Method

Network address (as dotted notation or resolvable name) to which the association is to be made

Port on which remote application is listening

Name to quote for this Application Entity

Name of remote Application Entity

In This Topic
    Open Method (DicomPrint)
    In This Topic
    Opens an association to a DICOM printer for printing
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Sub Open( _
   ByVal Node As String, _
   ByVal Port As Integer, _
   ByVal CallingAE As String, _
   ByVal CalledAE As String _
)
    'Usage

    Dim instance As DicomPrint
Dim Node As String
Dim Port As Integer
Dim CallingAE As String
Dim CalledAE As String

instance.Open(Node, Port, CallingAE, CalledAE)
    public void Open(
   string Node,
   int Port,
   string CallingAE,
   string CalledAE
)

    Parameters

    Node

    Network address (as dotted notation or resolvable name) to which the association is to be made

    Port

    Port on which remote application is listening

    CallingAE

    Name to quote for this Application Entity

    CalledAE

    Name of remote Application Entity

    Remarks

    This method opens a new connection to the destination specified by the Node and Port property.

    Although no result is returned, success at subsequent statements can always be assumed, as failure will produce a trappable error (error like "Fail to connection at TCP level" etc.).

    As part of this method the well-known printer object is retrieved, so after this call, the Printer property becomes valid.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomPrint Class
    DicomPrint Members


DicomObjects Namespace / DicomPrint Class / PrintFilm Method

    PrintFilm Method
    Print current film
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Sub PrintFilm()
    'Usage

    Dim instance As DicomPrint

instance.PrintFilm()
    public void PrintFilm()
    Remarks
    This method is implicitly called once a film becomes "full" as a result of PrintImage calls, or when Close is called but this method is provided for those wishing to flush a film to start subsequent images on a new sheet.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomPrint Class
    DicomPrint Members


DicomObjects Namespace / DicomPrint Class / PrintImage Method

The image to print

If true, the image is presumed to be pre-formatted (e.g. from a PrinterImage method), and is sent without modification, but if false (the norm), then an internal PrinterImage method is called first, thereby "fixing" the windowing, and (if UseLabels is true) adding any annotations.

In This Topic
    PrintImage Method
    In This Topic
    Sends an image to the printer
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Sub PrintImage( _
   ByVal Image As DicomDataSet, _
   ByVal Raw As Boolean _
)
    'Usage

    Dim instance As DicomPrint
Dim Image As DicomDataSet
Dim Raw As Boolean

instance.PrintImage(Image, Raw)
    public void PrintImage(
   DicomDataSet Image,
   bool Raw
)

    Parameters

    Image

    The image to print

    Raw

    If true, the image is presumed to be pre-formatted (e.g. from a PrinterImage method), and is sent without modification, but if false (the norm), then an internal PrinterImage method is called first, thereby "fixing" the windowing, and (if UseLabels is true) adding any annotations.

    Remarks
    Unless the order is altered explicitly using NextPosition or PrintFilm, images are put into each of the image boxes on the film in the default order, and each film is printed once full.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomPrint Class
    DicomPrint Members


%%PageItemTitle%% $$Properties$$

DicomObjects Namespace / DicomPrint Class

    DicomPrint Class Properties
    In This Topic

    For a list of all members of this type, see DicomPrint members.

    Public Properties
     | Name | Description
Public Property | AnnotationFormat | Common printing variable, the annotation format
Public Property | Annotations | DataSets containing annotations to add to a film
Public Property | BitDepth | The bit depth to send to the printer
Public Property | Colour | Controls whether monochrome of colour printing is attempted
Public Property | Connection | Reference to the underlying DicomAssociation object used by a DicomPrint object
Public Property | Copies | Common printing variable, number of copies to print
Public Property | FilmBox | Over-rides of default values for Film Box Object
Public Property | FilmSize | Common printing variable, the size of the film
Public Property | Format | Common printing variable, the printing format
Public Property | ImageBox | Over-rides of default values for Image Box Object
Public Property | MetaSOPClass | Returns the Meta SOP Class used during the printing session
Public Property | NextPosition | Indicates/Controls the next image box to be used by PrintImage
Public Property | Orientation | Common printing variable, the printing orientation
Public Property | Printer | The well known Printer Instance (as a DicomDataSet)
Public Property | Session | Over-rides of default values for Film Session Object
Public Property | Tag | A general purpose Tag for developer use
    Top
    See Also

    Reference

    DicomPrint Class
    DicomObjects Namespace


DicomObjects Namespace / DicomPrint Class / AnnotationFormat Property

    AnnotationFormat Property
    Common printing variable, the annotation format
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property AnnotationFormat As String
    'Usage

    Dim instance As DicomPrint
Dim value As String

instance.AnnotationFormat = value

value = instance.AnnotationFormat
    public string AnnotationFormat {get; set;}
    Remarks

    FilmSize, Orientation, Format, AnnotationFormat and Copies, these are the most commonly used variables when printing so they are given names, so that users do not need to remember the attribute tags for each, and which of the DataSets they apply to. These properties are simply shortcuts to values in Session or FilmBox. The equivalences and default values are as below:

    Property | DataSet | Tags | Default Value
FilmSize | FilmBox | 2010, 0050 | blank (printer default)
Orientation | FilmBox | 2010, 0040 | "PORTRAIT"
Format | FilmBox | 2010, 0010 | "STANDARD\1,1"
AnnotationFormat | FilmBox | 2010, 0030 | blank
Copies | Session | 2000, 0010 | 1

    Note that the "X" in the FilmSize value must be a capital letter !

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomPrint Class
    DicomPrint Members


DicomObjects Namespace / DicomPrint Class / Annotations Property

    Annotations Property
    DataSets containing annotations to add to a film
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property Annotations As DicomDataSetCollection
    'Usage

    Dim instance As DicomPrint
Dim value As DicomDataSetCollection

value = instance.Annotations
    public DicomDataSetCollection Annotations {get;}
    Remarks
    Annotations allow one or more items of text to be added to each film printed (not each image). They are very printer-dependent, and many printers do not support them at all. The number and placement depend on the annotation format ID, which in DicomObjects should be placed, before the FilmBox is created in the AnnotationFormat property. Each DicomDataSet in this collection corresponds to one annotation, and they must be added with appropriate tags (2030,0010 for the ID and 2030,0020 for the text). Alternatively, the AddAnnotation method may be used.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomPrint Class
    DicomPrint Members


DicomObjects Namespace / DicomPrint Class / BitDepth Property

    BitDepth Property
    The bit depth to send to the printer
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property BitDepth As Integer
    'Usage

    Dim instance As DicomPrint
Dim value As Integer

instance.BitDepth = value

value = instance.BitDepth
    public int BitDepth {get; set;}
    Remarks

    Not all printers support the same bit depths, and PrintImage uses this property to ensure that images are rendered to the appropriate number of bits before being sent to the printer (though if the Raw parameter is true, this becomes the user�s responsibility).

    Default value is 12. See DicomPrint for more details of initial values.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomPrint Class
    DicomPrint Members


DicomObjects Namespace / DicomPrint Class / Colour Property

    Colour Property
    Controls whether monochrome of colour printing is attempted
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property Colour As Boolean
    'Usage

    Dim instance As DicomPrint
Dim value As Boolean

instance.Colour = value

value = instance.Colour
    public bool Colour {get; set;}
    Remarks
    If true, then the DicomPrint object attempts to use the Basic Colour Print Meta SOP Class, but if false, then he Basic GreyScale Print Meta SOP Class is used. The film box classes are also changed to suit, and PrintImage uses this property to ensure that images are rendered appropriately (though if the Raw parameter is true, this becomes the user's responsibility).
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomPrint Class
    DicomPrint Members


DicomObjects Namespace / DicomPrint Class / Connection Property

    Connection Property
    Reference to the underlying DicomAssociation object used by a DicomPrint object
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property Connection As DicomAssociation
    'Usage

    Dim instance As DicomPrint
Dim value As DicomAssociation

value = instance.Connection
    public DicomAssociation Connection {get;}

    Property Value

    The underlying DicomAssociation
    Remarks
    This property is useful when extra operations are required over a print association, and enables the user to use the simplified interface provided by DicomPrint object, yet still have flexibility to make arbitrary requests. In particular, it can be used to N-GET the well-known printer instance during an association to check for the printer's status.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomPrint Class
    DicomPrint Members


DicomObjects Namespace / DicomPrint Class / Copies Property

    Copies Property
    Common printing variable, number of copies to print
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property Copies As Short
    'Usage

    Dim instance As DicomPrint
Dim value As Short

instance.Copies = value

value = instance.Copies
    public short Copies {get; set;}
    Remarks

    FilmSize, Orientation, Format, AnnotationFormat and Copies, these are the most commonly used variables when printing so they are given names, so that users do not need to remember the attribute tags for each, and which of the DataSets they apply to. These properties are simply shortcuts to values in Session or FilmBox. The equivalences and default values are as below:

    Property | DataSet | Tags | Default Value
FilmSize | FilmBox | 2010, 0050 | blank (printer default)
Orientation | FilmBox | 2010, 0040 | "PORTRAIT"
Format | FilmBox | 2010, 0010 | "STANDARD\1,1"
AnnotationFormat | FilmBox | 2010, 0030 | blank
Copies | Session | 2000, 0010 | 1

    Note that the "X" in the FilmSize value must be a capital letter, for example, 512X512.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomPrint Class
    DicomPrint Members


DicomObjects Namespace / DicomPrint Class / FilmBox Property

    FilmBox Property
    Over-rides of default values for Film Box Object
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property FilmBox As DicomDataSet
    'Usage

    Dim instance As DicomPrint
Dim value As DicomDataSet

value = instance.FilmBox
    public DicomDataSet FilmBox {get;}
    Remarks

    When this object is created during printing, values can be passed in the N-CREATE message, and the resulting dataset is retrieved. This property allows the initial values to be set to any non-default values needed.

    Some of the more commonly used properties have been given their own properties of the DicomPrint objects. These are FilmSize, Orientation, Format & AnnotationFormat. Values placed in the FilmBox object immediately update the corresponding values elements in the FilmBox property.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomPrint Class
    DicomPrint Members


DicomObjects Namespace / DicomPrint Class / FilmSize Property

    FilmSize Property
    Common printing variable, the size of the film
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property FilmSize As String
    'Usage

    Dim instance As DicomPrint
Dim value As String

instance.FilmSize = value

value = instance.FilmSize
    public string FilmSize {get; set;}
    Remarks

    FilmSize, Orientation, Format, AnnotationFormat and Copies, these are the most commonly used variables when printing so they are given names, so that users do not need to remember the attribute tags for each, and which of the DataSets they apply to. These properties are simply shortcuts to values in Session or FilmBox. The equivalences and default values are as below:

    Property | DataSet | Tags | Default Value
FilmSize | FilmBox | 2010, 0050 | blank (printer default)
Orientation | FilmBox | 2010, 0040 | "PORTRAIT"
Format | FilmBox | 2010, 0010 | "STANDARD\1,1"
AnnotationFormat | FilmBox | 2010, 0030 | blank
Copies | Session | 2000, 0010 | 1

    Note that the "X" in the FilmSize value must be a capital letter !

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomPrint Class
    DicomPrint Members


DicomObjects Namespace / DicomPrint Class / Format Property

    Format Property
    Common printing variable, the printing format
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property Format As String
    'Usage

    Dim instance As DicomPrint
Dim value As String

instance.Format = value

value = instance.Format
    public string Format {get; set;}
    Remarks

    FilmSize, Orientation, Format, AnnotationFormat and Copies, these are the most commonly used variables when printing so they are given names, so that users do not need to remember the attribute tags for each, and which of the DataSets they apply to. These properties are simply shortcuts to values in Session or FilmBox. The equivalences and default values are as below:

    Property | DataSet | Tags | Default Value
FilmSize | FilmBox | 2010, 0050 | blank (printer default)
Orientation | FilmBox | 2010, 0040 | "PORTRAIT"
Format | FilmBox | 2010, 0010 | "STANDARD\1,1"
AnnotationFormat | FilmBox | 2010, 0030 | blank
Copies | Session | 2000, 0010 | 1

    Note that the "X" in the FilmSize value must be a capital letter !

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomPrint Class
    DicomPrint Members


DicomObjects Namespace / DicomPrint Class / ImageBox Property

    ImageBox Property
    Over-rides of default values for Image Box Object
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property ImageBox As DicomDataSet
    'Usage

    Dim instance As DicomPrint
Dim value As DicomDataSet

value = instance.ImageBox
    public DicomDataSet ImageBox {get;}
    Remarks
    When this object is created during printing, values can be passed in the N-CREATE message, and the resulting dataset is retrieved. This property allows the initial values to be set to any non-default values needed.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomPrint Class
    DicomPrint Members


DicomObjects Namespace / DicomPrint Class / MetaSOPClass Property

    MetaSOPClass Property (DicomPrint)
    In This Topic
    Returns the Meta SOP Class used during the printing session
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property MetaSOPClass As String
    'Usage

    Dim instance As DicomPrint
Dim value As String

value = instance.MetaSOPClass
    public string MetaSOPClass {get;}
    Remarks
    Returns Meta_BasicColorPrintSOP Class UID "1.2.840.10008.5.1.1.18" if printing in color, otherwise returns BasicGrayscalePrint SOP Class UID "1.2.840.10008.5.1.1.9".
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomPrint Class
    DicomPrint Members


DicomObjects Namespace / DicomPrint Class / NextPosition Property

    NextPosition Property
    Indicates/Controls the next image box to be used by PrintImage
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property NextPosition As Integer
    'Usage

    Dim instance As DicomPrint
Dim value As Integer

instance.NextPosition = value

value = instance.NextPosition
    public int NextPosition {get; set;}
    Remarks
    The value ranges from 1 to n where n is the number of image boxes in the current film box, which in turn depends on the value of Format. If this property is not altered, then images are printed sequentially.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomPrint Class
    DicomPrint Members


DicomObjects Namespace / DicomPrint Class / Orientation Property

    Orientation Property
    Common printing variable, the printing orientation
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property Orientation As String
    'Usage

    Dim instance As DicomPrint
Dim value As String

instance.Orientation = value

value = instance.Orientation
    public string Orientation {get; set;}
    Remarks

    FilmSize, Orientation, Format, AnnotationFormat and Copies, these are the most commonly used variables when printing so they are given names, so that users do not need to remember the attribute tags for each, and which of the DataSets they apply to. These properties are simply shortcuts to values in Session or FilmBox. The equivalences and default values are as below:

    Property | DataSet | Tags | Default Value
FilmSize | FilmBox | 2010, 0050 | blank (printer default)
Orientation | FilmBox | 2010, 0040 | "PORTRAIT"
Format | FilmBox | 2010, 0010 | "STANDARD\1,1"
AnnotationFormat | FilmBox | 2010, 0030 | blank
Copies | Session | 2000, 0010 | 1

    Note that the "X" in the FilmSize value must be a capital letter !

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomPrint Class
    DicomPrint Members


DicomObjects Namespace / DicomPrint Class / Printer Property

    Printer Property
    The well known Printer Instance (as a DicomDataSet)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property Printer As DicomDataSet
    'Usage

    Dim instance As DicomPrint
Dim value As DicomDataSet

value = instance.Printer
    public DicomDataSet Printer {get;}
    Remarks

    When the DicomPrint's Open method is called, the well-known SOP instance representing the printer is retrieved, and placed into this property, which may allow some useful information about the printer and it�s current state to be determined before attempting to print any images.

    Please check the printer�s conformance statement for more details of what information may be available.

    To get updated information after the initial connection, use an NGet operation on the DicomAssociation object.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomPrint Class
    DicomPrint Members


DicomObjects Namespace / DicomPrint Class / Session Property

    Session Property
    Over-rides of default values for Film Session Object
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property Session As DicomDataSet
    'Usage

    Dim instance As DicomPrint
Dim value As DicomDataSet

value = instance.Session
    public DicomDataSet Session {get;}
    Remarks

    When this object is created during printing, values can be passed in the N-CREATE message, and the resulting dataset is retrieved. This property allows the initial values to be set to any non-default values needed.

    Values placed in the Copies property of DicomPrint object will immediately update the corresponding value element in the Session property.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomPrint Class
    DicomPrint Members


DicomObjects Namespace / DicomPrint Class / Tag Property

    Tag Property (DicomPrint)
    In This Topic
    A general purpose Tag for developer use
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property Tag As Object
    'Usage

    Dim instance As DicomPrint
Dim value As Object

instance.Tag = value

value = instance.Tag
    public object Tag {get; set;}
    Remarks
    This property is not used by DicomObjects in any way, and is provided purely as a convenience for developers who wish to associate other objects with this object. As an alternative, most of the objects in DicomObjects can have other classes derived from them.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomPrint Class
    DicomPrint Members


%%PageItemTitle%%

DicomObjects Namespace / DicomQuery Class
Members

In This Topic
    DicomQuery Class
    In This Topic
    Object used for DICOM Query/retrieve SCU operations
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Class DicomQuery
    'Usage

    Dim instance As DicomQuery
    public class DicomQuery
    Remarks

    A DicomQuery Object that facilitates the querying of information and retrieval of images from DICOM servers that support the Query/Retrieve protocols as a Service Class Provider (SCP)

    A useful feature of this object is that is re-usable, so as the user descends though a hierarchical search, new constraints may be added, and the search repeated, with having to re-set those already used.

    The query object can be used either to retrieve images to itself for data extraction, conversion to JPEG etc., or it may initiate DICOM C-MOVE requests to send the images to another entity, commonly a DicomServer control.

    Inheritance Hierarchy

    System.Object
    DicomObjects.DicomQuery

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomQuery Members
    DicomObjects Namespace


%%PageItemTitle%% $$Members$$

DicomObjects Namespace / DicomQuery Class
Properties Methods Events

In This Topic
    DicomQuery Class Members
    In This Topic

    The following tables list the members exposed by DicomQuery.

    Public Constructors
     | Name | Description
Public Constructor | DicomQuery Constructor | Create a new DicomQuery Object
    Top
    Public Properties
     | Name | Description
Public Property | CalculatedFrameList | Specify the list of frames (by triplets with the starting frame, ending frame and frame step) for Frame Level Retrival
Public Property | CalledAE | The Application Entity Title of the server providing the Query/Retrieve service to which the DicomQuery object is requesting a connection
Public Property | CallingAE | The Application Entity Title by which the DicomQuery object is to be known during its connection to the server providing the Query/Retrieve service
Public Property | DateOfBirth | Demographic details of the patient
Public Property | Destination | The Application Entity Name to which images should be sent by a C-MOVE request
Public Property | FrameTimes | Specify the range of frames by frame time, used for Frame Level Retrival
Public Property | InstanceUID | Unique identifiers for the four levels of the DICOM Query/Retrieve hierarchy
Public Property | Level | Define the level of query or retrieve request within the DICOM search hierarchies.
Public Property | Name | Demographic details of the patient
Public Property | NoBulkData | Specify if bulk data is required in the FrameLevelRetrieve C-GET response
Public Property | Node | The IP address at which the Query/Retrieve service to which the DicomQuery object is requesting a connection may be found
Public Property | PatientID | Unique identifiers for the four levels of the DICOM Query/Retrieve hierarchy
Public Property | Port | The TCP port at which the Query/Retrieve service to which the DicomQuery object is requesting a connection is listening
Public Property | Root | Define the type of query requested within the DICOM search hierarchies.
Public Property | SeriesUID | Unique identifiers for the four levels of the DICOM Query/Retrieve hierarchy
Public Property | Sex | Demographic details of the patient
Public Property | SimpleFrameList | Specify the list of single frames (by frame number) for Frame Level Retrival
Public Property | StudyDate | The date or date range to be searched for suitable studies
Public Property | StudyUID | Unique identifiers for the four levels of the DICOM Query/Retrieve hierarchy
Public Property | Tag | A general purpose Tag for developer use
Public Property | TransferSyntaxes | Controls the allowed transfer syntaxes for outgoing operations (C-FIND, C-MOVE & C-GET)
    Top
    Public Methods
     | Name | Description
Public Method | Find | Overloaded. Perform a C-FIND as SCU
Public Method | Get | Overloaded. Perform a C-GET as SCU
Public Method | Move | Overloaded. Perform a C-MOVE as SCU
Public Method | QueryDataSet | Returns the dataset which would have been used by Find method.
Public Method | RetrieveDataSet | Returns the DataSet which would have been used by Get or Move method
    Top
    Public Events
     | Name | Description
Public Event | InitiateTls | Routine to use to generate encrypted stream when TLS is to be used for outgoing associations.
Public Event | ResponseReceived | Event fires when a response is received on an out-going operation
    Top
    See Also

    Reference

    DicomQuery Class
    DicomObjects Namespace


%%PageItemTitle%%

DicomObjects Namespace / DicomQuery Class / DicomQuery Constructor

In This Topic
    DicomQuery Constructor
    In This Topic
    Create a new DicomQuery Object
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Function New()
    'Usage

    Dim instance As New DicomQuery()
    public DicomQuery()

    Return Value

    DicomQuery
    Remarks
    This is the Constructor method.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomQuery Class
    DicomQuery Members


%%PageItemTitle%% $$Methods$$

DicomObjects Namespace / DicomQuery Class

    DicomQuery Class Methods
    In This Topic

    For a list of all members of this type, see DicomQuery members.

    Public Methods
     | Name | Description
Public Method | Find | Overloaded. Perform a C-FIND as SCU
Public Method | Get | Overloaded. Perform a C-GET as SCU
Public Method | Move | Overloaded. Perform a C-MOVE as SCU
Public Method | QueryDataSet | Returns the dataset which would have been used by Find method.
Public Method | RetrieveDataSet | Returns the DataSet which would have been used by Get or Move method
    Top
    See Also

    Reference

    DicomQuery Class
    DicomObjects Namespace


DicomObjects Namespace / DicomQuery Class / Find Method

    Find Method (DicomQuery)
    In This Topic
    Perform a C-FIND as SCU
    Overload List
    Overload | Description
Find() | Perform a C-FIND as SCU without any search criteria.
Find(DicomDataSet) | Perform a C-FIND as SCU with search criteria.
Find(DicomAssociation,DicomDataSet) | Perform a C-FIND as SCU with search criteria.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomQuery Class
    DicomQuery Members


DicomObjects Namespace / DicomQuery Class / Find Method / Find() Method

    Find() Method
    Perform a C-FIND as SCU without any search criteria.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Function Find() As DicomDataSetCollection
    'Usage

    Dim instance As DicomQuery
Dim value As DicomDataSetCollection

value = instance.Find()
    public DicomDataSetCollection Find()

    Return Value

    DicomDataSetCollection
    Remarks

    This method takes no parameters, as all values are set as properties of the DicomQuery Object.

    The returned value is an object of type DicomDataSetCollection, containing one or more DicomDataSet for each single successful match. An unsuccessful search produces no error, but the Count property of the returned DicomDataSetCollection object will be Zero.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomQuery Class
    DicomQuery Members
    Overload List


DicomObjects Namespace / DicomQuery Class / Find Method / Find(DicomDataSet) Method

DicomDataSet containing the search criteria

    Find(DicomDataSet) Method
    In This Topic
    Perform a C-FIND as SCU with search criteria.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Function Find( _
   ByVal Request As DicomDataSet _
) As DicomDataSetCollection
    'Usage

    Dim instance As DicomQuery
Dim Request As DicomDataSet
Dim value As DicomDataSetCollection

value = instance.Find(Request)
    public DicomDataSetCollection Find(
   DicomDataSet Request
)

    Parameters

    Request

    DicomDataSet containing the search criteria

    Return Value

    DicomDataSetCollection
    Remarks
    This method is intended for advanced users, requiring more control over the query than can be achieved using the Query object's standard properties, and methods. Note that the Level value (Attribute 0008, 0052) where relevant must be included in the DataSet parameter. (For e.g. Level is not required for MWL query but it is required when quering for Patients, Studies, Series or Instances directly)
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomQuery Class
    DicomQuery Members
    Overload List


DicomObjects Namespace / DicomQuery Class / Find Method / Find(DicomAssociation,DicomDataSet) Method

DicomAssociation Exposes the underlying DICOM association object

DicomDataSet containing the search criteria

In This Topic
    Find(DicomAssociation,DicomDataSet) Method
    In This Topic
    Perform a C-FIND as SCU with search criteria.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Function Find( _
   ByVal Association As DicomAssociation, _
   ByVal Request As DicomDataSet _
) As DicomDataSetCollection
    'Usage

    Dim instance As DicomQuery
Dim Association As DicomAssociation
Dim Request As DicomDataSet
Dim value As DicomDataSetCollection

value = instance.Find(Association, Request)
    public DicomDataSetCollection Find(
   DicomAssociation Association,
   DicomDataSet Request
)

    Parameters

    Association

    DicomAssociation Exposes the underlying DICOM association object

    Request

    DicomDataSet containing the search criteria

    Return Value

    DicomDataSetCollection
    Remarks
    This method is based on the Find(DicomDataSet) method, but user can create their own DicomAssociation object so that access to other data, for example lastStatus, error message, can be available
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomQuery Class
    DicomQuery Members
    Overload List


DicomObjects Namespace / DicomQuery Class / Get Method

    Get Method (DicomQuery)
    In This Topic
    Perform a C-GET as SCU
    Overload List
    Overload | Description
Get() | Perform a C-GET as SCU without any search criteria
Get(DicomDataSet) | Perform a C-GET as SCU with matching criteria
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomQuery Class
    DicomQuery Members


DicomObjects Namespace / DicomQuery Class / Get Method / Get() Method

    Get() Method
    Perform a C-GET as SCU without any search criteria
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Function Get() As DicomDataSetCollection
    'Usage

    Dim instance As DicomQuery
Dim value As DicomDataSetCollection

value = instance.Get()
    public DicomDataSetCollection Get()

    Return Value

    DicomDataSetCollection
    Remarks

    This method takes no parameters, as all values are set as properties of the DicomQuery object.

    The returned value is an object of type DicomDataSetCollection, containing one DicomImage for each successful match. An unsuccessful retrieval produces no error, but the Count property of the returned DicomImages objects will be zero.

    Note that many servers do not support the C-GET protocol required for this method, requiring instead C-MOVE. In this case, use the Move method instead.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomQuery Class
    DicomQuery Members
    Overload List


DicomObjects Namespace / DicomQuery Class / Get Method / Get(DicomDataSet) Method

DicomDataSet containing the search criteria

    Get(DicomDataSet) Method
    In This Topic
    Perform a C-GET as SCU with matching criteria
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Function Get( _
   ByVal Request As DicomDataSet _
) As DicomDataSetCollection
    'Usage

    Dim instance As DicomQuery
Dim Request As DicomDataSet
Dim value As DicomDataSetCollection

value = instance.Get(Request)
    public DicomDataSetCollection Get(
   DicomDataSet Request
)

    Parameters

    Request

    DicomDataSet containing the search criteria

    Return Value

    DicomDataSetCollection

    Remarks

    This method is intended for advanced users, requiring more control over the query DataSet than can be achieved using the Query object's standard properties, and methods. Note that the Level value (Attribute 0008, 0052), must be included in the DataSet.

    The returned value is an object of type DicomDataSetCollection, containing one DicomImage for each successful match. An unsuccessful retrieval produces no error, but the Count property of the returned DicomImages objects will be zero.

    Note that many servers do not support the C-GET protocol required for this method, requiring instead C-MOVE. In this case, use the Move method instead.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomQuery Class
    DicomQuery Members
    Overload List


DicomObjects Namespace / DicomQuery Class / Move Method

    Move Method (DicomQuery)
    In This Topic
    Perform a C-MOVE as SCU
    Overload List
    Overload | Description
Move() | Perform a C-MOVE as SCU without any search criteria
Move(DicomDataSet) | Perform a C-MOVE as SCU with matching criteria
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomQuery Class
    DicomQuery Members


DicomObjects Namespace / DicomQuery Class / Move Method / Move() Method

    Move() Method
    Perform a C-MOVE as SCU without any search criteria
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Function Move() As DicomDataSet
    'Usage

    Dim instance As DicomQuery
Dim value As DicomDataSet

value = instance.Move()
    public DicomDataSet Move()

    Return Value

    DicomDataSet, which contains the final response from SCP.
    Remarks

    This method takes no parameters, as all values are set as properties of the DicomQuery Object.

    Images are requested to be transferred to the application entity specified by the DicomQuery object's Destination property.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomQuery Class
    DicomQuery Members
    Overload List


DicomObjects Namespace / DicomQuery Class / Move Method / Move(DicomDataSet) Method

DicomDataSet containing the search criteria

    Move(DicomDataSet) Method
    In This Topic
    Perform a C-MOVE as SCU with matching criteria
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Function Move( _
   ByVal Request As DicomDataSet _
) As DicomDataSet
    'Usage

    Dim instance As DicomQuery
Dim Request As DicomDataSet
Dim value As DicomDataSet

value = instance.Move(Request)
    public DicomDataSet Move(
   DicomDataSet Request
)

    Parameters

    Request

    DicomDataSet containing the search criteria

    Return Value

    DicomDataSet, which contains the final response from SCP.
    Remarks

    This method is intended for advanced users, requiring more control over the query DataSet than can be achieved using the Query object's standard properties, and methods. Note that the Level value (Attribute 0008, 0052), must be included in the DataSet.

    Images are requested to be transferred to the application entity specified by the DicomQuery object's Destination property.

    Final status of the MOVE operation can be obtained in Attribute [0x0000, 0x0900] of the returned DataSet.

    Responses during the entire C-MOVE operation can be obtained in the DicomQuery's ResponseReceived Event.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomQuery Class
    DicomQuery Members
    Overload List


DicomObjects Namespace / DicomQuery Class / QueryDataSet Method

    QueryDataSet Method
    Returns the dataset which would have been used by Find method.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Function QueryDataSet() As DicomDataSet
    'Usage

    Dim instance As DicomQuery
Dim value As DicomDataSet

value = instance.QueryDataSet()
    public DicomDataSet QueryDataSet()

    Return Value

    DicomDataSet
    Remarks
    This method returns exactly the same dataset that would have been used for a Find method, which depends on most of the other DicomQuery parameters such as Root, Level etc. The result is suitable for passing to Find, normally after some modification/addition and this method is particularly useful where a slight variation on the “standard” queries generated by Find is required, but the user does not wish to generate a whole new dataset from scratch.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomQuery Class
    DicomQuery Members


DicomObjects Namespace / DicomQuery Class / RetrieveDataSet Method

    RetrieveDataSet Method
    Returns the DataSet which would have been used by Get or Move method
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Function RetrieveDataSet() As DicomDataSet
    'Usage

    Dim instance As DicomQuery
Dim value As DicomDataSet

value = instance.RetrieveDataSet()
    public DicomDataSet RetrieveDataSet()

    Return Value

    DicomDataSet
    Remarks
    This method returns the DataSet which would have been used for a Get or Move method. Request level is set and UIDs are set according to the value of the level. If Patient Level then PatientID is set; if Study Level then PatientID and StudyUID are set; if Series Level then then PatientID, StudyUID and SeriesUID are set; if Image Level then PatientID, StudyUID, SeriesUID and InstanceUID are set.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomQuery Class
    DicomQuery Members


%%PageItemTitle%% $$Properties$$

DicomObjects Namespace / DicomQuery Class

    DicomQuery Class Properties
    In This Topic

    For a list of all members of this type, see DicomQuery members.

    Public Properties
     | Name | Description
Public Property | CalculatedFrameList | Specify the list of frames (by triplets with the starting frame, ending frame and frame step) for Frame Level Retrival
Public Property | CalledAE | The Application Entity Title of the server providing the Query/Retrieve service to which the DicomQuery object is requesting a connection
Public Property | CallingAE | The Application Entity Title by which the DicomQuery object is to be known during its connection to the server providing the Query/Retrieve service
Public Property | DateOfBirth | Demographic details of the patient
Public Property | Destination | The Application Entity Name to which images should be sent by a C-MOVE request
Public Property | FrameTimes | Specify the range of frames by frame time, used for Frame Level Retrival
Public Property | InstanceUID | Unique identifiers for the four levels of the DICOM Query/Retrieve hierarchy
Public Property | Level | Define the level of query or retrieve request within the DICOM search hierarchies.
Public Property | Name | Demographic details of the patient
Public Property | NoBulkData | Specify if bulk data is required in the FrameLevelRetrieve C-GET response
Public Property | Node | The IP address at which the Query/Retrieve service to which the DicomQuery object is requesting a connection may be found
Public Property | PatientID | Unique identifiers for the four levels of the DICOM Query/Retrieve hierarchy
Public Property | Port | The TCP port at which the Query/Retrieve service to which the DicomQuery object is requesting a connection is listening
Public Property | Root | Define the type of query requested within the DICOM search hierarchies.
Public Property | SeriesUID | Unique identifiers for the four levels of the DICOM Query/Retrieve hierarchy
Public Property | Sex | Demographic details of the patient
Public Property | SimpleFrameList | Specify the list of single frames (by frame number) for Frame Level Retrival
Public Property | StudyDate | The date or date range to be searched for suitable studies
Public Property | StudyUID | Unique identifiers for the four levels of the DICOM Query/Retrieve hierarchy
Public Property | Tag | A general purpose Tag for developer use
Public Property | TransferSyntaxes | Controls the allowed transfer syntaxes for outgoing operations (C-FIND, C-MOVE & C-GET)
    Top
    See Also

    Reference

    DicomQuery Class
    DicomObjects Namespace


DicomObjects Namespace / DicomQuery Class / CalculatedFrameList Property

    CalculatedFrameList Property
    Specify the list of frames (by triplets with the starting frame, ending frame and frame step) for Frame Level Retrival
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property CalculatedFrameList As Integer()
    'Usage

    Dim instance As DicomQuery
Dim value() As Integer

instance.CalculatedFrameList = value

value = instance.CalculatedFrameList
    public int[] CalculatedFrameList {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomQuery Class
    DicomQuery Members


DicomObjects Namespace / DicomQuery Class / CalledAE Property

    CalledAE Property
    The Application Entity Title of the server providing the Query/Retrieve service to which the DicomQuery object is requesting a connection
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property CalledAE As String
    'Usage

    Dim instance As DicomQuery
Dim value As String

instance.CalledAE = value

value = instance.CalledAE
    public string CalledAE {get; set;}
    Remarks
    Some servers allow access from any application entity, whilst others must be configured to include a list of "allowable" clients. Whilst this software allows an arbitrary choice of AE name, it would be prudent to keep to a limited, unique list for each machine.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomQuery Class
    DicomQuery Members


DicomObjects Namespace / DicomQuery Class / CallingAE Property

    CallingAE Property
    The Application Entity Title by which the DicomQuery object is to be known during its connection to the server providing the Query/Retrieve service
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property CallingAE As String
    'Usage

    Dim instance As DicomQuery
Dim value As String

instance.CallingAE = value

value = instance.CallingAE
    public string CallingAE {get; set;}
    Remarks
    For most servers this value must be looked up in the server’s documentation, and must be exactly correct for an association to be accepted.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomQuery Class
    DicomQuery Members


DicomObjects Namespace / DicomQuery Class / DateOfBirth Property

    DateOfBirth Property (DicomQuery)
    In This Topic
    Demographic details of the patient
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property DateOfBirth As String
    'Usage

    Dim instance As DicomQuery
Dim value As String

instance.DateOfBirth = value

value = instance.DateOfBirth
    public string DateOfBirth {get; set;}
    Remarks
    This property is used as search criteria only when QueryLevel is set to "PATIENT" and this property may be set to a string representing a range of values, but it is the user's responsibility to ensure that this is formatted exactly according to the DICOM standard format i.e. YYYYMMDD-YYYYMMDD.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomQuery Class
    DicomQuery Members


DicomObjects Namespace / DicomQuery Class / Destination Property

    Destination Property (DicomQuery)
    In This Topic
    The Application Entity Name to which images should be sent by a C-MOVE request
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property Destination As String
    'Usage

    Dim instance As DicomQuery
Dim value As String

instance.Destination = value

value = instance.Destination
    public string Destination {get; set;}
    Remarks
    A Query/Retrieve SCP should use this property to find the values of the IP address, port number and possibly calling AET to use before calling the Open method to respond any C-MOVE request.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomQuery Class
    DicomQuery Members


DicomObjects Namespace / DicomQuery Class / FrameTimes Property

    FrameTimes Property
    Specify the range of frames by frame time, used for Frame Level Retrival
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property FrameTimes As Date()
    'Usage

    Dim instance As DicomQuery
Dim value() As Date

instance.FrameTimes = value

value = instance.FrameTimes
    public DateTime[] FrameTimes {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomQuery Class
    DicomQuery Members


DicomObjects Namespace / DicomQuery Class / InstanceUID Property

    InstanceUID Property (DicomQuery)
    In This Topic
    Unique identifiers for the four levels of the DICOM Query/Retrieve hierarchy
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property InstanceUID As String
    'Usage

    Dim instance As DicomQuery
Dim value As String

instance.InstanceUID = value

value = instance.InstanceUID
    public string InstanceUID {get; set;}
    Remarks
    InstanceUID value is used to uniquely identify each single DICOM instance.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomQuery Class
    DicomQuery Members


DicomObjects Namespace / DicomQuery Class / Level Property

    Level Property (DicomQuery)
    In This Topic
    Define the level of query or retrieve request within the DICOM search hierarchies.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property Level As QueryLevel
    'Usage

    Dim instance As DicomQuery
Dim value As QueryLevel

instance.Level = value

value = instance.Level
    public QueryLevel Level {get; set;}
    Remarks

    DICOM defines three different hierarchies for image-related Query/Retrieve operations, each of which has different semantics and allowable search levels. The allowable combinations of QueryRoot and QueryLevel are:

    Root | PATIENT | STUDY | PATIENTSTUDY
Permitted Levels | PATIENT STUDY SERIES IMAGE | STUDY SERIES IMAGE | PATIENT STUDY

    In addition, to the above values, Root may be set to “WORKLIST” to indicate a Modality Worklist query, or “GP-WORKLIST” to indicate a General Purpose Worklist query, but if this is done, then a Find must be performed with a DicomDataSet parameter, as the parameters for the query DataSet are very different to those used for the other queries.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomQuery Class
    DicomQuery Members


DicomObjects Namespace / DicomQuery Class / Name Property

    Name Property (DicomQuery)
    In This Topic
    Demographic details of the patient
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property Name As String
    'Usage

    Dim instance As DicomQuery
Dim value As String

instance.Name = value

value = instance.Name
    public string Name {get; set;}
    Remarks
    This property is used as search criteria only when QueryLevel is set to "PATIENT".
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomQuery Class
    DicomQuery Members


DicomObjects Namespace / DicomQuery Class / NoBulkData Property

    NoBulkData Property
    Specify if bulk data is required in the FrameLevelRetrieve C-GET response
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property NoBulkData As Boolean
    'Usage

    Dim instance As DicomQuery
Dim value As Boolean

instance.NoBulkData = value

value = instance.NoBulkData
    public bool NoBulkData {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomQuery Class
    DicomQuery Members


DicomObjects Namespace / DicomQuery Class / Node Property

    Node Property
    The IP address at which the Query/Retrieve service to which the DicomQuery object is requesting a connection may be found
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property Node As String
    'Usage

    Dim instance As DicomQuery
Dim value As String

instance.Node = value

value = instance.Node
    public string Node {get; set;}
    Remarks
    This may be any form of IP address, either dotted numerical or text name, understandable by the machines IP implementation.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomQuery Class
    DicomQuery Members


DicomObjects Namespace / DicomQuery Class / PatientID Property

    PatientID Property (DicomQuery)
    In This Topic
    Unique identifiers for the four levels of the DICOM Query/Retrieve hierarchy
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property PatientID As String
    'Usage

    Dim instance As DicomQuery
Dim value As String

instance.PatientID = value

value = instance.PatientID
    public string PatientID {get; set;}
    Remarks

    For DicomQuery object, this property must be set for all levels of the hierarchy above the current Level.

    e.g. if Root is "PATIENT", and Level is "STUDY" then PatientID must be set to appropriate values.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomQuery Class
    DicomQuery Members


DicomObjects Namespace / DicomQuery Class / Port Property

    Port Property
    The TCP port at which the Query/Retrieve service to which the DicomQuery object is requesting a connection is listening
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property Port As Integer
    'Usage

    Dim instance As DicomQuery
Dim value As Integer

instance.Port = value

value = instance.Port
    public int Port {get; set;}
    Remarks
    The "official" value for DICOM should be 104, but many manufacturers use other values such as 4006. Please check with the documentation of the service provider.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomQuery Class
    DicomQuery Members


DicomObjects Namespace / DicomQuery Class / Root Property

    Root Property (DicomQuery)
    In This Topic
    Define the type of query requested within the DICOM search hierarchies.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property Root As QueryRoot
    'Usage

    Dim instance As DicomQuery
Dim value As QueryRoot

instance.Root = value

value = instance.Root
    public QueryRoot Root {get; set;}
    Remarks

    DICOM defines three different hierarchies for image-related Query/Retrieve operations, each of which has different semantics and allowable search levels. The allowable combinations of QueryRoot and QueryLevel are:

    Root | PATIENT | STUDY | PATIENTSTUDY
Permitted Levels | PATIENT STUDY SERIES IMAGE | STUDY SERIES IMAGE | PATIENT STUDY

    In addition, to the above values, Root may be set to “WORKLIST” to indicate a Modality Worklist query, or “GP-WORKLIST” to indicate a General Purpose Worklist query, but if this is done, then a Find must be performed with a DicomDataSet parameter, as the parameters for the query DataSet are very different to those used for the other queries.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomQuery Class
    DicomQuery Members


DicomObjects Namespace / DicomQuery Class / SeriesUID Property

    SeriesUID Property (DicomQuery)
    In This Topic
    Unique identifiers for the four levels of the DICOM Query/Retrieve hierarchy
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property SeriesUID As String
    'Usage

    Dim instance As DicomQuery
Dim value As String

instance.SeriesUID = value

value = instance.SeriesUID
    public string SeriesUID {get; set;}
    Remarks

    SeriesUID must be set to appropriate value if Level is "IMAGE".

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomQuery Class
    DicomQuery Members


DicomObjects Namespace / DicomQuery Class / Sex Property

    Sex Property (DicomQuery)
    In This Topic
    Demographic details of the patient
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property Sex As String
    'Usage

    Dim instance As DicomQuery
Dim value As String

instance.Sex = value

value = instance.Sex
    public string Sex {get; set;}
    Remarks
    This property is used as search criteria only when QueryLevel is set to "PATIENT".
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomQuery Class
    DicomQuery Members


DicomObjects Namespace / DicomQuery Class / SimpleFrameList Property

    SimpleFrameList Property
    Specify the list of single frames (by frame number) for Frame Level Retrival
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property SimpleFrameList As Integer()
    'Usage

    Dim instance As DicomQuery
Dim value() As Integer

instance.SimpleFrameList = value

value = instance.SimpleFrameList
    public int[] SimpleFrameList {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomQuery Class
    DicomQuery Members


DicomObjects Namespace / DicomQuery Class / StudyDate Property

    StudyDate Property
    The date or date range to be searched for suitable studies
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property StudyDate As String
    'Usage

    Dim instance As DicomQuery
Dim value As String

instance.StudyDate = value

value = instance.StudyDate
    public string StudyDate {get; set;}
    Remarks
    Like DateOfBirth, this property may either contain a single value, in any form intelligible as a date, or if a range is required, then it must comply exactly with the DICOM format for date ranges, namely YYYYMMDD-YYYYMMDD.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomQuery Class
    DicomQuery Members


DicomObjects Namespace / DicomQuery Class / StudyUID Property

    StudyUID Property (DicomQuery)
    In This Topic
    Unique identifiers for the four levels of the DICOM Query/Retrieve hierarchy
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property StudyUID As String
    'Usage

    Dim instance As DicomQuery
Dim value As String

instance.StudyUID = value

value = instance.StudyUID
    public string StudyUID {get; set;}
    Remarks
    For DicomQuery object, StudyUID must be set to appropriate value if Level is "SERIES" or "IMAGE".
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomQuery Class
    DicomQuery Members


DicomObjects Namespace / DicomQuery Class / Tag Property

    Tag Property (DicomQuery)
    In This Topic
    A general purpose Tag for developer use
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property Tag As Object
    'Usage

    Dim instance As DicomQuery
Dim value As Object

instance.Tag = value

value = instance.Tag
    public object Tag {get; set;}
    Remarks
    This property is not used by DicomObjects in any way, and is provided purely as a convenience for developers who wish to associate other objects with this object. As an alternative, most of the objects in DicomObjects can have other classes derived from them.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomQuery Class
    DicomQuery Members


DicomObjects Namespace / DicomQuery Class / TransferSyntaxes Property

    TransferSyntaxes Property
    Controls the allowed transfer syntaxes for outgoing operations (C-FIND, C-MOVE & C-GET)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property TransferSyntaxes As String
    'Usage

    Dim instance As DicomQuery
Dim value As String

instance.TransferSyntaxes = value

value = instance.TransferSyntaxes
    public string TransferSyntaxes {get; set;}
    Remarks

    If blank (the default) the default transfer syntax list specified by the Transfer Syntax Negotiation settings is used.

    The list is space separated – e.g. "1.2.840.10008.1.2 1.2.40.10008.1.2.1"

    Any syntaxes immediately preceded by an asterisk are sent in their own separate presentation context.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomQuery Class
    DicomQuery Members


%%PageItemTitle%% $$Events$$

DicomObjects Namespace / DicomQuery Class

    DicomQuery Class Events
    In This Topic

    For a list of all members of this type, see DicomQuery members.

    Public Events
     | Name | Description
Public Event | InitiateTls | Routine to use to generate encrypted stream when TLS is to be used for outgoing associations.
Public Event | ResponseReceived | Event fires when a response is received on an out-going operation
    Top
    See Also

    Reference

    DicomQuery Class
    DicomObjects Namespace


DicomObjects Namespace / DicomQuery Class / InitiateTls Event

    InitiateTls Event (DicomQuery)
    In This Topic
    Routine to use to generate encrypted stream when TLS is to be used for outgoing associations.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Event InitiateTls As TlsInitiator
    'Usage

    Dim instance As DicomQuery
Dim handler As TlsInitiator

AddHandler instance.InitiateTls, handler
    public event TlsInitiator InitiateTls
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomQuery Class
    DicomQuery Members


DicomObjects Namespace / DicomQuery Class / ResponseReceived Event

    ResponseReceived Event (DicomQuery)
    In This Topic
    Event fires when a response is received on an out-going operation
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Event ResponseReceived As ResponseReceivedHandler
    'Usage

    Dim instance As DicomQuery
Dim handler As ResponseReceivedHandler

AddHandler instance.ResponseReceived, handler
    public event ResponseReceivedHandler ResponseReceived
    Remarks

    This Event will be generated when any responses are received from the remote application.

    This is a direct equivalent of the ResponseReceived event.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomQuery Class
    DicomQuery Members


%%PageItemTitle%%

DicomObjects Namespace / DicomServer Class
Members

In This Topic
    DicomServer Class
    In This Topic
    An object for handling advanced network communications, as both SCU & SCP
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Class DicomServer
    'Usage

    Dim instance As DicomServer
    public class DicomServer
    Example
    In general, as much functionality as possible is devolved to the container. For instance, the control does not have its own application entity name, and acceptance or rejection of associations is controlled via an event. This event is given the remote IP address and the calling and called application entity titles, allowing the container to make its own accept/reject decision.
    Inheritance Hierarchy

    System.Object
    DicomObjects.DicomServer

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomServer Members
    DicomObjects Namespace


%%PageItemTitle%% $$Members$$

DicomObjects Namespace / DicomServer Class
Properties Methods Events

In This Topic
    DicomServer Class Members
    In This Topic

    The following tables list the members exposed by DicomServer.

    Public Constructors
     | Name | Description
Public Constructor | DicomServer Constructor | Creates a DicomServer object
    Top
    Public Properties
     | Name | Description
Public Property | AllowExtendedNegotiation | Controls whether extended negotation should be supported (as initiator or acceptor)
Public Property | AssociationCount | The number of associations currently open on this server
Public Property | DefaultStatus | The default status code to be returned in response to incoming requests
Public Property | NewAssociationType | This property is for user derived DicomAssociation
Public Property | Tag | A general purpose Tag for developer use
    Top
    Public Methods
     | Name | Description
Public Method | AbortAssociations | Aborts all related associations
Public Method | Accept | Means to allow DICOM negotiation on an existing socket
Public Method | Dispose | Release all system resources used by DicomServer object
Public Method | Listen | Overloaded. Open a TCP port to listen for incoming DICOM Connections
Public Method | Unlisten | Overloaded. Close a "Listening" TCP port for incoming DICOM Connections
Public Method | UnlistenAll | Close all "Listening" TCP ports for incoming DICOM Connections
    Top
    Public Events
     | Name | Description
Public Event | AssociationClosed | Event fired when an incoming DICOM association is closed
Public Event | AssociationRequest | Event fired when the object receives a DICOM connection request
Public Event | ErrorReceived | This event fires when an error is detected in received data
Public Event | InfoMessage | Passes information back to the container for error messages and notifications originating from the DICOM interface.
Public Event | InstanceReceived | This event is fired whenever a C-STORE operation completes, passing details of the instance received
Public Event | N_Event_Report | This event handler is fired on SCU when an N-EVENT-REPORT notification is received from the SCP.
Public Event | NormalisedReceived | This event fires when an incoming normalised request is received
Public Event | QueryReceived | Event fired when the object receives a DICOM C-FIND,C-GET or C-MOVE request
Public Event | ReceivingPixelData | Event called when pixel data is being received
Public Event | VerifyReceived | This event fires when a C-ECHO command (verification request) is received
    Top
    See Also

    Reference

    DicomServer Class
    DicomObjects Namespace


%%PageItemTitle%%

DicomObjects Namespace / DicomServer Class / DicomServer Constructor

In This Topic
    DicomServer Constructor
    In This Topic
    Creates a DicomServer object
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Function New()
    'Usage

    Dim instance As New DicomServer()
    public DicomServer()

    Return Value

    DicomServer
    Remarks
    This is the Constructor method.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomServer Class
    DicomServer Members


%%PageItemTitle%% $$Methods$$

DicomObjects Namespace / DicomServer Class

    DicomServer Class Methods
    In This Topic

    For a list of all members of this type, see DicomServer members.

    Public Methods
     | Name | Description
Public Method | AbortAssociations | Aborts all related associations
Public Method | Accept | Means to allow DICOM negotiation on an existing socket
Public Method | Dispose | Release all system resources used by DicomServer object
Public Method | Listen | Overloaded. Open a TCP port to listen for incoming DICOM Connections
Public Method | Unlisten | Overloaded. Close a "Listening" TCP port for incoming DICOM Connections
Public Method | UnlistenAll | Close all "Listening" TCP ports for incoming DICOM Connections
    Top
    See Also

    Reference

    DicomServer Class
    DicomObjects Namespace


DicomObjects Namespace / DicomServer Class / AbortAssociations Method

    AbortAssociations Method
    Aborts all related associations
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Sub AbortAssociations()
    'Usage

    Dim instance As DicomServer

instance.AbortAssociations()
    public void AbortAssociations()
    Remarks
    This method aborts all associations (incoming and outgoing) related to the DicomServer object.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomServer Class
    DicomServer Members


DicomObjects Namespace / DicomServer Class / Accept Method
The underlying socket
A stream based on that socket

In This Topic
    Accept Method
    In This Topic
    Means to allow DICOM negotiation on an existing socket
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Sub Accept( _
   ByVal Socket As Socket, _
   ByVal Stream As Stream _
)
    'Usage

    Dim instance As DicomServer
Dim Socket As Socket
Dim Stream As Stream

instance.Accept(Socket, Stream)
    public void Accept(
   Socket Socket,
   Stream Stream
)

    Parameters

    Socket
    The underlying socket
    Stream
    A stream based on that socket
    Remarks

    Normally this is all handled internally by DicomObjects, but this method is provided for developers who may wish to use their own listening and authorisation mechanisms

    Note that only one association is allowed per TCP connection, so this does require a "new" TCP connection, though TLS negotiation etc. may of course have been performed.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomServer Class
    DicomServer Members


DicomObjects Namespace / DicomServer Class / Dispose Method

    Dispose Method (DicomServer)
    In This Topic
    Release all system resources used by DicomServer object
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overridable Sub Dispose()
    'Usage

    Dim instance As DicomServer

instance.Dispose()
    public virtual void Dispose()
    Remarks
    This is the Destructor method.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomServer Class
    DicomServer Members


DicomObjects Namespace / DicomServer Class / Listen Method

    Listen Method
    Open a TCP port to listen for incoming DICOM Connections
    Overload List
    Overload | Description
Listen(Int32) | Open a TCP port to listen for incoming DICOM Connections
Listen(Int32,TlsAcceptor) | Open a TCP port to listen for secure incoming DICOM Connections
Listen(Int32,AddressFamily,TlsAcceptor) | Open a TCP port to listen for secure incoming DICOM Connections
Listen(Int32,String) | Open a TCP port to listen for incoming DICOM Connections, specified by port number and IP address
Listen(Int32,String,AddressFamily,TlsAcceptor) | Open a TCP port to listen for secure incoming DICOM Connections on a specific IP address
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomServer Class
    DicomServer Members


DicomObjects Namespace / DicomServer Class / Listen Method / Listen(Int32) Method

The TCP port on which to receive connections

    Listen(Int32) Method
    In This Topic
    Open a TCP port to listen for incoming DICOM Connections
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub Listen( _
   ByVal Port As Integer _
)
    'Usage

    Dim instance As DicomServer
Dim Port As Integer

instance.Listen(Port)
    public void Listen(
   int Port
)

    Parameters

    Port

    The TCP port on which to receive connections

    Remarks

    More than one port may be active simultaneously. The listening sockets are all closed when the control is de-activated.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomServer Class
    DicomServer Members
    Overload List


DicomObjects Namespace / DicomServer Class / Listen Method / Listen(Int32,TlsAcceptor) Method

The TCP port on which to receive connections

The DicomObjects.Delegates.TlsAcceptor object used to accept secure connections

In This Topic
    Listen(Int32,TlsAcceptor) Method
    In This Topic
    Open a TCP port to listen for secure incoming DICOM Connections
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub Listen( _
   ByVal Port As Integer, _
   ByVal AcceptTls As TlsAcceptor _
)
    'Usage

    Dim instance As DicomServer
Dim Port As Integer
Dim AcceptTls As TlsAcceptor

instance.Listen(Port, AcceptTls)
    public void Listen(
   int Port,
   TlsAcceptor AcceptTls
)

    Parameters

    Port

    The TCP port on which to receive connections

    AcceptTls

    The DicomObjects.Delegates.TlsAcceptor object used to accept secure connections

    Remarks

    This is the secure equivalent of the Listen method.

    Different ports must be used for secure and non-secure associations, as the security negotiation occurs before DICOM negotiation.

    More than one port may be active simultaneously. The listening sockets are all closed when the control is de-activated.

    Closing a �listening� socket has no effect on currently active associations that connected via that socket.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomServer Class
    DicomServer Members
    Overload List


DicomObjects Namespace / DicomServer Class / Listen Method / Listen(Int32,AddressFamily,TlsAcceptor) Method

The TCP port on which to receive connections

The address family to use (IPv4 or IPv6)

The DicomObjects.Delegates.TlsAcceptor object used to accept secure connections

In This Topic
    Listen(Int32,AddressFamily,TlsAcceptor) Method
    In This Topic
    Open a TCP port to listen for secure incoming DICOM Connections
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub Listen( _
   ByVal Port As Integer, _
   ByVal IpAddressFamily As AddressFamily, _
   ByVal AcceptTls As TlsAcceptor _
)
    'Usage

    Dim instance As DicomServer
Dim Port As Integer
Dim IpAddressFamily As AddressFamily
Dim AcceptTls As TlsAcceptor

instance.Listen(Port, IpAddressFamily, AcceptTls)
    public void Listen(
   int Port,
   AddressFamily IpAddressFamily,
   TlsAcceptor AcceptTls
)

    Parameters

    Port

    The TCP port on which to receive connections

    IpAddressFamily

    The address family to use (IPv4 or IPv6)

    AcceptTls

    The DicomObjects.Delegates.TlsAcceptor object used to accept secure connections

    Remarks

    This is the secure equivalent of the Listen method.

    Different ports must be used for secure and non-secure associations, as the security negotiation occurs before DICOM negotiation.

    More than one port may be active simultaneously. The listening sockets are all closed when the control is de-activated.

    Closing a �listening� socket has no effect on currently active associations that connected via that socket.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomServer Class
    DicomServer Members
    Overload List


DicomObjects Namespace / DicomServer Class / Listen Method / Listen(Int32,String) Method

The TCP port on which to receive connections

IP address to listen on

In This Topic
    Listen(Int32,String) Method
    In This Topic
    Open a TCP port to listen for incoming DICOM Connections, specified by port number and IP address
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub Listen( _
   ByVal Port As Integer, _
   ByVal Address As String _
)
    'Usage

    Dim instance As DicomServer
Dim Port As Integer
Dim Address As String

instance.Listen(Port, Address)
    public void Listen(
   int Port,
   string Address
)

    Parameters

    Port

    The TCP port on which to receive connections

    Address

    IP address to listen on

    Remarks

    This is the secure equivalent of the Listen method.

    Different ports must be used for secure and non-secure associations, as the security negotiation occurs before DICOM negotiation.

    More than one port may be active simultaneously. The listening sockets are all closed when the control is de-activated.

    Closing a �listening� socket has no effect on currently active associations that connected via that socket.

    If the IP address is used, then Address must be either in dotted form, or a resolvable name.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomServer Class
    DicomServer Members
    Overload List


DicomObjects Namespace / DicomServer Class / Listen Method / Listen(Int32,String,AddressFamily,TlsAcceptor) Method

The TCP port on which to receive connections

The address to listen on

The address family to use (IPv4 or IPv6)

The DicomObjects.Delegates.TlsAcceptor object used to accept secure connections

In This Topic
    Listen(Int32,String,AddressFamily,TlsAcceptor) Method
    In This Topic
    Open a TCP port to listen for secure incoming DICOM Connections on a specific IP address
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub Listen( _
   ByVal Port As Integer, _
   ByVal Address As String, _
   ByVal IpAddressFamily As AddressFamily, _
   ByVal AcceptTls As TlsAcceptor _
)
    'Usage

    Dim instance As DicomServer
Dim Port As Integer
Dim Address As String
Dim IpAddressFamily As AddressFamily
Dim AcceptTls As TlsAcceptor

instance.Listen(Port, Address, IpAddressFamily, AcceptTls)
    public void Listen(
   int Port,
   string Address,
   AddressFamily IpAddressFamily,
   TlsAcceptor AcceptTls
)

    Parameters

    Port

    The TCP port on which to receive connections

    Address

    The address to listen on

    IpAddressFamily

    The address family to use (IPv4 or IPv6)

    AcceptTls

    The DicomObjects.Delegates.TlsAcceptor object used to accept secure connections

    Remarks

    This is the secure equivalent of the Listen method.

    Different ports must be used for secure and non-secure associations, as the security negotiation occurs before DICOM negotiation.

    More than one port may be active simultaneously. The listening sockets are all closed when the control is de-activated.

    Closing a �listening� socket has no effect on currently active associations that connected via that socket.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomServer Class
    DicomServer Members
    Overload List


DicomObjects Namespace / DicomServer Class / Unlisten Method

    Unlisten Method
    Close a "Listening" TCP port for incoming DICOM Connections
    Overload List
    Overload | Description
Unlisten(Int32) | Close a "Listening" TCP port, specified by the port number, for incoming DICOM Connections
Unlisten(Int32,String) | Close a "Listening" TCP port, specified by the port number and IP address, for incoming DICOM Connections
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomServer Class
    DicomServer Members


DicomObjects Namespace / DicomServer Class / Unlisten Method / Unlisten(Int32) Method

The port number which is to be closed for incoming connection.

In This Topic
    Unlisten(Int32) Method
    In This Topic
    Close a "Listening" TCP port, specified by the port number, for incoming DICOM Connections
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub Unlisten( _
   ByVal Port As Integer _
)
    'Usage

    Dim instance As DicomServer
Dim Port As Integer

instance.Unlisten(Port)
    public void Unlisten(
   int Port
)

    Parameters

    Port

    The port number which is to be closed for incoming connection.

    Remarks

    Closing a �listening� socket has no effect on currently active associations that connected via that socket.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomServer Class
    DicomServer Members
    Overload List


DicomObjects Namespace / DicomServer Class / Unlisten Method / Unlisten(Int32,String) Method

The port number which is to be closed for incoming connection

IP address to listen on

In This Topic
    Unlisten(Int32,String) Method
    In This Topic
    Close a "Listening" TCP port, specified by the port number and IP address, for incoming DICOM Connections
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub Unlisten( _
   ByVal Port As Integer, _
   ByVal Address As String _
)
    'Usage

    Dim instance As DicomServer
Dim Port As Integer
Dim Address As String

instance.Unlisten(Port, Address)
    public void Unlisten(
   int Port,
   string Address
)

    Parameters

    Port

    The port number which is to be closed for incoming connection

    Address

    IP address to listen on

    Remarks

    Closing a �listening� socket has no effect on currently active associations that connected via that socket.

    If the address option is used, then address must be either in dotted form, or a resolvable name.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomServer Class
    DicomServer Members
    Overload List


DicomObjects Namespace / DicomServer Class / UnlistenAll Method

    UnlistenAll Method
    Close all "Listening" TCP ports for incoming DICOM Connections
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Sub UnlistenAll()
    'Usage

    Dim instance As DicomServer

instance.UnlistenAll()
    public void UnlistenAll()
    Remarks

    Since more than one port may be active simultaneously, this method is designed to close all "Listening" socket.

    For more information see Unlisten.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomServer Class
    DicomServer Members


%%PageItemTitle%% $$Properties$$

DicomObjects Namespace / DicomServer Class

    DicomServer Class Properties
    In This Topic

    For a list of all members of this type, see DicomServer members.

    Public Properties
     | Name | Description
Public Property | AllowExtendedNegotiation | Controls whether extended negotation should be supported (as initiator or acceptor)
Public Property | AssociationCount | The number of associations currently open on this server
Public Property | DefaultStatus | The default status code to be returned in response to incoming requests
Public Property | NewAssociationType | This property is for user derived DicomAssociation
Public Property | Tag | A general purpose Tag for developer use
    Top
    See Also

    Reference

    DicomServer Class
    DicomObjects Namespace


DicomObjects Namespace / DicomServer Class / AllowExtendedNegotiation Property

    AllowExtendedNegotiation Property
    Controls whether extended negotation should be supported (as initiator or acceptor)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property AllowExtendedNegotiation As Boolean
    'Usage

    Dim instance As DicomServer
Dim value As Boolean

instance.AllowExtendedNegotiation = value

value = instance.AllowExtendedNegotiation
    public bool AllowExtendedNegotiation {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomServer Class
    DicomServer Members


DicomObjects Namespace / DicomServer Class / AssociationCount Property

    AssociationCount Property
    The number of associations currently open on this server
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property AssociationCount As Integer
    'Usage

    Dim instance As DicomServer
Dim value As Integer

value = instance.AssociationCount
    public int AssociationCount {get;}
    Remarks
    This is a volatile property which can change at any time
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomServer Class
    DicomServer Members


DicomObjects Namespace / DicomServer Class / DefaultStatus Property

    DefaultStatus Property
    The default status code to be returned in response to incoming requests
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property DefaultStatus As Integer
    'Usage

    Dim instance As DicomServer
Dim value As Integer

instance.DefaultStatus = value

value = instance.DefaultStatus
    public int DefaultStatus {get; set;}
    Remarks

    When incoming requests such as C-STORE, C-ECHO or normalised operations are received, a status code must be returned to the Sender. Normally, this is supplied either by the final value of the "Status" parameter to the VerifyReceived or InstanceReceived event. Under some circumstances, however (such as when a message box is displayed in Visual Basic), events my not be fired, so this property provides a default value. It is used in the following circumstances:

    • It provides the initial value for the Status parameter for an InstanceReceived or VerifyReceved event
    • It provides the definitive value if the appropriate event is not fired or not captured

    Servers should normally set this value to a suitable error code, so that sending applications are alerted when an image cannot be handled due to server errors erc.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomServer Class
    DicomServer Members


DicomObjects Namespace / DicomServer Class / NewAssociationType Property

    NewAssociationType Property
    This property is for user derived DicomAssociation
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property NewAssociationType As Type
    'Usage

    Dim instance As DicomServer
Dim value As Type

instance.NewAssociationType = value

value = instance.NewAssociationType
    public Type NewAssociationType {get; set;}
    Remarks
    When deriving a new class from the DicomAssociation class, users can specify in this property the type of the derived Association class so that instances of the derived association used by DicomServer will be created for incoming associations.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomServer Class
    DicomServer Members


DicomObjects Namespace / DicomServer Class / Tag Property

    Tag Property (DicomServer)
    In This Topic
    A general purpose Tag for developer use
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property Tag As Object
    'Usage

    Dim instance As DicomServer
Dim value As Object

instance.Tag = value

value = instance.Tag
    public object Tag {get; set;}
    Remarks
    This property is not used by DicomObjects in any way, and is provided purely as a convenience for developers who wish to associate other objects with this object. As an alternative, most of the objects in DicomObjects can have other classes derived from them.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomServer Class
    DicomServer Members


%%PageItemTitle%% $$Events$$

DicomObjects Namespace / DicomServer Class

    DicomServer Class Events
    In This Topic

    For a list of all members of this type, see DicomServer members.

    Public Events
     | Name | Description
Public Event | AssociationClosed | Event fired when an incoming DICOM association is closed
Public Event | AssociationRequest | Event fired when the object receives a DICOM connection request
Public Event | ErrorReceived | This event fires when an error is detected in received data
Public Event | InfoMessage | Passes information back to the container for error messages and notifications originating from the DICOM interface.
Public Event | InstanceReceived | This event is fired whenever a C-STORE operation completes, passing details of the instance received
Public Event | N_Event_Report | This event handler is fired on SCU when an N-EVENT-REPORT notification is received from the SCP.
Public Event | NormalisedReceived | This event fires when an incoming normalised request is received
Public Event | QueryReceived | Event fired when the object receives a DICOM C-FIND,C-GET or C-MOVE request
Public Event | ReceivingPixelData | Event called when pixel data is being received
Public Event | VerifyReceived | This event fires when a C-ECHO command (verification request) is received
    Top
    See Also

    Reference

    DicomServer Class
    DicomObjects Namespace


DicomObjects Namespace / DicomServer Class / AssociationClosed Event

    AssociationClosed Event
    Event fired when an incoming DICOM association is closed
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Event AssociationClosed As AssociationClosedHandler
    'Usage

    Dim instance As DicomServer
Dim handler As AssociationClosedHandler

AddHandler instance.AssociationClosed, handler
    public event AssociationClosedHandler AssociationClosed
    Remarks

    At the time this event fires, the association has closed, but the associated DicomAssociation object still exists, so it's properties are all still available.

    When acting as a print SCP, this event is useful, as the DICOM standard allows all associated objects created during the association to be deleted once the association closes.

    Important Note:

    With the sole exception of applications acting as a print service SCP, DICOM specifically bars any application from making any assumptions about the organisation of incoming data based on he association on which it arrives - to quote part 4 (section B.4):

    "�an SCP of the Storage SOP Classes may not attach any significance to the particular association or associations over which C-STORE operations are requested, nor the order in which C-STORE operations occur within an association. No constraints are placed on the operations an SCU may perform during any particular association, other than those defined during association negotiation. An SCP may not expect an SCU to perform C-STORE operations in a particular order.

    Similarly, no semantics are attached to the closing of an Association, such as the end of Study or Performed Procedure."

    Therefore, if this event is used for any purpose other than a print SCP, any actions taken within it are most likely to be violations of the DICOM Standard.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomServer Class
    DicomServer Members


DicomObjects Namespace / DicomServer Class / AssociationRequest Event

    AssociationRequest Event
    Event fired when the object receives a DICOM connection request
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Event AssociationRequest As AssociationRequestHandler
    'Usage

    Dim instance As DicomServer
Dim handler As AssociationRequestHandler

AddHandler instance.AssociationRequest, handler
    public event AssociationRequestHandler AssociationRequest
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomServer Class
    DicomServer Members


DicomObjects Namespace / DicomServer Class / ErrorReceived Event

    ErrorReceived Event
    This event fires when an error is detected in received data
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Event ErrorReceived As ErrorReceivedHandler
    'Usage

    Dim instance As DicomServer
Dim handler As ErrorReceivedHandler

AddHandler instance.ErrorReceived, handler
    public event ErrorReceivedHandler ErrorReceived
    Remarks

    This may be a DicomException or any other form of Exception. If a DicomException, then more detailed error information may be available through it's properties.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomServer Class
    DicomServer Members


DicomObjects Namespace / DicomServer Class / InfoMessage Event

    InfoMessage Event
    Passes information back to the container for error messages and notifications originating from the DICOM interface.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Event InfoMessage As InfoMessageHandler
    'Usage

    Dim instance As DicomServer
Dim handler As InfoMessageHandler

AddHandler instance.InfoMessage, handler
    public event InfoMessageHandler InfoMessage
    Remarks

    Where possible, objects pass error information back to the container standard exceptions, but this is not possible for errors originating from the DICOM interface, as there is no call from the container to the object in progress. This event is therefore used for that purpose.

    Debugging information may include all or part of the byte stream exchanged between DicomObjects and other entities, and is useful when communication failures occur.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomServer Class
    DicomServer Members


DicomObjects Namespace / DicomServer Class / InstanceReceived Event

    InstanceReceived Event
    This event is fired whenever a C-STORE operation completes, passing details of the instance received
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Event InstanceReceived As InstanceReceivedHandler
    'Usage

    Dim instance As DicomServer
Dim handler As InstanceReceivedHandler

AddHandler instance.InstanceReceived, handler
    public event InstanceReceivedHandler InstanceReceived
    Remarks

    This is a more generic event as compared with the ImageReceived method in COM version, which fires only when a DicomImage has been successfully transferred.

    A status of 0 would be sent back indicating a successful instance transfer.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomServer Class
    DicomServer Members


DicomObjects Namespace / DicomServer Class / N_Event_Report Event

    N_Event_Report Event (DicomServer)
    In This Topic
    This event handler is fired on SCU when an N-EVENT-REPORT notification is received from the SCP.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Event N_Event_Report As N_Event_ReportHandler
    'Usage

    Dim instance As DicomServer
Dim handler As N_Event_ReportHandler

AddHandler instance.N_Event_Report, handler
    public event N_Event_ReportHandler N_Event_Report
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomServer Class
    DicomServer Members


DicomObjects Namespace / DicomServer Class / NormalisedReceived Event

    NormalisedReceived Event
    This event fires when an incoming normalised request is received
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Event NormalisedReceived As NormalisedReceivedHandler
    'Usage

    Dim instance As DicomServer
Dim handler As NormalisedReceivedHandler

AddHandler instance.NormalisedReceived, handler
    public event NormalisedReceivedHandler NormalisedReceived
    Remarks

    All information required for processing this event may be found within the various properties of the Connection. In particular, the Command property contains the main request (group 0000), including the CommandID (element 0000,0100), while the Request property contains the associated identifier. Calling one of the overloads of SendResponse method call on the Association should be used to reply to this request, if an identifier needs to be returned.

    You are expected to set the appropriate Status as a response for the request. This is accessible using the second parameter.

    The handling of Normalised requests as an SCP is a very advanced technique, and close attention to the appropriate sections of the DICOM standard is necessary.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomServer Class
    DicomServer Members


DicomObjects Namespace / DicomServer Class / QueryReceived Event

    QueryReceived Event
    Event fired when the object receives a DICOM C-FIND,C-GET or C-MOVE request
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Event QueryReceived As QueryReceivedHandler
    'Usage

    Dim instance As DicomServer
Dim handler As QueryReceivedHandler

AddHandler instance.QueryReceived, handler
    public event QueryReceivedHandler QueryReceived
    Remarks

    All information required for processing this event may be found within the various properties of the Connection. In particular, the Command property contains the main request (group 0000), including the CommandID (element 0000,0100), while the Request property contains the associated identifier. Calling one of the overloads of SendResponse method call on the Association should be used to reply to this request, if an identifier needs to be returned.

    You are expected to set the appropriate Status as a response for the request. This is accessible using the second parameter.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomServer Class
    DicomServer Members


DicomObjects Namespace / DicomServer Class / ReceivingPixelData Event

    ReceivingPixelData Event
    Event called when pixel data is being received
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Event ReceivingPixelData As ReceivingPixelDataHandler
    'Usage

    Dim instance As DicomServer
Dim handler As ReceivingPixelDataHandler

AddHandler instance.ReceivingPixelData, handler
    public event ReceivingPixelDataHandler ReceivingPixelData
    Remarks
    This event could be used to redirect incoming data
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomServer Class
    DicomServer Members


DicomObjects Namespace / DicomServer Class / VerifyReceived Event

    VerifyReceived Event
    This event fires when a C-ECHO command (verification request) is received
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Event VerifyReceived As VerifyReceivedHandler
    'Usage

    Dim instance As DicomServer
Dim handler As VerifyReceivedHandler

AddHandler instance.VerifyReceived, handler
    public event VerifyReceivedHandler VerifyReceived
    Remarks

    The initial value of Status is the originating object's DefaultStatus value, and applications should replace this by zero in this event.

    In all release applications, DefaultStatus should be non-zero, so that if the receiver application stalls or fails to respond then probing applications will receive a non-zero response to their C-ECHO request.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomServer Class
    DicomServer Members


%%PageItemTitle%%

DicomObjects Namespace / ReadBehaviours Class
Members

In This Topic
    ReadBehaviours Class
    In This Topic
    Specific behaviour to use when reading/receiving a DICOM instance
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Class ReadBehaviours
    'Usage

    Dim instance As ReadBehaviours
    public class ReadBehaviours
    Remarks

    An object of this class may be used in 4 ways:

    • As a parameter to one of the overrides of DicomDataSet.Read
    • By assigning to DicomGlobal.DefaultReadBehaviour
    • By setting the ReadBehaviour property of an explicitly created DicomAssociation
    • By setting the ReadBehaviour property of an internally generated DicomAssociation object during the DicomServer.AssociationRequest event

    Most of the behaviours controlled by the properties of this object may also be set globally using the internal registry, but this object allows more granular control.

    Inheritance Hierarchy

    System.Object
    DicomObjects.ReadBehaviours

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ReadBehaviours Members
    DicomObjects Namespace


%%PageItemTitle%% $$Members$$

DicomObjects Namespace / ReadBehaviours Class
Properties

In This Topic
    ReadBehaviours Class Members
    In This Topic

    The following tables list the members exposed by ReadBehaviours.

    Public Constructors
     | Name | Description
Public Constructor | ReadBehaviours Constructor | Create a new ReadBehaviours object
    Top
    Public Properties
     | Name | Description
Public Property | AttemptToFixHologicCompressedFrames | Try to detect and attempt to fix Hologic compressed frames. This will replace their private sequence containing the pixels with correctly formatted pixel data. Note this doesn't not replace the original pixel data, you have to explicitly overwrite the image by Write to disk
Public Property | BlankTransferSyntax | A default transfer syntax value for DicomObjects when reading DICOM image with missing transfer syntax value.
Public Property | CloseFilesAfterReading | Controls how pixel data is read from disk
Public Property | DelayedSequenceLoad | Controls whether to perform on-demand loading of all sequences only when needed
Public Property | DiscardBadIcons | Controls how "bad icons" are handled.
Public Property | DontReadPixels | Can disable reading of pixel values
Public Property | IgnoreAfterPixels | Controls whether all data after the pixel data is to be ignored.
Public Property | IgnoreAfterTag | Controls whether all data after a specifc tag is to be ignored. Value shall be in ggggeeee hex format, such as 0x00100010 for patient name.
Public Property | IgnoreAllPrivateAttributes | If set to true, any Private attribute will be skipped. Default value is false
Public Property | IgnoreBOT | Ignore any Basic Offset Table which may be present in the received data
Public Property | IgnoreExceptions | Ignores a list of DicomObjects error codes accessible from DicomException.Code during reading from disk/network and puts together what has been successfully read. This is particularly useful to skip exceptions and keep the association open to continue reading.
Public Property | IgnoreIconLengths | Ignore the lengths of the pixel data in icon sequences
Public Property | IgnorePrivateSequences | If set, private sequence items are skipped.
Public Property | SilentEndOfFileReached | Set to true to tell DicomObjects to not throw End Of File Reached exception and stop reading from file when an attribute with bad length is encountered. Default value is false
Public Property | ThrowNotDICOMDIRError | Controls whether to throw an exception if a file which is apparently a DICOM does not contain the expected DICOMDIR offset attributes.
Public Property | TolerateBadOffsets | Ignore bad "offset" data when reading a DICOMDIR
Public Property | ZeissBug | A workaround for old bad Zeiss Data, some of which had UT attributes with 2 Bytes length
    Top
    See Also

    Reference

    ReadBehaviours Class
    DicomObjects Namespace


%%PageItemTitle%%

DicomObjects Namespace / ReadBehaviours Class / ReadBehaviours Constructor

In This Topic
    ReadBehaviours Constructor
    In This Topic
    Create a new ReadBehaviours object
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Function New()
    'Usage

    Dim instance As New ReadBehaviours()
    public ReadBehaviours()
    Remarks
    The properties are all initialised from global or "registry" values, as described in each individual property
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ReadBehaviours Class
    ReadBehaviours Members


%%PageItemTitle%% $$Properties$$

DicomObjects Namespace / ReadBehaviours Class

    ReadBehaviours Class Properties
    In This Topic

    For a list of all members of this type, see ReadBehaviours members.

    Public Properties
     | Name | Description
Public Property | AttemptToFixHologicCompressedFrames | Try to detect and attempt to fix Hologic compressed frames. This will replace their private sequence containing the pixels with correctly formatted pixel data. Note this doesn't not replace the original pixel data, you have to explicitly overwrite the image by Write to disk
Public Property | BlankTransferSyntax | A default transfer syntax value for DicomObjects when reading DICOM image with missing transfer syntax value.
Public Property | CloseFilesAfterReading | Controls how pixel data is read from disk
Public Property | DelayedSequenceLoad | Controls whether to perform on-demand loading of all sequences only when needed
Public Property | DiscardBadIcons | Controls how "bad icons" are handled.
Public Property | DontReadPixels | Can disable reading of pixel values
Public Property | IgnoreAfterPixels | Controls whether all data after the pixel data is to be ignored.
Public Property | IgnoreAfterTag | Controls whether all data after a specifc tag is to be ignored. Value shall be in ggggeeee hex format, such as 0x00100010 for patient name.
Public Property | IgnoreAllPrivateAttributes | If set to true, any Private attribute will be skipped. Default value is false
Public Property | IgnoreBOT | Ignore any Basic Offset Table which may be present in the received data
Public Property | IgnoreExceptions | Ignores a list of DicomObjects error codes accessible from DicomException.Code during reading from disk/network and puts together what has been successfully read. This is particularly useful to skip exceptions and keep the association open to continue reading.
Public Property | IgnoreIconLengths | Ignore the lengths of the pixel data in icon sequences
Public Property | IgnorePrivateSequences | If set, private sequence items are skipped.
Public Property | SilentEndOfFileReached | Set to true to tell DicomObjects to not throw End Of File Reached exception and stop reading from file when an attribute with bad length is encountered. Default value is false
Public Property | ThrowNotDICOMDIRError | Controls whether to throw an exception if a file which is apparently a DICOM does not contain the expected DICOMDIR offset attributes.
Public Property | TolerateBadOffsets | Ignore bad "offset" data when reading a DICOMDIR
Public Property | ZeissBug | A workaround for old bad Zeiss Data, some of which had UT attributes with 2 Bytes length
    Top
    See Also

    Reference

    ReadBehaviours Class
    DicomObjects Namespace


DicomObjects Namespace / ReadBehaviours Class / AttemptToFixHologicCompressedFrames Property

    AttemptToFixHologicCompressedFrames Property
    Try to detect and attempt to fix Hologic compressed frames. This will replace their private sequence containing the pixels with correctly formatted pixel data.

    Note this doesn't not replace the original pixel data, you have to explicitly overwrite the image by Write to disk

    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property AttemptToFixHologicCompressedFrames As Boolean
    'Usage

    Dim instance As ReadBehaviours
Dim value As Boolean

instance.AttemptToFixHologicCompressedFrames = value

value = instance.AttemptToFixHologicCompressedFrames
    public bool AttemptToFixHologicCompressedFrames {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ReadBehaviours Class
    ReadBehaviours Members


DicomObjects Namespace / ReadBehaviours Class / BlankTransferSyntax Property

    BlankTransferSyntax Property
    A default transfer syntax value for DicomObjects when reading DICOM image with missing transfer syntax value.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property BlankTransferSyntax As String
    'Usage

    Dim instance As ReadBehaviours
Dim value As String

instance.BlankTransferSyntax = value

value = instance.BlankTransferSyntax
    public string BlankTransferSyntax {get; set;}
    Remarks

    The default value of this property is copied from the BlankTransferSyntax value of the internal registry, which in turn has a default value of 1.2.840.10008.1.2.1

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ReadBehaviours Class
    ReadBehaviours Members


DicomObjects Namespace / ReadBehaviours Class / CloseFilesAfterReading Property

    CloseFilesAfterReading Property (ReadBehaviours)
    In This Topic
    Controls how pixel data is read from disk
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property CloseFilesAfterReading As Boolean
    'Usage

    Dim instance As ReadBehaviours
Dim value As Boolean

instance.CloseFilesAfterReading = value

value = instance.CloseFilesAfterReading
    public bool CloseFilesAfterReading {get; set;}
    Remarks

    This is initialised from CloseFilesAfterReading - see that property for more details of the effects of this property.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ReadBehaviours Class
    ReadBehaviours Members


DicomObjects Namespace / ReadBehaviours Class / DelayedSequenceLoad Property

    DelayedSequenceLoad Property
    Controls whether to perform on-demand loading of all sequences only when needed
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property DelayedSequenceLoad As Boolean
    'Usage

    Dim instance As ReadBehaviours
Dim value As Boolean

instance.DelayedSequenceLoad = value

value = instance.DelayedSequenceLoad
    public bool DelayedSequenceLoad {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ReadBehaviours Class
    ReadBehaviours Members


DicomObjects Namespace / ReadBehaviours Class / DiscardBadIcons Property

    DiscardBadIcons Property
    Controls how "bad icons" are handled.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property DiscardBadIcons As Boolean
    'Usage

    Dim instance As ReadBehaviours
Dim value As Boolean

instance.DiscardBadIcons = value

value = instance.DiscardBadIcons
    public bool DiscardBadIcons {get; set;}
    Remarks

    Unfortunately, many DICOM files from a certan large manufacturer, commonly contain "thumbnail" sequences, which break the DICOM rules, as they have explicit length, indicating that they are uncompressed, when in fact they are compressed (and even then, they don't follow th encapsulation rules for compressed pixel data!)

    If set to true, then such defective icons (which where not in the original images and can be seen as "damage" by the PACS) are silently removed from the data at the time it is read - leaving only a warning in the log file.

    The default value of this property is derived from the DiscardBadIcons value of the internal registry, which in turn has a default value of 0, causing this property to be false.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ReadBehaviours Class
    ReadBehaviours Members


DicomObjects Namespace / ReadBehaviours Class / DontReadPixels Property

    DontReadPixels Property
    Can disable reading of pixel values
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property DontReadPixels As Boolean
    'Usage

    Dim instance As ReadBehaviours
Dim value As Boolean

instance.DontReadPixels = value

value = instance.DontReadPixels
    public bool DontReadPixels {get; set;}
    Remarks

    The default value of this property is derived from the DontReadPixels value of the internal registry, which in turn has a default value of 0, causing this property to be false.

    This property can sometimes be useful when scanning a large set of images soley for indexing

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ReadBehaviours Class
    ReadBehaviours Members


DicomObjects Namespace / ReadBehaviours Class / IgnoreAfterPixels Property

    IgnoreAfterPixels Property
    Controls whether all data after the pixel data is to be ignored.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property IgnoreAfterPixels As Boolean
    'Usage

    Dim instance As ReadBehaviours
Dim value As Boolean

instance.IgnoreAfterPixels = value

value = instance.IgnoreAfterPixels
    public bool IgnoreAfterPixels {get; set;}
    Remarks

    It may give the following advantages in some situations:

    • When there is rubbish at the end of the file
    • When reading very large compressed files, as it avoids the need to scan to the end of the pixel data.

    The default value of this property is derived from the IgnoreAfterPixels value of the internal registry, which in turn has a default value of 0, causing this property to be false.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ReadBehaviours Class
    ReadBehaviours Members


DicomObjects Namespace / ReadBehaviours Class / IgnoreAfterTag Property

    IgnoreAfterTag Property
    Controls whether all data after a specifc tag is to be ignored. Value shall be in ggggeeee hex format, such as 0x00100010 for patient name.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property IgnoreAfterTag As UInteger
    'Usage

    Dim instance As ReadBehaviours
Dim value As UInteger

instance.IgnoreAfterTag = value

value = instance.IgnoreAfterTag
    public uint IgnoreAfterTag {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ReadBehaviours Class
    ReadBehaviours Members


DicomObjects Namespace / ReadBehaviours Class / IgnoreAllPrivateAttributes Property

    IgnoreAllPrivateAttributes Property
    If set to true, any Private attribute will be skipped. Default value is false
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property IgnoreAllPrivateAttributes As Boolean
    'Usage

    Dim instance As ReadBehaviours
Dim value As Boolean

instance.IgnoreAllPrivateAttributes = value

value = instance.IgnoreAllPrivateAttributes
    public bool IgnoreAllPrivateAttributes {get; set;}
    Remarks
    The default value of this property is derived from the IgnoreAllPrivateAttributes value of the internal registry, which in turn has a default value of 0, causing this property to be false.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ReadBehaviours Class
    ReadBehaviours Members


DicomObjects Namespace / ReadBehaviours Class / IgnoreBOT Property

    IgnoreBOT Property
    Ignore any Basic Offset Table which may be present in the received data
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property IgnoreBOT As Boolean
    'Usage

    Dim instance As ReadBehaviours
Dim value As Boolean

instance.IgnoreBOT = value

value = instance.IgnoreBOT
    public bool IgnoreBOT {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ReadBehaviours Class
    ReadBehaviours Members


DicomObjects Namespace / ReadBehaviours Class / IgnoreExceptions Property

    IgnoreExceptions Property
    Ignores a list of DicomObjects error codes accessible from DicomException.Code during reading from disk/network and puts together what has been successfully read. This is particularly useful to skip exceptions and keep the association open to continue reading.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property IgnoreExceptions As Integer()
    'Usage

    Dim instance As ReadBehaviours
Dim value() As Integer

instance.IgnoreExceptions = value

value = instance.IgnoreExceptions
    public int[] IgnoreExceptions {get; set;}
    Remarks
    Similar to IgnoreAfterPixels, in which it excludes only error in while reading after Pixel data. This is more expansive as it ignores all listed exceptions while reading
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ReadBehaviours Class
    ReadBehaviours Members


DicomObjects Namespace / ReadBehaviours Class / IgnoreIconLengths Property

    IgnoreIconLengths Property
    Ignore the lengths of the pixel data in icon sequences
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property IgnoreIconLengths As Boolean
    'Usage

    Dim instance As ReadBehaviours
Dim value As Boolean

instance.IgnoreIconLengths = value

value = instance.IgnoreIconLengths
    public bool IgnoreIconLengths {get; set;}
    Remarks

    The default value of this property is derived from the IgnoreIconLengths value of the internal registry, which in turn has a default value of 0, causing this property to be false.

    Many manufacturers (including the largest!) still create images containing ICON images (either in the official DICOM icon sequence - 0088,0200 or in private sequences) which are badly formatted with innappropriate length (commonly being compressed, when the DICOM rules require them to be compressed). If set, this property causes such pixel data to be treated simply as a byte array, ignoring the length (but disabling transfer syntax conversion of it)

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ReadBehaviours Class
    ReadBehaviours Members


DicomObjects Namespace / ReadBehaviours Class / IgnorePrivateSequences Property

    IgnorePrivateSequences Property
    If set, private sequence items are skipped.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property IgnorePrivateSequences As Boolean
    'Usage

    Dim instance As ReadBehaviours
Dim value As Boolean

instance.IgnorePrivateSequences = value

value = instance.IgnorePrivateSequences
    public bool IgnorePrivateSequences {get; set;}
    Remarks

    The default value of this property is derived from the IgnorePrivateSequences value of the internal registry, which in turn has a default value of 0, causing this property to be false.

    Badly formed data in private sequences is unfortunately very common, and setting this property can allow some such data (if it has an explicit length) to be ignored, allowing the remainder of a dataset to be read.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ReadBehaviours Class
    ReadBehaviours Members


DicomObjects Namespace / ReadBehaviours Class / SilentEndOfFileReached Property

    SilentEndOfFileReached Property
    Set to true to tell DicomObjects to not throw End Of File Reached exception and stop reading from file when an attribute with bad length is encountered. Default value is false
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property SilentEndOfFileReached As Boolean
    'Usage

    Dim instance As ReadBehaviours
Dim value As Boolean

instance.SilentEndOfFileReached = value

value = instance.SilentEndOfFileReached
    public bool SilentEndOfFileReached {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ReadBehaviours Class
    ReadBehaviours Members


DicomObjects Namespace / ReadBehaviours Class / ThrowNotDICOMDIRError Property

    ThrowNotDICOMDIRError Property
    Controls whether to throw an exception if a file which is apparently a DICOM does not contain the expected DICOMDIR offset attributes.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property ThrowNotDICOMDIRError As Boolean
    'Usage

    Dim instance As ReadBehaviours
Dim value As Boolean

instance.ThrowNotDICOMDIRError = value

value = instance.ThrowNotDICOMDIRError
    public bool ThrowNotDICOMDIRError {get; set;}
    Remarks

    The default value of this property is derived from the ThrowNotDICOMDIRError value of the internal registry, which in turn has a default value of 1, causing this property to be true.

    This error can sometimes be triggered by files which are not DICOMDIRs but which for some reason do not contain a SOP class UID.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ReadBehaviours Class
    ReadBehaviours Members


DicomObjects Namespace / ReadBehaviours Class / TolerateBadOffsets Property

    TolerateBadOffsets Property
    Ignore bad "offset" data when reading a DICOMDIR
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property TolerateBadOffsets As Boolean
    'Usage

    Dim instance As ReadBehaviours
Dim value As Boolean

instance.TolerateBadOffsets = value

value = instance.TolerateBadOffsets
    public bool TolerateBadOffsets {get; set;}
    Remarks

    The default value of this property is derived from the TolerateBadOffsets value of the internal registry, which in turn has a default value of 0, causing this property to be false.

    Setting this to true may enable some otherwise unreadable DICOMDIR files to the read, but as the bizarre mechanism used to organise DICOMDIR files is based on using offsets, the resulting DicomDataSet may not be a complete representation of the file.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ReadBehaviours Class
    ReadBehaviours Members


DicomObjects Namespace / ReadBehaviours Class / ZeissBug Property

    ZeissBug Property
    A workaround for old bad Zeiss Data, some of which had UT attributes with 2 Bytes length
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property ZeissBug As Boolean
    'Usage

    Dim instance As ReadBehaviours
Dim value As Boolean

instance.ZeissBug = value

value = instance.ZeissBug
    public bool ZeissBug {get; set;}
    Remarks
    The default value of this property is derived from the ZeissBug value of the internal registry, which in turn has a default value of 0, causing this property to be false.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ReadBehaviours Class
    ReadBehaviours Members


%%PageItemTitle%%

DicomObjects Namespace / SequencePath Class
Members

In This Topic
    SequencePath Class
    In This Topic
    Class to hold details of the path from a dataset to an attribute within it, including those nested in sequences.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Class SequencePath
    'Usage

    Dim instance As SequencePath
    public class SequencePath
    Inheritance Hierarchy

    System.Object
    DicomObjects.SequencePath

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SequencePath Members
    DicomObjects Namespace


%%PageItemTitle%% $$Members$$

DicomObjects Namespace / SequencePath Class
Properties Methods

In This Topic
    SequencePath Class Members
    In This Topic

    The following tables list the members exposed by SequencePath.

    Public Properties
     | Name | Description
Public Property | DataSet | The top level dataset holding the attribute
Public Property | ParentAttributes | The attributes (sequences) between the top level dataset and the target attribute
Public Property | ParentSequenceItems | The ordinal position (starting from 1) of the child dataset items of each sequence between the top level dataset and the target attribute
Public Property | TargetAttribute | The attribute to which this class points.
    Top
    Public Methods
     | Name | Description
Public Method | Format | Format the path using rules for each part
    Top
    See Also

    Reference

    SequencePath Class
    DicomObjects Namespace


%%PageItemTitle%% $$Methods$$

DicomObjects Namespace / SequencePath Class

    SequencePath Class Methods
    In This Topic

    For a list of all members of this type, see SequencePath members.

    Public Methods
     | Name | Description
Public Method | Format | Format the path using rules for each part
    Top
    See Also

    Reference

    SequencePath Class
    DicomObjects Namespace


DicomObjects Namespace / SequencePath Class / Format Method
This is standard format string, to format the PatientID, StudyUID, SeriesUID and InstanceUID properties of the dataset.
This is standard format string, used repeatedly, on each sequence item between the top level and the target attribute, the values being the tag of the sequence, and the ordinal of the dataet within it.
This is standard format string, used only for the target attribute, the value being the tag of that atribute.

In This Topic
    Format Method
    In This Topic
    Format the path using rules for each part
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Function Format( _
   ByVal Basic As String, _
   ByVal Parents As String, _
   ByVal Bottom As String _
) As String
    'Usage

    Dim instance As SequencePath
Dim Basic As String
Dim Parents As String
Dim Bottom As String
Dim value As String

value = instance.Format(Basic, Parents, Bottom)
    public string Format(
   string Basic,
   string Parents,
   string Bottom
)

    Parameters

    Basic
    This is standard format string, to format the PatientID, StudyUID, SeriesUID and InstanceUID properties of the dataset.
    Parents
    This is standard format string, used repeatedly, on each sequence item between the top level and the target attribute, the values being the tag of the sequence, and the ordinal of the dataet within it.
    Bottom
    This is standard format string, used only for the target attribute, the value being the tag of that atribute.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SequencePath Class
    SequencePath Members


%%PageItemTitle%% $$Properties$$

DicomObjects Namespace / SequencePath Class

    SequencePath Class Properties
    In This Topic

    For a list of all members of this type, see SequencePath members.

    Public Properties
     | Name | Description
Public Property | DataSet | The top level dataset holding the attribute
Public Property | ParentAttributes | The attributes (sequences) between the top level dataset and the target attribute
Public Property | ParentSequenceItems | The ordinal position (starting from 1) of the child dataset items of each sequence between the top level dataset and the target attribute
Public Property | TargetAttribute | The attribute to which this class points.
    Top
    See Also

    Reference

    SequencePath Class
    DicomObjects Namespace


DicomObjects Namespace / SequencePath Class / DataSet Property

    DataSet Property (SequencePath)
    In This Topic
    The top level dataset holding the attribute
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property DataSet As DicomDataSet
    'Usage

    Dim instance As SequencePath
Dim value As DicomDataSet

value = instance.DataSet
    public DicomDataSet DataSet {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SequencePath Class
    SequencePath Members


DicomObjects Namespace / SequencePath Class / ParentAttributes Property

    ParentAttributes Property
    The attributes (sequences) between the top level dataset and the target attribute
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property ParentAttributes As List(Of DicomAttribute)
    'Usage

    Dim instance As SequencePath
Dim value As List(Of DicomAttribute)

value = instance.ParentAttributes
    public List<DicomAttribute> ParentAttributes {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SequencePath Class
    SequencePath Members


DicomObjects Namespace / SequencePath Class / ParentSequenceItems Property

    ParentSequenceItems Property
    The ordinal position (starting from 1) of the child dataset items of each sequence between the top level dataset and the target attribute
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property ParentSequenceItems As List(Of Integer)
    'Usage

    Dim instance As SequencePath
Dim value As List(Of Integer)

value = instance.ParentSequenceItems
    public List<int> ParentSequenceItems {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SequencePath Class
    SequencePath Members


DicomObjects Namespace / SequencePath Class / TargetAttribute Property

    TargetAttribute Property
    The attribute to which this class points.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property TargetAttribute As DicomAttribute
    'Usage

    Dim instance As SequencePath
Dim value As DicomAttribute

value = instance.TargetAttribute
    public DicomAttribute TargetAttribute {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SequencePath Class
    SequencePath Members


%%PageItemTitle%%

DicomObjects Namespace / WriteBehaviours Class
Members

In This Topic
    WriteBehaviours Class
    In This Topic
    Specific behaviour to use when writing/sending a DICOM instance
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Class WriteBehaviours
    'Usage

    Dim instance As WriteBehaviours
    public class WriteBehaviours
    Remarks

    An object of this class may be used in 4 ways:

    • As a parameter to one of the overrides of DicomDataSet.Write
    • By assiging to DicomGlobal.DefaultWriteBehaviour
    • By setting the WriteBehaviour property of an explicitly created DicomAssociation
    • By setting the WriteBehaviour property of an internally generated DicomAssociation object during the DicomServer.AssociationRequest event

    Most of the behaviours controlled by the properties of this object may also be set globally using the internal registry, but this object allows more granular control.

    Inheritance Hierarchy

    System.Object
    DicomObjects.WriteBehaviours

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WriteBehaviours Members
    DicomObjects Namespace


%%PageItemTitle%% $$Members$$

DicomObjects Namespace / WriteBehaviours Class
Properties

In This Topic
    WriteBehaviours Class Members
    In This Topic

    The following tables list the members exposed by WriteBehaviours.

    Public Constructors
     | Name | Description
Public Constructor | WriteBehaviours Constructor | Create a new WriteBehaviours object
    Top
    Public Properties
     | Name | Description
Public Property | AllowOddLengths | Allows data to do be written with odd lengths
Public Property | ChangeLossyAttributes | Controls whether DicomObjects alters Lossy compression related attributes (for e.g. Instance UID, Source Image Sequence and Image Type) to reflect the change in data due to lossy compression. ChangeLossyUIDs is a subset of this property where that only controls the UID changes but the other attributes are updated appropriately
Public Property | ChangeLossyUIDs | Controls whether DicomObjects changes the UID when doing lossy compression
Public Property | DontCompressIcons | Controls whether to compress icon pixcel data if using an encapsulated (compressed) transfer syntax.
Public Property | ImplicitSequenceItemLength | Controls whether sequence itemss are written out using Implicit or Explicit lengths for the sequence
Public Property | ImplicitSequenceLength | Controls whether sequences are written out using Implicit or Explicit lengths for the sequence
Public Property | NonSeekableBotHandling | Controls the creation of the Basic Offset Table (BOT) when writing data to non-seekable streams such as the network.
Public Property | OmitBOT | Controls whether to write a Basic Offset Table (BOT) for encapsulated (compressed) pixel data.
Public Property | OmitJpegComments | Controls whether to include JPEG comments during compression
Public Property | OverwriteWithCorrectVR | Controls the correction of mismatching VR. If this settings is enabled correction of wrong VR for all attributes will be attempted when writing out or sending, this won't affect the original dataset
Public Property | RescaleCTs | Controls whether to make changes to the rescale slope and offset if compressing to a smaller range.
Public Property | SeekableBotHandling | Controls the creation of the Basic Offset Table (BOT) when writing data to seekable streams such as files.
    Top
    See Also

    Reference

    WriteBehaviours Class
    DicomObjects Namespace


%%PageItemTitle%%

DicomObjects Namespace / WriteBehaviours Class / WriteBehaviours Constructor

In This Topic
    WriteBehaviours Constructor
    In This Topic
    Create a new WriteBehaviours object
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Function New()
    'Usage

    Dim instance As New WriteBehaviours()
    public WriteBehaviours()
    Remarks
    The properties are all initialised from global or "registry" values, as described in each individual property
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WriteBehaviours Class
    WriteBehaviours Members


%%PageItemTitle%% $$Properties$$

DicomObjects Namespace / WriteBehaviours Class

    WriteBehaviours Class Properties
    In This Topic

    For a list of all members of this type, see WriteBehaviours members.

    Public Properties
     | Name | Description
Public Property | AllowOddLengths | Allows data to do be written with odd lengths
Public Property | ChangeLossyAttributes | Controls whether DicomObjects alters Lossy compression related attributes (for e.g. Instance UID, Source Image Sequence and Image Type) to reflect the change in data due to lossy compression. ChangeLossyUIDs is a subset of this property where that only controls the UID changes but the other attributes are updated appropriately
Public Property | ChangeLossyUIDs | Controls whether DicomObjects changes the UID when doing lossy compression
Public Property | DontCompressIcons | Controls whether to compress icon pixcel data if using an encapsulated (compressed) transfer syntax.
Public Property | ImplicitSequenceItemLength | Controls whether sequence itemss are written out using Implicit or Explicit lengths for the sequence
Public Property | ImplicitSequenceLength | Controls whether sequences are written out using Implicit or Explicit lengths for the sequence
Public Property | NonSeekableBotHandling | Controls the creation of the Basic Offset Table (BOT) when writing data to non-seekable streams such as the network.
Public Property | OmitBOT | Controls whether to write a Basic Offset Table (BOT) for encapsulated (compressed) pixel data.
Public Property | OmitJpegComments | Controls whether to include JPEG comments during compression
Public Property | OverwriteWithCorrectVR | Controls the correction of mismatching VR. If this settings is enabled correction of wrong VR for all attributes will be attempted when writing out or sending, this won't affect the original dataset
Public Property | RescaleCTs | Controls whether to make changes to the rescale slope and offset if compressing to a smaller range.
Public Property | SeekableBotHandling | Controls the creation of the Basic Offset Table (BOT) when writing data to seekable streams such as files.
    Top
    See Also

    Reference

    WriteBehaviours Class
    DicomObjects Namespace


DicomObjects Namespace / WriteBehaviours Class / AllowOddLengths Property

    AllowOddLengths Property
    Allows data to do be written with odd lengths
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property AllowOddLengths As Boolean
    'Usage

    Dim instance As WriteBehaviours
Dim value As Boolean

instance.AllowOddLengths = value

value = instance.AllowOddLengths
    public bool AllowOddLengths {get; set;}
    Remarks

    The default value of this property is derived from the AllowOddLengths value of the internal registry, which in turn has a default value of 0, causing this property to be false.

    Data written with this property set does not conform to the DICOM standard, and this property should only be used either for testing, or when re-writing faulty files in an environment where bit-preservation is expected.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WriteBehaviours Class
    WriteBehaviours Members


DicomObjects Namespace / WriteBehaviours Class / ChangeLossyAttributes Property

    ChangeLossyAttributes Property
    Controls whether DicomObjects alters Lossy compression related attributes (for e.g. Instance UID, Source Image Sequence and Image Type) to reflect the change in data due to lossy compression. ChangeLossyUIDs is a subset of this property where that only controls the UID changes but the other attributes are updated appropriately
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property ChangeLossyAttributes As Boolean
    'Usage

    Dim instance As WriteBehaviours
Dim value As Boolean

instance.ChangeLossyAttributes = value

value = instance.ChangeLossyAttributes
    public bool ChangeLossyAttributes {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WriteBehaviours Class
    WriteBehaviours Members


DicomObjects Namespace / WriteBehaviours Class / ChangeLossyUIDs Property

    ChangeLossyUIDs Property (WriteBehaviours)
    In This Topic
    Controls whether DicomObjects changes the UID when doing lossy compression
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property ChangeLossyUIDs As Boolean
    'Usage

    Dim instance As WriteBehaviours
Dim value As Boolean

instance.ChangeLossyUIDs = value

value = instance.ChangeLossyUIDs
    public bool ChangeLossyUIDs {get; set;}
    Remarks

    This is initialised from DicomGlobal.ChangeLossyUIDs - see that property for more details of the effects of this property.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WriteBehaviours Class
    WriteBehaviours Members


DicomObjects Namespace / WriteBehaviours Class / DontCompressIcons Property

    DontCompressIcons Property
    Controls whether to compress icon pixcel data if using an encapsulated (compressed) transfer syntax.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property DontCompressIcons As Boolean
    'Usage

    Dim instance As WriteBehaviours
Dim value As Boolean

instance.DontCompressIcons = value

value = instance.DontCompressIcons
    public bool DontCompressIcons {get; set;}
    Remarks

    DICOM allows icon images to be either compressed (with an implicit length) or uncompressed (with an explicit length), and this property allows develoeprs to choose which to use.

    The default value of this property is derived from the DontCompressIcons value of the internal registry, which in turn has a default value of 0, causing this property to be false, causing icons to be compressed as per the transfer syntax of the surrounding dataset

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WriteBehaviours Class
    WriteBehaviours Members


DicomObjects Namespace / WriteBehaviours Class / ImplicitSequenceItemLength Property

    ImplicitSequenceItemLength Property
    Controls whether sequence itemss are written out using Implicit or Explicit lengths for the sequence
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property ImplicitSequenceItemLength As Boolean
    'Usage

    Dim instance As WriteBehaviours
Dim value As Boolean

instance.ImplicitSequenceItemLength = value

value = instance.ImplicitSequenceItemLength
    public bool ImplicitSequenceItemLength {get; set;}
    Remarks

    For sequences, DICOM allows either explicit or implicit length to be used for the individual sequence itmes, and when reading/receiving, both are accepted. This is separate from the choice made for the sequence itself, which is controlled by the ImplicitSequenceLength property.

    The default value of this property is derived from the the bit 1 of the ImplicitSequence value the internal registry, which in turn has a default value of 0, causing this property to be false, resulting in explicit sequence item lengths being used.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WriteBehaviours Class
    WriteBehaviours Members


DicomObjects Namespace / WriteBehaviours Class / ImplicitSequenceLength Property

    ImplicitSequenceLength Property
    Controls whether sequences are written out using Implicit or Explicit lengths for the sequence
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property ImplicitSequenceLength As Boolean
    'Usage

    Dim instance As WriteBehaviours
Dim value As Boolean

instance.ImplicitSequenceLength = value

value = instance.ImplicitSequenceLength
    public bool ImplicitSequenceLength {get; set;}
    Remarks

    For sequences, DICOM allows either explicit or implicit length to be used for the sequence itself, and when reading/receiving, both are accepted. This is separate from the choice made for individual sequence items, which are controlled by the ImplicitSequenceItemLength property.

    The default value of this property is derived from the the bit 0 of the ImplicitSequence value the internal registry, which in turn has a default value of 0, causing this property to be false, resulting in explicit sequence lengths being used.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WriteBehaviours Class
    WriteBehaviours Members


DicomObjects Namespace / WriteBehaviours Class / NonSeekableBotHandling Property

    NonSeekableBotHandling Property
    Controls the creation of the Basic Offset Table (BOT) when writing data to non-seekable streams such as the network.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property NonSeekableBotHandling As BasicOffsetTableHandling
    'Usage

    Dim instance As WriteBehaviours
Dim value As BasicOffsetTableHandling

instance.NonSeekableBotHandling = value

value = instance.NonSeekableBotHandling
    public BasicOffsetTableHandling NonSeekableBotHandling {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WriteBehaviours Class
    WriteBehaviours Members


DicomObjects Namespace / WriteBehaviours Class / OmitBOT Property

    OmitBOT Property
    Controls whether to write a Basic Offset Table (BOT) for encapsulated (compressed) pixel data.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    <ObsoleteAttribute("Please use SeekableBotHandling & NonSeekableBotHandling for finer control")>
Public Property OmitBOT As Boolean
    'Usage

    Dim instance As WriteBehaviours
Dim value As Boolean

instance.OmitBOT = value

value = instance.OmitBOT
    [Obsolete("Please use SeekableBotHandling & NonSeekableBotHandling for finer control")]
public bool OmitBOT {get; set;}
    Remarks

    The default value of this property is derived from the OmitBOT value of the internal registry, which in turn has a default value of 0, causing this property to be false, causing the BOT to be written as normal

    Setting this to true does not cause the BOT to be omited completely (as that would contavene DICOM rules) - instead it causes it to be zero lngth, which is permissible.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WriteBehaviours Class
    WriteBehaviours Members


DicomObjects Namespace / WriteBehaviours Class / OmitJpegComments Property

    OmitJpegComments Property
    Controls whether to include JPEG comments during compression
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property OmitJpegComments As Boolean
    'Usage

    Dim instance As WriteBehaviours
Dim value As Boolean

instance.OmitJpegComments = value

value = instance.OmitJpegComments
    public bool OmitJpegComments {get; set;}
    Remarks
    This parameter is set to false by default (i.e. include JPEG comments in the output)
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WriteBehaviours Class
    WriteBehaviours Members


DicomObjects Namespace / WriteBehaviours Class / OverwriteWithCorrectVR Property

    OverwriteWithCorrectVR Property
    Controls the correction of mismatching VR. If this settings is enabled correction of wrong VR for all attributes will be attempted when writing out or sending, this won't affect the original dataset
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property OverwriteWithCorrectVR As Boolean
    'Usage

    Dim instance As WriteBehaviours
Dim value As Boolean

instance.OverwriteWithCorrectVR = value

value = instance.OverwriteWithCorrectVR
    public bool OverwriteWithCorrectVR {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WriteBehaviours Class
    WriteBehaviours Members


DicomObjects Namespace / WriteBehaviours Class / RescaleCTs Property

    RescaleCTs Property
    Controls whether to make changes to the rescale slope and offset if compressing to a smaller range.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property RescaleCTs As Boolean
    'Usage

    Dim instance As WriteBehaviours
Dim value As Boolean

instance.RescaleCTs = value

value = instance.RescaleCTs
    public bool RescaleCTs {get; set;}
    Remarks

    The changes are needed to maintain proper Hounsfield units for CT, so this value should only be set to false for very specific test circumastances.

    The default value of this property is derived from the RescaleCTs value of the internal registry, which in turn has a default value of 1, causing this property to be true.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WriteBehaviours Class
    WriteBehaviours Members


DicomObjects Namespace / WriteBehaviours Class / SeekableBotHandling Property

    SeekableBotHandling Property
    Controls the creation of the Basic Offset Table (BOT) when writing data to seekable streams such as files.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property SeekableBotHandling As BasicOffsetTableHandling
    'Usage

    Dim instance As WriteBehaviours
Dim value As BasicOffsetTableHandling

instance.SeekableBotHandling = value

value = instance.SeekableBotHandling
    public BasicOffsetTableHandling SeekableBotHandling {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WriteBehaviours Class
    WriteBehaviours Members


%%PageItemTitle%%

DicomObjects Namespace / WsiTile Structure
Members

In This Topic
    WsiTile Structure
    In This Topic
    Representing WSI Tile with its list of tile fragments
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Structure WsiTile
   Inherits System.ValueType
    'Usage

    Dim instance As WsiTile
    public struct WsiTile : System.ValueType
    Inheritance Hierarchy

    System.Object
    System.ValueType
    DicomObjects.WsiTile

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WsiTile Members
    DicomObjects Namespace


%%PageItemTitle%% $$Members$$

DicomObjects Namespace / WsiTile Structure
Properties

In This Topic
    WsiTile Structure Members
    In This Topic

    The following tables list the members exposed by WsiTile.

    Public Properties
     | Name | Description
Public Property | Fragments | List of fragments for this tile
Public Property | Index | Tile number
    Top
    See Also

    Reference

    WsiTile Structure
    DicomObjects Namespace


%%PageItemTitle%% $$Properties$$

DicomObjects Namespace / WsiTile Structure

    WsiTile Structure Properties
    In This Topic

    For a list of all members of this type, see WsiTile members.

    Public Properties
     | Name | Description
Public Property | Fragments | List of fragments for this tile
Public Property | Index | Tile number
    Top
    See Also

    Reference

    WsiTile Structure
    DicomObjects Namespace


DicomObjects Namespace / WsiTile Structure / Fragments Property

    Fragments Property (WsiTile)
    In This Topic
    List of fragments for this tile
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property Fragments As List(Of WsiTileFragment)
    'Usage

    Dim instance As WsiTile
Dim value As List(Of WsiTileFragment)

instance.Fragments = value

value = instance.Fragments
    public List<WsiTileFragment> Fragments {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WsiTile Structure
    WsiTile Members


DicomObjects Namespace / WsiTile Structure / Index Property

    Index Property (WsiTile)
    In This Topic
    Tile number
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property Index As Integer
    'Usage

    Dim instance As WsiTile
Dim value As Integer

instance.Index = value

value = instance.Index
    public int Index {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WsiTile Structure
    WsiTile Members


%%PageItemTitle%%

DicomObjects Namespace / WsiTileFragment Structure
Members

In This Topic
    WsiTileFragment Structure
    In This Topic
    Representing each WSI Tile Fragment
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Structure WsiTileFragment
   Inherits System.ValueType
    'Usage

    Dim instance As WsiTileFragment
    public struct WsiTileFragment : System.ValueType
    Inheritance Hierarchy

    System.Object
    System.ValueType
    DicomObjects.WsiTileFragment

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WsiTileFragment Members
    DicomObjects Namespace


%%PageItemTitle%% $$Members$$

DicomObjects Namespace / WsiTileFragment Structure
Properties

In This Topic
    WsiTileFragment Structure Members
    In This Topic

    The following tables list the members exposed by WsiTileFragment.

    Public Properties
     | Name | Description
Public Property | Index | Tile fragment number
Public Property | Length | Lenght of the tile fragment
Public Property | Offset | Offset from the start of the Pixel Data
    Top
    See Also

    Reference

    WsiTileFragment Structure
    DicomObjects Namespace


%%PageItemTitle%% $$Properties$$

DicomObjects Namespace / WsiTileFragment Structure

    WsiTileFragment Structure Properties
    In This Topic

    For a list of all members of this type, see WsiTileFragment members.

    Public Properties
     | Name | Description
Public Property | Index | Tile fragment number
Public Property | Length | Lenght of the tile fragment
Public Property | Offset | Offset from the start of the Pixel Data
    Top
    See Also

    Reference

    WsiTileFragment Structure
    DicomObjects Namespace


DicomObjects Namespace / WsiTileFragment Structure / Index Property

    Index Property (WsiTileFragment)
    In This Topic
    Tile fragment number
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property Index As Integer
    'Usage

    Dim instance As WsiTileFragment
Dim value As Integer

instance.Index = value

value = instance.Index
    public int Index {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WsiTileFragment Structure
    WsiTileFragment Members


DicomObjects Namespace / WsiTileFragment Structure / Length Property

    Length Property
    Lenght of the tile fragment
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property Length As UInteger
    'Usage

    Dim instance As WsiTileFragment
Dim value As UInteger

instance.Length = value

value = instance.Length
    public uint Length {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WsiTileFragment Structure
    WsiTileFragment Members


DicomObjects Namespace / WsiTileFragment Structure / Offset Property

    Offset Property (WsiTileFragment)
    In This Topic
    Offset from the start of the Pixel Data
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property Offset As Long
    'Usage

    Dim instance As WsiTileFragment
Dim value As Long

instance.Offset = value

value = instance.Offset
    public long Offset {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WsiTileFragment Structure
    WsiTileFragment Members


%%PageItemTitle%%

DicomObjects Namespace / DicomAttribute.DelayedDataRoutine Delegate
The dataset the bid is realted to

In This Topic
    DicomAttribute.DelayedDataRoutine Delegate
    In This Topic
    Delegate to fetch binary data for the bid
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Delegate Function DicomAttribute.DelayedDataRoutine( _
   ByVal ds As DicomDataSet _
) As Byte()
    'Usage

    Dim instance As New DicomAttribute.DelayedDataRoutine(AddressOf HandlerMethod)
    public delegate byte[] DicomAttribute.DelayedDataRoutine(
   DicomDataSet ds
)

    Parameters

    ds
    The dataset the bid is realted to

    Return Value

    Binary data as byte[]
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomAttribute.DelayedDataRoutine Members
    DicomObjects Namespace


Inheritance Hierarchy
    DicomObjects.Codecs Namespace
    Classes
     | Class | Description
Class | CodecFactory | "Factory" class which creates and controls the instantiation of codecs
Class | CompressionArguments | class used to pass arguments to a compression codec
Class | DecompressionArguments | Class used to hold arguments passed to a decompression codec
Class | DicomCodecBaseArguments | The base class for arguments passed to codecs
Class | ImportArguments | Class used to hold arguments passed to an import codec
Class | Jpeg2000CompressionOptions | Class which allows control of the details of JPEG 2000 compression
Class | JpegLossless | The class which implements the internal JPEG Lossless codec
Class | JpegLSCompressionOptions | Class which allows control of the details of JpegLS compression
Class | Jpip | Static class to hold global options for JPIP usage
Class | ModificationArguments | Defines changes which need to be applied to a compressed image
Class | SimpleCodec | A class which provides a simple implementation of most of the required members of ICompressor and IDecompressor, simplifying implementation for transfer syntaxes which do not need partial decompression.
Class | VideoCodec | A class derived from SimpleCodec to be used by video codecs
    Interfaces
     | Interface | Description
Interface | ICodecBase | Common features for all codecs
Interface | ICompressor | Interface implemented by all compression codecs
Interface | IDecompressor | Interface implemented by for all DICOM decompression codecs
Interface | IExporter | Interface implemented by all export codecs
Interface | IImporter | Interface implemented by all import codecs
    See Also

    Reference

    DicomObjects.NetStandard Assembly


%%PageItemTitle%%

DicomObjects.Codecs Namespace / CodecFactory Class
Members

In This Topic
    CodecFactory Class
    In This Topic
    "Factory" class which creates and controls the instantiation of codecs
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public MustInherit Class CodecFactory
    'Usage

    Dim instance As CodecFactory
    public abstract class CodecFactory
    Remarks

    This is the main class which would need to be implemented by anyone missing to write their own codecs, to specify what transfer synatxes or external formats are supported.

    See for more details on the new codec interface used from verion 5.6.3.x onwards

    Inheritance Hierarchy

    System.Object
    DicomObjects.Codecs.CodecFactory

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    CodecFactory Members
    DicomObjects.Codecs Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.Codecs Namespace / CodecFactory Class
Methods

In This Topic
    CodecFactory Class Members
    In This Topic

    The following tables list the members exposed by CodecFactory.

    Public Methods
     | Name | Description
Public Method | CheckStart | Check whether a stream contains data which could be the start of a frame of compressed data
Public Method | Compressor | Create a Compressor object
Public Method | Decompressor | Create a Decompressor object
Public Method | Exporter | Create the Exporter object
Public Method | Importer | Create an Importer object
Public Method | SupportedTransferSyntaxes | The list of transfer syntaxes supported by this factory. This also includes file extensions for import and export
    Top
    See Also

    Reference

    CodecFactory Class
    DicomObjects.Codecs Namespace


%%PageItemTitle%% $$Methods$$

DicomObjects.Codecs Namespace / CodecFactory Class

    CodecFactory Class Methods
    In This Topic

    For a list of all members of this type, see CodecFactory members.

    Public Methods
     | Name | Description
Public Method | CheckStart | Check whether a stream contains data which could be the start of a frame of compressed data
Public Method | Compressor | Create a Compressor object
Public Method | Decompressor | Create a Decompressor object
Public Method | Exporter | Create the Exporter object
Public Method | Importer | Create an Importer object
Public Method | SupportedTransferSyntaxes | The list of transfer syntaxes supported by this factory. This also includes file extensions for import and export
    Top
    See Also

    Reference

    CodecFactory Class
    DicomObjects.Codecs Namespace


DicomObjects.Codecs Namespace / CodecFactory Class / CheckStart Method
The fragment data to test
The transfer syntax to check against

In This Topic
    CheckStart Method
    In This Topic
    Check whether a stream contains data which could be the start of a frame of compressed data
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public MustOverride Function CheckStart( _
   ByVal stream As Stream, _
   ByVal TransferSyntax As String _
) As Boolean
    'Usage

    Dim instance As CodecFactory
Dim stream As Stream
Dim TransferSyntax As String
Dim value As Boolean

value = instance.CheckStart(stream, TransferSyntax)
    public abstract bool CheckStart(
   Stream stream,
   string TransferSyntax
)

    Parameters

    stream
    The fragment data to test
    TransferSyntax
    The transfer syntax to check against

    Return Value

    true if the data could be the start of a new frame for this transfer syntax
    Remarks
    This routine is used in the difficult cases where the basic offset table is empty, and where there is no obvious 1:1 relationship between fragments and frames, to determine which fragment is the start of which frame.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    CodecFactory Class
    CodecFactory Members


DicomObjects.Codecs Namespace / CodecFactory Class / Compressor Method
The transfer syntax to be used for the compression

    Compressor Method
    In This Topic
    Create a Compressor object
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public MustOverride Function Compressor( _
   ByVal TransferSyntax As String _
) As ICompressor
    'Usage

    Dim instance As CodecFactory
Dim TransferSyntax As String
Dim value As ICompressor

value = instance.Compressor(TransferSyntax)
    public abstract ICompressor Compressor(
   string TransferSyntax
)

    Parameters

    TransferSyntax
    The transfer syntax to be used for the compression

    Return Value

    The new Compressor object
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    CodecFactory Class
    CodecFactory Members


DicomObjects.Codecs Namespace / CodecFactory Class / Decompressor Method
The transfer syntax of the data to be decompressed
The data to be decompressed
The DicomDataSet containing the data to be decompressed
The Frame number (as per DICOM rules, numbered from 1)

In This Topic
    Decompressor Method
    In This Topic
    Create a Decompressor object
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public MustOverride Function Decompressor( _
   ByVal TransferSyntax As String, _
   ByVal Data As Stream, _
   ByVal DataSet As DicomDataSet, _
   ByVal Frame As Integer _
) As IDecompressor
    'Usage

    Dim instance As CodecFactory
Dim TransferSyntax As String
Dim Data As Stream
Dim DataSet As DicomDataSet
Dim Frame As Integer
Dim value As IDecompressor

value = instance.Decompressor(TransferSyntax, Data, DataSet, Frame)
    public abstract IDecompressor Decompressor(
   string TransferSyntax,
   Stream Data,
   DicomDataSet DataSet,
   int Frame
)

    Parameters

    TransferSyntax
    The transfer syntax of the data to be decompressed
    Data
    The data to be decompressed
    DataSet
    The DicomDataSet containing the data to be decompressed
    Frame
    The Frame number (as per DICOM rules, numbered from 1)

    Return Value

    The new Decompressor object
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    CodecFactory Class
    CodecFactory Members


DicomObjects.Codecs Namespace / CodecFactory Class / Exporter Method
The format to be used for the compression/export

    Exporter Method
    In This Topic
    Create the Exporter object
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public MustOverride Function Exporter( _
   ByVal Format As String _
) As IExporter
    'Usage

    Dim instance As CodecFactory
Dim Format As String
Dim value As IExporter

value = instance.Exporter(Format)
    public abstract IExporter Exporter(
   string Format
)

    Parameters

    Format
    The format to be used for the compression/export

    Return Value

    The new Exported object
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    CodecFactory Class
    CodecFactory Members


DicomObjects.Codecs Namespace / CodecFactory Class / Importer Method
The format of the data being decompressed/imported

    Importer Method
    In This Topic
    Create an Importer object
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public MustOverride Function Importer( _
   ByVal Format As String _
) As IImporter
    'Usage

    Dim instance As CodecFactory
Dim Format As String
Dim value As IImporter

value = instance.Importer(Format)
    public abstract IImporter Importer(
   string Format
)

    Parameters

    Format
    The format of the data being decompressed/imported

    Return Value

    The new Importer object
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    CodecFactory Class
    CodecFactory Members


DicomObjects.Codecs Namespace / CodecFactory Class / SupportedTransferSyntaxes Method
The type of operation that the transfer syntaxes/file extensions are valid for

In This Topic
    SupportedTransferSyntaxes Method
    In This Topic
    The list of transfer syntaxes supported by this factory. This also includes file extensions for import and export
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public MustOverride Function SupportedTransferSyntaxes( _
   ByVal Operation As CodecOperation _
) As String()
    'Usage

    Dim instance As CodecFactory
Dim Operation As CodecOperation
Dim value() As String

value = instance.SupportedTransferSyntaxes(Operation)
    public abstract string[] SupportedTransferSyntaxes(
   CodecOperation Operation
)

    Parameters

    Operation
    The type of operation that the transfer syntaxes/file extensions are valid for

    Return Value

    he list of transfer syntaxes
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    CodecFactory Class
    CodecFactory Members


%%PageItemTitle%%

DicomObjects.Codecs Namespace / CompressionArguments Class
Members

In This Topic
    CompressionArguments Class
    In This Topic
    class used to pass arguments to a compression codec
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Class CompressionArguments
   Inherits DicomCodecBaseArguments
    'Usage

    Dim instance As CompressionArguments
    public class CompressionArguments : DicomCodecBaseArguments
    Inheritance Hierarchy

    System.Object
    DicomObjects.Codecs.DicomCodecBaseArguments
    DicomObjects.Codecs.CompressionArguments

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    CompressionArguments Members
    DicomObjects.Codecs Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.Codecs Namespace / CompressionArguments Class
Properties

In This Topic
    CompressionArguments Class Members
    In This Topic

    The following tables list the members exposed by CompressionArguments.

    Public Properties
     | Name | Description
Public Property | BitsAllocated | Number of bits per sample allocated (always 8 or 16) (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | BitsStored | Number of bits per sample used (always between 8 and 16) (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | DataSet | The full associated dataset (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | DestinationStream | The stream into which compressed pixel data is placed
Public Property | Image | The DICOM image being compressed
Public Property | ImplementationUID | The implementation UID of the original image (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | isSigned | Sign of the data (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | OutputDataset | Reference of the actual output Dataset made available in the codec
Public Property | OutputTransferSyntax | The transfer syntax into which the image should be compressed
Public Property | PhotometricInterpretation | The photometric interpretation of the data (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | Planarconfig | How the colour pixel data is arranged (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | Planes | The number of images planes. (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | Quality | A data to describe compression quality
Public Property | Size | The size of the image (pixels x pixels) (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | SourceArray | The array from which the original decompressed pixel data is obtained. This could be a byte or short or ushort array depending on the pixel data bits stored.
Public Property | WriteBehaviour | Specific behaviours to use for compression
    Top
    See Also

    Reference

    CompressionArguments Class
    DicomObjects.Codecs Namespace


%%PageItemTitle%% $$Properties$$

DicomObjects.Codecs Namespace / CompressionArguments Class

    CompressionArguments Class Properties
    In This Topic

    For a list of all members of this type, see CompressionArguments members.

    Public Properties
     | Name | Description
Public Property | BitsAllocated | Number of bits per sample allocated (always 8 or 16) (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | BitsStored | Number of bits per sample used (always between 8 and 16) (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | DataSet | The full associated dataset (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | DestinationStream | The stream into which compressed pixel data is placed
Public Property | Image | The DICOM image being compressed
Public Property | ImplementationUID | The implementation UID of the original image (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | isSigned | Sign of the data (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | OutputDataset | Reference of the actual output Dataset made available in the codec
Public Property | OutputTransferSyntax | The transfer syntax into which the image should be compressed
Public Property | PhotometricInterpretation | The photometric interpretation of the data (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | Planarconfig | How the colour pixel data is arranged (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | Planes | The number of images planes. (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | Quality | A data to describe compression quality
Public Property | Size | The size of the image (pixels x pixels) (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | SourceArray | The array from which the original decompressed pixel data is obtained. This could be a byte or short or ushort array depending on the pixel data bits stored.
Public Property | WriteBehaviour | Specific behaviours to use for compression
    Top
    See Also

    Reference

    CompressionArguments Class
    DicomObjects.Codecs Namespace


DicomObjects.Codecs Namespace / CompressionArguments Class / DestinationStream Property

    DestinationStream Property
    The stream into which compressed pixel data is placed
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property DestinationStream As Stream
    'Usage

    Dim instance As CompressionArguments
Dim value As Stream

value = instance.DestinationStream
    public Stream DestinationStream {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    CompressionArguments Class
    CompressionArguments Members


DicomObjects.Codecs Namespace / CompressionArguments Class / Image Property

    Image Property (CompressionArguments)
    In This Topic
    The DICOM image being compressed
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property Image As DicomDataSet
    'Usage

    Dim instance As CompressionArguments
Dim value As DicomDataSet

instance.Image = value

value = instance.Image
    public DicomDataSet Image {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    CompressionArguments Class
    CompressionArguments Members


DicomObjects.Codecs Namespace / CompressionArguments Class / OutputDataset Property

    OutputDataset Property
    Reference of the actual output Dataset made available in the codec
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property OutputDataset As DicomDataSet
    'Usage

    Dim instance As CompressionArguments
Dim value As DicomDataSet

instance.OutputDataset = value

value = instance.OutputDataset
    public DicomDataSet OutputDataset {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    CompressionArguments Class
    CompressionArguments Members


DicomObjects.Codecs Namespace / CompressionArguments Class / OutputTransferSyntax Property

    OutputTransferSyntax Property (CompressionArguments)
    In This Topic
    The transfer syntax into which the image should be compressed
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property OutputTransferSyntax As String
    'Usage

    Dim instance As CompressionArguments
Dim value As String

value = instance.OutputTransferSyntax
    public string OutputTransferSyntax {get;}
    Remarks
    Most codecs will only handle one transfer syntax, but this is provided, as some can handle many - e.g. the JPEG 2000 codec which handles the lossless and lossy modes.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    CompressionArguments Class
    CompressionArguments Members


DicomObjects.Codecs Namespace / CompressionArguments Class / Quality Property

    Quality Property (CompressionArguments)
    In This Topic
    A data to describe compression quality
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property Quality As Object
    'Usage

    Dim instance As CompressionArguments
Dim value As Object

instance.Quality = value

value = instance.Quality
    public object Quality {get; set;}
    Remarks
    The meaning of this property is codec dependent.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    CompressionArguments Class
    CompressionArguments Members


DicomObjects.Codecs Namespace / CompressionArguments Class / SourceArray Property

    SourceArray Property
    The array from which the original decompressed pixel data is obtained. This could be a byte or short or ushort array depending on the pixel data bits stored.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property SourceArray As Array
    'Usage

    Dim instance As CompressionArguments
Dim value As Array

value = instance.SourceArray
    public Array SourceArray {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    CompressionArguments Class
    CompressionArguments Members


DicomObjects.Codecs Namespace / CompressionArguments Class / WriteBehaviour Property

    WriteBehaviour Property (CompressionArguments)
    In This Topic
    Specific behaviours to use for compression
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property WriteBehaviour As WriteBehaviours
    'Usage

    Dim instance As CompressionArguments
Dim value As WriteBehaviours

value = instance.WriteBehaviour
    public WriteBehaviours WriteBehaviour {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    CompressionArguments Class
    CompressionArguments Members


%%PageItemTitle%%

DicomObjects.Codecs Namespace / DecompressionArguments Class
Members

In This Topic
    DecompressionArguments Class
    In This Topic
    Class used to hold arguments passed to a decompression codec
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Class DecompressionArguments
   Inherits DicomCodecBaseArguments
    'Usage

    Dim instance As DecompressionArguments
    public class DecompressionArguments : DicomCodecBaseArguments
    Inheritance Hierarchy

    System.Object
    DicomObjects.Codecs.DicomCodecBaseArguments
    DicomObjects.Codecs.DecompressionArguments

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DecompressionArguments Members
    DicomObjects.Codecs Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.Codecs Namespace / DecompressionArguments Class
Fields Properties

In This Topic
    DecompressionArguments Class Members
    In This Topic

    The following tables list the members exposed by DecompressionArguments.

    Public Fields
     | Name | Description
Public Field | ReadBehaviour | Specific behaviours to use for decompression
    Top
    Public Properties
     | Name | Description
Public Property | BitsAllocated | Number of bits per sample allocated (always 8 or 16) (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | BitsStored | Number of bits per sample used (always between 8 and 16) (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | DataSet | The full associated dataset (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | DestinationArray | The array into which the original decompressed pixel data is placed. This could be a byte or short or ushort array depending on the pixel data bits stored.
Public Property | Frame | The requested Frame number (first frame is 1, not 0)
Public Property | FrameCount | Total number of frames in the input stream. Useful for some codec (e.g. FFmpeg) if it needs to seek and run cope with out of sync and missing frames
Public Property | ImplementationUID | The implementation UID of the original image (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | InputTransferSyntax | The transfer syntax of the input data
Public Property | isSigned | Sign of the data (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | PhotometricInterpretation | The photometric interpretation of the data (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | PixelRequest | The requested resolution to decompress the image to
Public Property | Planarconfig | How the colour pixel data is arranged (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | Planes | The number of images planes. (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | Size | The size of the image (pixels x pixels) (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | SourceStream | The stream from which compressed pixel data is obtained
    Top
    See Also

    Reference

    DecompressionArguments Class
    DicomObjects.Codecs Namespace


%%PageItemTitle%% $$Properties$$

DicomObjects.Codecs Namespace / DecompressionArguments Class

    DecompressionArguments Class Properties
    In This Topic

    For a list of all members of this type, see DecompressionArguments members.

    Public Properties
     | Name | Description
Public Property | BitsAllocated | Number of bits per sample allocated (always 8 or 16) (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | BitsStored | Number of bits per sample used (always between 8 and 16) (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | DataSet | The full associated dataset (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | DestinationArray | The array into which the original decompressed pixel data is placed. This could be a byte or short or ushort array depending on the pixel data bits stored.
Public Property | Frame | The requested Frame number (first frame is 1, not 0)
Public Property | FrameCount | Total number of frames in the input stream. Useful for some codec (e.g. FFmpeg) if it needs to seek and run cope with out of sync and missing frames
Public Property | ImplementationUID | The implementation UID of the original image (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | InputTransferSyntax | The transfer syntax of the input data
Public Property | isSigned | Sign of the data (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | PhotometricInterpretation | The photometric interpretation of the data (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | PixelRequest | The requested resolution to decompress the image to
Public Property | Planarconfig | How the colour pixel data is arranged (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | Planes | The number of images planes. (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | Size | The size of the image (pixels x pixels) (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | SourceStream | The stream from which compressed pixel data is obtained
    Top
    See Also

    Reference

    DecompressionArguments Class
    DicomObjects.Codecs Namespace


DicomObjects.Codecs Namespace / DecompressionArguments Class / DestinationArray Property

    DestinationArray Property
    The array into which the original decompressed pixel data is placed. This could be a byte or short or ushort array depending on the pixel data bits stored.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property DestinationArray As Array
    'Usage

    Dim instance As DecompressionArguments
Dim value As Array

value = instance.DestinationArray
    public Array DestinationArray {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DecompressionArguments Class
    DecompressionArguments Members


DicomObjects.Codecs Namespace / DecompressionArguments Class / Frame Property

    Frame Property (DecompressionArguments)
    In This Topic
    The requested Frame number (first frame is 1, not 0)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property Frame As Integer
    'Usage

    Dim instance As DecompressionArguments
Dim value As Integer

instance.Frame = value

value = instance.Frame
    public int Frame {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DecompressionArguments Class
    DecompressionArguments Members


DicomObjects.Codecs Namespace / DecompressionArguments Class / FrameCount Property

    FrameCount Property (DecompressionArguments)
    In This Topic
    Total number of frames in the input stream. Useful for some codec (e.g. FFmpeg) if it needs to seek and run cope with out of sync and missing frames
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property FrameCount As Integer
    'Usage

    Dim instance As DecompressionArguments
Dim value As Integer

instance.FrameCount = value

value = instance.FrameCount
    public int FrameCount {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DecompressionArguments Class
    DecompressionArguments Members


DicomObjects.Codecs Namespace / DecompressionArguments Class / InputTransferSyntax Property

    InputTransferSyntax Property (DecompressionArguments)
    In This Topic
    The transfer syntax of the input data
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property InputTransferSyntax As String
    'Usage

    Dim instance As DecompressionArguments
Dim value As String

value = instance.InputTransferSyntax
    public string InputTransferSyntax {get;}
    Remarks
    Most codecs will only handle one transfer syntax, but this is provided, as some can handle many - e.g. the JPEG 2000 codec which handles the lossless and lossy modes.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DecompressionArguments Class
    DecompressionArguments Members


DicomObjects.Codecs Namespace / DecompressionArguments Class / PixelRequest Property

    PixelRequest Property
    The requested resolution to decompress the image to
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property PixelRequest As PixelRequest
    'Usage

    Dim instance As DecompressionArguments
Dim value As PixelRequest

instance.PixelRequest = value

value = instance.PixelRequest
    public PixelRequest PixelRequest {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DecompressionArguments Class
    DecompressionArguments Members


DicomObjects.Codecs Namespace / DecompressionArguments Class / SourceStream Property

    SourceStream Property (DecompressionArguments)
    In This Topic
    The stream from which compressed pixel data is obtained
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property SourceStream As Stream
    'Usage

    Dim instance As DecompressionArguments
Dim value As Stream

value = instance.SourceStream
    public Stream SourceStream {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DecompressionArguments Class
    DecompressionArguments Members


%%PageItemTitle%% $$Fields$$

DicomObjects.Codecs Namespace / DecompressionArguments Class

    DecompressionArguments Class Fields
    In This Topic

    For a list of all members of this type, see DecompressionArguments members.

    Public Fields
     | Name | Description
Public Field | ReadBehaviour | Specific behaviours to use for decompression
    Top
    See Also

    Reference

    DecompressionArguments Class
    DicomObjects.Codecs Namespace


DicomObjects.Codecs Namespace / DecompressionArguments Class / ReadBehaviour Field

    ReadBehaviour Field
    Specific behaviours to use for decompression
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadBehaviour As ReadBehaviours
    'Usage

    Dim instance As DecompressionArguments
Dim value As ReadBehaviours

value = instance.ReadBehaviour

instance.ReadBehaviour = value
    public ReadBehaviours ReadBehaviour
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DecompressionArguments Class
    DecompressionArguments Members


%%PageItemTitle%%

DicomObjects.Codecs Namespace / DicomCodecBaseArguments Class
Members

In This Topic
    DicomCodecBaseArguments Class
    In This Topic
    The base class for arguments passed to codecs
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Class DicomCodecBaseArguments
    'Usage

    Dim instance As DicomCodecBaseArguments
    public class DicomCodecBaseArguments
    Remarks

    Different derived classes are defined for:

    • Compression & Export (CompressionArguments)
    • Decompression (DecompressionArguments)
    • Import (ImportArguments)
    Inheritance Hierarchy

    System.Object
    DicomObjects.Codecs.DicomCodecBaseArguments
    DicomObjects.Codecs.CompressionArguments
    DicomObjects.Codecs.DecompressionArguments
    DicomObjects.Codecs.ImportArguments
    DicomObjects.Codecs.ModificationArguments

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomCodecBaseArguments Members
    DicomObjects.Codecs Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.Codecs Namespace / DicomCodecBaseArguments Class
Properties

In This Topic
    DicomCodecBaseArguments Class Members
    In This Topic

    The following tables list the members exposed by DicomCodecBaseArguments.

    Public Properties
     | Name | Description
Public Property | BitsAllocated | Number of bits per sample allocated (always 8 or 16)
Public Property | BitsStored | Number of bits per sample used (always between 8 and 16)
Public Property | DataSet | The full associated dataset
Public Property | ImplementationUID | The implementation UID of the original image
Public Property | isSigned | Sign of the data
Public Property | PhotometricInterpretation | The photometric interpretation of the data
Public Property | Planarconfig | How the colour pixel data is arranged
Public Property | Planes | The number of images planes.
Public Property | Size | The size of the image (pixels x pixels)
    Top
    See Also

    Reference

    DicomCodecBaseArguments Class
    DicomObjects.Codecs Namespace


%%PageItemTitle%% $$Properties$$

DicomObjects.Codecs Namespace / DicomCodecBaseArguments Class

In This Topic
    DicomCodecBaseArguments Class Properties
    In This Topic

    For a list of all members of this type, see DicomCodecBaseArguments members.

    Public Properties
     | Name | Description
Public Property | BitsAllocated | Number of bits per sample allocated (always 8 or 16)
Public Property | BitsStored | Number of bits per sample used (always between 8 and 16)
Public Property | DataSet | The full associated dataset
Public Property | ImplementationUID | The implementation UID of the original image
Public Property | isSigned | Sign of the data
Public Property | PhotometricInterpretation | The photometric interpretation of the data
Public Property | Planarconfig | How the colour pixel data is arranged
Public Property | Planes | The number of images planes.
Public Property | Size | The size of the image (pixels x pixels)
    Top
    See Also

    Reference

    DicomCodecBaseArguments Class
    DicomObjects.Codecs Namespace


DicomObjects.Codecs Namespace / DicomCodecBaseArguments Class / BitsAllocated Property

    BitsAllocated Property
    Number of bits per sample allocated (always 8 or 16)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property BitsAllocated As Integer
    'Usage

    Dim instance As DicomCodecBaseArguments
Dim value As Integer

value = instance.BitsAllocated
    public int BitsAllocated {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomCodecBaseArguments Class
    DicomCodecBaseArguments Members


DicomObjects.Codecs Namespace / DicomCodecBaseArguments Class / BitsStored Property

    BitsStored Property
    Number of bits per sample used (always between 8 and 16)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property BitsStored As Integer
    'Usage

    Dim instance As DicomCodecBaseArguments
Dim value As Integer

value = instance.BitsStored
    public int BitsStored {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomCodecBaseArguments Class
    DicomCodecBaseArguments Members


DicomObjects.Codecs Namespace / DicomCodecBaseArguments Class / DataSet Property

    DataSet Property (DicomCodecBaseArguments)
    In This Topic
    The full associated dataset
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property DataSet As DicomDataSet
    'Usage

    Dim instance As DicomCodecBaseArguments
Dim value As DicomDataSet

value = instance.DataSet
    public DicomDataSet DataSet {get;}
    Remarks
    This should NOT be changed during (de)compression, only during a prepare function
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomCodecBaseArguments Class
    DicomCodecBaseArguments Members


DicomObjects.Codecs Namespace / DicomCodecBaseArguments Class / ImplementationUID Property

    ImplementationUID Property (DicomCodecBaseArguments)
    In This Topic
    The implementation UID of the original image
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property ImplementationUID As String
    'Usage

    Dim instance As DicomCodecBaseArguments
Dim value As String

value = instance.ImplementationUID
    public string ImplementationUID {get;}
    Remarks
    This is very occasionally useful, where there are known bugs in implementations, and which need different handling according to the implementation UID. This is derived either from the association negotiation, or the 0002 meta header
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomCodecBaseArguments Class
    DicomCodecBaseArguments Members


DicomObjects.Codecs Namespace / DicomCodecBaseArguments Class / isSigned Property

    isSigned Property
    Sign of the data
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property isSigned As Boolean
    'Usage

    Dim instance As DicomCodecBaseArguments
Dim value As Boolean

value = instance.isSigned
    public bool isSigned {get;}
    Remarks

    0 = unsigned

    1 = signed

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomCodecBaseArguments Class
    DicomCodecBaseArguments Members


DicomObjects.Codecs Namespace / DicomCodecBaseArguments Class / PhotometricInterpretation Property

    PhotometricInterpretation Property
    The photometric interpretation of the data
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property PhotometricInterpretation As String
    'Usage

    Dim instance As DicomCodecBaseArguments
Dim value As String

value = instance.PhotometricInterpretation
    public string PhotometricInterpretation {get;}
    Remarks
    This should not change during the (de)compression phase. if this needs to be modified (e.g. changing to or from YBR_FULL_422 for JPEG images), then such changes should occur during the PrepareCompressFunction (for compression) or signaled via the GetDecompressedPhotometricInterpretationFunction (for decompression).
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomCodecBaseArguments Class
    DicomCodecBaseArguments Members


DicomObjects.Codecs Namespace / DicomCodecBaseArguments Class / Planarconfig Property

    Planarconfig Property
    How the colour pixel data is arranged
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property Planarconfig As Integer
    'Usage

    Dim instance As DicomCodecBaseArguments
Dim value As Integer

value = instance.Planarconfig
    public int Planarconfig {get;}
    Remarks

    Only relevant for colour images

    If 0 then pixel ordering is RGBRGBRGB....

    If 1, then there is a whole frame of Red, followed by a whole frame of Green etc.

    (could equally be Y, then B, then R in place of R, G & B)

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomCodecBaseArguments Class
    DicomCodecBaseArguments Members


DicomObjects.Codecs Namespace / DicomCodecBaseArguments Class / Planes Property

    Planes Property
    The number of images planes.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property Planes As Integer
    'Usage

    Dim instance As DicomCodecBaseArguments
Dim value As Integer

value = instance.Planes
    public int Planes {get;}
    Remarks
    Always 1 for monochrome images or 3 for colour
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomCodecBaseArguments Class
    DicomCodecBaseArguments Members


DicomObjects.Codecs Namespace / DicomCodecBaseArguments Class / Size Property

    Size Property (DicomCodecBaseArguments)
    In This Topic
    The size of the image (pixels x pixels)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property Size As SkiaSharp.SKSizeI
    'Usage

    Dim instance As DicomCodecBaseArguments
Dim value As SkiaSharp.SKSizeI

value = instance.Size
    public SkiaSharp.SKSizeI Size {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomCodecBaseArguments Class
    DicomCodecBaseArguments Members


%%PageItemTitle%%

DicomObjects.Codecs Namespace / ImportArguments Class
Members

In This Topic
    ImportArguments Class
    In This Topic
    Class used to hold arguments passed to an import codec
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Class ImportArguments
   Inherits DicomCodecBaseArguments
    'Usage

    Dim instance As ImportArguments
    public class ImportArguments : DicomCodecBaseArguments
    Inheritance Hierarchy

    System.Object
    DicomObjects.Codecs.DicomCodecBaseArguments
    DicomObjects.Codecs.ImportArguments

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ImportArguments Members
    DicomObjects.Codecs Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.Codecs Namespace / ImportArguments Class
Properties

In This Topic
    ImportArguments Class Members
    In This Topic

    The following tables list the members exposed by ImportArguments.

    Public Properties
     | Name | Description
Public Property | BitsAllocated | Number of bits per sample allocated (always 8 or 16) (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | BitsStored | Number of bits per sample used (always between 8 and 16) (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | DataSet | The full associated dataset (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | ImplementationUID | The implementation UID of the original image (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | ImportPixelData | Controls whether data should be actually read and put into the PixelData attribute at import time
Public Property | InputTransferSyntax | The transfer syntax of the input data
Public Property | isSigned | Sign of the data (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | LossyType | Value to place into DICOM attribute (0028,2114) when an image is compressed
Public Property | PhotometricInterpretation | The photometric interpretation of the data (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | Planarconfig | How the colour pixel data is arranged (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | Planes | The number of images planes. (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | Size | The size of the image (pixels x pixels) (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | SourceStream | The stream from which compressed pixel data is obtained
    Top
    See Also

    Reference

    ImportArguments Class
    DicomObjects.Codecs Namespace


%%PageItemTitle%% $$Properties$$

DicomObjects.Codecs Namespace / ImportArguments Class

    ImportArguments Class Properties
    In This Topic

    For a list of all members of this type, see ImportArguments members.

    Public Properties
     | Name | Description
Public Property | BitsAllocated | Number of bits per sample allocated (always 8 or 16) (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | BitsStored | Number of bits per sample used (always between 8 and 16) (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | DataSet | The full associated dataset (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | ImplementationUID | The implementation UID of the original image (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | ImportPixelData | Controls whether data should be actually read and put into the PixelData attribute at import time
Public Property | InputTransferSyntax | The transfer syntax of the input data
Public Property | isSigned | Sign of the data (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | LossyType | Value to place into DICOM attribute (0028,2114) when an image is compressed
Public Property | PhotometricInterpretation | The photometric interpretation of the data (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | Planarconfig | How the colour pixel data is arranged (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | Planes | The number of images planes. (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | Size | The size of the image (pixels x pixels) (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | SourceStream | The stream from which compressed pixel data is obtained
    Top
    See Also

    Reference

    ImportArguments Class
    DicomObjects.Codecs Namespace


DicomObjects.Codecs Namespace / ImportArguments Class / ImportPixelData Property

    ImportPixelData Property
    Controls whether data should be actually read and put into the PixelData attribute at import time
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property ImportPixelData As Boolean
    'Usage

    Dim instance As ImportArguments
Dim value As Boolean

instance.ImportPixelData = value

value = instance.ImportPixelData
    public bool ImportPixelData {get; set;}
    Remarks
    If false, then it is assumed that the SourceStream remains available for delayed pixel data reading
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ImportArguments Class
    ImportArguments Members


DicomObjects.Codecs Namespace / ImportArguments Class / InputTransferSyntax Property

    InputTransferSyntax Property (ImportArguments)
    In This Topic
    The transfer syntax of the input data
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property InputTransferSyntax As String
    'Usage

    Dim instance As ImportArguments
Dim value As String

value = instance.InputTransferSyntax
    public string InputTransferSyntax {get;}
    Remarks
    Most codecs will only handle one transfer syntax, but this is provided, as some can handle many - e.g. the JPEG 2000 codec which handles the lossless and lossy modes.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ImportArguments Class
    ImportArguments Members


DicomObjects.Codecs Namespace / ImportArguments Class / LossyType Property

    LossyType Property
    Value to place into DICOM attribute (0028,2114) when an image is compressed
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property LossyType As String
    'Usage

    Dim instance As ImportArguments
Dim value As String

instance.LossyType = value

value = instance.LossyType
    public string LossyType {get; set;}
    Remarks
    Leave blank for lossless compression.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ImportArguments Class
    ImportArguments Members


DicomObjects.Codecs Namespace / ImportArguments Class / SourceStream Property

    SourceStream Property (ImportArguments)
    In This Topic
    The stream from which compressed pixel data is obtained
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property SourceStream As Stream
    'Usage

    Dim instance As ImportArguments
Dim value As Stream

value = instance.SourceStream
    public Stream SourceStream {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ImportArguments Class
    ImportArguments Members


%%PageItemTitle%%

DicomObjects.Codecs Namespace / Jpeg2000CompressionOptions Class
Members

In This Topic
    Jpeg2000CompressionOptions Class
    In This Topic
    Class which allows control of the details of JPEG 2000 compression
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Class Jpeg2000CompressionOptions
    'Usage

    Dim instance As Jpeg2000CompressionOptions
    public class Jpeg2000CompressionOptions
    Inheritance Hierarchy

    System.Object
    DicomObjects.Codecs.Jpeg2000CompressionOptions

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    Jpeg2000CompressionOptions Members
    DicomObjects.Codecs Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.Codecs Namespace / Jpeg2000CompressionOptions Class
Properties Methods

In This Topic
    Jpeg2000CompressionOptions Class Members
    In This Topic

    The following tables list the members exposed by Jpeg2000CompressionOptions.

    Public Constructors
     | Name | Description
Public Constructor | Jpeg2000CompressionOptions Constructor | Create a blank Jpeg2000CompressionOptions object
    Top
    Public Properties
     | Name | Description
Public Property | ActualLevels | The number of decomposition levels actually used. If Levels is -1, then a default value (currently 5 but subject to change) is used.
Public Property | ForJpip | Specify useful values for subsequent JPIP usage
Public Property | Layers | The number of quality layers to use.
Public Property | Levels | The number of decomposition levels to use
Public Property | Lossy | Whether lossy compression is to be used.
Public Property | PrecinctSize | JPEG 2000 precinct size
Public Property | Progression | The order in which to output the packets
Public Property | Rate | The inverse of the compresion rate
    Top
    Public Methods
     | Name | Description
Public Method | Clone |
static (Shared in Visual Basic) | OptionsFromImage | Discover information about a JPEG 2000 encoded image
    Top
    See Also

    Reference

    Jpeg2000CompressionOptions Class
    DicomObjects.Codecs Namespace


%%PageItemTitle%%

DicomObjects.Codecs Namespace / Jpeg2000CompressionOptions Class / Jpeg2000CompressionOptions Constructor

In This Topic
    Jpeg2000CompressionOptions Constructor
    In This Topic
    Create a blank Jpeg2000CompressionOptions object
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Function New()
    'Usage

    Dim instance As New Jpeg2000CompressionOptions()
    public Jpeg2000CompressionOptions()
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    Jpeg2000CompressionOptions Class
    Jpeg2000CompressionOptions Members


%%PageItemTitle%% $$Methods$$

DicomObjects.Codecs Namespace / Jpeg2000CompressionOptions Class

In This Topic
    Jpeg2000CompressionOptions Class Methods
    In This Topic

    For a list of all members of this type, see Jpeg2000CompressionOptions members.

    Public Methods
     | Name | Description
Public Method | Clone |
static (Shared in Visual Basic) | OptionsFromImage | Discover information about a JPEG 2000 encoded image
    Top
    See Also

    Reference

    Jpeg2000CompressionOptions Class
    DicomObjects.Codecs Namespace


DicomObjects.Codecs Namespace / Jpeg2000CompressionOptions Class / Clone Method

    Clone Method (Jpeg2000CompressionOptions)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Function Clone() As Object
    'Usage

    Dim instance As Jpeg2000CompressionOptions
Dim value As Object

value = instance.Clone()
    public object Clone()
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    Jpeg2000CompressionOptions Class
    Jpeg2000CompressionOptions Members


DicomObjects.Codecs Namespace / Jpeg2000CompressionOptions Class / OptionsFromImage Method
The image/dataset to analyse
The frame number to analyse

In This Topic
    OptionsFromImage Method
    In This Topic
    Discover information about a JPEG 2000 encoded image
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Function OptionsFromImage( _
   ByVal DataSet As DicomDataSet, _
   ByVal Frame As Integer _
) As Jpeg2000CompressionOptions
    'Usage

    Dim DataSet As DicomDataSet
Dim Frame As Integer
Dim value As Jpeg2000CompressionOptions

value = Jpeg2000CompressionOptions.OptionsFromImage(DataSet, Frame)
    public static Jpeg2000CompressionOptions OptionsFromImage(
   DicomDataSet DataSet,
   int Frame
)

    Parameters

    DataSet
    The image/dataset to analyse
    Frame
    The frame number to analyse

    Return Value

    An object representing the compressionoptions used, or null if no JPEG 2000 data exists
    Remarks

    This is a little simplistic, as the JPEG 2000 standard allows huge flexibility, including even the ability to have different options for different tiles of an image, but only data from the "top level" is included here. Similarly, whilst JPEG 2000 allows different precinct sizes for different resolution levels, only the highest level is returned from this method (and -1 is returned if MaxPrecinct size is specified)

    At present, the data filled in by this method includes only:

    • Progression
    • Layers
    • Levels
    • PrecinctSize

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    Jpeg2000CompressionOptions Class
    Jpeg2000CompressionOptions Members


%%PageItemTitle%% $$Properties$$

DicomObjects.Codecs Namespace / Jpeg2000CompressionOptions Class

In This Topic
    Jpeg2000CompressionOptions Class Properties
    In This Topic

    For a list of all members of this type, see Jpeg2000CompressionOptions members.

    Public Properties
     | Name | Description
Public Property | ActualLevels | The number of decomposition levels actually used. If Levels is -1, then a default value (currently 5 but subject to change) is used.
Public Property | ForJpip | Specify useful values for subsequent JPIP usage
Public Property | Layers | The number of quality layers to use.
Public Property | Levels | The number of decomposition levels to use
Public Property | Lossy | Whether lossy compression is to be used.
Public Property | PrecinctSize | JPEG 2000 precinct size
Public Property | Progression | The order in which to output the packets
Public Property | Rate | The inverse of the compresion rate
    Top
    See Also

    Reference

    Jpeg2000CompressionOptions Class
    DicomObjects.Codecs Namespace


DicomObjects.Codecs Namespace / Jpeg2000CompressionOptions Class / ActualLevels Property

    ActualLevels Property
    The number of decomposition levels actually used. If Levels is -1, then a default value (currently 5 but subject to change) is used.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property ActualLevels As Integer
    'Usage

    Dim instance As Jpeg2000CompressionOptions
Dim value As Integer

value = instance.ActualLevels
    public int ActualLevels {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    Jpeg2000CompressionOptions Class
    Jpeg2000CompressionOptions Members


DicomObjects.Codecs Namespace / Jpeg2000CompressionOptions Class / ForJpip Property

    ForJpip Property
    Specify useful values for subsequent JPIP usage
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property ForJpip As Boolean
    'Usage

    Dim instance As Jpeg2000CompressionOptions
Dim value As Boolean

instance.ForJpip = value

value = instance.ForJpip
    public bool ForJpip {get; set;}
    Remarks
    JPEG images to be used for JPIP have certain unusual requirements such as being lossless, but with multiple quality layers. Setting this to true when generating a JPEG 2000 image helps to improve the quality of subsequent JPIP transfers based on the resulting image.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    Jpeg2000CompressionOptions Class
    Jpeg2000CompressionOptions Members


DicomObjects.Codecs Namespace / Jpeg2000CompressionOptions Class / Layers Property

    Layers Property
    The number of quality layers to use.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property Layers As Integer
    'Usage

    Dim instance As Jpeg2000CompressionOptions
Dim value As Integer

instance.Layers = value

value = instance.Layers
    public int Layers {get; set;}
    Remarks

    Default value is 1, which is appropriate for whole image use, but for JPIP a larger number would be more appropriate.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    Jpeg2000CompressionOptions Class
    Jpeg2000CompressionOptions Members


DicomObjects.Codecs Namespace / Jpeg2000CompressionOptions Class / Levels Property

    Levels Property
    The number of decomposition levels to use
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property Levels As Integer
    'Usage

    Dim instance As Jpeg2000CompressionOptions
Dim value As Integer

instance.Levels = value

value = instance.Levels
    public int Levels {get; set;}
    Remarks
    By default this is -1, which allows DicomObjects to choose a suitable default value, which might depend on the size or other characteristics of the image. The actuall value used is available via the ActualLevels property.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    Jpeg2000CompressionOptions Class
    Jpeg2000CompressionOptions Members


DicomObjects.Codecs Namespace / Jpeg2000CompressionOptions Class / Lossy Property

    Lossy Property
    Whether lossy compression is to be used.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property Lossy As Boolean
    'Usage

    Dim instance As Jpeg2000CompressionOptions
Dim value As Boolean

instance.Lossy = value

value = instance.Lossy
    public bool Lossy {get; set;}
    Remarks
    This is overridden and set to false when a lossless JPEG 2000 transfer syntax is used.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    Jpeg2000CompressionOptions Class
    Jpeg2000CompressionOptions Members


DicomObjects.Codecs Namespace / Jpeg2000CompressionOptions Class / PrecinctSize Property

    PrecinctSize Property
    JPEG 2000 precinct size
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property PrecinctSize As Integer
    'Usage

    Dim instance As Jpeg2000CompressionOptions
Dim value As Integer

instance.PrecinctSize = value

value = instance.PrecinctSize
    public int PrecinctSize {get; set;}
    Remarks

    Default value is 0, which means to use the "MaxPrecincts" option meaning just a single precinct per band. This is appropriate for whole image use, but for JPIP a smaller precinct size is more appropriate.

    The value must be a power of 2

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    Jpeg2000CompressionOptions Class
    Jpeg2000CompressionOptions Members


DicomObjects.Codecs Namespace / Jpeg2000CompressionOptions Class / Progression Property

    Progression Property
    The order in which to output the packets
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property Progression As Progression
    'Usage

    Dim instance As Jpeg2000CompressionOptions
Dim value As Progression

instance.Progression = value

value = instance.Progression
    public Progression Progression {get; set;}
    Remarks

    Default is LRCP (Layer Resolution Component Position)

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    Jpeg2000CompressionOptions Class
    Jpeg2000CompressionOptions Members


DicomObjects.Codecs Namespace / Jpeg2000CompressionOptions Class / Rate Property

    Rate Property
    The inverse of the compresion rate
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property Rate As Double
    'Usage

    Dim instance As Jpeg2000CompressionOptions
Dim value As Double

instance.Rate = value

value = instance.Rate
    public double Rate {get; set;}
    Remarks
    This value holds the ratio of the final compressed length to the original uncompressed length expressed as a fraction. e.g. Rate = 0.1 gives a compresison ratio of 10:1. It is only valid when Lossy=true;
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    Jpeg2000CompressionOptions Class
    Jpeg2000CompressionOptions Members


%%PageItemTitle%%

DicomObjects.Codecs Namespace / JpegLossless Class
Members

In This Topic
    JpegLossless Class
    In This Topic
    The class which implements the internal JPEG Lossless codec
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Class JpegLossless
   Inherits SimpleCodec
   Implements ICodecBase, ICompressor, IDecompressor
    'Usage

    Dim instance As JpegLossless
    public class JpegLossless : SimpleCodec, ICodecBase, ICompressor, IDecompressor
    Remarks
    This members of this class contains only static data. Some may in the future be used to fine-tune the behaviour of the codec.
    Inheritance Hierarchy

    System.Object
    DicomObjects.Codecs.SimpleCodec
    DicomObjects.Codecs.JpegLossless

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    JpegLossless Members
    DicomObjects.Codecs Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.Codecs Namespace / JpegLossless Class
Fields Properties Methods

In This Topic
    JpegLossless Class Members
    In This Topic

    The following tables list the members exposed by JpegLossless.

    Public Fields
     | Name | Description
static (Shared in Visual Basic) | CheckForBadCompression | Controls whether or not to check for images badly compressed using very old versions of the COM version.
    Top
    Public Properties
     | Name | Description
Public Property | MaximumBits | The maximum number of bits supported by this codec. (Inherited from DicomObjects.Codecs.SimpleCodec)
Public Property | NeedsPlanarConfigTransform | Lets a caller to SimpleCodec.Decompress tell whether data needs to be transformed following decompression. It is only relevant if the image has a Planar Configuration value (0028,0006) of 1. For the simple codec, the value comes from the constructor (Inherited from DicomObjects.Codecs.SimpleCodec)
    Top
    Public Methods
     | Name | Description
Public Method | BestRequest | The most appropriate DicomObjects.Internal.PixelRequest, given the requested zoom and image/codec type (Inherited from DicomObjects.Codecs.SimpleCodec)
Public Method | CalculatedFrameCount | Limiting number of frames. Only used by MPEG etc. - default values used by other classes is int.MaxValue (Inherited from DicomObjects.Codecs.SimpleCodec)
Public Method | Compress | Overridden. Abstract Placeholder for the compression routine
Public Method | Decompress | Overridden. Abstract Placeholder for the decompression routine
Public Method | DecompressedPhotometricInterpretation | The effective Photometric Interpretation of the decompressed data (Inherited from DicomObjects.Codecs.SimpleCodec)
Public Method | DecompressState | The status of the decompression (Inherited from DicomObjects.Codecs.SimpleCodec)
Public Method | DownloadStatus | The status of the download (Inherited from DicomObjects.Codecs.SimpleCodec)
Public Method | LockObject | Standard LockObject implementation for thread-safety (Inherited from DicomObjects.Codecs.SimpleCodec)
Public Method | PrepareFunction | Prepares the data for Compression (Inherited from DicomObjects.Codecs.SimpleCodec)
Public Method | Quality | (Inherited from DicomObjects.Codecs.SimpleCodec)
    Top
    See Also

    Reference

    JpegLossless Class
    DicomObjects.Codecs Namespace


%%PageItemTitle%% $$Methods$$

DicomObjects.Codecs Namespace / JpegLossless Class

    JpegLossless Class Methods
    In This Topic

    For a list of all members of this type, see JpegLossless members.

    Public Methods
     | Name | Description
Public Method | BestRequest | The most appropriate DicomObjects.Internal.PixelRequest, given the requested zoom and image/codec type (Inherited from DicomObjects.Codecs.SimpleCodec)
Public Method | CalculatedFrameCount | Limiting number of frames. Only used by MPEG etc. - default values used by other classes is int.MaxValue (Inherited from DicomObjects.Codecs.SimpleCodec)
Public Method | Compress | Overridden. Abstract Placeholder for the compression routine
Public Method | Decompress | Overridden. Abstract Placeholder for the decompression routine
Public Method | DecompressedPhotometricInterpretation | The effective Photometric Interpretation of the decompressed data (Inherited from DicomObjects.Codecs.SimpleCodec)
Public Method | DecompressState | The status of the decompression (Inherited from DicomObjects.Codecs.SimpleCodec)
Public Method | DownloadStatus | The status of the download (Inherited from DicomObjects.Codecs.SimpleCodec)
Public Method | LockObject | Standard LockObject implementation for thread-safety (Inherited from DicomObjects.Codecs.SimpleCodec)
Public Method | PrepareFunction | Prepares the data for Compression (Inherited from DicomObjects.Codecs.SimpleCodec)
Public Method | Quality | (Inherited from DicomObjects.Codecs.SimpleCodec)
    Top
    See Also

    Reference

    JpegLossless Class
    DicomObjects.Codecs Namespace


DicomObjects.Codecs Namespace / JpegLossless Class / Compress Method
Standard Decompression arguments

    Compress Method (JpegLossless)
    In This Topic
    Abstract Placeholder for the compression routine
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overrides Sub Compress( _
   ByVal args As CompressionArguments _
)
    'Usage

    Dim instance As JpegLossless
Dim args As CompressionArguments

instance.Compress(args)
    public override void Compress(
   CompressionArguments args
)

    Parameters

    args
    Standard Decompression arguments

    Return Value

    The compressed data
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    JpegLossless Class
    JpegLossless Members


DicomObjects.Codecs Namespace / JpegLossless Class / Decompress Method
Standard Decompression arguments

    Decompress Method (JpegLossless)
    In This Topic
    Abstract Placeholder for the decompression routine
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overrides Sub Decompress( _
   ByVal args As DecompressionArguments _
)
    'Usage

    Dim instance As JpegLossless
Dim args As DecompressionArguments

instance.Decompress(args)
    public override void Decompress(
   DecompressionArguments args
)

    Parameters

    args
    Standard Decompression arguments

    Return Value

    True if successful
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    JpegLossless Class
    JpegLossless Members


%%PageItemTitle%% $$Fields$$

DicomObjects.Codecs Namespace / JpegLossless Class

    JpegLossless Class Fields
    In This Topic

    For a list of all members of this type, see JpegLossless members.

    Public Fields
     | Name | Description
static (Shared in Visual Basic) | CheckForBadCompression | Controls whether or not to check for images badly compressed using very old versions of the COM version.
    Top
    See Also

    Reference

    JpegLossless Class
    DicomObjects.Codecs Namespace


DicomObjects.Codecs Namespace / JpegLossless Class / CheckForBadCompression Field

    CheckForBadCompression Field
    Controls whether or not to check for images badly compressed using very old versions of the COM version.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared CheckForBadCompression As Boolean
    'Usage

    Dim value As Boolean

value = JpegLossless.CheckForBadCompression

JpegLossless.CheckForBadCompression = value
    public static bool CheckForBadCompression
    Remarks

    See: web site for more information.

    Setting this to true does impact decompression performance, as each possibly affected image (a sub-set of JPEG lossless types) is decompressed twice, to try to determine which version is more likely to be "correct"

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    JpegLossless Class
    JpegLossless Members


%%PageItemTitle%%

DicomObjects.Codecs Namespace / JpegLSCompressionOptions Class
Members

In This Topic
    JpegLSCompressionOptions Class
    In This Topic
    Class which allows control of the details of JpegLS compression
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Class JpegLSCompressionOptions
    'Usage

    Dim instance As JpegLSCompressionOptions
    public class JpegLSCompressionOptions
    Inheritance Hierarchy

    System.Object
    DicomObjects.Codecs.JpegLSCompressionOptions

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    JpegLSCompressionOptions Members
    DicomObjects.Codecs Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.Codecs Namespace / JpegLSCompressionOptions Class
Properties Methods

In This Topic
    JpegLSCompressionOptions Class Members
    In This Topic

    The following tables list the members exposed by JpegLSCompressionOptions.

    Public Constructors
     | Name | Description
Public Constructor | JpegLSCompressionOptions Constructor |
    Top
    Public Properties
     | Name | Description
Public Property | Near | This value is the maximum permissible difference between the original and encoded pixel values
Public Property | T1 | T1 threshold value for JpegLS compression
Public Property | T2 | T2 threshold value for JpegLS compression
Public Property | T3 | T3 threshold value for JpegLS compression
    Top
    Public Methods
     | Name | Description
Public Method | Clone |
    Top
    See Also

    Reference

    JpegLSCompressionOptions Class
    DicomObjects.Codecs Namespace


%%PageItemTitle%%

DicomObjects.Codecs Namespace / JpegLSCompressionOptions Class / JpegLSCompressionOptions Constructor

In This Topic
    JpegLSCompressionOptions Constructor
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Function New()
    'Usage

    Dim instance As New JpegLSCompressionOptions()
    public JpegLSCompressionOptions()
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    JpegLSCompressionOptions Class
    JpegLSCompressionOptions Members


%%PageItemTitle%% $$Methods$$

DicomObjects.Codecs Namespace / JpegLSCompressionOptions Class

In This Topic
    JpegLSCompressionOptions Class Methods
    In This Topic

    For a list of all members of this type, see JpegLSCompressionOptions members.

    Public Methods
     | Name | Description
Public Method | Clone |
    Top
    See Also

    Reference

    JpegLSCompressionOptions Class
    DicomObjects.Codecs Namespace


DicomObjects.Codecs Namespace / JpegLSCompressionOptions Class / Clone Method

    Clone Method (JpegLSCompressionOptions)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Function Clone() As Object
    'Usage

    Dim instance As JpegLSCompressionOptions
Dim value As Object

value = instance.Clone()
    public object Clone()
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    JpegLSCompressionOptions Class
    JpegLSCompressionOptions Members


%%PageItemTitle%% $$Properties$$

DicomObjects.Codecs Namespace / JpegLSCompressionOptions Class

In This Topic
    JpegLSCompressionOptions Class Properties
    In This Topic

    For a list of all members of this type, see JpegLSCompressionOptions members.

    Public Properties
     | Name | Description
Public Property | Near | This value is the maximum permissible difference between the original and encoded pixel values
Public Property | T1 | T1 threshold value for JpegLS compression
Public Property | T2 | T2 threshold value for JpegLS compression
Public Property | T3 | T3 threshold value for JpegLS compression
    Top
    See Also

    Reference

    JpegLSCompressionOptions Class
    DicomObjects.Codecs Namespace


DicomObjects.Codecs Namespace / JpegLSCompressionOptions Class / Near Property

    Near Property
    This value is the maximum permissible difference between the original and encoded pixel values
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property Near As Byte
    'Usage

    Dim instance As JpegLSCompressionOptions
Dim value As Byte

instance.Near = value

value = instance.Near
    public byte Near {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    JpegLSCompressionOptions Class
    JpegLSCompressionOptions Members


DicomObjects.Codecs Namespace / JpegLSCompressionOptions Class / T1 Property

    T1 Property
    T1 threshold value for JpegLS compression
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property T1 As Integer
    'Usage

    Dim instance As JpegLSCompressionOptions
Dim value As Integer

instance.T1 = value

value = instance.T1
    public int T1 {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    JpegLSCompressionOptions Class
    JpegLSCompressionOptions Members


DicomObjects.Codecs Namespace / JpegLSCompressionOptions Class / T2 Property

    T2 Property
    T2 threshold value for JpegLS compression
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property T2 As Integer
    'Usage

    Dim instance As JpegLSCompressionOptions
Dim value As Integer

instance.T2 = value

value = instance.T2
    public int T2 {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    JpegLSCompressionOptions Class
    JpegLSCompressionOptions Members


DicomObjects.Codecs Namespace / JpegLSCompressionOptions Class / T3 Property

    T3 Property
    T3 threshold value for JpegLS compression
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property T3 As Integer
    'Usage

    Dim instance As JpegLSCompressionOptions
Dim value As Integer

instance.T3 = value

value = instance.T3
    public int T3 {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    JpegLSCompressionOptions Class
    JpegLSCompressionOptions Members


%%PageItemTitle%%

DicomObjects.Codecs Namespace / Jpip Class
Members

In This Topic
    Jpip Class
    In This Topic
    Static class to hold global options for JPIP usage
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public MustInherit NotInheritable Class Jpip
    'Usage

    Dim instance As Jpip
    public static class Jpip
    Inheritance Hierarchy

    System.Object
    DicomObjects.Codecs.Jpip

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    Jpip Members
    DicomObjects.Codecs Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.Codecs Namespace / Jpip Class
Properties Events

In This Topic
    Jpip Class Members
    In This Topic

    The following tables list the members exposed by Jpip.

    Public Properties
     | Name | Description
static (Shared in Visual Basic) | ClientCertificate | The client certificate to use when performing JPIP retrieval requests over https
static (Shared in Visual Basic) | JpipThreads | The number of concurrent threads to use to handle JPIP pixel data requests
static (Shared in Visual Basic) | JpipUriBase | Base Uri used to construct a Jpip Uri
static (Shared in Visual Basic) | LogLevel | The LogLevel to use to record JPIP activity
    Top
    Public Events
     | Name | Description
Public Event | GetUri | Event used to give finer control over the generation of Uris for JPIP transfer syntaxes
Public Event | StatusUpdate | Event fires when a JPIP image's status changes
    Top
    See Also

    Reference

    Jpip Class
    DicomObjects.Codecs Namespace


%%PageItemTitle%% $$Properties$$

DicomObjects.Codecs Namespace / Jpip Class

    Jpip Class Properties
    In This Topic

    For a list of all members of this type, see Jpip members.

    Public Properties
     | Name | Description
static (Shared in Visual Basic) | ClientCertificate | The client certificate to use when performing JPIP retrieval requests over https
static (Shared in Visual Basic) | JpipThreads | The number of concurrent threads to use to handle JPIP pixel data requests
static (Shared in Visual Basic) | JpipUriBase | Base Uri used to construct a Jpip Uri
static (Shared in Visual Basic) | LogLevel | The LogLevel to use to record JPIP activity
    Top
    See Also

    Reference

    Jpip Class
    DicomObjects.Codecs Namespace


DicomObjects.Codecs Namespace / Jpip Class / ClientCertificate Property

    ClientCertificate Property
    The client certificate to use when performing JPIP retrieval requests over https
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Property ClientCertificate As X509Certificate2
    'Usage

    Dim value As X509Certificate2

Jpip.ClientCertificate = value

value = Jpip.ClientCertificate
    public static X509Certificate2 ClientCertificate {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    Jpip Class
    Jpip Members


DicomObjects.Codecs Namespace / Jpip Class / JpipThreads Property

    JpipThreads Property
    The number of concurrent threads to use to handle JPIP pixel data requests
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Property JpipThreads As Integer
    'Usage

    Dim value As Integer

Jpip.JpipThreads = value

value = Jpip.JpipThreads
    public static int JpipThreads {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    Jpip Class
    Jpip Members


DicomObjects.Codecs Namespace / Jpip Class / JpipUriBase Property

    JpipUriBase Property
    Base Uri used to construct a Jpip Uri
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Property JpipUriBase As String
    'Usage

    Dim value As String

Jpip.JpipUriBase = value

value = Jpip.JpipUriBase
    public static string JpipUriBase {get; set;}
    Remarks

    This property is only used if the GetUri event is not set

    If used, then the Uri is set to the value of the property followed by the InstancerUID of the image

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    Jpip Class
    Jpip Members


DicomObjects.Codecs Namespace / Jpip Class / LogLevel Property

    LogLevel Property (Jpip)
    In This Topic
    The LogLevel to use to record JPIP activity
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Property LogLevel As LogLevel
    'Usage

    Dim value As LogLevel

Jpip.LogLevel = value

value = Jpip.LogLevel
    public static LogLevel LogLevel {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    Jpip Class
    Jpip Members


%%PageItemTitle%% $$Events$$

DicomObjects.Codecs Namespace / Jpip Class

    Jpip Class Events
    In This Topic

    For a list of all members of this type, see Jpip members.

    Public Events
     | Name | Description
Public Event | GetUri | Event used to give finer control over the generation of Uris for JPIP transfer syntaxes
Public Event | StatusUpdate | Event fires when a JPIP image's status changes
    Top
    See Also

    Reference

    Jpip Class
    DicomObjects.Codecs Namespace


DicomObjects.Codecs Namespace / Jpip Class / GetUri Event

    GetUri Event
    Event used to give finer control over the generation of Uris for JPIP transfer syntaxes
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Event GetUri As GetUrlHandler
    'Usage

    Dim instance As Jpip
Dim handler As GetUrlHandler

AddHandler instance.GetUri, handler
    public event GetUrlHandler GetUri
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    Jpip Class
    Jpip Members


DicomObjects.Codecs Namespace / Jpip Class / StatusUpdate Event

    StatusUpdate Event
    Event fires when a JPIP image's status changes
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Event StatusUpdate As StatusUpdateHandler
    'Usage

    Dim instance As Jpip
Dim handler As StatusUpdateHandler

AddHandler instance.StatusUpdate, handler
    public event StatusUpdateHandler StatusUpdate
    Remarks
    This can indicate that data has been downloaded and/or decompressed
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    Jpip Class
    Jpip Members


%%PageItemTitle%%

DicomObjects.Codecs Namespace / ModificationArguments Class
Members

In This Topic
    ModificationArguments Class
    In This Topic
    Defines changes which need to be applied to a compressed image
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Class ModificationArguments
   Inherits DicomCodecBaseArguments
    'Usage

    Dim instance As ModificationArguments
    public class ModificationArguments : DicomCodecBaseArguments
    Remarks
    This class is only passed to the prepare function, and enables the codec to notify DicomObjects of changes that the code will be making during compression.
    Inheritance Hierarchy

    System.Object
    DicomObjects.Codecs.DicomCodecBaseArguments
    DicomObjects.Codecs.ModificationArguments

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ModificationArguments Members
    DicomObjects.Codecs Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.Codecs Namespace / ModificationArguments Class
Properties

In This Topic
    ModificationArguments Class Members
    In This Topic

    The following tables list the members exposed by ModificationArguments.

    Public Properties
     | Name | Description
Public Property | BitsAllocated | Number of bits per sample allocated (always 8 or 16) (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | BitsStored | Number of bits per sample used (always between 8 and 16) (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | DataSet | The full associated dataset (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | ImplementationUID | The implementation UID of the original image (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | isSigned | Sign of the data (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | LossyDescription | The description of the image to put into the newly compressed object
Public Property | LossyMethod | The definition of the image to put into the newly compressed object
Public Property | Offset | The rescale offset to be applied to the new object
Public Property | OutputTransferSyntax | The transfer syntax into which the image should be compressed
Public Property | PhotometricInterpretation | The photometric interpretation of the data (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | Planarconfig | How the colour pixel data is arranged (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | Planes | The number of images planes. (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | Quality | A data to describe compression quality
Public Property | RequestedColourSpace | The colour space into which the codec will be converting the image
Public Property | Scale | The scale factor to be applied to the new image
Public Property | Size | The size of the image (pixels x pixels) (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
    Top
    See Also

    Reference

    ModificationArguments Class
    DicomObjects.Codecs Namespace


%%PageItemTitle%% $$Properties$$

DicomObjects.Codecs Namespace / ModificationArguments Class

    ModificationArguments Class Properties
    In This Topic

    For a list of all members of this type, see ModificationArguments members.

    Public Properties
     | Name | Description
Public Property | BitsAllocated | Number of bits per sample allocated (always 8 or 16) (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | BitsStored | Number of bits per sample used (always between 8 and 16) (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | DataSet | The full associated dataset (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | ImplementationUID | The implementation UID of the original image (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | isSigned | Sign of the data (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | LossyDescription | The description of the image to put into the newly compressed object
Public Property | LossyMethod | The definition of the image to put into the newly compressed object
Public Property | Offset | The rescale offset to be applied to the new object
Public Property | OutputTransferSyntax | The transfer syntax into which the image should be compressed
Public Property | PhotometricInterpretation | The photometric interpretation of the data (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | Planarconfig | How the colour pixel data is arranged (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | Planes | The number of images planes. (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
Public Property | Quality | A data to describe compression quality
Public Property | RequestedColourSpace | The colour space into which the codec will be converting the image
Public Property | Scale | The scale factor to be applied to the new image
Public Property | Size | The size of the image (pixels x pixels) (Inherited from DicomObjects.Codecs.DicomCodecBaseArguments)
    Top
    See Also

    Reference

    ModificationArguments Class
    DicomObjects.Codecs Namespace


DicomObjects.Codecs Namespace / ModificationArguments Class / LossyDescription Property

    LossyDescription Property
    The description of the image to put into the newly compressed object
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property LossyDescription As String
    'Usage

    Dim instance As ModificationArguments
Dim value As String

instance.LossyDescription = value

value = instance.LossyDescription
    public string LossyDescription {get; set;}
    Remarks
    This information will be placed into attribute (0008,2111)
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ModificationArguments Class
    ModificationArguments Members


DicomObjects.Codecs Namespace / ModificationArguments Class / LossyMethod Property

    LossyMethod Property
    The definition of the image to put into the newly compressed object
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property LossyMethod As String
    'Usage

    Dim instance As ModificationArguments
Dim value As String

instance.LossyMethod = value

value = instance.LossyMethod
    public string LossyMethod {get; set;}
    Remarks
    This information will be placed into attribute (0008,2114). Allowed values are:
    • ISO_10918_1 = JPEG Lossy Compression
    • ISO_14495_1 = JPEG-LS Near-lossless Compression
    • ISO_15444_1 = JPEG 2000 Irreversible Compression
    • ISO_13818_2 = MPEG2 Compression
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ModificationArguments Class
    ModificationArguments Members


DicomObjects.Codecs Namespace / ModificationArguments Class / Offset Property

    Offset Property (ModificationArguments)
    In This Topic
    The rescale offset to be applied to the new object
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property Offset As Single
    'Usage

    Dim instance As ModificationArguments
Dim value As Single

instance.Offset = value

value = instance.Offset
    public float Offset {get; set;}
    Remarks
    This is important for codecs compressing CT, so that the Hounsfield values remain valid
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ModificationArguments Class
    ModificationArguments Members


DicomObjects.Codecs Namespace / ModificationArguments Class / OutputTransferSyntax Property

    OutputTransferSyntax Property (ModificationArguments)
    In This Topic
    The transfer syntax into which the image should be compressed
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property OutputTransferSyntax As String
    'Usage

    Dim instance As ModificationArguments
Dim value As String

value = instance.OutputTransferSyntax
    public string OutputTransferSyntax {get;}
    Remarks
    Most codecs will only handle one transfer syntax, but this is provided, as some can handle many - e.g. the JPEG 2000 codec which handles the lossless and lossy modes.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ModificationArguments Class
    ModificationArguments Members


DicomObjects.Codecs Namespace / ModificationArguments Class / Quality Property

    Quality Property (ModificationArguments)
    In This Topic
    A data to describe compression quality
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property Quality As Object
    'Usage

    Dim instance As ModificationArguments
Dim value As Object

value = instance.Quality
    public object Quality {get;}
    Remarks
    The meaning of this property is codec dependent.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ModificationArguments Class
    ModificationArguments Members


DicomObjects.Codecs Namespace / ModificationArguments Class / RequestedColourSpace Property

    RequestedColourSpace Property
    The colour space into which the codec will be converting the image
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property RequestedColourSpace As String
    'Usage

    Dim instance As ModificationArguments
Dim value As String

instance.RequestedColourSpace = value

value = instance.RequestedColourSpace
    public string RequestedColourSpace {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ModificationArguments Class
    ModificationArguments Members


DicomObjects.Codecs Namespace / ModificationArguments Class / Scale Property

    Scale Property (ModificationArguments)
    In This Topic
    The scale factor to be applied to the new image
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property Scale As Single
    'Usage

    Dim instance As ModificationArguments
Dim value As Single

instance.Scale = value

value = instance.Scale
    public float Scale {get; set;}
    Remarks
    This is important for codecs compressing CT, so that the Hounsfield values remain valid
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ModificationArguments Class
    ModificationArguments Members


%%PageItemTitle%%

DicomObjects.Codecs Namespace / SimpleCodec Class
Members

In This Topic
    SimpleCodec Class
    In This Topic
    A class which provides a simple implementation of most of the required members of ICompressor and IDecompressor, simplifying implementation for transfer syntaxes which do not need partial decompression.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public MustInherit Class SimpleCodec
   Implements ICodecBase, ICompressor, IDecompressor
    'Usage

    Dim instance As SimpleCodec
    public abstract class SimpleCodec : ICodecBase, ICompressor, IDecompressor
    Inheritance Hierarchy

    System.Object
    DicomObjects.Codecs.SimpleCodec
    DicomObjects.Codecs.JpegLossless
    DicomObjects.Codecs.VideoCodec

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SimpleCodec Members
    DicomObjects.Codecs Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.Codecs Namespace / SimpleCodec Class
Properties Methods

In This Topic
    SimpleCodec Class Members
    In This Topic

    The following tables list the members exposed by SimpleCodec.

    Public Properties
     | Name | Description
Public Property | MaximumBits | The maximum number of bits supported by this codec.
Public Property | NeedsPlanarConfigTransform | Lets a caller to Decompress tell whether data needs to be transformed following decompression. It is only relevant if the image has a Planar Configuration value (0028,0006) of 1. For the simple codec, the value comes from the constructor
    Top
    Public Methods
     | Name | Description
Public Method | BestRequest | The most appropriate DicomObjects.Internal.PixelRequest, given the requested zoom and image/codec type
Public Method | CalculatedFrameCount | Limiting number of frames. Only used by MPEG etc. - default values used by other classes is int.MaxValue
Public Method | Compress | Abstract Placeholder for the compression routine
Public Method | Decompress | Abstract Placeholder for the decompression routine
Public Method | DecompressedPhotometricInterpretation | The effective Photometric Interpretation of the decompressed data
Public Method | DecompressState | The status of the decompression
Public Method | DownloadStatus | The status of the download
Public Method | LockObject | Standard LockObject implementation for thread-safety
Public Method | PrepareFunction | Prepares the data for Compression
Public Method | Quality |
    Top
    See Also

    Reference

    SimpleCodec Class
    DicomObjects.Codecs Namespace


%%PageItemTitle%% $$Methods$$

DicomObjects.Codecs Namespace / SimpleCodec Class

    SimpleCodec Class Methods
    In This Topic

    For a list of all members of this type, see SimpleCodec members.

    Public Methods
     | Name | Description
Public Method | BestRequest | The most appropriate DicomObjects.Internal.PixelRequest, given the requested zoom and image/codec type
Public Method | CalculatedFrameCount | Limiting number of frames. Only used by MPEG etc. - default values used by other classes is int.MaxValue
Public Method | Compress | Abstract Placeholder for the compression routine
Public Method | Decompress | Abstract Placeholder for the decompression routine
Public Method | DecompressedPhotometricInterpretation | The effective Photometric Interpretation of the decompressed data
Public Method | DecompressState | The status of the decompression
Public Method | DownloadStatus | The status of the download
Public Method | LockObject | Standard LockObject implementation for thread-safety
Public Method | PrepareFunction | Prepares the data for Compression
Public Method | Quality |
    Top
    See Also

    Reference

    SimpleCodec Class
    DicomObjects.Codecs Namespace


DicomObjects.Codecs Namespace / SimpleCodec Class / BestRequest Method
The requested Zoom
The requested usage of the pixel data
The surrounding dataset
The requested Frame

In This Topic
    BestRequest Method (SimpleCodec)
    In This Topic
    The most appropriate DicomObjects.Internal.PixelRequest, given the requested zoom and image/codec type
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Function BestRequest( _
   ByVal Zoom As Single, _
   ByVal Sync As RequestType, _
   ByVal parent As DicomDataSet, _
   ByVal Frame As Integer _
) As PixelRequest
    'Usage

    Dim instance As SimpleCodec
Dim Zoom As Single
Dim Sync As RequestType
Dim parent As DicomDataSet
Dim Frame As Integer
Dim value As PixelRequest

value = instance.BestRequest(Zoom, Sync, parent, Frame)
    public PixelRequest BestRequest(
   float Zoom,
   RequestType Sync,
   DicomDataSet parent,
   int Frame
)

    Parameters

    Zoom
    The requested Zoom
    Sync
    The requested usage of the pixel data
    parent
    The surrounding dataset
    Frame
    The requested Frame

    Return Value

    The best fit
    Remarks
    For this codec, the return object always references the full area, as this compression method does not support partial decompression
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SimpleCodec Class
    SimpleCodec Members


DicomObjects.Codecs Namespace / SimpleCodec Class / CalculatedFrameCount Method

    CalculatedFrameCount Method (SimpleCodec)
    In This Topic
    Limiting number of frames. Only used by MPEG etc. - default values used by other classes is int.MaxValue
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overridable Function CalculatedFrameCount() As Integer
    'Usage

    Dim instance As SimpleCodec
Dim value As Integer

value = instance.CalculatedFrameCount()
    public virtual int CalculatedFrameCount()
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SimpleCodec Class
    SimpleCodec Members


DicomObjects.Codecs Namespace / SimpleCodec Class / Compress Method
Standard Decompression arguments

    Compress Method (SimpleCodec)
    In This Topic
    Abstract Placeholder for the compression routine
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public MustOverride Sub Compress( _
   ByVal args As CompressionArguments _
)
    'Usage

    Dim instance As SimpleCodec
Dim args As CompressionArguments

instance.Compress(args)
    public abstract void Compress(
   CompressionArguments args
)

    Parameters

    args
    Standard Decompression arguments
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SimpleCodec Class
    SimpleCodec Members


DicomObjects.Codecs Namespace / SimpleCodec Class / Decompress Method
Standard Decompression arguments

    Decompress Method (SimpleCodec)
    In This Topic
    Abstract Placeholder for the decompression routine
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public MustOverride Sub Decompress( _
   ByVal args As DecompressionArguments _
)
    'Usage

    Dim instance As SimpleCodec
Dim args As DecompressionArguments

instance.Decompress(args)
    public abstract void Decompress(
   DecompressionArguments args
)

    Parameters

    args
    Standard Decompression arguments
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SimpleCodec Class
    SimpleCodec Members


DicomObjects.Codecs Namespace / SimpleCodec Class / DecompressedPhotometricInterpretation Method
The surrounding dataset

    DecompressedPhotometricInterpretation Method (SimpleCodec)
    In This Topic
    The effective Photometric Interpretation of the decompressed data
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overridable Function DecompressedPhotometricInterpretation( _
   ByVal parent As DicomDataSet _
) As String
    'Usage

    Dim instance As SimpleCodec
Dim parent As DicomDataSet
Dim value As String

value = instance.DecompressedPhotometricInterpretation(parent)
    public virtual string DecompressedPhotometricInterpretation(
   DicomDataSet parent
)

    Parameters

    parent
    The surrounding dataset

    Return Value

    Photometric Interpretation as a string
    Remarks
    For RLE, this will always be the native value of the parent dataset (0028,0004)
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SimpleCodec Class
    SimpleCodec Members


DicomObjects.Codecs Namespace / SimpleCodec Class / DecompressState Method
The request against which to compare the current status

    DecompressState Method (SimpleCodec)
    In This Topic
    The status of the decompression
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Function DecompressState( _
   ByVal Request As PixelRequest _
) As DecompressStatus
    'Usage

    Dim instance As SimpleCodec
Dim Request As PixelRequest
Dim value As DecompressStatus

value = instance.DecompressState(Request)
    public DecompressStatus DecompressState(
   PixelRequest Request
)

    Parameters

    Request
    The request against which to compare the current status

    Return Value

    DicomObjects.Enums.DecompressStatus.None
    Remarks
    For this codec, this method always returns DicomObjects.Enums.DecompressStatus.None
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SimpleCodec Class
    SimpleCodec Members


DicomObjects.Codecs Namespace / SimpleCodec Class / DownloadStatus Method
The request against which to compare the current status

    DownloadStatus Method (SimpleCodec)
    In This Topic
    The status of the download
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Function DownloadStatus( _
   ByVal Request As PixelRequest _
) As ProgressiveStatus
    'Usage

    Dim instance As SimpleCodec
Dim Request As PixelRequest
Dim value As ProgressiveStatus

value = instance.DownloadStatus(Request)
    public ProgressiveStatus DownloadStatus(
   PixelRequest Request
)

    Parameters

    Request
    The request against which to compare the current status

    Return Value

    DicomObjects.Enums.ProgressiveStatus.WholeImage
    Remarks
    For this codec, this method always returns DicomObjects.Enums.ProgressiveStatus.WholeImage
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SimpleCodec Class
    SimpleCodec Members


DicomObjects.Codecs Namespace / SimpleCodec Class / LockObject Method

    LockObject Method (SimpleCodec)
    In This Topic
    Standard LockObject implementation for thread-safety
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Function LockObject() As Object
    'Usage

    Dim instance As SimpleCodec
Dim value As Object

value = instance.LockObject()
    public object LockObject()

    Return Value

    The Instance object
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SimpleCodec Class
    SimpleCodec Members


DicomObjects.Codecs Namespace / SimpleCodec Class / PrepareFunction Method
Details of the compression to take place

    PrepareFunction Method (SimpleCodec)
    In This Topic
    Prepares the data for Compression
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overridable Sub PrepareFunction( _
   ByVal args As ModificationArguments _
)
    'Usage

    Dim instance As SimpleCodec
Dim args As ModificationArguments

instance.PrepareFunction(args)
    public virtual void PrepareFunction(
   ModificationArguments args
)

    Parameters

    args
    Details of the compression to take place
    Remarks
    For this codec, this function does nothing
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SimpleCodec Class
    SimpleCodec Members


DicomObjects.Codecs Namespace / SimpleCodec Class / Quality Method

    Quality Method (SimpleCodec)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Function Quality( _
   ByVal TransferSyntax As String, _
   ByVal qmap As Dictionary(Of String,Object), _
   ByVal dataset As DicomDataSet _
) As Object
    'Usage

    Dim instance As SimpleCodec
Dim TransferSyntax As String
Dim qmap As Dictionary(Of String,Object)
Dim dataset As DicomDataSet
Dim value As Object

value = instance.Quality(TransferSyntax, qmap, dataset)
    public object Quality(
   string TransferSyntax,
   Dictionary<string,object> qmap,
   DicomDataSet dataset
)

    Parameters

    TransferSyntax
    qmap
    dataset
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SimpleCodec Class
    SimpleCodec Members


%%PageItemTitle%% $$Properties$$

DicomObjects.Codecs Namespace / SimpleCodec Class

    SimpleCodec Class Properties
    In This Topic

    For a list of all members of this type, see SimpleCodec members.

    Public Properties
     | Name | Description
Public Property | MaximumBits | The maximum number of bits supported by this codec.
Public Property | NeedsPlanarConfigTransform | Lets a caller to Decompress tell whether data needs to be transformed following decompression. It is only relevant if the image has a Planar Configuration value (0028,0006) of 1. For the simple codec, the value comes from the constructor
    Top
    See Also

    Reference

    SimpleCodec Class
    DicomObjects.Codecs Namespace


DicomObjects.Codecs Namespace / SimpleCodec Class / MaximumBits Property

    MaximumBits Property (SimpleCodec)
    In This Topic
    The maximum number of bits supported by this codec.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overridable ReadOnly Property MaximumBits As Integer
    'Usage

    Dim instance As SimpleCodec
Dim value As Integer

value = instance.MaximumBits
    public virtual int MaximumBits {get;}
    Remarks

    For the simple codec, the maximum is as provided in the constructor

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SimpleCodec Class
    SimpleCodec Members


DicomObjects.Codecs Namespace / SimpleCodec Class / NeedsPlanarConfigTransform Property

    NeedsPlanarConfigTransform Property (SimpleCodec)
    In This Topic

    Lets a caller to Decompress tell whether data needs to be transformed following decompression. It is only relevant if the image has a Planar Configuration value (0028,0006) of 1.

    For the simple codec, the value comes from the constructor
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overridable ReadOnly Property NeedsPlanarConfigTransform As Boolean
    'Usage

    Dim instance As SimpleCodec
Dim value As Boolean

value = instance.NeedsPlanarConfigTransform
    public virtual bool NeedsPlanarConfigTransform {get;}
    Remarks
    For the simple codec, the value comes from the constructor
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SimpleCodec Class
    SimpleCodec Members


%%PageItemTitle%%

DicomObjects.Codecs Namespace / VideoCodec Class
Members

In This Topic
    VideoCodec Class
    In This Topic
    A class derived from SimpleCodec to be used by video codecs
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Class VideoCodec
   Inherits SimpleCodec
   Implements ICodecBase, ICompressor, IDecompressor
    'Usage

    Dim instance As VideoCodec
    public class VideoCodec : SimpleCodec, ICodecBase, ICompressor, IDecompressor
    Inheritance Hierarchy

    System.Object
    DicomObjects.Codecs.SimpleCodec
    DicomObjects.Codecs.VideoCodec

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    VideoCodec Members
    DicomObjects.Codecs Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.Codecs Namespace / VideoCodec Class
Properties Methods

In This Topic
    VideoCodec Class Members
    In This Topic

    The following tables list the members exposed by VideoCodec.

    Public Constructors
     | Name | Description
Public Constructor | VideoCodec Constructor | Simple constructor
    Top
    Public Properties
     | Name | Description
Public Property | MaximumBits | The maximum number of bits supported by this codec. (Inherited from DicomObjects.Codecs.SimpleCodec)
Public Property | NeedsPlanarConfigTransform | Lets a caller to Decompress tell whether data needs to be transformed following decompression. It is only relevant if the image has a Planar Configuration value (0028,0006) of 1. For the simple codec, the value comes from the constructor (Inherited from DicomObjects.Codecs.SimpleCodec)
    Top
    Public Methods
     | Name | Description
Public Method | BestRequest | The most appropriate DicomObjects.Internal.PixelRequest, given the requested zoom and image/codec type (Inherited from DicomObjects.Codecs.SimpleCodec)
Public Method | CalculatedFrameCount | Overridden. Limiting number of frames. Only used by MPEG etc. - default values used by other classes is int.MaxValue
Public Method | Compress | Overridden. Abstract Placeholder for the compression routine
Public Method | Decompress | Overridden. Abstract Placeholder for the decompression routine
Public Method | DecompressedPhotometricInterpretation | Overridden. The effective Photometric Interpretation of the decompressed data
Public Method | DecompressState | The status of the decompression (Inherited from DicomObjects.Codecs.SimpleCodec)
Public Method | DownloadStatus | The status of the download (Inherited from DicomObjects.Codecs.SimpleCodec)
Public Method | LockObject | Standard LockObject implementation for thread-safety (Inherited from DicomObjects.Codecs.SimpleCodec)
Public Method | PrepareFunction | Prepares the data for Compression (Inherited from DicomObjects.Codecs.SimpleCodec)
Public Method | Quality | (Inherited from DicomObjects.Codecs.SimpleCodec)
    Top
    See Also

    Reference

    VideoCodec Class
    DicomObjects.Codecs Namespace


%%PageItemTitle%%

DicomObjects.Codecs Namespace / VideoCodec Class / VideoCodec Constructor

In This Topic
    VideoCodec Constructor
    In This Topic
    Simple constructor
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Function New( _
   ByVal d As IFrameSource _
)
    'Usage

    Dim d As IFrameSource

Dim instance As New VideoCodec(d)
    public VideoCodec(
   IFrameSource d
)

    Parameters

    d
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    VideoCodec Class
    VideoCodec Members


%%PageItemTitle%% $$Methods$$

DicomObjects.Codecs Namespace / VideoCodec Class

    VideoCodec Class Methods
    In This Topic

    For a list of all members of this type, see VideoCodec members.

    Public Methods
     | Name | Description
Public Method | BestRequest | The most appropriate DicomObjects.Internal.PixelRequest, given the requested zoom and image/codec type (Inherited from DicomObjects.Codecs.SimpleCodec)
Public Method | CalculatedFrameCount | Overridden. Limiting number of frames. Only used by MPEG etc. - default values used by other classes is int.MaxValue
Public Method | Compress | Overridden. Abstract Placeholder for the compression routine
Public Method | Decompress | Overridden. Abstract Placeholder for the decompression routine
Public Method | DecompressedPhotometricInterpretation | Overridden. The effective Photometric Interpretation of the decompressed data
Public Method | DecompressState | The status of the decompression (Inherited from DicomObjects.Codecs.SimpleCodec)
Public Method | DownloadStatus | The status of the download (Inherited from DicomObjects.Codecs.SimpleCodec)
Public Method | LockObject | Standard LockObject implementation for thread-safety (Inherited from DicomObjects.Codecs.SimpleCodec)
Public Method | PrepareFunction | Prepares the data for Compression (Inherited from DicomObjects.Codecs.SimpleCodec)
Public Method | Quality | (Inherited from DicomObjects.Codecs.SimpleCodec)
    Top
    See Also

    Reference

    VideoCodec Class
    DicomObjects.Codecs Namespace


DicomObjects.Codecs Namespace / VideoCodec Class / CalculatedFrameCount Method

    CalculatedFrameCount Method (VideoCodec)
    In This Topic
    Limiting number of frames. Only used by MPEG etc. - default values used by other classes is int.MaxValue
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overrides Function CalculatedFrameCount() As Integer
    'Usage

    Dim instance As VideoCodec
Dim value As Integer

value = instance.CalculatedFrameCount()
    public override int CalculatedFrameCount()
    Remarks
    This is calculated from the codec - e.g. the length of an MPEG data stream in frames.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    VideoCodec Class
    VideoCodec Members


DicomObjects.Codecs Namespace / VideoCodec Class / Compress Method
Standard Decompression arguments

    Compress Method (VideoCodec)
    In This Topic
    Abstract Placeholder for the compression routine
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overrides Sub Compress( _
   ByVal args As CompressionArguments _
)
    'Usage

    Dim instance As VideoCodec
Dim args As CompressionArguments

instance.Compress(args)
    public override void Compress(
   CompressionArguments args
)

    Parameters

    args
    Standard Decompression arguments
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    VideoCodec Class
    VideoCodec Members


DicomObjects.Codecs Namespace / VideoCodec Class / Decompress Method
Standard Decompression arguments

    Decompress Method (VideoCodec)
    In This Topic
    Abstract Placeholder for the decompression routine
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overrides Sub Decompress( _
   ByVal args As DecompressionArguments _
)
    'Usage

    Dim instance As VideoCodec
Dim args As DecompressionArguments

instance.Decompress(args)
    public override void Decompress(
   DecompressionArguments args
)

    Parameters

    args
    Standard Decompression arguments
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    VideoCodec Class
    VideoCodec Members


DicomObjects.Codecs Namespace / VideoCodec Class / DecompressedPhotometricInterpretation Method
The surrounding dataset

    DecompressedPhotometricInterpretation Method (VideoCodec)
    In This Topic
    The effective Photometric Interpretation of the decompressed data
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overrides Function DecompressedPhotometricInterpretation( _
   ByVal parent As DicomDataSet _
) As String
    'Usage

    Dim instance As VideoCodec
Dim parent As DicomDataSet
Dim value As String

value = instance.DecompressedPhotometricInterpretation(parent)
    public override string DecompressedPhotometricInterpretation(
   DicomDataSet parent
)

    Parameters

    parent
    The surrounding dataset

    Return Value

    Photometric Interpretation as a string
    Remarks
    For RLE, this will always be the native value of the parent dataset (0028,0004)
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    VideoCodec Class
    VideoCodec Members


%%PageItemTitle%%

DicomObjects.Codecs Namespace / ICodecBase Interface
Members

In This Topic
    ICodecBase Interface
    In This Topic
    Common features for all codecs
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Interface ICodecBase
    'Usage

    Dim instance As ICodecBase
    public interface ICodecBase
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ICodecBase Members
    DicomObjects.Codecs Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.Codecs Namespace / ICodecBase Interface
Methods

In This Topic
    ICodecBase Interface Members
    In This Topic

    The following tables list the members exposed by ICodecBase.

    Public Methods
     | Name | Description
Method | LockObject | A simple object to provide synchronisation if a codec is accessed via multiple threads
    Top
    See Also

    Reference

    ICodecBase Interface
    DicomObjects.Codecs Namespace


%%PageItemTitle%% $$Methods$$

DicomObjects.Codecs Namespace / ICodecBase Interface

    ICodecBase Interface Methods
    In This Topic

    For a list of all members of this type, see ICodecBase members.

    Public Methods
     | Name | Description
Method | LockObject | A simple object to provide synchronisation if a codec is accessed via multiple threads
    Top
    See Also

    Reference

    ICodecBase Interface
    DicomObjects.Codecs Namespace


DicomObjects.Codecs Namespace / ICodecBase Interface / LockObject Method

    LockObject Method (ICodecBase)
    In This Topic
    A simple object to provide synchronisation if a codec is accessed via multiple threads
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Function LockObject() As Object
    'Usage

    Dim instance As ICodecBase
Dim value As Object

value = instance.LockObject()
    object LockObject()

    Return Value

    An object which should only be used for locking
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ICodecBase Interface
    ICodecBase Members


%%PageItemTitle%%

DicomObjects.Codecs Namespace / ICompressor Interface
Members

In This Topic
    ICompressor Interface
    In This Topic
    Interface implemented by all compression codecs
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Interface ICompressor
   Inherits ICodecBase
    'Usage

    Dim instance As ICompressor
    public interface ICompressor : ICodecBase
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ICompressor Members
    DicomObjects.Codecs Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.Codecs Namespace / ICompressor Interface
Properties Methods

In This Topic
    ICompressor Interface Members
    In This Topic

    The following tables list the members exposed by ICompressor.

    Public Properties
    Name | Description
    Property | MaximumBits | The maximum number of bits supported by this codec.
    Property NeedsPlanarConfigTransform

    Lets a caller to Compress tell whether data needs to be transformed before compression. It is only relevent if the image has a Planar Configuration value (0028,0006) of 1.

    If this property is true, then the compressor expects data in "by pixel" mode, irrespective of the stated Planar Configuration, so DicomObjects will apply a suitable transformation pre-compression.

    If this property is false, then the compressor can use data in the original form as stated by the Planar Configuration, so pre-compression transformation is not necessary.

    Top
    Public Methods
     | Name | Description
Method | Compress | Compress a frame of pixel data
Method | LockObject | A simple object to provide synchronisation if a codec is accessed via multiple threads (Inherited from DicomObjects.Codecs.ICodecBase)
Method | PrepareFunction | Make any changes to the main dataset, before doing the frame-by-frame compression, and inform DicomObjects of any preprocessing required.
Method | Quality |
    Top
    See Also

    Reference

    ICompressor Interface
    DicomObjects.Codecs Namespace


%%PageItemTitle%% $$Methods$$

DicomObjects.Codecs Namespace / ICompressor Interface

    ICompressor Interface Methods
    In This Topic

    For a list of all members of this type, see ICompressor members.

    Public Methods
     | Name | Description
Method | Compress | Compress a frame of pixel data
Method | LockObject | A simple object to provide synchronisation if a codec is accessed via multiple threads (Inherited from DicomObjects.Codecs.ICodecBase)
Method | PrepareFunction | Make any changes to the main dataset, before doing the frame-by-frame compression, and inform DicomObjects of any preprocessing required.
Method | Quality |
    Top
    See Also

    Reference

    ICompressor Interface
    DicomObjects.Codecs Namespace


DicomObjects.Codecs Namespace / ICompressor Interface / Compress Method
Standard compression arguments as defined by the CompressionArguments class

In This Topic
    Compress Method (ICompressor)
    In This Topic
    Compress a frame of pixel data
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Sub Compress( _
   ByVal args As CompressionArguments _
)
    'Usage

    Dim instance As ICompressor
Dim args As CompressionArguments

instance.Compress(args)
    void Compress(
   CompressionArguments args
)

    Parameters

    args
    Standard compression arguments as defined by the CompressionArguments class
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ICompressor Interface
    ICompressor Members


DicomObjects.Codecs Namespace / ICompressor Interface / PrepareFunction Method
Standard argument for PrepareCompress

    PrepareFunction Method (ICompressor)
    In This Topic
    Make any changes to the main dataset, before doing the frame-by-frame compression, and inform DicomObjects of any preprocessing required.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Sub PrepareFunction( _
   ByVal ModificationArguments As ModificationArguments _
)
    'Usage

    Dim instance As ICompressor
Dim ModificationArguments As ModificationArguments

instance.PrepareFunction(ModificationArguments)
    void PrepareFunction(
   ModificationArguments ModificationArguments
)

    Parameters

    ModificationArguments
    Standard argument for PrepareCompress
    Remarks
    Details vary according to the compression method, but examples include:
    • For some compression methods, a transform is needed to bring the data into the 12 bit unsigned range (e.g. JPEG lossy extended)
    • For colour images, the photometric interpretation of the dataset may need to be changed to (e.g. to YBR_FULL_422 for JPEG lossy)

    By changing the values in ModificationArguments, a compressor can control how the pixel data is passed to it by DicomObjects, or how some other values are later changed:

    Setting ModificationArgs.LossyDescription to a human description and and ModificationArgs.LossyMethod to a codec values (e.g. "ISO_10918_1" for JPEG)

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ICompressor Interface
    ICompressor Members


DicomObjects.Codecs Namespace / ICompressor Interface / Quality Method

    Quality Method (ICompressor)
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Function Quality( _
   ByVal TransferSyntax As String, _
   ByVal qmap As Dictionary(Of String,Object), _
   ByVal dataset As DicomDataSet _
) As Object
    'Usage

    Dim instance As ICompressor
Dim TransferSyntax As String
Dim qmap As Dictionary(Of String,Object)
Dim dataset As DicomDataSet
Dim value As Object

value = instance.Quality(TransferSyntax, qmap, dataset)
    object Quality(
   string TransferSyntax,
   Dictionary<string,object> qmap,
   DicomDataSet dataset
)

    Parameters

    TransferSyntax
    qmap
    dataset
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ICompressor Interface
    ICompressor Members


%%PageItemTitle%% $$Properties$$

DicomObjects.Codecs Namespace / ICompressor Interface

    ICompressor Interface Properties
    In This Topic

    For a list of all members of this type, see ICompressor members.

    Public Properties
    Name | Description
    Property | MaximumBits | The maximum number of bits supported by this codec.
    Property NeedsPlanarConfigTransform

    Lets a caller to Compress tell whether data needs to be transformed before compression. It is only relevent if the image has a Planar Configuration value (0028,0006) of 1.

    If this property is true, then the compressor expects data in "by pixel" mode, irrespective of the stated Planar Configuration, so DicomObjects will apply a suitable transformation pre-compression.

    If this property is false, then the compressor can use data in the original form as stated by the Planar Configuration, so pre-compression transformation is not necessary.

    Top
    See Also

    Reference

    ICompressor Interface
    DicomObjects.Codecs Namespace


DicomObjects.Codecs Namespace / ICompressor Interface / MaximumBits Property

    MaximumBits Property (ICompressor)
    In This Topic
    The maximum number of bits supported by this codec.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    ReadOnly Property MaximumBits As Integer
    'Usage

    Dim instance As ICompressor
Dim value As Integer

value = instance.MaximumBits
    int MaximumBits {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ICompressor Interface
    ICompressor Members


DicomObjects.Codecs Namespace / ICompressor Interface / NeedsPlanarConfigTransform Property

    NeedsPlanarConfigTransform Property (ICompressor)
    In This Topic

    Lets a caller to Compress tell whether data needs to be transformed before compression. It is only relevent if the image has a Planar Configuration value (0028,0006) of 1.

    If this property is true, then the compressor expects data in "by pixel" mode, irrespective of the stated Planar Configuration, so DicomObjects will apply a suitable transformation pre-compression.

    If this property is false, then the compressor can use data in the original form as stated by the Planar Configuration, so pre-compression transformation is not necessary.

    Syntax
    • Visual Basic
    • C#
    'Declaration

    ReadOnly Property NeedsPlanarConfigTransform As Boolean
    'Usage

    Dim instance As ICompressor
Dim value As Boolean

value = instance.NeedsPlanarConfigTransform
    bool NeedsPlanarConfigTransform {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ICompressor Interface
    ICompressor Members


%%PageItemTitle%%

DicomObjects.Codecs Namespace / IDecompressor Interface
Members

In This Topic
    IDecompressor Interface
    In This Topic
    Interface implemented by for all DICOM decompression codecs
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Interface IDecompressor
   Inherits ICodecBase
    'Usage

    Dim instance As IDecompressor
    public interface IDecompressor : ICodecBase
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    IDecompressor Members
    DicomObjects.Codecs Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.Codecs Namespace / IDecompressor Interface
Properties Methods

In This Topic
    IDecompressor Interface Members
    In This Topic

    The following tables list the members exposed by IDecompressor.

    Public Properties
    Name Description
    Property NeedsPlanarConfigTransform

    Lets a caller to Decompress tell whether data needs to be transformed following decompression. It is only relevent if the image has a Planar Configuration value (0028,0006) of 1.

    If this property is true, then the decompressor will return data in "by pixel" mode, irrespective of the stated Planar Configuration, so post-decompression transformation may be necessary.

    If this property is false, then the decompressor will return data in the form requested by the stated Planar Configuration, so post-decompression transformation is not necessary.

    Top
    Public Methods
     | Name | Description
Method | BestRequest | The most appropriate DicomObjects.Internal.PixelRequest, given the requested zoom and image/codec type
Method | CalculatedFrameCount | The number of frames calculated by decompressor
Method | Decompress | Decompress a frame as defined by the DecompressionArguments argument
Method | DecompressedPhotometricInterpretation | The effective Photometric Interpretation of the decompressed data
Method | DecompressState | The status of the decompression
Method | DownloadStatus | The status of the download
Method | LockObject | A simple object to provide synchronisation if a codec is accessed via multiple threads (Inherited from DicomObjects.Codecs.ICodecBase)
    Top
    See Also

    Reference

    IDecompressor Interface
    DicomObjects.Codecs Namespace


%%PageItemTitle%% $$Methods$$

DicomObjects.Codecs Namespace / IDecompressor Interface

    IDecompressor Interface Methods
    In This Topic

    For a list of all members of this type, see IDecompressor members.

    Public Methods
     | Name | Description
Method | BestRequest | The most appropriate DicomObjects.Internal.PixelRequest, given the requested zoom and image/codec type
Method | CalculatedFrameCount | The number of frames calculated by decompressor
Method | Decompress | Decompress a frame as defined by the DecompressionArguments argument
Method | DecompressedPhotometricInterpretation | The effective Photometric Interpretation of the decompressed data
Method | DecompressState | The status of the decompression
Method | DownloadStatus | The status of the download
Method | LockObject | A simple object to provide synchronisation if a codec is accessed via multiple threads (Inherited from DicomObjects.Codecs.ICodecBase)
    Top
    See Also

    Reference

    IDecompressor Interface
    DicomObjects.Codecs Namespace


DicomObjects.Codecs Namespace / IDecompressor Interface / BestRequest Method
The requested Zoom
The requested usage of the pixel data
The surrouding dataset
The requested Frame

In This Topic
    BestRequest Method (IDecompressor)
    In This Topic
    The most appropriate DicomObjects.Internal.PixelRequest, given the requested zoom and image/codec type
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Function BestRequest( _
   ByVal Zoom As Single, _
   ByVal Sync As RequestType, _
   ByVal parent As DicomDataSet, _
   ByVal Frame As Integer _
) As PixelRequest
    'Usage

    Dim instance As IDecompressor
Dim Zoom As Single
Dim Sync As RequestType
Dim parent As DicomDataSet
Dim Frame As Integer
Dim value As PixelRequest

value = instance.BestRequest(Zoom, Sync, parent, Frame)
    PixelRequest BestRequest(
   float Zoom,
   RequestType Sync,
   DicomDataSet parent,
   int Frame
)

    Parameters

    Zoom
    The requested Zoom
    Sync
    The requested usage of the pixel data
    parent
    The surrouding dataset
    Frame
    The requested Frame

    Return Value

    The best fit
    Remarks
    This is only really used for codecs with partial decompression options, such as JPEG 2000 and JPIP
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    IDecompressor Interface
    IDecompressor Members


DicomObjects.Codecs Namespace / IDecompressor Interface / CalculatedFrameCount Method

    CalculatedFrameCount Method (IDecompressor)
    In This Topic
    The number of frames calculated by decompressor
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Function CalculatedFrameCount() As Integer
    'Usage

    Dim instance As IDecompressor
Dim value As Integer

value = instance.CalculatedFrameCount()
    int CalculatedFrameCount()

    Return Value

    Number of frames as calculated by the codec
    Remarks
    This value may not match the NumberOfFrames in the DICOM data
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    IDecompressor Interface
    IDecompressor Members


DicomObjects.Codecs Namespace / IDecompressor Interface / Decompress Method
The decoompression arguments

    Decompress Method (IDecompressor)
    In This Topic
    Decompress a frame as defined by the DecompressionArguments argument
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Sub Decompress( _
   ByVal args As DecompressionArguments _
)
    'Usage

    Dim instance As IDecompressor
Dim args As DecompressionArguments

instance.Decompress(args)
    void Decompress(
   DecompressionArguments args
)

    Parameters

    args
    The decoompression arguments
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    IDecompressor Interface
    IDecompressor Members


DicomObjects.Codecs Namespace / IDecompressor Interface / DecompressedPhotometricInterpretation Method
The surrouding dataset

    DecompressedPhotometricInterpretation Method (IDecompressor)
    In This Topic
    The effective Photometric Interpretation of the decompressed data
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Function DecompressedPhotometricInterpretation( _
   ByVal parent As DicomDataSet _
) As String
    'Usage

    Dim instance As IDecompressor
Dim parent As DicomDataSet
Dim value As String

value = instance.DecompressedPhotometricInterpretation(parent)
    string DecompressedPhotometricInterpretation(
   DicomDataSet parent
)

    Parameters

    parent
    The surrouding dataset

    Return Value

    Photometric Interpretation as a string
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    IDecompressor Interface
    IDecompressor Members


DicomObjects.Codecs Namespace / IDecompressor Interface / DecompressState Method
The request against which to compare the current status

    DecompressState Method (IDecompressor)
    In This Topic
    The status of the decompression
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Function DecompressState( _
   ByVal Request As PixelRequest _
) As DecompressStatus
    'Usage

    Dim instance As IDecompressor
Dim Request As PixelRequest
Dim value As DecompressStatus

value = instance.DecompressState(Request)
    DecompressStatus DecompressState(
   PixelRequest Request
)

    Parameters

    Request
    The request against which to compare the current status

    Return Value

    The state of the decompression
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    IDecompressor Interface
    IDecompressor Members


DicomObjects.Codecs Namespace / IDecompressor Interface / DownloadStatus Method
The request against which to compare the current status

    DownloadStatus Method (IDecompressor)
    In This Topic
    The status of the download
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Function DownloadStatus( _
   ByVal Request As PixelRequest _
) As ProgressiveStatus
    'Usage

    Dim instance As IDecompressor
Dim Request As PixelRequest
Dim value As ProgressiveStatus

value = instance.DownloadStatus(Request)
    ProgressiveStatus DownloadStatus(
   PixelRequest Request
)

    Parameters

    Request
    The request against which to compare the current status

    Return Value

    The state of the download
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    IDecompressor Interface
    IDecompressor Members


%%PageItemTitle%% $$Properties$$

DicomObjects.Codecs Namespace / IDecompressor Interface

    IDecompressor Interface Properties
    In This Topic

    For a list of all members of this type, see IDecompressor members.

    Public Properties
    Name Description
    Property NeedsPlanarConfigTransform

    Lets a caller to Decompress tell whether data needs to be transformed following decompression. It is only relevent if the image has a Planar Configuration value (0028,0006) of 1.

    If this property is true, then the decompressor will return data in "by pixel" mode, irrespective of the stated Planar Configuration, so post-decompression transformation may be necessary.

    If this property is false, then the decompressor will return data in the form requested by the stated Planar Configuration, so post-decompression transformation is not necessary.

    Top
    See Also

    Reference

    IDecompressor Interface
    DicomObjects.Codecs Namespace


DicomObjects.Codecs Namespace / IDecompressor Interface / NeedsPlanarConfigTransform Property

    NeedsPlanarConfigTransform Property (IDecompressor)
    In This Topic

    Lets a caller to Decompress tell whether data needs to be transformed following decompression. It is only relevent if the image has a Planar Configuration value (0028,0006) of 1.

    If this property is true, then the decompressor will return data in "by pixel" mode, irrespective of the stated Planar Configuration, so post-decompression transformation may be necessary.

    If this property is false, then the decompressor will return data in the form requested by the stated Planar Configuration, so post-decompression transformation is not necessary.

    Syntax
    • Visual Basic
    • C#
    'Declaration

    ReadOnly Property NeedsPlanarConfigTransform As Boolean
    'Usage

    Dim instance As IDecompressor
Dim value As Boolean

value = instance.NeedsPlanarConfigTransform
    bool NeedsPlanarConfigTransform {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    IDecompressor Interface
    IDecompressor Members


%%PageItemTitle%%

DicomObjects.Codecs Namespace / IExporter Interface
Members

In This Topic
    IExporter Interface
    In This Topic
    Interface implemented by all export codecs
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Interface IExporter
   Inherits ICodecBase
    'Usage

    Dim instance As IExporter
    public interface IExporter : ICodecBase
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    IExporter Members
    DicomObjects.Codecs Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.Codecs Namespace / IExporter Interface
Methods

In This Topic
    IExporter Interface Members
    In This Topic

    The following tables list the members exposed by IExporter.

    Public Methods
     | Name | Description
Method | Export | Export to an external format image
Method | LockObject | A simple object to provide synchronisation if a codec is accessed via multiple threads (Inherited from DicomObjects.Codecs.ICodecBase)
    Top
    See Also

    Reference

    IExporter Interface
    DicomObjects.Codecs Namespace


%%PageItemTitle%% $$Methods$$

DicomObjects.Codecs Namespace / IExporter Interface

    IExporter Interface Methods
    In This Topic

    For a list of all members of this type, see IExporter members.

    Public Methods
     | Name | Description
Method | Export | Export to an external format image
Method | LockObject | A simple object to provide synchronisation if a codec is accessed via multiple threads (Inherited from DicomObjects.Codecs.ICodecBase)
    Top
    See Also

    Reference

    IExporter Interface
    DicomObjects.Codecs Namespace


DicomObjects.Codecs Namespace / IExporter Interface / Export Method
Standard export arguments as defined by the CompressionArguments class

In This Topic
    Export Method (IExporter)
    In This Topic
    Export to an external format image
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Sub Export( _
   ByVal args As CompressionArguments _
)
    'Usage

    Dim instance As IExporter
Dim args As CompressionArguments

instance.Export(args)
    void Export(
   CompressionArguments args
)

    Parameters

    args
    Standard export arguments as defined by the CompressionArguments class
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    IExporter Interface
    IExporter Members


%%PageItemTitle%%

DicomObjects.Codecs Namespace / IImporter Interface
Members

In This Topic
    IImporter Interface
    In This Topic
    Interface implemented by all import codecs
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Interface IImporter
   Inherits ICodecBase
    'Usage

    Dim instance As IImporter
    public interface IImporter : ICodecBase
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    IImporter Members
    DicomObjects.Codecs Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.Codecs Namespace / IImporter Interface
Methods

In This Topic
    IImporter Interface Members
    In This Topic

    The following tables list the members exposed by IImporter.

    Public Methods
     | Name | Description
Method | Import | Import from an external format image
Method | LockObject | A simple object to provide synchronisation if a codec is accessed via multiple threads (Inherited from DicomObjects.Codecs.ICodecBase)
    Top
    See Also

    Reference

    IImporter Interface
    DicomObjects.Codecs Namespace


%%PageItemTitle%% $$Methods$$

DicomObjects.Codecs Namespace / IImporter Interface

    IImporter Interface Methods
    In This Topic

    For a list of all members of this type, see IImporter members.

    Public Methods
     | Name | Description
Method | Import | Import from an external format image
Method | LockObject | A simple object to provide synchronisation if a codec is accessed via multiple threads (Inherited from DicomObjects.Codecs.ICodecBase)
    Top
    See Also

    Reference

    IImporter Interface
    DicomObjects.Codecs Namespace


DicomObjects.Codecs Namespace / IImporter Interface / Import Method
Standard import arguments as defined by the ImportArguments class

In This Topic
    Import Method (IImporter)
    In This Topic
    Import from an external format image
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Function Import( _
   ByVal args As ImportArguments _
) As Boolean
    'Usage

    Dim instance As IImporter
Dim args As ImportArguments
Dim value As Boolean

value = instance.Import(args)
    bool Import(
   ImportArguments args
)

    Parameters

    args
    Standard import arguments as defined by the ImportArguments class

    Return Value

    true if successful
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    IImporter Interface
    IImporter Members


Inheritance Hierarchy
    DicomObjects.Delegates Namespace
    Delegates
     | Delegate | Description
Delegate | AssociationClosedHandler | Delegate for the DicomObjects.DicomServer.AssociationClosed event
Delegate | AssociationRequestHandler | Delegate for the DicomObjects.DicomServer.AssociationRequest event
Delegate | ChangeUidHandler | Delegate for the DicomObjects.DicomGlobal.OnChangeUid event
Delegate | DataChangedHandler | Delegate for the DicomViewer's DataChanged event
Delegate | ErrorReceivedHandler | Delegate for the DicomObjects.DicomServer.ErrorReceived event
Delegate | GetUrlHandler | Delegate for the DicomObjects.Codecs.Jpip.GetUri event
Delegate | InfoMessageHandler | Delegate for the DicomObjects.DicomServer.InfoMessage event
Delegate | InstanceReceivedHandler | Delegate for the DicomObjects.DicomServer.InstanceReceived Event
Delegate | LabelChangedHandler | Delegate for the DicomObjects.DicomLabel.LabelChanged event
Delegate | LicenceExpirationHandler | Delegate used by the LicenceExpirationHandler
Delegate | LicenceRetrieveHandler | Delegate for the DicomObjects.DicomLicence.LicenceRetrieve event
Delegate | LicenceStoredHandler | Delegate for DicomObjects.DicomLicence.LicenceStore event
Delegate | LogHandler | Delegate for the DicomObjects.DicomGlobal.LogEvent Event
Delegate | N_Event_ReportHandler | Delegate for the "N_Event_Report" events of a DicomObjects.DicomAssociation and DicomObjects.DicomServer
Delegate | NormalisedReceivedHandler | Delegate for the DicomObjects.DicomServer.NormalisedReceived event
Delegate | PositionChangedHandler | Delegate for the DicomObjects.DicomImage.PositionChanged event
Delegate | PSLabelCreatedHandler | Delegate for the DicomObjects.DicomLabel.PSLabelCreated event
Delegate | QueryReceivedHandler | Delegate for the DicomObjects.DicomServer.QueryReceived event
Delegate | ReceivingPixelDataHandler | Delegate used by the DicomObjects.DicomServer.ReceivingPixelData event
Delegate | ResponseReceivedHandler | Delegate for the DicomObjects.DicomAssociation.ResponseReceived and DicomObjects.DicomQuery.ResponseReceived events
Delegate | StatusUpdateHandler | Delegate for the DicomObjects.Codecs.Jpip.StatusUpdate event
Delegate | TlsAcceptor | Delegate used to accept TLS communications
Delegate | TlsInitiator | Delegate used to initiate TLS communications
Delegate | VerifyReceivedHandler | Delegate for the DicomObjects.DicomServer.VerifyReceived event
    See Also

    Reference

    DicomObjects.NetStandard Assembly


%%PageItemTitle%%

DicomObjects.Delegates Namespace / AssociationClosedHandler Delegate
Sender as Object
e as AssocaitionClosedArgs

In This Topic
    AssociationClosedHandler Delegate
    In This Topic
    Delegate for the DicomObjects.DicomServer.AssociationClosed event
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Delegate Sub AssociationClosedHandler( _
   ByVal Sender As Object, _
   ByVal e As AssociationClosedArgs _
)
    'Usage

    Dim instance As New AssociationClosedHandler(AddressOf HandlerMethod)
    public delegate void AssociationClosedHandler(
   object Sender,
   AssociationClosedArgs e
)

    Parameters

    Sender
    Sender as Object
    e
    e as AssocaitionClosedArgs
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    AssociationClosedHandler Members
    DicomObjects.Delegates Namespace


%%PageItemTitle%%

DicomObjects.Delegates Namespace / AssociationRequestHandler Delegate
Sender as Object
e as AssociationRequestArgs

In This Topic
    AssociationRequestHandler Delegate
    In This Topic
    Delegate for the DicomObjects.DicomServer.AssociationRequest event
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Delegate Sub AssociationRequestHandler( _
   ByVal Sender As Object, _
   ByVal e As AssociationRequestArgs _
)
    'Usage

    Dim instance As New AssociationRequestHandler(AddressOf HandlerMethod)
    public delegate void AssociationRequestHandler(
   object Sender,
   AssociationRequestArgs e
)

    Parameters

    Sender
    Sender as Object
    e
    e as AssociationRequestArgs
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    AssociationRequestHandler Members
    DicomObjects.Delegates Namespace


%%PageItemTitle%%

DicomObjects.Delegates Namespace / ChangeUidHandler Delegate

    ChangeUidHandler Delegate
    In This Topic
    Delegate for the DicomObjects.DicomGlobal.OnChangeUid event
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Delegate Sub ChangeUidHandler( _
   ByVal e As ChangeUidArgs _
)
    'Usage

    Dim instance As New ChangeUidHandler(AddressOf HandlerMethod)
    public delegate void ChangeUidHandler(
   ChangeUidArgs e
)

    Parameters

    e
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ChangeUidHandler Members
    DicomObjects.Delegates Namespace


%%PageItemTitle%%

DicomObjects.Delegates Namespace / DataChangedHandler Delegate
Sender as Object

In This Topic
    DataChangedHandler Delegate
    In This Topic
    Delegate for the DicomViewer's DataChanged event
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Delegate Sub DataChangedHandler( _
   ByVal Sender As Object _
)
    'Usage

    Dim instance As New DataChangedHandler(AddressOf HandlerMethod)
    public delegate void DataChangedHandler(
   object Sender
)

    Parameters

    Sender
    Sender as Object
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DataChangedHandler Members
    DicomObjects.Delegates Namespace


%%PageItemTitle%%

DicomObjects.Delegates Namespace / ErrorReceivedHandler Delegate
As Object
As ErrorReceivedArgs

In This Topic
    ErrorReceivedHandler Delegate
    In This Topic
    Delegate for the DicomObjects.DicomServer.ErrorReceived event
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Delegate Sub ErrorReceivedHandler( _
   ByVal Sender As Object, _
   ByVal e As ErrorReceivedArgs _
)
    'Usage

    Dim instance As New ErrorReceivedHandler(AddressOf HandlerMethod)
    public delegate void ErrorReceivedHandler(
   object Sender,
   ErrorReceivedArgs e
)

    Parameters

    Sender
    As Object
    e
    As ErrorReceivedArgs
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ErrorReceivedHandler Members
    DicomObjects.Delegates Namespace


%%PageItemTitle%%

DicomObjects.Delegates Namespace / GetUrlHandler Delegate
The DataSet to generate the URI for

In This Topic
    GetUrlHandler Delegate
    In This Topic
    Delegate for the GetUri event
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Delegate Function GetUrlHandler( _
   ByVal DataSet As DicomDataSet _
) As String
    'Usage

    Dim instance As New GetUrlHandler(AddressOf HandlerMethod)
    public delegate string GetUrlHandler(
   DicomDataSet DataSet
)

    Parameters

    DataSet
    The DataSet to generate the URI for

    Return Value

    The required Uri
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    GetUrlHandler Members
    DicomObjects.Delegates Namespace


%%PageItemTitle%%

DicomObjects.Delegates Namespace / InfoMessageHandler Delegate
Sender as Object
e as InfoMessageArgs

In This Topic
    InfoMessageHandler Delegate
    In This Topic
    Delegate for the DicomObjects.DicomServer.InfoMessage event
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Delegate Sub InfoMessageHandler( _
   ByVal Sender As Object, _
   ByVal e As InfoMessageArgs _
)
    'Usage

    Dim instance As New InfoMessageHandler(AddressOf HandlerMethod)
    public delegate void InfoMessageHandler(
   object Sender,
   InfoMessageArgs e
)

    Parameters

    Sender
    Sender as Object
    e
    e as InfoMessageArgs
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    InfoMessageHandler Members
    DicomObjects.Delegates Namespace


%%PageItemTitle%%

DicomObjects.Delegates Namespace / InstanceReceivedHandler Delegate
Sender as Object
e as InstanceReceivedArgs

In This Topic
    InstanceReceivedHandler Delegate
    In This Topic
    Delegate for the DicomObjects.DicomServer.InstanceReceived Event
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Delegate Sub InstanceReceivedHandler( _
   ByVal Sender As Object, _
   ByVal e As InstanceReceivedArgs _
)
    'Usage

    Dim instance As New InstanceReceivedHandler(AddressOf HandlerMethod)
    public delegate void InstanceReceivedHandler(
   object Sender,
   InstanceReceivedArgs e
)

    Parameters

    Sender
    Sender as Object
    e
    e as InstanceReceivedArgs
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    InstanceReceivedHandler Members
    DicomObjects.Delegates Namespace


%%PageItemTitle%%

DicomObjects.Delegates Namespace / LabelChangedHandler Delegate
Standard event Sender argument
The label which has changed

In This Topic
    LabelChangedHandler Delegate
    In This Topic
    Delegate for the DicomObjects.DicomLabel.LabelChanged event
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Delegate Sub LabelChangedHandler( _
   ByVal Sender As Object, _
   ByVal label As DicomLabel _
)
    'Usage

    Dim instance As New LabelChangedHandler(AddressOf HandlerMethod)
    public delegate void LabelChangedHandler(
   object Sender,
   DicomLabel label
)

    Parameters

    Sender
    Standard event Sender argument
    label
    The label which has changed
    Remarks
    If the Area property changes, then the rectangle passed as a parameter is the union of the old and new Areas.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    LabelChangedHandler Members
    DicomObjects.Delegates Namespace


%%PageItemTitle%%

DicomObjects.Delegates Namespace / LicenceExpirationHandler Delegate

In This Topic
    LicenceExpirationHandler Delegate
    In This Topic
    Delegate used by the LicenceExpirationHandler
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Delegate Sub LicenceExpirationHandler()
    'Usage

    Dim instance As New LicenceExpirationHandler(AddressOf HandlerMethod)
    public delegate void LicenceExpirationHandler()
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    LicenceExpirationHandler Members
    DicomObjects.Delegates Namespace


%%PageItemTitle%%

DicomObjects.Delegates Namespace / LicenceRetrieveHandler Delegate

In This Topic
    LicenceRetrieveHandler Delegate
    In This Topic
    Delegate for the DicomObjects.DicomLicence.LicenceRetrieve event
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Delegate Function LicenceRetrieveHandler() As String
    'Usage

    Dim instance As New LicenceRetrieveHandler(AddressOf HandlerMethod)
    public delegate string LicenceRetrieveHandler()

    Return Value

    A previously stored Licence string as passed via LicenceStore
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    LicenceRetrieveHandler Members
    DicomObjects.Delegates Namespace


%%PageItemTitle%%

DicomObjects.Delegates Namespace / LicenceStoredHandler Delegate
Token to store

In This Topic
    LicenceStoredHandler Delegate
    In This Topic
    Delegate for LicenceStore event
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Delegate Function LicenceStoredHandler( _
   ByVal licenceToken As String _
) As Boolean
    'Usage

    Dim instance As New LicenceStoredHandler(AddressOf HandlerMethod)
    public delegate bool LicenceStoredHandler(
   string licenceToken
)

    Parameters

    licenceToken
    Token to store

    Return Value

    True if the routine stores the licence key successfully
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    LicenceStoredHandler Members
    DicomObjects.Delegates Namespace


%%PageItemTitle%%

DicomObjects.Delegates Namespace / LogHandler Delegate
The event details

In This Topic
    LogHandler Delegate
    In This Topic
    Delegate for the LogEvent Event
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Delegate Sub LogHandler( _
   ByVal e As LogEventArgs _
)
    'Usage

    Dim instance As New LogHandler(AddressOf HandlerMethod)
    public delegate void LogHandler(
   LogEventArgs e
)

    Parameters

    e
    The event details
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    LogHandler Members
    DicomObjects.Delegates Namespace


%%PageItemTitle%%

DicomObjects.Delegates Namespace / N_Event_ReportHandler Delegate
The object triggering the event - in fact the DicomAssociation
The N_Event_ReportArgs class

In This Topic
    N_Event_ReportHandler Delegate
    In This Topic
    Delegate for the "N_Event_Report" events of a DicomObjects.DicomAssociation and DicomObjects.DicomServer
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Delegate Sub N_Event_ReportHandler( _
   ByVal Sender As Object, _
   ByVal e As N_Event_ReportArgs _
)
    'Usage

    Dim instance As New N_Event_ReportHandler(AddressOf HandlerMethod)
    public delegate void N_Event_ReportHandler(
   object Sender,
   N_Event_ReportArgs e
)

    Parameters

    Sender
    The object triggering the event - in fact the DicomAssociation
    e
    The N_Event_ReportArgs class
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    N_Event_ReportHandler Members
    DicomObjects.Delegates Namespace
    N_Event_Report Event
    N_Event_Report Event


%%PageItemTitle%%

DicomObjects.Delegates Namespace / NormalisedReceivedHandler Delegate
Sender as Object
e as NormalisedReceivedArgs

In This Topic
    NormalisedReceivedHandler Delegate
    In This Topic
    Delegate for the DicomObjects.DicomServer.NormalisedReceived event
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Delegate Sub NormalisedReceivedHandler( _
   ByVal Sender As Object, _
   ByVal e As NormalisedReceivedArgs _
)
    'Usage

    Dim instance As New NormalisedReceivedHandler(AddressOf HandlerMethod)
    public delegate void NormalisedReceivedHandler(
   object Sender,
   NormalisedReceivedArgs e
)

    Parameters

    Sender
    Sender as Object
    e
    e as NormalisedReceivedArgs
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    NormalisedReceivedHandler Members
    DicomObjects.Delegates Namespace


%%PageItemTitle%%

DicomObjects.Delegates Namespace / PositionChangedHandler Delegate
The object causing the change to happen
The Image which has changed

In This Topic
    PositionChangedHandler Delegate
    In This Topic
    Delegate for the DicomObjects.DicomImage.PositionChanged event
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Delegate Sub PositionChangedHandler( _
   ByVal Sender As Object, _
   ByVal Image As DicomImage _
)
    'Usage

    Dim instance As New PositionChangedHandler(AddressOf HandlerMethod)
    public delegate void PositionChangedHandler(
   object Sender,
   DicomImage Image
)

    Parameters

    Sender
    The object causing the change to happen
    Image
    The Image which has changed
    Remarks
    In practice, currently, Sender and Image are the same object.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    PositionChangedHandler Members
    DicomObjects.Delegates Namespace


%%PageItemTitle%%

DicomObjects.Delegates Namespace / PSLabelCreatedHandler Delegate
Event args that contains the label which has been created from Presentation State, the DICOM presentation state instance from which the label is created and the specific Presentation State Item for the label created

In This Topic
    PSLabelCreatedHandler Delegate
    In This Topic
    Delegate for the DicomObjects.DicomLabel.PSLabelCreated event
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Delegate Sub PSLabelCreatedHandler( _
   ByVal args As PSLabelCreatedArgs _
)
    'Usage

    Dim instance As New PSLabelCreatedHandler(AddressOf HandlerMethod)
    public delegate void PSLabelCreatedHandler(
   PSLabelCreatedArgs args
)

    Parameters

    args
    Event args that contains the label which has been created from Presentation State, the DICOM presentation state instance from which the label is created and the specific Presentation State Item for the label created
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    PSLabelCreatedHandler Members
    DicomObjects.Delegates Namespace


%%PageItemTitle%%

DicomObjects.Delegates Namespace / QueryReceivedHandler Delegate
Sender as Object
e as QueryReceivedArgs

In This Topic
    QueryReceivedHandler Delegate
    In This Topic
    Delegate for the DicomObjects.DicomServer.QueryReceived event
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Delegate Sub QueryReceivedHandler( _
   ByVal Sender As Object, _
   ByVal e As QueryReceivedArgs _
)
    'Usage

    Dim instance As New QueryReceivedHandler(AddressOf HandlerMethod)
    public delegate void QueryReceivedHandler(
   object Sender,
   QueryReceivedArgs e
)

    Parameters

    Sender
    Sender as Object
    e
    e as QueryReceivedArgs
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    QueryReceivedHandler Members
    DicomObjects.Delegates Namespace


%%PageItemTitle%%

DicomObjects.Delegates Namespace / ReceivingPixelDataHandler Delegate

In This Topic
    ReceivingPixelDataHandler Delegate
    In This Topic
    Delegate used by the DicomObjects.DicomServer.ReceivingPixelData event
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Delegate Sub ReceivingPixelDataHandler( _
   ByVal Sender As Object, _
   ByVal e As ReceivingPixelDataArgs _
)
    'Usage

    Dim instance As New ReceivingPixelDataHandler(AddressOf HandlerMethod)
    public delegate void ReceivingPixelDataHandler(
   object Sender,
   ReceivingPixelDataArgs e
)

    Parameters

    Sender
    e
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ReceivingPixelDataHandler Members
    DicomObjects.Delegates Namespace


%%PageItemTitle%%

DicomObjects.Delegates Namespace / ResponseReceivedHandler Delegate
The object (DicomObjects.DicomAssociation or DicomObjects.DicomQuery generating the event
The event details

In This Topic
    ResponseReceivedHandler Delegate
    In This Topic
    Delegate for the DicomObjects.DicomAssociation.ResponseReceived and ResponseReceived events
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Delegate Sub ResponseReceivedHandler( _
   ByVal Sender As Object, _
   ByVal e As ResponseReceivedArgs _
)
    'Usage

    Dim instance As New ResponseReceivedHandler(AddressOf HandlerMethod)
    public delegate void ResponseReceivedHandler(
   object Sender,
   ResponseReceivedArgs e
)

    Parameters

    Sender
    The object (DicomObjects.DicomAssociation or DicomObjects.DicomQuery generating the event
    e
    The event details
    Remarks
    This is used by the DicomObjects.DicomAssociation and DicomObjects.DicomQuery objects
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ResponseReceivedHandler Members
    DicomObjects.Delegates Namespace


%%PageItemTitle%%

DicomObjects.Delegates Namespace / StatusUpdateHandler Delegate
The DicomDataSet which has been updated
The PixelRequest which has caused the update to occur
The new status

In This Topic
    StatusUpdateHandler Delegate
    In This Topic
    Delegate for the DicomObjects.Codecs.Jpip.StatusUpdate event
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Delegate Sub StatusUpdateHandler( _
   ByVal DataSet As DicomDataSet, _
   ByVal Request As PixelRequest, _
   ByVal Status As ProgressiveStatus _
)
    'Usage

    Dim instance As New StatusUpdateHandler(AddressOf HandlerMethod)
    public delegate void StatusUpdateHandler(
   DicomDataSet DataSet,
   PixelRequest Request,
   ProgressiveStatus Status
)

    Parameters

    DataSet
    The DicomDataSet which has been updated
    Request
    The PixelRequest which has caused the update to occur
    Status
    The new status
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    StatusUpdateHandler Members
    DicomObjects.Delegates Namespace


%%PageItemTitle%%

DicomObjects.Delegates Namespace / TlsAcceptor Delegate
The encrypted stream over which unencrypted data will be sent and received
Remote IP address
The local port to which the remote entity has connected

In This Topic
    TlsAcceptor Delegate
    In This Topic
    Delegate used to accept TLS communications
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Delegate Function TlsAcceptor( _
   ByVal EncryptedStream As Stream, _
   ByVal RemoteAddress As String, _
   ByVal LocalPort As Integer _
) As Stream
    'Usage

    Dim instance As New TlsAcceptor(AddressOf HandlerMethod)
    public delegate Stream TlsAcceptor(
   Stream EncryptedStream,
   string RemoteAddress,
   int LocalPort
)

    Parameters

    EncryptedStream
    The encrypted stream over which unencrypted data will be sent and received
    RemoteAddress
    Remote IP address
    LocalPort
    The local port to which the remote entity has connected
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    TlsAcceptor Members
    DicomObjects.Delegates Namespace


%%PageItemTitle%%

DicomObjects.Delegates Namespace / TlsInitiator Delegate
The cleartext stream over which unencrypted data will be sent and received
Remote IP address
remote Port

In This Topic
    TlsInitiator Delegate
    In This Topic
    Delegate used to initiate TLS communications
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Delegate Function TlsInitiator( _
   ByVal ClearTextStream As Stream, _
   ByVal RemoteAddress As String, _
   ByVal RemotePort As Integer _
) As Stream
    'Usage

    Dim instance As New TlsInitiator(AddressOf HandlerMethod)
    public delegate Stream TlsInitiator(
   Stream ClearTextStream,
   string RemoteAddress,
   int RemotePort
)

    Parameters

    ClearTextStream
    The cleartext stream over which unencrypted data will be sent and received
    RemoteAddress
    Remote IP address
    RemotePort
    remote Port

    Return Value

    An encrypted stream following TLS negotiation
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    TlsInitiator Members
    DicomObjects.Delegates Namespace


%%PageItemTitle%%

DicomObjects.Delegates Namespace / VerifyReceivedHandler Delegate
Sender as Object
e as VerifyReceivedArgs

In This Topic
    VerifyReceivedHandler Delegate
    In This Topic
    Delegate for the DicomObjects.DicomServer.VerifyReceived event
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Delegate Sub VerifyReceivedHandler( _
   ByVal Sender As Object, _
   ByVal e As VerifyReceivedArgs _
)
    'Usage

    Dim instance As New VerifyReceivedHandler(AddressOf HandlerMethod)
    public delegate void VerifyReceivedHandler(
   object Sender,
   VerifyReceivedArgs e
)

    Parameters

    Sender
    Sender as Object
    e
    e as VerifyReceivedArgs
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    VerifyReceivedHandler Members
    DicomObjects.Delegates Namespace


Inheritance Hierarchy
    DicomObjects.Enums Namespace
    Enumerations
     | Enumeration | Description
Enumeration | AutoSizeMode | Possible values for controlling the size of a text label.
Enumeration | BasicOffsetTableHandling | Allows control of Basic Offset Table (BOT) Handling when writing data
Enumeration | CacheTypes | Flags which are used to control caching.
Enumeration | ChangeUidReason | reason why a UID should be changed
Enumeration | CodecOperation | The basic types of codec operation requested by DicomObjects
Enumeration | CodecUsage | Enum to control which available codec to use.
Enumeration | DecompressStatus | The state of decompression of an image
Enumeration | DicomOperation | The Full List of DICOM Primitive operations
Enumeration | DisplayMode | Controls how images are rendered
Enumeration | DrawCacheMode | Controls how images are drawn internally
Enumeration | FilterMode | Enumerated values for filter mode
Enumeration | FlipState | Enumerated values for flip mode
Enumeration | Keyword | The complete enumerated list of all DICOM data element. Enum representation can be used for adding and indexing data element in DicomDataSet object
Enumeration | LabelType | The possible types of DicomObjects.DicomLabel
Enumeration | LicencedFunctions | A bitmask representing the functions that a particular licence allows to be used by DicomObjects.
Enumeration | LicenceTypes | Indicates the basic type of DicomObjects licence
Enumeration | LogLevel | Log levels
Enumeration | MaskMode | Enumerated values for mask operations
Enumeration | Plane | Common planes used to display 3D images
Enumeration | PresentationStateFeatures | Flags to control which features of presentation states are used and/or converted
Enumeration | Progression | Ordering of packet used in JPEG 2000 & JPIP
Enumeration | ProgressiveStatus | The status of an image being viewed in a progressive manner
Enumeration | QueryLevel | Enumerated values for Query Level
Enumeration | QueryRoot | Enumerated values for Query Root
Enumeration | RequestType | Enum used in the DicomObjects.Internal.PixelRequest class to pecify the required usage of the data requested
Enumeration | RetrieveType | The type of retrieval requested
Enumeration | RotateState | Enumerated values for rotate mode
Enumeration | RotationBehaviour | Rotation behaviour of the Image
Enumeration | RotationCentre | Possible values for controlling the centre of rotation of a text label.
Enumeration | RotationMode | Possible values for controlling the rotation behaviour of a label.
Enumeration | RulerOptions | Ruler options to for alignment and spacing
Enumeration | ScaleMode | How DicomLabel objects' dimensions should be interpreted - i.e. how they should be scaled
Enumeration | SelectMode | Enumerated values for DicomLabel select mode
Enumeration | ShadowTypes | Controls whether a labels is displayed with a specified shadow, to make it more visible over image areas with similar color.
Enumeration | SOPClassGroups | The categories of SOP class used for negotiation
Enumeration | StatusCode | Common DICOM status codes
Enumeration | StatusType | DICOM status code type
Enumeration | StretchModes | Controls how an image is displayed
Enumeration | SubscribeTargetResource | UPS Subscribe Target Resource
Enumeration | UIDType | Classification of DICOM UID types
Enumeration | UPSState | Progress of a Unified Procedure Step (UPS)
Enumeration | UserIdentityResponseType | User Identity Response Type for User Identity Negotiation
Enumeration | UserIdentityType | User Identity Type for User Identity Negotiation
Enumeration | ViewerMode | The modes which can be used for rendering image
Enumeration | VoiLUTFunction | Controls which VOILUT function to be used
Enumeration | WaveletTransform | The types of wavelet transform used in JPEG 2000 & JPIP
Enumeration | WorkItemOperation | Indicates the type of transaction of incoming WorkItem Web reqeust
    See Also

    Reference

    DicomObjects.NetStandard Assembly


%%PageItemTitle%%

DicomObjects.Enums Namespace / AutoSizeMode Enumeration

    AutoSizeMode Enumeration
    In This Topic
    Possible values for controlling the size of a text label.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Enum AutoSizeMode
   Inherits System.Enum
    'Usage

    Dim instance As AutoSizeMode
    public enum AutoSizeMode : System.Enum
    Members
    Member | Description
Auto | Both the height and width are reduced to fit the size of the text displayed. The original width is still used to control the wrapping of the text
AutoSizeHeight | The original width, as defined by the label's Area is used, but the height is reduced to fit the size of the actual text displayed
AutoSizeWidth | The original height, as defined by the label's Area is used, but the width is reduced to fit the size of the actual text displayed
NoAutoSize | The original size, as defined by the label's Area is used.
    Remarks
    This is used by the DicomLabel's AutoSizeMode property. It is used to control both the drawing of a visible box around the text, and also used for the positioning of child labels and for rotation.
    Inheritance Hierarchy

    System.Object
    System.ValueType
    System.Enum
    DicomObjects.Enums.AutoSizeMode

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomObjects.Enums Namespace


%%PageItemTitle%%

DicomObjects.Enums Namespace / BasicOffsetTableHandling Enumeration

In This Topic
    BasicOffsetTableHandling Enumeration
    In This Topic
    Allows control of Basic Offset Table (BOT) Handling when writing data
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Enum BasicOffsetTableHandling
   Inherits System.Enum
    'Usage

    Dim instance As BasicOffsetTableHandling
    public enum BasicOffsetTableHandling : System.Enum
    Members
    Member | Description
CompressAndCache | Each frame is compressed and cached in memory, allowing the lengths to be calculated. The BOT is then written using those lengths, followed by the cached fragments themselves.
CompressTwice | Each frame is compressed allowing the lengths to be calculated, but the frames are discarded. The BOT is then written using those lengths, followed by the fragments themselves, which are generated by compressing the data a second time.
Omit | An empty (zero-length) BOT is written
Seek | The individual fragments are written, and the stream position is then moved back to the BOT to write the locations. This is the most efficient solution to producing a BOT, but is only applicable to seekable media and therefore cannot be used when performing C-STORE etc.
    Remarks
    This is used by the DicomObjects.WriteBehaviours.NonSeekableBotHandling and DicomObjects.WriteBehaviours.SeekableBotHandling properties.
    Inheritance Hierarchy

    System.Object
    System.ValueType
    System.Enum
    DicomObjects.Enums.BasicOffsetTableHandling

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomObjects.Enums Namespace


%%PageItemTitle%%

DicomObjects.Enums Namespace / CacheTypes Enumeration

    CacheTypes Enumeration
    In This Topic
    Flags which are used to control caching.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    <FlagsAttribute()>
Public Enum CacheTypes
   Inherits System.Enum
    'Usage

    Dim instance As CacheTypes
    [Flags()]
public enum CacheTypes : System.Enum
    Members
    Member | Description
All | All caches
CompressedData | Specifies the raw compressed pixel data (where it needs to be read from disk)
Display | Specifies the cached copy of the pixel display data
LookupTables | Specifies the lookup tables generated as a result of windowing etc.
None | No caching at all
PixelData | Specifies the raw uncompressed pixel data (where it needs to be decompressed or read from disk)
Texture | Specifies the GPU texture for the basic image data (before indowing etc.) in DirectX mode.
    Inheritance Hierarchy

    System.Object
    System.ValueType
    System.Enum
    DicomObjects.Enums.CacheTypes

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomObjects.Enums Namespace


%%PageItemTitle%%

DicomObjects.Enums Namespace / ChangeUidReason Enumeration

    ChangeUidReason Enumeration
    In This Topic
    reason why a UID should be changed
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Enum ChangeUidReason
   Inherits System.Enum
    'Usage

    Dim instance As ChangeUidReason
    public enum ChangeUidReason : System.Enum
    Members
    Member | Description
LossyCompression | Lossy image compression is being applied
SopClassCoersion | The SOP class is being coerced
    Inheritance Hierarchy

    System.Object
    System.ValueType
    System.Enum
    DicomObjects.Enums.ChangeUidReason

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomObjects.Enums Namespace


%%PageItemTitle%%

DicomObjects.Enums Namespace / CodecOperation Enumeration

    CodecOperation Enumeration
    In This Topic
    The basic types of codec operation requested by DicomObjects
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Enum CodecOperation
   Inherits System.Enum
    'Usage

    Dim instance As CodecOperation
    public enum CodecOperation : System.Enum
    Members
    Member | Description
Compress | Compression of DICOM images
Decompress | Decompression of DICOM compressed images
Export | Export of images to external files
Import | Import of images from external files
    Inheritance Hierarchy

    System.Object
    System.ValueType
    System.Enum
    DicomObjects.Enums.CodecOperation

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomObjects.Enums Namespace


%%PageItemTitle%%

DicomObjects.Enums Namespace / CodecUsage Enumeration

    CodecUsage Enumeration
    In This Topic
    Enum to control which available codec to use.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Enum CodecUsage
   Inherits System.Enum
    'Usage

    Dim instance As CodecUsage
    public enum CodecUsage : System.Enum
    Members
    Member | Description
DicomObjects | Use DicomObjects codec
SkiaSharp | Use SkiaSharp codec
    Inheritance Hierarchy

    System.Object
    System.ValueType
    System.Enum
    DicomObjects.Enums.CodecUsage

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomObjects.Enums Namespace


%%PageItemTitle%%

DicomObjects.Enums Namespace / DecompressStatus Enumeration

    DecompressStatus Enumeration
    In This Topic
    The state of decompression of an image
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Enum DecompressStatus
   Inherits System.Enum
    'Usage

    Dim instance As DecompressStatus
    public enum DecompressStatus : System.Enum
    Members
    Member | Description
AllDownloaded | All data downloaded has been decompressed
Complete | The image has been fully decompressed at full resolution
InProgress | Data is waiting to be decompressed
None | Nothing decompressed yet
    Remarks
    This status is normally relative to a particular DicomObjects.Internal.PixelRequest
    Inheritance Hierarchy

    System.Object
    System.ValueType
    System.Enum
    DicomObjects.Enums.DecompressStatus

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomObjects.Enums Namespace


%%PageItemTitle%%

DicomObjects.Enums Namespace / DicomOperation Enumeration

    DicomOperation Enumeration
    In This Topic
    The Full List of DICOM Primitive operations
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Enum DicomOperation
   Inherits System.Enum
    'Usage

    Dim instance As DicomOperation
    public enum DicomOperation : System.Enum
    Members
    Member | Description
C_CANCEL | C-CANCEL : 0FFFH
C_ECHO | C-ECHO : 0030H
C_ECHO_RSP | C-ECHO Response : 8030H
C_FIND | C-FIND : 0020H
C_FIND_RSP | C-FIND Response : 8020H
C_GET | C-GET : 0010H
C_GET_RSP | C-GET Response : 8010H
C_MOVE | C-MOVE : 0021H
C_MOVE_RSP | C-MOVE Response : 8021H
C_STORE | C-STORE : 0001H
C_STORE_RSP | C-STORE Response : 8001H
N_ACTION | N-ACTION : 0130H
N_ACTION_RSP | N-ACTION Response : 8130H
N_CREATE | N-CREATE : 0140H
N_CREATE_RSP | N-CREATE Response : 8140H
N_DELETE | N-DELETE : 0150H
N_DELETE_RSP | N-DELETE Response : 8150H
N_EVENT_REPORT | N-EVENT_REPORT : 0100H
N_EVENT_REPORT_RSP | N-EVENT_REPORT Response : 8100H
N_GET | N-GET : 0110H
N_GET_RSP | N-GET Response : 8110H
N_SET | N-SET : 0120H
N_SET_RSP | N-SET Response : 8120H
NONE | No Operation
    Inheritance Hierarchy

    System.Object
    System.ValueType
    System.Enum
    DicomObjects.Enums.DicomOperation

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomObjects.Enums Namespace


%%PageItemTitle%%

DicomObjects.Enums Namespace / DisplayMode Enumeration

    DisplayMode Enumeration
    In This Topic
    Controls how images are rendered
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Enum DisplayMode
   Inherits System.Enum
    'Usage

    Dim instance As DisplayMode
    public enum DisplayMode : System.Enum
    Members
    Member | Description
Auto | Use Monochome if the image is monochrom and RGB is the image is colour
Monochrome | Force use of monochrome mode
RGB | Force use of RGB mode
    Remarks
    Although public, this is an experimental enum intended for performance tuning experiments and may not be supported in future versions of DicomObjects
    Inheritance Hierarchy

    System.Object
    System.ValueType
    System.Enum
    DicomObjects.Enums.DisplayMode

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomObjects.Enums Namespace


%%PageItemTitle%%

DicomObjects.Enums Namespace / DrawCacheMode Enumeration

    DrawCacheMode Enumeration
    In This Topic
    Controls how images are drawn internally
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Enum DrawCacheMode
   Inherits System.Enum
    'Usage

    Dim instance As DrawCacheMode
    public enum DrawCacheMode : System.Enum
    Members
    Member | Description
AfterLabels | Rendered copy has labelled added and is then cached. If this mode is used, then the cache is cleared when labels change. This mode is incompatible with DisplayMode.Monochrome as .NET des not permit use of a monochrome bitmap as a Graphics object. The mode will silently revert to BeforeLabels if DisplayMode is monochrome, or if it is Auto on a monochrome image.
BeforeLabels | Rendered copy is cached, and then drawn to the screen. Labels are drawn separately to the screen.
    Inheritance Hierarchy

    System.Object
    System.ValueType
    System.Enum
    DicomObjects.Enums.DrawCacheMode

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomObjects.Enums Namespace


%%PageItemTitle%%

DicomObjects.Enums Namespace / FilterMode Enumeration

    FilterMode Enumeration
    In This Topic
    Enumerated values for filter mode
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Enum FilterMode
   Inherits System.Enum
    'Usage

    Dim instance As FilterMode
    public enum FilterMode : System.Enum
    Members
    Member | Description
BiLinear | This mode is most applicable when zoom is >1, and uses bilinear interpolation. This is a simple and relatively fast means of magnification.
BSpline | This smoothing procedure interpolates using a Cubic B-Spline, which has the advantage of guaranteeing continuity in both the first and second differentials of the image, in both directions. No other parameters are used in this smoothing method, which produces good visual results, though some users find them a little too "smoothed"
BSpline2 | Custom format
CubicSpline | This is similar to the B-Spline described above, but uses an additional parameter (CubicSplineAlpha) to control the degree of smoothing or edge enhancement. The default value is –0.75, and normal values range fro –0.5 to –1.25, though higher negative values may be used to produce deliberate edge enhancement, though generally, UnsharpLength and UnsharpEnhancement should be used for this purpose, as they are independent of the smoothing method.
Default | For MagnificationMode, this acts identically to doFilterReplicate and for MinificationMode it acts as doFilterMovingAverage. This behaviour is the default, and is designed to minimise regulatory issues by doing the minimum necessary to display all pixel data, without adding extra "Image processing".
Gpu | This mode uses interpolation in the GPU to apply magnification or minification. It does not give as much flexibility as the other modes, but may be significant faster, whilst still avoiding a "blocky" effect for magnification and avoiding aliasing on grid-lines for minification.
MovingAverage | This mode is most applicable when zoom is <1, and calculates pixel values as a weighted average of the surrounding values. The number of values used for this calculation depends on the value of FilterLength. If this is 0 (the default), then a suitable values is determined internally, based on the zoom (approximately 2/ActualZoom), but if FilterLength is non-zero then 2*FilterLength values are used.
Replicate | If zooming up is necessary, then pixels are simply replicated, giving a possibly "blocky" but honest representation of the pixel data. For minification, rows and columns are simply omitted as necessary.
    Inheritance Hierarchy

    System.Object
    System.ValueType
    System.Enum
    DicomObjects.Enums.FilterMode

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomObjects.Enums Namespace


%%PageItemTitle%%

DicomObjects.Enums Namespace / FlipState Enumeration

    FlipState Enumeration
    In This Topic
    Enumerated values for flip mode
    Syntax
    • Visual Basic
    • C#
    'Declaration

    <FlagsAttribute()>
Public Enum FlipState
   Inherits System.Enum
    'Usage

    Dim instance As FlipState
    [Flags()]
public enum FlipState : System.Enum
    Members
    Member | Description
Both | Image is mirrored vertically and horizontally
Horizontal | Image is mirrored horizontally
Normal | No flipping specified
Vertical | Image is mirrored vertically
    Inheritance Hierarchy

    System.Object
    System.ValueType
    System.Enum
    DicomObjects.Enums.FlipState

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomObjects.Enums Namespace


%%PageItemTitle%%

DicomObjects.Enums Namespace / Keyword Enumeration

    Keyword Enumeration
    In This Topic
    The complete enumerated list of all DICOM data element. Enum representation can be used for adding and indexing data element in DicomDataSet object
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Enum Keyword
   Inherits System.Enum
    'Usage

    Dim instance As Keyword
    public enum Keyword : System.Enum
    Members
    Member | Description
AbortFlag | (4010,1024): Abort Flag
AbortReason | (4010,1021): Abort Reason
AbsoluteChannelDisplayScale | (003A,0248): Absolute Channel Display Scale
AbsoluteDosimetricObjectiveFlag | (3010,0073): Absolute Dosimetric Objective Flag
AbsorbedDoseToMetersetRatio | (300C,0121): Absorbed Dose to Meterset Ratio
AbstractPriorCodeSequence | (0072,003E): Abstract Prior Code Sequence
AbstractPriorValue | (0072,003C): Abstract Prior Value
Acceleration | (0016,0034): Acceleration
AccessionNumber | (0008,0050): Accession Number
AccessoryCode | (300A,00F9): Accessory Code
AcousticCouplingMediumCodeSequence | (0018,982A): Acoustic Coupling Medium Code Sequence
AcousticCouplingMediumFlag | (0018,9829): Acoustic Coupling Medium Flag
AcousticCouplingMediumSoundSpeed | (0018,9834): Acoustic Coupling Medium Sound Speed
AcousticCouplingMediumTemperature | (0018,982B): Acoustic Coupling Medium Temperature
AcquiredImageAreaDoseProduct | (0018,9473): Acquired Image Area Dose Product
AcquiredSoundpathLength | (0014,4031): Acquired Soundpath Length
AcquiredSubtractionMaskFlag | (0018,11B2): Acquired Subtraction Mask Flag
AcquisitionComments | (0018,4000): Acquisition Comments(Retired)
AcquisitionCompressionType | (0014,4032): Acquisition Compression Type
AcquisitionContextDescription | (0040,0556): Acquisition Context Description
AcquisitionContextSequence | (0040,0555): Acquisition Context Sequence
AcquisitionContrast | (0008,9209): Acquisition Contrast
AcquisitionDate | (0008,0022): Acquisition Date
AcquisitionDateTime | (0008,002A): Acquisition DateTime
AcquisitionDeviceProcessingCode | (0018,1401): Acquisition Device Processing Code
AcquisitionDeviceProcessingDescription | (0018,1400): Acquisition Device Processing Description
AcquisitionDeviceSequence | (3002,0117): Acquisition Device Sequence
AcquisitionDeviceTypeCodeSequence | (0022,0015): Acquisition Device Type Code Sequence
AcquisitionDuration | (0018,9073): Acquisition Duration
AcquisitionEndLocationSequence | (0018,9932): Acquisition End Location Sequence
AcquisitionFieldOfViewLabel | (0018,11BB): Acquisition Field of View Label
AcquisitionIndex | (0020,9518): Acquisition Index
AcquisitionInitiationSequence | (3002,0135): Acquisition Initiation Sequence
AcquisitionMatrix | (0018,1310): Acquisition Matrix
AcquisitionMethod | (3002,012A): Acquisition Method
AcquisitionMethodAlgorithmSequence | (0022,1423): Acquisition Method Algorithm Sequence
AcquisitionMethodCodeSequence | (0022,1420): Acquisition Method Code Sequence
AcquisitionMode | (0018,11B0): Acquisition Mode
AcquisitionMotion | (0018,9930): Acquisition Motion
AcquisitionNumber | (0020,0012): Acquisition Number
AcquisitionProtocolDescription | (0018,9424): Acquisition Protocol Description
AcquisitionProtocolElementSequence | (0018,9920): Acquisition Protocol Element Sequence
AcquisitionProtocolElementSpecificationSequence | (0018,991F): Acquisition Protocol Element Specification Sequence
AcquisitionProtocolName | (0018,9423): Acquisition Protocol Name
AcquisitionSampleSize | (0014,4033): Acquisition Sample Size
AcquisitionSignalType | (3002,0129): Acquisition Signal Type
AcquisitionsInSeries | (0020,1001): Acquisitions in Series(Retired)
AcquisitionsInStudy | (0020,1004): Acquisitions in Study
AcquisitionStartCondition | (0018,0073): Acquisition Start Condition
AcquisitionStartConditionData | (0018,0074): Acquisition Start Condition Data
AcquisitionStartLocationSequence | (0018,9931): Acquisition Start Location Sequence
AcquisitionStatus | (4010,1044): Acquisition Status
AcquisitionSubtaskIndex | (3002,011D): Acquisition Subtask Index
AcquisitionSubtaskSequence | (3002,011A): Acquisition Subtask Sequence
AcquisitionTaskApplicabilitySequence | (3002,0124): Acquisition Task Applicability Sequence
AcquisitionTaskIndex | (3002,011C): Acquisition Task Index
AcquisitionTaskSequence | (3002,0118): Acquisition Task Sequence
AcquisitionTaskWorkitemCodeSequence | (3002,0119): Acquisition Task Workitem Code Sequence
AcquisitionTerminationCondition | (0018,0071): Acquisition Termination Condition
AcquisitionTerminationConditionData | (0018,0075): Acquisition Termination Condition Data
AcquisitionTime | (0008,0032): Acquisition Time
AcquisitionTimeSynchronized | (0018,1800): Acquisition Time Synchronized
AcquisitionType | (0018,9302): Acquisition Type
AcquisitionUID | (0008,0017): Acquisition UID
AcrossScanSpatialResolution | (0022,0048): Across-scan Spatial Resolution
ActionTypeID | (0000,1008): Action Type ID
ActiveAperture | (0014,5100): Active Aperture
ActiveImageAreaOverlayGroup | (0018,6070): Active Image Area Overlay Group
ActiveSourceDiameter | (300A,0218): Active Source Diameter
ActiveSourceLength | (300A,021A): Active Source Length
ActualCardiacTriggerDelayTime | (0020,9252): Actual Cardiac Trigger Delay Time
ActualCardiacTriggerTimePriorToRPeak | (0020,9155): Actual Cardiac Trigger Time Prior To R-Peak
ActualEnvironmentalConditions | (0014,1010): Actual Environmental Conditions
ActualFrameDuration | (0018,1242): Actual Frame Duration
ActualHumanPerformersSequence | (0040,4035): Actual Human Performers Sequence
ActualRespiratoryTriggerDelayTime | (0020,9257): Actual Respiratory Trigger Delay Time
AdaptiveMapFormat | (0028,0730): Adaptive Map Format
AddGrayScale | (0000,5150): Add Gray Scale(Retired)
AddIntermediateSequence | (0046,0101): Add Intermediate Sequence
AdditionalDrugSequence | (0018,002A): Additional Drug Sequence
AdditionalInspectionMethodSequence | (4010,106F): Additional Inspection Method Sequence
AdditionalInspectionSelectionCriteria | (4010,106E): Additional Inspection Selection Criteria
AdditionalParameterRecordingInstanceSequence | (300A,0780): Additional Parameter Recording Instance Sequence
AdditionalPatientHistory | (0010,21B0): Additional Patient History
AdditionalRTAccessoryDeviceSequence | (3002,0130): Additional RT Accessory Device Sequence
AdditionalRTROIIdentificationCodeSequence | (3006,00B9): Additional RT ROI Identification Code Sequence
AdditionalScreeningPerformed | (4010,106D): Additional Screening Performed
AddNearSequence | (0046,0100): Add Near Sequence
AddOtherSequence | (0046,0102): Add Other Sequence
AddPower | (0046,0104): Add Power
AddressTrial | (0040,A353): Address (Trial)
AdministrationRouteCodeSequence | (0054,0302): Administration Route Code Sequence
AdmissionID | (0038,0010): Admission ID
AdmittingDate | (0038,0020): Admitting Date
AdmittingDiagnosesCodeSequence | (0008,1084): Admitting Diagnoses Code Sequence
AdmittingDiagnosesDescription | (0008,1080): Admitting Diagnoses Description
AdmittingTime | (0038,0021): Admitting Time
AdvancedBlendingSequence | (0070,1B01): Advanced Blending Sequence
AffectedSOPClassUID | (0000,0002): Affected SOP Class UID
AffectedSOPInstanceUID | (0000,1000): Affected SOP Instance UID
AfterloaderChannelID | (300A,0273): Afterloader Channel ID
AgeCorrectedSensitivityDeviationAlgorithmSequence | (0024,0065): Age Corrected Sensitivity Deviation Algorithm Sequence
AgeCorrectedSensitivityDeviationProbabilityValue | (0024,0100): Age Corrected Sensitivity Deviation Probability Value
AgeCorrectedSensitivityDeviationValue | (0024,0092): Age Corrected Sensitivity Deviation Value
AirCounts | (0014,3070): Air Counts
AITDeviceType | (4010,1070): AIT Device Type
AlarmDecision | (4010,1031): Alarm Decision
AlarmDecisionTime | (4010,102B): Alarm Decision Time
AlgorithmCodeSequenceTrial | (0040,A296): Algorithm Code Sequence (Trial)
AlgorithmDescription | (0018,9528): Algorithm Description
AlgorithmDescriptionTrial | (0040,A297): Algorithm Description (Trial)
AlgorithmFamilyCodeSequence | (0066,002F): Algorithm Family Code Sequence
AlgorithmName | (0066,0036): Algorithm Name
AlgorithmNameCodeSequence | (0066,0030): Algorithm Name Code Sequence
AlgorithmParameters | (0066,0032): Algorithm Parameters
AlgorithmRoutingCodeSequence | (4010,1064): Algorithm Routing Code Sequence
AlgorithmSource | (0024,0202): Algorithm Source
AlgorithmType | (0018,9527): Algorithm Type
AlgorithmVersion | (0066,0031): Algorithm Version
AliasedDataType | (0018,980B): Aliased Data Type
ALinePixelSpacing | (0052,0014): A-line Pixel Spacing
ALineRate | (0052,0011): A-line Rate
ALinesPerFrame | (0052,0012): A-lines Per Frame
Allergies | (0010,2110): Allergies
AllowLossyCompression | (2200,000F): Allow Lossy Compression
AllowMediaSplitting | (2200,0007): Allow Media Splitting
AlongScanSpatialResolution | (0022,0037): Along-scan Spatial Resolution
AlphaLUTTransferFunction | (0028,1410): Alpha LUT Transfer Function
AlphaPaletteColorLookupTableData | (0028,1204): Alpha Palette Color Lookup Table Data
AlphaPaletteColorLookupTableDescriptor | (0028,1104): Alpha Palette Color Lookup Table Descriptor
AlternateBeamDose | (300A,0091): Alternate Beam Dose
AlternateBeamDoseType | (300A,0092): Alternate Beam Dose Type
AlternateContainerIdentifierSequence | (0040,0515): Alternate Container Identifier Sequence
AlternateContentDescriptionSequence | (0070,0087): Alternate Content Description Sequence
AlternateRepresentationSequence | (0008,3001): Alternate Representation Sequence
AlternateValueSequence | (300A,073E): Alternate Value Sequence
AmbientLightValueSource | (0028,7025): Ambient Light Value Source
AmbientReflectionIntensity | (0070,1702): Ambient Reflection Intensity
AmplifierType | (0014,400A): Amplifier Type
AnalogFilterCharacteristicsSequence | (003A,0323): Analog Filter Characteristics Sequence
AnalogFilterRollOff | (003A,0324): Analog Filter Roll Off
AnalogFilterType | (003A,0325): Analog Filter Type Code Sequence
AnalyzedArea | (0046,0227): Analyzed Area
AnatomicalOrientationType | (0010,2210): Anatomical Orientation Type
AnatomicApproachDirectionCodeSequenceTrial | (0008,2255): Anatomic Approach Direction Code Sequence (Trial)
AnatomicLocationOfExaminingInstrumentCodeSequenceTrial | (0008,2259): Anatomic Location Of Examining Instrument Code Sequence (Trial)
AnatomicLocationOfExaminingInstrumentDescriptionTrial | (0008,2258): Anatomic Location Of Examining Instrument Description (Trial)
AnatomicPerspectiveCodeSequenceTrial | (0008,2257): Anatomic Perspective Code Sequence (Trial)
AnatomicPerspectiveDescriptionTrial | (0008,2256): Anatomic Perspective Description (Trial)
AnatomicPortalOfEntranceCodeSequenceTrial | (0008,2253): Anatomic Portal Of Entrance Code Sequence (Trial)
AnatomicRegionModifierSequence | (0008,2220): Anatomic Region Modifier Sequence
AnatomicRegionSequence | (0008,2218): Anatomic Region Sequence
AnatomicRegionsInStudyCodeSequence | (0008,0063): Anatomic Regions in Study Code Sequence
AnatomicStructure | (0008,2208): Anatomic Structure
AnatomicStructureReferencePoint | (0022,1463): Anatomic Structure Reference Point
AnatomicStructureSpaceOrRegionCodeSequenceTrial | (0008,2251): Anatomic Structure Space Or Region Code Sequence (Trial)
AnatomicStructureSpaceOrRegionModifierCodeSequenceTrial | (0008,225A): Anatomic Structure Space Or Region Modifier Code Sequence (Trial)
AnatomicStructureSpaceOrRegionSequence | (0008,2229): Anatomic Structure, Space or Region Sequence
AnchorPoint | (0070,0014): Anchor Point
AnchorPointAnnotationUnits | (0070,0004): Anchor Point Annotation Units
AnchorPointVisibility | (0070,0015): Anchor Point Visibility
AngioFlag | (0018,0025): Angio Flag
AngleNumber | (0020,0018): Angle Number
AngularPosition | (0018,1141): Angular Position
AngularStep | (0018,1144): Angular Step
AngularViewVector | (0054,0090): Angular View Vector
AnimationCurveSequence | (0070,1A04): Animation Curve Sequence
AnimationStepSize | (0070,1A05): Animation Step Size
AnnotationAppliesToAllOpticalPaths | (006A,000D): Annotation Applies to All Optical Paths
AnnotationAppliesToAllZPlanes | (006A,000F): Annotation Applies to All Z Planes
AnnotationClipping | (0070,1907): Annotation Clipping
AnnotationContentSequence | (2130,0050): Annotation Content Sequence
AnnotationCoordinateType | (006A,0001): Annotation Coordinate Type
AnnotationDisplayFormatID | (2010,0030): Annotation Display Format ID
AnnotationFlag | (2000,0065): Annotation Flag
AnnotationGroupAlgorithmIdentificationSequence | (006A,0008): Annotation Group Algorithm Identification Sequence
AnnotationGroupDescription | (006A,0006): Annotation Group Description
AnnotationGroupGenerationType | (006A,0007): Annotation Group Generation Type
AnnotationGroupLabel | (006A,0005): Annotation Group Label
AnnotationGroupNumber | (0040,A180): Annotation Group Number
AnnotationGroupSequence | (006A,0002): Annotation Group Sequence
AnnotationGroupUID | (006A,0003): Annotation Group UID
AnnotationIndexList | (006A,0011): Annotation Index List
AnnotationPosition | (2030,0010): Annotation Position
AnnotationPropertyCategoryCodeSequence | (006A,0009): Annotation Property Category Code Sequence
AnnotationPropertyTypeCodeSequence | (006A,000A): Annotation Property Type Code Sequence
AnnotationPropertyTypeModifierCodeSequence | (006A,000B): Annotation Property Type Modifier Code Sequence
AnodeTargetMaterial | (0018,1191): Anode Target Material
AnomalyLocatorIndicator | (4010,107A): Anomaly Locator Indicator
AnomalyLocatorIndicatorSequence | (4010,1079): Anomaly Locator Indicator Sequence
AnteriorChamberDepth | (0022,1131): Anterior Chamber Depth
AnteriorChamberDepthDefinitionCodeSequence | (0022,1125): Anterior Chamber Depth Definition Code Sequence
AnteriorChamberDepthSequence | (0022,1128): Anterior Chamber Depth Sequence
ApertureElevation | (0014,5102): Aperture Elevation
ApertureValue | (0016,0022): Aperture Value
ApexPosition | (0020,9308): Apex Position
ApplicableFrameRange | (0028,6102): Applicable Frame Range
ApplicableSafetyStandardAgency | (0018,9174): Applicable Safety Standard Agency
ApplicableSafetyStandardDescription | (0018,9175): Applicable Safety Standard Description
ApplicationManufacturer | (0018,9526): Application Manufacturer
ApplicationMaximumRepaintTime | (0072,010E): Application Maximum Repaint Time
ApplicationName | (0018,9524): Application Name
ApplicationSetupCheck | (3008,0116): Application Setup Check
ApplicationSetupManufacturer | (300A,0238): Application Setup Manufacturer
ApplicationSetupName | (300A,0236): Application Setup Name
ApplicationSetupNumber | (300A,0234): Application Setup Number
ApplicationSetupSequence | (300A,0230): Application Setup Sequence
ApplicationSetupType | (300A,0232): Application Setup Type
ApplicationVersion | (0018,9525): Application Version
ApplicatorApertureShape | (300A,0432): Applicator Aperture Shape
ApplicatorDescription | (300A,010A): Applicator Description
ApplicatorGeometrySequence | (300A,0431): Applicator Geometry Sequence
ApplicatorID | (300A,0108): Applicator ID
ApplicatorOpening | (300A,0433): Applicator Opening
ApplicatorOpeningX | (300A,0434): Applicator Opening X
ApplicatorOpeningY | (300A,0435): Applicator Opening Y
ApplicatorSequence | (300A,0107): Applicator Sequence
ApplicatorShapeReferencedROINumber | (300A,02A1): Applicator Shape Referenced ROI Number
ApplicatorType | (300A,0109): Applicator Type
AppliedMaskSubtractionFlag | (0018,11C0): Applied Mask Subtraction Flag
ApprovalSequence | (0044,0100): Approval Sequence
ApprovalStatus | (300E,0002): Approval Status
ApprovalStatusDateTime | (0044,0004): Approval Status DateTime
ApprovalStatusFurtherDescription | (0044,0003): Approval Status Further Description
ApprovalSubjectSequence | (0044,0109): Approval Subject Sequence
Arbitrary | (4000,0010): Arbitrary(Retired)
ArchiveRequested | (0040,A494): Archive Requested
ArterialSpinLabelingContrast | (0018,9250): Arterial Spin Labeling Contrast
AscanRate | (0022,1649): A-scan Rate
ASLBolusCutoffDelayTime | (0018,925F): ASL Bolus Cut-off Delay Time
ASLBolusCutoffFlag | (0018,925C): ASL Bolus Cut-off Flag
ASLBolusCutoffTechnique | (0018,925E): ASL Bolus Cut-off Technique
ASLBolusCutoffTimingSequence | (0018,925D): ASL Bolus Cut-off Timing Sequence
ASLContext | (0018,9257): ASL Context
ASLCrusherDescription | (0018,925B): ASL Crusher Description
ASLCrusherFlag | (0018,9259): ASL Crusher Flag
ASLCrusherFlowLimit | (0018,925A): ASL Crusher Flow Limit
ASLMidSlabPosition | (0018,9256): ASL Mid Slab Position
ASLPulseTrainDuration | (0018,9258): ASL Pulse Train Duration
ASLSlabNumber | (0018,9253): ASL Slab Number
ASLSlabOrientation | (0018,9255): ASL Slab Orientation
ASLSlabSequence | (0018,9260): ASL Slab Sequence
ASLSlabThickness | (0018,9254): ASL Slab Thickness
ASLTechniqueDescription | (0018,9252): ASL Technique Description
AsserterIdentificationSequence | (0044,0103): Asserter Identification Sequence
AssertionCodeSequence | (0044,0101): Assertion Code Sequence
AssertionComments | (0044,0106): Assertion Comments
AssertionDateTime | (0044,0104): Assertion DateTime
AssertionExpirationDateTime | (0044,0105): Assertion Expiration DateTime
AssertionUID | (0044,0102): Assertion UID
AssessedAttributeValueSequence | (0082,0010): Assessed Attribute Value Sequence
AssessedSOPInstanceSequence | (0082,0004): Assessed SOP Instance Sequence
AssessmentLabel | (0082,0023): Assessment Label
AssessmentObservationsSequence | (0082,0007): Assessment Observations Sequence
AssessmentRequesterSequence | (0082,0017): Assessment Requester Sequence
AssessmentSetID | (0082,0016): Assessment Set ID
AssessmentSummary | (0082,0001): Assessment Summary
AssessmentSummaryDescription | (0082,0003): Assessment Summary Description
AssessmentTypeCodeSequence | (0082,0021): Assessment Type Code Sequence
AssignedLocation | (4010,102A): Assigned Location
AssigningAgencyOrDepartmentCodeSequence | (0040,003A): Assigning Agency or Department Code Sequence
AssigningFacilitySequence | (0040,0036): Assigning Facility Sequence
AssigningJurisdictionCodeSequence | (0040,0039): Assigning Jurisdiction Code Sequence
ATDAbilityAssessment | (4010,1014): ATD Ability Assessment
ATDAssessmentFlag | (4010,1015): ATD Assessment Flag
ATDAssessmentProbability | (4010,1016): ATD Assessment Probability
ATDAssessmentSequence | (4010,1038): ATD Assessment Sequence
AttachedContours | (3006,0049): Attached Contours
AttenuationCorrected | (0018,9759): Attenuation Corrected
AttenuationCorrectionMethod | (0054,1101): Attenuation Correction Method
AttenuationCorrectionSource | (0018,9738): Attenuation Correction Source
AttenuationCorrectionTemporalRelationship | (0018,9770): Attenuation Correction Temporal Relationship
AttributeIdentifierList | (0000,1005): Attribute Identifier List
AttributeItemSelector | (0074,1054): Attribute Item Selector
AttributeModificationDateTime | (0400,0562): Attribute Modification DateTime
AttributeOccurrencePointer | (0074,1052): Attribute Occurrence Pointer
AttributeOccurrencePrivateCreator | (0074,1056): Attribute Occurrence Private Creator
AttributeOccurrenceSequence | (0074,1050): Attribute Occurrence Sequence
AttributeToleranceValuesSequence | (300A,062B): Attribute Tolerance Values Sequence
AudioComments | (50xx,200E): Audio Comments
AudioSampleData | (50xx,200C): Audio Sample Data
AudioSampleFormat | (50xx,2002): Audio Sample Format
AudioType | (50xx,2000): Audio Type
AuthorIdentificationSequence | (3010,0019): Author Identification Sequence
AuthorizationEquipmentCertificationNumber | (0100,0426): Authorization Equipment Certification Number
AuthorObserverSequence | (0040,A078): Author Observer Sequence
AutoKVPLowerBound | (0018,9946): Auto KVP Lower Bound
AutoKVPSelectionType | (0018,9944): Auto KVP Selection Type
AutoKVPUpperBound | (0018,9945): Auto KVP Upper Bound
AutorefractionLeftEyeSequence | (0046,0052): Autorefraction Left Eye Sequence
AutorefractionRightEyeSequence | (0046,0050): Autorefraction Right Eye Sequence
AutosequenceFlag | (0074,1025): Autosequence Flag
AvailableTransferSyntaxUID | (0008,3002): Available Transfer Syntax UID
AverageBeamDosePointDepth | (300A,008D): Average Beam Dose Point Depth
AverageBeamDosePointEquivalentDepth | (300A,008E): Average Beam Dose Point Equivalent Depth
AverageBeamDosePointSourceToExternalContourDistance | (300A,0131): Average Beam Dose Point Source to External Contour Distance
AverageBeamDosePointSSD | (300A,008F): Average Beam Dose Point SSD
AverageCornealPower | (0046,0220): Average Corneal Power
AveragePulseWidth | (0018,1154): Average Pulse Width
AxialAcceptance | (0054,1200): Axial Acceptance
AxialDetectorDimension | (0018,9727): Axial Detector Dimension
AxialLengthOfTheEye | (0022,0030): Axial Length of the Eye
AxialMash | (0054,1201): Axial Mash
AxialPower | (0046,0249): Axial Power
AxialResolution | (0052,0008): Axial Resolution
AxisLabels | (50xx,0040): Axis Labels
AxisOfRotation | (0066,001B): Axis of Rotation
AxisUnits | (50xx,0030): Axis Units
B1rms | (0018,1320): B1rms
BackgroundColor | (0046,0092): Background Color
BackgroundIlluminationColorCodeSequence | (0024,0024): Background Illumination Color Code Sequence
BackgroundLuminance | (0024,0020): Background Luminance
BadPixelImage | (0014,3080): Bad Pixel Image
BarcodeSymbology | (2200,0006): Barcode Symbology
BarcodeValue | (2200,0005): Barcode Value
BaselineCorrection | (0018,9067): Baseline Correction
BasicColorImageSequence | (2020,0111): Basic Color Image Sequence
BasicGrayscaleImageSequence | (2020,0110): Basic Grayscale Image Sequence
BasisMaterialsCodeSequence | (4010,1045): Basis Materials Code Sequence
BasisRTTreatmentPhaseIndex | (3010,003E): Basis RT Treatment Phase Index
BatteryLevel | (0016,0003): Battery Level
BeamAngle | (0018,9449): Beam Angle
BeamAreaLimitSequence | (300A,0689): Beam Area Limit Sequence
BeamCurrentModulationID | (300A,034C): Beam Current Modulation ID
BeamDeliveryDurationLimit | (300A,00C5): Beam Delivery Duration Limit
BeamDescription | (300A,00C3): Beam Description
BeamDose | (300A,0084): Beam Dose
BeamDoseMeaning | (300A,008B): Beam Dose Meaning
BeamDosePointDepth | (300A,0088): Beam Dose Point Depth
BeamDosePointEquivalentDepth | (300A,0089): Beam Dose Point Equivalent Depth
BeamDosePointSourceToExternalContourDistance | (300A,0094): Beam Dose Point Source to External Contour Distance
BeamDosePointSSD | (300A,008A): Beam Dose Point SSD
BeamDoseSpecificationPoint | (300A,0082): Beam Dose Specification Point
BeamDoseType | (300A,0090): Beam Dose Type
BeamDoseVerificationControlPointSequence | (300A,008C): Beam Dose Verification Control Point Sequence
BeamHardeningCorrectionTechnique | (0014,3101): Beam Hardening Correction Technique
BeamHoldOriginatingDeviceSequence | (300C,0128): Beam Hold Originating Device Sequence
BeamHoldTransition | (300C,0126): Beam Hold Transition
BeamHoldTransitionDateTime | (300C,0127): Beam Hold Transition DateTime
BeamHoldTransitionTriggerSource | (300C,0129): Beam Hold Transition Trigger Source
BeamLimitingDeviceAngle | (300A,0120): Beam Limiting Device Angle
BeamLimitingDeviceAngleTolerance | (300A,0046): Beam Limiting Device Angle Tolerance
BeamLimitingDeviceLeafPairsSequence | (3008,00A0): Beam Limiting Device Leaf Pairs Sequence
BeamLimitingDevicePositionSequence | (300A,011A): Beam Limiting Device Position Sequence
BeamLimitingDevicePositionTolerance | (300A,004A): Beam Limiting Device Position Tolerance
BeamLimitingDeviceRotationDirection | (300A,0121): Beam Limiting Device Rotation Direction
BeamLimitingDeviceSequence | (300A,00B6): Beam Limiting Device Sequence
BeamLimitingDeviceToleranceSequence | (300A,0048): Beam Limiting Device Tolerance Sequence
BeamMeterset | (300A,0086): Beam Meterset
BeamModifierCoordinatesPresenceFlag | (3002,0105): Beam Modifier Coordinates Presence Flag
BeamModifierOrientationAngle | (300A,0645): Beam Modifier Orientation Angle
BeamName | (300A,00C2): Beam Name
BeamNumber | (300A,00C0): Beam Number
BeamOrderIndex | (0074,1324): Beam Order Index
BeamOrderIndexTrial | (0074,1024): Beam Order Index (Trial)
BeamSequence | (300A,00B0): Beam Sequence
BeamSpotSize | (0052,0003): Beam Spot Size
BeamStopperPosition | (3008,0230): Beam Stopper Position
BeamTaskSequence | (0074,1020): Beam Task Sequence
BeamTaskType | (0074,1022): Beam Task Type
BeamType | (300A,00C4): Beam Type
BeatRejectionFlag | (0018,1080): Beat Rejection Flag
BeltHeight | (4010,1062): Belt Height
BibliographicCitationTrial | (0040,A16A): Bibliographic Citation (Trial)
BillingItemSequence | (0040,0296): Billing Item Sequence
BillingProcedureStepSequence | (0040,0320): Billing Procedure Step Sequence
BillingSuppliesAndDevicesSequence | (0040,0324): Billing Supplies and Devices Sequence
BiopsyTargetSequence | (0018,2041): Biopsy Target Sequence
BiPlaneAcquisitionSequence | (0028,5000): Bi-Plane Acquisition Sequence
BitsAllocated | (0028,0100): Bits Allocated
BitsForCodeWord | (0028,08x4): Bits For Code Word
BitsGrouped | (0028,0069): Bits Grouped
BitsMappedToColorLookupTable | (0028,1403): Bits Mapped to Color Lookup Table
BitsStored | (0028,0101): Bits Stored
BlendingDisplayInputSequence | (0070,1B03): Blending Display Input Sequence
BlendingDisplaySequence | (0070,1B04): Blending Display Sequence
BlendingInputNumber | (0070,1B02): Blending Input Number
BlendingLookupTableData | (0028,1408): Blending Lookup Table Data
BlendingLookupTableDescriptor | (0028,1407): Blending Lookup Table Descriptor
BlendingLUT1Sequence | (0028,1404): Blending LUT 1 Sequence
BlendingLUT1TransferFunction | (0028,1405): Blending LUT 1 Transfer Function
BlendingLUT2Sequence | (0028,140C): Blending LUT 2 Sequence
BlendingLUT2TransferFunction | (0028,140D): Blending LUT 2 Transfer Function
BlendingMode | (0070,1B06): Blending Mode
BlendingOperationType | (0072,0500): Blending Operation Type
BlendingPosition | (0070,0405): Blending Position
BlendingSequence | (0070,0402): Blending Sequence
BlendingWeightConstant | (0028,1406): Blending Weight Constant
BlindSpotLocalized | (0024,0106): Blind Spot Localized
BlindSpotXCoordinate | (0024,0107): Blind Spot X-Coordinate
BlindSpotYCoordinate | (0024,0108): Blind Spot Y-Coordinate
BlockColumns | (0028,0092): Block Columns
BlockData | (300A,0106): Block Data
BlockDefinitionSequence | (300A,066A): Block Definition Sequence
BlockDivergence | (300A,00FA): Block Divergence
BlockEdgeData | (300A,066B): Block Edge Data
BlockEdgeDataSequence | (300A,066F): Block Edge Data Sequence
BlockedPixels | (0028,0090): Blocked Pixels
BlockIdentifyingInformationStatus | (0008,0303): Block Identifying Information Status
BlockMountingPosition | (300A,00FB): Block Mounting Position
BlockName | (300A,00FE): Block Name
BlockNumber | (300A,00FC): Block Number
BlockNumberOfPoints | (300A,0104): Block Number of Points
BlockOrientation | (300A,066C): Block Orientation
BlockRows | (0028,0091): Block Rows
BlockSequence | (300A,00F4): Block Sequence
BlockSlabNumber | (300A,0443): Block Slab Number
BlockSlabSequence | (300A,0441): Block Slab Sequence
BlockSlabThickness | (300A,0442): Block Slab Thickness
BlockThickness | (300A,0100): Block Thickness
BlockTransmission | (300A,0102): Block Transmission
BlockTrayID | (300A,00F5): Block Tray ID
BlockType | (300A,00F8): Block Type
BloodSignalNulling | (0018,9022): Blood Signal Nulling
BluePaletteColorLookupTableData | (0028,1203): Blue Palette Color Lookup Table Data
BluePaletteColorLookupTableDescriptor | (0028,1103): Blue Palette Color Lookup Table Descriptor
BoardingPassID | (4010,101A): Boarding Pass ID
BodyPartExamined | (0018,0015): Body Part Examined
BodyPartThickness | (0018,11A0): Body Part Thickness
Bold | (0070,0249): Bold
BolusDefinitionSequence | (300A,0673): Bolus Definition Sequence
BolusDescription | (300A,00DD): Bolus Description
BolusID | (300A,00DC): Bolus ID
BoneThermalIndex | (0018,5024): Bone Thermal Index
BorderDensity | (2010,0100): Border Density
Borders | (0000,5160): Borders(Retired)
BottomRightHandCornerOfLocalizerArea | (0048,0202): Bottom Right Hand Corner of Localizer Area
BoundingBoxAnnotationUnits | (0070,0003): Bounding Box Annotation Units
BoundingBoxBottomRightHandCorner | (0070,0011): Bounding Box Bottom Right Hand Corner
BoundingBoxCrop | (0070,1303): Bounding Box Crop
BoundingBoxTextHorizontalJustification | (0070,0012): Bounding Box Text Horizontal Justification
BoundingBoxTopLeftHandCorner | (0070,0010): Bounding Box Top Left Hand Corner
BoundingPolygon | (4010,101D): Bounding Polygon
BoundingRectangle | (0068,6347): Bounding Rectangle
BrachyAccessoryDeviceID | (300A,0263): Brachy Accessory Device ID
BrachyAccessoryDeviceName | (300A,0266): Brachy Accessory Device Name
BrachyAccessoryDeviceNominalThickness | (300A,026A): Brachy Accessory Device Nominal Thickness
BrachyAccessoryDeviceNominalTransmission | (300A,026C): Brachy Accessory Device Nominal Transmission
BrachyAccessoryDeviceNumber | (300A,0262): Brachy Accessory Device Number
BrachyAccessoryDeviceSequence | (300A,0260): Brachy Accessory Device Sequence
BrachyAccessoryDeviceType | (300A,0264): Brachy Accessory Device Type
BrachyApplicationSetupDose | (300A,00A4): Brachy Application Setup Dose
BrachyApplicationSetupDoseSpecificationPoint | (300A,00A2): Brachy Application Setup Dose Specification Point
BrachyControlPointDeliveredSequence | (3008,0160): Brachy Control Point Delivered Sequence
BrachyControlPointSequence | (300A,02D0): Brachy Control Point Sequence
BrachyPulseControlPointDeliveredSequence | (3008,0173): Brachy Pulse Control Point Delivered Sequence
BrachyReferencedDoseReferenceSequence | (300C,0055): Brachy Referenced Dose Reference Sequence
BrachyTaskSequence | (0074,1401): Brachy Task Sequence
BrachytherapySourceType | (3010,0048): Brachytherapy Source Type
BrachyTreatmentTechnique | (300A,0200): Brachy Treatment Technique
BrachyTreatmentType | (300A,0202): Brachy Treatment Type
BranchOfService | (0010,1081): Branch of Service
BreastImplantPresent | (0028,1300): Breast Implant Present
BreastSupportIsocenterPrimaryAngle | (0018,9545): Breast Support Isocenter Primary Angle
BreastSupportIsocenterSecondaryAngle | (0018,9546): Breast Support Isocenter Secondary Angle
BreastSupportXPositionToIsocenter | (0018,9547): Breast Support X Position to Isocenter
BreastSupportYPositionToIsocenter | (0018,9548): Breast Support Y Position to Isocenter
BreastSupportZPositionToIsocenter | (0018,9549): Breast Support Z Position to Isocenter
BreedRegistrationNumber | (0010,2295): Breed Registration Number
BreedRegistrationSequence | (0010,2294): Breed Registration Sequence
BreedRegistryCodeSequence | (0010,2296): Breed Registry Code Sequence
BridgeResistors | (0014,4088): Bridge Resistors
BrightnessValue | (0016,0023): Brightness Value
BscanCycleTime | (0022,1645): B-scan Cycle Time
BscanCycleTimeVector | (0022,1646): B-scan Cycle Time Vector
BscanRate | (0022,1650): B-scan Rate
BscanSlabThickness | (0022,1643): B-scan Slab Thickness
BulkMotionCompensationTechnique | (0018,9172): Bulk Motion Compensation Technique
BulkMotionSignalSource | (0018,9173): Bulk Motion Signal Source
BulkMotionStatus | (0018,9166): Bulk Motion Status
BurnedInAnnotation | (0028,0301): Burned In Annotation
CADFileFormat | (0014,0023): CAD File Format
CalciumScoringMassFactorDevice | (0018,9352): Calcium Scoring Mass Factor Device
CalciumScoringMassFactorPatient | (0018,9351): Calcium Scoring Mass Factor Patient
CalculatedAnatomyThickness | (0018,9452): Calculated Anatomy Thickness
CalculatedDoseReferenceDescription | (3008,0074): Calculated Dose Reference Description
CalculatedDoseReferenceDoseValue | (3008,0076): Calculated Dose Reference Dose Value
CalculatedDoseReferenceNumber | (3008,0072): Calculated Dose Reference Number
CalculatedDoseReferenceSequence | (3008,0070): Calculated Dose Reference Sequence
CalculatedFrameList | (0008,1162): Calculated Frame List
CalculatedTargetPosition | (0018,2044): Calculated Target Position
CalculationComment | (0022,112C): Calculation Comment
CalculationCommentSequence | (0022,112A): Calculation Comment Sequence
CalculationCommentType | (0022,112B): Calculation Comment Type
CalibrationDataSequence | (0054,0306): Calibration Data Sequence
CalibrationDate | (0014,407E): Calibration Date
CalibrationDateTime | (0018,1203): Calibration DateTime
CalibrationImage | (0050,0004): Calibration Image
CalibrationNotes | (0014,3099): Calibration Notes
CalibrationProcedure | (0014,4072): Calibration Procedure
CalibrationReferencePointDepth | (300C,0124): Calibration Reference Point Depth
CalibrationSequence | (0018,9455): Calibration Sequence
CalibrationSettingsSequence | (0014,4070): Calibration Settings Sequence
CalibrationTime | (0014,407C): Calibration Time
CameraAngleOfView | (0022,001E): Camera Angle of View
CameraElevationAngle | (0016,0035): Camera Elevation Angle
CameraOwnerName | (0016,004D): Camera Owner Name
CameraPositionGroupSequence | (0034,000B): Camera Position Group Sequence
CardiacBeatRejectionTechnique | (0018,9169): Cardiac Beat Rejection Technique
CardiacCyclePosition | (0018,9236): Cardiac Cycle Position
CardiacFramingType | (0018,1064): Cardiac Framing Type
CardiacNumberOfImages | (0018,1090): Cardiac Number of Images
CardiacRRIntervalSpecified | (0018,9070): Cardiac R-R Interval Specified
CardiacSignalSource | (0018,9085): Cardiac Signal Source
CardiacSynchronizationSequence | (0018,9118): Cardiac Synchronization Sequence
CardiacSynchronizationTechnique | (0018,9037): Cardiac Synchronization Technique
CArmPhotonElectronControlPointSequence | (300A,062F): C-Arm Photon-Electron Control Point Sequence
CArmPositionerTabletopRelationship | (0018,9474): C-arm Positioner Tabletop Relationship
CarrierID | (4010,1058): Carrier ID
CarrierIDAssigningAuthority | (4010,1059): Carrier ID Assigning Authority
CassetteID | (0018,1007): Cassette ID
CassetteOrientation | (0018,1402): Cassette Orientation
CassetteSize | (0018,1403): Cassette Size
CatchTrialsDataFlag | (0024,0055): Catch Trials Data Flag
CatheterDirectionOfRotation | (0052,0031): Catheter Direction of Rotation
CatheterRotationalRate | (0052,0013): Catheter Rotational Rate
CellValuesSequence | (0040,A808): Cell Values Sequence
CenterFrequency | (0018,982D): Center Frequency
CenterOfCircularCollimator | (0018,1710): Center of Circular Collimator
CenterOfCircularExposureControlSensingRegion | (0018,9440): Center of Circular Exposure Control Sensing Region
CenterOfCircularOutline | (0018,1635): Center of Circular Outline
CenterOfCircularShutter | (0018,1610): Center of Circular Shutter
CenterOfMass | (4010,101B): Center of Mass
CenterOfPTO | (4010,101C): Center of PTO
CenterOfRotation | (0066,001C): Center of Rotation
CenterOfRotationOffset | (0018,1145): Center of Rotation Offset
CertificateOfSigner | (0400,0115): Certificate of Signer
CertificateType | (0400,0110): Certificate Type
CertifiedTimestamp | (0400,0310): Certified Timestamp
CertifiedTimestampType | (0400,0305): Certified Timestamp Type
ChairHeadFramePosition | (300A,0151): Chair Head Frame Position
ChairHeadFramePositionTolerance | (300A,0153): Chair Head Frame Position Tolerance
ChannelBaseline | (003A,0213): Channel Baseline
ChannelDefinitionSequence | (003A,0200): Channel Definition Sequence
ChannelDeliveryContinuationSequence | (0074,140D): Channel Delivery Continuation Sequence
ChannelDeliveryOrderIndex | (0074,140C): Channel Delivery Order Index
ChannelDeliveryOrderSequence | (0074,1405): Channel Delivery Order Sequence
ChannelDerivationDescription | (003A,020C): Channel Derivation Description
ChannelDescriptionCodeSequence | (0022,001A): Channel Description Code Sequence
ChannelDisplaySequence | (003A,0242): Channel Display Sequence
ChannelEffectiveLength | (300A,0271): Channel Effective Length
ChannelIdentificationCode | (003A,0301): Channel Identification Code
ChannelImpedanceSequence | (003A,0312): Channel Impedance Sequence
ChannelInnerLength | (300A,0272): Channel Inner Length
ChannelLabel | (003A,0203): Channel Label
ChannelLength | (300A,0284): Channel Length
ChannelMaximumValue | (5400,0112): Channel Maximum Value
ChannelMinimumValue | (5400,0110): Channel Minimum Value
ChannelMode | (003A,0302): Channel Mode
ChannelNumber | (300A,0282): Channel Number
ChannelOffset | (003A,0218): Channel Offset
ChannelOverlap | (0014,409F): Channel Overlap
ChannelPosition | (003A,0245): Channel Position
ChannelRecommendedDisplayCIELabValue | (003A,0244): Channel Recommended Display CIELab Value
ChannelSampleSkew | (003A,0215): Channel Sample Skew
ChannelSensitivity | (003A,0210): Channel Sensitivity
ChannelSensitivityCorrectionFactor | (003A,0212): Channel Sensitivity Correction Factor
ChannelSensitivityUnitsSequence | (003A,0211): Channel Sensitivity Units Sequence
ChannelSequence | (300A,0280): Channel Sequence
ChannelSettingsSequence | (0014,4091): Channel Settings Sequence
ChannelShieldID | (300A,02B3): Channel Shield ID
ChannelShieldName | (300A,02B4): Channel Shield Name
ChannelShieldNominalThickness | (300A,02B8): Channel Shield Nominal Thickness
ChannelShieldNominalTransmission | (300A,02BA): Channel Shield Nominal Transmission
ChannelShieldNumber | (300A,02B2): Channel Shield Number
ChannelShieldSequence | (300A,02B0): Channel Shield Sequence
ChannelSourceModifiersSequence | (003A,0209): Channel Source Modifiers Sequence
ChannelSourceSequence | (003A,0208): Channel Source Sequence
ChannelStatus | (003A,0205): Channel Status
ChannelThreshold | (0014,4092): Channel Threshold
ChannelTimeSkew | (003A,0214): Channel Time Skew
ChannelTotalTime | (300A,0286): Channel Total Time
ChannelWidth | (0046,0042): Channel Width
ChemicalShiftMaximumIntegrationLimitInHz | (0018,9196): Chemical Shift Maximum Integration Limit in Hz
ChemicalShiftMaximumIntegrationLimitInppm | (0018,9296): Chemical Shift Maximum Integration Limit in ppm
ChemicalShiftMinimumIntegrationLimitInHz | (0018,9195): Chemical Shift Minimum Integration Limit in Hz
ChemicalShiftMinimumIntegrationLimitInppm | (0018,9295): Chemical Shift Minimum Integration Limit in ppm
ChemicalShiftReference | (0018,9053): Chemical Shift Reference
ChemicalShiftSequence | (0018,9084): Chemical Shift Sequence
CIExyWhitePoint | (0028,7018): CIExy White Point
CineRate | (0018,0040): Cine Rate
CineRelativeToRealTime | (0072,0330): Cine Relative to Real-Time
ClinicalFractionNumber | (300A,0705): Clinical Fraction Number
ClinicalTrialCoordinatingCenterName | (0012,0060): Clinical Trial Coordinating Center Name
ClinicalTrialProtocolEthicsCommitteeApprovalNumber | (0012,0082): Clinical Trial Protocol Ethics Committee Approval Number
ClinicalTrialProtocolEthicsCommitteeName | (0012,0081): Clinical Trial Protocol Ethics Committee Name
ClinicalTrialProtocolID | (0012,0020): Clinical Trial Protocol ID
ClinicalTrialProtocolName | (0012,0021): Clinical Trial Protocol Name
ClinicalTrialSeriesDescription | (0012,0072): Clinical Trial Series Description
ClinicalTrialSeriesID | (0012,0071): Clinical Trial Series ID
ClinicalTrialSiteID | (0012,0030): Clinical Trial Site ID
ClinicalTrialSiteName | (0012,0031): Clinical Trial Site Name
ClinicalTrialSponsorName | (0012,0010): Clinical Trial Sponsor Name
ClinicalTrialSubjectID | (0012,0040): Clinical Trial Subject ID
ClinicalTrialSubjectReadingID | (0012,0042): Clinical Trial Subject Reading ID
ClinicalTrialTimePointDescription | (0012,0051): Clinical Trial Time Point Description
ClinicalTrialTimePointID | (0012,0050): Clinical Trial Time Point ID
ClinicalTrialTimePointTypeCodeSequence | (0012,0054): Clinical Trial Time Point Type Code Sequence
CoatingMaterialsCodeSequence | (0068,63A4): Coating Materials Code Sequence
CodeLabel | (0028,08x0): Code Label
CodeMeaning | (0008,0104): Code Meaning
CodeNumberFormat | (0028,0740): Code Number Format
CodeTableLocation | (0028,08x3): Code Table Location
CodeValue | (0008,0100): Code Value
CodingSchemeDesignator | (0008,0102): Coding Scheme Designator
CodingSchemeExternalID | (0008,0114): Coding Scheme External ID
CodingSchemeIdentificationSequence | (0008,0110): Coding Scheme Identification Sequence
CodingSchemeName | (0008,0115): Coding Scheme Name
CodingSchemeRegistry | (0008,0112): Coding Scheme Registry
CodingSchemeResourcesSequence | (0008,0109): Coding Scheme Resources Sequence
CodingSchemeResponsibleOrganization | (0008,0116): Coding Scheme Responsible Organization
CodingSchemeUID | (0008,010C): Coding Scheme UID
CodingSchemeURL | (0008,010E): Coding Scheme URL
CodingSchemeURLType | (0008,010A): Coding Scheme URL Type
CodingSchemeVersion | (0008,0103): Coding Scheme Version
CoefficientsSDDN | (7FE0,0040): Coefficients SDDN
CoefficientsSDHN | (7FE0,0030): Coefficients SDHN
CoefficientsSDVN | (7FE0,0020): Coefficients SDVN
CoincidenceWindowWidth | (0054,1210): Coincidence Window Width
CollationFlag | (2000,0063): Collation Flag
CollimatorGridName | (0018,1180): Collimator/grid Name
CollimatorLeftVerticalEdge | (0018,1702): Collimator Left Vertical Edge
CollimatorLowerHorizontalEdge | (0018,1708): Collimator Lower Horizontal Edge
CollimatorRightVerticalEdge | (0018,1704): Collimator Right Vertical Edge
CollimatorShape | (0018,1700): Collimator Shape
CollimatorShapeSequence | (0018,9407): Collimator Shape Sequence
CollimatorType | (0018,1181): Collimator Type
CollimatorUpperHorizontalEdge | (0018,1706): Collimator Upper Horizontal Edge
ColorFilterArrayPatternColumns | (0016,000F): Color Filter Array Pattern Columns
ColorFilterArrayPatternRows | (0016,000E): Color Filter Array Pattern Rows
ColorFilterArrayPatternValues | (0016,0010): Color Filter Array Pattern Values
ColorImagePrintingFlag | (2000,0062): Color Image Printing Flag
ColorSpace | (0028,2002): Color Space
ColumnAngulation | (0018,1450): Column Angulation
ColumnAngulationPatient | (0018,9447): Column Angulation (Patient)
ColumnOverlap | (0028,0094): Column Overlap
ColumnPositionInTotalImagePixelMatrix | (0048,021E): Column Position In Total Image Pixel Matrix
Columns | (0028,0011): Columns
CombinationSegmentReferenceSequence | (3010,0024): Combination Segment Reference Sequence
CommandDataSetType | (0000,0800): Command Data Set Type
CommandField | (0000,0100): Command Field
CommandGroupLength | (0000,0000): Command Group Length
CommandLengthToEnd | (0000,0001): Command Length to End(Retired)
CommandMagnificationType | (0000,5180): Command Magnification Type(Retired)
CommandRecognitionCode | (0000,0010): Command Recognition Code(Retired)
CommentsOnPatientPerformanceOfVisualField | (0024,0044): Comments on Patient's Performance of Visual Field
CommentsOnRadiationDose | (0040,0310): Comments on Radiation Dose
CommentsOnThePerformedProcedureStep | (0040,0280): Comments on the Performed Procedure Step
CommentsOnTheScheduledProcedureStep | (0040,0400): Comments on the Scheduled Procedure Step
CommonZCoordinateValue | (006A,0010): Common Z Coordinate Value
CompensatorBasePlaneOffset | (300A,0666): Compensator Base Plane Offset
CompensatorColumnOffset | (300A,02E5): Compensator Column Offset
CompensatorColumns | (300A,00E8): Compensator Columns
CompensatorDefinitionSequence | (300A,0662): Compensator Definition Sequence
CompensatorDescription | (300A,02EB): Compensator Description
CompensatorDistalThicknessMap | (300A,0665): Compensator Distal Thickness Map
CompensatorDivergence | (300A,02E0): Compensator Divergence
CompensatorID | (300A,00E5): Compensator ID
CompensatorMapOrientation | (300A,0663): Compensator Map Orientation
CompensatorMillingToolDiameter | (300A,02E8): Compensator Milling Tool Diameter
CompensatorMountingPosition | (300A,02E1): Compensator Mounting Position
CompensatorNumber | (300A,00E4): Compensator Number
CompensatorPixelSpacing | (300A,00E9): Compensator Pixel Spacing
CompensatorPosition | (300A,00EA): Compensator Position
CompensatorProximalThicknessMap | (300A,0664): Compensator Proximal Thickness Map
CompensatorRelativeStoppingPowerRatio | (300A,02E7): Compensator Relative Stopping Power Ratio
CompensatorRows | (300A,00E7): Compensator Rows
CompensatorSequence | (300A,00E3): Compensator Sequence
CompensatorShapeFabricationCodeSequence | (300A,0667): Compensator Shape Fabrication Code Sequence
CompensatorShapeSequence | (300A,0668): Compensator Shape Sequence
CompensatorThicknessData | (300A,00EC): Compensator Thickness Data
CompensatorTransmissionData | (300A,00EB): Compensator Transmission Data
CompensatorTrayID | (300A,00EF): Compensator Tray ID
CompensatorType | (300A,00EE): Compensator Type
CompletionFlag | (0040,A491): Completion Flag
CompletionFlagDescription | (0040,A492): Completion Flag Description
ComplexImageComponent | (0008,9208): Complex Image Component
Component1ReferencedID | (0076,0070): Component 1 Referenced ID
Component1ReferencedMatingFeatureID | (0076,0090): Component 1 Referenced Mating Feature ID
Component1ReferencedMatingFeatureSetID | (0076,0080): Component 1 Referenced Mating Feature Set ID
Component2ReferencedID | (0076,00A0): Component 2 Referenced ID
Component2ReferencedMatingFeatureID | (0076,00C0): Component 2 Referenced Mating Feature ID
Component2ReferencedMatingFeatureSetID | (0076,00B0): Component 2 Referenced Mating Feature Set ID
ComponentAssemblySequence | (0076,0060): Component Assembly Sequence
ComponentID | (0076,0055): Component ID
ComponentInputSequence | (0070,1803): Component Input Sequence
ComponentManufacturer | (0014,0028): Component Manufacturer
ComponentManufacturingProcedure | (0014,0025): Component Manufacturing Procedure
ComponentReferenceSystem | (0014,0024): Component Reference System
ComponentSequence | (0076,0040): Component Sequence
ComponentShape | (0014,0050): Component Shape
ComponentType | (0070,1802): Component Type
ComponentTypeCodeSequence | (0076,0034): Component Type Code Sequence
ComponentTypesSequence | (0076,0032): Component Types Sequence
ComponentWelderIDs | (0014,0100): Component Welder IDs
CompositingMethod | (0070,1206): Compositing Method
CompoundGraphicInstanceID | (0070,0226): Compound Graphic Instance ID
CompoundGraphicSequence | (0070,0209): Compound Graphic Sequence
CompoundGraphicType | (0070,0294): Compound Graphic Type
CompoundGraphicUnits | (0070,0282): Compound Graphic Units
CompressionCode | (0028,0060): Compression Code(Retired)
CompressionContactArea | (0018,11A5): Compression Contact Area
CompressionDescription | (0028,0063): Compression Description
CompressionForce | (0018,11A2): Compression Force
CompressionLabel | (0028,0062): Compression Label
CompressionOriginator | (0028,0061): Compression Originator
CompressionPressure | (0018,11A3): Compression Pressure
CompressionRecognitionCode | (0028,005F): Compression Recognition Code
CompressionSequence | (0028,0065): Compression Sequence
CompressionStepPointers | (0028,0066): Compression Step Pointers
ConcatenationFrameOffsetNumber | (0020,9228): Concatenation Frame Offset Number
ConcatenationUID | (0020,9161): Concatenation UID
ConceptCodeSequence | (0040,A168): Concept Code Sequence
ConceptNameCodeSequence | (0040,A043): Concept Name Code Sequence
ConceptualVolumeBlockingConstraint | (3010,0068): Conceptual Volume Blocking Constraint
ConceptualVolumeCategoryCodeSequence | (3010,0067): Conceptual Volume Category Code Sequence
ConceptualVolumeCombinationDescription | (3010,000F): Conceptual Volume Combination Description
ConceptualVolumeCombinationExpression | (3010,000C): Conceptual Volume Combination Expression
ConceptualVolumeCombinationFlag | (3010,000E): Conceptual Volume Combination Flag
ConceptualVolumeConstituentIndex | (3010,000D): Conceptual Volume Constituent Index
ConceptualVolumeConstituentSegmentationReferenceSequence | (3010,0012): Conceptual Volume Constituent Segmentation Reference Sequence
ConceptualVolumeConstituentSequence | (3010,0008): Conceptual Volume Constituent Sequence
ConceptualVolumeDerivationAlgorithmSequence | (3010,0016): Conceptual Volume Derivation Algorithm Sequence
ConceptualVolumeDescription | (3010,0017): Conceptual Volume Description
ConceptualVolumeIdentificationSequence | (3010,00A0): Conceptual Volume Identification Sequence
ConceptualVolumeOptimizationPrecedence | (3010,0066): Conceptual Volume Optimization Precedence
ConceptualVolumeSegmentationDefinedFlag | (3010,0010): Conceptual Volume Segmentation Defined Flag
ConceptualVolumeSegmentationReferenceSequence | (3010,0011): Conceptual Volume Segmentation Reference Sequence
ConceptualVolumeSequence | (3010,0025): Conceptual Volume Sequence
ConceptualVolumeTypeCodeSequence | (3010,0069): Conceptual Volume Type Code Sequence
ConceptualVolumeTypeModifierCodeSequence | (3010,006A): Conceptual Volume Type Modifier Code Sequence
ConceptualVolumeUID | (3010,0006): Conceptual Volume UID
CondenserLensPower | (0048,0111): Condenser Lens Power
ConfidentialityCode | (0040,1008): Confidentiality Code
ConfidentialityConstraintOnPatientDataDescription | (0040,3001): Confidentiality Constraint on Patient Data Description
ConfigurationDescription | (0028,700D): Configuration Description
ConfigurationID | (0028,700B): Configuration ID
ConfigurationInformation | (2010,0150): Configuration Information
ConfigurationInformationDescription | (2010,0152): Configuration Information Description
ConfigurationName | (0028,700C): Configuration Name
ConfigurationQAResultsSequence | (0028,7011): Configuration QA Results Sequence
ConfirmationSequence | (300A,073F): Confirmation Sequence
ConfocalMicroscopyImageFrameTypeSequence | (0048,0116): Confocal Microscopy Image Frame Type Sequence
ConfocalMode | (0048,0114): Confocal Mode
ConnectorType | (0014,5105): Connector Type
ConsentForClinicalTrialUseSequence | (0012,0083): Consent for Clinical Trial Use Sequence
ConsentForDistributionFlag | (0012,0085): Consent for Distribution Flag
ConstantVolumeFlag | (0018,9333): Constant Volume Flag
ConstituentConceptualVolumeUID | (3010,0013): Constituent Conceptual Volume UID
ConstraintType | (0082,0032): Constraint Type
ConstraintValueSequence | (0082,0034): Constraint Value Sequence
ConstraintViolationCondition | (0082,0037): Constraint Violation Condition
ConstraintViolationSignificance | (0082,0036): Constraint Violation Significance
ConstraintWeight | (300A,0021): Constraint Weight
ConsultingPhysicianIdentificationSequence | (0008,009D): Consulting Physician Identification Sequence
ConsultingPhysicianName | (0008,009C): Consulting Physician's Name
ContactDisplayName | (0074,100C): Contact Display Name
ContactMethod | (0016,1003): Contact Method
ContactURI | (0074,100A): Contact URI
ContainerComponentDescription | (0050,001E): Container Component Description
ContainerComponentDiameter | (0050,001D): Container Component Diameter
ContainerComponentID | (0050,001B): Container Component ID
ContainerComponentLength | (0050,001C): Container Component Length
ContainerComponentMaterial | (0050,001A): Container Component Material
ContainerComponentSequence | (0040,0520): Container Component Sequence
ContainerComponentThickness | (0050,0013): Container Component Thickness
ContainerComponentTypeCodeSequence | (0050,0012): Container Component Type Code Sequence
ContainerComponentWidth | (0050,0015): Container Component Width
ContainerDescription | (0040,051A): Container Description
ContainerFileType | (0008,040A): Container File Type
ContainerIdentifier | (0040,0512): Container Identifier
ContainerTypeCodeSequence | (0040,0518): Container Type Code Sequence
ContentCreatorIdentificationCodeSequence | (0070,0086): Content Creator's Identification Code Sequence
ContentCreatorName | (0070,0084): Content Creator's Name
ContentDate | (0008,0023): Content Date
ContentDescription | (0070,0081): Content Description
ContentItemModifierSequence | (0040,0441): Content Item Modifier Sequence
ContentLabel | (0070,0080): Content Label
ContentQualification | (0018,9004): Content Qualification
ContentSequence | (0040,A730): Content Sequence
ContentTemplateSequence | (0040,A504): Content Template Sequence
ContentTime | (0008,0033): Content Time
ContextGroupExtensionCreatorUID | (0008,010D): Context Group Extension Creator UID
ContextGroupExtensionFlag | (0008,010B): Context Group Extension Flag
ContextGroupIdentificationSequence | (0008,0123): Context Group Identification Sequence
ContextGroupLocalVersion | (0008,0107): Context Group Local Version
ContextGroupVersion | (0008,0106): Context Group Version
ContextIdentifier | (0008,010F): Context Identifier
ContextUID | (0008,0117): Context UID
ContinuationEndMeterset | (0074,0121): Continuation End Meterset
ContinuationEndTotalReferenceAirKerma | (0074,1403): Continuation End Total Reference Air Kerma
ContinuationPulseNumber | (0074,1404): Continuation Pulse Number
ContinuationStartMeterset | (0074,0120): Continuation Start Meterset
ContinuationStartTotalReferenceAirKerma | (0074,1402): Continuation Start Total Reference Air Kerma
ContinuityOfContent | (0040,A050): Continuity Of Content
ContourData | (3006,0050): Contour Data
ContourGeometricType | (3006,0042): Contour Geometric Type
ContourImageSequence | (3006,0016): Contour Image Sequence
ContourNumber | (3006,0048): Contour Number
ContourOffsetVector | (3006,0045): Contour Offset Vector
ContourSequence | (3006,0040): Contour Sequence
ContourSlabThickness | (3006,0044): Contour Slab Thickness
ContourUncertaintyRadius | (0070,0312): Contour Uncertainty Radius
ContraindicationsCodeSequence | (0018,990B): Contraindications Code Sequence
Contrast | (0016,0048): Contrast
ContrastAdministrationProfileSequence | (0018,9340): Contrast Administration Profile Sequence
ContrastBolusAdministrationRouteSequence | (0018,0014): Contrast/Bolus Administration Route Sequence
ContrastBolusAgent | (0018,0010): Contrast/Bolus Agent
ContrastBolusAgentAdministered | (0018,9342): Contrast/Bolus Agent Administered
ContrastBolusAgentDetected | (0018,9343): Contrast/Bolus Agent Detected
ContrastBolusAgentNumber | (0018,9337): Contrast/Bolus Agent Number
ContrastBolusAgentPhase | (0018,9344): Contrast/Bolus Agent Phase
ContrastBolusAgentSequence | (0018,0012): Contrast/Bolus Agent Sequence
ContrastBolusAutoInjectionTriggerFlag | (0018,11B6): Contrast/Bolus Auto Injection Trigger Flag
ContrastBolusIngredient | (0018,1048): Contrast/Bolus Ingredient
ContrastBolusIngredientCodeSequence | (0018,9338): Contrast/Bolus Ingredient Code Sequence
ContrastBolusIngredientConcentration | (0018,1049): Contrast/Bolus Ingredient Concentration
ContrastBolusIngredientOpaque | (0018,9425): Contrast/Bolus Ingredient Opaque
ContrastBolusIngredientPercentByVolume | (0052,0001): Contrast/Bolus Ingredient Percent by Volume
ContrastBolusInjectionDelay | (0018,11B7): Contrast/Bolus Injection Delay
ContrastBolusRoute | (0018,1040): Contrast/Bolus Route
ContrastBolusStartTime | (0018,1042): Contrast/Bolus Start Time
ContrastBolusStopTime | (0018,1043): Contrast/Bolus Stop Time
ContrastBolusT1Relaxivity | (0018,0013): Contrast/Bolus T1 Relaxivity
ContrastBolusTotalDose | (0018,1044): Contrast/Bolus Total Dose
ContrastBolusUsageSequence | (0018,9341): Contrast/Bolus Usage Sequence
ContrastBolusVolume | (0018,1041): Contrast/Bolus Volume
ContrastFlowDuration | (0018,1047): Contrast Flow Duration
ContrastFlowRate | (0018,1046): Contrast Flow Rate
ContrastFrameAveraging | (0028,6112): Contrast Frame Averaging
ContributingEquipmentSequence | (0018,A001): Contributing Equipment Sequence
ContributingSOPInstancesReferenceSequence | (0020,9529): Contributing SOP Instances Reference Sequence
ContributingSourcesSequence | (0018,9506): Contributing Sources Sequence
ContributionDateTime | (0018,A002): Contribution DateTime
ContributionDescription | (0018,A003): Contribution Description
ControlPoint3DPosition | (300A,02D4): Control Point 3D Position
ControlPointDeliverySequence | (3008,0040): Control Point Delivery Sequence
ControlPointIndex | (300A,0112): Control Point Index
ControlPointOrientation | (300A,0412): Control Point Orientation
ControlPointRelativePosition | (300A,02D2): Control Point Relative Position
ControlPointSequence | (300A,0111): Control Point Sequence
ConventionalControlPointVerificationSequence | (0074,104C): Conventional Control Point Verification Sequence
ConventionalMachineVerificationSequence | (0074,1044): Conventional Machine Verification Sequence
ConversionSourceAttributesSequence | (0020,9172): Conversion Source Attributes Sequence
ConversionType | (0008,0064): Conversion Type
ConvolutionKernel | (0018,1210): Convolution Kernel
ConvolutionKernelGroup | (0018,9316): Convolution Kernel Group
CoordinatesSetGeometricTypeTrial | (0040,A290): Coordinates Set Geometric Type (Trial)
CoordinateStartValue | (50xx,0112): Coordinate Start Value
CoordinateStepValue | (50xx,0114): Coordinate Step Value
CoordinateSystemAxesSequence | (0014,2204): Coordinate System Axes Sequence
CoordinateSystemAxisCodeSequence | (0040,08DA): Coordinate System Axis Code Sequence
CoordinateSystemAxisDescription | (0014,2206): Coordinate System Axis Description
CoordinateSystemAxisNumber | (0014,220A): Coordinate System Axis Number
CoordinateSystemAxisType | (0014,220C): Coordinate System Axis Type
CoordinateSystemAxisUnits | (0014,220E): Coordinate System Axis Units
CoordinateSystemAxisValues | (0014,2210): Coordinate System Axis Values
CoordinateSystemDataSetMapping | (0014,2208): Coordinate System Data Set Mapping
CoordinateSystemNumberOfAxes | (0014,2202): Coordinate System Number of Axes
CoordinateSystemTransformRotationAndScaleMatrix | (0014,222A): Coordinate System Transform Rotation and Scale Matrix
CoordinateSystemTransformSequence | (0014,2220): Coordinate System Transform Sequence
CoordinateSystemTransformTranslationMatrix | (0014,222C): Coordinate System Transform Translation Matrix
Copies | (0000,5170): Copies(Retired)
CornealAxis | (0046,0115): Corneal Axis
CornealEccentricityIndex | (0046,0234): Corneal Eccentricity Index
CornealISValue | (0046,0224): Corneal I-S Value
CornealPointEstimated | (0046,0248): Corneal Point Estimated
CornealPointLocation | (0046,0247): Corneal Point Location
CornealPower | (0046,0114): Corneal Power
CornealSize | (0046,0046): Corneal Size
CornealSizeSequence | (0046,0047): Corneal Size Sequence
CornealTopographyMappingNormalsSequence | (0046,0210): Corneal Topography Mapping Normals Sequence
CornealTopographyMapQualityEvaluation | (0046,0242): Corneal Topography Map Quality Evaluation
CornealTopographyMapTypeCodeSequence | (0046,0207): Corneal Topography Map Type Code Sequence
CornealTopographySurface | (0046,0201): Corneal Topography Surface
CornealVertexLocation | (0046,0202): Corneal Vertex Location
CornealWavefront | (0046,0253): Corneal Wavefront
CorneaMeasurementMethodCodeSequence | (0046,0116): Cornea Measurement Method Code Sequence
CorneaMeasurementsSequence | (0046,0110): Cornea Measurements Sequence
CorrectedImage | (0028,0051): Corrected Image
CorrectedLocalizedDeviationFromNormal | (0024,0079): Corrected Localized Deviation From Normal
CorrectedLocalizedDeviationFromNormalCalculated | (0024,0078): Corrected Localized Deviation From Normal Calculated
CorrectedLocalizedDeviationFromNormalProbability | (0024,0081): Corrected Localized Deviation From Normal Probability
CorrectedLocalizedDeviationFromNormalProbabilityCalculated | (0024,0080): Corrected Localized Deviation From Normal Probability Calculated
CorrectedParameterSequence | (3008,0068): Corrected Parameter Sequence
CorrectionValue | (3008,006A): Correction Value
CountLossNormalizationCorrected | (0018,9764): Count Loss Normalization Corrected
CountRate | (0018,1243): Count Rate
CountryOfResidence | (0010,2150): Country of Residence
CountsAccumulated | (0018,0070): Counts Accumulated
CountsIncluded | (0054,1400): Counts Included
CountsSource | (0054,1002): Counts Source
CouplingMedium | (0014,4056): Coupling Medium
CouplingTechnique | (0014,4054): Coupling Technique
CouplingVelocity | (0014,4057): Coupling Velocity
CoverageOfKSpace | (0018,9094): Coverage of k-Space
CranialThermalIndex | (0018,5026): Cranial Thermal Index
CreationDate | (2100,0040): Creation Date
CreationTime | (2100,0050): Creation Time
CreatorVersionUID | (0008,9123): Creator-Version UID
Crop | (0070,1204): Crop
CroppingSpecificationIndex | (0070,1205): Cropping Specification Index
CroppingSpecificationNumber | (0070,1309): Cropping Specification Number
CSSFontName | (0070,0229): CSS Font Name
CTAcquisitionDetailsSequence | (0018,9304): CT Acquisition Details Sequence
CTAcquisitionTypeSequence | (0018,9301): CT Acquisition Type Sequence
CTAdditionalXRaySourceSequence | (0018,9360): CT Additional X-Ray Source Sequence
CTDIPhantomTypeCodeSequence | (0018,9346): CTDI Phantom Type Code Sequence
CTDIvol | (0018,9345): CTDIvol
CTDIvolNotificationTrigger | (0018,9942): CTDIvol Notification Trigger
CTExposureSequence | (0018,9321): CT Exposure Sequence
CTGeometrySequence | (0018,9312): CT Geometry Sequence
CTImageFrameTypeSequence | (0018,9329): CT Image Frame Type Sequence
CTImagingAcquisitionParameterSequence | (3002,0126): CT Imaging Acquisition Parameter Sequence
CTPositionSequence | (0018,9326): CT Position Sequence
CTReconstructionSequence | (0018,9314): CT Reconstruction Sequence
CTTableDynamicsSequence | (0018,9308): CT Table Dynamics Sequence
CTXRayDetailsSequence | (0018,9325): CT X-Ray Details Sequence
CumulativeDoseReferenceCoefficient | (300A,010C): Cumulative Dose Reference Coefficient
CumulativeDoseToDoseReference | (3008,0052): Cumulative Dose to Dose Reference
CumulativeMeterset | (300A,063C): Cumulative Meterset
CumulativeMetersetWeight | (300A,0134): Cumulative Meterset Weight
CumulativeTimeWeight | (300A,02D6): Cumulative Time Weight
CurrentConfigurationID | (0028,7002): Current Configuration ID
CurrentFractionNumber | (3008,0022): Current Fraction Number
CurrentObserverTrial | (0040,A307): Current Observer (Trial)
CurrentPatientLocation | (0038,0300): Current Patient Location
CurrentRequestedProcedureEvidenceSequence | (0040,A375): Current Requested Procedure Evidence Sequence
CurrentTreatmentStatus | (3008,0200): Current Treatment Status
CurvatureType | (0014,0052): Curvature Type
CurveActivationLayer | (50xx,1001): Curve Activation Layer
CurveData | (50xx,3000): Curve Data
CurveDataDescriptor | (50xx,0110): Curve Data Descriptor
CurveDate | (0008,0025): Curve Date
CurveDescription | (50xx,0022): Curve Description
CurveDimensions | (50xx,0005): Curve Dimensions
CurveLabel | (50xx,2500): Curve Label
CurveNumber | (0020,0024): Curve Number
CurveRange | (50xx,0106): Curve Range
CurveReferencedOverlayGroup | (50xx,2610): Curve Referenced Overlay Group
CurveReferencedOverlaySequence | (50xx,2600): Curve Referenced Overlay Sequence
CurveTime | (0008,0035): Curve Time(Retired)
CustodialOrganizationSequence | (0040,A07C): Custodial Organization Sequence
CustomRendered | (0016,0041): Custom Rendered
CylinderAxis | (0022,0009): Cylinder Axis
CylinderLensPower | (0022,0008): Cylinder Lens Power
CylinderPower | (0046,0147): Cylinder Power
CylinderSequence | (0046,0018): Cylinder Sequence
DACAmplitude | (0014,403C): DAC Amplitude
DACGainPoints | (0014,4038): DAC Gain Points
DACSequence | (0014,4035): DAC Sequence
DACTimePoints | (0014,403A): DAC Time Points
DACType | (0014,4036): DAC Type
Damping | (0014,4028): Damping
DarkCurrentCounts | (0014,3050): Dark Current Counts
DarkCurrentSequence | (0014,3040): Dark Current Sequence
DataBlock | (0028,0702): Data Block
DataBlockDescription | (0028,0701): Data Block Description
DataCollectionCenterPatient | (0018,9313): Data Collection Center (Patient)
DataCollectionDiameter | (0018,0090): Data Collection Diameter
DataElement | (0014,0202): Data Element
DataElementConditionality | (0014,0205): Data Element Conditionality
DataElementDescription | (0014,0204): Data Element Description
DataElementLabelItemSequence | (0014,0201): Data Element Label Item Sequence
DataElementLabelSequence | (0014,0200): Data Element Label Sequence
DataElementMaximumCharacters | (0014,0207): Data Element Maximum Characters
DataElementMinimumCharacters | (0014,0206): Data Element Minimum Characters
DataElementName | (0014,0203): Data Element Name
DataElementsSigned | (0400,0020): Data Elements Signed
DataFrameAssignmentSequence | (0028,1401): Data Frame Assignment Sequence
DataInformationSequence | (0054,0063): Data Information Sequence
DataObservationSequence | (0024,0325): Data Observation Sequence
DataPathAssignment | (0028,1402): Data Path Assignment
DataPathID | (0028,140E): Data Path ID
DataPointColumns | (0028,9002): Data Point Columns
DataPointRows | (0028,9001): Data Point Rows
DataRepresentation | (0028,9108): Data Representation
DataSetDescription | (0024,0309): Data Set Description
DataSetName | (0024,0306): Data Set Name
DataSetSource | (0024,0308): Data Set Source
DataSetSubtype | (0008,0041): Data Set Subtype
DataSetTrailingPadding | (FFFC,FFFC): Data Set Trailing Padding
DataSetType | (0008,0040): Data Set Type
DataSetVersion | (0024,0307): Data Set Version
DataType | (0018,9808): Data Type
DataValueRepresentation | (50xx,0103): Data Value Representation
Date | (0040,A121): Date
DateOfDocumentOrVerbalTransactionTrial | (0040,A110): Date of Document or Verbal Transaction (Trial)
DateOfGainCalibration | (0014,3076): Date of Gain Calibration
DateOfInstallation | (0018,1205): Date of Installation
DateOfLastCalibration | (0018,1200): Date of Last Calibration
DateOfLastDetectorCalibration | (0018,700C): Date of Last Detector Calibration
DateOfManufacture | (0018,1204): Date of Manufacture
DateOfSecondaryCapture | (0018,1012): Date of Secondary Capture
DateTime | (0040,A120): DateTime
DateTimeOfLastCalibration | (0018,1202): DateTime of Last Calibration
dBdt | (0018,1318): dB/dt
DCTLabel | (0028,0700): DCT Label
DDLValue | (0028,7017): DDL Value
DeadTimeCorrected | (0018,9761): Dead Time Corrected
DeadTimeCorrectionFlag | (0054,1401): Dead Time Correction Flag
DeadTimeFactor | (0054,1324): Dead Time Factor
DecayCorrected | (0018,9758): Decay Corrected
DecayCorrection | (0054,1102): Decay Correction
DecayCorrectionDateTime | (0018,9701): Decay Correction DateTime
DecayFactor | (0054,1321): Decay Factor
DecimalPotentialVisualAcuity | (0046,0238): Decimal Potential Visual Acuity
DecimalVisualAcuity | (0046,0137): Decimal Visual Acuity
DecimateCropResult | (2020,00A2): Decimate/Crop Result
DecompositionAlgorithmIdentificationSequence | (0018,9380): Decomposition Algorithm Identification Sequence
DecompositionDescription | (0018,937F): Decomposition Description
DecompositionMaterialSequence | (0018,9381): Decomposition Material Sequence
DecompositionMethod | (0018,937E): Decomposition Method
DecoupledNucleus | (0018,9060): De-coupled Nucleus
Decoupling | (0018,9059): De-coupling
DecouplingChemicalShiftReference | (0018,9063): De-coupling Chemical Shift Reference
DecouplingFrequency | (0018,9061): De-coupling Frequency
DecouplingMethod | (0018,9062): De-coupling Method
DefaultMagnificationType | (2010,00A6): Default Magnification Type
DefaultPrinterResolutionID | (2010,0054): Default Printer Resolution ID
DefaultSmoothingType | (2010,00A8): Default Smoothing Type
DefinitionSourceSequence | (0008,1156): Definition Source Sequence
DeformableRegistrationGridSequence | (0064,0005): Deformable Registration Grid Sequence
DeformableRegistrationSequence | (0064,0002): Deformable Registration Sequence
DegreeOfDilation | (0022,000E): Degree of Dilation
DegreeOfFreedomID | (0068,6410): Degree of Freedom ID
DegreeOfFreedomType | (0068,6420): Degree of Freedom Type
DeidentificationAction | (0008,0307): Deidentification Action
DeidentificationActionSequence | (0008,0305): Deidentification Action Sequence
DeidentificationMethod | (0012,0063): De-identification Method
DeidentificationMethodCodeSequence | (0012,0064): De-identification Method Code Sequence
DelayLawIdentifier | (0014,405C): Delay Law Identifier
DeletionLock | (0074,1230): Deletion Lock
DelineatedRadiationFieldSize | (300C,0122): Delineated Radiation Field Size
DeliveredChannelTotalTime | (3008,0134): Delivered Channel Total Time
DeliveredDepthDoseParametersSequence | (300A,0506): Delivered Depth Dose Parameters Sequence
DeliveredDistalDepth | (300A,0508): Delivered Distal Depth
DeliveredDistalDepthFraction | (300A,0507): Delivered Distal Depth Fraction
DeliveredMeterset | (3008,0044): Delivered Meterset
DeliveredNominalRangeModulatedRegionDepths | (300A,0510): Delivered Nominal Range Modulated Region Depths
DeliveredNominalRangeModulationFractions | (300A,0509): Delivered Nominal Range Modulation Fractions
DeliveredNumberOfPulses | (3008,0138): Delivered Number of Pulses
DeliveredPrimaryMeterset | (3008,0036): Delivered Primary Meterset
DeliveredPulseRepetitionInterval | (3008,013C): Delivered Pulse Repetition Interval
DeliveredReferenceDoseDefinition | (300A,0511): Delivered Reference Dose Definition
DeliveredSecondaryMeterset | (3008,0037): Delivered Secondary Meterset
DeliveredTreatmentTime | (3008,003B): Delivered Treatment Time
DeliveryMaximumDose | (300A,0023): Delivery Maximum Dose
DeliveryRate | (300A,063D): Delivery Rate
DeliveryRateUnitSequence | (300A,063E): Delivery Rate Unit Sequence
DeliveryTimeStructureCodeSequence | (3010,0088): Delivery Time Structure Code Sequence
DeliveryVerificationImageSequence | (0074,1030): Delivery Verification Image Sequence
DeliveryWarningDose | (300A,0022): Delivery Warning Dose
Density | (4010,1018): Density
DepthDoseParametersSequence | (300A,0505): Depth Dose Parameters Sequence
DepthOfScanField | (0018,5050): Depth of Scan Field
DepthOfTransverseImage | (0022,0041): Depth of Transverse Image
DepthsOfFocus | (0018,9801): Depth(s) of Focus
DepthSpatialResolution | (0022,0035): Depth Spatial Resolution
DepthValueAveragingFlag | (300A,0093): Depth Value Averaging Flag
DerivationAlgorithmSequence | (0022,1612): Derivation Algorithm Sequence
DerivationCodeSequence | (0008,9215): Derivation Code Sequence
DerivationConceptualVolumeSequence | (3010,0014): Derivation Conceptual Volume Sequence
DerivationDescription | (0008,2111): Derivation Description
DerivationImageSequence | (0008,9124): Derivation Image Sequence
DerivationImplantAssemblyTemplateSequence | (0076,000E): Derivation Implant Assembly Template Sequence
DerivationImplantTemplateSequence | (0068,6224): Derivation Implant Template Sequence
DestinationAE | (2100,0140): Destination AE
DetailsOfCoefficients | (0028,0404): Details of Coefficients
DetectorActivationOffsetFromExposure | (0018,7016): Detector Activation Offset From Exposure
DetectorActiveAreaOrientation | (0018,9558): Detector Active Area Orientation
DetectorActiveAreaTLHCPosition | (0018,9557): Detector Active Area TLHC Position
DetectorActiveDimensions | (0018,7026): Detector Active Dimension(s)
DetectorActiveOrigin | (0018,7028): Detector Active Origin
DetectorActiveShape | (0018,7024): Detector Active Shape
DetectorActiveTime | (0018,7014): Detector Active Time
DetectorBinning | (0018,701A): Detector Binning
DetectorCalibrationData | (4010,106C): Detector Calibration Data
DetectorConditionsNominalFlag | (0018,7000): Detector Conditions Nominal Flag
DetectorConfiguration | (0018,7005): Detector Configuration
DetectorDescription | (0018,7006): Detector Description
DetectorElementPhysicalSize | (0018,7020): Detector Element Physical Size
DetectorElementSize | (0054,1203): Detector Element Size
DetectorElementSpacing | (0018,7022): Detector Element Spacing
DetectorGeometry | (0018,9725): Detector Geometry
DetectorGeometrySequence | (4010,0004): Detector Geometry Sequence
DetectorID | (0018,700A): Detector ID
DetectorInformationSequence | (0054,0022): Detector Information Sequence
DetectorIsocenterPrimaryAngle | (0018,9550): Detector Isocenter Primary Angle
DetectorIsocenterSecondaryAngle | (0018,9551): Detector Isocenter Secondary Angle
DetectorLinesOfResponseUsed | (0054,1104): Detector Lines of Response Used
DetectorManufacturerModelName | (0018,702B): Detector Manufacturer's Model Name
DetectorManufacturerName | (0018,702A): Detector Manufacturer Name
DetectorMode | (0018,7008): Detector Mode
DetectorNormalizationCorrection | (0018,9768): Detector Normalization Correction
DetectorPositioningType | (3002,012F): Detector Positioning Type
DetectorPositionSequence | (0018,9541): Detector Position Sequence
DetectorPrimaryAngle | (0018,1530): Detector Primary Angle
DetectorSecondaryAngle | (0018,1531): Detector Secondary Angle
DetectorTemperature | (0018,7001): Detector Temperature
DetectorTemperatureSequence | (0014,3020): Detector Temperature Sequence
DetectorTimeSinceLastExposure | (0018,7012): Detector Time Since Last Exposure
DetectorType | (0018,7004): Detector Type
DetectorVector | (0054,0020): Detector Vector
DetectorXPositionToIsocenter | (0018,9552): Detector X Position to Isocenter
DetectorYPositionToIsocenter | (0018,9553): Detector Y Position to Isocenter
DetectorZPositionToIsocenter | (0018,9554): Detector Z Position to Isocenter
DeviationIndex | (0018,1413): Deviation Index
DeviceAlternateIdentifier | (3010,001B): Device Alternate Identifier
DeviceAlternateIdentifierFormat | (3010,001D): Device Alternate Identifier Format
DeviceAlternateIdentifierType | (3010,001C): Device Alternate Identifier Type
DeviceDescription | (0050,0020): Device Description
DeviceDiameter | (0050,0016): Device Diameter
DeviceDiameterUnits | (0050,0017): Device Diameter Units
DeviceID | (0018,1003): Device ID
DeviceIndex | (3010,0039): Device Index
DeviceLabel | (3010,002D): Device Label
DeviceLength | (0050,0014): Device Length
DeviceMotionControlSequence | (300A,0450): Device Motion Control Sequence
DeviceMotionExecutionMode | (300A,0451): Device Motion Execution Mode
DeviceMotionObservationMode | (300A,0452): Device Motion Observation Mode
DeviceMotionParameterCodeSequence | (300A,0453): Device Motion Parameter Code Sequence
DeviceOrderIndex | (300A,065E): Device Order Index
DevicePositionParameterSequence | (3002,0110): Device Position Parameter Sequence
DevicePositionToEquipmentMappingMatrix | (3002,010F): Device Position to Equipment Mapping Matrix
DeviceSequence | (0050,0010): Device Sequence
DeviceSerialNumber | (0018,1000): Device Serial Number
DeviceSettingDescription | (0016,004B): Device Setting Description
DeviceSpecificAcquisitionParameterSequence | (3002,0131): Device-Specific Acquisition Parameter Sequence
DeviceTypeCodeSequence | (3010,002E): Device Type Code Sequence
DeviceUID | (0018,1002): Device UID
DeviceVolume | (0050,0018): Device Volume
DialogReceiver | (0000,4000): Dialog Receiver(Retired)
DiameterOfCircularOutline | (0018,1636): Diameter of Circular Outline
DiameterOfVisibility | (0070,0262): Diameter of Visibility
DiaphragmPosition | (3002,0034): Diaphragm Position
DICOMMediaRetrievalSequence | (0040,E022): DICOM Media Retrieval Sequence
DICOMRetrievalSequence | (0040,E021): DICOM Retrieval Sequence
DICOMStorageSequence | (0040,4071): DICOM Storage Sequence
DICOSVersion | (4010,103A): DICOS Version
DiffuseReflectionIntensity | (0070,1704): Diffuse Reflection Intensity
DiffusionAcquisitionCodeSequence | (0066,0133): Diffusion Acquisition Code Sequence
DiffusionAnisotropyType | (0018,9147): Diffusion Anisotropy Type
DiffusionBMatrixSequence | (0018,9601): Diffusion b-matrix Sequence
DiffusionBValue | (0018,9087): Diffusion b-value
DiffusionBValueXX | (0018,9602): Diffusion b-value XX
DiffusionBValueXY | (0018,9603): Diffusion b-value XY
DiffusionBValueXZ | (0018,9604): Diffusion b-value XZ
DiffusionBValueYY | (0018,9605): Diffusion b-value YY
DiffusionBValueYZ | (0018,9606): Diffusion b-value YZ
DiffusionBValueZZ | (0018,9607): Diffusion b-value ZZ
DiffusionDirectionality | (0018,9075): Diffusion Directionality
DiffusionGradientDirectionSequence | (0018,9076): Diffusion Gradient Direction Sequence
DiffusionGradientOrientation | (0018,9089): Diffusion Gradient Orientation
DiffusionModelCodeSequence | (0066,0134): Diffusion Model Code Sequence
DigitalFilterCharacteristicsSequence | (003A,0326): Digital Filter Characteristics Sequence
DigitalFilterOrder | (003A,0327): Digital Filter Order
DigitalFilterTypeCodeSequence | (003A,0328): Digital Filter Type Code Sequence
DigitalImageFormatAcquired | (0018,1023): Digital Image Format Acquired
DigitalSignatureDateTime | (0400,0105): Digital Signature DateTime
DigitalSignaturePurposeCodeSequence | (0400,0401): Digital Signature Purpose Code Sequence
DigitalSignaturesSequence | (FFFA,FFFA): Digital Signatures Sequence
DigitalSignatureUID | (0400,0100): Digital Signature UID
DigitalZoomRatio | (0016,0044): Digital Zoom Ratio
DigitizingDeviceTransportDirection | (0018,2020): Digitizing Device Transport Direction
DimensionDescriptionLabel | (0020,9421): Dimension Description Label
DimensionIndexPointer | (0020,9165): Dimension Index Pointer
DimensionIndexPrivateCreator | (0020,9213): Dimension Index Private Creator
DimensionIndexSequence | (0020,9222): Dimension Index Sequence
DimensionIndexValues | (0020,9157): Dimension Index Values
DimensionOrganizationSequence | (0020,9221): Dimension Organization Sequence
DimensionOrganizationType | (0020,9311): Dimension Organization Type
DimensionOrganizationUID | (0020,9164): Dimension Organization UID
DirectoryRecordSequence | (0004,1220): Directory Record Sequence
DirectoryRecordType | (0004,1430): Directory Record Type
DirectSegmentReferenceSequence | (3010,0023): Direct Segment Reference Sequence
DischargeDate | (0038,0030): Discharge Date
DischargeDiagnosisCodeSequence | (0038,0044): Discharge Diagnosis Code Sequence
DischargeDiagnosisDescription | (0038,0040): Discharge Diagnosis Description
DischargeTime | (0038,0032): Discharge Time
DisplacementMatrix | (300A,079B): Displacement Matrix
DisplacementReferenceLabel | (300A,079A): Displacement Reference Label
DisplacementReferenceLocationCodeSequence | (300A,079D): Displacement Reference Location Code Sequence
DisplayCalibrationResultSequence | (0028,7016): Display Calibration Result Sequence
DisplayDeviceTypeCodeSequence | (0028,7022): Display Device Type Code Sequence
DisplayedAreaBottomRightHandCorner | (0070,0053): Displayed Area Bottom Right Hand Corner
DisplayedAreaBottomRightHandCornerTrial | (0070,0051): Displayed Area Bottom Right Hand Corner (Trial)
DisplayedAreaSelectionSequence | (0070,005A): Displayed Area Selection Sequence
DisplayedAreaTopLeftHandCorner | (0070,0052): Displayed Area Top Left Hand Corner
DisplayedAreaTopLeftHandCornerTrial | (0070,0050): Displayed Area Top Left Hand Corner (Trial)
DisplayedZValue | (0018,2046): Displayed Z Value
DisplayEnvironmentSpatialPosition | (0072,0108): Display Environment Spatial Position
DisplayFilterPercentage | (0028,9411): Display Filter Percentage
DisplayFormat | (0000,5110): Display Format(Retired)
DisplayFunctionType | (0028,7019): Display Function Type
DisplaySetHorizontalJustification | (0072,0717): Display Set Horizontal Justification
DisplaySetLabel | (0072,0203): Display Set Label
DisplaySetNumber | (0072,0202): Display Set Number
DisplaySetPatientOrientation | (0072,0700): Display Set Patient Orientation
DisplaySetPresentationGroup | (0072,0204): Display Set Presentation Group
DisplaySetPresentationGroupDescription | (0072,0206): Display Set Presentation Group Description
DisplaySetScrollingGroup | (0072,0212): Display Set Scrolling Group
DisplaySetsSequence | (0072,0200): Display Sets Sequence
DisplaySetVerticalJustification | (0072,0718): Display Set Vertical Justification
DisplayShadingFlag | (003A,0246): Display Shading Flag
DisplaySubsystemConfigurationSequence | (0028,700A): Display Subsystem Configuration Sequence
DisplaySubsystemDescription | (0028,7005): Display Subsystem Description
DisplaySubsystemID | (0028,7003): Display Subsystem ID
DisplaySubsystemName | (0028,7004): Display Subsystem Name
DisplaySubsystemQAResultsSequence | (0028,7010): Display Subsystem QA Results Sequence
DisplaySubsystemSequence | (0028,7023): Display Subsystem Sequence
DisplayWindowLabelVector | (0018,2006): Display Window Label Vector
DistalDepth | (300A,0502): Distal Depth
DistalDepthFraction | (300A,0501): Distal Depth Fraction
DistanceBetweenBscanSlabs | (0022,1644): Distance Between B-scan Slabs
DistanceBetweenFocalPlanes | (0048,0014): Distance Between Focal Planes
DistanceObjectToTableTop | (0018,9403): Distance Object to Table Top
DistancePupillaryDistance | (0046,0060): Distance Pupillary Distance
DistanceReceptorPlaneToDetectorHousing | (0018,9426): Distance Receptor Plane to Detector Housing
DistanceSourceToDataCollectionCenter | (0018,9335): Distance Source to Data Collection Center
DistanceSourceToDetector | (0018,1110): Distance Source to Detector
DistanceSourceToEntrance | (0040,0306): Distance Source to Entrance
DistanceSourceToIsocenter | (0018,9402): Distance Source to Isocenter
DistanceSourceToPatient | (0018,1111): Distance Source to Patient
DistanceSourceToSupport | (0040,0307): Distance Source to Support
DistributionAddress | (4008,011A): Distribution Address
DistributionName | (4008,0119): Distribution Name
DistributionType | (0012,0084): Distribution Type
DLPNotificationTrigger | (0018,9943): DLP Notification Trigger
DocumentAuthorIdentifierCodeSequenceTrial | (0040,A068): Document Author Identifier Code Sequence (Trial)
DocumentAuthorTrial | (0040,A067): Document Author (Trial)
DocumentClassCodeSequence | (0040,E008): Document Class Code Sequence
DocumentIdentifierCodeSequenceTrial | (0040,A066): Document Identifier Code Sequence (Trial)
DocumentingObserverIdentifierCodeSequenceTrial | (0040,A076): Documenting Observer Identifier Code Sequence (Trial)
DocumentingOrganizationIdentifierCodeSequenceTrial | (0040,A028): Documenting Organization Identifier Code Sequence (Trial)
DocumentTitle | (0042,0010): Document Title
DopplerCorrectionAngle | (0018,6034): Doppler Correction Angle
DopplerSampleVolumeXPosition | (0018,6039): Doppler Sample Volume X Position
DopplerSampleVolumeXPositionRetired | (0018,6038): Doppler Sample Volume X Position (Retired)
DopplerSampleVolumeYPosition | (0018,603B): Doppler Sample Volume Y Position
DopplerSampleVolumeYPositionRetired | (0018,603A): Doppler Sample Volume Y Position (Retired)
DoseCalibrationConditionsSequence | (300C,0120): Dose Calibration Conditions Sequence
DoseCalibrationConditionsVerifiedFlag | (300C,0123): Dose Calibration Conditions Verified Flag
DoseCalibrationFactor | (0054,1322): Dose Calibration Factor
DoseComment | (3004,0006): Dose Comment
DoseGridScaling | (3004,000E): Dose Grid Scaling
DoseMeasurementDeviceCodeSequence | (300A,0774): Dose Measurement Device Code Sequence
DoseModeName | (0018,11B1): Dose Mode Name
DoseRateDelivered | (3008,0048): Dose Rate Delivered
DoseRateSet | (300A,0115): Dose Rate Set
DoseReferenceDescription | (300A,0016): Dose Reference Description
DoseReferenceNumber | (300A,0012): Dose Reference Number
DoseReferencePointCoordinates | (300A,0018): Dose Reference Point Coordinates
DoseReferenceSequence | (300A,0010): Dose Reference Sequence
DoseReferenceStructureType | (300A,0014): Dose Reference Structure Type
DoseReferenceType | (300A,0020): Dose Reference Type
DoseReferenceUID | (300A,0013): Dose Reference UID
DoseSummationType | (3004,000A): Dose Summation Type
DoseType | (3004,0004): Dose Type
DoseUnits | (3004,0002): Dose Units
DoseValue | (3004,0012): Dose Value
DoseValueInterpretation | (300A,068B): Dose Value Interpretation
DoseValuePurpose | (300A,061D): Dose Value Purpose
DoseValuesSequence | (300A,061C): Dose Values Sequence
DosimetricObjectiveEvaluationScope | (3010,0063): Dosimetric Objective Evaluation Scope
DosimetricObjectiveParameterSequence | (3010,0070): Dosimetric Objective Parameter Sequence
DosimetricObjectivePurpose | (3010,0075): Dosimetric Objective Purpose
DosimetricObjectiveSequence | (3010,006C): Dosimetric Objective Sequence
DosimetricObjectiveTypeCodeSequence | (3010,006D): Dosimetric Objective Type Code Sequence
DosimetricObjectiveUID | (3010,006E): Dosimetric Objective UID
DosimetricObjectiveWeight | (3010,0074): Dosimetric Objective Weight
DoubleExposureFieldDelta | (0074,133A): Double Exposure Field Delta
DoubleExposureFieldDeltaTrial | (0074,103A): Double Exposure Field Delta (Trial)
DoubleExposureFlag | (0074,1034): Double Exposure Flag
DoubleExposureMeterset | (0074,1338): Double Exposure Meterset
DoubleExposureMetersetTrial | (0074,1038): Double Exposure Meterset (Trial)
DoubleExposureOrdering | (0074,1036): Double Exposure Ordering
DoubleFloatPixelData | (7FE0,0009): Double Float Pixel Data
DoubleFloatPixelPaddingRangeLimit | (0028,0125): Double Float Pixel Padding Range Limit
DoubleFloatPixelPaddingValue | (0028,0123): Double Float Pixel Padding Value
DoubleFloatRealWorldValueFirstValueMapped | (0040,9214): Double Float Real World Value First Value Mapped
DoubleFloatRealWorldValueLastValueMapped | (0040,9213): Double Float Real World Value Last Value Mapped
DoublePointCoordinatesData | (0066,0022): Double Point Coordinates Data
DriveProbeSequence | (0014,4083): Drive Probe Sequence
DriveType | (0014,4081): Drive Type
DVHData | (3004,0058): DVH Data
DVHDoseScaling | (3004,0052): DVH Dose Scaling
DVHMaximumDose | (3004,0072): DVH Maximum Dose
DVHMeanDose | (3004,0074): DVH Mean Dose
DVHMinimumDose | (3004,0070): DVH Minimum Dose
DVHNormalizationDoseValue | (3004,0042): DVH Normalization Dose Value
DVHNormalizationPoint | (3004,0040): DVH Normalization Point
DVHNumberOfBins | (3004,0056): DVH Number of Bins
DVHReferencedROISequence | (3004,0060): DVH Referenced ROI Sequence
DVHROIContributionType | (3004,0062): DVH ROI Contribution Type
DVHSequence | (3004,0050): DVH Sequence
DVHType | (3004,0001): DVH Type
DVHVolumeUnits | (3004,0054): DVH Volume Units
DynamicRange | (0018,5030): Dynamic Range(Retired)
EchoNumbers | (0018,0086): Echo Number(s)
EchoPeakPosition | (0018,9298): Echo Peak Position
EchoPlanarPulseSequence | (0018,9018): Echo Planar Pulse Sequence
EchoPulseSequence | (0018,9008): Echo Pulse Sequence
EchoTime | (0018,0081): Echo Time
EchoTrainLength | (0018,0091): Echo Train Length
EdgePointIndexList | (0066,0024): Edge Point Index List
EffectiveBinEnergy | (0018,936E): Effective Bin Energy
EffectiveDateTime | (0068,6226): Effective DateTime
EffectiveDoseCalculationMethodCategoryCodeSequence | (3010,0003): Effective Dose Calculation Method Category Code Sequence
EffectiveDoseCalculationMethodCodeSequence | (3010,0004): Effective Dose Calculation Method Code Sequence
EffectiveDoseCalculationMethodDescription | (3010,0005): Effective Dose Calculation Method Description
EffectiveDuration | (0018,0072): Effective Duration
EffectiveEchoTime | (0018,9082): Effective Echo Time
EffectiveRefractiveIndex | (0052,0004): Effective Refractive Index
EffectiveWedgeAngle | (300A,00DE): Effective Wedge Angle
ElementDimensionA | (0014,4014): Element Dimension A
ElementDimensionB | (0014,4015): Element Dimension B
ElementPitchA | (0014,4016): Element Pitch A
ElementPitchB | (0014,401D): Element Pitch B
ElementShape | (0014,4013): Element Shape
EmitterColorTemperature | (0016,1002): Emitter Color Temperature
EmmetropicMagnification | (0022,000A): Emmetropic Magnification
EmptyImageBoxCIELabValue | (0072,0421): Empty Image Box CIELab Value
EmptyImageDensity | (2010,0110): Empty Image Density
EmptyValueMatchingSequence | (0008,0412): Empty Value Matching Sequence
EncapsulatedDocument | (0042,0011): Encapsulated Document
EncapsulatedDocumentLength | (0042,0015): Encapsulated Document Length
EncapsulatedPixelDataValueTotalLength | (7FE0,0003): Encapsulated Pixel Data Value Total Length
EncryptedAttributesSequence | (0400,0500): Encrypted Attributes Sequence
EncryptedContent | (0400,0520): Encrypted Content
EncryptedContentTransferSyntaxUID | (0400,0510): Encrypted Content Transfer Syntax UID
EndAcquisitionDateTime | (0018,9517): End Acquisition DateTime
EndCumulativeMetersetWeight | (300C,0009): End Cumulative Meterset Weight
EndCumulativeTimeWeight | (0074,1408): End Cumulative Time Weight
EndingRespiratoryAmplitude | (0020,9248): Ending Respiratory Amplitude
EndingRespiratoryPhase | (0020,9249): Ending Respiratory Phase
EndMessageID | (0000,5020): End Message ID(Retired)
EndMeterset | (3008,007A): End Meterset
EnergyDerivationCodeSequence | (3002,0133): Energy Derivation Code Sequence
EnergyUnitCodeSequence | (300A,0684): Energy Unit Code Sequence
EnergyWeightingFactor | (0018,9353): Energy Weighting Factor
EnergyWindowCenterline | (0018,0032): Energy Window Centerline
EnergyWindowInformationSequence | (0054,0012): Energy Window Information Sequence
EnergyWindowLowerLimit | (0054,0014): Energy Window Lower Limit
EnergyWindowName | (0054,0018): Energy Window Name
EnergyWindowNumber | (0054,0308): Energy Window Number
EnergyWindowRangeSequence | (0054,0013): Energy Window Range Sequence
EnergyWindowTotalWidth | (0018,0033): Energy Window Total Width
EnergyWindowUpperLimit | (0054,0015): Energy Window Upper Limit
EnergyWindowVector | (0054,0010): Energy Window Vector
EnhancedPaletteColorLookupTableSequence | (0028,140B): Enhanced Palette Color Lookup Table Sequence
EnhancedRTBeamLimitingDeviceDefinitionFlag | (3008,00A3): Enhanced RT Beam Limiting Device Definition Flag
EnhancedRTBeamLimitingDeviceSequence | (3008,00A1): Enhanced RT Beam Limiting Device Sequence
EnhancedRTBeamLimitingOpeningSequence | (3008,00A2): Enhanced RT Beam Limiting Opening Sequence
EntityDescription | (3010,0037): Entity Description
EntityLabel | (3010,0035): Entity Label
EntityLongLabel | (3010,0038): Entity Long Label
EntityName | (3010,0036): Entity Name
EntranceDose | (0040,0302): Entrance Dose
EntranceDoseDerivation | (0040,8303): Entrance Dose Derivation
EntranceDoseInmGy | (0040,8302): Entrance Dose in mGy
EnvironmentalConditions | (0014,1040): Environmental Conditions
EquipmentAdministratorSequence | (0028,7000): Equipment Administrator Sequence
EquipmentCoordinateSystemIdentification | (0028,9537): Equipment Coordinate System Identification
EquipmentFrameOfReferenceDescription | (300A,0676): Equipment Frame of Reference Description
EquipmentFrameOfReferenceUID | (300A,0675): Equipment Frame of Reference UID
EquipmentModality | (0008,0221): Equipment Modality
EquipmentReferencePointCodeSequence | (300A,0678): Equipment Reference Point Code Sequence
EquipmentReferencePointCoordinatesSequence | (300A,0677): Equipment Reference Point Coordinates Sequence
EquivalentCDADocumentSequence | (0040,A090): Equivalent CDA Document Sequence
EquivalentCodeSequence | (0008,0121): Equivalent Code Sequence
EquivalentConceptualVolumeInstanceReferenceSequence | (3010,0009): Equivalent Conceptual Volume Instance Reference Sequence
EquivalentConceptualVolumesSequence | (3010,000A): Equivalent Conceptual Volumes Sequence
EquivalentPupilRadius | (0046,0205): Equivalent Pupil Radius
Erase | (0000,5190): Erase(Retired)
ErrorComment | (0000,0902): Error Comment
ErrorID | (0000,0903): Error ID
EscapeTriplet | (1000,xxx0): Escape Triplet
EstimatedDoseSaving | (0018,9324): Estimated Dose Saving
EstimatedRadiographicMagnificationFactor | (0018,1114): Estimated Radiographic Magnification Factor
EthicsCommitteeApprovalEffectivenessEndDate | (0012,0087): Ethics Committee Approval Effectiveness End Date
EthicsCommitteeApprovalEffectivenessStartDate | (0012,0086): Ethics Committee Approval Effectiveness Start Date
EthnicGroup | (0010,2160): Ethnic Group
EthnicGroupCodeSequence | (0010,2161): Ethnic Group Code Sequence
EvaluationAttempt | (0014,2008): Evaluation Attempt
EvaluatorName | (0014,2006): Evaluator Name
EvaluatorNumber | (0014,2004): Evaluator Number
EvaluatorSequence | (0014,2002): Evaluator Sequence
EventCodeSequence | (0008,2135): Event Code Sequence
EventElapsedTimes | (0008,2130): Event Elapsed Time(s)
EventTimeOffset | (0008,2134): Event Time Offset
EventTimerNames | (0008,2132): Event Timer Name(s)
EventTimerSequence | (0008,2133): Event Timer Sequence
EventTypeID | (0000,1002): Event Type ID
ExaminedBodyThickness | (0010,9431): Examined Body Thickness
ExcessiveFalseNegatives | (0024,0052): Excessive False Negatives
ExcessiveFalseNegativesDataFlag | (0024,0051): Excessive False Negatives Data Flag
ExcessiveFalsePositives | (0024,0062): Excessive False Positives
ExcessiveFalsePositivesDataFlag | (0024,0061): Excessive False Positives Data Flag
ExcessiveFixationLosses | (0024,0040): Excessive Fixation Losses
ExcessiveFixationLossesDataFlag | (0024,0039): Excessive Fixation Losses Data Flag
ExcitationEnergy | (0018,9823): Excitation Energy
ExcitationFrequency | (0014,4024): Excitation Frequency
ExcitationPulseDuration | (0018,9824): Excitation Pulse Duration
ExcitationSpectralWidth | (0018,9822): Excitation Spectral Width
ExcitationWavelength | (0018,9826): Excitation Wavelength
ExcitationWavelengthSequence | (0018,9825): Excitation Wavelength Sequence
ExcludedIntervalsSequence | (0018,9803): Excluded Intervals Sequence
ExclusionDuration | (0018,9805): Exclusion Duration
ExclusionStartDateTime | (0018,9804): Exclusion Start DateTime
ExclusiveComponentType | (0076,0036): Exclusive Component Type
ExecutionStatus | (2100,0020): Execution Status
ExecutionStatusInfo | (2100,0030): Execution Status Info
EXIFVersion | (0016,0020): EXIF Version
ExpectedCompletionDateTime | (0040,4011): Expected Completion DateTime
ExpectedInVivoMeasurementValueIndex | (300A,0622): Expected In-Vivo Measurement Value Index
ExpectedInVivoMeasurementValuesSequence | (300A,0621): Expected In-Vivo Measurement Values Sequence
ExpirationDateTime | (0008,0416): Expiration DateTime
ExpiryDate | (0014,1020): Expiry Date
ExposedArea | (0040,0303): Exposed Area
Exposure | (0018,1152): Exposure
ExposureBiasValue | (0016,0024): Exposure Bias Value
ExposureControlMode | (0018,7060): Exposure Control Mode
ExposureControlModeDescription | (0018,7062): Exposure Control Mode Description
ExposureControlSensingRegionLeftVerticalEdge | (0018,9436): Exposure Control Sensing Region Left Vertical Edge
ExposureControlSensingRegionLowerHorizontalEdge | (0018,9439): Exposure Control Sensing Region Lower Horizontal Edge
ExposureControlSensingRegionRightVerticalEdge | (0018,9437): Exposure Control Sensing Region Right Vertical Edge
ExposureControlSensingRegionShape | (0018,9435): Exposure Control Sensing Region Shape
ExposureControlSensingRegionsSequence | (0018,9434): Exposure Control Sensing Regions Sequence
ExposureControlSensingRegionUpperHorizontalEdge | (0018,9438): Exposure Control Sensing Region Upper Horizontal Edge
ExposureDoseSequence | (0040,030E): Exposure Dose Sequence
ExposureIndex | (0018,1411): Exposure Index
ExposureInmAs | (0018,9332): Exposure in mAs
ExposureInuAs | (0018,1153): Exposure in µAs
ExposureMode | (0016,0042): Exposure Mode
ExposureModulationType | (0018,9323): Exposure Modulation Type
ExposureProgram | (0016,0016): Exposure Program
ExposureSequence | (3002,0030): Exposure Sequence
ExposuresOnDetectorSinceLastCalibration | (0018,7010): Exposures on Detector Since Last Calibration
ExposuresOnDetectorSinceManufactured | (0018,7011): Exposures on Detector Since Manufactured
ExposuresOnPlate | (0018,1404): Exposures on Plate
ExposureStatus | (0018,7064): Exposure Status
ExposureTime | (0018,1150): Exposure Time
ExposureTimeInms | (0018,9328): Exposure Time in ms
ExposureTimeInSeconds | (0016,0004): Exposure Time in Seconds
ExposureTimeInuS | (0018,8150): Exposure Time in µS
ExtendedCodeMeaning | (0008,0108): Extended Code Meaning
ExtendedCodeValue | (0008,0101): Extended Code Value
ExtendedDepthOfField | (0048,0012): Extended Depth of Field
ExtendedMatchingMechanisms | (0008,040F): Extended Matching Mechanisms
ExtendedOffsetTable | (7FE0,0001): Extended Offset Table
ExtendedOffsetTableLengths | (7FE0,0002): Extended Offset Table Lengths
ExternalContourEntryPoint | (300A,0133): External Contour Entry Point
FacetSequence | (0066,0034): Facet Sequence
FailedAttributesSequence | (0074,1048): Failed Attributes Sequence
FailedSOPInstanceUIDList | (0008,0058): Failed SOP Instance UID List
FailedSOPSequence | (0008,1198): Failed SOP Sequence
FailedStudySequence | (0008,119B): Failed Study Sequence
FailureAttributes | (2200,000E): Failure Attributes
FailureReason | (0008,1197): Failure Reason
FalseNegativesEstimate | (0024,0046): False Negatives Estimate
FalseNegativesEstimateFlag | (0024,0045): False Negatives Estimate Flag
FalseNegativesQuantity | (0024,0050): False Negatives Quantity
FalsePositivesEstimate | (0024,0054): False Positives Estimate
FalsePositivesEstimateFlag | (0024,0053): False Positives Estimate Flag
FalsePositivesQuantity | (0024,0060): False Positives Quantity
FiducialDescription | (0070,030F): Fiducial Description
FiducialIdentifier | (0070,0310): Fiducial Identifier
FiducialIdentifierCodeSequence | (0070,0311): Fiducial Identifier Code Sequence
FiducialSequence | (0070,031E): Fiducial Sequence
FiducialSetSequence | (0070,031C): Fiducial Set Sequence
FiducialsPropertyCategoryCodeSequence | (0070,031F): Fiducials Property Category Code Sequence
FiducialUID | (0070,031A): Fiducial UID
FieldOfViewDescription | (0018,9433): Field of View Description
FieldOfViewDimensions | (0018,1149): Field of View Dimension(s)
FieldOfViewDimensionsInFloat | (0018,9461): Field of View Dimension(s) in Float
FieldOfViewHorizontalFlip | (0018,7034): Field of View Horizontal Flip
FieldOfViewOrigin | (0018,7030): Field of View Origin
FieldOfViewRotation | (0018,7032): Field of View Rotation
FieldOfViewSequence | (0018,9432): Field of View Sequence
FieldOfViewShape | (0018,1147): Field of View Shape
FileAccessSequence | (0008,041A): File Access Sequence
FileAccessURI | (0008,0409): File Access URI
FileLengthInContainer | (0008,040D): File Length in Container
FileMetaInformationGroupLength | (0002,0000): File Meta Information Group Length
FileMetaInformationVersion | (0002,0001): File Meta Information Version
FilenameInContainer | (0008,040B): Filename in Container
FileOffsetInContainer | (0008,040C): File Offset in Container
FileSetAccessSequence | (0008,0419): File Set Access Sequence
FileSetConsistencyFlag | (0004,1212): File-set Consistency Flag
FileSetDescriptorFileID | (0004,1141): File-set Descriptor File ID
FileSetID | (0004,1130): File-set ID
FileSource | (0016,003A): File Source
FillerOrderNumberImagingServiceRequest | (0040,2017): Filler Order Number / Imaging Service Request
FillerOrderNumberImagingServiceRequestRetired | (0040,2007): Filler Order Number / Imaging Service Request (Retired)
FillerOrderNumberProcedure | (0040,1007): Filler Order Number / Procedure
FillMode | (0070,0257): Fill Mode
FillPattern | (0070,0256): Fill Pattern
FillStyleSequence | (0070,0233): Fill Style Sequence
FilmBoxContentSequence | (2130,0030): Film Box Content Sequence
FilmConsumptionSequence | (0040,0321): Film Consumption Sequence
FilmDestination | (2000,0040): Film Destination
FilmOrientation | (2010,0040): Film Orientation
FilmSessionLabel | (2000,0050): Film Session Label
FilmSizeID | (2010,0050): Film Size ID
FilterBeamPathLengthMaximum | (0018,7058): Filter Beam Path Length Maximum
FilterBeamPathLengthMinimum | (0018,7056): Filter Beam Path Length Minimum
FilterByAttributePresence | (0072,0404): Filter-by Attribute Presence
FilterByCategory | (0072,0402): Filter-by Category
FilterByOperator | (0072,0406): Filter-by Operator
FilterHighFrequency | (003A,0221): Filter High Frequency
FilterHighFrequencyCharacteristicsSequence | (003A,0319): Filter High Frequency Characteristics Sequence
FilterLookupTableData | (003A,032E): Filter Lookup Table Data
FilterLookupTableDescription | (003A,032B): Filter Lookup Table Description
FilterLookupTableSequence | (003A,032A): Filter Lookup Table Sequence
FilterLowFrequency | (003A,0220): Filter Low Frequency
FilterLowFrequencyCharacteristicsSequence | (003A,0318): Filter Low Frequency Characteristics Sequence
FilterMaterial | (0018,7050): Filter Material
FilterMaterialUsedInGainCalibration | (0014,3074): Filter Material Used in Gain Calibration
FilterOperationsSequence | (0072,0400): Filter Operations Sequence
FilterThicknessMaximum | (0018,7054): Filter Thickness Maximum
FilterThicknessMinimum | (0018,7052): Filter Thickness Minimum
FilterThicknessUsedInGainCalibration | (0014,3075): Filter Thickness Used in Gain Calibration
FilterType | (0018,1160): Filter Type
FinalCumulativeMetersetWeight | (300A,010E): Final Cumulative Meterset Weight
FinalCumulativeTimeWeight | (300A,02C8): Final Cumulative Time Weight
FindingsFlagTrial | (0040,A007): Findings Flag (Trial)
FindingsGroupRecordingDateTrial | (0040,A023): Findings Group Recording Date (Trial)
FindingsGroupRecordingTimeTrial | (0040,A024): Findings Group Recording Time (Trial)
FindingsGroupUIDTrial | (0040,A021): Findings Group UID (Trial)
FindingsSequenceTrial | (0040,A020): Findings Sequence (Trial)
FindingsSourceCategoryCodeSequenceTrial | (0040,A026): Findings Source Category Code Sequence (Trial)
FindLocation | (0000,0400): Find Location(Retired)
FiniteVolume | (0066,000E): Finite Volume
FirstALineLocation | (0052,0034): First A-line Location
FirstOrderPhaseCorrection | (0018,9198): First Order Phase Correction
FirstOrderPhaseCorrectionAngle | (5600,0010): First Order Phase Correction Angle
FirstTreatmentDate | (3008,0054): First Treatment Date
FixationCheckedQuantity | (0024,0035): Fixation Checked Quantity
FixationDeviceDescription | (300A,0196): Fixation Device Description
FixationDeviceLabel | (300A,0194): Fixation Device Label
FixationDevicePitchAngle | (300A,0199): Fixation Device Pitch Angle
FixationDevicePosition | (300A,0198): Fixation Device Position
FixationDeviceRollAngle | (300A,019A): Fixation Device Roll Angle
FixationDeviceSequence | (300A,0190): Fixation Device Sequence
FixationDeviceType | (300A,0192): Fixation Device Type
FixationEye | (300A,0150): Fixation Eye
FixationLightAzimuthalAngle | (300A,0356): Fixation Light Azimuthal Angle
FixationLightAzimuthalAngleTolerance | (300A,0154): Fixation Light Azimuthal Angle Tolerance
FixationLightPolarAngle | (300A,0358): Fixation Light Polar Angle
FixationLightPolarAngleTolerance | (300A,0155): Fixation Light Polar Angle Tolerance
FixationMethodCodeSequence | (0068,63AC): Fixation Method Code Sequence
FixationMonitoringCodeSequence | (0024,0033): Fixation Monitoring Code Sequence
FixationSequence | (0024,0032): Fixation Sequence
FixedRTBeamDelimiterDeviceSequence | (300A,0646): Fixed RT Beam Delimiter Device Sequence
FlashEnergy | (0016,0036): Flash Energy
FlashFiringStatus | (0016,0011): Flash Firing Status
FlashFunctionPresent | (0016,0014): Flash Function Present
FlashMode | (0016,0013): Flash Mode
FlashRedEyeMode | (0016,0015): Flash Red Eye Mode
FlashReturnStatus | (0016,0012): Flash Return Status
FlatCornealAxisSequence | (0046,0113): Flat Corneal Axis Sequence
FlatKeratometricAxisSequence | (0046,0080): Flat Keratometric Axis Sequence
FlipAngle | (0018,1314): Flip Angle
FloatingPointValue | (0040,A161): Floating Point Value
FloatingPointValues | (0066,0125): Floating Point Values
FloatPixelData | (7FE0,0008): Float Pixel Data
FloatPixelPaddingRangeLimit | (0028,0124): Float Pixel Padding Range Limit
FloatPixelPaddingValue | (0028,0122): Float Pixel Padding Value
FlowCompensation | (0018,9010): Flow Compensation
FlowCompensationDirection | (0018,9183): Flow Compensation Direction
FlowIdentifier | (0034,0002): Flow Identifier
FlowIdentifierSequence | (0034,0001): Flow Identifier Sequence
FlowRTPSamplingRate | (0034,0004): Flow RTP Sampling Rate
FlowTransferSyntaxUID | (0034,0003): Flow Transfer Syntax UID
FluenceDataScale | (3002,0042): Fluence Data Scale
FluenceDataSource | (3002,0041): Fluence Data Source
FluenceMapSequence | (3002,0040): Fluence Map Sequence
FluenceMode | (3002,0051): Fluence Mode
FluenceModeID | (3002,0052): Fluence Mode ID
FluoroscopyFlag | (0018,9334): Fluoroscopy Flag
FluoroscopyLastImageHoldPersistenceFlag | (0018,11B4): Fluoroscopy Last Image Hold Persistence Flag
FluoroscopyPersistenceFlag | (0018,11B3): Fluoroscopy Persistence Flag
FNumber | (0016,0005): F-Number
FocalDistance | (0018,1182): Focal Distance
FocalLength | (0016,0029): Focal Length
FocalLengthIn35mmFilm | (0016,0045): Focal Length In 35mm Film
FocalSpots | (0018,1190): Focal Spot(s)
FocusDepth | (0018,5012): Focus Depth
FocusMethod | (0048,0011): Focus Method
FolderAccessURI | (0008,0408): Folder Access URI
FontName | (0070,0227): Font Name
FontNameType | (0070,0228): Font Name Type
FovealPointNormativeDataFlag | (0024,0117): Foveal Point Normative Data Flag
FovealPointProbabilityValue | (0024,0118): Foveal Point Probability Value
FovealSensitivity | (0024,0087): Foveal Sensitivity
FovealSensitivityMeasured | (0024,0086): Foveal Sensitivity Measured
FractionalBandwidth | (0018,982E): Fractional Bandwidth
FractionalChannelDisplayScale | (003A,0247): Fractional Channel Display Scale
FractionationNotes | (3010,007F): Fractionation Notes
FractionBasedRelationshipIntervalAnchor | (3010,0083): Fraction-Based Relationship Interval Anchor
FractionBasedRelationshipSequence | (3010,0082): Fraction-Based Relationship Sequence
FractionGroupDescription | (300A,0072): Fraction Group Description
FractionGroupNumber | (300A,0071): Fraction Group Number
FractionGroupSequence | (300A,0070): Fraction Group Sequence
FractionGroupSummarySequence | (3008,0220): Fraction Group Summary Sequence
FractionGroupType | (3008,0224): Fraction Group Type
FractionNumber | (3002,0029): Fraction Number
FractionPattern | (300A,007B): Fraction Pattern
FractionPatternSequence | (3010,0079): Fraction Pattern Sequence
FractionStatusSummarySequence | (3008,0240): Fraction Status Summary Sequence
FrameAcquisitionDateTime | (0018,9074): Frame Acquisition DateTime
FrameAcquisitionDuration | (0018,9220): Frame Acquisition Duration
FrameAcquisitionNumber | (0020,9156): Frame Acquisition Number
FrameAcquisitionSequence | (0018,9417): Frame Acquisition Sequence
FrameAnatomySequence | (0020,9071): Frame Anatomy Sequence
FrameComments | (0020,9158): Frame Comments
FrameContentSequence | (0020,9111): Frame Content Sequence
FrameDelay | (0018,1066): Frame Delay
FrameDetectorParametersSequence | (0018,9451): Frame Detector Parameters Sequence
FrameDimensionPointer | (0028,000A): Frame Dimension Pointer
FrameDisplaySequence | (0008,9458): Frame Display Sequence
FrameDisplayShutterSequence | (0018,9472): Frame Display Shutter Sequence
FrameExtractionSequence | (0008,1164): Frame Extraction Sequence
FrameIncrementPointer | (0028,0009): Frame Increment Pointer
FrameLabel | (0020,9453): Frame Label
FrameLabelVector | (0018,2002): Frame Label Vector
FrameLaterality | (0020,9072): Frame Laterality
FrameNumbersOfInterest | (0028,6020): Frame Numbers of Interest (FOI)
FrameOfInterestDescription | (0028,6022): Frame of Interest Description
FrameOfInterestType | (0028,6023): Frame of Interest Type
FrameOfReferenceRelationshipSequence | (3006,00C0): Frame of Reference Relationship Sequence
FrameOfReferenceToDisplayedCoordinateSystemTransformationMatrix | (0070,030B): Frame of Reference to Displayed Coordinate System Transformation Matrix
FrameOfReferenceTransformationComment | (3006,00C8): Frame of Reference Transformation Comment
FrameOfReferenceTransformationMatrix | (3006,00C6): Frame of Reference Transformation Matrix
FrameOfReferenceTransformationMatrixType | (0070,030C): Frame of Reference Transformation Matrix Type
FrameOfReferenceTransformationType | (3006,00C4): Frame of Reference Transformation Type
FrameOfReferenceUID | (0020,0052): Frame of Reference UID
FrameOriginTimestamp | (0034,0007): Frame Origin Timestamp
FramePixelDataPropertiesSequence | (0028,9443): Frame Pixel Data Properties Sequence
FramePixelShiftSequence | (0028,9415): Frame Pixel Shift Sequence
FramePrimaryAngleVector | (0018,2003): Frame Primary Angle Vector
FrameReferenceDateTime | (0018,9151): Frame Reference DateTime
FrameReferenceTime | (0054,1300): Frame Reference Time
FrameSecondaryAngleVector | (0018,2004): Frame Secondary Angle Vector
FrameTime | (0018,1063): Frame Time
FrameTimeVector | (0018,1065): Frame Time Vector
FrameType | (0008,9007): Frame Type
FrameUsefulnessGroupSequence | (0034,0009): Frame Usefulness Group Sequence
FrameVOILUTSequence | (0028,9132): Frame VOI LUT Sequence
FrequencyCorrection | (0018,9101): Frequency Correction
FrequencyEncodingCodeSequence | (003A,032C): Frequency Encoding Code Sequence
FunctionalGroupPointer | (0020,9167): Functional Group Pointer
FunctionalGroupPrivateCreator | (0020,9238): Functional Group Private Creator
FunctionalMRSequence | (0018,9621): Functional MR Sequence
FunctionalSettlingPhaseFramesPresent | (0018,9622): Functional Settling Phase Frames Present
FunctionalSyncPulse | (0018,9623): Functional Sync Pulse
GainControl | (0016,0047): Gain Control
GainCorrectionReferenceSequence | (0014,3060): Gain Correction Reference Sequence
GammaValue | (0028,701A): Gamma Value
GantryAngle | (300A,011E): Gantry Angle
GantryAngleTolerance | (300A,0044): Gantry Angle Tolerance
GantryDetectorSlew | (0018,1121): Gantry/Detector Slew
GantryDetectorTilt | (0018,1120): Gantry/Detector Tilt
GantryID | (0018,1008): Gantry ID
GantryMotionCorrected | (0018,9762): Gantry Motion Corrected
GantryPitchAngle | (300A,014A): Gantry Pitch Angle
GantryPitchAngleTolerance | (300A,014E): Gantry Pitch Angle Tolerance
GantryPitchRotationDirection | (300A,014C): Gantry Pitch Rotation Direction
GantryRotationDirection | (300A,011F): Gantry Rotation Direction
GantryType | (4010,1008): Gantry Type
GapLength | (0070,0261): Gap Length
GatedInformationSequence | (0054,0062): Gated Information Sequence
GateSettingsSequence | (0014,4060): Gate Settings Sequence
GateThreshold | (0014,4062): Gate Threshold
GatingBeamHoldTransitionSequence | (300C,0125): Gating Beam Hold Transition Sequence
GeneralAccessoryDefinitionSequence | (300A,0671): General Accessory Definition Sequence
GeneralAccessoryDescription | (300A,0422): General Accessory Description
GeneralAccessoryID | (300A,0421): General Accessory ID
GeneralAccessoryNumber | (300A,0424): General Accessory Number
GeneralAccessorySequence | (300A,0420): General Accessory Sequence
GeneralAccessoryType | (300A,0423): General Accessory Type
GeneralizedDefectCorrectedSensitivityDeviationFlag | (0024,0102): Generalized Defect Corrected Sensitivity Deviation Flag
GeneralizedDefectCorrectedSensitivityDeviationProbabilityValue | (0024,0104): Generalized Defect Corrected Sensitivity Deviation Probability Value
GeneralizedDefectCorrectedSensitivityDeviationValue | (0024,0103): Generalized Defect Corrected Sensitivity Deviation Value
GeneralizedDefectSensitivityDeviationAlgorithmSequence | (0024,0067): Generalized Defect Sensitivity Deviation Algorithm Sequence
GeneralMachineVerificationSequence | (0074,1042): General Machine Verification Sequence
GeneralMatchingSequence | (0008,0413): General Matching Sequence
GeneralPurposePerformedProcedureStepStatus | (0040,4002): General Purpose Performed Procedure Step Status
GeneralPurposeScheduledProcedureStepPriority | (0040,4003): General Purpose Scheduled Procedure Step Priority
GeneralPurposeScheduledProcedureStepStatus | (0040,4001): General Purpose Scheduled Procedure Step Status
GeneratorID | (0018,1005): Generator ID
GeneratorPower | (0018,1170): Generator Power
GeneticModificationsCodeSequence | (0010,0229): Genetic Modifications Code Sequence
GeneticModificationsDescription | (0010,0222): Genetic Modifications Description
GeneticModificationsNomenclature | (0010,0223): Genetic Modifications Nomenclature
GeneticModificationsSequence | (0010,0221): Genetic Modifications Sequence
GeometricalProperties | (0028,9444): Geometrical Properties
GeometricMaximumDistortion | (0028,9445): Geometric Maximum Distortion
GeometryForDisplay | (0070,1B08): Geometry for Display
GeometryOfKSpaceTraversal | (0018,9032): Geometry of k-Space Traversal
GlobalCrop | (0070,120B): Global Crop
GlobalCroppingSpecificationIndex | (0070,120C): Global Cropping Specification Index
GlobalDeviationFromNormal | (0024,0066): Global Deviation From Normal
GlobalDeviationProbability | (0024,0071): Global Deviation Probability
GlobalDeviationProbabilityNormalsFlag | (0024,0059): Global Deviation Probability Normals Flag
GlobalDeviationProbabilitySequence | (0024,0083): Global Deviation Probability Sequence
GPSAltitude | (0016,0076): GPS Altitude
GPSAltitudeRef | (0016,0075): GPS Altitude Ref
GPSAreaInformation | (0016,008C): GPS Area Information
GPSDateStamp | (0016,008D): GPS Date Stamp
GPSDestBearing | (0016,0088): GPS Dest Bearing
GPSDestBearingRef | (0016,0087): GPS Dest Bearing Ref
GPSDestDistance | (0016,008A): GPS Dest Distance
GPSDestDistanceRef | (0016,0089): GPS Dest Distance Ref
GPSDestLatitude | (0016,0084): GPS Dest Latitude
GPSDestLatitudeRef | (0016,0083): GPS Dest Latitude Ref
GPSDestLongitude | (0016,0086): GPS Dest Longitude
GPSDestLongitudeRef | (0016,0085): GPS Dest Longitude Ref
GPSDifferential | (0016,008E): GPS Differential
GPSDOP | (0016,007B): GPS DOP
GPSImgDirection | (0016,0081): GPS Img Direction
GPSImgDirectionRef | (0016,0080): GPS Img Direction Ref
GPSLatitude | (0016,0072): GPS Latitude
GPSLatitudeRef | (0016,0071): GPS Latitude Ref
GPSLongitude | (0016,0074): GPS Longitude
GPSLongitudeRef | (0016,0073): GPS Longitude Ref
GPSMapDatum | (0016,0082): GPS Map Datum
GPSMeasureMode | (0016,007A): GPS Measure Mode
GPSProcessingMethod | (0016,008B): GPS Processing Method
GPSSatellites | (0016,0078): GPS Satellites
GPSSpeed | (0016,007D): GPS Speed
GPSSpeedRef | (0016,007C): GPS Speed Ref
GPSStatus | (0016,0079): GPS Status
GPSTimeStamp | (0016,0077): GPS Time Stamp
GPSTrack | (0016,007F): GPS Track
GPSTrackRef | (0016,007E): GPS Track Ref
GPSVersionID | (0016,0070): GPS Version ID
GradientEchoTrainLength | (0018,9241): Gradient Echo Train Length
GradientOutput | (0018,9182): Gradient Output
GradientOutputType | (0018,9180): Gradient Output Type
GraphicAnnotationSequence | (0070,0001): Graphic Annotation Sequence
GraphicAnnotationUnits | (0070,0005): Graphic Annotation Units
GraphicCoordinatesDataSequence | (0070,0318): Graphic Coordinates Data Sequence
GraphicData | (0070,0022): Graphic Data
GraphicDimensions | (0070,0020): Graphic Dimensions
GraphicFilled | (0070,0024): Graphic Filled
GraphicGroupDescription | (0070,0208): Graphic Group Description
GraphicGroupID | (0070,0295): Graphic Group ID
GraphicGroupLabel | (0070,0207): Graphic Group Label
GraphicGroupSequence | (0070,0234): Graphic Group Sequence
GraphicLayer | (0070,0002): Graphic Layer
GraphicLayerDescription | (0070,0068): Graphic Layer Description
GraphicLayerOrder | (0070,0062): Graphic Layer Order
GraphicLayerRecommendedDisplayCIELabValue | (0070,0401): Graphic Layer Recommended Display CIELab Value
GraphicLayerRecommendedDisplayGrayscaleValue | (0070,0066): Graphic Layer Recommended Display Grayscale Value
GraphicLayerRecommendedDisplayRGBValue | (0070,0067): Graphic Layer Recommended Display RGB Value
GraphicLayerSequence | (0070,0060): Graphic Layer Sequence
GraphicObjectSequence | (0070,0009): Graphic Object Sequence
GraphicType | (0070,0023): Graphic Type
GrayLookupTableData | (0028,1200): Gray Lookup Table Data(Retired)
GrayLookupTableDescriptor | (0028,1100): Gray Lookup Table Descriptor(Retired)
GrayScale | (0028,1080): Gray Scale(Retired)
GreenPaletteColorLookupTableData | (0028,1202): Green Palette Color Lookup Table Data
GreenPaletteColorLookupTableDescriptor | (0028,1102): Green Palette Color Lookup Table Descriptor
Grid | (0018,1166): Grid
GridAbsorbingMaterial | (0018,7040): Grid Absorbing Material
GridAspectRatio | (0018,7046): Grid Aspect Ratio
GridDimensions | (0064,0007): Grid Dimensions
GridFocalDistance | (0018,704C): Grid Focal Distance
GridFrameOffsetVector | (3004,000C): Grid Frame Offset Vector
GridID | (0018,1006): Grid ID
GridPeriod | (0018,7048): Grid Period
GridPitch | (0018,7044): Grid Pitch
GridResolution | (0064,0008): Grid Resolution
GridSpacingMaterial | (0018,7041): Grid Spacing Material
GridThickness | (0018,7042): Grid Thickness
GroupOfPatientsIdentificationSequence | (0010,0027): Group of Patients Identification Sequence
HalfValueLayer | (0040,0314): Half Value Layer
HangingProtocolCreationDateTime | (0072,000A): Hanging Protocol Creation DateTime
HangingProtocolCreator | (0072,0008): Hanging Protocol Creator
HangingProtocolDefinitionSequence | (0072,000C): Hanging Protocol Definition Sequence
HangingProtocolDescription | (0072,0004): Hanging Protocol Description
HangingProtocolLevel | (0072,0006): Hanging Protocol Level
HangingProtocolName | (0072,0002): Hanging Protocol Name
HangingProtocolUserGroupName | (0072,0010): Hanging Protocol User Group Name
HangingProtocolUserIdentificationCodeSequence | (0072,000E): Hanging Protocol User Identification Code Sequence
HardcopyCreationDeviceID | (0018,1011): Hardcopy Creation Device ID
HardcopyDeviceManufacturer | (0018,1017): Hardcopy Device Manufacturer
HardcopyDeviceManufacturerModelName | (0018,101B): Hardcopy Device Manufacturer's Model Name
HardcopyDeviceSoftwareVersion | (0018,101A): Hardcopy Device Software Version
HeadFixationAngle | (300A,0148): Head Fixation Angle
HeadFixationAngleTolerance | (300A,0152): Head Fixation Angle Tolerance
HeartRate | (0018,1088): Heart Rate
HighBit | (0028,0102): High Bit
HighDoseTechniqueType | (300A,00C7): High-Dose Technique Type
HighEnergyDetectors | (4010,0002): High Energy Detectors
HighRRValue | (0018,1082): High R-R Value
HistogramBinWidth | (0060,3008): Histogram Bin Width
HistogramData | (0060,3020): Histogram Data
HistogramExplanation | (0060,3010): Histogram Explanation
HistogramFirstBinValue | (0060,3004): Histogram First Bin Value
HistogramLastBinValue | (0060,3006): Histogram Last Bin Value
HistogramNumberOfBins | (0060,3002): Histogram Number of Bins
HistogramSequence | (0060,3000): Histogram Sequence
HL7DocumentEffectiveTime | (0040,E004): HL7 Document Effective Time
HL7DocumentTypeCodeSequence | (0040,E006): HL7 Document Type Code Sequence
HL7InstanceIdentifier | (0040,E001): HL7 Instance Identifier
HL7StructuredDocumentReferenceSequence | (0040,A390): HL7 Structured Document Reference Sequence
HomeCommunityID | (0040,E031): Home Community ID
HorizontalAlignment | (0070,0242): Horizontal Alignment
HorizontalFieldOfView | (0022,000C): Horizontal Field of View
HorizontalOffsetOfSensor | (0014,3024): Horizontal Offset of Sensor
HorizontalPrismBase | (0046,0032): Horizontal Prism Base
HorizontalPrismPower | (0046,0030): Horizontal Prism Power
HPGLContourPenNumber | (0068,6310): HPGL Contour Pen Number
HPGLDocument | (0068,6300): HPGL Document
HPGLDocumentID | (0068,62D0): HPGL Document ID
HPGLDocumentLabel | (0068,62D5): HPGL Document Label
HPGLDocumentScaling | (0068,62F2): HPGL Document Scaling
HPGLDocumentSequence | (0068,62C0): HPGL Document Sequence
HPGLPenDescription | (0068,6345): HPGL Pen Description
HPGLPenLabel | (0068,6340): HPGL Pen Label
HPGLPenNumber | (0068,6330): HPGL Pen Number
HPGLPenSequence | (0068,6320): HPGL Pen Sequence
HuffmanTableSize | (1000,xxx2): Huffman Table Size
HuffmanTableTriplet | (1000,xxx3): Huffman Table Triplet
HumanPerformerCodeSequence | (0040,4009): Human Performer Code Sequence
HumanPerformerName | (0040,4037): Human Performer's Name
HumanPerformerOrganization | (0040,4036): Human Performer's Organization
Humidity | (0016,0031): Humidity
ICCProfile | (0028,2000): ICC Profile
IconImageSequence | (0088,0200): Icon Image Sequence
IdenticalDocumentsSequence | (0040,A525): Identical Documents Sequence
IdentificationDescriptionTrial | (0040,A224): Identification Description (Trial)
IdentifierCodeSequenceTrial | (0040,A070): Identifier Code Sequence (Trial)
IdentifierTypeCode | (0040,0035): Identifier Type Code
IdentifyingComments | (0008,4000): Identifying Comments(Retired)
IdentifyingPrivateElements | (0008,0306): Identifying Private Elements
Illumination | (2010,015E): Illumination
IlluminationBandwidth | (0022,0057): Illumination Bandwidth
IlluminationColorCodeSequence | (0048,0108): Illumination Color Code Sequence
IlluminationPower | (0022,0056): Illumination Power
IlluminationTranslationFlag | (0018,9828): Illumination Translation Flag
IlluminationTypeCodeSequence | (0022,0016): Illumination Type Code Sequence
IlluminationWaveLength | (0022,0055): Illumination Wave Length
IlluminatorTypeCodeSequence | (0048,0100): Illuminator Type Code Sequence
ImageAcquisitionDepth | (0048,0117): Image Acquisition Depth
ImageAndFluoroscopyAreaDoseProduct | (0018,115E): Image and Fluoroscopy Area Dose Product
ImageBoxContentSequence | (2130,0040): Image Box Content Sequence
ImageBoxesSequence | (0072,0300): Image Boxes Sequence
ImageBoxLargeScrollAmount | (0072,0318): Image Box Large Scroll Amount
ImageBoxLargeScrollType | (0072,0316): Image Box Large Scroll Type
ImageBoxLayoutType | (0072,0304): Image Box Layout Type
ImageBoxNumber | (0072,0302): Image Box Number
ImageBoxOverlapPriority | (0072,0320): Image Box Overlap Priority
ImageBoxPosition | (2020,0010): Image Box Position
ImageBoxPresentationLUTFlag | (2000,006A): Image Box Presentation LUT Flag
ImageBoxScrollDirection | (0072,0310): Image Box Scroll Direction
ImageBoxSmallScrollAmount | (0072,0314): Image Box Small Scroll Amount
ImageBoxSmallScrollType | (0072,0312): Image Box Small Scroll Type
ImageBoxSynchronizationSequence | (0072,0430): Image Box Synchronization Sequence
ImageBoxTileHorizontalDimension | (0072,0306): Image Box Tile Horizontal Dimension
ImageBoxTileVerticalDimension | (0072,0308): Image Box Tile Vertical Dimension
ImageCenterPointCoordinatesSequence | (0040,071A): Image Center Point Coordinates Sequence
ImageComments | (0020,4000): Image Comments
ImageDataLocation | (0028,08x8): Image Data Location
ImageDataTypeCodeSequence | (0018,9836): Image Data Type Code Sequence
ImageDataTypeSequence | (0018,9807): Image Data Type Sequence
ImageDimensions | (0028,0005): Image Dimensions(Retired)
ImageDisplayFormat | (2010,0010): Image Display Format
ImagedNucleus | (0018,0085): Imaged Nucleus
ImagedVolumeDepth | (0048,0003): Imaged Volume Depth
ImagedVolumeHeight | (0048,0002): Imaged Volume Height
ImagedVolumeWidth | (0048,0001): Imaged Volume Width
ImageFilter | (0018,9320): Image Filter
ImageFilterDescription | (0018,9941): Image Filter Description
ImageFilterDetailsSequence | (0018,11BF): Image Filter Details Sequence
ImageFormat | (0028,0040): Image Format(Retired)
ImageFrameOrigin | (60xx,0051): Image Frame Origin
ImageGeometryType | (0020,0070): Image Geometry Type(Retired)
ImageHorizontalFlip | (0070,0041): Image Horizontal Flip
ImageID | (0054,0400): Image ID
ImageIndex | (0054,1330): Image Index
ImageLaterality | (0020,0062): Image Laterality
ImageLocation | (0028,0200): Image Location(Retired)
ImageOrientation | (0020,0035): Image Orientation(Retired)
ImageOrientationPatient | (0020,0037): Image Orientation (Patient)
ImageOrientationSlide | (0048,0102): Image Orientation (Slide)
ImageOrientationVolume | (0020,9302): Image Orientation (Volume)
ImageOverlayBoxContentSequence | (2130,0060): Image Overlay Box Content Sequence
ImageOverlayFlag | (2000,0067): Image Overlay Flag
ImagePathFilterPassBand | (0022,0004): Image Path Filter Pass Band
ImagePathFilterPassThroughWavelength | (0022,0003): Image Path Filter Pass-Through Wavelength
ImagePathFilterTypeStackCodeSequence | (0022,0018): Image Path Filter Type Stack Code Sequence
ImagePlanePixelSpacing | (3002,0011): Image Plane Pixel Spacing
ImagePosition | (0020,0030): Image Position(Retired)
ImagePositionPatient | (0020,0032): Image Position (Patient)
ImagePositionVolume | (0020,9301): Image Position (Volume)
ImagePresentationComments | (0028,4000): Image Presentation Comments(Retired)
ImageProcessingApplied | (0028,9446): Image Processing Applied
ImageQualityIndicatorMaterial | (0014,40A1): Image Quality Indicator Material
ImageQualityIndicatorSize | (0014,40A2): Image Quality Indicator Size
ImageQualityIndicatorType | (0014,40A0): Image Quality Indicator Type
ImageReceptorPositionSequence | (3002,010E): Image Receptor Position Sequence
ImageRotation | (0070,0042): Image Rotation
ImageRotationRetired | (0070,0040): Image Rotation (Retired)
ImagerPixelSpacing | (0018,1164): Imager Pixel Spacing
ImageScaleRepresentation | (4010,1075): Image Scale Representation
ImageSetLabel | (0072,0040): Image Set Label
ImageSetNumber | (0072,0032): Image Set Number
ImageSetSelectorCategory | (0072,0034): Image Set Selector Category
ImageSetSelectorSequence | (0072,0022): Image Set Selector Sequence
ImageSetSelectorUsageFlag | (0072,0024): Image Set Selector Usage Flag
ImageSetsSequence | (0072,0020): Image Sets Sequence
ImagesInAcquisition | (0020,1002): Images in Acquisition
ImagesInSeries | (0020,1003): Images in Series
ImagesInStudy | (0020,1005): Images in Study
ImageToEquipmentMappingMatrix | (0028,9520): Image to Equipment Mapping Matrix
ImageTransformationMatrix | (0018,5210): Image Transformation Matrix
ImageTranslationVector | (0018,5212): Image Translation Vector
ImageTriggerDelay | (0018,1067): Image Trigger Delay
ImageType | (0008,0008): Image Type
ImageVolumeGeometry | (0070,1208): Image Volume Geometry
ImagingApertureSequence | (3002,0114): Imaging Aperture Sequence
ImagingApertureSpecificationType | (3002,0115): Imaging Aperture Specification Type
ImagingDeviceLocationMatrixSequence | (3002,0112): Imaging Device Location Matrix Sequence
ImagingDeviceLocationParameterSequence | (3002,0113): Imaging Device Location Parameter Sequence
ImagingDeviceSpecificAcquisitionParameters | (300A,00CC): Imaging Device-Specific Acquisition Parameters
ImagingEquipmentToTreatmentDeliveryDeviceRelationshipSequence | (300A,07A1): Imaging Equipment to Treatment Delivery Device Relationship Sequence
ImagingFrequency | (0018,0084): Imaging Frequency
ImagingServiceRequestComments | (0040,2400): Imaging Service Request Comments
ImagingSourceLocationSpecificationType | (3002,0111): Imaging Source Location Specification Type
ImagingSourcePositionSequence | (3002,010D): Imaging Source Position Sequence
ImagingSourceToBeamModifierDefinitionPlaneDistance | (3002,012D): Imaging Source to Beam Modifier Definition Plane Distance
ImmersionMedia | (0016,1004): Immersion Media
ImpedanceMeasurementCurrentType | (003A,0316): Impedance Measurement Current Type
ImpedanceMeasurementDateTime | (003A,0314): Impedance Measurement DateTime
ImpedanceMeasurementFrequency | (003A,0315): Impedance Measurement Frequency
ImpedanceValue | (003A,0313): Impedance Value
ImplantAssemblyTemplateIssuer | (0076,0003): Implant Assembly Template Issuer
ImplantAssemblyTemplateName | (0076,0001): Implant Assembly Template Name
ImplantAssemblyTemplateTargetAnatomySequence | (0076,0010): Implant Assembly Template Target Anatomy Sequence
ImplantAssemblyTemplateType | (0076,000A): Implant Assembly Template Type
ImplantAssemblyTemplateVersion | (0076,0006): Implant Assembly Template Version
ImplantName | (0022,1095): Implant Name
ImplantPartNumber | (0022,1097): Implant Part Number
ImplantRegulatoryDisapprovalCodeSequence | (0068,62A0): Implant Regulatory Disapproval Code Sequence
ImplantSize | (0068,6210): Implant Size
ImplantTargetAnatomySequence | (0068,6230): Implant Target Anatomy Sequence
ImplantTemplate3DModelSurfaceNumber | (0068,6350): Implant Template 3D Model Surface Number
ImplantTemplateGroupDescription | (0078,0010): Implant Template Group Description
ImplantTemplateGroupIssuer | (0078,0020): Implant Template Group Issuer
ImplantTemplateGroupMemberID | (0078,002E): Implant Template Group Member ID
ImplantTemplateGroupMemberMatching2DCoordinatesSequence | (0078,0070): Implant Template Group Member Matching 2D Coordinates Sequence
ImplantTemplateGroupMembersSequence | (0078,002A): Implant Template Group Members Sequence
ImplantTemplateGroupName | (0078,0001): Implant Template Group Name
ImplantTemplateGroupTargetAnatomySequence | (0078,0028): Implant Template Group Target Anatomy Sequence
ImplantTemplateGroupVariationDimensionName | (0078,00B2): Implant Template Group Variation Dimension Name
ImplantTemplateGroupVariationDimensionRank | (0078,00B8): Implant Template Group Variation Dimension Rank
ImplantTemplateGroupVariationDimensionRankSequence | (0078,00B4): Implant Template Group Variation Dimension Rank Sequence
ImplantTemplateGroupVariationDimensionSequence | (0078,00B0): Implant Template Group Variation Dimension Sequence
ImplantTemplateGroupVersion | (0078,0024): Implant Template Group Version
ImplantTemplateVersion | (0068,6221): Implant Template Version
ImplantType | (0068,6223): Implant Type
ImplantTypeCodeSequence | (0068,63A8): Implant Type Code Sequence
ImplementationClassUID | (0002,0012): Implementation Class UID
ImplementationVersionName | (0002,0013): Implementation Version Name
Impressions | (4008,0300): Impressions
InboundArrivalType | (4010,1056): Inbound Arrival Type
IncidentAngle | (0014,4052): Incident Angle
IncludeDisplayApplication | (2200,0009): Include Display Application
IncludeNonDICOMObjects | (2200,0008): Include Non-DICOM Objects
IncludesImagingSubject | (0034,0008): Includes Imaging Subject
IncludesInformation | (0034,000C): Includes Information
InConcatenationNumber | (0020,9162): In-concatenation Number
InConcatenationTotalNumber | (0020,9163): In-concatenation Total Number
IncorporatedInventoryInstanceSequence | (0008,0422): Incorporated Inventory Instance Sequence
IndexNormalsFlag | (0024,0338): Index Normals Flag
IndexProbability | (0024,0341): Index Probability
IndexProbabilitySequence | (0024,0344): Index Probability Sequence
IndicationDescription | (0014,2018): Indication Description
IndicationDisposition | (0014,201C): Indication Disposition
IndicationLabel | (0014,2016): Indication Label
IndicationNumber | (0014,2014): Indication Number
IndicationPhysicalPropertySequence | (0014,2030): Indication Physical Property Sequence
IndicationROISequence | (0014,201E): Indication ROI Sequence
IndicationSequence | (0014,2012): Indication Sequence
IndicationType | (0014,201A): Indication Type
InformationFromManufacturerSequence | (0068,6260): Information From Manufacturer Sequence
InformationIssueDateTime | (0068,6270): Information Issue DateTime
InformationSummary | (0068,6280): Information Summary
InitialCineRunState | (0018,0042): Initial Cine Run State
Initiator | (0000,0200): Initiator(Retired)
InnerDiameter | (0014,0056): Inner Diameter
InPlanePhaseEncodingDirection | (0018,1312): In-plane Phase Encoding Direction
InputAvailabilityFlag | (0040,4020): Input Availability Flag
InputInformationSequence | (0040,4021): Input Information Sequence
InputReadinessState | (0040,4041): Input Readiness State
InputSequencePositionIndex | (0070,1203): Input Sequence Position Index
InspectionSelectionCriteria | (4010,107C): Inspection Selection Criteria
InStackPositionNumber | (0020,9057): In-Stack Position Number
InstanceAvailability | (0008,0056): Instance Availability
InstanceCoercionDateTime | (0008,0015): Instance Coercion DateTime
InstanceCreationDate | (0008,0012): Instance Creation Date
InstanceCreationTime | (0008,0013): Instance Creation Time
InstanceCreatorUID | (0008,0014): Instance Creator UID
InstanceLevelReferencedPerformedProcedureStepSequence | (3010,0044): Instance-Level Referenced Performed Procedure Step Sequence
InstanceNumber | (0020,0013): Instance Number
InstanceOriginStatus | (0400,0600): Instance Origin Status
InstitutionAddress | (0008,0081): Institution Address
InstitutionalDepartmentName | (0008,1040): Institutional Department Name
InstitutionalDepartmentTypeCodeSequence | (0008,1041): Institutional Department Type Code Sequence
InstitutionCodeSequence | (0008,0082): Institution Code Sequence
InstitutionName | (0008,0080): Institution Name
InstructionDescription | (0018,9917): Instruction Description
InstructionIndex | (0018,9915): Instruction Index
InstructionPerformanceComment | (0018,991A): Instruction Performance Comment
InstructionPerformedDateTime | (0018,9919): Instruction Performed DateTime
InstructionPerformedFlag | (0018,9918): Instruction Performed Flag
InstructionSequence | (0018,9914): Instruction Sequence
InstructionText | (0018,9916): Instruction Text
InsurancePlanIdentification | (0010,1050): Insurance Plan Identification(Retired)
IntendedDeliveryDuration | (3010,007E): Intended Delivery Duration
IntendedFractionStartTime | (3010,0085): Intended Fraction Start Time
IntendedNumberOfFractions | (300A,0636): Intended Number of Fractions
IntendedPhaseEndDate | (3010,004D): Intended Phase End Date
IntendedPhaseStartDate | (3010,004C): Intended Phase Start Date
IntendedRecipientsOfResultsIdentificationSequence | (0040,1011): Intended Recipients of Results Identification Sequence
IntendedRTTreatmentPhaseSequence | (3010,004B): Intended RT Treatment Phase Sequence
IntendedStartDayOfWeek | (3010,0086): Intended Start Day of Week
IntensifierActiveDimensions | (0018,9428): Intensifier Active Dimension(s)
IntensifierActiveShape | (0018,9427): Intensifier Active Shape
IntensifierSize | (0018,1162): Intensifier Size
InterlockCodeSequence | (300A,0744): Interlock Code Sequence
InterlockDateTime | (300A,0741): Interlock DateTime
InterlockDescription | (300A,0742): Interlock Description
InterlockOriginatingDeviceSequence | (300A,0743): Interlock Originating Device Sequence
InterlockOriginDescription | (300A,0783): Interlock Origin Description
InterlockResolutionCodeSequence | (300A,0745): Interlock Resolution Code Sequence
InterlockResolutionUserSequence | (300A,0746): Interlock Resolution User Sequence
InterlockSequence | (300A,0740): Interlock Sequence
InterMarkerDistance | (0050,0019): Inter-Marker Distance
IntermediatePupillaryDistance | (0046,0063): Intermediate Pupillary Distance
InternalDetectorFrameTime | (0014,3011): Internal Detector Frame Time
InternationalRouteSegment | (4010,1028): International Route Segment
InteroperabilityIndex | (0016,0061): Interoperability Index
InteroperabilityVersion | (0016,0062): Interoperability Version
InterpolationType | (0052,0039): Interpolation Type
InterpretationApprovalDate | (4008,0112): Interpretation Approval Date
InterpretationApprovalTime | (4008,0113): Interpretation Approval Time
InterpretationApproverSequence | (4008,0111): Interpretation Approver Sequence
InterpretationAuthor | (4008,010C): Interpretation Author
InterpretationDiagnosisCodeSequence | (4008,0117): Interpretation Diagnosis Code Sequence
InterpretationDiagnosisDescription | (4008,0115): Interpretation Diagnosis Description
InterpretationID | (4008,0200): Interpretation ID
InterpretationIDIssuer | (4008,0202): Interpretation ID Issuer
InterpretationRecordedDate | (4008,0100): Interpretation Recorded Date
InterpretationRecordedTime | (4008,0101): Interpretation Recorded Time
InterpretationRecorder | (4008,0102): Interpretation Recorder
InterpretationStatusID | (4008,0212): Interpretation Status ID
InterpretationText | (4008,010B): Interpretation Text
InterpretationTranscriber | (4008,010A): Interpretation Transcriber
InterpretationTranscriptionDate | (4008,0108): Interpretation Transcription Date
InterpretationTranscriptionTime | (4008,0109): Interpretation Transcription Time
InterpretationTypeID | (4008,0210): Interpretation Type ID
IntervalNumber | (0020,0016): Interval Number
IntervalsAcquired | (0018,1083): Intervals Acquired
IntervalsRejected | (0018,1084): Intervals Rejected
InterventionDescription | (0018,003A): Intervention Description
InterventionDrugCodeSequence | (0018,0029): Intervention Drug Code Sequence
InterventionDrugDose | (0018,0028): Intervention Drug Dose
InterventionDrugInformationSequence | (0018,0026): Intervention Drug Information Sequence
InterventionDrugName | (0018,0034): Intervention Drug Name
InterventionDrugStartTime | (0018,0035): Intervention Drug Start Time
InterventionDrugStopTime | (0018,0027): Intervention Drug Stop Time
InterventionSequence | (0018,0036): Intervention Sequence
InterventionStatus | (0018,0038): Intervention Status
IntraocularLensCalculationsLeftEyeSequence | (0022,1310): Intraocular Lens Calculations Left Eye Sequence
IntraocularLensCalculationsRightEyeSequence | (0022,1300): Intraocular Lens Calculations Right Eye Sequence
IntraOcularPressure | (0022,000B): Intra Ocular Pressure
IntravascularFrameContentSequence | (0052,0027): Intravascular Frame Content Sequence
IntravascularLongitudinalDistance | (0052,0028): Intravascular Longitudinal Distance
IntravascularOCTFrameContentSequence | (0052,0029): Intravascular OCT Frame Content Sequence
IntravascularOCTFrameTypeSequence | (0052,0025): Intravascular OCT Frame Type Sequence
InventoriedInstancesSequence | (0008,0425): Inventoried Instances Sequence
InventoriedSeriesSequence | (0008,0424): Inventoried Series Sequence
InventoriedStudiesSequence | (0008,0423): Inventoried Studies Sequence
InventoryAccessEndPointsSequence | (0008,0420): Inventory Access End Points Sequence
InventoryCompletionStatus | (0008,0426): Inventory Completion Status
InventoryInstanceDescription | (0008,0402): Inventory Instance Description
InventoryLevel | (0008,0403): Inventory Level
InventoryPurpose | (0008,0401): Inventory Purpose
InversionRecovery | (0018,9009): Inversion Recovery
InversionTime | (0018,0082): Inversion Time
InversionTimes | (0018,9079): Inversion Times
IOLFormulaCodeSequence | (0022,1028): IOL Formula Code Sequence
IOLFormulaDetail | (0022,1029): IOL Formula Detail
IOLManufacturer | (0022,1093): IOL Manufacturer
IOLPower | (0022,1053): IOL Power
IOLPowerForExactEmmetropia | (0022,1121): IOL Power For Exact Emmetropia
IOLPowerForExactTargetRefraction | (0022,1122): IOL Power For Exact Target Refraction
IOLPowerSequence | (0022,1090): IOL Power Sequence
IonBeamLimitingDeviceSequence | (300A,03A4): Ion Beam Limiting Device Sequence
IonBeamSequence | (300A,03A2): Ion Beam Sequence
IonBlockSequence | (300A,03A6): Ion Block Sequence
IonControlPointDeliverySequence | (3008,0041): Ion Control Point Delivery Sequence
IonControlPointSequence | (300A,03A8): Ion Control Point Sequence
IonControlPointVerificationSequence | (0074,104E): Ion Control Point Verification Sequence
IonMachineVerificationSequence | (0074,1046): Ion Machine Verification Sequence
IonRangeCompensatorSequence | (300A,02EA): Ion Range Compensator Sequence
IonToleranceTableSequence | (300A,03A0): Ion Tolerance Table Sequence
IonWedgePositionSequence | (300A,03AC): Ion Wedge Position Sequence
IonWedgeSequence | (300A,03AA): Ion Wedge Sequence
IrradiationEventIdentificationSequence | (0018,9477): Irradiation Event Identification Sequence
IrradiationEventUID | (0008,3010): Irradiation Event UID
IsocenterPosition | (300A,012C): Isocenter Position
IsocenterReferenceSystemSequence | (0018,9462): Isocenter Reference System Sequence
IsocenterToBeamLimitingDeviceDistance | (300A,00BB): Isocenter to Beam Limiting Device Distance
IsocenterToBlockTrayDistance | (300A,00F7): Isocenter to Block Tray Distance
IsocenterToCompensatorDistances | (300A,02E6): Isocenter to Compensator Distances
IsocenterToCompensatorTrayDistance | (300A,02E4): Isocenter to Compensator Tray Distance
IsocenterToGeneralAccessoryDistance | (300A,0426): Isocenter to General Accessory Distance
IsocenterToLateralSpreadingDeviceDistance | (300A,0374): Isocenter to Lateral Spreading Device Distance
IsocenterToRangeModulatorDistance | (300A,038A): Isocenter to Range Modulator Distance
IsocenterToRangeShifterDistance | (300A,0364): Isocenter to Range Shifter Distance
IsocenterToWedgeTrayDistance | (300A,00D9): Isocenter to Wedge Tray Distance
ISOSpeed | (0016,001D): ISO Speed
ISOSpeedLatitudeyyy | (0016,001E): ISO Speed Latitude yyy
ISOSpeedLatitudezzz | (0016,001F): ISO Speed Latitude zzz
IsotopeNumber | (0020,0014): Isotope Number
IssueDateOfImagingServiceRequest | (0040,2004): Issue Date of Imaging Service Request
IssuerOfAccessionNumberSequence | (0008,0051): Issuer of Accession Number Sequence
IssuerOfAdmissionID | (0038,0011): Issuer of Admission ID
IssuerOfAdmissionIDSequence | (0038,0014): Issuer of Admission ID Sequence
IssuerOfClinicalTrialProtocolID | (0012,0022): Issuer of Clinical Trial Protocol ID
IssuerOfClinicalTrialSeriesID | (0012,0073): Issuer of Clinical Trial Series ID
IssuerOfClinicalTrialSiteID | (0012,0032): Issuer of Clinical Trial Site ID
IssuerOfClinicalTrialSubjectID | (0012,0041): Issuer of Clinical Trial Subject ID
IssuerOfClinicalTrialSubjectReadingID | (0012,0043): Issuer of Clinical Trial Subject Reading ID
IssuerOfClinicalTrialTimePointID | (0012,0055): Issuer of Clinical Trial Time Point ID
IssuerOfPatientID | (0010,0021): Issuer of Patient ID
IssuerOfPatientIDQualifiersSequence | (0010,0024): Issuer of Patient ID Qualifiers Sequence
IssuerOfServiceEpisodeID | (0038,0061): Issuer of Service Episode ID
IssuerOfServiceEpisodeIDSequence | (0038,0064): Issuer of Service Episode ID Sequence
IssuerOfTheContainerIdentifierSequence | (0040,0513): Issuer of the Container Identifier Sequence
IssuerOfTheSpecimenIdentifierSequence | (0040,0562): Issuer of the Specimen Identifier Sequence
IssueTimeOfImagingServiceRequest | (0040,2005): Issue Time of Imaging Service Request
Italic | (0070,0250): Italic
Item | (FFFE,E000): Item
ItemDelimitationItem | (FFFE,E00D): Item Delimitation Item
ItemInventoryDateTime | (0008,0404): Item Inventory DateTime
ItemNumber | (0020,0019): Item Number
IterativeReconstructionMethod | (0018,9769): Iterative Reconstruction Method
ItineraryID | (4010,1051): Itinerary ID
ItineraryIDAssigningAuthority | (4010,1053): Itinerary ID Assigning Authority
ItineraryIDType | (4010,1052): Itinerary ID Type
IVUSAcquisition | (0018,3100): IVUS Acquisition
IVUSGatedRate | (0018,3102): IVUS Gated Rate
IVUSPullbackRate | (0018,3101): IVUS Pullback Rate
IVUSPullbackStartFrameNumber | (0018,3103): IVUS Pullback Start Frame Number
IVUSPullbackStopFrameNumber | (0018,3104): IVUS Pullback Stop Frame Number
KeratoconusPredictionIndex | (0046,0236): Keratoconus Prediction Index
KeratometerIndex | (0022,1033): Keratometer Index
KeratometricAxis | (0046,0077): Keratometric Axis
KeratometricPower | (0046,0076): Keratometric Power
KeratometryLeftEyeSequence | (0046,0071): Keratometry Left Eye Sequence
KeratometryMeasurementTypeCodeSequence | (0022,1096): Keratometry Measurement Type Code Sequence
KeratometryRightEyeSequence | (0046,0070): Keratometry Right Eye Sequence
KSpaceFiltering | (0018,9064): k-space Filtering
KVImagingGenerationParametersSequence | (3002,0127): KV Imaging Generation Parameters Sequence
KVP | (0018,0060): KVP
KVUsedInGainCalibration | (0014,3071): KV Used in Gain Calibration
LabelStyleSelection | (2200,0003): Label Style Selection
LabelText | (2200,0002): Label Text
LabelUsingInformationExtractedFromInstances | (2200,0001): Label Using Information Extracted From Instances
LanguageCodeSequence | (0008,0006): Language Code Sequence
LanguageCodeSequenceTrial | (0040,A744): Language Code Sequence (Trial)
LargeBluePaletteColorLookupTableData | (0028,1213): Large Blue Palette Color Lookup Table Data
LargeBluePaletteColorLookupTableDescriptor | (0028,1113): Large Blue Palette Color Lookup Table Descriptor
LargeGreenPaletteColorLookupTableData | (0028,1212): Large Green Palette Color Lookup Table Data
LargeGreenPaletteColorLookupTableDescriptor | (0028,1112): Large Green Palette Color Lookup Table Descriptor
LargePaletteColorLookupTableUID | (0028,1214): Large Palette Color Lookup Table UID
LargeRedPaletteColorLookupTableData | (0028,1211): Large Red Palette Color Lookup Table Data
LargeRedPaletteColorLookupTableDescriptor | (0028,1111): Large Red Palette Color Lookup Table Descriptor
LargestImagePixelValue | (0028,0107): Largest Image Pixel Value
LargestImagePixelValueInPlane | (0028,0111): Largest Image Pixel Value in Plane
LargestMonochromePixelValue | (0028,9099): Largest Monochrome Pixel Value
LargestPixelValueInSeries | (0028,0109): Largest Pixel Value in Series
LargestValidPixelValue | (0028,0105): Largest Valid Pixel Value(Retired)
LastMenstrualDate | (0010,21D0): Last Menstrual Date
Laterality | (0020,0060): Laterality
LateralSpreadingDeviceDescription | (300A,033A): Lateral Spreading Device Description
LateralSpreadingDeviceID | (300A,0336): Lateral Spreading Device ID
LateralSpreadingDeviceNumber | (300A,0334): Lateral Spreading Device Number
LateralSpreadingDeviceSequence | (300A,0332): Lateral Spreading Device Sequence
LateralSpreadingDeviceSetting | (300A,0372): Lateral Spreading Device Setting
LateralSpreadingDeviceSettingsSequence | (300A,0370): Lateral Spreading Device Settings Sequence
LateralSpreadingDeviceType | (300A,0338): Lateral Spreading Device Type
LateralSpreadingDeviceWaterEquivalentThickness | (300A,033C): Lateral Spreading Device Water Equivalent Thickness
LeafJawPositions | (300A,011C): Leaf/Jaw Positions
LeafPositionBoundaries | (300A,00BE): Leaf Position Boundaries
LeftImageSequence | (0022,0021): Left Image Sequence
LeftLensSequence | (0046,0015): Left Lens Sequence
LengthToEnd | (0008,0001): Length to End(Retired)
LensConstantDescription | (0022,1094): Lens Constant Description
LensConstantSequence | (0022,1092): Lens Constant Sequence
LensDescription | (0046,0012): Lens Description
LensesCodeSequence | (0022,0019): Lenses Code Sequence
LensMake | (0016,004F): Lens Make
LensModel | (0016,0050): Lens Model
LensSegmentType | (0046,0038): Lens Segment Type
LensSerialNumber | (0016,0051): Lens Serial Number
LensSpecification | (0016,004E): Lens Specification
LensStatusCodeSequence | (0022,1024): Lens Status Code Sequence
LensStatusDescription | (0022,1065): Lens Status Description
LensThickness | (0022,1130): Lens Thickness
LensThicknessSequence | (0022,1127): Lens Thickness Sequence
LesionNumber | (0018,3105): Lesion Number
LightDirection | (0070,1703): Light Direction
LightPathFilterPassBand | (0022,0002): Light Path Filter Pass Band
LightPathFilterPassThroughWavelength | (0022,0001): Light Path Filter Pass-Through Wavelength
LightPathFilterTypeStackCodeSequence | (0022,0017): Light Path Filter Type Stack Code Sequence
LightSource | (0016,0028): Light Source
LightSourcePolarization | (0016,1001): Light Source Polarization
LINACEnergy | (0014,5002): LINAC Energy
LINACOutput | (0014,5004): LINAC Output
LinearityCorrectionTechnique | (0014,3100): Linearity Correction Technique
LineDashingStyle | (0070,0254): Line Dashing Style
LinePattern | (0070,0255): Line Pattern
LineSequence | (0066,0028): Line Sequence
LineStyleSequence | (0070,0232): Line Style Sequence
LineThickness | (0070,0253): Line Thickness
ListOfMIMETypes | (0042,0014): List of MIME Types
ListOfUIDMatchingSequence | (0008,0411): List of UID Matching Sequence
LocalDeviationProbabilityNormalsFlag | (0024,0072): Local Deviation Probability Normals Flag
LocalizedDeviationFromNormal | (0024,0068): Localized Deviation From Normal
LocalizedDeviationProbability | (0024,0073): Localized Deviation Probability
LocalizedDeviationProbabilitySequence | (0024,0085): Localized Deviation Probability Sequence
LocalizingCursorPosition | (0018,2043): Localizing Cursor Position
LocalNamespaceEntityID | (0040,0031): Local Namespace Entity ID
Location | (0020,0050): Location(Retired)
LocationOfMeasuredBeamDiameter | (0014,4019): Location of Measured Beam Diameter
LongCodeValue | (0008,0119): Long Code Value
LongDeviceDescription | (0050,0021): Long Device Description
LongEdgePointIndexList | (0066,0042): Long Edge Point Index List
LongitudinalTemporalEventType | (0012,0053): Longitudinal Temporal Event Type
LongitudinalTemporalInformationModified | (0028,0303): Longitudinal Temporal Information Modified
LongitudinalTemporalOffsetFromEvent | (0012,0052): Longitudinal Temporal Offset from Event
LongPrimitivePointIndexList | (0066,0040): Long Primitive Point Index List
LongTrianglePointIndexList | (0066,0041): Long Triangle Point Index List
LongVertexPointIndexList | (0066,0043): Long Vertex Point Index List
LossyImageCompression | (0028,2110): Lossy Image Compression
LossyImageCompressionMethod | (0028,2114): Lossy Image Compression Method
LossyImageCompressionRatio | (0028,2112): Lossy Image Compression Ratio
LossyImageCompressionRetired | (0008,2110): Lossy Image Compression (Retired)
LowEnergyDetectors | (4010,0001): Low Energy Detectors
LowerCutoffFrequency | (0018,982F): Lower Cutoff Frequency
LowRRValue | (0018,1081): Low R-R Value
LuminanceCharacteristicsID | (0028,7009): Luminance Characteristics ID
LuminanceResponseDescription | (0028,7020): Luminance Response Description
LuminanceResponseSequence | (0028,701C): Luminance Response Sequence
LuminanceResultSequence | (0028,7024): Luminance Result Sequence
LuminanceUniformityResultSequence | (0028,7027): Luminance Uniformity Result Sequence
LuminanceValue | (0028,701F): Luminance Value
LUTData | (0028,3006): LUT Data
LUTDescriptor | (0028,3002): LUT Descriptor
LUTExplanation | (0028,3003): LUT Explanation
LUTFrameRange | (0028,9507): LUT Frame Range
LUTFunction | (0028,9474): LUT Function
LUTLabel | (0040,9210): LUT Label
LUTNumber | (0020,0026): LUT Number
MAC | (0400,0404): MAC
MACAlgorithm | (0400,0015): MAC Algorithm
MACCalculationTransferSyntaxUID | (0400,0010): MAC Calculation Transfer Syntax UID
MachineSpecificTreatmentTerminationCodeSequence | (300A,0716): Machine-Specific Treatment Termination Code Sequence
MACIDNumber | (0400,0005): MAC ID Number
MACParametersSequence | (4FFE,0001): MAC Parameters Sequence
MagneticFieldStrength | (0018,0087): Magnetic Field Strength
MagnetizationTransfer | (0018,9020): Magnetization Transfer
MagnificationType | (2010,0060): Magnification Type
MagnifyToNumberOfColumns | (2040,0074): Magnify to Number of Columns
MagnitudeEncodingCodeSequence | (003A,032D): Magnitude Encoding Code Sequence
MainLobeAngle | (0014,5103): Main Lobe Angle
MainRoofAngle | (0014,5104): Main Roof Angle
MajorTicksSequence | (0070,0287): Major Ticks Sequence
MakerNote | (0016,002B): Maker Note
MandatoryComponentType | (0076,0038): Mandatory Component Type
Manifold | (0066,0010): Manifold
ManipulatedImage | (0028,0050): Manipulated Image(Retired)
Manufacturer | (0008,0070): Manufacturer
ManufacturerDeviceClassUID | (0018,100B): Manufacturer's Device Class UID
ManufacturerDeviceIdentifier | (3010,0043): Manufacturer's Device Identifier
ManufacturerModelName | (0008,1090): Manufacturer's Model Name
ManufacturerModelVersion | (3010,001A): Manufacturer's Model Version
ManufacturerRelatedModelGroup | (0008,0222): Manufacturer's Related Model Group
MappedPixelValue | (0022,1452): Mapped Pixel Value
MappingResource | (0008,0105): Mapping Resource
MappingResourceIdentificationSequence | (0008,0124): Mapping Resource Identification Sequence
MappingResourceName | (0008,0122): Mapping Resource Name
MappingResourceUID | (0008,0118): Mapping Resource UID
MaskFrameNumbers | (0028,6110): Mask Frame Numbers
MaskingImage | (0020,0080): Masking Image(Retired)
MaskOperation | (0028,6101): Mask Operation
MaskOperationExplanation | (0028,6190): Mask Operation Explanation
MaskPointers | (0028,6030): Mask Pointer(s)
MaskSelectionMode | (0028,9454): Mask Selection Mode
MaskSubPixelShift | (0028,6114): Mask Sub-pixel Shift
MaskSubtractionSequence | (0028,6100): Mask Subtraction Sequence
MaskVisibilityPercentage | (0028,9478): Mask Visibility Percentage
Mass | (4010,1017): Mass
MaterialAttenuationSequence | (0018,9382): Material Attenuation Sequence
MaterialCodeSequence | (0018,937D): Material Code Sequence
MaterialGrade | (0014,0042): Material Grade
MaterialID | (300A,00E1): Material ID
MaterialIsolationDiameter | (0014,0034): Material Isolation Diameter
MaterialNotes | (0014,0046): Material Notes
MaterialPipeDiameter | (0014,0032): Material Pipe Diameter
MaterialPropertiesDescription | (0014,0044): Material Properties Description
MaterialPropertiesFileFormatRetired | (0014,0045): Material Properties File Format (Retired)
MaterialsCodeSequence | (0068,63A0): Materials Code Sequence
MaterialThickness | (0014,0030): Material Thickness
MatingFeatureDegreeOfFreedomSequence | (0068,6400): Mating Feature Degree of Freedom Sequence
MatingFeatureID | (0068,63F0): Mating Feature ID
MatingFeatureSequence | (0068,63E0): Mating Feature Sequence
MatingFeatureSetID | (0068,63C0): Mating Feature Set ID
MatingFeatureSetLabel | (0068,63D0): Mating Feature Set Label
MatingFeatureSetsSequence | (0068,63B0): Mating Feature Sets Sequence
MatrixRegistrationSequence | (0070,0309): Matrix Registration Sequence
MatrixSequence | (0070,030A): Matrix Sequence
MAUsedInGainCalibration | (0014,3072): MA Used in Gain Calibration
MaxApertureValue | (0016,0025): Max Aperture Value
MaxDensity | (2010,0130): Max Density
MaximumAcrossScanDistortion | (0022,0049): Maximum Across-scan Distortion
MaximumAlongScanDistortion | (0022,0038): Maximum Along-scan Distortion
MaximumCollatedFilms | (2010,0154): Maximum Collated Films
MaximumCoordinateValue | (50xx,0105): Maximum Coordinate Value
MaximumCornealCurvature | (0046,0212): Maximum Corneal Curvature
MaximumCornealCurvatureLocation | (0046,0213): Maximum Corneal Curvature Location
MaximumCornealCurvatureSequence | (0046,0211): Maximum Corneal Curvature Sequence
MaximumCumulativeMetersetExposure | (3002,0134): Maximum Cumulative Meterset Exposure
MaximumDepthDistortion | (0022,0036): Maximum Depth Distortion
MaximumFractionalValue | (0062,000E): Maximum Fractional Value
MaximumMemoryAllocation | (2000,0061): Maximum Memory Allocation
MaximumNominalEnergy | (300A,0682): Maximum Nominal Energy
MaximumNumberOfIntervalDays | (3010,0051): Maximum Number of Interval Days
MaximumNumberOfRecords | (0008,0429): Maximum Number of Records
MaximumPointDistance | (0066,0019): Maximum Point Distance
MaximumStimulusLuminance | (0024,0018): Maximum Stimulus Luminance
MaximumStoredValueMapped | (0028,1232): Maximum Stored Value Mapped
MeanPointDistance | (0066,0018): Mean Point Distance
MeasuredAPDimension | (0010,1023): Measured AP Dimension
MeasuredBandwidth | (0014,401C): Measured Bandwidth
MeasuredBeamDimensionA | (0014,4017): Measured Beam Dimension A
MeasuredBeamDimensionB | (0014,4018): Measured Beam Dimension B
MeasuredCenterFrequency | (0014,401B): Measured Center Frequency
MeasuredCharacteristics | (0028,7026): Measured Characteristics
MeasuredDoseDescription | (3008,0012): Measured Dose Description
MeasuredDoseReferenceNumber | (3008,0064): Measured Dose Reference Number
MeasuredDoseReferenceSequence | (3008,0010): Measured Dose Reference Sequence
MeasuredDoseType | (3008,0014): Measured Dose Type
MeasuredDoseValue | (3008,0016): Measured Dose Value
MeasuredLateralDimension | (0010,1024): Measured Lateral Dimension
MeasuredMetersetToDoseMappingSequence | (300A,0772): Measured Meterset to Dose Mapping Sequence
MeasuredValueSequence | (0040,A300): Measured Value Sequence
MeasurementAutomationTrial | (0040,A194): Measurement Automation (Trial)
MeasurementEquipmentSequence | (0028,7012): Measurement Equipment Sequence
MeasurementEquipmentType | (0028,7014): Measurement Equipment Type
MeasurementFunctions | (0028,7013): Measurement Functions
MeasurementLaterality | (0024,0113): Measurement Laterality
MeasurementPatternCodeSequence | (0028,702D): Measurement Pattern Code Sequence
MeasurementPrecisionDescriptionTrial | (0040,A047): Measurement Precision Description (Trial)
MeasurementsSequence | (0066,0121): Measurements Sequence
MeasurementUnitsCodeSequence | (0040,08EA): Measurement Units Code Sequence
MeasurementValuesSequence | (0066,0132): Measurement Values Sequence
MeasuringUnitsSequence | (0040,0295): Measuring Units Sequence
MechanicalIndex | (0018,5022): Mechanical Index
MediaDisposition | (2200,0004): Media Disposition
MediaInstalledSequence | (2000,00A2): Media Installed Sequence
MediaStorageSOPClassUID | (0002,0002): Media Storage SOP Class UID
MediaStorageSOPInstanceUID | (0002,0003): Media Storage SOP Instance UID
MedicalAlerts | (0010,2000): Medical Alerts
MedicalRecordLocator | (0010,1090): Medical Record Locator
MediumType | (2000,0030): Medium Type
MemoryAllocation | (2000,0060): Memory Allocation
MemoryBitDepth | (2000,00A0): Memory Bit Depth
MessageID | (0000,0110): Message ID
MessageIDBeingRespondedTo | (0000,0120): Message ID Being Responded To
MessageSetID | (0000,5010): Message Set ID(Retired)
MetaboliteMapCodeSequence | (0018,9083): Metabolite Map Code Sequence
MetaboliteMapDescription | (0018,9080): Metabolite Map Description
MetadataSequence | (0008,041D): Metadata Sequence
MeteringMode | (0016,0027): Metering Mode
MetersetExposure | (3002,0032): Meterset Exposure
MetersetRate | (300A,035A): Meterset Rate
MetersetRateDelivered | (3008,0046): Meterset Rate Delivered
MetersetRateSet | (3008,0045): Meterset Rate Set
MetersetToDoseMappingSequence | (300A,0620): Meterset to Dose Mapping Sequence
MidSlabPosition | (0018,9106): Mid Slab Position
MilitaryRank | (0010,1080): Military Rank
MIMETypeOfEncapsulatedDocument | (0042,0012): MIME Type of Encapsulated Document
MinDensity | (2010,0120): Min Density
MinimumCoordinateValue | (50xx,0104): Minimum Coordinate Value
MinimumHoursBetweenFractions | (3010,0084): Minimum Hours between Fractions
MinimumKeratometricSequence | (0046,0215): Minimum Keratometric Sequence
MinimumNominalEnergy | (300A,0681): Minimum Nominal Energy
MinimumNumberOfIntervalDays | (3010,0050): Minimum Number of Interval Days
MinimumSensitivityValue | (0024,0105): Minimum Sensitivity Value
MinimumStoredValueMapped | (0028,1231): Minimum Stored Value Mapped
ModalitiesInStudy | (0008,0061): Modalities in Study
Modality | (0008,0060): Modality
ModalityLUTSequence | (0028,3000): Modality LUT Sequence
ModalityLUTType | (0028,3004): Modality LUT Type
ModelGroupUID | (0068,7004): Model Group UID
ModelMirroring | (0068,7002): Model Mirroring
ModelModification | (0068,7001): Model Modification
ModelSpecificationSequence | (0018,9912): Model Specification Sequence
ModelUsageCodeSequence | (0068,7003): Model Usage Code Sequence
ModeOfPercutaneousAccessSequence | (0052,0016): Mode of Percutaneous Access Sequence
ModifiableConstraintFlag | (0082,0038): Modifiable Constraint Flag
ModifiedAttributesSequence | (0400,0550): Modified Attributes Sequence
ModifiedImageDate | (0020,3403): Modified Image Date(Retired)
ModifiedImageDescription | (0020,3406): Modified Image Description(Retired)
ModifiedImageID | (0020,3402): Modified Image ID(Retired)
ModifiedImageTime | (0020,3405): Modified Image Time(Retired)
ModifierCodeSequence | (0040,A195): Modifier Code Sequence
ModifyingDeviceID | (0020,3401): Modifying Device ID(Retired)
ModifyingDeviceManufacturer | (0020,3404): Modifying Device Manufacturer(Retired)
ModifyingSystem | (0400,0563): Modifying System
ModulatedScanModeType | (300A,0309): Modulated Scan Mode Type
ModulationType | (0014,4026): Modulation Type
MonoenergeticEnergyEquivalent | (0018,937C): Monoenergetic Energy Equivalent
MostRecentTreatmentDate | (3008,0056): Most Recent Treatment Date
MotionSynchronizationSequence | (300A,0410): Motion Synchronization Sequence
MoveDestination | (0000,0600): Move Destination
MoveOriginatorApplicationEntityTitle | (0000,1030): Move Originator Application Entity Title
MoveOriginatorMessageID | (0000,1031): Move Originator Message ID
MPRSlabThickness | (0070,1503): MPR Slab Thickness
MPRThicknessType | (0070,1502): MPR Thickness Type
MPRTopLeftHandCorner | (0070,1505): MPR Top Left Hand Corner
MPRViewHeight | (0070,1512): MPR View Height
MPRViewHeightDirection | (0070,1511): MPR View Height Direction
MPRViewWidth | (0070,1508): MPR View Width
MPRViewWidthDirection | (0070,1507): MPR View Width Direction
MRAcquisitionFrequencyEncodingSteps | (0018,9058): MR Acquisition Frequency Encoding Steps
MRAcquisitionPhaseEncodingStepsInPlane | (0018,9231): MR Acquisition Phase Encoding Steps in-plane
MRAcquisitionPhaseEncodingStepsOutOfPlane | (0018,9232): MR Acquisition Phase Encoding Steps out-of-plane
MRAcquisitionType | (0018,0023): MR Acquisition Type
MRArterialSpinLabelingSequence | (0018,9251): MR Arterial Spin Labeling Sequence
MRAveragesSequence | (0018,9119): MR Averages Sequence
MRDiffusionSequence | (0018,9117): MR Diffusion Sequence
MRDRDirectoryRecordOffset | (0004,1504): MRDR Directory Record Offset
MREchoSequence | (0018,9114): MR Echo Sequence
MRFOVGeometrySequence | (0018,9125): MR FOV/Geometry Sequence
MRImageFrameTypeSequence | (0018,9226): MR Image Frame Type Sequence
MRImagingModifierSequence | (0018,9006): MR Imaging Modifier Sequence
MRMetaboliteMapSequence | (0018,9152): MR Metabolite Map Sequence
MRModifierSequence | (0018,9115): MR Modifier Sequence
MRReceiveCoilSequence | (0018,9042): MR Receive Coil Sequence
MRSpatialSaturationSequence | (0018,9107): MR Spatial Saturation Sequence
MRSpectroscopyAcquisitionType | (0018,9200): MR Spectroscopy Acquisition Type
MRSpectroscopyFOVGeometrySequence | (0018,9103): MR Spectroscopy FOV/Geometry Sequence
MRSpectroscopyFrameTypeSequence | (0018,9227): MR Spectroscopy Frame Type Sequence
MRTimingAndRelatedParametersSequence | (0018,9112): MR Timing and Related Parameters Sequence
MRTransmitCoilSequence | (0018,9049): MR Transmit Coil Sequence
MRVelocityEncodingSequence | (0018,9197): MR Velocity Encoding Sequence
MultiCoilConfiguration | (0018,9046): Multi-Coil Configuration
MultiCoilDefinitionSequence | (0018,9045): Multi-Coil Definition Sequence
MultiCoilElementName | (0018,9047): Multi-Coil Element Name
MultiCoilElementUsed | (0018,9048): Multi-Coil Element Used
MultienergyAcquisitionDescription | (0018,937B): Multi-energy Acquisition Description
MultienergyCTAcquisition | (0018,9361): Multi-energy CT Acquisition
MultienergyCTAcquisitionSequence | (0018,9362): Multi-energy CT Acquisition Sequence
MultienergyCTCharacteristicsSequence | (0018,9364): Multi-energy CT Characteristics Sequence
MultienergyCTPathIndex | (0018,937A): Multi-energy CT Path Index
MultienergyCTPathSequence | (0018,9379): Multi-energy CT Path Sequence
MultienergyCTProcessingSequence | (0018,9363): Multi-energy CT Processing Sequence
MultienergyCTXRayDetectorSequence | (0018,936F): Multi-energy CT X-Ray Detector Sequence
MultienergyCTXRaySourceSequence | (0018,9365): Multi-energy CT X-Ray Source Sequence
MultienergyDetectorType | (0018,9372): Multi-energy Detector Type
MultienergySourceTechnique | (0018,9368): Multi-energy Source Technique
MultiFramePresentationSequence | (0028,9505): Multi-frame Presentation Sequence
MultiFrameSourceSOPInstanceUID | (0008,1167): Multi-frame Source SOP Instance UID
MultiPlanarExcitation | (0018,9012): Multi-planar Excitation
MultiPlanarReconstructionStyle | (0070,1501): Multi-Planar Reconstruction Style
MultipleComponentApprovalSequence | (0014,0106): Multiple Component Approval Sequence
MultipleCopiesFlag | (0040,4006): Multiple Copies Flag
MultipleSpinEcho | (0018,9011): Multiple Spin Echo
MultiplexedAudioChannelsDescriptionCodeSequence | (003A,0300): Multiplexed Audio Channels Description Code Sequence
MultiplexGroupLabel | (003A,0020): Multiplex Group Label
MultiplexGroupTimeOffset | (0018,1068): Multiplex Group Time Offset
MultiplexGroupUID | (003A,0310): Multiplex Group UID
MVImagingGenerationParametersSequence | (3002,0128): MV Imaging Generation Parameters Sequence
MydriaticAgentCodeSequence | (0022,001C): Mydriatic Agent Code Sequence
MydriaticAgentConcentration | (0022,004E): Mydriatic Agent Concentration
MydriaticAgentConcentrationUnitsSequence | (0022,0042): Mydriatic Agent Concentration Units Sequence
MydriaticAgentSequence | (0022,0058): Mydriatic Agent Sequence
NameOfPhysiciansReadingStudy | (0008,1060): Name of Physician(s) Reading Study
NamesOfIntendedRecipientsOfResults | (0040,1010): Names of Intended Recipients of Results
NavigationDisplaySet | (0072,0216): Navigation Display Set
NavigationIndicatorSequence | (0072,0214): Navigation Indicator Sequence
NearPupillaryDistance | (0046,0062): Near Pupillary Distance
NegativeCatchTrialsQuantity | (0024,0048): Negative Catch Trials Quantity
NetworkID | (0008,1000): Network ID(Retired)
NominalBeamAngle | (0014,5112): Nominal Beam Angle
NominalBeamEnergy | (300A,0114): Nominal Beam Energy
NominalBeamEnergyUnit | (300A,0015): Nominal Beam Energy Unit
NominalCardiacTriggerDelayTime | (0020,9153): Nominal Cardiac Trigger Delay Time
NominalCardiacTriggerTimePriorToRPeak | (0020,9154): Nominal Cardiac Trigger Time Prior To R-Peak
NominalEnergy | (300A,0680): Nominal Energy
NominalFrequency | (0014,401A): Nominal Frequency
NominalInterval | (0018,1062): Nominal Interval
NominalMaxEnergy | (0018,9374): Nominal Max Energy
NominalMinEnergy | (0018,9375): Nominal Min Energy
NominalPercentageOfCardiacPhase | (0020,9241): Nominal Percentage of Cardiac Phase
NominalPercentageOfRespiratoryPhase | (0020,9245): Nominal Percentage of Respiratory Phase
NominalPriorDose | (300A,001A): Nominal Prior Dose
NominalRangeModulatedRegionDepths | (300A,0504): Nominal Range Modulated Region Depths
NominalRangeModulationFractions | (300A,0503): Nominal Range Modulation Fractions
NominalRespiratoryTriggerDelayTime | (0020,9255): Nominal Respiratory Trigger Delay Time
NominalScannedPixelSpacing | (0018,2010): Nominal Scanned Pixel Spacing
NominalScreenDefinitionSequence | (0072,0102): Nominal Screen Definition Sequence
NonconformingDataElementValue | (0400,0552): Nonconforming Data Element Value
NonconformingModifiedAttributesSequence | (0400,0551): Nonconforming Modified Attributes Sequence
NonDICOMOutputCodeSequence | (0040,4032): Non-DICOM Output Code Sequence
NonidentifyingPrivateElements | (0008,0304): Nonidentifying Private Elements
NonUniformRadialSamplingCorrected | (0018,9766): Non-uniform Radial Sampling Corrected
NormalizationFactorFormat | (0028,0710): Normalization Factor Format
NormalizationPoint | (3004,0008): Normalization Point
NormalReverse | (0000,5140): Normal/Reverse(Retired)
NotchFilterBandwidth | (003A,0223): Notch Filter Bandwidth
NotchFilterCharacteristicsSequence | (003A,0321): Notch Filter Characteristics Sequence
NotchFilterFrequency | (003A,0222): Notch Filter Frequency
NotificationFromManufacturerSequence | (0068,6265): Notification From Manufacturer Sequence
NTPSourceAddress | (0018,1803): NTP Source Address
NuclearMedicineSeriesType | (0008,0042): Nuclear Medicine Series Type
NumberOfAcquisitionDevices | (3002,0116): Number of Acquisition Devices
NumberOfAlarmObjects | (4010,1034): Number of Alarm Objects
NumberOfAnnotations | (006A,000C): Number of Annotations
NumberOfAssessmentObservations | (0082,0006): Number of Assessment Observations
NumberOfAverages | (0018,0083): Number of Averages
NumberOfBeams | (300A,0080): Number of Beams
NumberOfBlocks | (300A,00F0): Number of Blocks
NumberOfBlockSlabItems | (300A,0440): Number of Block Slab Items
NumberOfBoli | (300A,00ED): Number of Boli
NumberOfBoluses | (300A,0674): Number of Boluses
NumberOfBrachyApplicationSetups | (300A,00A0): Number of Brachy Application Setups
NumberOfBscansPerFrame | (0022,1642): Number of B-scans Per Frame
NumberOfChannels | (50xx,2004): Number of Channels
NumberOfCompensators | (300A,00E0): Number of Compensators
NumberOfCompletedSuboperations | (0000,1021): Number of Completed Sub-operations
NumberOfContourPoints | (3006,0046): Number of Contour Points
NumberOfControlPoints | (300A,0110): Number of Control Points
NumberOfCopies | (2000,0010): Number of Copies
NumberOfDetectors | (0054,0021): Number of Detectors
NumberOfDisplaySubsystems | (0028,7001): Number of Display Subsystems
NumberOfElements | (0014,4012): Number of Elements
NumberOfEnergyWindows | (0054,0011): Number of Energy Windows
NumberOfEventTimers | (0008,2129): Number of Event Timers
NumberOfFailedSuboperations | (0000,1022): Number of Failed Sub-operations
NumberOfFilms | (2100,0170): Number of Films
NumberOfFocalPlanes | (0048,0013): Number of Focal Planes
NumberOfFractionPatternDigitsPerDay | (300A,0079): Number of Fraction Pattern Digits Per Day
NumberOfFractions | (3010,007D): Number of Fractions
NumberOfFractionsDelivered | (3008,005A): Number of Fractions Delivered
NumberOfFractionsIncluded | (300C,0119): Number of Fractions Included
NumberOfFractionsPlanned | (300A,0078): Number of Fractions Planned
NumberOfFrames | (0028,0008): Number of Frames
NumberOfFramesInOverlay | (60xx,0015): Number of Frames in Overlay
NumberOfFramesInPhase | (0054,0033): Number of Frames in Phase
NumberOfFramesInRotation | (0054,0053): Number of Frames in Rotation
NumberOfFramesIntegrated | (0014,3012): Number of Frames Integrated
NumberOfFramesUsedForIntegration | (0014,3073): Number of Frames Used for Integration
NumberOfGeneralAccessories | (300A,0672): Number of General Accessories
NumberOfGraphicPoints | (0070,0021): Number of Graphic Points
NumberOfHorizontalPixels | (0072,0106): Number of Horizontal Pixels
NumberOfIntervalFractions | (3010,007C): Number of Interval Fractions
NumberOfIterations | (0018,9739): Number of Iterations
NumberOfKSpaceTrajectories | (0018,9093): Number of k-Space Trajectories
NumberOfLateralSpreadingDevices | (300A,0330): Number of Lateral Spreading Devices
NumberOfLeafJawPairs | (300A,00BC): Number of Leaf/Jaw Pairs
NumberOfLuminancePoints | (0028,701B): Number of Luminance Points
NumberOfMapPoints | (0022,1530): Number of Map Points
NumberOfMatches | (0000,0850): Number of Matches(Retired)
NumberOfOpticalPaths | (0048,0302): Number of Optical Paths
NumberOfPaddedALines | (0052,0038): Number of Padded A-lines
NumberOfPaintings | (300A,039A): Number of Paintings
NumberOfParallelRTBeamDelimiters | (300A,0648): Number of Parallel RT Beam Delimiters
NumberOfPatientRelatedInstances | (0020,1204): Number of Patient Related Instances
NumberOfPatientRelatedSeries | (0020,1202): Number of Patient Related Series
NumberOfPatientRelatedStudies | (0020,1200): Number of Patient Related Studies
NumberOfPatientSupportDevices | (300A,0687): Number of Patient Support Devices
NumberOfPhaseEncodingSteps | (0018,0089): Number of Phase Encoding Steps
NumberOfPhases | (0054,0031): Number of Phases
NumberOfPoints | (50xx,0010): Number of Points
NumberOfPolygonalVertices | (0018,1637): Number of Polygonal Vertices
NumberOfPriorsReferenced | (0072,0014): Number of Priors Referenced
NumberOfPulses | (300A,028A): Number of Pulses
NumberOfRadiationGenerationModes | (300A,0685): Number of Radiation GenerationModes
NumberOfRangeModulators | (300A,0340): Number of Range Modulators
NumberOfRangeShifters | (300A,0312): Number of Range Shifters
NumberOfReferences | (0004,1600): Number of References
NumberOfRemainingSuboperations | (0000,1020): Number of Remaining Sub-operations
NumberOfRotations | (0054,0051): Number of Rotations
NumberOfRRIntervals | (0054,0061): Number of R-R Intervals
NumberOfRTAccessoryHolders | (300A,0670): Number of RT Accessory Holders
NumberOfRTBeamLimitingDeviceOpenings | (300A,0657): Number of RT Beam Limiting Device Openings
NumberOfRTBeamLimitingDevices | (300A,0641): Number of RT Beam Limiting Devices
NumberOfRTControlPoints | (300A,0604): Number of RT Control Points
NumberOfSamples | (50xx,2006): Number of Samples
NumberOfScanSpotPositions | (300A,0392): Number of Scan Spot Positions
NumberOfScreens | (0072,0100): Number of Screens
NumberOfSeriesRelatedInstances | (0020,1209): Number of Series Related Instances
NumberOfSlices | (0054,0081): Number of Slices
NumberOfStages | (0008,2124): Number of Stages
NumberOfStudyRecordsInInstance | (0008,0427): Number of Study Records in Instance
NumberOfStudyRelatedInstances | (0020,1208): Number of Study Related Instances
NumberOfStudyRelatedSeries | (0020,1206): Number of Study Related Series
NumberOfSubsets | (0018,9740): Number of Subsets
NumberOfSurfacePoints | (0066,0015): Number of Surface Points
NumberOfSurfaces | (0066,0001): Number of Surfaces
NumberOfTableBreakPoints | (0018,6050): Number of Table Break Points
NumberOfTableColumns | (0040,A803): Number of Table Columns
NumberOfTableEntries | (0018,6056): Number of Table Entries
NumberOfTableRows | (0040,A802): Number of Table Rows
NumberOfTables | (0028,08x2): Number of Tables
NumberOfTemporalPositions | (0020,0105): Number of Temporal Positions
NumberOfTimeSlices | (0054,0101): Number of Time Slices
NumberOfTimeSlots | (0054,0071): Number of Time Slots
NumberOfTomosynthesisSourceImages | (0018,1495): Number of Tomosynthesis Source Images
NumberOfTotalObjects | (4010,1033): Number of Total Objects
NumberOfTransformSteps | (0028,0402): Number of Transform Steps
NumberOfTriggersInPhase | (0054,0211): Number of Triggers in Phase
NumberOfVectors | (0066,001E): Number of Vectors
NumberOfVerticalPixels | (0072,0104): Number of Vertical Pixels
NumberOfViewsInStage | (0008,212A): Number of Views in Stage
NumberOfVisualStimuli | (0024,0038): Number of Visual Stimuli
NumberOfVolumetricCurvePoints | (0070,150C): Number of Volumetric Curve Points
NumberOfWarningSuboperations | (0000,1023): Number of Warning Sub-operations
NumberOfWaveformChannels | (003A,0005): Number of Waveform Channels
NumberOfWaveformSamples | (003A,0010): Number of Waveform Samples
NumberOfWedgePositions | (300A,0655): Number of Wedge Positions
NumberOfWedges | (300A,00D0): Number of Wedges
NumberOfZeroFills | (0018,9066): Number of Zero Fills
NumericValue | (0040,A30A): Numeric Value
NumericValueQualifierCodeSequence | (0040,A301): Numeric Value Qualifier Code Sequence
ObjectBinaryIdentifierTrial | (0040,A074): Object Binary Identifier (Trial)
ObjectDirectoryBinaryIdentifierTrial | (0040,A089): Object Directory Binary Identifier (Trial)
ObjectiveLensNumericalAperture | (0048,0113): Objective Lens Numerical Aperture
ObjectiveLensPower | (0048,0112): Objective Lens Power
ObjectPixelSpacingInCenterOfBeam | (0018,9404): Object Pixel Spacing in Center of Beam
ObjectSoundSpeed | (0018,9833): Object Sound Speed
ObjectThicknessSequence | (0018,9456): Object Thickness Sequence
ObliqueCroppingPlaneSequence | (0070,1304): Oblique Cropping Plane Sequence
ObservationBasisCodeSequence | (0082,0022): Observation Basis Code Sequence
ObservationCategoryCodeSequenceTrial | (0040,A167): Observation Category Code Sequence (Trial)
ObservationDateTime | (0040,A032): Observation DateTime
ObservationDateTrial | (0040,A192): Observation Date (Trial)
ObservationDescription | (0082,000A): Observation Description
ObservationNumber | (3006,0082): Observation Number
ObservationSignificance | (0082,0008): Observation Significance
ObservationStartDateTime | (0040,A033): Observation Start DateTime
ObservationSubjectClassTrial | (0040,A403): Observation Subject Class (Trial)
ObservationSubjectContextFlagTrial | (0040,A600): Observation Subject Context Flag (Trial)
ObservationSubjectTypeCodeSequenceTrial | (0040,A404): Observation Subject Type Code Sequence (Trial)
ObservationSubjectUIDTrial | (0040,A402): Observation Subject UID (Trial)
ObservationTimeTrial | (0040,A193): Observation Time (Trial)
ObservationUID | (0040,A171): Observation UID
ObserverContextFlagTrial | (0040,A601): Observer Context Flag (Trial)
ObserverType | (0040,A084): Observer Type
Occupation | (0010,2180): Occupation
OCTAcquisitionDomain | (0052,0006): OCT Acquisition Domain
OCTBscanAnalysisAcquisitionParametersSequence | (0022,1640): OCT B-scan Analysis Acquisition Parameters Sequence
OCTFocalDistance | (0052,0002): OCT Focal Distance
OCTOpticalCenterWavelength | (0052,0007): OCT Optical Center Wavelength
OCTZOffsetApplied | (0052,0026): OCT Z Offset Applied
OCTZOffsetCorrection | (0052,0030): OCT Z Offset Correction
OECFColumnNames | (0016,0008): OECF Column Names
OECFColumns | (0016,0007): OECF Columns
OECFRows | (0016,0006): OECF Rows
OECFValues | (0016,0009): OECF Values
OffendingElement | (0000,0901): Offending Element
OffsetDirection | (0018,9905): Offset Direction
OffsetDistance | (0018,9904): Offset Distance
OffsetOfReferencedLowerLevelDirectoryEntity | (0004,1420): Offset of Referenced Lower-Level Directory Entity
OffsetOfTheFirstDirectoryRecordOfTheRootDirectoryEntity | (0004,1200): Offset of the First Directory Record of the Root Directory Entity
OffsetOfTheLastDirectoryRecordOfTheRootDirectoryEntity | (0004,1202): Offset of the Last Directory Record of the Root Directory Entity
OffsetOfTheNextDirectoryRecord | (0004,1400): Offset of the Next Directory Record
OmittedApplicationSetupSequence | (0074,140E): Omitted Application Setup Sequence
OmittedBeamTaskSequence | (300C,0111): Omitted Beam Task Sequence
OmittedChannelSequence | (0074,1409): Omitted Channel Sequence
OmittedRadiationSequence | (300A,0787): Omitted Radiation Sequence
OnAxisBackgroundAnatomicStructureCodeSequenceTrial | (0008,225C): On Axis Background Anatomic Structure Code Sequence (Trial)
OOIOwnerCreationTime | (4010,1041): OOI Owner Creation Time
OOIOwnerSequence | (4010,1047): OOI Owner Sequence
OOIOwnerType | (4010,1009): OOI Owner Type
OOISize | (4010,1043): OOI Size
OOIType | (4010,1042): OOI Type
OOITypeDescriptor | (4010,1068): OOI Type Descriptor
OperatingMode | (0018,9178): Operating Mode
OperatingModeSequence | (0018,9176): Operating Mode Sequence
OperatingModeType | (0018,9177): Operating Mode Type
OperatorIdentificationSequence | (0008,1072): Operator Identification Sequence
OperatorsName | (0008,1070): Operators' Name
OphthalmicAnatomicReferencePointXCoordinate | (0022,1624): Ophthalmic Anatomic Reference Point X-Coordinate
OphthalmicAnatomicReferencePointYCoordinate | (0022,1626): Ophthalmic Anatomic Reference Point Y-Coordinate
OphthalmicAxialLength | (0022,1019): Ophthalmic Axial Length
OphthalmicAxialLengthAcquisitionMethodCodeSequence | (0022,1153): Ophthalmic Axial Length Acquisition Method Code Sequence
OphthalmicAxialLengthDataSourceCodeSequence | (0022,1150): Ophthalmic Axial Length Data Source Code Sequence
OphthalmicAxialLengthDataSourceDescription | (0022,1159): Ophthalmic Axial Length Data Source Description
OphthalmicAxialLengthMeasurementModified | (0022,1140): Ophthalmic Axial Length Measurement Modified
OphthalmicAxialLengthMeasurementsLengthSummationSequence | (0022,1212): Ophthalmic Axial Length Measurements Length Summation Sequence
OphthalmicAxialLengthMeasurementsSegmentalLengthSequence | (0022,1211): Ophthalmic Axial Length Measurements Segmental Length Sequence
OphthalmicAxialLengthMeasurementsSegmentNameCodeSequence | (0022,1101): Ophthalmic Axial Length Measurements Segment Name Code Sequence
OphthalmicAxialLengthMeasurementsSequence | (0022,1050): Ophthalmic Axial Length Measurements Sequence
OphthalmicAxialLengthMeasurementsTotalLengthSequence | (0022,1210): Ophthalmic Axial Length Measurements Total Length Sequence
OphthalmicAxialLengthMeasurementsType | (0022,1010): Ophthalmic Axial Length Measurements Type
OphthalmicAxialLengthMethod | (0022,1515): Ophthalmic Axial Length Method
OphthalmicAxialLengthQualityMetricSequence | (0022,1262): Ophthalmic Axial Length Quality Metric Sequence
OphthalmicAxialLengthQualityMetricTypeCodeSequence | (0022,1265): Ophthalmic Axial Length Quality Metric Type Code Sequence(Retired)
OphthalmicAxialLengthQualityMetricTypeDescription | (0022,1273): Ophthalmic Axial Length Quality Metric Type Description
OphthalmicAxialLengthSelectionMethodCodeSequence | (0022,1250): Ophthalmic Axial Length Selection Method Code Sequence
OphthalmicAxialLengthSequence | (0022,1012): Ophthalmic Axial Length Sequence
OphthalmicAxialLengthVelocity | (0022,1059): Ophthalmic Axial Length Velocity
OphthalmicAxialMeasurementsDeviceType | (0022,1009): Ophthalmic Axial Measurements Device Type
OphthalmicAxialMeasurementsLeftEyeSequence | (0022,1008): Ophthalmic Axial Measurements Left Eye Sequence
OphthalmicAxialMeasurementsRightEyeSequence | (0022,1007): Ophthalmic Axial Measurements Right Eye Sequence
OphthalmicEnFaceImageQualityRatingSequence | (0022,1628): Ophthalmic En Face Image Quality Rating Sequence
OphthalmicFOV | (0022,1517): Ophthalmic FOV
OphthalmicFrameLocationSequence | (0022,0031): Ophthalmic Frame Location Sequence
OphthalmicImageOrientation | (0022,0039): Ophthalmic Image Orientation
OphthalmicImageTypeCodeSequence | (0022,1615): Ophthalmic Image Type Code Sequence
OphthalmicImageTypeDescription | (0022,1616): Ophthalmic Image Type Description
OphthalmicMappingDeviceType | (0022,1415): Ophthalmic Mapping Device Type
OphthalmicPatientClinicalInformationLeftEyeSequence | (0024,0114): Ophthalmic Patient Clinical Information Left Eye Sequence
OphthalmicPatientClinicalInformationRightEyeSequence | (0024,0115): Ophthalmic Patient Clinical Information Right Eye Sequence
OphthalmicThicknessMappingNormalsSequence | (0022,1443): Ophthalmic Thickness Mapping Normals Sequence
OphthalmicThicknessMapQualityRatingSequence | (0022,1470): Ophthalmic Thickness Map Quality Rating Sequence
OphthalmicThicknessMapQualityThresholdSequence | (0022,1458): Ophthalmic Thickness Map Quality Threshold Sequence
OphthalmicThicknessMapThresholdQualityRating | (0022,1460): Ophthalmic Thickness Map Threshold Quality Rating
OphthalmicThicknessMapTypeCodeSequence | (0022,1436): Ophthalmic Thickness Map Type Code Sequence
OphthalmicUltrasoundMethodCodeSequence | (0022,1044): Ophthalmic Ultrasound Method Code Sequence
OphthalmicVolumetricPropertiesFlag | (0022,1622): Ophthalmic Volumetric Properties Flag
OpticalMagnificationFactor | (0016,1005): Optical Magnification Factor
OpticalOphthalmicAxialLengthMeasurementsSequence | (0022,1225): Optical Ophthalmic Axial Length Measurements Sequence
OpticalPathDescription | (0048,0107): Optical Path Description
OpticalPathIdentificationSequence | (0048,0207): Optical Path Identification Sequence
OpticalPathIdentifier | (0048,0106): Optical Path Identifier
OpticalPathSequence | (0048,0105): Optical Path Sequence
OpticalSelectedOphthalmicAxialLengthSequence | (0022,1255): Optical Selected Ophthalmic Axial Length Sequence
OpticalTransmittance | (0046,0040): Optical Transmittance
Optotype | (0046,0094): Optotype
OptotypeDetailedDefinition | (0046,0139): Optotype Detailed Definition
OptotypePresentation | (0046,0095): Optotype Presentation
OrderCallbackPhoneNumber | (0040,2010): Order Callback Phone Number
OrderCallbackTelecomInformation | (0040,2011): Order Callback Telecom Information
OrderEnteredBy | (0040,2008): Order Entered By
OrderEntererLocation | (0040,2009): Order Enterer's Location
OrderFillerIdentifierSequence | (0040,0027): Order Filler Identifier Sequence
OrderPlacerIdentifierSequence | (0040,0026): Order Placer Identifier Sequence
OrganAtRiskFullVolumeDose | (300A,002A): Organ at Risk Full-volume Dose
OrganAtRiskLimitDose | (300A,002B): Organ at Risk Limit Dose
OrganAtRiskMaximumDose | (300A,002C): Organ at Risk Maximum Dose
OrganAtRiskOverdoseVolumeFraction | (300A,002D): Organ at Risk Overdose Volume Fraction
OrganDose | (0040,0316): Organ Dose
OrganExposed | (0040,0318): Organ Exposed
OrganizationalRoleCodeSequence | (0044,010A): Organizational Role Code Sequence
OriginalAttributesSequence | (0400,0561): Original Attributes Sequence
OriginalImageIdentification | (0020,5000): Original Image Identification(Retired)
OriginalImageIdentificationNomenclature | (0020,5002): Original Image Identification Nomenclature(Retired)
OriginalImageSequence | (2130,00C0): Original Image Sequence
OriginalImplantAssemblyTemplateSequence | (0076,000C): Original Implant Assembly Template Sequence
OriginalImplantTemplateSequence | (0068,6225): Original Implant Template Sequence
OriginalSpecializedSOPClassUID | (0008,001B): Original Specialized SOP Class UID
OriginatingSOPInstanceReferenceSequence | (3010,0007): Originating SOP Instance Reference Sequence
Originator | (2100,0070): Originator
OtherApprovalStatus | (0014,0107): Other Approval Status
OtherClinicalTrialProtocolIDsSequence | (0012,0023): Other Clinical Trial Protocol IDs Sequence
OtherFailuresSequence | (0008,119A): Other Failures Sequence
OtherMagnificationTypesAvailable | (2010,00A7): Other Magnification Types Available
OtherMediaAvailableSequence | (2000,00A4): Other Media Available Sequence
OtherPatientIDs | (0010,1000): Other Patient IDs
OtherPatientIDsSequence | (0010,1002): Other Patient IDs Sequence
OtherPatientNames | (0010,1001): Other Patient Names
OtherPupillaryDistance | (0046,0064): Other Pupillary Distance
OtherSecondaryApprovalStatus | (0014,0108): Other Secondary Approval Status
OtherSmoothingTypesAvailable | (2010,00A9): Other Smoothing Types Available
OtherStudyNumbers | (0020,1070): Other Study Numbers
OuterDiameter | (0014,0054): Outer Diameter
OutlineLeftVerticalEdge | (0018,1631): Outline Left Vertical Edge
OutlineLowerHorizontalEdge | (0018,1634): Outline Lower Horizontal Edge
OutlineRightVerticalEdge | (0018,1632): Outline Right Vertical Edge
OutlineShapeType | (0018,1630): Outline Shape Type
OutlineUpperHorizontalEdge | (0018,1633): Outline Upper Horizontal Edge
OutputDestinationSequence | (0040,4070): Output Destination Sequence
OutputInformationSequence | (0040,4033): Output Information Sequence
OutputPower | (0018,5000): Output Power
OverallTemplateSpatialTolerance | (0068,62A5): Overall Template Spatial Tolerance
OverlayActivationLayer | (60xx,1001): Overlay Activation Layer
OverlayBackgroundDensity | (2040,0082): Overlay Background Density
OverlayBitPosition | (60xx,0102): Overlay Bit Position
OverlayBitsAllocated | (60xx,0100): Overlay Bits Allocated
OverlayBitsForCodeWord | (60xx,0804): Overlay Bits For Code Word
OverlayBitsGrouped | (60xx,0069): Overlay Bits Grouped
OverlayCodeLabel | (60xx,0800): Overlay Code Label
OverlayCodeTableLocation | (60xx,0803): Overlay Code Table Location
OverlayColumns | (60xx,0011): Overlay Columns
OverlayComments | (60xx,4000): Overlay Comments(Retired)
OverlayCompressionCode | (60xx,0060): Overlay Compression Code(Retired)
OverlayCompressionDescription | (60xx,0063): Overlay Compression Description
OverlayCompressionLabel | (60xx,0062): Overlay Compression Label
OverlayCompressionOriginator | (60xx,0061): Overlay Compression Originator
OverlayCompressionStepPointers | (60xx,0066): Overlay Compression Step Pointers
OverlayData | (60xx,3000): Overlay Data
OverlayDate | (0008,0024): Overlay Date
OverlayDescription | (60xx,0022): Overlay Description
OverlayDescriptorBlue | (60xx,1103): Overlay Descriptor - Blue
OverlayDescriptorGray | (60xx,1100): Overlay Descriptor - Gray
OverlayDescriptorGreen | (60xx,1102): Overlay Descriptor - Green
OverlayDescriptorRed | (60xx,1101): Overlay Descriptor - Red
OverlayForegroundDensity | (2040,0080): Overlay Foreground Density
OverlayFormat | (60xx,0110): Overlay Format(Retired)
OverlayLabel | (60xx,1500): Overlay Label
OverlayLocation | (60xx,0200): Overlay Location(Retired)
OverlayMagnificationType | (2040,0060): Overlay Magnification Type
OverlayMode | (2040,0090): Overlay Mode
OverlayNumber | (0020,0022): Overlay Number
OverlayNumberOfTables | (60xx,0802): Overlay Number of Tables
OverlayOrigin | (60xx,0050): Overlay Origin
OverlayOrImageMagnification | (2040,0072): Overlay or Image Magnification
OverlayPixelDataSequence | (2040,0020): Overlay Pixel Data Sequence
OverlayPlaneOrigin | (60xx,0052): Overlay Plane Origin
OverlayPlanes | (60xx,0012): Overlay Planes
OverlayRepeatInterval | (60xx,0068): Overlay Repeat Interval
OverlayRows | (60xx,0010): Overlay Rows
Overlays | (0000,51B0): Overlays(Retired)
OverlaysBlue | (60xx,1203): Overlays - Blue
OverlaysGray | (60xx,1200): Overlays - Gray
OverlaysGreen | (60xx,1202): Overlays - Green
OverlaySmoothingType | (2040,0070): Overlay Smoothing Type
OverlaysRed | (60xx,1201): Overlays - Red
OverlaySubtype | (60xx,0045): Overlay Subtype
OverlayTime | (0008,0034): Overlay Time
OverlayType | (60xx,0040): Overlay Type
OverriddenAttributesSequence | (0074,104A): Overridden Attributes Sequence
OverrideDateTime | (300A,0760): Override DateTime
OverrideParameterPointer | (3008,0062): Override Parameter Pointer
OverrideReason | (3008,0066): Override Reason
OverrideSequence | (3008,0060): Override Sequence
OversamplingPhase | (0018,9029): Oversampling Phase
OwnerID | (2100,0160): Owner ID
PaddleDescription | (0018,11A4): Paddle Description
PageNumberVector | (0018,2001): Page Number Vector
PagePositionID | (0000,5120): Page Position ID(Retired)
PaletteColorLookupTableSequence | (0048,0120): Palette Color Lookup Table Sequence
PaletteColorLookupTableUID | (0028,1199): Palette Color Lookup Table UID
ParallelAcquisition | (0018,9077): Parallel Acquisition
ParallelAcquisitionTechnique | (0018,9078): Parallel Acquisition Technique
ParallelReductionFactorInPlane | (0018,9069): Parallel Reduction Factor In-plane
ParallelReductionFactorInPlaneRetired | (0018,9096): Parallel Reduction Factor In-plane (Retired)
ParallelReductionFactorOutOfPlane | (0018,9155): Parallel Reduction Factor out-of-plane
ParallelReductionFactorSecondInPlane | (0018,9168): Parallel Reduction Factor Second In-plane
ParallelRTBeamDelimiterBoundaries | (300A,0649): Parallel RT Beam Delimiter Boundaries
ParallelRTBeamDelimiterDeviceOrientationLabelCodeSequence | (300A,0644): Parallel RT Beam Delimiter Device Orientation Label Code Sequence
ParallelRTBeamDelimiterDeviceSequence | (300A,0647): Parallel RT Beam Delimiter Device Sequence
ParallelRTBeamDelimiterLeafMountingSide | (300A,064F): Parallel RT Beam Delimiter Leaf Mounting Side
ParallelRTBeamDelimiterOpeningExtents | (3008,00A4): Parallel RT Beam Delimiter Opening Extents
ParallelRTBeamDelimiterOpeningMode | (300A,064E): Parallel RT Beam Delimiter Opening Mode
ParallelRTBeamDelimiterPositions | (300A,064A): Parallel RT Beam Delimiter Positions
ParameterItemIndex | (3008,0063): Parameter Item Index
ParameterPointer | (3008,0065): Parameter Pointer
ParameterSequencePointer | (3008,0061): Parameter Sequence Pointer
ParametersSpecificationSequence | (0018,9913): Parameters Specification Sequence
ParameterValueNumber | (3008,0067): Parameter Value Number
ParametricMapFrameTypeSequence | (0040,9092): Parametric Map Frame Type Sequence
PartialDataDisplayHandling | (0072,0208): Partial Data Display Handling
PartialFourier | (0018,9081): Partial Fourier
PartialFourierDirection | (0018,9036): Partial Fourier Direction
PartialView | (0028,1350): Partial View
PartialViewCodeSequence | (0028,1352): Partial View Code Sequence
PartialViewDescription | (0028,1351): Partial View Description
ParticipantSequence | (0040,A07A): Participant Sequence
ParticipationDateTime | (0040,A082): Participation DateTime
ParticipationType | (0040,A080): Participation Type
PatientAdditionalPosition | (300A,0184): Patient Additional Position
PatientAddress | (0010,1040): Patient's Address
PatientAge | (0010,1010): Patient's Age
PatientAlternativeCalendar | (0010,0035): Patient's Alternative Calendar
PatientBirthDate | (0010,0030): Patient's Birth Date
PatientBirthDateInAlternativeCalendar | (0010,0033): Patient's Birth Date in Alternative Calendar
PatientBirthName | (0010,1005): Patient's Birth Name
PatientBirthTime | (0010,0032): Patient's Birth Time
PatientBodyMassIndex | (0010,1022): Patient's Body Mass Index
PatientBreedCodeSequence | (0010,2293): Patient Breed Code Sequence
PatientBreedDescription | (0010,2292): Patient Breed Description
PatientClinicalTrialParticipationSequence | (0038,0502): Patient Clinical Trial Participation Sequence
PatientComments | (0010,4000): Patient Comments
PatientDeathDateInAlternativeCalendar | (0010,0034): Patient's Death Date in Alternative Calendar
PatientEquipmentRelationshipCodeSequence | (3010,0030): Patient Equipment Relationship Code Sequence
PatientEyeMovementCommandCodeSequence | (0022,0006): Patient Eye Movement Command Code Sequence
PatientEyeMovementCommanded | (0022,0005): Patient Eye Movement Commanded
PatientFrameOfReferenceSource | (0020,930C): Patient Frame of Reference Source
PatientGantryRelationshipCodeSequence | (0054,0414): Patient Gantry Relationship Code Sequence
PatientID | (0010,0020): Patient ID
PatientIdentityRemoved | (0012,0062): Patient Identity Removed
PatientInstitutionResidence | (0038,0400): Patient's Institution Residence
PatientInsurancePlanCodeSequence | (0010,0050): Patient's Insurance Plan Code Sequence
PatientLocationCoordinatesCodeSequence | (3006,00CA): Patient Location Coordinates Code Sequence
PatientLocationCoordinatesSequence | (3006,00C9): Patient Location Coordinates Sequence
PatientMotherBirthName | (0010,1060): Patient's Mother's Birth Name
PatientMotionCorrected | (0018,9763): Patient Motion Corrected
PatientName | (0010,0010): Patient's Name
PatientNotProperlyFixatedQuantity | (0024,0036): Patient Not Properly Fixated Quantity
PatientOrientation | (0020,0020): Patient Orientation
PatientOrientationCodeSequence | (0054,0410): Patient Orientation Code Sequence
PatientOrientationInFrameSequence | (0020,9450): Patient Orientation in Frame Sequence
PatientOrientationModifierCodeSequence | (0054,0412): Patient Orientation Modifier Code Sequence
PatientPhysiologicalStateCodeSequence | (0018,9772): Patient Physiological State Code Sequence
PatientPhysiologicalStateSequence | (0018,9771): Patient Physiological State Sequence
PatientPosition | (0018,5100): Patient Position
PatientPositioningInstructionSequence | (0018,991B): Patient Positioning Instruction Sequence
PatientPrimaryLanguageCodeSequence | (0010,0101): Patient's Primary Language Code Sequence
PatientPrimaryLanguageModifierCodeSequence | (0010,0102): Patient's Primary Language Modifier Code Sequence
PatientReliabilityIndicator | (0024,0069): Patient Reliability Indicator
PatientReligiousPreference | (0010,21F0): Patient's Religious Preference
PatientSetupLabel | (300A,0183): Patient Setup Label
PatientSetupNumber | (300A,0182): Patient Setup Number
PatientSetupPhotoDescription | (300A,0794): Patient Setup Photo Description
PatientSetupSequence | (300A,0180): Patient Setup Sequence
PatientSetupUID | (300A,0650): Patient Setup UID
PatientSex | (0010,0040): Patient's Sex
PatientSexNeutered | (0010,2203): Patient's Sex Neutered
PatientSize | (0010,1020): Patient's Size
PatientSizeCodeSequence | (0010,1021): Patient's Size Code Sequence
PatientSpeciesCodeSequence | (0010,2202): Patient Species Code Sequence
PatientSpeciesDescription | (0010,2201): Patient Species Description
PatientSpecificationSequence | (0018,9911): Patient Specification Sequence
PatientState | (0038,0500): Patient State
PatientSupportAccessoryCode | (300A,0354): Patient Support Accessory Code
PatientSupportAdjustedAngle | (0074,102A): Patient Support Adjusted Angle
PatientSupportAngle | (300A,0122): Patient Support Angle
PatientSupportAngleTolerance | (300A,004C): Patient Support Angle Tolerance
PatientSupportDevicesSequence | (300A,0686): Patient Support Devices Sequence
PatientSupportDisplacementSequence | (300A,079C): Patient Support Displacement Sequence
PatientSupportID | (300A,0352): Patient Support ID
PatientSupportPositionDeviceParameterSequence | (300A,065D): Patient Support Position Device Parameter Sequence
PatientSupportPositionDeviceToleranceSequence | (300A,0660): Patient Support Position Device Tolerance Sequence
PatientSupportPositionParameterOrderIndex | (300A,065F): Patient Support Position Parameter Order Index
PatientSupportPositionParameterSequence | (300A,065B): Patient Support Position Parameter Sequence
PatientSupportPositionSequence | (3006,00CB): Patient Support Position Sequence
PatientSupportPositionSpecificationMethod | (300A,065C): Patient Support Position Specification Method
PatientSupportPositionToleranceOrderIndex | (300A,0661): Patient Support Position Tolerance Order Index
PatientSupportPositionToleranceSequence | (300A,062D): Patient Support Position Tolerance Sequence
PatientSupportRotationDirection | (300A,0123): Patient Support Rotation Direction
PatientSupportType | (300A,0350): Patient Support Type
PatientTelecomInformation | (0010,2155): Patient's Telecom Information
PatientTelephoneNumbers | (0010,2154): Patient's Telephone Numbers
PatientToEquipmentRelationshipSequence | (300A,07A0): Patient to Equipment Relationship Sequence
PatientTransportArrangements | (0040,1004): Patient Transport Arrangements
PatientTreatmentOrientationSequence | (3010,0032): Patient Treatment Orientation Sequence
PatientTreatmentPreparationDeviceSequence | (300A,078F): Patient Treatment Preparation Device Sequence
PatientTreatmentPreparationMethodCodeSequence | (300A,078D): Patient Treatment Preparation Method Code Sequence
PatientTreatmentPreparationMethodDescription | (300A,0792): Patient Treatment Preparation Method Description
PatientTreatmentPreparationProcedureCodeSequence | (300A,0791): Patient Treatment Preparation Procedure Code Sequence
PatientTreatmentPreparationProcedureIndex | (300A,0795): Patient Treatment Preparation Procedure Index
PatientTreatmentPreparationProcedureParameterDescription | (300A,078E): Patient Treatment Preparation Procedure Parameter Description
PatientTreatmentPreparationProcedureParameterSequence | (300A,0793): Patient Treatment Preparation Procedure Parameter Sequence
PatientTreatmentPreparationProcedureSequence | (300A,0790): Patient Treatment Preparation Procedure Sequence
PatientTreatmentPreparationSequence | (300A,079F): Patient Treatment Preparation Sequence
PatientWeight | (0010,1030): Patient's Weight
PatternOffColorCIELabValue | (0070,0252): Pattern Off Color CIELab Value
PatternOffOpacity | (0070,0285): Pattern Off Opacity
PatternOnColorCIELabValue | (0070,0251): Pattern On Color CIELab Value
PatternOnOpacity | (0070,0284): Pattern On Opacity
PauseBetweenFrames | (0054,0038): Pause Between Frames
PercentPhaseFieldOfView | (0018,0094): Percent Phase Field of View
PercentSampling | (0018,0093): Percent Sampling
PerformedLocation | (0040,0243): Performed Location
PerformedProcedureCodeSequence | (0040,A372): Performed Procedure Code Sequence
PerformedProcedureStepDescription | (0040,0254): Performed Procedure Step Description
PerformedProcedureStepDiscontinuationReasonCodeSequence | (0040,0281): Performed Procedure Step Discontinuation Reason Code Sequence
PerformedProcedureStepEndDate | (0040,0250): Performed Procedure Step End Date
PerformedProcedureStepEndDateTime | (0040,4051): Performed Procedure Step End DateTime
PerformedProcedureStepEndTime | (0040,0251): Performed Procedure Step End Time
PerformedProcedureStepID | (0040,0253): Performed Procedure Step ID
PerformedProcedureStepStartDate | (0040,0244): Performed Procedure Step Start Date
PerformedProcedureStepStartDateTime | (0040,4050): Performed Procedure Step Start DateTime
PerformedProcedureStepStartTime | (0040,0245): Performed Procedure Step Start Time
PerformedProcedureStepStatus | (0040,0252): Performed Procedure Step Status
PerformedProcedureTypeDescription | (0040,0255): Performed Procedure Type Description
PerformedProcessingApplicationsCodeSequence | (0040,4007): Performed Processing Applications Code Sequence
PerformedProcessingParametersSequence | (0074,1212): Performed Processing Parameters Sequence
PerformedProtocolCodeSequence | (0040,0260): Performed Protocol Code Sequence
PerformedProtocolType | (0040,0261): Performed Protocol Type
PerformedSeriesSequence | (0040,0340): Performed Series Sequence
PerformedStationAETitle | (0040,0241): Performed Station AE Title
PerformedStationClassCodeSequence | (0040,4029): Performed Station Class Code Sequence
PerformedStationGeographicLocationCodeSequence | (0040,4030): Performed Station Geographic Location Code Sequence
PerformedStationName | (0040,0242): Performed Station Name
PerformedStationNameCodeSequence | (0040,4028): Performed Station Name Code Sequence
PerformedWorkitemCodeSequence | (0040,4019): Performed Workitem Code Sequence
PerformingPhysicianIdentificationSequence | (0008,1052): Performing Physician Identification Sequence
PerformingPhysicianName | (0008,1050): Performing Physician's Name
PerFrameFunctionalGroupsSequence | (5200,9230): Per-Frame Functional Groups Sequence
PerimeterTable | (0028,0070): Perimeter Table
PerimeterValue | (0028,0071): Perimeter Value
PerProjectionAcquisitionSequence | (0018,9538): Per Projection Acquisition Sequence
PersonAddress | (0040,1102): Person's Address
PersonIdentificationCodeSequence | (0040,1101): Person Identification Code Sequence
PersonName | (0040,A123): Person Name
PersonTelecomInformation | (0040,1104): Person's Telecom Information
PersonTelephoneNumbers | (0040,1103): Person's Telephone Numbers
PertinentDocumentsSequence | (0038,0100): Pertinent Documents Sequence
PertinentOtherEvidenceSequence | (0040,A385): Pertinent Other Evidence Sequence
PertinentResourcesSequence | (0038,0101): Pertinent Resources Sequence
PertinentSOPClassesInSeries | (3010,0053): Pertinent SOP Classes in Series
PertinentSOPClassesInStudy | (3010,0052): Pertinent SOP Classes in Study
PETDetectorMotionDetailsSequence | (0018,9733): PET Detector Motion Details Sequence
PETFrameAcquisitionSequence | (0018,9732): PET Frame Acquisition Sequence
PETFrameCorrectionFactorsSequence | (0018,9736): PET Frame Correction Factors Sequence
PETFrameTypeSequence | (0018,9751): PET Frame Type Sequence
PETPositionSequence | (0018,9735): PET Position Sequence
PETReconstructionSequence | (0018,9749): PET Reconstruction Sequence
PETTableDynamicsSequence | (0018,9734): PET Table Dynamics Sequence
PhantomType | (4010,1046): Phantom Type
PhaseContrast | (0018,9014): Phase Contrast
PhaseDelay | (0054,0036): Phase Delay
PhaseDescription | (0054,0039): Phase Description
PhaseInformationSequence | (0054,0032): Phase Information Sequence
PhaseNumber | (0020,0015): Phase Number
PhaseVector | (0054,0030): Phase Vector
PhosphorType | (0018,1261): Phosphor Type
PhotoacousticExcitationCharacteristicsSequence | (0018,9821): Photoacoustic Excitation Characteristics Sequence
PhotoacousticImageFrameTypeSequence | (0018,9835): Photoacoustic Image Frame Type Sequence
PhotographicExposureIndex | (0016,0038): Photographic Exposure Index
PhotographicSensitivity | (0016,0018): Photographic Sensitivity
PhotometricInterpretation | (0028,0004): Photometric Interpretation
PhotonEnergy | (0018,9383): Photon Energy
PhototimerSetting | (0018,7065): Phototimer Setting
PhysicalDeltaX | (0018,602C): Physical Delta X
PhysicalDeltaY | (0018,602E): Physical Delta Y
PhysicalDetectorSize | (0018,9429): Physical Detector Size
PhysicalUnitsXDirection | (0018,6024): Physical Units X Direction
PhysicalUnitsYDirection | (0018,6026): Physical Units Y Direction
PhysicianApprovingInterpretation | (4008,0114): Physician Approving Interpretation
PhysiciansOfRecord | (0008,1048): Physician(s) of Record
PhysiciansOfRecordIdentificationSequence | (0008,1049): Physician(s) of Record Identification Sequence
PhysiciansReadingStudyIdentificationSequence | (0008,1062): Physician(s) Reading Study Identification Sequence
PixelAspectRatio | (0028,0034): Pixel Aspect Ratio
PixelBandwidth | (0018,0095): Pixel Bandwidth
PixelComponentDataType | (0018,604E): Pixel Component Data Type
PixelComponentMask | (0018,6046): Pixel Component Mask
PixelComponentOrganization | (0018,6044): Pixel Component Organization
PixelComponentPhysicalUnits | (0018,604C): Pixel Component Physical Units
PixelComponentRangeStart | (0018,6048): Pixel Component Range Start
PixelComponentRangeStop | (0018,604A): Pixel Component Range Stop
PixelCoordinatesSetTrial | (0040,A29A): Pixel Coordinates Set (Trial)
PixelData | (7FE0,0010): Pixel Data
PixelDataAreaOriginRelativeToFOV | (0018,7036): Pixel Data Area Origin Relative To FOV
PixelDataAreaRotationAngleRelativeToFOV | (0018,7038): Pixel Data Area Rotation Angle Relative To FOV
PixelDataProviderURL | (0028,7FE0): Pixel Data Provider URL
PixelIntensityRelationship | (0028,1040): Pixel Intensity Relationship
PixelIntensityRelationshipLUTSequence | (0028,9422): Pixel Intensity Relationship LUT Sequence
PixelIntensityRelationshipSign | (0028,1041): Pixel Intensity Relationship Sign
PixelMeasuresSequence | (0028,9110): Pixel Measures Sequence
PixelOriginInterpretation | (0048,0301): Pixel Origin Interpretation
PixelPaddingRangeLimit | (0028,0121): Pixel Padding Range Limit
PixelPaddingValue | (0028,0120): Pixel Padding Value
PixelPresentation | (0008,9205): Pixel Presentation
PixelRepresentation | (0028,0103): Pixel Representation
PixelShiftFrameRange | (0028,9506): Pixel Shift Frame Range
PixelShiftSequence | (0028,9501): Pixel Shift Sequence
PixelSpacing | (0028,0030): Pixel Spacing
PixelSpacingCalibrationDescription | (0028,0A04): Pixel Spacing Calibration Description
PixelSpacingCalibrationType | (0028,0A02): Pixel Spacing Calibration Type
PixelSpacingSequence | (0040,08D8): Pixel Spacing Sequence
PixelValueMappingCodeSequence | (0040,9098): Pixel Value Mapping Code Sequence
PixelValueMappingExplanation | (0022,1454): Pixel Value Mapping Explanation
PixelValueMappingToCodedConceptSequence | (0022,1450): Pixel Value Mapping to Coded Concept Sequence
PixelValueTransformationSequence | (0028,9145): Pixel Value Transformation Sequence
PlacerOrderNumberImagingServiceRequest | (0040,2016): Placer Order Number / Imaging Service Request
PlacerOrderNumberImagingServiceRequestRetired | (0040,2006): Placer Order Number / Imaging Service Request (Retired)
PlacerOrderNumberProcedure | (0040,1006): Placer Order Number / Procedure
PlanarConfiguration | (0028,0006): Planar Configuration
Plane | (0070,1305): Plane
PlaneIdentification | (0018,9457): Plane Identification
PlaneNormal | (0070,1306): Plane Normal
PlaneOrientationSequence | (0020,9116): Plane Orientation Sequence
PlaneOrientationVolumeSequence | (0020,930F): Plane Orientation (Volume) Sequence
PlanePositionSequence | (0020,9113): Plane Position Sequence
PlanePositionSlideSequence | (0048,021A): Plane Position (Slide) Sequence
PlanePositionVolumeSequence | (0020,930E): Plane Position (Volume) Sequence
Planes | (0028,0012): Planes
PlanesInAcquisition | (0018,9410): Planes in Acquisition
PlanIntent | (300A,000A): Plan Intent
PlannedVerificationImageSequence | (300A,00CA): Planned Verification Image Sequence
PlanningInputInformationSequence | (3010,0076): Planning Input Information Sequence
PlanningLandmarkDescription | (0068,6540): Planning Landmark Description
PlanningLandmarkID | (0068,6530): Planning Landmark ID
PlanningLandmarkIdentificationCodeSequence | (0068,6545): Planning Landmark Identification Code Sequence
PlanningLandmarkLineSequence | (0068,6510): Planning Landmark Line Sequence
PlanningLandmarkPlaneSequence | (0068,6520): Planning Landmark Plane Sequence
PlanningLandmarkPointSequence | (0068,6500): Planning Landmark Point Sequence
PlanOverviewIndex | (300C,0117): Plan Overview Index
PlanOverviewSequence | (300C,0116): Plan Overview Sequence
PlateID | (0018,1004): Plate ID
PlateType | (0018,1260): Plate Type
PointCoordinatesData | (0066,0016): Point Coordinates Data
PointPositionAccuracy | (0066,0017): Point Position Accuracy
PointsBoundingBoxCoordinates | (0066,001A): Points Bounding Box Coordinates
Polarity | (2020,0020): Polarity
PositionAcquisitionTemplateCodeSequence | (3002,0122): Position Acquisition Template Code Sequence
PositionAcquisitionTemplateDescription | (3002,0123): Position Acquisition Template Description
PositionAcquisitionTemplateID | (3002,0120): Position Acquisition Template ID
PositionAcquisitionTemplateIdentificationSequence | (3002,011F): Position Acquisition Template Identification Sequence
PositionAcquisitionTemplateName | (3002,0121): Position Acquisition Template Name
PositionerIsocenterDetectorRotationAngle | (0018,9465): Positioner Isocenter Detector Rotation Angle
PositionerIsocenterPrimaryAngle | (0018,9463): Positioner Isocenter Primary Angle
PositionerIsocenterSecondaryAngle | (0018,9464): Positioner Isocenter Secondary Angle
PositionerMotion | (0018,1500): Positioner Motion
PositionerPositionSequence | (0018,9405): Positioner Position Sequence
PositionerPrimaryAngle | (0018,1510): Positioner Primary Angle
PositionerPrimaryAngleDirection | (0018,9559): Positioner Primary Angle Direction
PositionerPrimaryAngleIncrement | (0018,1520): Positioner Primary Angle Increment
PositionerSecondaryAngle | (0018,1511): Positioner Secondary Angle
PositionerSecondaryAngleIncrement | (0018,1521): Positioner Secondary Angle Increment
PositionerType | (0018,1508): Positioner Type
PositioningLandmarkSequence | (0018,991D): Positioning Landmark Sequence
PositioningMethodCodeSequence | (0018,991C): Positioning Method Code Sequence
PositionMeasuringDeviceUsed | (0018,980C): Position Measuring Device Used
PositionOfIsocenterProjection | (0018,9430): Position of Isocenter Projection
PositionReferenceIndicator | (0020,1040): Position Reference Indicator
PositiveCatchTrialsQuantity | (0024,0056): Positive Catch Trials Quantity
PostDeformationMatrixRegistrationSequence | (0064,0010): Post Deformation Matrix Registration Sequence
PostprocessingFunction | (0018,5021): Postprocessing Function
PotentialDiagnosticTasks | (0018,990A): Potential Diagnostic Tasks
PotentialReasonsForProcedure | (0018,9908): Potential Reasons for Procedure
PotentialReasonsForProcedureCodeSequence | (0018,9909): Potential Reasons for Procedure Code Sequence
PotentialRequestedProcedureCodeSequence | (0018,9907): Potential Requested Procedure Code Sequence
PotentialScheduledProtocolCodeSequence | (0018,9906): Potential Scheduled Protocol Code Sequence
PotentialThreatObjectID | (4010,1010): Potential Threat Object ID
PowerlineFrequency | (003A,0311): Powerline Frequency
PRCSToRCSOrientation | (4010,107E): PRCS to RCS Orientation
PreAmplifierEquipmentSequence | (0014,400E): Pre-Amplifier Equipment Sequence
PreAmplifierNotes | (0014,400F): Pre-Amplifier Notes
PreAmplifierSettingsSequence | (0014,4040): Pre-Amplifier Settings Sequence
PredecessorDocumentsSequence | (0040,A360): Predecessor Documents Sequence
PredecessorProtocolSequence | (0018,990E): Predecessor Protocol Sequence
PredecessorStructureSetSequence | (3006,0018): Predecessor Structure Set Sequence
PreDeformationMatrixRegistrationSequence | (0064,000F): Pre Deformation Matrix Registration Sequence
PredictedRefractiveError | (0022,1054): Predicted Refractive Error
PredictedToricErrorSequence | (0022,1048): Predicted Toric Error Sequence
PredictorColumns | (0028,0081): Predictor Columns
PredictorConstants | (0028,0082): Predictor Constants
PredictorRows | (0028,0080): Predictor Rows
PreferredPlaybackSequencing | (0018,1244): Preferred Playback Sequencing
PregnancyStatus | (0010,21C0): Pregnancy Status
PreliminaryFlag | (0040,A496): Preliminary Flag
PreMedication | (0040,0012): Pre-Medication
PrescriptionDescription | (300A,000E): Prescription Description
PrescriptionNotes | (3010,007B): Prescription Notes
PrescriptionNotesSequence | (3010,0081): Prescription Notes Sequence
PrescriptionOverviewSequence | (300C,0114): Prescription Overview Sequence
PreSelectedForImplantation | (0022,1049): Pre-Selected for Implantation
PresentationAnimationStyle | (0070,1A01): Presentation Animation Style
PresentationCreationDate | (0070,0082): Presentation Creation Date
PresentationCreationTime | (0070,0083): Presentation Creation Time
PresentationDisplayCollectionUID | (0070,1101): Presentation Display Collection UID
PresentationGroupNumber | (003A,0241): Presentation Group Number
PresentationInputType | (0070,1202): Presentation Input Type
PresentationIntentType | (0008,0068): Presentation Intent Type
PresentationLUTContentSequence | (2130,0080): Presentation LUT Content Sequence
PresentationLUTFlag | (2000,0069): Presentation LUT Flag
PresentationLUTSequence | (2050,0010): Presentation LUT Sequence
PresentationLUTShape | (2050,0020): Presentation LUT Shape
PresentationPixelAspectRatio | (0070,0102): Presentation Pixel Aspect Ratio
PresentationPixelMagnificationRatio | (0070,0103): Presentation Pixel Magnification Ratio
PresentationPixelSpacing | (0070,0101): Presentation Pixel Spacing
PresentationSequenceCollectionUID | (0070,1102): Presentation Sequence Collection UID
PresentationSequencePositionIndex | (0070,1103): Presentation Sequence Position Index
PresentationSizeMode | (0070,0100): Presentation Size Mode
PresentationStateClassificationComponentSequence | (0070,1801): Presentation State Classification Component Sequence
PresentationStateCompositorComponentSequence | (0070,1805): Presentation State Compositor Component Sequence
PresentedVisualStimuliDataFlag | (0024,0037): Presented Visual Stimuli Data Flag
PreserveCompositeInstancesAfterMediaCreation | (2200,000A): Preserve Composite Instances After Media Creation
Pressure | (0016,0032): Pressure
PrimaryAnatomicStructureModifierSequence | (0008,2230): Primary Anatomic Structure Modifier Sequence
PrimaryAnatomicStructureSequence | (0008,2228): Primary Anatomic Structure Sequence
PrimaryChromaticities | (0016,0002): Primary Chromaticities
PrimaryDoseValueIndicator | (300A,061B): Primary Dose Value Indicator
PrimaryDosimeterUnit | (300A,00B3): Primary Dosimeter Unit
PrimaryFluenceModeSequence | (3002,0050): Primary Fluence Mode Sequence
PrimaryPositionerIncrement | (0018,9514): Primary Positioner Increment
PrimaryPositionerIncrementSign | (0018,9518): Primary Positioner Increment Sign
PrimaryPositionerScanArc | (0018,9508): Primary Positioner Scan Arc
PrimaryPositionerScanStartAngle | (0018,9510): Primary Positioner Scan Start Angle
PrimaryPromptsCountsAccumulated | (0054,1310): Primary (Prompts) Counts Accumulated
PrimitivePointIndexList | (0066,0029): Primitive Point Index List
Print | (0000,51A0): Print(Retired)
PrinterCharacteristicsSequence | (2130,0015): Printer Characteristics Sequence
PrinterConfigurationSequence | (2000,001E): Printer Configuration Sequence
PrinterName | (2110,0030): Printer Name
PrinterPixelSpacing | (2010,0376): Printer Pixel Spacing
PrinterResolutionID | (2010,0052): Printer Resolution ID
PrinterStatus | (2110,0010): Printer Status
PrinterStatusInfo | (2110,0020): Printer Status Info
PrintingBitDepth | (2000,00A1): Printing Bit Depth
PrintJobDescriptionSequence | (2120,0050): Print Job Description Sequence
PrintJobID | (2100,0010): Print Job ID
PrintManagementCapabilitiesSequence | (2130,0010): Print Management Capabilities Sequence
PrintPriority | (2000,0020): Print Priority
PrintQueueID | (2110,0099): Print Queue ID
Priority | (0000,0700): Priority
PriorRecordKey | (0008,041C): Prior Record Key
PriorTreatmentDoseDescription | (3010,0061): Prior Treatment Dose Description
PriorTreatmentReferenceSequence | (3010,0062): Prior Treatment Reference Sequence
PrismSequence | (0046,0028): Prism Sequence
PrivateCreatorReference | (0008,0302): Private Creator Reference
PrivateDataElement | (0008,0308): Private Data Element
PrivateDataElementCharacteristicsSequence | (0008,0300): Private Data Element Characteristics Sequence
PrivateDataElementDefinitionSequence | (0008,0310): Private Data Element Definition Sequence
PrivateDataElementDescription | (0008,030E): Private Data Element Description
PrivateDataElementEncoding | (0008,030F): Private Data Element Encoding
PrivateDataElementKeyword | (0008,030D): Private Data Element Keyword
PrivateDataElementName | (0008,030C): Private Data Element Name
PrivateDataElementNumberOfItems | (0008,030B): Private Data Element Number of Items
PrivateDataElementValueMultiplicity | (0008,0309): Private Data Element Value Multiplicity
PrivateDataElementValueRepresentation | (0008,030A): Private Data Element Value Representation
PrivateGroupReference | (0008,0301): Private Group Reference
PrivateInformation | (0002,0102): Private Information
PrivateInformationCreatorUID | (0002,0100): Private Information Creator UID
PrivateRecordUID | (0004,1432): Private Record UID
ProbeCenterLocationX | (0014,4058): Probe Center Location X
ProbeCenterLocationZ | (0014,4059): Probe Center Location Z
ProbeDriveEquipmentSequence | (0014,4080): Probe Drive Equipment Sequence
ProbeDriveNotes | (0014,4082): Probe Drive Notes
ProbeDriveSettingsSequence | (0014,4087): Probe Drive Settings Sequence
ProbeInductance | (0014,4084): Probe Inductance
ProbeOrientationAngle | (0014,4089): Probe Orientation Angle
ProbeResistance | (0014,4085): Probe Resistance
ProcedureCodeSequence | (0008,1032): Procedure Code Sequence
ProcedureContextFlagTrial | (0040,A603): Procedure Context Flag (Trial)
ProcedureContextSequenceTrial | (0040,A340): Procedure Context Sequence (Trial)
ProcedureCreationDate | (0014,4076): Procedure Creation Date
ProcedureExpirationDate | (0014,4078): Procedure Expiration Date
ProcedureIdentifierCodeSequenceTrial | (0040,A085): Procedure Identifier Code Sequence (Trial)
ProcedureLastModifiedDate | (0014,407A): Procedure Last Modified Date
ProcedureStepCancellationDateTime | (0040,4052): Procedure Step Cancellation DateTime
ProcedureStepCommunicationsURISequence | (0074,1008): Procedure Step Communications URI Sequence
ProcedureStepDiscontinuationReasonCodeSequence | (0074,100E): Procedure Step Discontinuation Reason Code Sequence
ProcedureStepLabel | (0074,1204): Procedure Step Label
ProcedureStepProgress | (0074,1004): Procedure Step Progress
ProcedureStepProgressDescription | (0074,1006): Procedure Step Progress Description
ProcedureStepProgressInformationSequence | (0074,1002): Procedure Step Progress Information Sequence
ProcedureStepProgressParametersSequence | (0074,1007): Procedure Step Progress Parameters Sequence
ProcedureStepRelationshipType | (0074,1222): Procedure Step Relationship Type
ProcedureStepState | (0074,1000): Procedure Step State
ProcedureTypeCodeSequence | (0076,0020): Procedure Type Code Sequence
ProcedureVersion | (0014,4074): Procedure Version
ProcessingFunction | (0018,5020): Processing Function
ProductDescription | (0044,0009): Product Description
ProductExpirationDateTime | (0044,000B): Product Expiration DateTime
ProductLotIdentifier | (0044,000A): Product Lot Identifier
ProductName | (0044,0008): Product Name
ProductPackageIdentifier | (0044,0001): Product Package Identifier
ProductParameterSequence | (0044,0013): Product Parameter Sequence
ProductTypeCodeSequence | (0044,0007): Product Type Code Sequence
ProjectionEponymousNameCodeSequence | (0018,5104): Projection Eponymous Name Code Sequence
ProjectionImagingAcquisitionParameterSequence | (3002,0125): Projection Imaging Acquisition Parameter Sequence
ProjectionPixelCalibrationSequence | (0018,9401): Projection Pixel Calibration Sequence
PropertyLabel | (0014,2032): Property Label
ProposedStudySequence | (2130,00A0): Proposed Study Sequence
ProtocolContextSequence | (0040,0440): Protocol Context Sequence
ProtocolDefinedPatientPosition | (0018,9947): Protocol Defined Patient Position
ProtocolDesignRationale | (0018,9910): Protocol Design Rationale
ProtocolElementCharacteristicsSummary | (0018,9923): Protocol Element Characteristics Summary
ProtocolElementName | (0018,9922): Protocol Element Name
ProtocolElementNumber | (0018,9921): Protocol Element Number
ProtocolElementPurpose | (0018,9924): Protocol Element Purpose
ProtocolName | (0018,1030): Protocol Name
ProtocolPlanningInformation | (0018,990F): Protocol Planning Information
PseudoColorPaletteInstanceReferenceSequence | (0072,0705): Pseudo-Color Palette Instance Reference Sequence
PseudoColorType | (0072,0704): Pseudo-Color Type
PTOLocationDescription | (4010,1078): PTO Location Description
PTORegionSequence | (4010,107B): PTO Region Sequence
PTORepresentationSequence | (4010,1037): PTO Representation Sequence
PulseNumber | (3008,0172): Pulse Number
PulseRepetitionFrequency | (0018,6032): Pulse Repetition Frequency
PulseRepetitionInterval | (300A,028C): Pulse Repetition Interval
PulserEquipmentSequence | (0014,4002): Pulser Equipment Sequence
PulserNotes | (0014,4006): Pulser Notes
PulserSettingsSequence | (0014,4020): Pulser Settings Sequence
PulserType | (0014,4004): Pulser Type
PulseSequenceName | (0018,9005): Pulse Sequence Name
PulseSpecificBrachyControlPointDeliveredSequence | (3008,0171): Pulse Specific Brachy Control Point Delivered Sequence
PulseWidth | (0014,4022): Pulse Width
PupilCentroidXCoordinate | (0046,0203): Pupil Centroid X-Coordinate
PupilCentroidYCoordinate | (0046,0204): Pupil Centroid Y-Coordinate
PupilDilated | (0022,000D): Pupil Dilated
PupilSize | (0046,0044): Pupil Size
PurposeOfReferenceCodeSequence | (0040,A170): Purpose of Reference Code Sequence
PVCRejection | (0018,1085): PVC Rejection
PyramidDescription | (0008,1088): Pyramid Description
PyramidLabel | (0020,0027): Pyramid Label
PyramidUID | (0008,0019): Pyramid UID
QAResultsSequence | (0028,700F): QA Results Sequence
QRMeasurementsSequence | (4010,1071): QR Measurements Sequence
QuadratureReceiveCoil | (0018,9044): Quadrature Receive Coil
QualityControlImage | (0028,0300): Quality Control Image
QualityControlSubject | (0010,0200): Quality Control Subject
QualityControlSubjectTypeCodeSequence | (0010,0201): Quality Control Subject Type Code Sequence
QualityThreshold | (0022,1630): Quality Threshold
QuantifiedDefect | (0024,0098): Quantified Defect
Quantity | (0040,0294): Quantity
QuantityDefinitionSequence | (0040,9220): Quantity Definition Sequence
QuantitySequence | (0040,0293): Quantity Sequence
QueryRetrieveLevel | (0008,0052): Query/Retrieve Level
QueryRetrieveView | (0008,0053): Query/Retrieve View
QueueStatus | (2120,0010): Queue Status
RadialPosition | (0018,1142): Radial Position
RadiationAtomicNumber | (300A,0304): Radiation Atomic Number
RadiationBeamBlockSlabThickness | (300A,066E): Radiation Beam Block Slab Thickness
RadiationBeamBlockThickness | (300A,066D): Radiation Beam Block Thickness
RadiationBeamCompensatorMillingToolDiameter | (300A,0669): Radiation Beam Compensator Milling Tool Diameter
RadiationBeamEffectiveWedgeAngle | (300A,0654): Radiation Beam Effective Wedge Angle
RadiationBeamWedgeAngle | (300A,0652): Radiation Beam Wedge Angle
RadiationBeamWedgeThinEdgeDistance | (300A,0653): Radiation Beam Wedge Thin Edge Distance
RadiationChargeState | (300A,0306): Radiation Charge State
RadiationDeviceConfigurationAndCommissioningKeySequence | (300A,065A): Radiation Device Configuration and Commissioning Key Sequence
RadiationDoseCentralAxisDisplacement | (300A,0624): Radiation Dose Central Axis Displacement
RadiationDoseIdentificationIndex | (300A,0603): Radiation Dose Identification Index
RadiationDoseIdentificationLabel | (300A,0619): Radiation Dose Identification Label
RadiationDoseIdentificationSequence | (300A,0618): Radiation Dose Identification Sequence
RadiationDoseInVivoMeasurementLabel | (300A,0623): Radiation Dose In-Vivo Measurement Label
RadiationDoseMeasurementPointCoordinates | (300A,0627): Radiation Dose Measurement Point Coordinates
RadiationDoseSequence | (300A,0617): Radiation Dose Sequence
RadiationDoseSourceToExternalContourDistance | (300A,0628): Radiation Dose Source to External Contour Distance
RadiationDoseSourceToSkinDistance | (300A,0626): Radiation Dose Source to Skin Distance
RadiationDoseValue | (300A,0625): Radiation Dose Value
RadiationDoseValuesParametersSequence | (300A,061F): Radiation Dose Values Parameters Sequence
RadiationDosimeterUnitSequence | (300A,0658): Radiation Dosimeter Unit Sequence
RadiationFluenceModifierCodeSequence | (300A,0683): Radiation Fluence Modifier Code Sequence
RadiationGenerationModeDescription | (300A,067D): Radiation GenerationMode Description
RadiationGenerationModeIndex | (300A,0601): Radiation Generation Mode Index
RadiationGenerationModeLabel | (300A,067C): Radiation GenerationMode Label
RadiationGenerationModeMachineCodeSequence | (300A,067E): Radiation GenerationMode Machine Code Sequence
RadiationGenerationModeSequence | (300A,067B): Radiation GenerationMode Sequence
RadiationMachineName | (3002,0020): Radiation Machine Name
RadiationMachineSAD | (3002,0022): Radiation Machine SAD
RadiationMachineSSD | (3002,0024): Radiation Machine SSD
RadiationMassNumber | (300A,0302): Radiation Mass Number
RadiationMode | (0018,115A): Radiation Mode
RadiationOrderIndex | (300A,0786): Radiation Order Index
RadiationSetting | (0018,1155): Radiation Setting
RadiationSourceAxisDistance | (300A,0640): Radiation Source-Axis Distance
RadiationSourceCoordinateSystemPitchAngle | (3010,0096): Radiation Source Coordinate System Pitch Angle
RadiationSourceCoordinateSystemRollAngle | (3010,0095): Radiation Source Coordinate SystemRoll Angle
RadiationSourceCoordinateSystemYawAngle | (3010,0094): Radiation Source Coordinate SystemYaw Angle
RadiationType | (300A,00C6): Radiation Type
RadiationTypeCodeSequence | (300A,067F): Radiation Type Code Sequence
RadiobiologicalDoseEffectFlag | (3010,0002): Radiobiological Dose Effect Flag
RadiobiologicalDoseEffectSequence | (3010,0001): Radiobiological Dose Effect Sequence
Radionuclide | (0018,0030): Radionuclide
RadionuclideCodeSequence | (0054,0300): Radionuclide Code Sequence
RadionuclideHalfLife | (0018,1075): Radionuclide Half Life
RadionuclidePositronFraction | (0018,1076): Radionuclide Positron Fraction
RadionuclideTotalDose | (0018,1074): Radionuclide Total Dose
Radiopharmaceutical | (0018,0031): Radiopharmaceutical
RadiopharmaceuticalAdministrationEventUID | (0008,3012): Radiopharmaceutical Administration Event UID
RadiopharmaceuticalAgentNumber | (0018,9729): Radiopharmaceutical Agent Number
RadiopharmaceuticalCodeSequence | (0054,0304): Radiopharmaceutical Code Sequence
RadiopharmaceuticalInformationSequence | (0054,0016): Radiopharmaceutical Information Sequence
RadiopharmaceuticalRoute | (0018,1070): Radiopharmaceutical Route
RadiopharmaceuticalSpecificActivity | (0018,1077): Radiopharmaceutical Specific Activity
RadiopharmaceuticalStartDateTime | (0018,1078): Radiopharmaceutical Start DateTime
RadiopharmaceuticalStartTime | (0018,1072): Radiopharmaceutical Start Time
RadiopharmaceuticalStopDateTime | (0018,1079): Radiopharmaceutical Stop DateTime
RadiopharmaceuticalStopTime | (0018,1073): Radiopharmaceutical Stop Time
RadiopharmaceuticalUsageSequence | (0018,9737): Radiopharmaceutical Usage Sequence
RadiopharmaceuticalVolume | (0018,1071): Radiopharmaceutical Volume
RadiotherapyTreatmentType | (3010,0046): Radiotherapy Treatment Type
RadiusAlongWedge | (0014,511F): Radius Along the Wedge
RadiusOfCircularCollimator | (0018,1712): Radius of Circular Collimator
RadiusOfCircularExposureControlSensingRegion | (0018,9441): Radius of Circular Exposure Control Sensing Region
RadiusOfCircularShutter | (0018,1612): Radius of Circular Shutter
RadiusOfCurvature | (0046,0075): Radius of Curvature
RandomsCorrected | (0018,9765): Randoms Corrected
RandomsCorrectionMethod | (0054,1100): Randoms Correction Method
RangeMatchingSequence | (0008,0410): Range Matching Sequence
RangeModulatorDescription | (300A,034A): Range Modulator Description
RangeModulatorGatingStartValue | (300A,0382): Range Modulator Gating Start Value
RangeModulatorGatingStartWaterEquivalentThickness | (300A,0386): Range Modulator Gating Start Water Equivalent Thickness
RangeModulatorGatingStopValue | (300A,0384): Range Modulator Gating Stop Value
RangeModulatorGatingStopWaterEquivalentThickness | (300A,0388): Range Modulator Gating Stop Water Equivalent Thickness
RangeModulatorID | (300A,0346): Range Modulator ID
RangeModulatorNumber | (300A,0344): Range Modulator Number
RangeModulatorSequence | (300A,0342): Range Modulator Sequence
RangeModulatorSettingsSequence | (300A,0380): Range Modulator Settings Sequence
RangeModulatorType | (300A,0348): Range Modulator Type
RangeOfFreedom | (0068,64A0): Range of Freedom
RangeShifterDescription | (300A,0322): Range Shifter Description
RangeShifterID | (300A,0318): Range Shifter ID
RangeShifterNumber | (300A,0316): Range Shifter Number
RangeShifterSequence | (300A,0314): Range Shifter Sequence
RangeShifterSetting | (300A,0362): Range Shifter Setting
RangeShifterSettingsSequence | (300A,0360): Range Shifter Settings Sequence
RangeShifterType | (300A,0320): Range Shifter Type
RangeShifterWaterEquivalentThickness | (300A,0366): Range Shifter Water Equivalent Thickness
RangingDepth | (0052,0009): Ranging Depth
RationalDenominatorValue | (0040,A163): Rational Denominator Value
RationalNumeratorValue | (0040,A162): Rational Numerator Value
RawDataHandling | (0040,4040): Raw Data Handling
RealTimeBulkDataFlowSequence | (0034,000A): Real-Time Bulk Data Flow Sequence
RealWorldValueFirstValueMapped | (0040,9216): Real World Value First Value Mapped
RealWorldValueIntercept | (0040,9224): Real World Value Intercept
RealWorldValueLastValueMapped | (0040,9211): Real World Value Last Value Mapped
RealWorldValueLUTData | (0040,9212): Real World Value LUT Data
RealWorldValueMappingSequence | (0040,9096): Real World Value Mapping Sequence
RealWorldValueSlope | (0040,9225): Real World Value Slope
ReasonForCancellation | (0074,1238): Reason for Cancellation
ReasonForChannelOmission | (0074,140A): Reason for Channel Omission
ReasonForChannelOmissionDescription | (0074,140B): Reason for Channel Omission Description
ReasonForOmission | (300C,0112): Reason for Omission
ReasonForOmissionCodeSequence | (300A,0788): Reason for Omission Code Sequence
ReasonForOmissionDescription | (300C,0113): Reason for Omission Description
ReasonForPerformedProcedureCodeSequence | (0040,1012): Reason For Performed Procedure Code Sequence
ReasonForRemovalCodeSequence | (0008,0406): Reason for Removal Code Sequence
ReasonForRequestedProcedureCodeSequence | (0040,100A): Reason for Requested Procedure Code Sequence
ReasonForStudy | (0032,1030): Reason for Study
ReasonForSuperseding | (3010,005C): Reason for Superseding
ReasonForTheAttributeModification | (0400,0565): Reason for the Attribute Modification
ReasonForTheImagingServiceRequest | (0040,2001): Reason for the Imaging Service Request
ReasonForTheRequestedProcedure | (0040,1002): Reason for the Requested Procedure
ReasonForVisit | (0032,1066): Reason for Visit
ReasonForVisitCodeSequence | (0032,1067): Reason for Visit Code Sequence
ReceiveCoilManufacturerName | (0018,9041): Receive Coil Manufacturer Name
ReceiveCoilName | (0018,1250): Receive Coil Name
ReceiveCoilType | (0018,9043): Receive Coil Type
ReceiveProbeSequence | (0014,4086): Receive Probe Sequence
Receiver | (0000,0300): Receiver(Retired)
ReceiverEquipmentSequence | (0014,4008): Receiver Equipment Sequence
ReceiverNotes | (0014,400C): Receiver Notes
ReceiverSettingsSequence | (0014,4030): Receiver Settings Sequence
ReceiveTransducerSequence | (0014,4011): Receive Transducer Sequence
ReceiveTransducerSettingsSequence | (0014,4051): Receive Transducer Settings Sequence
ReceivingAE | (0074,1234): Receiving AE
ReceivingApplicationEntityTitle | (0002,0018): Receiving Application Entity Title
ReceivingPresentationAddress | (0002,0028): Receiving Presentation Address
RecognitionCode | (0008,0010): Recognition Code(Retired)
RecognizableVisualFeatures | (0028,0302): Recognizable Visual Features
RecommendedAbsentPixelCIELabValue | (0048,0015): Recommended Absent Pixel CIELab Value
RecommendedAnimationRate | (0070,1A03): Recommended Animation Rate
RecommendedDefaultValueSequence | (0082,0035): Recommended Default Value Sequence
RecommendedDisplayCIELabValue | (0062,000D): Recommended Display CIELab Value
RecommendedDisplayCIELabValueList | (0066,0103): Recommended Display CIELab Value List
RecommendedDisplayFrameRate | (0008,2144): Recommended Display Frame Rate
RecommendedDisplayFrameRateInFloat | (0008,9459): Recommended Display Frame Rate in Float
RecommendedDisplayGrayscaleValue | (0062,000C): Recommended Display Grayscale Value
RecommendedExposureIndex | (0016,001C): Recommended Exposure Index
RecommendedLineThickness | (0066,0038): Recommended Line Thickness
RecommendedPointRadius | (0066,0037): Recommended Point Radius
RecommendedPresentationOpacity | (0066,000C): Recommended Presentation Opacity
RecommendedPresentationType | (0066,000D): Recommended Presentation Type
RecommendedRotationPoint | (0068,6346): Recommended Rotation Point
RecommendedViewingMode | (0028,1090): Recommended Viewing Mode
ReconstructionAlgorithm | (0018,9315): Reconstruction Algorithm
ReconstructionAlgorithmSequence | (0018,993D): Reconstruction Algorithm Sequence
ReconstructionAngle | (0018,9319): Reconstruction Angle
ReconstructionDescription | (0018,9531): Reconstruction Description
ReconstructionDiameter | (0018,1100): Reconstruction Diameter
ReconstructionEndLocationSequence | (0018,993C): Reconstruction End Location Sequence
ReconstructionFieldOfView | (0018,9317): Reconstruction Field of View
ReconstructionIndex | (0020,9536): Reconstruction Index
ReconstructionMethod | (0054,1103): Reconstruction Method
ReconstructionPipelineType | (0018,11BE): Reconstruction Pipeline Type
ReconstructionPixelSpacing | (0018,9322): Reconstruction Pixel Spacing
ReconstructionProtocolElementSequence | (0018,9934): Reconstruction Protocol Element Sequence
ReconstructionProtocolElementSpecificationSequence | (0018,9933): Reconstruction Protocol Element Specification Sequence
ReconstructionStartLocationSequence | (0018,993B): Reconstruction Start Location Sequence
ReconstructionTargetCenterLocationSequence | (0018,993E): Reconstruction Target Center Location Sequence
ReconstructionTargetCenterPatient | (0018,9318): Reconstruction Target Center (Patient)
ReconstructionType | (0018,9756): Reconstruction Type
RecordedBlockSequence | (3008,00D0): Recorded Block Sequence
RecordedBlockSlabSequence | (3008,00D1): Recorded Block Slab Sequence
RecordedBrachyAccessoryDeviceSequence | (3008,0120): Recorded Brachy Accessory Device Sequence
RecordedChannelSequence | (3008,0130): Recorded Channel Sequence
RecordedChannelShieldSequence | (3008,0150): Recorded Channel Shield Sequence
RecordedCompensatorSequence | (3008,00C0): Recorded Compensator Sequence
RecordedLateralSpreadingDeviceSequence | (3008,00F4): Recorded Lateral Spreading Device Sequence
RecordedRangeModulatorSequence | (3008,00F6): Recorded Range Modulator Sequence
RecordedRangeShifterSequence | (3008,00F2): Recorded Range Shifter Sequence
RecordedRTControlPointDateTime | (300A,073A): Recorded RT Control Point DateTime
RecordedSnoutSequence | (3008,00F0): Recorded Snout Sequence
RecordedSourceApplicatorSequence | (3008,0140): Recorded Source Applicator Sequence
RecordedSourceSequence | (3008,0100): Recorded Source Sequence
RecordedWedgeSequence | (3008,00B0): Recorded Wedge Sequence
RecordInUseFlag | (0004,1410): Record In-use Flag
RecordKey | (0008,041B): Record Key
RectificationType | (0018,1156): Rectification Type
RectifierSmoothing | (0014,4034): Rectifier Smoothing
RectilinearPhaseEncodeReordering | (0018,9034): Rectilinear Phase Encode Reordering
RedPaletteColorLookupTableData | (0028,1201): Red Palette Color Lookup Table Data
RedPaletteColorLookupTableDescriptor | (0028,1101): Red Palette Color Lookup Table Descriptor
Reference | (0020,1020): Reference(Retired)
ReferenceAirKermaRate | (300A,022A): Reference Air Kerma Rate
ReferenceBasisCodeSequence | (0018,9902): Reference Basis Code Sequence
ReferenceCoordinates | (0022,0032): Reference Coordinates
ReferencedAccessionSequenceTrial | (0040,A313): Referenced Accession Sequence (Trial)
ReferencedAssertionUID | (0044,0108): Referenced Assertion UID
ReferencedBaselineParametersRTRadiationInstanceSequence | (3002,011E): Referenced Baseline Parameters RT Radiation Instance Sequence
ReferencedBasicAnnotationBoxSequence | (2010,0520): Referenced Basic Annotation Box Sequence
ReferencedBeamNumber | (300C,0006): Referenced Beam Number
ReferencedBeamSequence | (300C,0004): Referenced Beam Sequence
ReferencedBlockNumber | (300C,00E0): Referenced Block Number
ReferencedBolusSequence | (300C,00B0): Referenced Bolus Sequence
ReferencedBrachyAccessoryDeviceNumber | (3008,0122): Referenced Brachy Accessory Device Number
ReferencedBrachyApplicationSetupNumber | (300C,000C): Referenced Brachy Application Setup Number
ReferencedBrachyApplicationSetupSequence | (300C,000A): Referenced Brachy Application Setup Sequence
ReferencedCalculatedDoseReferenceNumber | (3008,0092): Referenced Calculated Dose Reference Number
ReferencedCalculatedDoseReferenceSequence | (3008,0090): Referenced Calculated Dose Reference Sequence
ReferencedChannelNumber | (0074,1406): Referenced Channel Number
ReferencedChannelShieldNumber | (3008,0152): Referenced Channel Shield Number
ReferencedColorPaletteInstanceUID | (0028,0304): Referenced Color Palette Instance UID
ReferencedComparisonSOPInstanceSequence | (0082,0005): Referenced Comparison SOP Instance Sequence
ReferencedCompensatorNumber | (300C,00D0): Referenced Compensator Number
ReferencedConceptualVolumeUID | (3010,000B): Referenced Conceptual Volume UID
ReferencedContentItem | (0070,1904): Referenced Content Item
ReferencedContentItemIdentifier | (0040,DB73): Referenced Content Item Identifier
ReferencedControlPointIndex | (300C,00F0): Referenced Control Point Index
ReferencedControlPointSequence | (300C,00F2): Referenced Control Point Sequence
ReferencedCurveSequence | (0008,1145): Referenced Curve Sequence
ReferencedDateTime | (0040,A13A): Referenced DateTime
ReferencedDefinedDeviceIndex | (300A,0602): Referenced Defined Device Index
ReferencedDefinedProtocolSequence | (0018,990C): Referenced Defined Protocol Sequence
ReferencedDeviceIndex | (300A,0607): Referenced Device Index
ReferencedDigitalSignatureSequence | (0400,0402): Referenced Digital Signature Sequence
ReferencedDirectSegmentInstanceSequence | (3010,004A): Referenced Direct Segment Instance Sequence
ReferencedDoseReferenceNumber | (300C,0051): Referenced Dose Reference Number
ReferencedDoseReferenceSequence | (300C,0050): Referenced Dose Reference Sequence
ReferencedDoseReferenceUID | (300A,0083): Referenced Dose Reference UID
ReferencedDoseSequence | (300C,0080): Referenced Dose Sequence
ReferencedDosimetricObjectivesSequence | (3010,0071): Referenced Dosimetric Objectives Sequence
ReferencedDosimetricObjectiveUID | (3010,006F): Referenced Dosimetric Objective UID
ReferencedExpectedInVivoMeasurementValueIndex | (300A,0773): Referenced Expected In-Vivo Measurement Value Index
ReferencedFiducialsUID | (3010,0031): Referenced Fiducials UID
ReferencedFiducialUID | (0070,031B): Referenced Fiducial UID
ReferencedFileID | (0004,1500): Referenced File ID
ReferencedFilmBoxSequence | (2000,0500): Referenced Film Box Sequence
ReferencedFilmSessionSequence | (2010,0500): Referenced Film Session Sequence
ReferencedFindingsGroupUIDTrial | (0040,A022): Referenced Findings Group UID (Trial)
ReferencedFirstFrameSequence | (0072,0427): Referenced First Frame Sequence
ReferencedFractionGroupNumber | (300C,0022): Referenced Fraction Group Number
ReferencedFractionGroupSequence | (300C,0020): Referenced Fraction Group Sequence
ReferencedFractionNumber | (3008,0223): Referenced Fraction Number
ReferencedFrameNumber | (0008,1160): Referenced Frame Number
ReferencedFrameNumbers | (0040,A136): Referenced Frame Numbers
ReferencedFrameOfReferenceSequence | (3006,0010): Referenced Frame of Reference Sequence
ReferencedFrameOfReferenceUID | (3006,0024): Referenced Frame of Reference UID
ReferencedGeneralPurposeScheduledProcedureStepSequence | (0040,4016): Referenced General Purpose Scheduled Procedure Step Sequence
ReferencedGeneralPurposeScheduledProcedureStepTransactionUID | (0040,4023): Referenced General Purpose Scheduled Procedure Step Transaction UID
ReferencedHPGLDocumentID | (0068,6440): Referenced HPGL Document ID
ReferencedImageBoxSequence | (2010,0510): Referenced Image Box Sequence
ReferencedImageBoxSequenceRetired | (2040,0500): Referenced Image Box Sequence (Retired)
ReferencedImageEvidenceSequence | (0008,9092): Referenced Image Evidence Sequence
ReferencedImageNavigationSequence | (0048,0200): Referenced Image Navigation Sequence
ReferencedImageOverlayBoxSequence | (2020,0130): Referenced Image Overlay Box Sequence
ReferencedImageRealWorldValueMappingSequence | (0040,9094): Referenced Image Real World Value Mapping Sequence
ReferencedImageSequence | (0008,1140): Referenced Image Sequence
ReferencedImplantTemplateGroupMemberID | (0078,00B6): Referenced Implant Template Group Member ID
ReferencedInstancesBySOPClassSequence | (0008,1112): Referenced Instances by SOP Class Sequence
ReferencedInstanceSequence | (0008,114A): Referenced Instance Sequence
ReferencedInterpretationSequence | (4008,0050): Referenced Interpretation Sequence
ReferenceDisplaySets | (0072,0218): Reference Display Sets
ReferencedLateralSpreadingDeviceNumber | (300C,0102): Referenced Lateral Spreading Device Number
ReferencedMeasuredDoseReferenceNumber | (3008,0082): Referenced Measured Dose Reference Number
ReferencedMeasuredDoseReferenceSequence | (3008,0080): Referenced Measured Dose Reference Sequence
ReferencedNonImageCompositeSOPInstanceSequence | (0040,0220): Referenced Non-Image Composite SOP Instance Sequence
ReferencedObjectObservationClassTrial | (0040,A174): Referenced Object Observation Class (Trial)
ReferencedObservationClassTrial | (0040,A173): Referenced Observation Class (Trial)
ReferencedObservationUIDTrial | (0040,A172): Referenced Observation UID (Trial)
ReferencedOphthalmicAxialLengthMeasurementQCImageSequence | (0022,1330): Referenced Ophthalmic Axial Length Measurement QC Image Sequence
ReferencedOphthalmicAxialMeasurementsSequence | (0022,1100): Referenced Ophthalmic Axial Measurements Sequence
ReferencedOpticalPathIdentifier | (006A,000E): Referenced Optical Path Identifier
ReferenceDoseDefinition | (300A,0512): Reference Dose Definition
ReferenceDosePointCoordinates | (300A,061E): Reference Dose Point Coordinates
ReferenceDoseType | (300A,061A): Reference Dose Type
ReferencedOtherPlaneSequence | (0008,9410): Referenced Other Plane Sequence
ReferencedOverlayPlaneGroups | (2040,0011): Referenced Overlay Plane Groups
ReferencedOverlayPlaneSequence | (2040,0010): Referenced Overlay Plane Sequence
ReferencedOverlaySequence | (0008,1130): Referenced Overlay Sequence
ReferencedParentRTPrescriptionIndex | (3010,0042): Referenced Parent RT Prescription Index
ReferencedPathIndex | (0018,9378): Referenced Path Index
ReferencedPatientAliasSequence | (0038,0004): Referenced Patient Alias Sequence
ReferencedPatientPhotoSequence | (0010,1100): Referenced Patient Photo Sequence
ReferencedPatientSequence | (0008,1120): Referenced Patient Sequence
ReferencedPatientSetupNumber | (300C,006A): Referenced Patient Setup Number
ReferencedPatientSetupPhotoSequence | (300A,078C): Referenced Patient Setup Photo Sequence
ReferencedPatientSetupProcedureIndex | (300A,0796): Referenced Patient Setup Procedure Index
ReferencedPerformedProcedureStepSequence | (0008,1111): Referenced Performed Procedure Step Sequence
ReferencedPerformedProtocolSequence | (0018,990D): Referenced Performed Protocol Sequence
ReferencedPlanOverviewIndex | (300C,0118): Referenced Plan Overview Index
ReferencedPositionReferenceInstanceSequence | (3002,0132): Referenced Position Reference Instance Sequence
ReferencedPresentationLUTSequence | (2050,0500): Referenced Presentation LUT Sequence
ReferencedPresentationStateSequence | (0008,9237): Referenced Presentation State Sequence
ReferencedPrintJobSequence | (2120,0070): Referenced Print Job Sequence
ReferencedPrintJobSequencePullStoredPrint | (2100,0500): Referenced Print Job Sequence (Pull Stored Print)
ReferencedProcedureStepSequence | (0040,0330): Referenced Procedure Step Sequence
ReferencedPTOSequence | (4010,1076): Referenced PTO Sequence
ReferencedRadiationDoseIdentificationIndex | (300A,060C): Referenced Radiation Dose Identification Index
ReferencedRadiationGenerationModeIndex | (300A,0605): Referenced Radiation Generation Mode Index
ReferencedRadiationRTControlPointIndex | (300A,073B): Referenced Radiation RT Control Point Index
ReferencedRangeModulatorNumber | (300C,0104): Referenced Range Modulator Number
ReferencedRangeShifterNumber | (300C,0100): Referenced Range Shifter Number
ReferencedRawDataSequence | (0008,9121): Referenced Raw Data Sequence
ReferencedRealWorldValueMappingInstanceSequence | (0008,114B): Referenced Real World Value Mapping Instance Sequence
ReferencedReferenceImageNumber | (300C,0007): Referenced Reference Image Number
ReferencedReferenceImageSequence | (300C,0042): Referenced Reference Image Sequence
ReferencedRefractiveMeasurementsSequence | (0046,0145): Referenced Refractive Measurements Sequence
ReferencedRelatedGeneralSOPClassUIDInFile | (0004,151A): Referenced Related General SOP Class UID in File
ReferencedRequestSequence | (0040,A370): Referenced Request Sequence
ReferencedResultsSequence | (0008,1100): Referenced Results Sequence
ReferencedROINumber | (3006,0084): Referenced ROI Number
ReferencedRTAccessoryHolderDeviceIndex | (300A,060E): Referenced RT Accessory Holder Device Index
ReferencedRTInstanceSequence | (300A,0631): Referenced RT Instance Sequence
ReferencedRTPatientSetupSequence | (300A,0632): Referenced RT Patient Setup Sequence
ReferencedRTPhysicianIntentIndex | (3010,005E): Referenced RT Physician Intent Index
ReferencedRTPhysicianIntentSequence | (300A,063B): Referenced RT Physician Intent Sequence
ReferencedRTPlanSequence | (300C,0002): Referenced RT Plan Sequence
ReferencedRTPrescriptionIndex | (3010,0041): Referenced RT Prescription Index
ReferencedRTPrescriptionSequence | (300A,068A): Referenced RT Prescription Sequence
ReferencedRTRadiationRecordSequence | (300A,0703): Referenced RT Radiation Record Sequence
ReferencedRTRadiationSequence | (300A,0630): Referenced RT Radiation Sequence
ReferencedRTRadiationSetSequence | (300A,0702): Referenced RT Radiation Set Sequence
ReferencedRTTreatmentPhaseIndex | (3010,0040): Referenced RT Treatment Phase Index
ReferencedRTTreatmentPhaseSequence | (3010,0049): Referenced RT Treatment Phase Sequence
ReferencedRTTreatmentPreparationSequence | (300A,078B): Referenced RT Treatment Preparation Sequence
ReferencedSamplePositions | (0040,A132): Referenced Sample Positions
ReferencedSegmentNumber | (0062,000B): Referenced Segment Number
ReferencedSegmentReferenceIndex | (3010,0020): Referenced Segment Reference Index
ReferencedSeriesSequence | (0008,1115): Referenced Series Sequence
ReferencedSetupImageSequence | (300A,0401): Referenced Setup Image Sequence
ReferencedSOPClassUID | (0008,1150): Referenced SOP Class UID
ReferencedSOPClassUIDInFile | (0004,1510): Referenced SOP Class UID in File
ReferencedSOPInstanceMACSequence | (0400,0403): Referenced SOP Instance MAC Sequence
ReferencedSOPInstanceUID | (0008,1155): Referenced SOP Instance UID
ReferencedSOPInstanceUIDInFile | (0004,1511): Referenced SOP Instance UID in File
ReferencedSOPSequence | (0008,1199): Referenced SOP Sequence
ReferencedSourceApplicatorNumber | (3008,0142): Referenced Source Applicator Number
ReferencedSourceNumber | (300C,000E): Referenced Source Number
ReferencedSpatialRegistrationSequence | (0070,0404): Referenced Spatial Registration Sequence
ReferencedStartControlPointIndex | (300C,00F4): Referenced Start Control Point Index
ReferencedStereometricInstanceSequence | (0008,1134): Referenced Stereometric Instance Sequence
ReferencedStopControlPointIndex | (300C,00F6): Referenced Stop Control Point Index
ReferencedStorageMediaSequence | (2200,000D): Referenced Storage Media Sequence
ReferencedStoredPrintSequence | (2000,0510): Referenced Stored Print Sequence
ReferencedStructuredContextSequence | (0070,1903): Referenced Structured Context Sequence
ReferencedStructureSetSequence | (300C,0060): Referenced Structure Set Sequence
ReferencedStudySequence | (0008,1110): Referenced Study Sequence
ReferencedSurfaceDataSequence | (0080,0013): Referenced Surface Data Sequence
ReferencedSurfaceMeshIdentificationSequence | (0022,1620): Referenced Surface Mesh Identification Sequence
ReferencedSurfaceNumber | (0066,002C): Referenced Surface Number
ReferencedSurfaceSequence | (0066,002B): Referenced Surface Sequence
ReferencedTargetLuminanceCharacteristicsID | (0028,700E): Referenced Target Luminance Characteristics ID
ReferencedTDRInstanceSequence | (4010,1077): Referenced TDR Instance Sequence
ReferencedTextureSequence | (0080,0012): Referenced Texture Sequence
ReferencedTimeOffsets | (0040,A138): Referenced Time Offsets
ReferencedToleranceTableNumber | (300C,00A0): Referenced Tolerance Table Number
ReferencedTransferSyntaxUIDInFile | (0004,1512): Referenced Transfer Syntax UID in File
ReferencedTreatmentPositionGroupUID | (300A,0785): Referenced Treatment Position Group UID
ReferencedTreatmentPositionIndex | (300A,060B): Referenced Treatment Position Index
ReferencedTreatmentRecordSequence | (3008,0030): Referenced Treatment Record Sequence
ReferencedVerificationImageSequence | (300C,0040): Referenced Verification Image Sequence
ReferencedVisitSequence | (0008,1125): Referenced Visit Sequence
ReferencedVOILUTBoxSequence | (2020,0140): Referenced VOI LUT Box Sequence
ReferencedWaveformChannels | (0040,A0B0): Referenced Waveform Channels
ReferencedWaveformSequence | (0008,113A): Referenced Waveform Sequence
ReferencedWedgeNumber | (300C,00C0): Referenced Wedge Number
ReferencedXRayDetectorIndex | (0018,9376): Referenced X-Ray Detector Index
ReferencedXRaySourceIndex | (0018,9377): Referenced X-Ray Source Index
ReferenceGeometryCodeSequence | (0018,9903): Reference Geometry Code Sequence
ReferenceImageNumber | (300A,00C8): Reference Image Number
ReferenceLocationDescription | (0018,9901): Reference Location Description
ReferenceLocationLabel | (0018,9900): Reference Location Label
ReferencePixelPhysicalValueX | (0018,6028): Reference Pixel Physical Value X
ReferencePixelPhysicalValueY | (0018,602A): Reference Pixel Physical Value Y
ReferencePixelX0 | (0018,6020): Reference Pixel X0
ReferencePixelY0 | (0018,6022): Reference Pixel Y0
ReferenceToRecordedSound | (4008,0103): Reference to Recorded Sound
ReferringPhysicianAddress | (0008,0092): Referring Physician's Address
ReferringPhysicianIdentificationSequence | (0008,0096): Referring Physician Identification Sequence
ReferringPhysicianName | (0008,0090): Referring Physician's Name
ReferringPhysicianTelephoneNumbers | (0008,0094): Referring Physician's Telephone Numbers
ReflectedAmbientLight | (2010,0160): Reflected Ambient Light
ReformattingInterval | (0072,0514): Reformatting Interval
ReformattingOperationInitialViewDirection | (0072,0516): Reformatting Operation Initial View Direction
ReformattingOperationType | (0072,0510): Reformatting Operation Type
ReformattingThickness | (0072,0512): Reformatting Thickness
RefractiveErrorBeforeRefractiveSurgeryCodeSequence | (0022,1103): Refractive Error Before Refractive Surgery Code Sequence
RefractiveIndexApplied | (0052,003A): Refractive Index Applied
RefractiveIndexOfAqueousHumor | (0046,0118): Refractive Index of Aqueous Humor
RefractiveIndexOfCornea | (0046,0117): Refractive Index of Cornea
RefractiveParametersUsedOnPatientSequence | (0024,0112): Refractive Parameters Used on Patient Sequence
RefractivePower | (0046,0251): Refractive Power
RefractiveProcedureOccurred | (0022,1039): Refractive Procedure Occurred
RefractiveStateSequence | (0022,001B): Refractive State Sequence
RefractiveSurgeryTypeCodeSequence | (0022,1040): Refractive Surgery Type Code Sequence
RegionDataType | (0018,6014): Region Data Type
RegionFlags | (0018,6016): Region Flags
RegionLocationMaxX1 | (0018,601C): Region Location Max X1
RegionLocationMaxY1 | (0018,601E): Region Location Max Y1
RegionLocationMinX0 | (0018,6018): Region Location Min X0
RegionLocationMinY0 | (0018,601A): Region Location Min Y0
RegionOfResidence | (0010,2152): Region of Residence
RegionPixelShiftSequence | (0028,9502): Region Pixel Shift Sequence
RegionSpatialFormat | (0018,6012): Region Spatial Format
RegisteredLocalizerBottomRightHandCorner | (0022,1468): Registered Localizer Bottom Right Hand Corner
RegisteredLocalizerTopLeftHandCorner | (0022,1467): Registered Localizer Top Left Hand Corner
RegisteredLocalizerUnits | (0022,1466): Registered Localizer Units
RegistrationMethodCodeSequence | (0080,0003): Registration Method Code Sequence
RegistrationSequence | (0070,0308): Registration Sequence
RegistrationToLocalizerSequence | (0022,1465): Registration to Localizer Sequence
RegistrationTypeCodeSequence | (0070,030D): Registration Type Code Sequence
RelatedAssertionSequence | (0044,0107): Related Assertion Sequence
RelatedFrameOfReferenceUID | (3006,00C2): Related Frame of Reference UID
RelatedGeneralSOPClassUID | (0008,001A): Related General SOP Class UID
RelatedProcedureStepSequence | (0074,1220): Related Procedure Step Sequence
RelatedReferenceRTImageSequence | (0074,1040): Related Reference RT Image Sequence
RelatedRTROIObservationsSequence | (3006,00A0): Related RT ROI Observations Sequence
RelatedRTTreatmentPhaseIndex | (3010,003F): Related RT Treatment Phase Index
RelatedSegmentCharacteristicsSequence | (3010,0028): Related Segment Characteristics Sequence
RelatedSeriesSequence | (0008,1250): Related Series Sequence
RelationshipSequenceTrial | (0040,A731): Relationship Sequence (Trial)
RelationshipType | (0040,A010): Relationship Type
RelationshipTypeCodeSequenceTrial | (0040,A732): Relationship Type Code Sequence (Trial)
RelativeElevation | (0046,0252): Relative Elevation
RelativeImagePositionCodeSequence | (0022,001D): Relative Image Position Code Sequence
RelativeOpacity | (0070,0403): Relative Opacity
RelativeTime | (0072,0038): Relative Time
RelativeTimeUnits | (0072,003A): Relative Time Units
RelativeURIReferenceWithinEncapsulatedDocument | (0068,7005): Relative URI Reference Within Encapsulated Document
RelativeXRayExposure | (0018,1405): Relative X-Ray Exposure
RelevantInformationSequence | (0040,4022): Relevant Information Sequence
RelevantOPTAttributesSequence | (0022,1472): Relevant OPT Attributes Sequence
RemovedFromOperationalUse | (0008,0405): Removed from Operational Use
RenderedImageReferenceSequence | (0070,1104): Rendered Image Reference Sequence
RenderFieldOfView | (0070,1606): Render Field of View
RenderingMethod | (0070,120D): Rendering Method
RenderProjection | (0070,1602): Render Projection
RepairID | (0014,0105): Repair ID
RepeatFractionCycleLength | (300A,007A): Repeat Fraction Cycle Length
RepeatInterval | (0028,0068): Repeat Interval
RepetitionTime | (0018,0080): Repetition Time
ReplacedImplantAssemblyTemplateSequence | (0076,0008): Replaced Implant Assembly Template Sequence
ReplacedImplantTemplateGroupSequence | (0078,0026): Replaced Implant Template Group Sequence
ReplacedImplantTemplateSequence | (0068,6222): Replaced Implant Template Sequence
ReplacedProcedureStepSequence | (0074,1224): Replaced Procedure Step Sequence
ReportDetailSequenceTrial | (0040,A380): Report Detail Sequence (Trial)
ReportedValuesOrigin | (3002,000A): Reported Values Origin
ReportingPriority | (0040,1009): Reporting Priority
ReportNumber | (0020,00AA): Report Number
ReportProductionStatusTrial | (4008,00FF): Report Production Status (Trial)
ReportStatusCommentTrial | (0040,A33A): Report Status Comment (Trial)
ReportStatusIDTrial | (0040,A125): Report Status ID (Trial)
RepositoryUniqueID | (0040,E030): Repository Unique ID
RepresentativeFrameNumber | (0028,6010): Representative Frame Number
ReprojectionMethod | (0054,1004): Reprojection Method
RequestAttributesSequence | (0040,0275): Request Attributes Sequence
RequestedContrastAgent | (0032,1070): Requested Contrast Agent
RequestedDecimateCropBehavior | (2020,0040): Requested Decimate/Crop Behavior
RequestedImageSize | (2020,0030): Requested Image Size
RequestedImageSizeFlag | (2020,00A0): Requested Image Size Flag
RequestedLateralityCodeSequence | (0032,1065): Requested Laterality Code Sequence
RequestedMediaApplicationProfile | (2200,000C): Requested Media Application Profile
RequestedProcedureCodeSequence | (0032,1064): Requested Procedure Code Sequence
RequestedProcedureComments | (0040,1400): Requested Procedure Comments
RequestedProcedureDescription | (0032,1060): Requested Procedure Description
RequestedProcedureDescriptionTrial | (0040,1060): Requested Procedure Description (Trial)
RequestedProcedureID | (0040,1001): Requested Procedure ID
RequestedProcedureLocation | (0040,1005): Requested Procedure Location
RequestedProcedurePriority | (0040,1003): Requested Procedure Priority
RequestedResolutionID | (2020,0050): Requested Resolution ID
RequestedSeriesDescription | (0018,9937): Requested Series Description
RequestedSeriesDescriptionCodeSequence | (0018,11C1): Requested Series Description Code Sequence
RequestedSOPClassUID | (0000,0003): Requested SOP Class UID
RequestedSOPInstanceUID | (0000,1001): Requested SOP Instance UID
RequestedStatusInterval | (0008,0414): Requested Status Interval
RequestedSubsequentWorkitemCodeSequence | (0040,4031): Requested Subsequent Workitem Code Sequence
RequestingAE | (0074,1236): Requesting AE
RequestingPhysician | (0032,1032): Requesting Physician
RequestingPhysicianIdentificationSequence | (0032,1031): Requesting Physician Identification Sequence
RequestingService | (0032,1033): Requesting Service
RequestingServiceCodeSequence | (0032,1034): Requesting Service Code Sequence
RequestPriority | (2200,0020): Request Priority
RescaleIntercept | (0028,1052): Rescale Intercept
RescaleSlope | (0028,1053): Rescale Slope
RescaleType | (0028,1054): Rescale Type
ResidualSyringeCounts | (0054,0017): Residual Syringe Counts
ResonantNucleus | (0018,9100): Resonant Nucleus
ResourceDescription | (0038,0102): Resource Description
RespiratoryCyclePosition | (0018,9214): Respiratory Cycle Position
RespiratoryIntervalTime | (0020,9254): Respiratory Interval Time
RespiratoryMotionCompensationTechnique | (0018,9170): Respiratory Motion Compensation Technique
RespiratoryMotionCompensationTechniqueDescription | (0018,9185): Respiratory Motion Compensation Technique Description
RespiratorySignalSource | (0018,9171): Respiratory Signal Source
RespiratorySignalSourceID | (0018,9186): Respiratory Signal Source ID
RespiratorySynchronizationSequence | (0020,9253): Respiratory Synchronization Sequence
RespiratoryTriggerDelayThreshold | (0020,9256): Respiratory Trigger Delay Threshold
RespiratoryTriggerType | (0020,9250): Respiratory Trigger Type
ResponseSequenceNumber | (0000,0860): Response Sequence Number(Retired)
ResponsibleGroupCodeSequence | (0008,0220): Responsible Group Code Sequence
ResponsibleOrganization | (0010,2299): Responsible Organization
ResponsiblePerson | (0010,2297): Responsible Person
ResponsiblePersonRole | (0010,2298): Responsible Person Role
ResultingGeneralPurposePerformedProcedureStepsSequence | (0040,4015): Resulting General Purpose Performed Procedure Steps Sequence
ResultsComments | (4008,4000): Results Comments
ResultsDistributionListSequence | (4008,0118): Results Distribution List Sequence
ResultsID | (4008,0040): Results ID
ResultsIDIssuer | (4008,0042): Results ID Issuer
ResultsNormalsSequence | (0024,0064): Results Normals Sequence
RetainInstances | (0008,0415): Retain Instances
RetestSensitivityValue | (0024,0096): Retest Sensitivity Value
RetestStimulusSeen | (0024,0095): Retest Stimulus Seen
RetinalThicknessDefinitionCodeSequence | (0022,1445): Retinal Thickness Definition Code Sequence
RetrieveAETitle | (0008,0054): Retrieve AE Title
RetrieveLocationUID | (0040,E011): Retrieve Location UID
RetrieveURI | (0040,E010): Retrieve URI
RetrieveURL | (0008,1190): Retrieve URL
ReviewDate | (300E,0004): Review Date
ReviewerName | (300E,0008): Reviewer Name
ReviewTime | (300E,0005): Review Time
RevolutionTime | (0018,9305): Revolution Time
RFEchoTrainLength | (0018,9240): RF Echo Train Length
RGBATransferFunctionDescription | (0070,1A09): RGBA Transfer Function Description
RGBLUTTransferFunction | (0028,140F): RGB LUT Transfer Function
RightImageSequence | (0022,0022): Right Image Sequence
RightLensSequence | (0046,0014): Right Lens Sequence
RoboticBaseLocationIndicator | (3010,0090): Robotic Base Location Indicator
RoboticNodeIdentifier | (3010,0092): Robotic Node Identifier
RoboticPathControlPointSequence | (3010,0097): Robotic Path Control Point Sequence
RoboticPathNodeSetCodeSequence | (3010,0091): Robotic Path Node Set Code Sequence
ROIArea | (60xx,1301): ROI Area
ROIContourSequence | (3006,0039): ROI Contour Sequence
ROICreatorSequence | (3006,004D): ROI Creator Sequence
ROIDateTime | (3006,002D): ROI DateTime
ROIDerivationAlgorithmIdentificationSequence | (3006,0037): ROI Derivation Algorithm Identification Sequence
ROIDescription | (3006,0028): ROI Description
ROIDisplayColor | (3006,002A): ROI Display Color
ROIElementalCompositionAtomicMassFraction | (3006,00B8): ROI Elemental Composition Atomic Mass Fraction
ROIElementalCompositionAtomicNumber | (3006,00B7): ROI Elemental Composition Atomic Number
ROIElementalCompositionSequence | (3006,00B6): ROI Elemental Composition Sequence
ROIGenerationAlgorithm | (3006,0036): ROI Generation Algorithm
ROIGenerationDescription | (3006,0038): ROI Generation Description
ROIInterpreter | (3006,00A6): ROI Interpreter
ROIInterpreterSequence | (3006,004E): ROI Interpreter Sequence
ROIMean | (60xx,1302): ROI Mean
ROIName | (3006,0026): ROI Name
ROINumber | (3006,0022): ROI Number
ROIObservationContextCodeSequence | (3006,004F): ROI Observation Context Code Sequence
ROIObservationDateTime | (3006,002E): ROI Observation DateTime
ROIObservationDescription | (3006,0088): ROI Observation Description
ROIObservationLabel | (3006,0085): ROI Observation Label
ROIPhysicalPropertiesSequence | (3006,00B0): ROI Physical Properties Sequence
ROIPhysicalProperty | (3006,00B2): ROI Physical Property
ROIPhysicalPropertyValue | (3006,00B4): ROI Physical Property Value
ROIStandardDeviation | (60xx,1303): ROI Standard Deviation
ROIVolume | (3006,002C): ROI Volume
RotationAngle | (0070,0230): Rotation Angle
RotationDirection | (0018,1140): Rotation Direction
RotationInformationSequence | (0054,0052): Rotation Information Sequence
RotationOffset | (0018,1146): Rotation Offset
RotationOfScannedFilm | (0018,2030): Rotation of Scanned Film
RotationPoint | (0070,0273): Rotation Point
RotationVector | (0054,0050): Rotation Vector
RouteID | (4010,1054): Route ID
RouteIDAssigningAuthority | (4010,1055): Route ID Assigning Authority
RouteOfAdmissions | (0038,0016): Route of Admissions
RouteSegmentEndLocationID | (4010,101F): Route Segment End Location ID
RouteSegmentEndTime | (4010,1026): Route Segment End Time
RouteSegmentID | (4010,1007): Route Segment ID
RouteSegmentLocationIDType | (4010,1020): Route Segment Location ID Type
RouteSegmentSequence | (4010,100A): Route Segment Sequence
RouteSegmentStartLocationID | (4010,101E): Route Segment Start Location ID
RouteSegmentStartTime | (4010,1025): Route Segment Start Time
RowOverlap | (0028,0093): Row Overlap
RowPositionInTotalImagePixelMatrix | (0048,021F): Row Position In Total Image Pixel Matrix
Rows | (0028,0010): Rows
RRIntervalTimeNominal | (0020,9251): R-R Interval Time Nominal
RRIntervalVector | (0054,0060): R-R Interval Vector
RTAccessoryDeviceSlotID | (300A,0615): RT Accessory Device Slot ID
RTAccessoryHolderDefinitionSequence | (300A,0614): RT Accessory Holder Definition Sequence
RTAccessoryHolderSlotDistance | (300A,0612): RT Accessory Holder Slot Distance
RTAccessoryHolderSlotExistenceFlag | (300A,060F): RT Accessory Holder Slot Existence Flag
RTAccessoryHolderSlotID | (300A,0611): RT Accessory Holder Slot ID
RTAccessoryHolderSlotSequence | (300A,0610): RT Accessory Holder Slot Sequence
RTAccessoryHolderWaterEquivalentThickness | (300A,060D): RT Accessory Holder Water-Equivalent Thickness
RTAccessorySlotDistance | (300A,0613): RT Accessory Slot Distance
RTAcquisitionPatientPositionSequence | (3002,0108): RT Acquisition Patient Position Sequence
RTAnatomicPrescriptionSequence | (3010,0060): RT Anatomic Prescription Sequence
RTBeamDelimiterGeometrySequence | (300A,064C): RT Beam Delimiter Geometry Sequence
RTBeamLimitingDeviceAngle | (300A,0679): RT Beam Limiting Device Angle
RTBeamLimitingDeviceDefinitionSequence | (300A,064D): RT Beam Limiting Device Definition Sequence
RTBeamLimitingDeviceDistalDistance | (300A,0643): RT Beam Limiting Device Distal Distance
RTBeamLimitingDeviceOffset | (300A,064B): RT Beam Limiting Device Offset
RTBeamLimitingDeviceOpeningSequence | (300A,0656): RT Beam Limiting Device Opening Sequence
RTBeamLimitingDeviceProximalDistance | (300A,0642): RT Beam Limiting Device Proximal Distance
RTBeamLimitingDeviceType | (300A,00B8): RT Beam Limiting Device Type
RTBeamModifierDefinitionDistance | (300A,0688): RT Beam Modifier Definition Distance
RTControlPointIndex | (300A,0600): RT Control Point Index
RTDeliveryStartPatientPositionSequence | (300A,0789): RT Delivery Start Patient Position Sequence
RTDeviceDistanceReferenceLocationCodeSequence | (300A,0659): RT Device Distance Reference Location Code Sequence
RTDiagnosisCodeSequence | (3010,005D): RT Diagnosis Code Sequence
RTDoseROISequence | (3004,0010): RT Dose ROI Sequence
RTImageDescription | (3002,0004): RT Image Description
RTImageFrameContextSequence | (3002,0103): RT Image Frame Context Sequence
RTImageFrameGeneralContentSequence | (3002,0102): RT Image Frame General Content Sequence
RTImageFrameImagingDevicePositionSequence | (3002,0109): RT Image Frame Imaging Device Position Sequence
RTImageFramekVRadiationAcquisitionSequence | (3002,010A): RT Image Frame kV Radiation Acquisition Sequence
RTImageFrameMVRadiationAcquisitionSequence | (3002,010B): RT Image Frame MV Radiation Acquisition Sequence
RTImageFrameRadiationAcquisitionSequence | (3002,010C): RT Image Frame Radiation Acquisition Sequence
RTImageLabel | (3002,0002): RT Image Label
RTImageName | (3002,0003): RT Image Name
RTImageOrientation | (3002,0010): RT Image Orientation
RTImagePlane | (3002,000C): RT Image Plane
RTImagePosition | (3002,0012): RT Image Position
RTImageScopeSequence | (3002,0104): RT Image Scope Sequence
RTImageSID | (3002,0026): RT Image SID
RTPatientPositionDisplacementSequence | (300A,0798): RT Patient Position Displacement Sequence
RTPatientPositionScopeSequence | (300A,0784): RT Patient Position Scope Sequence
RTPatientPositionSequence | (300A,0799): RT Patient Position Sequence
RTPhysicianIntentIndex | (3010,0058): RT Physician Intent Index
RTPhysicianIntentInputInstanceSequence | (3010,005F): RT Physician Intent Input Instance Sequence
RTPhysicianIntentNarrative | (3010,005A): RT Physician Intent Narrative
RTPhysicianIntentPredecessorSequence | (3010,0055): RT Physician Intent Predecessor Sequence
RTPhysicianIntentSequence | (3010,0057): RT Physician Intent Sequence
RTPlanDate | (300A,0006): RT Plan Date
RTPlanDescription | (300A,0004): RT Plan Description
RTPlanGeometry | (300A,000C): RT Plan Geometry
RTPlanLabel | (300A,0002): RT Plan Label
RTPlanName | (300A,0003): RT Plan Name
RTPlanRelationship | (300A,0055): RT Plan Relationship
RTPlanTime | (300A,0007): RT Plan Time
RTPrescriptionIndex | (3010,003C): RT Prescription Index
RTPrescriptionLabel | (3010,0054): RT Prescription Label
RTPrescriptionSequence | (3010,006B): RT Prescription Sequence
RTProtocolCodeSequence | (3010,005B): RT Protocol Code Sequence
RTRadiationPhysicalAndGeometricContentDetailFlag | (300A,0638): RT Radiation Physical and Geometric Content Detail Flag
RTRadiationSalvageRecordControlPointSequence | (300A,0722): RT Radiation Salvage Record Control Point Sequence
RTRadiationSequence | (300A,0616): RT Radiation Sequence
RTRadiationSetDeliveryNumber | (300A,0704): RT Radiation Set Delivery Number
RTRadiationSetDeliveryUsage | (300A,079E): RT Radiation Set Delivery Usage
RTRadiationSetIntent | (300A,0637): RT Radiation Set Intent
RTRadiationSetUsage | (300A,0707): RT Radiation Set Usage
RTRadiationTaskSequence | (300A,0797): RT Radiation Task Sequence
RTRadiationUsage | (300A,0701): RT Radiation Usage
RTRecordFlag | (300A,0639): RT Record Flag
RTReferencedSeriesSequence | (3006,0014): RT Referenced Series Sequence
RTReferencedStudySequence | (3006,0012): RT Referenced Study Sequence
RTRelatedROISequence | (3006,0030): RT Related ROI Sequence
RTROIIdentificationCodeSequence | (3006,0086): RT ROI Identification Code Sequence
RTROIInterpretedType | (3006,00A4): RT ROI Interpreted Type
RTROIObservationsSequence | (3006,0080): RT ROI Observations Sequence
RTROIRelationship | (3006,0033): RT ROI Relationship
RTSegmentAnnotationIndex | (3010,003D): RT Segment Annotation Index
RTSegmentAnnotationSequence | (3010,002A): RT Segment Annotation Sequence
RTToleranceSetLabel | (300A,062A): RT Tolerance Set Label
RTToleranceSetSequence | (300A,0629): RT Tolerance Set Sequence
RTTreatmentApproachLabel | (3010,0056): RT Treatment Approach Label
RTTreatmentFractionCompletionStatus | (300A,0706): RT Treatment Fraction Completion Status
RTTreatmentIntentType | (3010,0059): RT Treatment Intent Type
RTTreatmentPhaseIndex | (3010,003A): RT Treatment Phase Index
RTTreatmentPhaseIntentPresenceFlag | (3010,0045): RT Treatment Phase Intent Presence Flag
RTTreatmentPhaseIntervalSequence | (3010,004E): RT Treatment Phase Interval Sequence
RTTreatmentPhaseUID | (3010,003B): RT Treatment Phase UID
RTTreatmentPreparationPatientPositionSequence | (300A,078A): RT Treatment Preparation Patient Position Sequence
RTTreatmentSourceCoordinates | (3010,0093): RT Treatment Source Coordinates
RTTreatmentTechniqueCodeSequence | (3010,0080): RT Treatment Technique Code Sequence
RTTreatmentTerminationReasonCodeSequence | (300A,0715): RT Treatment Termination Reason Code Sequence
RTTreatmentTerminationStatus | (300A,0714): RT Treatment Termination Status
RTVCommunicationSOPClassUID | (0002,0032): RTV Communication SOP Class UID
RTVCommunicationSOPInstanceUID | (0002,0033): RTV Communication SOP Instance UID
RTVFlowActualFrameDuration | (0002,0038): RTV Flow Actual Frame Duration
RTVFlowIdentifier | (0002,0036): RTV Flow Identifier
RTVFlowRTPSamplingRate | (0002,0037): RTV Flow RTP Sampling Rate
RTVMetaInformationVersion | (0002,0031): RTV Meta Information Version
RTVSourceIdentifier | (0002,0035): RTV Source Identifier
RunLengthTriplet | (1000,xxx1): Run Length Triplet
RWavePointer | (0028,6040): R Wave Pointer
RWaveTimeVector | (0018,6060): R Wave Time Vector
SafePositionExitDate | (3008,0162): Safe Position Exit Date
SafePositionExitTime | (3008,0164): Safe Position Exit Time
SafePositionReturnDate | (3008,0166): Safe Position Return Date
SafePositionReturnTime | (3008,0168): Safe Position Return Time
SampleRate | (50xx,2008): Sample Rate
SamplesPerPixel | (0028,0002): Samples per Pixel
SamplesPerPixelUsed | (0028,0003): Samples per Pixel Used
SamplingFrequency | (003A,001A): Sampling Frequency
SamplingStepSize | (0070,1607): Sampling Step Size
SAR | (0018,1316): SAR
Saturation | (0016,0049): Saturation
SaturationRecovery | (0018,9024): Saturation Recovery
ScanArc | (0018,1143): Scan Arc
ScanArcType | (3002,012E): Scan Arc Type
ScanLength | (0018,1302): Scan Length
ScanMode | (300A,0308): Scan Mode
ScannerSettingsSequence | (0014,409A): Scanner Settings Sequence
ScanningSequence | (0018,0020): Scanning Sequence
ScanningSpotSize | (300A,0398): Scanning Spot Size
ScanOptions | (0018,0022): Scan Options
ScanPatternTypeCodeSequence | (0022,1618): Scan Pattern Type Code Sequence
ScanProcedure | (0014,409B): Scan Procedure
ScanProgressionDirection | (0054,0501): Scan Progression Direction
ScanSpotMetersetsDelivered | (3008,0047): Scan Spot Metersets Delivered
ScanSpotMetersetWeights | (300A,0396): Scan Spot Meterset Weights
ScanSpotPositionMap | (300A,0394): Scan Spot Position Map
ScanSpotPrescribedIndices | (300A,0391): Scan Spot Prescribed Indices
ScanSpotReordered | (300A,0393): Scan Spot Reordered
ScanSpotReorderingAllowed | (300A,0395): Scan Spot Reordering Allowed
ScanSpotSizesDelivered | (300A,0399): Scan Spot Sizes Delivered
ScanSpotTimeOffset | (300A,038F): Scan Spot Time Offset
ScanSpotTuneID | (300A,0390): Scan Spot Tune ID
ScanStartPositionSequence | (3002,012B): Scan Start Position Sequence
ScanStopPositionSequence | (3002,012C): Scan Stop Position Sequence
ScanType | (4010,1048): Scan Type
ScanVelocity | (0018,1300): Scan Velocity
ScatterCorrected | (0018,9760): Scatter Corrected
ScatterCorrectionMethod | (0054,1105): Scatter Correction Method
ScatterFractionFactor | (0054,1323): Scatter Fraction Factor
SceneCaptureType | (0016,0046): Scene Capture Type
SceneType | (0016,003B): Scene Type
ScheduledAdmissionDate | (0038,001A): Scheduled Admission Date
ScheduledAdmissionTime | (0038,001B): Scheduled Admission Time
ScheduledDischargeDate | (0038,001C): Scheduled Discharge Date
ScheduledDischargeTime | (0038,001D): Scheduled Discharge Time
ScheduledHumanPerformersSequence | (0040,4034): Scheduled Human Performers Sequence
ScheduledPatientInstitutionResidence | (0038,001E): Scheduled Patient Institution Residence
ScheduledPerformingPhysicianIdentificationSequence | (0040,000B): Scheduled Performing Physician Identification Sequence
ScheduledPerformingPhysicianName | (0040,0006): Scheduled Performing Physician's Name
ScheduledProcedureStepDescription | (0040,0007): Scheduled Procedure Step Description
ScheduledProcedureStepEndDate | (0040,0004): Scheduled Procedure Step End Date
ScheduledProcedureStepEndTime | (0040,0005): Scheduled Procedure Step End Time
ScheduledProcedureStepExpirationDateTime | (0040,4008): Scheduled Procedure Step Expiration DateTime
ScheduledProcedureStepID | (0040,0009): Scheduled Procedure Step ID
ScheduledProcedureStepLocation | (0040,0011): Scheduled Procedure Step Location
ScheduledProcedureStepModificationDateTime | (0040,4010): Scheduled Procedure Step Modification DateTime
ScheduledProcedureStepPriority | (0074,1200): Scheduled Procedure Step Priority
ScheduledProcedureStepSequence | (0040,0100): Scheduled Procedure Step Sequence
ScheduledProcedureStepStartDate | (0040,0002): Scheduled Procedure Step Start Date
ScheduledProcedureStepStartDateTime | (0040,4005): Scheduled Procedure Step Start DateTime
ScheduledProcedureStepStartTime | (0040,0003): Scheduled Procedure Step Start Time
ScheduledProcedureStepStatus | (0040,0020): Scheduled Procedure Step Status
ScheduledProcessingApplicationsCodeSequence | (0040,4004): Scheduled Processing Applications Code Sequence
ScheduledProcessingParametersSequence | (0074,1210): Scheduled Processing Parameters Sequence
ScheduledProtocolCodeSequence | (0040,0008): Scheduled Protocol Code Sequence
ScheduledSpecimenSequence | (0040,0500): Scheduled Specimen Sequence
ScheduledStationAETitle | (0040,0001): Scheduled Station AE Title
ScheduledStationClassCodeSequence | (0040,4026): Scheduled Station Class Code Sequence
ScheduledStationGeographicLocationCodeSequence | (0040,4027): Scheduled Station Geographic Location Code Sequence
ScheduledStationName | (0040,0010): Scheduled Station Name
ScheduledStationNameCodeSequence | (0040,4025): Scheduled Station Name Code Sequence
ScheduledStepAttributesSequence | (0040,0270): Scheduled Step Attributes Sequence
ScheduledStudyLocation | (0032,1020): Scheduled Study Location
ScheduledStudyLocationAETitle | (0032,1021): Scheduled Study Location AE Title
ScheduledStudyStartDate | (0032,1000): Scheduled Study Start Date
ScheduledStudyStartTime | (0032,1001): Scheduled Study Start Time
ScheduledStudyStopDate | (0032,1010): Scheduled Study Stop Date
ScheduledStudyStopTime | (0032,1011): Scheduled Study Stop Time
ScheduledWorkitemCodeSequence | (0040,4018): Scheduled Workitem Code Sequence
ScopeOfInventorySequence | (0008,0400): Scope of Inventory Sequence
SCPStatus | (0074,1242): SCP Status
ScreeningBaselineMeasured | (0024,0120): Screening Baseline Measured
ScreeningBaselineMeasuredSequence | (0024,0122): Screening Baseline Measured Sequence
ScreeningBaselineType | (0024,0124): Screening Baseline Type
ScreeningBaselineValue | (0024,0126): Screening Baseline Value
ScreeningTestModeCodeSequence | (0024,0016): Screening Test Mode Code Sequence
ScreenMinimumColorBitDepth | (0072,010C): Screen Minimum Color Bit Depth
ScreenMinimumGrayscaleBitDepth | (0072,010A): Screen Minimum Grayscale Bit Depth
SeamLineIndex | (0052,0036): Seam Line Index
SeamLineLocation | (0052,0033): Seam Line Location
SecondaryApprovalStatus | (0014,0101): Secondary Approval Status
SecondaryCaptureDeviceID | (0018,1010): Secondary Capture Device ID
SecondaryCaptureDeviceManufacturer | (0018,1016): Secondary Capture Device Manufacturer
SecondaryCaptureDeviceManufacturerModelName | (0018,1018): Secondary Capture Device Manufacturer's Model Name
SecondaryCaptureDeviceSoftwareVersions | (0018,1019): Secondary Capture Device Software Versions
SecondaryCountsAccumulated | (0054,1311): Secondary Counts Accumulated
SecondaryCountsType | (0054,1220): Secondary Counts Type
SecondaryInspectionMethodSequence | (4010,107D): Secondary Inspection Method Sequence
SecondaryPositionerIncrement | (0018,9515): Secondary Positioner Increment
SecondaryPositionerIncrementSign | (0018,9519): Secondary Positioner Increment Sign
SecondaryPositionerScanArc | (0018,9509): Secondary Positioner Scan Arc
SecondaryPositionerScanStartAngle | (0018,9511): Secondary Positioner Scan Start Angle
SecondaryReviewDate | (0014,0102): Secondary Review Date
SecondaryReviewerName | (0014,0104): Secondary Reviewer Name
SecondaryReviewTime | (0014,0103): Secondary Review Time
SegmentAlgorithmName | (0062,0009): Segment Algorithm Name
SegmentAlgorithmType | (0062,0008): Segment Algorithm Type
SegmentAnnotationCategoryCodeSequence | (3010,002B): Segment Annotation Category Code Sequence
SegmentAnnotationTypeCodeSequence | (3010,002C): Segment Annotation Type Code Sequence
SegmentAnnotationTypeModifierCodeSequence | (3010,002F): Segment Annotation Type Modifier Code Sequence
SegmentationAlgorithmIdentificationSequence | (0062,0007): Segmentation Algorithm Identification Sequence
SegmentationCreationTemplateLabel | (3010,001E): Segmentation Creation Template Label
SegmentationFractionalType | (0062,0010): Segmentation Fractional Type
SegmentationTemplateUID | (3010,001F): Segmentation Template UID
SegmentationType | (0062,0001): Segmentation Type
SegmentCharacteristicsPrecedence | (3010,0029): Segment Characteristics Precedence
SegmentCharacteristicsSequence | (3010,0027): Segment Characteristics Sequence
SegmentDescription | (0062,0006): Segment Description
SegmentedAlphaPaletteColorLookupTableData | (0028,1224): Segmented Alpha Palette Color Lookup Table Data
SegmentedBluePaletteColorLookupTableData | (0028,1223): Segmented Blue Palette Color Lookup Table Data
SegmentedGreenPaletteColorLookupTableData | (0028,1222): Segmented Green Palette Color Lookup Table Data
SegmentedKSpaceTraversal | (0018,9033): Segmented k-Space Traversal
SegmentedPropertyCategoryCodeSequence | (0062,0003): Segmented Property Category Code Sequence
SegmentedPropertyTypeCodeSequence | (0062,000F): Segmented Property Type Code Sequence
SegmentedPropertyTypeModifierCodeSequence | (0062,0011): Segmented Property Type Modifier Code Sequence
SegmentedRedPaletteColorLookupTableData | (0028,1221): Segmented Red Palette Color Lookup Table Data
SegmentedRTAccessoryDeviceSequence | (3010,0026): Segmented RT Accessory Device Sequence
SegmentIdentificationSequence | (0062,000A): Segment Identification Sequence
SegmentLabel | (0062,0005): Segment Label
SegmentNumber | (0062,0004): Segment Number
SegmentReferenceIndex | (3010,0022): Segment Reference Index
SegmentReferenceSequence | (3010,0021): Segment Reference Sequence
SegmentSequence | (0062,0002): Segment Sequence
SegmentsOverlap | (0062,0013): Segments Overlap
SegmentSurfaceGenerationAlgorithmIdentificationSequence | (0066,002D): Segment Surface Generation Algorithm Identification Sequence
SegmentSurfaceSourceInstanceSequence | (0066,002E): Segment Surface Source Instance Sequence
SelectedFrameFunctionalGroupsSequence | (3002,0101): Selected Frame Functional Groups Sequence
SelectedFrameNumber | (3002,0100): Selected Frame Number
SelectedSegmentalOphthalmicAxialLengthSequence | (0022,1257): Selected Segmental Ophthalmic Axial Length Sequence
SelectedTotalOphthalmicAxialLengthSequence | (0022,1260): Selected Total Ophthalmic Axial Length Sequence
SelectorAEValue | (0072,005E): Selector AE Value
SelectorASValue | (0072,005F): Selector AS Value
SelectorAttribute | (0072,0026): Selector Attribute
SelectorAttributeKeyword | (0082,0019): Selector Attribute Keyword
SelectorAttributeName | (0082,0018): Selector Attribute Name
SelectorAttributePrivateCreator | (0072,0056): Selector Attribute Private Creator
SelectorAttributeVR | (0072,0050): Selector Attribute VR
SelectorATValue | (0072,0060): Selector AT Value
SelectorCodeSequenceValue | (0072,0080): Selector Code Sequence Value
SelectorCSValue | (0072,0062): Selector CS Value
SelectorDAValue | (0072,0061): Selector DA Value
SelectorDSValue | (0072,0072): Selector DS Value
SelectorDTValue | (0072,0063): Selector DT Value
SelectorFDValue | (0072,0074): Selector FD Value
SelectorFLValue | (0072,0076): Selector FL Value
SelectorISValue | (0072,0064): Selector IS Value
SelectorLOValue | (0072,0066): Selector LO Value
SelectorLTValue | (0072,0068): Selector LT Value
SelectorOBValue | (0072,0065): Selector OB Value
SelectorODValue | (0072,0073): Selector OD Value
SelectorOFValue | (0072,0067): Selector OF Value
SelectorOLValue | (0072,0075): Selector OL Value
SelectorOVValue | (0072,0081): Selector OV Value
SelectorOWValue | (0072,0069): Selector OW Value
SelectorPNValue | (0072,006A): Selector PN Value
SelectorSequencePointer | (0072,0052): Selector Sequence Pointer
SelectorSequencePointerItems | (0074,1057): Selector Sequence Pointer Items
SelectorSequencePointerPrivateCreator | (0072,0054): Selector Sequence Pointer Private Creator
SelectorSHValue | (0072,006C): Selector SH Value
SelectorSLValue | (0072,007C): Selector SL Value
SelectorSSValue | (0072,007E): Selector SS Value
SelectorSTValue | (0072,006E): Selector ST Value
SelectorSVValue | (0072,0082): Selector SV Value
SelectorTMValue | (0072,006B): Selector TM Value
SelectorUCValue | (0072,006F): Selector UC Value
SelectorUIValue | (0072,007F): Selector UI Value
SelectorULValue | (0072,0078): Selector UL Value
SelectorUNValue | (0072,006D): Selector UN Value
SelectorURValue | (0072,0071): Selector UR Value
SelectorUSValue | (0072,007A): Selector US Value
SelectorUTValue | (0072,0070): Selector UT Value
SelectorUVValue | (0072,0083): Selector UV Value
SelectorValueNumber | (0072,0028): Selector Value Number
SelfTimerMode | (0016,0019): Self Timer Mode
SendingApplicationEntityTitle | (0002,0017): Sending Application Entity Title
SendingPresentationAddress | (0002,0027): Sending Presentation Address
SensingMethod | (0016,0039): Sensing Method
Sensitivity | (0018,6000): Sensitivity
SensitivityCalibrated | (0018,9767): Sensitivity Calibrated
SensitivityType | (0016,001A): Sensitivity Type
SensitivityValue | (0024,0094): Sensitivity Value
SensorName | (0014,3022): Sensor Name
SensorTemperature | (0014,3028): Sensor Temperature
SequenceDelimitationItem | (FFFE,E0DD): Sequence Delimitation Item
SequenceName | (0018,0024): Sequence Name
SequenceOfCompressedData | (0028,0403): Sequence of Compressed Data
SequenceOfUltrasoundRegions | (0018,6011): Sequence of Ultrasound Regions
SequenceVariant | (0018,0021): Sequence Variant
SequencingIndicatorTrial | (0040,A060): Sequencing Indicator (Trial)
SeriesDate | (0008,0021): Series Date
SeriesDescription | (0008,103E): Series Description
SeriesDescriptionCodeSequence | (0008,103F): Series Description Code Sequence
SeriesInstanceUID | (0020,000E): Series Instance UID
SeriesInStudy | (0020,1000): Series in Study
SeriesNumber | (0020,0011): Series Number
SeriesTime | (0008,0031): Series Time
SeriesType | (0054,1000): Series Type
ServiceEpisodeDescription | (0038,0062): Service Episode Description
ServiceEpisodeID | (0038,0060): Service Episode ID
SettlingPhaseFrame | (0018,9624): Settling Phase Frame
SetupDeviceDescription | (300A,01BA): Setup Device Description
SetupDeviceLabel | (300A,01B8): Setup Device Label
SetupDeviceParameter | (300A,01BC): Setup Device Parameter
SetupDeviceSequence | (300A,01B4): Setup Device Sequence
SetupDeviceType | (300A,01B6): Setup Device Type
SetupImageComment | (300A,0402): Setup Image Comment
SetupReferenceDescription | (300A,01D0): Setup Reference Description
SetupTechnique | (300A,01B0): Setup Technique
SetupTechniqueDescription | (300A,01B2): Setup Technique Description
ShadingStyle | (0070,1701): Shading Style
ShadowColorCIELabValue | (0070,0247): Shadow Color CIELab Value
ShadowOffsetX | (0070,0245): Shadow Offset X
ShadowOffsetY | (0070,0246): Shadow Offset Y
ShadowOpacity | (0070,0258): Shadow Opacity
ShadowStyle | (0070,0244): Shadow Style
ShapeType | (0070,0306): Shape Type
SharedFunctionalGroupsSequence | (5200,9229): Shared Functional Groups Sequence
Sharpness | (0016,004A): Sharpness
ShieldingDeviceDescription | (300A,01A6): Shielding Device Description
ShieldingDeviceLabel | (300A,01A4): Shielding Device Label
ShieldingDevicePosition | (300A,01A8): Shielding Device Position
ShieldingDeviceSequence | (300A,01A0): Shielding Device Sequence
ShieldingDeviceType | (300A,01A2): Shielding Device Type
ShiftTableSize | (1000,xxx4): Shift Table Size
ShiftTableTriplet | (1000,xxx5): Shift Table Triplet
Shininess | (0070,1706): Shininess
ShortTermFluctuation | (0024,0075): Short Term Fluctuation
ShortTermFluctuationCalculated | (0024,0074): Short Term Fluctuation Calculated
ShortTermFluctuationProbability | (0024,0077): Short Term Fluctuation Probability
ShortTermFluctuationProbabilityCalculated | (0024,0076): Short Term Fluctuation Probability Calculated
ShotDurationTime | (0080,0004): Shot Duration Time
ShotOffsetTime | (0080,0005): Shot Offset Time
ShowAcquisitionTechniquesFlag | (0072,0716): Show Acquisition Techniques Flag
ShowGraphicAnnotationFlag | (0072,0712): Show Graphic Annotation Flag
ShowGrayscaleInverted | (0072,0706): Show Grayscale Inverted
ShowImageTrueSizeFlag | (0072,0710): Show Image True Size Flag
ShowPatientDemographicsFlag | (0072,0714): Show Patient Demographics Flag
ShowTickLabel | (0070,0278): Show Tick Label
ShutterLeftVerticalEdge | (0018,1602): Shutter Left Vertical Edge
ShutterLowerHorizontalEdge | (0018,1608): Shutter Lower Horizontal Edge
ShutterOverlayGroup | (0018,1623): Shutter Overlay Group
ShutterPresentationColorCIELabValue | (0018,1624): Shutter Presentation Color CIELab Value
ShutterPresentationValue | (0018,1622): Shutter Presentation Value
ShutterRightVerticalEdge | (0018,1604): Shutter Right Vertical Edge
ShutterShape | (0018,1600): Shutter Shape
ShutterSpeedValue | (0016,0021): Shutter Speed Value
ShutterUpperHorizontalEdge | (0018,1606): Shutter Upper Horizontal Edge
SignalDomainColumns | (0028,9003): Signal Domain Columns
SignalDomainRows | (0028,9235): Signal Domain Rows
SignalToNoiseRatio | (0022,1155): Signal to Noise Ratio
Signature | (0400,0120): Signature
SimpleFrameList | (0008,1161): Simple Frame List
SimulatedKeratometricCylinderSequence | (0046,0218): Simulated Keratometric Cylinder Sequence
SingleCollimationWidth | (0018,9306): Single Collimation Width
SkipBeats | (0018,1086): Skip Beats
SkipFrameRangeFlag | (0008,9460): Skip Frame Range Flag
SlabOrientation | (0018,9105): Slab Orientation
SlabThickness | (0018,9104): Slab Thickness
SliceLocation | (0020,1041): Slice Location
SliceLocationVector | (0018,2005): Slice Location Vector
SliceProgressionDirection | (0054,0500): Slice Progression Direction
SliceSensitivityFactor | (0054,1320): Slice Sensitivity Factor
SliceThickness | (0018,0050): Slice Thickness
SliceVector | (0054,0080): Slice Vector
SlideIdentifier | (0040,06FA): Slide Identifier
SmallestImagePixelValue | (0028,0106): Smallest Image Pixel Value
SmallestImagePixelValueInPlane | (0028,0110): Smallest Image Pixel Value in Plane
SmallestPixelValueInSeries | (0028,0108): Smallest Pixel Value in Series
SmallestValidPixelValue | (0028,0104): Smallest Valid Pixel Value(Retired)
SmokingStatus | (0010,21A0): Smoking Status
SmoothingType | (2010,0080): Smoothing Type
SnoutID | (300A,030F): Snout ID
SnoutPosition | (300A,030D): Snout Position
SnoutPositionTolerance | (300A,004B): Snout Position Tolerance
SnoutSequence | (300A,030C): Snout Sequence
SNRThreshold | (4010,1073): SNR Threshold
SoftcopyVOILUTSequence | (0028,3110): Softcopy VOI LUT Sequence
SoftTissueFocusThermalIndex | (0018,5028): Soft Tissue-focus Thermal Index
SoftTissueSurfaceThermalIndex | (0018,5029): Soft Tissue-surface Thermal Index
SoftTissueThermalIndex | (0018,5027): Soft Tissue Thermal Index
SoftwareVersions | (0018,1020): Software Versions
SOPAuthorizationComment | (0100,0424): SOP Authorization Comment
SOPAuthorizationDateTime | (0100,0420): SOP Authorization DateTime
SOPClassesInStudy | (0008,0062): SOP Classes in Study
SOPClassesSupported | (0008,115A): SOP Classes Supported
SOPClassUID | (0008,0016): SOP Class UID
SOPInstanceStatus | (0100,0410): SOP Instance Status
SOPInstanceUID | (0008,0018): SOP Instance UID
SOPInstanceUIDOfConcatenationSource | (0020,0242): SOP Instance UID of Concatenation Source
SortByCategory | (0072,0602): Sort-by Category
SortingDirection | (0072,0604): Sorting Direction
SortingOperationsSequence | (0072,0600): Sorting Operations Sequence
SoundPathLength | (0014,405A): Sound Path Length
SoundSpeedCorrectionMechanismCodeSequence | (0018,9832): Sound Speed Correction Mechanism Code Sequence
SourceAcquisitionBeamNumber | (0018,9939): Source Acquisition Beam Number
SourceAcquisitionProtocolElementNumber | (0018,9938): Source Acquisition Protocol Element Number
SourceApplicationEntityTitle | (0002,0016): Source Application Entity Title
SourceApplicatorID | (300A,0291): Source Applicator ID
SourceApplicatorLength | (300A,0296): Source Applicator Length
SourceApplicatorManufacturer | (300A,0298): Source Applicator Manufacturer
SourceApplicatorName | (300A,0294): Source Applicator Name
SourceApplicatorNumber | (300A,0290): Source Applicator Number
SourceApplicatorStepSize | (300A,02A0): Source Applicator Step Size
SourceApplicatorTipLength | (300A,0274): Source Applicator Tip Length
SourceApplicatorType | (300A,0292): Source Applicator Type
SourceApplicatorWallNominalThickness | (300A,029C): Source Applicator Wall Nominal Thickness
SourceApplicatorWallNominalTransmission | (300A,029E): Source Applicator Wall Nominal Transmission
SourceAxisDistance | (300A,00B4): Source-Axis Distance
SourceConceptualVolumeSequence | (3010,0018): Source Conceptual Volume Sequence
SourceConceptualVolumeUID | (3010,0015): Source Conceptual Volume UID
SourceDescription | (300A,021C): Source Description
SourceEncapsulationNominalThickness | (300A,0222): Source Encapsulation Nominal Thickness
SourceEncapsulationNominalTransmission | (300A,0224): Source Encapsulation Nominal Transmission
SourceEndDateTime | (0018,936A): Source End DateTime
SourceFrameOfReferenceUID | (0064,0003): Source Frame of Reference UID
SourceHangingProtocolSequence | (0072,0012): Source Hanging Protocol Sequence
SourceIdentifier | (0034,0005): Source Identifier
SourceImageCornealProcessedDataSequence | (0046,0244): Source Image Corneal Processed Data Sequence
SourceImageEvidenceSequence | (0008,9154): Source Image Evidence Sequence
SourceImageIDs | (0020,31xx): Source Image IDs(Retired)
SourceImageSequence | (0008,2112): Source Image Sequence
SourceInstanceSequence | (0042,0013): Source Instance Sequence
SourceIrradiationEventSequence | (0008,3011): Source Irradiation Event Sequence
SourceIsotopeHalfLife | (300A,0228): Source Isotope Half Life
SourceIsotopeName | (300A,0226): Source Isotope Name
SourceManufacturer | (300A,0216): Source Manufacturer
SourceModelID | (300A,021B): Source Model ID
SourceMovementType | (300A,0288): Source Movement Type
SourceNumber | (300A,0212): Source Number
SourceOfAnteriorChamberDepthDataCodeSequence | (0022,1133): Source of Anterior Chamber Depth Data Code Sequence
SourceOfCornealSizeDataCodeSequence | (0022,1036): Source of Corneal Size Data Code Sequence
SourceOfCorneaMeasurementDataCodeSequence | (0046,0111): Source of Cornea Measurement Data Code Sequence
SourceOfLensThicknessDataCodeSequence | (0022,1132): Source of Lens Thickness Data Code Sequence
SourceOfOphthalmicAxialLengthCodeSequence | (0022,1035): Source of Ophthalmic Axial Length Code Sequence
SourceOfPreviousValues | (0400,0564): Source of Previous Values
SourceOfRefractiveMeasurementsCodeSequence | (0022,1135): Source of Refractive Measurements Code Sequence
SourceOfRefractiveMeasurementsSequence | (0022,1134): Source of Refractive Measurements Sequence
SourceOrientation | (4010,1060): Source Orientation
SourcePatientGroupIdentificationSequence | (0010,0026): Source Patient Group Identification Sequence
SourcePixelPlanesCharacteristicsSequence | (3006,004A): Source Pixel Planes Characteristics Sequence
SourcePosition | (4010,1061): Source Position
SourcePresentationAddress | (0002,0026): Source Presentation Address
SourceReconstructionProtocolElementNumber | (0018,993A): Source Reconstruction Protocol Element Number
SourceRollAngle | (300A,067A): Source Roll Angle
SourceSequence | (300A,0210): Source Sequence
SourceSerialNumber | (3008,0105): Source Serial Number
SourceSeriesInformationSequence | (3006,004C): Source Series Information Sequence
SourceSeriesSequence | (3006,004B): Source Series Sequence
SourceStartDateTime | (0018,9369): Source Start DateTime
SourceStrength | (300A,022B): Source Strength
SourceStrengthReferenceDate | (300A,022C): Source Strength Reference Date
SourceStrengthReferenceTime | (300A,022E): Source Strength Reference Time
SourceStrengthUnits | (300A,0229): Source Strength Units
SourceToApplicatorMountingPositionDistance | (300A,0436): Source to Applicator Mounting Position Distance
SourceToBeamLimitingDeviceDistance | (300A,00BA): Source to Beam Limiting Device Distance
SourceToBlockTrayDistance | (300A,00F6): Source to Block Tray Distance
SourceToCompensatorDistance | (300A,02E2): Source to Compensator Distance
SourceToCompensatorTrayDistance | (300A,00E6): Source to Compensator Tray Distance
SourceToExternalContourDistance | (300A,0132): Source to External Contour Distance
SourceToGeneralAccessoryDistance | (300A,0425): Source to General Accessory Distance
SourceToPatientSurfaceDistance | (300A,0634): Source to Patient Surface Distance
SourceToReferenceObjectDistance | (3002,0028): Source to Reference Object Distance
SourceToSurfaceDistance | (300A,0130): Source to Surface Distance
SourceToWedgeTrayDistance | (300A,00DA): Source to Wedge Tray Distance
SourceType | (300A,0214): Source Type
SourceWaveformSequence | (003A,020A): Source Waveform Sequence
SpacingBetweenSlices | (0018,0088): Spacing Between Slices
SpatialFrequencyResponseColumnNames | (0016,000C): Spatial Frequency Response Column Names
SpatialFrequencyResponseColumns | (0016,000B): Spatial Frequency Response Columns
SpatialFrequencyResponseRows | (0016,000A): Spatial Frequency Response Rows
SpatialFrequencyResponseValues | (0016,000D): Spatial Frequency Response Values
SpatialLocationsPreserved | (0028,135A): Spatial Locations Preserved
SpatialPresaturation | (0018,9027): Spatial Pre-saturation
SpatialResolution | (0018,1050): Spatial Resolution
SpatialTransformOfDose | (3004,0005): Spatial Transform of Dose
SpecialNeeds | (0038,0050): Special Needs
SpecificAbsorptionRateDefinition | (0018,9179): Specific Absorption Rate Definition
SpecificAbsorptionRateSequence | (0018,9239): Specific Absorption Rate Sequence
SpecificAbsorptionRateValue | (0018,9181): Specific Absorption Rate Value
SpecificationSelectionGuidance | (0082,0033): Specification Selection Guidance
SpecificCharacterSet | (0008,0005): Specific Character Set
SpecificCharacterSetOfFileSetDescriptorFile | (0004,1142): Specific Character Set of File-set Descriptor File
SpecifiedChannelTotalTime | (3008,0132): Specified Channel Total Time
SpecifiedMeterset | (3008,0042): Specified Meterset
SpecifiedNumberOfPulses | (3008,0136): Specified Number of Pulses
SpecifiedPrimaryMeterset | (3008,0032): Specified Primary Meterset
SpecifiedPulseRepetitionInterval | (3008,013A): Specified Pulse Repetition Interval
SpecifiedSecondaryMeterset | (3008,0033): Specified Secondary Meterset
SpecifiedTreatmentTime | (3008,003A): Specified Treatment Time
SpecimenAccessionNumber | (0040,050A): Specimen Accession Number
SpecimenDescriptionSequence | (0040,0560): Specimen Description Sequence
SpecimenDescriptionSequenceTrial | (0040,0552): Specimen Description Sequence (Trial)
SpecimenDescriptionTrial | (0040,0553): Specimen Description (Trial)
SpecimenDetailedDescription | (0040,0602): Specimen Detailed Description
SpecimenIdentifier | (0040,0551): Specimen Identifier
SpecimenLabelInImage | (0048,0010): Specimen Label in Image
SpecimenLocalizationContentItemSequence | (0040,0620): Specimen Localization Content Item Sequence
SpecimenPreparationSequence | (0040,0610): Specimen Preparation Sequence
SpecimenPreparationStepContentItemSequence | (0040,0612): Specimen Preparation Step Content Item Sequence
SpecimenReferenceSequence | (0048,0110): Specimen Reference Sequence
SpecimenSequence | (0040,0550): Specimen Sequence
SpecimenShortDescription | (0040,0600): Specimen Short Description
SpecimenTypeCodeSequence | (0040,059A): Specimen Type Code Sequence
SpecimenUID | (0040,0554): Specimen UID
SpectrallySelectedExcitation | (0018,9026): Spectrally Selected Excitation
SpectrallySelectedSuppression | (0018,9025): Spectrally Selected Suppression
SpectralSensitivity | (0016,0017): Spectral Sensitivity
SpectralWidth | (0018,9052): Spectral Width
SpectroscopyAcquisitionDataColumns | (0018,9127): Spectroscopy Acquisition Data Columns
SpectroscopyAcquisitionOutOfPlanePhaseSteps | (0018,9159): Spectroscopy Acquisition Out-of-plane Phase Steps
SpectroscopyAcquisitionPhaseColumns | (0018,9234): Spectroscopy Acquisition Phase Columns
SpectroscopyAcquisitionPhaseRows | (0018,9095): Spectroscopy Acquisition Phase Rows
SpectroscopyData | (5600,0020): Spectroscopy Data
SpecularReflectionIntensity | (0070,1705): Specular Reflection Intensity
SpherePower | (0046,0146): Sphere Power
SphericalLensPower | (0022,0007): Spherical Lens Power
SpiralPitchFactor | (0018,9311): Spiral Pitch Factor
Spoiling | (0018,9016): Spoiling
StackID | (0020,9056): Stack ID
StageCodeSequence | (0040,000A): Stage Code Sequence
StageName | (0008,2120): Stage Name
StageNumber | (0008,2122): Stage Number
StandardOutputSensitivity | (0016,001B): Standard Output Sensitivity
StartAcquisitionDateTime | (0018,9516): Start Acquisition DateTime
StartAngle | (0054,0200): Start Angle
StartCardiacTriggerCountThreshold | (0018,9717): Start Cardiac Trigger Count Threshold
StartCumulativeMeterset | (3002,0106): Start Cumulative Meterset
StartCumulativeMetersetWeight | (300C,0008): Start Cumulative Meterset Weight
StartCumulativeTimeWeight | (0074,1407): Start Cumulative Time Weight
StartDensityThreshold | (0018,9715): Start Density Threshold
StartingMetersetValueKnownFlag | (300A,0723): Starting Meterset Value Known Flag
StartingRespiratoryAmplitude | (0020,9246): Starting Respiratory Amplitude
StartingRespiratoryPhase | (0020,9247): Starting Respiratory Phase
StartMeterset | (3008,0078): Start Meterset
StartRelativeDensityDifferenceThreshold | (0018,9716): Start Relative Density Difference Threshold
StartRespiratoryTriggerCountThreshold | (0018,9718): Start Respiratory Trigger Count Threshold
StartTrim | (0008,2142): Start Trim
StationAETitle | (0008,0055): Station AE Title
StationName | (0008,1010): Station Name
Status | (0000,0900): Status
SteadyStatePulseSequence | (0018,9017): Steady State Pulse Sequence
SteepCornealAxisSequence | (0046,0112): Steep Corneal Axis Sequence
SteepKeratometricAxisSequence | (0046,0074): Steep Keratometric Axis Sequence
SteeringAngle | (0018,6036): Steering Angle
StereoBaselineAngle | (0022,0010): Stereo Baseline Angle
StereoBaselineDisplacement | (0022,0011): Stereo Baseline Displacement
StereoHorizontalPixelOffset | (0022,0012): Stereo Horizontal Pixel Offset
StereoPairsPresent | (0022,0028): Stereo Pairs Present
StereoPairsSequence | (0022,0020): Stereo Pairs Sequence
StereoRotation | (0022,0014): Stereo Rotation
StereoVerticalPixelOffset | (0022,0013): Stereo Vertical Pixel Offset
StimuliRetestingQuantity | (0024,0042): Stimuli Retesting Quantity
StimulusArea | (0024,0025): Stimulus Area
StimulusColorCodeSequence | (0024,0021): Stimulus Color Code Sequence
StimulusPresentationTime | (0024,0028): Stimulus Presentation Time
StimulusResults | (0024,0093): Stimulus Results
StopCumulativeMeterset | (3002,0107): Stop Cumulative Meterset
StopTrim | (0008,2143): Stop Trim
StorageMediaFileSetID | (0088,0130): Storage Media File-set ID
StorageMediaFileSetUID | (0088,0140): Storage Media File-set UID
StorageProtocolElementSequence | (0018,9936): Storage Protocol Element Sequence
StorageProtocolElementSpecificationSequence | (0018,9935): Storage Protocol Element Specification Sequence
StorageURL | (0040,4073): Storage URL
StoredInstanceBaseURI | (0008,0407): Stored Instance Base URI
StoredInstanceTransferSyntaxUID | (0008,040E): Stored Instance Transfer Syntax UID
StoredValueColorRangeSequence | (0028,1230): Stored Value Color Range Sequence
STOWRSStorageSequence | (0040,4072): STOW-RS Storage Sequence
StrainAdditionalInformation | (0010,0218): Strain Additional Information
StrainCodeSequence | (0010,0219): Strain Code Sequence
StrainDescription | (0010,0212): Strain Description
StrainNomenclature | (0010,0213): Strain Nomenclature
StrainSource | (0010,0217): Strain Source
StrainSourceRegistryCodeSequence | (0010,0215): Strain Source Registry Code Sequence
StrainStockNumber | (0010,0214): Strain Stock Number
StrainStockSequence | (0010,0216): Strain Stock Sequence
StructuredConstraintObservationSequence | (0082,000C): Structured Constraint Observation Sequence
StructuredDisplayBackgroundCIELabValue | (0072,0420): Structured Display Background CIELab Value
StructuredDisplayImageBoxSequence | (0072,0422): Structured Display Image Box Sequence
StructuredDisplayTextBoxSequence | (0072,0424): Structured Display Text Box Sequence
StructureSetDate | (3006,0008): Structure Set Date
StructureSetDescription | (3006,0006): Structure Set Description
StructureSetLabel | (3006,0002): Structure Set Label
StructureSetName | (3006,0004): Structure Set Name
StructureSetROISequence | (3006,0020): Structure Set ROI Sequence
StructureSetTime | (3006,0009): Structure Set Time
StudiesContainingOtherReferencedInstancesSequence | (0008,1200): Studies Containing Other Referenced Instances Sequence
StudyAccessEndPointsSequence | (0008,0421): Study Access End Points Sequence
StudyArrivalDate | (0032,1040): Study Arrival Date
StudyArrivalTime | (0032,1041): Study Arrival Time
StudyComments | (0032,4000): Study Comments
StudyCompletionDate | (0032,1050): Study Completion Date
StudyCompletionTime | (0032,1051): Study Completion Time
StudyComponentStatusID | (0032,1055): Study Component Status ID
StudyDate | (0008,0020): Study Date
StudyDescription | (0008,1030): Study Description
StudyID | (0020,0010): Study ID
StudyIDIssuer | (0032,0012): Study ID Issuer
StudyInstanceUID | (0020,000D): Study Instance UID
StudyPriorityID | (0032,000C): Study Priority ID
StudyReadDate | (0032,0034): Study Read Date
StudyReadTime | (0032,0035): Study Read Time
StudyStatusID | (0032,000A): Study Status ID
StudyTime | (0008,0030): Study Time
StudyUpdateDateTime | (0008,041F): Study Update DateTime
StudyVerifiedDate | (0032,0032): Study Verified Date
StudyVerifiedTime | (0032,0033): Study Verified Time
SubjectArea | (0016,002A): Subject Area
SubjectDistance | (0016,0026): Subject Distance
SubjectDistanceRange | (0016,004C): Subject Distance Range
SubjectiveRefractionLeftEyeSequence | (0046,0098): Subjective Refraction Left Eye Sequence
SubjectiveRefractionRightEyeSequence | (0046,0097): Subjective Refraction Right Eye Sequence
SubjectLocation | (0016,0037): Subject Location
SubjectRelativePositionInImage | (0010,0028): Subject Relative Position in Image
SubscriptionListStatus | (0074,1244): Subscription List Status
SubstanceAdministrationApproval | (0044,0002): Substance Administration Approval
SubstanceAdministrationDateTime | (0044,0010): Substance Administration DateTime
SubstanceAdministrationDeviceID | (0044,0012): Substance Administration Device ID
SubstanceAdministrationNotes | (0044,0011): Substance Administration Notes
SubstanceAdministrationParameterSequence | (0044,0019): Substance Administration Parameter Sequence
SubtaskWorkitemCodeSequence | (3002,011B): Subtask Workitem Code Sequence
SubtractionItemID | (0028,9416): Subtraction Item ID
SummarizedFilterLookupTable | (003A,0320): Summarized Filter Lookup Table Sequence
SupportedImageDisplayFormatsSequence | (2000,00A8): Supported Image Display Formats Sequence
SurfaceAsymmetryIndex | (0046,0232): Surface Asymmetry Index
SurfaceComments | (0066,0004): Surface Comments
SurfaceCount | (0066,002A): Surface Count
SurfaceEntryPoint | (300A,012E): Surface Entry Point
SurfaceMeshPrimitivesSequence | (0066,0013): Surface Mesh Primitives Sequence
SurfaceMeshZPixelOffset | (0022,1658): Surface Mesh Z-Pixel Offset
SurfaceModelDescriptionSequence | (0068,6360): Surface Model Description Sequence
SurfaceModelLabel | (0068,6380): Surface Model Label
SurfaceModelScalingFactor | (0068,6390): Surface Model Scaling Factor
SurfaceNumber | (0066,0003): Surface Number
SurfacePointColorCIELabValueData | (0080,0007): Surface Point Color CIELab Value Data
SurfacePointPresentationValueData | (0080,0006): Surface Point Presentation Value Data
SurfacePointsNormalsSequence | (0066,0012): Surface Points Normals Sequence
SurfacePointsSequence | (0066,0011): Surface Points Sequence
SurfaceProcessing | (0066,0009): Surface Processing
SurfaceProcessingAlgorithmIdentificationSequence | (0066,0035): Surface Processing Algorithm Identification Sequence
SurfaceProcessingDescription | (0066,000B): Surface Processing Description
SurfaceProcessingRatio | (0066,000A): Surface Processing Ratio
SurfaceRegularityIndex | (0046,0230): Surface Regularity Index
SurfaceScanAcquisitionTypeCodeSequence | (0080,0001): Surface Scan Acquisition Type Code Sequence
SurfaceScanModeCodeSequence | (0080,0002): Surface Scan Mode Code Sequence
SurfaceSequence | (0066,0002): Surface Sequence
SurgicallyInducedAstigmatismSequence | (0022,1045): Surgically Induced Astigmatism Sequence
SurgicalTechnique | (0076,0030): Surgical Technique
SUVType | (0054,1006): SUV Type
SwitchingPhaseNominalDuration | (0018,936C): Switching Phase Nominal Duration
SwitchingPhaseNumber | (0018,936B): Switching Phase Number
SwitchingPhaseTransitionDuration | (0018,936D): Switching Phase Transition Duration
SwivelRange | (0070,1A06): Swivel Range
SynchronizationChannel | (0018,106C): Synchronization Channel
SynchronizationFrameOfReferenceUID | (0020,0200): Synchronization Frame of Reference UID
SynchronizationTrigger | (0018,106A): Synchronization Trigger
SynchronizedImageBoxList | (0072,0432): Synchronized Image Box List
SynchronizedScrollingSequence | (0072,0210): Synchronized Scrolling Sequence
SyntheticData | (0008,001C): Synthetic Data
SyringeCounts | (0018,1045): Syringe Counts
SystemStatus | (0028,7006): System Status
SystemStatusComment | (0028,7007): System Status Comment
T2Preparation | (0018,9021): T2 Preparation
TableAngle | (0018,1138): Table Angle
TableColumnDefinitionSequence | (0040,A807): Table Column Definition Sequence
TableColumnNumber | (0040,A805): Table Column Number
TableCradleTiltAngle | (0018,9471): Table Cradle Tilt Angle
TableFeedPerRotation | (0018,9310): Table Feed per Rotation
TableFrameOfReferenceUID | (0020,9313): Table Frame of Reference UID
TableHeadTiltAngle | (0018,9470): Table Head Tilt Angle
TableHeight | (0018,1130): Table Height
TableHorizontalRotationAngle | (0018,9469): Table Horizontal Rotation Angle
TableLateralIncrement | (0018,1136): Table Lateral Increment
TableLongitudinalIncrement | (0018,1137): Table Longitudinal Increment
TableMotion | (0018,1134): Table Motion
TableOfParameterValues | (0018,605A): Table of Parameter Values
TableOfPixelValues | (0018,6058): Table of Pixel Values
TableOfXBreakPoints | (0018,6052): Table of X Break Points
TableOfYBreakPoints | (0018,6054): Table of Y Break Points
TablePosition | (0018,9327): Table Position
TablePositionSequence | (0018,9406): Table Position Sequence
TableRowDefinitionSequence | (0040,A806): Table Row Definition Sequence
TableRowNumber | (0040,A804): Table Row Number
TableSpeed | (0018,9309): Table Speed
TableTopEccentricAdjustedAngle | (0074,102B): Table Top Eccentric Adjusted Angle
TableTopEccentricAngle | (300A,0125): Table Top Eccentric Angle
TableTopEccentricAngleTolerance | (300A,004E): Table Top Eccentric Angle Tolerance
TableTopEccentricAxisDistance | (300A,0124): Table Top Eccentric Axis Distance
TableTopEccentricRotationDirection | (300A,0126): Table Top Eccentric Rotation Direction
TableTopLateralAdjustedPosition | (0074,1028): Table Top Lateral Adjusted Position
TableTopLateralPosition | (300A,012A): Table Top Lateral Position
TableTopLateralPositionTolerance | (300A,0053): Table Top Lateral Position Tolerance
TableTopLateralSetupDisplacement | (300A,01D6): Table Top Lateral Setup Displacement
TableTopLongitudinalAdjustedPosition | (0074,1027): Table Top Longitudinal Adjusted Position
TableTopLongitudinalPosition | (300A,0129): Table Top Longitudinal Position
TableTopLongitudinalPositionTolerance | (300A,0052): Table Top Longitudinal Position Tolerance
TableTopLongitudinalSetupDisplacement | (300A,01D4): Table Top Longitudinal Setup Displacement
TableTopPitchAdjustedAngle | (0074,102C): Table Top Pitch Adjusted Angle
TableTopPitchAngle | (300A,0140): Table Top Pitch Angle
TableTopPitchAngleTolerance | (300A,004F): Table Top Pitch Angle Tolerance
TableTopPitchRotationDirection | (300A,0142): Table Top Pitch Rotation Direction
TableTopPositionAlignmentUID | (300A,0054): Table Top Position Alignment UID
TableTopRollAdjustedAngle | (0074,102D): Table Top Roll Adjusted Angle
TableTopRollAngle | (300A,0144): Table Top Roll Angle
TableTopRollAngleTolerance | (300A,0050): Table Top Roll Angle Tolerance
TableTopRollRotationDirection | (300A,0146): Table Top Roll Rotation Direction
TableTopVerticalAdjustedPosition | (0074,1026): Table Top Vertical Adjusted Position
TableTopVerticalPosition | (300A,0128): Table Top Vertical Position
TableTopVerticalPositionTolerance | (300A,0051): Table Top Vertical Position Tolerance
TableTopVerticalSetupDisplacement | (300A,01D2): Table Top Vertical Setup Displacement
TableTraverse | (0018,1131): Table Traverse
TableType | (0018,113A): Table Type
TableVerticalIncrement | (0018,1135): Table Vertical Increment
TableXPositionToIsocenter | (0018,9466): Table X Position to Isocenter
TableYPositionToIsocenter | (0018,9467): Table Y Position to Isocenter
TableZPositionToIsocenter | (0018,9468): Table Z Position to Isocenter
TabulatedValuesSequence | (0040,A801): Tabulated Values Sequence
TagAngleFirstAxis | (0018,9019): Tag Angle First Axis
TagAngleSecondAxis | (0018,9219): Tag Angle Second Axis
Tagging | (0018,9028): Tagging
TaggingDelay | (0018,9184): Tagging Delay
TagSpacingFirstDimension | (0018,9030): Tag Spacing First Dimension
TagSpacingSecondDimension | (0018,9218): Tag Spacing Second Dimension
TagThickness | (0018,9035): Tag Thickness
TangentialPower | (0046,0250): Tangential Power
TargetExposureIndex | (0018,1412): Target Exposure Index
TargetFrameOfReferenceUID | (0018,991E): Target Frame of Reference UID
TargetLabel | (0018,2045): Target Label
TargetLuminanceCharacteristicsSequence | (0028,7008): Target Luminance Characteristics Sequence
TargetMaterialSequence | (4010,1072): Target Material Sequence
TargetMaximumDose | (300A,0027): Target Maximum Dose
TargetMaximumLuminance | (0028,701E): Target Maximum Luminance
TargetMinimumDose | (300A,0025): Target Minimum Dose
TargetMinimumLuminance | (0028,701D): Target Minimum Luminance
TargetPositionReferenceIndicator | (0020,103F): Target Position Reference Indicator
TargetPrescriptionDose | (300A,0026): Target Prescription Dose
TargetRefraction | (0022,1037): Target Refraction
TargetUID | (0018,2042): Target UID
TargetUnderdoseVolumeFraction | (300A,0028): Target Underdose Volume Fraction
TDRType | (4010,1027): TDR Type
TelephoneNumberTrial | (0040,A354): Telephone Number (Trial)
TeletherapyRadiationType | (3010,0047): Teletherapy Radiation Type
Temperature | (0016,0030): Temperature
TemplateExtensionCreatorUID | (0040,DB0D): Template Extension Creator UID
TemplateExtensionFlag | (0040,DB0B): Template Extension Flag
TemplateExtensionOrganizationUID | (0040,DB0C): Template Extension Organization UID
TemplateIdentifier | (0040,DB00): Template Identifier
TemplateLocalVersion | (0040,DB07): Template Local Version
TemplateName | (300A,0244): Template Name
TemplateNumber | (300A,0240): Template Number
TemplateType | (300A,0242): Template Type
TemplateVersion | (0040,DB06): Template Version
TemporalPositionIdentifier | (0020,0100): Temporal Position Identifier
TemporalPositionIndex | (0020,9128): Temporal Position Index
TemporalPositionSequence | (0020,9310): Temporal Position Sequence
TemporalPositionTimeOffset | (0020,930D): Temporal Position Time Offset
TemporalRangeType | (0040,A130): Temporal Range Type
TemporalRelationshipIntervalAnchor | (3010,004F): Temporal Relationship Interval Anchor
TemporalResolution | (0020,0110): Temporal Resolution
TerminalType | (0000,4010): Terminal Type(Retired)
TerminationCardiacTriggerCountThreshold | (0018,9723): Termination Cardiac Trigger Count Threshold
TerminationCountsThreshold | (0018,9719): Termination Counts Threshold
TerminationDensityThreshold | (0018,9720): Termination Density Threshold
TerminationRelativeDensityThreshold | (0018,9721): Termination Relative Density Threshold
TerminationRespiratoryTriggerCountThreshold | (0018,9724): Termination Respiratory Trigger Count Threshold
TerminationTimeThreshold | (0018,9722): Termination Time Threshold
TestImageValidation | (0028,702B): Test Image Validation
TestPatternCodeSequence | (0028,702C): Test Pattern Code Sequence
TestPointNormalsDataFlag | (0024,0057): Test Point Normals Data Flag
TestPointNormalsSequence | (0024,0058): Test Point Normals Sequence
TestResult | (0028,7029): Test Result
TestResultComment | (0028,702A): Test Result Comment
TextColorCIELabValue | (0070,0241): Text Color CIELab Value
TextComments | (4000,4000): Text Comments(Retired)
TextFormatID | (0000,5130): Text Format ID(Retired)
TextObjectSequence | (0070,0008): Text Object Sequence
TextString | (2030,0020): Text String
TextStyleSequence | (0070,0231): Text Style Sequence
TextureLabel | (0080,0009): Texture Label
TextValue | (0040,A160): Text Value
TherapeuticRoleCategoryCodeSequence | (3010,0064): Therapeutic Role Category Code Sequence
TherapeuticRoleTypeCodeSequence | (3010,0065): Therapeutic Role Type Code Sequence
TherapyDescription | (0018,0039): Therapy Description
TherapyType | (0018,0037): Therapy Type
ThreatCategory | (4010,1012): Threat Category
ThreatCategoryDescription | (4010,1013): Threat Category Description
ThreatDetectionAlgorithmAndVersion | (4010,1029): Threat Detection Algorithm and Version
ThreatROIBase | (4010,1004): Threat ROI Base
ThreatROIBitmap | (4010,1006): Threat ROI Bitmap
ThreatROIExtents | (4010,1005): Threat ROI Extents
ThreatROIVoxelSequence | (4010,1001): Threat ROI Voxel Sequence
ThreatSequence | (4010,1011): Threat Sequence
ThreeDDegreeOfFreedomAxis | (0068,6490): 3D Degree of Freedom Axis
ThreeDImplantTemplateGroupMemberMatchingAxes | (0078,0060): 3D Implant Template Group Member Matching Axes
ThreeDImplantTemplateGroupMemberMatchingPoint | (0078,0050): 3D Implant Template Group Member Matching Point
ThreeDLineCoordinates | (0068,65D0): 3D Line Coordinates
ThreeDMatingAxes | (0068,64D0): 3D Mating Axes
ThreeDMatingPoint | (0068,64C0): 3D Mating Point
ThreeDPlaneNormal | (0068,6620): 3D Plane Normal
ThreeDPlaneOrigin | (0068,6610): 3D Plane Origin
ThreeDPointCoordinates | (0068,6590): 3D Point Coordinates
ThreeDRenderingType | (0072,0520): 3D Rendering Type
ThresholdDensity | (2040,0100): Threshold Density
ThresholdSequence | (0070,1B11): Threshold Sequence
ThresholdType | (0070,1B13): Threshold Type
ThresholdValue | (0070,1B14): Threshold Value
ThresholdValueSequence | (0070,1B12): Threshold Value Sequence
TickAlignment | (0070,0274): Tick Alignment
TickLabel | (0070,0289): Tick Label
TickLabelAlignment | (0070,0279): Tick Label Alignment
TickPosition | (0070,0288): Tick Position
TIDOffset | (0028,6120): TID Offset
Time | (0040,A122): Time
TimeBasedImageSetsSequence | (0072,0030): Time Based Image Sets Sequence
TimeDistributionProtocol | (0018,1802): Time Distribution Protocol
TimeDomainFiltering | (0018,9065): Time Domain Filtering
TimeOfDocumentCreationOrVerbalTransactionTrial | (0040,A112): Time of Document Creation or Verbal Transaction (Trial)
TimeOfFlightContrast | (0018,9015): Time of Flight Contrast
TimeOfFlightInformationUsed | (0018,9755): Time of Flight Information Used
TimeOfFrameGroupSequence | (0034,000D): Time of Frame Group Sequence
TimeOfGainCalibration | (0014,3077): Time of Gain Calibration
TimeOfLastCalibration | (0018,1201): Time of Last Calibration
TimeOfLastDetectorCalibration | (0018,700E): Time of Last Detector Calibration
TimeOfSecondaryCapture | (0018,1014): Time of Secondary Capture
TimeRange | (0008,1163): Time Range
TimeSeriesBlending | (0070,1B07): Time Series Blending
TimeSliceVector | (0054,0100): Time Slice Vector
TimeSlotInformationSequence | (0054,0072): Time Slot Information Sequence
TimeSlotNumber | (0020,0017): Time Slot Number
TimeSlotTime | (0054,0073): Time Slot Time
TimeSlotVector | (0054,0070): Time Slot Vector
TimeSource | (0018,1801): Time Source
TimezoneOffsetFromUTC | (0008,0201): Timezone Offset From UTC
TIPType | (4010,1039): TIP Type
TissueHeterogeneityCorrection | (3004,0014): Tissue Heterogeneity Correction
TissueLocation | (0048,0115): Tissue Location
TMLinePositionX0 | (0018,603D): TM-Line Position X0
TMLinePositionX0Retired | (0018,603C): TM-Line Position X0 (Retired)
TMLinePositionX1 | (0018,6041): TM-Line Position X1
TMLinePositionX1Retired | (0018,6040): TM-Line Position X1 (Retired)
TMLinePositionY0 | (0018,603F): TM-Line Position Y0
TMLinePositionY0Retired | (0018,603E): TM-Line Position Y0 (Retired)
TMLinePositionY1 | (0018,6043): TM-Line Position Y1
TMLinePositionY1Retired | (0018,6042): TM-Line Position Y1 (Retired)
ToleranceTableLabel | (300A,0043): Tolerance Table Label
ToleranceTableNumber | (300A,0042): Tolerance Table Number
ToleranceTableSequence | (300A,0040): Tolerance Table Sequence
ToleranceValue | (300A,062C): Tolerance Value
TomoAngle | (0018,1470): Tomo Angle
TomoClass | (0018,1491): Tomo Class
TomoLayerHeight | (0018,1460): Tomo Layer Height
TomotherapeuticControlPointSequence | (3010,0098): Tomotherapeutic Control Point Sequence
TomotherapeuticLeafInitialClosedDurations | (3010,009A): Tomotherapeutic Leaf Initial Closed Durations
TomotherapeuticLeafOpenDurations | (3010,0099): Tomotherapeutic Leaf Open Durations
TomoTime | (0018,1480): Tomo Time
TomoType | (0018,1490): Tomo Type
TopicAuthor | (0088,0910): Topic Author
TopicKeywords | (0088,0912): Topic Keywords
TopicSubject | (0088,0906): Topic Subject
TopicTitle | (0088,0904): Topic Title
TopLeftHandCornerOfLocalizerArea | (0048,0201): Top Left Hand Corner of Localizer Area
ToricIOLPowerForExactEmmetropiaSequence | (0022,104A): Toric IOL Power for Exact Emmetropia Sequence
ToricIOLPowerForExactTargetRefractionSequence | (0022,104B): Toric IOL Power for Exact Target Refraction Sequence
ToricIOLPowerSequence | (0022,1047): Toric IOL Power Sequence
TotalAperture | (0014,5101): Total Aperture
TotalBlockTrayFactor | (300A,00F2): Total Block Tray Factor
TotalBlockTrayWaterEquivalentThickness | (300A,00F3): Total Block Tray Water-Equivalent Thickness
TotalCollimationWidth | (0018,9307): Total Collimation Width
TotalCompensatorTrayFactor | (300A,00E2): Total Compensator Tray Factor
TotalCompensatorTrayWaterEquivalentThickness | (300A,02E3): Total Compensator Tray Water-Equivalent Thickness
TotalGain | (0018,5040): Total Gain(Retired)
TotalNumberOfExposures | (0040,0301): Total Number of Exposures
TotalNumberOfPiecesOfMediaCreated | (2200,000B): Total Number of Pieces of Media Created
TotalNumberOfStudyRecords | (0008,0428): Total Number of Study Records
TotalPixelMatrixColumns | (0048,0006): Total Pixel Matrix Columns
TotalPixelMatrixFocalPlanes | (0048,0303): Total Pixel Matrix Focal Planes
TotalPixelMatrixOriginSequence | (0048,0008): Total Pixel Matrix Origin Sequence
TotalPixelMatrixRows | (0048,0007): Total Pixel Matrix Rows
TotalPrescriptionDose | (300C,0115): Total Prescription Dose
TotalProcessingTime | (4010,1069): Total Processing Time
TotalReferenceAirKerma | (300A,0250): Total Reference Air Kerma
TotalTime | (50xx,200A): Total Time
TotalTimeOfFluoroscopy | (0040,0300): Total Time of Fluoroscopy
TotalWedgeTrayWaterEquivalentThickness | (300A,00D7): Total Wedge Tray Water-Equivalent Thickness
TrackingAlgorithmIdentificationSequence | (0066,0104): Tracking Algorithm Identification Sequence
TrackingID | (0062,0020): Tracking ID
TrackingUID | (0062,0021): Tracking UID
TrackPointIndexList | (0066,0129): Track Point Index List
TrackSequence | (0066,0102): Track Sequence
TrackSetAnatomicalTypeCodeSequence | (0066,0108): Track Set Anatomical Type Code Sequence
TrackSetDescription | (0066,0107): Track Set Description
TrackSetLabel | (0066,0106): Track Set Label
TrackSetNumber | (0066,0105): Track Set Number
TrackSetSequence | (0066,0101): Track Set Sequence
TrackSetStatisticsSequence | (0066,0124): Track Set Statistics Sequence
TrackStatisticsSequence | (0066,0130): Track Statistics Sequence
TransactionStatus | (0008,0417): Transaction Status
TransactionStatusComment | (0008,0418): Transaction Status Comment
TransactionUID | (0008,1195): Transaction UID
TransducerApplicationCodeSequence | (0018,980F): Transducer Application Code Sequence
TransducerBeamSteeringCodeSequence | (0018,980E): Transducer Beam Steering Code Sequence
TransducerData | (0018,5010): Transducer Data
TransducerFrequency | (0018,6030): Transducer Frequency
TransducerGeometryCodeSequence | (0018,980D): Transducer Geometry Code Sequence
TransducerIdentificationSequence | (0018,5011): Transducer Identification Sequence
TransducerOrientation | (0008,2204): Transducer Orientation
TransducerOrientationModifierSequence | (0008,2246): Transducer Orientation Modifier Sequence
TransducerOrientationSequence | (0008,2244): Transducer Orientation Sequence
TransducerPosition | (0008,2200): Transducer Position
TransducerPositionModifierSequence | (0008,2242): Transducer Position Modifier Sequence
TransducerPositionSequence | (0008,2240): Transducer Position Sequence
TransducerResponseSequence | (0018,982C): Transducer Response Sequence
TransducerScanPatternCodeSequence | (0018,9809): Transducer Scan Pattern Code Sequence
TransducerTechnologySequence | (0018,9831): Transducer Technology Sequence
TransducerType | (0018,6031): Transducer Type
TransferSyntaxUID | (0002,0010): Transfer Syntax UID
TransferTubeLength | (300A,02A4): Transfer Tube Length
TransferTubeNumber | (300A,02A2): Transfer Tube Number
TransformationAlgorithmSequence | (0022,1513): Transformation Algorithm Sequence
TransformationMethodCodeSequence | (0022,1512): Transformation Method Code Sequence
TransformDescription | (0014,2222): Transform Description
TransformedAxisUnits | (0014,2228): Transformed Axis Units
TransformLabel | (0028,0400): Transform Label
TransformNumberOfAxes | (0014,2224): Transform Number of Axes
TransformOrderOfAxes | (0014,2226): Transform Order of Axes
TransformVersionNumber | (0028,0401): Transform Version Number
TranslationRateX | (0014,409C): Translation Rate X
TranslationRateY | (0014,409D): Translation Rate Y
TransmitCoilManufacturerName | (0018,9050): Transmit Coil Manufacturer Name
TransmitCoilName | (0018,1251): Transmit Coil Name
TransmitCoilType | (0018,9051): Transmit Coil Type
TransmitterFrequency | (0018,9098): Transmitter Frequency
TransmitTransducerSequence | (0014,4010): Transmit Transducer Sequence
TransmitTransducerSettingsSequence | (0014,4050): Transmit Transducer Settings Sequence
TransportClassification | (4010,1067): Transport Classification
TransverseDetectorSeparation | (0018,9726): Transverse Detector Separation
TransverseMash | (0054,1202): Transverse Mash
TrayAccessoryCode | (300A,0355): Tray Accessory Code
TreatmentControlPointDate | (3008,0024): Treatment Control Point Date
TreatmentControlPointTime | (3008,0025): Treatment Control Point Time
TreatmentDate | (3008,0250): Treatment Date
TreatmentDeliveryContinuationFlag | (300A,0708): Treatment Delivery Continuation Flag
TreatmentDeliveryType | (300A,00CE): Treatment Delivery Type
TreatmentDeviceIdentificationSequence | (300A,063A): Treatment Device Identification Sequence
TreatmentMachineName | (300A,00B2): Treatment Machine Name
TreatmentMachineSequence | (300A,0206): Treatment Machine Sequence
TreatmentMachineSpecialModeCodeSequence | (300A,0635): Treatment Machine Special Mode Code Sequence
TreatmentPositionGroupLabel | (300A,0608): Treatment Position Group Label
TreatmentPositionGroupSequence | (300A,060A): Treatment Position Group Sequence
TreatmentPositionGroupUID | (300A,0609): Treatment Position Group UID
TreatmentPositionIndex | (300A,0606): Treatment Position Index
TreatmentPositionSequence | (300A,063F): Treatment Position Sequence
TreatmentProtocols | (300A,0009): Treatment Protocols
TreatmentRecordContentOrigin | (300A,0709): Treatment Record Content Origin
TreatmentSessionApplicationSetupSequence | (3008,0110): Treatment Session Application Setup Sequence
TreatmentSessionBeamSequence | (3008,0020): Treatment Session Beam Sequence
TreatmentSessionIonBeamSequence | (3008,0021): Treatment Session Ion Beam Sequence
TreatmentSessionUID | (300A,0700): Treatment Session UID
TreatmentSite | (3010,0077): Treatment Site
TreatmentSiteCodeSequence | (3010,0078): Treatment Site Code Sequence
TreatmentSiteModifierCodeSequence | (3010,0089): Treatment Site Modifier Code Sequence
TreatmentSites | (300A,000B): Treatment Sites
TreatmentStatusComment | (3008,0202): Treatment Status Comment
TreatmentSummaryCalculatedDoseReferenceSequence | (3008,0050): Treatment Summary Calculated Dose Reference Sequence
TreatmentSummaryMeasuredDoseReferenceSequence | (3008,00E0): Treatment Summary Measured Dose Reference Sequence
TreatmentTechniqueNotes | (3010,007A): Treatment Technique Notes
TreatmentTerminationCode | (3008,002B): Treatment Termination Code
TreatmentTerminationDescription | (300A,0730): Treatment Termination Description
TreatmentTerminationStatus | (3008,002A): Treatment Termination Status
TreatmentTime | (3008,0251): Treatment Time
TreatmentTimeLimit | (300A,062E): Treatment Time Limit
TreatmentToleranceViolationAttributeSequence | (300A,0733): Treatment Tolerance Violation Attribute Sequence
TreatmentToleranceViolationCategory | (300A,0732): Treatment Tolerance Violation Category
TreatmentToleranceViolationCauseCodeSequence | (300A,0762): Treatment Tolerance Violation Cause Code Sequence
TreatmentToleranceViolationDateTime | (300A,0736): Treatment Tolerance Violation DateTime
TreatmentToleranceViolationDescription | (300A,0734): Treatment Tolerance Violation Description
TreatmentToleranceViolationIdentification | (300A,0735): Treatment Tolerance Violation Identification
TreatmentToleranceViolationSequence | (300A,0731): Treatment Tolerance Violation Sequence
TreatmentToleranceViolationTypeCodeSequence | (300A,0761): Treatment Tolerance Violation Type Code Sequence
TreatmentVerificationStatus | (3008,002C): Treatment Verification Status
TriangleFanSequence | (0066,0027): Triangle Fan Sequence
TrianglePointIndexList | (0066,0023): Triangle Point Index List
TriangleStripSequence | (0066,0026): Triangle Strip Sequence
TriggerSamplePosition | (0018,106E): Trigger Sample Position
TriggerSourceOrType | (0018,1061): Trigger Source or Type
TriggerTime | (0018,1060): Trigger Time
TriggerTimeOffset | (0018,1069): Trigger Time Offset
TriggerVector | (0054,0210): Trigger Vector
TriggerWindow | (0018,1094): Trigger Window
Trim | (2010,0140): Trim
TubeAngle | (0018,9303): Tube Angle
TwoDDegreeOfFreedomAxis | (0068,64F0): 2D Degree of Freedom Axis
TwoDDegreeOfFreedomSequence | (0068,6470): 2D Degree of Freedom Sequence
TwoDimensionalToThreeDimensionalMapData | (0022,1531): Two Dimensional to Three Dimensional Map Data
TwoDimensionalToThreeDimensionalMapSequence | (0022,1518): Two Dimensional to Three Dimensional Map Sequence
TwoDImplantTemplateGroupMemberMatchingAxes | (0078,00A0): 2D Implant Template Group Member Matching Axes
TwoDImplantTemplateGroupMemberMatchingPoint | (0078,0090): 2D Implant Template Group Member Matching Point
TwoDLineCoordinates | (0068,65B0): 2D Line Coordinates
TwoDLineCoordinatesSequence | (0068,65A0): 2D Line Coordinates Sequence
TwoDMatingAxes | (0068,6460): 2D Mating Axes
TwoDMatingFeatureCoordinatesSequence | (0068,6430): 2D Mating Feature Coordinates Sequence
TwoDMatingPoint | (0068,6450): 2D Mating Point
TwoDPlaneCoordinatesSequence | (0068,65E0): 2D Plane Coordinates Sequence
TwoDPlaneIntersection | (0068,65F0): 2D Plane Intersection
TwoDPointCoordinates | (0068,6560): 2D Point Coordinates
TwoDPointCoordinatesSequence | (0068,6550): 2D Point Coordinates Sequence
TypeOfData | (50xx,0020): Type of Data
TypeOfDetectorMotion | (0054,0202): Type of Detector Motion
TypeOfFilters | (0018,1161): Type of Filters
TypeOfInstances | (0040,E020): Type of Instances
TypeOfOpticalCorrection | (0022,1046): Type of Optical Correction
TypeOfPatientID | (0010,0022): Type of Patient ID
TypeOfSynchronization | (0072,0434): Type of Synchronization
UDISequence | (0018,100A): UDI Sequence
UID | (0040,A124): UID
UltrasoundAcquisitionGeometry | (0020,9307): Ultrasound Acquisition Geometry
UltrasoundColorDataPresent | (0028,0014): Ultrasound Color Data Present
UltrasoundOphthalmicAxialLengthMeasurementsSequence | (0022,1220): Ultrasound Ophthalmic Axial Length Measurements Sequence
UltrasoundSelectedOphthalmicAxialLengthSequence | (0022,1230): Ultrasound Selected Ophthalmic Axial Length Sequence
UnassignedPerFrameConvertedAttributesSequence | (0020,9171): Unassigned Per-Frame Converted Attributes Sequence
UnassignedSharedConvertedAttributesSequence | (0020,9170): Unassigned Shared Converted Attributes Sequence
Underlined | (0070,0248): Underlined
UnformattedTextValue | (0070,0006): Unformatted Text Value
UnifiedProcedureStepListStatus | (0074,1246): Unified Procedure Step List Status
UnifiedProcedureStepPerformedProcedureSequence | (0074,1216): Unified Procedure Step Performed Procedure Sequence
UniformResourceLocatorTrial | (0040,A992): Uniform Resource Locator (Trial)
UniqueDeviceIdentifier | (0018,1009): Unique Device Identifier
Units | (0054,1001): Units
UniversalEntityID | (0040,0032): Universal Entity ID
UniversalEntityIDType | (0040,0033): Universal Entity ID Type
UnspecifiedLateralityLensSequence | (0046,0016): Unspecified Laterality Lens Sequence
UpdatedMetadataSequence | (0008,041E): Updated Metadata Sequence
UpperCutoffFrequency | (0018,9830): Upper Cutoff Frequency
UpperLimitNumberOfPersistentFluoroscopyFrames | (0018,11B5): Upper Limit Number Of Persistent Fluoroscopy Frames
UpperLowerPixelValues | (0018,1240): Upper/Lower Pixel Values(Retired)
UrgencyOrPriorityAlertsTrial | (0040,A057): Urgency or Priority Alerts (Trial)
URNCodeValue | (0008,0120): URN Code Value
UsedFiducialsSequence | (0070,0314): Used Fiducials Sequence
UsedRTStructureSetROISequence | (0070,0315): Used RT Structure Set ROI Sequence
UsedSegmentsSequence | (0062,0012): Used Segments Sequence
UserContentLabel | (3010,0033): User Content Label
UserContentLongLabel | (3010,0034): User Content Long Label
UserSelectedGainY | (0014,408B): User Selected Gain Y
UserSelectedOffsetX | (0014,408D): User Selected Offset X
UserSelectedOffsetY | (0014,408E): User Selected Offset Y
UserSelectedPhase | (0014,408C): User Selected Phase
USImageDescriptionSequence | (0018,9806): US Image Description Sequence
UValueData | (0080,0010): U Value Data
UVMappingSequence | (0080,0008): UV Mapping Sequence
ValueType | (0040,A040): Value Type
VariableCoefficientsSDDN | (7Fxx,0040): Variable Coefficients SDDN
VariableCoefficientsSDHN | (7Fxx,0030): Variable Coefficients SDHN
VariableCoefficientsSDVN | (7Fxx,0020): Variable Coefficients SDVN
VariableFlipAngleFlag | (0018,1315): Variable Flip Angle Flag
VariableModalityLUTSequence | (0028,3001): Variable Modality LUT Sequence
VariableNextDataGroup | (7Fxx,0011): Variable Next Data Group
VariablePixelData | (7Fxx,0010): Variable Pixel Data
VectorAccuracy | (0066,0020): Vector Accuracy
VectorCoordinateData | (0066,0021): Vector Coordinate Data
VectorDimensionality | (0066,001F): Vector Dimensionality
VectorGridData | (0064,0009): Vector Grid Data
VelocityEncodingAcquisitionSequence | (0018,9092): Velocity Encoding Acquisition Sequence
VelocityEncodingDirection | (0018,9090): Velocity Encoding Direction
VelocityEncodingMaximumValue | (0018,9217): Velocity Encoding Maximum Value
VelocityEncodingMinimumValue | (0018,9091): Velocity Encoding Minimum Value
VelocityOfSound | (0014,4064): Velocity of Sound
VerbalSourceIdentifierCodeSequenceTrial | (0040,A358): Verbal Source Identifier Code Sequence (Trial)
VerbalSourceTrial | (0040,A352): Verbal Source (Trial)
VerificationDateTime | (0040,A030): Verification DateTime
VerificationFlag | (0040,A493): Verification Flag
VerificationImageTiming | (0074,1032): Verification Image Timing
VerifyingObserverIdentificationCodeSequence | (0040,A088): Verifying Observer Identification Code Sequence
VerifyingObserverName | (0040,A075): Verifying Observer Name
VerifyingObserverSequence | (0040,A073): Verifying Observer Sequence
VerifyingOrganization | (0040,A027): Verifying Organization
VertexDistance | (0022,000F): Vertex Distance
VertexPointIndexList | (0066,0025): Vertex Point Index List
VerticalAlignment | (0070,0243): Vertical Alignment
VerticalOffsetOfSensor | (0014,3026): Vertical Offset of Sensor
VerticalPrismBase | (0046,0036): Vertical Prism Base
VerticalPrismPower | (0046,0034): Vertical Prism Power
VerticesOfTheOutlineOfPupil | (0046,0208): Vertices of the Outline of Pupil
VerticesOfThePolygonalCollimator | (0018,1720): Vertices of the Polygonal Collimator
VerticesOfThePolygonalExposureControlSensingRegion | (0018,9442): Vertices of the Polygonal Exposure Control Sensing Region
VerticesOfThePolygonalOutline | (0018,1638): Vertices of the Polygonal Outline
VerticesOfThePolygonalShutter | (0018,1620): Vertices of the Polygonal Shutter
VerticesOfTheRegion | (0028,9503): Vertices of the Region
VideoImageFormatAcquired | (0018,1022): Video Image Format Acquired
ViewCodeSequence | (0054,0220): View Code Sequence
ViewingDistance | (0046,0106): Viewing Distance
ViewingDistanceType | (0046,0125): Viewing Distance Type
ViewModifierCodeSequence | (0054,0222): View Modifier Code Sequence
ViewName | (0008,2127): View Name
ViewNumber | (0008,2128): View Number
ViewOrientationCodeSequence | (0068,62E0): View Orientation Code Sequence
ViewOrientationModifierCodeSequence | (0068,62F0): View Orientation Modifier Code Sequence
ViewpointLookAtPoint | (0070,1604): Viewpoint LookAt Point
ViewpointPosition | (0070,1603): Viewpoint Position
ViewpointUpDirection | (0070,1605): Viewpoint Up Direction
ViewPosition | (0018,5101): View Position
VirtualSourceAxisDistances | (300A,030A): Virtual Source-Axis Distances
VisitComments | (0038,4000): Visit Comments
VisitStatusID | (0038,0008): Visit Status ID
VisualAcuityBothEyesOpenSequence | (0046,0124): Visual Acuity Both Eyes Open Sequence
VisualAcuityLeftEyeSequence | (0046,0123): Visual Acuity Left Eye Sequence
VisualAcuityMeasurementSequence | (0024,0110): Visual Acuity Measurement Sequence
VisualAcuityModifiers | (0046,0135): Visual Acuity Modifiers
VisualAcuityRightEyeSequence | (0046,0122): Visual Acuity Right Eye Sequence
VisualAcuityTypeCodeSequence | (0046,0121): Visual Acuity Type Code Sequence
VisualEvaluationMethodCodeSequence | (0028,702E): Visual Evaluation Method Code Sequence
VisualEvaluationResultSequence | (0028,7015): Visual Evaluation Result Sequence
VisualEvaluationTestSequence | (0028,7028): Visual Evaluation Test Sequence
VisualFieldCatchTrialSequence | (0024,0034): Visual Field Catch Trial Sequence
VisualFieldGlobalResultsIndexSequence | (0024,0320): Visual Field Global Results Index Sequence
VisualFieldHorizontalExtent | (0024,0010): Visual Field Horizontal Extent
VisualFieldMeanSensitivity | (0024,0070): Visual Field Mean Sensitivity
VisualFieldShape | (0024,0012): Visual Field Shape
VisualFieldTestDuration | (0024,0088): Visual Field Test Duration
VisualFieldTestNormalsFlag | (0024,0063): Visual Field Test Normals Flag
VisualFieldTestPointNormalsSequence | (0024,0097): Visual Field Test Point Normals Sequence
VisualFieldTestPointSequence | (0024,0089): Visual Field Test Point Sequence
VisualFieldTestPointXCoordinate | (0024,0090): Visual Field Test Point X-Coordinate
VisualFieldTestPointYCoordinate | (0024,0091): Visual Field Test Point Y-Coordinate
VisualFieldTestReliabilityGlobalIndexSequence | (0024,0317): Visual Field Test Reliability Global Index Sequence
VisualFieldVerticalExtent | (0024,0011): Visual Field Vertical Extent
VitalStainCodeSequenceTrial | (0040,09F8): Vital Stain Code Sequence (Trial)
VitreousStatusCodeSequence | (0022,1025): Vitreous Status Code Sequence
VitreousStatusDescription | (0022,1066): Vitreous Status Description
VOILUTFunction | (0028,1056): VOI LUT Function
VOILUTSequence | (0028,3010): VOI LUT Sequence
VOIType | (0072,0702): VOI Type
VolumeBasedCalculationTechnique | (0008,9207): Volume Based Calculation Technique
VolumeCroppingMethod | (0070,1302): Volume Cropping Method
VolumeCroppingSequence | (0070,1301): Volume Cropping Sequence
VolumeFrameOfReferenceUID | (0020,9312): Volume Frame of Reference UID
VolumeLocalizationSequence | (0018,9126): Volume Localization Sequence
VolumeLocalizationTechnique | (0018,9054): Volume Localization Technique
VolumeOfPTO | (4010,1023): Volume of PTO
VolumeStreamSequence | (0070,1A08): Volume Stream Sequence
VolumeToTableMappingMatrix | (0020,930A): Volume to Table Mapping Matrix
VolumeToTransducerMappingMatrix | (0020,9309): Volume to Transducer Mapping Matrix
VolumeToTransducerRelationship | (0020,930B): Volume to Transducer Relationship
VolumetricAnnotationSequence | (0070,1901): Volumetric Annotation Sequence
VolumetricCurvePoints | (0070,150D): Volumetric Curve Points
VolumetricCurveUpDirections | (0070,1A07): Volumetric Curve Up Directions
VolumetricPresentationInputAnnotationSequence | (0070,1905): Volumetric Presentation Input Annotation Sequence
VolumetricPresentationInputIndex | (0070,1804): Volumetric Presentation Input Index
VolumetricPresentationInputNumber | (0070,1207): Volumetric Presentation Input Number
VolumetricPresentationInputSetSequence | (0070,120A): Volumetric Presentation Input Set Sequence
VolumetricPresentationInputSetUID | (0070,1209): Volumetric Presentation Input Set UID
VolumetricPresentationStateInputSequence | (0070,1201): Volumetric Presentation State Input Sequence
VolumetricProperties | (0008,9206): Volumetric Properties
VValueData | (0080,0011): V Value Data
WADORetrievalSequence | (0040,E023): WADO Retrieval Sequence
WADORSRetrievalSequence | (0040,E025): WADO-RS Retrieval Sequence
WarningReason | (0008,1196): Warning Reason
WaterDepth | (0016,0033): Water Depth
WaterEquivalentDiameter | (0018,1271): Water Equivalent Diameter
WaterEquivalentDiameterCalculationMethodCodeSequence | (0018,1272): Water Equivalent Diameter Calculation Method Code Sequence
WaterReferenceAcquisition | (0018,9297): Water Reference Acquisition
WaterReferencedPhaseCorrection | (0018,9199): Water Referenced Phase Correction
WaveformAmplifierType | (003A,0317): Waveform Amplifier Type
WaveformAnnotationSequence | (0040,B020): Waveform Annotation Sequence
WaveformBitsAllocated | (5400,1004): Waveform Bits Allocated
WaveformBitsStored | (003A,021A): Waveform Bits Stored
WaveformChannelNumber | (003A,0202): Waveform Channel Number
WaveformData | (5400,1010): Waveform Data
WaveformDataDisplayScale | (003A,0230): Waveform Data Display Scale
WaveformDisplayBackgroundCIELabValue | (003A,0231): Waveform Display Background CIELab Value
WaveformFilterDescription | (003A,0329): Waveform Filter Description
WaveformFilterType | (003A,0322): Waveform Filter Type
WaveformOriginality | (003A,0004): Waveform Originality
WaveformPaddingValue | (5400,100A): Waveform Padding Value
WaveformPresentationGroupSequence | (003A,0240): Waveform Presentation Group Sequence
WaveformSampleInterpretation | (5400,1006): Waveform Sample Interpretation
WaveformSequence | (5400,0100): Waveform Sequence
WedgeAngle | (300A,00D5): Wedge Angle
WedgeAngleFloat | (0014,5107): Wedge Angle Float
WedgeChamferHeight | (0014,511D): Wedge Chamfer Height
WedgeCurve | (0014,511E): Wedge Curve
WedgeDefinitionSequence | (300A,0651): Wedge Definition Sequence
WedgeDescription | (0014,5111): Wedge Description
WedgeElement1Position | (0014,5109): Wedge Element 1 Position
WedgeFactor | (300A,00D6): Wedge Factor
WedgeFrontGap | (0014,5117): Wedge Front Gap
WedgeFrontHeight | (0014,5119): Wedge Front Height
WedgeID | (300A,00D4): Wedge ID
WedgeInContactLength | (0014,5116): Wedge In Contact Length
WedgeInContactWidth | (0014,511C): Wedge In Contact Width
WedgeManufacturerName | (0014,5110): Wedge Manufacturer Name
WedgeMaterial | (0014,510B): Wedge Material
WedgeMaterialVelocity | (0014,510A): Wedge Material Velocity
WedgeModelNumber | (0014,5106): Wedge Model Number
WedgeName | (0014,510F): Wedge Name
WedgeNumber | (300A,00D2): Wedge Number
WedgeOffsetX | (0014,5113): Wedge Offset X
WedgeOffsetY | (0014,5114): Wedge Offset Y
WedgeOffsetZ | (0014,510C): Wedge Offset Z
WedgeOrientation | (300A,00D8): Wedge Orientation
WedgeOriginOffsetX | (0014,510D): Wedge Origin Offset X
WedgePosition | (300A,0118): Wedge Position
WedgePositionSequence | (300A,0116): Wedge Position Sequence
WedgeRearHeight | (0014,511A): Wedge Rear Height
WedgeRoofAngle | (0014,5108): Wedge Roof Angle
WedgeSequence | (300A,00D1): Wedge Sequence
WedgeThinEdgePosition | (300A,00DB): Wedge Thin Edge Position
WedgeTimeDelay | (0014,510E): Wedge Time Delay
WedgeTotalHeight | (0014,5118): Wedge Total Height
WedgeTotalLength | (0014,5115): Wedge Total Length
WedgeTotalWidth | (0014,511B): Wedge Total Width
WedgeType | (300A,00D3): Wedge Type
WeekdayFractionPatternSequence | (3010,0087): Weekday Fraction Pattern Sequence
WeightingLookupTableData | (0070,1808): Weighting Lookup Table Data
WeightingLookupTableDescriptor | (0070,1807): Weighting Lookup Table Descriptor
WeightingTransferFunctionSequence | (0070,1806): Weighting Transfer Function Sequence
WhiteBalance | (0016,0043): White Balance
WhitePoint | (0016,0001): White Point
WhitePointFlag | (0028,7021): White Point Flag
WholeBodyTechnique | (0018,1301): Whole Body Technique
WholeSlideMicroscopyImageFrameTypeSequence | (0040,0710): Whole Slide Microscopy Image Frame Type Sequence
WideFieldOphthalmicPhotographyQualityRatingSequence | (0022,1525): Wide Field Ophthalmic Photography Quality Rating Sequence
WideFieldOphthalmicPhotographyQualityThresholdSequence | (0022,1526): Wide Field Ophthalmic Photography Quality Threshold Sequence
WideFieldOphthalmicPhotographyThresholdQualityRating | (0022,1527): Wide Field Ophthalmic Photography Threshold Quality Rating
WindowCenter | (0028,1050): Window Center
WindowCenterWidthExplanation | (0028,1055): Window Center & Width Explanation
WindowWidth | (0028,1051): Window Width
WorklistLabel | (0074,1202): Worklist Label
XAAcquisitionDuration | (0018,11BD): XA Acquisition Duration
XAAcquisitionFrameRate | (0018,11B9): XA Acquisition Frame Rate
XAAcquisitionPhaseDetailsSequence | (0018,11B8): XA Acquisition Phase Details Sequence
XAPlaneDetailsSequence | (0018,11BA): XA Plane Details Sequence
XAXRFFrameCharacteristicsSequence | (0018,9412): XA/XRF Frame Characteristics Sequence
XCoordinatesCenterPixelViewAngle | (0022,1528): X Coordinates Center Pixel View Angle
XDSRetrievalSequence | (0040,E024): XDS Retrieval Sequence
XDSStorageSequence | (0040,4074): XDS Storage Sequence
XFocusCenter | (0018,1183): X Focus Center
XOffsetInSlideCoordinateSystem | (0040,072A): X Offset in Slide Coordinate System
XRay3DAcquisitionSequence | (0018,9507): X-Ray 3D Acquisition Sequence
XRay3DFrameTypeSequence | (0018,9504): X-Ray 3D Frame Type Sequence
XRay3DReconstructionSequence | (0018,9530): X-Ray 3D Reconstruction Sequence
XRayAcquisitionDoseSequence | (0018,9542): X-Ray Acquisition Dose Sequence
XRayDetectorID | (0018,9371): X-Ray Detector ID
XRayDetectorIndex | (0018,9370): X-Ray Detector Index
XRayDetectorLabel | (0018,9373): X-Ray Detector Label
XRayFilterDetailsSequence | (0018,11BC): X-Ray Filter Details Sequence
XRayFilterSequence | (0018,9556): X-Ray Filter Sequence
XRayGeometrySequence | (0018,9476): X-Ray Geometry Sequence
XRayGridSequence | (0018,9555): X-Ray Grid Sequence
XRayImageReceptorAngle | (3002,000E): X-Ray Image Receptor Angle
XRayImageReceptorTranslation | (3002,000D): X-Ray Image Receptor Translation
XRayMassAttenuationCoefficient | (0018,9384): X-Ray Mass Attenuation Coefficient
XRayOutput | (0040,0312): X-Ray Output
XRayReceptorType | (0018,9420): X-Ray Receptor Type
XRaySourceID | (0018,9367): X-Ray Source ID
XRaySourceIndex | (0018,9366): X-Ray Source Index
XRaySourceIsocenterPrimaryAngle | (0018,9543): X-Ray Source Isocenter Primary Angle
XRaySourceIsocenterSecondaryAngle | (0018,9544): X-Ray Source Isocenter Secondary Angle
XRayTubeCurrent | (0018,1151): X-Ray Tube Current
XRayTubeCurrentInmA | (0018,9330): X-Ray Tube Current in mA
XRayTubeCurrentInuA | (0018,8151): X-Ray Tube Current in µA
YCoordinatesCenterPixelViewAngle | (0022,1529): Y Coordinates Center Pixel View Angle
YFocusCenter | (0018,1184): Y Focus Center
YOffsetInSlideCoordinateSystem | (0040,073A): Y Offset in Slide Coordinate System
ZEffective | (4010,1019): Z Effective
ZeroVelocityPixelValue | (0018,9810): Zero Velocity Pixel Value
ZOffsetInSlideCoordinateSystem | (0040,074A): Z Offset in Slide Coordinate System
ZonalMap | (1010,xxxx): Zonal Map
ZonalMapFormat | (0028,0722): Zonal Map Format
ZonalMapLocation | (0028,0721): Zonal Map Location
ZonalMapNumberFormat | (0028,0720): Zonal Map Number Format
ZoomCenter | (0028,0032): Zoom Center
ZoomFactor | (0028,0031): Zoom Factor
    Inheritance Hierarchy

    System.Object
    System.ValueType
    System.Enum
    DicomObjects.Enums.Keyword

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomObjects.Enums Namespace


%%PageItemTitle%%

DicomObjects.Enums Namespace / LabelType Enumeration

    LabelType Enumeration
    In This Topic
    The possible types of DicomObjects.DicomLabel
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Enum LabelType
   Inherits System.Enum
    'Usage

    Dim instance As LabelType
    public enum LabelType : System.Enum
    Members
    Member | Description
Arc | Arc
Arrow | Arrow
Bitmap | Bitmap - i.e. a set of points - see Image for a picture
Ellipse | Ellipse or Circle
Formatted | Formatted with Macros
Image | An arbitrary Image .NET object
Line | Line
Polygon | Polygon
PolyLine | PolyLine
Rectangle | Rectangle or Square
ReferenceLine | Dynamic Reference Line
Ruler | Ruler (Scale)
Special | Anatomic Side Markers
Text | Text
    Inheritance Hierarchy

    System.Object
    System.ValueType
    System.Enum
    DicomObjects.Enums.LabelType

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomObjects.Enums Namespace


%%PageItemTitle%%

DicomObjects.Enums Namespace / LicencedFunctions Enumeration

    LicencedFunctions Enumeration
    In This Topic
    A bitmask representing the functions that a particular licence allows to be used by DicomObjects.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    <FlagsAttribute()>
Public Enum LicencedFunctions
   Inherits System.Enum
    'Usage

    Dim instance As LicencedFunctions
    [Flags()]
public enum LicencedFunctions : System.Enum
    Members
    Member | Description
Acceptor | Allows listening for and accepting new associations
CompositeSCP | Allows use as a Query/Retrieve SCP
Initiator | Allows associations to be initiated
NormalisedSCP | Allows use as an SCP for normalised services
Read | Allows reading and importing of images
Write | Allows writing and exporting of images
    Inheritance Hierarchy

    System.Object
    System.ValueType
    System.Enum
    DicomObjects.Enums.LicencedFunctions

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomObjects.Enums Namespace


%%PageItemTitle%%

DicomObjects.Enums Namespace / LicenceTypes Enumeration

    LicenceTypes Enumeration
    In This Topic
    Indicates the basic type of DicomObjects licence
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Enum LicenceTypes
   Inherits System.Enum
    'Usage

    Dim instance As LicenceTypes
    public enum LicenceTypes : System.Enum
    Members
    Member | Description
Demo | Allows use for demonstrations
Developer | Use for development and testing only
Full | Full commercial licence for production use
Trial | Allows use for evaluation only
    Inheritance Hierarchy

    System.Object
    System.ValueType
    System.Enum
    DicomObjects.Enums.LicenceTypes

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomObjects.Enums Namespace


%%PageItemTitle%%

DicomObjects.Enums Namespace / LogLevel Enumeration

    LogLevel Enumeration
    In This Topic
    Log levels
    Syntax
    • Visual Basic
    • C#
    'Declaration

    <FlagsAttribute()>
Public Enum LogLevel
   Inherits System.Enum
    'Usage

    Dim instance As LogLevel
    [Flags()]
public enum LogLevel : System.Enum
    Members
    Member | Description
ALLBYTESIN | Full incoming network traffic
ALLBYTESOUT | Full outgoing network traffic
CACHE | Detailed cache usage data (only on specific test builds)
CODEC | Detailed codec logging (e.g. loading of codecs)
DEBUG | Specialist debug data (only on specific test builds)
DETAILED | Detailed informational messages
ELEMENTSIN | Interpetted version of incoming attributes (file and network)
ELEMENTSOUT | Interpetted version of outgoing attributes (file and network)
ERROR | Errors
HIGH | Detailed byte level log (includes all levels)
JPIP | Detailed JPIP logging
LIMITEDBYTESIN | PDU and PDV headers for incoming network traffic
LIMITEDBYTESOUT | PDU and PDV headers for outgong network traffic
LOG | Miscellaneous informational messages
LOW | Errors and main events only
MEDIUM | Most data incoming and outgoing, errors and warnings
PROFILE | Profiling data (only on specific test builds)
WARNING | Warnings
    Remarks
    These are a bit filed and may be combined as required, though common values are:
    • 7: errors, warning and information
    • 63 (3F): Basic attributes in and out
    • Full byte level for network operations
    Inheritance Hierarchy

    System.Object
    System.ValueType
    System.Enum
    DicomObjects.Enums.LogLevel

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomObjects.Enums Namespace


%%PageItemTitle%%

DicomObjects.Enums Namespace / MaskMode Enumeration

    MaskMode Enumeration
    In This Topic
    Enumerated values for mask operations
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Enum MaskMode
   Inherits System.Enum
    'Usage

    Dim instance As MaskMode
    public enum MaskMode : System.Enum
    Members
    Member | Description
AverageSubtraction | The frames specified by the MaskFrames property are averaged together, shifted by the amount specified in the MaskShift property, then subtracted from the contrast frames in the range specified in the ApplicableFrames property.
Maximum | In this mode, value of the frames specified by the MaskFrames property are compaired against the contrast frames specified in the ApplicableFrames property, the maximum value is then used for Rendering.
Minimum | In this mode, value of the frames specified by the MaskFrames property are compaired against the contrast frames specified in the ApplicableFrames property, the minimum value is then used for Rendering.
None | No mask subtraction operation is specified
ReverseTimeDifference | This is the reversed Time Interval Differencing mode, in which the number of the mask frame for each contrast frame is calculated by subtracting TID Offset from the first frame within the Applicable Frame Range, TID Offset+2 from the second frame within the Applicable Frame Range, TID Offset+4 from the third frame and so on.
TimeDifference | The mask for each frame within the Applicable Frames range, specified by the ApplicableFrames property, is selected by subtracting the value (specified by TIDOffset property) from the respective frame number.
    Inheritance Hierarchy

    System.Object
    System.ValueType
    System.Enum
    DicomObjects.Enums.MaskMode

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomObjects.Enums Namespace


%%PageItemTitle%%

DicomObjects.Enums Namespace / Plane Enumeration

    Plane Enumeration
    In This Topic
    Common planes used to display 3D images
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Enum Plane
   Inherits System.Enum
    'Usage

    Dim instance As Plane
    public enum Plane : System.Enum
    Members
    Member | Description
Axial | Typical a cross-section of a patient
Coronal | A slice as if viewed from the front/back
Sagittal | A slice as if viewed from the side
Unchanged | As special Plane, which when used in DicomImage3D.SetViewPlane indicates the view plane should be left unaltered.
    Inheritance Hierarchy

    System.Object
    System.ValueType
    System.Enum
    DicomObjects.Enums.Plane

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomObjects.Enums Namespace


%%PageItemTitle%%

DicomObjects.Enums Namespace / PresentationStateFeatures Enumeration

In This Topic
    PresentationStateFeatures Enumeration
    In This Topic
    Flags to control which features of presentation states are used and/or converted
    Syntax
    • Visual Basic
    • C#
    'Declaration

    <FlagsAttribute()>
Public Enum PresentationStateFeatures
   Inherits System.Enum
    'Usage

    Dim instance As PresentationStateFeatures
    [Flags()]
public enum PresentationStateFeatures : System.Enum
    Members
    Member | Description
All | All features
DisplayArea | Selection of part of image for display
Gamma | Use of the Gamma property. Note that gamma is not part of the presentation state definition, but by default (if this bit is set), DicomObjects disables Gamma when a PS is applied to maintain consistency.
GraphicAnnotations | Graphical Annotations
Masking | Masking / Subtraction
ModalityTransform | Modality Transform - i.e. rescale slope and intercept or Modality LUT
Overlays | overlays activated or help by the presentation state
PresentationTransform | Presentation Transform - i.e. inversion or Presentation LUT
Shutters | Shutters defined
SpatialTransform | Rotate/flip etc.
TextAnnotations | Text Annotations
VoiTransform | VOI Transform - i.e. windowing or VOI LUT
    Inheritance Hierarchy

    System.Object
    System.ValueType
    System.Enum
    DicomObjects.Enums.PresentationStateFeatures

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomObjects.Enums Namespace


%%PageItemTitle%%

DicomObjects.Enums Namespace / Progression Enumeration

    Progression Enumeration
    In This Topic
    Ordering of packet used in JPEG 2000 & JPIP
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Enum Progression
   Inherits System.Enum
    'Usage

    Dim instance As Progression
    public enum Progression : System.Enum
    Members
    Member | Description
CPRL | Component Position Resolution Layer
LRCP | Layer Resolution Component Position
PCRL | Position Component Resolution Layer
RLCP | Resolution Layer Component Position
RPCL | Resolution Position Component Layer
    Inheritance Hierarchy

    System.Object
    System.ValueType
    System.Enum
    DicomObjects.Enums.Progression

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomObjects.Enums Namespace


%%PageItemTitle%%

DicomObjects.Enums Namespace / ProgressiveStatus Enumeration

    ProgressiveStatus Enumeration
    In This Topic
    The status of an image being viewed in a progressive manner
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Enum ProgressiveStatus
   Inherits System.Enum
    'Usage

    Dim instance As ProgressiveStatus
    public enum ProgressiveStatus : System.Enum
    Members
    Member | Description
Incomplete | The image is currently being retrieved, and will update asynchronously
NotStarted | The meta data and JPEG 2000 Header have not yet been retrieved/
RequiredResolution | All data available and needed for the current display area and resolution has been received, but more may be available if the area or magnification change.
WholeImage | All available data for the image has been retrieved.
    Remarks

    This enumeration is currently only used for JPIP, but is generic, and could be used for other similar transports in the future.

    Note that the values are strictly ordered allowing greater and lesser comparisons to be used.

    Inheritance Hierarchy

    System.Object
    System.ValueType
    System.Enum
    DicomObjects.Enums.ProgressiveStatus

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomObjects.Enums Namespace


%%PageItemTitle%%

DicomObjects.Enums Namespace / QueryLevel Enumeration

    QueryLevel Enumeration
    In This Topic
    Enumerated values for Query Level
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Enum QueryLevel
   Inherits System.Enum
    'Usage

    Dim instance As QueryLevel
    public enum QueryLevel : System.Enum
    Members
    Member | Description
FRAME | Frame level as per supplment 119
IMAGE | IMAGE level for query
INSTANCE | Equivalent to IMAGE level
NONE | No level specified
PATIENT | PATIENT level for query
SERIES | SERIES level for query
STUDY | STUDY level for query
    Inheritance Hierarchy

    System.Object
    System.ValueType
    System.Enum
    DicomObjects.Enums.QueryLevel

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomObjects.Enums Namespace


%%PageItemTitle%%

DicomObjects.Enums Namespace / QueryRoot Enumeration

    QueryRoot Enumeration
    In This Topic
    Enumerated values for Query Root
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Enum QueryRoot
   Inherits System.Enum
    'Usage

    Dim instance As QueryRoot
    public enum QueryRoot : System.Enum
    Members
    Member | Description
CompositeInstance | Composite Instance Root
GeneralPurposeWorklist | Root for General Purpose Worklist query
ModalityWorklist | Root for Modality Worklist query
None | No root specified
Patient | Patient Root
PatientStudyOnly | A combined root of Patient and Study
Study | Study Root
UnifiedProcedureStep | Root for UPS query
    Inheritance Hierarchy

    System.Object
    System.ValueType
    System.Enum
    DicomObjects.Enums.QueryRoot

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomObjects.Enums Namespace


%%PageItemTitle%%

DicomObjects.Enums Namespace / RequestType Enumeration

    RequestType Enumeration
    In This Topic
    Enum used in the DicomObjects.Internal.PixelRequest class to pecify the required usage of the data requested
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Enum RequestType
   Inherits System.Enum
    'Usage

    Dim instance As RequestType
    public enum RequestType : System.Enum
    Members
    Member | Description
Background | Low priority background request to satisfy a possible future requirement
Display | Data is for display - i.e. it will may be acquired asynchronously
Synchronous | Data must be acquired synchronously (e.g. for Writing out, or generating a bitmap etc.)
    Inheritance Hierarchy

    System.Object
    System.ValueType
    System.Enum
    DicomObjects.Enums.RequestType

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomObjects.Enums Namespace


%%PageItemTitle%%

DicomObjects.Enums Namespace / RetrieveType Enumeration

    RetrieveType Enumeration
    In This Topic
    The type of retrieval requested
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Enum RetrieveType
   Inherits System.Enum
    'Usage

    Dim instance As RetrieveType
    public enum RetrieveType : System.Enum
    Members
    Member | Description
Full | Full Data
NoBulkData | Remove all bulk data before sending
    Remarks
    Until 2009, all DICOM retrievals were "Full", but supplement 119 introduced the concept of "No Bulk data" retrieval which is indicated in the EventArguments.QueryReceivedArgs by a property of this type.
    Inheritance Hierarchy

    System.Object
    System.ValueType
    System.Enum
    DicomObjects.Enums.RetrieveType

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomObjects.Enums Namespace


%%PageItemTitle%%

DicomObjects.Enums Namespace / RotateState Enumeration

    RotateState Enumeration
    In This Topic
    Enumerated values for rotate mode
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Enum RotateState
   Inherits System.Enum
    'Usage

    Dim instance As RotateState
    public enum RotateState : System.Enum
    Members
    Member | Description
Full | Image is rotated 180°
Left | Image is rotated 90° counter-clockwise
Normal | No Rotate mode is specified
Right | Image is rotated 90° clockwise
    Inheritance Hierarchy

    System.Object
    System.ValueType
    System.Enum
    DicomObjects.Enums.RotateState

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomObjects.Enums Namespace


%%PageItemTitle%%

DicomObjects.Enums Namespace / RotationBehaviour Enumeration

    RotationBehaviour Enumeration
    In This Topic
    Rotation behaviour of the Image
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Enum RotationBehaviour
   Inherits System.Enum
    'Usage

    Dim instance As RotationBehaviour
    public enum RotationBehaviour : System.Enum
    Members
    Member | Description
BoundingBox | The top left position is defined as the top left corner of the bounding box which surrounds the rotated image.
FixedCentrePoint | The top left position is defined as being where the top left corner of the image would be if it were not rotated. If the image is rotated, it will rotate around the centre point of that non rotated position
    Inheritance Hierarchy

    System.Object
    System.ValueType
    System.Enum
    DicomObjects.Enums.RotationBehaviour

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomObjects.Enums Namespace


%%PageItemTitle%%

DicomObjects.Enums Namespace / RotationCentre Enumeration

    RotationCentre Enumeration
    In This Topic
    Possible values for controlling the centre of rotation of a text label.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Enum RotationCentre
   Inherits System.Enum
    'Usage

    Dim instance As RotationCentre
    public enum RotationCentre : System.Enum
    Members
    Member | Description
AutoSizeCentre | The rotation point is the centre of the chosen text area, as defined by the AutoSizeMode property
LabelCentre | The rotation point is the centre of the originally defined label, as defined by it's Area property
SpecifiedPoint | The rotation point is the point specified by the RotationPoint property
TextCentre | The rotation point is the centre of the calculated text area - irrespective of the value of AutoSizeMode property
    Remarks
    These values are used for 2 purposes:
    • When an explicit rotation is applied to a label
    • When an image is rotated, but the label is not rotated due to the setting of the RotationMode which therefore requires that the label be rotated relative to the image.
    Inheritance Hierarchy

    System.Object
    System.ValueType
    System.Enum
    DicomObjects.Enums.RotationCentre

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomObjects.Enums Namespace


%%PageItemTitle%%

DicomObjects.Enums Namespace / RotationMode Enumeration

    RotationMode Enumeration
    In This Topic
    Possible values for controlling the rotation behaviour of a label.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Enum RotationMode
   Inherits System.Enum
    'Usage

    Dim instance As RotationMode
    public enum RotationMode : System.Enum
    Members
    Member | Description
CentreToRotationPoint | Move label position so that it remains centred on the rotation point as defined by RotationBehaviour.FixedCentrePoint
Default | Non-text labels rotate, but text labels do not.
NoRotate | The label does not rotate if the image is rotated
WithImage | The label rotates with the image (provided that label is set to ScaleMode.Image)
    Remarks
    This is used by the DicomLabel's RotationMode property.
    Inheritance Hierarchy

    System.Object
    System.ValueType
    System.Enum
    DicomObjects.Enums.RotationMode

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomObjects.Enums Namespace


%%PageItemTitle%%

DicomObjects.Enums Namespace / RulerOptions Enumeration

    RulerOptions Enumeration
    In This Topic
    Ruler options to for alignment and spacing
    Syntax
    • Visual Basic
    • C#
    'Declaration

    <FlagsAttribute()>
Public Enum RulerOptions
   Inherits System.Enum
    'Usage

    Dim instance As RulerOptions
    [Flags()]
public enum RulerOptions : System.Enum
    Members
    Member | Description
AlignCentre | Centered within the cell area for all changes
AlignFar | If truncated, Ruler label will be placed at the far-side of the cell area (opposite of AlignNear)
AlignNear | This is the default behaviour. Ruler label will be placed within the defined cell area and if shortened it will remain attached to top of the defined area
RoundToLarge | If set any small division beyond the large division will be ignored. In other words, only the large divisions will be displayed/updated as the length of the ruler
    Inheritance Hierarchy

    System.Object
    System.ValueType
    System.Enum
    DicomObjects.Enums.RulerOptions

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomObjects.Enums Namespace


%%PageItemTitle%%

DicomObjects.Enums Namespace / ScaleMode Enumeration

    ScaleMode Enumeration
    In This Topic
    How DicomLabel objects' dimensions should be interpreted - i.e. how they should be scaled
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Enum ScaleMode
   Inherits System.Enum
    'Usage

    Dim instance As ScaleMode
    public enum ScaleMode : System.Enum
    Members
    Member | Description
Cell | Dimensions are in the coordinate system used by DICOM in presentation states, where (0.0,0.0) represents the top left corner of the display area, and (1.0,1.0) represents the bottom right
Cell1000 | Like Cell, but the corners are (0,0) and (1000,1000)
Image | Dimensions are in image pixels
Image3D | Used to specify points in 3D space using images' frame of reference
Output | Dimensions are in screen or other output device pixels and are unaffected by the zooming of the image
    Inheritance Hierarchy

    System.Object
    System.ValueType
    System.Enum
    DicomObjects.Enums.ScaleMode

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomObjects.Enums Namespace


%%PageItemTitle%%

DicomObjects.Enums Namespace / SelectMode Enumeration

    SelectMode Enumeration
    In This Topic
    Enumerated values for DicomLabel select mode
    Syntax
    • Visual Basic
    • C#
    'Declaration

    <FlagsAttribute()>
Public Enum SelectMode
   Inherits System.Enum
    'Usage

    Dim instance As SelectMode
    [Flags()]
public enum SelectMode : System.Enum
    Members
    Member | Description
AllHandles | Handles are drawn at all relevant "Points" (This only applies to labels of type doLabelPolygon, doLabelPolyline & doLabelArc)
Box | A bounding box is drawn around the label
BoxHandles | Handles are drawn at the corners of the above box
None | No highlighting
    Remarks
    Although defined as enumerated types, the values above can be (and normally are) used as bit fields, so the value doSelectBox + doSelectBoxHandles gives a bounding box with visible corners.
    Inheritance Hierarchy

    System.Object
    System.ValueType
    System.Enum
    DicomObjects.Enums.SelectMode

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomObjects.Enums Namespace


%%PageItemTitle%%

DicomObjects.Enums Namespace / ShadowTypes Enumeration

    ShadowTypes Enumeration
    In This Topic
    Controls whether a labels is displayed with a specified shadow, to make it more visible over image areas with similar color.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    <FlagsAttribute()>
Public Enum ShadowTypes
   Inherits System.Enum
    'Usage

    Dim instance As ShadowTypes
    [Flags()]
public enum ShadowTypes : System.Enum
    Members
    Member | Description
All | 256
Bottom | 32
BottomLeft | 64
BottomRight | 16
Left | 128
None | 0
Right | 8
Top | 2
TopLeft | 1
TopRight | 4
    Remarks

    Although defined as enumerated types, the values above can be (and normally are) combined and used as bit fields.

    The shadow is drawn in the direction(s) indicated above displaced by one pixel from the main label, and it is drawn using the label’s ShadowColor property.

    Inheritance Hierarchy

    System.Object
    System.ValueType
    System.Enum
    DicomObjects.Enums.ShadowTypes

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomObjects.Enums Namespace


%%PageItemTitle%%

DicomObjects.Enums Namespace / SOPClassGroups Enumeration

    SOPClassGroups Enumeration
    In This Topic
    The categories of SOP class used for negotiation
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Enum SOPClassGroups
   Inherits System.Enum
    'Usage

    Dim instance As SOPClassGroups
    public enum SOPClassGroups : System.Enum
    Members
    Member | Description
Images16Bit | DICOM Images expected to contain up to 16 bit pixel data
Images1Bit | DICOM Images expected to contain only 1 bit pixel data
Images32Bit | DICOM Images expected to contain up to 32 bit pixel data
Images8Bit | DICOM Images expected to contain only 8 bit pixel data
ImplicitVrOnly | Special group for objects at risk of exceeding 64k for attributes with 2 byte lengths
NonImageObjects | Persistent DICOM objects without pixel data
Services | DICOM Services such as verification and C-GET etc.
User1 | User group for custom SOP class/transfer syntax definitions
User2 | User group for custom SOP class/transfer syntax definitions
User3 | User group for custom SOP class/transfer syntax definitions
    Remarks
    These groups are used as indices for the DicomGlobal.SOPClassGroup, DicomGlobal.OfferedTransferSyntaxes and DicomGlobal.AcceptedTransferSyntaxes indexed properties
    Inheritance Hierarchy

    System.Object
    System.ValueType
    System.Enum
    DicomObjects.Enums.SOPClassGroups

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomObjects.Enums Namespace


%%PageItemTitle%%

DicomObjects.Enums Namespace / StatusCode Enumeration

    StatusCode Enumeration
    In This Topic
    Common DICOM status codes
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Enum StatusCode
   Inherits System.Enum
    'Usage

    Dim instance As StatusCode
    public enum StatusCode : System.Enum
    Members
    Member | Description
AttributeListError | Attribute List Error
AttributeValueOutOfRange | Attribute Value Out of Range
Cancel | Operation cancelled
ClassInstanceConflict | Class-instance conflict
DuplicateInvocation | Duplicate invocation
DuplicateSOPInstance | Duplicate SOP instance
InvalidArgumentValue | Invalid argument value
InvalidAttributeValue | Invalid attribute value
InvalidObjectInstance | Invalid object instance
MissingAttribute | Missing attribute
MissingAttributeValue | Missing attribute value
MistypedArgument | Mistyped argument
NoSuchActionType | No such action type
NoSuchArgument | No such argument
NoSuchAttribute | No such attribute
NoSuchEventType | No such event type
NoSuchObjectInstance | No such object instance
NoSuchSOPClass | No such SOP class
ProcessingFailure | Processing failure
ResourceLimitation | Resource limitation
SOPClassNotSupported | SOP class not supported
Success | Operation successful
UnrecognizedOperation | Unrecognized operation
    Inheritance Hierarchy

    System.Object
    System.ValueType
    System.Enum
    DicomObjects.Enums.StatusCode

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomObjects.Enums Namespace


%%PageItemTitle%%

DicomObjects.Enums Namespace / StatusType Enumeration

    StatusType Enumeration
    In This Topic
    DICOM status code type
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Enum StatusType
   Inherits System.Enum
    'Usage

    Dim instance As StatusType
    public enum StatusType : System.Enum
    Members
    Member | Description
Cancel | Cancel status code
Failure | Failure status code
Pending | Pending status code
Success | Success status code
Unknown | Not a DICOM defined status code
Warning | Warning status code
    Inheritance Hierarchy

    System.Object
    System.ValueType
    System.Enum
    DicomObjects.Enums.StatusType

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomObjects.Enums Namespace


%%PageItemTitle%%

DicomObjects.Enums Namespace / StretchModes Enumeration

    StretchModes Enumeration
    In This Topic
    Controls how an image is displayed
    Syntax
    • Visual Basic
    • C#
    'Declaration

    <FlagsAttribute()>
Public Enum StretchModes
   Inherits System.Enum
    'Usage

    Dim instance As StretchModes
    [Flags()]
public enum StretchModes : System.Enum
    Members
    Member | Description
NoStretch | Not stretched at all - display depends on DicomObjects.DicomImage.Zoom and Scroll properties. If rotated, image position will be calculated as if non-rotated, the moved by Scroll and then finally rotated around its centre point.
StretchCentred | Fitted to the available size, and centered within that
StretchTopLeft | Fitted to the available size, but placed in the top left corner
TrueSize | Similar to NoStretch, but image will be zoomed and rotated and the top-left of its bounding box calculated to provide a reference position before the Scroll is applied.
    Remarks
    The replaces the previous StrecthToFit property, but has additional flexibility
    Inheritance Hierarchy

    System.Object
    System.ValueType
    System.Enum
    DicomObjects.Enums.StretchModes

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomObjects.Enums Namespace


%%PageItemTitle%%

DicomObjects.Enums Namespace / SubscribeTargetResource Enumeration

In This Topic
    SubscribeTargetResource Enumeration
    In This Topic
    UPS Subscribe Target Resource
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Enum SubscribeTargetResource
   Inherits System.Enum
    'Usage

    Dim instance As SubscribeTargetResource
    public enum SubscribeTargetResource : System.Enum
    Members
    Member | Description
FilteredWorklist | Target resource is filtered worklist
Workitem | Target resource is workitem
Worklist | Target resource is worklist
    Inheritance Hierarchy

    System.Object
    System.ValueType
    System.Enum
    DicomObjects.Enums.SubscribeTargetResource

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomObjects.Enums Namespace


%%PageItemTitle%%

DicomObjects.Enums Namespace / UIDType Enumeration

    UIDType Enumeration
    In This Topic
    Classification of DICOM UID types
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Enum UIDType
   Inherits System.Enum
    'Usage

    Dim instance As UIDType
    public enum UIDType : System.Enum
    Members
    Member | Description
ApplicationContext | The single DICOM Application Context
FrameOfReference | Well-known frames of reference
Image16Bit | DICOM Images expected to contain up to 16 bit pixel data
Image1Bit | DICOM Images containing only 1 bit pixel data
Image32Bit | DICOM Images expected to contain up to 32 bit pixel data
Image8Bit | DICOM Images expected to contain only 8 bit pixel data
MetaSOPClass | A DICOM Meta SOP class
NonImageObject | Persistent DICOM objects without pixel data
Service | DICOM Services such as verification and C-GET etc.
TransferSyntax | A DICOM Transfer Syntax
WellKnownInstance | Well-known fixed DICOM Instances
    Inheritance Hierarchy

    System.Object
    System.ValueType
    System.Enum
    DicomObjects.Enums.UIDType

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomObjects.Enums Namespace


%%PageItemTitle%%

DicomObjects.Enums Namespace / UPSState Enumeration

    UPSState Enumeration
    In This Topic
    Progress of a Unified Procedure Step (UPS)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Enum UPSState
   Inherits System.Enum
    'Usage

    Dim instance As UPSState
    public enum UPSState : System.Enum
    Members
    Member | Description
CANCELLED | UPS is Cancelled
COMPLETED | UPS is Completed
INPROGRESS | UPS is Scheduled
SCHEDULED | UPS is In-Progress
    Inheritance Hierarchy

    System.Object
    System.ValueType
    System.Enum
    DicomObjects.Enums.UPSState

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomObjects.Enums Namespace


%%PageItemTitle%%

DicomObjects.Enums Namespace / UserIdentityResponseType Enumeration

In This Topic
    UserIdentityResponseType Enumeration
    In This Topic
    User Identity Response Type for User Identity Negotiation
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Enum UserIdentityResponseType
   Inherits System.Enum
    'Usage

    Dim instance As UserIdentityResponseType
    public enum UserIdentityResponseType : System.Enum
    Members
    Member | Description
NoResponseRequested | No response requested
PositiveResponseRequested | Positive response requested
    Inheritance Hierarchy

    System.Object
    System.ValueType
    System.Enum
    DicomObjects.Enums.UserIdentityResponseType

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomObjects.Enums Namespace


%%PageItemTitle%%

DicomObjects.Enums Namespace / UserIdentityType Enumeration

    UserIdentityType Enumeration
    In This Topic
    User Identity Type for User Identity Negotiation
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Enum UserIdentityType
   Inherits System.Enum
    'Usage

    Dim instance As UserIdentityType
    public enum UserIdentityType : System.Enum
    Members
    Member | Description
JsonWebToken | JSON Web Token (JWT)
Kerberos | Kerberos Service ticket
SamlAssertion | SAML Assertion
UserName | Username as a string in UTF-8
UserNameAndPassword | Username as a string in UTF-8 and passcode
    Inheritance Hierarchy

    System.Object
    System.ValueType
    System.Enum
    DicomObjects.Enums.UserIdentityType

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomObjects.Enums Namespace


%%PageItemTitle%%

DicomObjects.Enums Namespace / ViewerMode Enumeration

    ViewerMode Enumeration
    In This Topic
    The modes which can be used for rendering image
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Enum ViewerMode
   Inherits System.Enum
    'Usage

    Dim instance As ViewerMode
    public enum ViewerMode : System.Enum
    Members
    Member | Description
Default | Using Gdi objects
    Inheritance Hierarchy

    System.Object
    System.ValueType
    System.Enum
    DicomObjects.Enums.ViewerMode

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomObjects.Enums Namespace


%%PageItemTitle%%

DicomObjects.Enums Namespace / VoiLUTFunction Enumeration

    VoiLUTFunction Enumeration
    In This Topic
    Controls which VOILUT function to be used
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Enum VoiLUTFunction
   Inherits System.Enum
    'Usage

    Dim instance As VoiLUTFunction
    public enum VoiLUTFunction : System.Enum
    Members
    Member | Description
Linear | Linear Windowing
Sigmoid | Sigmoide Window function
    Remarks
    Default value is Linear
    Inheritance Hierarchy

    System.Object
    System.ValueType
    System.Enum
    DicomObjects.Enums.VoiLUTFunction

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomObjects.Enums Namespace


%%PageItemTitle%%

DicomObjects.Enums Namespace / WaveletTransform Enumeration

    WaveletTransform Enumeration
    In This Topic
    The types of wavelet transform used in JPEG 2000 & JPIP
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Enum WaveletTransform
   Inherits System.Enum
    'Usage

    Dim instance As WaveletTransform
    public enum WaveletTransform : System.Enum
    Members
    Member | Description
Irreversible | Irreversible 9/7
None | No transform
Reversible | Reversible 5/3
    Inheritance Hierarchy

    System.Object
    System.ValueType
    System.Enum
    DicomObjects.Enums.WaveletTransform

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomObjects.Enums Namespace


%%PageItemTitle%%

DicomObjects.Enums Namespace / WorkItemOperation Enumeration

    WorkItemOperation Enumeration
    In This Topic
    Indicates the type of transaction of incoming WorkItem Web reqeust
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Enum WorkItemOperation
   Inherits System.Enum
    'Usage

    Dim instance As WorkItemOperation
    public enum WorkItemOperation : System.Enum
    Members
    Member | Description
ChangeState | Change Workitem State transaction which is used to claim ownership, complete, or cancel a Workitem (UPS instance)
Create | This transaction creates a Workitem on the target Worklist. It corresponds to the UPS DIMSE N-CREATE operation.
None | Default value
RequestCancellation | This transaction allows a user agent that does not own a Workitem to request that it be canceled. It corresponds to the UPS DIMSE N-ACTION operation "Request UPS Cancel".
Retreive | This transaction retrieves a Workitem. It corresponds to the UPS DIMSE N-GET operation.
Search | This transaction searches the Worklist for Workitems that match the specified Query Parameters and returns a list of matching Workitems.
Subscribe | This transaction creates a Subscription to a Worklist or Workitem resource. It corresponds to the UPS DIMSE N-ACTION operation "Subscribe to Receive UPS Event Reports".
SuspendGlobalSubscription | This transaction is used to stop the origin server from automatically subscribing the User-Agent to new Workitems. This does not delete any existing subscriptions to specific Workitems.
Unsubscribe | This transaction is used to stop the origin server from sending new Event Reports to the user agent and may also stop the origin server from subscribing the user agent to new Workitems.
Update | This transaction modifies Attributes of an existing Workitem. It corresponds to the UPS DIMSE N-SET operation.
    Inheritance Hierarchy

    System.Object
    System.ValueType
    System.Enum
    DicomObjects.Enums.WorkItemOperation

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomObjects.Enums Namespace


Inheritance Hierarchy
    DicomObjects.EventArguments Namespace
    Classes
     | Class | Description
Class | AssociationClosedArgs | Argument passed in the AssociationClosed event
Class | AssociationRequestArgs | Argument passed in the DicomObjects.DicomServer.AssociationRequest event
Class | ChangeUidArgs | Argument for the DicomObjects.DicomGlobal.OnChangeUid event, allowing visibility and control of UID changes
Class | ErrorReceivedArgs | Argument passed in the ErrorReceived event
Class | InfoMessageArgs | Argument passed in the InfoMessage event
Class | InstanceReceivedArgs | Argument passed in the InstanceReceived event
Class | LogEventArgs | Arguments for the DicomObjects.DicomGlobal.LogEvent Event
Class | N_Event_ReportArgs | Event argument passed in the DicomObjects.DicomServer.N_Event_Report and DicomObjects.DicomAssociation.N_Event_Report events
Class | NormalisedReceivedArgs | Argument passed in the NormalisedReceived evetn
Class | OperationBaseArgs | A base class for other Arguments classes used for incoming operations It is not used directly on its own.
Class | PSLabelCreatedArgs | Argument for the event, allowing customisation of the DicomLabel as a PS is applied to an Image
Class | QueryReceivedArgs | Argument passed in the QueryReceived event
Class | ReceivingPixelDataArgs | Class used by the DicomObjects.DicomServer.ReceivingPixelData event
Class | ResponseReceivedArgs | Event argument passed in the ResponseReceived
Class | ValidateFragmentsArgs | Argument for the DicomObjects.DicomGlobal.ValidateFragments event.
Class | VerifyReceivedArgs | Argument passed in the VerifyReceived Event
    See Also

    Reference

    DicomObjects.NetStandard Assembly


%%PageItemTitle%%

DicomObjects.EventArguments Namespace / AssociationClosedArgs Class
Members

In This Topic
    AssociationClosedArgs Class
    In This Topic
    Argument passed in the AssociationClosed event
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Class AssociationClosedArgs
    'Usage

    Dim instance As AssociationClosedArgs
    public class AssociationClosedArgs
    Inheritance Hierarchy

    System.Object
    DicomObjects.EventArguments.AssociationClosedArgs

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    AssociationClosedArgs Members
    DicomObjects.EventArguments Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.EventArguments Namespace / AssociationClosedArgs Class
Properties

In This Topic
    AssociationClosedArgs Class Members
    In This Topic

    The following tables list the members exposed by AssociationClosedArgs.

    Public Properties
     | Name | Description
Public Property | Association | The association that is to be closed
    Top
    See Also

    Reference

    AssociationClosedArgs Class
    DicomObjects.EventArguments Namespace


%%PageItemTitle%% $$Properties$$

DicomObjects.EventArguments Namespace / AssociationClosedArgs Class

In This Topic
    AssociationClosedArgs Class Properties
    In This Topic

    For a list of all members of this type, see AssociationClosedArgs members.

    Public Properties
     | Name | Description
Public Property | Association | The association that is to be closed
    Top
    See Also

    Reference

    AssociationClosedArgs Class
    DicomObjects.EventArguments Namespace


DicomObjects.EventArguments Namespace / AssociationClosedArgs Class / Association Property

    Association Property (AssociationClosedArgs)
    In This Topic
    The association that is to be closed
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property Association As DicomAssociation
    'Usage

    Dim instance As AssociationClosedArgs
Dim value As DicomAssociation

value = instance.Association
    public DicomAssociation Association {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    AssociationClosedArgs Class
    AssociationClosedArgs Members


%%PageItemTitle%%

DicomObjects.EventArguments Namespace / AssociationRequestArgs Class
Members

In This Topic
    AssociationRequestArgs Class
    In This Topic
    Argument passed in the DicomObjects.DicomServer.AssociationRequest event
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Class AssociationRequestArgs
   Inherits System.EventArgs
    'Usage

    Dim instance As AssociationRequestArgs
    public class AssociationRequestArgs : System.EventArgs
    Inheritance Hierarchy

    System.Object
    System.EventArgs
    DicomObjects.EventArguments.AssociationRequestArgs

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    AssociationRequestArgs Members
    DicomObjects.EventArguments Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.EventArguments Namespace / AssociationRequestArgs Class
Properties Methods

In This Topic
    AssociationRequestArgs Class Members
    In This Topic

    The following tables list the members exposed by AssociationRequestArgs.

    Public Properties
     | Name | Description
Public Property | Association | The association that contains the incoming request
Public Property | Contexts | The Contexts proposed by the remote application
    Top
    Public Methods
     | Name | Description
Public Method | Reject | Reject a whole association request
    Top
    See Also

    Reference

    AssociationRequestArgs Class
    DicomObjects.EventArguments Namespace


%%PageItemTitle%% $$Methods$$

DicomObjects.EventArguments Namespace / AssociationRequestArgs Class

In This Topic
    AssociationRequestArgs Class Methods
    In This Topic

    For a list of all members of this type, see AssociationRequestArgs members.

    Public Methods
     | Name | Description
Public Method | Reject | Reject a whole association request
    Top
    See Also

    Reference

    AssociationRequestArgs Class
    DicomObjects.EventArguments Namespace


DicomObjects.EventArguments Namespace / AssociationRequestArgs Class / Reject Method / Reject(Byte,Byte,Byte) Method
Result as byte, indicating whether it's a permanent or transient rejection
Source as byte, indicating the source of the rejection
Reason as byte, indicating the reason of the rejection

In This Topic
    Reject(Byte,Byte,Byte) Method
    In This Topic
    Reject a whole association request
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub Reject( _
   ByVal Result As Byte, _
   ByVal Source As Byte, _
   ByVal Reason As Byte _
)
    'Usage

    Dim instance As AssociationRequestArgs
Dim Result As Byte
Dim Source As Byte
Dim Reason As Byte

instance.Reject(Result, Source, Reason)
    public void Reject(
   byte Result,
   byte Source,
   byte Reason
)

    Parameters

    Result
    Result as byte, indicating whether it's a permanent or transient rejection
    Source
    Source as byte, indicating the source of the rejection
    Reason
    Reason as byte, indicating the reason of the rejection
    Remarks

    Values for Result, Source and Reason are as follow:

    Result:

    • 1 - rejected-permanent
    • 2 - rejected-transient

    Source

    • 1 - DICOM UL service-user
    • 2 - DICOM UL service-provider (ACSE related function)
    • 3 - DICOM UL service-provider (Presentation related function)

    Reason:

    For Source field value of 1 (DICOM UL service-user)

    • 1 - no-reason-given
    • 2 - application-context-name-not-supported
    • 3 - calling-AE-title-not-recognized
    • 4-6 - reserved
    • 7 - called-AE-title-not-recognized
    • 8-10 - reserved

    For Source field value of 2 (DICOM UL service-provider (ACSE related function))

    • 1 - no-reason-given
    • 2 - protocol-version-not-supported

    For Source field value of 3 (DICOM UL service-provider (Presentation related function))

    • 0 - reserved
    • 1 - temporary-congestion
    • 2 - local-limit-exceeded
    • 3-7 - reserved
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    AssociationRequestArgs Class
    AssociationRequestArgs Members
    Overload List


%%PageItemTitle%% $$Properties$$

DicomObjects.EventArguments Namespace / AssociationRequestArgs Class

In This Topic
    AssociationRequestArgs Class Properties
    In This Topic

    For a list of all members of this type, see AssociationRequestArgs members.

    Public Properties
     | Name | Description
Public Property | Association | The association that contains the incoming request
Public Property | Contexts | The Contexts proposed by the remote application
    Top
    See Also

    Reference

    AssociationRequestArgs Class
    DicomObjects.EventArguments Namespace


DicomObjects.EventArguments Namespace / AssociationRequestArgs Class / Association Property

    Association Property (AssociationRequestArgs)
    In This Topic
    The association that contains the incoming request
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property Association As DicomAssociation
    'Usage

    Dim instance As AssociationRequestArgs
Dim value As DicomAssociation

value = instance.Association
    public DicomAssociation Association {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    AssociationRequestArgs Class
    AssociationRequestArgs Members


DicomObjects.EventArguments Namespace / AssociationRequestArgs Class / Contexts Property

    Contexts Property
    The Contexts proposed by the remote application
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property Contexts As DicomContextCollection
    'Usage

    Dim instance As AssociationRequestArgs
Dim value As DicomContextCollection

value = instance.Contexts
    public DicomContextCollection Contexts {get;}
    Remarks
    Select using reject and/or setting AcceptedTS of each
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    AssociationRequestArgs Class
    AssociationRequestArgs Members


%%PageItemTitle%%

DicomObjects.EventArguments Namespace / ChangeUidArgs Class
Members

In This Topic
    ChangeUidArgs Class
    In This Topic
    Argument for the DicomObjects.DicomGlobal.OnChangeUid event, allowing visibility and control of UID changes
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Class ChangeUidArgs
    'Usage

    Dim instance As ChangeUidArgs
    public class ChangeUidArgs
    Inheritance Hierarchy

    System.Object
    DicomObjects.EventArguments.ChangeUidArgs

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ChangeUidArgs Members
    DicomObjects.EventArguments Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.EventArguments Namespace / ChangeUidArgs Class
Properties

In This Topic
    ChangeUidArgs Class Members
    In This Topic

    The following tables list the members exposed by ChangeUidArgs.

    Public Properties
     | Name | Description
Public Property | AllowChange | Controls whether to actually make the UID change
Public Property | DataSet | The dataset whose UID should be changed
Public Property | NewUID | The UID being proposed by DicomObjects.
Public Property | Quality | The quality being used for the image compression
Public Property | Reason | The reason that the UID should be changed
Public Property | TransferSyntax | The new transfer syntax being used
    Top
    See Also

    Reference

    ChangeUidArgs Class
    DicomObjects.EventArguments Namespace


%%PageItemTitle%% $$Properties$$

DicomObjects.EventArguments Namespace / ChangeUidArgs Class

    ChangeUidArgs Class Properties
    In This Topic

    For a list of all members of this type, see ChangeUidArgs members.

    Public Properties
     | Name | Description
Public Property | AllowChange | Controls whether to actually make the UID change
Public Property | DataSet | The dataset whose UID should be changed
Public Property | NewUID | The UID being proposed by DicomObjects.
Public Property | Quality | The quality being used for the image compression
Public Property | Reason | The reason that the UID should be changed
Public Property | TransferSyntax | The new transfer syntax being used
    Top
    See Also

    Reference

    ChangeUidArgs Class
    DicomObjects.EventArguments Namespace


DicomObjects.EventArguments Namespace / ChangeUidArgs Class / AllowChange Property

    AllowChange Property
    Controls whether to actually make the UID change
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property AllowChange As Boolean
    'Usage

    Dim instance As ChangeUidArgs
Dim value As Boolean

instance.AllowChange = value

value = instance.AllowChange
    public bool AllowChange {get; set;}
    Remarks
    This property is initially true, but if required may be set to false in the DicomObjects.DicomGlobal.OnChangeUid event to prevent the UID update from occuring.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ChangeUidArgs Class
    ChangeUidArgs Members


DicomObjects.EventArguments Namespace / ChangeUidArgs Class / DataSet Property

    DataSet Property (ChangeUidArgs)
    In This Topic
    The dataset whose UID should be changed
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property DataSet As DicomDataSet
    'Usage

    Dim instance As ChangeUidArgs
Dim value As DicomDataSet

instance.DataSet = value

value = instance.DataSet
    public DicomDataSet DataSet {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ChangeUidArgs Class
    ChangeUidArgs Members


DicomObjects.EventArguments Namespace / ChangeUidArgs Class / NewUID Property

    NewUID Property
    The UID being proposed by DicomObjects.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property NewUID As String
    'Usage

    Dim instance As ChangeUidArgs
Dim value As String

instance.NewUID = value

value = instance.NewUID
    public string NewUID {get; set;}
    Remarks
    This may be replaced if required in the DicomObjects.DicomGlobal.OnChangeUid event
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ChangeUidArgs Class
    ChangeUidArgs Members


DicomObjects.EventArguments Namespace / ChangeUidArgs Class / Quality Property

    Quality Property (ChangeUidArgs)
    In This Topic
    The quality being used for the image compression
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property Quality As Object
    'Usage

    Dim instance As ChangeUidArgs
Dim value As Object

instance.Quality = value

value = instance.Quality
    public object Quality {get; set;}
    Remarks
    This is only applicable when DicomObjects.Enums.ChangeUidReason is DicomObjects.Enums.ChangeUidReason.LossyCompression
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ChangeUidArgs Class
    ChangeUidArgs Members


DicomObjects.EventArguments Namespace / ChangeUidArgs Class / Reason Property

    Reason Property
    The reason that the UID should be changed
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property Reason As ChangeUidReason
    'Usage

    Dim instance As ChangeUidArgs
Dim value As ChangeUidReason

instance.Reason = value

value = instance.Reason
    public ChangeUidReason Reason {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ChangeUidArgs Class
    ChangeUidArgs Members


DicomObjects.EventArguments Namespace / ChangeUidArgs Class / TransferSyntax Property

    TransferSyntax Property
    The new transfer syntax being used
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property TransferSyntax As String
    'Usage

    Dim instance As ChangeUidArgs
Dim value As String

instance.TransferSyntax = value

value = instance.TransferSyntax
    public string TransferSyntax {get; set;}
    Remarks
    This is only applicable when DicomObjects.Enums.ChangeUidReason is DicomObjects.Enums.ChangeUidReason.LossyCompression
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ChangeUidArgs Class
    ChangeUidArgs Members


%%PageItemTitle%%

DicomObjects.EventArguments Namespace / ErrorReceivedArgs Class
Members

In This Topic
    ErrorReceivedArgs Class
    In This Topic
    Argument passed in the ErrorReceived event
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Class ErrorReceivedArgs
    'Usage

    Dim instance As ErrorReceivedArgs
    public class ErrorReceivedArgs
    Inheritance Hierarchy

    System.Object
    DicomObjects.EventArguments.ErrorReceivedArgs

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ErrorReceivedArgs Members
    DicomObjects.EventArguments Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.EventArguments Namespace / ErrorReceivedArgs Class
Properties

In This Topic
    ErrorReceivedArgs Class Members
    In This Topic

    The following tables list the members exposed by ErrorReceivedArgs.

    Public Properties
     | Name | Description
Public Property | Association | The association which contains the detected error
Public Property | Error | The Exception received
    Top
    See Also

    Reference

    ErrorReceivedArgs Class
    DicomObjects.EventArguments Namespace


%%PageItemTitle%% $$Properties$$

DicomObjects.EventArguments Namespace / ErrorReceivedArgs Class

In This Topic
    ErrorReceivedArgs Class Properties
    In This Topic

    For a list of all members of this type, see ErrorReceivedArgs members.

    Public Properties
     | Name | Description
Public Property | Association | The association which contains the detected error
Public Property | Error | The Exception received
    Top
    See Also

    Reference

    ErrorReceivedArgs Class
    DicomObjects.EventArguments Namespace


DicomObjects.EventArguments Namespace / ErrorReceivedArgs Class / Association Property

    Association Property (ErrorReceivedArgs)
    In This Topic
    The association which contains the detected error
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property Association As DicomAssociation
    'Usage

    Dim instance As ErrorReceivedArgs
Dim value As DicomAssociation

value = instance.Association
    public DicomAssociation Association {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ErrorReceivedArgs Class
    ErrorReceivedArgs Members


DicomObjects.EventArguments Namespace / ErrorReceivedArgs Class / Error Property

    Error Property
    The Exception received
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property Error As Exception
    'Usage

    Dim instance As ErrorReceivedArgs
Dim value As Exception

value = instance.Error
    public Exception Error {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ErrorReceivedArgs Class
    ErrorReceivedArgs Members


%%PageItemTitle%%

DicomObjects.EventArguments Namespace / InfoMessageArgs Class
Members

In This Topic
    InfoMessageArgs Class
    In This Topic
    Argument passed in the InfoMessage event
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Class InfoMessageArgs
    'Usage

    Dim instance As InfoMessageArgs
    public class InfoMessageArgs
    Inheritance Hierarchy

    System.Object
    DicomObjects.EventArguments.InfoMessageArgs

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    InfoMessageArgs Members
    DicomObjects.EventArguments Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.EventArguments Namespace / InfoMessageArgs Class
Properties

In This Topic
    InfoMessageArgs Class Members
    In This Topic

    The following tables list the members exposed by InfoMessageArgs.

    Public Properties
     | Name | Description
Public Property | Association | The current association
Public Property | Level | Level indicating the importance of the message
Public Property | Message | The message to be passed back
    Top
    See Also

    Reference

    InfoMessageArgs Class
    DicomObjects.EventArguments Namespace


%%PageItemTitle%% $$Properties$$

DicomObjects.EventArguments Namespace / InfoMessageArgs Class

In This Topic
    InfoMessageArgs Class Properties
    In This Topic

    For a list of all members of this type, see InfoMessageArgs members.

    Public Properties
     | Name | Description
Public Property | Association | The current association
Public Property | Level | Level indicating the importance of the message
Public Property | Message | The message to be passed back
    Top
    See Also

    Reference

    InfoMessageArgs Class
    DicomObjects.EventArguments Namespace


DicomObjects.EventArguments Namespace / InfoMessageArgs Class / Association Property

    Association Property (InfoMessageArgs)
    In This Topic
    The current association
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property Association As DicomAssociation
    'Usage

    Dim instance As InfoMessageArgs
Dim value As DicomAssociation

value = instance.Association
    public DicomAssociation Association {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    InfoMessageArgs Class
    InfoMessageArgs Members


DicomObjects.EventArguments Namespace / InfoMessageArgs Class / Level Property

    Level Property (InfoMessageArgs)
    In This Topic
    Level indicating the importance of the message
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property Level As Integer
    'Usage

    Dim instance As InfoMessageArgs
Dim value As Integer

value = instance.Level
    public int Level {get;}
    Remarks

    Enumerated values as follows:

    0 - Fatal Error

    1 - Protocol Error

    2 - Warning

    3 - Information

    4 - Debugging trace

    Will be put into DicomObjects.Enums in the near future.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    InfoMessageArgs Class
    InfoMessageArgs Members


DicomObjects.EventArguments Namespace / InfoMessageArgs Class / Message Property

    Message Property
    The message to be passed back
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property Message As String
    'Usage

    Dim instance As InfoMessageArgs
Dim value As String

value = instance.Message
    public string Message {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    InfoMessageArgs Class
    InfoMessageArgs Members


%%PageItemTitle%%

DicomObjects.EventArguments Namespace / InstanceReceivedArgs Class
Members

In This Topic
    InstanceReceivedArgs Class
    In This Topic
    Argument passed in the InstanceReceived event
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Class InstanceReceivedArgs
   Inherits OperationBaseArgs
    'Usage

    Dim instance As InstanceReceivedArgs
    public class InstanceReceivedArgs : OperationBaseArgs
    Inheritance Hierarchy

    System.Object
    System.EventArgs
    DicomObjects.EventArguments.OperationBaseArgs
    DicomObjects.EventArguments.InstanceReceivedArgs

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    InstanceReceivedArgs Members
    DicomObjects.EventArguments Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.EventArguments Namespace / InstanceReceivedArgs Class
Properties

In This Topic
    InstanceReceivedArgs Class Members
    In This Topic

    The following tables list the members exposed by InstanceReceivedArgs.

    Public Properties
     | Name | Description
Public Property | Command | The incoming command (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Errors | List of errors found in an incoming request (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Instance | The received composite DICOM instance
Public Property | Operation | The normalised operation currently requested (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | PresentationContextId | The Presentation Context ID used to transmit this operation (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | ReceivedFilename | Filename to which the instance has already been saved
Public Property | Request | The incoming request (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | RequestAssociation | The Association which contains the Query (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | ResultDataSet | Specifies the result DicomDataSet to be sent back for Normalised operations operations for for failures for retrieval operations (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Status | The status to be sent back as a C-Echo response (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
    Top
    See Also

    Reference

    InstanceReceivedArgs Class
    DicomObjects.EventArguments Namespace


%%PageItemTitle%% $$Properties$$

DicomObjects.EventArguments Namespace / InstanceReceivedArgs Class

In This Topic
    InstanceReceivedArgs Class Properties
    In This Topic

    For a list of all members of this type, see InstanceReceivedArgs members.

    Public Properties
     | Name | Description
Public Property | Command | The incoming command (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Errors | List of errors found in an incoming request (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Instance | The received composite DICOM instance
Public Property | Operation | The normalised operation currently requested (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | PresentationContextId | The Presentation Context ID used to transmit this operation (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | ReceivedFilename | Filename to which the instance has already been saved
Public Property | Request | The incoming request (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | RequestAssociation | The Association which contains the Query (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | ResultDataSet | Specifies the result DicomDataSet to be sent back for Normalised operations operations for for failures for retrieval operations (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Status | The status to be sent back as a C-Echo response (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
    Top
    See Also

    Reference

    InstanceReceivedArgs Class
    DicomObjects.EventArguments Namespace


DicomObjects.EventArguments Namespace / InstanceReceivedArgs Class / Instance Property

    Instance Property
    The received composite DICOM instance
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property Instance As DicomDataSet
    'Usage

    Dim instance As InstanceReceivedArgs
Dim value As DicomDataSet

value = instance.Instance
    public DicomDataSet Instance {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    InstanceReceivedArgs Class
    InstanceReceivedArgs Members


DicomObjects.EventArguments Namespace / InstanceReceivedArgs Class / ReceivedFilename Property

    ReceivedFilename Property
    Filename to which the instance has already been saved
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property ReceivedFilename As String
    'Usage

    Dim instance As InstanceReceivedArgs
Dim value As String

value = instance.ReceivedFilename
    public string ReceivedFilename {get;}
    Remarks
    This is only valid for images saved as a result of ReceivingPixelDataArgs.ReceiveToDisk -
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    InstanceReceivedArgs Class
    InstanceReceivedArgs Members


%%PageItemTitle%%

DicomObjects.EventArguments Namespace / LogEventArgs Class
Members

In This Topic
    LogEventArgs Class
    In This Topic
    Arguments for the LogEvent Event
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Class LogEventArgs
    'Usage

    Dim instance As LogEventArgs
    public class LogEventArgs
    Inheritance Hierarchy

    System.Object
    DicomObjects.EventArguments.LogEventArgs

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    LogEventArgs Members
    DicomObjects.EventArguments Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.EventArguments Namespace / LogEventArgs Class
Properties

In This Topic
    LogEventArgs Class Members
    In This Topic

    The following tables list the members exposed by LogEventArgs.

    Public Properties
     | Name | Description
Public Property | Level | The level of the event being logged
Public Property | Source | The Log Event Source
Public Property | Text | The test of the association
    Top
    See Also

    Reference

    LogEventArgs Class
    DicomObjects.EventArguments Namespace


%%PageItemTitle%% $$Properties$$

DicomObjects.EventArguments Namespace / LogEventArgs Class

    LogEventArgs Class Properties
    In This Topic

    For a list of all members of this type, see LogEventArgs members.

    Public Properties
     | Name | Description
Public Property | Level | The level of the event being logged
Public Property | Source | The Log Event Source
Public Property | Text | The test of the association
    Top
    See Also

    Reference

    LogEventArgs Class
    DicomObjects.EventArguments Namespace


DicomObjects.EventArguments Namespace / LogEventArgs Class / Level Property

    Level Property (LogEventArgs)
    In This Topic
    The level of the event being logged
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property Level As Integer
    'Usage

    Dim instance As LogEventArgs
Dim value As Integer

value = instance.Level
    public int Level {get;}
    Remarks
    See DicomGlobal.LogToFile for the meaning of this level
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    LogEventArgs Class
    LogEventArgs Members


DicomObjects.EventArguments Namespace / LogEventArgs Class / Source Property

    Source Property (LogEventArgs)
    In This Topic
    The Log Event Source
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property Source As String
    'Usage

    Dim instance As LogEventArgs
Dim value As String

value = instance.Source
    public string Source {get;}
    Remarks

    For associations, this is a sequentially increment number, unique for each association.

    Files read or written are also allocated a "pseudo-association" number for identification

    May be zero for non-association related log events

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    LogEventArgs Class
    LogEventArgs Members


DicomObjects.EventArguments Namespace / LogEventArgs Class / Text Property

    Text Property (LogEventArgs)
    In This Topic
    The test of the association
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property Text As String
    'Usage

    Dim instance As LogEventArgs
Dim value As String

value = instance.Text
    public string Text {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    LogEventArgs Class
    LogEventArgs Members


%%PageItemTitle%%

DicomObjects.EventArguments Namespace / N_Event_ReportArgs Class
Members

In This Topic
    N_Event_ReportArgs Class
    In This Topic
    Event argument passed in the DicomObjects.DicomServer.N_Event_Report and DicomObjects.DicomAssociation.N_Event_Report events
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Class N_Event_ReportArgs
   Inherits OperationBaseArgs
    'Usage

    Dim instance As N_Event_ReportArgs
    public class N_Event_ReportArgs : OperationBaseArgs
    Inheritance Hierarchy

    System.Object
    System.EventArgs
    DicomObjects.EventArguments.OperationBaseArgs
    DicomObjects.EventArguments.N_Event_ReportArgs

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    N_Event_ReportArgs Members
    DicomObjects.EventArguments Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.EventArguments Namespace / N_Event_ReportArgs Class
Properties

In This Topic
    N_Event_ReportArgs Class Members
    In This Topic

    The following tables list the members exposed by N_Event_ReportArgs.

    Public Properties
     | Name | Description
Public Property | Command | The incoming command (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Errors | List of errors found in an incoming request (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | EventID | The ID of the notification
Public Property | Operation | The normalised operation currently requested (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | PresentationContextId | The Presentation Context ID used to transmit this operation (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Request | The incoming request (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | RequestAssociation | The Association which contains the Query (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | ResultDataSet | Specifies the result DicomDataSet to be sent back for Normalised operations operations for for failures for retrieval operations (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Status | The status to be sent back as a C-Echo response (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
    Top
    See Also

    Reference

    N_Event_ReportArgs Class
    DicomObjects.EventArguments Namespace


%%PageItemTitle%% $$Properties$$

DicomObjects.EventArguments Namespace / N_Event_ReportArgs Class

In This Topic
    N_Event_ReportArgs Class Properties
    In This Topic

    For a list of all members of this type, see N_Event_ReportArgs members.

    Public Properties
     | Name | Description
Public Property | Command | The incoming command (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Errors | List of errors found in an incoming request (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | EventID | The ID of the notification
Public Property | Operation | The normalised operation currently requested (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | PresentationContextId | The Presentation Context ID used to transmit this operation (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Request | The incoming request (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | RequestAssociation | The Association which contains the Query (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | ResultDataSet | Specifies the result DicomDataSet to be sent back for Normalised operations operations for for failures for retrieval operations (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Status | The status to be sent back as a C-Echo response (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
    Top
    See Also

    Reference

    N_Event_ReportArgs Class
    DicomObjects.EventArguments Namespace


DicomObjects.EventArguments Namespace / N_Event_ReportArgs Class / EventID Property

    EventID Property
    The ID of the notification
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property EventID As Integer
    'Usage

    Dim instance As N_Event_ReportArgs
Dim value As Integer

value = instance.EventID
    public int EventID {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    N_Event_ReportArgs Class
    N_Event_ReportArgs Members


%%PageItemTitle%%

DicomObjects.EventArguments Namespace / NormalisedReceivedArgs Class
Members

In This Topic
    NormalisedReceivedArgs Class
    In This Topic
    Argument passed in the NormalisedReceived evetn
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Class NormalisedReceivedArgs
   Inherits OperationBaseArgs
    'Usage

    Dim instance As NormalisedReceivedArgs
    public class NormalisedReceivedArgs : OperationBaseArgs
    Inheritance Hierarchy

    System.Object
    System.EventArgs
    DicomObjects.EventArguments.OperationBaseArgs
    DicomObjects.EventArguments.NormalisedReceivedArgs

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    NormalisedReceivedArgs Members
    DicomObjects.EventArguments Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.EventArguments Namespace / NormalisedReceivedArgs Class
Properties

In This Topic
    NormalisedReceivedArgs Class Members
    In This Topic

    The following tables list the members exposed by NormalisedReceivedArgs.

    Public Properties
     | Name | Description
Public Property | Command | The incoming command (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Errors | List of errors found in an incoming request (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Operation | The normalised operation currently requested (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | PresentationContextId | The Presentation Context ID used to transmit this operation (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Request | The incoming request (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | RequestAssociation | The Association which contains the Query (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | ResultDataSet | Specifies the result DicomDataSet to be sent back for Normalised operations operations for for failures for retrieval operations (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Status | The status to be sent back as a C-Echo response (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
    Top
    See Also

    Reference

    NormalisedReceivedArgs Class
    DicomObjects.EventArguments Namespace


%%PageItemTitle%%

DicomObjects.EventArguments Namespace / OperationBaseArgs Class
Members

In This Topic
    OperationBaseArgs Class
    In This Topic
    A base class for other Arguments classes used for incoming operations It is not used directly on its own.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Class OperationBaseArgs
   Inherits System.EventArgs
    'Usage

    Dim instance As OperationBaseArgs
    public class OperationBaseArgs : System.EventArgs
    Inheritance Hierarchy

    System.Object
    System.EventArgs
    DicomObjects.EventArguments.OperationBaseArgs
    DicomObjects.EventArguments.InstanceReceivedArgs
    DicomObjects.EventArguments.N_Event_ReportArgs
    DicomObjects.EventArguments.NormalisedReceivedArgs
    DicomObjects.EventArguments.QueryReceivedArgs
    DicomObjects.EventArguments.VerifyReceivedArgs

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    OperationBaseArgs Members
    DicomObjects.EventArguments Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.EventArguments Namespace / OperationBaseArgs Class
Properties

In This Topic
    OperationBaseArgs Class Members
    In This Topic

    The following tables list the members exposed by OperationBaseArgs.

    Public Properties
     | Name | Description
Public Property | Command | The incoming command
Public Property | Errors | List of errors found in an incoming request
Public Property | Operation | The normalised operation currently requested
Public Property | PresentationContextId | The Presentation Context ID used to transmit this operation
Public Property | Request | The incoming request
Public Property | RequestAssociation | The Association which contains the Query
Public Property | ResultDataSet | Specifies the result DicomDataSet to be sent back for Normalised operations operations for for failures for retrieval operations
Public Property | Status | The status to be sent back as a C-Echo response
    Top
    See Also

    Reference

    OperationBaseArgs Class
    DicomObjects.EventArguments Namespace


%%PageItemTitle%% $$Properties$$

DicomObjects.EventArguments Namespace / OperationBaseArgs Class

In This Topic
    OperationBaseArgs Class Properties
    In This Topic

    For a list of all members of this type, see OperationBaseArgs members.

    Public Properties
     | Name | Description
Public Property | Command | The incoming command
Public Property | Errors | List of errors found in an incoming request
Public Property | Operation | The normalised operation currently requested
Public Property | PresentationContextId | The Presentation Context ID used to transmit this operation
Public Property | Request | The incoming request
Public Property | RequestAssociation | The Association which contains the Query
Public Property | ResultDataSet | Specifies the result DicomDataSet to be sent back for Normalised operations operations for for failures for retrieval operations
Public Property | Status | The status to be sent back as a C-Echo response
    Top
    See Also

    Reference

    OperationBaseArgs Class
    DicomObjects.EventArguments Namespace


DicomObjects.EventArguments Namespace / OperationBaseArgs Class / Command Property

    Command Property (OperationBaseArgs)
    In This Topic
    The incoming command
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property Command As DicomDataSet
    'Usage

    Dim instance As OperationBaseArgs
Dim value As DicomDataSet

value = instance.Command
    public DicomDataSet Command {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    OperationBaseArgs Class
    OperationBaseArgs Members


DicomObjects.EventArguments Namespace / OperationBaseArgs Class / Errors Property

    Errors Property
    List of errors found in an incoming request
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property Errors As DicomDataSet
    'Usage

    Dim instance As OperationBaseArgs
Dim value As DicomDataSet

value = instance.Errors
    public DicomDataSet Errors {get;}
    Remarks

    If a client identifies errors in a DicomAssociation, it should place appropriate values into this property before setting the Status to an appropriate error code.

    The appropriate elements to be inserted into this dataset are:

    • (0000, 0901) : Offending Element
    • (0000, 0902) : Error Comment

    Only the appropriate elements, as defined by the returned status will be transmitted.

    SCP uses this property to check if there is any errors reported by the connected clients.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    OperationBaseArgs Class
    OperationBaseArgs Members


DicomObjects.EventArguments Namespace / OperationBaseArgs Class / Operation Property

    Operation Property
    The normalised operation currently requested
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property Operation As DicomOperation
    'Usage

    Dim instance As OperationBaseArgs
Dim value As DicomOperation

value = instance.Operation
    public DicomOperation Operation {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    OperationBaseArgs Class
    OperationBaseArgs Members


DicomObjects.EventArguments Namespace / OperationBaseArgs Class / PresentationContextId Property

    PresentationContextId Property
    The Presentation Context ID used to transmit this operation
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property PresentationContextId As Byte
    'Usage

    Dim instance As OperationBaseArgs
Dim value As Byte

value = instance.PresentationContextId
    public byte PresentationContextId {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    OperationBaseArgs Class
    OperationBaseArgs Members


DicomObjects.EventArguments Namespace / OperationBaseArgs Class / Request Property

    Request Property (OperationBaseArgs)
    In This Topic
    The incoming request
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property Request As DicomDataSet
    'Usage

    Dim instance As OperationBaseArgs
Dim value As DicomDataSet

value = instance.Request
    public DicomDataSet Request {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    OperationBaseArgs Class
    OperationBaseArgs Members


DicomObjects.EventArguments Namespace / OperationBaseArgs Class / RequestAssociation Property

    RequestAssociation Property
    The Association which contains the Query
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property RequestAssociation As DicomAssociation
    'Usage

    Dim instance As OperationBaseArgs
Dim value As DicomAssociation

value = instance.RequestAssociation
    public DicomAssociation RequestAssociation {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    OperationBaseArgs Class
    OperationBaseArgs Members


DicomObjects.EventArguments Namespace / OperationBaseArgs Class / ResultDataSet Property

    ResultDataSet Property
    Specifies the result DicomDataSet to be sent back for Normalised operations operations for for failures for retrieval operations
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property ResultDataSet As DicomDataSet
    'Usage

    Dim instance As OperationBaseArgs
Dim value As DicomDataSet

instance.ResultDataSet = value

value = instance.ResultDataSet
    public DicomDataSet ResultDataSet {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    OperationBaseArgs Class
    OperationBaseArgs Members


DicomObjects.EventArguments Namespace / OperationBaseArgs Class / Status Property

    Status Property (OperationBaseArgs)
    In This Topic
    The status to be sent back as a C-Echo response
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property Status As Integer
    'Usage

    Dim instance As OperationBaseArgs
Dim value As Integer

instance.Status = value

value = instance.Status
    public int Status {get; set;}
    Remarks
    Set Status to Zero as a successful C-Echo response, none-zero status indicates C-Echo failure.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    OperationBaseArgs Class
    OperationBaseArgs Members


%%PageItemTitle%%

DicomObjects.EventArguments Namespace / PSLabelCreatedArgs Class
Members

In This Topic
    PSLabelCreatedArgs Class
    In This Topic
    Argument for the event, allowing customisation of the DicomLabel as a PS is applied to an Image
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Class PSLabelCreatedArgs
    'Usage

    Dim instance As PSLabelCreatedArgs
    public class PSLabelCreatedArgs
    Inheritance Hierarchy

    System.Object
    DicomObjects.EventArguments.PSLabelCreatedArgs

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    PSLabelCreatedArgs Members
    DicomObjects.EventArguments Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.EventArguments Namespace / PSLabelCreatedArgs Class
Properties

In This Topic
    PSLabelCreatedArgs Class Members
    In This Topic

    The following tables list the members exposed by PSLabelCreatedArgs.

    Public Constructors
     | Name | Description
Public Constructor | PSLabelCreatedArgs Constructor |
    Top
    Public Properties
     | Name | Description
Public Property | Label | Label created form the PresentationStateItem
Public Property | PresentationState | The general DICOM Presentation State Instance
Public Property | PresentationStateItem | The specific DICOM Presentation State Item from which the label is created
    Top
    See Also

    Reference

    PSLabelCreatedArgs Class
    DicomObjects.EventArguments Namespace


%%PageItemTitle%%

DicomObjects.EventArguments Namespace / PSLabelCreatedArgs Class / PSLabelCreatedArgs Constructor

In This Topic
    PSLabelCreatedArgs Constructor
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Function New()
    'Usage

    Dim instance As New PSLabelCreatedArgs()
    public PSLabelCreatedArgs()
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    PSLabelCreatedArgs Class
    PSLabelCreatedArgs Members


%%PageItemTitle%% $$Properties$$

DicomObjects.EventArguments Namespace / PSLabelCreatedArgs Class

In This Topic
    PSLabelCreatedArgs Class Properties
    In This Topic

    For a list of all members of this type, see PSLabelCreatedArgs members.

    Public Properties
     | Name | Description
Public Property | Label | Label created form the PresentationStateItem
Public Property | PresentationState | The general DICOM Presentation State Instance
Public Property | PresentationStateItem | The specific DICOM Presentation State Item from which the label is created
    Top
    See Also

    Reference

    PSLabelCreatedArgs Class
    DicomObjects.EventArguments Namespace


DicomObjects.EventArguments Namespace / PSLabelCreatedArgs Class / Label Property

    Label Property
    Label created form the PresentationStateItem
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property Label As DicomLabel
    'Usage

    Dim instance As PSLabelCreatedArgs
Dim value As DicomLabel

instance.Label = value

value = instance.Label
    public DicomLabel Label {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    PSLabelCreatedArgs Class
    PSLabelCreatedArgs Members


DicomObjects.EventArguments Namespace / PSLabelCreatedArgs Class / PresentationState Property

    PresentationState Property (PSLabelCreatedArgs)
    In This Topic
    The general DICOM Presentation State Instance
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property PresentationState As DicomDataSet
    'Usage

    Dim instance As PSLabelCreatedArgs
Dim value As DicomDataSet

instance.PresentationState = value

value = instance.PresentationState
    public DicomDataSet PresentationState {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    PSLabelCreatedArgs Class
    PSLabelCreatedArgs Members


DicomObjects.EventArguments Namespace / PSLabelCreatedArgs Class / PresentationStateItem Property

    PresentationStateItem Property
    The specific DICOM Presentation State Item from which the label is created
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property PresentationStateItem As DicomDataSet
    'Usage

    Dim instance As PSLabelCreatedArgs
Dim value As DicomDataSet

instance.PresentationStateItem = value

value = instance.PresentationStateItem
    public DicomDataSet PresentationStateItem {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    PSLabelCreatedArgs Class
    PSLabelCreatedArgs Members


%%PageItemTitle%%

DicomObjects.EventArguments Namespace / QueryReceivedArgs Class
Members

In This Topic
    QueryReceivedArgs Class
    In This Topic
    Argument passed in the QueryReceived event
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Class QueryReceivedArgs
   Inherits OperationBaseArgs
    'Usage

    Dim instance As QueryReceivedArgs
    public class QueryReceivedArgs : OperationBaseArgs
    Inheritance Hierarchy

    System.Object
    System.EventArgs
    DicomObjects.EventArguments.OperationBaseArgs
    DicomObjects.EventArguments.QueryReceivedArgs

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    QueryReceivedArgs Members
    DicomObjects.EventArguments Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.EventArguments Namespace / QueryReceivedArgs Class
Properties Methods

In This Topic
    QueryReceivedArgs Class Members
    In This Topic

    The following tables list the members exposed by QueryReceivedArgs.

    Public Properties
     | Name | Description
Public Property | Command | The incoming command (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Destination | The Application Entity Name to which images should be sent by a C-MOVE request
Public Property | Errors | List of errors found in an incoming request (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | InstanceAssociation | The Association to which to send instances using SendInstances
Public Property | Level | The Query Level
Public Property | ModificationsDone | Property to inform DicomObjects whether frame extraction (as per Supplement 119) has been performed
Public Property | NumberCompleted | Numbers of completed C-STORE sub-operations in a C-GET or C_MOVE operation
Public Property | NumberFailed | Numbers of failed C-STORE sub-operations in a C-GET or C_MOVE operation
Public Property | NumberRemaining | Numbers of remaining C-STORE sub-operations in a C-GET or C_MOVE operation
Public Property | NumberWarning | Numbers of warning C-STORE sub-operations in a C-GET or C_MOVE operation
Public Property | Operation | The normalised operation currently requested (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | PresentationContextId | The Presentation Context ID used to transmit this operation (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Request | The incoming request (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | RequestAssociation | The Association which contains the Query (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | ResultDataSet | Specifies the result DicomDataSet to be sent back for Normalised operations operations for for failures for retrieval operations (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | RetrieveType | The type of retrieval requested
Public Property | Root | The Query Root
Public Property | Status | The status to be sent back as a C-Echo response (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
    Top
    Public Methods
     | Name | Description
Public Method | SendPending | Return a pending response
Public Method | SendResponse | Overloaded. Send response back as DicomDataSetCollection to the request association
    Top
    See Also

    Reference

    QueryReceivedArgs Class
    DicomObjects.EventArguments Namespace


%%PageItemTitle%% $$Methods$$

DicomObjects.EventArguments Namespace / QueryReceivedArgs Class

In This Topic
    QueryReceivedArgs Class Methods
    In This Topic

    For a list of all members of this type, see QueryReceivedArgs members.

    Public Methods
     | Name | Description
Public Method | SendPending | Return a pending response
Public Method | SendResponse | Overloaded. Send response back as DicomDataSetCollection to the request association
    Top
    See Also

    Reference

    QueryReceivedArgs Class
    DicomObjects.EventArguments Namespace


DicomObjects.EventArguments Namespace / QueryReceivedArgs Class / SendPending Method

    SendPending Method (QueryReceivedArgs)
    In This Topic
    Return a pending response
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Sub SendPending()
    'Usage

    Dim instance As QueryReceivedArgs

instance.SendPending()
    public void SendPending()
    Remarks

    The status response is FF00. This method may be useful to keep an association "alive"

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    QueryReceivedArgs Class
    QueryReceivedArgs Members


DicomObjects.EventArguments Namespace / QueryReceivedArgs Class / SendResponse Method

    SendResponse Method (QueryReceivedArgs)
    In This Topic
    Send response back as DicomDataSetCollection to the request association
    Overload List
    Overload | Description
SendResponse(IEnumerable<DicomDataSet>,Int32) | Send response back as DicomDataSetCollection to the request association
SendResponse(DicomDataSet,Int32) | Send response back as DicomDataSet to the request association
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    QueryReceivedArgs Class
    QueryReceivedArgs Members


DicomObjects.EventArguments Namespace / QueryReceivedArgs Class / SendResponse Method / SendResponse(IEnumerable<DicomDataSet>,Int32) Method

    SendResponse(IEnumerable<DicomDataSet>,Int32) Method
    Send response back as DicomDataSetCollection to the request association
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub SendResponse( _
   ByVal Data As IEnumerable(Of DicomDataSet), _
   ByVal Status As Integer _
)
    'Usage

    Dim instance As QueryReceivedArgs
Dim Data As IEnumerable(Of DicomDataSet)
Dim Status As Integer

instance.SendResponse(Data, Status)
    public void SendResponse(
   IEnumerable<DicomDataSet> Data,
   int Status
)

    Parameters

    Data
    Status
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    QueryReceivedArgs Class
    QueryReceivedArgs Members
    Overload List


DicomObjects.EventArguments Namespace / QueryReceivedArgs Class / SendResponse Method / SendResponse(DicomDataSet,Int32) Method

    SendResponse(DicomDataSet,Int32) Method
    Send response back as DicomDataSet to the request association
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overloads Sub SendResponse( _
   ByVal Data As DicomDataSet, _
   ByVal Status As Integer _
)
    'Usage

    Dim instance As QueryReceivedArgs
Dim Data As DicomDataSet
Dim Status As Integer

instance.SendResponse(Data, Status)
    public void SendResponse(
   DicomDataSet Data,
   int Status
)

    Parameters

    Data
    Status
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    QueryReceivedArgs Class
    QueryReceivedArgs Members
    Overload List


%%PageItemTitle%% $$Properties$$

DicomObjects.EventArguments Namespace / QueryReceivedArgs Class

In This Topic
    QueryReceivedArgs Class Properties
    In This Topic

    For a list of all members of this type, see QueryReceivedArgs members.

    Public Properties
     | Name | Description
Public Property | Command | The incoming command (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Destination | The Application Entity Name to which images should be sent by a C-MOVE request
Public Property | Errors | List of errors found in an incoming request (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | InstanceAssociation | The Association to which to send instances using SendInstances
Public Property | Level | The Query Level
Public Property | ModificationsDone | Property to inform DicomObjects whether frame extraction (as per Supplement 119) has been performed
Public Property | NumberCompleted | Numbers of completed C-STORE sub-operations in a C-GET or C_MOVE operation
Public Property | NumberFailed | Numbers of failed C-STORE sub-operations in a C-GET or C_MOVE operation
Public Property | NumberRemaining | Numbers of remaining C-STORE sub-operations in a C-GET or C_MOVE operation
Public Property | NumberWarning | Numbers of warning C-STORE sub-operations in a C-GET or C_MOVE operation
Public Property | Operation | The normalised operation currently requested (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | PresentationContextId | The Presentation Context ID used to transmit this operation (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Request | The incoming request (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | RequestAssociation | The Association which contains the Query (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | ResultDataSet | Specifies the result DicomDataSet to be sent back for Normalised operations operations for for failures for retrieval operations (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | RetrieveType | The type of retrieval requested
Public Property | Root | The Query Root
Public Property | Status | The status to be sent back as a C-Echo response (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
    Top
    See Also

    Reference

    QueryReceivedArgs Class
    DicomObjects.EventArguments Namespace


DicomObjects.EventArguments Namespace / QueryReceivedArgs Class / Destination Property

    Destination Property (QueryReceivedArgs)
    In This Topic
    The Application Entity Name to which images should be sent by a C-MOVE request
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property Destination As String
    'Usage

    Dim instance As QueryReceivedArgs
Dim value As String

value = instance.Destination
    public string Destination {get;}
    Remarks

    A Query/Retrieve SCP must use this property to find the values of the IP address, port number and possibly Calling AET to use before calling Open on the InstanceAssociation.

    This Application Entity Name must be known by the C-MOVE SCP, as the standard allows no other means of specifying the destination. In particular, it is not possible to direct images to an arbitrary IP address and port using Move.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    QueryReceivedArgs Class
    QueryReceivedArgs Members


DicomObjects.EventArguments Namespace / QueryReceivedArgs Class / InstanceAssociation Property

    InstanceAssociation Property
    The Association to which to send instances using SendInstances
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property InstanceAssociation As DicomAssociation
    'Usage

    Dim instance As QueryReceivedArgs
Dim value As DicomAssociation

instance.InstanceAssociation = value

value = instance.InstanceAssociation
    public DicomAssociation InstanceAssociation {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    QueryReceivedArgs Class
    QueryReceivedArgs Members


DicomObjects.EventArguments Namespace / QueryReceivedArgs Class / Level Property

    Level Property (QueryReceivedArgs)
    In This Topic
    The Query Level
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property Level As QueryLevel
    'Usage

    Dim instance As QueryReceivedArgs
Dim value As QueryLevel

value = instance.Level
    public QueryLevel Level {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    QueryReceivedArgs Class
    QueryReceivedArgs Members


DicomObjects.EventArguments Namespace / QueryReceivedArgs Class / ModificationsDone Property

    ModificationsDone Property
    Property to inform DicomObjects whether frame extraction (as per Supplement 119) has been performed
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property ModificationsDone As Boolean
    'Usage

    Dim instance As QueryReceivedArgs
Dim value As Boolean

instance.ModificationsDone = value

value = instance.ModificationsDone
    public bool ModificationsDone {get; set;}
    Remarks
    If a FRAME level retrieve is requested, then the SCP is required to create a new instance consisting of the requested frames from the original image. There are 2 options for doing this in in DicomObjects:
    • Simply send the original instance using DicomObjects.DicomAssociation.SendInstances and allow DicomObjects to create the new image
    • Make the new object yourself and send using DicomObjects.DicomAssociation.SendInstances. If this option is chosen then ModificationsDone must be set to true to inform DicomObjects not to do an internal extraction as well.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    QueryReceivedArgs Class
    QueryReceivedArgs Members


DicomObjects.EventArguments Namespace / QueryReceivedArgs Class / NumberCompleted Property

    NumberCompleted Property
    Numbers of completed C-STORE sub-operations in a C-GET or C_MOVE operation
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property NumberCompleted As Integer
    'Usage

    Dim instance As QueryReceivedArgs
Dim value As Integer

instance.NumberCompleted = value

value = instance.NumberCompleted
    public int NumberCompleted {get; set;}
    Remarks
    NumberComleted, NumberWarning, NumberFailed and NumberRemaining, these values are returned to the requester as part of pending or final status notifications.

    Values are updated automatically as part of SendImages, each operation decrementing NumberRemaining, and incrementing NumberCompleted, NumberWarning or NumberFailed according to the status returned.

    If NumberRemaining is less than the number of images sent by a SendImages call, then NumberRemaining is set to the number of images to be returned by that call. Therefore, if an application intends to return all the images for a request in one operation, then it need not manipulate these values at all, as the DicomAssociation object will handle then automatically. If however the application wishes to call SendImages more than once, then NumberRemaining must be set correctly before the first call.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    QueryReceivedArgs Class
    QueryReceivedArgs Members


DicomObjects.EventArguments Namespace / QueryReceivedArgs Class / NumberFailed Property

    NumberFailed Property
    Numbers of failed C-STORE sub-operations in a C-GET or C_MOVE operation
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property NumberFailed As Integer
    'Usage

    Dim instance As QueryReceivedArgs
Dim value As Integer

instance.NumberFailed = value

value = instance.NumberFailed
    public int NumberFailed {get; set;}
    Remarks
    NumberComleted, NumberWarning, NumberFailed and NumberRemaining, these values are returned to the requester as part of pending or final status notifications.

    Values are updated automatically as part of SendImages, each operation decrementing NumberRemaining, and incrementing NumberCompleted, NumberWarning or NumberFailed according to the status returned.

    If NumberRemaining is less than the number of images sent by a SendImages call, then NumberRemaining is set to the number of images to be returned by that call. Therefore, if an application intends to return all the images for a request in one operation, then it need not manipulate these values at all, as the DicomAssociation object will handle then automatically. If however the application wishes to call SendImages more than once, then NumberRemaining must be set correctly before the first call.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    QueryReceivedArgs Class
    QueryReceivedArgs Members


DicomObjects.EventArguments Namespace / QueryReceivedArgs Class / NumberRemaining Property

    NumberRemaining Property
    Numbers of remaining C-STORE sub-operations in a C-GET or C_MOVE operation
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property NumberRemaining As Integer
    'Usage

    Dim instance As QueryReceivedArgs
Dim value As Integer

instance.NumberRemaining = value

value = instance.NumberRemaining
    public int NumberRemaining {get; set;}
    Remarks

    NumberComleted, NumberWarning, NumberFailed and NumberRemaining, these values are returned to the requester as part of pending or final status notifications.

    Values are updated automatically as part of SendImages, each operation decrementing NumberRemaining, and incrementing NumberCompleted, NumberWarning or NumberFailed according to the status returned.

    If NumberRemaining is less than the number of images sent by a SendImages call, then NumberRemaining is set to the number of images to be returned by that call. Therefore, if an application intends to return all the images for a request in one operation, then it need not manipulate these values at all, as the DicomAssociation object will handle then automatically. If however the application wishes to call SendImages more than once, then NumberRemaining must be set correctly before the first call.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    QueryReceivedArgs Class
    QueryReceivedArgs Members


DicomObjects.EventArguments Namespace / QueryReceivedArgs Class / NumberWarning Property

    NumberWarning Property
    Numbers of warning C-STORE sub-operations in a C-GET or C_MOVE operation
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property NumberWarning As Integer
    'Usage

    Dim instance As QueryReceivedArgs
Dim value As Integer

instance.NumberWarning = value

value = instance.NumberWarning
    public int NumberWarning {get; set;}
    Remarks
    NumberComleted, NumberWarning, NumberFailed and NumberRemaining, these values are returned to the requester as part of pending or final status notifications.

    Values are updated automatically as part of SendImages, each operation decrementing NumberRemaining, and incrementing NumberCompleted, NumberWarning or NumberFailed according to the status returned.

    If NumberRemaining is less than the number of images sent by a SendImages call, then NumberRemaining is set to the number of images to be returned by that call. Therefore, if an application intends to return all the images for a request in one operation, then it need not manipulate these values at all, as the DicomAssociation object will handle then automatically. If however the application wishes to call SendImages more than once, then NumberRemaining must be set correctly before the first call.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    QueryReceivedArgs Class
    QueryReceivedArgs Members


DicomObjects.EventArguments Namespace / QueryReceivedArgs Class / RetrieveType Property

    RetrieveType Property
    The type of retrieval requested
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property RetrieveType As RetrieveType
    'Usage

    Dim instance As QueryReceivedArgs
Dim value As RetrieveType

instance.RetrieveType = value

value = instance.RetrieveType
    public RetrieveType RetrieveType {get; set;}
    Remarks
    Until 2009, all DICOM retrievals were "Full", but supplement 119 introduced the concept of "No Bulk data" retrieval, which can be indicated by this property.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    QueryReceivedArgs Class
    QueryReceivedArgs Members


DicomObjects.EventArguments Namespace / QueryReceivedArgs Class / Root Property

    Root Property (QueryReceivedArgs)
    In This Topic
    The Query Root
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property Root As QueryRoot
    'Usage

    Dim instance As QueryReceivedArgs
Dim value As QueryRoot

value = instance.Root
    public QueryRoot Root {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    QueryReceivedArgs Class
    QueryReceivedArgs Members


%%PageItemTitle%%

DicomObjects.EventArguments Namespace / ReceivingPixelDataArgs Class
Members

In This Topic
    ReceivingPixelDataArgs Class
    In This Topic
    Class used by the DicomObjects.DicomServer.ReceivingPixelData event
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Class ReceivingPixelDataArgs
    'Usage

    Dim instance As ReceivingPixelDataArgs
    public class ReceivingPixelDataArgs
    Inheritance Hierarchy

    System.Object
    DicomObjects.EventArguments.ReceivingPixelDataArgs

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ReceivingPixelDataArgs Members
    DicomObjects.EventArguments Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.EventArguments Namespace / ReceivingPixelDataArgs Class
Properties Methods

In This Topic
    ReceivingPixelDataArgs Class Members
    In This Topic

    The following tables list the members exposed by ReceivingPixelDataArgs.

    Public Properties
     | Name | Description
Public Property | Association | The association on which data is arriving
Public Property | Dataset | The dataset so far
    Top
    Public Methods
     | Name | Description
Public Method | ReceiveToDisk | Write the data received so far to the names file, and then pass received pixel data direct to that file, without holding it all in memory
    Top
    See Also

    Reference

    ReceivingPixelDataArgs Class
    DicomObjects.EventArguments Namespace


%%PageItemTitle%% $$Methods$$

DicomObjects.EventArguments Namespace / ReceivingPixelDataArgs Class

In This Topic
    ReceivingPixelDataArgs Class Methods
    In This Topic

    For a list of all members of this type, see ReceivingPixelDataArgs members.

    Public Methods
     | Name | Description
Public Method | ReceiveToDisk | Write the data received so far to the names file, and then pass received pixel data direct to that file, without holding it all in memory
    Top
    See Also

    Reference

    ReceivingPixelDataArgs Class
    DicomObjects.EventArguments Namespace


DicomObjects.EventArguments Namespace / ReceivingPixelDataArgs Class / ReceiveToDisk Method

    ReceiveToDisk Method
    Write the data received so far to the names file, and then pass received pixel data direct to that file, without holding it all in memory
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Sub ReceiveToDisk( _
   ByVal FileName As String _
)
    'Usage

    Dim instance As ReceivingPixelDataArgs
Dim FileName As String

instance.ReceiveToDisk(FileName)
    public void ReceiveToDisk(
   string FileName
)

    Parameters

    FileName
    Remarks

    The transfer syntax used for the file is always the same as that received over the network

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ReceivingPixelDataArgs Class
    ReceivingPixelDataArgs Members


%%PageItemTitle%% $$Properties$$

DicomObjects.EventArguments Namespace / ReceivingPixelDataArgs Class

In This Topic
    ReceivingPixelDataArgs Class Properties
    In This Topic

    For a list of all members of this type, see ReceivingPixelDataArgs members.

    Public Properties
     | Name | Description
Public Property | Association | The association on which data is arriving
Public Property | Dataset | The dataset so far
    Top
    See Also

    Reference

    ReceivingPixelDataArgs Class
    DicomObjects.EventArguments Namespace


DicomObjects.EventArguments Namespace / ReceivingPixelDataArgs Class / Association Property

    Association Property (ReceivingPixelDataArgs)
    In This Topic
    The association on which data is arriving
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property Association As DicomAssociation
    'Usage

    Dim instance As ReceivingPixelDataArgs
Dim value As DicomAssociation

value = instance.Association
    public DicomAssociation Association {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ReceivingPixelDataArgs Class
    ReceivingPixelDataArgs Members


DicomObjects.EventArguments Namespace / ReceivingPixelDataArgs Class / Dataset Property

    Dataset Property (ReceivingPixelDataArgs)
    In This Topic
    The dataset so far
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property Dataset As DicomDataSet
    'Usage

    Dim instance As ReceivingPixelDataArgs
Dim value As DicomDataSet

value = instance.Dataset
    public DicomDataSet Dataset {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ReceivingPixelDataArgs Class
    ReceivingPixelDataArgs Members


%%PageItemTitle%%

DicomObjects.EventArguments Namespace / ResponseReceivedArgs Class
Members

In This Topic
    ResponseReceivedArgs Class
    In This Topic
    Event argument passed in the ResponseReceived
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Class ResponseReceivedArgs
   Inherits System.EventArgs
    'Usage

    Dim instance As ResponseReceivedArgs
    public class ResponseReceivedArgs : System.EventArgs
    Inheritance Hierarchy

    System.Object
    System.EventArgs
    DicomObjects.EventArguments.ResponseReceivedArgs

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ResponseReceivedArgs Members
    DicomObjects.EventArguments Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.EventArguments Namespace / ResponseReceivedArgs Class
Properties

In This Topic
    ResponseReceivedArgs Class Members
    In This Topic

    The following tables list the members exposed by ResponseReceivedArgs.

    Public Properties
     | Name | Description
Public Property | Association | The incoming association that contains the received responses
Public Property | ReturnStatus | The Status to be returned for Instance received via C-GET
    Top
    See Also

    Reference

    ResponseReceivedArgs Class
    DicomObjects.EventArguments Namespace


%%PageItemTitle%% $$Properties$$

DicomObjects.EventArguments Namespace / ResponseReceivedArgs Class

In This Topic
    ResponseReceivedArgs Class Properties
    In This Topic

    For a list of all members of this type, see ResponseReceivedArgs members.

    Public Properties
     | Name | Description
Public Property | Association | The incoming association that contains the received responses
Public Property | ReturnStatus | The Status to be returned for Instance received via C-GET
    Top
    See Also

    Reference

    ResponseReceivedArgs Class
    DicomObjects.EventArguments Namespace


DicomObjects.EventArguments Namespace / ResponseReceivedArgs Class / Association Property

    Association Property (ResponseReceivedArgs)
    In This Topic
    The incoming association that contains the received responses
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property Association As DicomAssociation
    'Usage

    Dim instance As ResponseReceivedArgs
Dim value As DicomAssociation

value = instance.Association
    public DicomAssociation Association {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ResponseReceivedArgs Class
    ResponseReceivedArgs Members


DicomObjects.EventArguments Namespace / ResponseReceivedArgs Class / ReturnStatus Property

    ReturnStatus Property
    The Status to be returned for Instance received via C-GET
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property ReturnStatus As Integer
    'Usage

    Dim instance As ResponseReceivedArgs
Dim value As Integer

instance.ReturnStatus = value

value = instance.ReturnStatus
    public int ReturnStatus {get; set;}
    Remarks

    C-GET request causes internal C-STORE operations to happen and this property provides means to send status back after each single instance received via C-STORE. The default value is zero and if you need to send non-zero status back to indicate an unsuccessful C-Store operation, set this property to any non-zero value (normally 1).

    The COM version hasn't got such a property to send non-zero C-Store (caused by C-GET) status back.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ResponseReceivedArgs Class
    ResponseReceivedArgs Members


%%PageItemTitle%%

DicomObjects.EventArguments Namespace / ValidateFragmentsArgs Class
Members

In This Topic
    ValidateFragmentsArgs Class
    In This Topic
    Argument for the DicomObjects.DicomGlobal.ValidateFragments event.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Class ValidateFragmentsArgs
    'Usage

    Dim instance As ValidateFragmentsArgs
    public class ValidateFragmentsArgs
    Inheritance Hierarchy

    System.Object
    DicomObjects.EventArguments.ValidateFragmentsArgs

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ValidateFragmentsArgs Members
    DicomObjects.EventArguments Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.EventArguments Namespace / ValidateFragmentsArgs Class
Properties

In This Topic
    ValidateFragmentsArgs Class Members
    In This Topic

    The following tables list the members exposed by ValidateFragmentsArgs.

    Public Constructors
     | Name | Description
Public Constructor | ValidateFragmentsArgs Constructor |
    Top
    Public Properties
     | Name | Description
Public Property | BasicOffsetTable | The basic offset table as read from the received data.
Public Property | DataSet | The dataset to which this pixel data belongs
Public Property | Fragments | The fragments exactly as received. These may be replaced, but if you do (whether by replacing individual Stream, or even by replacing the whole list of Streams, you must set Modified to true to force DicomObjects to use your modified data.
Public Property | Modified | Indication that data has been modified. Unless this is set to true, the return values in Fragments and BasicOffsetTable will be ignored.
    Top
    See Also

    Reference

    ValidateFragmentsArgs Class
    DicomObjects.EventArguments Namespace


%%PageItemTitle%%

DicomObjects.EventArguments Namespace / ValidateFragmentsArgs Class / ValidateFragmentsArgs Constructor

In This Topic
    ValidateFragmentsArgs Constructor
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Function New()
    'Usage

    Dim instance As New ValidateFragmentsArgs()
    public ValidateFragmentsArgs()
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ValidateFragmentsArgs Class
    ValidateFragmentsArgs Members


%%PageItemTitle%% $$Properties$$

DicomObjects.EventArguments Namespace / ValidateFragmentsArgs Class

In This Topic
    ValidateFragmentsArgs Class Properties
    In This Topic

    For a list of all members of this type, see ValidateFragmentsArgs members.

    Public Properties
     | Name | Description
Public Property | BasicOffsetTable | The basic offset table as read from the received data.
Public Property | DataSet | The dataset to which this pixel data belongs
Public Property | Fragments | The fragments exactly as received. These may be replaced, but if you do (whether by replacing individual Stream, or even by replacing the whole list of Streams, you must set Modified to true to force DicomObjects to use your modified data.
Public Property | Modified | Indication that data has been modified. Unless this is set to true, the return values in Fragments and BasicOffsetTable will be ignored.
    Top
    See Also

    Reference

    ValidateFragmentsArgs Class
    DicomObjects.EventArguments Namespace


DicomObjects.EventArguments Namespace / ValidateFragmentsArgs Class / BasicOffsetTable Property

    BasicOffsetTable Property
    The basic offset table as read from the received data.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property BasicOffsetTable As UInteger()
    'Usage

    Dim instance As ValidateFragmentsArgs
Dim value() As UInteger

instance.BasicOffsetTable = value

value = instance.BasicOffsetTable
    public uint[] BasicOffsetTable {get; set;}
    Remarks

    You may set this to null if modifying the data, and DicomObjects will attempt to recalculate it, checking whether the fragements start with the appropriate markers.

    Alternatively, you may set it explicitly

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ValidateFragmentsArgs Class
    ValidateFragmentsArgs Members


DicomObjects.EventArguments Namespace / ValidateFragmentsArgs Class / DataSet Property

    DataSet Property (ValidateFragmentsArgs)
    In This Topic
    The dataset to which this pixel data belongs
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property DataSet As DicomDataSet
    'Usage

    Dim instance As ValidateFragmentsArgs
Dim value As DicomDataSet

value = instance.DataSet
    public DicomDataSet DataSet {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ValidateFragmentsArgs Class
    ValidateFragmentsArgs Members


DicomObjects.EventArguments Namespace / ValidateFragmentsArgs Class / Fragments Property

    Fragments Property (ValidateFragmentsArgs)
    In This Topic
    The fragments exactly as received. These may be replaced, but if you do (whether by replacing individual Stream, or even by replacing the whole list of Streams, you must set Modified to true to force DicomObjects to use your modified data.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property Fragments As List(Of List(Of Stream))
    'Usage

    Dim instance As ValidateFragmentsArgs
Dim value As List(Of List(Of Stream))

instance.Fragments = value

value = instance.Fragments
    public List<List<Stream>> Fragments {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ValidateFragmentsArgs Class
    ValidateFragmentsArgs Members


DicomObjects.EventArguments Namespace / ValidateFragmentsArgs Class / Modified Property

    Modified Property
    Indication that data has been modified. Unless this is set to true, the return values in Fragments and BasicOffsetTable will be ignored.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property Modified As Boolean
    'Usage

    Dim instance As ValidateFragmentsArgs
Dim value As Boolean

instance.Modified = value

value = instance.Modified
    public bool Modified {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ValidateFragmentsArgs Class
    ValidateFragmentsArgs Members


%%PageItemTitle%%

DicomObjects.EventArguments Namespace / VerifyReceivedArgs Class
Members

In This Topic
    VerifyReceivedArgs Class
    In This Topic
    Argument passed in the VerifyReceived Event
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Class VerifyReceivedArgs
   Inherits OperationBaseArgs
    'Usage

    Dim instance As VerifyReceivedArgs
    public class VerifyReceivedArgs : OperationBaseArgs
    Inheritance Hierarchy

    System.Object
    System.EventArgs
    DicomObjects.EventArguments.OperationBaseArgs
    DicomObjects.EventArguments.VerifyReceivedArgs

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    VerifyReceivedArgs Members
    DicomObjects.EventArguments Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.EventArguments Namespace / VerifyReceivedArgs Class
Properties

In This Topic
    VerifyReceivedArgs Class Members
    In This Topic

    The following tables list the members exposed by VerifyReceivedArgs.

    Public Properties
     | Name | Description
Public Property | Command | The incoming command (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Errors | List of errors found in an incoming request (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Operation | The normalised operation currently requested (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | PresentationContextId | The Presentation Context ID used to transmit this operation (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Request | The incoming request (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | RequestAssociation | The Association which contains the Query (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | ResultDataSet | Specifies the result DicomDataSet to be sent back for Normalised operations operations for for failures for retrieval operations (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Status | The status to be sent back as a C-Echo response (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
    Top
    See Also

    Reference

    VerifyReceivedArgs Class
    DicomObjects.EventArguments Namespace


Inheritance Hierarchy
    DicomObjects.UIDs Namespace
    Classes
     | Class | Description
Class | ApplicationContexts | Contains UIDs for Application Context
Class | FramesOfReference | Well known frames of reference
Class | MetaSOPClasses | Contains UIDs for Meta SOP Class
Class | SOPClasses | Contains UIDs for SOP Class
Class | TransferSyntaxes | Contains UIDs for Transfer Syntax
Class | UID | A class to represent the constant UIDs present as readonly fields in the objects within the DicomObjects.UIDs namespace.
Class | WellKnownInstances | Contains UIDs for Well Known Instance
    See Also

    Reference

    DicomObjects.NetStandard Assembly


%%PageItemTitle%%

DicomObjects.UIDs Namespace / ApplicationContexts Class
Members

In This Topic
    ApplicationContexts Class
    In This Topic
    Contains UIDs for Application Context
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public MustInherit NotInheritable Class ApplicationContexts
    'Usage

    Dim instance As ApplicationContexts
    public static class ApplicationContexts
    Remarks

    Contains constant UID ApplicationContext "1.2.840.10008.3.1.1.1"

    Inheritance Hierarchy

    System.Object
    DicomObjects.UIDs.ApplicationContexts

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ApplicationContexts Members
    DicomObjects.UIDs Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.UIDs Namespace / ApplicationContexts Class
Fields

In This Topic
    ApplicationContexts Class Members
    In This Topic

    The following tables list the members exposed by ApplicationContexts.

    Public Fields
     | Name | Description
static (Shared in Visual Basic) | DICOM30 | DICOM Application Context Name (1.2.840.10008.3.1.1.1)
    Top
    See Also

    Reference

    ApplicationContexts Class
    DicomObjects.UIDs Namespace


%%PageItemTitle%% $$Fields$$

DicomObjects.UIDs Namespace / ApplicationContexts Class

    ApplicationContexts Class Fields
    In This Topic

    For a list of all members of this type, see ApplicationContexts members.

    Public Fields
     | Name | Description
static (Shared in Visual Basic) | DICOM30 | DICOM Application Context Name (1.2.840.10008.3.1.1.1)
    Top
    See Also

    Reference

    ApplicationContexts Class
    DicomObjects.UIDs Namespace


DicomObjects.UIDs Namespace / ApplicationContexts Class / DICOM30 Field

    DICOM30 Field
    DICOM Application Context Name (1.2.840.10008.3.1.1.1)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly DICOM30 As UID
    'Usage

    Dim value As UID

value = ApplicationContexts.DICOM30
    public static readonly UID DICOM30
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ApplicationContexts Class
    ApplicationContexts Members


%%PageItemTitle%%

DicomObjects.UIDs Namespace / FramesOfReference Class
Members

In This Topic
    FramesOfReference Class
    In This Topic
    Well known frames of reference
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public MustInherit NotInheritable Class FramesOfReference
    'Usage

    Dim instance As FramesOfReference
    public static class FramesOfReference
    Remarks
    The constants in this class are well-known instances, representing externally defined frames of reference
    Inheritance Hierarchy

    System.Object
    DicomObjects.UIDs.FramesOfReference

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    FramesOfReference Members
    DicomObjects.UIDs Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.UIDs Namespace / FramesOfReference Class
Fields

In This Topic
    FramesOfReference Class Members
    In This Topic

    The following tables list the members exposed by FramesOfReference.

    Public Fields
     | Name | Description
static (Shared in Visual Basic) | ICBM452T1FrameofReference | ICBM 452 T1 Frame of Reference (1.2.840.10008.1.4.2.1)
static (Shared in Visual Basic) | ICBMSingleSubjectMRIFrameofReference | ICBM Single Subject MRI Frame of Reference (1.2.840.10008.1.4.2.2)
static (Shared in Visual Basic) | SPM2AVG152PDFrameofReference | SPM2 AVG152PD Frame of Reference (1.2.840.10008.1.4.1.17)
static (Shared in Visual Basic) | SPM2AVG152T1FrameofReference | SPM2 AVG152T1 Frame of Reference (1.2.840.10008.1.4.1.15)
static (Shared in Visual Basic) | SPM2AVG152T2FrameofReference | SPM2 AVG152T2 Frame of Reference (1.2.840.10008.1.4.1.16)
static (Shared in Visual Basic) | SPM2AVG305T1FrameofReference | SPM2 AVG305T1 Frame of Reference (1.2.840.10008.1.4.1.14)
static (Shared in Visual Basic) | SPM2BRAINMASKFrameofReference | SPM2 BRAINMASK Frame of Reference (1.2.840.10008.1.4.1.13)
static (Shared in Visual Basic) | SPM2CSFFrameofReference | SPM2 CSF Frame of Reference (1.2.840.10008.1.4.1.12)
static (Shared in Visual Basic) | SPM2EPIFrameofReference | SPM2 EPI Frame of Reference (1.2.840.10008.1.4.1.5)
static (Shared in Visual Basic) | SPM2FILT1FrameofReference | SPM2 FIL T1 Frame of Reference (1.2.840.10008.1.4.1.6)
static (Shared in Visual Basic) | SPM2GRAYFrameofReference | SPM2 GRAY Frame of Reference (1.2.840.10008.1.4.1.10)
static (Shared in Visual Basic) | SPM2PDFrameofReference | SPM2 PD Frame of Reference (1.2.840.10008.1.4.1.4)
static (Shared in Visual Basic) | SPM2PETFrameofReference | SPM2 PET Frame of Reference (1.2.840.10008.1.4.1.7)
static (Shared in Visual Basic) | SPM2SINGLESUBJT1FrameofReference | SPM2 SINGLESUBJT1 Frame of Reference (1.2.840.10008.1.4.1.18)
static (Shared in Visual Basic) | SPM2SPECTFrameofReference | SPM2 SPECT Frame of Reference (1.2.840.10008.1.4.1.9)
static (Shared in Visual Basic) | SPM2T1FrameofReference | SPM2 T1 Frame of Reference (1.2.840.10008.1.4.1.2)
static (Shared in Visual Basic) | SPM2T2FrameofReference | SPM2 T2 Frame of Reference (1.2.840.10008.1.4.1.3)
static (Shared in Visual Basic) | SPM2TRANSMFrameofReference | SPM2 TRANSM Frame of Reference (1.2.840.10008.1.4.1.8)
static (Shared in Visual Basic) | SPM2WHITEFrameofReference | SPM2 WHITE Frame of Reference (1.2.840.10008.1.4.1.11)
static (Shared in Visual Basic) | TalairachBrainAtlasFrameofReference | Talairach Brain Atlas Frame of Reference (1.2.840.10008.1.4.1.1)
    Top
    See Also

    Reference

    FramesOfReference Class
    DicomObjects.UIDs Namespace


%%PageItemTitle%% $$Fields$$

DicomObjects.UIDs Namespace / FramesOfReference Class

    FramesOfReference Class Fields
    In This Topic

    For a list of all members of this type, see FramesOfReference members.

    Public Fields
     | Name | Description
static (Shared in Visual Basic) | ICBM452T1FrameofReference | ICBM 452 T1 Frame of Reference (1.2.840.10008.1.4.2.1)
static (Shared in Visual Basic) | ICBMSingleSubjectMRIFrameofReference | ICBM Single Subject MRI Frame of Reference (1.2.840.10008.1.4.2.2)
static (Shared in Visual Basic) | SPM2AVG152PDFrameofReference | SPM2 AVG152PD Frame of Reference (1.2.840.10008.1.4.1.17)
static (Shared in Visual Basic) | SPM2AVG152T1FrameofReference | SPM2 AVG152T1 Frame of Reference (1.2.840.10008.1.4.1.15)
static (Shared in Visual Basic) | SPM2AVG152T2FrameofReference | SPM2 AVG152T2 Frame of Reference (1.2.840.10008.1.4.1.16)
static (Shared in Visual Basic) | SPM2AVG305T1FrameofReference | SPM2 AVG305T1 Frame of Reference (1.2.840.10008.1.4.1.14)
static (Shared in Visual Basic) | SPM2BRAINMASKFrameofReference | SPM2 BRAINMASK Frame of Reference (1.2.840.10008.1.4.1.13)
static (Shared in Visual Basic) | SPM2CSFFrameofReference | SPM2 CSF Frame of Reference (1.2.840.10008.1.4.1.12)
static (Shared in Visual Basic) | SPM2EPIFrameofReference | SPM2 EPI Frame of Reference (1.2.840.10008.1.4.1.5)
static (Shared in Visual Basic) | SPM2FILT1FrameofReference | SPM2 FIL T1 Frame of Reference (1.2.840.10008.1.4.1.6)
static (Shared in Visual Basic) | SPM2GRAYFrameofReference | SPM2 GRAY Frame of Reference (1.2.840.10008.1.4.1.10)
static (Shared in Visual Basic) | SPM2PDFrameofReference | SPM2 PD Frame of Reference (1.2.840.10008.1.4.1.4)
static (Shared in Visual Basic) | SPM2PETFrameofReference | SPM2 PET Frame of Reference (1.2.840.10008.1.4.1.7)
static (Shared in Visual Basic) | SPM2SINGLESUBJT1FrameofReference | SPM2 SINGLESUBJT1 Frame of Reference (1.2.840.10008.1.4.1.18)
static (Shared in Visual Basic) | SPM2SPECTFrameofReference | SPM2 SPECT Frame of Reference (1.2.840.10008.1.4.1.9)
static (Shared in Visual Basic) | SPM2T1FrameofReference | SPM2 T1 Frame of Reference (1.2.840.10008.1.4.1.2)
static (Shared in Visual Basic) | SPM2T2FrameofReference | SPM2 T2 Frame of Reference (1.2.840.10008.1.4.1.3)
static (Shared in Visual Basic) | SPM2TRANSMFrameofReference | SPM2 TRANSM Frame of Reference (1.2.840.10008.1.4.1.8)
static (Shared in Visual Basic) | SPM2WHITEFrameofReference | SPM2 WHITE Frame of Reference (1.2.840.10008.1.4.1.11)
static (Shared in Visual Basic) | TalairachBrainAtlasFrameofReference | Talairach Brain Atlas Frame of Reference (1.2.840.10008.1.4.1.1)
    Top
    See Also

    Reference

    FramesOfReference Class
    DicomObjects.UIDs Namespace


DicomObjects.UIDs Namespace / FramesOfReference Class / ICBM452T1FrameofReference Field

    ICBM452T1FrameofReference Field
    ICBM 452 T1 Frame of Reference (1.2.840.10008.1.4.2.1)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly ICBM452T1FrameofReference As UID
    'Usage

    Dim value As UID

value = FramesOfReference.ICBM452T1FrameofReference
    public static readonly UID ICBM452T1FrameofReference
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    FramesOfReference Class
    FramesOfReference Members


DicomObjects.UIDs Namespace / FramesOfReference Class / ICBMSingleSubjectMRIFrameofReference Field

    ICBMSingleSubjectMRIFrameofReference Field
    ICBM Single Subject MRI Frame of Reference (1.2.840.10008.1.4.2.2)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly ICBMSingleSubjectMRIFrameofReference As UID
    'Usage

    Dim value As UID

value = FramesOfReference.ICBMSingleSubjectMRIFrameofReference
    public static readonly UID ICBMSingleSubjectMRIFrameofReference
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    FramesOfReference Class
    FramesOfReference Members


DicomObjects.UIDs Namespace / FramesOfReference Class / SPM2AVG152PDFrameofReference Field

    SPM2AVG152PDFrameofReference Field
    SPM2 AVG152PD Frame of Reference (1.2.840.10008.1.4.1.17)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly SPM2AVG152PDFrameofReference As UID
    'Usage

    Dim value As UID

value = FramesOfReference.SPM2AVG152PDFrameofReference
    public static readonly UID SPM2AVG152PDFrameofReference
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    FramesOfReference Class
    FramesOfReference Members


DicomObjects.UIDs Namespace / FramesOfReference Class / SPM2AVG152T1FrameofReference Field

    SPM2AVG152T1FrameofReference Field
    SPM2 AVG152T1 Frame of Reference (1.2.840.10008.1.4.1.15)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly SPM2AVG152T1FrameofReference As UID
    'Usage

    Dim value As UID

value = FramesOfReference.SPM2AVG152T1FrameofReference
    public static readonly UID SPM2AVG152T1FrameofReference
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    FramesOfReference Class
    FramesOfReference Members


DicomObjects.UIDs Namespace / FramesOfReference Class / SPM2AVG152T2FrameofReference Field

    SPM2AVG152T2FrameofReference Field
    SPM2 AVG152T2 Frame of Reference (1.2.840.10008.1.4.1.16)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly SPM2AVG152T2FrameofReference As UID
    'Usage

    Dim value As UID

value = FramesOfReference.SPM2AVG152T2FrameofReference
    public static readonly UID SPM2AVG152T2FrameofReference
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    FramesOfReference Class
    FramesOfReference Members


DicomObjects.UIDs Namespace / FramesOfReference Class / SPM2AVG305T1FrameofReference Field

    SPM2AVG305T1FrameofReference Field
    SPM2 AVG305T1 Frame of Reference (1.2.840.10008.1.4.1.14)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly SPM2AVG305T1FrameofReference As UID
    'Usage

    Dim value As UID

value = FramesOfReference.SPM2AVG305T1FrameofReference
    public static readonly UID SPM2AVG305T1FrameofReference
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    FramesOfReference Class
    FramesOfReference Members


DicomObjects.UIDs Namespace / FramesOfReference Class / SPM2BRAINMASKFrameofReference Field

    SPM2BRAINMASKFrameofReference Field
    SPM2 BRAINMASK Frame of Reference (1.2.840.10008.1.4.1.13)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly SPM2BRAINMASKFrameofReference As UID
    'Usage

    Dim value As UID

value = FramesOfReference.SPM2BRAINMASKFrameofReference
    public static readonly UID SPM2BRAINMASKFrameofReference
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    FramesOfReference Class
    FramesOfReference Members


DicomObjects.UIDs Namespace / FramesOfReference Class / SPM2CSFFrameofReference Field

    SPM2CSFFrameofReference Field
    SPM2 CSF Frame of Reference (1.2.840.10008.1.4.1.12)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly SPM2CSFFrameofReference As UID
    'Usage

    Dim value As UID

value = FramesOfReference.SPM2CSFFrameofReference
    public static readonly UID SPM2CSFFrameofReference
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    FramesOfReference Class
    FramesOfReference Members


DicomObjects.UIDs Namespace / FramesOfReference Class / SPM2EPIFrameofReference Field

    SPM2EPIFrameofReference Field
    SPM2 EPI Frame of Reference (1.2.840.10008.1.4.1.5)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly SPM2EPIFrameofReference As UID
    'Usage

    Dim value As UID

value = FramesOfReference.SPM2EPIFrameofReference
    public static readonly UID SPM2EPIFrameofReference
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    FramesOfReference Class
    FramesOfReference Members


DicomObjects.UIDs Namespace / FramesOfReference Class / SPM2FILT1FrameofReference Field

    SPM2FILT1FrameofReference Field
    SPM2 FIL T1 Frame of Reference (1.2.840.10008.1.4.1.6)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly SPM2FILT1FrameofReference As UID
    'Usage

    Dim value As UID

value = FramesOfReference.SPM2FILT1FrameofReference
    public static readonly UID SPM2FILT1FrameofReference
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    FramesOfReference Class
    FramesOfReference Members


DicomObjects.UIDs Namespace / FramesOfReference Class / SPM2GRAYFrameofReference Field

    SPM2GRAYFrameofReference Field
    SPM2 GRAY Frame of Reference (1.2.840.10008.1.4.1.10)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly SPM2GRAYFrameofReference As UID
    'Usage

    Dim value As UID

value = FramesOfReference.SPM2GRAYFrameofReference
    public static readonly UID SPM2GRAYFrameofReference
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    FramesOfReference Class
    FramesOfReference Members


DicomObjects.UIDs Namespace / FramesOfReference Class / SPM2PDFrameofReference Field

    SPM2PDFrameofReference Field
    SPM2 PD Frame of Reference (1.2.840.10008.1.4.1.4)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly SPM2PDFrameofReference As UID
    'Usage

    Dim value As UID

value = FramesOfReference.SPM2PDFrameofReference
    public static readonly UID SPM2PDFrameofReference
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    FramesOfReference Class
    FramesOfReference Members


DicomObjects.UIDs Namespace / FramesOfReference Class / SPM2PETFrameofReference Field

    SPM2PETFrameofReference Field
    SPM2 PET Frame of Reference (1.2.840.10008.1.4.1.7)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly SPM2PETFrameofReference As UID
    'Usage

    Dim value As UID

value = FramesOfReference.SPM2PETFrameofReference
    public static readonly UID SPM2PETFrameofReference
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    FramesOfReference Class
    FramesOfReference Members


DicomObjects.UIDs Namespace / FramesOfReference Class / SPM2SINGLESUBJT1FrameofReference Field

    SPM2SINGLESUBJT1FrameofReference Field
    SPM2 SINGLESUBJT1 Frame of Reference (1.2.840.10008.1.4.1.18)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly SPM2SINGLESUBJT1FrameofReference As UID
    'Usage

    Dim value As UID

value = FramesOfReference.SPM2SINGLESUBJT1FrameofReference
    public static readonly UID SPM2SINGLESUBJT1FrameofReference
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    FramesOfReference Class
    FramesOfReference Members


DicomObjects.UIDs Namespace / FramesOfReference Class / SPM2SPECTFrameofReference Field

    SPM2SPECTFrameofReference Field
    SPM2 SPECT Frame of Reference (1.2.840.10008.1.4.1.9)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly SPM2SPECTFrameofReference As UID
    'Usage

    Dim value As UID

value = FramesOfReference.SPM2SPECTFrameofReference
    public static readonly UID SPM2SPECTFrameofReference
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    FramesOfReference Class
    FramesOfReference Members


DicomObjects.UIDs Namespace / FramesOfReference Class / SPM2T1FrameofReference Field

    SPM2T1FrameofReference Field
    SPM2 T1 Frame of Reference (1.2.840.10008.1.4.1.2)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly SPM2T1FrameofReference As UID
    'Usage

    Dim value As UID

value = FramesOfReference.SPM2T1FrameofReference
    public static readonly UID SPM2T1FrameofReference
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    FramesOfReference Class
    FramesOfReference Members


DicomObjects.UIDs Namespace / FramesOfReference Class / SPM2T2FrameofReference Field

    SPM2T2FrameofReference Field
    SPM2 T2 Frame of Reference (1.2.840.10008.1.4.1.3)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly SPM2T2FrameofReference As UID
    'Usage

    Dim value As UID

value = FramesOfReference.SPM2T2FrameofReference
    public static readonly UID SPM2T2FrameofReference
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    FramesOfReference Class
    FramesOfReference Members


DicomObjects.UIDs Namespace / FramesOfReference Class / SPM2TRANSMFrameofReference Field

    SPM2TRANSMFrameofReference Field
    SPM2 TRANSM Frame of Reference (1.2.840.10008.1.4.1.8)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly SPM2TRANSMFrameofReference As UID
    'Usage

    Dim value As UID

value = FramesOfReference.SPM2TRANSMFrameofReference
    public static readonly UID SPM2TRANSMFrameofReference
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    FramesOfReference Class
    FramesOfReference Members


DicomObjects.UIDs Namespace / FramesOfReference Class / SPM2WHITEFrameofReference Field

    SPM2WHITEFrameofReference Field
    SPM2 WHITE Frame of Reference (1.2.840.10008.1.4.1.11)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly SPM2WHITEFrameofReference As UID
    'Usage

    Dim value As UID

value = FramesOfReference.SPM2WHITEFrameofReference
    public static readonly UID SPM2WHITEFrameofReference
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    FramesOfReference Class
    FramesOfReference Members


DicomObjects.UIDs Namespace / FramesOfReference Class / TalairachBrainAtlasFrameofReference Field

    TalairachBrainAtlasFrameofReference Field
    Talairach Brain Atlas Frame of Reference (1.2.840.10008.1.4.1.1)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly TalairachBrainAtlasFrameofReference As UID
    'Usage

    Dim value As UID

value = FramesOfReference.TalairachBrainAtlasFrameofReference
    public static readonly UID TalairachBrainAtlasFrameofReference
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    FramesOfReference Class
    FramesOfReference Members


%%PageItemTitle%%

DicomObjects.UIDs Namespace / MetaSOPClasses Class
Members

In This Topic
    MetaSOPClasses Class
    In This Topic
    Contains UIDs for Meta SOP Class
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public MustInherit NotInheritable Class MetaSOPClasses
    'Usage

    Dim instance As MetaSOPClasses
    public static class MetaSOPClasses
    Inheritance Hierarchy

    System.Object
    DicomObjects.UIDs.MetaSOPClasses

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    MetaSOPClasses Members
    DicomObjects.UIDs Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.UIDs Namespace / MetaSOPClasses Class
Fields

In This Topic
    MetaSOPClasses Class Members
    In This Topic

    The following tables list the members exposed by MetaSOPClasses.

    Public Fields
     | Name | Description
static (Shared in Visual Basic) | BasicColorPrint | Basic SKColor Print Management Meta SOP Class (1.2.840.10008.5.1.1.18)
static (Shared in Visual Basic) | BasicGrayscalePrint | Basic Grayscale Print Management Meta SOP Class (1.2.840.10008.5.1.1.9)
static (Shared in Visual Basic) | DetachedPatient | Detached Patient Management Meta SOP Class (Retired) (1.2.840.10008.3.1.2.1.4)
static (Shared in Visual Basic) | DetachedResults | Detached Results Management Meta SOP Class (Retired) (1.2.840.10008.3.1.2.5.4)
static (Shared in Visual Basic) | DetachedStudy | Detached Study Management Meta SOP Class (Retired) (1.2.840.10008.3.1.2.5.5)
static (Shared in Visual Basic) | GeneralPurposeWorklist | General Purpose Worklist Management Meta SOP Class (1.2.840.10008.5.1.4.32)
static (Shared in Visual Basic) | PullStoredPrint | Pull Stored Print Management Meta SOP Class (Retired) (1.2.840.10008.5.1.1.32)
static (Shared in Visual Basic) | ReferencedColorPrint | Referenced SKColor Print Management Meta SOP Class (Retired) (1.2.840.10008.5.1.1.18.1)
static (Shared in Visual Basic) | ReferencedGrayscalePrint | Referenced Grayscale Print Management Meta SOP Class (Retired) (1.2.840.10008.5.1.1.9.1)
    Top
    See Also

    Reference

    MetaSOPClasses Class
    DicomObjects.UIDs Namespace


%%PageItemTitle%% $$Fields$$

DicomObjects.UIDs Namespace / MetaSOPClasses Class

    MetaSOPClasses Class Fields
    In This Topic

    For a list of all members of this type, see MetaSOPClasses members.

    Public Fields
     | Name | Description
static (Shared in Visual Basic) | BasicColorPrint | Basic SKColor Print Management Meta SOP Class (1.2.840.10008.5.1.1.18)
static (Shared in Visual Basic) | BasicGrayscalePrint | Basic Grayscale Print Management Meta SOP Class (1.2.840.10008.5.1.1.9)
static (Shared in Visual Basic) | DetachedPatient | Detached Patient Management Meta SOP Class (Retired) (1.2.840.10008.3.1.2.1.4)
static (Shared in Visual Basic) | DetachedResults | Detached Results Management Meta SOP Class (Retired) (1.2.840.10008.3.1.2.5.4)
static (Shared in Visual Basic) | DetachedStudy | Detached Study Management Meta SOP Class (Retired) (1.2.840.10008.3.1.2.5.5)
static (Shared in Visual Basic) | GeneralPurposeWorklist | General Purpose Worklist Management Meta SOP Class (1.2.840.10008.5.1.4.32)
static (Shared in Visual Basic) | PullStoredPrint | Pull Stored Print Management Meta SOP Class (Retired) (1.2.840.10008.5.1.1.32)
static (Shared in Visual Basic) | ReferencedColorPrint | Referenced SKColor Print Management Meta SOP Class (Retired) (1.2.840.10008.5.1.1.18.1)
static (Shared in Visual Basic) | ReferencedGrayscalePrint | Referenced Grayscale Print Management Meta SOP Class (Retired) (1.2.840.10008.5.1.1.9.1)
    Top
    See Also

    Reference

    MetaSOPClasses Class
    DicomObjects.UIDs Namespace


DicomObjects.UIDs Namespace / MetaSOPClasses Class / BasicColorPrint Field

    BasicColorPrint Field
    Basic SKColor Print Management Meta SOP Class (1.2.840.10008.5.1.1.18)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly BasicColorPrint As UID
    'Usage

    Dim value As UID

value = MetaSOPClasses.BasicColorPrint
    public static readonly UID BasicColorPrint
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    MetaSOPClasses Class
    MetaSOPClasses Members


DicomObjects.UIDs Namespace / MetaSOPClasses Class / BasicGrayscalePrint Field

    BasicGrayscalePrint Field
    Basic Grayscale Print Management Meta SOP Class (1.2.840.10008.5.1.1.9)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly BasicGrayscalePrint As UID
    'Usage

    Dim value As UID

value = MetaSOPClasses.BasicGrayscalePrint
    public static readonly UID BasicGrayscalePrint
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    MetaSOPClasses Class
    MetaSOPClasses Members


DicomObjects.UIDs Namespace / MetaSOPClasses Class / DetachedPatient Field

    DetachedPatient Field
    Detached Patient Management Meta SOP Class (Retired) (1.2.840.10008.3.1.2.1.4)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    <ObsoleteAttribute("Retired UID - should not be used in new implementions")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Shared ReadOnly DetachedPatient As UID
    'Usage

    Dim value As UID

value = MetaSOPClasses.DetachedPatient
    [Obsolete("Retired UID - should not be used in new implementions")]
[EditorBrowsable(EditorBrowsableState.Advanced)]
public static readonly UID DetachedPatient
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    MetaSOPClasses Class
    MetaSOPClasses Members


DicomObjects.UIDs Namespace / MetaSOPClasses Class / DetachedResults Field

    DetachedResults Field
    Detached Results Management Meta SOP Class (Retired) (1.2.840.10008.3.1.2.5.4)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    <ObsoleteAttribute("Retired UID - should not be used in new implementions")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Shared ReadOnly DetachedResults As UID
    'Usage

    Dim value As UID

value = MetaSOPClasses.DetachedResults
    [Obsolete("Retired UID - should not be used in new implementions")]
[EditorBrowsable(EditorBrowsableState.Advanced)]
public static readonly UID DetachedResults
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    MetaSOPClasses Class
    MetaSOPClasses Members


DicomObjects.UIDs Namespace / MetaSOPClasses Class / DetachedStudy Field

    DetachedStudy Field
    Detached Study Management Meta SOP Class (Retired) (1.2.840.10008.3.1.2.5.5)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    <ObsoleteAttribute("Retired UID - should not be used in new implementions")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Shared ReadOnly DetachedStudy As UID
    'Usage

    Dim value As UID

value = MetaSOPClasses.DetachedStudy
    [Obsolete("Retired UID - should not be used in new implementions")]
[EditorBrowsable(EditorBrowsableState.Advanced)]
public static readonly UID DetachedStudy
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    MetaSOPClasses Class
    MetaSOPClasses Members


DicomObjects.UIDs Namespace / MetaSOPClasses Class / GeneralPurposeWorklist Field

    GeneralPurposeWorklist Field
    General Purpose Worklist Management Meta SOP Class (1.2.840.10008.5.1.4.32)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly GeneralPurposeWorklist As UID
    'Usage

    Dim value As UID

value = MetaSOPClasses.GeneralPurposeWorklist
    public static readonly UID GeneralPurposeWorklist
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    MetaSOPClasses Class
    MetaSOPClasses Members


DicomObjects.UIDs Namespace / MetaSOPClasses Class / PullStoredPrint Field

    PullStoredPrint Field
    Pull Stored Print Management Meta SOP Class (Retired) (1.2.840.10008.5.1.1.32)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    <ObsoleteAttribute("Retired UID - should not be used in new implementions")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Shared ReadOnly PullStoredPrint As UID
    'Usage

    Dim value As UID

value = MetaSOPClasses.PullStoredPrint
    [Obsolete("Retired UID - should not be used in new implementions")]
[EditorBrowsable(EditorBrowsableState.Advanced)]
public static readonly UID PullStoredPrint
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    MetaSOPClasses Class
    MetaSOPClasses Members


DicomObjects.UIDs Namespace / MetaSOPClasses Class / ReferencedColorPrint Field

    ReferencedColorPrint Field
    Referenced SKColor Print Management Meta SOP Class (Retired) (1.2.840.10008.5.1.1.18.1)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    <ObsoleteAttribute("Retired UID - should not be used in new implementions")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Shared ReadOnly ReferencedColorPrint As UID
    'Usage

    Dim value As UID

value = MetaSOPClasses.ReferencedColorPrint
    [Obsolete("Retired UID - should not be used in new implementions")]
[EditorBrowsable(EditorBrowsableState.Advanced)]
public static readonly UID ReferencedColorPrint
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    MetaSOPClasses Class
    MetaSOPClasses Members


DicomObjects.UIDs Namespace / MetaSOPClasses Class / ReferencedGrayscalePrint Field

    ReferencedGrayscalePrint Field
    Referenced Grayscale Print Management Meta SOP Class (Retired) (1.2.840.10008.5.1.1.9.1)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    <ObsoleteAttribute("Retired UID - should not be used in new implementions")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Shared ReadOnly ReferencedGrayscalePrint As UID
    'Usage

    Dim value As UID

value = MetaSOPClasses.ReferencedGrayscalePrint
    [Obsolete("Retired UID - should not be used in new implementions")]
[EditorBrowsable(EditorBrowsableState.Advanced)]
public static readonly UID ReferencedGrayscalePrint
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    MetaSOPClasses Class
    MetaSOPClasses Members


%%PageItemTitle%%

DicomObjects.UIDs Namespace / SOPClasses Class
Members

In This Topic
    SOPClasses Class
    In This Topic
    Contains UIDs for SOP Class
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public MustInherit NotInheritable Class SOPClasses
    'Usage

    Dim instance As SOPClasses
    public static class SOPClasses
    Remarks
    Contains a full list of all DICOM SOP Class UIDs.
    Inheritance Hierarchy

    System.Object
    DicomObjects.UIDs.SOPClasses

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Members
    DicomObjects.UIDs Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.UIDs Namespace / SOPClasses Class
Fields

In This Topic
    SOPClasses Class Members
    In This Topic

    The following tables list the members exposed by SOPClasses.

    Public Fields
     | Name | Description
static (Shared in Visual Basic) | AmbulatoryECGWaveform | Ambulatory ECG Waveform Storage (1.2.840.10008.5.1.4.1.1.9.1.3)
static (Shared in Visual Basic) | ArterialPulseWaveform | Arterial Pulse Waveform Storage (1.2.840.10008.5.1.4.1.1.9.5.1)
static (Shared in Visual Basic) | AudioSRTrial | Audio SR Storage - Trial (Retired) (1.2.840.10008.5.1.4.1.1.88.2)
static (Shared in Visual Basic) | AutorefractionMeasurements | Autorefraction Measurements Storage (1.2.840.10008.5.1.4.1.1.78.2)
static (Shared in Visual Basic) | BasicAnnotationBox | Basic Annotation Box SOP Class (1.2.840.10008.5.1.1.15)
static (Shared in Visual Basic) | BasicColorImageBox | Basic SKColor Image Box SOP Class (1.2.840.10008.5.1.1.4.1)
static (Shared in Visual Basic) | BasicFilmBox | Basic Film Box SOP Class (1.2.840.10008.5.1.1.2)
static (Shared in Visual Basic) | BasicFilmSession | Basic Film Session SOP Class (1.2.840.10008.5.1.1.1)
static (Shared in Visual Basic) | BasicGrayscaleImageBox | Basic Grayscale Image Box SOP Class (1.2.840.10008.5.1.1.4)
static (Shared in Visual Basic) | BasicPrintImageOverlayBox | Basic Print Image Overlay Box SOP Class (Retired) (1.2.840.10008.5.1.1.24.1)
static (Shared in Visual Basic) | BasicStructuredDisplay | Basic Structured Display Storage (1.2.840.10008.5.1.4.1.1.131)
static (Shared in Visual Basic) | BasicStudyContentNotification | Basic Study Content Notification SOP Class (Retired) (1.2.840.10008.1.9)
static (Shared in Visual Basic) | BasicTextSR | Basic Text SR Storage (1.2.840.10008.5.1.4.1.1.88.11)
static (Shared in Visual Basic) | BasicVoiceAudioWaveform | Basic Voice Audio Waveform Storage (1.2.840.10008.5.1.4.1.1.9.4.1)
static (Shared in Visual Basic) | BlendingSoftcopyPresentationState | Blending Softcopy Presentation State Storage SOP Class (1.2.840.10008.5.1.4.1.1.11.4)
static (Shared in Visual Basic) | BreastImagingRelevantPatientInformationQuery | Breast Imaging Relevant Patient Information Query (1.2.840.10008.5.1.4.37.2)
static (Shared in Visual Basic) | BreastTomosynthesisImage | Breast Tomosynthesis Image Storage (1.2.840.10008.5.1.4.1.1.13.1.3)
static (Shared in Visual Basic) | CardiacElectrophysiologyWaveform | Cardiac Electrophysiology Waveform Storage (1.2.840.10008.5.1.4.1.1.9.3.1)
static (Shared in Visual Basic) | CardiacRelevantPatientInformationQuery | Cardiac Relevant Patient Information Query (1.2.840.10008.5.1.4.37.3)
static (Shared in Visual Basic) | ChestCADSR | Chest CAD SR Storage (1.2.840.10008.5.1.4.1.1.88.65)
static (Shared in Visual Basic) | ColonCADSR | Colon CAD SR Storage (1.2.840.10008.5.1.4.1.1.88.69)
static (Shared in Visual Basic) | ColorPalette | SKColor Palette Storage (1.2.840.10008.5.1.4.39.1)
static (Shared in Visual Basic) | ColorPaletteQRFIND | SKColor Palette Information Model - FIND (1.2.840.10008.5.1.4.39.2)
static (Shared in Visual Basic) | ColorPaletteQRGET | SKColor Palette Information Model - GET (1.2.840.10008.5.1.4.39.4)
static (Shared in Visual Basic) | ColorPaletteQRMOVE | SKColor Palette Information Model - MOVE (1.2.840.10008.5.1.4.39.3)
static (Shared in Visual Basic) | ColorSoftcopyPresentationState | SKColor Softcopy Presentation State Storage SOP Class (1.2.840.10008.5.1.4.1.1.11.2)
static (Shared in Visual Basic) | CompositeInstanceRootRetrieve_GET | Composite Instance Root Retrieve - GET (1.2.840.10008.5.1.4.1.2.4.3)
static (Shared in Visual Basic) | CompositeInstanceRootRetrieve_MOVE | Composite Instance Root Retrieve - MOVE (1.2.840.10008.5.1.4.1.2.4.2)
static (Shared in Visual Basic) | CompositeInstanceRootRetrieveWithoutBulkData_GET | Composite Instance Retrieve Without Bulk Data - GET (1.2.840.10008.5.1.4.1.2.5.3)
static (Shared in Visual Basic) | ComprehensiveSR | Comprehensive SR Storage (1.2.840.10008.5.1.4.1.1.88.33)
static (Shared in Visual Basic) | ComprehensiveSRTrial | Comprehensive SR Storage - Trial (Retired) (1.2.840.10008.5.1.4.1.1.88.4)
static (Shared in Visual Basic) | ComputedRadiography | Computed Radiography Image Storage (1.2.840.10008.5.1.4.1.1.1)
static (Shared in Visual Basic) | CornealTopographyMap | Corneal Topography Map Storage (1.2.840.10008.5.1.4.1.1.82.1)
static (Shared in Visual Basic) | CT | CT Image Storage (1.2.840.10008.5.1.4.1.1.2)
static (Shared in Visual Basic) | DeformableSpatialRegistration | Deformable Spatial Registration Storage (1.2.840.10008.5.1.4.1.1.66.3)
static (Shared in Visual Basic) | DetachedInterpretationManagement | Detached Interpretation Management SOP Class (Retired) (1.2.840.10008.3.1.2.6.1)
static (Shared in Visual Basic) | DetachedPatientManagement | Detached Patient Management SOP Class (Retired) (1.2.840.10008.3.1.2.1.1)
static (Shared in Visual Basic) | DetachedResultsManagement | Detached Results Management SOP Class (Retired) (1.2.840.10008.3.1.2.5.1)
static (Shared in Visual Basic) | DetachedStudyManagement | Detached Study Management SOP Class (Retired) (1.2.840.10008.3.1.2.3.1)
static (Shared in Visual Basic) | DetachedVisitManagement | Detached Visit Management SOP Class (Retired) (1.2.840.10008.3.1.2.2.1)
static (Shared in Visual Basic) | DetailSRTrial | Detail SR Storage - Trial (Retired) (1.2.840.10008.5.1.4.1.1.88.3)
static (Shared in Visual Basic) | DICOSCTImage | DICOS CT Image Storage (1.2.840.10008.5.1.4.1.1.501.1)
static (Shared in Visual Basic) | DICOSDigitalXRayImageForPresentation | DICOS Digital X-Ray Image Storage - For Presentation (1.2.840.10008.5.1.4.1.1.501.2.1)
static (Shared in Visual Basic) | DICOSDigitalXRayImageForProcessing | DICOS Digital X-Ray Image Storage - For Processing (1.2.840.10008.5.1.4.1.1.501.2.2)
static (Shared in Visual Basic) | DICOSThreatDetectionReport | DICOS Threat Detection Report Storage (1.2.840.10008.5.1.4.1.1.501.3)
static (Shared in Visual Basic) | DigitalIntraoralXRay_Presentation | Digital Intra-oral X-Ray Image Storage - For Presentation (1.2.840.10008.5.1.4.1.1.1.3)
static (Shared in Visual Basic) | DigitalIntraoralXRay_Processing | Digital Intra-oral X-Ray Image Storage - For Processing (1.2.840.10008.5.1.4.1.1.1.3.1)
static (Shared in Visual Basic) | DigitalMammographyXRay_Presentation | Digital Mammography X-Ray Image Storage - For Presentation (1.2.840.10008.5.1.4.1.1.1.2)
static (Shared in Visual Basic) | DigitalMammographyXRay_Processing | Digital Mammography X-Ray Image Storage - For Processing (1.2.840.10008.5.1.4.1.1.1.2.1)
static (Shared in Visual Basic) | DigitalXRay_Presentation | Digital X-Ray Image Storage - For Presentation (1.2.840.10008.5.1.4.1.1.1.1)
static (Shared in Visual Basic) | DigitalXRay_Processing | Digital X-Ray Image Storage - For Processing (1.2.840.10008.5.1.4.1.1.1.1.1)
static (Shared in Visual Basic) | EddyCurrentImage | Eddy Current Image Storage (1.2.840.10008.5.1.4.1.1.601.1)
static (Shared in Visual Basic) | EddyCurrentMultiframeImage | Eddy Current Multi-frame Image Storage (1.2.840.10008.5.1.4.1.1.601.2)
static (Shared in Visual Basic) | EncapsulatedCDA | Encapsulated CDA Storage (1.2.840.10008.5.1.4.1.1.104.2)
static (Shared in Visual Basic) | EncapsulatedPDF | Encapsulated PDF Storage (1.2.840.10008.5.1.4.1.1.104.1)
static (Shared in Visual Basic) | EncapsulatedSTL | Encapsulated STL Storage (1.2.840.10008.5.1.4.1.1.104.3)
static (Shared in Visual Basic) | EnhancedCT | Enhanced CT Image Storage (1.2.840.10008.5.1.4.1.1.2.1)
static (Shared in Visual Basic) | EnhancedMR | Enhanced MR Image Storage (1.2.840.10008.5.1.4.1.1.4.1)
static (Shared in Visual Basic) | EnhancedMRColorImage | Enhanced MR SKColor Image Storage (1.2.840.10008.5.1.4.1.1.4.3)
static (Shared in Visual Basic) | EnhancedPETImage | Enhanced PET Image Storage (1.2.840.10008.5.1.4.1.1.130)
static (Shared in Visual Basic) | EnhancedSR | Enhanced SR Storage (1.2.840.10008.5.1.4.1.1.88.22)
static (Shared in Visual Basic) | EnhancedUSVolume | Enhanced US Volume Storage (1.2.840.10008.5.1.4.1.1.6.2)
static (Shared in Visual Basic) | EnhancedXAImage | Enhanced XA Image Storage (1.2.840.10008.5.1.4.1.1.12.1.1)
static (Shared in Visual Basic) | EnhancedXRFImage | Enhanced XRF Image Storage (1.2.840.10008.5.1.4.1.1.12.2.1)
static (Shared in Visual Basic) | GeneralAudioWaveform | General Audio Waveform Storage (1.2.840.10008.5.1.4.1.1.9.4.2)
static (Shared in Visual Basic) | GeneralECGWaveform | General ECG Waveform Storage (1.2.840.10008.5.1.4.1.1.9.1.2)
static (Shared in Visual Basic) | GeneralPurposePerformedProcedureStep | General Purpose Performed Procedure Step SOP Class (1.2.840.10008.5.1.4.32.3)
static (Shared in Visual Basic) | GeneralPurposeScheduledProcedureStep | General Purpose Scheduled Procedure Step SOP Class (1.2.840.10008.5.1.4.32.2)
static (Shared in Visual Basic) | GeneralPurposeWorklistQRFIND | General Purpose Worklist Information Model - FIND (1.2.840.10008.5.1.4.32.1)
static (Shared in Visual Basic) | GeneralRelevantPatientInformationQuery | General Relevant Patient Information Query (1.2.840.10008.5.1.4.37.1)
static (Shared in Visual Basic) | GenericImplantTemplate | Generic Implant Template Storage (1.2.840.10008.5.1.4.43.1)
static (Shared in Visual Basic) | GenericImplantTemplateQRFIND | Generic Implant Template Information Model - FIND (1.2.840.10008.5.1.4.43.2)
static (Shared in Visual Basic) | GenericImplantTemplateQRGET | Generic Implant Template Information Model - GET (1.2.840.10008.5.1.4.43.4)
static (Shared in Visual Basic) | GenericImplantTemplateQRMOVE | Generic Implant Template Information Model - MOVE (1.2.840.10008.5.1.4.43.3)
static (Shared in Visual Basic) | GrayscaleSoftcopyPresentationState | Grayscale Softcopy Presentation State Storage SOP Class (1.2.840.10008.5.1.4.1.1.11.1)
static (Shared in Visual Basic) | HangingProtocol | Hanging Protocol Storage (1.2.840.10008.5.1.4.38.1)
static (Shared in Visual Basic) | HangingProtocolQRFIND | Hanging Protocol Information Model - FIND (1.2.840.10008.5.1.4.38.2)
static (Shared in Visual Basic) | HangingProtocolQRGET | Hanging Protocol Information Model - GET (1.2.840.10008.5.1.4.38.4)
static (Shared in Visual Basic) | HangingProtocolQRMOVE | Hanging Protocol Information Model - MOVE (1.2.840.10008.5.1.4.38.3)
static (Shared in Visual Basic) | HardcopyColor | Hardcopy SKColor Image Storage SOP Class (Retired) (1.2.840.10008.5.1.1.30)
static (Shared in Visual Basic) | HardcopyGrayscale | Hardcopy Grayscale Image Storage SOP Class (Retired) (1.2.840.10008.5.1.1.29)
static (Shared in Visual Basic) | HemodynamicWaveform | Hemodynamic Waveform Storage (1.2.840.10008.5.1.4.1.1.9.2.1)
static (Shared in Visual Basic) | ImageOverlayBox | Image Overlay Box SOP Class (Retired) (1.2.840.10008.5.1.1.24)
static (Shared in Visual Basic) | ImplantAssemblyTemplate | Implant Assembly Template Storage (1.2.840.10008.5.1.4.44.1)
static (Shared in Visual Basic) | ImplantAssemblyTemplateQRFIND | Implant Assembly Template Information Model - FIND (1.2.840.10008.5.1.4.44.2)
static (Shared in Visual Basic) | ImplantAssemblyTemplateQRGET | Implant Assembly Template Information Model - GET (1.2.840.10008.5.1.4.44.4)
static (Shared in Visual Basic) | ImplantAssemblyTemplateQRMOVE | Implant Assembly Template Information Model - MOVE (1.2.840.10008.5.1.4.44.3)
static (Shared in Visual Basic) | ImplantationPlanSR | Implantation Plan SR Storage (1.2.840.10008.5.1.4.1.1.88.70)
static (Shared in Visual Basic) | ImplantTemplateGroup | Implant Template Group Storage (1.2.840.10008.5.1.4.45.1)
static (Shared in Visual Basic) | ImplantTemplateGroupQRFIND | Implant Template Group Information Model - FIND (1.2.840.10008.5.1.4.45.2)
static (Shared in Visual Basic) | ImplantTemplateGroupQRGET | Implant Template Group Information Model - GET (1.2.840.10008.5.1.4.45.4)
static (Shared in Visual Basic) | ImplantTemplateGroupQRMOVE | Implant Template Group Information Model - MOVE (1.2.840.10008.5.1.4.45.3)
static (Shared in Visual Basic) | InstanceAvailabilityNotification | Instance Availability Notification SOP Class (1.2.840.10008.5.1.4.33)
static (Shared in Visual Basic) | IntraocularLensCalculations | Intraocular Lens Calculations Storage (1.2.840.10008.5.1.4.1.1.78.8)
static (Shared in Visual Basic) | IntravascularOpticalCoherenceTomographyImageForPresentation | Intravascular Optical Coherence Tomography Image Storage - For Presentation (1.2.840.10008.5.1.4.1.1.14.1)
static (Shared in Visual Basic) | IntravascularOpticalCoherenceTomographyImageForProcessing | Intravascular Optical Coherence Tomography Image Storage - For Processing (1.2.840.10008.5.1.4.1.1.14.2)
static (Shared in Visual Basic) | KeratometryMeasurements | Keratometry Measurements Storage (1.2.840.10008.5.1.4.1.1.78.3)
static (Shared in Visual Basic) | KeyObjectSelectionDocument | Key Object Selection Document Storage (1.2.840.10008.5.1.4.1.1.88.59)
static (Shared in Visual Basic) | LegacyConvertedEnhancedCT | Legacy Converted Enhanced CT Image Storage (1.2.840.10008.5.1.4.1.1.2.2)
static (Shared in Visual Basic) | LegacyConvertedEnhancedMRColorImage | Legacy Converted Enhanced MR Image Storage (1.2.840.10008.5.1.4.1.1.4.4)
static (Shared in Visual Basic) | LegacyConvertedEnhancedPETImage | Legacy Converted Enhanced PET Image Storage (1.2.840.10008.5.1.4.1.1.128.1)
static (Shared in Visual Basic) | LensometryMeasurements | Lensometry Measurements Storage (1.2.840.10008.5.1.4.1.1.78.1)
static (Shared in Visual Basic) | MacularGridThicknessandVolumeReport | Macular Grid Thickness and Volume Report Storage (1.2.840.10008.5.1.4.1.1.79.1)
static (Shared in Visual Basic) | MammographyCADSR | Mammography CAD SR Storage (1.2.840.10008.5.1.4.1.1.88.50)
static (Shared in Visual Basic) | MediaCreationManagementUID | Media Creation Management SOP Class UID (1.2.840.10008.5.1.1.33)
static (Shared in Visual Basic) | MediaStorageDirectory | Media Storage Directory Storage (1.2.840.10008.1.3.10)
static (Shared in Visual Basic) | ModalityPerformedProcedureStep | Modality Performed Procedure Step SOP Class (1.2.840.10008.3.1.2.3.3)
static (Shared in Visual Basic) | ModalityPerformedProcedureStepNotification | Modality Performed Procedure Step Notification SOP Class (1.2.840.10008.3.1.2.3.5)
static (Shared in Visual Basic) | ModalityPerformedProcedureStepRetrieve | Modality Performed Procedure Step Retrieve SOP Class (1.2.840.10008.3.1.2.3.4)
static (Shared in Visual Basic) | ModalityWorklistQRFIND | Modality Worklist Information Model - FIND (1.2.840.10008.5.1.4.31)
static (Shared in Visual Basic) | MR | MR Image Storage (1.2.840.10008.5.1.4.1.1.4)
static (Shared in Visual Basic) | MRSpectroscopy | MR Spectroscopy Storage (1.2.840.10008.5.1.4.1.1.4.2)
static (Shared in Visual Basic) | MultiFrameGrayscaleByteSC | Multi-frame Grayscale Byte Secondary Capture Image Storage (1.2.840.10008.5.1.4.1.1.7.2)
static (Shared in Visual Basic) | MultiFrameGrayscaleWordSC | Multi-frame Grayscale Word Secondary Capture Image Storage (1.2.840.10008.5.1.4.1.1.7.3)
static (Shared in Visual Basic) | MultiFrameSingleBitSC | Multi-frame Single Bit Secondary Capture Image Storage (1.2.840.10008.5.1.4.1.1.7.1)
static (Shared in Visual Basic) | MultiFrameTrueColorSC | Multi-frame True SKColor Secondary Capture Image Storage (1.2.840.10008.5.1.4.1.1.7.4)
static (Shared in Visual Basic) | NuclearMedicine | Nuclear Medicine Image Storage (1.2.840.10008.5.1.4.1.1.20)
static (Shared in Visual Basic) | OldNuclearMedicine | Nuclear Medicine Image Storage (Retired) (1.2.840.10008.5.1.4.1.1.5)
static (Shared in Visual Basic) | OldUltrasound | Ultrasound Image Storage (Retired) (1.2.840.10008.5.1.4.1.1.6)
static (Shared in Visual Basic) | OldUltrasoundMultiframe | Ultrasound Multi-frame Image Storage (Retired) (1.2.840.10008.5.1.4.1.1.3)
static (Shared in Visual Basic) | OphthalmicAxialMeasurements | Ophthalmic Axial Measurements Storage (1.2.840.10008.5.1.4.1.1.78.7)
static (Shared in Visual Basic) | OphthalmicPhotography16Bit | Ophthalmic Photography 16 Bit Image Storage (1.2.840.10008.5.1.4.1.1.77.1.5.2)
static (Shared in Visual Basic) | OphthalmicPhotography8Bit | Ophthalmic Photography 8 Bit Image Storage (1.2.840.10008.5.1.4.1.1.77.1.5.1)
static (Shared in Visual Basic) | OphthalmicThicknessMap | Ophthalmic Thickness Map Storage (1.2.840.10008.5.1.4.1.1.81.1)
static (Shared in Visual Basic) | OphthalmicTomographyImage | Ophthalmic Tomography Image Storage (1.2.840.10008.5.1.4.1.1.77.1.5.4)
static (Shared in Visual Basic) | OphthalmicVisualFieldStaticPerimetryMeasurements | Ophthalmic Visual Field Static Perimetry Measurements Storage (1.2.840.10008.5.1.4.1.1.80.1)
static (Shared in Visual Basic) | PatientRootQR_FIND | Patient Root Query/Retrieve Information Model - FIND (1.2.840.10008.5.1.4.1.2.1.1)
static (Shared in Visual Basic) | PatientRootQR_GET | Patient Root Query/Retrieve Information Model - GET (1.2.840.10008.5.1.4.1.2.1.3)
static (Shared in Visual Basic) | PatientRootQR_MOVE | Patient Root Query/Retrieve Information Model - MOVE (1.2.840.10008.5.1.4.1.2.1.2)
static (Shared in Visual Basic) | PatientStudyOnlyQR_FIND | Patient/Study Only Query/Retrieve Information Model - FIND (Retired) (1.2.840.10008.5.1.4.1.2.3.1)
static (Shared in Visual Basic) | PatientStudyOnlyQR_GET | Patient/Study Only Query/Retrieve Information Model - GET (Retired) (1.2.840.10008.5.1.4.1.2.3.3)
static (Shared in Visual Basic) | PatientStudyOnlyQR_MOVE | Patient/Study Only Query/Retrieve Information Model - MOVE (Retired) (1.2.840.10008.5.1.4.1.2.3.2)
static (Shared in Visual Basic) | PositronEmissionTomography | Positron Emission Tomography Image Storage (1.2.840.10008.5.1.4.1.1.128)
static (Shared in Visual Basic) | PresentationLUT | Presentation LUT SOP Class (1.2.840.10008.5.1.1.23)
static (Shared in Visual Basic) | Printer | Printer SOP Class (1.2.840.10008.5.1.1.16)
static (Shared in Visual Basic) | PrinterConfigurationRetrieval | Printer Configuration Retrieval SOP Class (1.2.840.10008.5.1.1.16.376)
static (Shared in Visual Basic) | PrintJob | Print Job SOP Class (1.2.840.10008.5.1.1.14)
static (Shared in Visual Basic) | PrintQueueManagement | Print Queue Management SOP Class (Retired) (1.2.840.10008.5.1.1.26)
static (Shared in Visual Basic) | ProceduralEventLogging | Procedural Event Logging SOP Class (1.2.840.10008.1.40)
static (Shared in Visual Basic) | ProcedureLog | Procedure Log Storage (1.2.840.10008.5.1.4.1.1.88.40)
static (Shared in Visual Basic) | ProductCharacteristicsQuery | Product Characteristics Query SOP Class (1.2.840.10008.5.1.4.41)
static (Shared in Visual Basic) | PseudoColorSoftcopyPresentationState | Pseudo-SKColor Softcopy Presentation State Storage SOP Class (1.2.840.10008.5.1.4.1.1.11.3)
static (Shared in Visual Basic) | PullPrintRequest | Pull Print Request SOP Class (Retired) (1.2.840.10008.5.1.1.31)
static (Shared in Visual Basic) | RawData | Raw Data Storage (1.2.840.10008.5.1.4.1.1.66)
static (Shared in Visual Basic) | RealWorldValueMapping | Real World Value Mapping Storage (1.2.840.10008.5.1.4.1.1.67)
static (Shared in Visual Basic) | ReferencedImageBox | Referenced Image Box SOP Class (Retired) (1.2.840.10008.5.1.1.4.2)
static (Shared in Visual Basic) | RespiratoryWaveform | Respiratory Waveform Storage (1.2.840.10008.5.1.4.1.1.9.6.1)
static (Shared in Visual Basic) | RT | RT Image Storage (1.2.840.10008.5.1.4.1.1.481.1)
static (Shared in Visual Basic) | RTBeamsDeliveryInstruction | RT Beams Delivery Instruction Storage (1.2.840.10008.5.1.4.34.7)
static (Shared in Visual Basic) | RTBeamsDeliveryInstructionTrial | RT Beams Delivery Instruction Storage - Trial (Retired) (1.2.840.10008.5.1.4.34.1)
static (Shared in Visual Basic) | RTBeamsTreatmentRecord | RT Beams Treatment Record Storage (1.2.840.10008.5.1.4.1.1.481.4)
static (Shared in Visual Basic) | RTBrachyTreatmentRecord | RT Brachy Treatment Record Storage (1.2.840.10008.5.1.4.1.1.481.6)
static (Shared in Visual Basic) | RTConventionalMachineVerification | RT Conventional Machine Verification (1.2.840.10008.5.1.4.34.8)
static (Shared in Visual Basic) | RTConventionalMachineVerificationTrial | RT Conventional Machine Verification - Trial (Retired) (1.2.840.10008.5.1.4.34.2)
static (Shared in Visual Basic) | RTDose | RT Dose Storage (1.2.840.10008.5.1.4.1.1.481.2)
static (Shared in Visual Basic) | RTIonBeamsTreatmentRecord | RT Ion Beams Treatment Record Storage (1.2.840.10008.5.1.4.1.1.481.9)
static (Shared in Visual Basic) | RTIonMachineVerification | RT Ion Machine Verification (1.2.840.10008.5.1.4.34.9)
static (Shared in Visual Basic) | RTIonMachineVerificationTrial | RT Ion Machine Verification - Trial (Retired) (1.2.840.10008.5.1.4.34.3)
static (Shared in Visual Basic) | RTIonPlan | RT Ion Plan Storage (1.2.840.10008.5.1.4.1.1.481.8)
static (Shared in Visual Basic) | RTPlan | RT Plan Storage (1.2.840.10008.5.1.4.1.1.481.5)
static (Shared in Visual Basic) | RTStructureSet | RT Structure Set Storage (1.2.840.10008.5.1.4.1.1.481.3)
static (Shared in Visual Basic) | RTTreatmentSummaryRecord | RT Treatment Summary Record Storage (1.2.840.10008.5.1.4.1.1.481.7)
static (Shared in Visual Basic) | SecondaryCapture | Secondary Capture Image Storage (1.2.840.10008.5.1.4.1.1.7)
static (Shared in Visual Basic) | Segmentation | Segmentation Storage (1.2.840.10008.5.1.4.1.1.66.4)
static (Shared in Visual Basic) | SpatialFiducials | Spatial Fiducials Storage (1.2.840.10008.5.1.4.1.1.66.2)
static (Shared in Visual Basic) | SpatialRegistration | Spatial Registration Storage (1.2.840.10008.5.1.4.1.1.66.1)
static (Shared in Visual Basic) | SpectaclePrescriptionReport | Spectacle Prescription Report Storage (1.2.840.10008.5.1.4.1.1.78.6)
static (Shared in Visual Basic) | StandaloneCurve | Standalone Curve Storage (Retired) (1.2.840.10008.5.1.4.1.1.9)
static (Shared in Visual Basic) | StandaloneModalityLUT | Standalone Modality LUT Storage (Retired) (1.2.840.10008.5.1.4.1.1.10)
static (Shared in Visual Basic) | StandaloneOverlay | Standalone Overlay Storage (Retired) (1.2.840.10008.5.1.4.1.1.8)
static (Shared in Visual Basic) | StandalonePETCurve | Standalone PET Curve Storage (Retired) (1.2.840.10008.5.1.4.1.1.129)
static (Shared in Visual Basic) | StandaloneVOILUT | Standalone VOI LUT Storage (Retired) (1.2.840.10008.5.1.4.1.1.11)
static (Shared in Visual Basic) | StereometricRelationship | Stereometric Relationship Storage (1.2.840.10008.5.1.4.1.1.77.1.5.3)
static (Shared in Visual Basic) | StorageCommitmentPull | Storage Commitment Pull Model SOP Class (Retired) (1.2.840.10008.1.20.2)
static (Shared in Visual Basic) | StorageCommitmentPush | Storage Commitment Push Model SOP Class (1.2.840.10008.1.20.1)
static (Shared in Visual Basic) | StorageServiceClass | Storage Service Class (1.2.840.10008.4.2)
static (Shared in Visual Basic) | StoredPrint | Stored Print Storage SOP Class (Retired) (1.2.840.10008.5.1.1.27)
static (Shared in Visual Basic) | StudyComponentManagement | Study Component Management SOP Class (Retired) (1.2.840.10008.3.1.2.3.2)
static (Shared in Visual Basic) | StudyRootQR_FIND | Study Root Query/Retrieve Information Model - FIND (1.2.840.10008.5.1.4.1.2.2.1)
static (Shared in Visual Basic) | StudyRootQR_GET | Study Root Query/Retrieve Information Model - GET (1.2.840.10008.5.1.4.1.2.2.3)
static (Shared in Visual Basic) | StudyRootQR_MOVE | Study Root Query/Retrieve Information Model - MOVE (1.2.840.10008.5.1.4.1.2.2.2)
static (Shared in Visual Basic) | SubjectiveRefractionMeasurements | Subjective Refraction Measurements Storage (1.2.840.10008.5.1.4.1.1.78.4)
static (Shared in Visual Basic) | SubstanceAdministrationLogging | Substance Administration Logging SOP Class (1.2.840.10008.1.42)
static (Shared in Visual Basic) | SubstanceApprovalQuery | Substance Approval Query SOP Class (1.2.840.10008.5.1.4.42)
static (Shared in Visual Basic) | SurfaceSegmentation | Surface Segmentation Storage (1.2.840.10008.5.1.4.1.1.66.5)
static (Shared in Visual Basic) | TextSRTrial | Text SR Storage - Trial (Retired) (1.2.840.10008.5.1.4.1.1.88.1)
static (Shared in Visual Basic) | TwelveLeadECGWaveform | 12-lead ECG Waveform Storage (1.2.840.10008.5.1.4.1.1.9.1.1)
static (Shared in Visual Basic) | Ultrasound | Ultrasound Image Storage (1.2.840.10008.5.1.4.1.1.6.1)
static (Shared in Visual Basic) | UltrasoundMultiframe | Ultrasound Multi-frame Image Storage (1.2.840.10008.5.1.4.1.1.3.1)
static (Shared in Visual Basic) | UnifiedProcedureStepEvent | Unified Procedure Step - Event SOP Class (1.2.840.10008.5.1.4.34.6.4)
static (Shared in Visual Basic) | UnifiedProcedureStepEventTrial | Unified Procedure Step - Event SOP Class - Trial (Retired) (1.2.840.10008.5.1.4.34.4.4)
static (Shared in Visual Basic) | UnifiedProcedureStepPull | Unified Procedure Step - Pull SOP Class (1.2.840.10008.5.1.4.34.6.3)
static (Shared in Visual Basic) | UnifiedProcedureStepPullTrial | Unified Procedure Step - Pull SOP Class - Trial (Retired) (1.2.840.10008.5.1.4.34.4.3)
static (Shared in Visual Basic) | UnifiedProcedureStepPush | Unified Procedure Step - Push SOP Class (1.2.840.10008.5.1.4.34.6.1)
static (Shared in Visual Basic) | UnifiedProcedureStepPushTrial | Unified Procedure Step - Push SOP Class - Trial (Retired) (1.2.840.10008.5.1.4.34.4.1)
static (Shared in Visual Basic) | UnifiedProcedureStepWatch | Unified Procedure Step - Watch SOP Class (1.2.840.10008.5.1.4.34.6.2)
static (Shared in Visual Basic) | UnifiedProcedureStepWatchTrial | Unified Procedure Step - Watch SOP Class - Trial (Retired) (1.2.840.10008.5.1.4.34.4.2)
static (Shared in Visual Basic) | UnifiedWorklistandProcedureStepServiceClass | Unified Worklist and Procedure Step Service Class (1.2.840.10008.5.1.4.34.6)
static (Shared in Visual Basic) | UnifiedWorklistandProcedureStepServiceClassTrial | Unified Worklist and Procedure Step Service Class - Trial (Retired) (1.2.840.10008.5.1.4.34.4)
static (Shared in Visual Basic) | Verification | Verification SOP Class (1.2.840.10008.1.1)
static (Shared in Visual Basic) | VideoEndoscopic | Video Endoscopic Image Storage (1.2.840.10008.5.1.4.1.1.77.1.1.1)
static (Shared in Visual Basic) | VideoMicroscopic | Video Microscopic Image Storage (1.2.840.10008.5.1.4.1.1.77.1.2.1)
static (Shared in Visual Basic) | VideoPhotographic | Video Photographic Image Storage (1.2.840.10008.5.1.4.1.1.77.1.4.1)
static (Shared in Visual Basic) | VisualAcuityMeasurements | Visual Acuity Measurements Storage (1.2.840.10008.5.1.4.1.1.78.5)
static (Shared in Visual Basic) | VLEndoscopic | VL Endoscopic Image Storage (1.2.840.10008.5.1.4.1.1.77.1.1)
static (Shared in Visual Basic) | VLMicroscopic | VL Microscopic Image Storage (1.2.840.10008.5.1.4.1.1.77.1.2)
static (Shared in Visual Basic) | VLPhotographic | VL Photographic Image Storage (1.2.840.10008.5.1.4.1.1.77.1.4)
static (Shared in Visual Basic) | VLSlideCoordinatesMicroscopic | VL Slide-Coordinates Microscopic Image Storage (1.2.840.10008.5.1.4.1.1.77.1.3)
static (Shared in Visual Basic) | VLWholeSlideMicroscopyImage | VL Whole Slide Microscopy Image Storage (1.2.840.10008.5.1.4.1.1.77.1.6)
static (Shared in Visual Basic) | VOILUTBox | VOI LUT Box SOP Class (1.2.840.10008.5.1.1.22)
static (Shared in Visual Basic) | WaveformTrial | Waveform Storage - Trial (Retired) (1.2.840.10008.5.1.4.1.1.9.1)
static (Shared in Visual Basic) | XA_XRFGrayscaleSoftcopyPresentationState | XA/XRF Grayscale Softcopy Presentation State Storage (1.2.840.10008.5.1.4.1.1.11.5)
static (Shared in Visual Basic) | XRay3DAngiographicImage | X-Ray 3D Angiographic Image Storage (1.2.840.10008.5.1.4.1.1.13.1.1)
static (Shared in Visual Basic) | XRay3DCraniofacialImage | X-Ray 3D Craniofacial Image Storage (1.2.840.10008.5.1.4.1.1.13.1.2)
static (Shared in Visual Basic) | XRayAngiographic | X-Ray Angiographic Image Storage (1.2.840.10008.5.1.4.1.1.12.1)
static (Shared in Visual Basic) | XRayAngiographicBiPlane | X-Ray Angiographic Bi-Plane Image Storage (Retired) (1.2.840.10008.5.1.4.1.1.12.3)
static (Shared in Visual Basic) | XRayRadiationDoseSR | X-Ray Radiation Dose SR Storage (1.2.840.10008.5.1.4.1.1.88.67)
static (Shared in Visual Basic) | XRayRadiofluoroscopic | X-Ray Radiofluoroscopic Image Storage (1.2.840.10008.5.1.4.1.1.12.2)
    Top
    See Also

    Reference

    SOPClasses Class
    DicomObjects.UIDs Namespace


%%PageItemTitle%% $$Fields$$

DicomObjects.UIDs Namespace / SOPClasses Class

    SOPClasses Class Fields
    In This Topic

    For a list of all members of this type, see SOPClasses members.

    Public Fields
     | Name | Description
static (Shared in Visual Basic) | AmbulatoryECGWaveform | Ambulatory ECG Waveform Storage (1.2.840.10008.5.1.4.1.1.9.1.3)
static (Shared in Visual Basic) | ArterialPulseWaveform | Arterial Pulse Waveform Storage (1.2.840.10008.5.1.4.1.1.9.5.1)
static (Shared in Visual Basic) | AudioSRTrial | Audio SR Storage - Trial (Retired) (1.2.840.10008.5.1.4.1.1.88.2)
static (Shared in Visual Basic) | AutorefractionMeasurements | Autorefraction Measurements Storage (1.2.840.10008.5.1.4.1.1.78.2)
static (Shared in Visual Basic) | BasicAnnotationBox | Basic Annotation Box SOP Class (1.2.840.10008.5.1.1.15)
static (Shared in Visual Basic) | BasicColorImageBox | Basic SKColor Image Box SOP Class (1.2.840.10008.5.1.1.4.1)
static (Shared in Visual Basic) | BasicFilmBox | Basic Film Box SOP Class (1.2.840.10008.5.1.1.2)
static (Shared in Visual Basic) | BasicFilmSession | Basic Film Session SOP Class (1.2.840.10008.5.1.1.1)
static (Shared in Visual Basic) | BasicGrayscaleImageBox | Basic Grayscale Image Box SOP Class (1.2.840.10008.5.1.1.4)
static (Shared in Visual Basic) | BasicPrintImageOverlayBox | Basic Print Image Overlay Box SOP Class (Retired) (1.2.840.10008.5.1.1.24.1)
static (Shared in Visual Basic) | BasicStructuredDisplay | Basic Structured Display Storage (1.2.840.10008.5.1.4.1.1.131)
static (Shared in Visual Basic) | BasicStudyContentNotification | Basic Study Content Notification SOP Class (Retired) (1.2.840.10008.1.9)
static (Shared in Visual Basic) | BasicTextSR | Basic Text SR Storage (1.2.840.10008.5.1.4.1.1.88.11)
static (Shared in Visual Basic) | BasicVoiceAudioWaveform | Basic Voice Audio Waveform Storage (1.2.840.10008.5.1.4.1.1.9.4.1)
static (Shared in Visual Basic) | BlendingSoftcopyPresentationState | Blending Softcopy Presentation State Storage SOP Class (1.2.840.10008.5.1.4.1.1.11.4)
static (Shared in Visual Basic) | BreastImagingRelevantPatientInformationQuery | Breast Imaging Relevant Patient Information Query (1.2.840.10008.5.1.4.37.2)
static (Shared in Visual Basic) | BreastTomosynthesisImage | Breast Tomosynthesis Image Storage (1.2.840.10008.5.1.4.1.1.13.1.3)
static (Shared in Visual Basic) | CardiacElectrophysiologyWaveform | Cardiac Electrophysiology Waveform Storage (1.2.840.10008.5.1.4.1.1.9.3.1)
static (Shared in Visual Basic) | CardiacRelevantPatientInformationQuery | Cardiac Relevant Patient Information Query (1.2.840.10008.5.1.4.37.3)
static (Shared in Visual Basic) | ChestCADSR | Chest CAD SR Storage (1.2.840.10008.5.1.4.1.1.88.65)
static (Shared in Visual Basic) | ColonCADSR | Colon CAD SR Storage (1.2.840.10008.5.1.4.1.1.88.69)
static (Shared in Visual Basic) | ColorPalette | SKColor Palette Storage (1.2.840.10008.5.1.4.39.1)
static (Shared in Visual Basic) | ColorPaletteQRFIND | SKColor Palette Information Model - FIND (1.2.840.10008.5.1.4.39.2)
static (Shared in Visual Basic) | ColorPaletteQRGET | SKColor Palette Information Model - GET (1.2.840.10008.5.1.4.39.4)
static (Shared in Visual Basic) | ColorPaletteQRMOVE | SKColor Palette Information Model - MOVE (1.2.840.10008.5.1.4.39.3)
static (Shared in Visual Basic) | ColorSoftcopyPresentationState | SKColor Softcopy Presentation State Storage SOP Class (1.2.840.10008.5.1.4.1.1.11.2)
static (Shared in Visual Basic) | CompositeInstanceRootRetrieve_GET | Composite Instance Root Retrieve - GET (1.2.840.10008.5.1.4.1.2.4.3)
static (Shared in Visual Basic) | CompositeInstanceRootRetrieve_MOVE | Composite Instance Root Retrieve - MOVE (1.2.840.10008.5.1.4.1.2.4.2)
static (Shared in Visual Basic) | CompositeInstanceRootRetrieveWithoutBulkData_GET | Composite Instance Retrieve Without Bulk Data - GET (1.2.840.10008.5.1.4.1.2.5.3)
static (Shared in Visual Basic) | ComprehensiveSR | Comprehensive SR Storage (1.2.840.10008.5.1.4.1.1.88.33)
static (Shared in Visual Basic) | ComprehensiveSRTrial | Comprehensive SR Storage - Trial (Retired) (1.2.840.10008.5.1.4.1.1.88.4)
static (Shared in Visual Basic) | ComputedRadiography | Computed Radiography Image Storage (1.2.840.10008.5.1.4.1.1.1)
static (Shared in Visual Basic) | CornealTopographyMap | Corneal Topography Map Storage (1.2.840.10008.5.1.4.1.1.82.1)
static (Shared in Visual Basic) | CT | CT Image Storage (1.2.840.10008.5.1.4.1.1.2)
static (Shared in Visual Basic) | DeformableSpatialRegistration | Deformable Spatial Registration Storage (1.2.840.10008.5.1.4.1.1.66.3)
static (Shared in Visual Basic) | DetachedInterpretationManagement | Detached Interpretation Management SOP Class (Retired) (1.2.840.10008.3.1.2.6.1)
static (Shared in Visual Basic) | DetachedPatientManagement | Detached Patient Management SOP Class (Retired) (1.2.840.10008.3.1.2.1.1)
static (Shared in Visual Basic) | DetachedResultsManagement | Detached Results Management SOP Class (Retired) (1.2.840.10008.3.1.2.5.1)
static (Shared in Visual Basic) | DetachedStudyManagement | Detached Study Management SOP Class (Retired) (1.2.840.10008.3.1.2.3.1)
static (Shared in Visual Basic) | DetachedVisitManagement | Detached Visit Management SOP Class (Retired) (1.2.840.10008.3.1.2.2.1)
static (Shared in Visual Basic) | DetailSRTrial | Detail SR Storage - Trial (Retired) (1.2.840.10008.5.1.4.1.1.88.3)
static (Shared in Visual Basic) | DICOSCTImage | DICOS CT Image Storage (1.2.840.10008.5.1.4.1.1.501.1)
static (Shared in Visual Basic) | DICOSDigitalXRayImageForPresentation | DICOS Digital X-Ray Image Storage - For Presentation (1.2.840.10008.5.1.4.1.1.501.2.1)
static (Shared in Visual Basic) | DICOSDigitalXRayImageForProcessing | DICOS Digital X-Ray Image Storage - For Processing (1.2.840.10008.5.1.4.1.1.501.2.2)
static (Shared in Visual Basic) | DICOSThreatDetectionReport | DICOS Threat Detection Report Storage (1.2.840.10008.5.1.4.1.1.501.3)
static (Shared in Visual Basic) | DigitalIntraoralXRay_Presentation | Digital Intra-oral X-Ray Image Storage - For Presentation (1.2.840.10008.5.1.4.1.1.1.3)
static (Shared in Visual Basic) | DigitalIntraoralXRay_Processing | Digital Intra-oral X-Ray Image Storage - For Processing (1.2.840.10008.5.1.4.1.1.1.3.1)
static (Shared in Visual Basic) | DigitalMammographyXRay_Presentation | Digital Mammography X-Ray Image Storage - For Presentation (1.2.840.10008.5.1.4.1.1.1.2)
static (Shared in Visual Basic) | DigitalMammographyXRay_Processing | Digital Mammography X-Ray Image Storage - For Processing (1.2.840.10008.5.1.4.1.1.1.2.1)
static (Shared in Visual Basic) | DigitalXRay_Presentation | Digital X-Ray Image Storage - For Presentation (1.2.840.10008.5.1.4.1.1.1.1)
static (Shared in Visual Basic) | DigitalXRay_Processing | Digital X-Ray Image Storage - For Processing (1.2.840.10008.5.1.4.1.1.1.1.1)
static (Shared in Visual Basic) | EddyCurrentImage | Eddy Current Image Storage (1.2.840.10008.5.1.4.1.1.601.1)
static (Shared in Visual Basic) | EddyCurrentMultiframeImage | Eddy Current Multi-frame Image Storage (1.2.840.10008.5.1.4.1.1.601.2)
static (Shared in Visual Basic) | EncapsulatedCDA | Encapsulated CDA Storage (1.2.840.10008.5.1.4.1.1.104.2)
static (Shared in Visual Basic) | EncapsulatedPDF | Encapsulated PDF Storage (1.2.840.10008.5.1.4.1.1.104.1)
static (Shared in Visual Basic) | EncapsulatedSTL | Encapsulated STL Storage (1.2.840.10008.5.1.4.1.1.104.3)
static (Shared in Visual Basic) | EnhancedCT | Enhanced CT Image Storage (1.2.840.10008.5.1.4.1.1.2.1)
static (Shared in Visual Basic) | EnhancedMR | Enhanced MR Image Storage (1.2.840.10008.5.1.4.1.1.4.1)
static (Shared in Visual Basic) | EnhancedMRColorImage | Enhanced MR SKColor Image Storage (1.2.840.10008.5.1.4.1.1.4.3)
static (Shared in Visual Basic) | EnhancedPETImage | Enhanced PET Image Storage (1.2.840.10008.5.1.4.1.1.130)
static (Shared in Visual Basic) | EnhancedSR | Enhanced SR Storage (1.2.840.10008.5.1.4.1.1.88.22)
static (Shared in Visual Basic) | EnhancedUSVolume | Enhanced US Volume Storage (1.2.840.10008.5.1.4.1.1.6.2)
static (Shared in Visual Basic) | EnhancedXAImage | Enhanced XA Image Storage (1.2.840.10008.5.1.4.1.1.12.1.1)
static (Shared in Visual Basic) | EnhancedXRFImage | Enhanced XRF Image Storage (1.2.840.10008.5.1.4.1.1.12.2.1)
static (Shared in Visual Basic) | GeneralAudioWaveform | General Audio Waveform Storage (1.2.840.10008.5.1.4.1.1.9.4.2)
static (Shared in Visual Basic) | GeneralECGWaveform | General ECG Waveform Storage (1.2.840.10008.5.1.4.1.1.9.1.2)
static (Shared in Visual Basic) | GeneralPurposePerformedProcedureStep | General Purpose Performed Procedure Step SOP Class (1.2.840.10008.5.1.4.32.3)
static (Shared in Visual Basic) | GeneralPurposeScheduledProcedureStep | General Purpose Scheduled Procedure Step SOP Class (1.2.840.10008.5.1.4.32.2)
static (Shared in Visual Basic) | GeneralPurposeWorklistQRFIND | General Purpose Worklist Information Model - FIND (1.2.840.10008.5.1.4.32.1)
static (Shared in Visual Basic) | GeneralRelevantPatientInformationQuery | General Relevant Patient Information Query (1.2.840.10008.5.1.4.37.1)
static (Shared in Visual Basic) | GenericImplantTemplate | Generic Implant Template Storage (1.2.840.10008.5.1.4.43.1)
static (Shared in Visual Basic) | GenericImplantTemplateQRFIND | Generic Implant Template Information Model - FIND (1.2.840.10008.5.1.4.43.2)
static (Shared in Visual Basic) | GenericImplantTemplateQRGET | Generic Implant Template Information Model - GET (1.2.840.10008.5.1.4.43.4)
static (Shared in Visual Basic) | GenericImplantTemplateQRMOVE | Generic Implant Template Information Model - MOVE (1.2.840.10008.5.1.4.43.3)
static (Shared in Visual Basic) | GrayscaleSoftcopyPresentationState | Grayscale Softcopy Presentation State Storage SOP Class (1.2.840.10008.5.1.4.1.1.11.1)
static (Shared in Visual Basic) | HangingProtocol | Hanging Protocol Storage (1.2.840.10008.5.1.4.38.1)
static (Shared in Visual Basic) | HangingProtocolQRFIND | Hanging Protocol Information Model - FIND (1.2.840.10008.5.1.4.38.2)
static (Shared in Visual Basic) | HangingProtocolQRGET | Hanging Protocol Information Model - GET (1.2.840.10008.5.1.4.38.4)
static (Shared in Visual Basic) | HangingProtocolQRMOVE | Hanging Protocol Information Model - MOVE (1.2.840.10008.5.1.4.38.3)
static (Shared in Visual Basic) | HardcopyColor | Hardcopy SKColor Image Storage SOP Class (Retired) (1.2.840.10008.5.1.1.30)
static (Shared in Visual Basic) | HardcopyGrayscale | Hardcopy Grayscale Image Storage SOP Class (Retired) (1.2.840.10008.5.1.1.29)
static (Shared in Visual Basic) | HemodynamicWaveform | Hemodynamic Waveform Storage (1.2.840.10008.5.1.4.1.1.9.2.1)
static (Shared in Visual Basic) | ImageOverlayBox | Image Overlay Box SOP Class (Retired) (1.2.840.10008.5.1.1.24)
static (Shared in Visual Basic) | ImplantAssemblyTemplate | Implant Assembly Template Storage (1.2.840.10008.5.1.4.44.1)
static (Shared in Visual Basic) | ImplantAssemblyTemplateQRFIND | Implant Assembly Template Information Model - FIND (1.2.840.10008.5.1.4.44.2)
static (Shared in Visual Basic) | ImplantAssemblyTemplateQRGET | Implant Assembly Template Information Model - GET (1.2.840.10008.5.1.4.44.4)
static (Shared in Visual Basic) | ImplantAssemblyTemplateQRMOVE | Implant Assembly Template Information Model - MOVE (1.2.840.10008.5.1.4.44.3)
static (Shared in Visual Basic) | ImplantationPlanSR | Implantation Plan SR Storage (1.2.840.10008.5.1.4.1.1.88.70)
static (Shared in Visual Basic) | ImplantTemplateGroup | Implant Template Group Storage (1.2.840.10008.5.1.4.45.1)
static (Shared in Visual Basic) | ImplantTemplateGroupQRFIND | Implant Template Group Information Model - FIND (1.2.840.10008.5.1.4.45.2)
static (Shared in Visual Basic) | ImplantTemplateGroupQRGET | Implant Template Group Information Model - GET (1.2.840.10008.5.1.4.45.4)
static (Shared in Visual Basic) | ImplantTemplateGroupQRMOVE | Implant Template Group Information Model - MOVE (1.2.840.10008.5.1.4.45.3)
static (Shared in Visual Basic) | InstanceAvailabilityNotification | Instance Availability Notification SOP Class (1.2.840.10008.5.1.4.33)
static (Shared in Visual Basic) | IntraocularLensCalculations | Intraocular Lens Calculations Storage (1.2.840.10008.5.1.4.1.1.78.8)
static (Shared in Visual Basic) | IntravascularOpticalCoherenceTomographyImageForPresentation | Intravascular Optical Coherence Tomography Image Storage - For Presentation (1.2.840.10008.5.1.4.1.1.14.1)
static (Shared in Visual Basic) | IntravascularOpticalCoherenceTomographyImageForProcessing | Intravascular Optical Coherence Tomography Image Storage - For Processing (1.2.840.10008.5.1.4.1.1.14.2)
static (Shared in Visual Basic) | KeratometryMeasurements | Keratometry Measurements Storage (1.2.840.10008.5.1.4.1.1.78.3)
static (Shared in Visual Basic) | KeyObjectSelectionDocument | Key Object Selection Document Storage (1.2.840.10008.5.1.4.1.1.88.59)
static (Shared in Visual Basic) | LegacyConvertedEnhancedCT | Legacy Converted Enhanced CT Image Storage (1.2.840.10008.5.1.4.1.1.2.2)
static (Shared in Visual Basic) | LegacyConvertedEnhancedMRColorImage | Legacy Converted Enhanced MR Image Storage (1.2.840.10008.5.1.4.1.1.4.4)
static (Shared in Visual Basic) | LegacyConvertedEnhancedPETImage | Legacy Converted Enhanced PET Image Storage (1.2.840.10008.5.1.4.1.1.128.1)
static (Shared in Visual Basic) | LensometryMeasurements | Lensometry Measurements Storage (1.2.840.10008.5.1.4.1.1.78.1)
static (Shared in Visual Basic) | MacularGridThicknessandVolumeReport | Macular Grid Thickness and Volume Report Storage (1.2.840.10008.5.1.4.1.1.79.1)
static (Shared in Visual Basic) | MammographyCADSR | Mammography CAD SR Storage (1.2.840.10008.5.1.4.1.1.88.50)
static (Shared in Visual Basic) | MediaCreationManagementUID | Media Creation Management SOP Class UID (1.2.840.10008.5.1.1.33)
static (Shared in Visual Basic) | MediaStorageDirectory | Media Storage Directory Storage (1.2.840.10008.1.3.10)
static (Shared in Visual Basic) | ModalityPerformedProcedureStep | Modality Performed Procedure Step SOP Class (1.2.840.10008.3.1.2.3.3)
static (Shared in Visual Basic) | ModalityPerformedProcedureStepNotification | Modality Performed Procedure Step Notification SOP Class (1.2.840.10008.3.1.2.3.5)
static (Shared in Visual Basic) | ModalityPerformedProcedureStepRetrieve | Modality Performed Procedure Step Retrieve SOP Class (1.2.840.10008.3.1.2.3.4)
static (Shared in Visual Basic) | ModalityWorklistQRFIND | Modality Worklist Information Model - FIND (1.2.840.10008.5.1.4.31)
static (Shared in Visual Basic) | MR | MR Image Storage (1.2.840.10008.5.1.4.1.1.4)
static (Shared in Visual Basic) | MRSpectroscopy | MR Spectroscopy Storage (1.2.840.10008.5.1.4.1.1.4.2)
static (Shared in Visual Basic) | MultiFrameGrayscaleByteSC | Multi-frame Grayscale Byte Secondary Capture Image Storage (1.2.840.10008.5.1.4.1.1.7.2)
static (Shared in Visual Basic) | MultiFrameGrayscaleWordSC | Multi-frame Grayscale Word Secondary Capture Image Storage (1.2.840.10008.5.1.4.1.1.7.3)
static (Shared in Visual Basic) | MultiFrameSingleBitSC | Multi-frame Single Bit Secondary Capture Image Storage (1.2.840.10008.5.1.4.1.1.7.1)
static (Shared in Visual Basic) | MultiFrameTrueColorSC | Multi-frame True SKColor Secondary Capture Image Storage (1.2.840.10008.5.1.4.1.1.7.4)
static (Shared in Visual Basic) | NuclearMedicine | Nuclear Medicine Image Storage (1.2.840.10008.5.1.4.1.1.20)
static (Shared in Visual Basic) | OldNuclearMedicine | Nuclear Medicine Image Storage (Retired) (1.2.840.10008.5.1.4.1.1.5)
static (Shared in Visual Basic) | OldUltrasound | Ultrasound Image Storage (Retired) (1.2.840.10008.5.1.4.1.1.6)
static (Shared in Visual Basic) | OldUltrasoundMultiframe | Ultrasound Multi-frame Image Storage (Retired) (1.2.840.10008.5.1.4.1.1.3)
static (Shared in Visual Basic) | OphthalmicAxialMeasurements | Ophthalmic Axial Measurements Storage (1.2.840.10008.5.1.4.1.1.78.7)
static (Shared in Visual Basic) | OphthalmicPhotography16Bit | Ophthalmic Photography 16 Bit Image Storage (1.2.840.10008.5.1.4.1.1.77.1.5.2)
static (Shared in Visual Basic) | OphthalmicPhotography8Bit | Ophthalmic Photography 8 Bit Image Storage (1.2.840.10008.5.1.4.1.1.77.1.5.1)
static (Shared in Visual Basic) | OphthalmicThicknessMap | Ophthalmic Thickness Map Storage (1.2.840.10008.5.1.4.1.1.81.1)
static (Shared in Visual Basic) | OphthalmicTomographyImage | Ophthalmic Tomography Image Storage (1.2.840.10008.5.1.4.1.1.77.1.5.4)
static (Shared in Visual Basic) | OphthalmicVisualFieldStaticPerimetryMeasurements | Ophthalmic Visual Field Static Perimetry Measurements Storage (1.2.840.10008.5.1.4.1.1.80.1)
static (Shared in Visual Basic) | PatientRootQR_FIND | Patient Root Query/Retrieve Information Model - FIND (1.2.840.10008.5.1.4.1.2.1.1)
static (Shared in Visual Basic) | PatientRootQR_GET | Patient Root Query/Retrieve Information Model - GET (1.2.840.10008.5.1.4.1.2.1.3)
static (Shared in Visual Basic) | PatientRootQR_MOVE | Patient Root Query/Retrieve Information Model - MOVE (1.2.840.10008.5.1.4.1.2.1.2)
static (Shared in Visual Basic) | PatientStudyOnlyQR_FIND | Patient/Study Only Query/Retrieve Information Model - FIND (Retired) (1.2.840.10008.5.1.4.1.2.3.1)
static (Shared in Visual Basic) | PatientStudyOnlyQR_GET | Patient/Study Only Query/Retrieve Information Model - GET (Retired) (1.2.840.10008.5.1.4.1.2.3.3)
static (Shared in Visual Basic) | PatientStudyOnlyQR_MOVE | Patient/Study Only Query/Retrieve Information Model - MOVE (Retired) (1.2.840.10008.5.1.4.1.2.3.2)
static (Shared in Visual Basic) | PositronEmissionTomography | Positron Emission Tomography Image Storage (1.2.840.10008.5.1.4.1.1.128)
static (Shared in Visual Basic) | PresentationLUT | Presentation LUT SOP Class (1.2.840.10008.5.1.1.23)
static (Shared in Visual Basic) | Printer | Printer SOP Class (1.2.840.10008.5.1.1.16)
static (Shared in Visual Basic) | PrinterConfigurationRetrieval | Printer Configuration Retrieval SOP Class (1.2.840.10008.5.1.1.16.376)
static (Shared in Visual Basic) | PrintJob | Print Job SOP Class (1.2.840.10008.5.1.1.14)
static (Shared in Visual Basic) | PrintQueueManagement | Print Queue Management SOP Class (Retired) (1.2.840.10008.5.1.1.26)
static (Shared in Visual Basic) | ProceduralEventLogging | Procedural Event Logging SOP Class (1.2.840.10008.1.40)
static (Shared in Visual Basic) | ProcedureLog | Procedure Log Storage (1.2.840.10008.5.1.4.1.1.88.40)
static (Shared in Visual Basic) | ProductCharacteristicsQuery | Product Characteristics Query SOP Class (1.2.840.10008.5.1.4.41)
static (Shared in Visual Basic) | PseudoColorSoftcopyPresentationState | Pseudo-SKColor Softcopy Presentation State Storage SOP Class (1.2.840.10008.5.1.4.1.1.11.3)
static (Shared in Visual Basic) | PullPrintRequest | Pull Print Request SOP Class (Retired) (1.2.840.10008.5.1.1.31)
static (Shared in Visual Basic) | RawData | Raw Data Storage (1.2.840.10008.5.1.4.1.1.66)
static (Shared in Visual Basic) | RealWorldValueMapping | Real World Value Mapping Storage (1.2.840.10008.5.1.4.1.1.67)
static (Shared in Visual Basic) | ReferencedImageBox | Referenced Image Box SOP Class (Retired) (1.2.840.10008.5.1.1.4.2)
static (Shared in Visual Basic) | RespiratoryWaveform | Respiratory Waveform Storage (1.2.840.10008.5.1.4.1.1.9.6.1)
static (Shared in Visual Basic) | RT | RT Image Storage (1.2.840.10008.5.1.4.1.1.481.1)
static (Shared in Visual Basic) | RTBeamsDeliveryInstruction | RT Beams Delivery Instruction Storage (1.2.840.10008.5.1.4.34.7)
static (Shared in Visual Basic) | RTBeamsDeliveryInstructionTrial | RT Beams Delivery Instruction Storage - Trial (Retired) (1.2.840.10008.5.1.4.34.1)
static (Shared in Visual Basic) | RTBeamsTreatmentRecord | RT Beams Treatment Record Storage (1.2.840.10008.5.1.4.1.1.481.4)
static (Shared in Visual Basic) | RTBrachyTreatmentRecord | RT Brachy Treatment Record Storage (1.2.840.10008.5.1.4.1.1.481.6)
static (Shared in Visual Basic) | RTConventionalMachineVerification | RT Conventional Machine Verification (1.2.840.10008.5.1.4.34.8)
static (Shared in Visual Basic) | RTConventionalMachineVerificationTrial | RT Conventional Machine Verification - Trial (Retired) (1.2.840.10008.5.1.4.34.2)
static (Shared in Visual Basic) | RTDose | RT Dose Storage (1.2.840.10008.5.1.4.1.1.481.2)
static (Shared in Visual Basic) | RTIonBeamsTreatmentRecord | RT Ion Beams Treatment Record Storage (1.2.840.10008.5.1.4.1.1.481.9)
static (Shared in Visual Basic) | RTIonMachineVerification | RT Ion Machine Verification (1.2.840.10008.5.1.4.34.9)
static (Shared in Visual Basic) | RTIonMachineVerificationTrial | RT Ion Machine Verification - Trial (Retired) (1.2.840.10008.5.1.4.34.3)
static (Shared in Visual Basic) | RTIonPlan | RT Ion Plan Storage (1.2.840.10008.5.1.4.1.1.481.8)
static (Shared in Visual Basic) | RTPlan | RT Plan Storage (1.2.840.10008.5.1.4.1.1.481.5)
static (Shared in Visual Basic) | RTStructureSet | RT Structure Set Storage (1.2.840.10008.5.1.4.1.1.481.3)
static (Shared in Visual Basic) | RTTreatmentSummaryRecord | RT Treatment Summary Record Storage (1.2.840.10008.5.1.4.1.1.481.7)
static (Shared in Visual Basic) | SecondaryCapture | Secondary Capture Image Storage (1.2.840.10008.5.1.4.1.1.7)
static (Shared in Visual Basic) | Segmentation | Segmentation Storage (1.2.840.10008.5.1.4.1.1.66.4)
static (Shared in Visual Basic) | SpatialFiducials | Spatial Fiducials Storage (1.2.840.10008.5.1.4.1.1.66.2)
static (Shared in Visual Basic) | SpatialRegistration | Spatial Registration Storage (1.2.840.10008.5.1.4.1.1.66.1)
static (Shared in Visual Basic) | SpectaclePrescriptionReport | Spectacle Prescription Report Storage (1.2.840.10008.5.1.4.1.1.78.6)
static (Shared in Visual Basic) | StandaloneCurve | Standalone Curve Storage (Retired) (1.2.840.10008.5.1.4.1.1.9)
static (Shared in Visual Basic) | StandaloneModalityLUT | Standalone Modality LUT Storage (Retired) (1.2.840.10008.5.1.4.1.1.10)
static (Shared in Visual Basic) | StandaloneOverlay | Standalone Overlay Storage (Retired) (1.2.840.10008.5.1.4.1.1.8)
static (Shared in Visual Basic) | StandalonePETCurve | Standalone PET Curve Storage (Retired) (1.2.840.10008.5.1.4.1.1.129)
static (Shared in Visual Basic) | StandaloneVOILUT | Standalone VOI LUT Storage (Retired) (1.2.840.10008.5.1.4.1.1.11)
static (Shared in Visual Basic) | StereometricRelationship | Stereometric Relationship Storage (1.2.840.10008.5.1.4.1.1.77.1.5.3)
static (Shared in Visual Basic) | StorageCommitmentPull | Storage Commitment Pull Model SOP Class (Retired) (1.2.840.10008.1.20.2)
static (Shared in Visual Basic) | StorageCommitmentPush | Storage Commitment Push Model SOP Class (1.2.840.10008.1.20.1)
static (Shared in Visual Basic) | StorageServiceClass | Storage Service Class (1.2.840.10008.4.2)
static (Shared in Visual Basic) | StoredPrint | Stored Print Storage SOP Class (Retired) (1.2.840.10008.5.1.1.27)
static (Shared in Visual Basic) | StudyComponentManagement | Study Component Management SOP Class (Retired) (1.2.840.10008.3.1.2.3.2)
static (Shared in Visual Basic) | StudyRootQR_FIND | Study Root Query/Retrieve Information Model - FIND (1.2.840.10008.5.1.4.1.2.2.1)
static (Shared in Visual Basic) | StudyRootQR_GET | Study Root Query/Retrieve Information Model - GET (1.2.840.10008.5.1.4.1.2.2.3)
static (Shared in Visual Basic) | StudyRootQR_MOVE | Study Root Query/Retrieve Information Model - MOVE (1.2.840.10008.5.1.4.1.2.2.2)
static (Shared in Visual Basic) | SubjectiveRefractionMeasurements | Subjective Refraction Measurements Storage (1.2.840.10008.5.1.4.1.1.78.4)
static (Shared in Visual Basic) | SubstanceAdministrationLogging | Substance Administration Logging SOP Class (1.2.840.10008.1.42)
static (Shared in Visual Basic) | SubstanceApprovalQuery | Substance Approval Query SOP Class (1.2.840.10008.5.1.4.42)
static (Shared in Visual Basic) | SurfaceSegmentation | Surface Segmentation Storage (1.2.840.10008.5.1.4.1.1.66.5)
static (Shared in Visual Basic) | TextSRTrial | Text SR Storage - Trial (Retired) (1.2.840.10008.5.1.4.1.1.88.1)
static (Shared in Visual Basic) | TwelveLeadECGWaveform | 12-lead ECG Waveform Storage (1.2.840.10008.5.1.4.1.1.9.1.1)
static (Shared in Visual Basic) | Ultrasound | Ultrasound Image Storage (1.2.840.10008.5.1.4.1.1.6.1)
static (Shared in Visual Basic) | UltrasoundMultiframe | Ultrasound Multi-frame Image Storage (1.2.840.10008.5.1.4.1.1.3.1)
static (Shared in Visual Basic) | UnifiedProcedureStepEvent | Unified Procedure Step - Event SOP Class (1.2.840.10008.5.1.4.34.6.4)
static (Shared in Visual Basic) | UnifiedProcedureStepEventTrial | Unified Procedure Step - Event SOP Class - Trial (Retired) (1.2.840.10008.5.1.4.34.4.4)
static (Shared in Visual Basic) | UnifiedProcedureStepPull | Unified Procedure Step - Pull SOP Class (1.2.840.10008.5.1.4.34.6.3)
static (Shared in Visual Basic) | UnifiedProcedureStepPullTrial | Unified Procedure Step - Pull SOP Class - Trial (Retired) (1.2.840.10008.5.1.4.34.4.3)
static (Shared in Visual Basic) | UnifiedProcedureStepPush | Unified Procedure Step - Push SOP Class (1.2.840.10008.5.1.4.34.6.1)
static (Shared in Visual Basic) | UnifiedProcedureStepPushTrial | Unified Procedure Step - Push SOP Class - Trial (Retired) (1.2.840.10008.5.1.4.34.4.1)
static (Shared in Visual Basic) | UnifiedProcedureStepWatch | Unified Procedure Step - Watch SOP Class (1.2.840.10008.5.1.4.34.6.2)
static (Shared in Visual Basic) | UnifiedProcedureStepWatchTrial | Unified Procedure Step - Watch SOP Class - Trial (Retired) (1.2.840.10008.5.1.4.34.4.2)
static (Shared in Visual Basic) | UnifiedWorklistandProcedureStepServiceClass | Unified Worklist and Procedure Step Service Class (1.2.840.10008.5.1.4.34.6)
static (Shared in Visual Basic) | UnifiedWorklistandProcedureStepServiceClassTrial | Unified Worklist and Procedure Step Service Class - Trial (Retired) (1.2.840.10008.5.1.4.34.4)
static (Shared in Visual Basic) | Verification | Verification SOP Class (1.2.840.10008.1.1)
static (Shared in Visual Basic) | VideoEndoscopic | Video Endoscopic Image Storage (1.2.840.10008.5.1.4.1.1.77.1.1.1)
static (Shared in Visual Basic) | VideoMicroscopic | Video Microscopic Image Storage (1.2.840.10008.5.1.4.1.1.77.1.2.1)
static (Shared in Visual Basic) | VideoPhotographic | Video Photographic Image Storage (1.2.840.10008.5.1.4.1.1.77.1.4.1)
static (Shared in Visual Basic) | VisualAcuityMeasurements | Visual Acuity Measurements Storage (1.2.840.10008.5.1.4.1.1.78.5)
static (Shared in Visual Basic) | VLEndoscopic | VL Endoscopic Image Storage (1.2.840.10008.5.1.4.1.1.77.1.1)
static (Shared in Visual Basic) | VLMicroscopic | VL Microscopic Image Storage (1.2.840.10008.5.1.4.1.1.77.1.2)
static (Shared in Visual Basic) | VLPhotographic | VL Photographic Image Storage (1.2.840.10008.5.1.4.1.1.77.1.4)
static (Shared in Visual Basic) | VLSlideCoordinatesMicroscopic | VL Slide-Coordinates Microscopic Image Storage (1.2.840.10008.5.1.4.1.1.77.1.3)
static (Shared in Visual Basic) | VLWholeSlideMicroscopyImage | VL Whole Slide Microscopy Image Storage (1.2.840.10008.5.1.4.1.1.77.1.6)
static (Shared in Visual Basic) | VOILUTBox | VOI LUT Box SOP Class (1.2.840.10008.5.1.1.22)
static (Shared in Visual Basic) | WaveformTrial | Waveform Storage - Trial (Retired) (1.2.840.10008.5.1.4.1.1.9.1)
static (Shared in Visual Basic) | XA_XRFGrayscaleSoftcopyPresentationState | XA/XRF Grayscale Softcopy Presentation State Storage (1.2.840.10008.5.1.4.1.1.11.5)
static (Shared in Visual Basic) | XRay3DAngiographicImage | X-Ray 3D Angiographic Image Storage (1.2.840.10008.5.1.4.1.1.13.1.1)
static (Shared in Visual Basic) | XRay3DCraniofacialImage | X-Ray 3D Craniofacial Image Storage (1.2.840.10008.5.1.4.1.1.13.1.2)
static (Shared in Visual Basic) | XRayAngiographic | X-Ray Angiographic Image Storage (1.2.840.10008.5.1.4.1.1.12.1)
static (Shared in Visual Basic) | XRayAngiographicBiPlane | X-Ray Angiographic Bi-Plane Image Storage (Retired) (1.2.840.10008.5.1.4.1.1.12.3)
static (Shared in Visual Basic) | XRayRadiationDoseSR | X-Ray Radiation Dose SR Storage (1.2.840.10008.5.1.4.1.1.88.67)
static (Shared in Visual Basic) | XRayRadiofluoroscopic | X-Ray Radiofluoroscopic Image Storage (1.2.840.10008.5.1.4.1.1.12.2)
    Top
    See Also

    Reference

    SOPClasses Class
    DicomObjects.UIDs Namespace


DicomObjects.UIDs Namespace / SOPClasses Class / AmbulatoryECGWaveform Field

    AmbulatoryECGWaveform Field
    Ambulatory ECG Waveform Storage (1.2.840.10008.5.1.4.1.1.9.1.3)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly AmbulatoryECGWaveform As UID
    'Usage

    Dim value As UID

value = SOPClasses.AmbulatoryECGWaveform
    public static readonly UID AmbulatoryECGWaveform
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / ArterialPulseWaveform Field

    ArterialPulseWaveform Field
    Arterial Pulse Waveform Storage (1.2.840.10008.5.1.4.1.1.9.5.1)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly ArterialPulseWaveform As UID
    'Usage

    Dim value As UID

value = SOPClasses.ArterialPulseWaveform
    public static readonly UID ArterialPulseWaveform
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / AudioSRTrial Field

    AudioSRTrial Field
    Audio SR Storage - Trial (Retired) (1.2.840.10008.5.1.4.1.1.88.2)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    <ObsoleteAttribute("Retired UID - should not be used in new implementations")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Shared ReadOnly AudioSRTrial As UID
    'Usage

    Dim value As UID

value = SOPClasses.AudioSRTrial
    [Obsolete("Retired UID - should not be used in new implementations")]
[EditorBrowsable(EditorBrowsableState.Advanced)]
public static readonly UID AudioSRTrial
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / AutorefractionMeasurements Field

    AutorefractionMeasurements Field
    Autorefraction Measurements Storage (1.2.840.10008.5.1.4.1.1.78.2)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly AutorefractionMeasurements As UID
    'Usage

    Dim value As UID

value = SOPClasses.AutorefractionMeasurements
    public static readonly UID AutorefractionMeasurements
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / BasicAnnotationBox Field

    BasicAnnotationBox Field
    Basic Annotation Box SOP Class (1.2.840.10008.5.1.1.15)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly BasicAnnotationBox As UID
    'Usage

    Dim value As UID

value = SOPClasses.BasicAnnotationBox
    public static readonly UID BasicAnnotationBox
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / BasicColorImageBox Field

    BasicColorImageBox Field
    Basic SKColor Image Box SOP Class (1.2.840.10008.5.1.1.4.1)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly BasicColorImageBox As UID
    'Usage

    Dim value As UID

value = SOPClasses.BasicColorImageBox
    public static readonly UID BasicColorImageBox
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / BasicFilmBox Field

    BasicFilmBox Field
    Basic Film Box SOP Class (1.2.840.10008.5.1.1.2)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly BasicFilmBox As UID
    'Usage

    Dim value As UID

value = SOPClasses.BasicFilmBox
    public static readonly UID BasicFilmBox
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / BasicFilmSession Field

    BasicFilmSession Field
    Basic Film Session SOP Class (1.2.840.10008.5.1.1.1)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly BasicFilmSession As UID
    'Usage

    Dim value As UID

value = SOPClasses.BasicFilmSession
    public static readonly UID BasicFilmSession
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / BasicGrayscaleImageBox Field

    BasicGrayscaleImageBox Field
    Basic Grayscale Image Box SOP Class (1.2.840.10008.5.1.1.4)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly BasicGrayscaleImageBox As UID
    'Usage

    Dim value As UID

value = SOPClasses.BasicGrayscaleImageBox
    public static readonly UID BasicGrayscaleImageBox
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / BasicPrintImageOverlayBox Field

    BasicPrintImageOverlayBox Field
    Basic Print Image Overlay Box SOP Class (Retired) (1.2.840.10008.5.1.1.24.1)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    <ObsoleteAttribute("Retired UID - should not be used in new implementations")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Shared ReadOnly BasicPrintImageOverlayBox As UID
    'Usage

    Dim value As UID

value = SOPClasses.BasicPrintImageOverlayBox
    [Obsolete("Retired UID - should not be used in new implementations")]
[EditorBrowsable(EditorBrowsableState.Advanced)]
public static readonly UID BasicPrintImageOverlayBox
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / BasicStructuredDisplay Field

    BasicStructuredDisplay Field
    Basic Structured Display Storage (1.2.840.10008.5.1.4.1.1.131)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly BasicStructuredDisplay As UID
    'Usage

    Dim value As UID

value = SOPClasses.BasicStructuredDisplay
    public static readonly UID BasicStructuredDisplay
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / BasicStudyContentNotification Field

    BasicStudyContentNotification Field
    Basic Study Content Notification SOP Class (Retired) (1.2.840.10008.1.9)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    <ObsoleteAttribute("Retired UID - should not be used in new implementations")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Shared ReadOnly BasicStudyContentNotification As UID
    'Usage

    Dim value As UID

value = SOPClasses.BasicStudyContentNotification
    [Obsolete("Retired UID - should not be used in new implementations")]
[EditorBrowsable(EditorBrowsableState.Advanced)]
public static readonly UID BasicStudyContentNotification
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / BasicTextSR Field

    BasicTextSR Field
    Basic Text SR Storage (1.2.840.10008.5.1.4.1.1.88.11)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly BasicTextSR As UID
    'Usage

    Dim value As UID

value = SOPClasses.BasicTextSR
    public static readonly UID BasicTextSR
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / BasicVoiceAudioWaveform Field

    BasicVoiceAudioWaveform Field
    Basic Voice Audio Waveform Storage (1.2.840.10008.5.1.4.1.1.9.4.1)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly BasicVoiceAudioWaveform As UID
    'Usage

    Dim value As UID

value = SOPClasses.BasicVoiceAudioWaveform
    public static readonly UID BasicVoiceAudioWaveform
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / BlendingSoftcopyPresentationState Field

    BlendingSoftcopyPresentationState Field
    Blending Softcopy Presentation State Storage SOP Class (1.2.840.10008.5.1.4.1.1.11.4)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly BlendingSoftcopyPresentationState As UID
    'Usage

    Dim value As UID

value = SOPClasses.BlendingSoftcopyPresentationState
    public static readonly UID BlendingSoftcopyPresentationState
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / BreastImagingRelevantPatientInformationQuery Field

    BreastImagingRelevantPatientInformationQuery Field
    Breast Imaging Relevant Patient Information Query (1.2.840.10008.5.1.4.37.2)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly BreastImagingRelevantPatientInformationQuery As UID
    'Usage

    Dim value As UID

value = SOPClasses.BreastImagingRelevantPatientInformationQuery
    public static readonly UID BreastImagingRelevantPatientInformationQuery
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / BreastTomosynthesisImage Field

    BreastTomosynthesisImage Field
    Breast Tomosynthesis Image Storage (1.2.840.10008.5.1.4.1.1.13.1.3)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly BreastTomosynthesisImage As UID
    'Usage

    Dim value As UID

value = SOPClasses.BreastTomosynthesisImage
    public static readonly UID BreastTomosynthesisImage
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / CardiacElectrophysiologyWaveform Field

    CardiacElectrophysiologyWaveform Field
    Cardiac Electrophysiology Waveform Storage (1.2.840.10008.5.1.4.1.1.9.3.1)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly CardiacElectrophysiologyWaveform As UID
    'Usage

    Dim value As UID

value = SOPClasses.CardiacElectrophysiologyWaveform
    public static readonly UID CardiacElectrophysiologyWaveform
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / CardiacRelevantPatientInformationQuery Field

    CardiacRelevantPatientInformationQuery Field
    Cardiac Relevant Patient Information Query (1.2.840.10008.5.1.4.37.3)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly CardiacRelevantPatientInformationQuery As UID
    'Usage

    Dim value As UID

value = SOPClasses.CardiacRelevantPatientInformationQuery
    public static readonly UID CardiacRelevantPatientInformationQuery
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / ChestCADSR Field

    ChestCADSR Field
    Chest CAD SR Storage (1.2.840.10008.5.1.4.1.1.88.65)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly ChestCADSR As UID
    'Usage

    Dim value As UID

value = SOPClasses.ChestCADSR
    public static readonly UID ChestCADSR
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / ColonCADSR Field

    ColonCADSR Field
    Colon CAD SR Storage (1.2.840.10008.5.1.4.1.1.88.69)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly ColonCADSR As UID
    'Usage

    Dim value As UID

value = SOPClasses.ColonCADSR
    public static readonly UID ColonCADSR
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / ColorPalette Field

    ColorPalette Field
    SKColor Palette Storage (1.2.840.10008.5.1.4.39.1)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly ColorPalette As UID
    'Usage

    Dim value As UID

value = SOPClasses.ColorPalette
    public static readonly UID ColorPalette
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / ColorPaletteQRFIND Field

    ColorPaletteQRFIND Field
    SKColor Palette Information Model - FIND (1.2.840.10008.5.1.4.39.2)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly ColorPaletteQRFIND As UID
    'Usage

    Dim value As UID

value = SOPClasses.ColorPaletteQRFIND
    public static readonly UID ColorPaletteQRFIND
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / ColorPaletteQRGET Field

    ColorPaletteQRGET Field
    SKColor Palette Information Model - GET (1.2.840.10008.5.1.4.39.4)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly ColorPaletteQRGET As UID
    'Usage

    Dim value As UID

value = SOPClasses.ColorPaletteQRGET
    public static readonly UID ColorPaletteQRGET
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / ColorPaletteQRMOVE Field

    ColorPaletteQRMOVE Field
    SKColor Palette Information Model - MOVE (1.2.840.10008.5.1.4.39.3)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly ColorPaletteQRMOVE As UID
    'Usage

    Dim value As UID

value = SOPClasses.ColorPaletteQRMOVE
    public static readonly UID ColorPaletteQRMOVE
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / ColorSoftcopyPresentationState Field

    ColorSoftcopyPresentationState Field
    SKColor Softcopy Presentation State Storage SOP Class (1.2.840.10008.5.1.4.1.1.11.2)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly ColorSoftcopyPresentationState As UID
    'Usage

    Dim value As UID

value = SOPClasses.ColorSoftcopyPresentationState
    public static readonly UID ColorSoftcopyPresentationState
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / CompositeInstanceRootRetrieve_GET Field

    CompositeInstanceRootRetrieve_GET Field
    Composite Instance Root Retrieve - GET (1.2.840.10008.5.1.4.1.2.4.3)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly CompositeInstanceRootRetrieve_GET As UID
    'Usage

    Dim value As UID

value = SOPClasses.CompositeInstanceRootRetrieve_GET
    public static readonly UID CompositeInstanceRootRetrieve_GET
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / CompositeInstanceRootRetrieve_MOVE Field

    CompositeInstanceRootRetrieve_MOVE Field
    Composite Instance Root Retrieve - MOVE (1.2.840.10008.5.1.4.1.2.4.2)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly CompositeInstanceRootRetrieve_MOVE As UID
    'Usage

    Dim value As UID

value = SOPClasses.CompositeInstanceRootRetrieve_MOVE
    public static readonly UID CompositeInstanceRootRetrieve_MOVE
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / CompositeInstanceRootRetrieveWithoutBulkData_GET Field

    CompositeInstanceRootRetrieveWithoutBulkData_GET Field
    Composite Instance Retrieve Without Bulk Data - GET (1.2.840.10008.5.1.4.1.2.5.3)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly CompositeInstanceRootRetrieveWithoutBulkData_GET As UID
    'Usage

    Dim value As UID

value = SOPClasses.CompositeInstanceRootRetrieveWithoutBulkData_GET
    public static readonly UID CompositeInstanceRootRetrieveWithoutBulkData_GET
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / ComprehensiveSR Field

    ComprehensiveSR Field
    Comprehensive SR Storage (1.2.840.10008.5.1.4.1.1.88.33)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly ComprehensiveSR As UID
    'Usage

    Dim value As UID

value = SOPClasses.ComprehensiveSR
    public static readonly UID ComprehensiveSR
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / ComprehensiveSRTrial Field

    ComprehensiveSRTrial Field
    Comprehensive SR Storage - Trial (Retired) (1.2.840.10008.5.1.4.1.1.88.4)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    <ObsoleteAttribute("Retired UID - should not be used in new implementations")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Shared ReadOnly ComprehensiveSRTrial As UID
    'Usage

    Dim value As UID

value = SOPClasses.ComprehensiveSRTrial
    [Obsolete("Retired UID - should not be used in new implementations")]
[EditorBrowsable(EditorBrowsableState.Advanced)]
public static readonly UID ComprehensiveSRTrial
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / ComputedRadiography Field

    ComputedRadiography Field
    Computed Radiography Image Storage (1.2.840.10008.5.1.4.1.1.1)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly ComputedRadiography As UID
    'Usage

    Dim value As UID

value = SOPClasses.ComputedRadiography
    public static readonly UID ComputedRadiography
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / CornealTopographyMap Field

    CornealTopographyMap Field
    Corneal Topography Map Storage (1.2.840.10008.5.1.4.1.1.82.1)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly CornealTopographyMap As UID
    'Usage

    Dim value As UID

value = SOPClasses.CornealTopographyMap
    public static readonly UID CornealTopographyMap
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / CT Field

    CT Field
    CT Image Storage (1.2.840.10008.5.1.4.1.1.2)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly CT As UID
    'Usage

    Dim value As UID

value = SOPClasses.CT
    public static readonly UID CT
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / DeformableSpatialRegistration Field

    DeformableSpatialRegistration Field
    Deformable Spatial Registration Storage (1.2.840.10008.5.1.4.1.1.66.3)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly DeformableSpatialRegistration As UID
    'Usage

    Dim value As UID

value = SOPClasses.DeformableSpatialRegistration
    public static readonly UID DeformableSpatialRegistration
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / DetachedInterpretationManagement Field

    DetachedInterpretationManagement Field
    Detached Interpretation Management SOP Class (Retired) (1.2.840.10008.3.1.2.6.1)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    <ObsoleteAttribute("Retired UID - should not be used in new implementations")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Shared ReadOnly DetachedInterpretationManagement As UID
    'Usage

    Dim value As UID

value = SOPClasses.DetachedInterpretationManagement
    [Obsolete("Retired UID - should not be used in new implementations")]
[EditorBrowsable(EditorBrowsableState.Advanced)]
public static readonly UID DetachedInterpretationManagement
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / DetachedPatientManagement Field

    DetachedPatientManagement Field
    Detached Patient Management SOP Class (Retired) (1.2.840.10008.3.1.2.1.1)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    <ObsoleteAttribute("Retired UID - should not be used in new implementations")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Shared ReadOnly DetachedPatientManagement As UID
    'Usage

    Dim value As UID

value = SOPClasses.DetachedPatientManagement
    [Obsolete("Retired UID - should not be used in new implementations")]
[EditorBrowsable(EditorBrowsableState.Advanced)]
public static readonly UID DetachedPatientManagement
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / DetachedResultsManagement Field

    DetachedResultsManagement Field
    Detached Results Management SOP Class (Retired) (1.2.840.10008.3.1.2.5.1)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    <ObsoleteAttribute("Retired UID - should not be used in new implementations")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Shared ReadOnly DetachedResultsManagement As UID
    'Usage

    Dim value As UID

value = SOPClasses.DetachedResultsManagement
    [Obsolete("Retired UID - should not be used in new implementations")]
[EditorBrowsable(EditorBrowsableState.Advanced)]
public static readonly UID DetachedResultsManagement
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / DetachedStudyManagement Field

    DetachedStudyManagement Field
    Detached Study Management SOP Class (Retired) (1.2.840.10008.3.1.2.3.1)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    <ObsoleteAttribute("Retired UID - should not be used in new implementations")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Shared ReadOnly DetachedStudyManagement As UID
    'Usage

    Dim value As UID

value = SOPClasses.DetachedStudyManagement
    [Obsolete("Retired UID - should not be used in new implementations")]
[EditorBrowsable(EditorBrowsableState.Advanced)]
public static readonly UID DetachedStudyManagement
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / DetachedVisitManagement Field

    DetachedVisitManagement Field
    Detached Visit Management SOP Class (Retired) (1.2.840.10008.3.1.2.2.1)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    <ObsoleteAttribute("Retired UID - should not be used in new implementations")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Shared ReadOnly DetachedVisitManagement As UID
    'Usage

    Dim value As UID

value = SOPClasses.DetachedVisitManagement
    [Obsolete("Retired UID - should not be used in new implementations")]
[EditorBrowsable(EditorBrowsableState.Advanced)]
public static readonly UID DetachedVisitManagement
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / DetailSRTrial Field

    DetailSRTrial Field
    Detail SR Storage - Trial (Retired) (1.2.840.10008.5.1.4.1.1.88.3)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    <ObsoleteAttribute("Retired UID - should not be used in new implementations")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Shared ReadOnly DetailSRTrial As UID
    'Usage

    Dim value As UID

value = SOPClasses.DetailSRTrial
    [Obsolete("Retired UID - should not be used in new implementations")]
[EditorBrowsable(EditorBrowsableState.Advanced)]
public static readonly UID DetailSRTrial
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / DICOSCTImage Field

    DICOSCTImage Field
    DICOS CT Image Storage (1.2.840.10008.5.1.4.1.1.501.1)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly DICOSCTImage As UID
    'Usage

    Dim value As UID

value = SOPClasses.DICOSCTImage
    public static readonly UID DICOSCTImage
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / DICOSDigitalXRayImageForPresentation Field

    DICOSDigitalXRayImageForPresentation Field
    DICOS Digital X-Ray Image Storage - For Presentation (1.2.840.10008.5.1.4.1.1.501.2.1)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly DICOSDigitalXRayImageForPresentation As UID
    'Usage

    Dim value As UID

value = SOPClasses.DICOSDigitalXRayImageForPresentation
    public static readonly UID DICOSDigitalXRayImageForPresentation
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / DICOSDigitalXRayImageForProcessing Field

    DICOSDigitalXRayImageForProcessing Field
    DICOS Digital X-Ray Image Storage - For Processing (1.2.840.10008.5.1.4.1.1.501.2.2)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly DICOSDigitalXRayImageForProcessing As UID
    'Usage

    Dim value As UID

value = SOPClasses.DICOSDigitalXRayImageForProcessing
    public static readonly UID DICOSDigitalXRayImageForProcessing
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / DICOSThreatDetectionReport Field

    DICOSThreatDetectionReport Field
    DICOS Threat Detection Report Storage (1.2.840.10008.5.1.4.1.1.501.3)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly DICOSThreatDetectionReport As UID
    'Usage

    Dim value As UID

value = SOPClasses.DICOSThreatDetectionReport
    public static readonly UID DICOSThreatDetectionReport
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / DigitalIntraoralXRay_Presentation Field

    DigitalIntraoralXRay_Presentation Field
    Digital Intra-oral X-Ray Image Storage - For Presentation (1.2.840.10008.5.1.4.1.1.1.3)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly DigitalIntraoralXRay_Presentation As UID
    'Usage

    Dim value As UID

value = SOPClasses.DigitalIntraoralXRay_Presentation
    public static readonly UID DigitalIntraoralXRay_Presentation
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / DigitalIntraoralXRay_Processing Field

    DigitalIntraoralXRay_Processing Field
    Digital Intra-oral X-Ray Image Storage - For Processing (1.2.840.10008.5.1.4.1.1.1.3.1)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly DigitalIntraoralXRay_Processing As UID
    'Usage

    Dim value As UID

value = SOPClasses.DigitalIntraoralXRay_Processing
    public static readonly UID DigitalIntraoralXRay_Processing
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / DigitalMammographyXRay_Presentation Field

    DigitalMammographyXRay_Presentation Field
    Digital Mammography X-Ray Image Storage - For Presentation (1.2.840.10008.5.1.4.1.1.1.2)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly DigitalMammographyXRay_Presentation As UID
    'Usage

    Dim value As UID

value = SOPClasses.DigitalMammographyXRay_Presentation
    public static readonly UID DigitalMammographyXRay_Presentation
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / DigitalMammographyXRay_Processing Field

    DigitalMammographyXRay_Processing Field
    Digital Mammography X-Ray Image Storage - For Processing (1.2.840.10008.5.1.4.1.1.1.2.1)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly DigitalMammographyXRay_Processing As UID
    'Usage

    Dim value As UID

value = SOPClasses.DigitalMammographyXRay_Processing
    public static readonly UID DigitalMammographyXRay_Processing
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / DigitalXRay_Presentation Field

    DigitalXRay_Presentation Field
    Digital X-Ray Image Storage - For Presentation (1.2.840.10008.5.1.4.1.1.1.1)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly DigitalXRay_Presentation As UID
    'Usage

    Dim value As UID

value = SOPClasses.DigitalXRay_Presentation
    public static readonly UID DigitalXRay_Presentation
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / DigitalXRay_Processing Field

    DigitalXRay_Processing Field
    Digital X-Ray Image Storage - For Processing (1.2.840.10008.5.1.4.1.1.1.1.1)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly DigitalXRay_Processing As UID
    'Usage

    Dim value As UID

value = SOPClasses.DigitalXRay_Processing
    public static readonly UID DigitalXRay_Processing
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / EddyCurrentImage Field

    EddyCurrentImage Field
    Eddy Current Image Storage (1.2.840.10008.5.1.4.1.1.601.1)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly EddyCurrentImage As UID
    'Usage

    Dim value As UID

value = SOPClasses.EddyCurrentImage
    public static readonly UID EddyCurrentImage
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / EddyCurrentMultiframeImage Field

    EddyCurrentMultiframeImage Field
    Eddy Current Multi-frame Image Storage (1.2.840.10008.5.1.4.1.1.601.2)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly EddyCurrentMultiframeImage As UID
    'Usage

    Dim value As UID

value = SOPClasses.EddyCurrentMultiframeImage
    public static readonly UID EddyCurrentMultiframeImage
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / EncapsulatedCDA Field

    EncapsulatedCDA Field
    Encapsulated CDA Storage (1.2.840.10008.5.1.4.1.1.104.2)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly EncapsulatedCDA As UID
    'Usage

    Dim value As UID

value = SOPClasses.EncapsulatedCDA
    public static readonly UID EncapsulatedCDA
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / EncapsulatedPDF Field

    EncapsulatedPDF Field
    Encapsulated PDF Storage (1.2.840.10008.5.1.4.1.1.104.1)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly EncapsulatedPDF As UID
    'Usage

    Dim value As UID

value = SOPClasses.EncapsulatedPDF
    public static readonly UID EncapsulatedPDF
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / EncapsulatedSTL Field

    EncapsulatedSTL Field
    Encapsulated STL Storage (1.2.840.10008.5.1.4.1.1.104.3)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly EncapsulatedSTL As UID
    'Usage

    Dim value As UID

value = SOPClasses.EncapsulatedSTL
    public static readonly UID EncapsulatedSTL
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / EnhancedCT Field

    EnhancedCT Field
    Enhanced CT Image Storage (1.2.840.10008.5.1.4.1.1.2.1)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly EnhancedCT As UID
    'Usage

    Dim value As UID

value = SOPClasses.EnhancedCT
    public static readonly UID EnhancedCT
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / EnhancedMR Field

    EnhancedMR Field
    Enhanced MR Image Storage (1.2.840.10008.5.1.4.1.1.4.1)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly EnhancedMR As UID
    'Usage

    Dim value As UID

value = SOPClasses.EnhancedMR
    public static readonly UID EnhancedMR
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / EnhancedMRColorImage Field

    EnhancedMRColorImage Field
    Enhanced MR SKColor Image Storage (1.2.840.10008.5.1.4.1.1.4.3)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly EnhancedMRColorImage As UID
    'Usage

    Dim value As UID

value = SOPClasses.EnhancedMRColorImage
    public static readonly UID EnhancedMRColorImage
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / EnhancedPETImage Field

    EnhancedPETImage Field
    Enhanced PET Image Storage (1.2.840.10008.5.1.4.1.1.130)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly EnhancedPETImage As UID
    'Usage

    Dim value As UID

value = SOPClasses.EnhancedPETImage
    public static readonly UID EnhancedPETImage
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / EnhancedSR Field

    EnhancedSR Field
    Enhanced SR Storage (1.2.840.10008.5.1.4.1.1.88.22)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly EnhancedSR As UID
    'Usage

    Dim value As UID

value = SOPClasses.EnhancedSR
    public static readonly UID EnhancedSR
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / EnhancedUSVolume Field

    EnhancedUSVolume Field
    Enhanced US Volume Storage (1.2.840.10008.5.1.4.1.1.6.2)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly EnhancedUSVolume As UID
    'Usage

    Dim value As UID

value = SOPClasses.EnhancedUSVolume
    public static readonly UID EnhancedUSVolume
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / EnhancedXAImage Field

    EnhancedXAImage Field
    Enhanced XA Image Storage (1.2.840.10008.5.1.4.1.1.12.1.1)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly EnhancedXAImage As UID
    'Usage

    Dim value As UID

value = SOPClasses.EnhancedXAImage
    public static readonly UID EnhancedXAImage
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / EnhancedXRFImage Field

    EnhancedXRFImage Field
    Enhanced XRF Image Storage (1.2.840.10008.5.1.4.1.1.12.2.1)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly EnhancedXRFImage As UID
    'Usage

    Dim value As UID

value = SOPClasses.EnhancedXRFImage
    public static readonly UID EnhancedXRFImage
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / GeneralAudioWaveform Field

    GeneralAudioWaveform Field
    General Audio Waveform Storage (1.2.840.10008.5.1.4.1.1.9.4.2)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly GeneralAudioWaveform As UID
    'Usage

    Dim value As UID

value = SOPClasses.GeneralAudioWaveform
    public static readonly UID GeneralAudioWaveform
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / GeneralECGWaveform Field

    GeneralECGWaveform Field
    General ECG Waveform Storage (1.2.840.10008.5.1.4.1.1.9.1.2)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly GeneralECGWaveform As UID
    'Usage

    Dim value As UID

value = SOPClasses.GeneralECGWaveform
    public static readonly UID GeneralECGWaveform
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / GeneralPurposePerformedProcedureStep Field

    GeneralPurposePerformedProcedureStep Field
    General Purpose Performed Procedure Step SOP Class (1.2.840.10008.5.1.4.32.3)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly GeneralPurposePerformedProcedureStep As UID
    'Usage

    Dim value As UID

value = SOPClasses.GeneralPurposePerformedProcedureStep
    public static readonly UID GeneralPurposePerformedProcedureStep
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / GeneralPurposeScheduledProcedureStep Field

    GeneralPurposeScheduledProcedureStep Field
    General Purpose Scheduled Procedure Step SOP Class (1.2.840.10008.5.1.4.32.2)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly GeneralPurposeScheduledProcedureStep As UID
    'Usage

    Dim value As UID

value = SOPClasses.GeneralPurposeScheduledProcedureStep
    public static readonly UID GeneralPurposeScheduledProcedureStep
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / GeneralPurposeWorklistQRFIND Field

    GeneralPurposeWorklistQRFIND Field
    General Purpose Worklist Information Model - FIND (1.2.840.10008.5.1.4.32.1)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly GeneralPurposeWorklistQRFIND As UID
    'Usage

    Dim value As UID

value = SOPClasses.GeneralPurposeWorklistQRFIND
    public static readonly UID GeneralPurposeWorklistQRFIND
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / GeneralRelevantPatientInformationQuery Field

    GeneralRelevantPatientInformationQuery Field
    General Relevant Patient Information Query (1.2.840.10008.5.1.4.37.1)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly GeneralRelevantPatientInformationQuery As UID
    'Usage

    Dim value As UID

value = SOPClasses.GeneralRelevantPatientInformationQuery
    public static readonly UID GeneralRelevantPatientInformationQuery
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / GenericImplantTemplate Field

    GenericImplantTemplate Field
    Generic Implant Template Storage (1.2.840.10008.5.1.4.43.1)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly GenericImplantTemplate As UID
    'Usage

    Dim value As UID

value = SOPClasses.GenericImplantTemplate
    public static readonly UID GenericImplantTemplate
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / GenericImplantTemplateQRFIND Field

    GenericImplantTemplateQRFIND Field
    Generic Implant Template Information Model - FIND (1.2.840.10008.5.1.4.43.2)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly GenericImplantTemplateQRFIND As UID
    'Usage

    Dim value As UID

value = SOPClasses.GenericImplantTemplateQRFIND
    public static readonly UID GenericImplantTemplateQRFIND
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / GenericImplantTemplateQRGET Field

    GenericImplantTemplateQRGET Field
    Generic Implant Template Information Model - GET (1.2.840.10008.5.1.4.43.4)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly GenericImplantTemplateQRGET As UID
    'Usage

    Dim value As UID

value = SOPClasses.GenericImplantTemplateQRGET
    public static readonly UID GenericImplantTemplateQRGET
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / GenericImplantTemplateQRMOVE Field

    GenericImplantTemplateQRMOVE Field
    Generic Implant Template Information Model - MOVE (1.2.840.10008.5.1.4.43.3)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly GenericImplantTemplateQRMOVE As UID
    'Usage

    Dim value As UID

value = SOPClasses.GenericImplantTemplateQRMOVE
    public static readonly UID GenericImplantTemplateQRMOVE
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / GrayscaleSoftcopyPresentationState Field

    GrayscaleSoftcopyPresentationState Field
    Grayscale Softcopy Presentation State Storage SOP Class (1.2.840.10008.5.1.4.1.1.11.1)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly GrayscaleSoftcopyPresentationState As UID
    'Usage

    Dim value As UID

value = SOPClasses.GrayscaleSoftcopyPresentationState
    public static readonly UID GrayscaleSoftcopyPresentationState
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / HangingProtocol Field

    HangingProtocol Field
    Hanging Protocol Storage (1.2.840.10008.5.1.4.38.1)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly HangingProtocol As UID
    'Usage

    Dim value As UID

value = SOPClasses.HangingProtocol
    public static readonly UID HangingProtocol
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / HangingProtocolQRFIND Field

    HangingProtocolQRFIND Field
    Hanging Protocol Information Model - FIND (1.2.840.10008.5.1.4.38.2)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly HangingProtocolQRFIND As UID
    'Usage

    Dim value As UID

value = SOPClasses.HangingProtocolQRFIND
    public static readonly UID HangingProtocolQRFIND
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / HangingProtocolQRGET Field

    HangingProtocolQRGET Field
    Hanging Protocol Information Model - GET (1.2.840.10008.5.1.4.38.4)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly HangingProtocolQRGET As UID
    'Usage

    Dim value As UID

value = SOPClasses.HangingProtocolQRGET
    public static readonly UID HangingProtocolQRGET
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / HangingProtocolQRMOVE Field

    HangingProtocolQRMOVE Field
    Hanging Protocol Information Model - MOVE (1.2.840.10008.5.1.4.38.3)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly HangingProtocolQRMOVE As UID
    'Usage

    Dim value As UID

value = SOPClasses.HangingProtocolQRMOVE
    public static readonly UID HangingProtocolQRMOVE
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / HardcopyColor Field

    HardcopyColor Field
    Hardcopy SKColor Image Storage SOP Class (Retired) (1.2.840.10008.5.1.1.30)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    <ObsoleteAttribute("Retired UID - should not be used in new implementations")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Shared ReadOnly HardcopyColor As UID
    'Usage

    Dim value As UID

value = SOPClasses.HardcopyColor
    [Obsolete("Retired UID - should not be used in new implementations")]
[EditorBrowsable(EditorBrowsableState.Advanced)]
public static readonly UID HardcopyColor
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / HardcopyGrayscale Field

    HardcopyGrayscale Field
    Hardcopy Grayscale Image Storage SOP Class (Retired) (1.2.840.10008.5.1.1.29)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    <ObsoleteAttribute("Retired UID - should not be used in new implementations")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Shared ReadOnly HardcopyGrayscale As UID
    'Usage

    Dim value As UID

value = SOPClasses.HardcopyGrayscale
    [Obsolete("Retired UID - should not be used in new implementations")]
[EditorBrowsable(EditorBrowsableState.Advanced)]
public static readonly UID HardcopyGrayscale
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / HemodynamicWaveform Field

    HemodynamicWaveform Field
    Hemodynamic Waveform Storage (1.2.840.10008.5.1.4.1.1.9.2.1)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly HemodynamicWaveform As UID
    'Usage

    Dim value As UID

value = SOPClasses.HemodynamicWaveform
    public static readonly UID HemodynamicWaveform
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / ImageOverlayBox Field

    ImageOverlayBox Field
    Image Overlay Box SOP Class (Retired) (1.2.840.10008.5.1.1.24)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    <ObsoleteAttribute("Retired UID - should not be used in new implementations")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Shared ReadOnly ImageOverlayBox As UID
    'Usage

    Dim value As UID

value = SOPClasses.ImageOverlayBox
    [Obsolete("Retired UID - should not be used in new implementations")]
[EditorBrowsable(EditorBrowsableState.Advanced)]
public static readonly UID ImageOverlayBox
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / ImplantAssemblyTemplate Field

    ImplantAssemblyTemplate Field
    Implant Assembly Template Storage (1.2.840.10008.5.1.4.44.1)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly ImplantAssemblyTemplate As UID
    'Usage

    Dim value As UID

value = SOPClasses.ImplantAssemblyTemplate
    public static readonly UID ImplantAssemblyTemplate
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / ImplantAssemblyTemplateQRFIND Field

    ImplantAssemblyTemplateQRFIND Field
    Implant Assembly Template Information Model - FIND (1.2.840.10008.5.1.4.44.2)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly ImplantAssemblyTemplateQRFIND As UID
    'Usage

    Dim value As UID

value = SOPClasses.ImplantAssemblyTemplateQRFIND
    public static readonly UID ImplantAssemblyTemplateQRFIND
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / ImplantAssemblyTemplateQRGET Field

    ImplantAssemblyTemplateQRGET Field
    Implant Assembly Template Information Model - GET (1.2.840.10008.5.1.4.44.4)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly ImplantAssemblyTemplateQRGET As UID
    'Usage

    Dim value As UID

value = SOPClasses.ImplantAssemblyTemplateQRGET
    public static readonly UID ImplantAssemblyTemplateQRGET
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / ImplantAssemblyTemplateQRMOVE Field

    ImplantAssemblyTemplateQRMOVE Field
    Implant Assembly Template Information Model - MOVE (1.2.840.10008.5.1.4.44.3)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly ImplantAssemblyTemplateQRMOVE As UID
    'Usage

    Dim value As UID

value = SOPClasses.ImplantAssemblyTemplateQRMOVE
    public static readonly UID ImplantAssemblyTemplateQRMOVE
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / ImplantationPlanSR Field

    ImplantationPlanSR Field
    Implantation Plan SR Storage (1.2.840.10008.5.1.4.1.1.88.70)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly ImplantationPlanSR As UID
    'Usage

    Dim value As UID

value = SOPClasses.ImplantationPlanSR
    public static readonly UID ImplantationPlanSR
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / ImplantTemplateGroup Field

    ImplantTemplateGroup Field
    Implant Template Group Storage (1.2.840.10008.5.1.4.45.1)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly ImplantTemplateGroup As UID
    'Usage

    Dim value As UID

value = SOPClasses.ImplantTemplateGroup
    public static readonly UID ImplantTemplateGroup
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / ImplantTemplateGroupQRFIND Field

    ImplantTemplateGroupQRFIND Field
    Implant Template Group Information Model - FIND (1.2.840.10008.5.1.4.45.2)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly ImplantTemplateGroupQRFIND As UID
    'Usage

    Dim value As UID

value = SOPClasses.ImplantTemplateGroupQRFIND
    public static readonly UID ImplantTemplateGroupQRFIND
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / ImplantTemplateGroupQRGET Field

    ImplantTemplateGroupQRGET Field
    Implant Template Group Information Model - GET (1.2.840.10008.5.1.4.45.4)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly ImplantTemplateGroupQRGET As UID
    'Usage

    Dim value As UID

value = SOPClasses.ImplantTemplateGroupQRGET
    public static readonly UID ImplantTemplateGroupQRGET
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / ImplantTemplateGroupQRMOVE Field

    ImplantTemplateGroupQRMOVE Field
    Implant Template Group Information Model - MOVE (1.2.840.10008.5.1.4.45.3)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly ImplantTemplateGroupQRMOVE As UID
    'Usage

    Dim value As UID

value = SOPClasses.ImplantTemplateGroupQRMOVE
    public static readonly UID ImplantTemplateGroupQRMOVE
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / InstanceAvailabilityNotification Field

    InstanceAvailabilityNotification Field
    Instance Availability Notification SOP Class (1.2.840.10008.5.1.4.33)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly InstanceAvailabilityNotification As UID
    'Usage

    Dim value As UID

value = SOPClasses.InstanceAvailabilityNotification
    public static readonly UID InstanceAvailabilityNotification
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / IntraocularLensCalculations Field

    IntraocularLensCalculations Field
    Intraocular Lens Calculations Storage (1.2.840.10008.5.1.4.1.1.78.8)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly IntraocularLensCalculations As UID
    'Usage

    Dim value As UID

value = SOPClasses.IntraocularLensCalculations
    public static readonly UID IntraocularLensCalculations
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / IntravascularOpticalCoherenceTomographyImageForPresentation Field

    IntravascularOpticalCoherenceTomographyImageForPresentation Field
    In This Topic
    Intravascular Optical Coherence Tomography Image Storage - For Presentation (1.2.840.10008.5.1.4.1.1.14.1)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly IntravascularOpticalCoherenceTomographyImageForPresentation As UID
    'Usage

    Dim value As UID

value = SOPClasses.IntravascularOpticalCoherenceTomographyImageForPresentation
    public static readonly UID IntravascularOpticalCoherenceTomographyImageForPresentation
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / IntravascularOpticalCoherenceTomographyImageForProcessing Field

    IntravascularOpticalCoherenceTomographyImageForProcessing Field
    In This Topic
    Intravascular Optical Coherence Tomography Image Storage - For Processing (1.2.840.10008.5.1.4.1.1.14.2)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly IntravascularOpticalCoherenceTomographyImageForProcessing As UID
    'Usage

    Dim value As UID

value = SOPClasses.IntravascularOpticalCoherenceTomographyImageForProcessing
    public static readonly UID IntravascularOpticalCoherenceTomographyImageForProcessing
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / KeratometryMeasurements Field

    KeratometryMeasurements Field
    Keratometry Measurements Storage (1.2.840.10008.5.1.4.1.1.78.3)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly KeratometryMeasurements As UID
    'Usage

    Dim value As UID

value = SOPClasses.KeratometryMeasurements
    public static readonly UID KeratometryMeasurements
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / KeyObjectSelectionDocument Field

    KeyObjectSelectionDocument Field
    Key Object Selection Document Storage (1.2.840.10008.5.1.4.1.1.88.59)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly KeyObjectSelectionDocument As UID
    'Usage

    Dim value As UID

value = SOPClasses.KeyObjectSelectionDocument
    public static readonly UID KeyObjectSelectionDocument
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / LegacyConvertedEnhancedCT Field

    LegacyConvertedEnhancedCT Field
    Legacy Converted Enhanced CT Image Storage (1.2.840.10008.5.1.4.1.1.2.2)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly LegacyConvertedEnhancedCT As UID
    'Usage

    Dim value As UID

value = SOPClasses.LegacyConvertedEnhancedCT
    public static readonly UID LegacyConvertedEnhancedCT
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / LegacyConvertedEnhancedMRColorImage Field

    LegacyConvertedEnhancedMRColorImage Field
    Legacy Converted Enhanced MR Image Storage (1.2.840.10008.5.1.4.1.1.4.4)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly LegacyConvertedEnhancedMRColorImage As UID
    'Usage

    Dim value As UID

value = SOPClasses.LegacyConvertedEnhancedMRColorImage
    public static readonly UID LegacyConvertedEnhancedMRColorImage
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / LegacyConvertedEnhancedPETImage Field

    LegacyConvertedEnhancedPETImage Field
    Legacy Converted Enhanced PET Image Storage (1.2.840.10008.5.1.4.1.1.128.1)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly LegacyConvertedEnhancedPETImage As UID
    'Usage

    Dim value As UID

value = SOPClasses.LegacyConvertedEnhancedPETImage
    public static readonly UID LegacyConvertedEnhancedPETImage
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / LensometryMeasurements Field

    LensometryMeasurements Field
    Lensometry Measurements Storage (1.2.840.10008.5.1.4.1.1.78.1)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly LensometryMeasurements As UID
    'Usage

    Dim value As UID

value = SOPClasses.LensometryMeasurements
    public static readonly UID LensometryMeasurements
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / MacularGridThicknessandVolumeReport Field

    MacularGridThicknessandVolumeReport Field
    Macular Grid Thickness and Volume Report Storage (1.2.840.10008.5.1.4.1.1.79.1)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly MacularGridThicknessandVolumeReport As UID
    'Usage

    Dim value As UID

value = SOPClasses.MacularGridThicknessandVolumeReport
    public static readonly UID MacularGridThicknessandVolumeReport
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / MammographyCADSR Field

    MammographyCADSR Field
    Mammography CAD SR Storage (1.2.840.10008.5.1.4.1.1.88.50)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly MammographyCADSR As UID
    'Usage

    Dim value As UID

value = SOPClasses.MammographyCADSR
    public static readonly UID MammographyCADSR
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / MediaCreationManagementUID Field

    MediaCreationManagementUID Field
    Media Creation Management SOP Class UID (1.2.840.10008.5.1.1.33)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly MediaCreationManagementUID As UID
    'Usage

    Dim value As UID

value = SOPClasses.MediaCreationManagementUID
    public static readonly UID MediaCreationManagementUID
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / MediaStorageDirectory Field

    MediaStorageDirectory Field
    Media Storage Directory Storage (1.2.840.10008.1.3.10)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly MediaStorageDirectory As UID
    'Usage

    Dim value As UID

value = SOPClasses.MediaStorageDirectory
    public static readonly UID MediaStorageDirectory
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / ModalityPerformedProcedureStep Field

    ModalityPerformedProcedureStep Field
    Modality Performed Procedure Step SOP Class (1.2.840.10008.3.1.2.3.3)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly ModalityPerformedProcedureStep As UID
    'Usage

    Dim value As UID

value = SOPClasses.ModalityPerformedProcedureStep
    public static readonly UID ModalityPerformedProcedureStep
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / ModalityPerformedProcedureStepNotification Field

    ModalityPerformedProcedureStepNotification Field
    Modality Performed Procedure Step Notification SOP Class (1.2.840.10008.3.1.2.3.5)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly ModalityPerformedProcedureStepNotification As UID
    'Usage

    Dim value As UID

value = SOPClasses.ModalityPerformedProcedureStepNotification
    public static readonly UID ModalityPerformedProcedureStepNotification
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / ModalityPerformedProcedureStepRetrieve Field

    ModalityPerformedProcedureStepRetrieve Field
    Modality Performed Procedure Step Retrieve SOP Class (1.2.840.10008.3.1.2.3.4)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly ModalityPerformedProcedureStepRetrieve As UID
    'Usage

    Dim value As UID

value = SOPClasses.ModalityPerformedProcedureStepRetrieve
    public static readonly UID ModalityPerformedProcedureStepRetrieve
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / ModalityWorklistQRFIND Field

    ModalityWorklistQRFIND Field
    Modality Worklist Information Model - FIND (1.2.840.10008.5.1.4.31)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly ModalityWorklistQRFIND As UID
    'Usage

    Dim value As UID

value = SOPClasses.ModalityWorklistQRFIND
    public static readonly UID ModalityWorklistQRFIND
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / MR Field

    MR Field
    MR Image Storage (1.2.840.10008.5.1.4.1.1.4)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly MR As UID
    'Usage

    Dim value As UID

value = SOPClasses.MR
    public static readonly UID MR
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / MRSpectroscopy Field

    MRSpectroscopy Field
    MR Spectroscopy Storage (1.2.840.10008.5.1.4.1.1.4.2)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly MRSpectroscopy As UID
    'Usage

    Dim value As UID

value = SOPClasses.MRSpectroscopy
    public static readonly UID MRSpectroscopy
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / MultiFrameGrayscaleByteSC Field

    MultiFrameGrayscaleByteSC Field
    Multi-frame Grayscale Byte Secondary Capture Image Storage (1.2.840.10008.5.1.4.1.1.7.2)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly MultiFrameGrayscaleByteSC As UID
    'Usage

    Dim value As UID

value = SOPClasses.MultiFrameGrayscaleByteSC
    public static readonly UID MultiFrameGrayscaleByteSC
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / MultiFrameGrayscaleWordSC Field

    MultiFrameGrayscaleWordSC Field
    Multi-frame Grayscale Word Secondary Capture Image Storage (1.2.840.10008.5.1.4.1.1.7.3)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly MultiFrameGrayscaleWordSC As UID
    'Usage

    Dim value As UID

value = SOPClasses.MultiFrameGrayscaleWordSC
    public static readonly UID MultiFrameGrayscaleWordSC
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / MultiFrameSingleBitSC Field

    MultiFrameSingleBitSC Field
    Multi-frame Single Bit Secondary Capture Image Storage (1.2.840.10008.5.1.4.1.1.7.1)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly MultiFrameSingleBitSC As UID
    'Usage

    Dim value As UID

value = SOPClasses.MultiFrameSingleBitSC
    public static readonly UID MultiFrameSingleBitSC
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / MultiFrameTrueColorSC Field

    MultiFrameTrueColorSC Field
    Multi-frame True SKColor Secondary Capture Image Storage (1.2.840.10008.5.1.4.1.1.7.4)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly MultiFrameTrueColorSC As UID
    'Usage

    Dim value As UID

value = SOPClasses.MultiFrameTrueColorSC
    public static readonly UID MultiFrameTrueColorSC
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / NuclearMedicine Field

    NuclearMedicine Field
    Nuclear Medicine Image Storage (1.2.840.10008.5.1.4.1.1.20)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly NuclearMedicine As UID
    'Usage

    Dim value As UID

value = SOPClasses.NuclearMedicine
    public static readonly UID NuclearMedicine
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / OldNuclearMedicine Field

    OldNuclearMedicine Field
    Nuclear Medicine Image Storage (Retired) (1.2.840.10008.5.1.4.1.1.5)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    <ObsoleteAttribute("Retired UID - should not be used in new implementations")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Shared ReadOnly OldNuclearMedicine As UID
    'Usage

    Dim value As UID

value = SOPClasses.OldNuclearMedicine
    [Obsolete("Retired UID - should not be used in new implementations")]
[EditorBrowsable(EditorBrowsableState.Advanced)]
public static readonly UID OldNuclearMedicine
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / OldUltrasound Field

    OldUltrasound Field
    Ultrasound Image Storage (Retired) (1.2.840.10008.5.1.4.1.1.6)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    <ObsoleteAttribute("Retired UID - should not be used in new implementations")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Shared ReadOnly OldUltrasound As UID
    'Usage

    Dim value As UID

value = SOPClasses.OldUltrasound
    [Obsolete("Retired UID - should not be used in new implementations")]
[EditorBrowsable(EditorBrowsableState.Advanced)]
public static readonly UID OldUltrasound
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / OldUltrasoundMultiframe Field

    OldUltrasoundMultiframe Field
    Ultrasound Multi-frame Image Storage (Retired) (1.2.840.10008.5.1.4.1.1.3)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    <ObsoleteAttribute("Retired UID - should not be used in new implementations")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Shared ReadOnly OldUltrasoundMultiframe As UID
    'Usage

    Dim value As UID

value = SOPClasses.OldUltrasoundMultiframe
    [Obsolete("Retired UID - should not be used in new implementations")]
[EditorBrowsable(EditorBrowsableState.Advanced)]
public static readonly UID OldUltrasoundMultiframe
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / OphthalmicAxialMeasurements Field

    OphthalmicAxialMeasurements Field
    Ophthalmic Axial Measurements Storage (1.2.840.10008.5.1.4.1.1.78.7)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly OphthalmicAxialMeasurements As UID
    'Usage

    Dim value As UID

value = SOPClasses.OphthalmicAxialMeasurements
    public static readonly UID OphthalmicAxialMeasurements
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / OphthalmicPhotography16Bit Field

    OphthalmicPhotography16Bit Field
    Ophthalmic Photography 16 Bit Image Storage (1.2.840.10008.5.1.4.1.1.77.1.5.2)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly OphthalmicPhotography16Bit As UID
    'Usage

    Dim value As UID

value = SOPClasses.OphthalmicPhotography16Bit
    public static readonly UID OphthalmicPhotography16Bit
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / OphthalmicPhotography8Bit Field

    OphthalmicPhotography8Bit Field
    Ophthalmic Photography 8 Bit Image Storage (1.2.840.10008.5.1.4.1.1.77.1.5.1)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly OphthalmicPhotography8Bit As UID
    'Usage

    Dim value As UID

value = SOPClasses.OphthalmicPhotography8Bit
    public static readonly UID OphthalmicPhotography8Bit
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / OphthalmicThicknessMap Field

    OphthalmicThicknessMap Field
    Ophthalmic Thickness Map Storage (1.2.840.10008.5.1.4.1.1.81.1)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly OphthalmicThicknessMap As UID
    'Usage

    Dim value As UID

value = SOPClasses.OphthalmicThicknessMap
    public static readonly UID OphthalmicThicknessMap
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / OphthalmicTomographyImage Field

    OphthalmicTomographyImage Field
    Ophthalmic Tomography Image Storage (1.2.840.10008.5.1.4.1.1.77.1.5.4)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly OphthalmicTomographyImage As UID
    'Usage

    Dim value As UID

value = SOPClasses.OphthalmicTomographyImage
    public static readonly UID OphthalmicTomographyImage
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / OphthalmicVisualFieldStaticPerimetryMeasurements Field

    OphthalmicVisualFieldStaticPerimetryMeasurements Field
    Ophthalmic Visual Field Static Perimetry Measurements Storage (1.2.840.10008.5.1.4.1.1.80.1)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly OphthalmicVisualFieldStaticPerimetryMeasurements As UID
    'Usage

    Dim value As UID

value = SOPClasses.OphthalmicVisualFieldStaticPerimetryMeasurements
    public static readonly UID OphthalmicVisualFieldStaticPerimetryMeasurements
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / PatientRootQR_FIND Field

    PatientRootQR_FIND Field
    Patient Root Query/Retrieve Information Model - FIND (1.2.840.10008.5.1.4.1.2.1.1)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly PatientRootQR_FIND As UID
    'Usage

    Dim value As UID

value = SOPClasses.PatientRootQR_FIND
    public static readonly UID PatientRootQR_FIND
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / PatientRootQR_GET Field

    PatientRootQR_GET Field
    Patient Root Query/Retrieve Information Model - GET (1.2.840.10008.5.1.4.1.2.1.3)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly PatientRootQR_GET As UID
    'Usage

    Dim value As UID

value = SOPClasses.PatientRootQR_GET
    public static readonly UID PatientRootQR_GET
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / PatientRootQR_MOVE Field

    PatientRootQR_MOVE Field
    Patient Root Query/Retrieve Information Model - MOVE (1.2.840.10008.5.1.4.1.2.1.2)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly PatientRootQR_MOVE As UID
    'Usage

    Dim value As UID

value = SOPClasses.PatientRootQR_MOVE
    public static readonly UID PatientRootQR_MOVE
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / PatientStudyOnlyQR_FIND Field

    PatientStudyOnlyQR_FIND Field
    Patient/Study Only Query/Retrieve Information Model - FIND (Retired) (1.2.840.10008.5.1.4.1.2.3.1)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    <ObsoleteAttribute("Retired UID - should not be used in new implementations")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Shared ReadOnly PatientStudyOnlyQR_FIND As UID
    'Usage

    Dim value As UID

value = SOPClasses.PatientStudyOnlyQR_FIND
    [Obsolete("Retired UID - should not be used in new implementations")]
[EditorBrowsable(EditorBrowsableState.Advanced)]
public static readonly UID PatientStudyOnlyQR_FIND
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / PatientStudyOnlyQR_GET Field

    PatientStudyOnlyQR_GET Field
    Patient/Study Only Query/Retrieve Information Model - GET (Retired) (1.2.840.10008.5.1.4.1.2.3.3)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    <ObsoleteAttribute("Retired UID - should not be used in new implementations")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Shared ReadOnly PatientStudyOnlyQR_GET As UID
    'Usage

    Dim value As UID

value = SOPClasses.PatientStudyOnlyQR_GET
    [Obsolete("Retired UID - should not be used in new implementations")]
[EditorBrowsable(EditorBrowsableState.Advanced)]
public static readonly UID PatientStudyOnlyQR_GET
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / PatientStudyOnlyQR_MOVE Field

    PatientStudyOnlyQR_MOVE Field
    Patient/Study Only Query/Retrieve Information Model - MOVE (Retired) (1.2.840.10008.5.1.4.1.2.3.2)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    <ObsoleteAttribute("Retired UID - should not be used in new implementations")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Shared ReadOnly PatientStudyOnlyQR_MOVE As UID
    'Usage

    Dim value As UID

value = SOPClasses.PatientStudyOnlyQR_MOVE
    [Obsolete("Retired UID - should not be used in new implementations")]
[EditorBrowsable(EditorBrowsableState.Advanced)]
public static readonly UID PatientStudyOnlyQR_MOVE
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / PositronEmissionTomography Field

    PositronEmissionTomography Field
    Positron Emission Tomography Image Storage (1.2.840.10008.5.1.4.1.1.128)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly PositronEmissionTomography As UID
    'Usage

    Dim value As UID

value = SOPClasses.PositronEmissionTomography
    public static readonly UID PositronEmissionTomography
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / PresentationLUT Field

    PresentationLUT Field
    Presentation LUT SOP Class (1.2.840.10008.5.1.1.23)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly PresentationLUT As UID
    'Usage

    Dim value As UID

value = SOPClasses.PresentationLUT
    public static readonly UID PresentationLUT
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / Printer Field

    Printer Field (SOPClasses)
    In This Topic
    Printer SOP Class (1.2.840.10008.5.1.1.16)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly Printer As UID
    'Usage

    Dim value As UID

value = SOPClasses.Printer
    public static readonly UID Printer
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / PrinterConfigurationRetrieval Field

    PrinterConfigurationRetrieval Field (SOPClasses)
    In This Topic
    Printer Configuration Retrieval SOP Class (1.2.840.10008.5.1.1.16.376)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly PrinterConfigurationRetrieval As UID
    'Usage

    Dim value As UID

value = SOPClasses.PrinterConfigurationRetrieval
    public static readonly UID PrinterConfigurationRetrieval
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / PrintJob Field

    PrintJob Field
    Print Job SOP Class (1.2.840.10008.5.1.1.14)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly PrintJob As UID
    'Usage

    Dim value As UID

value = SOPClasses.PrintJob
    public static readonly UID PrintJob
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / PrintQueueManagement Field

    PrintQueueManagement Field
    Print Queue Management SOP Class (Retired) (1.2.840.10008.5.1.1.26)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    <ObsoleteAttribute("Retired UID - should not be used in new implementations")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Shared ReadOnly PrintQueueManagement As UID
    'Usage

    Dim value As UID

value = SOPClasses.PrintQueueManagement
    [Obsolete("Retired UID - should not be used in new implementations")]
[EditorBrowsable(EditorBrowsableState.Advanced)]
public static readonly UID PrintQueueManagement
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / ProceduralEventLogging Field

    ProceduralEventLogging Field
    Procedural Event Logging SOP Class (1.2.840.10008.1.40)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly ProceduralEventLogging As UID
    'Usage

    Dim value As UID

value = SOPClasses.ProceduralEventLogging
    public static readonly UID ProceduralEventLogging
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / ProcedureLog Field

    ProcedureLog Field
    Procedure Log Storage (1.2.840.10008.5.1.4.1.1.88.40)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly ProcedureLog As UID
    'Usage

    Dim value As UID

value = SOPClasses.ProcedureLog
    public static readonly UID ProcedureLog
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / ProductCharacteristicsQuery Field

    ProductCharacteristicsQuery Field
    Product Characteristics Query SOP Class (1.2.840.10008.5.1.4.41)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly ProductCharacteristicsQuery As UID
    'Usage

    Dim value As UID

value = SOPClasses.ProductCharacteristicsQuery
    public static readonly UID ProductCharacteristicsQuery
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / PseudoColorSoftcopyPresentationState Field

    PseudoColorSoftcopyPresentationState Field
    Pseudo-SKColor Softcopy Presentation State Storage SOP Class (1.2.840.10008.5.1.4.1.1.11.3)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly PseudoColorSoftcopyPresentationState As UID
    'Usage

    Dim value As UID

value = SOPClasses.PseudoColorSoftcopyPresentationState
    public static readonly UID PseudoColorSoftcopyPresentationState
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / PullPrintRequest Field

    PullPrintRequest Field
    Pull Print Request SOP Class (Retired) (1.2.840.10008.5.1.1.31)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    <ObsoleteAttribute("Retired UID - should not be used in new implementations")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Shared ReadOnly PullPrintRequest As UID
    'Usage

    Dim value As UID

value = SOPClasses.PullPrintRequest
    [Obsolete("Retired UID - should not be used in new implementations")]
[EditorBrowsable(EditorBrowsableState.Advanced)]
public static readonly UID PullPrintRequest
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / RawData Field

    RawData Field
    Raw Data Storage (1.2.840.10008.5.1.4.1.1.66)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly RawData As UID
    'Usage

    Dim value As UID

value = SOPClasses.RawData
    public static readonly UID RawData
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / RealWorldValueMapping Field

    RealWorldValueMapping Field
    Real World Value Mapping Storage (1.2.840.10008.5.1.4.1.1.67)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly RealWorldValueMapping As UID
    'Usage

    Dim value As UID

value = SOPClasses.RealWorldValueMapping
    public static readonly UID RealWorldValueMapping
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / ReferencedImageBox Field

    ReferencedImageBox Field
    Referenced Image Box SOP Class (Retired) (1.2.840.10008.5.1.1.4.2)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    <ObsoleteAttribute("Retired UID - should not be used in new implementations")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Shared ReadOnly ReferencedImageBox As UID
    'Usage

    Dim value As UID

value = SOPClasses.ReferencedImageBox
    [Obsolete("Retired UID - should not be used in new implementations")]
[EditorBrowsable(EditorBrowsableState.Advanced)]
public static readonly UID ReferencedImageBox
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / RespiratoryWaveform Field

    RespiratoryWaveform Field
    Respiratory Waveform Storage (1.2.840.10008.5.1.4.1.1.9.6.1)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly RespiratoryWaveform As UID
    'Usage

    Dim value As UID

value = SOPClasses.RespiratoryWaveform
    public static readonly UID RespiratoryWaveform
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / RT Field

    RT Field
    RT Image Storage (1.2.840.10008.5.1.4.1.1.481.1)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly RT As UID
    'Usage

    Dim value As UID

value = SOPClasses.RT
    public static readonly UID RT
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / RTBeamsDeliveryInstruction Field

    RTBeamsDeliveryInstruction Field
    RT Beams Delivery Instruction Storage (1.2.840.10008.5.1.4.34.7)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly RTBeamsDeliveryInstruction As UID
    'Usage

    Dim value As UID

value = SOPClasses.RTBeamsDeliveryInstruction
    public static readonly UID RTBeamsDeliveryInstruction
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / RTBeamsDeliveryInstructionTrial Field

    RTBeamsDeliveryInstructionTrial Field
    RT Beams Delivery Instruction Storage - Trial (Retired) (1.2.840.10008.5.1.4.34.1)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    <ObsoleteAttribute("Retired UID - should not be used in new implementations")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Shared ReadOnly RTBeamsDeliveryInstructionTrial As UID
    'Usage

    Dim value As UID

value = SOPClasses.RTBeamsDeliveryInstructionTrial
    [Obsolete("Retired UID - should not be used in new implementations")]
[EditorBrowsable(EditorBrowsableState.Advanced)]
public static readonly UID RTBeamsDeliveryInstructionTrial
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / RTBeamsTreatmentRecord Field

    RTBeamsTreatmentRecord Field
    RT Beams Treatment Record Storage (1.2.840.10008.5.1.4.1.1.481.4)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly RTBeamsTreatmentRecord As UID
    'Usage

    Dim value As UID

value = SOPClasses.RTBeamsTreatmentRecord
    public static readonly UID RTBeamsTreatmentRecord
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / RTBrachyTreatmentRecord Field

    RTBrachyTreatmentRecord Field
    RT Brachy Treatment Record Storage (1.2.840.10008.5.1.4.1.1.481.6)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly RTBrachyTreatmentRecord As UID
    'Usage

    Dim value As UID

value = SOPClasses.RTBrachyTreatmentRecord
    public static readonly UID RTBrachyTreatmentRecord
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / RTConventionalMachineVerification Field

    RTConventionalMachineVerification Field
    RT Conventional Machine Verification (1.2.840.10008.5.1.4.34.8)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly RTConventionalMachineVerification As UID
    'Usage

    Dim value As UID

value = SOPClasses.RTConventionalMachineVerification
    public static readonly UID RTConventionalMachineVerification
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / RTConventionalMachineVerificationTrial Field

    RTConventionalMachineVerificationTrial Field
    RT Conventional Machine Verification - Trial (Retired) (1.2.840.10008.5.1.4.34.2)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    <ObsoleteAttribute("Retired UID - should not be used in new implementations")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Shared ReadOnly RTConventionalMachineVerificationTrial As UID
    'Usage

    Dim value As UID

value = SOPClasses.RTConventionalMachineVerificationTrial
    [Obsolete("Retired UID - should not be used in new implementations")]
[EditorBrowsable(EditorBrowsableState.Advanced)]
public static readonly UID RTConventionalMachineVerificationTrial
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / RTDose Field

    RTDose Field
    RT Dose Storage (1.2.840.10008.5.1.4.1.1.481.2)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly RTDose As UID
    'Usage

    Dim value As UID

value = SOPClasses.RTDose
    public static readonly UID RTDose
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / RTIonBeamsTreatmentRecord Field

    RTIonBeamsTreatmentRecord Field
    RT Ion Beams Treatment Record Storage (1.2.840.10008.5.1.4.1.1.481.9)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly RTIonBeamsTreatmentRecord As UID
    'Usage

    Dim value As UID

value = SOPClasses.RTIonBeamsTreatmentRecord
    public static readonly UID RTIonBeamsTreatmentRecord
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / RTIonMachineVerification Field

    RTIonMachineVerification Field
    RT Ion Machine Verification (1.2.840.10008.5.1.4.34.9)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly RTIonMachineVerification As UID
    'Usage

    Dim value As UID

value = SOPClasses.RTIonMachineVerification
    public static readonly UID RTIonMachineVerification
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / RTIonMachineVerificationTrial Field

    RTIonMachineVerificationTrial Field
    RT Ion Machine Verification - Trial (Retired) (1.2.840.10008.5.1.4.34.3)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    <ObsoleteAttribute("Retired UID - should not be used in new implementations")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Shared ReadOnly RTIonMachineVerificationTrial As UID
    'Usage

    Dim value As UID

value = SOPClasses.RTIonMachineVerificationTrial
    [Obsolete("Retired UID - should not be used in new implementations")]
[EditorBrowsable(EditorBrowsableState.Advanced)]
public static readonly UID RTIonMachineVerificationTrial
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / RTIonPlan Field

    RTIonPlan Field
    RT Ion Plan Storage (1.2.840.10008.5.1.4.1.1.481.8)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly RTIonPlan As UID
    'Usage

    Dim value As UID

value = SOPClasses.RTIonPlan
    public static readonly UID RTIonPlan
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / RTPlan Field

    RTPlan Field
    RT Plan Storage (1.2.840.10008.5.1.4.1.1.481.5)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly RTPlan As UID
    'Usage

    Dim value As UID

value = SOPClasses.RTPlan
    public static readonly UID RTPlan
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / RTStructureSet Field

    RTStructureSet Field
    RT Structure Set Storage (1.2.840.10008.5.1.4.1.1.481.3)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly RTStructureSet As UID
    'Usage

    Dim value As UID

value = SOPClasses.RTStructureSet
    public static readonly UID RTStructureSet
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / RTTreatmentSummaryRecord Field

    RTTreatmentSummaryRecord Field
    RT Treatment Summary Record Storage (1.2.840.10008.5.1.4.1.1.481.7)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly RTTreatmentSummaryRecord As UID
    'Usage

    Dim value As UID

value = SOPClasses.RTTreatmentSummaryRecord
    public static readonly UID RTTreatmentSummaryRecord
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / SecondaryCapture Field

    SecondaryCapture Field
    Secondary Capture Image Storage (1.2.840.10008.5.1.4.1.1.7)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly SecondaryCapture As UID
    'Usage

    Dim value As UID

value = SOPClasses.SecondaryCapture
    public static readonly UID SecondaryCapture
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / Segmentation Field

    Segmentation Field
    Segmentation Storage (1.2.840.10008.5.1.4.1.1.66.4)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly Segmentation As UID
    'Usage

    Dim value As UID

value = SOPClasses.Segmentation
    public static readonly UID Segmentation
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / SpatialFiducials Field

    SpatialFiducials Field
    Spatial Fiducials Storage (1.2.840.10008.5.1.4.1.1.66.2)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly SpatialFiducials As UID
    'Usage

    Dim value As UID

value = SOPClasses.SpatialFiducials
    public static readonly UID SpatialFiducials
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / SpatialRegistration Field

    SpatialRegistration Field
    Spatial Registration Storage (1.2.840.10008.5.1.4.1.1.66.1)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly SpatialRegistration As UID
    'Usage

    Dim value As UID

value = SOPClasses.SpatialRegistration
    public static readonly UID SpatialRegistration
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / SpectaclePrescriptionReport Field

    SpectaclePrescriptionReport Field
    Spectacle Prescription Report Storage (1.2.840.10008.5.1.4.1.1.78.6)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly SpectaclePrescriptionReport As UID
    'Usage

    Dim value As UID

value = SOPClasses.SpectaclePrescriptionReport
    public static readonly UID SpectaclePrescriptionReport
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / StandaloneCurve Field

    StandaloneCurve Field
    Standalone Curve Storage (Retired) (1.2.840.10008.5.1.4.1.1.9)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    <ObsoleteAttribute("Retired UID - should not be used in new implementations")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Shared ReadOnly StandaloneCurve As UID
    'Usage

    Dim value As UID

value = SOPClasses.StandaloneCurve
    [Obsolete("Retired UID - should not be used in new implementations")]
[EditorBrowsable(EditorBrowsableState.Advanced)]
public static readonly UID StandaloneCurve
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / StandaloneModalityLUT Field

    StandaloneModalityLUT Field
    Standalone Modality LUT Storage (Retired) (1.2.840.10008.5.1.4.1.1.10)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    <ObsoleteAttribute("Retired UID - should not be used in new implementations")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Shared ReadOnly StandaloneModalityLUT As UID
    'Usage

    Dim value As UID

value = SOPClasses.StandaloneModalityLUT
    [Obsolete("Retired UID - should not be used in new implementations")]
[EditorBrowsable(EditorBrowsableState.Advanced)]
public static readonly UID StandaloneModalityLUT
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / StandaloneOverlay Field

    StandaloneOverlay Field
    Standalone Overlay Storage (Retired) (1.2.840.10008.5.1.4.1.1.8)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    <ObsoleteAttribute("Retired UID - should not be used in new implementations")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Shared ReadOnly StandaloneOverlay As UID
    'Usage

    Dim value As UID

value = SOPClasses.StandaloneOverlay
    [Obsolete("Retired UID - should not be used in new implementations")]
[EditorBrowsable(EditorBrowsableState.Advanced)]
public static readonly UID StandaloneOverlay
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / StandalonePETCurve Field

    StandalonePETCurve Field
    Standalone PET Curve Storage (Retired) (1.2.840.10008.5.1.4.1.1.129)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    <ObsoleteAttribute("Retired UID - should not be used in new implementations")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Shared ReadOnly StandalonePETCurve As UID
    'Usage

    Dim value As UID

value = SOPClasses.StandalonePETCurve
    [Obsolete("Retired UID - should not be used in new implementations")]
[EditorBrowsable(EditorBrowsableState.Advanced)]
public static readonly UID StandalonePETCurve
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / StandaloneVOILUT Field

    StandaloneVOILUT Field
    Standalone VOI LUT Storage (Retired) (1.2.840.10008.5.1.4.1.1.11)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    <ObsoleteAttribute("Retired UID - should not be used in new implementations")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Shared ReadOnly StandaloneVOILUT As UID
    'Usage

    Dim value As UID

value = SOPClasses.StandaloneVOILUT
    [Obsolete("Retired UID - should not be used in new implementations")]
[EditorBrowsable(EditorBrowsableState.Advanced)]
public static readonly UID StandaloneVOILUT
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / StereometricRelationship Field

    StereometricRelationship Field
    Stereometric Relationship Storage (1.2.840.10008.5.1.4.1.1.77.1.5.3)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly StereometricRelationship As UID
    'Usage

    Dim value As UID

value = SOPClasses.StereometricRelationship
    public static readonly UID StereometricRelationship
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / StorageCommitmentPull Field

    StorageCommitmentPull Field (SOPClasses)
    In This Topic
    Storage Commitment Pull Model SOP Class (Retired) (1.2.840.10008.1.20.2)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    <ObsoleteAttribute("Retired UID - should not be used in new implementations")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Shared ReadOnly StorageCommitmentPull As UID
    'Usage

    Dim value As UID

value = SOPClasses.StorageCommitmentPull
    [Obsolete("Retired UID - should not be used in new implementations")]
[EditorBrowsable(EditorBrowsableState.Advanced)]
public static readonly UID StorageCommitmentPull
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / StorageCommitmentPush Field

    StorageCommitmentPush Field (SOPClasses)
    In This Topic
    Storage Commitment Push Model SOP Class (1.2.840.10008.1.20.1)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly StorageCommitmentPush As UID
    'Usage

    Dim value As UID

value = SOPClasses.StorageCommitmentPush
    public static readonly UID StorageCommitmentPush
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / StorageServiceClass Field

    StorageServiceClass Field
    Storage Service Class (1.2.840.10008.4.2)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly StorageServiceClass As UID
    'Usage

    Dim value As UID

value = SOPClasses.StorageServiceClass
    public static readonly UID StorageServiceClass
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / StoredPrint Field

    StoredPrint Field
    Stored Print Storage SOP Class (Retired) (1.2.840.10008.5.1.1.27)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    <ObsoleteAttribute("Retired UID - should not be used in new implementations")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Shared ReadOnly StoredPrint As UID
    'Usage

    Dim value As UID

value = SOPClasses.StoredPrint
    [Obsolete("Retired UID - should not be used in new implementations")]
[EditorBrowsable(EditorBrowsableState.Advanced)]
public static readonly UID StoredPrint
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / StudyComponentManagement Field

    StudyComponentManagement Field
    Study Component Management SOP Class (Retired) (1.2.840.10008.3.1.2.3.2)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    <ObsoleteAttribute("Retired UID - should not be used in new implementations")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Shared ReadOnly StudyComponentManagement As UID
    'Usage

    Dim value As UID

value = SOPClasses.StudyComponentManagement
    [Obsolete("Retired UID - should not be used in new implementations")]
[EditorBrowsable(EditorBrowsableState.Advanced)]
public static readonly UID StudyComponentManagement
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / StudyRootQR_FIND Field

    StudyRootQR_FIND Field
    Study Root Query/Retrieve Information Model - FIND (1.2.840.10008.5.1.4.1.2.2.1)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly StudyRootQR_FIND As UID
    'Usage

    Dim value As UID

value = SOPClasses.StudyRootQR_FIND
    public static readonly UID StudyRootQR_FIND
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / StudyRootQR_GET Field

    StudyRootQR_GET Field
    Study Root Query/Retrieve Information Model - GET (1.2.840.10008.5.1.4.1.2.2.3)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly StudyRootQR_GET As UID
    'Usage

    Dim value As UID

value = SOPClasses.StudyRootQR_GET
    public static readonly UID StudyRootQR_GET
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / StudyRootQR_MOVE Field

    StudyRootQR_MOVE Field
    Study Root Query/Retrieve Information Model - MOVE (1.2.840.10008.5.1.4.1.2.2.2)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly StudyRootQR_MOVE As UID
    'Usage

    Dim value As UID

value = SOPClasses.StudyRootQR_MOVE
    public static readonly UID StudyRootQR_MOVE
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / SubjectiveRefractionMeasurements Field

    SubjectiveRefractionMeasurements Field
    Subjective Refraction Measurements Storage (1.2.840.10008.5.1.4.1.1.78.4)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly SubjectiveRefractionMeasurements As UID
    'Usage

    Dim value As UID

value = SOPClasses.SubjectiveRefractionMeasurements
    public static readonly UID SubjectiveRefractionMeasurements
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / SubstanceAdministrationLogging Field

    SubstanceAdministrationLogging Field
    Substance Administration Logging SOP Class (1.2.840.10008.1.42)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly SubstanceAdministrationLogging As UID
    'Usage

    Dim value As UID

value = SOPClasses.SubstanceAdministrationLogging
    public static readonly UID SubstanceAdministrationLogging
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / SubstanceApprovalQuery Field

    SubstanceApprovalQuery Field
    Substance Approval Query SOP Class (1.2.840.10008.5.1.4.42)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly SubstanceApprovalQuery As UID
    'Usage

    Dim value As UID

value = SOPClasses.SubstanceApprovalQuery
    public static readonly UID SubstanceApprovalQuery
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / SurfaceSegmentation Field

    SurfaceSegmentation Field
    Surface Segmentation Storage (1.2.840.10008.5.1.4.1.1.66.5)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly SurfaceSegmentation As UID
    'Usage

    Dim value As UID

value = SOPClasses.SurfaceSegmentation
    public static readonly UID SurfaceSegmentation
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / TextSRTrial Field

    TextSRTrial Field
    Text SR Storage - Trial (Retired) (1.2.840.10008.5.1.4.1.1.88.1)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    <ObsoleteAttribute("Retired UID - should not be used in new implementations")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Shared ReadOnly TextSRTrial As UID
    'Usage

    Dim value As UID

value = SOPClasses.TextSRTrial
    [Obsolete("Retired UID - should not be used in new implementations")]
[EditorBrowsable(EditorBrowsableState.Advanced)]
public static readonly UID TextSRTrial
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / TwelveLeadECGWaveform Field

    TwelveLeadECGWaveform Field
    12-lead ECG Waveform Storage (1.2.840.10008.5.1.4.1.1.9.1.1)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly TwelveLeadECGWaveform As UID
    'Usage

    Dim value As UID

value = SOPClasses.TwelveLeadECGWaveform
    public static readonly UID TwelveLeadECGWaveform
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / Ultrasound Field

    Ultrasound Field
    Ultrasound Image Storage (1.2.840.10008.5.1.4.1.1.6.1)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly Ultrasound As UID
    'Usage

    Dim value As UID

value = SOPClasses.Ultrasound
    public static readonly UID Ultrasound
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / UltrasoundMultiframe Field

    UltrasoundMultiframe Field
    Ultrasound Multi-frame Image Storage (1.2.840.10008.5.1.4.1.1.3.1)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly UltrasoundMultiframe As UID
    'Usage

    Dim value As UID

value = SOPClasses.UltrasoundMultiframe
    public static readonly UID UltrasoundMultiframe
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / UnifiedProcedureStepEvent Field

    UnifiedProcedureStepEvent Field
    Unified Procedure Step - Event SOP Class (1.2.840.10008.5.1.4.34.6.4)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly UnifiedProcedureStepEvent As UID
    'Usage

    Dim value As UID

value = SOPClasses.UnifiedProcedureStepEvent
    public static readonly UID UnifiedProcedureStepEvent
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / UnifiedProcedureStepEventTrial Field

    UnifiedProcedureStepEventTrial Field
    Unified Procedure Step - Event SOP Class - Trial (Retired) (1.2.840.10008.5.1.4.34.4.4)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    <ObsoleteAttribute("Retired UID - should not be used in new implementations")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Shared ReadOnly UnifiedProcedureStepEventTrial As UID
    'Usage

    Dim value As UID

value = SOPClasses.UnifiedProcedureStepEventTrial
    [Obsolete("Retired UID - should not be used in new implementations")]
[EditorBrowsable(EditorBrowsableState.Advanced)]
public static readonly UID UnifiedProcedureStepEventTrial
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / UnifiedProcedureStepPull Field

    UnifiedProcedureStepPull Field
    Unified Procedure Step - Pull SOP Class (1.2.840.10008.5.1.4.34.6.3)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly UnifiedProcedureStepPull As UID
    'Usage

    Dim value As UID

value = SOPClasses.UnifiedProcedureStepPull
    public static readonly UID UnifiedProcedureStepPull
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / UnifiedProcedureStepPullTrial Field

    UnifiedProcedureStepPullTrial Field
    Unified Procedure Step - Pull SOP Class - Trial (Retired) (1.2.840.10008.5.1.4.34.4.3)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    <ObsoleteAttribute("Retired UID - should not be used in new implementations")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Shared ReadOnly UnifiedProcedureStepPullTrial As UID
    'Usage

    Dim value As UID

value = SOPClasses.UnifiedProcedureStepPullTrial
    [Obsolete("Retired UID - should not be used in new implementations")]
[EditorBrowsable(EditorBrowsableState.Advanced)]
public static readonly UID UnifiedProcedureStepPullTrial
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / UnifiedProcedureStepPush Field

    UnifiedProcedureStepPush Field
    Unified Procedure Step - Push SOP Class (1.2.840.10008.5.1.4.34.6.1)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly UnifiedProcedureStepPush As UID
    'Usage

    Dim value As UID

value = SOPClasses.UnifiedProcedureStepPush
    public static readonly UID UnifiedProcedureStepPush
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / UnifiedProcedureStepPushTrial Field

    UnifiedProcedureStepPushTrial Field
    Unified Procedure Step - Push SOP Class - Trial (Retired) (1.2.840.10008.5.1.4.34.4.1)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    <ObsoleteAttribute("Retired UID - should not be used in new implementations")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Shared ReadOnly UnifiedProcedureStepPushTrial As UID
    'Usage

    Dim value As UID

value = SOPClasses.UnifiedProcedureStepPushTrial
    [Obsolete("Retired UID - should not be used in new implementations")]
[EditorBrowsable(EditorBrowsableState.Advanced)]
public static readonly UID UnifiedProcedureStepPushTrial
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / UnifiedProcedureStepWatch Field

    UnifiedProcedureStepWatch Field
    Unified Procedure Step - Watch SOP Class (1.2.840.10008.5.1.4.34.6.2)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly UnifiedProcedureStepWatch As UID
    'Usage

    Dim value As UID

value = SOPClasses.UnifiedProcedureStepWatch
    public static readonly UID UnifiedProcedureStepWatch
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / UnifiedProcedureStepWatchTrial Field

    UnifiedProcedureStepWatchTrial Field
    Unified Procedure Step - Watch SOP Class - Trial (Retired) (1.2.840.10008.5.1.4.34.4.2)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    <ObsoleteAttribute("Retired UID - should not be used in new implementations")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Shared ReadOnly UnifiedProcedureStepWatchTrial As UID
    'Usage

    Dim value As UID

value = SOPClasses.UnifiedProcedureStepWatchTrial
    [Obsolete("Retired UID - should not be used in new implementations")]
[EditorBrowsable(EditorBrowsableState.Advanced)]
public static readonly UID UnifiedProcedureStepWatchTrial
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / UnifiedWorklistandProcedureStepServiceClass Field

    UnifiedWorklistandProcedureStepServiceClass Field
    Unified Worklist and Procedure Step Service Class (1.2.840.10008.5.1.4.34.6)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly UnifiedWorklistandProcedureStepServiceClass As UID
    'Usage

    Dim value As UID

value = SOPClasses.UnifiedWorklistandProcedureStepServiceClass
    public static readonly UID UnifiedWorklistandProcedureStepServiceClass
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / UnifiedWorklistandProcedureStepServiceClassTrial Field

    UnifiedWorklistandProcedureStepServiceClassTrial Field
    Unified Worklist and Procedure Step Service Class - Trial (Retired) (1.2.840.10008.5.1.4.34.4)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    <ObsoleteAttribute("Retired UID - should not be used in new implementations")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Shared ReadOnly UnifiedWorklistandProcedureStepServiceClassTrial As UID
    'Usage

    Dim value As UID

value = SOPClasses.UnifiedWorklistandProcedureStepServiceClassTrial
    [Obsolete("Retired UID - should not be used in new implementations")]
[EditorBrowsable(EditorBrowsableState.Advanced)]
public static readonly UID UnifiedWorklistandProcedureStepServiceClassTrial
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / Verification Field

    Verification Field
    Verification SOP Class (1.2.840.10008.1.1)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly Verification As UID
    'Usage

    Dim value As UID

value = SOPClasses.Verification
    public static readonly UID Verification
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / VideoEndoscopic Field

    VideoEndoscopic Field
    Video Endoscopic Image Storage (1.2.840.10008.5.1.4.1.1.77.1.1.1)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly VideoEndoscopic As UID
    'Usage

    Dim value As UID

value = SOPClasses.VideoEndoscopic
    public static readonly UID VideoEndoscopic
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / VideoMicroscopic Field

    VideoMicroscopic Field
    Video Microscopic Image Storage (1.2.840.10008.5.1.4.1.1.77.1.2.1)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly VideoMicroscopic As UID
    'Usage

    Dim value As UID

value = SOPClasses.VideoMicroscopic
    public static readonly UID VideoMicroscopic
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / VideoPhotographic Field

    VideoPhotographic Field
    Video Photographic Image Storage (1.2.840.10008.5.1.4.1.1.77.1.4.1)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly VideoPhotographic As UID
    'Usage

    Dim value As UID

value = SOPClasses.VideoPhotographic
    public static readonly UID VideoPhotographic
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / VisualAcuityMeasurements Field

    VisualAcuityMeasurements Field
    Visual Acuity Measurements Storage (1.2.840.10008.5.1.4.1.1.78.5)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly VisualAcuityMeasurements As UID
    'Usage

    Dim value As UID

value = SOPClasses.VisualAcuityMeasurements
    public static readonly UID VisualAcuityMeasurements
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / VLEndoscopic Field

    VLEndoscopic Field
    VL Endoscopic Image Storage (1.2.840.10008.5.1.4.1.1.77.1.1)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly VLEndoscopic As UID
    'Usage

    Dim value As UID

value = SOPClasses.VLEndoscopic
    public static readonly UID VLEndoscopic
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / VLMicroscopic Field

    VLMicroscopic Field
    VL Microscopic Image Storage (1.2.840.10008.5.1.4.1.1.77.1.2)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly VLMicroscopic As UID
    'Usage

    Dim value As UID

value = SOPClasses.VLMicroscopic
    public static readonly UID VLMicroscopic
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / VLPhotographic Field

    VLPhotographic Field
    VL Photographic Image Storage (1.2.840.10008.5.1.4.1.1.77.1.4)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly VLPhotographic As UID
    'Usage

    Dim value As UID

value = SOPClasses.VLPhotographic
    public static readonly UID VLPhotographic
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / VLSlideCoordinatesMicroscopic Field

    VLSlideCoordinatesMicroscopic Field
    VL Slide-Coordinates Microscopic Image Storage (1.2.840.10008.5.1.4.1.1.77.1.3)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly VLSlideCoordinatesMicroscopic As UID
    'Usage

    Dim value As UID

value = SOPClasses.VLSlideCoordinatesMicroscopic
    public static readonly UID VLSlideCoordinatesMicroscopic
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / VLWholeSlideMicroscopyImage Field

    VLWholeSlideMicroscopyImage Field
    VL Whole Slide Microscopy Image Storage (1.2.840.10008.5.1.4.1.1.77.1.6)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly VLWholeSlideMicroscopyImage As UID
    'Usage

    Dim value As UID

value = SOPClasses.VLWholeSlideMicroscopyImage
    public static readonly UID VLWholeSlideMicroscopyImage
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / VOILUTBox Field

    VOILUTBox Field
    VOI LUT Box SOP Class (1.2.840.10008.5.1.1.22)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly VOILUTBox As UID
    'Usage

    Dim value As UID

value = SOPClasses.VOILUTBox
    public static readonly UID VOILUTBox
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / WaveformTrial Field

    WaveformTrial Field
    Waveform Storage - Trial (Retired) (1.2.840.10008.5.1.4.1.1.9.1)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    <ObsoleteAttribute("Retired UID - should not be used in new implementations")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Shared ReadOnly WaveformTrial As UID
    'Usage

    Dim value As UID

value = SOPClasses.WaveformTrial
    [Obsolete("Retired UID - should not be used in new implementations")]
[EditorBrowsable(EditorBrowsableState.Advanced)]
public static readonly UID WaveformTrial
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / XA_XRFGrayscaleSoftcopyPresentationState Field

    XA_XRFGrayscaleSoftcopyPresentationState Field
    XA/XRF Grayscale Softcopy Presentation State Storage (1.2.840.10008.5.1.4.1.1.11.5)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly XA_XRFGrayscaleSoftcopyPresentationState As UID
    'Usage

    Dim value As UID

value = SOPClasses.XA_XRFGrayscaleSoftcopyPresentationState
    public static readonly UID XA_XRFGrayscaleSoftcopyPresentationState
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / XRay3DAngiographicImage Field

    XRay3DAngiographicImage Field
    X-Ray 3D Angiographic Image Storage (1.2.840.10008.5.1.4.1.1.13.1.1)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly XRay3DAngiographicImage As UID
    'Usage

    Dim value As UID

value = SOPClasses.XRay3DAngiographicImage
    public static readonly UID XRay3DAngiographicImage
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / XRay3DCraniofacialImage Field

    XRay3DCraniofacialImage Field
    X-Ray 3D Craniofacial Image Storage (1.2.840.10008.5.1.4.1.1.13.1.2)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly XRay3DCraniofacialImage As UID
    'Usage

    Dim value As UID

value = SOPClasses.XRay3DCraniofacialImage
    public static readonly UID XRay3DCraniofacialImage
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / XRayAngiographic Field

    XRayAngiographic Field
    X-Ray Angiographic Image Storage (1.2.840.10008.5.1.4.1.1.12.1)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly XRayAngiographic As UID
    'Usage

    Dim value As UID

value = SOPClasses.XRayAngiographic
    public static readonly UID XRayAngiographic
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / XRayAngiographicBiPlane Field

    XRayAngiographicBiPlane Field
    X-Ray Angiographic Bi-Plane Image Storage (Retired) (1.2.840.10008.5.1.4.1.1.12.3)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    <ObsoleteAttribute("Retired UID - should not be used in new implementations")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Shared ReadOnly XRayAngiographicBiPlane As UID
    'Usage

    Dim value As UID

value = SOPClasses.XRayAngiographicBiPlane
    [Obsolete("Retired UID - should not be used in new implementations")]
[EditorBrowsable(EditorBrowsableState.Advanced)]
public static readonly UID XRayAngiographicBiPlane
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / XRayRadiationDoseSR Field

    XRayRadiationDoseSR Field
    X-Ray Radiation Dose SR Storage (1.2.840.10008.5.1.4.1.1.88.67)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly XRayRadiationDoseSR As UID
    'Usage

    Dim value As UID

value = SOPClasses.XRayRadiationDoseSR
    public static readonly UID XRayRadiationDoseSR
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


DicomObjects.UIDs Namespace / SOPClasses Class / XRayRadiofluoroscopic Field

    XRayRadiofluoroscopic Field
    X-Ray Radiofluoroscopic Image Storage (1.2.840.10008.5.1.4.1.1.12.2)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly XRayRadiofluoroscopic As UID
    'Usage

    Dim value As UID

value = SOPClasses.XRayRadiofluoroscopic
    public static readonly UID XRayRadiofluoroscopic
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    SOPClasses Class
    SOPClasses Members


%%PageItemTitle%%

DicomObjects.UIDs Namespace / TransferSyntaxes Class
Members

In This Topic
    TransferSyntaxes Class
    In This Topic
    Contains UIDs for Transfer Syntax
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public MustInherit NotInheritable Class TransferSyntaxes
    'Usage

    Dim instance As TransferSyntaxes
    public static class TransferSyntaxes
    Inheritance Hierarchy

    System.Object
    DicomObjects.UIDs.TransferSyntaxes

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    TransferSyntaxes Members
    DicomObjects.UIDs Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.UIDs Namespace / TransferSyntaxes Class
Fields

In This Topic
    TransferSyntaxes Class Members
    In This Topic

    The following tables list the members exposed by TransferSyntaxes.

    Public Fields
     | Name | Description
static (Shared in Visual Basic) | DeflatedExplicitVRLittleEndian | Deflated Explicit VR Little Endian (1.2.840.10008.1.2.1.99)
static (Shared in Visual Basic) | ExplicitVRBigEndian | Explicit VR Big Endian (1.2.840.10008.1.2.2)
static (Shared in Visual Basic) | ExplicitVRLittleEndian | Explicit VR Little Endian (1.2.840.10008.1.2.1)
static (Shared in Visual Basic) | ImplicitVRLittleEndian | Implicit VR Little Endian (1.2.840.10008.1.2)
static (Shared in Visual Basic) | JPEG2000Lossless | JPEG 2000 Image Compression (Lossless Only) (1.2.840.10008.1.2.4.90)
static (Shared in Visual Basic) | JPEG2000Lossy | JPEG 2000 Image Compression (1.2.840.10008.1.2.4.91)
static (Shared in Visual Basic) | JPEG2000Part2MulticomponentImageCompression | JPEG 2000 Part 2 Multi-component Image Compression (1.2.840.10008.1.2.4.93)
static (Shared in Visual Basic) | JPEG2000Part2MulticomponentImageCompressionLosslessOnly | JPEG 2000 Part 2 Multi-component Image Compression (Lossless Only) (1.2.840.10008.1.2.4.92)
static (Shared in Visual Basic) | JPEGBaseline | JPEG Baseline (Process 1) (1.2.840.10008.1.2.4.50)
static (Shared in Visual Basic) | JPEGExtended | JPEG Extended (Process 2 & 4) (1.2.840.10008.1.2.4.51)
static (Shared in Visual Basic) | JPEGExtendedHierarchicalProcess16and18 | JPEG Extended, Hierarchical (Process 16 & 18) (Retired) (1.2.840.10008.1.2.4.59)
static (Shared in Visual Basic) | JPEGExtendedHierarchicalProcess17and19 | JPEG Extended, Hierarchical (Process 17 & 19) (Retired) (1.2.840.10008.1.2.4.60)
static (Shared in Visual Basic) | JPEGExtendedProcess3and5 | JPEG Extended (Process 3 & 5) (Retired) (1.2.840.10008.1.2.4.52)
static (Shared in Visual Basic) | JPEGFullProgressionHierarchicalProcess24and26 | JPEG Full Progression, Hierarchical (Process 24 & 26) (Retired) (1.2.840.10008.1.2.4.63)
static (Shared in Visual Basic) | JPEGFullProgressionHierarchicalProcess25and27 | JPEG Full Progression, Hierarchical (Process 25 & 27) (Retired) (1.2.840.10008.1.2.4.64)
static (Shared in Visual Basic) | JPEGFullProgressionNonHierarchicalProcess10and12 | JPEG Full Progression, Non-Hierarchical (Process 10 & 12) (Retired) (1.2.840.10008.1.2.4.55)
static (Shared in Visual Basic) | JPEGFullProgressionNonHierarchicalProcess11and13 | JPEG Full Progression, Non-Hierarchical (Process 11 & 13) (Retired) (1.2.840.10008.1.2.4.56)
static (Shared in Visual Basic) | JPEGLossless | JPEG Lossless, Non-Hierarchical (Process 14) (1.2.840.10008.1.2.4.57)
static (Shared in Visual Basic) | JPEGLosslessFirstOrder | JPEG Lossless, Non-Hierarchical, First-Order Prediction (Process 14 [Selection Value 1]) (1.2.840.10008.1.2.4.70)
static (Shared in Visual Basic) | JPEGLosslessHierarchicalProcess28 | JPEG Lossless, Hierarchical (Process 28) (Retired) (1.2.840.10008.1.2.4.65)
static (Shared in Visual Basic) | JPEGLosslessHierarchicalProcess29 | JPEG Lossless, Hierarchical (Process 29) (Retired) (1.2.840.10008.1.2.4.66)
static (Shared in Visual Basic) | JPEGLosslessNonHierarchicalProcess15 | JPEG Lossless, Non-Hierarchical (Process 15) (Retired) (1.2.840.10008.1.2.4.58)
static (Shared in Visual Basic) | JPEGLSLossless | JPEG-LS Lossless Image Compression (1.2.840.10008.1.2.4.80)
static (Shared in Visual Basic) | JPEGLSLossy | JPEG-LS Lossy (Near-Lossless) Image Compression (1.2.840.10008.1.2.4.81)
static (Shared in Visual Basic) | JPEGSpectralSelectionHierarchicalProcess20and22 | JPEG Spectral Selection, Hierarchical (Process 20 & 22) (Retired) (1.2.840.10008.1.2.4.61)
static (Shared in Visual Basic) | JPEGSpectralSelectionHierarchicalProcess21and23 | JPEG Spectral Selection, Hierarchical (Process 21 & 23) (Retired) (1.2.840.10008.1.2.4.62)
static (Shared in Visual Basic) | JPEGSpectralSelectionNonHierarchicalProcess6and8 | JPEG Spectral Selection, Non-Hierarchical (Process 6 & 8) (Retired) (1.2.840.10008.1.2.4.53)
static (Shared in Visual Basic) | JPEGSpectralSelectionNonHierarchicalProcess7and9 | JPEG Spectral Selection, Non-Hierarchical (Process 7 & 9) (Retired) (1.2.840.10008.1.2.4.54)
static (Shared in Visual Basic) | JPIPReferenced | JPIP Referenced (1.2.840.10008.1.2.4.94)
static (Shared in Visual Basic) | JPIPReferencedDeflate | JPIP Referenced Deflate (1.2.840.10008.1.2.4.95)
static (Shared in Visual Basic) | MPEG2 | MPEG2 Main Profile @ Main Level (1.2.840.10008.1.2.4.100)
static (Shared in Visual Basic) | MPEG2_HL | MPEG2 Main Profile @ High Level (1.2.840.10008.1.2.4.101)
static (Shared in Visual Basic) | MPEG4 | MPEG-4 AVC/H.264 High Profile / Level 4.1 (1.2.840.10008.1.2.4.102)
static (Shared in Visual Basic) | MPEG4_BD | MPEG-4 AVC/H.264 BD-compatible High Profile / Level 4.1 (1.2.840.10008.1.2.4.103)
static (Shared in Visual Basic) | RFC2557MIMEencapsulation | RFC 2557 MIME encapsulation (1.2.840.10008.1.2.6.1)
static (Shared in Visual Basic) | RLELossless | RLE Lossless (1.2.840.10008.1.2.5)
static (Shared in Visual Basic) | XMLEncoding | XML Encoding (1.2.840.10008.1.2.6.2)
    Top
    See Also

    Reference

    TransferSyntaxes Class
    DicomObjects.UIDs Namespace


%%PageItemTitle%% $$Fields$$

DicomObjects.UIDs Namespace / TransferSyntaxes Class

    TransferSyntaxes Class Fields
    In This Topic

    For a list of all members of this type, see TransferSyntaxes members.

    Public Fields
     | Name | Description
static (Shared in Visual Basic) | DeflatedExplicitVRLittleEndian | Deflated Explicit VR Little Endian (1.2.840.10008.1.2.1.99)
static (Shared in Visual Basic) | ExplicitVRBigEndian | Explicit VR Big Endian (1.2.840.10008.1.2.2)
static (Shared in Visual Basic) | ExplicitVRLittleEndian | Explicit VR Little Endian (1.2.840.10008.1.2.1)
static (Shared in Visual Basic) | ImplicitVRLittleEndian | Implicit VR Little Endian (1.2.840.10008.1.2)
static (Shared in Visual Basic) | JPEG2000Lossless | JPEG 2000 Image Compression (Lossless Only) (1.2.840.10008.1.2.4.90)
static (Shared in Visual Basic) | JPEG2000Lossy | JPEG 2000 Image Compression (1.2.840.10008.1.2.4.91)
static (Shared in Visual Basic) | JPEG2000Part2MulticomponentImageCompression | JPEG 2000 Part 2 Multi-component Image Compression (1.2.840.10008.1.2.4.93)
static (Shared in Visual Basic) | JPEG2000Part2MulticomponentImageCompressionLosslessOnly | JPEG 2000 Part 2 Multi-component Image Compression (Lossless Only) (1.2.840.10008.1.2.4.92)
static (Shared in Visual Basic) | JPEGBaseline | JPEG Baseline (Process 1) (1.2.840.10008.1.2.4.50)
static (Shared in Visual Basic) | JPEGExtended | JPEG Extended (Process 2 & 4) (1.2.840.10008.1.2.4.51)
static (Shared in Visual Basic) | JPEGExtendedHierarchicalProcess16and18 | JPEG Extended, Hierarchical (Process 16 & 18) (Retired) (1.2.840.10008.1.2.4.59)
static (Shared in Visual Basic) | JPEGExtendedHierarchicalProcess17and19 | JPEG Extended, Hierarchical (Process 17 & 19) (Retired) (1.2.840.10008.1.2.4.60)
static (Shared in Visual Basic) | JPEGExtendedProcess3and5 | JPEG Extended (Process 3 & 5) (Retired) (1.2.840.10008.1.2.4.52)
static (Shared in Visual Basic) | JPEGFullProgressionHierarchicalProcess24and26 | JPEG Full Progression, Hierarchical (Process 24 & 26) (Retired) (1.2.840.10008.1.2.4.63)
static (Shared in Visual Basic) | JPEGFullProgressionHierarchicalProcess25and27 | JPEG Full Progression, Hierarchical (Process 25 & 27) (Retired) (1.2.840.10008.1.2.4.64)
static (Shared in Visual Basic) | JPEGFullProgressionNonHierarchicalProcess10and12 | JPEG Full Progression, Non-Hierarchical (Process 10 & 12) (Retired) (1.2.840.10008.1.2.4.55)
static (Shared in Visual Basic) | JPEGFullProgressionNonHierarchicalProcess11and13 | JPEG Full Progression, Non-Hierarchical (Process 11 & 13) (Retired) (1.2.840.10008.1.2.4.56)
static (Shared in Visual Basic) | JPEGLossless | JPEG Lossless, Non-Hierarchical (Process 14) (1.2.840.10008.1.2.4.57)
static (Shared in Visual Basic) | JPEGLosslessFirstOrder | JPEG Lossless, Non-Hierarchical, First-Order Prediction (Process 14 [Selection Value 1]) (1.2.840.10008.1.2.4.70)
static (Shared in Visual Basic) | JPEGLosslessHierarchicalProcess28 | JPEG Lossless, Hierarchical (Process 28) (Retired) (1.2.840.10008.1.2.4.65)
static (Shared in Visual Basic) | JPEGLosslessHierarchicalProcess29 | JPEG Lossless, Hierarchical (Process 29) (Retired) (1.2.840.10008.1.2.4.66)
static (Shared in Visual Basic) | JPEGLosslessNonHierarchicalProcess15 | JPEG Lossless, Non-Hierarchical (Process 15) (Retired) (1.2.840.10008.1.2.4.58)
static (Shared in Visual Basic) | JPEGLSLossless | JPEG-LS Lossless Image Compression (1.2.840.10008.1.2.4.80)
static (Shared in Visual Basic) | JPEGLSLossy | JPEG-LS Lossy (Near-Lossless) Image Compression (1.2.840.10008.1.2.4.81)
static (Shared in Visual Basic) | JPEGSpectralSelectionHierarchicalProcess20and22 | JPEG Spectral Selection, Hierarchical (Process 20 & 22) (Retired) (1.2.840.10008.1.2.4.61)
static (Shared in Visual Basic) | JPEGSpectralSelectionHierarchicalProcess21and23 | JPEG Spectral Selection, Hierarchical (Process 21 & 23) (Retired) (1.2.840.10008.1.2.4.62)
static (Shared in Visual Basic) | JPEGSpectralSelectionNonHierarchicalProcess6and8 | JPEG Spectral Selection, Non-Hierarchical (Process 6 & 8) (Retired) (1.2.840.10008.1.2.4.53)
static (Shared in Visual Basic) | JPEGSpectralSelectionNonHierarchicalProcess7and9 | JPEG Spectral Selection, Non-Hierarchical (Process 7 & 9) (Retired) (1.2.840.10008.1.2.4.54)
static (Shared in Visual Basic) | JPIPReferenced | JPIP Referenced (1.2.840.10008.1.2.4.94)
static (Shared in Visual Basic) | JPIPReferencedDeflate | JPIP Referenced Deflate (1.2.840.10008.1.2.4.95)
static (Shared in Visual Basic) | MPEG2 | MPEG2 Main Profile @ Main Level (1.2.840.10008.1.2.4.100)
static (Shared in Visual Basic) | MPEG2_HL | MPEG2 Main Profile @ High Level (1.2.840.10008.1.2.4.101)
static (Shared in Visual Basic) | MPEG4 | MPEG-4 AVC/H.264 High Profile / Level 4.1 (1.2.840.10008.1.2.4.102)
static (Shared in Visual Basic) | MPEG4_BD | MPEG-4 AVC/H.264 BD-compatible High Profile / Level 4.1 (1.2.840.10008.1.2.4.103)
static (Shared in Visual Basic) | RFC2557MIMEencapsulation | RFC 2557 MIME encapsulation (1.2.840.10008.1.2.6.1)
static (Shared in Visual Basic) | RLELossless | RLE Lossless (1.2.840.10008.1.2.5)
static (Shared in Visual Basic) | XMLEncoding | XML Encoding (1.2.840.10008.1.2.6.2)
    Top
    See Also

    Reference

    TransferSyntaxes Class
    DicomObjects.UIDs Namespace


DicomObjects.UIDs Namespace / TransferSyntaxes Class / DeflatedExplicitVRLittleEndian Field

    DeflatedExplicitVRLittleEndian Field
    Deflated Explicit VR Little Endian (1.2.840.10008.1.2.1.99)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly DeflatedExplicitVRLittleEndian As UID
    'Usage

    Dim value As UID

value = TransferSyntaxes.DeflatedExplicitVRLittleEndian
    public static readonly UID DeflatedExplicitVRLittleEndian
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    TransferSyntaxes Class
    TransferSyntaxes Members


DicomObjects.UIDs Namespace / TransferSyntaxes Class / ExplicitVRBigEndian Field

    ExplicitVRBigEndian Field
    Explicit VR Big Endian (1.2.840.10008.1.2.2)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly ExplicitVRBigEndian As UID
    'Usage

    Dim value As UID

value = TransferSyntaxes.ExplicitVRBigEndian
    public static readonly UID ExplicitVRBigEndian
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    TransferSyntaxes Class
    TransferSyntaxes Members


DicomObjects.UIDs Namespace / TransferSyntaxes Class / ExplicitVRLittleEndian Field

    ExplicitVRLittleEndian Field
    Explicit VR Little Endian (1.2.840.10008.1.2.1)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly ExplicitVRLittleEndian As UID
    'Usage

    Dim value As UID

value = TransferSyntaxes.ExplicitVRLittleEndian
    public static readonly UID ExplicitVRLittleEndian
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    TransferSyntaxes Class
    TransferSyntaxes Members


DicomObjects.UIDs Namespace / TransferSyntaxes Class / ImplicitVRLittleEndian Field

    ImplicitVRLittleEndian Field
    Implicit VR Little Endian (1.2.840.10008.1.2)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly ImplicitVRLittleEndian As UID
    'Usage

    Dim value As UID

value = TransferSyntaxes.ImplicitVRLittleEndian
    public static readonly UID ImplicitVRLittleEndian
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    TransferSyntaxes Class
    TransferSyntaxes Members


DicomObjects.UIDs Namespace / TransferSyntaxes Class / JPEG2000Lossless Field

    JPEG2000Lossless Field
    JPEG 2000 Image Compression (Lossless Only) (1.2.840.10008.1.2.4.90)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly JPEG2000Lossless As UID
    'Usage

    Dim value As UID

value = TransferSyntaxes.JPEG2000Lossless
    public static readonly UID JPEG2000Lossless
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    TransferSyntaxes Class
    TransferSyntaxes Members


DicomObjects.UIDs Namespace / TransferSyntaxes Class / JPEG2000Lossy Field

    JPEG2000Lossy Field
    JPEG 2000 Image Compression (1.2.840.10008.1.2.4.91)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly JPEG2000Lossy As UID
    'Usage

    Dim value As UID

value = TransferSyntaxes.JPEG2000Lossy
    public static readonly UID JPEG2000Lossy
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    TransferSyntaxes Class
    TransferSyntaxes Members


DicomObjects.UIDs Namespace / TransferSyntaxes Class / JPEG2000Part2MulticomponentImageCompression Field

    JPEG2000Part2MulticomponentImageCompression Field
    JPEG 2000 Part 2 Multi-component Image Compression (1.2.840.10008.1.2.4.93)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly JPEG2000Part2MulticomponentImageCompression As UID
    'Usage

    Dim value As UID

value = TransferSyntaxes.JPEG2000Part2MulticomponentImageCompression
    public static readonly UID JPEG2000Part2MulticomponentImageCompression
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    TransferSyntaxes Class
    TransferSyntaxes Members


DicomObjects.UIDs Namespace / TransferSyntaxes Class / JPEG2000Part2MulticomponentImageCompressionLosslessOnly Field

    JPEG2000Part2MulticomponentImageCompressionLosslessOnly Field
    In This Topic
    JPEG 2000 Part 2 Multi-component Image Compression (Lossless Only) (1.2.840.10008.1.2.4.92)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly JPEG2000Part2MulticomponentImageCompressionLosslessOnly As UID
    'Usage

    Dim value As UID

value = TransferSyntaxes.JPEG2000Part2MulticomponentImageCompressionLosslessOnly
    public static readonly UID JPEG2000Part2MulticomponentImageCompressionLosslessOnly
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    TransferSyntaxes Class
    TransferSyntaxes Members


DicomObjects.UIDs Namespace / TransferSyntaxes Class / JPEGBaseline Field

    JPEGBaseline Field
    JPEG Baseline (Process 1) (1.2.840.10008.1.2.4.50)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly JPEGBaseline As UID
    'Usage

    Dim value As UID

value = TransferSyntaxes.JPEGBaseline
    public static readonly UID JPEGBaseline
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    TransferSyntaxes Class
    TransferSyntaxes Members


DicomObjects.UIDs Namespace / TransferSyntaxes Class / JPEGExtended Field

    JPEGExtended Field
    JPEG Extended (Process 2 & 4) (1.2.840.10008.1.2.4.51)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly JPEGExtended As UID
    'Usage

    Dim value As UID

value = TransferSyntaxes.JPEGExtended
    public static readonly UID JPEGExtended
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    TransferSyntaxes Class
    TransferSyntaxes Members


DicomObjects.UIDs Namespace / TransferSyntaxes Class / JPEGExtendedHierarchicalProcess16and18 Field

    JPEGExtendedHierarchicalProcess16and18 Field
    JPEG Extended, Hierarchical (Process 16 & 18) (Retired) (1.2.840.10008.1.2.4.59)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    <ObsoleteAttribute("Retired UID - should not be used in new implementions")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Shared ReadOnly JPEGExtendedHierarchicalProcess16and18 As UID
    'Usage

    Dim value As UID

value = TransferSyntaxes.JPEGExtendedHierarchicalProcess16and18
    [Obsolete("Retired UID - should not be used in new implementions")]
[EditorBrowsable(EditorBrowsableState.Advanced)]
public static readonly UID JPEGExtendedHierarchicalProcess16and18
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    TransferSyntaxes Class
    TransferSyntaxes Members


DicomObjects.UIDs Namespace / TransferSyntaxes Class / JPEGExtendedHierarchicalProcess17and19 Field

    JPEGExtendedHierarchicalProcess17and19 Field
    JPEG Extended, Hierarchical (Process 17 & 19) (Retired) (1.2.840.10008.1.2.4.60)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    <ObsoleteAttribute("Retired UID - should not be used in new implementions")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Shared ReadOnly JPEGExtendedHierarchicalProcess17and19 As UID
    'Usage

    Dim value As UID

value = TransferSyntaxes.JPEGExtendedHierarchicalProcess17and19
    [Obsolete("Retired UID - should not be used in new implementions")]
[EditorBrowsable(EditorBrowsableState.Advanced)]
public static readonly UID JPEGExtendedHierarchicalProcess17and19
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    TransferSyntaxes Class
    TransferSyntaxes Members


DicomObjects.UIDs Namespace / TransferSyntaxes Class / JPEGExtendedProcess3and5 Field

    JPEGExtendedProcess3and5 Field
    JPEG Extended (Process 3 & 5) (Retired) (1.2.840.10008.1.2.4.52)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    <ObsoleteAttribute("Retired UID - should not be used in new implementions")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Shared ReadOnly JPEGExtendedProcess3and5 As UID
    'Usage

    Dim value As UID

value = TransferSyntaxes.JPEGExtendedProcess3and5
    [Obsolete("Retired UID - should not be used in new implementions")]
[EditorBrowsable(EditorBrowsableState.Advanced)]
public static readonly UID JPEGExtendedProcess3and5
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    TransferSyntaxes Class
    TransferSyntaxes Members


DicomObjects.UIDs Namespace / TransferSyntaxes Class / JPEGFullProgressionHierarchicalProcess24and26 Field

    JPEGFullProgressionHierarchicalProcess24and26 Field
    JPEG Full Progression, Hierarchical (Process 24 & 26) (Retired) (1.2.840.10008.1.2.4.63)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    <ObsoleteAttribute("Retired UID - should not be used in new implementions")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Shared ReadOnly JPEGFullProgressionHierarchicalProcess24and26 As UID
    'Usage

    Dim value As UID

value = TransferSyntaxes.JPEGFullProgressionHierarchicalProcess24and26
    [Obsolete("Retired UID - should not be used in new implementions")]
[EditorBrowsable(EditorBrowsableState.Advanced)]
public static readonly UID JPEGFullProgressionHierarchicalProcess24and26
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    TransferSyntaxes Class
    TransferSyntaxes Members


DicomObjects.UIDs Namespace / TransferSyntaxes Class / JPEGFullProgressionHierarchicalProcess25and27 Field

    JPEGFullProgressionHierarchicalProcess25and27 Field
    JPEG Full Progression, Hierarchical (Process 25 & 27) (Retired) (1.2.840.10008.1.2.4.64)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    <ObsoleteAttribute("Retired UID - should not be used in new implementions")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Shared ReadOnly JPEGFullProgressionHierarchicalProcess25and27 As UID
    'Usage

    Dim value As UID

value = TransferSyntaxes.JPEGFullProgressionHierarchicalProcess25and27
    [Obsolete("Retired UID - should not be used in new implementions")]
[EditorBrowsable(EditorBrowsableState.Advanced)]
public static readonly UID JPEGFullProgressionHierarchicalProcess25and27
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    TransferSyntaxes Class
    TransferSyntaxes Members


DicomObjects.UIDs Namespace / TransferSyntaxes Class / JPEGFullProgressionNonHierarchicalProcess10and12 Field

    JPEGFullProgressionNonHierarchicalProcess10and12 Field
    JPEG Full Progression, Non-Hierarchical (Process 10 & 12) (Retired) (1.2.840.10008.1.2.4.55)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    <ObsoleteAttribute("Retired UID - should not be used in new implementions")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Shared ReadOnly JPEGFullProgressionNonHierarchicalProcess10and12 As UID
    'Usage

    Dim value As UID

value = TransferSyntaxes.JPEGFullProgressionNonHierarchicalProcess10and12
    [Obsolete("Retired UID - should not be used in new implementions")]
[EditorBrowsable(EditorBrowsableState.Advanced)]
public static readonly UID JPEGFullProgressionNonHierarchicalProcess10and12
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    TransferSyntaxes Class
    TransferSyntaxes Members


DicomObjects.UIDs Namespace / TransferSyntaxes Class / JPEGFullProgressionNonHierarchicalProcess11and13 Field

    JPEGFullProgressionNonHierarchicalProcess11and13 Field
    JPEG Full Progression, Non-Hierarchical (Process 11 & 13) (Retired) (1.2.840.10008.1.2.4.56)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    <ObsoleteAttribute("Retired UID - should not be used in new implementions")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Shared ReadOnly JPEGFullProgressionNonHierarchicalProcess11and13 As UID
    'Usage

    Dim value As UID

value = TransferSyntaxes.JPEGFullProgressionNonHierarchicalProcess11and13
    [Obsolete("Retired UID - should not be used in new implementions")]
[EditorBrowsable(EditorBrowsableState.Advanced)]
public static readonly UID JPEGFullProgressionNonHierarchicalProcess11and13
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    TransferSyntaxes Class
    TransferSyntaxes Members


DicomObjects.UIDs Namespace / TransferSyntaxes Class / JPEGLossless Field

    JPEGLossless Field
    JPEG Lossless, Non-Hierarchical (Process 14) (1.2.840.10008.1.2.4.57)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly JPEGLossless As UID
    'Usage

    Dim value As UID

value = TransferSyntaxes.JPEGLossless
    public static readonly UID JPEGLossless
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    TransferSyntaxes Class
    TransferSyntaxes Members


DicomObjects.UIDs Namespace / TransferSyntaxes Class / JPEGLosslessFirstOrder Field

    JPEGLosslessFirstOrder Field
    JPEG Lossless, Non-Hierarchical, First-Order Prediction (Process 14 [Selection Value 1]) (1.2.840.10008.1.2.4.70)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly JPEGLosslessFirstOrder As UID
    'Usage

    Dim value As UID

value = TransferSyntaxes.JPEGLosslessFirstOrder
    public static readonly UID JPEGLosslessFirstOrder
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    TransferSyntaxes Class
    TransferSyntaxes Members


DicomObjects.UIDs Namespace / TransferSyntaxes Class / JPEGLosslessHierarchicalProcess28 Field

    JPEGLosslessHierarchicalProcess28 Field
    JPEG Lossless, Hierarchical (Process 28) (Retired) (1.2.840.10008.1.2.4.65)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    <ObsoleteAttribute("Retired UID - should not be used in new implementions")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Shared ReadOnly JPEGLosslessHierarchicalProcess28 As UID
    'Usage

    Dim value As UID

value = TransferSyntaxes.JPEGLosslessHierarchicalProcess28
    [Obsolete("Retired UID - should not be used in new implementions")]
[EditorBrowsable(EditorBrowsableState.Advanced)]
public static readonly UID JPEGLosslessHierarchicalProcess28
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    TransferSyntaxes Class
    TransferSyntaxes Members


DicomObjects.UIDs Namespace / TransferSyntaxes Class / JPEGLosslessHierarchicalProcess29 Field

    JPEGLosslessHierarchicalProcess29 Field
    JPEG Lossless, Hierarchical (Process 29) (Retired) (1.2.840.10008.1.2.4.66)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    <ObsoleteAttribute("Retired UID - should not be used in new implementions")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Shared ReadOnly JPEGLosslessHierarchicalProcess29 As UID
    'Usage

    Dim value As UID

value = TransferSyntaxes.JPEGLosslessHierarchicalProcess29
    [Obsolete("Retired UID - should not be used in new implementions")]
[EditorBrowsable(EditorBrowsableState.Advanced)]
public static readonly UID JPEGLosslessHierarchicalProcess29
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    TransferSyntaxes Class
    TransferSyntaxes Members


DicomObjects.UIDs Namespace / TransferSyntaxes Class / JPEGLosslessNonHierarchicalProcess15 Field

    JPEGLosslessNonHierarchicalProcess15 Field
    JPEG Lossless, Non-Hierarchical (Process 15) (Retired) (1.2.840.10008.1.2.4.58)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    <ObsoleteAttribute("Retired UID - should not be used in new implementions")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Shared ReadOnly JPEGLosslessNonHierarchicalProcess15 As UID
    'Usage

    Dim value As UID

value = TransferSyntaxes.JPEGLosslessNonHierarchicalProcess15
    [Obsolete("Retired UID - should not be used in new implementions")]
[EditorBrowsable(EditorBrowsableState.Advanced)]
public static readonly UID JPEGLosslessNonHierarchicalProcess15
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    TransferSyntaxes Class
    TransferSyntaxes Members


DicomObjects.UIDs Namespace / TransferSyntaxes Class / JPEGLSLossless Field

    JPEGLSLossless Field
    JPEG-LS Lossless Image Compression (1.2.840.10008.1.2.4.80)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly JPEGLSLossless As UID
    'Usage

    Dim value As UID

value = TransferSyntaxes.JPEGLSLossless
    public static readonly UID JPEGLSLossless
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    TransferSyntaxes Class
    TransferSyntaxes Members


DicomObjects.UIDs Namespace / TransferSyntaxes Class / JPEGLSLossy Field

    JPEGLSLossy Field
    JPEG-LS Lossy (Near-Lossless) Image Compression (1.2.840.10008.1.2.4.81)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly JPEGLSLossy As UID
    'Usage

    Dim value As UID

value = TransferSyntaxes.JPEGLSLossy
    public static readonly UID JPEGLSLossy
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    TransferSyntaxes Class
    TransferSyntaxes Members


DicomObjects.UIDs Namespace / TransferSyntaxes Class / JPEGSpectralSelectionHierarchicalProcess20and22 Field

    JPEGSpectralSelectionHierarchicalProcess20and22 Field
    JPEG Spectral Selection, Hierarchical (Process 20 & 22) (Retired) (1.2.840.10008.1.2.4.61)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    <ObsoleteAttribute("Retired UID - should not be used in new implementions")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Shared ReadOnly JPEGSpectralSelectionHierarchicalProcess20and22 As UID
    'Usage

    Dim value As UID

value = TransferSyntaxes.JPEGSpectralSelectionHierarchicalProcess20and22
    [Obsolete("Retired UID - should not be used in new implementions")]
[EditorBrowsable(EditorBrowsableState.Advanced)]
public static readonly UID JPEGSpectralSelectionHierarchicalProcess20and22
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    TransferSyntaxes Class
    TransferSyntaxes Members


DicomObjects.UIDs Namespace / TransferSyntaxes Class / JPEGSpectralSelectionHierarchicalProcess21and23 Field

    JPEGSpectralSelectionHierarchicalProcess21and23 Field
    JPEG Spectral Selection, Hierarchical (Process 21 & 23) (Retired) (1.2.840.10008.1.2.4.62)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    <ObsoleteAttribute("Retired UID - should not be used in new implementions")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Shared ReadOnly JPEGSpectralSelectionHierarchicalProcess21and23 As UID
    'Usage

    Dim value As UID

value = TransferSyntaxes.JPEGSpectralSelectionHierarchicalProcess21and23
    [Obsolete("Retired UID - should not be used in new implementions")]
[EditorBrowsable(EditorBrowsableState.Advanced)]
public static readonly UID JPEGSpectralSelectionHierarchicalProcess21and23
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    TransferSyntaxes Class
    TransferSyntaxes Members


DicomObjects.UIDs Namespace / TransferSyntaxes Class / JPEGSpectralSelectionNonHierarchicalProcess6and8 Field

    JPEGSpectralSelectionNonHierarchicalProcess6and8 Field
    JPEG Spectral Selection, Non-Hierarchical (Process 6 & 8) (Retired) (1.2.840.10008.1.2.4.53)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    <ObsoleteAttribute("Retired UID - should not be used in new implementions")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Shared ReadOnly JPEGSpectralSelectionNonHierarchicalProcess6and8 As UID
    'Usage

    Dim value As UID

value = TransferSyntaxes.JPEGSpectralSelectionNonHierarchicalProcess6and8
    [Obsolete("Retired UID - should not be used in new implementions")]
[EditorBrowsable(EditorBrowsableState.Advanced)]
public static readonly UID JPEGSpectralSelectionNonHierarchicalProcess6and8
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    TransferSyntaxes Class
    TransferSyntaxes Members


DicomObjects.UIDs Namespace / TransferSyntaxes Class / JPEGSpectralSelectionNonHierarchicalProcess7and9 Field

    JPEGSpectralSelectionNonHierarchicalProcess7and9 Field
    JPEG Spectral Selection, Non-Hierarchical (Process 7 & 9) (Retired) (1.2.840.10008.1.2.4.54)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    <ObsoleteAttribute("Retired UID - should not be used in new implementions")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Shared ReadOnly JPEGSpectralSelectionNonHierarchicalProcess7and9 As UID
    'Usage

    Dim value As UID

value = TransferSyntaxes.JPEGSpectralSelectionNonHierarchicalProcess7and9
    [Obsolete("Retired UID - should not be used in new implementions")]
[EditorBrowsable(EditorBrowsableState.Advanced)]
public static readonly UID JPEGSpectralSelectionNonHierarchicalProcess7and9
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    TransferSyntaxes Class
    TransferSyntaxes Members


DicomObjects.UIDs Namespace / TransferSyntaxes Class / JPIPReferenced Field

    JPIPReferenced Field
    JPIP Referenced (1.2.840.10008.1.2.4.94)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly JPIPReferenced As UID
    'Usage

    Dim value As UID

value = TransferSyntaxes.JPIPReferenced
    public static readonly UID JPIPReferenced
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    TransferSyntaxes Class
    TransferSyntaxes Members


DicomObjects.UIDs Namespace / TransferSyntaxes Class / JPIPReferencedDeflate Field

    JPIPReferencedDeflate Field
    JPIP Referenced Deflate (1.2.840.10008.1.2.4.95)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly JPIPReferencedDeflate As UID
    'Usage

    Dim value As UID

value = TransferSyntaxes.JPIPReferencedDeflate
    public static readonly UID JPIPReferencedDeflate
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    TransferSyntaxes Class
    TransferSyntaxes Members


DicomObjects.UIDs Namespace / TransferSyntaxes Class / MPEG2 Field

    MPEG2 Field
    MPEG2 Main Profile @ Main Level (1.2.840.10008.1.2.4.100)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly MPEG2 As UID
    'Usage

    Dim value As UID

value = TransferSyntaxes.MPEG2
    public static readonly UID MPEG2
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    TransferSyntaxes Class
    TransferSyntaxes Members


DicomObjects.UIDs Namespace / TransferSyntaxes Class / MPEG2_HL Field

    MPEG2_HL Field
    MPEG2 Main Profile @ High Level (1.2.840.10008.1.2.4.101)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly MPEG2_HL As UID
    'Usage

    Dim value As UID

value = TransferSyntaxes.MPEG2_HL
    public static readonly UID MPEG2_HL
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    TransferSyntaxes Class
    TransferSyntaxes Members


DicomObjects.UIDs Namespace / TransferSyntaxes Class / MPEG4 Field

    MPEG4 Field
    MPEG-4 AVC/H.264 High Profile / Level 4.1 (1.2.840.10008.1.2.4.102)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly MPEG4 As UID
    'Usage

    Dim value As UID

value = TransferSyntaxes.MPEG4
    public static readonly UID MPEG4
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    TransferSyntaxes Class
    TransferSyntaxes Members


DicomObjects.UIDs Namespace / TransferSyntaxes Class / MPEG4_BD Field

    MPEG4_BD Field
    MPEG-4 AVC/H.264 BD-compatible High Profile / Level 4.1 (1.2.840.10008.1.2.4.103)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly MPEG4_BD As UID
    'Usage

    Dim value As UID

value = TransferSyntaxes.MPEG4_BD
    public static readonly UID MPEG4_BD
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    TransferSyntaxes Class
    TransferSyntaxes Members


DicomObjects.UIDs Namespace / TransferSyntaxes Class / RFC2557MIMEencapsulation Field

    RFC2557MIMEencapsulation Field
    RFC 2557 MIME encapsulation (1.2.840.10008.1.2.6.1)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly RFC2557MIMEencapsulation As UID
    'Usage

    Dim value As UID

value = TransferSyntaxes.RFC2557MIMEencapsulation
    public static readonly UID RFC2557MIMEencapsulation
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    TransferSyntaxes Class
    TransferSyntaxes Members


DicomObjects.UIDs Namespace / TransferSyntaxes Class / RLELossless Field

    RLELossless Field
    RLE Lossless (1.2.840.10008.1.2.5)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly RLELossless As UID
    'Usage

    Dim value As UID

value = TransferSyntaxes.RLELossless
    public static readonly UID RLELossless
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    TransferSyntaxes Class
    TransferSyntaxes Members


DicomObjects.UIDs Namespace / TransferSyntaxes Class / XMLEncoding Field

    XMLEncoding Field
    XML Encoding (1.2.840.10008.1.2.6.2)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly XMLEncoding As UID
    'Usage

    Dim value As UID

value = TransferSyntaxes.XMLEncoding
    public static readonly UID XMLEncoding
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    TransferSyntaxes Class
    TransferSyntaxes Members


%%PageItemTitle%%

DicomObjects.UIDs Namespace / UID Class
Members

In This Topic
    UID Class
    In This Topic
    A class to represent the constant UIDs present as readonly fields in the objects within the DicomObjects.UIDs namespace.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Class UID
    'Usage

    Dim instance As UID
    public class UID
    Inheritance Hierarchy

    System.Object
    DicomObjects.UIDs.UID

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    UID Members
    DicomObjects.UIDs Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.UIDs Namespace / UID Class
Properties Methods

In This Topic
    UID Class Members
    In This Topic

    The following tables list the members exposed by UID.

    Public Properties
     | Name | Description
Public Property | Description | Description of the attribute, as defined in DICOM Part 6
Public Property | Name | The Name of the UID
Public Property | Retired | True if the attribute is official retired
Public Property | Type | The "type" of the UID
Public Property | Value | The dotted form UID string
    Top
    Public Methods
     | Name | Description
static (Shared in Visual Basic) | Parse | Standard parsing routine, which returns a reference to the existing UID object (from any of the classes in DicomObjects.UIDs corresponding to the value passed.
Public Method | ToString | Returns a string that represents the current object.
    Top
    Public Operators
    public Operator Implicit Type Conversion Overloaded. Create a UID from a string
    Top
    See Also

    Reference

    UID Class
    DicomObjects.UIDs Namespace


%%PageItemTitle%% $$Methods$$

DicomObjects.UIDs Namespace / UID Class

    UID Class Methods
    In This Topic

    For a list of all members of this type, see UID members.

    Public Methods
     | Name | Description
static (Shared in Visual Basic) | Parse | Standard parsing routine, which returns a reference to the existing UID object (from any of the classes in DicomObjects.UIDs corresponding to the value passed.
Public Method | ToString | Returns a string that represents the current object.
    Top
    See Also

    Reference

    UID Class
    DicomObjects.UIDs Namespace


DicomObjects.UIDs Namespace / UID Class / Parse Method
The String to be parsed - this may be either in name form e.g. "EnhancedCT" or numberic - e.g. "1.2.840.10008.5.1.4.1.1.2.1"
An out parameter which returns the "name" of the returned UID object. If Value is a name, then this will be set to the same string, so its main use is when Value is in numeric form.

In This Topic
    Parse Method
    In This Topic
    Standard parsing routine, which returns a reference to the existing UID object (from any of the classes in DicomObjects.UIDs corresponding to the value passed.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared Function Parse( _
   ByVal Value As String, _
   ByRef Name As String _
) As UID
    'Usage

    Dim Value As String
Dim Name As String
Dim value As UID

value = UID.Parse(Value, Name)
    public static UID Parse(
   string Value,
   out string Name
)

    Parameters

    Value
    The String to be parsed - this may be either in name form e.g. "EnhancedCT" or numberic - e.g. "1.2.840.10008.5.1.4.1.1.2.1"
    Name
    An out parameter which returns the "name" of the returned UID object. If Value is a name, then this will be set to the same string, so its main use is when Value is in numeric form.

    Return Value

    the matching UID value or null if there is no match
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    UID Class
    UID Members


DicomObjects.UIDs Namespace / UID Class / ToString Method

    ToString Method (UID)
    In This Topic
    Returns a string that represents the current object.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overrides Function ToString() As String
    'Usage

    Dim instance As UID
Dim value As String

value = instance.ToString()
    public override string ToString()

    Return Value

    A string that represents the current object.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    UID Class
    UID Members


%%PageItemTitle%% $$Properties$$

DicomObjects.UIDs Namespace / UID Class

    UID Class Properties
    In This Topic

    For a list of all members of this type, see UID members.

    Public Properties
     | Name | Description
Public Property | Description | Description of the attribute, as defined in DICOM Part 6
Public Property | Name | The Name of the UID
Public Property | Retired | True if the attribute is official retired
Public Property | Type | The "type" of the UID
Public Property | Value | The dotted form UID string
    Top
    See Also

    Reference

    UID Class
    DicomObjects.UIDs Namespace


DicomObjects.UIDs Namespace / UID Class / Description Property

    Description Property (UID)
    In This Topic
    Description of the attribute, as defined in DICOM Part 6
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property Description As String
    'Usage

    Dim instance As UID
Dim value As String

value = instance.Description
    public string Description {get;}
    Remarks
    This should not be confused with the Keyword enumeration, which is a single word with no spaces and used in code in place of Group and Element
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    UID Class
    UID Members


DicomObjects.UIDs Namespace / UID Class / Name Property

    Name Property (UID)
    In This Topic
    The Name of the UID
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property Name As String
    'Usage

    Dim instance As UID
Dim value As String

value = instance.Name
    public string Name {get;}
    Remarks
    This name is the name of the field within one of the classes in the DicomObjects.UIDs namespace which holds this UID object
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    UID Class
    UID Members


DicomObjects.UIDs Namespace / UID Class / Retired Property

    Retired Property
    True if the attribute is official retired
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property Retired As Boolean
    'Usage

    Dim instance As UID
Dim value As Boolean

value = instance.Retired
    public bool Retired {get;}
    Remarks
    Retired attributes may legally be used in DICOM, but their use is discouraged in new implementations
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    UID Class
    UID Members


DicomObjects.UIDs Namespace / UID Class / Type Property

    Type Property (UID)
    In This Topic
    The "type" of the UID
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property Type As UIDType
    'Usage

    Dim instance As UID
Dim value As UIDType

value = instance.Type
    public UIDType Type {get;}
    Remarks
    See DicomObjects.Enums.UIDType for the list of types
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    UID Class
    UID Members


DicomObjects.UIDs Namespace / UID Class / Value Property

    Value Property (UID)
    In This Topic
    The dotted form UID string
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property Value As String
    'Usage

    Dim instance As UID
Dim value As String

value = instance.Value
    public string Value {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    UID Class
    UID Members


DicomObjects.UIDs Namespace / UID Class / Implicit Type Conversion Operator

    Implicit Type Conversion Operator (UID)
    In This Topic
    Create a UID from a string
    Overload List
    Overload | Description
Implicit Type Conversion(UID,String) | Create a UID from a string
Implicit Type Conversion(String,UID) | An implicit conversion to a string, returning the same string as Value
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    UID Class
    UID Members


%%PageItemTitle%%

DicomObjects.UIDs Namespace / WellKnownInstances Class
Members

In This Topic
    WellKnownInstances Class
    In This Topic
    Contains UIDs for Well Known Instance
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public MustInherit NotInheritable Class WellKnownInstances
    'Usage

    Dim instance As WellKnownInstances
    public static class WellKnownInstances
    Inheritance Hierarchy

    System.Object
    DicomObjects.UIDs.WellKnownInstances

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WellKnownInstances Members
    DicomObjects.UIDs Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.UIDs Namespace / WellKnownInstances Class
Fields

In This Topic
    WellKnownInstances Class Members
    In This Topic

    The following tables list the members exposed by WellKnownInstances.

    Public Fields
     | Name | Description
static (Shared in Visual Basic) | HotIronColorPaletteSOPInstance | Hot Iron SKColor Palette SOP Instance (1.2.840.10008.1.5.1)
static (Shared in Visual Basic) | HotMetalBlueColorPaletteSOPInstance | Hot Metal Blue SKColor Palette SOP Instance (1.2.840.10008.1.5.3)
static (Shared in Visual Basic) | PET20StepColorPaletteSOPInstance | PET 20 Step SKColor Palette SOP Instance (1.2.840.10008.1.5.4)
static (Shared in Visual Basic) | PETColorPaletteSOPInstance | PET SKColor Palette SOP Instance (1.2.840.10008.1.5.2)
static (Shared in Visual Basic) | Printer | Printer SOP Instance (1.2.840.10008.5.1.1.17)
static (Shared in Visual Basic) | PrinterConfigurationRetrieval | Printer Configuration Retrieval SOP Instance (1.2.840.10008.5.1.1.17.376)
static (Shared in Visual Basic) | PrintQueue | Print Queue SOP Instance (Retired) (1.2.840.10008.5.1.1.25)
static (Shared in Visual Basic) | ProceduralEventLoggingSOPInstance | Procedural Event Logging SOP Instance (1.2.840.10008.1.40.1)
static (Shared in Visual Basic) | StorageCommitmentPull | Storage Commitment Pull Model SOP Instance (Retired) (1.2.840.10008.1.20.2.1)
static (Shared in Visual Basic) | StorageCommitmentPush | Storage Commitment Push Model SOP Instance (1.2.840.10008.1.20.1.1)
static (Shared in Visual Basic) | SubstanceAdministrationLoggingSOPInstance | Substance Administration Logging SOP Instance (1.2.840.10008.1.42.1)
static (Shared in Visual Basic) | UPSFilteredGlobalSubscriptionInstance | UPS Filtered Global Subscription SOP Instance (1.2.840.10008.5.1.4.34.5.1)
static (Shared in Visual Basic) | UPSGlobalSubscriptionInstance | UPS Global Subscription SOP Instance (1.2.840.10008.5.1.4.34.5)
    Top
    See Also

    Reference

    WellKnownInstances Class
    DicomObjects.UIDs Namespace


%%PageItemTitle%% $$Fields$$

DicomObjects.UIDs Namespace / WellKnownInstances Class

    WellKnownInstances Class Fields
    In This Topic

    For a list of all members of this type, see WellKnownInstances members.

    Public Fields
     | Name | Description
static (Shared in Visual Basic) | HotIronColorPaletteSOPInstance | Hot Iron SKColor Palette SOP Instance (1.2.840.10008.1.5.1)
static (Shared in Visual Basic) | HotMetalBlueColorPaletteSOPInstance | Hot Metal Blue SKColor Palette SOP Instance (1.2.840.10008.1.5.3)
static (Shared in Visual Basic) | PET20StepColorPaletteSOPInstance | PET 20 Step SKColor Palette SOP Instance (1.2.840.10008.1.5.4)
static (Shared in Visual Basic) | PETColorPaletteSOPInstance | PET SKColor Palette SOP Instance (1.2.840.10008.1.5.2)
static (Shared in Visual Basic) | Printer | Printer SOP Instance (1.2.840.10008.5.1.1.17)
static (Shared in Visual Basic) | PrinterConfigurationRetrieval | Printer Configuration Retrieval SOP Instance (1.2.840.10008.5.1.1.17.376)
static (Shared in Visual Basic) | PrintQueue | Print Queue SOP Instance (Retired) (1.2.840.10008.5.1.1.25)
static (Shared in Visual Basic) | ProceduralEventLoggingSOPInstance | Procedural Event Logging SOP Instance (1.2.840.10008.1.40.1)
static (Shared in Visual Basic) | StorageCommitmentPull | Storage Commitment Pull Model SOP Instance (Retired) (1.2.840.10008.1.20.2.1)
static (Shared in Visual Basic) | StorageCommitmentPush | Storage Commitment Push Model SOP Instance (1.2.840.10008.1.20.1.1)
static (Shared in Visual Basic) | SubstanceAdministrationLoggingSOPInstance | Substance Administration Logging SOP Instance (1.2.840.10008.1.42.1)
static (Shared in Visual Basic) | UPSFilteredGlobalSubscriptionInstance | UPS Filtered Global Subscription SOP Instance (1.2.840.10008.5.1.4.34.5.1)
static (Shared in Visual Basic) | UPSGlobalSubscriptionInstance | UPS Global Subscription SOP Instance (1.2.840.10008.5.1.4.34.5)
    Top
    See Also

    Reference

    WellKnownInstances Class
    DicomObjects.UIDs Namespace


DicomObjects.UIDs Namespace / WellKnownInstances Class / HotIronColorPaletteSOPInstance Field

    HotIronColorPaletteSOPInstance Field
    Hot Iron SKColor Palette SOP Instance (1.2.840.10008.1.5.1)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly HotIronColorPaletteSOPInstance As UID
    'Usage

    Dim value As UID

value = WellKnownInstances.HotIronColorPaletteSOPInstance
    public static readonly UID HotIronColorPaletteSOPInstance
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WellKnownInstances Class
    WellKnownInstances Members


DicomObjects.UIDs Namespace / WellKnownInstances Class / HotMetalBlueColorPaletteSOPInstance Field

    HotMetalBlueColorPaletteSOPInstance Field
    Hot Metal Blue SKColor Palette SOP Instance (1.2.840.10008.1.5.3)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly HotMetalBlueColorPaletteSOPInstance As UID
    'Usage

    Dim value As UID

value = WellKnownInstances.HotMetalBlueColorPaletteSOPInstance
    public static readonly UID HotMetalBlueColorPaletteSOPInstance
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WellKnownInstances Class
    WellKnownInstances Members


DicomObjects.UIDs Namespace / WellKnownInstances Class / PET20StepColorPaletteSOPInstance Field

    PET20StepColorPaletteSOPInstance Field
    PET 20 Step SKColor Palette SOP Instance (1.2.840.10008.1.5.4)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly PET20StepColorPaletteSOPInstance As UID
    'Usage

    Dim value As UID

value = WellKnownInstances.PET20StepColorPaletteSOPInstance
    public static readonly UID PET20StepColorPaletteSOPInstance
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WellKnownInstances Class
    WellKnownInstances Members


DicomObjects.UIDs Namespace / WellKnownInstances Class / PETColorPaletteSOPInstance Field

    PETColorPaletteSOPInstance Field
    PET SKColor Palette SOP Instance (1.2.840.10008.1.5.2)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly PETColorPaletteSOPInstance As UID
    'Usage

    Dim value As UID

value = WellKnownInstances.PETColorPaletteSOPInstance
    public static readonly UID PETColorPaletteSOPInstance
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WellKnownInstances Class
    WellKnownInstances Members


DicomObjects.UIDs Namespace / WellKnownInstances Class / Printer Field

    Printer Field (WellKnownInstances)
    In This Topic
    Printer SOP Instance (1.2.840.10008.5.1.1.17)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly Printer As UID
    'Usage

    Dim value As UID

value = WellKnownInstances.Printer
    public static readonly UID Printer
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WellKnownInstances Class
    WellKnownInstances Members


DicomObjects.UIDs Namespace / WellKnownInstances Class / PrinterConfigurationRetrieval Field

    PrinterConfigurationRetrieval Field (WellKnownInstances)
    In This Topic
    Printer Configuration Retrieval SOP Instance (1.2.840.10008.5.1.1.17.376)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly PrinterConfigurationRetrieval As UID
    'Usage

    Dim value As UID

value = WellKnownInstances.PrinterConfigurationRetrieval
    public static readonly UID PrinterConfigurationRetrieval
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WellKnownInstances Class
    WellKnownInstances Members


DicomObjects.UIDs Namespace / WellKnownInstances Class / PrintQueue Field

    PrintQueue Field
    Print Queue SOP Instance (Retired) (1.2.840.10008.5.1.1.25)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    <ObsoleteAttribute("Retired UID - should not be used in new implementions")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Shared ReadOnly PrintQueue As UID
    'Usage

    Dim value As UID

value = WellKnownInstances.PrintQueue
    [Obsolete("Retired UID - should not be used in new implementions")]
[EditorBrowsable(EditorBrowsableState.Advanced)]
public static readonly UID PrintQueue
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WellKnownInstances Class
    WellKnownInstances Members


DicomObjects.UIDs Namespace / WellKnownInstances Class / ProceduralEventLoggingSOPInstance Field

    ProceduralEventLoggingSOPInstance Field
    Procedural Event Logging SOP Instance (1.2.840.10008.1.40.1)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly ProceduralEventLoggingSOPInstance As UID
    'Usage

    Dim value As UID

value = WellKnownInstances.ProceduralEventLoggingSOPInstance
    public static readonly UID ProceduralEventLoggingSOPInstance
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WellKnownInstances Class
    WellKnownInstances Members


DicomObjects.UIDs Namespace / WellKnownInstances Class / StorageCommitmentPull Field

    StorageCommitmentPull Field (WellKnownInstances)
    In This Topic
    Storage Commitment Pull Model SOP Instance (Retired) (1.2.840.10008.1.20.2.1)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    <ObsoleteAttribute("Retired UID - should not be used in new implementions")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Shared ReadOnly StorageCommitmentPull As UID
    'Usage

    Dim value As UID

value = WellKnownInstances.StorageCommitmentPull
    [Obsolete("Retired UID - should not be used in new implementions")]
[EditorBrowsable(EditorBrowsableState.Advanced)]
public static readonly UID StorageCommitmentPull
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WellKnownInstances Class
    WellKnownInstances Members


DicomObjects.UIDs Namespace / WellKnownInstances Class / StorageCommitmentPush Field

    StorageCommitmentPush Field (WellKnownInstances)
    In This Topic
    Storage Commitment Push Model SOP Instance (1.2.840.10008.1.20.1.1)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly StorageCommitmentPush As UID
    'Usage

    Dim value As UID

value = WellKnownInstances.StorageCommitmentPush
    public static readonly UID StorageCommitmentPush
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WellKnownInstances Class
    WellKnownInstances Members


DicomObjects.UIDs Namespace / WellKnownInstances Class / SubstanceAdministrationLoggingSOPInstance Field

    SubstanceAdministrationLoggingSOPInstance Field
    Substance Administration Logging SOP Instance (1.2.840.10008.1.42.1)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly SubstanceAdministrationLoggingSOPInstance As UID
    'Usage

    Dim value As UID

value = WellKnownInstances.SubstanceAdministrationLoggingSOPInstance
    public static readonly UID SubstanceAdministrationLoggingSOPInstance
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WellKnownInstances Class
    WellKnownInstances Members


DicomObjects.UIDs Namespace / WellKnownInstances Class / UPSFilteredGlobalSubscriptionInstance Field

    UPSFilteredGlobalSubscriptionInstance Field
    UPS Filtered Global Subscription SOP Instance (1.2.840.10008.5.1.4.34.5.1)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly UPSFilteredGlobalSubscriptionInstance As UID
    'Usage

    Dim value As UID

value = WellKnownInstances.UPSFilteredGlobalSubscriptionInstance
    public static readonly UID UPSFilteredGlobalSubscriptionInstance
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WellKnownInstances Class
    WellKnownInstances Members


DicomObjects.UIDs Namespace / WellKnownInstances Class / UPSGlobalSubscriptionInstance Field

    UPSGlobalSubscriptionInstance Field
    UPS Global Subscription SOP Instance (1.2.840.10008.5.1.4.34.5)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly UPSGlobalSubscriptionInstance As UID
    'Usage

    Dim value As UID

value = WellKnownInstances.UPSGlobalSubscriptionInstance
    public static readonly UID UPSGlobalSubscriptionInstance
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WellKnownInstances Class
    WellKnownInstances Members


Inheritance Hierarchy
    DicomObjects.Validation Namespace
    Classes
     | Class | Description
Class | ValidationException | Specialised Exception for reporting validation exceptions
Class | ValidationOptions | Options to validate DicomObjects.DicomDataSet and its DicomObjects.DicomAttributes
    See Also

    Reference

    DicomObjects.NetStandard Assembly


%%PageItemTitle%%

DicomObjects.Validation Namespace / ValidationException Class
Members

In This Topic
    ValidationException Class
    In This Topic
    Specialised Exception for reporting validation exceptions
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Class ValidationException
   Inherits DicomObjects.DicomException
    'Usage

    Dim instance As ValidationException
    public class ValidationException : DicomObjects.DicomException
    Remarks

    This class is thrown when validation errors are detected in normal useage - e.g. by:

    • DicomDataSet.Add
    • DicomObjects.DicomDataSet.Validate

    A list of this class is also returned by the DicomObjects.DicomDataSet.ValidateAll method

    As this class is derived from DicomObjects.DicomException all the properties from that object are of course populated

    Inheritance Hierarchy

    System.Object
    System.Exception
    DicomObjects.DicomException
    DicomObjects.Validation.ValidationException

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ValidationException Members
    DicomObjects.Validation Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.Validation Namespace / ValidationException Class
Properties Methods

In This Topic
    ValidationException Class Members
    In This Topic

    The following tables list the members exposed by ValidationException.

    Public Properties
     | Name | Description
Public Property | Attribute | The attribute which failed validation
Public Property | CausedAbort | True if this exception caused the related to association to issue an Abort (thereby no longer requiring to be closed) (Inherited from DicomObjects.DicomException)
Public Property | Code | The Error code (Inherited from DicomObjects.DicomException)
Public Property | Data | (Inherited from System.Exception)
Public Property | DataSet | The DataSet which contains the offending attribute
Public Property | Element | The Element number of the offending attribute
Public Property | Group | The Group number of the offending attribute
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Path | The route to this offending attribute, from the DataSet being validated
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | Tag | A general purpose Tag for developer use (Inherited from DicomObjects.DicomException)
Public Property | TargetSite | (Inherited from System.Exception)
    Top
    Public Methods
     | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
    Top
    See Also

    Reference

    ValidationException Class
    DicomObjects.Validation Namespace


%%PageItemTitle%% $$Properties$$

DicomObjects.Validation Namespace / ValidationException Class

In This Topic
    ValidationException Class Properties
    In This Topic

    For a list of all members of this type, see ValidationException members.

    Public Properties
     | Name | Description
Public Property | Attribute | The attribute which failed validation
Public Property | CausedAbort | True if this exception caused the related to association to issue an Abort (thereby no longer requiring to be closed) (Inherited from DicomObjects.DicomException)
Public Property | Code | The Error code (Inherited from DicomObjects.DicomException)
Public Property | Data | (Inherited from System.Exception)
Public Property | DataSet | The DataSet which contains the offending attribute
Public Property | Element | The Element number of the offending attribute
Public Property | Group | The Group number of the offending attribute
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Path | The route to this offending attribute, from the DataSet being validated
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | Tag | A general purpose Tag for developer use (Inherited from DicomObjects.DicomException)
Public Property | TargetSite | (Inherited from System.Exception)
    Top
    See Also

    Reference

    ValidationException Class
    DicomObjects.Validation Namespace


DicomObjects.Validation Namespace / ValidationException Class / Attribute Property

    Attribute Property
    The attribute which failed validation
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property Attribute As DicomAttribute
    'Usage

    Dim instance As ValidationException
Dim value As DicomAttribute

value = instance.Attribute
    public DicomAttribute Attribute {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ValidationException Class
    ValidationException Members


DicomObjects.Validation Namespace / ValidationException Class / DataSet Property

    DataSet Property (ValidationException)
    In This Topic
    The DataSet which contains the offending attribute
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property DataSet As DicomDataSet
    'Usage

    Dim instance As ValidationException
Dim value As DicomDataSet

value = instance.DataSet
    public DicomDataSet DataSet {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ValidationException Class
    ValidationException Members


DicomObjects.Validation Namespace / ValidationException Class / Element Property

    Element Property (ValidationException)
    In This Topic
    The Element number of the offending attribute
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property Element As Integer
    'Usage

    Dim instance As ValidationException
Dim value As Integer

value = instance.Element
    public int Element {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ValidationException Class
    ValidationException Members


DicomObjects.Validation Namespace / ValidationException Class / Group Property

    Group Property (ValidationException)
    In This Topic
    The Group number of the offending attribute
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property Group As Integer
    'Usage

    Dim instance As ValidationException
Dim value As Integer

value = instance.Group
    public int Group {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ValidationException Class
    ValidationException Members


DicomObjects.Validation Namespace / ValidationException Class / Path Property

    Path Property
    The route to this offending attribute, from the DataSet being validated
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public ReadOnly Property Path As List(Of ItemLocation)
    'Usage

    Dim instance As ValidationException
Dim value As List(Of ItemLocation)

value = instance.Path
    public List<ItemLocation> Path {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ValidationException Class
    ValidationException Members


%%PageItemTitle%%

DicomObjects.Validation Namespace / ValidationOptions Class
Members

In This Topic
    ValidationOptions Class
    In This Topic
    Options to validate DicomObjects.DicomDataSet and its DicomObjects.DicomAttributes
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Class ValidationOptions
    'Usage

    Dim instance As ValidationOptions
    public class ValidationOptions
    Inheritance Hierarchy

    System.Object
    DicomObjects.Validation.ValidationOptions

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ValidationOptions Members
    DicomObjects.Validation Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.Validation Namespace / ValidationOptions Class
Properties Methods

In This Topic
    ValidationOptions Class Members
    In This Topic

    The following tables list the members exposed by ValidationOptions.

    Public Constructors
     | Name | Description
Public Constructor | ValidationOptions Constructor |
    Top
    Public Properties
     | Name | Description
static (Shared in Visual Basic) | All | Generate a Full ValidationOptions object
Public Property | CharacterSet | Validation for Character Set if Non-ASCII characters are present Specifically checking for (0008,0005) Specific Character Set. Refer to the Standard for more details
Public Property | DataLength | Include data length compatibility check for VR as specified in the Standard (Length of Value)
Public Property | Detailed | Include data length compatibility check for VR (Character Repertoire) and allowed VM for associated attribute as specified in the Standard
Public Property | ForQuery | Validation for attributes in the context of a Query with range matching Refer to the Standard for more details
static (Shared in Visual Basic) | None | Generate a No ValidationOptions object
Public Property | PrivateAttributes | Validation of Private Attributes if present Non-standard, DicomObjects only option. Default is to skip validation for these types
Public Property | PrivateSequences | Validation of Private Sequences if present Non-standard, DicomObjects only option. Default is to skip validation for these types
static (Shared in Visual Basic) | Query | Generate a ValidationOptions object with ForQuery enabled
    Top
    Public Methods
     | Name | Description
Public Method | Equals | Member comparison
Public Method | GetHashCode | Serves as the default hash function.
    Top
    See Also

    Reference

    ValidationOptions Class
    DicomObjects.Validation Namespace


%%PageItemTitle%%

DicomObjects.Validation Namespace / ValidationOptions Class / ValidationOptions Constructor

In This Topic
    ValidationOptions Constructor
    In This Topic
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Function New()
    'Usage

    Dim instance As New ValidationOptions()
    public ValidationOptions()
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ValidationOptions Class
    ValidationOptions Members


%%PageItemTitle%% $$Methods$$

DicomObjects.Validation Namespace / ValidationOptions Class

    ValidationOptions Class Methods
    In This Topic

    For a list of all members of this type, see ValidationOptions members.

    Public Methods
     | Name | Description
Public Method | Equals | Member comparison
Public Method | GetHashCode | Serves as the default hash function.
    Top
    See Also

    Reference

    ValidationOptions Class
    DicomObjects.Validation Namespace


DicomObjects.Validation Namespace / ValidationOptions Class / Equals Method
ValidationOptions to compare

    Equals Method (ValidationOptions)
    In This Topic
    Member comparison
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
    'Usage

    Dim instance As ValidationOptions
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
    public override bool Equals(
   object obj
)

    Parameters

    obj
    ValidationOptions to compare

    Return Value

    Comparison result
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ValidationOptions Class
    ValidationOptions Members


DicomObjects.Validation Namespace / ValidationOptions Class / GetHashCode Method

    GetHashCode Method (ValidationOptions)
    In This Topic
    Serves as the default hash function.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Overrides Function GetHashCode() As Integer
    'Usage

    Dim instance As ValidationOptions
Dim value As Integer

value = instance.GetHashCode()
    public override int GetHashCode()

    Return Value

    A hash code for the current object.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ValidationOptions Class
    ValidationOptions Members


%%PageItemTitle%% $$Properties$$

DicomObjects.Validation Namespace / ValidationOptions Class

    ValidationOptions Class Properties
    In This Topic

    For a list of all members of this type, see ValidationOptions members.

    Public Properties
     | Name | Description
static (Shared in Visual Basic) | All | Generate a Full ValidationOptions object
Public Property | CharacterSet | Validation for Character Set if Non-ASCII characters are present Specifically checking for (0008,0005) Specific Character Set. Refer to the Standard for more details
Public Property | DataLength | Include data length compatibility check for VR as specified in the Standard (Length of Value)
Public Property | Detailed | Include data length compatibility check for VR (Character Repertoire) and allowed VM for associated attribute as specified in the Standard
Public Property | ForQuery | Validation for attributes in the context of a Query with range matching Refer to the Standard for more details
static (Shared in Visual Basic) | None | Generate a No ValidationOptions object
Public Property | PrivateAttributes | Validation of Private Attributes if present Non-standard, DicomObjects only option. Default is to skip validation for these types
Public Property | PrivateSequences | Validation of Private Sequences if present Non-standard, DicomObjects only option. Default is to skip validation for these types
static (Shared in Visual Basic) | Query | Generate a ValidationOptions object with ForQuery enabled
    Top
    See Also

    Reference

    ValidationOptions Class
    DicomObjects.Validation Namespace


DicomObjects.Validation Namespace / ValidationOptions Class / All Property

    All Property
    Generate a Full ValidationOptions object
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly Property All As ValidationOptions
    'Usage

    Dim value As ValidationOptions

value = ValidationOptions.All
    public static ValidationOptions All {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ValidationOptions Class
    ValidationOptions Members


DicomObjects.Validation Namespace / ValidationOptions Class / CharacterSet Property

    CharacterSet Property
    Validation for Character Set if Non-ASCII characters are present

    Specifically checking for (0008,0005) Specific Character Set. Refer to the Standard for more details

    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property CharacterSet As Boolean
    'Usage

    Dim instance As ValidationOptions
Dim value As Boolean

instance.CharacterSet = value

value = instance.CharacterSet
    public bool CharacterSet {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ValidationOptions Class
    ValidationOptions Members


DicomObjects.Validation Namespace / ValidationOptions Class / DataLength Property

    DataLength Property
    Include data length compatibility check for VR as specified in the Standard (Length of Value)
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property DataLength As Boolean
    'Usage

    Dim instance As ValidationOptions
Dim value As Boolean

instance.DataLength = value

value = instance.DataLength
    public bool DataLength {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ValidationOptions Class
    ValidationOptions Members


DicomObjects.Validation Namespace / ValidationOptions Class / Detailed Property

    Detailed Property
    Include data length compatibility check for VR (Character Repertoire) and allowed VM for associated attribute as specified in the Standard
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property Detailed As Boolean
    'Usage

    Dim instance As ValidationOptions
Dim value As Boolean

instance.Detailed = value

value = instance.Detailed
    public bool Detailed {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ValidationOptions Class
    ValidationOptions Members


DicomObjects.Validation Namespace / ValidationOptions Class / ForQuery Property

    ForQuery Property
    Validation for attributes in the context of a Query with range matching

    Refer to the Standard for more details

    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property ForQuery As Boolean
    'Usage

    Dim instance As ValidationOptions
Dim value As Boolean

instance.ForQuery = value

value = instance.ForQuery
    public bool ForQuery {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ValidationOptions Class
    ValidationOptions Members


DicomObjects.Validation Namespace / ValidationOptions Class / None Property

    None Property
    Generate a No ValidationOptions object
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly Property None As ValidationOptions
    'Usage

    Dim value As ValidationOptions

value = ValidationOptions.None
    public static ValidationOptions None {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ValidationOptions Class
    ValidationOptions Members


DicomObjects.Validation Namespace / ValidationOptions Class / PrivateAttributes Property

    PrivateAttributes Property
    Validation of Private Attributes if present

    Non-standard, DicomObjects only option. Default is to skip validation for these types

    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property PrivateAttributes As Boolean
    'Usage

    Dim instance As ValidationOptions
Dim value As Boolean

instance.PrivateAttributes = value

value = instance.PrivateAttributes
    public bool PrivateAttributes {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ValidationOptions Class
    ValidationOptions Members


DicomObjects.Validation Namespace / ValidationOptions Class / PrivateSequences Property

    PrivateSequences Property
    Validation of Private Sequences if present

    Non-standard, DicomObjects only option. Default is to skip validation for these types

    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property PrivateSequences As Boolean
    'Usage

    Dim instance As ValidationOptions
Dim value As Boolean

instance.PrivateSequences = value

value = instance.PrivateSequences
    public bool PrivateSequences {get; set;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ValidationOptions Class
    ValidationOptions Members


DicomObjects.Validation Namespace / ValidationOptions Class / Query Property

    Query Property
    Generate a ValidationOptions object with ForQuery enabled
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Shared ReadOnly Property Query As ValidationOptions
    'Usage

    Dim value As ValidationOptions

value = ValidationOptions.Query
    public static ValidationOptions Query {get;}
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    ValidationOptions Class
    ValidationOptions Members


Inheritance Hierarchy
    DicomObjects.Video Namespace
    Classes
     | Class | Description
Class | VideoCompressionOptions | Control the encoding of video for either export, or for encoding into one of the DICOM video transfer syntaxes
    Enumerations
     | Enumeration | Description
Enumeration | Level | Video level enumerations
Enumeration | Profile | Video profile enumerations
    See Also

    Reference

    DicomObjects.NetStandard Assembly


%%PageItemTitle%%

DicomObjects.Video Namespace / VideoCompressionOptions Class
Members

In This Topic
    VideoCompressionOptions Class
    In This Topic
    Control the encoding of video for either export, or for encoding into one of the DICOM video transfer syntaxes
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Class VideoCompressionOptions
    'Usage

    Dim instance As VideoCompressionOptions
    public class VideoCompressionOptions
    Remarks

    The only public constructor for this class takes a DicomImage and a "format" - which is generally the extension of the file to be used for export, which therefore sets the Container, which in turn normally sets a default codec. The Codec can however subsequently be changed.

    For internal DICOM transfer syntax conversion, default VideoCompressionOptions objects are created to match the requirements of the output transfer syntax, but they may be

    Inheritance Hierarchy

    System.Object
    DicomObjects.Video.VideoCompressionOptions

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    VideoCompressionOptions Members
    DicomObjects.Video Namespace


%%PageItemTitle%% $$Members$$

DicomObjects.Video Namespace / VideoCompressionOptions Class
Properties

In This Topic
    VideoCompressionOptions Class Members
    In This Topic

    The following tables list the members exposed by VideoCompressionOptions.

    Public Constructors
     | Name | Description
Public Constructor | VideoCompressionOptions Constructor | Construct a default set of compression options for a given image and output format
    Top
    Public Properties
     | Name | Description
Public Property | BitsPerSecond | The defined output rate in Bits per second
Public Property | Container | The name of the container ("format") to use when encoding.
Public Property | ExplicitCodec | The name of the video compression codec to use
Public Property | FirstFrame | The first frame of the video to export
Public Property | InputFilter | Filter to apply to raw frames before scaling etc.
Public Property | InputFrameRate | The rate at which the source frames are to be used.
Public Property | LastFrame | The last frame of the video to export
Public Property | Level | Video level to use
Public Property | OutputFilter | Filter to apply to scaled frames before passing to the codec
Public Property | OutputFrameRate | The rate at which frame are fed to the codec
Public Property | OutputSize | The size of the output frames to be encoded
Public Property | PaddingColour | Colour to use for any padding required if OutputSize is not the same as the original DICOM image size
Public Property | Profile | The Video profile to use
Public Property | Scale | Controls whether to scale video if OutputSize is not the same as the original DICOM image size
Public Property | UseWindowing | Controls whether data is put into the MPEG "raw" or via the presentaiton chain, including windowing
    Top
    See Also

    Reference

    VideoCompressionOptions Class
    DicomObjects.Video Namespace


%%PageItemTitle%%

DicomObjects.Video Namespace / VideoCompressionOptions Class / VideoCompressionOptions Constructor
The Image to be compressed to video
The output format - see remarks
If specified (may be null), then the specific codec is used - otherwise this can be selected internally based on the container
If set to a value convertable to an integer, then this is used to initialise the BitsPerSecond property

In This Topic
    VideoCompressionOptions Constructor
    In This Topic
    Construct a default set of compression options for a given image and output format
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Function New( _
   ByVal Image As DicomDataSet, _
   ByVal Format As String, _
   ByVal Codec As String, _
   ByVal Quality As Object _
)
    'Usage

    Dim Image As DicomDataSet
Dim Format As String
Dim Codec As String
Dim Quality As Object

Dim instance As New VideoCompressionOptions(Image, Format, Codec, Quality)
    public VideoCompressionOptions(
   DicomDataSet Image,
   string Format,
   string Codec,
   object Quality
)

    Parameters

    Image
    The Image to be compressed to video
    Format
    The output format - see remarks
    Codec
    If specified (may be null), then the specific codec is used - otherwise this can be selected internally based on the container
    Quality
    If set to a value convertable to an integer, then this is used to initialise the BitsPerSecond property
    Remarks

    This constructor sets very many default options, depending on the characteristics of the image and the output format. Only change them if you know what you are doing!

    The format parameter has 2 quite different forms:

    • If it is a UID, then it is interpretted as a DICOM Transfer Syntax, and options are set according to the DICOM rules for that transfer syntax
    • Otherwise, it is treated as an container format (such as "avi" or "mp4")

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    VideoCompressionOptions Class
    VideoCompressionOptions Members


%%PageItemTitle%% $$Properties$$

DicomObjects.Video Namespace / VideoCompressionOptions Class

    VideoCompressionOptions Class Properties
    In This Topic

    For a list of all members of this type, see VideoCompressionOptions members.

    Public Properties
     | Name | Description
Public Property | BitsPerSecond | The defined output rate in Bits per second
Public Property | Container | The name of the container ("format") to use when encoding.
Public Property | ExplicitCodec | The name of the video compression codec to use
Public Property | FirstFrame | The first frame of the video to export
Public Property | InputFilter | Filter to apply to raw frames before scaling etc.
Public Property | InputFrameRate | The rate at which the source frames are to be used.
Public Property | LastFrame | The last frame of the video to export
Public Property | Level | Video level to use
Public Property | OutputFilter | Filter to apply to scaled frames before passing to the codec
Public Property | OutputFrameRate | The rate at which frame are fed to the codec
Public Property | OutputSize | The size of the output frames to be encoded
Public Property | PaddingColour | Colour to use for any padding required if OutputSize is not the same as the original DICOM image size
Public Property | Profile | The Video profile to use
Public Property | Scale | Controls whether to scale video if OutputSize is not the same as the original DICOM image size
Public Property | UseWindowing | Controls whether data is put into the MPEG "raw" or via the presentaiton chain, including windowing
    Top
    See Also

    Reference

    VideoCompressionOptions Class
    DicomObjects.Video Namespace


DicomObjects.Video Namespace / VideoCompressionOptions Class / BitsPerSecond Property

    BitsPerSecond Property
    The defined output rate in Bits per second
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property BitsPerSecond As Integer
    'Usage

    Dim instance As VideoCompressionOptions
Dim value As Integer

instance.BitsPerSecond = value

value = instance.BitsPerSecond
    public int BitsPerSecond {get; set;}
    Remarks
    If the "Quality" parameter for video copmression is set to a number rather than a VideoCompressionOptions object, then a default VideoCompressionOptions object will be created, based on the format, and the rate will then be set to that quality value.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    VideoCompressionOptions Class
    VideoCompressionOptions Members


DicomObjects.Video Namespace / VideoCompressionOptions Class / Container Property

    Container Property
    The name of the container ("format") to use when encoding.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property Container As String
    'Usage

    Dim instance As VideoCompressionOptions
Dim value As String

instance.Container = value

value = instance.Container
    public string Container {get; set;}
    Remarks

    For encapsulating into DICOM, this must always be "mp4" (MPEG-4 Part 14) or "mpeg" (MPEG program stream) - irrespective of the ExplicitCodec used.

    For export, this may be other formats such as "avi"

    As "gif" is used for standard static gif export, the special value "v-gif" may be used which will force video export, and which will be passed to ffmpeg as "gif"

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    VideoCompressionOptions Class
    VideoCompressionOptions Members


DicomObjects.Video Namespace / VideoCompressionOptions Class / ExplicitCodec Property

    ExplicitCodec Property
    The name of the video compression codec to use
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property ExplicitCodec As String
    'Usage

    Dim instance As VideoCompressionOptions
Dim value As String

instance.ExplicitCodec = value

value = instance.ExplicitCodec
    public string ExplicitCodec {get; set;}
    Remarks

    This is semi-independent of the Container, but not all combinations are valid.

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    VideoCompressionOptions Class
    VideoCompressionOptions Members


DicomObjects.Video Namespace / VideoCompressionOptions Class / FirstFrame Property

    FirstFrame Property
    The first frame of the video to export
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property FirstFrame As Integer
    'Usage

    Dim instance As VideoCompressionOptions
Dim value As Integer

instance.FirstFrame = value

value = instance.FirstFrame
    public int FirstFrame {get; set;}
    Remarks
    Default is 1
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    VideoCompressionOptions Class
    VideoCompressionOptions Members


DicomObjects.Video Namespace / VideoCompressionOptions Class / InputFilter Property

    InputFilter Property
    Filter to apply to raw frames before scaling etc.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property InputFilter As String
    'Usage

    Dim instance As VideoCompressionOptions
Dim value As String

instance.InputFilter = value

value = instance.InputFilter
    public string InputFilter {get; set;}
    Remarks
    The whole of the filter set defined by ffmpeg is available, and this filter allows options to be set as one would at the ffmpeg command line
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    VideoCompressionOptions Class
    VideoCompressionOptions Members


DicomObjects.Video Namespace / VideoCompressionOptions Class / InputFrameRate Property

    InputFrameRate Property
    The rate at which the source frames are to be used.
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property InputFrameRate As Integer
    'Usage

    Dim instance As VideoCompressionOptions
Dim value As Integer

instance.InputFrameRate = value

value = instance.InputFrameRate
    public int InputFrameRate {get; set;}
    Remarks
    By default, this is calculated the same way as is used for cine display, based on the FrameTime etc. in the DICOM data
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    VideoCompressionOptions Class
    VideoCompressionOptions Members


DicomObjects.Video Namespace / VideoCompressionOptions Class / LastFrame Property

    LastFrame Property
    The last frame of the video to export
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property LastFrame As Integer
    'Usage

    Dim instance As VideoCompressionOptions
Dim value As Integer

instance.LastFrame = value

value = instance.LastFrame
    public int LastFrame {get; set;}
    Remarks
    Default is the image's FrameCount
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    VideoCompressionOptions Class
    VideoCompressionOptions Members


DicomObjects.Video Namespace / VideoCompressionOptions Class / Level Property

    Level Property (VideoCompressionOptions)
    In This Topic
    Video level to use
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property Level As Level
    'Usage

    Dim instance As VideoCompressionOptions
Dim value As Level

instance.Level = value

value = instance.Level
    public Level Level {get; set;}
    Remarks

    It is the user's responsibility to ensure that the Level chosen is suitable for the chosen Codec, as different codecs use differnet numbering schemes.

    If a particular value is not available in this list, please let us know for future releases, but a suitable integer value may simply be cast to a Level

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    VideoCompressionOptions Class
    VideoCompressionOptions Members


DicomObjects.Video Namespace / VideoCompressionOptions Class / OutputFilter Property

    OutputFilter Property
    Filter to apply to scaled frames before passing to the codec
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property OutputFilter As String
    'Usage

    Dim instance As VideoCompressionOptions
Dim value As String

instance.OutputFilter = value

value = instance.OutputFilter
    public string OutputFilter {get; set;}
    Remarks
    The whole of the filter set defined by ffmpeg is available, and this filter allows options to be set as one would at the ffmpeg command line
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    VideoCompressionOptions Class
    VideoCompressionOptions Members


DicomObjects.Video Namespace / VideoCompressionOptions Class / OutputFrameRate Property

    OutputFrameRate Property
    The rate at which frame are fed to the codec
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property OutputFrameRate As Integer
    'Usage

    Dim instance As VideoCompressionOptions
Dim value As Integer

instance.OutputFrameRate = value

value = instance.OutputFrameRate
    public int OutputFrameRate {get; set;}
    Remarks
    By default, this is the same as InputFrameRate, but some codecs (especially when combined with DICOM rules) have specific requirements, so this can be set independently. If the input and output rates differ, then the ffmpeg "fps" filter is applied to duplicate/drop as required.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    VideoCompressionOptions Class
    VideoCompressionOptions Members


DicomObjects.Video Namespace / VideoCompressionOptions Class / OutputSize Property

    OutputSize Property
    The size of the output frames to be encoded
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property OutputSize As SkiaSharp.SKSizeI
    'Usage

    Dim instance As VideoCompressionOptions
Dim value As SkiaSharp.SKSizeI

instance.OutputSize = value

value = instance.OutputSize
    public SkiaSharp.SKSizeI OutputSize {get; set;}
    Remarks
    By default, this is the same as the size of the DICOm frames, but some codecs (especially when combined with DICOM rules) have specific requirements, so this can be set independently. If the input and output rates differ, then the ffmpeg "pad" and/or "scale" filters are change the size as required.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    VideoCompressionOptions Class
    VideoCompressionOptions Members
    Scale Property
    PaddingColour Property


DicomObjects.Video Namespace / VideoCompressionOptions Class / PaddingColour Property

    PaddingColour Property
    Colour to use for any padding required if OutputSize is not the same as the original DICOM image size
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property PaddingColour As SkiaSharp.SKColor
    'Usage

    Dim instance As VideoCompressionOptions
Dim value As SkiaSharp.SKColor

instance.PaddingColour = value

value = instance.PaddingColour
    public SkiaSharp.SKColor PaddingColour {get; set;}
    Remarks
    Default is Black
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    VideoCompressionOptions Class
    VideoCompressionOptions Members


DicomObjects.Video Namespace / VideoCompressionOptions Class / Profile Property

    Profile Property
    The Video profile to use
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property Profile As Profile
    'Usage

    Dim instance As VideoCompressionOptions
Dim value As Profile

instance.Profile = value

value = instance.Profile
    public Profile Profile {get; set;}
    Remarks

    It is the user's responsibility to ensure that the Profile chosen is suitable for the chosen Codec, as different codecs use differnet numbering schemes.

    If a particular value is not available in this list, please let us know for future releases, but a suitable integer value may simply be cast to a Profile

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    VideoCompressionOptions Class
    VideoCompressionOptions Members


DicomObjects.Video Namespace / VideoCompressionOptions Class / Scale Property

    Scale Property (VideoCompressionOptions)
    In This Topic
    Controls whether to scale video if OutputSize is not the same as the original DICOM image size
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property Scale As Boolean
    'Usage

    Dim instance As VideoCompressionOptions
Dim value As Boolean

instance.Scale = value

value = instance.Scale
    public bool Scale {get; set;}
    Remarks

    If true or if the original DICOM image size is larger than the OutputSize, then the images are scaled to fit on the most restrictive dimension

    If false, and if the original DICOM image size is smaller than the OutputSize, then the original size is retained, and padding is placed around it

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    VideoCompressionOptions Class
    VideoCompressionOptions Members
    OutputSize Property
    PaddingColour Property


DicomObjects.Video Namespace / VideoCompressionOptions Class / UseWindowing Property

    UseWindowing Property
    Controls whether data is put into the MPEG "raw" or via the presentaiton chain, including windowing
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Property UseWindowing As Boolean
    'Usage

    Dim instance As VideoCompressionOptions
Dim value As Boolean

instance.UseWindowing = value

value = instance.UseWindowing
    public bool UseWindowing {get; set;}
    Remarks
    The default for colour images is false, and for monochrome images it is true. It should not be set to false for images with more than 8 bits per sample.
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    VideoCompressionOptions Class
    VideoCompressionOptions Members


%%PageItemTitle%%

DicomObjects.Video Namespace / Level Enumeration

    Level Enumeration
    In This Topic
    Video level enumerations
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Enum Level
   Inherits System.Enum
    'Usage

    Dim instance As Level
    public enum Level : System.Enum
    Members
    Member | Description
MPEG2_High | MPEG 2 High level - as used in the MPEG-2 DICOM MP@HLtransfer syntax
MPEG2_High1440 | MPEG 2 High 1440 level (not generally used in DICOM)
MPEG2_Low | MPEG 2 Simple level (not generally used in DICOM)
MPEG2_Main | MPEG 2 Main level - as used in the MPEG-2 DICOM MP@MLtransfer syntax
MPEG4_41 | MPEG-4 AVC/H.264 Level 4.1 as used in the MPEG-4 AVC/H.264 HiP@Level4.1 transfer syntaxes
MPEG4_42 | MPEG-4 AVC/H.264 Level 4.2 as used in the MPEG-4 AVC/H.264 HiP@Level4.1 transfer syntaxes
    Remarks

    It is the user's responsibility to ensure that the Level chosen is suitable for the chosen Codec, as different codecs use differnet numbering schemes.

    If a particular value is not available in this list, please let us know for future releases, but a suitable integer value may simply be cast to a Level

    Inheritance Hierarchy

    System.Object
    System.ValueType
    System.Enum
    DicomObjects.Video.Level

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomObjects.Video Namespace


%%PageItemTitle%%

DicomObjects.Video Namespace / Profile Enumeration

    Profile Enumeration
    In This Topic
    Video profile enumerations
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Public Enum Profile
   Inherits System.Enum
    'Usage

    Dim instance As Profile
    public enum Profile : System.Enum
    Members
    Member | Description
MPEG2_High | MPEG 2 High profile. This is not generally used in DICOM. Not to be confused with the High Level (Level.MPEG2_High which is used in the DICOM MPEG2 MP@HL transfer syntax)
MPEG2_Main | MPEG 2 Main profile - as used in the MPEG-2 DICOM transfer syntaxes
MPEG2_Simple | MPEG 2 Simple profile. This is not generally used in DICOM.
MPEG4_High | MPEG-4 AVC/H.264 High profile as used in the MPEG-4 AVC/H.264 HiP@Level4.1 transfer syntaxes
    Remarks

    It is the user's responsibility to ensure that the Profile chosen is suitable for the chosen Codec, as different codecs use different numbering schemes.

    If a particular value is not available in this list, please let us know for future releases, but a suitable integer value may simply be cast to a Profile

    Inheritance Hierarchy

    System.Object
    System.ValueType
    System.Enum
    DicomObjects.Video.Profile

    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomObjects.Video Namespace


Reference Material / Useful Links
    Useful Links

    For FAQ please check our website articles, where you can find discussions and solutions for most common errors and questions regarding DICOM and our toolkit KB articles.

    Latest DICOM standard can be found here DICOM standard.

    For the latest list of DICOM attributes please follow this link DICOM standard Part 6.

    Some values that relate to DicomObjects as a whole are controlled through registry values, which can be set using the RegWord and RegString methods of DicomGlobal. For latest list please click here.


Reference Material / Third party license compliance
    Third party license compliance

    Below is a list of third party tools included in this product and their usage policy as defined. This is to make you (our users) aware of the usage of third party tools, their policies and adherence to the legal aspects of using them in your product. Here is the complete list of external code included in our product and how you are entitled to use them, if you wish to.

    1. FFmpeg is a Codec to support variety of video formats and their usage policy can be viewed on their website which also has a compliance checklist for using FFmpeg in your project https://www.ffmpeg.org/legal.html. You can also find their reference in our website license http://www.medicalconnections.co.uk/kb/Video_support_with_FFmpeg
    2. Newtonsoft library has been used to parse Json data to DICOM and vice versa. Its licensing terms can be found here https://github.com/JamesNK/Newtonsoft.Json/blob/master/LICENSE.md


Reference Material / Contents of this version
    Contents of this version

    Main library files (All DICOM operations)

    • DicomObjects.NetStandard.dll
    • DicomObjects.NetStandard.xml (Documentation, intellisense tooltip)

    Optional

    Video support using FFmpeg

    • FFmpeg.Adapter.dll

    32 bit

    64 bit

    • avcodec.x86-58.dll
    • avdevice.x86-58.dll
    • avfilter.x86-7.dll
    • avformat.x86-58.dll
    • avutil.x86-56.dll
    • swresample.x86-3.dll
    • swscale.x86-5.dll
    • avcodec.x64-58.dll
    • avdevice.x64-58.dll
    • avfilter.x64-7.dll
    • avformat.x64-58.dll
    • avutil.x64-56.dll
    • swresample.x64-3.dll
    • swscale.x64-5.dll
    * Please include appropriate DLLs depending on your project platform. You may include both sets of DLLs if your application supports both platforms.

    JSON parser (mainly used in DICOM Web)

    • Newtonsoft.Json.dll

    Dependency Injection and Logging Libraries

    • Microsoft.Extensions.DependencyInjection.Abstractions.dll
    • Microsoft.Extensions.Logging.Abstractions.dll
    • Serilog.dll

    Language and Encoding Libraries

    • Microsoft.CSharp.dll
    • System.Text.Encoding.CodePages.dll

    Graphics and Encoding Libraries

    • SkiaSharp.dll

    Security and Cryptography Libraries

    • System.Security.Cryptography.Pkcs.dll
    • System.Formats.Asn1.dll

    Web Service Libraries

    • System.ServiceModel.Http.dll


Reference Material / Contact Us
    Contact Us

    Contact Information for Medical Connections Ltd:

    E-mail: | support@medicalconnections.co.uk / accounts@medicalconnections.co.uk
Web: | www.medicalconnections.co.uk
Address: | Axis 7, Axis Court, Mallard Way Llansamlet Swansea SA7 0AJ United Kingdom
Telephone: | +44 1792 390209


Reference Material / Conformance
    Conformance

    Please see the knowledge base article:

    http://www.medicalconnections.co.uk/kb/Conformance_Statement_for_DicomObjects


%%PageItemTitle%% $$Properties$$

DicomObjects.Codecs Namespace / JpegLossless Class

    JpegLossless Class Properties
    In This Topic

    For a list of all members of this type, see JpegLossless members.

    Public Properties
     | Name | Description
Public Property | MaximumBits | The maximum number of bits supported by this codec. (Inherited from DicomObjects.Codecs.SimpleCodec)
Public Property | NeedsPlanarConfigTransform | Lets a caller to SimpleCodec.Decompress tell whether data needs to be transformed following decompression. It is only relevant if the image has a Planar Configuration value (0028,0006) of 1. For the simple codec, the value comes from the constructor (Inherited from DicomObjects.Codecs.SimpleCodec)
    Top
    See Also

    Reference

    JpegLossless Class
    DicomObjects.Codecs Namespace


%%PageItemTitle%% $$Properties$$

DicomObjects.Codecs Namespace / VideoCodec Class

    VideoCodec Class Properties
    In This Topic

    For a list of all members of this type, see VideoCodec members.

    Public Properties
     | Name | Description
Public Property | MaximumBits | The maximum number of bits supported by this codec. (Inherited from DicomObjects.Codecs.SimpleCodec)
Public Property | NeedsPlanarConfigTransform | Lets a caller to Decompress tell whether data needs to be transformed following decompression. It is only relevant if the image has a Planar Configuration value (0028,0006) of 1. For the simple codec, the value comes from the constructor (Inherited from DicomObjects.Codecs.SimpleCodec)
    Top
    See Also

    Reference

    VideoCodec Class
    DicomObjects.Codecs Namespace


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

    DicomObjects.Codecs Namespace Inheritance Hierarchy
    Inheritance Hierarchy
    System.Object
    DicomObjects.Codecs.CodecFactory
    DicomObjects.Codecs.DicomCodecBaseArguments
    DicomObjects.Codecs.CompressionArguments
    DicomObjects.Codecs.DecompressionArguments
    DicomObjects.Codecs.ImportArguments
    DicomObjects.Codecs.ModificationArguments
    DicomObjects.Codecs.Jpeg2000CompressionOptions
    DicomObjects.Codecs.JpegLSCompressionOptions
    DicomObjects.Codecs.Jpip
    DicomObjects.Codecs.SimpleCodec
    DicomObjects.Codecs.JpegLossless
    DicomObjects.Codecs.VideoCodec
    See Also

    Reference

    DicomObjects.NetStandard Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

    DicomObjects.Delegates Namespace Inheritance Hierarchy
    Inheritance Hierarchy
    System.Object
    See Also

    Reference

    DicomObjects.NetStandard Assembly


DicomObjects Namespace / DicomDataSet Class / FrameSubSet Method

    FrameSubSet Method
    Generates a new DicomDataSet as a subset of the current instance as described in supplement 119
    Overload List
    Overload | Description
FrameSubSet | Generates a new DicomDataSet as a subset of the current instance as described in supplement 119
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


DicomObjects Namespace / DicomDataSet Class / PrinterImage Method

    PrinterImage Method (DicomDataSet)
    In This Topic
    Creates a copy of the image for printing or other purposes
    Overload List
    Overload | Description
PrinterImage | Creates a copy of the image for printing or other purposes
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomDataSet Class
    DicomDataSet Members


%%PageItemTitle%% $$Methods$$

DicomObjects Namespace / DicomException Class

    DicomException Class Methods
    In This Topic

    For a list of all members of this type, see DicomException members.

    Public Methods
     | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
    Top
    See Also

    Reference

    DicomException Class
    DicomObjects Namespace


DicomObjects Namespace / DicomImage Class / Dispose Method

    Dispose Method (DicomImage)
    In This Topic
    Standard Dispose methods
    Overload List
    Overload | Description
Dispose | Releases the resources used by the DicomImage object This does not dispose the underlying DicomDataSet object which is DataSet, an explicit Dispose call will be needed to have that effect
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / Matrix Method

    Matrix Method
    Matrix specifying how the image is displayed
    Overload List
    Overload | Description
Matrix | Matrix specifying how the image is displayed onto display of the stated size
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / SetDefaultWindows Method

    SetDefaultWindows Method
    Recalculates the default windows used by DicomObjects as if the image had just been loaded
    Overload List
    Overload | Description
SetDefaultWindows | Recalculates the default windows used by DicomObjects as if the image had just been loaded
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomImage Class / Update Method

    Update Method (DicomImage)
    In This Topic
    Causes the image to be updated
    Overload List
    Overload | Description
Update | Causes the image to be updated
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomImage Class
    DicomImage Members


DicomObjects Namespace / DicomLabel Class / Transform Method

    Transform Method
    Adjusts the position, size etc. of the label
    Overload List
    Overload | Description
Transform | Adjusts the position, size etc. of the label
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    DicomLabel Class
    DicomLabel Members


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

    DicomObjects.Enums Namespace Inheritance Hierarchy
    Inheritance Hierarchy
    System.Object
    See Also

    Reference

    DicomObjects.NetStandard Assembly


DicomObjects.EventArguments Namespace / AssociationRequestArgs Class / Reject Method

    Reject Method (AssociationRequestArgs)
    In This Topic
    Reject the assocation.
    Overload List
    Overload | Description
Reject | Reject a whole association request
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    AssociationRequestArgs Class
    AssociationRequestArgs Members


%%PageItemTitle%% $$Properties$$

DicomObjects.EventArguments Namespace / NormalisedReceivedArgs Class

In This Topic
    NormalisedReceivedArgs Class Properties
    In This Topic

    For a list of all members of this type, see NormalisedReceivedArgs members.

    Public Properties
     | Name | Description
Public Property | Command | The incoming command (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Errors | List of errors found in an incoming request (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Operation | The normalised operation currently requested (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | PresentationContextId | The Presentation Context ID used to transmit this operation (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Request | The incoming request (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | RequestAssociation | The Association which contains the Query (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | ResultDataSet | Specifies the result DicomDataSet to be sent back for Normalised operations operations for for failures for retrieval operations (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Status | The status to be sent back as a C-Echo response (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
    Top
    See Also

    Reference

    NormalisedReceivedArgs Class
    DicomObjects.EventArguments Namespace


%%PageItemTitle%% $$Properties$$

DicomObjects.EventArguments Namespace / VerifyReceivedArgs Class

In This Topic
    VerifyReceivedArgs Class Properties
    In This Topic

    For a list of all members of this type, see VerifyReceivedArgs members.

    Public Properties
     | Name | Description
Public Property | Command | The incoming command (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Errors | List of errors found in an incoming request (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Operation | The normalised operation currently requested (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | PresentationContextId | The Presentation Context ID used to transmit this operation (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Request | The incoming request (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | RequestAssociation | The Association which contains the Query (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | ResultDataSet | Specifies the result DicomDataSet to be sent back for Normalised operations operations for for failures for retrieval operations (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
Public Property | Status | The status to be sent back as a C-Echo response (Inherited from DicomObjects.EventArguments.OperationBaseArgs)
    Top
    See Also

    Reference

    VerifyReceivedArgs Class
    DicomObjects.EventArguments Namespace


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

    DicomObjects.EventArguments Namespace Inheritance Hierarchy
    Inheritance Hierarchy
    System.Object
    DicomObjects.EventArguments.AssociationClosedArgs
    DicomObjects.EventArguments.ChangeUidArgs
    DicomObjects.EventArguments.ErrorReceivedArgs
    DicomObjects.EventArguments.InfoMessageArgs
    DicomObjects.EventArguments.LogEventArgs
    DicomObjects.EventArguments.PSLabelCreatedArgs
    DicomObjects.EventArguments.ReceivingPixelDataArgs
    DicomObjects.EventArguments.ValidateFragmentsArgs
    System.EventArgs
    DicomObjects.EventArguments.AssociationRequestArgs
    DicomObjects.EventArguments.OperationBaseArgs
    DicomObjects.EventArguments.InstanceReceivedArgs
    DicomObjects.EventArguments.N_Event_ReportArgs
    DicomObjects.EventArguments.NormalisedReceivedArgs
    DicomObjects.EventArguments.QueryReceivedArgs
    DicomObjects.EventArguments.VerifyReceivedArgs
    DicomObjects.EventArguments.ResponseReceivedArgs
    See Also

    Reference

    DicomObjects.NetStandard Assembly


DicomObjects.UIDs Namespace / UID Class / Implicit Type Conversion Operator / Implicit Type Conversion(String,UID) Operator
The UID object from which to obtain the Value

    Implicit Type Conversion(String,UID) Operator
    In This Topic
    An implicit conversion to a string, returning the same string as Value
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Overloads Public Operator Widening CType( _
   ByVal uid As UID _
) As String
    'Usage

    public string operator implicit(
   UID uid
)

    Parameters

    uid
    The UID object from which to obtain the Value

    Return Value

    The dotted form of the UID as a string
    Remarks
    This conversion is provided to assists migration from earlier versions of DicomObjects.NET in which the UID objects were strings
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    UID Class
    UID Members
    Overload List


DicomObjects.UIDs Namespace / UID Class / Implicit Type Conversion Operator / Implicit Type Conversion(UID,String) Operator
The UID as a string

    Implicit Type Conversion(UID,String) Operator
    In This Topic
    Create a UID from a string
    Syntax
    • Visual Basic
    • C#
    'Declaration

    Overloads Public Operator Widening CType( _
   ByVal value As String _
) As UID
    'Usage

    public UID operator implicit(
   string value
)

    Parameters

    value
    The UID as a string

    Return Value

    The UID object
    Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    UID Class
    UID Members
    Overload List


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

    DicomObjects.UIDs Namespace Inheritance Hierarchy
    Inheritance Hierarchy
    System.Object
    DicomObjects.UIDs.ApplicationContexts
    DicomObjects.UIDs.FramesOfReference
    DicomObjects.UIDs.MetaSOPClasses
    DicomObjects.UIDs.SOPClasses
    DicomObjects.UIDs.TransferSyntaxes
    DicomObjects.UIDs.UID
    DicomObjects.UIDs.WellKnownInstances
    See Also

    Reference

    DicomObjects.NetStandard Assembly


%%PageItemTitle%% $$Methods$$

DicomObjects.Validation Namespace / ValidationException Class

In This Topic
    ValidationException Class Methods
    In This Topic

    For a list of all members of this type, see ValidationException members.

    Public Methods
     | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
    Top
    See Also

    Reference

    ValidationException Class
    DicomObjects.Validation Namespace


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

    DicomObjects.Validation Namespace Inheritance Hierarchy
    Inheritance Hierarchy
    System.Object
    DicomObjects.Validation.ValidationOptions
    System.Exception
    DicomObjects.DicomException
    DicomObjects.Validation.ValidationException
    See Also

    Reference

    DicomObjects.NetStandard Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

    DicomObjects.Video Namespace Inheritance Hierarchy
    Inheritance Hierarchy
    System.Object
    DicomObjects.Video.VideoCompressionOptions
    See Also

    Reference

    DicomObjects.NetStandard Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

    DicomObjects Namespace Inheritance Hierarchy
    Inheritance Hierarchy
    System.Object
    DicomObjects.DicomAssociation
    DicomObjects.DicomAttribute
    DicomObjects.DicomContext
    DicomObjects.DicomDataSet
    DicomObjects.DicomGlobal
    DicomObjects.DicomImage
    DicomObjects.DicomLabel
    DicomObjects.DicomLicence
    DicomObjects.DicomMaskRange
    DicomObjects.DicomPrint
    DicomObjects.DicomQuery
    DicomObjects.DicomServer
    DicomObjects.ReadBehaviours
    DicomObjects.SequencePath
    DicomObjects.WriteBehaviours
    System.Collections.ObjectModel.Collection<T>
    DicomObjects.DicomDataSetCollection
    DicomObjects.DicomImageCollection
    DicomObjects.DicomLabelCollection
    System.Collections.ObjectModel.KeyedCollection<TKey,TItem>
    DicomObjects.DicomContextCollection
    System.Exception
    DicomObjects.DicomException
    DicomObjects.Validation.ValidationException
    System.ValueType
    DicomObjects.WsiTile
    DicomObjects.WsiTileFragment
    See Also

    Reference

    DicomObjects.NetStandard Assembly